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Welcome
Welcome to the Vectorworks Help System
Welcome to Vectorworks® software—a CAD and BIM program that includes all the 2D and 3D tools and technology 
you need in one easy-to-use, cost-effective package. In addition to precision drafting, it provides powerful tools for 3D 
modeling that can be used to create, present, and even manufacture designs. Built-in database and worksheet 
capabilities help track costs and materials. A host of import and export formats makes it easy to share files.
The Vectorworks Fundamentals product includes extensive symbol libraries, default drawing resources, and a built-in 
scripting environment that can be used to automate routine tasks. Renderworks® is a plug-in product that allows you to 
create beautiful photo-realistic, hand-drawn, or schematic rendered views of your designs.
The Vectorworks Design Series software is a complete design and production management system for architects, 
landscape architects, lighting designers, and mechanical engineers. Vectorworks Design Series software includes the 
following products: Architect, Landmark, Spotlight, and Designer. Some features in the Vectorworks Design Series 
software expand upon core Vectorworks Fundamentals or Renderworks product functionality.
The Vectorworks Designer product includes the combined feature set of the Vectorworks Architect, Landmark, and 
Spotlight products. Therefore, it is not necessary to document each individual feature as belonging to the Vectorworks 
Designer product. The Designer workspace contains a major subset of the entire combined feature set.
Summaries of the new software features for all products are located in “New Features” on page 1. Descriptions of 
documentation improvements can be found in “Documentation Improvements” on page 18.
~~~~~~~~~~~~~~~~~~~~~~~~~
New Features
Using the Help System
Vectorworks Basics
Setting Up a File
Creating Objects
Editing Objects
Using Symbols
Viewing the Drawing
Rendering
Printing a File
Import and Export

Using the Help System
This help system serves as a comprehensive reference for the tools, commands, and dialog boxes contained in the 
Vectorworks Fundamentals and Design Series workspaces. The program is linked to the appropriate help topic, 
providing instant information.

Online Help and Locally-installed Help
To open the help system, select Help > Vectorworks Help. The help window opens in your default browser. If you are 
connected to the Internet, the online version of the help displays. If an Internet connection is not available, the 
locally-installed version of the help opens. The local version may not contain the latest information, but in general, the 
online and local versions are very similar. 
If bandwidth or connection issues cause topic display or searching to become unacceptably slow, select the 
Vectorworks Session preference, Use local help even when an Internet connection is available, to always use the 
local version of the help system. 
Using the local version of the help with the Internet Explorer browser may cause a blocked content warning. Enabling 
the blocked content is perfectly safe; however, the help opens to the first page in this situation. Search the help for the 
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item of interest at that time, switch to a different default browser, or use the online version of the help system to avoid 
this issue.
The Internet Explorer browser, prior to version 9, does not support the HTML5 features of this help system. Upgrade to 
a more recent version of the browser if possible, or switch to a different browser.

Help System Appearance
Depending on the size of your screen, the help system adjusts itself automatically. To display the help system on your 
mobile device, access the help from the Vectorworks | Support area of the website.

Desktop View
On a large screen, typically a desktop, the help opens from the Vectorworks Help menu command with an area for the 
Table of Contents and Glossary on the left, and the topics on the right.

On a typical desktop screen, the help window is divided into two resizable sections containing the topics and a 
Navigation pane, containing the Table of Contents and a Glossary. If you do not see the Navigation pane, click the 
divider arrow to open the pane on your desktop, or reposition the adjustable divider between the pane and the topic 
panel to view more or less of the topic. Click the vertical divider to toggle the Navigation pane display.

Table of
Contents

Glossary

Toggle
Navigation

pane
display

Browse, 
print

Back to top

Breadcrumb 
navigation

From single-topic view on the desktop browser, click 
the divider arrow to open the Navigation pane, or 
reposition the divider.

http://www.vectorworks.net/support/online-help-system


Using the Help System |  iii
Tablet View
On a smaller screen, or on a tablet, the help system displays the topic, with buttons to the right or bottom depending on 
orientation, for accessing the table of contents, glossary, and search. Click a button to access one of the functions. There 
are no Print or Back to Top buttons in tablet view.

Phone View
On a much smaller screen, such as a cell phone, the three buttons are located at the bottom of the screen, to maximize 
the topic viewing area. There are no Print or Back to Top buttons in phone view.
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Context-sensitive Help
Context-sensitive help is available from within the Vectorworks program. If you need information about a particular 
tool or command, select Help > What’s This? and move the question mark cursor to the tool or command of interest, 
and then click it.

The “What’s This” question mark cursor can be deactivated by selecting Help > What’s This once again.
If you need information about a particular dialog box or a selected tool, press the keys listed in the table.

Vectorworks cannot directly access context-sensitive help for some context menu commands or the Worksheet 
menu commands. To obtain help on these items, launch the help and locate the help topic by conducting a help 
search. 

The help you need opens in a single-topic window. You can simultaneously view the help topic and the Vectorworks 
application. Since it is assumed that you have a dialog box open in Vectorworks when seeking help, the same default 
dialog box generally does not also display in the help. 

Help System Updates
If significant changes occur to the Vectorworks application or the help information during the Vectorworks product 
cycle, Nemetschek Vectorworks may release an update to the help system. This update is automatically available 
online. The local help is also updated automatically when a Vectorworks software service pack is updated or installed.
~~~~~~~~~~~~~~~~~~~~~~~~~
Help System Features
Conventions

Help System Features

Searching the Topics
Enter text in the Search box and press Enter, or click the search loupe, to search the help system.
While searching, the progress is displayed under the Search box. When the search is complete, the number of results 
found displays. If no results are found, “No results found” displays.

If the search is progressing slowly or appears frozen at 0%, connection or bandwidth issues may be impeding the 
search progress. The Session tab of the Vectorworks preferences allows switching to the local version of the help 
in this type of situation.

The first toggle switch under Search Options turns highlighting on or off. The second switch enables “AND” search 
functionality if desired. Turn the toggle off to find results that contain one or more of the search terms (“OR” 
functionality).

Platform /OS Help key

Windows F1
Mac (pre-Leopard) Help key, Cmd + ?, F1
Mac (Leopard and later) Help key, F1
Mac (aluminum keyboard) Fn + F1
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When entering search text:
• Enter one or more words and toggle the Show results that include all search words option on to search the help 

for topics that contain all the words, or turn it off to search the help for topics that contain any of the words
• Enter text within quotation marks to search the help for a text string

For example, searching for the words color palette finds topics that contain both the word color and palette. However, 
searching for the string “color palette” (with quotation marks) finds topics that contain the term color palette.
The search results list the topics that contain the search text or string. Topics are listed in order of relevance, and 
display both the topic heading and an excerpt from the text for you to determine the topic’s relevance. 
If there are more search results than can be displayed on one page, buttons at the bottom of the page allow navigation 
among search result pages.

Click a search result title to open the associated topic. The search term(s) are highlighted within the topic, if 
highlighting is enabled by the toggle switch.

Related Topics
At the end of certain topics, a list of additional topics with information related to the current topic is displayed. Click 
one of the topics to view the additional information. To return to the original topic, use the browser’s Back button.

Cross-references
Cross-references located within a topic are underlined and in color. Click these links to navigate to more information 
about the underlined topic. To return to the original topic, click the browser’s Back button.

Click the switch to toggle the
functionality on and off

Click a results page number
to navigate to that page

Navigates to the 
next help results 
page

Navigates to the previous help
results page
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Browse Navigation
The browse sequence buttons allow you to scroll through the help topics, in order. These special navigation buttons 
display at the top of the topic window (the buttons also display at the bottom of the topic window for tablet or phone 
view). Click Previous and Next to navigate through the topics.

Breadcrumb Navigation
At the top of each topic page, breadcrumb navigation displays the current topic path and facilitates navigation to other 
topics along the path. Click any part of the breadcrumb path to navigate to that topic.

Back to Top
In desktop view, longer topics include a Back to Top button at the bottom of the page. Click the button to return to the 
top of the topic.

Tablet and phone view do not include Back to Top functionality.

Movie Links
The Vectorworks YouTube channel contains video technical tips with an audio/visual explanation of various concepts. 
If a topic in the help has a related video tip, a link in the help directs you to the associated Vectorworks YouTube movie.

Click Next to navigate to 
the next topic

Click Previous to navigate 
to the previous topic

Desktop view browse buttons

Phone view browse buttons

Click Back to Top to return to 
the top of the topic page
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Parameter Tables
The parameters of every dialog box are described in tables. By default, these tables are hidden so that you can read the 
steps of a procedure easily first. To view a parameter table, click the link “Click to show/hide the parameters.” This link 
toggles the table display on and off.

When accessing a topic from a search, the table may be showing by default, if the search term is found within the 
table and the Highlight Search Results option is turned on.

Glossary

Click the Glossary button from the navigation panel.

The Glossary pane displays an alphabetical listing of frequently encountered terms in the Vectorworks program. Scroll 
to the term of interest and click it to view its definition. The glossary definitions can be filtered by typing a term in 
Filter Terms.

Click to toggle the parameter 
table open
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Printing Topics

Click the Print button (desktop view only) to print the currently displayed topic through the browser’s print 
function. 

Tablet and phone view do not include print functionality.

Conventions
Vectorworks is a cross-platform product. Most Vectorworks features are the same in the Windows and Mac versions; 
however, in some instances, differences exist. These are explained in detail.

See the Commands and Tools PDF, available from the Help system Table of Contents, for a detailed list of the 
products where each tool and command is available.

The conventions are as follows:
 

Convention Definition

Indicates functionality that exists in each of the Vectorworks Design Series products 
as well as Designer.

As an example, if you have Spotlight, you have the functionality.
Indicates functionality that exists in the Vectorworks Architect and Designer 
products only
Indicates functionality that exists in the Vectorworks Landmark and Designer 
products only
Indicates functionality that exists in the Vectorworks Spotlight and Designer 
products only
Indicates functionality that exists in the Vectorworks Architect, Landmark, and 
Designer products only.

As an example, if you have Architect or Landmark, you have the functionality.
Indicates functionality that exists in the Vectorworks Architect, Spotlight, and 
Designer products only
Indicates functionality that exists in the Renderworks product

Indicates functionality that exists in the Vectorworks Spotlight and Renderworks or 
Designer and Renderworks products only

(Mac) Mac-specific instruction
(Windows) Windows-specific instruction
Enter (Windows)/return 
(Mac) and Backspace 
(Windows)/delete (Mac)

To reduce unnecessary wordiness, both operating system terms will not be used; we 
have standardized upon “Enter” and “Backspace.” The meaning should be evident 
for users of either operating system.

bold text Indicates a specific button, command, class, or explicitly named item
indented text Indicates a note, tip, or warning

click Click the mouse button and release. The left button is always implied in Windows.
double-click Click two times quickly on the mouse button and release
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All instructions are based on click-click drawing.

Additional Resources
There are a variety of technical support, training, and other options available to you to ensure your success with the 
Vectorworks product and to support your business needs.

The Help menu has links to the Getting Started Guides, Vectorworks Knowledgebase Search, Vectorworks Cloud 
Services, and Vectorworks Service Select websites (Internet access required).

Technical Support
Technical support is available for registered users in several ways. International users should contact their local reseller 
for details concerning technical support; for reseller information, see www.vectorworks.net/international 
United States users can contact Technical Support using the following methods:

• Call 443.542.0411
• Send a tweet to @VectorworksHelp on Twitter
• Send an email to tech@vectorworks.net 
• Visit the technical support knowledgebase at kbase.vectorworks.net 

When you contact Technical Support, please have access to your computer and be ready to tell the specialist:
• Vectorworks software serial number
• Vectorworks software version number
• Operating system
• Type of computer being used
• Amount of RAM installed in the computer
• List of any recent changes to the computer’s setup (such as new fonts, software, or hardware)
• A brief description of the problem with specific details about what actions were taken prior to the problem’s 

occurrence. The more information you can give your support specialist, the easier it will be to solve your problem 
quickly.

right-click Click with the right mouse button and release; on the Mac, hold down the Ctrl key 
and click the mouse

Key and mouse 
combination, as in 
Shift-click

Hold down the key(s) and click; in this example, hold down the Shift key and click

Key combination, as in 
Alt+Shift+D

Hold down the key(s) and press the specified letter or number key; in this example, 
hold down both the Alt and Shift keys, and press the D key

click-click Click the mouse button once and release. Move the cursor to the desired location and 
click again. This is the default drawing preference for the program at installation. 
See “Edit Preferences” on page 49 to change the drawing preference to click-drag.

click-drag Click once with the mouse button and do not release. Drag (move) the cursor to a 
desired location and then release. 

select Click an object with the mouse, or click-drag over an object with marquee selection, 
to highlight it. The object is highlighted, and/or “handles” display on the object to 
indicate that it is currently active. This term also refers to executing menu 
commands.

Context menu A menu command accessed by a Ctrl-click (Mac) or right-click (Windows) 

Convention Definition

http://www.vectorworks.net/international
mailto:tech@vectorworks.net
http://kbase.vectorworks.net
https://twitter.com/VectorworksHelp
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Troubleshooting
Troubleshooting a problem prior to calling Technical Support will also aid in a speedy resolution. Basic 
troubleshooting tips include:

• Test to see if the problem occurs in a new, blank file
• Test to see if the problem occurs system wide (especially print and font problems)
• Copy and paste part of the document to a new file to see if the problem persists
• Run the computer in Safe Mode (Windows) to see if there is a system conflict
• Check the community message board to see if the problem has already been reported or resolved - 

techboard.vectorworks.net 

Training
For details about the following training options, visit www.vectorworks.net/training 

• Tutorial manuals
• One-on one online training
• Customized onsite training
• Hands-on classroom training

To contact a training specialist, call 1.877.202.8871 (in the United States) or send an email to 
training@vectorworks.net

Other Resources
The following additional resources are available to Nemetschek Vectorworks users:

• Vectorworks community board - techboard.vectorworks.net 
• Vectorworks YouTube channel - www.youtube.com/vectorworks 
• Independent local user groups - www.vectorworks.net/community/usergroups.php 
• Planet Vectorworks, our company news site - planet.vectorworks.net 
• Various social media sites, such as Facebook, Twitter, Delicious, LinkedIn, and Flickr
• LISTSERV® user lists - www.vectorworks.net/community/mailinglists.php 

Vectorworks Service Select
Vectorworks Service Select is a software service agreement that allows subscribers to purchase Vectorworks software 
at a fraction of the cost of a new license. Subscribers also get exclusive content and learning resources and always have 
access to the latest Vectorworks products. To learn more about Vectorworks Service Select, visit 
http://serviceselect.vectorworks.net/learn-more 

Vectorworks Cloud Services
Share files and make design decisions from any location with Vectorworks Cloud Services, a member benefit for 
Vectorworks Service Select subscribers. Accessibility options, including a desktop application and the Vectorworks 
Nomad iOS™, Android™, and Kindle Fire™ apps, allow you to view, mark up, share, and synchronize Vectorworks 
files across devices. Learn more about Vectorworks Cloud Services at 
http://www.vectorworks.net/cloudservices and check its availability in your location by visiting: 
http://serviceselect.vectorworks.net/learn-more 
Vectorworks Nomad iOS has the additional benefit of being able to view and present your 3D drawings rendered in 
OpenGL on your iOS mobile device.

Vectorworks Remote App
The Vectorworks Remote app connects your mobile device to your Vectorworks desktop using a remote connection 
plug-in. Visualization remotes are available for Renderworks and navigation remotes are available for Vectorworks 

http://www.vectorworks.net/community/mailinglists.php
http://techboard.vectorworks.net
http://www.vectorworks.net/training
mailto:training@vectorworks.net
http://techboard.vectorworks.net
http://www.youtube.com/vectorworks
http://www.vectorworks.net/community/usergroups.php
http://planet.vectorworks.net
http://serviceselect.vectorworks.net/learn-more
http://www.vectorworks.net/cloudservices/
http://serviceselect.vectorworks.net/learn-more
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Design Series. Interactively use the remotes to view, navigate, and present designs without having to be at your 
desktop. To learn more, visit http://www.vectorworks.net

Knowledgebase
One of the primary technical support resources available to you is our Knowledgebase. This resource provides answers 
to the most common technical questions, as well as video tutorials and tech tips, all in a central location. Access our 
Knowledgebase at http://kbase.vectorworks.net 

Getting Started Guides
These videos and printed guides provide you with a strong base as you learn to use Vectorworks software to design, 
communicate, and document your ideas. View an introduction and learn more about these resources by visiting: http://
www.vectorworks.net/training/getting-started-guides 

Copyright Information
© 1985-2015 Nemetschek Vectorworks, Incorporated. All Rights Reserved.
Nemetschek Vectorworks, Inc., hereafter referred to as Nemetschek Vectorworks, and its licensors retain all ownership 
rights to the MiniCAD® Vectorworks® computer program and all other computer programs as well as documentation 
offered by Nemetschek Vectorworks. Use of Nemetschek Vectorworks software is governed by the license agreement 
accompanying your original media. The source code for such software is a confidential trade secret of Nemetschek 
Vectorworks. You may not attempt to decipher, decompile, develop or otherwise reverse engineer Nemetschek 
Vectorworks software. Information necessary to achieve interoperability with this software may be furnished upon 
request.

Vectorworks Documentation

The Vectorworks User’s Guides were written and illustrated by Alexandra Duffy, Teresa Heaps, Kristin Bailey, Martin 
Brown, and Susan Collins. 
This documentation, as well as the software described in it, is furnished under license and may only be used or copied 
in accordance with the terms of such license. The information in these guides is furnished for informational use only, is 
subject to change without notice, and should not be construed as a commitment by Nemetschek Vectorworks. 
Nemetschek Vectorworks assumes no responsibility or liability for any errors or inaccuracies that may appear in this 
documentation.
Except as permitted by such license, no part of this publication may be reproduced, stored in a retrieval system, or 
transmitted, in any form or by any means, electronic, mechanical, recording, or otherwise, without the express prior 
written permission of Nemetschek Vectorworks. Permission is typically granted to reproduce materials for personal 
use, but under no circumstances may it be used for commercial purposes or for financial gain. To obtain permission, 
contact Nemetschek Vectorworks (email tech@vectorworks.net) or an authorized Vectorworks distributor if not in 
the USA.
Existing artwork or images that you may desire to scan or copy may be protected under copyright law. The 
unauthorized incorporation of such artwork into your work may be a violation of the rights of the author or illustrator. 
Please be sure to obtain any permission required from such authors.
Vectorworks, Renderworks, and MiniCAD are registered trademarks of Nemetschek Vectorworks, Inc. SmartCursor, 
and VectorScript are trademarks of Nemetschek Vectorworks, Inc.; X-ray Select (patent pending)
The following are copyrights or trademarks of their respective companies or organizations:
Mac, QuickDraw 3D, QuickTime, Quartz 2D, and Retina are registered trademarks of Apple, Inc.
iOS is a registered trademark of Cisco Systems, Inc., and is used under license by Apple, Inc.
Microsoft and Windows are registered trademarks of the Microsoft Corporation in the United States and other 
countries.

http://www.vectorworks.net
http://kbase.vectorworks.net/
http://www.vectorworks.net/training/getting-started-guides/
http://www.vectorworks.net/training/getting-started-guides/
mailto:tech@vectorworks.net
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Android is a trademark of Google, Inc.
Amazon, Kindle, Kindle Fire, the Amazon Kindle logo and the Kindle Fire logo are trademarks of Amazon.com, Inc. 
or its affiliates.
FileMaker is a trademark of FileMaker, Inc., registered in the U.S. and other countries.
Adobe, Adobe PDF Library, Adobe AIR, and the Adobe logo are trademarks of Adobe Systems Incorporated.
Parasolid is a registered trademark of Siemens Product Lifecycle Management Software Inc.
CINEMA 4D is a registered trademark of MAXON Computer GmbH, MAXON Computer Inc. and MAXON 
Computer Ltd.
Rhino 3DM and Rhinoceros is a registered trademark of Robert McNeel and Associates.
SpaceNavigator is a trademark of 3Dconnexion.
OpenEXR is a trademark of Lucasfilm, Ltd.
ACIS and SAT are registered trademarks of Spatial Corporation.
The Forbo flooring textures are based on textures supplied by Forbo Holding S.A.
The shader appendix contains content, copyright MAXON Computer GmbH, MAXON Computer Inc. and MAXON 
Computer Ltd. All rights reserved. Reprinted with permission.
PDFNet SDK is copyright PDFTron™ Systems, 2001-2009, and distributed by Nemetschek Vectorworks under 
license. All Rights Reserved.
PANTONE® Colors displayed in the software application or in the user documentation may not match 
PANTONE-identified standards. Consult current PANTONE Color Publications for accurate color. PANTONE® and 
other Pantone, Inc. trademarks are the property of Pantone, Inc. ©Pantone, Inc., 2010.
Pantone, Inc. is the copyright owner of color data and/or software that are licensed to Nemetschek Vectorworks to 
distribute for use only in combination with Vectorworks software. PANTONE Color Data and/or software shall not be 
copied onto another disk or into memory unless as part of the execution of the Vectorworks products.
Times and Helvetica are trademarks of Linotype-Hell AG and/or its subsidiaries.
ITC Zapf Dingbats is a registered trademark of International Typeface Corporation.
Google Earth is a registered trademark of Google, Inc.
SketchUp and 3D Warehouse are trademarks of Trimble Navigation Limited.
AutoCAD, FBX, and 3ds Max are registered trademarks of Autodesk, Inc.
Python is a registered trademark of the Python Software Foundation.
The Renderworks Camera tool, Heliodon tool, and Existing Tree tool were developed by Julian Carr, OzCAD, Sydney, 
Australia.
The television, video screen, LED screen, blended screen, blended projector, speaker, speaker array, stage lift, stage 
deck, stage plug, stage steps, and stage ramp were created by C. Andrew Dunning, Landru Design, Nashville, TN.
The Lighting Symbol Maintenance and Lighting Inventory Setup commands, and the Lighting Pipe, Lighting Pipe 
Ladder, and Instrument Summary tools were developed by Joshua Benghiat Lighting Design, 
www.BenghiatLighting.com
The www.caddetails.com library contains architecture and landscape architecture symbols provided by CADdetails 
Ltd.
Image-based Arroway textures from Arroway textures™.
A variety of water textures were provided by Dan Jansenson, author of the Remarkable Renderworks manual.
The Xfrog Plant Images library contains plant images by Xfrog®.
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The Kohler plumbing fixture libraries supplied with certain Vectorworks Design Series products are based on geometry 
from the Kohler Company.
The Marvin door and window libraries supplied with certain Vectorworks Design Series products are based on 
geometry from the Marvin Company. 
The Loewen door and window libraries supplied with certain Vectorworks Design Series products are based on 
geometry from the Loewen Company.
The Weather Shield® door and window libraries supplied with certain Vectorworks Design Series products are based 
on geometry from Weather Shield Mfg. Inc.
The AGA/Rayburn appliance library supplied with certain Vectorworks Design Series products are based on geometry 
from AGA Foodservices Group Plc.
The Copper Beech Millwork molding profiles supplied with certain Vectorworks Design Series products are based on 
geometry from Copper Beech Millwork, an Amherst Woodworking and Supply, Inc., Company.
The Sub-Zero and Wolf appliance libraries supplied with certain Vectorworks Design Series products are based on 
geometry from the Sub-Zero Freezer Company, Inc., and the Wolf Appliance Company, Inc.
The Knoll furniture library supplied with certain Vectorworks Design Series products is based on geometry supplied by 
the Knoll Furniture company. For more information on their products, see www.knoll.com
The Herman Miller (HMI) furniture libraries supplied with certain Vectorworks Design Series products are based on 
geometry from Herman Miller, Inc.
The Unilock® hatch library supplied with certain Vectorworks Design Series products is based on geometry from 
Unilock. 
The Benjamin Moore® paint color palettes supplied with certain Vectorworks Design Series products are based on 
color values supplied by Benjamin Moore & Co.
The Sherwin-Williams paint color palettes supplied with certain Vectorworks Design Series products are based on 
color values supplied by The Sherwin-Williams Company.
The Pittsburgh® Paints paint color palette supplied with certain Vectorworks Design Series products is based on color 
values supplied by PPG Industries.
The Landmark plant database was created using public domain data. Nemetschek Vectorworks assumes no 
responsibility for inaccuracies, omissions, or errors in this data.
Lightwright is a trademark of John McKernon.
High End Systems' lighting symbols provided by, and used with the permission of, High End Systems, Inc. High End 
Systems is a registered servicemark of High End Systems, Inc., a division of Barco N.V.
Clay Paky lighting symbols are based on geometry provided by Clay Paky S.P.A.
Coemar lighting symbols are based on geometry provided by Coemar manufacturing.
Martin® lighting symbols are based on geometry provided by Martin Professionals A/S.
Selecon lighting symbols are based on geometry provided by Selecon, a division of Philips Global Entertainment 
Lighting Group.
Vari-Lite® lighting symbols are based on geometry provided by Vari-Lite Corporation, a division of Philips Global 
Entertainment Lighting Group.
Color Kinetics™ lighting symbols are based on geometry provided by Color Kinetics™, a division of Philips Solid 
State Lighting Solutions.
James Thomas Lighting Symbols and Truss Symbols are based on geometry provided by James Thomas 
Engineering™, Ltd.



  xiv | Copyright Information
ADB lighting symbols are based on geometry provided by ADB-TTV Lighting Technologies.
DTS lighting symbols are based on geometry provided by DTS, The Lighting Company.
JB lighting symbols are based on geometry provided by JB Lighting.
Eurotruss truss symbols are based on geometry provided by Eurotruss.
Atlas Sound® speaker symbols are based on geometry provided by Atlas Sound Lp.
EAW Sound speaker symbols are based on geometry provided by EAW sound, a division of LOUD Technologies Inc.
d&b audiotechnik® speaker symbols are based on geometry provided by d&b audiotechnik GmbH.
Meyer Sound® speaker symbols are based on geometry provided by Meyer Sound Laboratories, Inc.
Rosco gobo textures and color information provided by and used with the permission of Rosco Laboratories, Inc. 
Rosco is a registered trademark of Rosco Laboratories, Inc.
Apollo gobo textures and color information provided by and used with the permission of Apollo Design Technology, 
Inc. Apollo is a registered trademark of Apollo Design Technology, Inc.
GAM gobo textures and color information provided by and used with the permission of GAM the Great American 
Market, Inc. GAM is a registered trademark of GAM, Inc.
GOBOLAND gobo textures provided by and used with permission of GOBOLAND. GOBOLAND is a registered 
trademark.
GoboMan gobo textures and color information provided by, and used with the permission of, GoboMan.
LEE gobo textures and color information provided by and used with the permission of LEE Filters USA.
Rosco, Apollo, GAM, GOBOLAND, GoboMan, and LEE images and color information are copyrighted. All rights 
reserved. Their resale, redistribution, or use in derivative works is prohibited.
Thomas Register is a trademark of, and PartSpec is a registered trademark of Thomas Publishing Corp.
All other brand or product names are trademarks or registered trademarks of their respective companies or 
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New Features
The following table contains a list of new and improved features for the Service Pack 3 release of Vectorworks 2015 
software, and indicates the section where the functionality is documented.

The following table contains a list of new and improved features for the Service Pack 2 release of Vectorworks 2015 
software, and indicates the section where the functionality is documented.

The following table contains a list of new and improved features for the initial release of the Vectorworks 2015 
software, and indicates the section where the functionality is documented and the product to which the feature applies. 

New Features videos are available from the website.

Feature Purpose Location Product

BIM Collaboration Format 
(BCF) file viewer

The Open BCF Viewer command allows 
you to open BCF files produced by other 
BIM applications, to view issues, 
proposals, and change requests for the 
project

“Viewing BCF 
Files” on page 1759

Architect and 
Landmark

IFC export options for walls 
and slabs

• The Simplified Geometry option for the 
Model View merges components, and 
exports a simple extrude for each wall 
and slab object

• The Export Walls/Slabs by 
components option exports each 
component of walls and slabs as 
sub-elements

“Exporting IFC 
Projects” on 
page 1755

Architect and 
Landmark

Feature Purpose Location Product

Improvements to the 
Lightwright Data Exchange

Improvements to coordinate with a future 
release of Lightwright include:
• a new Address parameter for lighting 

device objects, to be used in automatic 
universe assignment

• a new option to exchange inventory lists 
between Vectorworks Spotlight and 
Lightwright

• the ability to receive updated lighting 
device rotation information from 
Lightwright

“Lighting Instrument 
Properties” on 
page 877; “Universe 
Assignment in 
Vectorworks 
Spotlight” on 
page 99; and 
“Importing and 
Exporting 
Vectorworks 
Spotlight Data” on 
page 1703

Spotlight

Feature Purpose Location Product

Vectorworks help system The Vectorworks help system, keyboard 
shortcut file, and list of tools and 
commands have been updated to reflect 
version 2015 functionality 

Not applicable

Cocoa® API Replaces Apple’s Carbon® API with their 
modern Cocoa API

Not Applicable Fundamentals

http://www.vectorworks.net


  2 | New Features
Closing 2D polygon, 
polyline, polygonal wall 
network, or path-based 
objects

After completing all but the final click, 
press the keyboard shortcut (K by default) 
to automatically close polygon, polyline, 
polygonal wall network, or path-based 
objects

“Miscellaneous 
Keys” on page 3

Fundamentals

Unified install Vectorworks no longer requires reinstalling 
when upgrading products or upgrading 
from an evaluation version

“Installing 
Vectorworks 
Products” on 
page 21

Fundamentals

Default workspaces for 
student and evaluation 
versions of Vectorworks 
software

Installation of student and evaluation 
versions of the software now includes a 
question that determines the most relevant 
default workspace to open on product 
launch

“Installing 
Vectorworks 
Products” on 
page 21

Fundamentals

High-resolution display The Vectorworks application now supports 
high-resolution display devices

“Screen Resolution” 
on page 25

Fundamentals

Mac Retina display support All icons and static images in the Mac 
version of the software have been recreated 
to display appropriately on Retina as well 
as standard resolution devices. The 
Workspace Editor and Plug-in Manager 
allow users to add high-resolution images 
in addition to standard-resolution images.

“Screen Resolution” 
on page 25; 
“Modifying Tool 
Palettes and Tool 
Sets” on page 1840; 
and “Plug-in 
Definition” on 
page 1785

Fundamentals

Description field for layers 
and classes

The edit dialog boxes for design layers, 
sheet layers, and classes now each have a 
Description button, which allows you to 
store additional information. Descriptions 
display as screen tips on the layer and class 
lists on the Organization dialog box, 
Navigation palette, and (on Mac only) 
View bar. Descriptions also display on the 
New Design Layer, New Sheet Layer, and 
New Class dialog boxes, so that you can 
see descriptions of layers and classes 
before you import them.

“The View Bar” on 
page 37, “Setting 
Design Layer 
Properties” on 
page 165, “Setting 
Sheet Layer 
Properties” on 
page 170, “Setting 
Class Properties” on 
page 179, and “The 
Navigation Palette” 
on page 199

Fundamentals

Updates for Center on 
objects after view change 
preference

Helps you feel oriented when switching 
views or changing layers

“Vectorworks 
Display Preferences” 
on page 50

Fundamentals

Feature Purpose Location Product
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The Quartz imaging display 
technology is now always 
used on Mac systems

As part of the 64-bit application change, 
Apple’s 32-bit QuickDraw technology can 
no longer be used. This caused the 
following additional changes:
• In the Vectorworks Display preferences, 

the Quartz imaging option was removed.
• On the Edit Design Layers dialog box, 

the Transfer Mode option for 
controlling layer display is no longer 
available.

• The Export PDF (Quartz only) 
command was removed; Vectorworks 
Fundamentals users can print to PDF 
using the operating system print option.

“Vectorworks 
Display Preferences” 
on page 50, “Setting 
Design Layer 
Properties” on 
page 165, and 
“Setting the Design 
Layer Transfer 
Mode” on page 168

Fundamentals

Ability to disable class 
hierarchical display in 
pop-up menus

You can now opt to disable hierarchical 
display of classes in pop-up menus 
throughout the software, including in the 
Object Info palette, the View bar, and 
dialog boxes

“Session 
Preferences” on 
page 52

Fundamentals

3D render mode and 
projection preferences

You can now set the preferred 3D render 
mode and projection, applied whenever you 
switch a drawing from Top/Plan into a 3D 
view

“3D Preferences” on 
page 54

Fundamentals

Remove Obsolete OpenGL 
Options

Removes outdated and obsolete OpenGL 
options from the user interface.

“3D Preferences” on 
page 54
“OpenGL” on 
page 1590

Fundamentals

View transition animation Adds the option to animate the transition 
when switching views

“Interactive 
Preferences” on 
page 56

Fundamentals

Sheet border improvements You can now add a countersignature field 
to the sheet border, as required by the 
regulations of certain countries.
You can now adjust sheet border marker 
line length and weight and grid line 
extensions.

“Specifying 
Additional Sheet 
Border Settings” on 
page 81

Fundamentals

Beam angle, field angle, and 
centerline class assignment 
preference

The beam angle, field angle, and centerline 
of lighting instruments can be shown or 
hidden, and each can be assigned to 
individual classes for better control of the 
beam appearance, especially in viewports

“Lighting Device 
Setup” on page 95

Spotlight

Add custom pop-up 
parameter lists for lighting 
devices

You can now create a pop-up list of 
pre-defined parameter options for lighting 
devices

“Specifying Lighting 
Device Parameter 
Display” on page 98

Spotlight

Feature Purpose Location Product



  4 | New Features
Page boundary SmartCursor 
cues

Improved SmartCursor cues assist users in 
locating the edges of the page boundary

“SmartCursor Cues” 
on page 149

Fundamentals

Screen tips for referenced 
design layers

For referenced design layers, the full layer 
name and the source file name display as a 
screen tip when the cursor is positioned 
over the italicized layer name in the 
Organization dialog box, Navigation 
palette, and (for Mac only) the Layers list 
on the View bar

“The Organization 
Dialog Box” on 
page 155, “The 
Navigation Palette” 
on page 199, and 
“The View Bar” on 
page 37

Fundamentals

Simplified story workflows It is now much easier to create and manage 
stories. Story levels do not need to be 
associated with a layer, if the purpose of the 
level is to constrain objects. This reduces 
the number of design layers required to 
create stories.

“Setting Up the 
Building Structure 
with Stories” on 
page 172, “Creating 
Layers” on page 162

Architect

Text style as a class attribute The Edit Class(es) dialog box now has a 
Use Text Style at Creation option, which 
allows you to assign a text style to a class, 
as well as specify that the style be applied 
when an object in that class is created.
The Text Style field is now an option on the 
Object Info palette for several plug-in 
objects that have embedded text, such as 
drawing labels and callouts. Select <Class 
Text Style> to apply the class style to the 
object.

“Setting Class 
Properties” on 
page 179 and 
“Applying Text 
Styles” on page 394

Fundamentals

Visibility tool improvements 
in viewports

You can now use the Visibility tool to 
change class and layer visibilities in 
viewports

“The Visibility Tool” 
on page 195

Fundamentals

Assign objects to classes and 
layers in the Navigation 
palette

A new Assign to Selection context menu 
command in the Navigation palette 
provides an easy alternative method for 
assigning objects to classes and design 
layers

“The Navigation 
Palette” on page 199 
and “Assigning 
Objects to Classes 
and Layers” on 
page 998

Architect,
Landmark,
Spotlight

Symbol editing shortcuts for 
the Resource Browser

Adds editing modes directly to the context 
menu in the Resource Browser

“Working with 
Resources” on 
page 225
“Editing Symbol 
Definitions” on 
page 247

Fundamentals

Locate the repetitive unit 
symbol in the Resource 
Browser

The Locate Symbol in Resource Browser 
context menu command is now available 
for repetitive unit objects

“Finding Resources” 
on page 232

Architect,
Landmark

Feature Purpose Location Product
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Show and reverse direction 
for lines, polylines, and 2D/
3D polygons

Show the direction for lines, polylines, and 
2D/3D polygons; reverse direction as 
necessary for consistent operations and 
appearance

“Displaying and 
Reversing Object 
Direction” on 
page 326

Fundamentals

Deform Tool The Deform tool (formerly the Twist tool) 
twists, tapers, bulges, and bends solid 
objects, offering expanded modeling 
capabilities to designers

“Deforming Solids 
and NURBS 
Surfaces” on 
page 361

Fundamentals

Variable spacing for tab 
stops in text objects

You can now add multiple tab stops to text 
objects and control the spacing of each one 
independently

“Adding Tabs to 
Text” on page 386

Fundamentals

Tracking support for text 
objects

For text objects, the new Tracking field on 
the Object Info Palette controls the 
horizontal spacing between characters

“Changing Other 
Text Features” on 
page 391

Fundamentals

Space object gross boundary 
definitions

The gross boundary definition of space 
objects can now be set to the outer wall 
core or center wall core, to accommodate a 
variety of standards and requirements

“Space Settings: 2D 
Boundaries & Area 
Pane” on page 410

Architect

Multiple labels for space 
object

Individually format and position as many 
as three space labels per space object

“Space Settings: 
Space Label 1, 2, and 
3 Panes” on 
page 412

Architect

Improved control of leader 
lines for space objects

You now have greater control over the 
placement of leader lines for space labels

“Space Settings: 
Leader Line Pane” 
on page 413

Architect

Roof framing improvements • Increases functionality of the Roof 
Framer command

• Increases accuracy of 3D roof framing 
models

• Provides new option for specifying how 
the end of a rafter meets the plate

• The message bar now displays the 
progress of the roof framing process

“Framing a Roof” on 
page 461

Architect

Framing Member tool 
enhancements

Framing member objects now have a 
Length parameter and a directional 
indicator

“Creating Framing 
Members” on 
page 471

Architect

Joist from poly progress 
indicator

The message bar now displays the progress 
of the joist creation process

“Creating Framing 
Members” on 
page 471

Architect

Feature Purpose Location Product
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Curtain walls A new feature of the Wall and Round Wall 
tools is the ability to create curtain walls. A 
new Edit Curtain Wall tool edits the 
frames and panels that make up the curtain 
wall. Curtain wall styles are an extension of 
wall style resources. New worksheet 
functions have been added for curtain 
walls. Doors and windows have been 
improved to automatically size to the 
bounding frames when placed as a special 
curtain wall door or window.

“Creating Curtain 
Walls” on page 522, 
“Editing Curtain 
Walls” on page 551, 
“Inserting Windows 
in Vectorworks 
Design Series” on 
page 594, “Inserting 
Doors in 
Vectorworks Design 
Series” on page 617, 
“Worksheet 
Functions” on 
page 1344

Architect,
Landmark

Rectangle mode for Wall 
tool

The Wall tool now offers a Rectangle 
mode that allows quick, two-click drawing 
of rectangular walls. Walls drawn this way 
interact to speed the drawing of complex 
wall systems.

“Creating Walls” on 
page 497 and 
“Automatically 
Joining Walls in 
Rectangle Mode” on 
page 543

Fundamentals

Wall object and slab object 
dialog box improvements

Dialog boxes relating to wall and slab 
attributes and wall component and slab 
component attributes now offer an easy 
way to duplicate components, greater 
control of fill and pen attributes including 
complex line types, and relocated texture 
controls

“Drawing Straight 
Walls” on page 499, 
“Defining 
Components for 
New Walls” on 
page 514, “Creating 
Slab Styles” on 
page 486, and 
“Creating Slab 
Components” on 
page 491

Fundamentals

Wall component constraints Like walls, wall components can now be 
individually constrained at their top and 
bottom to layer elevation or layer wall 
height. Vectorworks Architect users also 
have the option to constrain to story levels, 
so that the components automatically adjust 
when the story elevations change.

“Creating Wall 
Components” on 
page 513

Architect

Class support for door and 
window 2D geometry

All attributes of door and window 2D 
geometry can now optionally be controlled 
by class

“Door Settings: 2D 
Visualization Pane” 
on page 619, 
“Window Settings: 
2D Visualization 
Pane” on page 596 
and various locations

Fundamentals

Feature Purpose Location Product
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Centerline Marker for Doors 
and Windows

The Door tool and Window tool now offer 
a centerline marker option

“Door Settings: 
Centerline Marker 
Pane” on page 627 
and “Window 
Settings: Centerline 
Marker Pane” on 
page 603

Architect,
Landmark

New Stair configurations The Stair tool adds two stair configurations 
(Double-U Stair, Double Landings and 
Triple-L Stair, Triple Landings) that 
support the design of O-shaped stairs. The 
new stair configurations and angled 
landings capability (listed separately) 
eliminate the need for a separate Custom 
Stair tool, which has been removed from 
all workspaces; the Stair tool has been 
added to the Landmark workspace.

“Stair Settings: 
General Tab” on 
page 636

Architect,
Landmark

Angled landings for stairs The Stair tool now supports angles other 
than 90 degrees for the landings of some L- 
and U-shaped stair configurations

“Stair Settings: 
Geometry Tab” on 
page 638

Architect,
Landmark

Toilet stall improvements Toilet stall doors can be set to be open or 
closed in 3D view

“Inserting Toilet 
Stalls” on page 669

Architect

Variable batter slopes for 
Create Pad from Grade 
Limits command

When creating a pad automatically from 
grade limits, you can now set individual 
slope values for each side of the pad; in 
addition, rise-over-run, angle, or percent 
values can be used to specify slope values

“Creating a Pad from 
Grade Limits” on 
page 713

Landmark

New Roadway Polyline 
object

A new Roadway (Poly) tool makes it much 
easier to create and edit road segments

“Creating Polyline 
Roadways” on 
page 722

Architect,
Landmark

New Roadway Custom Curb 
object

A new tool joins roadway sections by 
creating a free-form custom curb roadway, 
for intersections, exits, dead-ends, and 
more

“Joining Roadways 
with a Custom Curb” 
on page 724

Architect,
Landmark

Roadway object 
improvements

Improves the consistency between roadway 
objects for increased ease of use:
• Allows control of paving and curb 

appearance and/or visibility by class
• Provides an arc center locus for tee and 

curved roads
• Measures the radius to the center of tee 

and curved roads

“Creating and 
Joining Straight and 
Curved Roadways” 
on page 733

Architect,
Landmark

On-screen indicators for site 
model errors

Grade modifier errors that prevent a site 
model from updating correctly are 
indicated by an icon at the site of each error

“Correcting Site 
Modifier Errors” on 
page 754

Architect,
Landmark

Feature Purpose Location Product
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Preserve the grade of a 
reshaped grade object

You can now opt to preserve the grades of 
reshaped grade objects and automatically 
recalculate the elevation instead

“Specifying Global 
Grade Object 
Preferences” on 
page 764

Landmark

Grade object length display 
options

The Grade tool’s new parameters allow the 
optional display of the grade object’s 
projected and/or surface length, and grade 
parameters can now be entered as a rise/run 
ratio

“Inserting Grade 
Objects” on 
page 765

Landmark

Automatic generation of 
minimum and maximum 
values for graticule object 
creation

The Graticule tool automatically 
calculates the graticule’s minimum and 
maximum latitude and longitude based on 
the geometry and location of the defining 
polyline

“Creating a 
Graticule” on 
page 780

Landmark

Plant object tight outline A new tight Outline option for plant 
objects offers a more defined look than the 
existing sketch styles

“Plant Definition: 
Render Pane” on 
page 789

Landmark

Improved access to plant 
content libraries

It is easier to add a wide variety of plants to 
drawings, with plant content libraries 
accessible directly from the Plant Settings 
dialog box, Copy From Symbol dialog box, 
and Edit Plant Information dialog box

“Plant Settings: 
Definition Pane” on 
page 795; “Creating 
Plant Geometry from 
a Symbol” on 
page 791; and 
“Creating Landscape 
Areas” on page 834

Landmark

Extended customization for 
plant tags

You can now create multiple lines of data 
for the top, center, and bottom of the 
custom plant tag and can now edit the 
center and bottom tags directly in the 
Object Info palette

“Creating a Custom 
Plant Tag” on 
page 798

Landmark

Existing Tree tool 
enhancements

The Existing Tree tool is now even more 
flexible. You can specify irregular canopy 
shapes, and use trees with multiple trunks 
in calculations. Textures can be included 
for enhancing the 3D appearance of the 
trees. Additional options have been added 
for tree protection zone display and for the 
use of custom and specialized fields in the 
Object Info palette.

“Documenting 
Existing Trees” on 
page 818

Landmark

Landscape Area tool 
improvements

The landscape area is now calculated based 
on the site model if one exists, and displays 
in the Landscape Area Settings dialog box

“Creating Landscape 
Areas” on page 834

Landmark

Custom landscape area tag 
improvements

Improves the functionality of the custom 
landscape area tag

“Creating a Custom 
Landscape Area 
Tag” on page 838

Landmark

Feature Purpose Location Product
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Parking spaces terminology 
improvement

Handicapped parking space options have 
been renamed “Accessible” in keeping with 
current usage

“Creating Parking 
Spaces” on page 845

Architect,
Landmark, 
Spotlight

Spotlight user interface 
improvements

The names of several Vectorworks 
Spotlight tools, commands, dialog boxes, 
and parameters have been changed to be 
more complete and/or consistent

Various locations Spotlight

Option to embed the 
geometry in a lighting 
position object

When you use the Convert to Light 
Position command to convert geometry 
into a lighting position object, you are now 
prompted to either use the geometry 
directly in the object, or create a symbol.
If you use the geometry in the object, a new 
Edit Position Geometry button will be 
available on the Object Info palette, to 
allow easier editing.

“Creating a Lighting 
Position Object” on 
page 865

Spotlight

Flip label legend settings Adds settings to adjust orientation of the 
label legend for lighting instruments

“Lighting Instrument 
Properties” on 
page 877
“Spotlight Setup” on 
page 95

Spotlight

Soft Goods improvements The parts of a soft goods curtain or border 
can now be classed individually, offering 
more control over appearance and visibility

“Inserting Soft 
Goods” on page 904

Spotlight

Video screen improvements Improvements to all the video screen 
objects allow greater control over classing 
and the addition of a note to the label; new 
options for screen borders, mounting, and 
additional screen parameters and aspect 
ratio options are available to applicable 
video screen objects

“Inserting Video 
Screen Objects” on 
page 913

Spotlight

Audio object improvements Speakers and speaker arrays have been 
enhanced with additional orientation and 
mounting options and the ability to specify 
textures for the various parts of the speaker

“Inserting Speakers 
and Speaker Arrays” 
on page 930

Spotlight

Stage Lift tool A new tool inserts a stage lift object, an 
adjustable supporting device for stage 
equipment

“Inserting a Stage 
Lift” on page 940

Spotlight

Stage objects Stage and theatrical structures can now be 
included in entertainment industry 
drawings with several new tools for stages, 
step, and ramp structures. The improved 
stage and steps are now also used by event 
design commands.

“Inserting Stage 
Structures” on 
page 942, “Event 
Design” on page 983

Spotlight

Feature Purpose Location Product
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Instrument summary header 
added

A position height header can now be added 
to instrument summaries. When the 
summary is filtered by lighting position, the 
height is displayed in the header.

“Creating an 
Instrument 
Summary” on 
page 961

Spotlight

Lighting inventory 
improvements

Inventory reports have been consolidated. 
The same inventory report that is set up 
from the Lighting Inventory Setup 
command is now included in generated 
paperwork.

“Inventory Reports” 
on page 969

Spotlight

Replace PICT data with 
bitmap data

As part of the 64-bit application change, 
most workflows that used PICT data now 
use bitmap data.
• The following commands were renamed, 

because they now create bitmap data 
rather than PICT data:
Paste as Bitmap (was Paste as Picture)
Import Metafile as Bitmap (was 
Import Metafile as Picture)
Import PICT as Bitmap (was Import 
PICT as Picture)

• The Export PICT command was 
removed.

• The Import PICT command continues 
to convert PICT data into Vectorworks 
primitive objects.

• The Import EPSF command no longer 
imports the PICT format previews that 
can be embedded in PostScript files; 
only TIFF format previews are imported.

• The Export EPSF command has 
different options for including previews 
with the PostScript data. The PICT 
format preview option (Mac only) was 
removed. All previews are now TIFF 
format, and there are now Full color, 
Grayscale, and Black and white options.

“Paste as Bitmap” on 
page 1010, 
“Importing and 
Exporting in 
Metafile Format” on 
page 1685, 
“Importing in PICT 
Format” on 
page 1671, and 
“Importing and 
Exporting in EPSF 
Format” on 
page 1679

Fundamentals

Duplicate Along Path 
command improvement

You can now select whether to center 
objects along the path during a 
duplicate-along-path operation

“Duplicating Objects 
Along a Path” on 
page 1017

Fundamentals

Align/Distribute context 
menu command

The Align/Distribute command is now 
available from the context menu for ease of 
operation

“Aligning and 
Distributing Objects 
in the Screen Plane” 
on page 1032

Fundamentals

Feature Purpose Location Product
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Save settings for the 
Extrude Along Path 
command

The settings in the Extrude Along Path 
dialog box are now saved between 
Vectorworks sessions

“Extrude Along 
Path” on page 1040

Fundamentals

Save settings for the Sweep 
command

The settings for angles in the Create Sweep 
dialog box are saved between Vectorworks 
sessions

“Sweeping Objects” 
on page 1042

Fundamentals

Improvement to Reshape 
tool Move Edges Parallel 
mode

The Reshape tool’s Move Edges Parallel 
mode now operates on vertices, in addition 
to midpoints

“Move Edges 
Parallel Mode” on 
page 1046

Fundamentals

Trim and join straight walls 
using the Trim tool

Straight walls are easily trimmed and 
joined to intersecting straight walls using 
the Trim tool

“Trim Tool” on 
page 1060

Fundamentals

New Fill Patterns New fill patterns are available in the 
Attributes palette, including fill patterns 
that are required for drawing standards of 
some countries

“The Attributes 
Palette” on 
page 1093

Fundamentals

Viewport rendering attribute 
transfer 

Adds an option to the Eyedropper tool to 
specifically transfer viewport rendering 
settings to another viewport

“Transferring 
Attributes” on 
page 1095

Fundamentals

Opacity support for 
gradients

Apply opacity to gradient resources to 
create more dynamic presentations

“Defining 
Gradients” on 
page 1115

Fundamentals

Color menu Mac 
improvement

Enhanced the Color Palette search function 
on the Mac

“Applying Colors” 
on page 1132

Fundamentals

Mobile 3D Viewer Vectorworks Nomad on iOS now supports 
3D viewing of OpenGL rendered models

“Vectorworks 
Nomad” on 
page 1142
“Vectorworks Cloud 
Services” on page x

Fundamentals

Consolidate Projection and 
Perspective menus

The perspective commands have been 
incorporated into the Projection menu for a 
more streamlined workflow

“Projection” on 
page 1142

Fundamentals

Colored caps and edges for 
clip cube objects

Colored caps and edges have been added to 
the display of solid geometry that is cut by 
the clip cube. This preserves the solid 
appearance of the clipped model, rather 
than showing the model as if it were 
constructed from a hollow shell.

“Viewing a Model 
with the Clip Cube” 
on page 1155 and 
“Configuring 
Interactive Display” 
on page 116

Fundamentals

Updated Working Planes 
palette

The Working Planes palette has a 
streamlined interface and eliminates 
redundancies 

“The Working 
Planes Palette” on 
page 1176

Fundamentals

Drawing animation 
improvements

Drawing animation has been simplified and 
no longer depends on QuickTime 
technology

“Animating 
Drawings” on 
page 1180

Fundamentals
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New option for the 
placement of dimension 
values in custom dimension 
standards

In the Edit Custom Dimension Standard 
dialog box, the Align Vertical Text Left 
field was replaced with the Text Position 
field, which has the following options:
• Above/Left places the text above the 

dimension line for non-vertical 
dimensions, or left of the dimension line 
for vertical dimensions

• Above/Right places the text above the 
dimension line for non-vertical 
dimensions, or right of the dimension 
line for vertical dimensions

• Outside places the text outside the area 
enclosed by the two witness lines and 
dimension line, regardless of the 
dimension orientation

“Creating a Custom 
Dimension 
Standard” on 
page 1188

Fundamentals

Notes for dimensions A Note field was added to the Object Info 
palette; the note displays on the opposite 
side of the dimension line from the 
dimension value

“Editing Dimension 
Properties” on 
page 1211

Fundamentals

Improvements for editing 
and removing object 
constraints

Adds a context menu command for quickly 
removing parametric constraints from an 
object. Also, the Edit Constraints 
command now works with multiple objects 
selected.

“Editing Parametric 
Constraints” on 
page 1237

Fundamentals

Improvements to the 
Drawing Label tool

Adds features to alter both the style and 
positioning of the drawing title and scale 
display

“Creating Drawing 
Labels” on 
page 1244

Fundamentals

Elevation benchmark 
improvements

The Elevation Benchmark tool’s 
parameters offer greater customization, 
including new options for placing the text 
relative to the marker and line and new 
marker fill and crosshair options for ISO 
style benchmarks. The Align/Distribute 
Leader Lines command now applies to 
elevation benchmark objects

“Elevation 
Benchmark” on 
page 1251 and 
“Aligning and 
Distributing Leader 
Lines” on page 1035

Architect,
Landmark

New Symmetry Label tool Use the new Symmetry Label tool to 
easily designate the symmetry centerline as 
defined by some nations’ drawing 
standards

“Inserting a 
Symmetry Label” on 
page 1257

Fundamentals

Feature Purpose Location Product
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New vertical text position 
and bubble style for callouts 
and keynote legends

The new Above Shoulder Vertical Position 
option and new Split Circle Bubble Style 
provide additional ways to customize 
callouts and keynote legends

“Inserting Callouts 
or Keynotes” on 
page 1293 and 
“Editing Keynotes 
and the Keynote 
Legend” on 
page 1298

Fundamentals

Notes Manager horizontal 
text alignment

New controls allow left, center, right, or 
justified alignment of text in callouts, 
keynote legends, and general notes 

“Inserting Callouts 
or Keynotes” on 
page 1293, “Editing 
the Keynote Legend” 
on page 1298, and 
“Placing General 
Notes” on page 1301

Fundamentals

Callout bubble shadow 
improvements

Callout bubble shadows can now be drawn 
in custom colors

“Specifying Callout 
or Keynote Legend 
Bubble Shadow 
Settings” on 
page 1297

Fundamentals

Move default Notes 
Manager databases to 
content library

Notes Manager default databases are now 
located in the default content library in 
[Vectorworks]\Libraries\Defaults\Notes

“Notes Management 
with Databases” on 
page 1304

Fundamentals

Easier editing of space 
boundary classes and room 
finishes for space objects

Space object 2D/3D Boundary Class can 
now be edited directly in a worksheet or in 
the Object Info palette. Room finishes can 
also be edited in a worksheet, and the 
Object Info palette now supports assigning 
room finishes for several selected space 
objects at the same time.

“Selecting and 
Editing Worksheet 
Cells” on page 1321, 
“Space Settings: 
Advanced Settings 
Pane” on page 416, 
and “Space 
Properties” on 
page 417

Architect

Worksheet menu bar The worksheet window now has a menu 
bar and expanded context menus, to 
provide easier access to worksheet 
commands

“Worksheet 
Commands” on 
page 1324

Fundamentals

New worksheet number 
formats

The Format Cells dialog box has a new 
Percentage option on the Number tab, 
which converts decimal numbers to 
percentages in worksheet cells. The same 
option was added to the Number Format 
dialog box, which is used when you create 
or edit a record format.
Also on the Format Cells dialog box, the 
YYYY-MM-DD format was added to the 
Date format options.

“Formatting 
Worksheet Cells” on 
page 1330 and 
“Creating Record 
Formats” on 
page 262

Fundamentals

Feature Purpose Location Product
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Smooth selected mesh 
objects

Smooth the appearance of selected meshes 
rendered in OpenGL or Renderworks for a 
more polished presentation 

“Applying a Texture 
to an Object” on 
page 1530

Architect,
Landmark,
Spotlight,
Renderworks

Improved rendering of 
imported meshes

The Import SketchUp and Import 3ds 
commands now preserve the mesh smooth 
normals and mesh texture mapping of the 
original files, resulting in a much smoother 
final rendering and greatly reduced model 
size

“Applying a Texture 
to an Object” on 
page 1530

Architect,
Landmark,
Spotlight, 
Renderworks

Wireframe rendering 
improvements

Improves efficiency and visual perception 
of wireframe rendering

“Rendering with 
Vectorworks” on 
page 1587

Fundamentals

OpenGL rendering crease 
edges

Improves consistency of edges in OpenGL 
rendering

“OpenGL Options” 
on page 1590

Renderworks

OpenGL rendering color 
option

Adds ability to turn colors on and off in 
OpenGL rendering while maintaining any 
reflectivity, transparency, and bump effects

“OpenGL Options” 
on page 1590

Renderworks

Hidden line rendering text 
and marker options

Allows you to hide or display text and 
markers in hidden line renderings

“Line Render 
Options” on 
page 1592

Fundamentals

Renderworks style artistic 
edges

Create new effects by applying artistic 
edges on top of realistic-shaded renderings

“Creating 
Renderworks Styles” 
on page 1596

Renderworks

3D hatching for hidden line 
rendering

Display planar hatches on 3D hidden line 
renderings wherever a textured surface 
would exist in a raster-rendering mode. 
Some of the most commonly used standard 
Renderworks textures are pre-associated 
with appropriate hatches for ease of use.

“Hidden Line 
Rendering with 
Surface Hatches” on 
page 1606

Renderworks

Detail callout improvements Previously, detail callout objects were only 
displayed in the viewport or design layer 
where the detail viewport was created. You 
can now create multiple detail callout 
objects in other design layers or viewports, 
which are linked to the same detail 
viewport.

“Detail Callout 
Instances” on 
page 1635

Architect,
Landmark,
Spotlight

Feature Purpose Location Product
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Improved control over the 
dimension text position in 
viewports

The advanced properties of both sheet layer 
and design layer viewports have a new 
Re-Position Dimension Text option. The 
option re-positions rotated and flipped 
dimension text in the viewport according to 
the text position in the dimension standard. 
The text itself stays in the rotated and 
flipped orientation, but the position of the 
text box relative to the dimension line is 
changed.
In addition, the Adjust Flipped Text 
option now only adjusts the dimension text 
to be readable, without moving it to be 
above the dimension line.

“Advanced Sheet 
Layer Viewport 
Properties” on 
page 1642 and 
“Advanced Design 
Layer Viewport 
Properties” on 
page 1644

Fundamentals

SketchUp and 3DS import 
improvements

Improvements to the SketchUp import 
process include a more organized user 
interface and options for importing 
materials and textures; 3DS import was 
also improved for consistency and to 
provide texture import when creating mesh 
objects

“Importing in 
SketchUp Format” 
on page 1669
“Importing in 3ds 
Format (3D only)” 
on page 1695

Architect,
Landmark,
Spotlight

Improvements to STL 
(Stereo lithography) export

• Renamed the Export Stereo 
Lithography command to Export STL 
to make it clearer that it produces STL 
format files.

• Added options to export selected objects 
on the active layer, or export all visible 
objects on all layers; previously, the only 
option was to export all visible objects 
from the active layer.

“Exporting in STL 
Format” on 
page 1677

Fundamentals

Image import/export updates Importing and exporting image files no 
longer relies on QuickTime technology

“Importing an Image 
File” on page 1680 
and “Exporting an 
Image File” on 
page 1683

Fundamentals

Snapping option for PDF 
page objects

You can now enable or disable snapping for 
imported PDF files. Additionally, file size 
is reduced because snapping geometry is 
only generated when needed and it is never 
written to disk.

“Snapping to and 
Scaling Imported 
PDF Files” on 
page 1687

Architect,
Landmark,
Spotlight

PDF cropping Allows you to crop PDF objects imported 
into the Vectorworks program

“Cropping Imported 
PDF Files” on 
page 1689

Architect,
Landmark,
Spotlight

PDF/A-1b format export Files can be exported in the PDF/A-1b 
format

“Exporting PDF 
Files” on page 1690

Architect,
Landmark,
Spotlight

Feature Purpose Location Product
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Import/export of STEP files Vectorworks now supports the import and 
export of STEP files, increasing 
interoperability

“Importing and 
Exporting in STEP 
Format” on 
page 1699

Fundamentals

Parasolid export version The Export Parasolid X_T (3D only) 
command now supports Parasolid version 
27

“Exporting in 
Parasolid X_T 
Format (3D only)” 
on page 1701

Fundamentals

New options to control 
dashed lines during DXF/
DWG import

You can now select an option and set a 
minimum gap size to convert dashed lines 
to solid lines during import

“DXF/DWG and 
DWF Import 
Options” on 
page 1720

Fundamentals

New option to import DXF/
DWG tables as worksheets

A new option allows you to import tables 
as worksheets, for easier modification. 
Previously, tables were always imported as 
sets of individual line and text objects.

“DXF/DWG and 
DWF Import 
Options” on 
page 1720

Fundamentals

DWG/DXF and DWF 
import terminology 
improvements

Updates in terminology to make import 
dialogs more clear as to which type of file 
is being imported

“DXF/DWG and 
DWF Import 
Options” on 
page 1720

Fundamentals

Use Vectorworks rounding 
precision for DXF/DWG 
export

The precision settings for length and angle 
are now set according to the setting in the 
Units dialog box during export. Previously, 
only the length precision was set, to a fixed 
value.

Not applicable Fundamentals

Improved import of DWG/
DXF leader lines

Standard leader and multileader lines now 
import as polygons or polylines with arrow 
markers, instead of importing as a 
collection of independent objects

Not applicable Fundamentals

Feature Purpose Location Product
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Improvements related to the 
Vectorworks internal origin 
and user origin

Several improvements have been made 
regarding the Vectorworks internal origin 
and user origin.
• When importing a DXF/DWG/DWF file, 

a new Location tab allows you to choose 
the best import option for importing files 
relative to the internal origin; the default 
option prevents objects from being 
imported far from the internal origin

• A new Vectorworks preference displays 
the internal origin marker

• Two new commands locate the internal 
origin and center the drawing to the 
internal origin

• The User Origin dialog box has been 
renamed and improved

• User origin and internal origin 
terminology throughout the Vectorworks 
program has been renamed to eliminate 
confusion

“Import Options: 
Location Tab” on 
page 1727, 
“Vectorworks 
Display Preferences” 
on page 50, and 
“Internal Origin and 
User Origin” on 
page 72

Fundamentals

New options for exporting 
SIA dimensions to DXF/
DWG format

A new option allows you to export SIA 
dimensions as non-superscript AutoCAD 
dimensions that update automatically 
during reshape. Previously, SIA 
dimensions were always converted into 
non-dimension objects that looked exactly 
the same as they did in Vectorworks.

“DXF/DWG and 
DWF Export 
Options” on 
page 1734

Fundamentals

Filtering on IFC import Apply a filter when importing IFC files to 
eliminate irrelevant objects, reduce file 
size, and collaborate more efficiently

“Importing IFC 
Files” on page 1753

Architect,
Landmark

Export IFC command 
supports COBie/Facilities 
Management 

The Export IFC command now supports 
the COBie/Facilities Management MVD to 
produce COBie-compatible IFC files

“Exporting IFC 
Projects” on 
page 1755

Architect,
Landmark

Publish command 
improvements

• Allows you to have different settings for 
multiple items of the same file type

• Remembers the last used set
• Adds new folder options to the Publish 

dialog box
• Saves publishing options with sets
• Provides easier access to saved and 

published sets

“Batch Publishing” 
on page 1765

Fundamentals

Publish images You can now batch publish images using 
the Publish command

“Batch Publishing” 
on page 1765

Architect,
Landmark,
Spotlight

Feature Purpose Location Product
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Documentation Improvements
The following table lists major improvements to the documentation for the initial release of the Vectorworks 2015 
software.

Simplified export of 
database tables

The process of exporting record formats to 
a database table has been simplified

“Automatically 
Creating a Database 
Table from a Record 
Format” on 
page 1813

Architect,
Landmark,
Spotlight

Workspace editor 
improvements

Enhances the workspace editor by 
improving the usability and consistency, 
making it easier to manage workspaces.
You will now be notified if you attempt to 
create a workspace or if you import a 
third-party workspace containing tools or 
commands not available with your license.

“Managing 
Workspaces” on 
page 1835

Fundamentals

Save settings for resource 
name conflict

The settings in the Resource Name Conflict 
dialog box are now saved between 
Vectorworks sessions. This dialog box can 
display during both import and export of 
resources (Vectorworks Design Series 
required for export).

Various locations Fundamentals

QuickTime® Removal from 
Windows Core

Animation and projection operations 
throughout the Vectorworks program no 
longer depend on QuickTime

Various locations Fundamentals

Mac Resource Browser 
layout improvements

On Mac, the Resource Browser layout was 
made more consistent with other palettes 
and more compact to occupy less of the 
document window

Not applicable Fundamentals

Modernize object editing 
mode display

The appearance and functionality of the 
object editing mode button has been 
improved to comply with operating system 
requirements

Not applicable Fundamentals

Tablet command removal The Tablet command used now obsolete 
technology and as a result was removed 
from all workspaces

Not applicable Fundamentals

Feature Purpose Location Product
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Improvement Purpose Location

Complete re-engineering of the 
help system

The help system has been completely 
re-designed to make it easier to use.
• The help format has switched to HTML5 and 

displays in your default browser
• The help system is available online and can be 

viewed separately on a mobile device
• The Fundamentals and Design Series manuals 

have been combined
• Parameter tables are collapsed by default, 

allowing you to view the procedure only
• The Table of Contents is task-oriented
• Workflow topics and pages of relevant links 

help you get started with a procedure

Vectorworks Help system

New links to videos Where relevant, additional links to instructional 
videos located on the Vectorworks channel have 
been added, to assist with comprehension. 

Vectorworks Help system

New local help preference A new Vectorworks session preference allows 
you to always use the locally-installed version of 
the help system

“Session Preferences” on 
page 52

Expanded and improved 
worksheet documentation

The worksheet functions table now includes 
examples for both database header and 
spreadsheet cells for many functions. In 
addition, a new tutorial topic provides a simple 
introduction to worksheet features.

“Worksheet Functions” on 
page 1344, and “Worksheet 
Tutorial: Creating a Wall 
Schedule” on page 1361

Updated shortcuts list and 
Import PartSpec command 
path

Shortcuts were removed from the Machine 
Design commands so they can be reassigned to 
more frequently used commands. The Import 
PartSpec command has been removed from the 
File menu and is now available only beneath the 
Machine Design menu heading.

“Vectorworks 2015 
Keyboard Shortcuts” on 
page 1 and “Importing in 
PartSpec Format” on 
page 1668
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Getting Started
Installing Vectorworks Products
The Vectorworks installation program lists the installation system requirements, any known installation issues, and any 
information that changed in the software after final online help was produced. To ensure a smooth installation, confirm 
that system requirements are met and take note of any issues or incompatibilities prior to installing the software.
The installation program installs the entire Vectorworks series of programs, and determines which products to allow 
access to based on the serial number.
The installation process includes an option to add material to your copy of Vectorworks software, including 
industry-specific content libraries that can be added to drawings through the Resource Browser (see “Resource 
Libraries” on page 219). If you opt not to download this material when you install Vectorworks, it can be added later by 
selecting Help > Download Content to launch the Vectorworks Package Manager, and clicking Install for the libraries 
you want to download. 
Your software license allows for one copy to be made for backup purposes. The Vectorworks software should be 
backed up on a regular basis. These backups are invaluable in restoring user-customized settings that may be 
potentially lost by computer failure.

Student and evaluation versions of Vectorworks software include an additional step at installation: selection of an 
area of design that best describes the kind of work to be done. This is so that the most relevant default workspace 
displays on product launch. For instance, if lighting design is selected as the primary use, the Spotlight workspace 
opens. The entire Design Series and Renderworks product line is available and the workspace can be changed in 
the Tools > Workspaces menu regardless of how the question is answered.

Adding and Removing Serial Numbers
During installation you are typically required to enter the serial number, which is provided with the Vectorworks 
software. If you are not prompted to enter the serial number during installation, you must enter it the first time the 
program is accessed. You may also need to update a serial number to enable more products or to switch from an 
evaluation version to a full version.
To add a serial number:

1. Open the Vectorworks program.
The Serial Numbers dialog box opens the first time the program is accessed. Thereafter, it is accessed by clicking 
Serial Numbers from the Session tab of Vectorworks preferences.

2. Click Add.
The Add New Serial Number dialog box opens.

3. Enter the serial number exactly as it appears on the label. The serial number is case sensitive. The letters o and i 
are not used in serial numbers; enter zero or one instead.

4. Click Add.
The list of Enabled Products in the Serial Numbers dialog box displays all products enabled by this serial 
number. For security, serial numbers that begin with the letter A are partially hidden wherever they display in 
Vectorworks.

5. Only one serial number can be applied at a time. When the serial number is set, click Done.
To remove a serial number:

1. Click Serial Numbers from the Session tab of Vectorworks preferences.
The Serial Numbers dialog box opens.

2. Select the serial number to remove, and then click Remove.
3. Click Done.
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Viewing the Vectorworks License Agreement
The license agreement for the Vectorworks software can be viewed at any time.
To view the license agreement:

1. On Windows, select Help > About Vectorworks, or on Mac select Vectorworks > About Vectorworks.
2. Click License to display the license agreement text.
3. Click OK twice to return to the program.

Network Protection
When you run multiple copies of the Vectorworks program across a network, serial numbers are checked when the 
program is launched, and also periodically throughout the session.
If the same serial number is found to be in use, the All Serial Numbers In Use dialog box opens. From this dialog box, 
click User Information to display the User Name, if given, and the IP address of the other location. Click Edit 
Numbers to delete the existing serial number and enter a new one. Once the situation is resolved, click Retry 
Numbers to regain access to the program. If the serial number is still in use after three attempts, the program 
automatically shuts down.

Updating Vectorworks Products
Vectorworks software updates are called Service Packs, and are considered maintenance releases. There are several 
ways to obtain updates:

• Click Check for Updates from Help > About Vectorworks. Alternatively, select Help > Check for Updates 
(Windows) or Vectorworks > Check for Updates (Mac).
A dialog box opens to indicate whether the software is up to date, or if an update is available. If an update is 
available, click More Info to open a web browser to display and download available updates. If it is inconvenient 
to update the software at this time, click Cancel.

• Select to Automatically check for updates on a weekly or monthly basis from the Session tab of Vectorworks 
preferences (see “Session Preferences” on page 52).

• Updates are available for download at www.vectorworks.net/downloads

Creating a New File
To create a new file:

1. Select File > New.
The Create Document dialog box opens.

2. Select the type of document to create and click OK to open the new file.

Vectorworks searches your user folder, your workgroup folders, and the Vectorworks application folder for 
template files. If no templates are found anywhere on the system, the Create Document dialog box does not open. 
Instead, a blank new document is created automatically.

Document Type Description

Create blank document Opens a new drawing file with the default program settings (attributes, scale, units, etc.)
Use document template Opens a new drawing with settings that were saved in a template file; select the template 

to use (see “Creating Templates” on page 75 to learn more about templates)

http://www.vectorworks.net/downloads
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Opening a File
There are three ways to open a file that already exists. Up to eight files can be open at once in the program.
To open a file that already exists:

1. Select File > Open.
The Open dialog box opens.

2. Select the name of the file or template to open.
3. Click Open.

The program opens the last saved version of the selected drawing file.
To open a file that was recently used:

Select File > Open Recent and select a name from the list of the last 20 files that were opened or saved.
The file is opened; if the file is already open, it is moved to the front of the screen to become the current file.

To open a file from the operating system:
Double-click a file directly in Windows Explorer or Mac Finder.
If multiple versions of the Vectorworks program are installed, when you double-click to open a Vectorworks file 
from the operating system, the results may vary for Windows and Mac.

Windows

On Windows, file associations are determined in the Vectorworks File Associations dialog box.
• If Vectorworks file types have been associated with a particular copy of Vectorworks in the Vectorworks File 

Associations dialog box, double-clicking a file opens it in that particular version of Vectorworks.
• If the Vectorworks File Associations dialog box specifies that current Vectorworks file associations remain in 

place, double-clicking a file opens the file in the version of Vectorworks with which it is associated.

Mac

• If multiple versions of Vectorworks are currently open, double-clicking a file opens the file in whichever 
version of Vectorworks you opened first.

• If multiple versions of Vectorworks are installed but not open, double-clicking a file opens the file in the latest 
version of Vectorworks.

The Vectorworks program can open files that were created in MiniCAD 7 or in Vectorworks versions 8 and above. 
Files that were created in versions earlier than MiniCAD 7 must be converted to at least version 7, with a version of the 
program that is earlier than version 12. If an earlier version of the program is not available, contact Nemetschek 
Vectorworks Sales Support for assistance.
When a user attempts to open a file that another user already has open, an alert displays the name of the user who has 
the file open and where it is open; additional information about the file can be displayed, including its path, when it was 
opened, and how long it has been open.

Watermarked and Fingerprinted Files
Files from the Vectorworks educational version include a watermark. If this is the first time the file is being opened, a 
message displays, notifying you that the data in the file may only be used in other watermarked documents. This type 
of file is identified as watermarked in the title bar. If an educational version of the Vectorworks software is being used, 
a message displays to that effect, and also warns that any files created or modified in this version of the software will be 
watermarked. If you reference or import objects from a watermarked file, the current file is irreversibly converted to a 
watermarked file; and therefore prints with an educational watermark on every page.
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Library files which contain product-specific content, such as a Landmark library file, include a fingerprint which 
identifies the Vectorworks Design Series product(s) required to be able to use the content. This type of file is identified 
as fingerprinted in the title bar. When a fingerprinted file is opened, a message displays, warning that the file or any 
files created from it can only be used with the indicated Design Series product(s).
~~~~~~~~~~~~~~~~~~~~~~~~~
Mapping Missing Fonts

Mapping Missing Fonts
When you open a file that contains fonts that are not available on your system, the Font Mapping dialog box opens. 
Map fonts from the original file to a font available on your system, or open the document quickly by automatically 
mapping fonts to the default replacement font.
Click to show/hide the parameters.

To map missing fonts:
1. Populate the list of original fonts by selecting New Mappings or All Mappings.
2. If the default replacement font is acceptable for replacing all original fonts, click OK to open the document. 

Otherwise, proceed to Step 3.
Font mappings can be changed at any time by clicking Edit Font Mappings from the Display tab of Vectorworks 
preferences. 

3. Select an original font to map.
The Replace field displays the selected original font, and the With field lists the default and all available fonts. 
Select the desired replacement font, and then select the next original font to map. Repeat the process until all 
desired original fonts have been mapped.

4. Click OK when all desired original fonts have been mapped.
Mapped fonts are stored as a Vectorworks preference. If Vectorworks preferences are deleted, the Font Mapping 
dialog box re-displays for a file that may have previously had the fonts mapped.

Previewing Vectorworks Files from the Operating System
For Vectorworks files created in version 2008 or later, the Windows Explorer or Mac Quick Look plug-in provides 
image previews and thumbnail icon previews of files to more easily locate them (requires Windows Vista or later 
operating system, or Mac OS X 10.5+). 
When a file is saved, an image of the file’s current view is also saved. This image is then supplied to the operating 
system with the Vectorworks Windows Explorer or Quick Look plug-in. 

Parameter Description

Replace Automatically populates when an original font is selected
With Lists the default font and all available system fonts (the default font is the system font for 

the computer on which the program is installed)
Original Font Lists the unavailable font used in the file
Replacement Font Lists the font that will be used to replace the original font
New Mappings Lists fonts that have not previously been mapped
All Mappings Lists all fonts regardless of whether they have been previously mapped
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Windows Explorer File Preview
The preview options and views available in Windows operating systems depend on your specific OS and settings. The 
information that may be available includes a thumbnail preview of the file, a larger preview of the saved file’s current 
view, the date the file was last modified, and the Vectorworks version the file was created with, if known. When the 
Windows Search service is enabled, it can be used to locate text strings within the Vectorworks files.

Mac Quick Look File Preview
On the Mac, the preview image can be viewed in a number of ways:

• Select one or more documents within the Finder, and then press the Space Bar
• Select a document and then press the Quick Look button within the Finder (if your Mac settings display the Quick 

Look button)
• Select a document in the column view; the preview column contains the preview image
• Display the preview image in the preview section for Get Info

A preview is not available for files saved with auto-save or batch convert.

Mac Quick Look Thumbnail Preview
Vectorworks documents can use either the document thumbnail icon or the standard Vectorworks icon. The default 
setting for Show icon preview is off (the standard Vectorworks icon displays), and can be changed by the View > 
Show View Options (or the Cmd+J keyboard shortcut) from the Finder menu.
When Show icon preview is enabled, the default behavior applies only to the current folder, and to the current folder 
view (with or without details, for example). Click all folders in Finder Preferences to see the thumbnails for all folders. 
Change the setting for each individual View (list view or column view, for example) to see Quick Look thumbnails in 
all folder views.
~~~~~~~~~~~~~~~~~~~~~~~~~
Converting Previous Version Files as a Batch
Migrating from Previous Versions

Screen Resolution
Vectorworks software supports high resolution monitors, including Mac Retina® displays. This not only displays crisp, 
appropriately sized images, but also allows accurate 1:1 scale measurements and line weights to display on screen. 
When the Vectorworks application is open across display devices with different resolutions, the following rules apply:

• multiple document windows open on different devices will each display appropriately for the resolution of the 
screen on which it displays

• documents that span multiple devices display at the resolution appropriate for the screen on which the majority of 
the document displays

• documents that are mirrored on multiple displays display at the resolution of the lowest-resolution device
On the Mac, to force the software to open in low resolution, for instance to speed up rendering updates while drawing, 
before opening the Vectorworks application, Ctrl-click on the application icon and select Get Info. Select Open in 
Low Resolution. This setting persists across sessions until it is changed.

Closing a File
To close the current file:

1. Select File > Close or click the close box on the drawing window.
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2. If the file changed since it was last saved, click Save (Mac) or Yes (Windows) to save and close the file. Click 
Don’t Save (Mac) or No (Windows) to close the file without a save.

To close all open files (Windows only):
1. Select Window > Close All.
2. If the files changed since they were last saved, click Yes to save and close the files. Click No to close the files 

without a save.

Saving a File
The Save command saves the open file, which replaces the earlier version of the file. When you save a file for the first 
time, specify the file name and location. The Save command is disabled if no changes have been made to the file since 
it was first opened or created.
On Windows, the files require a “.vwx” or “.mcd” extension to be recognized by the Vectorworks program. If you do 
not enter an extension, the program adds the .vwx extension automatically.
To save the current file:

1. Select File > Save.
If the file has not been saved before, the Save Vectorworks Drawing dialog box opens.

2. Enter a name for the file in the Name field, and then select the destination for the file.
3. Click Save.

The program saves the file. The time required may depend on the file size.

Save As
To save the current file with a different name:

1. Select File > Save As.
The Save Vectorworks Drawing dialog box opens.

2. Enter a new Name for the file, and then select the destination for the file.
3. Click Save.

The program saves a new copy of the file. The time required may depend on the file size.

Save a Copy As
To save a copy of the current file and continue to edit the current file:

1. Select File > Save A Copy As.
The Save dialog box opens.

2. Enter a new Name for the file, and then select the destination for the file.
3. Click Save.

The program saves a new copy of the file and keeps the original file open for further edits. The time required may 
depend on the file size.

Automatically Saving Files
The autosave feature automatically saves the current file after either a specified number of minutes or a specified 
number of operations, as defined in the Autosave tab of the Vectorworks Preferences dialog box. See “Autosave 
Preferences” on page 55 for more information.
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If the Confirm before save preference is selected, a confirmation dialog box displays before the autosave is 
performed. The information that displays in this dialog box depends on the settings selected in Vectorworks 
preferences.
Click to show/hide the parameters.

When the save is complete, the message Autosave complete displays in the lower right corner of the window; the 
message clears when you click the mouse.
~~~~~~~~~~~~~~~~~~~~~~~~~
Reverting to the Last Saved Version

Reverting to the Last Saved Version
The Revert to Saved command replaces the active drawing with the most recently saved version. This deletes all 
changes made since the last save, which can remove several undesirable changes in one step.
To revert to the last saved version:

1. Select File > Revert to Saved.
This action cannot be undone. Confirm that changes should not be saved.

2. Click OK.
The program closes the active drawing and opens the last saved version of the file.

~~~~~~~~~~~~~~~~~~~~~~~~~
Saving a File

Exiting Vectorworks
To close the Vectorworks program along with any open files:

1. Select File > Quit (Windows) or Vectorworks > Quit (Mac).
2. If there are any unsaved files, click Save (Mac) or Yes (Windows) to save the changes and exit. Click Don’t Save 

(Mac) or No (Windows) to exit without a save.

Converting Previous Version Files
The Vectorworks program must translate files created in previous versions into the current format. The program cannot 
convert MiniCAD 6 or earlier files, however. 

• To convert an entire folder of files at once, use the Batch Convert command as described in “Converting Previous 
Version Files as a Batch” on page 28.

• To convert one file at a time, open and save the file with the current version of the program as described in 
“Converting a Single Previous Version File” on page 31.

The program automatically applies PNG compression to images contained in converted files.

Parameter Description

Yes Saves the file; if the document has not been saved, the Save dialog box opens to name the file first
No Cancels the save operation and resets the autosave counters
Settings Opens the Vectorworks Preferences dialog box to edit the autosave parameters; select Don’t backup 

this document for the remainder of the session to disable the autosave feature for the active 
document for the remainder of the session
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You may need to correct the visibility of crop objects and annotation objects in sheet layer viewports (see “Creating 
Sheet Layer Viewports” on page 1616).
For files earlier than Vectorworks 2009, the geometry of the drawing objects is automatically converted using the new 
Parasolid kernel. The conversion may fail for some solids for a variety of reasons: for example, if an object has 
self-intersecting profiles inside an extrude or sweep, or if an object’s surfaces do not pass the Parasolid checks. If this 
happens, the program converts all of the other objects and alerts you that some objects were not converted. A 
wireframe representation of the failed solid is included in the file; you may be able to edit these objects and regenerate 
the solids.
As of Vectorworks 2013, dash styles are line type resources. Standard dash styles from previous versions are now 
included as default resources. At translation time, new resources are created for all custom dash styles that exist in a 
document, and all objects that use dash styles are updated to use the appropriate resource.
~~~~~~~~~~~~~~~~~~~~~~~~~
Migrating from Previous Versions
Converting Previous Version Files as a Batch
Converting a Single Previous Version File
Migrating Site Models from Previous Versions
Resetting Plug-in Objects from Previous Versions
Migrating Rendered Files from Previous Versions of Renderworks

Migrating from Previous Versions
The Update Plug-in Objects command converts a variety of legacy objects to the current format. This command 
works across all file layers, and as applicable, on objects that are freestanding, inserted in walls, in a placed symbol, or 
in a symbol definition. All applicable parameter values, and any attached records are also transferred during the 
conversion. 

Saving a copy of the file prior to running the command is recommended, as the command cannot be undone.
To update plug-in objects:

1. Open a file containing legacy objects.
2. Select Tools > Utilities > Update Plug-in Objects.

The Update Plug-in Objects dialog box opens. 
3. Select the type(s) of objects to convert to the new format, and then click OK. 

All older version objects of the selected type(s) are converted into the new format. 
~~~~~~~~~~~~~~~~~~~~~~~~~
Converting Previous Version Files

Converting Previous Version Files as a Batch
During a batch conversion, the program scans all files in the source folder (and in subfolders, optionally), and converts 
previous version files to the current format. Non-Vectorworks files and Vectorworks files that are too old to convert are 
skipped and recorded in the log file.
There are two options for Vectorworks files during batch conversions:

• By default, the program moves the previous version files to an archive folder and places the converted versions of 
those files in the source folder.

• Alternatively, the program makes no changes to the source folder. Instead, the converted files (and copies of any 
current version Vectorworks files) are placed in a specified folder.
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To convert a batch of files:
1. Place all files to be converted in one folder, or in subfolders within the source folder.
2. In the Vectorworks program, select File > Batch Convert.

The Batch Convert dialog box opens.
Click to show/hide the parameters.

3. Click OK to convert the files.
Each file is briefly opened and re-saved into the appropriate folder. Subfolder names and hierarchies are recreated, 
if they are included in the conversion process. If Convert in place is selected, the original files are moved to the 
archive folder, in the original subfolder structure.

4. Once the conversion is complete, the Batch Conversion Results dialog box displays a summary.
Click to show/hide the parameters.

Parameter Description

Source Folder Click Choose to open either the Choose Source Folder dialog box (Mac) or the Browse 
for Folder dialog box (Windows). Select the folder that contains the files you want to 
convert, and then click Choose (Mac) or OK (Windows) to return to the Batch Convert 
dialog box.

Destination Folder To place the converted files into a different folder, click Choose to open either the 
Choose Destination Folder dialog box (Mac) or the Browse for Folder dialog box 
(Windows). Select the folder, and then click Choose (Mac) or OK (Windows) to return 
to the Batch Convert dialog box. Then deselect Convert in place.

Include subfolders Converts the files within the subfolders of the source folder
Convert in place Moves the original Vectorworks files to an archive folder, and places the newly 

converted files in the original source file locations. The archive folder is created within 
the source folder and is named “Old Version Vectorworks Files.”
Deselect this option to place the converted files in the destination folder and make no 
changes to the source folder.

Convert layer links into 
viewports
(Vectorworks Design 
Series required)

Creates viewports on design layers that reference one or more layers within the same 
file. Select this option to convert any layer links in the older version files into viewports.

Convert referenced 
layers into referenced 
viewports
(Vectorworks Design 
Series required)

Creates viewports on design layers that reference one or more layers in an external file. 
Select this option to convert any referenced layers in the older version files into 
viewports.

Convert absolute 
references into relative 
references
(Vectorworks Design 
Series required)

Converts workgroup references with absolute file paths to relative file paths, if a relative 
file path is allowed. A relative file path is not allowed if the file is on a different volume 
from the referenced file.
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5. Click Details to view a log file with information about each file processed during the conversion.

Parameter Description

Total files in source folder The total number of files contained in the specified source folder
Total files successfully 
converted

The total number of files successfully converted by the Batch Convert command

Total current version files 
copied

The total number of files that were already in the current version of the Vectorworks 
program; if Convert in place is selected, the files are left in place in the original 
folder; if Convert in place is not selected, the files are copied to the destination folder

Total files not converted The total number of files that were not converted
Not a Vectorworks file The number of files that were not converted because they were not Vectorworks files
Damaged files The number of files that were not converted because they damaged in some way and 

could not be opened and processed
Unsupported 
Vectorworks file 
version 

The number of files that were not converted because they were MiniCAD 6 or an 
earlier version, which is not supported by the Batch Convert command

Unknown reasons The number of files that were not converted, for which the program could not detect a 
reason

One or more files had 
solid conversion errors

This message indicates that one or more of the successfully converted files contained a 
solid that could not be properly generated by the Parasolid kernel. Check the log file to 
see which files had solid conversion failures. You may be able to edit the converted 
geometry and regenerate the solids. 
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~~~~~~~~~~~~~~~~~~~~~~~~~
Converting a Single Previous Version File
Creating Design Layer Viewports

Converting a Single Previous Version File
When you open an older file, the program automatically converts the file and assigns it an appropriate name. By 
default, the program renames the converted file and keeps the original file intact. Change the default setting to rename 
the original file and use the original file name for the converted file instead. In this case, if the original file is 
write-protected, the program cannot rename it; save the converted file and give it an appropriate name.
To convert a single file:

1. In the current version of the Vectorworks program, open a file that was created with a previous version of the 
program.
A conversion alert box opens, showing which file will be renamed, along with the new name. The action described 
in the dialog box depends on the current setting for converting file names.

2. To change the way this file will be converted, click Settings.
The Vectorworks dialog box opens.

Click to show/hide the parameters.

Parameter Description

Keep the original file name with 
the

Select which file will have the original file name: the original file or the new 
file
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3. Specify the conversion settings and click OK to save the change; future file conversions will use this setting.
4. In the conversion alert box, click OK to continue with the conversion.
5. If the file contains a solid that could not be properly generated by the Parasolid kernel, an alert displays to this 

effect.
You may be able to edit the converted geometry and regenerate the solid. (See “Converting Previous Version 
Files” on page 27 for more information.)

~~~~~~~~~~~~~~~~~~~~~~~~~
Converting Previous Version Files as a Batch
Creating Design Layer Viewports

Migrating Site Models from Previous Versions
As of version 12, files containing site model symbols from previous versions can be easily converted.
When you update a site model from a previous version, you are prompted to convert to the new site model. If the file 
contains more than one site model symbol, an alert dialog box prompts for the selection of one of the symbols to be 
converted to the primary site model object. The remaining symbols become snapshots of the primary site model.
Site model classes that were necessary for previous versions remain in the file, although they are no longer used.
~~~~~~~~~~~~~~~~~~~~~~~~~
Sitework Overview

Resetting Plug-in Objects from Previous Versions
When you migrate plug-in objects from previous versions, some Object Info palette parameters display when they 
should be hidden. Select the Reset All Plug-ins command to update the Object Info palette parameter display.
To reset plug-in objects:

1. Open an older drawing containing plug-in objects.
2. Select Tools > Utilities > Reset All Plug-ins.

The Reset All Plug-ins dialog box opens. 
3. Click Yes to reset plug-in objects.

A message displays the update status. When complete, the Object Info palette displays only the pertinent 
parameters.

Convert layer links into viewports
(Vectorworks Design Series 
required) 

Creates viewports on design layers that reference one or more layers within the 
same file. Select this option to convert any layer links in the older file into 
viewports.

Convert referenced layers into 
referenced viewports
(Vectorworks Design Series 
required) 

Creates viewports on design layers that reference one or more layers in an 
external file. Select this option to convert any referenced layers in the older 
version file into viewports.

Convert absolute references into 
relative references
(Vectorworks Design Series 
required)

Converts workgroup references with absolute file paths to relative file paths, if 
a relative file path is allowed. A relative file path is not allowed if the file is on 
a different volume from the referenced file.

Parameter Description



Undocumented Plug-in Objects |  33
Migrating Rendered Files from Previous Versions of Renderworks
Significant changes and improvements to rendering occurred after the Renderworks 2010 version. The Renderworks 
program now uses the CINEMA 4D® rendering engine, which provides many benefits, such as increased rendering 
speed, high-quality rendering, additional export options, and a simplified interface. 
When opening previous version files, please keep the following points in mind.

• The rendered appearance and quality of converted files is kept as similar as possible. However, some shaders 
cannot be matched exactly and render differently.
• The following shaders are not matched: Corrugated, Spanish, and Roman roof tiles.
• The following Artistic Renderworks options are no longer available: Contour, Mosaic, Stipple, Color Wash, 

and Ink Print styles.
• Other Artistic Renderworks styles do not render identically in previous version files; however, the number of 

Artistic Renderworks options has increased.
• Area lights now emit light in both surface directions, not just in the surface normal direction. Therefore, some 

masking geometry may be required behind the area light to obtain a similar rendered effect to previous versions.
• Lighting and image brightness from previous versions can now be adjusted with the Emitter Brightness 

parameter in the lighting options (View > Lighting > Set Lighting Options). If rendering with Custom 
Renderworks, adjusting the Image Exposure parameter may also help match a previous look.

• If you have created custom plug-in objects in previous versions, the shader record numbers have changed.

Undocumented Plug-in Objects
                                                                               
Certain older plug-in objects have historically not been documented. As these plug-in objects are updated, they will 
gradually be incorporated into the help system.

The Vectorworks Workspace
When the Vectorworks Fundamentals program is started, the main window opens with a new, blank file; the 
Fundamentals workspace is selected, and contains menus, palettes, and tool sets in a default layout. During a work 
session, palettes may be opened, closed, and moved around as necessary. When the application is closed, the last 
workspace settings are preserved and restored for the next session.
Custom workspaces can be created, as described in “Creating or Editing Workspaces” on page 1835. To switch to 
another workspace, select Tools > Workspaces, and then select the workspace from the list of those available.
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Menu bar
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File name

Tool Sets
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Object Info palette - the 
Render tab displays if 
Renderworks or a Design 
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Vectorworks Application Window on Windows
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Windows, palettes, tool sets, and dialog boxes that contain a sizing handle in their bottom right corner can be resized; 
click-drag the sizing handle to the desired location.
The following table describes some of the workspace features common to all Vectorworks products.

Component Description

Menu bar Contains pull-down menus that access Vectorworks commands
Title bar All windows, palettes, tool sets, and dialog boxes have a title bar; click and drag any title bar to 

move the item to the desired location. See “Palette Layout Options” on page 40.
Data bar Depending on the tool and on the action being performed, the Data bar displays information 

such as coordinate data, length, and angle. Use the Data Bar and Edit Group Options list to set 
the Data bar either to “float” with the cursor, or to be stationary on the Data bar. See “Using the 
Data Bar” on page 125 for more information. These options can also be set from the selections 
listed under Windows > Data Bar Options. 

Tool bar Displays the various modes of the active tool; click a mode to select it. The bar also displays 
mode information and accesses the tool preferences, if any. The Tool bar is divided into 
sections grouped by mode function. To move easily through the mode sections from the 
keyboard, press the U, I, O, P, [ (left bracket), and ] (right bracket) keys. Each key corresponds 
to a consecutive Tool bar section (see the Mode Modifier shortcuts in “Modifying Snapping 
and Mode Shortcuts” on page 1842).

View bar Contains buttons and pull-down menus that control the view in various ways (see “The View 
Bar” on page 37)

Vectorworks Application Window on Mac
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Vectorworks Fundamentals and Design Series Workspaces
When Vectorworks Design Series products are installed, additional workspaces are available in addition to the 
Fundamentals workspace.
The Fundamentals workspace commands and tools also appear in Design Series workspaces. In some cases, command 
or tool functionality is extended in the Vectorworks Design Series products, and the location in the workspace may be 
different. If a command, tool, or parameter described in the documentation requires Design Series, an icon or text 
indicates that requirement. Examples of commands and tools with extended functionality in Design Series products 
include straight and round walls, columns, sheet borders, callouts, objects from shapes, and roof object creation.
~~~~~~~~~~~~~~~~~~~~~~~~~
The View Bar
Palettes and Tool Sets
Palette Layout Options
List Box Functionality
Additional Key Functionality
Screen Tips
Object Editing Mode
Setting Vectorworks Preferences
Setting Document Preferences
Context Menus
Using the Resource Browser
The Object Info Palette

Message bar Displays tool explanations, undo messages, minor alerts, and a progress bar (when applicable). 
To also display cursor location fields on the Message bar, click the triangle at the far right of 
the bar; select the option to display all positional fields, only cursor-based location fields, or no 
cursor location fields.

Drawing area This is the open portion in the middle of the Vectorworks application window where drawings 
are created; it includes both the print area and the space that surrounds it

Print area Within the drawing area, a gray border defines the print area, if shown. Only the objects that 
are included within the print area are printed. The print area is divided into pages; each page 
equals a physical sheet of paper to be printed. A print margin is built in for each page (see “The 
Print Area” on page 1761).

Rulers Based on the current measurement system, rulers make it easier to precisely create and place 
objects within the drawing. 
The 0,0 point on the rulers represents the location of the user origin, or of the working plane 
axes when using a working plane. The User Origin command moves the user origin relative to 
the internal origin, or moves the working plane origin to that of the layer (see “Setting the User 
Origin” on page 74).
The rulers can be hidden with an option in the Vectorworks preferences (see “Vectorworks 
Display Preferences” on page 50).

Grids Based on the current measurement system, two grid systems make it easier to precisely create 
and place objects within the file. To hide the reference grid, deselect Show Grid Lines (see 
“Snap and Reference Grids” on page 71).

Component Description
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The View Bar
The View bar is located along the top of the application window. It provides quick access to various options that affect 
the drawing view. Some View bar items have equivalent menu commands.
The selections made in the View bar menu determine what displays on the View bar.

Component Description

Previous View Displays the previous view that was created by a pan, zoom, or scroll in the drawing area; 
the application keeps track of up to 50 views

Next View Displays the next view; the application keeps track of up to 50 views
Classes tab shortcut Opens the Classes tab of the Organization dialog box
Classes Displays the active class, activates a class that is selected from the list of existing classes 

in the file, or enables a new class to be created.
When a new class is created, it does not automatically become the active class.

The list of classes provides the following information:
• An icon to the left of each name indicates the current visibility setting of the class (see 

“Using Visibility Columns” on page 193 for more information).
• A triangle to the right of the class name indicates that the class has subgroups that can 

be selected individually (for example, a wall class with exterior and interior 
subgroups).

To turn off hierarchical display of classes, see “Session Preferences” on page 52.
• On Mac only, if a description was entered for the class, it displays in a screen tip when 

you position the cursor over the class name.

Shortcut to the Classes 
tab of the Organization 
dialog box

Previous 
View

Next View

Classes

Shortcut to either the Design Layers tab 
or the Sheet Layers tab of the 
Organization dialog box

Layers Look At Working 
Plane

Current Layer Scale 
(display only)

Shortcut to the
Layer Scale

dialog box

Fit to Page Area

Fit to Objects

Zoom In/Out
Current Zoom

Current View/ 
Standard 
Views list

Unified View 

Current Render Mode/ 
Render Modes list/ Available 
render options

View bar menu
Rotated View options
(Vectorworks Design

Series required)

Active Planes list

Saved Views 
menu

Working Plane Views

Active Layer 
Plane Views
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Design Layers tab/Sheet 
Layers tab shortcut

Depending on whether a Design Layer or a Sheet Layer is active, opens either the Design 
Layers tab or the Sheet Layers tab of the Organization dialog box

Layers Displays the active layer, activates a design layer or sheet layer that is selected from the 
list of existing layers in the file, or enables a new layer to be created.

When a new layer is created, it becomes the active layer.
The list of layers provides the following information:
• The area to the left of each name indicates the view and visibility of the layer. 

Depending on the view, any of the following icons can display for design layers; sheet 
layers are always in Top/Plan view:

The visibility of the layer is indicated as follows:
Black icon — the layer is visible
Gray icon — the layer is grayed
No icon — the layer is invisible

• Referenced design layers display in italics.
• On Mac only, if a description was entered for the layer, it displays in a screen tip when 

you position the cursor over the layer name. If the layer is referenced, the full layer 
name and the source file name also display in the screen tip.

Active Planes list Displays the active plane. Depending on the current tool, view, and presence of named 
working planes, also activates a plane that is selected from the list. See “The Active 
Planes List” on page 1168.

Look At Working Plane Changes the view to be perpendicular to the working plane; in other words, rotates the 
X’, Y’ axes to the screen X and screen Y position

Saved Views menu Activates a saved view that is selected from the list. Select Edit View to open the Saved 
Views tab of the Organization dialog box, or select Save View to open the Save View 
dialog box; see “Creating or Editing Saved Views Using the Saved Views Menu” on 
page 192.

Layer Scale shortcut Opens the Layer Scale dialog box; the scale of the active design layer displays to the 
right. See “Changing the Scale of the Drawing or the Active Design Layer” on page 67.

Fit to Page Area Displays the whole drawing (all pages) in the drawing window; see “Fit to Page Area” on 
page 1162

Fit to Objects Zooms in or out so that all of the objects in a drawing are visible. If an object or objects 
are currently selected, the zoom is relative to those object(s); see “Fit to Objects” on 
page 1162.

Zoom In/Out Click to double the magnification of the drawing; to reduce the magnification of the 
drawing by one-half, use Alt-click (Windows) or Option-click (Mac). The zoom centers 
on any objects that are selected; if nothing is selected, the zoom centers on the last empty 
spot that was clicked. See “Zooming from the View Bar” on page 105.

Current Zoom Zooms in or out by the zoom factor that is selected or entered; this option is available 
when the Zoom - Long option is selected on the View bar menu

Component Description

Top/Plan view Any standard view 
other than Top/Plan

Plan Rotation active (Vectorworks 
Design Series required)
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Layers
Creating Classes
Setting Design Layer Properties
Setting Class Properties
Saved Views
Zooming
Using Standard Views
Rendering with Vectorworks
Renderworks Rendering Modes
Understanding the Working Plane
Rotating the Plan

Palettes and Tool Sets
The Fundamentals workspace contains various palettes for creating and editing objects. Basic and Tool Sets are tool 
palettes, which have special functionality, as described in “Tool Palette Features” on page 42. If a keyboard shortcut is 
currently assigned to a menu command or tool, the shortcut displays when the mouse hovers over the command or tool; 
to set up or modify keyboard shortcuts, see “Modifying Menus and Commands” on page 1837.

Depending on the initial settings, some palettes may be hidden when the program is launched.

Working Plane Views Displays global coordinate views based on X’, Y’, and Z’ axes. In any standard view, and 
when switching views, such as to Top or Front, the view is based on the working plane 
position rather than the layer plane position. For a rotated top/plan view (Vectorworks 
Design Series required), switching to a view such as Front will take into account the 
rotated plan view and display a rotated Front view.

Active Layer Plane 
Views

Displays working plane coordinate views (such as Top or Front) based on X, Y, and Z 
axes. In any standard view, and when switching views, the view is based on the active 
layer plane position. 

If switching from a rotated top/plan view (Vectorworks Design Series required), an 
alert message provides the option to enable Working Plane Views mode instead.

Current View/ Standard 
Views list

Displays the current view, and activates a standard view (such as Top) that is selected 
from the list; see “Using Standard Views” on page 1141. If the view is not standard (for 
example, if the Flyover tool was used), Custom View displays.

Rotated View 
(Vectorworks Design 
Series required)

Rotates the plan view by the angle specified; see “Rotating the Plan” on page 1163

Unified View Toggles Unified View mode; see “Unified Layer View” on page 1152
Current Render Mode 
Options

If the current render mode has options, displays the appropriate options dialog box; this 
option is available when the Render Mode - Long option is selected on the View bar 
menu

Current Render Mode/ 
Render Modes list

Displays the current render mode, and activates a render mode selected from the list; 
select Options for Other Render Modes to access the options for a particular mode. See 
“Rendering with Vectorworks” on page 1587 and “Renderworks Rendering Modes” on 
page 1593.

View bar menu Selects the options to display on the View bar

Component Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Vectorworks Fundamentals and Design Series Workspaces

Palette Layout Options
Customize the palette layout as needed.

• Select Window > Palettes to display or hide palettes. Alternatively, right-click (Windows) or Ctrl-click (Mac) on 
the drawing area, and select Palettes from the document context menu.

• Click on the title bar of any displayed palette and drag it to the desired location.
• Most palettes can be resized by the standard Windows or Mac resize method.

Each time you exit the Vectorworks program, the current palette settings and positions are automatically saved for each 
workspace in a file in your user folder ([User]\Settings\SavedSettings.xml). The settings in this user file override the 
initial palette settings in the workspace file. To reset to the original workspace settings, click Reset Saved Settings 
from the Session tab of Vectorworks preferences (see “Session Preferences” on page 52).

Palette / Tool Set Purpose

Snapping Contains SmartCursor snapping controls that can be toggled on or off; see “Setting 
Snapping Parameters” on page 131

Attributes Contains a selection of colors, fills, pens, and other object attributes; see “The Attributes 
Palette” on page 1093

Object Info Lists context-sensitive object information for viewing and editing; see “The Object Info 
Palette” on page 997

Working Planes Contains controls for adding and modifying working planes; see “The Working Planes 
Palette” on page 1176

Resource Browser Accesses the resources available for use in drawings, including gradient fills, hatch 
patterns, image fills, record formats, scripts and script palettes, symbols and symbol 
folders, worksheets, textures, backgrounds, and more. See “Resource Libraries” on 
page 219.

Visualization 
(Renderworks required)

Accesses all lights and cameras in the file; see “Managing Lights and Cameras with the 
Visualization Palette” on page 1611

Basic Contains a single set of basic object creation and editing tools; the palette can be 
customized through the Workspace Editor

Tool Sets In the Fundamentals workspace, the palette includes the following tool sets, whose tools 
are grouped by similar functionality; the palette and its tool sets can be customized 
through the Workspace Editor

3D Modeling Contains tools for creating and editing 3D objects, including solids and NURBS
Visualization Contains tools for changing the drawing view in different ways, including the 

Walkthrough and Light tools
Dims / Notes Contains tools for adding dimension and label objects
Walls Contains basic wall creation tools
Detailing Contains tools for adding architectural detail objects, such as tubing

Script Palettes Contains palettes with script resources
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Specifying Mac Palette Margins
On the Mac, the palettes can be placed in a margin on either side of the drawing area. When the palette margins are in 
use, the drawing area cannot expand past a fixed size, which allows the palettes to remain out of the way. The palette 
margin area can be turned on and off in the Vectorworks preferences as described in “Session Preferences” on page 52.

Minimizing Palettes
To increase the available drawing area, palettes can be minimized while not in use, and then maximized when needed.
On Mac, click the palette’s yellow title bar button or double-click the palette’s title bar to minimize the palette. Repeat 
the process to maximize the palette.
On Windows, click the palette’s pin icon in the title bar to toggle between minimized (horizontal pin icon) and 
maximized (vertical pin icon) display. Move the cursor over a minimized title bar to temporarily maximize the palette; 
move the cursor off the palette to minimize it again.

~~~~~~~~~~~~~~~~~~~~~~~~~
Docking Windows Palettes
Tool Palette Features
Vectorworks Fundamentals and Design Series Workspaces

Docking Windows Palettes
In Windows, most palettes can be docked to any of the four drawing window edges, or snapped to other docked 
palettes. The Object Info, Resource Browser, Attributes palette, and Working Planes palettes can only be docked to the 
left and right window edges.
The ability to dock palettes is enabled by default in the Session tab of the Vectorworks Preferences dialog box. Deselect 
this option to disable docking. See “Setting Vectorworks Preferences” on page 49 for more information.
To dock or undock a palette by double-clicking:

1. Double-click a palette’s title bar.
If the palette was undocked, double-clicking docks it in its previous location. If the palette was docked, 
double-clicking undocks it and moves it to its previous location in the drawing area.

2. To toggle the docked/undocked status, double-click the palette’s title bar again, as necessary.
To dock a palette by dragging it:

1. Drag the title bar of the desired palette toward the edge of the window.
The palette’s view switches to a gray outline. When the palette is in range of a window edge, the outline changes 
shape to represent the new docked shape.

2. Move the palette’s outline to the edge of the docking location and release. Currently docked palettes adjust their 
location along the edge to accommodate the new palette.

Minimized palette Maximized palette
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To prevent a palette from docking, hold down the Ctrl key while dragging the palette near an edge.
To undock a palette by dragging it:

1. Drag the title bar of the desired palette away from the edge.
The palette’s view switches to a gray outline. When the palette is out of window edge range, the outline changes 
shape to represent the new undocked shape.

2. Drag the palette to the desired location within the drawing area.
~~~~~~~~~~~~~~~~~~~~~~~~~
Palette Layout Options
Tool Palette Features
Vectorworks Fundamentals and Design Series Workspaces

Tool Palette Features
Both the standard tool palettes (Basic and Tool Sets) and any custom tool palettes have special features that other 
palettes do not. Tool palettes and their tool sets can be created and customized using the Workspace Editor (see 
“Creating or Editing Workspaces” on page 1835).

Pop-out Tools
On tool palettes, an arrow on the right side of a tool icon or label indicates additional, related pop-out tools. Click and 
hold down the mouse button to open the menu of pop-out tools.

Utility Menus
Each tool palette has a button at the bottom that opens a utility menu, which controls the palette and tool display.
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Menu / Command Action

View Tools As
Icons Display only an icon for each tool
Icons and Text Display both an icon and a text label for each tool
Text Display only a text label for each tool

Sort Tools By
Manual Placement Display tools in the order appearing in the Workspace Editor
Ascending Alphabetical Display tools in ascending alphabetical order according to text labels
Descending Alphabetical Display tools in descending alphabetical order according to text labels

View Tool Sets As (These options are available only for tool palettes with multiple tool sets)
Icons Display only an icon for each tool set in the palette
Icons and Text Display both an icon and a text label for each tool set in the palette
Text Display only a text label for each tool set in the palette

Sort Tool Sets By (These options are available only for tool palettes with multiple tool sets)
Manual Placement Display tool sets in the order appearing in the Workspace Editor
Ascending Alphabetical Display tool sets in ascending alphabetical order according to text labels
Descending Alphabetical Display tool sets in descending alphabetical order according to text labels

Place Tool Sets At (These options are available only for tool palettes with multiple tool sets)
Top of Palette Display tool set selection buttons at the top of the tool palette
Bottom of Palette Display tool set selection buttons at the bottom of the tool palette

Customize Opens the Workspace Editor Options dialog box (see “Creating or Editing 
Workspaces” on page 1835 for details)
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Tool Set Selection Buttons and Tear-off Palettes
If a tool palette has multiple tool sets (as does the Tool Sets palette), selection buttons for each tool set display on the 
palette. To display a tool set’s tools, click the appropriate button. The button is highlighted to indicate which tool set is 
active.
To see multiple tool sets at once, drag a tool set’s selection button off the main palette. This creates a separate, 
temporary palette for the tool set, with a “perforated” top edge. Like other palettes, these tear-off palettes can be 
docked, resized, and minimized. To close a tear-off palette, click its close button. On Windows, a docked tear-off 
palette does not have a perforated edge; instead, it has a special close button in the shape of a curved arrow.

~~~~~~~~~~~~~~~~~~~~~~~~~
Palette Layout Options
Docking Windows Palettes
Vectorworks Fundamentals and Design Series Workspaces

List Box Functionality
Dialog boxes that contain long lists of information (such as the Organization dialog box) may have some or all of the 
following functionality. 

Task Action

Change the list’s sort key Click the heading of the column to sort by; an arrow appears on the right side of 
the column heading to indicate that it is the sort key

Change a column’s sort order Click the column heading; the sort arrow in the heading indicates whether the 
current sort is ascending or descending

Resize a column Click the vertical line on the right side of a column’s heading and drag it left or 
right

Select a group of items Click the first item, and then Shift-click the last item in the group
Select multiple items 
individually

Click the first item, and then Command-click (Mac) or Ctrl-click (Windows) each 
additional item

Select an item on the list Type the first letter(s) of the desired item’s name
Edit an item on the list Double-click the desired item
Open a context menu for an 
item on the list

Ctrl-click (Mac) or right-click (Windows) the desired item

Drag the Walls tool set button off 
the Tool Sets palette to create a 
Walls tear-off palette

Click the Visualization tool set
button to display its tools
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~~~~~~~~~~~~~~~~~~~~~~~~~
Vectorworks Fundamentals and Design Series Workspaces
Displaying Classes in Hierarchical Order

Additional Key Functionality
In the Vectorworks program, several keys have additional functionality beyond the standard conventions:

For lists with a Visibility 
column, set the same visibility 
for all items on the list

Option-click (Mac) or Alt-click (Windows) the desired setting

Display lists in hierarchical 
order

Classes can be displayed in hierarchical order (up to four levels). To enable or 
disable hierarchical display of classes on pop-up menus including in the Object 
Info palette, the View bar, and dialog boxes, see “Session Preferences” on 
page 52.
On the Classes tab of the Organization dialog box and the Navigation palette 
(Vectorworks Design Series required), display options are saved separately. See 
“Displaying Classes in Hierarchical Order” on page 159.

Key Usage

Esc Cancels the current operation. When a dialog box is open, this is the equivalent of 
pressing the Cancel button. In the Data bar or Object Info palette, cancels the entry in a 
field and returns the focus to the drawing area. Cancels rendering. Clears smart points. 
Deselects the working plane.

Task Action

The arrow indicates the current sort key and sort 
order; click the column heading to reverse the 
sort order; not available for classes sorted in 
hierarchical order, or stories (Vectorworks Design 
Series required)

Click the heading of a column
without the sort arrow (as

applicable) to sort the list by
that column

Drag the vertical line on the right 
side of a column heading to adjust 
the column size

Type the first letter
of an item’s name

to select it

Option-click (Mac) or
Alt-click (Windows) one

of the Visibility
columns to set that

visibility for all items on
the list
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Using Arithmetic Expressions
Arithmetic expressions can be entered into most of the edit fields, including the Object Info palette’s Shape tab and the 
Data bar. For this reason, the dash (-) cannot be used as a separator between feet and inches.
Parentheses can be used to override the default operator precedence. For example:
1” + 2” * 3” = 7” (without parentheses)
(1” + 2”) * 3” = 9” (with parentheses)
Values can be entered in any unit; the program converts it into the current unit. For example, if the current unit is Inches 
and an entry of 4”+3 cm is made into the Object Info palette X field, the program converts the units automatically. The 
result, 5.1811”, is displayed.
~~~~~~~~~~~~~~~~~~~~~~~~~
Units
Vectorworks Fundamentals and Design Series Workspaces

Screen Tips
Screen tips are available throughout the program to identify items such as tool, mode, and snapping names. To view a 
screen tip, hold the cursor briefly over the item in question.

On Windows, some items have screen tips that can be collapsed (default) and expanded. When collapsed, only the 
name of the item displays. When expanded, additional help information is displayed below the name. To expand screen 
tips, click on the disclosure arrow. When a screen tip is expanded, it remains expanded until it is manually collapsed 
again. Screen tips for all other items are expanded until a tip is collapsed again.

Return (Mac) / Enter 
(Windows)

When a dialog box is open, this is the equivalent to pressing the Done or OK button. In 
a field in the Data bar or Object Info palette, this accepts the information and returns 
the focus to the drawing area. Adds a line of text to a text block.
In the Object Info palette, press Shift+return (Mac) or Shift+Enter (Windows) to save 
the entry and keep the focus in the same field, so that you can enter a different value if 
necessary.

Tab Moves the cursor from one field to the next in the Data bar, Object Info palette, and 
dialog boxes. Press Shift+Tab to move backwards through the fields.

Delete (Mac) / 
Backspace (Windows)

Removes the last segment of or cancels the creation of an object being drawn

Ctrl (Windows) Prevents palettes from docking when they are moved near an edge
Space Bar Engages the Pause/Boomerang mode. Holding down the Space Bar temporarily pauses 

the current tool. A second tool can then be selected and used. Release the Space Bar to 
return to the previous tool.

Command (Mac) / Shift 
(Windows)

Briefly expands the currently selected screen tip

Key Usage
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~~~~~~~~~~~~~~~~~~~~~~~~~
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Context Menus
Click on an object, plug-in object, the drawing area, or a section of the Resource Browser with a right-click (Windows) 
or Ctrl-click (Mac), to display a menu containing context-sensitive commands that pertain to the selected item or items. 
If several similar items are selected, only the applicable context menu commands to all the items in the selection 
become available. Many of these commands can be used to move directly from one editing mode to another, bypassing 
a dialog box. For instance, context menu commands can be used within an edit viewport mode to switch directly from 
editing one viewport component to another, such as from editing a crop to editing annotations.
Document and object context menus can be customized to include frequently-needed commands; see “Modifying 
Context Menus” on page 1839.
Many context menu commands are also available from the menu command lists; however, certain commands are 
available exclusively from a context menu.

Expanded screen tipCollapsed screen tip

Disclosure arrow
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Preferences
Setting Vectorworks Preferences
Vectorworks preferences are options that apply to every file you open, every time you run the program.
To change the Vectorworks preference settings:

1. Select Tools > Options > Vectorworks Preferences.
The Vectorworks Preferences dialog box opens. There are seven preferences tabs (Edit, Display, Session, 3D, 
Autosave, Interactive, and User Folders).

2. Click one of the tabs to set the Vectorworks preferences for that tab.
3. Click OK to save the settings.

Edit Preferences
Click the Edit tab to set preferences that control various edit functions in the program.
Click to show/hide the parameters.

Parameter Description

Click drag drawing Lets you draw objects with the click-drag method rather than the click-click method 
(click-click is the default). Click once with the mouse button and do not release; drag the 
cursor to a desired location and then release. See “Using the Mouse” on page 103.

Eight reshape 
handles 

Shows eight handles (four corner and four center) on most objects; deselect the option to 
display only four corner handles

Offset duplications When you use the Duplicate command, places the duplicate object so that it is offset from 
the original object; deselect the option to place duplicates directly over the original

Auto join walls When you use the Wall tool, automatically joins walls at corners and intersections; when 
walls are separated, their ends automatically heal; when walls have core components, 
components also automatically join (see “Automatically Joining Walls” on page 542)

Separate sheet views Saves the view origin and zoom factor for each sheet layer; deselect the option to use the 
same view for all design layers and sheet layers 

Mouse wheel zooms Sets the default behavior of the mouse wheel and the scroll ball. When selected, the wheel 
zooms by default; when deselected, the wheel scrolls by default. See “Zooming with the 
Mouse Wheel” on page 105 and “Scrolling with the Mouse Wheel” on page 107 for details.

Allow ctrl-click/
option-click in-place 
duplication

When selected, allows a Ctrl-click (Windows) or Option-click (Mac) with the Selection 
tool to create a duplicate copy of a selected object in place. Since it is simple to 
inadvertently create duplicate objects that cannot be easily detected, leaving this option 
deselected is recommended; it is deselected by default. Regardless of the setting made here, 
duplicates can be created with a Ctrl-click/drag or Option-click/drag.

Edit text horizontally 
by default

Always displays the text editing box in a horizontal position, even when the text is rotated 
(see “Creating Rotated Text” on page 385)

2D conversion 
resolution

Sets the number of segments that will be used to represent polylines and circles when you 
draw and edit objects

Default compression Specifies the default image compression to apply to images in a viewport cache and to 
images created by the Render Bitmap tool (Renderworks required). PNG compression 
provides the best image quality but produces larger files, while JPEG creates smaller files, 
but with possible loss of detail. PNG is selected by default.
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Vectorworks Display Preferences
Click the Display tab to set the display preferences. 
Click to show/hide the parameters.

Allow interactive 2D 
symbol scaling

Specifies whether the Selection tool, in Interactive Scaling mode, is allowed to resize 
symbol instances; if allowed, a warning can be displayed to avoid inadvertently scaling 
symbol. If Never is selected, symbols can still be resized from the Object Info palette; see 
“Scaling Symbols from the Object Info Palette” on page 1064.

Arrow Keys Select an arrow and modifier key combination as a shortcut for four common operations; 
each key combination can be assigned to only one operation. Alternatively, disable the 
ability to use arrow key combinations to perform any of these functions.

Switch active 
layer/class

Select the key combination that switches the active layer (up and down arrows) and the 
active class (left and right arrows)

Pan drawing Select the key combination that pans the drawing by half of the area currently in view
Nudge objects Select the key combination that nudges objects by one pixel, and select whether to display 

an alert on the Message bar when nudging items to avoid accidentally moving objects
Move objects Select the key combination that moves objects, and select whether to move objects by the 

snap grid distance or by the specified custom distance

Parameter Description

Rulers Shows the rulers
Show Internal Origin Marker Displays the drawing’s internal origin in Top/Plan view. The marker does not 

print.

Colored axes in Top/Plan view Displays X (red) and Y (green) axes in 2D Top/Plan view
Scroll bars Shows the scroll bars
Black background Uses a black drawing background instead of the default settings
Zoom line thickness Lines in the drawing appear thicker when you zoom in; the screens redraw slower 

on Mac or on Windows if GDI+ imaging is enabled
Create text without fill When you create text objects, dimension objects, and some plug-in objects that 

contain text, the text block has no fill, even if the default attributes are set to add a 
fill to new objects. This prevents objects beneath the text from being obscured.

Show parametric constraints Displays parametric constraints

Parameter Description
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Show other objects while in 
editing modes

When certain complex objects are edited, an Edit window with a colored border 
displays in the drawing area.
When you edit solids, groups, symbols (in the drawing only), or viewports in the 
Edit window, select this option to make the other objects from the drawing visible 
and snappable during editing; deselect the option to show only the object being 
edited. (See “Object Editing Mode” on page 1004 for more information.)
This option does not apply to other types of objects that are edited from the Edit 
window, including extrudes, multiple extrudes, tapered extrudes, sweeps, meshes, 
floors, and roof faces. For symbols, the option applies only when you edit a 
symbol definition by clicking on a symbol instance in a design layer.

Gray other objects If Show other objects while in editing modes is selected, select this option to 
gray the objects in the drawing that are not being edited

Use VectorCaching for faster 
drawing

Caches vector information for complex document entities, such as polylines and 
hatches; while this makes screen redraws faster, it also can potentially increase 
RAM requirements by up to 50 percent 

Center on objects after view 
change

When switching standard views (such as Top or Left Isometric), centers the view 
to display either selected objects, or if nothing is selected, all objects on the layer 
or in the drawing. Centers the view on all objects in a layer if there are no objects 
in view after switching between layers. This helps you feel oriented when 
switching views or changing layers.

GDI+ imaging (Windows only) Draws lines of equal thickness with round end caps; also provides these features:
• fills in 3D planar objects
• variable object opacity
• layer transparency
• anti-aliasing
• object transparency in X-ray Select mode

Disable this option if you need to use OpenType fonts.
Anti-aliasing Blends the edges of fills and lines for a smoother appearance; on Windows, this 

option is available only when GDI+ imaging is enabled
Use Enhanced Navigation 
Graphics 

This preference provides more graphical information as you navigate in your 
drawing (for example, during pan, zoom, flyover, and walkthrough). It also 
provides more on-screen clarity and detail as you navigate between views.

If your hardware cannot support this feature, it can be deselected.
Display light objects Controls the visibility of light objects; hide light objects to reduce screen clutter 

but maintain light effects
Always Light objects are always visible
Only in wireframe Light objects are only visible in Wireframe mode; otherwise, they are hidden
Never Light objects are hidden regardless of the render mode

Display 3D loci Controls the visibility of 3D loci
Always 3D loci are always visible
Only in wireframe 3D loci are only visible in Wireframe mode; otherwise, they are hidden
Never 3D loci are hidden regardless of the render mode

Parameter Description
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Session Preferences
Click the Session tab to set general Vectorworks preferences.
Click to show/hide the parameters.

Edit Font Mappings Specifies the replacement fonts for fonts that are not available. Font mappings can 
be changed or deleted. If mappings are deleted, the Font Mappings dialog box 
appears so that unavailable fonts can be mapped.

Parameter Description

Use sound Supplements the visual SmartCursor cues with audible cues; move the slider bar left 
(to reduce) or right (to increase) the program volume relative to the system volume

Log time in program Records in a log file the time spent in the program, as well as the time spent to open 
and close documents; the date format depends on the language and regional settings in 
the operating system. The log file is called Vectorworks Log.txt, and it is created in 
the User Data and Preferences Folder (which displays on the User Folders tab of 
Vectorworks preferences).

Display minor alerts on 
message bar

Displays minor warnings on the Message bar instead of in a dialog box

Display classes in pop-up 
menus hierarchically

Displays classes hierarchically in pop-up menus including in the Object Info palette, 
the View bar, and dialog boxes throughout Vectorworks.

Hierarchical class display in the Organization dialog box and Navigation palette 
(Vectorworks Design Series required) is controlled separately, on the Classes tab 
of the dialog box/palette.

Run scripts in developer 
mode

For plug-in development, controls the display of warning messages during script 
execution. This is a convenient way for advanced developers to speed up the 
development process. By default, the scripts of scripted plug-in objects, tools, and 
menus are compiled once and stored in memory. The object, tool, or menu command 
memory cache is executed when the script is invoked. However, in developer mode, 
the script is compiled each time so that script changes are executed immediately and 
the developer does not need to restart the application to view changes.
For Python scripts, warning messages are displayed along with Python log data, and 
initialization code (extended properties set in the script options) are called on each 
run. For VectorScripts, plug-ins are compiled on each run and warning messages are 
displayed. Plug-ins may work more slowly when this option is enabled.

Maximum number of 
undos

Sets how many undo operations are kept in memory; the maximum number of undos 
is 100

Issue undo warnings Presents a dialog box when an action that cannot be undone is about to be performed

Parameter Description
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Undo view changes Sets how the program handles view changes when you undo actions
• Never - ignores all operations that are strictly view changes
• Grouping All View Changes - treats all consecutive view changes as one single 

undoable action
• Grouping Similar View Changes - treats similar consecutive view changes as a 

single undoable action
• Individually - treats each individual view change as an undoable action

Enable palette docking 
(Windows)

Lets you dock palettes; deselect the option to disable docks and to undock all active 
palettes

Automatically append file 
extensions (Mac)

Appends the appropriate file extension (.vwx, or .sta for template files) to a newly 
created drawing file on a Mac

Display default content Enables pre-defined content (such as hatches and gradients) to display for selection 
throughout the program

Create a new document on 
startup

Creates a new, untitled file when the program is launched. The new file is based on the 
Default.sta template file (if one exists); otherwise, it is blank.

Change active layer for 
Similar Object Creation 
(Vectorworks Design 
Series required)

When the Create Similar Object command is invoked, changes the active layer to be 
that of the source object. Select this option to create the new object on the same layer 
as the source object. See “Creating Similar Objects” on page 124.

Use local help even when 
an Internet connection is 
available

When you are connected to the Internet, the help system is obtained online. When you 
are not connected, the local version of the help displays. There is not normally a big 
difference between the online and local versions. If bandwidth or connection issues 
cause online help display or searching to become unacceptably slow, select this option 
to always use the local version of the help system. 

Enable Mac OS restore 
windows functionality for 
Vectorworks (Mac)

For Mac OS X 10.7 and later, enables the operating system to automatically restore 
previously open files when re-launching Vectorworks. Keep this option deselected 
when working with several different versions of Vectorworks, to prevent older 
versions from unsuccessfully attempting to open newer version files. This option is 
not available on Windows or versions of the Mac operating system prior to 10.7.

Parameter Description



  54 | Setting Vectorworks Preferences
3D Preferences
Click the 3D tab to set preferences for 3D edits.
Click to show/hide the parameters.

Check for updates Select how often the program should check for available software updates. When the 
specified update check interval has elapsed, an alert dialog box displays if a new 
Service Pack (maintenance release) or major release of the Vectorworks software is 
available. 

If both a Service Pack and major release are available simultaneously, the system 
will send notification about the Service Pack first, followed by notification about 
the major release in the next session.

• Click More Info (or Tell Me More) in the alert dialog box to open a web browser 
to display and download the available update. You must exit the program to 
successfully install the software update.

• If it is not convenient to update the software at this time, click Not Now (or 
Remind Me Later) in the alert dialog box. The alert dialog box will redisplay 
when the specified update check interval has elapsed.

• To disable notifications of a major release until the next major release is available, 
click Not Interested.

If the program is unable to connect to the update server, it attempts to connect once a 
day for seven days after the original failed attempt. If a connection to the update 
server still cannot be established, a dialog box opens to suggest running a manual 
update. If the Check for Updates command is run after the automatic update check 
fails, the next automatic update check occurs the day after the manual check.

Error reporting Optionally sends information about application crashes and other basic usage 
statistics to Nemetschek Vectorworks. Crash details allow our programmers to receive 
crash notifications, including the area of the program where the crash occurred. Usage 
patterns help us see what events led up to a particular crash.This reporting assists us 
with product development while maintaining user privacy; to allay any concerns you 
may have, we never see the data in your drawings, and the reporting has no impact on 
your software operations.

Serial Numbers Opens the Serial Numbers dialog box to add or remove serial numbers for all installed 
Nemetschek Vectorworks products (see “Adding and Removing Serial Numbers” on 
page 21)

Reset Saved Settings Reverts to default settings instead of user-specified settings for tool modes, dialog box 
positions, and dialog box values. For palette positions and settings, reverts to the 
settings established when the workspace was created (in the User Data and 
Preferences folder).
In the dialog box that opens, select whether to reset settings for always performing the 
selected action in alert dialog boxes. Also select whether to reset settings for all tool 
modes, dialog box positions, dialog box values, and palette positions and settings. 
Click OK to return to the Vectorworks Preferences dialog box. 

Palette margins (Mac) Sets whether the document window leaves a space for palettes when the window is 
opened

Parameter Description
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Click here for a video tip about this topic (Internet access required).

Autosave Preferences
Click the Autosave tab to set preferences for automatic file saves and backups.
Click to show/hide the parameters.

Parameter Description

3D Rotation Sets the detail level that displays while the 3D view is rotated. Select Detailed to display 
objects completely, but to rotate slower. Select Responsive to rotate faster, but to display 
objects with less detail during the rotation.

Retain Rendering 
Model

Determines the degree to which the program retains the rendered model in memory during 
3D rotation. Select Never to force the model to always display in Wireframe mode; select 
Always to force the model to remain rendered.

3D conversion 
resolution

Sets the segmentation resolution used to display curved 3D objects; affects extruded and 
swept polylines, circles, and arcs

Render mode when 
changing from 
Top/Plan to a 3D 
View

Sets the preferred 3D render mode to OpenGL or Wireframe; this setting is applied 
whenever a drawing is switched from Top/Plan to a 3D view

Projection when 
changing from 
Top/Plan to a 3D 
View

Sets the preferred 3D projection to Orthogonal, Narrow Perspective, Normal Perspective, 
or Wide Perspective; this setting is applied whenever a drawing is switched from Top/Plan 
to a 3D view

Use occluded 
selection and 
snapping

In rendered views, solid objects “occlude,” or hide, objects behind them. Keep this option 
enabled to more easily select, and snap to, solid objects without interference from hidden 
geometry. To access hidden geometry, use the X-ray Select mode of the Selection tool, turn 
on the clip cube, or switch to Wireframe render mode; see “X-ray Select Mode” on 
page 113.

Parameter Description

Autosave every Enables the Autosave feature; also sets the number of minutes or operations between 
autosaves

Confirm before save Before each save, opens a dialog box so that you can choose either to save or to continue 
to work without a save. The timer/counter resets regardless of which option is selected. 
See “Automatically Saving Files” on page 26.

Occluded selection and snapping enabled Occluded selection and snapping disabled

http://www.youtube.com/watch?v=NFAIeoq_1zI
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Click here for a video tip about this topic (Internet access required).

Interactive Preferences
Click the Interactive tab to set preferences for the display of the interactive drawing features, such as the cursor, 
selection boxes, and selection highlighting. See “Drawing with Snapping” on page 131 for more information about 
snapping. See “Selection and Pre-selection Indicators” on page 114 for more information about highlighting.
Click to show/hide the parameters.

Overwrite original file Writes over the original file with the latest changes during a save
Autosave a backup 
copy to

Automatically saves a backup copy of the file either to a folder named VW Backup (in 
the same folder as the original file) or to a custom location, such as a network drive (click 
Choose to select a folder). The original file is not saved automatically; to save it, use one 
of the save commands on the File menu.
Backup files have unique names that include the word “Backup” and a date and time 
stamp appended to the original file name. Use backup file(s) to restore a project if 
something happens to the original file.

Keep the ___ most 
recent backups

If Autosave a backup copy to is selected, specifies the maximum number of backup 
files to keep; the oldest backup file is replaced when a new backup is made

Parameter Description

Cursor
Full screen cursor Displays a crosshair cursor that extends to the edges of the drawing area
Show selection box Displays a box beneath the cursor that indicates the active selection area; an object 

beneath the box can be selected when the mouse is clicked
Show snap box Displays a box around the cursor that indicates the area in which to find possible snap 

points; when a snap point is beneath the box, it can be snapped to
Show acquisition hints Show graphical hints near the cursor when smart points, edges, and vector locks can be 

acquired (see “Snapping Indicators” on page 144)
Selection box size Controls the size of the selection box, if Show selection box is selected; must be 

smaller than the snap box. The actual size of the selection box is shown. 
Snap box size Controls the size of the snap box, if Show snap box is selected; must be larger than the 

selection box. The actual size of the snap box is shown. 
Highlighting

Selection highlighting When enabled, objects that are selected are highlighted with the specified colors and 
patterns, and square handles indicate points that can be used to reshape objects with the 
tool that is currently active.
When this option is disabled, square handles indicate objects that are selected, and the 
handles may or may not be reshape points.

Parameter Description

https://www.youtube.com/watch?v=l6phlIFFHos&list=UUN7uzhu-ljLJOe6a0J-fBcQ
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User Folders Preferences
You can designate which folder will hold your user data and preferences files. The subfolders within this folder mirror 
several of the standard subfolders in the Vectorworks application folder (Libraries, Plug-Ins, Settings, Workspaces, and 
so on).
This duplication of folders in separate locations makes it easy for users to do the following:

• Back up (or transfer to another computer) custom content and preferences
• Work in an environment where user permissions are limited (such as a school lab)
• Switch between users on the same computer
• Update the Vectorworks software with no loss of custom files

The Vectorworks software provides a variety of content to aid in drawing, but you can also create custom content and 
place it in your user folder (see “Creating Custom Default Content Libraries” on page 219). When the Vectorworks 
program presents content in a palette or dialog box, it includes content from your user folder as well as the content it 
ships with. For example, when you select Modify > Hatch to edit a hatch, the Hatches dialog box shows default 
hatches from the Vectorworks folder (where the software is installed), and your user folder.
If the same file name exists in more than one folder, only the content from one of the files is shown in the Vectorworks 
program, according to the following priority: user folder, application folder. For example, if the following files exist, 
only hatches from the file in the user folder show in the hatch list in the Attributes palette in the Vectorworks program.

• [User]\Libraries\Defaults\Attributes - Hatches\Hatches_Default.vwx

Animation If Selection highlighting is selected, specify how the selection highlights will be 
animated when the cursor moves out of the drawing window or over a palette:
• Off turns off all animation of highlights
• On pulses the highlight continuously
• Burst briefly highlights with 100% opacity

Cursor pre-selection 
highlighting

Highlights any object that can be selected when the cursor is over the object

Highlighting timer When a drawing object is beneath the cursor, specifies the number of seconds to delay 
before pre-selection highlighting begins

Marquee pre-selection 
highlighting

As a selection marquee is drawn over objects, highlights any object that will be 
selected

Snapped object 
highlighting

Highlights the geometry that generated the current snap

Tool highlighting Highlights any object that can be modified or used by the current tool when the cursor 
is over the object

View transition 
animation

Animates the transition from the current view to a new view, providing a smoother 
experience when changing views.

Rendered views may temporarily switch to wireframe view during the transition, 
specifically when switching from sketch to wireframe, dashed hidden line to 
interactive hidden line, and any polygon or Renderworks rendering mode to 
OpenGL

Interactive Appearance 
Settings

Opens a dialog box to change the appearance of the interactive elements in 
Vectorworks, including general elements, object highlighting, SmartCursor elements, 
and snap points; see “Configuring Interactive Display” on page 116

Parameter Description
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• [Vectorworks]\Libraries\Defaults\Attributes - Hatches\Hatches_Default.vwx
If Vectorworks Design Series products are installed, you can also access custom content from shared workgroup 
folders on a network; see “Sharing Custom Content Using Workgroup Folders” on page 216.

Click the User Folders tab to specify the user folder.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Resetting Vectorworks Preferences
Setting Document Preferences
Setting Quick Preferences

User Data and Preferences Folder
The User Data and Preferences folder contains the Vectorworks files that are created and used by you. Within this 
folder, the program automatically creates subfolders for Libraries, Plant Database (Vectorworks Landmark required), 
Plug-Ins, Settings, VWHelp, and Workspaces. The following customizations are automatically saved to the user folder.

• Vectorworks Preferences settings
• Workspace Editor changes
• Log files
• Resource Browser Favorite files
• SmartCursor settings
• Saved export and import options for DXF/DWG files
• Saved settings for the Eyedropper and Select Similar tools
• Settings for certain plug-ins, such as the Stair and Space tools
• Dialog box and palette positions

You can also manually add custom files to the Libraries folder, to have resources such as symbols and hatches display 
as favorites in the Resource Browser, or as default content in dialog boxes and palettes. See “Resource Libraries” on 
page 219 for more information.
The program defaults the following locations for the user data folder, but they can be changed. Note that, by default, 
Windows hides the application data folder; if you want to use the default location, adjust the folder options in Microsoft 

Parameter Description

User Data and Preferences 
Folder

Specifies the folder that contains program preferences, log files, workspaces, 
and any personal content you create. This might be a folder on the local 
computer, or on a USB drive or network drive; this allows you to run 
Vectorworks from any computer. See “User Data and Preferences Folder” on 
page 58.

Choose Click Choose to change the user data folder. The program must be restarted if 
you change the location of the user data. See “User Data and Preferences 
Folder” on page 58 for details.

Explore (Windows) or Reveal 
in Finder (Mac)

To look at the contents of the current folder, click Explore (to open Windows 
Explorer) or click Reveal in Finder (to open Mac Finder)

Workgroup and Project Folders
(Vectorworks Design Series 
required)

Permits access to content for the Vectorworks program from a location that is 
shared with other users. To share customizations with other users, place the files 
in a network folder, and then notify other users so they can designate that folder 
as a workgroup folder. See “Sharing Custom Content Using Workgroup 
Folders” on page 216 for details.
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Explorer to make hidden folders visible. Because the user folder is outside of the Vectorworks installation folder, your 
data and preferences remain undisturbed when the Vectorworks program is updated.

To easily access the user folder, use the file list in the Resource Browser. See “Accessing Existing Resources” on 
page 229 for more information.

To change the user data folder:
1. From the User Folders tab, click Choose.
2. A confirmation dialog box displays. Click Yes to continue with the folder change.
3. Select a folder from the dialog box that opens, and click OK (Windows) or Choose (Mac).
4. Another confirmation dialog box displays. Click Yes to copy the user data to the new location, or click No to use 

the Vectorworks defaults.
5. If you copy the data to the new location, and the destination folder already contains a file with the same name as a 

file in the source folder, the program displays a notice that files in the destination folder will be overridden. Click 
Yes to continue.

6. If any unsaved files are currently open, you are prompted to save them. Click Yes to continue.
7. The program copies the files to the new location and then closes automatically.
8. Restart the program.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Vectorworks Preferences

Resetting Vectorworks Preferences
Click the Reset button at the bottom of the Vectorworks Preferences dialog box to reset the preferences to their 
defaults; this also clears the most recently opened files list and the font mapping table. Serial number(s), user name, 
and company name are left intact. This operation cannot be undone.

• Mac: /Users/<Username>/Library/Application Support/Vectorworks/2015/

• Windows XP: C:\Documents and Settings\<Username>\Application Data\Nemetschek\Vectorworks\2015\

• Windows 
Vista/7/8: 

C:\Users\<Username>\AppData\Roaming\Nemetschek\Vectorworks\2015\

Click to open the file list

Select User Libraries to 
access your user folder

Accessing the user folder from the Resource Browser
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Setting Document Preferences
Document preferences apply only to the current drawing, and they remain in effect until they are changed. When you 
create a template, the current document preferences are saved with the template (see “Cutting Sections” on page 1855).
To change the preference settings in the document:

1. Select File > Document Settings > Document Preferences.
Alternatively, right-click (Windows) or Ctrl-click (Mac) in the drawing area, and select Document Preferences 
from the document context menu.
The Document Preferences dialog box opens, with the following tabs: Display, Dimensions, Resolution, Plane 
Mode, and Plan Shadows (Vectorworks Architect or Landmark required for Plan Shadows).

2. Click one of the tabs to set the document preferences for that tab.

Document Display Preferences
Click the Display tab to set the display preferences.
Click to show/hide the parameters.

Parameter Description

Black and white only Draws objects using only the colors black and white (black items display as black, and 
all colors—including gray—display as white); this choice overrides any other color 
settings (including viewport settings) and is used mainly for printing on black and white 
printers.

To create a “grayscale” effect for prints and PDFs when this feature is enabled, use 
pattern fills instead of solid color fills. Set the pattern foreground color to black, 
and set the background color to any other color. Patterns 4 through 9 in the pattern 
fill selection box display as various shades of gray.

Hide details when layer 
scale < = 1:

Select to hide wall components and stair details when the layer is set to, or is below, the 
scale ratio specified (this setting does not affect wall component display in viewports; 
see “Advanced Sheet Layer Viewport Properties” on page 1642 to show or hide 
components in viewports)

Save viewport cache Indicates whether to save viewport caches in the file; saving the cache may increase file 
size, but saves time when files that contain viewports are opened. If deselected, any 
viewports will require updating when the file is opened, but file size is reduced. Note 
that the viewport cache(s) are already compressed to PNG or JPEG format to save space 
(the format depends on the selection in Vectorworks preferences; see “Edit Preferences” 
on page 49 for more information).

These six patterns
display as grays in

prints and PDFs
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Click here for a video tip on this topic (Internet access required).

Dimension Preferences
Click the Dimensions tab to set the dimension preferences.
Click to show/hide the parameters.

Display viewport 
out-of-date border

Choose whether to display a red and white striped border around sheet layer viewports 
and design layer section viewports that do not reflect the most recent changes to a 
drawing. Regardless of this selection, the Update button’s text displays in red on the 
Object Info palette when the viewport needs to be updated (see “Viewport Status” on 
page 1664).

Save site model cache
(Vectorworks Architect 
or Landmark required)

Stores a filtered copy of the triangulated source data and the existing and proposed site 
model(s), so that the site model updates more efficiently. If disabled, updating the site 
model causes the source data to be recalculated, but file size is reduced.

Use layer colors When specific pen and fill colors have been set for a design layer, draws all objects on 
that layer with the specified colors (see “Setting the Design Layer Color” on page 170)

Mesh smoothing with 
crease angle

Select to smooth mesh objects rendered with OpenGL or Renderworks; enter a higher 
crease angle value for a smoother surface (valid values are 0 to 180)

To activate mesh smoothing only for selected mesh objects, see “Applying a 
Texture to an Object” on page 1530.

Use automatic drawing 
coordination 
(Vectorworks Design 
Series required)

Automatically coordinates and updates sheet numbers and drawing numbers among 
sheet borders, drawing labels, and section markers

Adjust flipped text Re-orients mirrored, rotated, and flipped text in symbols, plug-in objects, and text 
objects so that the text is always readable

Cropped Perspective Toggles the rectangular frame around perspective views on and off, switching between a 
cropped perspective view for presentation and an uncropped perspective view for 
modeling; see “Cropped and Uncropped Perspective Views” on page 1144

Parameter Description

Associate dimensions Associates dimensions with the applicable objects. When a dimension is associated with an 
object, the dimension automatically updates when the object it is applied to is modified. For 
more information about associative dimensioning, see “Associative Dimensioning” on 
page 1191.

Auto associate Select this option to automatically associate a dimension to the top-most object when more 
than one object shares a dimension endpoint

Create dimensions in 
dimension class

Assigns dimensions to the Dimension class as they are created (default setting). If 
deselected, created dimensions are assigned to the active class.

Parameter Description

http://www.youtube.com/watch?v=byCueHC1p2A
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Default dimension standards are presented in the following table.

Click here for a video tip on this topic (Internet access required).

Resolution Preferences
Click the Resolution tab to set the resolution preferences.
Click to show/hide the parameters.

Dimension Standard Select the default Dimension Standard to use, or click Custom to add a custom dimension 
standard (see “Using Custom Dimension Standards” on page 1187).
Changing the dimension standard does not affect dimensions that have already been placed 
on the drawing. 

Dimension Slash Sets the desired Thickness of the slash at each end of a dimension, in points, mils, or 
millimeters

Standard Description Text Placement Marker Style Text Rotation

Above 
Dim. Line

Within 
Dim. Line

Slash Arrow Aligned Horiz.

Arch Architectural Standards X X X
ASME American Society of Mechanical 

Engineers
X X X

BSI British Standards Institute X X X
DIN German Standards X X X
ISO International Standards Organization X X X
JIS Japanese Industrial Standards X X X
SIA Swiss Standards X X X
ASME Dual 
Side By Side

American Society of Mechanical 
Engineers

X X X

ASME Dual 
Stacked

American Society of Mechanical 
Engineers

X X X

Parameter Description

Rotated Text Display Sets how rotated text is displayed: Highest quality shows rotated text at the best quality 
available, Normal quality shows rotated text slightly jagged, and Bounding box shows 
only a bounding box representing the text’s location

Bitmap Display Sets how bitmaps are displayed: Full resolution shows bitmaps at the best resolution 
available, Reduced resolution shows bitmaps at a reduced detail, and Bounding box 
shows only a bounding box representing the bitmap’s location. Reduce the resolution to 
save time when using the Pan tool or scroll bars.

Output

Parameter Description

http://www.youtube.com/watch?v=9V6bRyWhArI
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Click here for a video tip on this topic (Internet access required).

Plane Mode Preferences
Click the Plane Mode tab to set the plane mode preference, depending on how you prefer to work and what you are 
drawing. Planar tools, such as the Rectangle tool, normally can operate in either the screen plane or in the current 
working plane, which is usually the layer plane. With this preference setting, planar tools can be set to operate in the 
screen plane only, active 3D working plane only, or any available plane, depending on the option selected. This setting 
does not affect tools that require an active working plane, such as the NURBS Curve tool, tools like the Split tool that 
always operate in the screen plane, or tools that are not affected by the planar choice, such as the Eyedropper tool. See 
“Vectorworks Modeling Environment” on page 152 for a discussion of how planes function in the Vectorworks 
software.
The plane mode preference does not affect the Object Info palette planes list.
Click to show/hide the parameters.

Plan Shadows Preferences
In the Vectorworks Architect and Landmark products, click the Plan Shadows tab to set the shadow style preferences 
for plants and massing models. These preferences apply in Top/Plan view for plants that are set to use the document 
preference shadow settings (available only in Vectorworks Landmark; see “Plant Definition: Render Pane” on 
page 789) and for massing models set to display shadows (see “Creating a Massing Model” on page 718).
Click to show/hide the parameters.

Design layer raster 
rendering DPI

Sets the resolution for renderings when the Print command is used.
This setting controls only the design layer Open GL and Renderworks (if installed) 
rendering resolution for print; it significantly affects the output file size. Any PICT/PDF 
rasterization and Vectorworks geometry will print at the resolution of the printer. For 
bitmaps and rendered viewports, each sheet layer’s DPI setting determines the upper limit 
for print resolution. See “Setting the Print Resolution” on page 1765 for more 
information.

Parameter Description

Screen Plane Only Planar tools operate on the screen plane only; all created 2D objects are set to the screen 
plane. When a planar tool is active, only the screen plane can be selected from the Active 
Planes list on the View bar (see “The Active Planes List” on page 1168).

Working Plane Only Planar tools operate on the active 3D plane, which is usually the layer plane. All created 
2D objects are set to the active 3D plane, and when a planar tool is active, the screen plane 
cannot be selected from the Active Planes list on the View bar.

Screen Plane or 
Working Plane

When a planar tool is active, either screen plane or any of the available 3D planes can be 
selected from the Active Planes list on the View bar

Parameter Description

Shadow Settings
Offset Enter a value for the shadow offset

Parameter Description

http://www.youtube.com/watch?v=riiuxi467-c
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Setting Vectorworks Preferences
Setting Quick Preferences

Setting Quick Preferences
The most commonly used Vectorworks, document, and interactive preferences are available for access from buttons on 
the Tool bar. Other commonly used settings, such as those for the clip cube, are similarly available. The Quick 
Preferences menu controls which buttons display on the Tool bar. The Data Bar and Edit Group Options list and the 
Zoom Line Thickness preference are enabled by default on the Quick Preferences menu.
Select the desired item to display its shortcut button on the Tool bar, if it is not already present. A check mark to the left 
of an item indicates that it is selected. Buttons display in the order the item was selected, so the first selected item 
displays the furthest left on the Tool bar. If the application window is resized, the Tool bar will truncate the display of 
buttons when necessary and replace them with ellipses on the right.

Offset Units Select the shadow offset units.
Factor of Object Height calculates the offset based on the object’s height and the 
offset value.

Angle Set the shadow angle by entering a value between -180° to 180° or by using the slider.
0° is straight up.

Fill Style Select a fill style for the shadow
Color/Resource/Class Depending on the fill style selected, select a fill color, resource (hatch, image, gradient, 

tile), or class for the shadow (see “Applying Object Attributes” on page 1093)
Opacity Set the shadow opacity by entering a value between 0 and 100% or by using the slider
Use Class Opacity Select to use the object’s class opacity setting (see “Setting Class Properties” on 

page 179)
Top/Plan Preview Provides a dynamic representation of the shadow values selected

Parameter Description
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Menu Commands Description of Button Functionality

Auto Join Walls Displays the Auto Join Walls preference button (see “Edit Preferences” on page 49)

Autosave Displays the Autosave preference button (see “Autosave Preferences” on page 55)

Black and White Only Displays the Black and White Only preference button (see “Document Display 
Preferences” on page 60)

Black Background Displays the Black Background preference button (see “Vectorworks Display 
Preferences” on page 50)

Data Bar and Edit Group 
Options

Displays the Data Bar and Edit Group Options list (see “Data Bar and Edit Group 
Options” on page 127)

Display Light Objects Displays the Display Light Objects list, to specify whether lights are visible always, 
never, or only in Wireframe mode (see “Vectorworks Display Preferences” on page 50). 
The displayed icon matches the currently selected option.

Quick Preferences menu
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Setting Vectorworks Preferences
Setting Document Preferences

Display Viewport 
Out-of-date Borders

Displays the Display Viewport Out-of-date Borders preference button (see “Document 
Display Preferences” on page 60)

Hide Details Displays the Hide Details preference button (see “Document Display Preferences” on 
page 60)

Show Acquisition Hints Displays the Show Acquisition Hints preference button (see “Interactive Preferences” 
on page 56)

Show Clip Cube Displays the Show Clip Cube button (see “Viewing a Model with the Clip Cube” on 
page 1155)

Show Grid Displays the Show Grid preference button (see “Grid Snapping” on page 133)

Show Other Objects 
While in Edit Modes

Displays the Show Other Objects While in Edit Modes preference button (see 
“Vectorworks Display Preferences” on page 50)

Show Page Boundary Displays the Show Page Boundary preference button (see “Page Setup” on page 1761)

Show Rulers Displays the Show Rulers preference button (see “Vectorworks Display Preferences” on 
page 50)

Use Layer Colors Displays the Use Layer Colors preference button (see “Document Display Preferences” 
on page 60)

Zoom Line Thickness Displays the Zoom Line Thickness preference button (see “Vectorworks Display 
Preferences” on page 50)

Document Preferences Opens the Document Preferences dialog box (see “Setting Document Preferences” on 
page 60)

Vectorworks Preferences Opens the Vectorworks Preferences dialog box (see “Setting Vectorworks Preferences” 
on page 49)

Menu Commands Description of Button Functionality
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Setting up the Drawing
Before beginning a new drawing, determine drawing properties like scale, units, interactive displays, color palettes, 
line thickness, and dimension standards. See “Palette Layout Options” on page 40 to set the preferred window options 
prior to setting up the drawing.
The combination of layers, classes, and views can produce a variety of drawings generated from a single file (see 
“Drawing Structure” on page 155). Proper file setup ensures maximum usability for multiple output.
The three required drawing settings are layer scale, units, and drawing size. Once these are established, optional 
drawing settings can be found in document preferences, scripts, snap and reference grids, layers and classes, and other 
defaults; although making these settings is not required, it is recommended.
Setting up the layers and classes while setting up the drawing is recommended. See “Layers” on page 161 and 
“Classes” on page 176 for more detailed information about creating layers and classes.
When using templates, many of these settings will have already been specified.
~~~~~~~~~~~~~~~~~~~~~~~~~
Design Layer Scale
Units
The Print Area
Page Setup
Guides
Internal Origin and User Origin
Configuring Interactive Display
Setting Default Object Attributes

Design Layer Scale
Layer scale is the ratio of the actual size of an object to its size in a drawing. Layer scale exists to allow graphic 
properties of the drawing or model to be represented properly, as though you were drawing at a particular scale on a 
piece of paper. For example, for the default layer scale of 1:1, every inch in the drawing represents an inch in the “real 
world.” The scaling value allows the proper representation of attributes such as line thickness, line type, marker size, 
text size, and hatches.
In “What You See Is What You Get” (WYSIWYG) drawing, an intended output scale is needed to properly display 
these attributes; this allows you to see how the drawing will look at that intended format. For practical use, set the layer 
scale to be the same as that of the predominant output scale of the project. This will necessitate the least amount of 
attribute scaling in viewports.
Vectorworks can set one scale for all design layers in a drawing, or set a different scale for individual design layers.

Changing the Scale of the Drawing or the Active Design Layer

To change the scale of the active design layer or of the entire drawing:

1. Right-click (Windows) or Ctrl-click (Mac) in the drawing area to access the document context menu, and then 
select Active Layer Scale. Alternatively, if the layer scale is displayed on the View bar, click the Layer Scale 
button.
The Layer Scale dialog box opens.

2. Either select a scale, or enter a custom value in Paper Scale.
3. To simultaneously change the scale of all existing design layers in the entire drawing, select All Layers.
4. To scale text proportionally to the rest of the design layer, select Scale Text. Deselect Scale Text to keep the text 

at its current size even if the scale changes.



  68 | Setting up the Drawing
5. Click OK to return to the drawing.

Changing the Scale of Selected Design Layers
To change the scale of one or more selected design layers:

1. Select Tools > Organization.
The Organization dialog box opens. Click on the Design Layers tab.

2. Select the layer(s) to change from the Design Layer list and click Edit (or double-click a single layer name).
The Edit Design Layers dialog box opens (see “Setting Design Layer Properties” on page 165).

3. Click Scale.
The Layer Scale dialog box opens.

4. Either select one of the scales, or enter a custom value in Paper Scale.
5. To scale text proportionally to the rest of the design layer, select Scale Text. Deselect Scale Text to keep the text 

at its current size even if the scale changes.
6. Make sure that All Layers is not selected.
7. Click OK.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Design Layer Properties
Units

Units
The Vectorworks program provides a wide range of measurement systems to select from and also provides the 
flexibility to create a customized measurement system. The selected measurement system is applied globally 
throughout the drawing, from the measurements that display on the rulers to those used in dimensions and worksheets.
The Units command opens the Units dialog box, which organizes units settings on two tabbed panes:

• The General Display and Dimensions tab settings affect the units throughout the drawing and the rounding 
settings for primary dimensions.

• The Dual Dimensions tab contains many of the same parameters found on the General Display and Dimensions 
tab, but its settings apply only to secondary dimensions. If dual dimensions are not being used, these settings have 
no effect. For more information on dual dimensioning, see “Dual Dimensioning” on page 1200.

Selecting a Unit System
To select or change the current measurement system:

1. Select File > Document Settings > Units.
The Units dialog box opens.

2. Specify the units display parameters, and then click OK.
Click to show/hide the parameters.
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Parameter Description

Length
Units Select the desired length measurement system from the list.

If this setting is changed from one metric unit to a different metric unit, the 
Decimal precision and Dimension object precision values are automatically 
scaled by the same ratio, to maintain the same inherent precision the document 
had before. If the setting is changed from a non-metric unit to a metric unit, the 
precision values are automatically set to new default values suitable for the 
selected metric unit.

Custom If the Custom unit is selected, click Custom to create a custom length measurement 
system; see “Creating a Custom Unit System” on page 70

Show Unit Mark Select to display the unit mark along with the unit value; if the Feet & Inches unit is 
selected, Vectorworks automatically displays unit marks and therefore, Show Unit 
Mark is unavailable

Show Thousands 
Separators in Dimension 
Text

Select to display a thousands separator in the values of dimension objects; the 
separator used (a period or comma) depends on the current regional setting in the 
operating system

Separators are for display only; they are not used in the Object Info palette, or in 
the dimension text as it is being edited

Rounding Style Rounding only affects how numbers are displayed; if the number 1.23456 is entered 
with a rounding of .00, the value is recognized as 1.23456 but displays as 1.23

Fractional Select for fractional rounding
Decimal Select for decimal rounding
Exact as Fractions / 
Non-Exact as Decimals

Select for a combination of fractional and decimal rounding

Fractional Display for 
Dimensions

If a fractional Rounding Style was selected, select a style for the fractions that appear 
in dimensions:
• Standard: 
• Diagonally stacked: 
• Vertically stacked: 

Rounding Precision
Fraction precision If a fractional or combination Rounding Style was selected, select the fractional 

precision value, up to 1/64
Decimal precision If a decimal or combination Rounding Style was selected, select up to ten digits of 

decimal precision
Dimension object 
precision

Select a precision value for dimension objects; to link the dimension value to the 
fraction or decimal precision value, click the link button to the right of the precision 
fields: 

Decimal rounding base Select whether decimal rounding is performed using multiples of tenths, quarters, or 
halves; the option selected is reflected in the Decimal precision field



  70 | Setting up the Drawing
Creating a Custom Unit System
To create a customized measurement system:

1. Select File > Document Settings > Units.
The Units dialog box opens.

2. Select Custom from the length, area, or volume Units list, or if editing an existing custom measurement system, 
select the custom name from the Units list.

3. Click Custom.
The Custom Units:Length, Custom Units:Area, or Custom Units:Volume dialog box opens, depending on the type 
of custom unit being created or edited. The available values in each field vary based on the custom unit type.

Click to show/hide the parameters.

Dimension rounding 
base

Select whether dimension rounding is performed using multiples of tenths, quarters, 
or halves; to link the dimension value to the decimal base value, click the link button 
to the right of the rounding base fields: 

Decimal Options
Leading Zero If one of the decimal rounding options is chosen, select to display a leading zero
Trailing Zeros If one of the decimal rounding options is chosen, select to display trailing zero(s)
Area / Volume / Angle
Units Select the area, volume, and angular measurement system from the list.

If this setting is changed from one metric unit to a different metric unit, the 
Precision value is automatically scaled by the same ratio, to maintain the same 
inherent precision the document had before. If the setting is changed from a 
non-metric unit to a metric unit, the precision value is automatically set to a new 
default value suitable for the selected metric unit.

Custom If the Custom area or volume unit is selected, click Custom to create a custom area or 
volume measurement system; see “Creating a Custom Unit System” on page 70

Precision For area and volume measurement systems, select up to ten digits of decimal 
precision. For angular measurement systems, select to display angular units in degrees 
(there are 360 degrees in a circle, and the angle mark is °), radians (there are 2pi 
radians in a circle, and the angle mark is r), or gradians (there are 400 gradians in a 
circle, and the angle mark is g); also, select up to eight digits of angular precision or 
specify degrees, minutes, and/or seconds.

Parameter Description

Unit Name Name given to the custom measurement system—for example, “Cubit”
Unit Mark Mark (abbreviation) used to represent a unit in the custom measurement system—for 

example, “cbt”
Smaller from Larger Set the number of custom units that occur per selected unit—for example, “There Are 2 

Units Per Inch”

Parameter Description
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4. Click OK to exit the Custom Units dialog box.
5. Enter the remaining criteria as described in “Units” on page 68.
6. Click OK.

Snap and Reference Grids
There are two separate grid systems for precise drawing: the snap grid and the reference grid.

The Snap Grid assists with drawing and placing objects precisely. The snap grid appears as small dots when zoomed 
in, depending on the snap grid dimensions. The snap grid is used in combination with the Snap to Grid snapping 
option on the Snapping palette. As the mouse moves across the screen, it automatically “catches” at each increment on 
the snap grid. When you are placing or drawing an object, it snaps to the grid.
With shortcut keys, objects can be moved constrained to the snap grid. See “Edit Preferences” on page 49 for more 
information.
The Reference Grid normally displays on the screen (depending on the zoom factor and grid dimensions), and can be 
printed. The most useful way to set the reference grid is so that it is an extension of the set scale.
Depending on the drawing, the snap and reference grids can have identical or different dimensions. For example, if you 
are designing kitchen cabinets with a tolerance of one-sixteenth of an inch, set the snap grid to 1/16”. It would be hard 
to draw on a screen that displayed 16 horizontal and vertical lines squeezed within every inch. For that reason, you 
might want to mark off only whole inches on the screen by setting the reference grid to 1”.
At file setup, establish the snap and reference grid settings based on the drawing scale. See “Grid Snapping” on 
page 133. The color of the reference grid can be changed; see “Configuring Interactive Display” on page 116.
~~~~~~~~~~~~~~~~~~~~~~~~~
Grid Snapping
Configuring Interactive Display

Guides
The Make Guide command enables the placement of guidelines which can be used to visually align objects in the 
drawing. Guides can be any shape and size. In addition to providing visual clues, guides work with the SmartCursor to 
ensure precise alignment. Guide objects are locked into a class called “Guides” and are colored light purple. Guides are 
printed unless the Hide Guides command is selected, or the Delete All Guides command has permanently removed 
them.
To create a guide:

1. Create the object to become a guide.

Larger from Smaller Set the number of selected units that occur per custom unit—for example, “There Are 2 
Inches Per Unit”

Parameter Description

Snap 
Grid

Reference 
Grid
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2. Select the object.
3. Select Modify > Guides > Make Guide.

The object changes into a guide and is placed in a Guides class.
The following commands can be selected from the Modify > Guides menu.

You can snap objects to the guide(s) closest to it by using Snap to Object from the Snapping palette. The distance 
at which the objects snap to the guides is determined by the Snap box size setting in the Vectorworks preferences. 
See “Interactive Preferences” on page 56 for details on setting the snap radius setting.

To delete a single guide, highlight it and then select Modify > Unlock. The guide is now editable. Select Edit > Clear 
to remove it from the drawing. A guide can also be unlocked in order to move it to a new location. Select Modify > 
Lock to lock the guide into place once it is relocated.

Internal Origin and User Origin
The center of a Vectorworks drawing has fixed coordinates of (0,0); this location is called the internal origin. A user 
origin also exists. Drawing coordinates display relative to the user origin. Normally, the internal origin, the user origin, 
and the page center are all coincident. While the internal origin cannot move, the user origin and page center can be 
moved.
Depending on the design needs, and for some imported files (to maintain the imported file’s coordinates), the user 
origin needs to shift so that the user origin location is different from the internal origin. One reason to change the origin 
is to make it easier to work with coordinates, measurements, and distance values. For example, the Swiss use a 
reference point system for architectural measurements, where everything is in relation to a point in Europe. When a 
building is located at a site, that site is referenced to be a certain distance and direction from this point. Using this 
system creates large numbers on the ruler and in the Object Info palette. In the User Origin dialog box, you can shift the 
user origin close to the building site so that the system does not display large coordinates.

Changing the user origin can have far-reaching consequences. Use caution when changing the user origin.
Several commands related to the user origin and the internal origin are available in the Vectorworks program.
~~~~~~~~~~~~~~~~~~~~~~~~~
Locating the Internal Origin
Centering the Drawing on the Internal Origin
Setting the User Origin

Locating the Internal Origin
In some drawings, objects may be located several kilometers or miles away from each other and/or from the drawing’s 
internal origin. For reference, it is easy to change the view to locate the internal origin with the Locate Internal Origin 
command.
To locate the internal origin relative to visible objects:

1. Select Tools > Origin > Locate Internal Origin.

Option Description

Make Guides The object becomes a guide
Select Guides Selects all the guides in a drawing
Show Guides Displays guides which were hidden
Hide Guides Temporarily hides the guides in the drawing 
Delete all Guides Permanently removes all guides and the objects used to create them
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2. The drawing view changes; it switches to Top/Plan view if needed, and centers the internal origin in the view. The 
zoom factor is adjusted so that currently visible objects remain on the screen relative to the internal origin. If the 
internal origin marker was not set to display in the Vectorworks preferences, it is automatically turned on.
If the objects are too far away from the internal origin, use Center Drawing on Internal Origin to resolve the 
problem.

~~~~~~~~~~~~~~~~~~~~~~~~~
Centering the Drawing on the Internal Origin
Setting the User Origin
Internal Origin and User Origin

Centering the Drawing on the Internal Origin
When a drawing contains objects that are located far away from the internal origin, this can cause problems with 
OpenGL rendering and with calculation precision due to rounding errors. By centering the objects about the internal 
origin, the problems are resolved because the distance from the internal origin to the objects has been reduced. The 
centering operation adjusts the user origin so that the coordinates of any objects in the drawing remain unchanged.

This command moves objects in the drawing, even though the coordinates do not appear to change. The user 
origin changes as a result of the command to keep the coordinates unchanged.

To center the drawing on the internal origin:
1. Select Tools > Origin > Center Drawing on Internal Origin.
2. An alert displays, explaining how far away the most distant object is located from the internal origin (in document 

units) before the centering operation, and showing where it will be located after the operation. Click Yes to 
continue.

3. The entire drawing is centered about the internal origin, moving all objects on all design layers, including locked 
objects and non-visible objects. Any sheet layer viewports and saved views are automatically adjusted. Because 
the user origin is also adjusted, the coordinates of the file remain intact.

While working on a drawing, it becomes necessary to 
know where the internal origin is located

The Locate Internal Origin command zooms out and centers 
the view on the internal origin, which displays as a marker. It 
becomes clear that the objects are located far away from the 
internal origin.
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~~~~~~~~~~~~~~~~~~~~~~~~~
Locating the Internal Origin
Setting the User Origin
Internal Origin and User Origin

Setting the User Origin
The User Origin command and the User Origin button can be used to change the location of the user origin in the 
drawing area. Normally, the user origin is located coincident with the internal origin, where the X and Y axes meet 
(0,0). Depending on design needs, the user origin may need to shift relative to the internal origin. The drawing 
coordinates display relative to the user origin.
All design layers have the same user origin, but each sheet layer has its own user origin.
When the user origin is different from the internal origin, the User Origin button displays in yellow.

To set the location of the user origin:
1. To set the user origin for a specific sheet layer, activate the sheet layer first; for design layers, switch the active 

design layer to Top/Plan view if not in 2D view.
2. Select Tools > Origin > User Origin. The User Origin dialog box opens.

Alternatively, click the User Origin button once to set the user origin by the next mouse click, if this functionality 
has not been disabled in the User Origin dialog box. Double-click the User Origin button to open the User Origin 
dialog box.

Click to show/hide the parameters.

Objects in the drawing are located too far away from the 
internal origin

The Center Drawing on Internal Origin command centers the 
objects in the drawing about the internal origin. Object 
coordinates remain intact.

User Origin

The user origin and the internal origin 
are coincident

The user origin has been set to a location that is 
different from (0, 0)
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3. Click OK.
If setting the user origin by mouse click, click to set the location of the user origin (Set User Origin to next 
mouse click) or to set the location of the offset user origin (Next mouse click is).
The user origin moves to its new location. Coordinates are adjusted relative to the user origin. If a working plane 
is in use, the working plane coordinates are set to be relative to the user origin.

~~~~~~~~~~~~~~~~~~~~~~~~~
Locating the Internal Origin
Centering the Drawing on the Internal Origin
Internal Origin and User Origin

Setting Default Object Attributes
The default attributes for a document are the attributes that are automatically applied to each new object when it is 
created. To set the default attributes, simply adjust the Attributes palette settings with no objects selected.
When you first open a new document, set the default attributes to those you use most often. For example, you might 
adjust the fill and line colors, and line thickness. The available attributes can be customized as needed.
The default attributes apply to the current document only. To save a set of default attributes or custom attributes for 
future use, set the attributes as desired and save the document as a template.
~~~~~~~~~~~~~~~~~~~~~~~~~
The Attributes Palette
Creating Templates

Creating Templates
Save a drawing file as a template to use it as a foundation for new files. Templates save layers, classes, title blocks, 
sheet borders, resources, and the current settings for attributes and units. (See “Creating a New File” on page 22 for 
details about using a template.)

Parameter Description

Set User Origin to next mouse 
click 

Changes the cursor to a bull’s-eye cursor; click to set the user origin to any point 
within the drawing area

Set User Origin to Internal 
Origin

Sets the user origin to the internal origin, making them both coincident at (0,0)

Set User Origin (relative to 
the Internal Origin) to

Enter the specific coordinates of the user origin relative to the internal origin.
The last non-zero values of the user origin are saved; the values remain in the 
dialog box to be easily reselected. In this way, you can toggle between setting 
the user origin to a specific location and setting it to (0,0).

Next mouse click is Sets the user origin relative to the coordinates of the next point clicked by the 
mouse. 
Sets the clicked point to specific coordinates. After selecting this option, enter the 
X and Y coordinates of the point. The user origin is set relative to the values 
entered.

Disable dragging for the Set 
User Origin button 

Disables the User Origin button, so that clicking on it once does not activate the 
ability to set the user origin to the next mouse click. Double-clicking the button 
still opens the User Origin dialog box.
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When a template is opened, the Vectorworks program automatically opens a copy of the file. When the new drawing is 
saved the first time, the program prompts for a new file name. This makes it impossible to accidentally replace the 
master template with the new drawing file.
To create a template:

1. Start with a new, empty file.
2. Set up the file with all of the desired elements.
3. Select File > Save As Template.
4. Enter the name of the template (.sta) file and place it in an appropriate Templates folder. (See “User Folders 

Preferences” on page 57 for details about how to specify the folder for your user data.)
• To save the template for personal use, place it in the Templates subfolder in your user data folder: 

[User]\Libraries\Defaults\Templates.
• If Vectorworks Design Series products are installed, you can share the template with other users in a 

workgroup. To do so, place it in the Templates subfolder of a workgroup folder on a network drive; other users 
can then specify that workgroup folder in their Vectorworks preferences: 
[Workgroup]\Libraries\Defaults\Templates.

The .sta extension is required for Windows. It is recommended for use on the Mac if the file will be shared with 
Windows users.

5. Click Save.
The program launches with a blank drawing file, in 1:1 scale. To launch the program with a file containing different 
settings, name the template file Default.sta and save it in the Templates subfolder in your user data folder: 
[User]\Libraries\Defaults\Templates.
~~~~~~~~~~~~~~~~~~~~~~~~~
Saving a File

Document Setup
Use the Document Setup command to set up a file’s basic characteristics (units, scale, drawing area, and grid) as well 
as define the sheet border and title block settings.
To set up a file with the Document Setup command:

1. Select File > Document Settings > Document Setup. 
2. The Document Setup dialog box opens. Set the parameters for the drawing. See “Setting up the Drawing” on 

page 67 for more information on units, scale, drawing grids, and print area. 
Click to show/hide the parameters.

Parameter Description

Units, Scale and Grids
Drawing Units Click Change to open the Units dialog box; specify the global unit settings for the 

project
Layer Scale Click Change to open the Layer Scale dialog box. Specify the default layer scale for the 

project. This scale will be used for all floor design layers (Mod-Floor-#) and associated 
design layers such as Mod-Slab.

Drawing Area Click Change to open the Page Setup dialog box; specify the drawing’s printable area
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3. Click OK.
To use the Issue Manager (see “The Issue Manager” on page 90), select one of the predefined sheet border styles.
Select the Document Setup command again to re-adjust a sheet border if the paper size has changed.

Adding a Sheet Border
All Vectorworks products include pre-formatted sheet borders for project viewports or views; they can be added to a 
file in various ways.
The Sheet Border tool places a pre-formatted border along the edges of the drawing area, set to the drawing size. 
Standard size pages have a matching standard sheet border. A custom size border can easily be specified, and sheet 
borders and title blocks can be customized to meet office requirements.
The sheet border in the Vectorworks Design Series products has expanded capabilities. Additional default content and 
parameters are available only in the Vectorworks Design Series products. Various types of sheet borders can be created, 
including ConDoc, GSA, AEC, ASME, and ISO formats and their associated title blocks, revision blocks, tolerance 
blocks, projection blocks, and issue and revision data.
To work with the Issue Manager, special considerations apply when the title block fields are formatted. See “Creating a 
Custom Title Block” on page 86.

The Update Plug-in Objects command may need to be run on files that contain sheet borders (formerly known as 
“drawing borders”) that were created in an earlier version of the Vectorworks program. This command converts 
the drawing borders to the latest format; see “Migrating from Previous Versions” on page 28. Additional sheet 
border capabilities are available in the Vectorworks Design Series products. See “Adding a Sheet Border” on 
page 77.

Drawing Grids Click Change to open the SmartCursor Settings dialog box; specify the reference and 
snap grid settings

Georeferencing If this document will use georeferencing, click Change to open the Document 
Georeferencing dialog box. Specify the default georeferencing information for all design 
layers; see “GIS and Georeferencing” on page 775.

Sheet Border/Title Block If not created during setup, sheet borders and title blocks can be added manually with the 
Sheet Border tool (see “Adding a Sheet Border” on page 77)

Sheet Border Select the sheet border to automatically include as the file is set up, or leave the default 
selection of None to create no sheet border

Title Block Select the title block from either the default content or the current file’s content to 
automatically include as the file is set up (see “Resource Libraries” on page 219), or 
leave the default selection of None to create no title block

Use Border Settings
As preferences Saves the sheet border and title block selections and applies them to the sheet layers 

when the Create Standard Viewports command is selected (Vectorworks Architect 
required)

To create a border 
now on layer

Places the specified sheet border and title block on the selected layer immediately 

Parameter Description
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To place a sheet border:

1. Make the design or sheet layer active.
2. Click the Sheet Border tool from the Dims/Notes tool set.

Alternatively, the Vectorworks Architect and Landmark products allow sheet borders to be set up using drawing 
standards. See “Document Setup” on page 76 and “Standard Viewports” on page 186.

3. Click Preferences from the Tool bar to set the default sheet border parameters.
The Sheet Border Preferences dialog box opens.

Click to show/hide the parameters.

4. Click once in the drawing to set the sheet border insertion point, and then click again to set the sheet border 
orientation.

5. The sheet border is placed on the drawing. Sheet borders should be placed as 2D screen objects (See “Planar 
Modes of 2D Objects: Screen Plane and Layer Plane” on page 152).

6. Set the text attributes as needed using the Text > Format Text command. You can also drag and drop a text style 
from the Resource Browser onto the sheet border object.

7. Set the line attributes as needed using the Attributes palette.
8. The sheet border can be re-sized and re-scaled after placement, and title blocks and revision histories can be 

added.
~~~~~~~~~~~~~~~~~~~~~~~~~
The Attributes Palette
Formatting Text
Using Text Styles
Sheet Border Properties
Adding a Title Block
Creating a Custom Title Block

Sheet Border Properties
The sheet border properties can be edited in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Sheet Size Select a standard size and format for the sheet border, or select Fit to Page to set the sheet 
border to the page dimensions (see “Page Setup” on page 1761). Select Custom to use 
custom sheet border dimensions, and specify the Width and Height dimensions.

Title Block Opens the Import Title Block dialog box, for selecting a title block symbol to insert, or 
select None for no title block

Lock to Page Center Locks the sheet border center position to the page center; deselect to position the sheet 
border manually. If the plan has been rotated (Vectorworks Design Series required), select 
Lock to Page Center to position the sheet border correctly when in a non-rotated view.

Use As Title Block 
Only

When a title block has been selected, displays only the title block and hides all other sheet 
border elements
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Parameter Description

Plane Generally, for sheet borders, select Screen to place the border on the screen plane. See 
“Planar Modes of 2D Objects: Screen Plane and Layer Plane” on page 152.

Lock to Page Center Locks the sheet border center position to the page center; deselect to position the sheet 
border manually. If the plan has been rotated (Vectorworks Design Series required), 
select Lock to Page Center to position the sheet border correctly when in a non-rotated 
view.

Size Select a standard size and format for the sheet border, or select Fit to Page to set the sheet 
border to the page dimensions. Select Custom to use custom sheet border dimensions, 
and click Border Settings to specify the dimensions. 

Orientation Select Portrait or Landscape orientation
Horizontal Dimension Displays the sheet border horizontal dimensions
Vertical Dimension Displays the sheet border vertical dimensions
Border Settings Opens the Sheet Border Settings dialog box, for specifying further properties (see 

“Specifying Additional Sheet Border Settings” on page 81)
Title Block Opens the Import Title Block dialog box, to select a title block symbol to insert (see 

“Adding a Title Block” on page 83). This dialog box can also be accessed from the sheet 
border context menu; right-click (Windows) or Ctrl-click (Mac) on the sheet border, and 
select Title Block.
ASME title blocks are required to insert a tolerance or projection block.

Additional default title blocks are available with the Vectorworks Design Series 
products; for US Arch title blocks, information is linked to the Issue Manager.
To remove a title block, select the Defaults symbol folder, and then select None from the 
Symbols list.

Current Title Block When a title block has been inserted, displays the title block symbol name
Use As Title Block 
Only

When a title block has been selected, displays only the title block and hides all other 
sheet border elements

Title Block Position Specifies the title block location relative to the sheet border
Title Blk Scale Factor If the title block is too large or small at normal scale (scale factor 1), scales the title block 

size, including text. A value below 1 makes the title block smaller, while a value above 1 
makes the title block larger; text is automatically scaled along with the title block 
geometry.

Title Blk Margin Adds a horizontal, vertical, or block margin to the title block
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Use Revision Block
(Vectorworks Design 
Series required)

Adds a revision history block to the sheet border

Rev. Block Position Specifies the revision block location relative to the sheet border
Rev. Block Height Specifies the height of the revision block
Rev. Block Width Specifies the width of the revision block
Show Revision Zone Adds a revision zone column to the revision block, for specifying the location of the 

revision 
Use Tolerance Block 
(Vectorworks Design 
Series required)

For ASME sheet borders, adds a tolerance specifications block to the title block. The 
tolerance block creates a legend containing the drawing tolerances, including both 
angular and linear accuracy. 

Tolerance block details are text objects, and do not affect the actual dimensional 
tolerances.

Use Projection Block
(Vectorworks Design 
Series required)

For ASME title blocks, adds a projection block area to the title block; specify First 
Angle or Third Angle in Projection

Show Grids Displays grid text and lines in the sheet border margin. This setting can also be accessed 
from the sheet border context menu: right-click (Windows) or Ctrl-click (Mac) on the 
sheet border, and select Show Grids.

Show Grid Lines Displays grid lines on the drawing
Fold Marks Select the fold mark measurements when adding fold marks to the sheet border. The first 

measurement specifies the drawing fold width and the second measurement indicates the 
margin fold width. Select Custom to specify custom fold mark distances.
Fold marks are designed for use with ISO drawings.

Margin Width When custom fold marks are selected, enter the margin fold width
Folded Width When custom fold marks are selected, enter the drawing fold width
Folded Height When custom fold marks are selected, enter the drawing fold height

Hide Border When the sheet border includes a title block, hides the sheet border and displays only the 
title block (this allows a different sheet border to be used with that title block, if desired)

Fill Border Fills the area between the outer and inner border lines with a fill selected from the 
Attributes palette

Add Parts List
(Vectorworks Design 
Series required)

Adds a parts list to the title block (this is intended for ASME title blocks, but can be 
added to any title block). Information from detail bubbles populates the parts list; see 
“Creating Detail Bubbles” on page 1274. If a parts list worksheet does not yet exist, it is 
created.

Parameter Description

UNLESS OTHERWISE SPECIFIED
DIM ARE IN INCHES

TOL ON ANGLE ± .25°
2 PL ± .01 3 PL ± 005

INTERPRET DIM AND TOL PER
ASME Y14.5M-1994



Adding a Sheet Border |  81
Specifying Additional Sheet Border Settings
Additional sheet border settings are available from the Object Info palette.
To specify additional sheet border settings:

1. Select the sheet border.
2. In the Object Info palette, click Border Settings. Alternatively, double-click on the sheet border.

The Sheet Border Settings dialog box opens.
Click to show/hide the parameters.

Edit Title Block
(extended capabilities in 
Vectorworks Design 
Series)

Opens the Edit Title Block dialog box, for specifying the title block information. 
Depending on the selected title block, different fields and tabs are available.
In Vectorworks Design Series products, ASME title blocks include a tolerance tab, for 
editing the tolerance block information (see “Editing a Tolerance Block” on page 85). 
US Arch title blocks include Project and Sheet tabs; information is entered from the 
Issue Manager but can be edited manually (see “The Issue Manager” on page 90). Any 
title block that contains a Project tab can have the same Project tab information applied 
to all title blocks in the file by selecting Apply these values to all title blocks.
If Use Automatic Drawing Coordination is enabled in document preferences, the sheet 
layer is automatically updated if the Sht Title Line 1 is changed. Similarly, if the Sheet 
Number value is changed, the sheet layer and any annotation objects (drawing labels or 
section markers) on the sheet layer that show this information are updated automatically.

Edit Revision Data 
(Vectorworks Design 
Series required)

Opens the Edit Revision Data dialog box, for specifying revision information and format

Edit Issue Data 
(Vectorworks Design 
Series required)

Opens the Edit Issue Data dialog box, for specifying issue data on US Arch title blocks

Parameter Description

Drawing Size Specifies the sheet border size
Vertical/Horizontal 
Dimension

Specifies the sheet border vertical/horizontal dimensions; initially, these are based on the 
Size selected in the Object Info palette, but the dimensions can be edited. This parameter 
is not available when the Size is Fit to Page.

Dimensions Shown 
Are

Applies the dimensions to either the outer or inner border dimensions

Margins Specifies the sheet border margin widths
Zones/Grids

Vertical Zones Specifies the number of vertical zones to include
Grid Text Order Indicates whether vertical grid text starts at the top or bottom of the border; select Not 

Shown to remove grid text
Horizontal Zones Specifies the number of horizontal zones to include

Parameter Description
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3. Click OK to set the sheet border parameters.
~~~~~~~~~~~~~~~~~~~~~~~~~
Adding a Title Block
Creating a Custom Title Block
Adding a Sheet Border
Adding a Sheet Border

Sheet List Indexing
The Create Sheet List command compiles the current sheet border information for use as a sheet list index or 
worksheet.
To create a sheet list index:

1. Select Tools > Reports > Create Sheet List.
The Create Sheet List dialog box opens. 

Click to show/hide the parameters.

Grid Number Order Indicates whether horizontal grid numbers start at the left or right of the border; select 
Not Shown to remove grid numbers

Grid Label Size Specifies the text size for both grid text and numbers
Grid Marker Line 
Length

Specify the length of the grid marker lines and grid line extensions; lines cannot extend 
past the margin area

Grid Marker Line 
Weight

Select the line weight of the grid marker lines and extensions

Show Grid Line 
Extensions

Includes lines that extend past the border to the ends of the margin in area

 

Countersignature Select whether to include a countersignature area in the sheet border margin area, and, if 
included, where to place it.
• Select None to omit the countersignature field
• Vertical places the countersignature vertically in the upper left corner of the sheet 

border
• Horizontal places the countersignature horizontally in the upper right corner of the 

sheet border
Sheet border margins may need adjustments to allow enough space for the 
countersignature if one is selected.

Reset to Default Values If the sheet border Size is set to one of the standard sizes (such as US Arch B or ISO AS), 
select this button to restore the default sheet border settings

Parameter Description

With grid line extensionsWithout grid line extensions
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2. Move the desired title block entries to the proposed sheet list to create the sheet list, and format the list by clicking 
Format; select whether to create a text object or worksheet from the list.

3. Click OK.
4. If the sheet list index is formatted as a text block, click to select the top left and bottom right corners of the sheet 

list area; the text wraps to fit within this width. If the sheet list index is formatted as a worksheet, click to add the 
worksheet to the file.

The sheet list index worksheet can also be added to the drawing from the VA Create Schedule command or the 
Resource Browser. From the Resource Browser, open the default architectural reports file from the 
[Vectorworks]\Libraries folder that is included with the Vectorworks Architect product (see “Resource Libraries” on 
page 219). Drag the Sheet List worksheet to the drawing. The worksheet is populated with information from the objects 
in the current drawing.

Adding a Title Block
A title block containing drawing information can be added to the sheet border. Title blocks are saved as symbols with 
text linked to a record.
A title block can be the only part of the sheet border that displays, by selecting Use As Title Block Only in the sheet 
border preferences or the Object Info palette.

Additional title block capabilities are described in “Adding a Sheet Border” on page 77.
To add a title block to the sheet border:

1. Select the sheet border.
2. In the Object Info palette, click Title Block.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the sheet border and select Title Block from the 
context menu.
The Import Title Block dialog box opens.

Click to show/hide the parameters.

Parameter Description

US Arch Title Block 
Entries

Lists the current US Arch title blocks

Sheet No. Displays the contents of the current title block selection
Add > Moves a selected item from the US Arch Title Block Entries list to the Proposed Sheet 

list
< Remove Removes a selected item from the Proposed Sheet list and displays it in the US Arch 

Title Block Entries list
New Click to open the New List Entry dialog box and add the drawing and title block 

information to the Proposed Sheet list
Move Up/Move Dn Moves the selected title up or down in the Proposed Sheet list
Format Click to open the Sheet List Index Preferences dialog box and specify whether to create 

the sheet index as a text block or worksheet; also specify formatting criteria
Proposed Sheet List Lists the proposed sheet borders to include in the sheet list
Sheet No./Title Displays the contents of the current selection for editing
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3. Select a title block symbol from the selected symbol folder. The Defaults folder contains the default title block 
resources; see “Resource Libraries” on page 219. The title blocks listed under Top Level are title block symbols 
that exist in the current file.
To remove an existing title block, select None.

4. Click OK to add the selected title block symbol to the sheet border. The title block is scaled to match the current 
layer scale if necessary.
When a sheet border with a title block is inserted into a drawing, the Sheet Border Components symbol folder is 
automatically created and displays in the Resource Browser. Title block symbols added to the sheet border are 
automatically placed in that folder.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Custom Title Block
Creating a Custom Title Block
Sheet Border Properties

Editing Revision Block Data
To add a revision block to the sheet border, select Use Revision Block from the Object Info palette of a selected sheet 
border. The revision block parameters (such as height and width) are specified from the Object Info palette, but the 
actual revisions are specified in a separate dialog box.
To add or edit revision block data:

1. From the Object Info palette of a selected sheet border with a revision block, click Edit Revision Data.
2. The Edit Revision Data dialog box opens.

Click to show/hide the parameters.

3. Click Add to create a revision entry.
The Add New Revision dialog box opens. Specify the revision data.

4. Click OK to return to the Edit Revision Data dialog box. Existing revisions can also be edited or deleted.
5. Click OK. The revision block is updated.

Parameter Description

Symbol Folders Specifies the location of the sheet border symbols
Symbols Provides a graphical list of available sheet border symbols

Parameter Description

Revisions list Lists the current revisions displayed in the revision block
Add Opens the Add New Revision dialog box, for adding a revision to the block
Edit Opens the Edit Existing Revision dialog box, for editing the currently selected revision
Remove Deletes the currently selected revision
Use Select Letters or Numbers for the Rev# format
Show the Specifies how many revisions to display in the revision block, from recent to oldest
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~~~~~~~~~~~~~~~~~~~~~~~~~
Sheet Border Properties

Editing a Tolerance Block
When an ASME title block is added to a sheet border, an area for tolerance specifications data is included. The 
tolerance data is specified in a separate dialog box.
To edit the tolerance block data:

1. Select the sheet border from the drawing area.
2. In the Object Info palette, click Edit Title Block.

The Edit Title Block dialog box opens. Click the Tolerance tab.
3. Enter the angular and dimensional tolerances to be displayed in the tolerance block.

Only the angular accuracy, two place, and three place parameters apply to the ASME tolerance block. The 
remaining tolerances might apply to a custom title block.

4. Click OK.
The tolerance block is updated with the new information.

~~~~~~~~~~~~~~~~~~~~~~~~~
Sheet Border Properties

Editing Issue Data
When a US Arch title block is added to a sheet border, an area for issue data is included. The issue notes are specified 
in a separate dialog box.
To add or edit issue data:

1. From the Object Info palette of a selected sheet border with a revision block, click Edit Issue Data.
2. The Edit Issue Data dialog box opens.

Click to show/hide the parameters.

3. Click Add to create an issue entry.
The Add New Issue dialog box opens. Specify the issue note.

Parameter Description

Issue list Lists the current issues displayed in the title block
Add Opens the Add New Issue dialog box, for adding an issue note
Edit Opens the Edit Existing Issue dialog box, for editing the currently selected issue note
Remove Deletes the currently selected issue note
Use Select Letters or Numbers for the Issue# format
Show the Specifies how many issues to display in the title block, from recent to oldest
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4. Click OK to return to the Edit Issue Data dialog box. Existing issue notes can also be edited or deleted.
5. Click OK. The issue data is updated.

~~~~~~~~~~~~~~~~~~~~~~~~~
Sheet Border Properties

Creating a Custom Title Block
A custom title block, containing company-specific graphics, information, and data fields, can be created and then 
inserted into a sheet border.
Three steps are required: create a title block symbol, create a custom record format, and link the record format fields to 
the title block symbol text fields.

Creating a custom title block in the Vectorworks Design Series products requires additional steps, if the custom 
title block is to be used with the Issue Manager. 

To create a custom title block:
1. In a new file with a scale of 1:1, create the elements of the title block, including lines, rectangles, graphics, and 

text. Creating the title block at a scale of 1:1 ensures that it is inserted at the correct scale when it is placed on a 
sheet layer or a design layer of any scale. The title block should be a 2D screen object (See “Planar Modes of 2D 
Objects: Screen Plane and Layer Plane” on page 152.)

• Do not use any 3D elements.
• Company logos can be imported as bitmaps.
• The title block geometry (pen color, pen style, and line thickness) and text (font, style, and color) can either 

inherit the sheet border attributes, or retain those attributes as created. The “By Class” setting in the Attributes 
palette indicates that the attributes should be inherited from the sheet border. If an attribute is not set to “By 
Class,” then its original setting is retained.

Description Method

The attributes of the title block elements are 
inherited from the sheet border

Specify “By Class” in the Attributes palette for 
these elements. For text font and style attributes, set 
the Pen Style by class to use the same font and style 
as the sheet border. For text color, set the Pen Color 
to “Color By Class.”
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Different settings can be combined so that some attributes are inherited from the sheet border, while others remain 
as created. For example, if a line should use the same color as the sheet border, but have a dashed line type with a 
thickness of 1 mm, when creating the line, set the line’s Pen Color to “Color By Class,” its Line Thickness to 1 
mm, and its Pen Style to the desired dashed line type.

2. Select all the title block elements, and then select Modify > Create Symbol.
The insertion point of the symbol should be at lower right corner of the title block. See “Creating New Symbols” 
on page 239.

3. Create a new record format as described in “Creating Record Formats” on page 262.
The field names of the record format are used as the titles for the associated editable fields in the Edit Title Block 
dialog box.

To create a multi-line field, append a pound sign (#) to the field name, as in Drawing Title#.
Use a P_ prefix to indicate project fields (these are fields with the same value on all title blocks in the file). An S_ 
prefix indicates sheet fields (these are fields with a different value on any title blocks). The prefixes cause the Edit 
Title Block dialog box, accessed from the Object Info palette, to be separated into project and sheet tabs. Fields 
without a prefix are placed on the General tab.
Use an _SN suffix to indicate that a field should gets its value from the Sheet Number of its sheet layer. If Use 
Automatic Drawing Coordination is enabled in document preferences (Vectorworks Design Series required), 
the _SN suffix also means that when this title block field is updated, the Sheet Number of the sheet layer and of 
annotation objects on the layer are updated.
Use an _SD suffix to indicate that the field should get its value from the Sheet Title of its sheet layer. If Use 
Automatic Drawing Coordination is enabled in document preferences (Vectorworks Design Series required), 
the _SD suffix also means that when this title block field is updated, the Sheet Title of the sheet layer is updated. 
If the field should also be multi-line, use an _SD# suffix.

The title block elements retain the attributes 
as created

Set the attributes of the geometry and text from the 
Attributes palette when the title block is created. For 
text font and style attributes, set the Pen Style to 
Solid to use the text attributes set when the title 
block was created. For text color, select the desired 
Pen Color.

Description Method
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4. Creating a custom title block in the Vectorworks Design Series products requires additional steps, if the custom 
title block is to be used with the Issue Manager (see “The Issue Manager” on page 90), or contain issue fields or 
revision fields. When creating the record format to attach to the custom title block, fields linked to the Issue 
Manager require special prefixes or suffixes. If creating issue or revision fields, special text strings are added to 
the title block design. These record fields do not require linking, as they are automatically recognized by the 
Vectorworks program.

Title Block Area Prefix Required

Issue Manager If you are creating a US Arch-style title block with issue data linked to the Issue Manager:
• Project fields (which contain the same value in all drawing set title blocks) must be prefaced 

with P_ (example: P_Project Title)
• Sheet fields (which contain different values in different drawing set title blocks) must be 

prefaced with S_ (example: S_Sheet Scale)
• Multi-line text fields (which contain multiple lines of text) must be appended with a # (pound 

sign) (example: P_Drawing Title#)
Issue Data To add issue fields, such as issue number, date, note, and/or approvals to a sheet border which 

can be populated by the Issue Manager and edited manually, create text fields with special text 
strings to represent the issue fields and place these fields in the title block. The special text 
strings are (including colon):
• Issue note :iNote
• Issue number :iNo
• Issue date :iDate
• Issue approval :iAppr
The text fields can have any justification, and should have word wrap on. The vertical alignment 
must be set to Top for the issue text to flow down, and to Bottom for the issue text to flow up.
To enter or edit issue text, click Edit Issue Data from the Object Info palette of a selected sheet 
border (see “Editing Issue Data” on page 85), or use the Issue Manager. The issue history is a 
property of the sheet border, not the title block, so a title block is not required to enter issue data.
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5. Attach the custom record format to the title block symbol through the Resource Browser as described in 
“Attaching Record Formats to a Single Symbol Instance or Object” on page 264.

6. Edit the title block symbol and attach the record fields to the associated symbol text; see “Linking Text to Record 
Formats” on page 269 for more information.

7. To be available to the Sheet Border tool, either the file must be saved in the sheet border- title block folder in the 
[Vectorworks]\Libraries\Defaults folder, or the custom symbol and its associated record format must be imported 
into the Custom Title Blocks.vwx file, located in the same default content folder.
Alternatively, import the title block symbol from another file.

8. To place the custom title block, click Title Block from the Object Info palette of a selected sheet border, and select 
the custom title block symbol.

Revision Data To add revision fields, such as revision number, date, zone, and/or approvals to a sheet border, 
create text fields with special text strings to represent the revisions and place these fields in the 
title block. The special text strings are (including colon):
• Revision note :rNote
• Revision number :rNo
• Revision date :rDate
• Revision zone :rZone
• Revision approval :rAppr
The text fields can have any justification, and should have word wrap on. The vertical alignment 
must be set to Top for the revision text to flow down, and to Bottom for the revision text to flow 
up.
To add revision text to a sheet border, select Use Revision Block from the Object Info palette of 
a selected sheet border. To enter or edit the revision text, click Edit Revision Data (see “Editing 
Revision Block Data” on page 84). The revision history is a property of the sheet border, not the 
title block, so a title block is not required to enter revision data.

Title Block Area Prefix Required
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~~~~~~~~~~~~~~~~~~~~~~~~~
Adding a Title Block
Sheet Border Properties
The Issue Manager

The Issue Manager
The Issue Manager accesses and displays information about drawing issue, dates, and history on a sheet-by-sheet basis. 
It interacts with the sheet border object by allowing the user to control the sheet border title block data and issue 
information. (Sheet borders can either be placed with the Sheet Border tool in the Dims/Notes tool set—see “Adding a 
Sheet Border” on page 77—or created and placed by the Document Setup or Create Standard Viewports 
commands—see “Document Setup” on page 76 and “Standard Viewports” on page 186.)
To use the Issue Manager:

1. Ensure that at least one sheet border with a title block is present in the drawing.
2. Select File > Issue Manager.

The Issue Manager dialog box opens.
The tabs and fields displayed depend on the title block inserted in the sheet border. Custom title blocks may not 
match the parameters or tabs shown here. The fields and tabs shown assume that an Arch-style title block is 
inserted.

3. Click the Project Data tab to configure the project information.
Leave a blank field to create an empty line in the title block.

Click to show/hide the parameters.

The information on the Project tab applies to all sheet borders or title blocks in the set.

Parameter Description

Project ID Specifies the company project ID code
Project Title Indicates the project title, which can include name and address information
Design Firm Describes the name and address of the design firm
Project Manager Provides the project manager’s name
Designed By Specifies the name of the lead designer
Total Sheets Indicates the total number of sheet layers (or design layers named “sheet-”) in the project
CAD File Name Indicates the name of the file
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4. Enter the project information. If the project was created with the Create Standard Viewports command 
(Vectorworks Architect required), some of the information has been automatically entered.

5. Click the Sheet Data tab to configure information about individual sheet layers in the set.
Click to show/hide the parameters.

6. Complete the information for each sheet in the drawing set to be issued. Toggle among other sheets in the drawing 
with the Next and Prev buttons.
If the project was set up with the Create Standard Viewports command (Vectorworks Architect required), some 
of the information has been automatically entered. For each sheet, specify sheet-specific information and indicate 
whether to include the sheet in the issue. 

7. Click the Issue Data tab to specify information about the current issue.
Click to show/hide the parameters.

8. Click OK.
The sheet border title blocks are updated for the selected sheets. If specified, the issue information is included in 
the title block.
Regardless of whether the title block contains fields for the issue data, the data is still written to a record attached 
to the sheet border, becoming a permanent part of the sheet border. If the title block changes later, the data can be 
displayed.

Parameter Description

Sheet Number Specifies the sheet number
Sht Title The drawing title can contain up to three lines
Sheet Scale Displays the scale of the major drawing on this sheet
Consultant Specifies the name and address of any consultants involved with this particular sheet
Drawn By Provides the draftsperson’s initials
Reviewed By Specifies the reviewer’s initials
Submitted By Specifies the submitter’s initials
Checked By Specifies the checker’s initials
Date Specifies the date of the issue
Include in Current 
Issue

Select to include this sheet in the current issue set

< Prev / Next > Click Prev and Next to switch to each sheet and enter the relevant data

Parameter Description

Record the issue of this Drawing Set Updates the title block issue data area
Issue Number Specifies the number or letter of the current issue
Issue Date Indicates the date of the current issue
Issue Note Adds any comments or description of the issue
Record on checked sheets only Updates only the issue data of sheets that were selected on the Sheet Data 

tab
Record on all sheets Updates the issue data for all sheets in the file
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Standard Naming
The Standard Naming command controls the layer, class, and viewport names used in a project. These names can be 
changed to a user-defined system other than the default VWArch naming system. Standards can be mapped for 
office-wide use or to convert an existing file to the office standard. This command can also be used to assign specific 
attributes to classes in standards, and to change the names of layers, viewports/views and classes in the current 
standard. The command does not create new layers, classes, or viewports/views.

If classes, layers, and viewports/views have not been set up according to VWArch standards, their names may not 
match the example layer and class names presented here.

To set the standard naming of layers, classes, and views:
1. Select File > Document Settings > Standard Naming.

The Standard Naming dialog box opens. Select a naming standard for the file, and choose whether auto-classing 
should be enabled for objects.

Click to show/hide the parameters.

2. Click Details to edit custom class, layer, and viewport/view names.
The Standard Naming Details dialog box opens, displaying class names on the Classes tab. Select the Design 
Layers tab to display design layer names, and the Sheet Layers, VP, Saved Views tab to display the names for 
viewports and their associated sheet layers, or for saved views.
Using the reference list, verify the mapping of standard names. Custom naming can be specified for custom active 
standards by entering a new name for each layer, class, or viewport/view. If desired, class attributes can also be 
specified for each standard or custom class name. See “The Attributes Palette” on page 1093.

Click to show/hide the parameters.

Parameter Description

Active Standard Select the naming standard to apply to classes, design layers, sheet layers, viewports, and 
saved views

Details Opens the Standard Naming Details dialog box; to edit the names for a custom standard (User 
1, User 2, and User 3), the standard must be selected as the Active Standard first

Enable 
Auto-classing

Enables Auto-classing for the file and automatically places auto-classing objects into 
pre-assigned classes; see “Automatically Created Classes” on page 185. If objects were 
already present in the drawing when auto-classing is enabled, choose whether existing 
objects should be auto-classed when exiting this dialog box.

Parameter Description

Reference Standard Select a reference naming standard from the list; the relevant class, layer, or 
viewport/view names are displayed below. Each active entry in the list is 
mapped to its corresponding reference list entry.
User 1, User 2, and User 3 are custom standards. More custom standards can 
be defined (see “Creating Additional Custom Standards” on page 93).

Active Standard Displays the overall naming standard currently in effect for the file (selected 
in the initial Standard Naming dialog box)

Reference Standard List Lists the reference standard names for the class, design layer, viewport/sheet 
layer, or saved view
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3. When the desired class attributes have been specified, and, for custom standards, the standard names have been 
established, click OK.

4. In the Standard Naming dialog box, click OK. If custom viewports exist in the drawing, you are prompted to run 
the Create Standard Viewports command again (Vectorworks Architect required; see “Creating Standard 
Viewports” on page 187) to update the viewports/views with the new naming standard, and update any new class 
attributes. If auto-classing was selected and objects had already been placed in the drawing, select whether to 
auto-class those existing objects.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Additional Custom Standards
Coarse and Fine Custom Standards

Creating Additional Custom Standards
A custom naming standard can be created rather than using the VWArch or AIA/NCS standard. Although three layer, 
class, and viewport/view standards are available from within the Standard Naming dialog box (User 1, User 2 and User 
3), up to ninety-nine can be created for layers, classes, and viewport/views by editing the ClassNameStds, 
LayerNameStds, and ViewNameStds worksheets. See “Using Worksheets” on page 1319.
To create a custom naming standard by worksheet:

1. In a new file, select File > Document Settings > Standard Naming.
The Standard Naming dialog box opens.

2. Without making any changes, click OK.
Three worksheets are created in the file, and are visible in the Resource Browser: ClassNameStds, 
LayerNameStds, and ViewNameStds.

Active Standard List Lists the standard name currently in effect and mapped to the reference 
standard for the class, design layer, or viewport/sheet layer, or saved view

Description of class/layer/view Describes the currently selected class, layer, viewport/sheet layer, or saved 
view in the list

Edit Class/Layer/View Name When a custom active standard is selected (User 1, User 2 or User 3), enter 
the custom name for the currently selected class, layer, or viewport/view

Class Attributes (Classes tab only) Sets the attributes of a selected class in the Active Standard list
Lines Select the line class attributes

Pen Color Select the pen color
Line Weight Select the line weight
Line Style Select the line style

Fills Select the fill style class attributes
Fill Pattern Select the fill pattern
Fill Fore Color Select the fill foreground color
Fill Back Color Select the fill background color

Use at Creation Applies the class attributes as the classed item is created

Parameter Description

http://www.youtube.com/watch?v=FMKRV7rJMVA
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3. Select one of the worksheets from the Resource Browser, and select Resources > Open.
The worksheet opens for editing.

4. Highlight column D (User 1) and from the Worksheet menu select Insert > Columns. A new column is added in 
front of the selected one.
New columns must be inserted after the AIA/NCS column and before the Description or Pen Color column.

5. Enter a name in cell D1 for the new standard.
6. Enter a new standard name for each cell below D1.

Cells left blank in the ClassNameStds worksheet will be assigned to the “None” class. Cells left blank in the 
LayerNameStds worksheet will be assigned to the “Layer-None” layer. Blank cells are not permitted in the 
ViewNameStds worksheet; if a worksheet with blank viewport/view names is attempted for use in Standard 
Naming, an error message is displayed.

7. The new standard is displayed in the Standard Naming dialog box.
To use these changes in other files, either save the file as a template to be used as the basis for new drawings, or 
import each worksheet into the other file before running the Standard Naming command.

Coarse and Fine Custom Standards
When creating custom standard naming, naming standards may contain fewer standard names (coarser) or additional 
standard names (finer).
A “coarser” custom standard names two or more of the standard class, layer, or view names with the same user-defined 
name. Except for auto-classing, this is an irreversible process.
For example, the classes Area-Main, Area-Patterns, and Area-Spec can be combined into a single class called Areas. 
All objects assigned to the original three classes are reassigned to Areas.
When custom standard naming changes are complete, additional information displays to confirm any actions to be 
taken, such as merging changed class names to eliminate duplicates.
A “finer” standard maps a single class, layer, or view name to multiple names. Mapping is required to define the 
standard naming change, and the Standard Naming - Mapping dialog box opens automatically.
For example, an A-FP# layer AIA standard corresponds to two layer standards in the Vectorworks Architect product: 
Mod-Floor-# and Mod-Slab-#. If switching from the AIA standard to the VWArch standard, select the A-FP# layer 
from the list on the left and indicate the mapping for objects currently on the A-FP# layer by selecting the mapping 
layer on the right.
All objects assigned to the A-FP# layer are assigned to the Mod-Floor-# layer. Unmapped layers are not created.

Mapping Classes and Layers
The Class and Layer Mapping command “maps” any set of layers and/or classes in a drawing into a new layer and/or 
class. The file structure can be simplified, condensed, and/or renamed. Use this feature, for example, when a consultant 
is using DWG or DXF files. Complex, multi-classed files imported from DWG can be condensed or renamed, and 
empty classes deleted in a single operation. Mapping can be saved so the next time a file is received from that 
consultant, the file can be re-mapped in a single step. This same procedure can be revised for the process of providing 
files to consultants using a different file structure or drawing standard. See “Layers” on page 161 and “Classes” on 
page 176.
To modify layers and classes:

1.  Select Tools > Class and Layer Mapping.
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The Class Mapping dialog box opens. Modify the existing classes, and then click Go To Layers to open the Layer 
Mapping dialog box. The Layer Mapping dialog box is identical in layout to the Class Mapping dialog box.

Click to show/hide the parameters.

When selecting existing and proposed classes and layers, press and hold the Shift key to select multiple, 
contiguous items or press and hold the Ctrl key (Windows) or Command key (Mac) to select non-contiguous 
items.

2. Click OK.
The drawing is updated, using the new layer and class mapping. Layers and classes not moved to the Proposed or 
Merged list are deleted from the file, along with any objects in those layers or classes.

Spotlight Setup

Lighting Device Setup
The options on the Lighting Device tab enable automatic positioning behavior, assign classes, and specify attributes of 
the lighting devices in the file. The parameters selected can have a powerful global effect on all the devices, both 
existing and new.

Parameter Description

Existing Classes/
Layers

Lists the existing classes or layers in the file; layers or classes that are not moved to the 
Proposed or Merged list are deleted

Add > Adds a layer or class from the list of existing layers or classes to the Proposed list
Merge > Adds a layer or class to the Merged list; layers or classes in this list will be merged with the 

layer or class that is selected in the Proposed list
< Remove Removes the selected item from the Proposed list
New Creates a new class or layer in the Proposed list
Rename Renames the selected proposed layer or class
Merged Items Lists layers or classes to merge with the selected layer or class in the Proposed list. The 

merge occurs when the next action is performed in the dialog box, so that layers and classes 
are merged on an ongoing basis. Selecting a proposed layer or class lists its merged items 
again so that changes can be made, if desired.

Remove Removes the selected item from the Merged list
Load Opens a previously saved mapping file
Save Saves the layer or class mapping as a file; layer and class mapping settings are saved 

separately. This saves time when making the same modifications to several drawings that 
are set up similarly.

Reset All Moves all proposed and merged items back to the Existing list
Delete empty class/
layer in proposed 
drawing

Deletes all layers and classes that have no items associated with them

Go To Layers > /Go 
To Classes >

Toggles between the Class Mapping and Layer Mapping dialog boxes
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Lighting instruments can be automatically associated with a lighting position, both at insertion and when an existing 
instrument is moved on the light plot. At various times during the design work, particularly in the later stages, 
instruments may need to be moved slightly, but they should not be accidentally associated with a different nearby 
lighting position. The auto-positioning option provides the necessary control over the automatic association of 
instruments to lighting positions.
Class and color assignments for lighting instruments allow the designer to:

• Assign the lighting instruments to a specific class, or to one or more classes determined by an instrument 
parameter

• Control the color of lighting instruments, or parts of instruments, by gel color or from the Attributes palette
• Control the wireframe light beams, angles, and centerline of lighting instruments by class
• Control the label legend container appearance by class
• Control the appearance and visibility of lighting instruments in viewports, when using viewport overrides

The Object Info palette display of lighting device parameters can also be set from this tab.
To specify lighting device preferences:

1. Select File > Document Settings > Spotlight Preferences.
The Spotlight Preferences dialog box opens. Click the Lighting Device tab.

Click to show/hide the parameters.

Parameter Description

Enable lighting 
instrument auto 
positioning

Toggles the option to automatically associate lighting instruments with nearby lighting 
positions. When enabled, the instrument automatically associates with the closest 
lighting position within the Pick radius. When disabled, the instrument is assigned to a 
lighting position at insertion, but if moved later, the instrument’s associated position 
remains unchanged.

If instruments are still being added to a complex light plot, enable auto positioning, 
but decrease the radius value so that existing instruments can be moved without 
losing their pipe association. When instruments are only being repositioned, disable 
the auto-positioning option.

Beam

Labels

Lighting instrument 
symbol geometry

Container shapes

Centerline

Beam angle

Field angle
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Pick radius When auto positioning is enabled, specifies the radius for automatic association
Automatically assign 
the classes of all 
lighting instruments

Sets class options for lighting instruments; select the option to enable automatic classing 
options or deselect the option to turn off automatic class assignment

Use existing document 
class

Places all instruments in the selected class; select the class from the current list of classes 
or select New to create a new class

Use value of the field Places all lighting instruments into a class that is determined by the value of an 
instrument parameter; select one of the instrument parameters from the list. For example, 
the value of the field User Field 2 could determine the class of each lighting instrument; 
instruments whose User Field 2 value is set to “FOH” will automatically be placed into 
a class together for automated appearance and visibility control. If the value of a 
particular field is not set (blank) for a lighting instrument, the instrument remains in the 
current class.

Class name Specifies class naming options when the lighting instrument classes are determined by 
field value name; select a Prefix or Suffix and then enter the prefix or suffix name. Using 
a dash will nest the classes. 
For example, using a prefix of Fixtures- means that when a lighting instrument contains 
a value of Rental for User Field 2, the instrument is placed in a class named 
“Fixtures-Rental.”

Modify lighting 
instrument color

Sets color options for the lighting instrument; select the option to enable automatic color 
options, or deselect the option to turn off automatic color control (the symbol specifies 
the instrument color)

Lighting instrument 
color set by: Lighting 
instrument

The Attributes palette controls the color of the lighting instrument geometry. Attributes 
can be set directly from the palette for selected lighting instrument or controlled by class 
(see “Setting Class Attributes” on page 181).

Lighting instrument 
color set by: Color field

The color specified in the lighting instrument’s Color parameter also controls the 
appearance of the lighting instrument geometry

Use color field for the 
fill color

Applies the Color parameter value to the fill color of the lighting instrument

Use color field for the 
pen color

Applies the Color parameter value to the pen color of the lighting instrument

Modify only geometry in 
the class

Modifies the color of lighting instruments components within the selected class; select 
<All> to modify all the geometry, select the class from the current list of classes, or 
select New to create a new class

Label legend container Controls the appearance of the label legend container(s)
• Use symbol attributes: uses the container symbol definition to specify the attributes
• Use label attributes: matches the attributes of the container to the attributes of the label 

legend text within the container
• Use lighting instrument attributes: matches the attributes of the container to the 

attributes of the instrument
Show beam angle Draws the beam angle for all lighting instruments with Draw Beam selected 

Parameter Description
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2. Specify the auto-positioning and appearance settings for the file’s lighting devices.
Click Save as default to use the lighting device and other Spotlight settings for other files created with the 
Vectorworks Spotlight product.

3. Click OK.
Class setting changes require confirmation before regenerating the lighting devices.

Specifying Lighting Device Parameter Display
The lighting device parameters that display on the Shape tab of the Object Info palette can be customized. The 
customized parameters apply to all lighting devices in the file, and parameter sets can be saved.
To specify lighting device parameters:

1. Select File > Document Settings > Spotlight Preferences.
2. The Spotlight Preferences dialog box opens. Click the Lighting Device tab.
3. Click Lighting Device Parameters.

Beam angle class Controls the class of the wireframe representation of the beam angle; select a class for 
the beam, or create a new class. Alternatively, select <Lighting instrument Class>, which 
places the beam angle attributes in the same class as the instrument.

Show field angle Draws the field angle for all lighting instruments with Draw Beam selected
Field angle class Controls the class of the wireframe representation of the field angle; select a class for the 

beam, or create a new class. Alternatively, select <Lighting instrument Class>, which 
places the field angle attributes in the same class as the instrument.

Show centerline Draws the centerline for all lighting instruments with Draw Beam selected
Centerline class Controls the class of the wireframe representation of the centerline; select a class for the 

line, or create a new class. Alternatively, select <Lighting instrument Class>, which 
places the centerline attributes in the same class as the instrument.

Automatically Flip Front 
& Back Legend Text

Select to mirror the label legend along the X axis of all lighting instruments

Automatically Flip Left 
& Right Legend Text

Select to mirror the label legend along the Y axis of all lighting instruments

Additional Default 
Records

Opens the Additional Default Records dialog box, to select additional records with 
default data for lighting devices. 
Only applicable records display for selection. Select one or more record formats from 
those present in the file; a check mark in the Use column indicates that the default data in 
the record will be included. At insertion or replacement, the lighting device processes the 
additional record(s). If a match is found for a record field name, the default data from the 
record attached to the symbol applies to that field and displays in the Object Info palette. 

Lighting Device 
Parameters

Opens the Lighting Device Parameters dialog box, to set lighting device parameter 
display options; see “Specifying Lighting Device Parameter Display” on page 98

Save as default Saves the current Spotlight preferences as the default; the default settings saved include 
those on the Universe and Lightwright tab

Parameter Description
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The Lighting Device Parameters dialog box opens. From this dialog box, Object Info palette parameters for 
lighting devices can be added, renamed, deleted, removed from display, and ordered. Parameter sets can be saved 
and managed.
Default lighting device parameters cannot be deleted.

Click to show/hide the parameters.

4. If settings have been changed, save the current settings as a set by clicking Save; <customized> is not considered 
as a saved set, though it applies to the current file.

5. Click OK to return to the Spotlight Preferences dialog box. The parameter display set that was selected applies to 
the current file. 
Regardless of whether Save as default is clicked in the Spotlight Preferences dialog box, the last selected saved 
set of parameters is in effect, even when creating a new file. New files created in Vectorworks Spotlight always 
default to the last saved parameter set.

~~~~~~~~~~~~~~~~~~~~~~~~~
Universe Assignment in Vectorworks Spotlight
Automated Import and Export to Lightwright
Lighting Instrument Properties
Record Formats

Universe Assignment in Vectorworks Spotlight
At the beginning of a project (and at any other time), the Vectorworks Spotlight product can be set to automatically 
handle the assignment of DMX universe and dimmer combinations. As instruments are added to the light plot, the 
Universe and U Address instrument parameters are determined based on the dimmer numbers specified in the 
Spotlight Preferences dialog box.

Parameter Description

Settings list Select a saved set of parameters to apply or edit. Once a saved set has been edited, <customized> 
displays in the list; click Save to save the custom set. Select <Default> to apply the standard set 
for the Vectorworks Spotlight program.

Save Opens the Save Settings dialog box; enter the name for the new saved set. Enter the same name as 
a previously saved set to overwrite the set.

Manage Opens the Saved Settings dialog box; select the set of saved parameters to rename or delete. Click 
OK to return to the Lighting Device Parameters dialog box.

Parameter list Lists the parameters, in order, that will display on the Shape Tab of the Object Info palette. Only 
items with a check mark in the Show in Shape Pane column will display on the Object Info 
palette. To change the order of a parameter, click and drag within the # column.

New Opens the Edit Field dialog box, to add a custom parameter to the list.
Enter the name of the new parameter, and select its type and default value, if any (see “Creating 
Record Formats” on page 262). Click OK to return to the Lighting Device Parameters dialog box.
To create a pop-up list of pre-defined parameter options, select the Type Pop-up and click 
Choices to open the Edit Choices dialog box. List the options and click OK.

Edit Opens the Edit Field dialog box, to edit the currently selected parameter name, type, and default 
value.

Remove Deletes the currently selected parameter(s) from the set
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To specify the dimmer and universe assignment:
1. Select File > Document Settings > Spotlight Preferences.

The Spotlight Preferences dialog box opens. Click the Universe tab.
Click to show/hide the parameters.

2. To enable automatic universe assignment, click Automatically assign Universe. 
3. Select a universe system and then for each universe in the system, provide a name (optional) and a starting and 

ending value. Click Next Page to continue entering universe break values.
Click Save as default to use this universe assignment and other Spotlight preferences for other files created with 
the Vectorworks Spotlight product.

4. Click OK.
The addresses of inserted instruments are automatically assigned to a universe. The U Address parameter in the 
Object Info palette displays the automatically assigned address when automatic assignment is enabled.

~~~~~~~~~~~~~~~~~~~~~~~~~
Lighting Device Setup
Automated Import and Export to Lightwright

Project Setup for Mechanical Design
At the beginning of a mechanical design project, use the Drawing Setup command to quickly set relevant drawing 
units, layer scale and print area from a single dialog box. A sheet border and title block can also be inserted 
automatically. An alternate method of setting up a document is to open one of the pre-configured machine design 
template files and use it as a starting point. 

The Machine Design (Imperial) template opens with File > Document Settings > Units set to inches on the 
General Display tab, decimal rounding set to three decimal places, and the design layer scale set at 1:1. 

To set up a project with the Drawing Setup command:
1. Select File > New.

The Create Document dialog box opens.

Parameter Description

Manually assign the Dimmer 
and Universe

Disables automatic universe assignment by the Vectorworks Spotlight product; 
dimmer and universe values need to be assigned manually for each instrument

Automatically assign 
Universe

As addresses are entered for instruments, the universe is automatically assigned by 
the Vectorworks Spotlight product

System Specifies the universe system; up to six systems, A through F, are available. Each 
system can contain up to 64 DMX universes.

Univ #, Label, Start #, End # Specifies where the universe breaks occur. For each universe, enter the dimmer 
range with a Start and End value; divisions of 512 are typical, but non-uniform 
divisions are also accepted. The universe name (label) is not required.

< Previous Page /Next Page > When defining more than eight universes, navigate to additional universe entries 
with Previous Page and Next Page. Up to 64 DMX universes can be specified per 
system.

Save as default Saves the current Spotlight preferences as the default; the default settings saved 
include those on the Universe and Lightwright tab
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2. Select Create blank document, and then click OK.
3. Select the Drawing Setup command from the appropriate menu:

• Architect workspace: AEC > Machine Design > Drawing Setup
• Landmark workspace: Landmark > Machine Design > Drawing Setup
• Spotlight workspace: Spotlight > Machine Design > Drawing Setup
The Drawing Setup dialog box opens.

4. Specify the drawing units, layer scale, print area, and sheet border, and then click OK. For more information on 
Drawing Units, Layer Scale, and the Print Area, see “Setting up the Drawing” on page 67.

Click to show/hide the parameters.

The drawing setup parameters are saved with the file. Use the Object Info palette to make any changes to the sheet 
border once it has been placed in the drawing.

Parameter Description

Drawing Units The current drawing units value on the General Display tab of the Units dialog box 
displays; click Change to revise the current drawing units

Layer Scale The current layer scale displays; click Change to set a different layer scale.
If the active layer is a sheet layer, the layer scale cannot be changed.

Print Area The current print area value displays; click Change to enter different print area 
parameters 

Insert Sheet Border Automatically inserts a sheet border
Insert Title Block Select the title block to insert within the sheet border, or select None to leave out the 

title block; see “Adding a Sheet Border” on page 77
Insert Revision Block Select to insert a revision history block within the sheet border; for more information, 

see “Adding a Sheet Border” on page 77
Insert Tolerance Block Select to insert a tolerance specifications block within the sheet border (ASME title 

block required); for more information, see “Editing a Tolerance Block” on page 85
Insert Projection Block Select to insert a projection block containing either a first angle or third angle 

projection symbol within the sheet border (ASME title block required)
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Basic Techniques
Using the Mouse
The easiest way to draw in the Vectorworks program is to use the mouse. Select the appropriate tool button and create 
an object in either the click-drag or the click-click mode, depending on the type of object.
In click-drag mode, click and continue to hold down the mouse button while you create an object; release the button 
when the object is the desired size and shape.

In click-click mode, click the mouse to mark the start point of an object, and then click again at each of the object’s 
corners or vertices.

The program defaults to click-click mode, and all procedures in this guide are based on click-click drawing. This 
preference can be changed in Vectorworks preferences.

Use the Data bar for accurate object placement and creation. See “Using the Data Bar” on page 125.

Moving Around
There are several ways to move around within a drawing file, which allows you to look at the whole drawing or at 
select portions of it.
~~~~~~~~~~~~~~~~~~~~~~~~~
Panning
Moving the Page Print Boundary
Zooming
Scrolling

Panning
Use the Pan tool to move the drawing around the drawing window, changing the area of display. When in an uncropped 
perspective projection, the Pan tool moves the viewpoint in the model while the line of sight remains centered in the 
window; see “Projection” on page 1142.

To pan around the drawing:

1. Click the Pan tool from the Basic palette.
2. Move the hand into the drawing window.
3. Click and hold down the mouse button, and drag the drawing around the screen.

The rulers move with the page. 
4. When the drawing shows the desired area, release the mouse button.

Areas of the drawing that were off the page do not display until the mouse is released.

Click 1

Release

Click 1

Click 2



  104 | Moving Around
Double-click the Pan tool to refresh the drawing view.

Panning with the Mouse Wheel
On a wheel-mouse, click and hold down the mouse wheel to pan at any time, regardless of which tool is currently 
selected.
This feature will not work properly if the wheel button has been assigned a custom function in the mouse setup. For 
example, if the wheel button is set to perform a delete when clicked, a wheel click in the Vectorworks program deletes 
rather than pans. (The specific setting required for this feature depends on the type of mouse being used.)

Panning with the Arrow Keys
Use the arrow keys on the keyboard to pan at any time, regardless of which tool is currently selected. Specify the arrow 
shortcut keys for panning in Vectorworks preferences (see “Edit Preferences” on page 49). Press the shortcut key 
combination once to move the drawing one half-screen in the direction of the arrow.
~~~~~~~~~~~~~~~~~~~~~~~~~
Moving Around

Moving the Page Print Boundary
The Move Page tool changes the position of the print boundary within the drawing area. Though the boundary moves, 
the rulers, user origin, and objects remain fixed. In 3D, the working plane does not move along with the boundary.

To move the page:

1. Click the Move Page tool from the Basic palette.
2. Click and drag the page outline to the desired location.

The original position of the page continues to display, helping to measure your movement.
3. Click to set the position of the page.
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Paste in Place works from user origin. If the page is moved, the image is placed in relation to the user origin, not the 
new page location.
Double-click the Move Page tool to set the page origin to be the same as the user origin.
~~~~~~~~~~~~~~~~~~~~~~~~~
The Print Area
Moving Around

Zooming
Zoom controls the visual scale of a drawing. It does not affect the physical size of objects as set by the layer scale. Like 
a magnifying glass, zoom controls how close or far away objects appear on the screen. Zoom in to get a close-up view 
of a detail, and zoom out to get a broader view of the whole drawing.
During a zoom operation, the drawing continues to display normally if possible. A complex drawing may not display in 
full detail during a zoom operation, but as soon as the zoom is complete, the drawing displays normally. When in an 
uncropped perspective projection, zooming moves the viewpoint in the model while the line of sight remains centered 
in the window; see “Projection” on page 1142.
The Vectorworks program includes zoom functionality through the mouse wheel, through buttons on the View bar, and 
through the Zoom tool on the Basic palette.

Zooming with the Mouse Wheel
On a wheel-mouse, roll the mouse wheel forward to magnify the drawing (the Zoom tool on the Basic palette need not 
be selected). Roll the mouse wheel backward to zoom out from the drawing.
The mouse wheel behavior is controlled by the Mouse wheel zooms setting in the Edit tab of the Vectorworks 
Preferences dialog box. If the wheel is set to scroll by default, you must press the Ctrl (Windows) or Option (Mac) key 
while you roll in order to zoom. See “Edit Preferences” on page 49 for details.

This feature will not work properly if standard scrolling is disabled in the mouse setup. For example, if the 
mouse’s scrolling size is set to “none,” mouse zooming in the Vectorworks program is disabled. (The specific 
settings required for this feature depend on the type of mouse being used.)

Zooming from the View Bar
From the View bar, click the Zoom button to double the magnification of the drawing (a single-click on this button 
performs the same function as a double-click on the Zoom tool on the Basic palette). To reduce the magnification by 
half, press the Alt key (Windows) or Option key (Mac) when you click the Zoom button. To zoom by a specific 
amount, enter a zoom factor in the View bar, or select one from the pull-down list.
If an object or objects are currently selected, the zoom is centered on those object(s). To zoom on a specific area of the 
drawing (with nothing selected), click in an open area and then click the Zoom button.

Zooming with the Zoom Tool
The Zoom tool has two modes.

Zoom In/Out Current Zoom

Marquee Interactive 
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With the Zoom tool selected, double-click anywhere in the drawing to automatically activate the Selection tool. 
Double-click the Zoom tool from the Basic palette to double the magnification of the drawing. The Zoom In 
button on the View bar performs the same action.

Marquee Mode

Select a portion of the drawing to magnify using marquee selection.

To marquee zoom:

1. Click the Zoom tool from the Basic palette.
2. Click Marquee mode.
3. Click and drag to create a marquee box around the portion of the drawing to magnify.
4. Click again to zoom in.

Vectorworks magnifies the selected section so that it fills the drawing window.

To zoom out, hold down the Option (Mac) or Alt (Windows) key while you draw a marquee box around a portion of the 
drawing. Click again to zoom out. The program reduces the magnification to display additional portions of the drawing 
around the selected section.

Interactive Mode

Choose an area of the drawing to magnify interactively.

Mode Description

Marquee Magnifies the portion of the drawing that is within the marquee area; in click-drag mode, 
simply click once (do not create a marquee box) to double the zoom factor.
To zoom out, hold down the Option (Mac) or Alt (Windows) key during the zoom.

Interactive Interactively zooms the drawing area while moving the mouse
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To interactively zoom:

1. Click the Zoom tool from the Basic palette.
2. Click Interactive mode.
3. Click in the drawing and hold down the mouse button (Mac) or left mouse button (Windows) while you move the 

mouse forward to zoom in on the drawing from the location of the click.
To zoom out, click in the drawing and hold down the mouse button (Mac) or left mouse button (Windows) while you 
move the mouse backward to zoom out of the drawing from the location of the click.
~~~~~~~~~~~~~~~~~~~~~~~~~
Moving Around
Normal Scale

Normal Scale
The Normal Scale command automatically displays the drawing file at 100% of its real-world scale. For example, if a 
drawing scale is set to 1:1, every inch on the monitor corresponds to an inch on paper. Normal scale is the scale at 
which the drawing is printed.
To set the drawing to normal scale:

1. Select View > Zoom > Normal Scale.
Vectorworks changes the view so that the objects’ screen size and print size are the same.

2. If the drawing size is larger than the monitor’s dimensions, scroll or pan around the drawing to see all elements.

Scrolling

Automatically Scrolling While Drawing
The Vectorworks program automatically scrolls the drawing area when an object is being drawn.
To use autoscroll:

1. Select any drawing tool.
2. Press and hold down the mouse button to begin drawing.
3. Drag the cursor on top of or past a scroll bar or ruler.

The drawing window scrolls in the direction of the cursor.
In click-click mode, if you do not hold down the mouse button while you draw, the autoscroll is halted if the cursor 
passes a scroll bar or ruler; this allows interaction with the scroll bars, tool palettes, and tool sets.

Using the Scroll Bars
Use the scroll bars to move the drawing around the screen. However, the scroll bars are best used for small movements, 
because they require the screen to redraw more frequently. For large movements, the Pan tool is faster. To display or 
hide the scroll bars, change the scroll bars setting in the Vectorworks Preferences dialog box.

Scrolling with the Mouse Wheel
On a wheel-mouse, press the Ctrl (Windows) or Cmd (Mac) key while you roll the wheel forward or backward to scroll 
the window up or down. To scroll the window left or right, press the Shift key while you roll.
The mouse wheel behavior is controlled by the Mouse wheel zooms setting in the Edit tab of the Vectorworks 
Preferences dialog box. The wheel can be set to scroll by default, so that no additional key must be pressed while you 
roll in order to scroll. See “Edit Preferences” on page 49 for details.
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This feature will not work properly if standard scrolling is disabled in the mouse setup. For example, if the 
mouse’s scrolling size is set to “none,” mouse scrolling in the Vectorworks program is disabled. (The specific 
settings required for this feature depend on the type of mouse being used.)

~~~~~~~~~~~~~~~~~~~~~~~~~
Moving Around

Undoing and Redoing Actions
Specify preferences to control how many actions can be undone and redone.

Undoing Actions
One or more of the most recent actions can be undone. Specify the number of actions that can be undone on the Session 
tab of Vectorworks preferences. See “Session Preferences” on page 52 for information on this tab. The maximum 
number of actions that can be undone is 100. Select Issue undo warnings to open a warning dialog box when 
attempting to undo an action that cannot be undone.
To undo recent changes:

Select Edit > Undo.
The most recent change is undone. Continue to select the Undo command to undo changes in the reverse order in 
which they were performed.
The higher the maximum number of undos, the more memory may be required.

Redoing Actions
Actions that have been undone can then be redone. The number of actions that can be redone is determined by how 
many undos were performed.
To redo actions that were undone:

Select Edit > Redo.
The most recent undo is reversed and the action is executed again. Continuing to select the Redo command will 
redo changes in the reverse order that they were undone.

Selecting Objects
Use the Selection tool from the Basic palette to select objects for the next command or edit operation. The Shift key 
and the Alt (Windows) or Option (Mac) key are modifiers for selection actions. Create rectangular, lasso, or polygonal 
marquees around objects to select single or multiple objects. The following table describes the various selection 
methods.

Method Selection Action

Click Standard selection method; selects a single object only
Option-click (Mac) or Ctrl-click 
(Windows)

Creates a copy of the object and places it directly over the selected object, 
unless the preference has been disabled (see “Edit Preferences” on page 49)

Shift-click Selects multiple objects as each object is clicked; also can be used to deselect 
one or more objects without affecting other selected objects

Option-drag (Mac) or Ctrl-drag 
(Windows)

Places a copy of the object where the mouse button is released

Rectangle, lasso, polygon marquee Selects all objects that are completely contained within the marquee
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To deselect all selected objects, double-click on the Selection tool, click in an empty area of the drawing, or press the 
“x” key twice in rapid succession.
~~~~~~~~~~~~~~~~~~~~~~~~~
The Selection Tool
Select All
Previous Selection
Coincident Object Selection
Selection and Pre-selection Indicators

The Selection Tool
Use the Selection tool to select objects, to move and resize objects in any view, and to insert objects in or next to a wall.
In a rendered 3D view, hidden geometry located behind solid objects cannot be directly selected. This makes it easier to 
select solid objects without the interference of hidden objects. To select hidden geometry, use X-ray Select mode (see 
“X-ray Select Mode” on page 113) or the clip cube feature (see “Viewing a Model with the Clip Cube” on page 1155).
For marquee selection, press the Option (Mac) or Alt (Windows) key while drawing the marquee to select all objects 
that intersect the marquee.

Shift-marquee Reverses the selection status of objects inside a marquee; if objects inside the 
marquee are selected, this method deselects those objects

Option-marquee (Mac) or 
Alt-marquee (Windows)

Selects all objects that the marquee passes through, as well as those contained 
within the marquee

Invert Selection command (on the 
Edit menu)

Deselects everything that is currently selected, and selects all visible objects in 
editable layers and classes that are not currently selected

Double-click Reactivates the working plane on which a planar object was created; may also 
have other behavior such as symbol editing or polygon reshaping, depending 
on selected settings

Select Vertex in Object Info 
Palette (context menu command)

For vertex-based objects, selects a single vertex for editing on the Object Info 
palette; see “Editing Vertex-Based Objects” on page 1002

Force Select (context menu 
command)

Activates the object’s class, layer, or both (as necessary) and selects the object, 
even if the object could not normally be selected due to a different layer scale, 
or the current class or layer option settings

Method Selection Action

Rectangular 
Marquee

Wall 
Insertion Lasso Marquee

Unrestricted Interactive 
Scaling

Connected Walls 
(Vectorworks Design 
Series required)

Disabled Interactive
Scaling

Single Object 
Interactive Scaling

Polygonal 
Marquee
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Mode Description

Disabled Interactive Scaling No reshape handles display for a selected object, so that it can be dragged from any 
point without accidentally affecting its size

Single Object Interactive 
Scaling

Allows resizing by dragging a reshape handle that displays on a single selected 
object.

Allows symbols to be scaled, similar to the Scaling option in the Object Info palette, 
unless the Allow Interactive 2D symbol scaling Vectorworks preference has been 
disabled; see “Edit Preferences” on page 49.

Page-based symbols can only be scaled symmetrically.
To rotate certain objects (such as rectangles, rounded rectangles, ovals, text objects, 
bitmaps, and PICT images), press the Option key (Mac) or Alt key (Windows) while 
dragging a reshape handle.

Unrestricted Interactive 
Scaling

Allows resizing of multiple objects by dragging a reshape handle that displays on 
one of the selected object(s)

 Wall Insertion Allows symbols and plug-in objects that are already on drawing to be placed into a 
wall segment. When disabled, symbols can be moved next to or on a wall without 
becoming part of the wall. See “Wall Insertion Mode” on page 246 for more 
information. 

Rectangular Marquee Creates a marquee box around objects when selecting. Click to set the start point, 
drag the mouse in the desired direction, and release to set the end point. All objects 
within the marquee are selected.

Drag the middle handle to
the right to reduce the

rectangle’s width

Drag the lower left handle
upward and to the right to

rotate the rectangle

Drag the middle
handle to the right to

reduce the width of
both rectangles
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To select objects:

1. Click the Selection tool from the Basic palette.
2. Select the appropriate mode.
3. Select the desired object(s).

Click here for a video tip on this topic (Internet connection required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Selecting Objects
Select All
Previous Selection
Coincident Object Selection
X-ray Select Mode
Selection and Pre-selection Indicators

Select All
The Select All command selects all visible objects in editable layers and classes. The active layer is always editable, 
but other layers can be editable if they are visible and if the Layer Options are set to Show/Snap/Modify Others. For 
more information about setting layer and class visibility and layer and class options, see “Setting Visibilities in the 
Organization Dialog Box” on page 193, “The Visibility Tool” on page 195, and “Setting Class and Design Layer 
Options” on page 193.

Lasso Marquee Creates a free-form marquee, allowing a more exact selection of irregular shapes. 
Click to set the start point, drag the mouse in the desired direction, and release to set 
the end point. All objects within the marquee are selected.

Polygonal Marquee Creates a marquee with an irregular polygonal shape. Click to set the start point, and 
then continue clicking to define the shape. Double-click to finish the marquee. All 
objects within the marquee are selected.

Connected Walls 
(Vectorworks Design Series 
required)

Connected Walls mode becomes available when the Vectorworks Architect or 
Landmark product is installed. See “Moving Connected Walls” on page 541 for 
information.

Mode Description

http://www.youtube.com/watch?v=PTMW8iOXOrk
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To select all objects in the drawing area:
Select Edit > Select All.
Alternatively, right-click (Windows) or Ctrl-click (Mac) on the drawing area, and select Select All from the 
document context menu.
The program selects all visible objects that can be modified. Each of these selected objects is displayed with 
highlighting. Locked objects are also selected so they can be unlocked for modification.

~~~~~~~~~~~~~~~~~~~~~~~~~
Selection and Pre-selection Indicators
Selecting Objects
The Selection Tool

Previous Selection
The Previous Selection command reselects the set of objects that were most recently selected. This is especially useful 
if a large number of objects were accidentally deselected.
To reselect previously selected objects, select Edit > Previous Selection.
~~~~~~~~~~~~~~~~~~~~~~~~~
Selection and Pre-selection Indicators
Configuring Interactive Display
Selecting Objects
The Selection Tool

Coincident Object Selection
When the edges or points of multiple objects exist at the same location on the drawing, you might not be able to simply 
click with the Selection tool to select the object(s) you need. The desired object might have an edge that coincides with 
the edge of another object, for example. In this situation, an asterisk (*) is added to the various selection cursors to 
indicate that multiple objects exist at the current location, as follows.

You can then use either the Coincident Selection key or the Select Coincident Objects command from the context 
menu to open a dialog box from which you can select the appropriate objects. Coincident selection can work in 
conjunction with X-ray Select mode when coincident objects are hidden by rendered solids (see “X-ray Select Mode” 
on page 113).
To select one or more coincident objects:

1. Click the Selection tool from the Basic palette.
2. When the cursor indicates that multiple objects are available beneath it, press and hold the Coincident Selection 

key (J by default) and click the drawing. Alternatively, right-click (Windows) or Ctrl-click (Mac) and select Select 
Coincident Objects from the object context menu.
The Coincident Selection key can be changed in the Workspace Editor; see “Modifying Snapping and Mode 
Shortcuts” on page 1842.

3. The Select dialog box opens. Each object available for selection at that point displays in a list, in top to bottom 
stacking order.

4. Click to select one or more items from the list; the selected objects are highlighted in the drawing.
5. Click OK to close the dialog box and select the objects.

Move 
cursor

Selection 
cursor

Add Selection 
cursor

Resize 
cursor
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Alternatively, double-click an item from the list to select it in the drawing.
~~~~~~~~~~~~~~~~~~~~~~~~~
Selection and Pre-selection Indicators
Selecting Objects
The Selection Tool
X-ray Select Mode

X-ray Select Mode
This feature is available on all Mac systems, and on Windows systems only when the GDI+ imaging preference is 
enabled. (See “Vectorworks Display Preferences” on page 50 for information about setting this preference.)
A 2D object in Top/Plan view can have a fill that obscures objects beneath it on the same design layer or on other 
visible layers. In a 3D view, rendered objects hide or “occlude” objects behind them. To make it easier to see these 
hidden objects and select them with the Selection tool, use the X-ray Select mode. When the designated key is pressed 
in Top/Plan view, all 2D objects with fill become semi-transparent. In a 3D rendered view, pressing the key creates an 
area around the cursor where you can view the objects behind the solid object(s) in Wireframe mode, as if you had 
X-ray vision.

This is a convenient way of selecting objects without switching to Wireframe render mode.

In addition to the Selection tool, the X-ray Select mode can be used with other tools that require the selection of 
objects, such as the Eyedropper, Visibility, and Select Similar tools.
To see and select objects with the X-ray Select mode:

1. Click the Selection tool from the Basic palette.
2. Press and hold the X-ray Select mode key (the B key, by default). In Top/Plan view, all 2D objects that have a fill 

become semi-transparent (edge lines are unaffected); in a 3D view, rendered objects display in Wireframe mode 
near the cursor.
The X-ray Select mode key can be changed in the Workspace Editor; see “Modifying Snapping and Mode 
Shortcuts” on page 1842.
The opacity of fills in X-ray Select mode can be changed in the Interactive Appearance Settings dialog box; see 
“Configuring Interactive Display” on page 116.

3. Click or Shift-click to select objects as needed. Objects are selected the same way they are normally, except that a 
filled object that is beneath another object behaves as if it has no fill; you must click the edge of the object to select 
it.

4. Release the key to exit X-ray Select mode.
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Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Selection and Pre-selection Indicators
Selecting Objects
The Selection Tool
Coincident Object Selection

Selection and Pre-selection Indicators
When you move the cursor over the objects in a drawing, and when you select objects, highlighting and handles 
provide information about the current state of the objects. These indicators can be customized as needed in the 
Vectorworks preferences. See “Interactive Preferences” on page 56 for details. 

Highlighting
Highlighting can indicate the following information about an object in a drawing.

• Currently selected
• Currently “pre-selected” because it is under the cursor (or within the selection marquee)
• Locked
• On an inactive layer
• Causing one of the displayed “snap points”
• Can be acted upon by the currently active tool

In the Vectorworks preferences, there are several options to customize the highlighting. 
• The different types of highlighting can be enabled and disabled individually.
• The highlighting for selected objects can be animated.
• The timing of the highlighting for pre-selected objects can be adjusted.
• The color, opacity, and size of each type of highlighting can be adjusted.

By default, all highlighting options are enabled, and selected objects display as shown in the following illustration.

Layer 1 has an exterior view of a building made from filled 
objects. Even though the layer options are set to Show/
Snap/Modify Others, the objects on Layer 2 are not visible 
and cannot be selected by clicking with the Selection tool.

Layer 2 has a section view of the same building, also 
made from filled objects. When the X-ray Select mode 
key is pressed, all filled objects become transparent. 
The objects on Layer 2 are visible and can be selected 
by clicking with the Selection tool.

http://www.youtube.com/watch?v=FCH4mCTk5rk


Selecting Objects |  115
In a rendered 3D view, solid objects “occlude” or hide objects behind them. Highlighting of occluded objects is set, by 
default, to be less opaque than that of objects not occluded behind other objects.

Handles
In addition to highlighting, square “handles” can display on selected objects. The appearance of the handles is 
controlled by the Selection highlighting setting on the Interactive tab in the Vectorworks preferences. Also, the colors 
of the handles can be customized.
If selection highlighting is enabled (the default setting):

• Handles display on a selected object if the object can be edited with the active tool
• Unlocked objects on the active layer have blue handles
• Unlocked objects on an inactive layer have white handles
• Locked objects have no handles (since they cannot be edited)
• Handles can be used as reshape points

If selection highlighting is disabled:
• Handles display on all selected objects
• Unlocked objects on the active layer have blue handles
• Locked objects on the active layer have gray handles
• All objects on an inactive layer have white handles

Sample highlighting with several types of objects selected 

Objects highlighted in dark 
orange are on an inactive layer

Objects highlighted in gray 
are locked

Objects highlighted in orange 
are on the active layer and are 
not locked

The cursor is snapping to the
circle’s center; the circle has

gray dashed line highlighting,
in addition to the orange

selection highlighting

The selected stair is partially occluded by the walls and 
other objects; selection highlighting is not as opaque in 
those areas
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• Some of the handles can be used as reshape points, and some cannot, depending on the object, and on which tool 
is active

~~~~~~~~~~~~~~~~~~~~~~~~~
Configuring Interactive Display
Selecting Objects

Configuring Interactive Display
You may find it helpful to customize the appearance of interactive elements in the program, including general elements, 
object highlighting, SmartCursor elements, and snap points.
To configure the appearance of interactive elements:

1. Select Tools > Options > Vectorworks Preferences. On the Interactive tab of the Vectorworks Preferences dialog 
box, click Interactive Appearance Settings.
Alternatively, select Tools > SmartCursor Settings. On the General tab of the SmartCursor Settings dialog box, 
click Interactive Appearance Settings.
The Interactive Appearance Settings dialog box opens.

2. Select either the Standard Background or Black Background tab, depending on whether the black background 
display preference is enabled (see “Vectorworks Display Preferences” on page 50). The same elements can be 
customized for both background types, except that there are no options for setting background colors for black 
backgrounds.

Element Description Example

Clip Cube
Edges Sets the color for edges where surfaces intersect a face 

of a clip cube

With three walls selected, the locked 
wall (bottom) has a gray handle on the 
right side; the unlocked walls have blue 
handles

With three walls selected, the locked 
wall (bottom) is highlighted in gray; there 
are no handles because the objects 
cannot be reshaped with the active tool

The selected wall is highlighted in 
orange; blue handles indicate that 
the wall can be reshaped with the 
active tool

Selection highlighting enabled Selection highlighting disabled 
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Solid Fill Sets the color for the area where solid objects intersect 
a face of a clip cube

General
Active Layer Plane Sets the color and opacity of the active layer plane grid

Background - 3D Views
(Standard Background only)

Sets the background color of the drawing area for 
design layers in 3D views

Background - Perspective 
Horizon Ground

Sets the ground color and ground horizon color when 
in non-cropped perspective view; the foreground color 
gradually transitions to the background color as a 
gradient in the direction of the horizon

Background - Perspective 
Horizon Sky

Sets the sky color and sky horizon color when in 
non-cropped perspective view; the foreground color 
gradually transitions to the background color as a 
gradient in the direction of the horizon

Background - Sheet Layers
(Standard Background only)

Sets the background color of sheet layers

Background - Top/Plan
(Standard Background only)

Sets the background color of the drawing area for 
design layers in Top/Plan view

Element Description Example
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Editing Modes Border Sets the color, opacity, and thickness of the colored 
border when in an editing mode

Grid Sets the color and opacity of the reference grid

Page Boundary Sets the color and opacity of the page boundary border

Repetition Opacity Sets the opacity for the repetitions of the selected line 
type or tile object, which are displayed when a line type 
or tile resource is being edited

Reshape Handles - Active 
Layer

Sets the color of the square handles that can be dragged 
to reshape a selected object on the active layer

Reshape Handles - Inactive 
Layer

Sets the color of the square handles that can be dragged 
to reshape a selected object on an inactive layer

Working Plane Sets the color of the working plane and opacity of its 
fill and frame, as well as the opacity and thickness of 
the working plane axes

X-ray Select Mode Sets the opacity of the objects in X-ray Select mode

Object Highlighting
Action Sets the color, opacity, and thickness of the 

highlighting for objects being modified

Active Layer Sets the pattern, forecolor, backcolor, opacity, and 
thickness of the highlighting for an object that is 
selected on the active layer

Inactive Layer Sets the pattern, forecolor, backcolor, opacity, and 
thickness of the highlighting for an object that is 
selected on an inactive layer

Element Description Example

Repeated 
object

Selected 
tile object
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Automatic Plane Source Sets the color and opacity of the automatic working 
plane

Locked Sets the pattern, forecolor, backcolor, opacity, and 
thickness of the highlighting for an object that is locked

Pre-Selection - Active Layer Sets the color, opacity, and thickness of the 
highlighting for an object that is pre-selected on the 
active layer; an object can be pre-selected by being 
either under the cursor’s selection box, or inside a 
selection marquee

Pre-Selection - Inactive 
Layer

Sets the color, opacity, and thickness of the 
highlighting for an object that is pre-selected on the 
inactive layer

Pre-Selection - Locked Sets the color, opacity, and thickness of the 
highlighting for an object that is locked

Snap Object Sets the color, opacity, and thickness of the 
highlighting for an object that is being snapped to; the 
highlighting is always a dashed line

Tool Highlighting Sets the color, opacity, and thickness of the 
highlighting for an object that can be edited by the 
active tool

Occluded 3D Graphics Sets the opacity of feedback graphics, such as 
highlighting, snapping, selection indication, and some 
preview graphics, when occluded by a rendered 3D 
solid

SmartCursor
Acquisition Hints Sets the color, opacity, and thickness of the graphical 

hints which display near the cursor to show when a 
smart point, smart edge, or vector lock can be acquired 
or released

Cue Background Specifies the background color and opacity of 
SmartCursor cues

Cue Text Sets the color and size of SmartCursor text

Datum Indicator Sets the color, opacity and thickness of the datum 
indicator 

Element Description Example
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Extension Lines - Angle Sets the color, opacity and thickness of angle extension 
lines

Extension Lines - Smart 
Point

Sets the color, opacity and thickness of smart point 
alignment lines (the selected color may be overridden 
by the default X, Y, and Z axis colors)

Planes Sets the color and opacity of angle and alignment 
planes (the selected color may be overridden by the 
default X, Y, and Z axis colors)

Selection Box Sets the color, opacity, and thickness of the selection 
box around the SmartCursor

Smart Edges Sets the color, opacity and thickness of smart edge lines

Smart Points Sets the color, opacity, and thickness of smart points

Snap Box Sets the color, opacity, and thickness of the snap box 
around the SmartCursor

Vector Locks Sets the color, opacity, and thickness of vector locks

Snap Points
Available Sets the color, opacity, and thickness of snap points 

available near the cursor and within the snap box

Element Description Example
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3. Click the column heading to sort by interface element, if desired. Select the element to change, and then set the 
parameters that display to the right of the element list as needed. Different parameters display, depending on the 
element selected.

Click to show/hide the parameters.

4. Click OK to save the settings, which apply to all Vectorworks drawings.
5. From the Vectorworks Preferences dialog box, click OK again to save the preferences.

~~~~~~~~~~~~~~~~~~~~~~~~~
Selection and Pre-selection Indicators
Selecting Objects
Setting Snapping Parameters
Drawing with Snapping
The Selection Tool

Congestion Indicator Sets the color, opacity, and thickness of the snap box 
when there are too many available snap points around 
the SmartCursor (using the snap loupe is recommended 
in this situation; see “Using the Snap Loupe” on 
page 148)

Current Sets the color, opacity, and thickness of the current 
snap indicator

Obtained Sets the color, opacity, and thickness of the acquired 
snap point

Special Sets the color, opacity, and thickness of snap point 
hints such as midpoint, center, along line, and tangent 
snaps

Reset Restores the default settings for all interface elements

Parameter Description

Pattern / ForeColor / BackColor To use a solid color, select the color from the ForeColor menu; then from the 
Pattern menu, select the solid pattern for that color
To use a pattern, select the ForeColor and BackColor colors from the menus 
(see “Selecting a Color from a Color Palette” on page 1135); then select a 
Pattern

Color Select the color (see “Selecting a Color from a Color Palette” on page 1135)
Opacity Drag the slider right to increase or left to decrease the opacity of the interactive 

element
Size Drag the slider right to increase or left to decrease the width of the interactive 

element

Element Description Example
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Selecting Similar Objects
Use the Select Similar tool to select objects that have features in common with a specific object. This can be useful if 
you need to move or modify a large number of similar objects, such as windows. It can also make it easier to locate 
similar objects in a drawing that is very crowded.

Walls and objects within walls cannot be selected at the same time. Therefore, sometimes the objects selected by 
this tool may not be as expected. For example, you cannot select a set of walls and then use Current Selection 
mode to select all windows within those walls.

To select similar objects:

1. To select from a specific set of objects, select the objects first.
2. Click the Select Similar tool from the Basic tool palette.
3. Click Preferences from the Tool bar to specify the set of object attributes to match. The Select Similar Preferences 

dialog box opens.
Alternatively, select a set of saved attributes from the Settings list on the Tool bar.

Click to show/hide the parameters.

Mode Description

Select any Object Selects objects that are similar to the clicked object
Current Selection Selects objects that are similar to the clicked object, within a group of preselected objects
Preferences Sets the default parameters to be used for the tool
Settings Sets the group of parameters to be used for the tool—either the currently active settings, 

or a selection from the list of saved settings

Parameter Description

Saved Settings Options
Settings Select <Active Settings> to use the attributes currently selected in the dialog box; to 

use a set of saved attributes, select them from the pull-down list
Save Opens a dialog box to name and save the currently selected attributes so that they can 

quickly be selected as a set
Manage Opens the Saved Settings dialog box to rename or delete sets of saved tool attributes

All • Checked box: All attributes in the group are selected; click to deselect all attributes 
in the group.

• Empty box: No attributes in the group are selected; click to select all attributes in 
the group.

• Box displays  (Windows) or  (Mac): One or more attributes in the group are 
not selected; click to select all attributes in the group.

Select any Object

PreferencesCurrent Selection

Settings list



Selecting Similar Objects |  123
4. Select the similar attributes to use for the selection, and click OK.
5. Click the object that is similar to the objects you want to find.

An alert displays if the clicked object is not appropriate for the selected attributes (for example, if the Font 
attribute is selected, but a plant object is clicked).

6. The similar objects are selected. 

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Managing Saved Settings

Managing Saved Settings
If you have saved attributes to use with the Select Similar tool, use the Manage button on the Select Similar 
Preferences dialog box to rename or delete these saved settings when needed.
To manage saved settings for the Select Similar tool:

1. Select the Select Similar tool from the Basic tool palette, and then select Preferences on the Tool bar. The Select 
Similar Preferences dialog box opens.

2. Click Manage.
The Saved Settings dialog box opens. Select the set of saved attributes to change.

Click to show/hide the parameters.

Fill Attributes Selects objects with matching fills, including foreground and background colors, styles 
(pattern, hatch, gradient, or image fill), and textures

Text Attributes Selects text objects, dimensions, or plug-in objects with matching text attributes, 
including font, size, font style, alignment, and spacing

Wall Attributes Selects walls and round walls with matching thicknesses and fill styles
Pen Attributes Selects objects with matching pen foreground and background colors, styles (solid, 

pattern, or line type), and line weights
Other Selects objects with various other matching attributes
Line End Marker Selects line objects with matching end markers, including marker styles and sizes

Parameter Description

With the Select Similar tool set to select by similar object type, click on 
a window

All window objects are selected (including those behind solid objects)

http://www.youtube.com/watch?v=SzRoWdiBEH0
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3. Click OK to close the Saved Settings dialog box. Click OK again to close the Select Similar Preferences dialog 
box.

~~~~~~~~~~~~~~~~~~~~~~~~~
Selecting Similar Objects

Creating Similar Objects
The Create Similar Object command is an easy way of creating an object that matches an object that is already in a 
drawing. The associated tool, tool mode, and object attributes and parameters are automatically set to create an object 
that matches the source object.
To create an object similar to an existing object:

1. With the cursor over the source object, either right-click (Windows) or Ctrl-click (Mac) and select Create Similar 
Object from the context menu. The source object can be visible or grayed, and does not need to be in the current 
layer.
Alternatively, press the Ctrl + Alt (Windows) or Cmd + Option (Mac) shortcut key combination while clicking 
over the source object.

2. The tool required to create the object is automatically activated.
Any tool settings, as well as any global settings used by the tool, change to match the source object, as shown 
here.

Parameter Description

Rename Select and enter a new name for the set of attributes. If the entered name is already assigned to 
another set of attributes, you are prompted to confirm that you want to replace the existing set 
with the set being saved.

Delete Select to delete the set of attributes. You are prompted to confirm that you want to delete the 
saved settings.

Source Object or 
Attribute

Result

Graphical attributes Updates the global Attributes palette settings to match those of the source object, 
including by-class or class settings

Class Sets the active class to that of the source object
Layer Sets the active layer to that of the source object, if the Vectorworks preference Change 

active layer for Similar Object Creation is enabled; see “Session Preferences” on 
page 52

Text, or object with 
text set by global font 
settings

Matches the global font settings of the source text or object text
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3. Create the similar object in the same way the source object was created.
Because the Attributes palette may have changed to match the source object, the Attributes palette utility menu 
can quickly set or change attributes globally if needed (see “Setting Global and Default Attributes” on page 1094).

Using the Data Bar
Use the Data bar when you draw to lock certain values for an object, such as the length of a circle radius, the angle of a 
wall, the length of a hemisphere radius, or the height of an extruded rectangle. The fields that are available on the Data 
bar depend on the active tool and on the action being performed.

The data displayed in the bar is gathered from the feedback segment of the object being created. The coordinates are 
relative to a floating datum, if one exists; otherwise the coordinates are absolute. The more common Data bar fields are 
described in the following table; other fields that can display are described where their use is relevant.
Click to show/hide the parameters.

Object, such as a 
rectangle, with a 
rotated creation mode

Matches rotated/non-rotated creation mode of source object

Symbols Makes the source symbol the active symbol, and activates the appropriate symbol 
insertion tool

Plug-in object Sets the tool parameters to those of the source plug-in object
Wall Matches the wall style of the source wall

Parameter Description

2D Parameters
Delta X The offset distance from the previous click or position along the X axis
Delta Y The offset distance from the previous click or position along the Y axis
L The length or distance from 0,0, or the radius of the object that is being drawn
A The angle or rotation of the object that is being drawn

Source Object or 
Attribute

Result

Horizontal location of the cursor
in the drawing window

Vertical location of the cursor in 
the drawing window

Fixed 2D Data bar
(on the Tool bar)

Floating 2D Data bar
(follows the cursor)

2D Data bar 

Location of the cursor relative 
to the working plane

Floating 3D Data bar
(follows the cursor)

Fixed 3D Data bar
(on the Tool bar)

Offset of the cursor relative to 
the working plane

3D Data bar 
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The location and behavior of the Data bar fields can be adjusted by options listed under Windows > Data Bar Options 
or from the Data Bar and Edit Group Options list (see “Data Bar and Edit Group Options” on page 127 for details).
~~~~~~~~~~~~~~~~~~~~~~~~~
Drawing with the Data Bar
Data Bar and Edit Group Options

Drawing with the Data Bar
To draw an object with the Data bar:

1. There are two different ways to activate the Data bar for drawing. 
• Select a drawing tool and click once to begin to draw the object. Press the Tab key to activate the first field in 

the Data bar, or press Shift+Tab to activate the last field. Alternatively, if the Data bar options are set so that 
instant activation is enabled, type the value for the first field in the Data bar to activate it.

• Select a drawing tool and press Tab to activate the first field in the Data bar. After entering the data, click to 
begin drawing.

In click-drag drawing or moving operations, after you press Tab or Shift+Tab to activate the Data bar field, you 
can release the mouse button for ease of data entry. Complete the operation with a mouse click or press the Enter 
key twice.

2. Enter values in the appropriate field(s), using the keys as follows.

X The X (horizontal) location of the cursor in the drawing window
Y The Y (vertical) location of the cursor in the drawing window

3D Parameters
WP A The angle or rotation of the object that is being drawn relative to the working plane X axis
X’ The absolute location of X’ in working plane coordinates
Y’ The absolute location of Y’ in working plane coordinates
Z’ The absolute location of Z’ in working plane coordinates (applies to 3D objects only)
L The length or distance of the object that is being drawn
Z The Z (depth) of the object being drawn
Ctr X The center of the object along the X axis
Ctr Y The center of the object along the Y axis
Ctr Z The center of the object along the Z axis
Delta X’ The offset distance from the previous click or position of X’ in working plane space
Delta Y’ The offset distance from the previous click or position of Y’ in working plane space
Delta Z’ The offset distance from the previous click or position of Z’ in working plane space
Delta X The offset distance from the previous click or position of X
Delta Y The offset distance from the previous click or position of Y
Delta Z The offset distance from the previous click or position of Z
Radius The radius of the object being drawn
Height The height of the object being drawn

Parameter Description
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To clear an entry before it is set, press the Backspace key. The previous value in that field redisplays.
If the SmartCursor option is enabled in Vectorworks preferences, a dotted line displays to represent the location of 
the values entered for the X, Y, and Z axes.

3. A vector lock (red dashed line) displays to represent the location of the values entered in the Data bar.
See “Creating Vector Locks” on page 147 for more information.

4. To complete the object according to the values you entered, click the mouse button. For non-path objects, you can 
also press Enter to complete the object if the focus is in the drawing area, or press Enter twice to complete the 
object if the focus is in the Data bar. For path objects, such as polygons, walls, and dimensions, you may need to 
click to complete the object.

~~~~~~~~~~~~~~~~~~~~~~~~~
Using the Data Bar
Data Bar and Edit Group Options

Data Bar and Edit Group Options
The Data bar is controlled by options on a drop-down list on the right side of the Tool bar. Options for editing groups 
are also provided in this list. The Data Bar and Edit Group Options list is enabled by default on the Quick Preferences 
menu on the Tool bar; therefore, it displays as a button to the left of the Quick Preferences menu. The Data Bar 
Options and Edit Group Options can also be selected from the Window menu.

Key Action

Enter • When the focus is in a Data bar field, sets the value that is currently displayed, and moves the focus 
to the drawing area

• When the focus is in the drawing area, completes the object (or completes the current segment of 
the object, for path objects such as polygons, walls, and dimensions)

Tab • When the focus is in a Data bar field, sets the entered value and moves to the next field (if no value 
was entered, the field is not set)

• When the focus is in the drawing area, moves the focus to the first field in the Data bar
Shift+Tab • When the focus is in a Data bar field, sets the entered value and moves to the previous field (if no 

value was entered, the field is not set)
• When the focus is in the drawing area, moves the focus to the last field in the Data bar
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Menu Command Description

Location of the Data bar fields
Use floating Data bar The Data bar floats with the cursor in the drawing area
Use floating Data bar only when tab 
key is pressed

The Data bar floats with the cursor only when the Tab key is pressed; 
otherwise the bar does not display

Do not use floating data bar - show 
data bar fields on fixed data bar

The Data bar displays on the top left side of the window, at the top of the 
Tool bar

Activation of the Data bar
Allow numeric keypad entry for 
instant Data bar activation

When the floating Data bar is displayed, enter numbers on the keyboard 
or numeric keypad to activate the first field

Do not allow numeric keypad entry 
for instant Data bar activation

When the floating Data bar is displayed, enter numbers on the keyboard 
only to activate the first field

Do not allow instant Data bar 
activation

When the floating Data bar is displayed, press the Tab key to activate the 
first field

Field display on the Data bar
Show only primary fields on Data bar Show only the primary data fields (for example, L and A for circles)
Show primary and secondary fields 
on data bar

Show all fields except the cursor location fields (X and Y)

Data Bar and Edit 
Group Options list

Quick Preferences menu

Edit Group Options

Data Bar Options
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~~~~~~~~~~~~~~~~~~~~~~~~~
Using the Data Bar
Drawing with the Data Bar
Setting Quick Preferences

Show primary secondary, and cursor 
location fields on data bar

Show all fields

Field cycling options
Auto cycle to non-displayed fields 
when tabbing past last field

When some of the data fields are hidden, press the Tab key in the last 
visible field to make the non-displayed fields become visible 

Do not auto cycle to non-displayed 
fields when tabbing past last field

When some of the data fields are hidden, press the Tab key in the last 
visible field to return to the first field

Location of the floating Data bar
Show floating Data bar below 
SmartCursor cues

When the floating Data bar is enabled, displays the Data bar below the 
SmartCursor cues (below the cursor)

Show floating Data bar above 
SmartCursor cues

When the floating Data bar is enabled, displays the Data bar above the 
SmartCursor cues (above the cursor)

Data bar activation on datum creation
Show floating Data bar after datum 
creation

When the floating Data bar is enabled, displays the Data bar 
automatically after a datum is set

Do not show floating Data bar after 
datum creation

The floating Data bar does not automatically display after a datum is set. 
Press the Tab key to display the floating Data bar.

Display of the Exit Group button
Use large exit group button When a group is being edited, show a large button with the label Exit 

Group in the upper right corner of the drawing area
Use small exit group button When a group is being edited, show a small button with an arrow icon in 

the upper right corner of the drawing area
Exit group options

<Esc><Esc> exits group When a group is being edited, pressing the Escape key twice exits the 
editing window

<Esc><Esc> does not exit group When a group is being edited, pressing the Escape key twice does not 
exit the editing window

Menu Command Description
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Drawing with Snapping
SmartCursor snapping allows you to draw with precision in both 2D and 3D. Used in conjunction with drawing tools, 
the SmartCursor uses snap indicators, hints, extension lines, text (SmartCursor cues), and sounds, and then precisely 
snaps the cursor based on the snapping categories enabled in the Snapping palette.
~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Snapping Parameters
Snapping Techniques
SmartCursor Cues

Setting Snapping Parameters
The Snapping palette manages SmartCursor snapping; the on-screen feedback which displays while drawing is based 
on the snapping categories enabled in the Snapping palette. Different drawing tasks may require a variety of snapping 
combinations. A snapping category is enabled by clicking the desired tool from the Snapping palette. Each tool toggles 
to turn the snapping category on or off.
Snapping categories can be used individually or combined for precise drawing and snapping. For example, snap to 
object points and snap to the grid to find points which are both on an object and on a grid line. Snapping can also be 
combined with Data bar input to find a specific snap point along a defined location in the drawing area.
Snapping is available for both 2D and 3D tools; however, Snap to Tangent only applies to 2D tools, and Snap to 
Working Plane only applies to 3D tools. 
The snapping parameters of most of the snapping tools are set in the SmartCursor Settings dialog box. Most of these 
settings are considered application settings, and apply to any file opened in the Vectorworks program. Certain settings 
are considered document settings and are saved with the file; these include grid dimensions, alternate angle extension 
lines, datum and smart edge offset, and distance snap settings. Some of the snapping tools do not have additional 
parameters, and are simply toggled on or off.
When drawing, it may become necessary to temporarily suspend SmartCursor snapping. Press and hold the ‘ key (back 
quote key) to suspend all snapping. The snapping settings are retained, and snapping resumes when the ‘ key is no 
longer pressed. The shortcut key for suspending snapping can be customized; see “Modifying Snapping and Mode 
Shortcuts” on page 1842.
To set up and activate snapping categories:

1. If the Snapping palette is not open, select Window > Palettes > Snapping.
The Snapping palette opens. The last tool on the palette is different depending on whether a 2D or 3D tool is 
currently active.

2. Double-click a snapping tool to open the SmartCursor Settings dialog box with specific snapping parameters for 
that tool. Some of the tools do not have any additional parameters.
The SmartCursor Settings dialog box can also be opened by selecting Tools > SmartCursor Settings. Each tab of 
the dialog box is described in the following sections.

3. Enter the desired criteria, and then click OK to set.
The criteria are described in the following sections.

2D Snapping 
palette

3D Snapping 
palette

Snapping suspended 
with back quote key



  132 | Drawing with Snapping
4. Click a snapping tool to activate it.
Snapping palette shortcut keys can be set in the Workspace Editor; see “Modifying Snapping and Mode Shortcuts” 
on page 1842.
Different combinations of constraints and snapping parameters are required for different drawing tasks. Select the 
Tools > Custom Tool/Attribute command to easily create a script with the current SmartCursor settings and 
active tools on the Snapping palette. Execute the script by double-clicking on it from the Resource Browser to 
quickly change snapping parameters and settings. See “Creating Custom Tool/Attribute Scripts” on page 1773 for 
more information.

~~~~~~~~~~~~~~~~~~~~~~~~~
General Snapping
Grid Snapping
Object Snapping
Angle Snapping
Smart Points Snapping
Smart Edge Snapping
Distance Snapping
Snap to Intersection
Snap to Tangent (2D Only)
Snap to Working Plane (3D Only)
Drawing with Snapping
SmartCursor Cues
Configuring Interactive Display

General Snapping
The parameters on the General tab specify global SmartCursor functionality.
To set general snapping parameters:

1. Select Tools > SmartCursor Settings, or double-click a Snapping palette tool that has additional parameters.
The SmartCursor Settings dialog box opens. Click the General tab.

Click to show/hide the parameters.

Parameter Description

Show SmartCursor Cues Displays SmartCursor cues while drawing. The cues displayed depend on the 
combination enabled in the Snapping palette, as well as the current cursor position.

Show Snap Points Displays temporary graphical hints to indicate that a snap point is available; see 
“Snapping Indicators” on page 144 for more information. Deselect to hide snap points.

Zoom Line Thicknesses 
in Snap Loupe

When using the snap loupe (see “Using the Snap Loupe” on page 148), sets the line 
thicknesses relative to the zoom level so that objects display normally in the loupe 
view

Snap to Combined Page 
Area

Snaps to the edges and center of the combined printable area of design layer and sheet 
layer pages

Snap to Individual Pages Snaps to the edges and center of the individual pages within design layer and sheet 
layer pages
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2. Click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
SmartCursor Cues
Setting Snapping Parameters
Drawing with Snapping
The Automatic Working Plane

Grid Snapping
The snap and reference grids assist with precise drawing on both design and sheet layers, as described in “Snap and 
Reference Grids” on page 71.
When snap to grid is on, the SmartCursor snaps to set points on the snap grid. For example, if the grid is set to 1”, as the 
mouse moves over the grid, it automatically “catches” every inch. When you create a line, the line’s first and last point 
will (if no other snapping is active) lie on the snap grid. Snap to grid is the only type of snapping that does not provide 
any sort of visual cues. If snap to grid is on, the mouse is always on the grid, unless other snaps are also selected which 
override snap to grid.

When snap to grid is on, the working plane displays with “dots.” The dots do not display for working planes when snap 
to grid is off. See “Appearance of the Planes” on page 1169.

To set grid snapping:

1. Select Tools > SmartCursor Settings, or double-click the Snap to Grid tool in the Snapping palette.
The SmartCursor Settings dialog box opens. From the Grid tab, specify the snap and reference grid settings.

Click to show/hide the parameters.

Ignore Non-planar Snaps 
in Planar Contexts

Snaps only to snap points that are planar within the current plane’s context, ignoring 
snap points that are not co-planar. When using the automatic working plane with a tool 
that operates on a plane, the current planar context is the plane that is acquired by the 
automatic working plane.When not using the automatic working plane, and you are 
creating a 2D object, the current planar context is the current working plane.
This is useful in Wireframe mode when the automatic working plane is on, and the 
cursor is over a planar face (not a curved face); and when the automatic working plane 
is off, and you are drawing planar objects. It is not needed in rendered views because 
snapping does not occur for geometry hidden behind solid objects.

Interactive Appearance 
Settings

Opens a dialog box to change the appearance of the interactive elements in the 
Vectorworks program, including general elements, object highlighting, SmartCursor 
elements, and snap points; see “Configuring Interactive Display” on page 116

Note Reminds you that snapping can be suspended temporarily by pressing the ‘ key (back 
quote key)

Reset Restores default parameter settings for all tabs

Parameter Description

Reference grid Snap grid
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2. Click OK. 
3. To activate snapping to the snap grid, click the Snap to Grid tool from the Snapping palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Snap and Reference Grids
SmartCursor Cues
Setting Snapping Parameters
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Object Snapping
When snap to object is on, the SmartCursor finds specific parts of an object, such as corners, endpoints, midpoints, or 
centers of 2D objects and arc edges, as well as meshes, extrudes, sweeps, spheres, 3D polygons, 3D planar faces, and 
walls, floors, roofs, roof faces, loci, and columns. Cues display near the cursor to identify the location.

To set object snapping:

1. Select Tools > SmartCursor Settings, or double-click the Snap to Object tool in the Snapping palette.
The SmartCursor Settings dialog box opens. From the Object tab, specify the object snap settings.

Parameter Description

Snap Grid The grid that aligns (snaps) objects during drawing and editing, when Snap to Grid is 
active

Symmetrical Select to constrain the Y setting to be the same as the X setting, resulting in a symmetrical 
grid (this setting is selected by default)

X and Y Sets the grid dimensions in the X and Y directions; the Y setting appears dimmed if 
Symmetrical is selected

Reference Grid The visible grid used for visually aligning objects during drawing and editing
Symmetrical Select to constrain the Y setting to be the same as the X setting, resulting in a symmetrical 

grid (this setting is selected by default)
X and Y Sets the grid dimensions in the X and Y direction; the Y setting appears dimmed if 

Symmetrical is selected
Grid Options Sets how the reference grid behaves on screen and when printing

Show Grids Displays the reference grid when possible (even with this option selected, the reference 
grid may not display depending on the zoom factor); also displays the active layer plane 
grid in 3D views. This setting is selected by default.

Print Grid Prints the reference grid on both design layers and sheet layers
3D Grid Axes

Show 3D Z Axis Shows the Z axis for working planes (this setting is selected by default)

Show 3D Axis Labels Shows labels for each axis in the active layer plane and working plane

Z axis
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Click to show/hide the parameters.

Parameter Description

End Point Finds the endpoint of arcs, and the end of an object’s edge

Mid Point of Edge Finds the middle of the edge of an object

Center Point Locates the center of 2D objects and arc edges, as well as meshes, extrudes, sweeps, 
spheres, 3D polygons, 3D planar faces, and walls, floors, roofs, roof faces, and columns

Quadrant Points Finds the top, left, right, and bottom of circles, ovals, rectangles, and rounded rectangles

Insertion Point Locates the object origin of loci, lights, objects, symbols, text, and for dimensions, one of 
the referenced points

Endpoint Endpoint

Midpoint

Midpoint

2D Object Snapping 3D Object Snapping

Center Center

Top Center

Insertion Point
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2. Click OK to set the object snapping options.
3. To activate object snapping, click the Snap to Object tool from the Snapping palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Angle Snapping
Two points define an angle; Snap to Angle only applies to the second point of a two-point feedback segment, such as 
when drawing a line or polygon. When snapping to angles, the SmartCursor finds the angles specified, and by default, 
the SmartCursor also finds angles relative to the horizontal and vertical axes. Snap to Angle can also detect a plan 
rotation angle (Vectorworks Design Series required); items created along that angle when in a rotated plan view, appear 
horizontal when in a non-rotated, world coordinate view.

To set angle snapping:

1. Select Tools > SmartCursor Settings, or double-click the Snap to Angle tool in the Snapping palette.
The SmartCursor Settings dialog box opens. From the Angle tab, specify the angle snap settings.

Click to show/hide the parameters.

Vertex Locates the corner point on polyline, polyline Bézier, and polyline cubic segments; for 
3D, finds the vertex of a solid or the control point of a NURBS curve

Nearest Point on Edge For 2D, finds the closest point on an object’s edge, and for 3D, finds any non-specific 
point along a solid edge or NURBS curve. It may be more convenient to use smart edge 
snapping instead; see “Smart Edge Snapping” on page 140.

Parameter Description

Angles

Parameter Description

Point

Point

Object
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Holding the Shift key while drawing forces the SmartCursor to select the nearest snap angle.
2. Click OK to set the angle snapping options.
3. To activate angle snapping, click the Snap to Angle tool from the Snapping palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Smart Points Snapping
When smart points snapping is on, you can temporarily remember a point where the cursor paused for a set length of 
time, or where a special shortcut key was pressed. Once a smart point has been defined, you can align to it horizontally, 
vertically, or at a specific angle using extension lines and SmartCursor cues. 

Angles from 
Axes

Snaps to the specified angles with respect to the horizontal or vertical axes. For example, if 
45° is specified, the angles found include 45°, 135° (90+45), 225°(180+45), and so on. 
Specify the angles to detect, separated by a semi-colon; 45° and 30° are suggested by default. 
Up to eight angles can be set.

Angles relative 
to prior 
segment

Snaps to the specified angles relative to the previously drawn segment, instead of with respect 
to the axes. This is convenient when drawing multi-segment shapes, since the angle snap is 
based on the prior segment while drawing, and no mental arithmetic is required.
The / key toggles this option on and off. When off, angles snap relative to the axes as in the 
Angles from Axes setting. The shortcut key can be set in the workspace editor; see 
“Modifying Snapping and Mode Shortcuts” on page 1842

Plan Rotation
(Vectorworks 
Design Series 
required)

Finds the angle of plan rotation; this snap is useful when drawing in a rotated top/plan view, 
and requiring objects to be horizontal when the plan is no longer rotated

Alternate 
Coordinate 
System

Specifies an additional rotated coordinate system that provides angle snaps and alignments 
along its axes

Enter Angle Sets an angle other than the angles entered in Angles from Axes. Enter an alternate angle. 
Extension Lines Draws an extension line from a smart point to the alternate angle and 90° to the alternate angle

Parameter Description

45°
45°

Align Alt / Align Alt 90°
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To set a smart point, pause the cursor over an object point for the set number of seconds, or press the T key. A small box 
displays when the smart point has been set.
A special smart point, called a datum, can be set to temporarily create a new origin for snapping and measuring 
purposes. The datum does not need to be set over an object, but can be placed anywhere. When a datum is set, all 
measurements along the X and Y axis are taken from that point, rather than the drawing’s origin, until the datum is 
moved or deactivated. When a datum is created, the Data bar displays coordinates relative to the datum, using the 
datum point as the origin. If a datum is set before moving an object with the Selection tool, the object’s location and 
angle are measured relative to the datum.
To set a datum point, pause the cursor for the set number of seconds, or press the G key. The datum displays as a small 
circle around the chosen point. See “Data Bar and Edit Group Options” on page 127 to activate the floating Data bar 
automatically after a datum is set.
The SmartCursor remembers up to three smart points, and then the oldest points are replaced. A smart point or datum 
can be released by pausing the cursor or pressing the shortcut key over the point again.

Press the Esc key to clear all smart points.
A current snap is needed to acquire smart points, so enabling Snap to Object, at a minimum, is recommended.

To set smart point snapping:

1. Select Tools > SmartCursor Settings, or double-click the Smart Points tool in the Snapping palette.
The SmartCursor Settings dialog box opens. From the Smart Point tab, specify the smart point snap settings.

Click to show/hide the parameters.

Parameter Description

Horizontal/Vertical 
Extensions

Displays an extension line when the cursor aligns horizontally, vertically, or in the 
X, Y, or Z direction with a smart point or datum

Extension Lines Creates an extension line from a smart point when drawing at a snap angle and the 
SmartCursor is aligned perpendicular to the smart point

Align V

Align Y

15° / Align
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2. Click OK to set the smart point options.
3. To activate smart point snapping, click the Smart Points tool from the Snapping palette.

The appearance of the smart points can be changed; see “Configuring Interactive Display” on page 116. The 
shortcut key assigned to smart points and the datum can be customized; see “Modifying Snapping and Mode 
Shortcuts” on page 1842.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Snap to line between Smart 
Points

Snaps to the extension line between smart points

Allow extensions from 
nearby Smart Points

Creates extension lines from smart points located near the cursor.
When deselected, prevents extension lines generated by smart points located close 
to the cursor, so that alignment does not occur to unintentionally acquired smart 
points in cluttered drawings.

Acquire Smart Point Sets a smart point at the cursor location when the cursor pauses for the indicated 
number of seconds. (Experienced users may wish to reduce the pause time to 0.1 or 
0.2 seconds.)
Alternatively, press the T key to set or release a smart point at the cursor location, 
even if the Acquire Smart Point option is disabled.

Set Datum Sets a floating datum to define a temporary data origin by pausing the cursor for 
the indicated number of seconds (normally, set this time interval to be longer than 
the smart point acquisition time). Alternatively, press the G key to set or release a 
datum at the cursor location, even if the Set Datum option is disabled.

Datum Offset Sets an offset from the temporary datum origin that is indicated by an additional 
marker along the extension line; enter the offset value

Parameter Description

Edge

Datum

Datum

Datum
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Smart Edge Snapping
When smart edge snapping is on, the SmartCursor finds points on, or at a certain distance away from, a specified edge. 
The edges of linear 2D geometry, arc and polyline curve segments, and 3D segments and curves, can be acquired as 
smart edges. Once a smart edge has been defined, you can align to it horizontally, vertically, or at a specific angle using 
extension lines and SmartCursor cues. A smart edge also provides snapping to a point on an edge without having to 
activate Nearest Point on Edge object snapping.
To set a smart edge, slowly move the cursor over a 2D object edge for the set number of seconds, or press the T key 
while over an edge. Dotted extension lines indicate that the smart edge has been set.
Up to two smart edges can be set, and then the oldest edges are replaced. A smart edge can be released by moving the 
cursor slowly over the edge or pressing the T key over the edge again.

To set smart edge snapping:

1. Select Tools > SmartCursor Settings, or double-click the Smart Edge tool in the Snapping palette.
The SmartCursor Settings dialog box opens. From the Smart Edge tab, specify the smart edge snap settings.

Click to show/hide the parameters.

Parameter Description

Acquire Edge Sets a smart edge at the cursor location when the cursor moves over an object edge for the 
indicated number of seconds. Alternatively, press the T key to set or release a smart edge 
at the cursor location, even if the Acquire Edge option is disabled.

Snap to Bisector Finds points along the bisector that intersects two smart edges

Snap to Offset Sets an offset from either end of a smart edge extension line that is indicated by additional 
markers along the extension line; enter the offset value

Smart Edge

Bisector Bisector

Offset / Align V
Offset 
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2. Click OK to set the smart edge options.
3. To activate smart edge snapping, click the Smart Edge tool from the Snapping palette.

The appearance of the smart edge can be changed; see “Configuring Interactive Display” on page 116. The 
shortcut key assigned to the smart edge can be customized; see “Modifying Snapping and Mode Shortcuts” on 
page 1842.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Distance Snapping
When snap to distance snapping is on, the SmartCursor finds points at a selected distance along a straight or curved 
line, polygon edges, wall edges, and other linear objects.

To set the snap distance:

1. Select Tools > SmartCursor Settings, or double-click the Snap to Distance tool in the Snapping palette.
The SmartCursor Settings dialog box opens. From the Distance tab, specify the distance snap settings.

2. Set the distance using a fraction, percentage, or a dimensional distance. Select Multiple Divisions to repeat snap 
points along a line. For example, the SmartCursor can snap every quarter inch, or every 1/8 of the length of the 
line.
The SmartCursor measures from each endpoint to the center of the line. If a line is 10 units long and the distance 
is set to 6 units, the distance will not be found at all, since it is longer than half a line. Similarly, any fraction 
greater than 1/2 the length of the object or less than 0 cannot be used.

3. Click OK to set the Snap to Distance options.
4. To activate Distance snapping, click the Snap to Distance tool from the Snapping palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
SmartCursor Cues
Setting Snapping Parameters

Snap to Extension 
Lines

Generates extension lines from smart points perpendicular and parallel to the smart edge
Parameter Description

Align Edge 90°

Align X

Along Line Along Line
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Snap to Intersection
When snap to intersection snapping is on, the SmartCursor finds the intersection between two objects or between the 
parts of an object.

To activate snapping to intersection:

Click the Snap to Intersection tool from the Snapping palette. No parameters are required.
~~~~~~~~~~~~~~~~~~~~~~~~~
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Snap to Tangent (2D Only)
The Snap to Tangent option uses the SmartCursor to locate tangents on circular arc geometry when drawing.

Tangents cannot be found on quarter arcs.

To activate tangent snapping:

Click the Snap to Tangent tool from the Snapping palette. No parameters are required.

Hold down the Option (Mac) or Alt (Windows) key to switch the tangent to the opposite side of the object.
Click here for a video tip on this topic (Internet connection required).

~~~~~~~~~~~~~~~~~~~~~~~~~
SmartCursor Cues
Setting Snapping Parameters
Drawing with Snapping

Object/Object

Tangent

While drawing, as the 
feedback segment 
approaches a tangent, the 
special snap points indicator 
shows that a tangent snap is 
available

Move the cursor to the 
tangent snap, and click to 
create a line that is tangent 
to the circle

Alternatively, begin drawing a 
line from the arc geometry, and 
the feedback segment remains 
tangent to the circle. Click to 
create a tangent line.

Use tangent snapping to 
find the tangent when 
drawing arcs or polylines in 
Tangent Arc mode

Tangent

http://youtu.be/KfFFt3oLZus
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Snap to Working Plane (3D Only)
When Snap to Working Plane snapping is on, the SmartCursor snaps/projects any point not on the working plane down 
to its shadow point on the working plane. 

To activate snapping to the working plane:

Click the Snap to Working Plane tool from the Snapping palette. No parameters are required.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Snapping Techniques
A variety of settings and options combine to facilitate drawing with snapping. Several types of snap types and snapping 
indicators assist with snapping. The snap loupe temporarily zooms into the drawing view near the cursor to obtain a 
snap in a complex drawing.
Snapping is used with the feedback segment preview line that displays while drawing with most tools. For example, 
when drawing a line, you may want it to be vertical, and also aligned with a point on your drawing. To do this, set a 
smart point (with extension lines) on the point to align to. Angle snapping should be enabled (because it snaps to the 
vertical) along with smart point snapping. The feedback segment of the line snaps to the vertical and to the smart point, 
and a second click finishes drawing the line as desired.

Several areas in the program control the various aspects of snapping.

Functionality Location/Description

Enable/disable snapping tools Snapping palette
Enable/disable individual snapping 
parameters

SmartCursor Settings dialog box

Change the appearance of snap 
points and indicators

Interactive Appearance Settings dialog box; “Configuring Interactive 
Display” on page 116

While moving along the top edge of the extrude with 
working plane snapping on, the cursor snaps to the 
working plane

Shadow point on 
working plane

Feedback segment
(Line tool in use)

Smart point has 
already been set

Feedback segment
snaps to vertical and

to smart point
extension line

Vertical / Align V
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Snapping Indicators
There are several types of snap points. Use these in combination with the settings in the Snapping palette, SmartCursor 
Settings dialog box, the Interactive Appearance Settings dialog box, and Interactive tab in Vectorworks preferences to 
tailor snapping and snapping appearance to your drawing task. In addition to the snap points, other interactive elements 
assist with snapping.

• Available snap points
Available snap points display near the cursor, within the snap box area, to indicate that a snap point is near the 
cursor. 

• Special snap points
Special snap points display in the general cursor area, to inform you that midpoint, center, along line, and/or 
tangent snap points are nearby. The visible snap points depend on the snapping enabled in both the SmartCursor 
Settings dialog box and the Snapping palette.

• Current snap point
The current snap point shows that the SmartCursor is snapped.

Enable/disable snap box, selection 
box, and acquisition hints

Interactive tab of Vectorworks preferences

Change the appearance of the snap 
box and selection box

Interactive tab of Vectorworks preferences

Save snap settings as a script Custom Tool/Attribute command; “Creating Custom Tool/Attribute 
Scripts” on page 1773

Change snapping shortcut keys Keys tab of the Workspace Editor; “Modifying Snapping and Mode 
Shortcuts” on page 1842

Snapping to objects in other layers 
or in classes or layers set to gray

Class and layer option commands; “Setting Class and Design Layer Options” 
on page 193

Functionality Location/Description

Special snap points near
the cursor
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The current snap point indicator is black in 2D. In 3D, the indicator displays with red, green, and blue colors, 
which correspond to the red (X), green (Y), and blue (Z) axes. The orientation of the 3D indicator is relative to the 
current working plane; dashed lines indicate the negative axes.

• Obtained snap point
When drawing with a tool, such as the Line tool, the first click of the tool on a current snap becomes the obtained 
snap point. The obtained snap point only displays for a brief moment, letting you know that the click was snapped.

• Smart point
When the Smart Point snapping is enabled, up to three smart points can be defined at one time; see “Smart Points 
Snapping” on page 137. A smart point displays as a red rectangle by default. If extension lines are enabled, the 
extension line for the smart point appears as a dashed line. A datum is a special type of smart point and counts as 
one of the three smart points.

• Snap object highlighting
The object from which the snap points are generated is highlighted with a dashed line. This ensures that the correct 
snap points are being obtained within a congested drawing.

• SmartCursor selection box and snap box
Two areas around the cursor assist with drawing: the selection box and snap box.

2D current point 3D current point

Smart point Smart point with extension line Datum Datum with extension line

Selection box

Snap box
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The selection box shows the area where object geometry can be selected or recognized by a tool that selects or 
clicks objects (such as the Selection tool or the Eyedropper tool). The snap box indicates the area from which the 
current snap will be obtained. The current snap is obtained from all the available snaps inside the snap box. The 
snap box allows a snap to be held while the selection box moves around to change the snapping selection.
The size and visibility of the selection box and snap box can be adjusted, and these indicators enabled, from the 
Interactive tab in Vectorworks preferences.

• Acquisition hints
Acquisition hints display the potential snap points that can be acquired near the cursor. They indicate that a smart 
point, smart edge, or vector lock can be acquired.

Enable the acquisition hints from the Interactive tab in Vectorworks preferences.
• Alignment Indicators

Lightly colored axis and plane indicators provide subtle hints to help determine whether the cursor is aligned to an 
axis (2D) or an axis and/or plane (3D). The color of the indicator matches the axis color (red for X, green for Y, 
and blue for Z) to help you determine when the cursor is aligned to an axis or plane.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Acquisition Hint Appearance

Smart point

Smart edge

Vector lock

The lock acquisition hint indicates
that by pressing the T key, a vector

lock can be placed at the current
cursor location

Green Y axis alignment
indicator

Green Y plane 
alignment indicator

Green Y axis 
alignment indicator
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Creating Vector Locks
An extension line created from a smart point indicates a vector, or direction. This vector can be locked to facilitate 
drawing and moving objects, because the SmartCursor stays locked to that vector and serves as a guide for snapping 
along that vector.
To create a vector lock:

1. Select the tool for drawing, an object to move, or other operation that requires a vector lock.
It is helpful to display acquisition hints, which show when a vector lock can be set. This is a Vectorworks 
interactive preference; see “Interactive Preferences” on page 56.

2. During the operation, the feedback segment indicates the vector direction and the acquisition hint at the cursor 
indicates that a vector lock can be set. A vector lock can be set along a smart point extension line. As the cursor 
moves along the extension line, the lock acquisition hint shows that a vector lock can be set.

3. Press the T key to create the vector lock in the direction of the extension line, or press the G key to set the vector 
lock relative to a datum, using the Data bar.
The vector lock displays. The appearance of vector locks can be set as described in “Configuring Interactive 
Display” on page 116.

4. The SmartCursor locks to the vector and the operation is snapped along the desired direction.

The Data bar can create a vector lock along a specific direction. Enter values in the Data bar as described in “Using the 
Data Bar” on page 125. A vector lock displays, and the SmartCursor only snaps to points on the locked line.

The selection needs to move up in 
a vertical direction

Press the T key

Vector locks can also be created in 
3D
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Using the Snap Loupe
In a congested drawing, it can be difficult to obtain the desired snap point. The snap loupe temporarily zooms into a 
drawing to obtain the snap. In this zoomed in view, the snap points near the mouse are easier to see.
The snap loupe is not intended to include navigation within the loupe window. It is a convenient way obtaining snap 
points and quickly returning to the drawing.
To use the snap loupe:

1. Move the mouse to the area where snapping is desired, but difficult.

2. Press the Z key.
The snap loupe window opens, displaying the region near the cursor in a zoomed view. Within the loupe window, 
move the cursor to locate the desired point. If the snap loupe window is not sufficiently magnified to find a snap, 
press the Z key again.
The Zoom Line Thickness in Snap Loupe preference determines how the drawing displays within the snap 
loupe. See “General Snapping” on page 132 to change this setting.

3. Click to perform the desired operation; the snap loupe window closes automatically, returning to the drawing.
Alternatively, press the Esc key to exit the snap loupe without clicking, or click outside of the loupe to close it.
Click here for a video tip about this topic (Internet access required).

http://www.youtube.com/watch?v=opUdIB8KHc4
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SmartCursor Cues
The following table lists the individual cues that the SmartCursor uses along with a description of each. In many cases, 
two cues are used together to indicate that two snaps have been activated. For example, the cue ‘Align H/Angle’ means 
that the point located is both aligned horizontally to the indicated smart point and also snapping to an angle.
Some cues display when a first point has already been found, and a second point is being sought. These two points form 
a line called the feedback segment. This segment forms an angle and length which the SmartCursor uses for some of its 
snaps.
For a line, the feedback segment is the same as the line being drawn. However, for other objects, the interactive image 
does not lie on the feedback segment. The SmartCursor works on the feedback segment created from the first to the 
second points (for polygons, from the previous point to the current point).

Cue Description

Snap to Angle
Alt Feedback segment is parallel to the alternative coordinate system angle
Alt 90° Feedback segment is perpendicular to the alternative coordinate system angle
Delta angle Feedback segment is at the specified snap angle from the rotated grid
Horizontal Feedback segment is horizontal
Parallel Feedback segment is parallel to an object
Perpendicular Feedback segment is perpendicular to an object
Plan Rotation
(Vectorworks Design 
Series required)

Feedback segment is aligned to the rotated plan angle

Symmetric Feedback segment is sketching out a square or circle
Vertical Feedback segment is vertical
X Feedback segment is aligned with the X axis
Y Feedback segment is aligned with the Y axis
Z Feedback segment is aligned with the Z axis, or point is aligned to a smart point in the 

direction of the Z axis
X’ Feedback segment is aligned with the X axis of the rotated grid
Y’ Feedback segment is aligned with the Y axis of the rotated grid
Z’ Feedback segment is aligned with the Z axis of the rotated grid, or point is aligned to a 

smart point in the direction of the Z axis of the rotated grid
Smart Point

-------------- Extension line used for all smart point cues except Datum
Align Feedback segment is perpendicular to a segment from the cursor to a smart point
Align H Point is aligned horizontally with a smart point
Align V Point is aligned vertically with a smart point
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Align X Point is aligned with the X coordinate of a smart point
Align Y Point is aligned with the Y coordinate of a smart point
Align Z Point is aligned with the Z coordinate of a smart point
Align X’ Point is aligned with the X coordinate of a smart point, in the space of the rotated grid
Align Y’ Point is aligned with the Y coordinate of a smart point, in the space of the rotated grid
Align Z’ Point is aligned with the Z coordinate of a smart point, in the space of the rotated grid
Align Edge Point is aligned to smart edge
Align Edge 90° Point is aligned perpendicular to smart edge
Align Alt Point is aligned to the user coordinate system
Align Alt 90° Point is aligned perpendicular to the user coordinate system
Datum Point is the Datum
O Circle around Datum
Working Plane Point is on the grid plane

Snap to Distance
Along Line 2D—Point is at a specified distance along line

3D—Point is at a specified distance along line from the end point of a NURBS curve, 
3D polygon, or edge of a solid object

Data bar
-------------- Extension line used to indicate X or Y value is locked
Angle Feedback segment is constrained to an angle
Length Feedback segment is of a fixed length set in Data bar

Snap to Object
Arc Cursor is over the corner point of a polyline arc segment
Arc Center Cursor is over the center point of an arc
Arc End Cursor is over the end of an arc segment
Bézier Cursor is over the corner point of a polyline Bézier segment
Bottom Center Cursor is over the bottom center of rectangle or group
Bottom Left Cursor is over the bottom left of the object’s bounding box
Bottom Right Cursor is over the bottom right of the object’s bounding box
Center 2D—Cursor is over the center of the object’s bounding box

3D—Cursor is over the geometric center of certain objects, NURBS curves, 3D 
polygons, or the center of a circular NURBS curve

Center Left Cursor is over the center left of the object’s bounding box
Center Right Cursor is over the center right of the object’s bounding box
Corner Cursor is over the corner point of a polyline segment
Endpoint Cursor is over the end of an object’s edge

Cue Description
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Fit Cursor is over the corner point of a polyline cubic segment
Internal Origin Cursor is over the file’s internal origin marker
Insertion Point Cursor is over the object origin for symbols, parametric objects, and text objects; for 

dimensions, the cursor is over one of the referenced points
Light Cursor is on a light
Locus Cursor is on a locus
3D Locus Cursor is on a 3D locus
Midpoint Cursor is over the middle of an object’s edge
Object 2D—Cursor is on an object’s edge

3D—Cursor is on any non-specific point along a solid edge or NURBS curve; displays 
at all corner points when the Nearest Point on Edge option is deselected for object 
snapping

Page Cursor is over the page boundary
Page Bottom Center Cursor is over the bottom center of the page boundary
Page Bottom Left Cursor is over the bottom left of the page boundary
Page Bottom Right Cursor is over the bottom right of the page boundary
Page Center Cursor is over the center of the page
Page Center Left Cursor is over the center left of the page boundary
Page Center Right Cursor is over the center right of the page boundary
Page Top Center Cursor is over the top center of the page boundary
Page Top Left Cursor is over the top left of the page boundary
Page Top Right Cursor is over the top right of the page boundary
Point 2D—Cursor is on an object point

3D—Cursor is on one of the vertices of a solid, the control point of a NURBS curve, the 
control point of a NURBS surface, or NURBS curve interpolation point

Top Center Cursor is over the top center of the object’s bounding box
Top Left Cursor is over the top left of the object’s bounding box
Top Right Cursor is over the top right of the object’s bounding box

Smart Edge
Bisector Point is on the bisector between two smart edges
Edge Feedback segment is parallel to a smart edge, or cursor is on the edge between two 

smart points
Edge 90° Feedback segment is perpendicular to a smart edge
Offset Point is a preset distance from a smart edge
Smart Edge Point is on a smart edge, but not on the object itself

Snap to Tangent
Tangent Feedback segment is tangent to an arc

Cue Description
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Vectorworks Modeling Environment
Vectorworks software provides robust 2D functionality with a variety of tools and commands for those who draft in 
Top/Plan. For those who design in 3D instead of, or in addition to, 2D, the Vectorworks program is a true modeling 
environment.

Planar Modes of 2D Objects: Screen Plane and Layer Plane
2D objects can be created as either screen plane objects or layer plane (planar) objects, depending on the selected 
planes mode. The screen plane is coincident to the computer screen, and perpendicular to the designer’s view direction. 
2D objects drawn in the screen plane “float” in 3D views. Planar objects, however, exist in 3D space; a planar object is 
drawn in a 3D plane—either the layer plane or a 3D working plane, maintaining its geometric relationship to the 3D 
model when in 3D views. 

Objects are created as planar objects by default; they display in Wireframe mode with their graphic attributes on the 
layer plane in views other than Top/Plan, and become part of the 3D model. 2D objects can be created and edited on 
any plane and in any view; the editing occurs within the “planar context” of the object’s plane. When performing 
operations on multiple selected planar objects in a 3D view, the objects must be co-planar. 

Double-click on a planar object to set the working plane to the plane on which the object was created.
The Split tool, as well as the Modify > Rotate > Rotate, Rotate Left, and Rotate Right, and Flip commands, 
operate within the screen plane only.

While most 2D objects should normally be planar, some objects function best as screen plane objects. For example, all 
elements on sheet layers are, by definition, on the screen plane. Objects created as crop objects for viewports are 
automatically placed in the screen plane. In addition, when creating special hybrid symbols, the 2D component of the 
symbol should be created in the screen plane, so that the symbol has a representation when viewed in Top/Plan. 
2D objects created in version 2010 and later retain their planar designation upon conversion. 2D objects created in 
versions of Vectorworks software prior to 2010 become screen plane objects upon conversion.
The Active Planes list located on the View bar sets the currently active plane, and determines whether 2D objects are 
created as planar or screen plane objects. The available planes depend on the drawing view, current tool, presence of 
named working planes, and plane mode options. To create planar objects, select Layer Plane from the Active Planes 
list. To create screen plane objects, select Screen Plane. (To create planar objects on the automatic working plane, 

Tangent/Tangent Feedback segment is tangent to two arcs
Cue Description

2D object in Top/Plan view 2D planar object in isometric view 2D screen plane object in isometric view
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select Automatic as described in the next section.) The selected planar mode remains in effect until the next time it is 
changed.

The Active Planes list on the Shape tab of the Object Info palette switches the planar property of selected existing 2D 
objects. A selected 2D object drawn in screen plane mode can be switched to layer (planar), and vice versa.

Click here for a video tip about this topic (Internet access required).
Depending on your workflow and preferences, the available options on the Active Planes list can be restricted, to never 
show the layer plane or never show the screen plane.

The Automatic Working Plane
In a 3D view, and when a typical drawing tool is selected, the automatic working plane is in effect. As the cursor moves 
over suitable drawing surfaces, the automatic working plane is highlighted on the surface to indicate that the drawing 
object can be placed there and will be drawn planar to the surface. “Automatic” displays in the Active Planes list. 

When the cursor is not over a suitable surface while in a 3D view, the default automatic plane is in effect. The default 
automatic working plane aligns to the layer plane, and an object drawn is placed on the layer plane. See 
“Understanding the Working Plane” on page 1166 for more information.
In some cases, it may be desirable to turn off the automatic working plane, as when drawing on the layer plane or 
screen plane, when drawing on a hidden surface where the automatic plane does not appear, or when drawing on a 
specific working plane that was established by the Set Working Plane tool. The \ key (backslash) toggles the 
automatic working plane on and off. This key can be customized in the Workspace Editor; see “Modifying Snapping 
and Mode Shortcuts” on page 1842. The color and opacity of the automatic working plane can also be customized; see 
“Configuring Interactive Display” on page 116.

Push/Pull Mode of Planar Tools
In a 3D view, and when the screen plane is not the active plane, planar objects such as circles, rectangles, rounded 
rectangles, ovals, arcs, polylines, and polygons can be extruded immediately after creation when the Push/Pull mode 
on the Tool bar is enabled for the tool. The mode’s toggle status applies to all these planar tools; if the mode is enabled 

With the Hemisphere tool selected, the 
automatic working plane displays on an 

applicable surface as the cursor moves over it. 
The axes display the working plane origin.

The hemisphere is created on the 
automatic working plane, and it is 

automatically made planar to the surface

Rendered view

http://www.youtube.com/watch?v=U2C7TrMnjiQ 
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for one of the tools, it is enabled for all of them. This instantly and easily allows 3D objects to be created from planar 
objects, by moving the cursor or entering a distance in the data bar.

When the automatic working plane mode is enabled and the Push/Pull mode is in use over an object that supports solid 
operations, press and hold the Option key (Mac) or Alt key (Windows) and pull “out” to create a solid addition or push 
“in” to create a solid subtraction.
The Push/Pull mode of planar objects operates directly after creation of the object. If the object is deselected, it can be 
extruded later with the Push/Pull tool; see “Direct Modeling with the Push/Pull Tool” on page 357. In some cases, the 
Push/Pull mode may need to be toggled off, such as when creating several planar objects one after another.

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Objects
Understanding the Working Plane
The Active Planes List
Plane Mode Preferences

Use the Circle tool to create a circle 
on the side face of an object. The 

automatic working plane indicates a 
suitable planar surface.

The circle that was just created is 
still selected, and can immediately 
be extruded when the Push/Pull 

mode is enabled.

The extruded cylinder is created.

http://www.youtube.com/watch?v=iFqbtY5EpZU


Drawing Structure
Organizing the Drawing
When you begin a drawing project, first develop a layer and class structure, along with a system for assigning items to 
the appropriate layers and classes. A layer is basically a container that holds items. Layers are comparable to the sheets 
of vellum that are used for hand-drafting; each item “belongs” to a layer in the same way that a hand-drafted item 
“belongs” to its vellum sheet. Additionally, in the Vectorworks Architect product, story levels and, optionally, design 
layers, can belong to building stories.
A class, however, is an attribute of an object. Classes span the layers and allow you to control the attributes and 
visibility of objects across multiple layers. To output specific elements of a drawing quickly and easily, simply select 
the appropriate layers and classes for display.
The program also provides ways to save the current drawing display with histories and saved views, and to present 
final drawings with viewports. Views and histories provide a “slice-of-time” look at the drawing. Histories record 
views of the drawing in a stack similar to the way Internet browsers do, while saved views store one or more aspects of 
the current display, such as the view, zoom, and layer and class visibility settings. Viewports are used to display final 
views of a drawing for client presentation.
~~~~~~~~~~~~~~~~~~~~~~~~~
The Organization Dialog Box
Layers
Setting Up the Building Structure with Stories
Classes
Design Series Layers, Classes, and Viewport Standards
Saved Views
Setting Class and Design Layer Options
Setting Visibilities in the Organization Dialog Box
The Visibility Tool
The Navigation Palette
Workgroups and Referencing

The Organization Dialog Box
Create and manage structural elements of the drawing using the Organization dialog box. This dialog box has 
specialized functions to sort and select its list items; see “List Box Functionality” on page 44.
To use the Organization dialog box:

1. Select Tools > Organization. Alternatively, click the Classes or Layers button on the View bar, or select Edit 
View from the Saved Views menu on the View bar.
The Organization dialog box opens.

2. Select the appropriate tab for the element to be created or edited: Classes, Design Layers, Sheet Layers, 
Viewports, Saved Views, or References.
In the Vectorworks Architect product, an additional Stories tab is available; see “Creating and Managing Stories” 
on page 174.

3. From the top of the dialog box, select either Details or Visibilities view.
Generally, the Details view shows the current settings for each element, and enables editing of layer and class 
visibilities in the drawing area; the Visibilities view enables editing of layer and class visibilities in viewports and 
in saved views (see “Setting Visibilities in the Organization Dialog Box” on page 193).

4. Buttons at the bottom of each tab provide creation and management functions. Alternatively, right-click 
(Windows) or Ctrl-click (Mac) on a list item to display a context menu, which has most of the same functions as 
the tab buttons.
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Classes Tab
If a description was entered for the class, it displays in a screen tip when you position the cursor over the class name. 
On Windows, click the disclosure arrow on the screen tip to collapse or expand it.
Click to show/hide the parameters.

Design Layers Tab
The names of referenced design layers display in italics. If a description was entered for the design layer, it displays in 
a screen tip when you position the cursor over the layer name. If the layer is referenced, the screen tip also displays the 
full layer name and the source file name. On Windows, click the disclosure arrow on the screen tip to collapse or 
expand it.
Click to show/hide the parameters.

Button Function

New Click New to open the New Class dialog box. See “Creating Classes” on page 177.
When a new class is created, it does not automatically become the active class.

Edit Select a class and click Edit to edit it in the Edit Class(es) dialog box. See “Setting 
Class Properties” on page 179. This option is not available when classes are displayed 
in hierarchical order and a class group header is selected.

Duplicate Select a class and click Duplicate to create a copy of it. The name of the duplicate is the 
same as the original class, with a number added (as in cabinets-2); if the original name 
ends in a number, the next available sequential number is used. This option is not 
available when classes are displayed in hierarchical order and a class group header is 
selected.

Delete Select a class and click Delete to open the Delete Class(es) dialog box. Specify what to 
do with the objects currently assigned to the class(es) being deleted (delete them, or 
reassign them to another selected class). Click OK to return to the Organization dialog 
box. Vectorworks moves all objects in the deleted class(es) to the appropriate class, or 
deletes them, as specified. This option is not available when classes are displayed in 
hierarchical order and a class group header is selected.
Note that the Dimension and None classes cannot be deleted. These are default classes 
in every drawing.

Preview Displays a preview of the current settings in the drawing area
Hierarchical display mode Click to toggle the hierarchical display of classes; additional options are available for 

controlling the hierarchical display at various levels, and for controlling visibility 
settings. See “Displaying Classes in Hierarchical Order” on page 159.

Button Function

New Click New to open the New Design Layer dialog box. See “Creating Layers” on 
page 162.

When a new layer is created, it becomes the active layer.
Edit Select a layer and click Edit to edit it in the Edit Design Layers dialog box. See 

“Setting Design Layer Properties” on page 165.
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Sheet Layers Tab
If a description was entered for the sheet layer, it displays in a screen tip when you position the cursor over the layer 
name. On Windows, click the disclosure arrow on the screen tip to collapse or expand it.
Click to show/hide the parameters.

Viewports Tab
Click to show/hide the parameters.

Duplicate Select a design layer and click Duplicate to create a copy of it. The name of the 
duplicate is the same as the original layer, with a number added (as in floorplan-2); if 
the original name ends in a number, the next available sequential number is used.

Delete Select a design layer and click Delete; when prompted, click Yes to confirm the 
deletion. When a design layer is removed from the drawing, all objects in that layer are 
also removed.
Note that at least one design layer must remain in the drawing.

Preview Displays a preview of the current settings in the drawing area
Update Reference
(on the context menu only; 
layer import referencing 
method only)

This option is available if a design layer has been imported into this file with 
workgroup referencing. To update this file with layer information from the master file, 
right-click (Windows) or Ctrl-click (Mac) the layer, and select Update Reference from 
the context menu. See “Referencing Features” on page 207.

Level Types (Vectorworks 
Architect required)

Manages available level types; see “Managing Level Types” on page 174

Page Setup Opens the Page Setup dialog box; see “Page Setup” on page 1761

Button Function

New Click New to open the New Sheet Layer dialog box. See “Creating Layers” on 
page 162.

When a new layer is created, it becomes the active layer.
Edit Select a sheet layer and click Edit to edit it in the Edit Sheet Layers dialog box. See 

“Setting Sheet Layer Properties” on page 170.
Duplicate Select a sheet layer and click Duplicate to create a copy of it. The Sheet Title of the 

duplicate is the same as the original layer. The Sheet Number of the duplicate is the 
same as the original layer, with a number added (as in details-2); if the original Sheet 
Number ends in a number, the next available sequential number is used.

Delete Select a sheet layer and click Delete; when prompted, click Yes to confirm the deletion
Preview Displays a preview of the current settings in the drawing area

Button Function

New Select New to open the Create Viewport dialog box. For sheet layer viewports, see 
“Creating a Sheet Layer Viewport from a Design Layer” on page 1616. For design 
layer viewports (Vectorworks Design Series required), see “Creating a Referenced 
Design Layer Viewport” on page 1622.

Button Function
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Saved Views Tab
Click to show/hide the parameters.

References Tab
Click to show/hide the parameters.

Edit Select a viewport and then select Edit to edit it in the Properties dialog box. For sheet 
layer viewports, see “Viewport Properties” on page 1636. For design layer viewports 
(Vectorworks Design Series required), see “Viewport Properties” on page 1636.

Duplicate Select a viewport and click Duplicate to create a copy of it. The name of the duplicate 
is the same as the original viewport, with a number added (as in details-2); if the 
original name ends in a number, the next available sequential number is used.
The Drawing Title of the duplicate is the same as the original viewport. If the original 
viewport has a drawing label, the Drawing Number of the label in the duplicate 
viewport is the next available sequential number.
Vectorworks places the duplicate viewport directly on top of the original, in the 
original sheet layer.

Delete Select a viewport and click Delete; when prompted, click Yes to confirm the deletion
Preview Displays a preview of the current settings in the drawing area

Button Function

New Click New to open the Save View dialog box; see “Creating Saved Views” on 
page 189

Edit Select a saved view and click Edit to edit it in the Edit Saved View dialog box; see 
“Editing Saved Views” on page 190

Duplicate Select a saved view and click Duplicate to create a copy of it. The name of the 
duplicate is the same as the original view, with a number added (as in deckview-2); if 
the original name ends in a number, the next available sequential number is used.

Delete Select a saved view and click Delete; when prompted, click Yes to confirm the 
deletion

Button Function

New Click New to open the Open File dialog box. For layer import references, see “Adding 
and Editing Layer Import References” on page 210. For design layer viewport 
references (Vectorworks Design Series required), see “Creating a Referenced Design 
Layer Viewport” on page 1622.

Edit Select a referenced file and click Edit to open the Edit Reference dialog box. For layer 
import references, see “Adding and Editing Layer Import References” on page 210. 
For design layer viewport references (Vectorworks Design Series required), see 
“Creating a Referenced Design Layer Viewport” on page 1622.

Delete Select a referenced file and click Delete. In the Delete Reference dialog box, specify 
what to do with the items in the file that are currently referenced. See “Deleting 
References” on page 215.

Button Function
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Click here for a video tip on this topic (Internet connection required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Organizing the Drawing
Layers
Classes
Saved Views
Workgroups and Referencing

Displaying Classes in Hierarchical Order
On pop-up menus (including in the Object Info palette, the View bar, and dialog boxes), in the Organization dialog box, 
and (for Vectorworks Design Series products) in the Navigation palette classes with compound names separated by a 
dash, such as Walls-Ext, can be displayed in hierarchical order (up to four levels). Each level of a class is assigned a 
group header at the top level when displayed in hierarchical order. A number of options are available to control the 
hierarchical display of classes at various levels.
To enable/disable hierarchical order display on pop-up menus throughout Vectorworks software:

• On the Session tab of the Vectorworks Preferences dialog box, select/deselect Display classes in pop-up menus 
hierarchically to toggle between hierarchical and non-hierarchical display. This setting controls all pop-up menus 
throughout the software.

To enable/disable hierarchical order display in the Organization dialog box and the Navigation palette:
• In the Organization dialog box Classes tab, click the toggle button in the lower right corner or select the 

Hierarchical Display context menu option to toggle between hierarchical and non-hierarchical display; whatever 
expand/collapse state all items were last in is displayed

• In the Navigation palette (Vectorworks Design Series required), select the Hierarchical Display context menu 
option to toggle between hierarchical and non-hierarchical display; whatever expand/collapse state all items were 
last in is displayed

Update Select a referenced file and click Update to update this file with information from the 
master file. See “Updating References” on page 212.

Settings Click Settings to open the Reference Settings dialog box; see “Setting the Referencing 
Options” on page 209

Button Function

http://www.youtube.com/watch?v=m4_JiaG-d2I
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When classes are displayed in hierarchical order, the list’s sort key and sort order cannot be changed.
To expand/collapse a single class group header in hierarchical order display:

• Click the disclosure arrow to the left of a class group header
• Double-click the class group header

To expand all classes in the file or to collapse the list to only top-level classes (those with no dash in the name) and 
class group headers in hierarchical order display:

• Shift+Option-click (Mac) or Shift+Alt-click (Windows) the disclosure arrow to the left of a class group header
• Shift+Option-double-click (Mac) or Shift+Alt-double-click (Windows) on the class group header 

Alternatively, select Expand All or Collapse All from the context menu.
To expand/collapse all class subgroups in hierarchical order display:

• Option-click (Mac) or Alt-click (Windows) the disclosure arrow to the left of a class group header
• Option-double-click (Mac) or Alt-double-click (Windows) on the class group header

To manage visibility settings in hierarchical order display:
• If all class sublevels contain the same visibility setting, then their class group header is also automatically assigned 

that same visibility setting; otherwise, the Visibility column is blank for the class group header
• Assign or change a visibility setting in the Visibility column for the class group header, and all of its sublevels 

inherit that visibility setting
~~~~~~~~~~~~~~~~~~~~~~~~~
The Organization Dialog Box
Classes
List Box Functionality

Top level class

Class group
header

Disclosure
arrow
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Importing Drawing Structure from Standards or Other Files
Specific aspects of the drawing structure (classes, sheet layers, and design layers) can be imported from one or more 
existing files. The files from which you import can be the standard files provided with the Vectorworks software, or 
other files that you have created.
The standard files (.sta files) are located in the Standards folder (in [Vectorworks]/Libraries/Defaults). Layer standards 
use only approved layer names for a particular industry. Class standards use approved name and class settings for a 
particular industry. Custom layers or classes can be created in a blank file and saved as an .sta file in the Standards 
folder. Once they are placed in the Standards folder, these new layers or classes become part of the Standards list and 
are available when new layers or classes are created.
If one of your work files becomes corrupted, a possible recovery method is to import the data into a new file. Create a 
new file and then import classes, sheet layers, and design layers (and optionally, design layer objects) from the original 
file as needed.
To import drawing structure, use the Organization dialog box to create a new class, sheet layer, or design layer. Instead 
of creating a new item, however, select the import option. Select the file from which to import, and then select the 
specific classes or layers from that file to import. For a design layer, select whether to import the objects on the design 
layer, as well as the layer itself.
See “Creating Layers” on page 162 and “Creating Classes” on page 177 for details.

Click here for a video tip about this topic (Internet access required).

Layers
Create layers in a drawing to provide immediate flexibility. Stack the design layers in any order, or temporarily hide 
some of them. Reorder the layers, which moves all of the objects contained within each layer to another location 
without actually modifying the objects or their alignment with each other.

If you hand-draw a floor plan on two design layers, one vellum sheet with a master drafting plan and another with an 
addition to the plan, it would be easy to look at the floor plan with or without the addition. In the Vectorworks program, 
the vellum is electronic, so far more can be done with it. A distance can be set between design layers rather than having 
them lie flat on top of each other. Additionally, with the program’s modeling capabilities, these layers can be viewed in 
3D. For example, if the first floor, second floor, basement, and roof of a house are each placed in their own design 
layers, not only can the 2D drafting plan be printed for any one of those layers, but the design layers can be linked 
together, creating a model of a fully formed 3D house. Use viewports to display several views of the finished design, 
either on design layers (Vectorworks Design Series required) or on sheet layers, which are special presentation layers. 
The original design layers remain unchanged.
Layers have many other uses, as well. Move elements between design layers, or change the scale of a layer, instantly 
making a detail of an area of the drawing without re-drawing anything. Create design layers with objects that should 
always display, or layers that contain objects for display only at particular times. Control the visibility of the design 
layers to limit the need for creating new objects.

Layer 2

Layer 1

Layer 3

Layer order rearranged

Layer 3

Layer 2

Layer 1

http://www.youtube.com/watch?v=H4OW70kR3yU
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In the Vectorworks Architect program, design layers can optionally be associated with stories that contain objects; 
stories define absolute elevations in the building model, while layers can be set at an elevation relative to the story. This 
method of organizing a file makes it much easier to manage a building’s layers and certain associated objects like walls 
and columns. See “Setting Up the Building Structure with Stories” on page 172.
Use design layers to draw and model projects. Use sheet layers to create a presentation version of the finalized 
drawing; this can include viewports, title blocks, notes, and other annotations (see “Creating Sheet Layer Viewports” 
on page 1616).
On the layers list in the View bar, sheet layers are listed first, and then design layers. A separator divides the two types 
of layers in the list.
Sheet layers display with a wide gray border representing the print margin area, as opposed to design layers, which 
have a thin gray border (when the page boundary is displayed). This makes it easier to distinguish the layer types at a 
glance.

Click here for a video tip on this topic (Internet connection required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Layers
Assigning Objects to Classes and Layers
Setting Design Layer Properties
Setting the Active Layer
Setting Sheet Layer Properties
Setting Class and Design Layer Options
Setting Visibilities in the Organization Dialog Box
The Visibility Tool
Organizing the Drawing

Creating Layers
When a new drawing is created, it automatically contains an empty design layer entitled “Design Layer-1.” Add design 
layers to the drawing as needed to organize it. Add sheet layers as needed for presentation. Create new design layers 
and sheet layers, or import them (and optionally, the objects they contain) from other current version files or from 
standard files. In Vectorworks Design Series products, create a design layer viewport to reference design layers in other 
files without importing them.

To create a new layer:

1. For convenience, a new layer can be created from multiple locations in the Vectorworks software.
• New button on the Design Layers/Sheet Layers tab of the Organization dialog box (Tools > Organization)
• Layers button on the View bar to open the Organization dialog box
• New Design Layer or New Sheet Layer option from the Layers drop-down list on the View bar
• Layer field on the Shape tab of the Object Info palette

Layer 3

Layer 2

Layer 1

Layer 3

Layer 1

Layer 2 visibility set to Invisible

http://www.youtube.com/watch?v=7HVpfo1ELMA
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• New context menu on the Design Layers or Sheet Layers tab of the Navigation palette (Vectorworks Design 
Series required)

2. From the New Design Layer or New Sheet Layer dialog box, create a new layer, or import a layer and its 
properties from standard or existing Vectorworks files.

Click to show/hide the parameters.

3. Click OK to create the new design or sheet layer(s).
The layers display in the Layers list on the Organization dialog box, View bar, Object Info palette and (for 
Vectorworks Design Series) the Navigation palette. If the layer was created from anywhere other than the Object 
Info palette, it becomes the active layer.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Design Layer Properties
Setting Sheet Layer Properties
Assigning Objects to Classes and Layers
Setting Class and Design Layer Options
Setting Visibilities in the Organization Dialog Box
The Visibility Tool
Layers

Parameter Description

Create a New Design 
Layer 
or Create New Sheet 
Layer

Creates a new design or sheet layer.
• For a design layer, also enter a descriptive Name.
• For a sheet layer, enter a unique Sheet Number, or use the default (as in Sht-2). The 

Sheet Number can be displayed in drawing labels, section markers, and title blocks on 
sheet layers. Also enter a descriptive Sheet Title, which can be displayed in title 
blocks.

Import Design Layers 
or Import Sheet Layer

Imports layers and their attributes from standard files or from existing files. Files located 
in the Standards folder, as well as existing files selected previously, are displayed in the 
list. Select a file; the available layers and descriptions are listed beneath the file name. If 
a layer name in the current file matches a layer in the import file, that layer is not on the 
list as an import option.
Select the desired layer(s). To select multiple layers from the import list, hold down the 
Ctrl (Windows) or Command (Mac) key while you click.

Choose Click Choose to select a file for layer import. Files must be in the current version.
Import Layer Objects 
(design layer only)

In addition to importing the design layer structure and attributes, imports the contents of 
the layers; if a file has become corrupted, this is a possible way of recovering its data. If 
there is a naming conflict with pre-existing symbols or pre-existing layers in the current 
document, replace or rename the symbols or rename the layers.

Creation Options
Saved View Visibility 
(design layer only)

Sets the visibility of the new design layer in saved views (when saved views exist in the 
drawing)

Viewport Visibility 
(design layer only)

Sets the visibility of the new design layer in viewports (when viewports exist in the 
drawing)

Edit Properties After 
Creation

Immediately after creation, opens the Edit Design Layers or Edit Sheet Layers dialog box 
to set the properties of the new layer(s)
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Setting the Active Layer
There are several ways to change the active design layer or sheet layer.

To be able to add, remove, or edit objects on a design layer, either the layer must be active or the layer options 
must be set to allow modifications to other layers (see “Setting Class and Design Layer Options” on page 193). 

Setting the Active Layer in the Organization Dialog Box
To set the active layer:

1. From the Organization dialog box, in Details view, select the Design Layers tab or the Sheet Layers tab.
The active layer is indicated by a check mark to the left of the Design Layer Name or Sheet Number. The layer 
also is highlighted in bold text.

2. To make a different layer active, click the column to the left of its name/number.
3. Click OK.

The dialog box closes and the active layer displays.

Setting the Active Layer in the View Bar
To set the active layer:

1. Click the Layers list on the View bar to display a list of all of the sheet layers (top section) and design layers 
(bottom section) in the drawing.
On Mac, the active layer is indicated by a check mark; on Windows, the layer is highlighted in bold text.

2. Click the layer to be activated.
The layers list closes and the active layer displays.

Setting the Active Layer in the Navigation Palette
To set the active layer:

1. From the Navigation palette, select the Design Layers tab or the Sheet Layers tab.
The active layer is indicated by a check mark to the left of the Design Layer Name or Sheet Number. The layer 
also is highlighted in bold text.

2. To make a different layer active, click the column to the left of its name/number.
Alternatively, Right-click (Windows) or Ctrl-click (Mac) on the layer to be activated and select Activate from the 
context menu.
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Setting the Active Layer Using the Shortcut Keys
If there is a small number of layers, switch among layers with the Switch active layer/class shortcut key combination 
specified in Vectorworks preferences (see “Edit Preferences” on page 49). This selects a layer by moving up or down 
through the layer list one layer at a time. 

Setting the Active Design Layer in the Document Context Menu
If multiple design layers are set to be visible, and the layer options are set to show those other layers, the drawing area 
may display objects that are on non-active layers. Use the Activate Layer command to make the layer of one of these 
objects active.

The Force Select command on the document context menu also changes the active class and layer (if necessary), 
and selects the clicked object.

To set the active design layer:
1. In the drawing area, right-click (Windows) or Ctrl-click (Mac) a visible object on a non-active design layer.
2. From the document context menu, select Activate Layer.

The object’s layer becomes active.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Design Layer Properties
Setting Sheet Layer Properties

Setting Design Layer Properties
Once created, the design layers display on the Design Layers tab of the Organization dialog box, where various 
properties can be set and edited.

To edit design layers:

1. Select Tools > Organization. Alternatively, click the Layers button on the View bar.
The Organization dialog box opens.

2. Select the Design Layers tab.

Right-click (Windows) or Ctrl-click 
(Mac) on the sink from a gray, 
non-active layer to open the document 
context menu

The Activate Layer command 
activates the sink’s layer, and the 
objects that are not in that layer 
become grayed
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A list of the current layers in the drawing displays in their stacking order. Depending on which view option is 
selected at the top of the dialog box, either details or visibilities of the design layers display. Stacking order, 
drawing area visibility, and active layer can be changed in Details view. The visibility of layers in viewports and 
in saved views can be changed in Visibilities view.
In the Vectorworks Architect product, Details view includes the stories and story levels for each layer that is 
associated with a story level.
Layers that are imported from another file with layer import referencing display in italics. Position the cursor over 
the layer name to display a screen tip with the full layer name and the source file name.

3. To change other layer properties, select one or more layers and click Edit to open the Edit Design Layers dialog 
box.

Click to show/hide the parameters.

Parameter Description

Name If one layer was selected, displays the layer’s name; edit as needed
Description Click to enter additional information about the design layer. The description 

displays as a screen tip when you position the cursor over the design layer name in 
the Organization dialog box, Navigation palette, or (on Mac only) the Layers list on 
the View bar. Descriptions also display in the New Design Layer dialog box, so that 
you can see descriptions of layers before you import them.

Scale Sets the scale for the selected layer(s); see “Changing the Scale of Selected Design 
Layers” on page 68

Stacking Order Changes the 2D stacking order of the layer(s); see “Changing the Design Layer 
Stacking Order” on page 167

Story 
(Vectorworks Architect 
required)

Associates the layer with a story; select the story from the list, or create a new story 
for the layer (see “Creating and Managing Stories” on page 174).Layers that are 
associated with story levels derive their elevation value from the associated level. If 
the design layer does not need to belong to a story and one of its levels, select None; 
for example, a detail layer does not need to be associated with a building story.

Story Level
(Vectorworks Architect 
required)

Associates the layer with a story level; select the level from the list of levels for the 
story selected in Story. The level elevations are displayed in brackets to assist with 
choosing the correct level. Alternatively, create a new level (see “Default Story 
Levels” on page 173). 

Elevation Sets the height of a layer relative to the ground plane.
For Vectorworks Architect users, the elevation is set relative to the story, if the layer 
is associated with a story level, and the elevation cannot be changed here. 
The elevation relative to the ground plane also displays. For example, the second 
story of a building might be slightly offset from the story elevation, and also several 
feet above street level.

When a new layer is added to a drawing, its elevation values are automatically 
entered based on the previous layer’s elevation and layer wall height values.

Layer Wall Height Indicates the height of walls (and certain other objects such as columns) created on 
that layer, when the Top Bound option for those objects is set to Layer Wall Height

Opacity Controls how the selected layer(s) and other visible layers display; on Windows, the 
Vectorworks display preference for GDI+ imaging must be enabled
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~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Design Layer Opacity
Setting the Design Layer Transfer Mode
Creating Layer Backgrounds
Setting the Design Layer Color
Setting Up the Building Structure with Stories

Changing the Design Layer Stacking Order
Design layers are viewed and printed in “stacking order,” the top-to-bottom order in the Layers Setup dialog box. 
Initially, layers are “stacked” in the order in which they are created, but their order can be changed at any time.
To change the stacking order of design layers:

1. From the Organization dialog box, select the Design Layers tab in Details view to see the current stacking order. 
The # column to the right of the layer name indicates the layer’s current position in the stack, with 1 being the top 
layer.

2. Use one of the following methods to change the layer stacking order:
• The # column must be the current sorting column to change the stacking order; if the list is not currently sorted 

by stacking order, click the # column heading to change it. Then click the # column of the layer(s) to be moved, 
and drag it up or down the list. A horizontal line indicates where the layer(s) will be inserted in the current 
order.

• Select the layer(s) to move, and then click Edit (or double-click a layer row) to open the Edit Design Layers 
dialog box. In the Stacking Order field, enter the number for the new stacking order position of the layer(s). 
Click OK to accept the changes.

3. The Design Layers tab displays the new stacking order. Click OK to close the Organization dialog box and save 
the changes.

Transfer Mode
(Windows only)

Controls how the selected layer(s) and other visible layers display; the Vectorworks 
display preference for GDI+ imaging must be disabled

Renderworks Background When the Renderworks product is installed, select the Renderworks background to 
use for the selected layer(s) from either the default content or the current file’s 
content.

If the Renderworks Background choices are not available, the background 
selection is controlled by the Renderworks style in effect. Set the background 
in the Renderworks style instead; see “Renderworks Styles” on page 1596.

Colors Specifies the default layer color for the selected layer(s)
Saved Views Specifies the visibility settings for the selected layer(s) in each saved view; see 

“Setting Visibilities in the Organization Dialog Box” on page 193
Viewports Specifies the visibility settings for the selected layer(s) in each viewport; see 

“Setting Visibilities in the Organization Dialog Box” on page 193
Georeferenced
(Vectorworks Architect or 
Landmark required)

Enables georeference information to be attached to the layer(s); click Edit 
Georeferencing to open the Georeferencing dialog box. See “GIS and 
Georeferencing” on page 775 for details.

Parameter Description
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Setting the Design Layer Opacity
This feature is available on all Mac systems, and on Windows systems only when the GDI+ imaging preference is 
enabled. (See “Vectorworks Display Preferences” on page 50 for information about setting this preference.) Design 
layers have a setting that controls the transparency of layer objects that overlap visible objects in another layer. An 
Opacity value of 100% means that nothing beneath the active layer is visible. Decrease the Opacity value to increase 
the transparency of the objects on the layer.
To set the opacity for a design layer:

1. From the Organization dialog box, select the Design Layers tab. Select one or more layers, and then click Edit.
The Edit Design Layers dialog box opens.

2. Drag the Opacity slider to the left to increase the transparency, or enter an opacity percentage (0-100) in the box 
to the right of the slider.

3. Click OK to close the Edit Design Layers dialog box, and then click OK again to close the Organization dialog 
box.
Individual objects can also have an opacity percentage applied. See “Opacity Attributes” on page 1101.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Design Layer Transfer Mode

Setting the Design Layer Transfer Mode
This feature is only available on Windows systems. When the GDI+ imaging preference is disabled, design layers have 
a setting that controls the display of layer objects that overlap visible objects in another layer. (See “Vectorworks 
Display Preferences” on page 50 for information about setting this preference.)
To set the transfer mode for a design layer:

1. From the Organization dialog box, select the Design Layers tab. Select one or several layers, and then click Edit.
The Edit Design Layers dialog box opens.

2. Select the desired Transfer Mode from the list. Click OK to close the Edit Design Layers dialog box, and then 
click OK again to close the Organization dialog box.

Click on the layer’s # column
and drag it up or down the

list to change the layer’s
stacking order



Layers |  169
Mode Description

Paint Makes objects in the new layer solid, obscuring objects in layers stacked below it (this is the 
default setting)

Overlay Makes it so objects in the new layer do not obscure stacked layers

Invert Makes a reversed, or photo-negative image display when an object in the new layer overlaps an 
object in another layer

Erase Makes objects in the new layer display all foreground patterns as white and all background 
patterns as transparent

Not Paint Makes objects in the new layer solid and inverts any areas that overlap objects in stacked layers

Not Overlay Makes objects in the new layer transparent and inverts layer colors

Not Invert Makes objects in the new layer transparent and converts any black pixels from overlapping areas 
to white and white pixels to transparent

Not Erase Makes objects in the new layer transparent and converts any white pixels from overlapping areas 
to black and black pixels to transparent
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Most printer devices do not support all of these modes, especially PostScript printers and vector devices such as 
pen plotters. The Rasterize print output option may produce the best results for certain transfer modes. The use 
of color in transfer modes may produce color blending.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Design Layer Opacity
Printing a File

Setting the Design Layer Color
The fill and pen color of objects that are drawn on or moved to a design layer can be controlled by the color settings of 
the design layer. The Use layer colors setting in the Document Preferences dialog box must be turned on (see 
“Document Display Preferences” on page 60).

These settings are overridden by the Black and white only option in the Document Preferences dialog box, even 
with the Use layer colors option selected.

To control the color of objects by their design layers:
1. From the Organization dialog box, select the Design Layers tab. Select one or several layers, and then click Edit.

The Edit Design Layers dialog box opens.
2. Click Colors.

The Color Defaults for Layer dialog box opens.
3. For both the fill and pen, set the Foreground and Background colors by clicking the appropriate list and selecting 

a color from the main Color Menu dialog box. A preview example is shown at the bottom of the dialog box.
The fill background color controls the appearance of objects with a solid fill.

4. Click OK.
When the Use layer colors preference is selected, all objects on the layer are drawn with the specified colors. 
Viewports have separate control of layer color (see “Advanced Sheet Layer Viewport Properties” on page 1642).
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Colors

Setting Sheet Layer Properties
Once created, the sheet layers display on the Sheet Layers tab of the Organization dialog box, where various layer 
properties can be set and edited.

Sheet layers are always at a 1:1 scale, Active Only, and set to Top/Plan view.

To edit sheet layers:

1. Select Tools > Organization. Alternatively, click the Layers button on the View bar.
The Organization dialog box opens.

2. Select the Sheet Layers tab and the Details view.
The Sheet Layers tab opens, with a list of the current layers in the drawing. The layer stacking order and the active 
layer can be changed in Details view. Visibilities view does not apply to sheet layers.

3. To change layer properties, select one or more layers and click Edit to open the Edit Sheet Layers dialog box.
Click to show/hide the parameters.

http://www.youtube.com/watch?v=Qd9JXJzI9AY


Layers |  171
Changing the Sheet Layer Stacking Order
Sheet layers are viewed and printed in “stacking order,” the top-to-bottom order in the Organization dialog box. 
Initially, layers are “stacked” in the order in which they are created, but their order can be changed at any time.
To change the stacking order of sheet layers:

1. From the Organization dialog box, select the Sheet Layers tab in Details view to see the current stacking order. 
The # column to the right of the sheet title indicates the layer’s current position in the stack, with 1 being the top 
layer.

2. Use one of the following methods to change the layer stacking order:
• The # column must be the current sorting column to change the stacking order; if the list is not currently sorted 

by stacking order, click the # column heading to change it. Then click the # column of the layer(s) to be moved, 
and drag it up or down the list. A horizontal line indicates where the layer(s) will be inserted in the current 
order.

• Select the layer(s) to move, and then click Edit (or double-click a layer row) to open the Edit Sheet Layers 
dialog box. In the Stacking Order field, enter the number for the new stacking order position of the layer(s). 
Click OK to accept the changes.

3. The Sheet Layers tab displays the new stacking order. Click OK to close the Organization dialog box and save the 
changes.

Parameter Description

Sheet 
Number

Displays the number of the selected sheet layer; this number must be unique in the document. If this 
value is changed and Use Automatic Drawing Coordination is enabled in document preferences 
(Vectorworks Design Series required), any annotation objects (sheet borders, drawing labels, or 
section markers) that show this number are updated automatically.

Description Click to enter additional information about the sheet layer. The description displays as a screen tip 
when you position the cursor over the sheet number in the Organization dialog box, Navigation 
palette, or (on Mac only) the Layers list on the View bar. Descriptions also display in the New Sheet 
Layer dialog box, so that you can see descriptions of layers before you import them.

Sheet Title Displays the descriptive title of the selected sheet layer. If Use Automatic Drawing Coordination 
is enabled in document preferences (Vectorworks Design Series required), any sheet borders that 
show this title are updated automatically.

Stacking 
Order

Changes the 2D stacking order of the layer(s); see “Changing the Sheet Layer Stacking Order” on 
page 171

Raster 
Rendering 
DPI

Specifies the resolution (Dots Per Inch) for printing and viewing the raster rendered viewports in the 
selected sheet layer (does not affect vector geometry or bitmaps that are inside viewports); see 
“Setting the Print Resolution” on page 1765 for more details

Origin Specifies the X and Y coordinates of the sheet layer origin; each sheet layer has its own origin
Page Setup Opens the Page Setup dialog box for entry of sheet layer printing parameters; this saves time later, 

when different sheet layers can be automatically sent to different printers with different print area 
settings (see “Page Setup” on page 1761)
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Setting Up the Building Structure with Stories
The Vectorworks Architect product includes an additional document structural feature called stories. Stories define 
absolute elevations for the various floors of a building, and allow architects to manage defined story levels within those 
floors for construction elements like slabs, finish floors, and ceilings. The levels in a story have a Z height relative to 
the story; the story controls their absolute elevation, and if the story elevation changes, the levels and certain objects 
that are associated with them automatically change their elevation or boundaries along with the story. 
Story levels can be optionally associated with a layer that contains objects (such as furniture, fixtures, and walls). To 
add objects to a story, at least one layer is required. The story levels that make up a story act as a top or bottom 
constraint for special “bounded” objects. These bounded objects can be defined at their boundaries by the levels that 
make up a story, such as a slab or a ceiling. For example, an exterior wall (or one of its components) can extend from 
the top of the slab on one story to the top of a slab on the story above it. Slabs, walls, wall components, curtain walls, 
spaces, stairs, escalators, columns, and pilasters can be set according to a top and bottom boundary layer; the location 
of these boundaries is controlled by the elevation of the level and ultimately by the story elevation. Both walls and 
slabs can have their dynamic height information set and saved in a wall or slab style, so they can automatically take on 
their defined height condition. This method of using bounded objects allows flexibility and accuracy when defining a 
model, from the early to the final stages of design.
Begin project setup by creating the stories and their associated levels. Stories are created and managed from the 
Organization dialog box; either pre-defined standards or custom standards can be used. As the stories are added, any 
associated design layers are also created according to story level definitions. Finally, associate the applicable objects to 
the story level at the object’s top and bottom boundaries, creating a cohesive model that is structured and controlled by 
its building stories. 
~~~~~~~~~~~~~~~~~~~~~~~~~
Default Story Levels
Creating and Managing Stories
Organizing the Drawing
The Organization Dialog Box

Click on the layer’s #
column and drag it up or
down the list to change

the layer’s stacking order
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Default Story Levels
Stories contain levels with names and parameters defined by standards. When a story has a level, it can be used as a 
potential boundary for objects in its story (such as walls, slabs, and so on) or for the story above or below it. You can 
select the automatically defined levels when creating a story, or create customized levels by defining the default story 
levels before creating the stories. Certain projects may require custom level types, which can also be set up in advance. 
To create or edit default story levels:

1. Select Tools > Organization to open the Organization dialog box. Click the Stories tab.
The functionality of the Organization dialog box is described in “The Organization Dialog Box” on page 155. 

2. Click Default Story Levels.
The Default Story Levels dialog box opens, listing the currently defined default levels, their elevations (offset 
from the story elevation), and any associated layer names.

3. Click New to create a new default story level, or Edit to modify the currently selected default level.
The New Default Story Level or Edit Default Story level dialog box opens.

Click to show/hide the parameters.

4. By default, several level types are available, such as slab, finish floor, and ceiling; default story level types are 
provided as default content (see “Resource Libraries” on page 219). To create a custom level type, select New 
Level Type from the Level Type list.
The New Level Type dialog box opens. Enter the name of the new type of level.

5. Click OK to return to the New/Edit Default Story Level dialog box.
6. Once the default story level has been defined or modified, click OK to return to the Default Story Levels dialog 

box.
7. Once the default story levels in the list have been defined or modified, click OK to return to the Organization 

dialog box.

Parameter Description

Level Type Select the type of level from the list of standard levels, or click New Level Type to add the 
name of a custom level type to the list

Elevation Sets the elevation of the layer, relative to the story. 
Create Layer Creates a design layer, and associates the level with the layer; this is necessary when the level 

and associated layer contains objects such as furniture, fixtures, walls, windows, and so on. 
When a level is only being used as an elevation reference for bounded objects, an associated 
layer is not needed.
When an associated layer is no longer required and Create Layer is deselected, an alert 
displays. Select Yes to delete the layer, or No to keep the layer in the file but disassociate it 
from the level.

Name Specifies the name of the associated layer. This name is used with a story-specific prefix or 
suffix to create the actual layer name.

Scale Click Scale to set the scale to use for the associated layer; see “Design Layer Scale” on page 67
Layer Wall 
Height

Sets the default height for walls and columns that belong to the associated layer; the object’s 
settings must define its top height by the layer wall height for the object to use this height
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Stories can now be created. They will use the default information specified to create the levels associated with the 
stories.

Managing Level Types
Available story levels can be managed from the Organization dialog box.
To manage available level types:

1. Select Tools > Organization to open the Organization dialog box. Click the Design Layers tab.
2. Click Level Types.

The Level Types dialog box opens. Specify the level types that are available by default when creating stories.
Click to show/hide the parameters.

3. Click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating and Managing Stories
The Organization Dialog Box
Standard Viewports
Standard Naming

Creating and Managing Stories
Project setup begins with creating stories and specifying their associated story levels. The Stories tab of the 
Organization dialog box allows stories to be created and managed. Stories can also be created when creating or editing 
design layers with options that display only when the Vectorworks Architect product is installed. See “Setting Design 
Layer Properties” on page 165.
To create and manage stories from the Organization dialog box:

1. Select Tools > Organization to open the Organization dialog box. Click the Stories tab.
The functionality of the Organization dialog box is described in “The Organization Dialog Box” on page 155.

2. Visibilities view displays a list of story names. From the top of the dialog box, select Details view.
3. On the left, the stories are listed, along with the story’s prefix or suffix, and elevation. On the right, an interactive 

diagram displays the stories and associated layers that make up the building model. 

Parameter Description

Level Type Name Lists the current default level types
New Opens the New Level Type dialog box, to create a new level type
Edit Opens the Edit Level Type dialog box, to edit the name of the level type
Delete Deletes the currently selected level type
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Click to show/hide the parameters.

4. Click New to create a new story, or Edit to modify the currently selected story.
The New Story or Edit Story dialog box opens. Specify the name, elevation, prefix or suffix for any layers to be 
created, and associated levels. To add objects to a story, at least one layer is required.

Click to show/hide the parameters.

Parameter Description

Story Name list Lists the stories in the building model, along with each story’s prefix or suffix designation 
and elevation. The story order cannot be changed; stories are always listed in elevation order.

New Creates a new story and specifies the associated levels, prefix or suffix, layer (if any), and 
elevation

Edit Edits the selected story’s name, suffix, or elevation
Delete Deletes the selected story or stories; when prompted, select whether to delete all layers 

associated with the story or stories
Default Story Levels Opens the Default Story Levels dialog box, for defining or editing the defined layer defaults; 

see “Default Story Levels” on page 173

Parameter Description

Name Specifies the name of the story
Story Elevation Sets the story elevation; a default value is suggested, based on the elevation of other 

stories
Layer Name Suffix/Prefix When design layers are associated with story levels, specifies the prefix or suffix to 

append to associated design layer names, to distinguish the layers from other design 
layers. The design layer name can be changed later if needed.

Summary story: 
non selected

Expanded story: 
indicates story selected 
in list on left

Story indicator line

Story marker 
(imperial or metric)

Scale figure

Story level; the layer 
icon indicates a link to a 
design layer, and a 
brown color indicates a 
level that overlaps the 
story above or below it
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5. If changing the elevation of a story from the Edit Story dialog box, the Change Story Elevation dialog box opens 
to determine how to adjust the story and the stories around it. If not changing the story elevation, proceed to 
Step 7.

Click to show/hide the parameters.

6. Click OK to return to the Edit Story dialog box.
7. When the story settings have been made, click OK to return to the Organization dialog box.

The stories, once set up with associated levels and any layers with layer-defined objects, define the building 
model. On the Design Layers tab of the Organization dialog box, listed layers that are associated with levels 
display their story, level type, elevation, and default wall height.

~~~~~~~~~~~~~~~~~~~~~~~~~
Organizing the Drawing
Default Story Levels
Standard Viewports
Standard Naming

Classes
In addition to design layers, classes are a powerful way to organize the elements in a drawing project according to 
category. This allows the objects to be viewed, changed, and tracked as a group. Because classes work across design 
layers, they allow the grouping of similar objects in a drawing that for practical reasons need to exist on separate layers. 

Level List Lists the available levels to associate with the story; select a level to include by 
clicking in the first column. Associated levels are indicated with a check mark. Only 
one level of a given type can be associated with a story; the available levels are 
determined by the default story levels. 
When a story layer includes a level, it can be used as a potential boundary for objects 
on layers in its story, or in the story above or below it. Selecting level types for the 
story is optional; however, level types are necessary when setting up a model with 
bounded objects.

New Level Opens the New Story Level dialog box, to add a new level type
Edit Level Opens the Edit Story Level dialog box, to edit the selected level type
Edit Default Story Levels Opens the Default Story Levels dialog box, for editing or adding to the levels 

available in the story; see “Default Story Levels” on page 173

Parameter Description

Move this Story and all 
Stories above it

Changes the elevation of the story, and adjusts all stories above it, including associated 
levels, layers, and layer-defined objects

Move this Story only Changes the elevation of the current story and its associated levels, layers, and objects 
only; other stories remain at their set elevation

Move this Story and all 
Stories below it

Changes the elevation of the story, and adjusts all stories below it, including associated 
levels, layers, and layer-defined objects

Move all Stories Changes the elevation of the story, and adjusts all stories above it and below it, 
including associated levels, layers, and layer-defined objects

Parameter Description
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Classes also allow the same file to be used for all stages of a project and for various purposes. For example, the classes 
shown for a license application could be different from those shown for the building contractor.

Vectorworks classes are similar in function to—and are exported as—AutoCAD layers. If a drawing will be 
exported to AutoCAD, use classes to make it easy to turn on or off selected portions of the drawing. For example, 
if a consultant using AutoCAD will be doing the duct layout for a building, a furniture class allows him or her to 
turn off the furniture layer, instead of deleting furniture objects.

Setting up the classes at the beginning of a project is recommended, so that objects can be assigned to appropriate 
classes as they are created.
Each new drawing created with the Vectorworks program automatically has two classes: Dimension and None. Any 
dimensions created are assigned, by default, to the Dimension class (this is a preference setting that can be changed; see 
“Dimension Preferences” on page 61). Group objects are assigned to the active class. All other objects and symbols are 
assigned to the None class, which is the default active class. These two classes can be renamed but not deleted.
If the drawing was created from a template, other classes may have been provided. New classes can be created, 
duplicated, edited, or deleted. The visibility of the classes can also be changed.
For example, for a drawing of a house with four separate plan layers (first floor, second floor, basement, and roof), 
assign all bathroom fixtures to a class called “Fixtures.” Make the Fixtures class invisible to print the floor plans 
without fixtures, and then make them visible to print the bathroom fixtures for each story of the house.

 

Class information can be linked to worksheets. Using the house example in the previous paragraph, not only can the 
plumbing fixtures plan for the house be printed, but a running inventory of the cost for all plumbing fixtures can be 
kept (see “Using Worksheets” on page 1319).
If Vectorworks Design Series is installed, you can set up the drawing file to have a set of standard classes, which can be 
automatically assigned to specific types of objects as they are created. See “Design Series Layers, Classes, and 
Viewport Standards” on page 184.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Classes
Assigning Objects to Classes and Layers
Displaying Classes in Hierarchical Order
Setting Class Properties
Setting the Active Class
Copying and Pasting Classed Objects
Setting Class and Design Layer Options
Setting Visibilities in the Organization Dialog Box
The Visibility Tool

Creating Classes
Decide on a naming scheme before you create classes. If there are a large number of classes, organize them by naming 
each class with a compound name consisting of up to four parts, separated by a dash. Each name part represents a 
different level in the class naming structure. For example, a drawing of a building might have a class structure that 

Fixtures class invisible Fixtures class visible
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includes main groups for architecture, plumbing, and electrical objects. Within the architecture group, there might be 
door, floor, and wall groups. Those groups in turn have subgroups—for example, the wall subgroup might have interior 
and exterior designations. A class is named according to its position in the class structure, as in Arch-Wall-Ext, 
Elec-Lite-Ceiling, or Plum-Equip-New. 
Class names impact hierarchical display on pop-up menus (including in the Object Info palette, the View bar, and 
dialog boxes) and in the Organization dialog box and (for Vectorworks Design Series products) the Navigation palette. 
To enable or disable hierarchical display on pop-up menus, see “Session Preferences” on page 52; for the Organization 
dialog box and Navigation palette, see “Displaying Classes in Hierarchical Order” on page 159.
In the classes list on the View bar with hierarchical display enabled, each main group is a menu option, with submenus 
for the subgroups. In the following example, the Arch option has a Wall submenu, with Ext and Int options. This type 
of organization makes it easy to assign classes as objects are created.

 

Classes can be created as new, or imported from other current version Vectorworks files or standard files.

To create a new class:

1. For convenience, a new class can be added from multiple locations in the Vectorworks software.
• New button on the Classes tab of the Organization dialog box (Tools > Organization)
• Classes button on the View bar to open the Organization dialog box
• New Class option from the Classes drop-down list on the View bar
• Class field on the Shape tab of the Object Info palette
• New context menu on the Classes tab of the Navigation palette (Vectorworks Design Series required)

2. From the New Class dialog box, create a new class, or import a class and its properties from standard or existing 
Vectorworks files.

Class Type Action

Create New Class Creates a class based on current Attributes palette settings; enter a class Name 
Import Classes Imports classes and their attributes from standard files or existing files. Files located in the 

Standards folder, as well as existing files selected previously, are displayed in the list. 
Select a file; the available classes and descriptions are listed beneath the file name.
Select the desired class(es). To select multiple classes from the import list, hold the Ctrl 
(Windows) or Command (Mac) key while you click.

Show only classes 
that are not in the 
current document

If a class name in the current file matches a class in the import file, normally that class is 
not included on the list as an import option. To display all the classes to be imported, 
deselect this option. The existing classes in the file are replaced by any imported classes 
with the same name, changing the existing class definitions (and any associated objects) to 
those of the imported classes.

Choose Click Choose to select a file for class import. Files must be in the current version.
Creation Options
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3. Click OK to create the new class(es).
The classes display in the Classes list on the Organization dialog box, View bar, Object Info palette, and (for 
Vectorworks Design Series) the Navigation palette. When a new class is created, it does not automatically become 
the active class.

~~~~~~~~~~~~~~~~~~~~~~~~~
Classes
Assigning Objects to Classes and Layers
Importing Drawing Structure from Standards or Other Files
Displaying Classes in Hierarchical Order
Setting Class Properties

Setting Class Properties
Once created, the classes display on the Classes tab of the Organization dialog box, where various properties can be set 
and edited.

To edit classes:

1. Select Tools > Organization. Alternatively, click the Classes button on the View bar.
The Organization dialog box opens.

2. Select the Classes tab.
A list of the current classes in the drawing displays. Depending on which view option is selected at the top of the 
dialog box, either details or visibilities of the classes display. The visibility of classes in the drawing area and the 
active class can be changed in Details view. The visibility of classes in viewports and in saved views can be 
changed in Visibilities view (see “Setting Visibilities in the Organization Dialog Box” on page 193).

3. To change other class properties, select one or more classes and click Edit to open the Edit Class(es) dialog box.
Click to show/hide the parameters.

Saved View 
Visibility

Sets the visibility of the new class in saved views (when saved views exist in the drawing)

Viewport Visibility Sets the visibility of the new class in viewports (when viewports exist in the drawing)
Edit Properties 
After Creation

Immediately after creation, opens the Edit Class(es) dialog box to set the properties of the 
new class(es)

Parameter Description

Name Displays the name of the class; edit as needed
Description Click to enter additional information about the class. The description displays as a screen 

tip when you position the cursor over the class name in the Organization dialog box, 
Navigation palette, or (on Mac only) the Classes list on the View bar. Descriptions also 
display in the New Class dialog box, so that you can see descriptions of classes before you 
import them.

Class Type Action
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Use at Creation Applies the graphic attributes displayed in this dialog box when you create an object 
assigned to this class. If Use at Creation is not selected, you can apply these attributes to 
the object later by selecting Class Style from the Attributes palette.
See “Setting Class Attributes” on page 181 for more information about graphic attributes.

Fill 
Style Select one of the following fill styles from the list

None No fill is applied to the objects in this class
If a Renderworks texture will be applied to objects in this class, select a fill style. If 
the object fill is None, no texture displays when the objects are rendered.

Solid Applies a solid fill to the objects in this class; click the Color box to select the desired 
color

Pattern Applies a patterned fill and color to objects in this class. Click the Pattern box to select 
the desired pattern, and then select the foreground color and background color from the 
color boxes below the pattern.

Hatch Applies a hatch fill to objects in this class. Select a hatch from either the default content or 
the current file’s content.

Tile Applies a tile fill to objects in this class. Select a tile from either the default content or the 
current file’s content.

Gradient Applies a gradient fill to objects in this class. Select a gradient from either the default 
content or the current file’s content.

Image Applies an image fill to objects in this class. Select an image from either the default 
content or the current file’s content.

Opacity Specifies the class transparency (on Windows, the GDI+ imaging Vectorworks preference 
must be enabled). Drag the slider to the left to increase the transparency, or enter an 
opacity percentage in the box to the right of the slider.

Pen
Style Select one of the following pen styles from the list

None No pen outline is applied to the objects in this class
Solid Applies a solid outline to the objects in this class; click the Color box to select the desired 

color
Pattern Applies a patterned outline and color to objects in this class. Click the Pattern box to 

select the desired pattern, and then select the foreground color and background color from 
the color boxes below the pattern.

Line Type Applies a line type outline to objects in this class. Select a line type from either the default 
content or the current file’s content.

Thickness Select the line thickness for the class; to use a custom thickness, select Set Thickness 
from the line thickness list to access the Set Thickness dialog box.

Markers Select the marker style for each end of lines, dimensions, arcs, polylines, 2D polygons, or 
freehand lines in this class. To use a custom marker style, select Custom and specify the 
marker settings, or select Edit Marker List from the marker style list to set the available 
marker types (see “Editing the Marker List” on page 1103).

Parameter Description
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4. Click OK to return to the Organization dialog box. If objects in an edited class already exist in the drawing, and 
the class is set to use attributes “at creation,” you are prompted to specify how to apply the changes to the existing 
objects.

5. Click OK from the Organization dialog box to save the changes.
If multiple classes are simultaneously selected for editing, and some or all of the attribute values are different for the 
selected classes, the editing fields for those values indicate that the value is unknown. When the OK button is clicked, 
the currently defined settings shown are applied to all of the selected classes. Any information with an unknown setting 
is not applied.
~~~~~~~~~~~~~~~~~~~~~~~~~
Displaying Classes in Hierarchical Order
Setting Class Attributes
The Attributes Palette
Resource Libraries

Setting Class Attributes
There are two categories of attributes available for each object: object attributes and class attributes. Object attributes 
are assigned directly to an object from the Attributes palette, Object Info palette, or Resource Browser (depending on 
the type of attribute). Class attributes are determined by the object’s class settings.
The attributes that an object uses when it is created are controlled by options in the Edit Class(es) dialog box:

• Use at Creation (for 2D graphic attributes)
• Use Text Style at Creation (for text in text objects, dimensions, callouts, and other annotation objects)
• Use Textures/Surface Hatches at Creation (for textures in walls, roofs, and other 3D shapes)

When one of these “use at creation” options is selected for a class, objects created in that class or subsequently assigned 
to that class use the class attributes. The Attributes palette displays an arrow to indicate that the attributes have been set 
by class. If objects in that class already existed before the “use at creation” option is selected, you are prompted to 
decide how to apply the attributes to the existing objects.
Class attributes can also be assigned after objects are created:

• From the Attributes palette, select Class Style or Class Thickness from the appropriate attribute list.
• In the Shape tab of the Object Info palette, select <Class Text Style> from the Text Style list.
• In the Render tab of the Object Info palette, select Class Texture from the Texture list.

Use Text Style __ at 
Creation

From the list, select a text style to apply to objects in this class. To apply the text style 
when you create an object in this class, also select the Use Text Style at Creation option. 
If Use Text Style at Creation is not selected, you can apply this text style to the object 
later by selecting <Class Text Style> as the Text Style in the Object Info palette.

Walls, Roofs, and Other 
tabs

If Renderworks is installed, click these tabs to set the texture/surface hatch properties for 
wall, roof, and other objects assigned to the class. See “Applying Textures to Symbols, 
Walls, and Roofs” on page 1542 for more information.

Saved Views If there are saved views in the drawing, opens the Saved View Visibilities dialog box. Set 
the visibility for the new class(es) in the saved views (Visible, Invisible, Gray, or Don’t 
Save). See “Setting Visibilities in the Organization Dialog Box” on page 193.

Viewports If there are viewports in the drawing, opens the Viewport Visibilities dialog box. Set the 
visibility for the new class(es) in the viewports (Visible, Invisible, Gray, or Don’t Save). 
See “Setting Visibilities in the Organization Dialog Box” on page 193.

Parameter Description
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To override class attributes, select the object(s) and apply different attributes directly from the Attributes palette, Object 
Info palette, or Resource Browser.
Several plug-in objects (such as Vectorworks Design Series doors and windows) offer the option to control the 
appearance and visibility of the smaller object parts either individually, or by the same class as the overall object. For 
example, select the <Door Class> option for the door jamb, lintel, and threshold to assign those door parts to the same 
class as the door object. If you change the door’s class later, the appearance and visibility of the smaller door parts 
automatically change according to the new class.

For more information, see “The Attributes Palette” on page 1093.

Setting the Active Class
To be able to remove or edit objects in a particular class, either the class must be active or the class options must be set 
to allow modifications to other classes (see “Setting Class and Design Layer Options” on page 193). There are several 
ways to change the active class.

If there are a small number of classes, switch between classes with the Switch active layer/class shortcut key 
combination specified in the Vectorworks preferences (see “Edit Preferences” on page 49). This selects a class by 
moving up or down through the class list one layer at a time. If the drawing has a large number of classes, use one 
of the following options.

Setting the Active Class in the Organization Dialog Box
To set the active class:

1. From the Organization dialog box, select the Classes tab in Details view.
The active class is indicated by a check mark to the left of the Class Name. The name of the class also is 
highlighted in bold text.

2. To make a different class active, click the column to the left of its name.
3. Click OK.

The dialog box closes and the active class displays.

Setting the Active Class in the View Bar
To set the active class:

1. Click the Classes list on the View bar to display a list of all of the drawing’s classes.
On Mac, the active class is indicated by a check mark; on Windows, the class name is highlighted in bold text.

2. Click the class to be activated.
The classes list closes and the active class displays.

Class attribute: controlled by the
attributes set for the object’s class

Object attribute: controlled by the
Attributes palette setting

Class attributes are represented by a curved arrow
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Setting the Active Class in the Navigation Palette
To set the active class:

1. From the Navigation palette, select the Classes tab. 
The active class is indicated by a check mark to the left of the class name. The name of the class also is highlighted 
in bold text.

2. To make a different class active, click the column to the left of its name.
Alternatively, Right-click (Windows) or Ctrl-click (Mac) on the class to be activated and select Activate from the 
context menu.

Setting the Active Class in the Document Context Menu
If multiple classes are set to be visible, and the class options are set to show those other classes, the drawing area may 
display objects that are in non-active classes. Use the Activate Class command to make the class of one of these 
objects active.

The Force Select command on the document context menu also changes the active class and the active layer (if 
necessary), and selects the clicked object.

To set the active class:
1. In the drawing area, right-click (Windows) or Ctrl-click (Mac) a visible object in a non-active class.
2. From the document context menu, select Activate Class.

The object’s class becomes active.

Copying and Pasting Classed Objects
Objects in a class can be copied and pasted from one drawing to another, even if the destination drawing does not 
contain the same class as the original drawing. The program automatically creates a new class in the destination 
drawing and transfers all of the class information from the source drawing. If the destination drawing already has a 
class with the same name as the source drawing, only the object information is pasted. All of the class information for 
the destination drawing’s class remains unchanged.
When you paste objects that could become invisible due to class visibility settings, specify whether the invisible classes 
should be made visible so that the pasted objects can be seen.

Right-click (Windows) or Ctrl-click (Mac) on a 
cabinet in a gray, non-active class to open the 
document context menu

The Activate Class command activates 
the cabinet’s class, and the objects that are 
not in that class become grayed
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Design Series Layers, Classes, and Viewport Standards
The standards for the Vectorworks Architect and Landmark products take advantage of layer and class characteristics.

Class Characteristics
Each drawing object is assigned to a class, as well as a layer. The class determines the object’s appearance, while the 
layer determines the object’s location. Classes apply to the entire file and control the visibility of objects. The currently 
active class is visible; but classes can be set to be visible, invisible, or grayed when they are inactive. Complex objects, 
such as symbols or plug-in objects, may contain more than one class; if so, different parts of the object can be hidden or 
shown. Classes can also be used to assign graphical attributes, textures, and text styles to objects.
Many plug-in objects that are included with Vectorworks Architect and Landmark products are set with pre-assigned 
classes. The appropriate classes are created at setup and by certain other commands (see “Automatically Created 
Classes” on page 185). The use of automatic classing is determined with the Standard Naming setup command. For 
more information, see “Importing Drawing Structure from Standards or Other Files” on page 161 and “Classes” on 
page 176.

Layer and Viewport Characteristics
A layer is a named container that holds items. There are two types of layers: design layers and sheet layers. Design 
layers are used for drawing and modeling the elements of a project. Sheet layers are created for the presentation of a 
finalized project, and can contain viewports, title blocks, notes, and other annotations. A viewport, located on a sheet or 
design layer, is a particular combination of visible, grayed, and/or hidden design layers and classes.
Layers have certain characteristics that are used when drawing and structuring files:

• Design layers can automatically set default elevation values for objects they contain. They create natural structural 
divisions within a project for objects on different floors or different vertical locations within a floor. 

• Design layers can be visible, invisible, or grayed. Sheet layers are always set to Active Only. 
• Design layers, as well as viewports, can be displayed at different drawing scales, for the display of all aspects of a 

project plan from the site model to details.
• Design layers, as well as viewports, can have different 3D views. A building can be viewed in Plan view in one 

viewport and in an elevation or perspective view in another.
• Layers can be contained in different files and shared using workgroup referencing.

Projects set up according to standards contain both design layers and sheet layers with viewports. An architectural 
project file contains, at a minimum, stories with design layers for every level, as well as a number of viewports on sheet 
layers.
A typical Vectorworks Landmark product standard file setup includes landscape site plans composed of shared model 
information on four layers:

• Mod-Site-Arch – contains any buildings or other improvements
• Mod-Site-Civil – contains topographic and survey information
• Mod-Site-DTMData – contains the site model output
• Mod-Site-Landscape – contains tree and planting data

When a file is set up with the Create Standard Viewports command (Vectorworks Architect required), the appropriate 
classes and layers are created automatically. The number and types of layers and classes created depend on the setup 
selections. In the Vectorworks Architect product, design layers are created by stories, and begin with “Mod-” (model 
layers, since this is where the model is designed). The Create Standard Viewports command creates the appropriate 
viewports and sheet layers for the viewports (beginning with “Sheet-”), along with the appropriate classes if they are 
not already in the file (see “Standard Viewports” on page 186).
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The Standard Naming command establishes or changes the naming conventions used for these classes, design layers, 
sheet layers, and viewports or saved views (see “Standard Naming” on page 92).

Set up a new, blank file with standards, and then save as a template for future use.
Setup standards are determined by the LayerMap.G worksheet, which can be imported and customized by 
advanced users. If an existing file already contains a set of custom standards and the LayerMap.G worksheet is 
present in the file, the Import LayerMap.G dialog box opens when selecting Create Standard Viewports 
(Vectorworks Architect required). Select whether to keep the imported and customized worksheet, or whether to 
revert to the standard setup. See “Using the Layermap Worksheet” on page 1891 for more information.

~~~~~~~~~~~~~~~~~~~~~~~~~
Automatically Created Classes
Standard Viewports

Automatically Created Classes
Several classes are created automatically by features in the Vectorworks Design Series products, regardless of whether 
standards have been established at setup. See “Setting Class Properties” on page 179. Examples of automatically 
created classes include:

• NonPlot (Vectorworks Architect): This class is created as part of doors and windows. The loci that define the 
window and door edges are created in this class, which is normally set to Invisible so that the loci are hidden.

• Redlines (Vectorworks Architect, Landmark, Spotlight): This class is created by the Redline tool. All redline 
objects are placed in this class, which allows all redlines in the file to be shown or hidden. This class is toggled to 
visible and invisible by the Show or Hide Redlines command.

• Guides (Vectorworks Architect and Landmark): This class is created and used by selecting Modify > Guides > 
Make Guide.

• The Wall Framer command (Vectorworks Architect) creates the following classes: Framer-Block, Framer-Sole 
Plate, Framer-Header, Framer-Stud, Framer-Sill, and Framer-Top Plate.

• Site-DTM-Modifier (Vectorworks Architect and Landmark): This class is created by the Pad, Texture Bed, Grade 
Limits, and Spoil Pile objects. The Landscape Walls and Roadway objects include pad and grade limit objects if 
the Use Site Modifiers and Use Grade Limits check box is selected on the Object Info palette. This class is 
toggled to visible and invisible by the Show or Hide Site Modifiers command.

• Irrigation-SprayPat (Vectorworks Landmark): This class is created by using the Irrigation Head and Drip Emitter 
objects. This class is toggled to visible and invisible by the Show or Hide Spray Pattern command.

Object Auto-classing
Auto-classing is the automatic assignment of certain objects to a default class. Many plug-in objects in the libraries 
provided have been pre-assigned to the proper class according to the drawing standard for the Vectorworks Architect 
and Landmark products (VWArch). For a list of auto-classing objects, see “Auto-classing Objects” on page 1895.
If the Use Auto-classing check box is selected in Standard Naming (see “Standard Naming” on page 92), then these 
plug-in objects will be automatically placed in the designated class as they are added to the drawing. The object’s class 
is created automatically if it does not yet exist.
If a file has not been structured according to setup standards, or the Use Auto-classing check box is not selected, the 
objects are placed in the active class. The objects, upon regeneration, are assigned to the proper class if the file is later 
set up. Any symbol, when created, can be set to default to a class from the Symbol Insertion Options dialog box.
If you use a naming standard other than VWArch, the default class of the object libraries must be reset.

Save a backup version of the object libraries before editing them. See “Resource Libraries” on page 219.
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To set the default class of all the symbols in a library file:
1. Select File > Open.

The standard Open dialog box opens.
2. Select the Libraries folder, and then click Open.
3. Select the first object library file to convert, and then click Open.

The selected file opens in the drawing window.
4. Select Tools > Utilities > Set Default Symbol Class.

A warning dialog box opens. Click Yes to acknowledge converting all symbol definitions in the file to the new 
default class name.
The Enter String dialog box opens.

5. Enter the default class name for the symbols, and then click OK.
Ensure that the name is spelled correctly to match the desired custom class standard. This command can be 
undone if necessary. If the name matches an existing name in the file other than a class, an alert dialog box opens.

6. Select File > Save to save the changes.
7. Repeat steps 1 through 6 for each object library.

Any time that symbols are used from this file, they will take on the specified class as their default class.
The command does not distinguish between one symbol definition and another. All symbol definitions in the file 
will take on the new class name. For that reason, to use on custom libraries, run the command on a copy of the file.

~~~~~~~~~~~~~~~~~~~~~~~~~
Auto-classing Objects

Standard Viewports
The Create Standard Viewports command creates standards-compliant viewports and their associated sheet layers, 
with the layer and class visibilities of a standard drawing. See “Creating Sheet Layer Viewports” on page 1616.
If desired, views corresponding to the viewports can also be created. This allows easy navigation through the different 
drawing views (with set layer and class visibilities) during the design process.
Viewports are created in five categories. The available viewport types are:

• Site Plan Drawings
• Project Plan Drawings
• Floor Plan Drawings
• Auxiliary Plan Drawings
• Notation Drawings

Select the Create Standard Viewports command again to make changes to the project settings at any time. The 
column on the right shows the current viewports when the command is run again.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Standard Viewport Preferences
Creating Standard Viewports
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Setting Standard Viewport Preferences
Stories must be created before creating standard viewports (see “Setting Up the Building Structure with Stories” on 
page 172). The default viewport scale and sheet border settings can be set prior to adding standard viewports to a 
project.
To set viewport preferences:

1. Select File > Document Settings > Create Standard Viewports.
The Create Standard Viewports dialog box opens.

2. Click Preferences.
The Create Viewport Preferences dialog box opens. The preferences apply as viewports are added to the list for 
inclusion in the project.

3. Set the default scale for each type of viewport; select a sheet border and, if desired, title block to add automatically 
to each sheet layer. The scale settings affect only the viewport scale, not the layer scale of any model layers. See 
“Adding a Sheet Border” on page 77 for more information on sheet borders.

4. Click OK to return to the Create Standard Viewports dialog box.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Standard Viewports
Standard Viewports

Creating Standard Viewports
Stories must be created before creating standard viewports (see “Setting Up the Building Structure with Stories” on 
page 172). 
To create standard viewports:

1. Select File > Document Settings > Create Standard Viewports.
The Create Standard Viewports dialog box opens. Select a drawing category from the Type of Drawing list. The 
available drawing types display in the Drawing Types list on the left, with a short description beneath. Select the 
viewport to be created in the Drawing Types list and then click Add to move it to the Viewports to Be Created 
list on the right.
For auxiliary view viewports (sections and elevations), types with a -Man suffix (such as Sections-Man) typically 
indicate that the elements of the section or elevation are to be drawn manually on, for instance, Mod-Section or 
Mod-Elevation layers, which are created along with the viewports. The visibility of all other layers is set to 
Invisible for these viewports. Types with a -VP suffix (such as Sections-VP) are for creating a view or a section 
viewport of the model from existing Mod- layers. No new layers are created and the visibility of all existing Mod- 
layers is set to Visible for these viewports.

Click to show/hide the parameters.

Parameter Description

Type of Drawing Lists the categories of viewport types
Drawing Types Lists the available viewport types in the selected Type of Drawing category
Description of Drawing Type Provides a description of the Type of Drawing category
Viewports to be Created Lists the viewports that will be created, along with the specified scale, sheet border 

and sheet layer parameters
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2. Once the list of viewports is ready, click OK. Any sheet layers specified that do not already exist in the drawing 
are created along with the listed viewports (and views if the Create Corresponding View option was selected).
In a new drawing, the viewports display with a red X, indicating that they are currently empty. As the drawing is 
developed on the design layers, the viewports will display the contents appropriately. Depending on the rendering 
mode specified, some viewports may require updating with the Update Selected Viewports command.

~~~~~~~~~~~~~~~~~~~~~~~~~
Standard Viewports
Standard Naming

Add > Adds the selected viewport types from the Drawing Types list to the Viewports to 
be Created list, including them in the drawing setup

< Remove Removes the selected viewport from the Viewports to be Created list
<< Remove All Removes all viewports from the Viewports to be Created list 
Preferences Specifies the scale and sheet border parameter preferences when adding viewports 

to the Viewports to be Created list
Sheet Options

Create All Stories
(Vectorworks Architect 
required)

For Floor Plan drawings, creates the selected viewport for each story; deselect to 
specify an individual story based on its Suffix instead

Suffix For Floor Plan, Auxiliary or Notation drawings, specify the individual story by its 
suffix to create the viewport

Use sheet border on 
selected sheet

Places the sheet border specified in Create Viewport Preferences on the sheet layer 
when the viewport is added to the drawing

Use Vectorworks uniform 
drawing numbering system

Uses the Vectorworks uniform sheet numbers and sheet type designators  

Use automatic drawing 
coordination

Matches the sheet number and title to the sheet border title block

Viewport Options Select a viewport from the Drawing Types list to set its parameters before adding 
it to the Viewports to be Created list. Alternatively, select a viewport in the 
Viewports to be Created list to set or change its options.

On Sheet Layer Select a sheet layer where the viewport will be placed. A default sheet layer name 
is provided, but a different sheet layer can be selected. Alternatively, a new sheet 
layer name can be created, by selecting New Sheet Layer and providing the sheet 
layer name.

Viewport parameters Sets the viewport scale, view, projection, perspective, and rendering as described 
in “Creating a Sheet Layer Viewport from a Design Layer” on page 1616

Create corresponding view 
for each viewport

For each viewport in the Viewports to be Created list, creates a corresponding 
view with the same name. It is useful during the design process to navigate among 
the different project views, where the proper layer and class visibilities have 
already been set.

Parameter Description
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Saved Views
A saved view is like a camera that is set up to show a drawing from a certain orientation, with a specific set of viewing 
parameters, including which class and design layer are active, the visibilities of the inactive classes and the design 
layers, the current zoom and pan, and the page location. If Vectorworks Design Series is installed, the plan rotation and 
the clip cube position can be saved.

Views are also used to create Move Along Path animations (see “Creating and Editing Move Along Path Animations” 
on page 1182 for more information).
Saved views can be created, edited, duplicated, and deleted from the Organization dialog box as described in the 
following sections.

Click here for a video tip on this topic (Internet connection required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Saved Views
Editing Saved Views
Creating or Editing Saved Views Using the Saved Views Menu
Viewing History
Organizing the Drawing

Creating Saved Views
To save the current drawing area view:

1. Select View > Save View.
Alternatively, from the Organization dialog box, click the Saved Views tab, and then click the New button. If 
Vectorworks Design Series is installed, from the Navigation palette, click the Saved Views tab, and then select the 
New command from the navigation menu.

2. The Save View dialog box opens.
3. Specify the view options, the active layer and class, and the visibilities of layers and classes.

Click to show/hide the parameters.

Parameter Description

View Name Specify the view name

Zoomed in view Zoomed out view

http://www.youtube.com/watch?v=uOnOOoPz0hg
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4. Click OK to save the view with the specified settings. The saved view is then available from the Saved Views 
menu and from the Organization dialog box.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Saved Views
Creating or Editing Saved Views Using the Saved Views Menu
Viewing History
Setting Class and Design Layer Options
Setting Visibilities in the Organization Dialog Box

Editing Saved Views
Set the active class and layer, the class and design layer options, and the class and design layer visibilities when you 
create the saved view (in the Save View dialog box). Those initial settings can be changed later from the Organization 
dialog box.
To edit a saved view:

1. Select Tools > Organization. The Organization dialog box opens.
2. Select the Saved Views tab in Visibilities view.

The visibilities of classes and design layers for the selected saved view display. 

Save View 
Orientation

Saves the general view parameters of the active layer, including the projection, 3D 
orientation, and page origin settings. If Vectorworks Design Series is installed, the plan 
rotation and the clip cube position are also saved.

Save Zoom and Pan Saves the zoom and pan settings of the active layer
Save Page Location Saves the design layer page location with the view; if deselected, the current page location 

setting is used when the view is displayed. The page location of sheet layers cannot be saved.
Save Unified View Saves the unified view status with the view; if deselected, the current unified view setting is 

used when the view is displayed
Save Render Mode 
and Options

Saves the render mode and options with the view; if deselected, the current render mode and 
options are used when the view is displayed

Saving the render settings with the view is an effective method of saving and restoring 
custom rendering options.

Save Layer 
Visibility

Specifies the layer visibility options to save; if deselected, the current layer visibility settings 
are used when the view is displayed

Layer Options Select the design layer display options
Active Layer Select the active layer; if a sheet layer is selected, the Layers button is disabled
Layers Opens the Layer Visibilities dialog box; specify the design layer visibilities for the saved 

view (see “Using Visibility Columns” on page 193 for details)
Save Class 
Visibility

Specifies the class visibility options to save; if deselected, the current class visibility settings 
are used when the view is displayed

Class Options Select the class display options
Active Class Select the active class from the list of classes
Classes Opens the Class Visibilities dialog box; specify the class visibilities for the saved view (see 

“Using Visibility Columns” on page 193 for details)

Parameter Description
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3. Select a view to edit from the Saved View Name list.
4. If Save Class Visibility was selected in the Save View dialog box, Class Options and Active Class are enabled in 

the Organization dialog box. If Save Layer Visibility was selected in the Save View dialog box, Layer Options 
and Active Layer are enabled in the Organization dialog box. Change the Active Layer and the Active Class as 
necessary. Change the Class Options and Layer Options as described in “Setting Class and Design Layer 
Options” on page 193.

5. Change the visibilities of classes and design layers as necessary. See “Setting Visibilities in the Organization 
Dialog Box” on page 193.

6. To change other saved view properties, click Edit.
The Edit Saved View dialog box opens.
The settings are the same as when the view is created. Classes and layers that were added after a view was created 
are listed as visible in the visibility settings.
If the layer or class visibility was saved when the view was created, Restore Layer Visibility and Restore Class 
Visibility are enabled. Select Restore Layer Visibility to restore the layer visibilities, the layer options, and the 
active layer that were set when the view was saved. Select Restore Class Visibility to restore the class visibilities, 
the class options, and the active class that were set when the view was saved.
Saved views are saved as VectorScript macros. If necessary, click Edit Script to edit the script.

7. Click OK to save the changes. Click OK again to close the Organization dialog box.
Another way to edit a saved view is through the Saved Views palette. Select Window > Script Palettes > Saved 
Views. Press the Option (Mac) or Alt (Windows) key and double-click the view name to edit. Double-click the view 
script name to switch the current drawing area to the saved view.
If Vectorworks Design Series is installed, you can also edit saved views from the Navigation palette; see “The 
Navigation Palette” on page 199.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Saved Views
Creating or Editing Saved Views Using the Saved Views Menu

Redefining Saved Views
To change the content of a saved view, use the Redefine command. This changes the saved view settings to match 
those of the current drawing area view, including the current layer options and class options, the plan rotation, the 
visibility of layers and classes that are inactive, and the active layer and class.
To redefine a saved view:

1. From the Navigation palette, select the Saved Views tab.
2. Select the view to be changed from the list.
3. From the Navigation menu or the view context menu, select Redefine.

The Redefine Saved View dialog box opens. Specify the view options and the visibility parameters. 
Click to show/hide the parameters.

Parameter Description

View Name Specify the view name
Restore Options
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4. Click OK to save the current drawing area view with the specified settings.

Creating or Editing Saved Views Using the Saved Views Menu
The View bar has shortcuts to save a view, to edit a saved view, or to switch the current drawing area view to a 
previously saved view.

Views can also be accessed through the Saved Views palette. Select Window > Script Palettes > Saved Views. 
Double-click the view name to switch to that view.

To use the Saved Views menu:
1. Click the Saved Views menu on the View bar.

 

2. Select the desired item from the menu.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Saved Views
Editing Saved Views
Viewing History

View 
Orientation

Saves the general view parameters (current projection, 3D orientation, plan rotation, and page 
origin settings) of the active layer

Zoom and Pan Saves the zoom and pan settings of the active layer
Page Location Saves the design layer page location with the view; if deselected, the current page location 

setting is used when the view is displayed. The page location of sheet layers cannot be saved.
Unified View Saves the current unified view status, whether on or off; if deselected, the current unified view 

status is ignored and the status in effect when the view was created is used
Render Mode 
and Options

Saves the current render mode and render options; if deselected, uses the render mode and 
options that were set when the view was created (if saved at that time)

Layer 
Visibility

Saves the current layer visibilities; if deselected, uses the visibilities that were set when the view 
was created (if saved at that time)

Class Visibility Saves the current class visibilities; if deselected, uses the visibilities that were set when the view 
was created (if saved at that time)

Menu Item Description

Save View Opens the Save View dialog box
Edit View Opens the Saved Views tab of the Organization dialog box
List of saved views Select a saved view from the list to switch to that view

Parameter Description

List of saved views

Click to open the
Saved Views menu
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Setting Class and Design Layer Options
The Class Options and Layer Options commands control how all the classes or design layers in a drawing display. 
For example, a drawing project can be set to display only the active class, temporarily hiding all objects assigned to 
other classes.
To change the options for displaying, snapping to, and editing objects in the current class or design layer:

1. Select View > Class Options (or Layer Options) and then the option.
Alternatively, right-click (Windows) or Ctrl-click (Mac) in the drawing area and select Class Options or Layer 
Options from the document context menu.

2. The current class or design layer display changes accordingly.
Click here for a video tip on this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Visibilities in the Organization Dialog Box
The Visibility Tool

Setting Visibilities in the Organization Dialog Box
The active class and design layer are always visible. Each inactive class and design layer can be set to be visible, 
invisible, or gray. These visibilities can be set independently for the drawing area, saved views, and viewports.

The level of gray for grayed layers and classes can be adjusted for printing; see “Printing a File” on page 1763.

Using Visibility Columns
For maximum usability, class and design layer visibilities can be set in multiple places in the Organization dialog box, 
and also in other dialog boxes. The Visibility columns work the same wherever they are used.

Command Description

Active Only Displays only objects in the active class/layer; only the active class/layer prints
Gray Others Displays the active class/layer normally and all other classes/layers appear dimmed (except for 

those set to invisible); even though visible, objects in dimmed classes/layers cannot be edited
Gray/Snap 
Others

Displays the active class/layer normally and all other classes/layers appear dimmed (except for 
those set to invisible); objects in any normally displayed or gray class/layer can be snapped to. 
Only objects in the active class/layer can be edited.

Show Others All classes/layers display normally, except for those set to invisible or grayed; even though 
visible, objects in classes/layers other than the active class/layer are not editable and cannot be 
snapped to

Show/Snap 
Others

All classes/layers display normally, except for those set to invisible or grayed; objects in any 
normally displayed or gray class/layer can be snapped to. Only objects in the active class/layer 
can be edited.

Show/Snap/
Modify Others

All classes/layers display normally, except for those set to invisible or grayed. Objects in any 
normally displayed or gray class/layer can be snapped to; only objects in normally displayed 
classes/layers can be edited. (An object on another layer can only be edited if its layer scale and 
view are the same as those of the active layer.) Locked objects display with gray highlighting.

http://www.youtube.com/watch?v=1f_gXMPFjf8
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To change the setting for a single class or design layer, click in one of its visibility columns. To change the settings for 
multiple items, click a visibility column as follows:

• Press the Ctrl key (Windows) or Cmd key (Mac) and click selected class or layer rows
• Press the Shift key and click the first and last rows of a group of classes or layers
• Press the Alt key (Windows) or Option key (Mac) and click any row to change all classes or layers

For classes displayed in hierarchical order, change the visibility setting of a group header to change the visibility 
of all of its subclasses; see “Displaying Classes in Hierarchical Order” on page 159.

Setting Class and Design Layer Visibility for the Drawing Area
Use the Organization dialog box to set the visibilities of classes and design layers in the drawing area. If Vectorworks 
Design Series software is installed, you can use the Navigation palette to set visibilities also (see “The Navigation 
Palette” on page 199).
Class and design layer visibility in the drawing area are also affected by the Class Options and Layer Options 
settings. See “Setting Class and Design Layer Options” on page 193 for details.
To set the class and design layer visibilities for the drawing area:

1. From the Organization dialog box, select the Classes or Design Layers tab in Details view.
2. Change the Visibility settings as desired.
3. To see the changes before saving them, click Preview.
4. Click OK to save the changes.

Column Description

Visible Class/design layer is visible; objects in this class/layer display when another class/layer is active

Invisible Class/design layer is invisible; objects in this class/layer display only when the class/layer is active

Gray Class/design layer is gray; objects in this class/layer are dimmed when another class/layer is active

Don’t Save For saved views, a fourth column displays to the right of the other columns. When selected, class/
design layer visibility is not saved for the saved view; the current class/layer visibility is used when 
the view is displayed.
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Setting Class and Design Layer Visibility for Viewports and Saved Views
Use the Organization dialog box to set the visibilities of classes and design layers in existing viewports and saved 
views. You can also set these visibilities while creating and editing classes, design layers, viewports, and saved views, 
as described in the following topics:

• “Creating Classes” on page 177 and “Setting Class Properties” on page 179
• “Creating Layers” on page 162 and “Setting Design Layer Properties” on page 165
• “Viewport Properties” on page 1636
• “Creating Saved Views” on page 189

To set the class and design layer visibilities for viewports and saved views:
1. From the Organization dialog box, select a tab in Visibilities view. 

2. Select one or more class, design layer, viewport, or saved view names and change the Visibility settings for 
classes and design layers as desired.

3. On the Saved Views tab, change the active design layer and class, and the design layer and class options.
4. To see the changes before saving them, click Preview (not available on the Saved Views tab).
5. Click OK to save the changes.

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Class and Design Layer Options
The Visibility Tool

The Visibility Tool
The Visibility tool changes the visibility of either the layer or class associated with a clicked object. If you click an 
object in the drawing area, the document visibility changes. If you click an object in a sheet layer or design layer 
viewport, only the visibility in that viewport changes (with some exceptions). You can also make rapid changes to the 
visibilities of multiple layers or classes in the drawing at one time by double-clicking the tool itself.

You cannot change the class and layer visibilities within a section viewport with the Visibility tool.
The Visibility tool is available in the workspaces of all Vectorworks Design Series products; for the Vectorworks 
Fundamentals product, you can edit the workspace to add the Visibility tool.
Several modes are available, to specify whether to change class or layer visibility, and what type of visibility change to 
make.

Organization Dialog Box Tab Sets Visibility of

Classes Classes in viewports and saved views; if classes are displayed in hierarchical order 
and a class group header is selected, the viewport and saved view lists are disabled

Design Layer Design layers in viewports and saved views
Viewports Classes and design layers in a viewport
Saved Views Classes and design layers in a saved view

Classes Visible

Invisible

Greyed

PreferencesLayers

http://www.youtube.com/watch?v=Y_YyygWd9dw
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Click here for a video tip about this topic (Internet access required).

Layer or Class Visibility Changes

To change class or layer visibilities based on a clicked object:

1. Click the Visibility tool from the Basic palette.
2. From the Tool bar, select Classes or Layers mode. Then select whether to make the object’s class or layer Visible, 

Invisible, or Greyed.
3. If the class or layer to be changed is currently invisible, ensure that the class or layer options are not set to Active 

Only. Press and hold the shortcut key for the Visibility tool (V by default) to temporarily make all classes (in 
Classes mode) or layers (in Layers mode) visible. If the cursor is over a viewport, all classes or layers in the 
viewport become visible.
In Classes mode, if the cursor is over a design layer viewport that is set to use the class visibilities of the 
document, all document classes become visible (which includes the classes in the viewport).

4. Move the cursor over a drawing object that is in the class or layer to be changed. All objects that will be affected 
by the visibility change are highlighted. In addition, a screen tip indicates the name of the class or layer that will 
be changed, as well as its current visibility setting. If the object is in a viewport, the screen tip also indicates the 
name of the viewport in which the change will be made.
In Classes mode, if the object is in a design layer viewport that is set to use the class visibilities of the document, 
the screen tip does not show the viewport name. This indicates that a click on the object will change the class 
visibility for the document (not the viewport)—including objects of that class that are not in the viewport.

5. Click on the object to change the visibility setting for its class or layer.
The object’s class or layer is set to visible, invisible, or gray, and the Message bar shows the change that occurred. 
The Navigation palette (Vectorworks Design Series required) updates to display the new visibility status. On a 
design layer, changes to class visibility redraw the entire drawing; changes to layer visibility redraw the layer.

Mode Description

Classes Affects the visibility of the clicked object’s class
Layers Affects the visibility of the clicked object’s layer
Visible Sets the clicked object’s class or layer to visible
Invisible Hides the clicked object’s class or layer
Greyed Sets the clicked object’s class or layer to gray
Preferences Specifies the behavior when the Visibility tool is double-clicked

http://www.youtube.com/watch?v=xQ7um3lBM9U
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Reasons for Class or Layer Visibility not Changing
When you use the Visibility tool to make class or layer changes, several factors may prevent the visibility from 
changing as expected.

• The layer and class options control the visibility of objects in the inactive layers and classes. For example, if the 
layer options are set to gray objects in inactive layers, grayed objects do not become fully visible when clicked 
with the Visibility tool. (See “Setting Class and Design Layer Options” on page 193.) An alert displays in this 
situation.

• The Visibility tool cannot hide or gray the active class or layer immediately, since the active class or layer is 
always set to visible. An alert displays in this situation.

• A container object (such as a symbol or a group) and its component parts can belong to different classes, and their 
visibilities can be set differently. For example, if the classes of the individual objects that make up a symbol are set 
to invisible or gray, they do not become visible when the symbol’s class is made visible.

• In a viewport, changes to class or layer visibility display immediately if the viewport has a background render 
mode of Wireframe, Sketch, or OpenGL. For other render modes, you must update the viewport to see the 
visibility change. An alert displays in this situation.

• If a design layer viewport (Vectorworks Design Series required) is embedded in another viewport, several factors 
affect the behavior of the Visibility tool. See “Visibility Tool Behavior in Embedded Viewports” on page 198 for 
more information.

Global Visibility Changes
The Visibility tool can make global changes to the class or layer visibilities of a drawing. In a complex drawing, for 
example, this can be an easy way to quickly show only the classes or layers of selected objects. All classes or layers can 
easily be set to show again. This feature does not affect visibilities in viewports.

The “Furniture” class becomes gray

With the Visibility tool set to make the class gray, press the 
V key to temporarily show all classes, including those that 
are currently invisible

Click an object in the “Furniture” class

Class: Furniture (Invisible)
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To make global changes to the visibility of classes or layers:

1. To make changes to the class or layer visibility of selected objects, select the objects first.
The objects do not need to be in the same class or layer.

2. Click the Visibility tool from the Basic palette.
3. Select Preferences from the Tool bar.

The Visibility Tool Preferences dialog box opens. Specify the effect to occur when the Visibility tool is 
double-clicked.

Click to show/hide the parameters.

4. Click OK.
5. Double-click the Visibility tool to execute the selected action.

The classes or layers in the drawing area are set to visible or invisible as specified, and the Message bar shows the 
change that occurred. The Navigation palette (Vectorworks Design Series required) updates to display the new 
visibility status.

Reasons for Global Visibility not Changing
When you use the Visibility tool to make global changes, several factors may prevent the visibility from changing as 
expected.

• The layer and class options control the visibility of objects in the inactive layers and classes. For example, if the 
layer options are set to gray objects in inactive layers, grayed objects do not become fully visible when the 
Visibility tool is double-clicked. (See “Setting Class and Design Layer Options” on page 193.) An alert displays 
in this situation.

• The Visibility tool cannot hide the active class or layer immediately, since the active class or layer is always set to 
visible. An alert displays in this situation.

• A container object (such as a symbol or a group) and its component parts can belong to different classes, and their 
visibilities can be set differently. For example, if the classes of the individual objects that make up a symbol are set 
to invisible or gray, they become visible only when the first double-click option (Makes all classes visible) is used.

Visibility Tool Behavior in Embedded Viewports
Design layer viewports (Vectorworks Design Series required) can be embedded in both sheet layer and design layer 
viewports, and they can be referenced or not. There are settings in the viewport properties of all of these viewports to 
control the way classes and layers display, which affect the behavior of the Visibility tool.

Cases Where Viewport Visibility Does not Change
The following cases describe the conditions under which the Visibility tool cannot change the visibilities of the class or 
layer of a clicked object, when the object is in a design layer viewport that is embedded in another viewport.

Parameter Description

Makes all classes visible All classes in the drawing area are set to visible
Makes all layers visible All layers in the drawing area are set to visible
Makes only the classes of the selected objects 
visible

The class(es) of selected objects remain visible; other classes are 
set to invisible

Makes only the layers of the selected objects 
visible

The layer(s) of selected objects remain visible; other layers are set 
to invisible



The Navigation Palette |  199
• The top-level viewport is a sheet layer viewport, and it is set to use the class or layer visibilities of the embedded 
viewport. The tool can only change the top-level viewport’s visibility setting for the class or layer of the embedded 
viewport itself. The tool cannot change the visibility for the class or layer of an object inside the embedded 
viewport.

• The top-level viewport is a sheet layer viewport, and it is not set to use the class or layer visibilities of the 
embedded viewport. However, the embedded viewport is referenced. In a referenced viewport, each class can 
either keep its own settings, or take on the settings of the document in which it is embedded. In Classes mode, if 
you click on an object whose class is set to keep its own settings, the tool changes the top-level viewport’s 
visibility setting for the class of the embedded viewport itself. In Layers mode, the tool can only change the 
top-level viewport’s visibility setting for the layer of the embedded viewport itself.

• The top-level viewport is a design layer viewport, and the embedded viewport is referenced. In Classes mode, if 
you click on an object whose class is set to keep its own settings, the tool changes the top-level viewport’s 
visibility setting for the class of the embedded viewport itself.

• The top-level viewport is a design layer viewport. In Layers mode, the tool can only change the top-level 
viewport’s visibility setting for the layer of the embedded viewport itself. The tool cannot change the visibility for 
the layer of an object inside the embedded viewport.

Cases Where Class Visibility for the Document Changes
The following cases describe the conditions under which the Visibility tool changes the class visibilities for the entire 
document, when you click on an object in a design layer viewport that is embedded in another viewport.

• The top-level viewport is a design layer viewport, and it is set to use the class visibilities of the document. The 
embedded viewport is not referenced. The tool changes the visibility of the class of the clicked object, not only in 
the viewport, but in the entire document.

• The top-level viewport is a design layer viewport, and it is set to use the class visibilities of the document. The 
embedded viewport is referenced. If the clicked object belongs to a class that is set to take on the settings of the 
document, the tool changes the class visibility for the entire document.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Class and Design Layer Options
Changing the Class Properties of Sheet Layer or Design Layer Viewports

The Navigation Palette
The Navigation palette provides access to classes, design layers, sheet layers, viewports, and saved views, similar to the 
Organization dialog box. However, unlike the Organization dialog box, the drawing area is accessible while the 
Navigation palette is open.
To use the Navigation palette:

1. Select Window > Palettes > Navigation.
The Navigation palette opens. 
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Click the desired tab to set the active tab upon opening the Navigation palette. Select Window > Palettes > Save 
Palette Positions to save the changes. To revert the active tab back to the setting established when a custom 
workspace was created (in the User Data and Preferences folder), click Reset Saved Settings from the Session tab 
of Vectorworks preferences (see “Session Preferences” on page 52).

2. Select the appropriate tab: Classes, Design Layers, Sheet Layers, Viewports, Saved Views, or References.
A list of items of that type in the current drawing displays. If a description was entered for a class or layer, the 
description displays in a screen tip when you position the cursor over the item name; on Windows, click the disclosure 
arrow on the screen tip to collapse or expand it.

3. Change the settings for classes, design layers, sheet layers, viewports, saved views, or references as needed.
• Click a class or design layer’s Visibility column to set the visibility for objects in that layer. To set the same 

visibility for all classes or design layers in the list, Option-click (Mac) or Alt-click (Windows) one of the 
Visibility columns.

• Use the navigation context menu options to toggle the display of classes in hierarchical order, or to expand or 
collapse the class list for better manageability.

• If classes are displayed in hierarchical order, click the Visibility column for a class group header and all of its 
sublevels inherit that visibility setting.

• Double-click a class, design layer, or sheet layer to activate it. Alternatively, click the column to the left of the 
item’s name to activate it.

• Double-click a saved view to switch to that view.
• Double-click a viewport to switch the active layer to the sheet layer or design layer that contains the viewport, 

and to select the viewport (if a viewport is in a class with settings that prevent the viewport from being 
selected, a message displays to indicate that the active class changed to the viewport class).

• Select a class or design layer and then select one of the Class Options or Layer Options.

Classe
s ta

b

Options menu (classes and
design layers tabs only)

Active class/layer setting
(classes, design layers, and

sheet layers tabs only)

Navigation/
context menu 
(varies by active 
tab)

Visibility settings

Stacking order (design layers and 
sheet layers tabs only)

Desig
n Layers 

tab

Sheet L
ayers t

ab

Viewports
 ta

b

Saved Views ta
b

References ta
b

Story column available for 
design layers (Vectorworks 
Architect required) 
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• Change the stacking order of a design layer or sheet layer by clicking the number in its # column and dragging 
it up or down the list.

• Double-click on a tab in the Navigation palette to open the equivalent tab in the Organization dialog box.
See the following sections for details:
• “List Box Functionality” on page 44
• “Displaying Classes in Hierarchical Order” on page 159
• “Changing the Design Layer Stacking Order” on page 167
• “Setting the Active Layer” on page 164
• “Changing the Sheet Layer Stacking Order” on page 171
• “Creating Classes” on page 177
• “Setting the Active Class” on page 182
• “Saved Views” on page 189
• “Setting Visibilities in the Organization Dialog Box” on page 193

4. The Navigation menu provides creation and management functions. Select a list item and then select the desired 
function from the Navigation menu to the right of the References tab.
Alternatively, Ctrl-click (Mac) or right-click (Windows) a list item and then select the desired function from the 
navigation context menu.

Menu Command Function

Classes tab
New Select New to open the New Class dialog box. See “Creating Classes” on page 177.

When a new class is created, it does not automatically become the active class.
Edit Select a class and then select Edit to edit it in the Edit Class(es) dialog box. See “Setting 

Class Properties” on page 179. This option is not available when classes are displayed in 
hierarchical order and a class group header is selected. 

Duplicate Select a class and then select Duplicate to create a copy of it. The name of the duplicate is the 
same as the original class, with a number added (as in cabinets-2); if the original name ends 
in a number, the next available sequential number is used. This option is not available when 
classes are displayed in hierarchical order and a class group header is selected. 

Delete Select a class and then select Delete to open the Delete Class(es) dialog box. Specify what to 
do with the objects currently assigned to the class(es) being deleted (delete them, or reassign 
them to another selected class). Click OK to return to the Navigation palette. The program 
moves all objects in the deleted class(es) to the appropriate class, or deletes them, as 
specified. Shortcut keys for this command are Delete (Windows) and Forward Delete (Mac). 
This option is not available when classes are displayed in hierarchical order and a class group 
header is selected.

The Dimension and None classes cannot be deleted. These are default classes in every 
drawing.

Assign to 
Selection

Select one or more drawing object(s) and one class; then select Assign to Selection to place 
the object(s) in the specified class

Activate Select a class and then select Activate to make that class active for every design layer, 
viewport, and saved view without class visibility saved. (Enter is a shortcut key for this 
command.)

Details Select Details to open the Organization dialog box to the Classes tab in Details view; 
double-clicking the Classes tab in the Navigation palette is a shortcut for this command
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Visibilities Select a class and then select Visibilities to open the Organization dialog box to the Classes 
tab in Visibilities view (showing Viewport and Saved View visibilities for the class)

Select All Choose Select All to select all classes
Hierarchical 
Display

Toggles the hierarchical display of classes on or off

Expand All When classes are displayed in hierarchical order, displays all classes in the file
Collapse All When classes are displayed in hierarchical order, collapses the list to display only top-level 

classes (those with no dash in the name) and class group headers
Design Layers tab

New Select New to open the New Design Layer dialog box.
When a new layer is created, it becomes the active layer.

Edit Select a layer and then select Edit to edit it in the Edit Design Layers dialog box. See “Setting 
Design Layer Properties” on page 165.

Duplicate Select a design layer and then select Duplicate to create a copy of it. The name of the 
duplicate is the same as the original layer, with a number added (as in floorplan-2); if the 
original name ends in a number, the next available sequential number is used.

Delete Select a design layer and then select Delete; when prompted, click Yes to confirm the 
deletion. Shortcut keys for this command are Delete (Windows) and Forward Delete (Mac).

When a design layer is removed from the drawing, all objects in that layer are also 
removed.

Assign to 
Selection

Select one or more drawing object(s) and one layer; then select Assign to Selection to place 
the object(s) on the specified layer

Activate Select a layer and then select Activate to switch to that design layer. (Enter is a shortcut key 
for this command.)

Update 
Reference

(Layer import referencing method only) This option is available if a design layer has been 
referenced into this file.

The referenced layer name displays in italics. Position the cursor over the layer name to 
display a screen tip with the full layer name and the source file name; on Windows, click 
the disclosure arrow on the screen tip to collapse or expand it.

Select a referenced layer and then select Update Reference to update this file with layer 
information from the master file. See “Workgroups and Referencing” on page 207.

Details Select Details to open the Organization dialog box to the Design Layers tab in Details view; 
double-clicking the Design Layers tab in the Navigation palette is a shortcut for this 
command

Visibilities Select a layer and then select Visibilities to open the Organization dialog box to the Design 
Layers tab in Visibilities view (showing Viewport and Saved View visibilities for the layer)

Select All Choose Select All to select all design layers
Sheet Layers tab

New Select New to open the New Sheet Layer dialog box.
When a new layer is created, it becomes the active layer.

Menu Command Function
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Edit Select a sheet layer and then select Edit to edit it in the Edit Sheet Layers dialog box. See 
“Setting Sheet Layer Properties” on page 170.

Duplicate Select a sheet layer and then select Duplicate to create a copy of it. The Sheet Title of the 
duplicate is the same as the original layer. The Sheet Number of the duplicate is the same as 
the original layer, with a number added (as in details-2); if the original Sheet Number ends in 
a number, the next available sequential number is used.

Delete Select a sheet layer and then select Delete; when prompted, click Yes to confirm the deletion. 
Shortcut keys for this command are Delete (Windows) and Forward Delete (Mac).

Activate Select a layer and then select Activate to switch to that sheet layer. (Enter is a shortcut key 
for this command.)

Details Select Details to open the Organization dialog box to the Sheet Layers tab in Details view; 
double-clicking the Sheet Layers tab in the Navigation palette is a shortcut for this command

Select All Choose Select All to select all sheet layers
Viewports tab

New Select New to open the Create Viewport dialog box. For sheet layer viewports, see “Creating 
a Sheet Layer Viewport from a Design Layer” on page 1616. For design layer viewports, see 
“Creating Design Layer Viewports” on page 1620.

Edit Select a viewport and then select Edit to edit it in the Properties dialog box. For sheet layer 
viewports, see “Viewport Properties” on page 1636. For design layer viewports, see 
“Viewport Properties” on page 1636.

Duplicate Select a viewport and then select Duplicate to create a copy of it. The name of the duplicate 
is the same as the original viewport, with a number added (as in details-2); if the original 
name ends in a number, the next available sequential number is used.
The Drawing Title of the duplicate is the same as the original viewport. If the original 
viewport has a drawing label, the Drawing Number of the label in the duplicate viewport is 
the next available sequential number.
The duplicate viewport is placed directly on top of the original, in the original sheet layer.

Delete Select a viewport and then select Delete; when prompted, click Yes to confirm the deletion. 
Shortcut keys for this command are Delete (Windows) and Forward Delete (Mac).

Activate Select a viewport and then select Activate to switch to that viewport’s sheet layer and select 
that viewport (if a viewport is in a class with settings that prevent the viewport from being 
selected, a message displays to indicate that the active class changed to the viewport class). 
(Enter is a shortcut key for this command.)

Update Select one or more sheet layer viewports, and then select Update to render the viewports with 
their foreground and background render settings. (Alternatively, select View > Update 
Selected Viewports.) When a Renderworks render mode is selected, the viewports render in 
the background once the geometry has been processed (see “Background Rendering” on 
page 1594). Icons in the Navigation palette indicate the render status of the viewports.

Menu Command Function

Up to date, rendered

Rendering in progress

Queued for rendering

Out of date
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Cancel Update When one or more selected sheet layer viewports are in the process of updating, or in the 
render queue, Cancel Update cancels the current render and any pending rendering. 
(Alternatively, select View > Cancel All Viewport Updates.)

Details Click Details to open the Organization dialog box to the Viewports tab in Details view; 
double-clicking the Viewports tab in the Navigation palette is a shortcut for this command

Visibilities Select a viewport and then select Visibilities to open the Organization dialog box to the 
Viewports tab in Visibilities view (showing Class and Design Layer visibilities for the 
viewport)

Select All Choose Select All to select all viewports
Saved Views tab

New Select New to open the Save View dialog box. See “Creating Saved Views” on page 189.
Edit Select a saved view and then select Edit to edit it in the Edit Saved View dialog box. See 

“Editing Saved Views” on page 190.
Duplicate Select a saved view and then select Duplicate to create a copy of it. The name of the 

duplicate is the same as the original view, with a number added (as in deckview-2); if the 
original name ends in a number, the next available sequential number is used.

Delete Select a saved view and then select Delete; when prompted, click Yes to confirm the deletion. 
Shortcut keys for this command are Delete (Windows) and Forward Delete (Mac).

Activate Select a saved view and then select Activate to switch to that view. (Enter is a shortcut key 
for this command.)

Redefine Select a saved view and then select Redefine to open the Redefine Saved Views dialog box. 
See “Redefining Saved Views” on page 191.

Details Select Details to open the Organization dialog box to the Saved Views tab in Details view; 
double-clicking the Saved Views tab in the Navigation palette is a shortcut for this command

Visibilities Select a saved view and then select Visibilities to open the Organization dialog box to the 
Saved Views tab in Visibilities view (showing Class and Design Layer visibilities for the 
saved view). The active class/layer and class/layer options can also be changed here.

Select All Choose Select All to select all saved views
References tab

New Click New to open the Open File dialog box. For layer import references, see “Adding and 
Editing Layer Import References” on page 210. For design layer viewport references, see 
“Creating a Referenced Design Layer Viewport” on page 1622.

Edit Select a referenced file and click Edit to open the Edit Reference dialog box. For layer import 
references, see “Adding and Editing Layer Import References” on page 210. For design layer 
viewport references, see “Creating a Referenced Design Layer Viewport” on page 1622.

Delete Select a reference and click Delete. In the Delete Reference dialog box, specify what to do 
with the items in the file that are currently referenced. See “Deleting References” on 
page 215.

Update Select a referenced file and click Update to update this document with references from the 
file. 

Update All Click Update All to update all of the references in this document.

Menu Command Function
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Open Select a referenced file and click Open to open the referenced file. Referenced PDF or image 
files are opened with the default application for the file type. This command is not available 
when more than one referenced file is selected.

Details Select Details to open the Organization dialog box to the References tab in Details view; 
double-clicking the References tab in the Navigation palette is a shortcut for this command

Select All Choose Select All to select all references

Menu Command Function
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Workgroups and Referencing
File sharing can provide consistency and efficiency in your project files, especially in a large business where several 
people work on the same project. The Vectorworks program has referencing and workgroup features to make it easier 
to share drawing elements with your coworkers when needed.

Referencing Features
Referencing allows you to use drawing elements from another file in the current file. When a referenced item in the 
master file changes, the changes are reflected in the target file. Updates to target files can be performed automatically 
or only when manually requested.

• A “layer import” reference imports all classes and objects from a design layer in an external Vectorworks file to a 
design layer in the target file.

• A “design layer viewport” reference imports the contents of an external Vectorworks file to a viewport in the 
target file. Like any other viewport, you can then select which classes and layers to display in the viewport. 
(Vectorworks Design Series required)

• Resources (such as hatches, worksheets, or symbols) in other Vectorworks files can be referenced, and then used 
in your drawings as needed.

• In addition to Vectorworks files, you can reference DXF/DWG and DWF files (see “DXF/DWG and DWF 
References” on page 1728).

• If Vectorworks Design Series products are installed, you can also reference image and PDF files (see “Importing 
an Image File” on page 1680 and “Importing PDF Files” on page 1686).

Use the References tab of the Organization dialog box to create references to other files, and to edit or update existing 
references.

Workgroup Feature
When Vectorworks Design Series is installed, you can create a workgroup environment, to share one or more folders of 
custom content files on a network with coworkers. These files might contain content that will be used by all users (such 
as templates, symbols, export settings, or workspaces). Alternatively they might contain custom content specific to 
different projects.
This method of file sharing is best for custom content that does not change often. The content is available to multiple 
users without being referenced into each file, but because it is not referenced, it cannot be updated automatically.

Workgroup and Referencing Strategies
Communication among coworkers is essential when referencing and/or workgroups are in use. Discuss a strategy for 
how to name, maintain, and update master files. Keep each other informed of major changes—especially the deletion 
of a master file or resources, which can affect multiple files.
If either the file name or the location of a referenced file is changed, the reference is broken. Items referenced from that 
file cannot be updated until the broken reference is corrected.
~~~~~~~~~~~~~~~~~~~~~~~~~
Layer Referencing
Adding and Editing Layer Import References
Creating a Referenced Design Layer Viewport
Setting the Referencing Options
Prioritizing Referenced Files
Updating References
Correcting Broken References
Referencing Resources
Deleting References
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Layer Referencing
You can reference specific layers with all of the classes and resources used in those layers, as well as any resources 
from a master file. Referenced design layers can be displayed in viewports. Referenced items are indicated in the 
Resource Browser and in the Organization dialog box by italicized names.
There are two ways to reference design layers:

• In the Vectorworks Fundamentals product, design layers are imported into the target file when they are referenced. 
For backward compatibility, Vectorworks Design Series products support this method; see “Adding and Editing 
Layer Import References” on page 210.

• In the Vectorworks Design Series products, the recommended method is to create a design layer viewport and then 
reference the desired design layers from the master file. See “Creating a Referenced Design Layer Viewport” on 
page 1622 for details about this type of reference.

Depending on the type of object referenced, you may be able to update the master file from the target file.
• Resources can be edited or renamed in the target file, and the corresponding resource in the master file is 

automatically updated. See “Referencing Resources” on page 213.
• Objects on layers referenced with layer import referencing are locked; they can be unlocked and edited in the 

target file, but the change will not appear in the master file. Moreover, when the target file’s references are 
updated, referenced items are over-written to reflect the master file. Therefore, any permanent change to a 
referenced item must be made in the master file.

• Objects on layers referenced in a design layer viewport cannot be edited directly, but there is an option to navigate 
to the master file, make the change, and then return to the target file to view the change.

Keep the following concepts in mind for both design layer referencing methods.
• Drawing information is shared and updated on a layer-by-layer basis.
• For layer import referencing, referenced layers should be treated as read-only layers; any changes to referenced 

information and any information added to referenced layers are removed the next time the referenced layer is 
updated.

• Referenced layer names cannot be changed.
• Resources (symbol names) in layers that are referenced from the master file take precedence over resources in the 

target file.
• If there is a naming conflict with pre-existing symbols or pre-existing layers in the current file, replace the 

symbols or rename the layers.
• Sheet layer viewports cannot directly reference layers in external master files. If you are using layer import 

referencing, create a reference to the master file, and select the external layers to import into the target file; then 
make the imported layers visible in a sheet layer viewport. If you are using design layer viewport referencing 
(Vectorworks Design Series required), create a design layer viewport from the master file and make the desired 
layers visible; then make the design layer that contains the viewport visible in a sheet layer viewport.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Referencing Options
Adding and Editing Layer Import References
Creating a Referenced Design Layer Viewport
Prioritizing Referenced Files
Updating References
Correcting Broken References
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Setting the Referencing Options
The reference settings control how manual and automatic updates to references are performed in the current file. In 
addition, in the Vectorworks Design Series products, you have the option to change the layer referencing method for 
this file from design layer viewport referencing (the default for the Vectorworks Design Series product) to layer import 
referencing.
To set the referencing options:

1. Select Tools > Organization.
The Organization dialog box opens.

2. Select the References tab and click Settings.
The Reference Settings dialog box opens. Specify the referencing settings.

Click to show/hide the parameters.

3. Click OK to return to the Organization dialog box.

Parameter Description

Check for out of date 
references every ___ 

Automatically checks referenced files for changes after this time interval; if any 
references are out of date, an alert dialog box displays to allow the target file to be 
updated

Use reference priority 
when updating resources

If the same resource exists in multiple referenced master files, deselect this option to 
update each referenced item from the original source, regardless of the priority order of 
the referenced files. This is recommended because, if you change the priority order, or 
if you update an individual reference (instead of all references), you could change the 
source file of a resource inadvertently.
Select this option to update resources in the target file according to the priority order 
set in the References tab of the Organization dialog box (see “Prioritizing Referenced 
Files” on page 211). An alert message prompts you to confirm that you want to use 
priority updating for references.

When manually updating Specifies what happens when the Update button on the References tab of the 
Organization dialog box is clicked: the button either updates only the selected 
references that are out of date, or it updates all of the selected references in the target 
file

Use this method to 
reference Vectorworks files
(Vectorworks Design 
Series required)

Specifies which method to use to reference design layers in other Vectorworks 
documents. By default, Vectorworks Design Series products use design layer 
viewports, as described in “Creating a Referenced Design Layer Viewport” on 
page 1622. Select Layer import to use the referencing method described in “Adding 
and Editing Layer Import References” on page 210.

The selected method is also used to reference DXF/DWG and DWF files, as 
described in “DXF/DWG and DWF Import Options” on page 1720.
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Adding and Editing Layer Import References
In the Vectorworks Design Series products, you must first select the Layer import referencing option for the current 
file, as described in “Setting the Referencing Options” on page 209. See “Creating a Referenced Design Layer 
Viewport” on page 1622 for information about the design layer viewport referencing option.
To add or edit references to design layers in other Vectorworks files:

1. In the active target file, select Tools > Organization.
The Organization dialog box opens.

2. Select the References tab.
Referenced files are listed in priority order, along with their current status, whether they are set to update 
automatically when the target file is opened, and whether they are set to save copies of the referenced items with 
the file.

3. To edit a current reference file, select the file and click Edit.
The Edit Reference dialog box opens. Proceed to step 5.

4. To add a new reference file, click New.
The Open File dialog box opens. Select the desired file, and then click Open to open the appropriate dialog box:
• Vectorworks file: New Reference dialog box
• DXF/DWG or DWF file: Import Options dialog box
• Image file: Image Import Options dialog box (Vectorworks Design Series required)
• PDF file: Import PDF dialog box (Vectorworks Design Series required)
Referenced Vectorworks files must be the same version as the target file.

5. From the New Reference or Edit Reference dialog box, specify the parameters for the reference.
Click to show/hide the parameters.

Button Description

New Opens the Open File dialog box to select a new reference file
Edit Opens the Edit Reference dialog box to change the parameters of a selected reference file
Delete Opens the Delete Reference dialog box to delete a file from the list of referenced files, and to choose 

whether to keep the referenced layers and resources in the target file; see “Deleting References” on 
page 215

Update Manually updates the referenced items from the selected file(s); see “Updating References” on 
page 212

Settings Opens the Reference Settings dialog box to set options for updates of referenced items; see “Setting the 
Referencing Options” on page 209

Parameter Description

Source File Displays the path and file name of the referenced master file; if the Edit option was 
selected, click Browse to edit the file location
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Referenced layers can be used in a sheet layer viewport. Because sheet layer viewports cannot directly reference 
design layers in other files, reference the layers and then create a sheet layer viewport that shows the referenced 
layers.

6. Click OK to return to the Organization dialog box.
The selected layers are added to the target file, along with any new layers and layer links.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Referencing Options
Prioritizing Referenced Files
Updating References
Correcting Broken References
Referencing Resources
Deleting References
Opening Referenced Files
Layer Referencing
Creating a Referenced Design Layer Viewport

Prioritizing Referenced Files
During a reference update, the program can search the referenced files in the order in which they are listed on the 
References tab, and then update the target file with the first instance of each referenced resource that is found.

Save reference location as Maintains either an absolute or relative file path reference from the current file to 
the referenced file. Use the absolute path when the location of the referenced file 
with respect to the current file is not going to change. Use the relative path when the 
files might be moved to another computer or platform; as long as the relative path 
between the files remains the same, the reference can be found. Both files must be 
saved on the same volume to select this option.
The Source File path displays either an absolute or relative path, depending on the 
selection.

Layers Available Specify the design layers to be referenced; selected layers are indicated with a check 
mark. Sheet layers cannot be referenced. This step is optional; a layer does not have 
to be selected to reference its resources. Resources in the entire referenced file are 
available through the Reference command in the Resource Browser.

Options Select the update options
Save referenced cache to 
disk

Saves a copy of the referenced data with the target file. When this option is 
deselected, a copy of the referenced data is not saved, which means that the target 
file size is smaller; the referenced data is updated when the target file is opened.

Automatically update out 
of date reference during 
file open

Updates the reference each time the target file is opened; when deselected, the 
reference is updated only when Update is clicked from the References tab of the 
Organization dialog box

Update class definitions Updates class definitions along with the referenced objects that use those classes
Ignore source user origin Ignores the user origin in the master file; referenced objects will not change location 

in the target file if the user origin changes in the master file
Create layer link(s) on 
layer

Creates a layer link for each newly referenced layer on the specified design layer; 
select the design layer from the list or select New Layer to specify a new design 
layer, set to the same scale as the first selected layer to reference

Parameter Description
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If the same resource exists in multiple referenced master files, it is recommended that you disable this feature. 
Otherwise, if you change the priority order, or if you update an individual reference, you could change the source 
file of a resource inadvertently. To prevent this from happening, deselect the option to Use reference priority 
when updating resources in the Reference Settings dialog box (see “Setting the Referencing Options” on 
page 209).

To set the priority of referenced files:
1. Select Tools > Organization to open the Organization dialog box.
2. From the References tab, click Settings to open the Reference Settings dialog box, and ensure that the option to 

Use reference priority when updating resources is selected.
3. From the References tab, click the number in its # column to select the master reference file(s) to be moved; drag 

the item up or down the list to the new priority position. The first file listed on the References tab has the highest 
priority. 

~~~~~~~~~~~~~~~~~~~~~~~~~
Adding and Editing Layer Import References
Creating a Referenced Design Layer Viewport

Updating References
Referenced design layers and resources are either updated automatically when the target file is opened, or they are 
updated manually upon command. These preferences are set in either the New Reference or the Edit Reference dialog 
box. If the file is set to update automatically, manual updates can still be performed at any time.
Before an update, correct any broken references as described in “Correcting Broken References” on page 213.
To update references manually:

1. Select Tools > Organization to open the Organization dialog box.
2. From the References tab, select the master file(s) that contain the referenced items to be updated.

To update all references in the target file, select all of the files.
3. Click Update to update the referenced items in the target file from the selected files.

• If priority updating is disabled (recommended), referenced items are always updated from the original file.
• If priority updating is enabled, referenced items are updated according to the priority order on the References 

tab.
For more information about priority updating, see “Setting the Referencing Options” on page 209, and 
“Prioritizing Referenced Files” on page 211.

4. If a referenced item is missing, the Referenced Resource not Found dialog box opens. Select an action option.
Click to show/hide the parameters.

5. Click OK To All to perform the same action for all missing resources. To select an action for each missing 
resource individually, click OK; the dialog box redisplays for each missing item.

Parameter Description

Break the reference Breaks the reference with the master file, leaving the resource in the target file
Delete the resource Deletes all occurrences of the resource in the target file (from both the drawing and the 

Resource Browser)
Replace resource with To replace the missing resource with another item from the master file, select this option, 

and then select the replacement item from the list of available resources
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Correcting Broken References

Correcting Broken References
If a reference has a status of “Broken link” in the References tab, the program cannot locate the master file. Items 
referenced from that file cannot be updated until the broken reference is corrected.
To correct broken references:

1. Select Tools > Organization to open the Organization dialog box.
2. From the References tab, select one or more master files that have broken references, and click Update.
3. An alert prompts you to locate the master file. If you selected multiple references, select Look for subsequent 

broken references in all of the folders manually located to have the program search the same location for all of 
them.
If a file is set to update automatically when it is opened, and one of its references is broken, this alert displays 
when you open the file.

4. Click Yes to open the Open Current-Version Drawing dialog box.
5. Locate the master file and click Open.

On the References tab, the status of the broken reference changes from Broken link to Up to date or Out of date. If 
you selected the option to look for subsequent references in the same location, those references are corrected also. 

6. Click OK to save the new name and/or location for the references.
~~~~~~~~~~~~~~~~~~~~~~~~~
Updating References

Referencing Resources
The resources of files listed in the References tab of the Organization dialog box, as well as the resources in any 
Vectorworks file of the same version number, can be referenced through the Resource Browser.
To reference the resources of a master file:

1. To display the resources of the master file in the Resource Browser, either use the Browse a Document command 
on the Files menu, or use the Files list to access the master file if it is in a resource library (see “Accessing 
Existing Resources” on page 229).

2. Right-click (Windows) or Ctrl-click (Mac) on the desired resource, and select Reference from the context menu.
3. If the resource is a symbol or plug-in object, the Reference Symbol(s) dialog box opens. Specify the location of 

the referenced symbol and click OK.
Click to show/hide the parameters.

Parameter Description

Preserve folder hierarchy Maintains the same folder structure the referenced symbol had in its source file
Select destination folder Adds the referenced symbol to the selected folder

Folder list Displays the target file’s symbol folders; the selected folder becomes the destination for 
the referenced symbol

New Folder Creates a new folder within the selected folder; specify the folder name and click OK 
to create the symbol folder
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4. If the master file has never been referenced in the current file, the New Reference dialog box opens. Specify the 
reference parameters and click OK.

Click to show/hide the parameters.

5. The resource is added to the target file. Referenced resources display with italicized names in the Resource 
Browser.
The following rules apply to referenced resources.

Parameter Description

Source File Displays the path and file name of the referenced resource file
Save reference location 
as

Maintains either an absolute or relative file path reference from the current file to the 
referenced resource’s file. Use the absolute path when the location of the referenced file 
with respect to the current file is not going to change. Use the relative path when the files 
might be moved to another computer or platform; as long as the relative path between the 
files remains the same, the reference can be found. Both files must be saved on the save 
volume to select this option.
The Source File path displays either an absolute or relative path, depending on the 
selection.

Save referenced cache to 
disk

Saves a copy of the referenced resource with the target file. When this option is 
deselected, a copy of the referenced resource is not saved, which means that the target 
file size is smaller; the referenced resource is refreshed when the target file is opened.

Automatically update 
out of date reference 
during file open

Updates the reference each time the target file is opened; when deselected, the reference 
is updated only when Update is clicked from the References tab of the Organization 
dialog box

Update class definitions Updates class definitions along with the referenced resources that use those classes

Situation Description

Editing a referenced resource A referenced resource can be edited within the target file, provided the source 
file is not opened by another user, and the reference is not broken or the resource 
out of date. Changes to the referenced resource are automatically exported to the 
source file; while in edit mode, the source file is locked.
The following resources can be edited within the referenced file: gradients, 
hatches, record formats, symbol definitions, plant symbols (Vectorworks 
Landmark required), sketch styles and wall styles (Vectorworks Design Series 
required), Renderworks backgrounds and textures (Renderworks required).

Resource name conflict If there is a name conflict between a referenced object and another object when 
creating a reference, an alert displays and you have the option to replace the 
object in the current document. (If the other object is also a referenced object, it 
cannot be replaced and the update fails.)

Change user origin of master file If the user origin of a master file is changed, the location of the referenced 
resources do not change, if Ignore source user origin is selected in the Edit 
Reference dialog box

Change master file classes Changes to the class of a referenced resource are only reflected in the target file 
after an update if Update class definitions is selected in the New Reference 
dialog box
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To break a reference, right-click (Windows) or Ctrl-click (Mac) on the desired resource, and select Break 
Reference from the context menu. The resource remains in the target file, but it is no longer referenced to the 
master file.

~~~~~~~~~~~~~~~~~~~~~~~~~
Adding and Editing Layer Import References
Creating a Referenced Design Layer Viewport

Deleting References
You can stop referencing a file, and choose whether to keep the referenced layers and resources in the target file.
To delete a reference to a file:

1. Select Tools > Organization to open the Organization dialog box.
2. Select the file to stop referencing, and then click Delete.

The Delete Reference dialog box opens.
Click to show/hide the parameters.

3. Specify what to do with the referenced layers and resources, and click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
Layer Referencing

Opening Referenced Files
The Vectorworks program provides easy access to the master files that a target file references.

Resource deleted in master file If a referenced resource is deleted in a master file and the resource does not exist 
in any other master file included in an update, when the reference to the master 
file is updated, an alert displays. Click OK to confirm that the resource is an 
“orphan,” or click OK to All to hide all alerts about orphaned resources during 
the current update. Orphaned resources are no longer referenced.

Parameter Description

Reference to Displays the master file name and path
Referenced Layers Select an option for layers that are currently referenced in the target file from the 

master file
Keep in current document Keeps the layers in the target file, but removes the reference
Delete Removes referenced layers from the target file, including layer links and any 

objects on the layer
Referenced Resources Select an option for resources that are currently referenced in the target file from 

the master file
Keep in current document Keeps the resources in the target file, but removes the reference
Delete if unused Deletes unused referenced resources; keeps resources that have been placed in the 

file, but removes the reference

Situation Description
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To open a referenced file:
1. Click on Window. The bottom portion of the menu provides a submenu for each Vectorworks file that is currently 

open.
2. From the submenu for the target file, select Referenced Files to display the Vectorworks files that the target file 

references. Though DXF/DWG, DWF, PDF, and image files can be referenced, they do not appear on the menu.
3. Select a referenced file to open it.

Sharing Custom Content Using Workgroup Folders
When Vectorworks Design Series is installed, you can create a workgroup environment, to share one or more folders of 
custom content files on a network with coworkers. These files might contain content that will be used by all users (such 
as templates, symbols, export settings, or workspaces). Alternatively they might contain custom content specific to 
different projects. Each user who needs access to those files can then designate that shared network folder as a 
workgroup folder in his or her Vectorworks Preferences, so that the custom content will be available in the Vectorworks 
program.
You can manually add files to the workgroup Libraries folder, to access custom resource libraries such as symbols and 
hatches from the Files list in the Resource Browser. You can also have custom resources display as default content in 
dialog boxes and palettes. See “Resource Libraries” on page 219 for more information. For details about where to put 
files and how to name them, see “Sharing Custom Files with a Workgroup” on page 217.

Designating Workgroup Folders
To designate workgroup and project folders:

1. Select Tools > Options > Vectorworks Preferences, and then click the User Folders tab.
Click to show/hide the parameters.

Parameter Description

User Data and Preferences 
Folder

Specifies the folder that contains Vectorworks preferences, log files, workspaces, 
and any personal content you create. This might be a folder on the local computer, 
or on a USB drive or network drive; this allows you to run the Vectorworks 
program from any computer.
For more information about user folders, see “User Folders Preferences” on 
page 57.

Choose Click Choose to change the user data folder. The Vectorworks program must be 
restarted if you change the location of the user data. See “User Data and 
Preferences Folder” on page 58 for details.

List of referenced 
Vectorworks files
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2. Enter the workgroup folder(s) as needed, and click OK to save the changes.
To easily access a workgroup folder, use the file list in the Resource Browser. See “Accessing Existing Resources” 
on page 229 for more information.

Sharing Custom Files with a Workgroup
To share custom content with a workgroup, create a main workgroup folder in a shared location. Within the folder, 
create a subfolder that matches the standard Vectorworks program subfolder for that type of data (Libraries, Plug-Ins, 
Settings, or Workspaces). If necessary, create additional subfolders within those folders (for example, 
Libraries\Defaults\Templates or Libraries\Defaults\Space\Space - Space Name).

Do not modify the Plant Database subfolder, if present. Place custom plant symbols in one of the plant library 
subfolders (in the Libraries\Defaults folder).

To access the shared content, another Vectorworks user simply designates the main folder as a workgroup folder in his 
or her Vectorworks Preferences. Here are some examples of possible workgroup folder content:

• Master files from which design layers, classes, and resources can be referenced
• Plug-ins

Explore (Windows) or 
Reveal in Finder (Mac)

To look at the contents of the current folder, click Explore (to open Windows 
Explorer) or click Reveal in Finder (to open Mac Finder)

Workgroup and Project Folders Specifies the folders where the Vectorworks program will look for additional 
content, such as office standard files, shared project files, and workgroup 
reference files. This might be a shared folder on a network drive, or a 
project-specific folder on the local computer.
Folders are searched in order from the top of the list to bottom; if multiple files 
with the same name are found, only the first version of the file is shown in the 
program. To change the position of a folder, click in the # column and drag the 
folder up or down in the list.

Add Opens a dialog box to select a folder to add to the list
Remove Deletes the selected folder from the list
Explore (Windows) or 
Reveal in Finder (Mac)

Displays the contents of the selected folder in either Windows Explorer or Mac 
Finder

Parameter Description

Click to open the file list

Select Workgroup Libraries to
access your workgroup folders

Accessing workgroup folders from the Resource Browser
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• Templates
• Resource libraries (for gradients, hatches, line types, record formats, Renderworks textures, slab styles, symbols, 

text styles, tiles, VectorScripts, wall styles, and worksheets)
• Space object lists (space names, occupant organizations, and room finishes)

Sharing Custom Resource Libraries
When the Vectorworks program presents content in a palette or dialog box, it includes content from the user and 
workgroup folders as well as the content it ships with. For example, when you select Modify > Hatch to edit a hatch, 
the Hatches dialog box shows default hatches from the Vectorworks folder (where the software is installed), your user 
folder, and any workgroup folders you have designated.
If the same file name exists in more than one folder, only the content from one of the files is shown in the Vectorworks 
program, according to the following priority: user folder, workgroup folder, application folder. For example, if the 
following files exist, only hatches from the file in the user folder show in the hatch list in the Attributes palette in the 
Vectorworks program.

• [User]\Libraries\Defaults\Attributes - Hatches\Hatches_Default.vwx
• [Workgroup]\Libraries\Defaults\Attributes - Hatches\Hatches_Default.vwx
• [Vectorworks]\Libraries\Defaults\Attributes - Hatches\Hatches_Default.vwx

Therefore, the name of your custom library file affects content availability in the Vectorworks program.
• To totally supersede the Vectorworks default hatches, use the same name as the hatch file in the Vectorworks 

program folder (“Hatches_Default.vwx”).
• To make your custom hatches available along with the Vectorworks default hatches, use a unique name, such as 

“Custom_Hatches.”
To share a custom library, create a library file and put the file on the network in a workgroup folder. The folder 
structure must be the same as that of the Vectorworks default content. For example, to add a custom hatch library, place 
the file in your workgroup default hatch folder: [Workgroup]\Libraries\Defaults\Attributes - Hatches.
If the same resource name exists in two default files (that have different names), the resource list in Vectorworks shows 
both resources, and includes the file name. For example, on the Attributes palette you might see two hatches named 
“Brick (Custom_Hatches.vwx)” and “Brick (Hatches_Default.vwx).” You can use both hatches in a drawing, but after 
you import the first one, you are prompted to either replace the first one, or rename the second one.

To make the custom library resources available from the Resource Browser only (not as defaults in dialog boxes 
and palettes), place the file in a Favorites folder in a workgroup folder. See “Using Favorites Files” on page 230. 
This method of sharing resources is more flexible, because users can choose either to import the resource, or 
reference it (see “Referencing Resources” on page 213).
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Resource Libraries
Vectorworks software comes with hundreds of libraries, which can be accessed through the Resource Browser (see 
“Accessing Existing Resources” on page 229). Default content (which is available at the time of use) is automatically 
installed with the Vectorworks software. All other content, including industry-specific content, is optionally added 
during the installation process (Internet access required). If the additional content was not added during installation, it 
can be added later. Select Help > Download Content to download it via the Vectorworks Package Manager.
Excluding standards and templates (which are installed based on the drawing unit selected during installation), all 
libraries for the Vectorworks Fundamentals and Renderworks products are universal, and are installed regardless of the 
drawing unit selected during installation.
Libraries are organized by professional discipline and subject. The Vectorworks Design Series products contain 
additional libraries. Even more content is available exclusively for Vectorworks Service Select subscribers.
For a list of libraries and the product(s) to which they belong, see the Libraries-Index and Product Matrix.pdf file 
located in the [Vectorworks]\Libraries folder.
All of the Vectorworks interior and building objects (symbols) specifically developed for Architect and Designer have 
ifc data records attached. This includes the symbols libraries available in Vectorworks Architect and Designer products, 
as well as libraries available in our subscription service, Vectorworks Service Select.
A subset of content (some of which are resources available in libraries) is also available by default at the point of use. 
The ability to use default content is a preference on the Session tab of the Vectorworks preferences, which can be 
disabled if default content use is not desired; see “Session Preferences” on page 52.
Default content is available from a variety of dialog boxes and also from the Attributes and Object Info palettes. Once 
default content is selected for use, it is automatically imported into the current file and if it is a resource (such as a hatch 
or gradient) it also displays in the Resource Browser.

Creating Custom Default Content Libraries
To make your own custom content available as default content in the Vectorworks program, use any of the following 
methods.

• Import custom content into a default content file
• Add a custom content file to a default content folder
• Create a custom content file and place an alias of (Mac) or shortcut to (Windows) that file in a default content 

folder
Files that contain custom content can be placed in different locations, depending on who needs access to the content. 
The folder structure must be the same as that of the Vectorworks default content, and if a subfolder exists, the file must 
be placed in a subfolder. For example, Vectorworks default hatches are in a file in the folder 
[Vectorworks]\Libraries\Defaults\Attributes - Hatches. To make your library of custom hatches available in 
Vectorworks, place a file that contains the hatches in either your user folder or a workgroup folder.

• To create default content for yourself only, put the file in the appropriate subfolder within 
[User]\Libraries\Defaults (where [User] is the user data folder specified in your Vectorworks preferences). For 
example, place a hatches file in [User]\Libraries\Defaults\Attributes - Hatches. See “User Folders Preferences” on 
page 57 for more information.

• If Vectorworks Design Series products are installed, you can create default content that is project-specific, or that 
is shared with a workgroup. To do so, put the file on the network in the appropriate subfolder within 
[Workgroup]\Libraries\Defaults (where [Workgroup] is a workgroup folder specified in your Vectorworks 
preferences). For example, place a hatches file in [Workgroup]\Libraries\Defaults\Attributes - Hatches). When 
coworkers set up this workgroup folder in their preferences, they also have access to the default content. See 
“Sharing Custom Files with a Workgroup” on page 217 for more information.
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The name of your custom library file also affects resource availability in the Vectorworks program.
• To totally supersede the Vectorworks default hatches, use the same name as the hatch file in the Vectorworks 

program folder (“Hatches_Default.vwx”).
• To make your custom default hatches available along with the Vectorworks default hatches, use a unique name, 

such as “Custom_Hatches.vwx.”
If a file name is repeated in any of the folders, only the content from one file is shown, according to the following 
precedence: user folder, workgroup folder, application folder. For example, if the following files exist, only hatches 
from the file in the user folder show in the hatch list in the Attributes palette in the Vectorworks program.

• [User]\Libraries\Defaults\Attributes - Hatches\Hatches_Default.vwx
• [Workgroup]\Libraries\Defaults\Attributes - Hatches\Hatches_Default.vwx
• [Vectorworks]\Libraries\Defaults\Attributes - Hatches\Hatches_Default.vwx

If a custom library file contains multiple types of content, the program only displays the content type for the folder that 
contains the custom file (or an alias or shortcut to the file). For example, if a file contains both wall hatches and 
textures, and the file is in the Libraries\Defaults\Walls - Textures folder, only the wall textures are displayed as defaults 
in the Vectorworks program.

To make the custom library resources available from the Resource Browser only (not as defaults in dialog boxes 
and palettes), place the file in a Favorites folder in either your user folder or a workgroup folder. See “Using 
Favorites Files” on page 230.

Organizing Content Display
In dialog boxes and palettes, the custom and default content are displayed below the content in the current file; each list 
is in ascending alphabetical order.
To display the custom or current file’s content first in a selection list, implement a naming standard that places the 
desired content toward the top of the list alphabetically. To view only the current file’s content in a selection list, 
disable the Display default content Vectorworks preference.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Resource Libraries
Using Resources from Open Files, Favorites, and Libraries
Using the Resource Browser

Creating Resource Libraries
Resource libraries are simply files that contain specific resources to make it faster and easier to access the resources 
while drawing in the Vectorworks program. Libraries do not increase the size of the current file or consume significant 
amounts of memory. Save similar resources in the same library file to make it easier to search for them.
Once created, resource libraries can be accessed from the Resource Browser as a Favorites file, or located using the 
User Libraries or Workgroup Libraries options on the Files list. Resource libraries can also be used as custom default 
content.
To create a resource library file:

1. Select File > New.
2. Import or create the resources to be included in the library.
3. Select File > Save.

The Save Vectorworks Drawing dialog box opens.
4. Select the location for saving the file.
5. Enter a name for the file in the Name field.
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6. Click Save.
7. Place the library file in the appropriate location, depending on how you want to access it:

~~~~~~~~~~~~~~~~~~~~~~~~~
Organizing Content Display
Using Resources from Open Files, Favorites, and Libraries
Using the Resource Browser

Using the Resource Browser
The Resource Browser is the central repository for all Vectorworks resources. Use it to create, apply, and manage 
resources in the current file, and to access resources in other files.
To use the Resource Browser:

1. Select Window > Palettes > Resource Browser.
The Resource Browser opens.

Access Method Library File Location Reference

From the Files list in the 
Resource Browser, select the 
library file from the Favorites 
section, and then select a 
resource from the resource 
display window

Favorites folder in your user folder:
[User]/Libraries/Favorites/[folder name]

“Using Favorites 
Files” on page 230

From the Files list in the 
Resource Browser, select the 
User Libraries option, select 
the library file, and then select 
the resource from the resource 
display window

Libraries folder in your user folder:
[User]/Libraries/[folder name]

“User Folders 
Preferences” on 
page 57

From the Files list in the 
Resource Browser, select the 
Workgroup Libraries option, 
select the library file, and then 
select the resource from the 
resource display window

Libraries folder in a network folder designated as your 
workgroup folder (Vectorworks Design Series required):

[Workgroup]/Libraries/[folder name]

“Sharing Custom 
Files with a 
Workgroup” on 
page 217

Available from anywhere 
default content resources are 
available, such as the hatches 
list in the Attributes palette

Defaults folder in your user folder, or in a network folder 
designated as your workgroup folder (Vectorworks Design 
Series required):

[User]/Libraries/Defaults/[standard folder name]
[Workgroup]/Libraries/Defaults/[standard folder name]

“Creating Custom 
Default Content 
Libraries” on 
page 219
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Feature Description

Files menu Lists menu commands that are used to create and manage a set of favorite resource files 
and to browse the resources in an existing document (see “Quick Resource Browsing” on 
page 229)

Files list Specifies the file from which to display resources in the Resource Browser. Select a file 
from the Open Files or Favorites sections of the list, or select an option from the Libraries 
section of the list and browse to locate the file that contains the resources you need.
Select Always Display Active Document to automatically display the resources in the 
active file whenever you switch from one open file to another.
See “Using Resources from Open Files, Favorites, and Libraries” on page 229.

Home button Displays the resources of the currently active file
Resources menu Lists menu commands that are used to work with resources; see the following:

• “Viewing Resources” on page 223
• “Creating New Resources” on page 228
• “Finding Resources” on page 232
• “Working with Resources” on page 225

Up one level button Moves one level up the symbol folder or script palette folder hierarchy
File folder list Lists the file’s resource folders, if there are symbol folders or script palette folders in the 

file. Select a folder to display the folder’s resources in the resource display window.
To return to a view of the entire resource hierarchy, select Top Level. All resource types 
and folders that are currently selected to be shown display in the resource display window.

Resource type In Thumbnails mode, displays resources divided into categories by type; the types are 
displayed in headings that can be shown and expanded, or collapsed and hidden (see 
“Hiding and Showing Resources” on page 225). In List mode, click the column header to 
sort the columns by resource name or by resource type.

Resource screen tip Shows the full resource name as a screen tip when you position the cursor over a resource; 
for referenced resources, the screen tip also shows the source file name

Resource preview Displays resources with a preview image, or lists the resources with a representational icon

Files menu

Resources menu

Resource type

Resource preview

Files list

File folder list

Resource name

Home button

Up one level button

Active symbol
button

Select an open file to
display its resources

Select to always
display the resources

of the active file

Select a favorite file to
display its resources,

without opening the file

Select a library option
to browse for a file from

which to display
resources, without

opening the file

A check mark indicates which 
file’s resources are currently 
displayed (Mac only)

Resource screen tip

Resource
display window
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2. By default, the resources from the currently active document display. Locate and select a resource to use from this 
file, or use the Files list to view resources from other files. If the resource you need does not exist, you can create 
one.

3. Once a resource is selected, you can use it in the drawing, or select another action from the Resources menu, such 
as Edit or Export to another file. See “Working with Resources” on page 225 for more details.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Viewing Resources
Accessing Existing Resources
Using Favorites Files
Finding Resources
Working with Resources
Creating Resource Libraries

Viewing Resources
Resources can be viewed in either Thumbnails (default) or List mode. 

In Thumbnails mode, resources are displayed in 64x64 pixel full color. Gradient fills, hatch fills, image fills, line types, 
symbols, plug-in objects, text styles, and tile fills are previewed with an actual image; other resources are previewed 
with a representational icon. For symbols, the thumbnail view and render mode can be set from the Resources menu, 
and when editing symbols, the thumbnail view can be set to match the editing view. Long resource names display on up 

Resource name Shows the resource name; a name in italics indicates a referenced resource. Type the first 
letter of a resource to quickly display resource names beginning with that letter. The color 
of a symbol (black, red, or blue) indicates the symbol type (see “Symbol Types” on 
page 237). 

Resource display 
window

Displays the resources from the file shown in the Files list, and the symbol folder shown in 
the File Folder list. Select which resource types to display from the Resources menu (see 
“Hiding and Showing Resources” on page 225).

Active symbol button Displays the currently active symbol in the resource display window

Feature Description

Full color, 64x64
pixel image

Click the column header to
select how to sort the

resources; click again to
change the sort order

Representational resource icon

Thumbnails mode List mode

http://www.youtube.com/watch?v=vcg4eKZYz9I 
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to five lines, and the number of characters displayed depends on the system font selected. In List mode, resources are 
displayed as 16x16 pixel representational icons.

 

Resource Thumbnail Icon List Icon

Gradient Fill (see “Using Gradient Fills” on page 1115)

Hatch Fill (see “Using Hatch Fills” on page 1104)

Image Fill (see “Using Image Fills” on page 1119)

Line Type (see “Using Line Types” on page 1128)

Record Format (see “Record Formats” on page 262)

Referenced Resource (see “Referencing Resources” on page 213) Resource name displays in 
italics

Renderworks Background (Renderworks required; see “Creating Layer 
Backgrounds” on page 1522)

Renderworks Texture (Renderworks required; see “Creating Textures” on 
page 1505)

Renderworks Prop Texture (Renderworks required); see “Creating Image Prop 
Objects” on page 1520

Renderworks Style (Renderworks required); see “Creating Renderworks Styles” 
on page 1596
Sketch Style (Vectorworks Design Series required; see “Sketch Rendering” on 
page 1497)

Slab Style (Vectorworks Architect required; see “Creating Slabs” on page 481)

2D Symbols and Plug-in Objects (see “Symbols” on page 237) 

3D Symbols and Plug-in Objects (see “Symbols” on page 237)

Hybrid Symbols and Plug-in Objects (see “Symbols” on page 237)

Symbol Folder (see “Managing Symbols” on page 251)

Text Style (see “Using Text Styles” on page 393)

Tile Fill (see “Using Tile Fills” on page 1111)

Script (see “Using Scripts” on page 1771)
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To change the view mode:
1. In the Resource Browser, select Resources > View As.
2. From the list, select Thumbnails or List.

Select Window > Palettes > Save Palette Positions to save selected views across Vectorworks sessions. To revert 
to settings established when the custom workspace was created (in the User Data and Preferences folder), click 
Reset Saved Settings from the Session tab of Vectorworks preferences.

Hiding and Showing Resources
When there are a large number of resource types, it may be useful to hide unused resource types from view.
To hide or show resource types:

1. In the Resource Browser, select Resources > Show Object Types.
2. Select the resource type to hide or show. A currently visible resource type is indicated by a check mark next to its 

name. (In List view, hidden resources are not shown in the resource display window.)
In Thumbnails mode, click on the disclosure arrow next to the resource type name in the Resource Browser to hide or 
display resources. Alternatively, double-click on the resource name bar to hide or display resources.
Select Window > Palettes > Save Palette Positions to save the current show/hide status across Vectorworks sessions. 
To revert to settings established when the custom workspace was created (in the User Data and Preferences folder), 
click Reset Saved Settings from the Session tab of Vectorworks preferences.
~~~~~~~~~~~~~~~~~~~~~~~~~
Using the Resource Browser
Session Preferences

Working with Resources
Available commands are determined by the resource selected.
To use a resource:

1. Select the resource to use in the Resource Browser.
2. Select the desired command from the Resources menu.

Right-click (Windows) or Ctrl-click (Mac) on a resource to access a context menu. This menu lists the associated 
commands from the Resources menu for the selected resource.

Script Palette (see “Using Scripts” on page 1771)

Wall Style (Vectorworks Architect or Landmark required)

Curtain Wall Style (Vectorworks Architect or Landmark required)

Worksheet (see “Creating Worksheets” on page 1315)

Resource Thumbnail Icon List Icon
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Command Description Shortcut Key Equivalent

Apply Applies the selected resource to the selected drawing 
object(s)

Double-click

Attach Record Opens the Attach Record dialog box, to attach a record 
to the selected plug-in object, or to the symbol 
definition (changing all symbol instances, existing and 
future); see “Attaching Record Formats to a Symbol 
Definition” on page 264

Not applicable

Delete Deletes the selected resource from the Resource 
Browser

Delete key

Duplicate Opens the Assign Name dialog box; enter a name and 
click OK to create a duplicate of the selected resource

Not applicable

Edit Opens an edit dialog box for the selected resource.
If the resource is referenced, an alert prompts you 
to verify that you want to edit the resource before 
the edit dialog box opens. Edits made in the current 
document are also saved automatically to the 
source document, which may affect references to 
this resource in other files.

Ctrl-double-click (Windows)
Option-double-click (Mac)

Edit 2D Component Edits the 2D component of the symbol definition (see 
“Object Editing Mode” on page 1004)

Ctrl-double-click (Windows)
Option-double-click (Mac)

Edit 3D Component Edits the 3D component of the symbol definition (see 
“Object Editing Mode” on page 1004)

Ctrl-double-click (Windows)
Option-double-click (Mac)

Edit 3D Wall Hole 
Component

Edits the 3D wall hole component of the symbol 
definition (see “Adding a 3D Wall Hole Component to a 
Symbol Definition” on page 260)

Ctrl-double-click (Windows)
Option-double-click (Mac)

Edit Definition 
(Vectorworks Landmark 
required)

Edits the definition of the plant symbol as described in 
“Creating Plant Definitions” on page 787

Ctrl-double-click (Windows)
Option-double-click (Mac)

Edit Symbol Options Opens the Symbol Options dialog box to specify wall 
insertion options and other symbol parameters. See 
“Editing the Symbol Options of Multiple Symbols” on 
page 250.

Ctrl-double-click (Windows)
Option-double-click (Mac)

Enter Opens the selected symbol folder or script palette to 
display the symbols or scripts inside

Double-click

Export (Vectorworks 
Design Series required)

Opens the Export Resource dialog box to export the 
selected resource to another file. See “Exporting 
Custom Resources” on page 234.

Not applicable
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Extract Image(s) Opens the Select Folder (Windows) or Export Image 
File (Mac) dialog box to save a .png file extracted from 
the selected image or texture resource

To extract images from all image-based textures, 
Renderworks backgrounds, and image resources in 
the current document, execute this command with 
no resources selected.

Not applicable

IFC Data (Vectorworks 
Architect or Landmark 
required)

Attaches IFC data to the selected symbol definition, 
changing all symbol instances, existing and future; see 
“Assigning IFC Data to Objects” on page 1746

Not applicable

Make Active Makes the selected symbol or plug-in active, and 
activates the Symbol Insertion tool so that the symbol 
or plug-in can be inserted

Double-click

Move Opens the Move Symbol dialog box to move the 
selected symbol or plug-in object to another folder

Not applicable

New [resource] Opens a dialog box to create a new resource of the same 
type as the one selected (for example, a new gradient, 
record format, or worksheet)

Not applicable

Open When a worksheet is selected, opens the worksheet on 
screen for edits; when a script palette is selected, opens 
the palette

Ctrl-double-click (Windows)
Option-double-click (Mac)

Rename Opens the Assign Name dialog box; enter a name and 
click OK to rename the selected resource.

If the resource is referenced, an alert prompts you 
to verify that you want to rename the resource 
before the Assign Name dialog box opens. The 
name change made in the current document is also 
saved automatically to the source document, which 
may break references to this resource in other files. 
Referenced symbols, gradients, record formats, 
hatches, tiles, Renderworks backgrounds, textures, 
sketch styles, wall styles, text styles, slab styles, 
plants, and image resources can be renamed.

Ctrl-double-click (Windows)
Option-double-click (Mac)
(Image fills only)

Import When a resource from a different file is selected, 
imports the resource into the current file

Not applicable

Reference When a resource from a different file is selected, creates 
a reference to it in the current file. See “Referencing 
Resources” on page 213.

Not applicable

Break Reference When a referenced resource is selected, breaks the link 
between the current file and the master file; the resource 
remains in the current file but is no longer referenced

Not applicable

Run Runs the selected script. Text documents that contain 
scripts must be run using the Tools > Plug-ins > Run 
Script command. 

Double-click

Command Description Shortcut Key Equivalent
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Image resources can be compressed to reduce the Vectorworks file size. See “Compressing Images” on page 1822 
for more information.

~~~~~~~~~~~~~~~~~~~~~~~~~
Accessing Existing Resources
Using the Resource Browser

Creating New Resources
There are various methods to create new resources in a drawing. Most new resources are created through the Resource 
Browser, as described here. Some types of resources can also be created from menu commands elsewhere in the 
Vectorworks program, such as scripts and text styles. Symbols display in the Resource Browser, but they can only be 
created with the Modify > Create Symbol command.
To create a new resource:

1. In the Resource Browser, select Resources > New Resource to display the list of new resource types.
Alternatively, right-click (Windows) or Ctrl-click (Mac) in the Resource Browser to open the menu.
Double-click in an unused area of the resource display area to open the Create Resource dialog box. The dialog 
box contains the list of new resource types.

2. Select the resource type to create.
The resource-specific dialog box opens.

3. Follow the specific creation procedures for that resource.
Once created, the resource displays in the Resource Browser.

Quick Resource Creation
When you right-click (Windows) or Ctrl-click (Mac) in an area of the Resource Browser that is associated with an 
existing resource type, the context menu contains an additional option for quickly creating another resource of the same 
type. For example, right-click or Ctrl-click in the Hatches section and the New Hatch in (document) option displays. 
The context menu that displays varies slightly, depending on whether you click a blank area of the Resource Browser, 
or directly on a resource. 
Also, immediately after a new resource is created, the Resources menu contains an additional option for quickly 
creating another resource of the same type.

Worksheet On Drawing Places the selected worksheet on the drawing for display 
and printing

Double-click

Set Thumbnail View Applies a view to the thumbnail preview of the selected 
symbol(s), or to all symbols within folders and 
subfolders if a symbol folder is selected, or to all 
symbols in the file if nothing is selected

Not applicable

Set Thumbnail Render 
Mode

Applies a render mode to the thumbnail preview of the 
selected symbol(s), or to all symbols within folders and 
subfolders if a symbol is selected, or to all symbols in 
the file if nothing is selected

Not applicable

Command Description Shortcut Key Equivalent
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~~~~~~~~~~~~~~~~~~~~~~~~~
Finding Resources
Identifying Duplicate Resources
Working with Resources
Using the Resource Browser
Creating Resource Libraries

Accessing Existing Resources
While new resources are automatically added to the Resource Browser upon creation, resources that exist in other files 
must be imported or referenced into the current file through the Resource Browser palette. Default content is 
automatically imported into the current file at the point of use, and if it is a resource (such as a hatch or gradient) also 
displays in the Resource Browser; see “Resource Libraries” on page 219.

Quick Resource Browsing
Resources in another file can be quickly browsed to locate resources and to determine whether that file should be added 
as a favorite.
To view the resources available in another file that is not yet a favorite: 

1. In the Resource Browser, select Files > Browse a Document.
The standard file open dialog box opens.

2. Select the file to browse, and then click Open.
The resources in the selected file temporarily display in the Resource Browser. A resource from that file can be 
imported into the current file, but the browsed file is not saved as a favorite.

Using Resources from Open Files, Favorites, and Libraries
The Files list displays all currently open files and favorites. In addition, the Files list provides easy access to resource 
libraries—both the hundreds of libraries delivered with the Vectorworks software, and any other custom libraries that 
you create.
• Vectorworks Libraries accesses the libraries installed with the Vectorworks program.

Right-click (Windows) 
or Ctrl-click (Mac) 
here to display the 
context menu

Click here to display 
the command from 
the Resources menu
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• User Libraries accesses the libraries placed in your User Data and Preferences folder. See “User Folders 
Preferences” on page 57 for more information about user folders.

• Workgroup Libraries accesses the libraries placed in your Workgroup and Project folders (Vectorworks Design 
Series required). See “Sharing Custom Files with a Workgroup” on page 217 for details about using workgroup 
folders.

“Active Document” displays when Always Display Active Document has been selected from the Files list; the 
resources from the currently active file are always displayed.

To use a resource from a different file:
1. In the Resource Browser, do one of the following:

• Select the desired open file or favorite from the Files list.
• Select the desired library type (Vectorworks, User, or Workgroup) from the Files list. From the standard file 

open dialog box, locate the desired library file and click Open.
The file name is displayed in the Files list, and its resources display in the resource display window.

2. Select the desired resource from the resource display window. Multiple resources can be selected and imported at 
the same time.
• To use the resource immediately, double-click it to activate it, or select Resources > Apply or Resources > 

Make Active, if applicable. (Alternatively, drag the resource onto an object or to a location in the current file.) 
If symbol folders are present in the drawing, specify the location of the imported resource.

• To import the resource for future use, select Resources > Import.
• To reference the resource, select Resources > Reference. If the source file is not currently referenced by this 

file, specify the new reference information. (See “Referencing Resources” on page 213.)
The resource is added to the current file’s Resource Browser. (Default content is automatically imported into the 
current file at the point of use, and displays in the Resource Browser.)
When you access symbols or scripts within folders, the selected folder name is displayed in the Document Folder list, 
and its contents are displayed in the resource display window. To return to the main resource window, click on the 
Document Folder list, and then select Top Level. Alternatively, click the Up One Level button until the top level is 
reached.
~~~~~~~~~~~~~~~~~~~~~~~~~
Using Favorites Files
Finding Resources
Identifying Duplicate Resources
Working with Resources
Using the Resource Browser

Using Favorites Files
For quick access, the Resource Browser can store links to Vectorworks files that contain resources that you use 
frequently. You can then import resources from a Favorites file into any Vectorworks file and not have to search for the 
file again. Remove the link when the file is of no further use. Favorite files are remembered for future sessions.
Use the Files menu in the Resource Browser to create, use, and manage your Favorites list. Alternatively, add files (or 
aliases or shortcuts to the files) to the appropriate Favorites folder manually. 

Making the Current File a Favorite
To make the current file a favorite:

In the Resource Browser, select Files > Add Current to Favorites.
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The file is added to the Files list under Favorites.
The file must be saved to be added as a favorite.

Making an Unopened File a Favorite
To make an unopened file a favorite:

1. In the Resource Browser, select Files > Add New Favorite Files.
The standard Open dialog box opens.

2. Select the file to make a favorite, and then click Open.
The file is added to the Files list under Favorites.
The file must be saved in the same version of Vectorworks software as the current file to be added as a favorite.

Multiple files can be selected and added as favorites at the same time; alternatively, press Ctrl+A (Windows) or 
Command+A (Mac) to select all files at once.

Opening the Current Favorite
To open the current favorite:

1. In the Resource Browser, select the favorite file to open from the Files list.
2. Select Files > Open Current Favorite.

The file opens.

Refreshing Favorites from Disk
To update the resources from all favorite files:

In the Resource Browser, select Files > Refresh Favorites from Disk.
All current favorite files are reloaded into the Resource Browser, to reflect any changes that occurred since they 
were loaded when this Vectorworks session began.

Revealing the Location of the Current Favorite
To reveal the location of a favorite file:

1. In the Resource Browser, select the favorite file to reveal from the Files list.
The file name is displayed as the current file in the Files list, and its resources display in the resource window.

2. Select Files > Reveal Current Favorite.
Either Windows Explorer or Mac Finder opens to the folder that contains the file.

Removing Favorites
To remove a single favorite file:

1. In the Resource Browser, select the favorite file to delete from the Files list.
2. Select Files > Remove Current Favorite.

The file is removed from the Favorites list.
To remove all favorite files:

1. In the Resource Browser, select Files > Remove All Favorites.
A confirmation dialog box opens.

2. Click Yes to remove all favorites.
All favorite files are removed from the Favorites list.
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Adding a Favorite Manually
To create a favorite manually (not through the Resource Browser):

1. Place the file that you want to appear on the Favorites list (or a shortcut or alias that points to the file) in one of 
the following folders.

The file is added to the Files list under Favorites.
2. In the Resource Browser, select Files > Refresh Favorites from Disk.

Only files that are in your user Favorites folder can be removed with the commands in the Resource Browser. (See 
“User Folders Preferences” on page 57 for more information.) Files that were placed in a workgroup Favorites 
folder must be removed manually.

~~~~~~~~~~~~~~~~~~~~~~~~~
Accessing Existing Resources
Finding Resources
Identifying Duplicate Resources
Working with Resources
Using the Resource Browser

Finding Resources
There are three ways to quickly access specific resources through the Resource Browser: 

• Use the Resource Browser’s incremental name search feature to locate and select a resource that is already in the 
document.

• Use the Resource Browser’s Find Resource command to search for a specific resource name in the current file or 
in another file in a specified file path. When the resource is found, it can be selected from the Resource Browser.

• Find an instance of the resource in the drawing, and then Right-click (Windows) or Ctrl-click (Mac) and select 
Locate in Resource Browser from the context menu to select the resource in the Resource Browser.

Incremental Search
To quickly access a resource that is already in the document, click in the resource display window and begin to type the 
resource’s name. The resource display window scrolls to the first resource or folder that begins with the letter(s) you 
entered. The resource type (such as Textures or Worksheets) must be shown in the browser window to be part of the 
search. If the resource is in a folder, select the folder from the File folder list first.

Finding a Resource
Use the Find Resource command to quickly locate a resource in any file created with the current version of the 
program, and optionally to select that resource in the Resource Browser.
To locate and use a resource:

1. In the Resource Browser, select Resources > Find Resource. 
The Find Resource dialog box opens.

Favorites Folder Effect on Favorites Lists

[User]/Libraries/Favorites The file appears only in your Favorites list ([User] is the user data folder 
specified in your Vectorworks preferences). See “User Folders 
Preferences” on page 57 for more information about user folders.

[Workgroup]/Libraries/Favorites
(Vectorworks Design Series required)

The file appears in the Favorites list of any user who has the workgroup 
folder set up in Vectorworks preferences
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Click to show/hide the parameters.

2. Enter the search criteria and click Find.
The Find Resource Results dialog box displays the resource name, type, and file location for all resources that 
match the specified search criteria. Select the resource name and click Select (or double-click the resource name). 
If the selected resource is in a different file, the Resource Browser temporarily displays all the resources of that 
type (such as Hatches) that are contained in the file. The resource you selected is highlighted. 

3. Once the resource is found, there are various ways to use it:
• To use the resource immediately, double-click it to activate it, or in the Resource Browser select Resources > 

Apply or Resources > Make Active, if applicable. (Alternatively, drag the resource onto an object or to a 
location in the current file.) If symbol folders are present in the drawing, specify the location of the imported 
resource.

• To import the resource for future use, select Resources > Import.
• To reference the resource, select Resources > Reference. If the source file is not currently referenced by this 

file, specify the new reference information. (See “Referencing Resources” on page 213.)
The resource is added to the current file’s Resource Browser. (Default content is automatically imported into the 
current file at the point of use, and displays in the Resource Browser; see “Resource Libraries” on page 219.)

Locating Specific Resources
Resources used in a drawing can be quickly located and selected in the Resource Browser with the Locate in Resource 
Browser context menu command.
To locate a resource from the drawing:

1. Move the cursor over the resource (or object containing a resource, such as a rectangle with a hatch) to be located. 
Right-click (Windows) or Ctrl-click (Mac) and select Locate in Resource Browser from the context menu.
The command name dynamically updates to reflect the resource; if the cursor is over an image, or an object with 
an image resource applied is selected, the command displays as Locate Image in Resource Browser. Textures 
applied to object parts can also be located (Renderworks required). Most resource types can be quickly located by 
this method, except for record formats, symbol folders, scripts, and script palettes.

2. The Resource Browser automatically navigates to, and selects, the specific resource.

Parameter Description

Find resource names containing Enter the full or partial resource name to find
Search Location

Current file Select to search for the resource in the current file
Files on disk Select to search for the resource in the displayed path. To search for the resource 

in a different folder, click Choose; select the folder to search in, and then click 
Open (Mac) or OK (Windows) to return to the Find Resource dialog box.

Include subfolders Select whether to include subfolders in the search process
Options

Resource types Select to search for all resource types or for one specific resource type
Match case Select whether the search is case sensitive
Find whole words only Select this option to search for occurrences that are whole words only, and not 

part of a larger string of text



  234 | Using the Resource Browser
~~~~~~~~~~~~~~~~~~~~~~~~~
Accessing Existing Resources
Working with Resources
Identifying Duplicate Resources
Using the Resource Browser

Identifying Duplicate Resources
When a resources name has been duplicated in the current file, the program checks to see if any difference exists 
between the two resources.

• If the two resources are identical, only one is listed for selection 
• If there are variations between the resources containing duplicate names, the program appends the originating file 

name in parentheses to the default resource, and both items display for selection
~~~~~~~~~~~~~~~~~~~~~~~~~
Accessing Existing Resources
Finding Resources
Working with Resources
Using the Resource Browser
Working with Resources

Exporting Custom Resources
If you create custom resources and reuse them frequently, you may want to organize them into resource libraries. You 
and other users can add the libraries to the Resource Browser favorites, or add them to the default content, and then 
easily use resources from them as needed. (For more information about resources, see “Using the Resource Browser” 
on page 221.)
In the Vectorworks Design Series products, use the export function of the Resource Browser to export one or more 
resources from the current document to another file, without opening the file. If an older version of the resource is 
already in the target document, it can be updated with the new version.
To export resources:

1. In the Resource Browser, select the resource(s) to export.
2. Select Resources > Export. Alternatively, right-click (Windows) or Ctrl-click (Mac) on the resource and select 

Export Resource from the context menu.
The Export Resource dialog box opens.

Click to show/hide the parameters.

3. Click OK.

Parameter Description

Destination list Displays Recent Export Files, Libraries, and Currently Open files. Either select a file 
from the window and click OK, or click Browse to select a file from another location.
If the resource is to be exported one of the default content folders within the user folder 
(Libraries\Defaults), place the file within a subfolder if one exists.

Browse Specifies a different location for the exported resource
Preserve folder 
hierarchy

During export, maintains the same folder structure the exported resource had in its source 
file
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If the target file already contains a resource with the same name, the Resource Name Conflict dialog box opens 
with three options: replace the resource, rename the resource, or do not export that resource (any other selected 
resources will be exported, if there are no further name conflicts). Select an option, and then click OK. 
If there is a name conflict between two resources of different types (such as a symbol and an image), the option to 
replace the resource in the target file is not available.
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Symbols
Symbol Advantages
Objects can be saved as 2D (screen plane), 3D (2D planar or 3D), or hybrid (2D screen plane and 3D combined) 
symbol definitions. Vectorworks software also ships with thousands of symbols. Symbol definitions save the object 
properties, such as size, color, and class, within the symbol definition; these properties are retained each time the 
symbol is placed, and when a symbol is imported into a different drawing.
Symbols provide several advantages:

• Smaller file sizes: The symbol and its definition are stored only once in the drawing file. Placement information 
(location coordinates, rotation) is all that is required for each symbol instance.

• One-time editing: Changes to the symbol definition automatically update all the instances of the symbol in the 
drawing.

• Attached database information: The information associated with a symbol can be used to generate reports and 
worksheets. Information attached to a symbol is specific to that instance, allowing each instance to be edited 
individually.

• Ease of import: With the Resource Browser, importing symbols from one file to another is fast and easy, and any 
database information attached to the symbol is also imported.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Symbol Types
Creating New Symbols

Symbol Types
In Vectorworks, you can create 2D and 3D objects. Symbols, which are converted objects, can also consist of 2D, 3D, 
or hybrid objects. 
In addition, there are special symbol categories which indicate the symbol’s behavior at placement. These categories 
are color-coded within the Resource Browser for identification. The category a symbol belongs to depends on the type 
of object converted to a symbol and the options selected at symbol creation.
Symbols can be nested within other symbols. 

Symbol Type Symbol Category

2D 2D symbols are composed exclusively of 2D screen plane objects. The instances of the symbol are 
considered planar, and may occupy the screen plane, layer plane, or a 3D plane.

3D 3D symbols are created from 2D planar objects and/or 3D objects, have a height (Z coordinate) as 
well as widths and lengths (X and Y coordinates). These objects display flat in Top/Plan view. 
However, they retain their 3D properties. Symbols created from 3D objects that are not hybrid 
objects appear flat in 2D views, but show dimension in 3D views.

Hybrid A hybrid symbol contains both a 2D screen plane object and a 3D component, and displays 
correctly according to the view. The advantage of working with hybrid symbols is that 3D models 
can automatically be created from 2D drawings, or vice versa. For example, a hybrid door symbol 
displays as a “swing arc” in Top/Plan 2D view and as a fully formed door in a 3D view. Hybrid 
symbols must be inserted in the layer plane. 

Black This is the most common type of symbol, the static symbol. Its parameters are saved within the 
symbol definition, and set at placement. Changes made to the symbol definition affect all instances 
of the symbol.

http://www.youtube.com/watch?v=4ciZns8Q7cM
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Plug-in Objects
Plug-in objects have all the power of standard symbols, with the added advantage of being customizable. Unlike 
symbols, plug-in objects have the option of being placed onto the drawing and remaining modifiable. This is useful if 
the drawing needs to contain many different variations of the same object. 
Some tool sets and libraries contain plug-in objects; for example, the Scale Bar tool, located in the Dims/Notes tool 
set, inserts a plug-in object. In addition to the tool sets, pre-defined plug-in objects are available in the Libraries folder 
(in subfolders beginning with the word Object or Objects), and are accessed through the Resource Browser.
When a plug-in object from a tool set is inserted, an object properties dialog box may open the first time the item is 
placed in the drawing. The properties in this dialog box set the default values for the object during this session. Modify 
the properties prior to inserting the object, or accept the default values and click OK. Object instances can be modified 
through the Object Info palette after insertion.
Custom plug-in objects can be created through the Tools > Plug-ins > Plug-in Manager; see “Creating Scripted 
Plug-Ins” on page 1782.
In addition, a symbol can be saved as a “red” symbol that becomes a plug-in object upon insertion.
There are four different types of plug-in objects: point, linear, rectangular, and path. Each type is different in how it is 
placed in the drawing and edited.

Linear and rectangular objects cannot be inserted directly into a wall. However, once placed in the drawing, they 
can be dragged onto a wall to insert them.

Point Plug-in Objects
Point plug-in objects are placed by a single click in the drawing to specify the location, and then a second click to set 
the rotation angle. This is the same way symbols are placed using the symbol insertion tool. A preview image of the 
object is visible at the cursor location. Point plug-in objects cannot be edited (resized or rotated) with the cursor; they 
are edited using the Object Info palette.

Linear Plug-in Objects
Linear plug-in objects are placed with two clicks. The first click sets the beginning point and the second sets the 
endpoint of a line. The orientation of the object is determined by this line. The object can be resized or rotated by 
clicking on a reshape handle at either end of the line. It can also be edited using the Object Info palette.

Rectangular Plug-in Objects
Rectangular plug-in objects are placed by a sequence of three clicks in the drawing. There are two different placement 
modes which determine how these three clicks are interpreted.

Blue When placed, this type of symbol is converted to a group. Any changes made to the symbol 
definition later have no effect on the group. At symbol creation, select Convert to Group in the 
insertion options to specify a “blue” symbol.

Red When placed, this type of symbol is converted to a plug-in object. It has a specific insertion 
behavior (point, linear, rectangular, or path) and set parameters, and it can be modified, with many 
variations of the same object in the file. At symbol creation, select Convert to Plug-in Object in 
the insertion options to specify a “red” symbol. Changes to a “red” symbol definition affect future 
instances, but not existing ones.

Green This is a page-based symbol. Typically these symbols are annotation symbols that are scaled 
relative to the page size, such as a North arrow indicator.

Symbol Type Symbol Category
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• Center-line Placement Mode: The first click specifies the origin of the object, the second click specifies the 
length, and the third click defines half the width of the rectangular object. After the second click, the cursor 
displays feedback symmetrically on both sides of the center-line of the rectangle.

• Edge Placement Mode: The first click specifies one corner of the rectangular object, the second click determines 
the length, and the third click specifies the entire width.

When a rectangular plug-in object is selected, there are eight selection handles visible. The object can be resized by 
dragging these handles, or edited through the Object Info palette.

Path Plug-in Objects
Path plug-in objects are created with a sequence of several clicks that define the vertex points along a path. There are 
two different types of path plug-in objects based on the type of path that is used. A 2D path plug-in object uses a 
polyline path and a 3D path plug-in object uses a 3D NURBS curve for its path.
Path plug-in objects can be edited using the Reshape tool directly. They can also be edited through Modify > Edit 
Group, or the Object Info palette.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating New Symbols
Inserting Symbols
Editing Symbols
Symbol Advantages
Record Formats
Global Symbol Commands

Creating New Symbols
The Create Symbol command creates symbols from 2D and/or 3D objects, including text. Symbols can also be created 
from other symbols, from plug-in objects, groups, and worksheets. At placement, the symbol can convert automatically 
into a group or plug-in object. Viewports cannot be made into symbols.
For more information on symbol types and color categories, see “Symbol Types” on page 237.

Item Convert to Result

2D screen object 2D symbol 2D black symbol, planar
3D object and/or 2D 
planar

3D symbol 3D black symbol, for use in a 3D view only

2D screen + 3D object Hybrid 
symbol

Hybrid black symbol, for use in 2D plan and 3D models

Symbol Symbol Saves any changes to the current symbol attributes as a new, black symbol 
definition

Group Creates a new blue symbol definition, to be inserted as a group
Plug-in object Creates a new red symbol definition, to be inserted as a plug-in object

Group Symbol Creates a new black symbol definition, with multiple objects existing 
within a symbol container

Center-line Placement

Edge Placement

Plug-in object specific 
preferences



  240 | Creating New Symbols
To create a new symbol:
1. Select the object(s) to convert into a symbol.

To create a hybrid symbol, select both the 2D and 3D objects, which become the 2D and 3D components of the 
symbol. In Top/Plan view, align the objects first (symbol alignment can be adjusted after creation with the Edit 
Symbol command). The symbol preview that displays in the Resource Browser is generated in the symbol view at 
creation or editing.
If a hybrid symbol will be inserted into a wall, you can optionally specify the 3D wall hole component in addition 
to the 2D and 3D components; see “Adding a 3D Wall Hole Component to a Symbol Definition” on page 260.
For 2D symbols inserted in walls, two loci can be specified as wall break locations. In Top/Plan view, place two 
loci at opposing locations with the object to convert, and select them all before converting. When the symbol is 
inserted into the wall, the wall breaks at the loci locations instead of the symbol bounding box. 

2. Select Modify > Create Symbol.
The Create Symbol dialog box opens.

Click to show/hide the parameters.

Plug-in object Symbol Creates a new black symbol definition. This allows all instances to 
change by editing the plug-in object inside the symbol, even though the 
actual symbol instance cannot be edited.

Plug-in object Creates a new red symbol definition, to be inserted as a plug-in object. 
This allows an editable plug-in object to be placed in a drawing with 
saved parameters. For example, a door plug-in object, when saved with a 
width of 4’ and inserted as a plug-in object, is inserted with a width of 4’ 
rather than with the default width.

Worksheet Group Creates a new blue symbol definition, to be inserted as a group. For 
example, a worksheet can be saved as a preformatted report by saving it 
as a blue symbol definition.

Parameter Description

Name Provide a name for the new symbol. Do not use single quotes in symbol names. Single 
quotes in names are reserved for use in scripts.

Insertion Point Controls how the symbol is inserted
Plan Projection Center/
3D Object Center/
Plug-in Object Origin

Sets the insertion point according to the object’s geometry. 
• If working in Top/Plan view, the insertion point is defined by the bounding box 

center. For 3D objects, the z coordinate is defined by the object's relation to the 
active layer plane.

• If working in 3D view, the insertion point is defined as the center of the object's 
bounding cube.

• If creating a symbol from a Plug-in object, the insertion point is defined to be the 
same as the object's insertion point.

Next Mouse Click Sets the insertion point manually, with the cursor, after clicking OK
Units Determines the symbol’s size units

Item Convert to Result
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3. Click OK. 
4. If the Next Mouse Click insertion point option was selected, click to specify the desired symbol insertion point.
5. Specify the folder location for the new symbol in the next Create Symbol dialog box.

Click the folder to select it as the destination for the new symbol.
Click to show/hide the parameters.

Page-based Sets the symbol size according to the page. When inserted, the symbol automatically 
scales relative to the page environment. This is useful for annotation objects that 
should always remain the same size on the “page,” regardless of the layer scale.

World-based Sets the symbol size according to constant world dimensions; its insertion size depends 
on the layer scale

Insert in Walls Select whether the symbol will be insertable in walls. When Wall Insertion mode is 
enabled, objects that have the Insert in Walls option enabled will insert into walls (see 
“Inserting Symbols” on page 242).

On Centerline/On Edge If Insert in Walls is selected, select how the symbol will be inserted. On Centerline 
snaps the symbol’s insertion point to the center line of the wall. On Edge snaps the 
symbol’s insertion point along either edge of the wall. 

Wall Breaks If Insert in Walls is selected, select how the wall will break around the symbol when it 
is inserted into a wall

Other Options
Leave Instance In-Place When selected, replaces the current selection with a symbol instance; when deselected, 

the object is removed from the drawing
Change 2D Objects 
from Layer Plane to 
Screen Plane

Converts any planar 2D objects in the layer plane into screen plane 2D objects, for the 
Top/Plan representation of the symbol. If deselected, any 2D planar objects in the layer 
plane that are part of the symbol will not display in Top/Plan view, so a hybrid symbol 
may not display properly in Top/Plan view.

Convert to Group Converts the symbol into a grouped object when inserted, disassociating it from the 
original symbol definition. Converted grouped objects are identified in the Resource 
Browser with a blue name.
Deselect to convert the symbol into a black, unmodifiable symbol; each instance is 
controlled by the symbol definition.

Convert to Plug-in 
Object

Converts the symbol into a plug-in object when inserted, allowing the current 
parameters to be pre-set when the plug-in object is inserted. Converted plug-in objects 
are identified in the Resource Browser with a red name.
Deselect to convert the symbol into a black, unmodifiable symbol; each instance is 
controlled by the symbol definition.

Assign To Class Select the class the symbol will be assigned to upon insertion. The symbol can be 
assigned to the active class or to another class present in the drawing; alternatively, 
create a new class by selecting New.

When a new class is created, it does not automatically become the active class.

Parameter Description
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6. Click OK.
The new symbol is added to the Resource Browser.

Inserting Symbols
Symbols are resources available from the Resource Browser. To open the Resource Browser, select Windows > 
Palettes > Resource Browser. Display the symbol to insert in the Resource Browser (see “Accessing Existing 
Resources” on page 229).
The currently active symbol is inserted; the active symbol’s name displays at the bottom of the Resource Browser. 
Clicking on the active symbol button automatically displays the currently active symbol in the resource display 
window.
Symbols are inserted from the Resource Browser by dragging and dropping, or with the Symbol Insertion tool. 
Symbols can be inserted as individual objects or inserted to become part of a wall.

~~~~~~~~~~~~~~~~~~~~~~~~~
Drag and Drop Symbol Insertion Method
The Symbol Insertion Tool

Drag and Drop Symbol Insertion Method
To insert a symbol by dragging it from the Resource Browser:

1. Click the symbol in the Resource Browser and drag it to the desired location in the drawing. To insert the symbol 
into a wall, the symbol must have the Insert in Walls option enabled (see “Creating New Symbols” on page 239).

Parameter Description

Folder list Displays the file’s symbol folders; the selected folder becomes the destination for the new 
symbol

New Folder Creates a new folder within the selected folder; specify the folder name and click OK to 
create the symbol folder

Don’t show this dialog Hides this dialog box if you only want to see it when a file already contains symbol folders

Active symbol
button

Active symbol name
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The symbol cannot be rotated during insertion, since the Symbol Insertion tool is not automatically activated. 
When a symbol is dropped onto a wall, round wall, or roof, Vectorworks inserts the symbol into the object using 
the default flip value and insertion point. 
A symbol inserted by dragging and dropping is placed on the active layer plane by default. Press the Option key 
(Mac) or the Alt key (Windows) while dragging and dropping to place the symbol on the working plane.

2. The symbol is inserted.
If necessary, edit the symbol rotation or flip in the Object Info palette.

The Symbol Insertion Tool
Use the Symbol Insertion tool to place 2D, 3D, and hybrid symbols in the drawing. During insertion, a preview of the 
symbol is shown to aid in placement. Symbols can also be inserted by dragging them from the Resource Browser.
Each symbol has its own insertion point, a location on the symbol shown by crosshairs in the Edit Symbol window, that 
controls how the symbol is placed into the drawing. The insertion point is specified during the symbol’s creation.

Hybrid symbols can only be inserted on a working plane that is parallel to the active layer plane. When inserting a 
hybrid symbol, if the working plane is not parallel to the active layer plane, the working plane is aligned with the 
active layer plane. (The working plane origin remains unchanged.)

Mode Description

Standard Insertion Inserts the symbol based on its specified insertion point, or aligned according to one of 
the symbol alignment modes

Offset Insertion Inserts the symbol in a wall according to an offset reference point
Symbol Pick up Designates a symbol from the drawing as the active symbol
Wall Insertion Toggles between inserting a symbol or plug-in object into a wall with wall breaks, and 

inserting a symbol or plug-in object near or on a wall without breaking it.
To prevent all symbol and plug-in objects from inserting into walls, turn off Wall 
Insertion mode. When Wall Insertion mode is enabled, objects that have the Insert in 
Walls option enabled will insert into walls. 

Symbol Alignment 
Modes

These alignment modes apply to Standard Insertion mode, and temporarily override the 
insertion point. These modes change the alignment of the insertion point along the X axis 
of the bounding box surrounding the symbol. Alternatively, keep the original point as the 
insertion point.

Align Symbol Left Moves the insertion point to the left edge of the symbol’s bounding box, along the 
original X axis

Align Symbol 
Center

Moves the insertion point to the center of the symbol’s bounding box, along the original X 
axis

Align Symbol Right Moves the insertion point to the right edge of the symbol’s bounding box, along the 
original X axis

Align Actual 
Insertion Point

Uses the symbol’s originally specified insertion point

Symbol Alignment Modes

Standard Insertion

Offset Insertion Wall Insertion

Symbol Pick up
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Click here for a video tip on this topic (Internet connection required).
~~~~~~~~~~~~~~~~~~~~~~~~~
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Offset Symbol Insertion Mode
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Wall Insertion Mode
Drag and Drop Symbol Insertion Method

Standard Symbol Insertion Mode

To insert a symbol:

1. Select the desired symbol from the Resource Browser.
2. Select Resources > Make Active. The Symbol Insertion tool, on the Basic palette, automatically becomes active.

Alternatively, double-click the symbol in the Resource Browser to make the symbol active and select the Symbol 
Insertion tool.

3. Click Standard Insertion from the Tool bar.
To insert the symbol into a wall with breaks, enable Wall Insertion mode. The symbol also must have the Insert 
in Walls option enabled (see “Creating New Symbols” on page 239).

4. Click the desired alignment mode (see “Inserting Symbols” on page 242).
5. Click to set the location of the symbol.
6. If the symbol is not oriented properly, move the cursor slightly away from the insertion point; then move the 

cursor to rotate the symbol about its insertion point. In the Data bar, use the A (angle) and WP A (working plane 
angle) fields to help position the symbol.

7. Click a second time, without moving the mouse, to position the symbol exactly as inserted. Alternatively, move 
the cursor slightly away from the insertion point to rotate or flip the symbol about its insertion point.
For symbols placed inside walls, moving the mouse flips the symbol about one of two axes: up and down, or left 
and right.
In click-drag mode, click and hold the mouse to insert the symbol and still be able to rotate it. A quick click 
eliminates the ability to rotate or flip the symbol and locks the orientation of the symbol as it is placed.

8. Click to set the symbol.

To place another copy of the symbol in the drawing, move the cursor to another location and click. The selected symbol 
and Symbol Insertion tool remain active until another tool is selected.

The first click inserts the 
symbol horizontally

Click 1

Click 2

Move the cursor up to rotate 
the symbol vertically

Click again to set the 
symbol’s position

Horizontal

Vertical

http://www.youtube.com/watch?v=xSdvDfmr8pw


Inserting Symbols |  245
~~~~~~~~~~~~~~~~~~~~~~~~~
Wall Insertion Mode

Offset Symbol Insertion Mode
Use Offset Insertion mode to insert a symbol into a wall at a specific distance from a reference point. The offset 
distance can be measured either to the symbol’s insertion point or to a clicked point on the symbol.

To insert a symbol into a wall with offset insertion:

1. Select the desired symbol from the Resource Browser. The symbol must have the Insert in Walls option enabled 
(see “Creating New Symbols” on page 239).

2. Select Resources > Make Active. The Symbol Insertion tool, on the Basic palette, becomes active. 
Alternatively, double-click the symbol in the Resource Browser to make the symbol active and to select the 
Symbol Insertion tool.

3. Click Offset Insertion mode.
4. Click the desired alignment mode.
5. Click to set the reference point from which the symbol is to be offset. The reference point does not have to be 

within the wall.
The symbol preview displays when the cursor is over a wall.

6. Click to set the offset location of the symbol.
7. If the symbol is not oriented properly in the wall, move the cursor slightly away from the insertion point, and then 

flip the symbol about its axis to the correct position.
In click-drag mode, click and hold the mouse to insert the symbol and still be able to flip it. A quick click 
eliminates the ability to flip the symbol and locks the orientation of the symbol as it is placed.

8. Click to set the symbol.
The Enter Offset dialog box opens, displaying the distance between the clicked points. The fields available depend 
on whether the wall is straight or round.

Click to show/hide the parameters.

9. Click OK.
10. If the Insertion Point option was selected, the symbol is placed into the wall so that the insertion point is offset as 

specified from the reference point.
If the Next Click option was selected, a witness line of the specified length or angle extends from the reference 
point to the end point. Click on the symbol to indicate the appropriate offset point and to place the symbol into the 
wall so that the clicked point is offset as specified from the reference point.

Parameter Description

Offset For straight walls, specify the offset distance. For round walls, specify either the Distance or the 
Angle between the reference point and the symbol. The distance is measured along the outer arc 
of the round wall.

Offset Using Select whether to offset the symbol using the insertion point or the next mouse click on another 
point on the symbol
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Symbol Pick Up Mode
The Symbol Pick up mode “picks up” any symbol already inserted into the drawing and makes it the active symbol. 
This avoids having to locate and select the symbol in the Resource Browser.

To pick up and place a symbol:

1. Click the Symbol Insertion tool from the Basic palette.
2. Click Symbol Pick up mode.
3. Click a symbol in the drawing.

The symbol becomes the active symbol. Note that the symbol clicked on is not highlighted (selection handles do 
not display).
Either the Standard Insertion mode or Offset Insertion mode is automatically enabled, depending on the last mode 
used. Select a different insertion mode, if desired.

4. Insert the symbol according to the instructions for that mode.
To switch to Symbol Pick up mode quickly, press and hold the Option (Mac) or Alt (Windows) key while the Symbol 
Insertion tool is active, and then click on the desired symbol. The selected symbol is now ready to be inserted into the 
drawing.
~~~~~~~~~~~~~~~~~~~~~~~~~
Standard Symbol Insertion Mode
Offset Symbol Insertion Mode

Wall Insertion Mode
When enabled, the Wall Insertion mode allows a symbol or plug-in object to be inserted into a wall. In addition, the 
symbol must have the Insert in Walls option enabled (see “Creating New Symbols” on page 239).
When Wall Insertion mode is disabled, a symbol or plug-in object is placed near or on top of a wall without being 
inserted directly into it.
A symbol or plug-in object inserted into a wall is automatically made parallel to the wall’s center line, by rotating it to 
match the wall’s angle. To remove a symbol from a wall, click and drag it out of the wall. Vectorworks automatically 
seals the cut in the wall.
For more information on inserting and moving symbols into, out of, and within walls, see “Bulb Flat” on page 458.
~~~~~~~~~~~~~~~~~~~~~~~~~
Drag and Drop Symbol Insertion Method
Inserting Symbols

Editing Symbols
Once a symbol instance is placed in a drawing, its information can be displayed in the Object Info palette. Select a 
symbol instance to display its properties. A symbol’s location can be adjusted, or its layer and class association can be 
changed by selecting a new class or layer from the appropriate list. A symbol can be replaced with another symbol, 
rotated in 2D or 3D space, and, for symbols located in walls, flipped, replaced, and repositioned.
Most of a black symbol’s physical attributes cannot be directly changed in the Object Info or Attributes palette. Instead, 
the components of a symbol must be accessed and edited through the Edit Symbol window. Changes made to a symbol 
definition affect all existing and future instances of that symbol, unless the symbol was inserted as a group (blue) or 
plug-in object (red).
If you delete a symbol definition and there are instances of that symbol in the drawing, you can specify whether to 
replace all instances with loci or to delete them completely.
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Replacing Existing Symbols
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Converting a Symbol Instance to a Group
Managing Symbols
Creating New Symbols
Inserting Symbols
Deleting Symbols
Inserting and Editing Symbols Within a Wall

Rotating Existing Symbols
Rotate 2D symbols in the screen plane by entering a rotation angle in the Rot field of the Object Info palette. Rotate 3D 
symbols by clicking the Rotate 3D button in the Object Info palette. This button accesses the Rotate Object in 3D 
dialog box for specification of the rotation angle, center, and axis; see “Rotate Tool” on page 1022.
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Symbols

Replacing Existing Symbols
To exchange a symbol instance’s definition with another:

1. Select the existing symbol.
2. In the Object Info palette, click the Replace button.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on a symbol, and select Replace from the context menu.
The Choose a Symbol dialog box opens.

3. Select the desired new symbol.
Only the symbols that are currently part of the active drawing are listed.

4. Click OK.
The old symbol instance is replaced with the new symbol instance.

The new symbol uses the settings from the replaced symbol. Future occurrences of the new symbol are unaffected by 
these settings.
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Symbols

Editing Symbol Definitions
Most of a black symbol’s physical attributes cannot be directly changed in the Object Info or Attributes palette. Instead, 
the components of a symbol must be accessed and edited through the Edit Symbol window. Changes made to a symbol 
definition affect all existing and future instances of that symbol, unless the symbol was inserted as a group (blue) or 
plug-in object (red).
Editing a symbol from the drawing area allows you to edit the symbol definition from within that symbol instance. 
Other objects in the drawing can be visible, grayed, or hidden depending on two settings in the Display tab of the 
Vectorworks preferences: Show other objects while in editing modes and Gray other objects. When other objects 
are visible, they are also snappable, which makes it is easier to edit the symbol quickly and accurately.

The Show other objects while in editing modes preference does not work when editing a symbol definition from 
a flipped symbol instance; an alert message displays when this operation is attempted.
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When editing page-based (green) symbols from the drawing area, the scale of the symbol editing window is set to 1:1 
so that the symbol definition is the same size as the symbol instance, for ease of editing. The active layer scale cannot 
be changed from the document context menu while in the symbol editing mode. This is an exception for page-based 
symbols only. Due to the scale adjustment, other objects that are not part of the symbol definition are not snappable 
unless they are also at a 1:1 scale in the active layer.
Referenced symbols can be edited or renamed in the target file, which changes the symbol definition in the source file. 
See “Referencing Resources” on page 213.
Editing behavior and results depend on the symbol type (see “Symbol Types” on page 237).

To edit a symbol definition:
1. In the Resource Browser, select the symbol to edit, and select Resources > Edit. 

You can also right-click (Windows) or Ctrl-click (Mac) the symbol, and select Edit 2D Component, Edit 3D 
Component, Edit 3D Wall Hole Component, or Edit Symbol Options. For plant symbols, Edit Definition 
(Vectorworks Landmark required) is also available from the context menu.
Alternatively, edit a black symbol instance from the drawing using one of the following methods:
• Select the symbol and then select Modify > Edit Symbol.
• Double-click the symbol.
• Right-click (Windows) or Ctrl-click (Mac) the symbol, and select Edit from the context menu.
• To edit the components of a hybrid symbol directly, right-click (Windows) or Ctrl-click (Mac) the symbol, and 

select Edit 2D Component, Edit 3D Component, or Edit 3D Wall Hole Component from the context menu.
2. Only one component of a hybrid symbol can be edited at one time. If the symbol is hybrid, the Edit Symbol dialog 

box opens. Insertion options and units can be specified when the symbol is edited from the Resource Browser, and 
additional double-click behavior for the dialog box can be specified when the symbol is edited from the drawing.
Select the component to edit.

Click to show/hide the parameters.

Symbol Type Edit Behavior/Result

Black or green Edit from the Resource Browser or from the drawing. Changes to the symbol, whether made to 
the definition or the instance, affect both existing and future symbol instances.

Blue Edit from the Resource Browser. Changes to the definition affect future symbol instances only. 
A blue symbol inserted on the drawing as a group cannot be edited from the drawing in the Edit 
Symbol window (make edits directly from the Object Info or Attributes palette, and by editing 
the group). Changes to a drawing instance affect that instance only. 

Red Edit from the Resource Browser. Changes to the definition affect future symbol instances only. 
A red symbol inserted on the drawing as a plug-in object cannot be edited from the drawing in 
the Edit Symbol window (make edits directly from the Object Info or Attributes palette). 
Changes to a drawing instance affect that instance only. 

Parameter Description

2D/3D Component Edits the 2D screen plane or the 2D planar/3D component of the symbol
3D Wall Hole Component Edits the 3D wall hole component of the symbol definition (see “Adding a 3D Wall 

Hole Component to a Symbol Definition” on page 260)
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3. Click Edit.
• If Symbol Options was selected, the Symbol Options dialog box opens. See “Creating New Symbols” on 

page 239 for information on wall insertion options and units.
• If one of the component options was selected, the Edit Symbol window opens, containing the symbol to be 

edited. A colored border around the drawing window indicates that you are in an editing mode. The Exit 
Symbol command becomes available from the Modify menu, and the Exit Symbol button is visible in the top 
right corner of the drawing window.

To edit nested symbols, select Modify > Edit Symbol again.
The visibility of other objects when in editing mode is controlled by the Show other objects while in editing 
modes option in the Display tab of the Vectorworks preferences (see “Vectorworks Display Preferences” on 
page 50). To show the other objects in a less obtrusive way, also select the Gray other objects option. If the 
symbol was edited from the Resource Browser, other objects cannot be displayed; edit a symbol instance from the 
drawing to display other objects while in editing mode. See “Object Editing Mode” on page 1004 for more 
information). If a page-based (green) symbol is being edited, the editing mode scale has changed to 1:1, and while 
other objects that are not at a 1:1 scale may be visible at their own active layer scale, they are not snappable.
The Show other objects while in editing modes preference does not work when editing a symbol definition from 
a flipped symbol instance; an alert message displays when this operation is attempted.
If you are pasting 2D layer plane objects from the clipboard while editing a symbol, an alert allows you to assign 
those objects to the screen plane. Normally, select Yes so that the 2D components display correctly in Top/Plan 
view. 
In addition, if you are editing a 2D-only symbol and adding 3D objects (including 2D planar objects) or hybrid 
objects, or editing a 3D-only symbol and adding screen plane or hybrid objects, an alert informs you that you are 
creating a hybrid symbol. Portions of the symbol may not be visible in certain views. Similarly, if removing 
portions of a hybrid symbol during editing, you may be creating a 2D-only or 3D-only symbol which may not 
display as expected in certain views. Keep in mind that 2D objects that are part of a symbol must be in the screen 
plane to be visible in Top/Plan view; if they are planar, they will be visible in 3D views. 3D objects that are part of 
a symbol are not visible in Top/Plan view.

4. When editing components, make the symbol edits in the Attributes or Object Info palette. To edit the symbol 
insertion point, select all the components of the symbol, and relocate the components about the insertion point 
crosshairs. The intersection of the crosshairs gives the feedback segment Locus when encountered.

Symbol Options Edits the method of inserting the symbol into a wall, and whether symbols are 
world-based or page-based (see “Creating New Symbols” on page 239). To edit the 
symbol options of multiple symbols, see “Editing the Symbol Options of Multiple 
Symbols” on page 250)

Double-click Sets the future behavior when double-clicking on a symbol in a drawing. Select 
whether to display the Edit Symbol dialog box, or directly edit the 2D or 3D 
component or insertion options. Select Edits the Component based on current view 
to automatically edit the 2D component if in Top/Plan view, or the 3D component if in 
one of the 3D views.

Use the edit view Matches the Resource Browser thumbnail view to the selected editing view. For 
example, if a hybrid symbol’s thumbnail preview is set to Top/Plan, and the 3D 
component of the symbol is edited while in a Right Isometric view, the thumbnail view 
switches to Right Isometric to match.

Parameter Description
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The other component of a hybrid symbol is not automatically adjusted to match changes made to the insertion 
point. It must be edited separately. Switch easily to the other component from the context menu.

5. After editing, click the Exit Symbol button (or select Modify > Exit Symbol) to update all instances of the 
symbol and return to the normal drawing mode.
If the edited symbol is nested in other symbols, the Exit Symbol button returns back to the symbol container.

Editing the Symbol Options of Multiple Symbols
When multiple symbols are selected in the Resource Browser, it is possible to change the symbol options of all the 
symbols at one time.
To edit the symbol options of multiple symbols:

1. Select the symbols in the Resource Browser.
2. Select Resources > Edit Symbol Options.

The Symbol Options dialog box opens. 
3. The options are the same as those described in “Creating New Symbols” on page 239. However, the dialog box 

displays the current status of parameters for the selected symbols. When the parameter settings of the symbols are 
different, the option displays as blank, or a check box displays with an “indeterminate state;” any edits to that 
parameter affect all the selected symbols.
If the selected symbols consist of a mixed set of symbol types, the available conversion options may differ 
(Convert to Group/Convert to Plug-in Object). Symbols are converted as described in “Creating New Symbols” 
on page 239.

4. Click OK to edit the symbol options.
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Symbols
Editing Symbol Default Record Values
Object Editing Mode
Converting a Symbol Instance to a Group

Converting a Symbol Instance to a Group
Changes made to a black symbol definition affect all instances of that symbol in the drawing. The Convert to Group 
command changes a selected symbol into a group of Vectorworks objects, allowing edits to be made to that object 
without affecting the other instances of the symbol in the drawing. This command “disassociates” the symbol instance 
from its definition. The edited symbol can then be turned into a new symbol if desired.

Before using this command to edit a symbol instance that has been inserted into a wall, first drag the symbol 
outside of the wall. This avoids converting the wall as well.

To convert a symbol to a group:
1. In the drawing, select the symbol instance to edit.
2. Select Modify > Convert > Convert to Group.

Crosshairs
Insertion point
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If a symbol contains multiple levels of grouped objects, other symbols, or plug-in objects, the Convert to Group 
Options dialog box opens. Select the desired criteria for converting the symbol.

Click to show/hide the parameters.

Use caution when converting hybrid symbols. If in Top/Plan view, the 3D component of the symbol may be lost 
during the conversion. Similarly, in a 3D view, the 2D screen plane portion of the symbol may be lost.

3. Click OK.
The symbol is converted into a group. To make changes to grouped items, select Modify > Edit Group or 
Ungroup.
The object can be left as a grouped object or saved as a new symbol. Any changes to the original symbol definition 
do not affect this instance.
Instead of repeatedly converting a symbol to a group, create a “blue” symbol which automatically converts to a 
group upon insertion.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Symbols
Creating New Symbols

Managing Symbols

Creating a New Symbol Folder
Create symbol folders to organize symbols within the Resource Browser.
To create a new symbol folder:

1. Select Resources > New Resource to display the list of new resource types.
2. Select Symbol Folder.

The Assign Name dialog box opens.
3. Enter the name to assign to the new symbol folder.
4. Click OK. 

The new folder is added to the Resource Browser.

Moving a Symbol into a Folder
Group symbols according to topic or placement by moving them into folders within the Resource Browser.
To move a symbol into a folder:

1. Select the symbol in the Resource Browser.
2. Select Resources > Move.

The Move Symbol dialog box opens. Click the folder to select it as the destination for the new symbol.

Parameter Description

Don’t convert sub-objects to groups Excludes any subobjects, such as nested symbols, from the 
conversion process

Convert nested symbols and plug-in objects Converts nested symbols and/or plug-in objects within the symbol to 
individual objects within the group

Convert all sub-objects Converts all objects within the symbol to individual objects within 
the group
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Click to show/hide the parameters.

3. Click OK.
Vectorworks moves the symbol to the new folder.

Importing a Symbol or Symbol Folder
To import a symbol or symbol folder from another Vectorworks file:

1. Select Window > Palettes > Resource Browser.
The Resource Browser opens.

2. Locate the file that contains the symbol or symbol folder to be imported.
For information using the Resource Browser to locate resources in other Vectorworks files, see “Accessing 
Existing Resources” on page 229.

3. Select the symbol or symbol folder to be imported, and then select Resources > Import. (Alternatively, drag the 
symbol or symbol folder resource into the desired Vectorworks file.)
The Import Symbol(s) dialog box opens.

Click to show/hide the parameters.

4. Set parameters and click OK.
If the target file already contains a resource with the same name, the Resource Name Conflict dialog box opens 
with three options: replace the resource, rename the resource, or do not import the resource. Select an option, and 
then click OK.

5. Click OK.
The symbol folder and any symbols it contains are imported into the active Vectorworks file.

Parameter Description

Folder list Displays the file’s symbol folders; the selected folder becomes the destination for the 
symbol

New Folder Creates a new folder within the selected folder; specify the folder name and click OK to 
create the symbol folder

Parameter Description

Preserve folder 
hierarchy (symbol folder 
import only)

Imports the symbol folder, and any subfolders and symbols it contains, and maintains 
the same folder structure it had in its source file

Select destination folder For symbol folders, imports the symbol folder, and any subfolders and symbols it 
contains, to the selected folder; for symbols, imports the symbol to the selected folder

Folder list Displays the file’s symbol folders; the selected folder becomes the destination for the 
symbol or symbol folder

New Folder Creates a new folder within the selected folder; specify the folder name and click OK to 
create the symbol folder

Don’t show this dialog 
when the current file has 
no symbol folders

If the current file has no symbol folders, select this option to hide this dialog box when 
you import symbols or symbol folders by dragging them into drawings in the future
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Creating a New Symbol Folder
Referencing Resources

Deleting Symbols
When a symbol resource is deleted, all instances of the symbol in the current document can be either deleted or 
replaced with loci to preserve the symbol locations.
To delete a symbol resource:

1. In the Resource Browser, select the symbol definition to delete, and select Resources > Delete.
Alternatively, right-click (Windows) or Ctrl-click (Mac) on a symbol definition, and select Delete from the 
context menu, or select the symbol definition and press the Delete key.

2. An alert displays to confirm that the resource should be deleted. If there are any instances of the symbol currently 
in the document, specify whether to replace all instances with loci or to delete them completely. Click Yes.
The symbol resource is deleted and each symbol instance is either deleted or replaced with a locus.

Inserting and Editing Symbols Within a Wall
Once walls have been created in a drawing, symbols and plug-in objects such as windows and doors can be added to 
them. After they are in the wall, the symbols may be moved or duplicated. When a 3D wall hole component has been 
added to a symbol, it can cut a hole of the desired shape in a wall. 
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Symbols with the Duplicate Symbol in Wall Tool
Inserting Symbols in a Duplicate Array
Dragging and Dropping Symbols into Walls
Moving Symbols in Walls with the Selection Tool
Nudging Symbols in Walls
Moving Symbols in Walls with the Move Command
Moving Symbols in Walls with the Move by Points Tool
Editing Symbols in Walls
Adding a 3D Wall Hole Component to a Symbol Definition
Creating New Symbols
Editing Symbols
Inserting Symbols 

Inserting Symbols with the Duplicate Symbol in Wall Tool 
Use the Duplicate Symbol in Wall tool to easily place multiple copies of a symbol (or plug-in object) in a wall, such as 
doors or windows in an office building or electrical outlets along a wall.

Symbols can also be duplicated within walls with the Duplicate Array command (see “Inserting Symbols in a 
Duplicate Array” on page 255) and with the Move by Points tool (see “Moving Symbols in Walls with the Move 
by Points Tool” on page 258).

The Duplicate Symbol in Wall tool has two modes.

Flip

Standard

Preferences
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To place duplicate symbols in a wall:

1. Select Window > Palettes > Resource Browser.
The Resource Browser opens.

2. Click the desired symbol from the list.
The symbol must have the Insert in Walls option enabled (see “Creating New Symbols” on page 239).

3. Select Resources > Make Active.
Activate a symbol already placed in the drawing with the Symbol Pick up mode of the Symbol Insertion tool 
(see “Symbol Pick Up Mode” on page 246).

4. Click the Duplicate Symbol in Wall tool from the appropriate tool set:
• Fundamentals workspace: Walls tool set
• Design Series workspaces: Building Shell tool set

5. Select the placement mode from the Tool bar.
This sets the symbol orientation. To place the symbol using the orientation in which is was created, click 
Standard mode. To flip the symbol when it is placed, click Flip mode.

6. Click Preferences from the Tool bar.
The Duplicate Symbol In Wall dialog box opens. Indicate how to place the symbols.

Click to show/hide the parameters.

7. Click OK.
8. Click on the wall to indicate where the first symbol should be inserted. A preview of the symbols are shown along 

the wall to aid in placement. If inserting the first symbol by an offset value, click anywhere on the wall and the 
first symbol preview displays at the proper offset distance.

9. If spacing symbols by the next mouse click, move the mouse along the wall to set the spacing between symbols, 
and click again to insert the duplicate symbols. If spacing symbols by a specified distance, click again to insert the 
duplicate symbols. If a number of copies was specified, that number of symbols is automatically inserted.
Move the mouse to the opposite side of the wall to flip the symbol direction.

Mode Description

Flip Flips the symbol during placement (for example, changes the direction that a door opens)
Standard Places the symbol using the orientation at creation
Preferences Specifies symbol placement information

Parameter Description

Start 
Offset

To set the first symbol position with the mouse, select Next Click; to set the first symbol position by 
a specified distance from a wall end, select the button next to the text box and enter a distance from 
the wall end

Spacing To place successive symbols by mouse click, select Next Click; to place successive symbols a 
specified distance apart, select the button next to the text box and enter a distance between symbols

Copies If selected, enter the specific number of symbol copies to insert into the wall
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Moving Symbols in Walls with the Selection Tool
Nudging Symbols in Walls
Moving Symbols in Walls with the Move Command
Moving Symbols in Walls with the Move by Points Tool
Editing Symbols in Walls

Inserting Symbols in a Duplicate Array
Use the Duplicate Array command to place multiple copies of a selected symbol into straight or round walls. 

Symbols can also be duplicated within walls with the Duplicate Symbol in Wall tool (see “Inserting Symbols 
with the Duplicate Symbol in Wall Tool” on page 253) and with the Move by Points tool (see “Moving Symbols 
in Walls with the Move by Points Tool” on page 258).

To create a duplicate array of symbols in a wall:
1. Select the symbol in the wall that is to be duplicated. The duplicates will be placed along the wall following the 

wall’s blue direction arrow.
2. Select Edit > Duplicate Array.

The Duplicate Array dialog box opens. The fields available depend on whether the wall that contains the selected 
symbol is straight or round.

Click to show/hide the parameters.

3. Click OK, and the array of duplicate symbols is placed into the wall.

Parameter Description

Direction The preview window shows the direction the duplicate symbols will be placed in the 
wall. To reverse the direction of the duplication, click the button to the left of the 
window.

Number of Duplicates Specify the number of copies of the original object to create
Offset Between 
Duplicates

Specify how far apart to place the duplicate symbols. For straight walls, enter the 
distance from the center of each symbol to the center of the next symbol in the wall. 
For round walls, specify either the distance or the angle between the duplicates. 
Distance is measured along the outer arc of the round wall. Angle is the angle between 
the center of each symbol to the center of the next symbol in the wall.

Z Offset Between 
Duplicates

Optionally, specify a difference in height on the wall between each symbol
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Dragging and Dropping Symbols into Walls
To insert a 2D, 3D, or hybrid symbol in a wall by dragging it from the Resource Browser:

1. Click the symbol in the Resource Browser and drag it to the desired location in the wall.
The symbol must have the Insert in Walls option enabled (see “Creating New Symbols” on page 239).
The symbol cannot be rotated during insertion, since the Symbol Insertion tool is not automatically activated. 
When you drop a symbol onto a wall or round wall, the symbol is inserted using the default flip value.

2. If necessary, edit the symbol parameters in the Object Info palette.
~~~~~~~~~~~~~~~~~~~~~~~~~
Moving Symbols in Walls with the Selection Tool
Nudging Symbols in Walls
Moving Symbols in Walls with the Move Command
Moving Symbols in Walls with the Move by Points Tool
Editing Symbols in Walls

Moving Symbols in Walls with the Selection Tool
The Selection tool moves symbols (or plug-in objects) within walls. Several symbols can be selected and moved at 
once. When multiple symbols are selected, their common parameters can be changed in the Object Info palette.
Symbols within walls and symbols outside of walls cannot be selected at the same time.

To move one or more symbols within a wall:

1. Click the Selection tool from the Basic palette.
Toggle Wall Insertion mode on or off, depending on the desired result.

2. Select the symbol or symbols.
3. Position the cursor near the symbol to be moved. When the resize cursor displays, drag the symbol(s).

Action Description

Select one or more symbols inserted in a 
wall, with Wall Insertion mode on

Inserted symbols can be dragged out of the wall (and into another wall 
if desired)

Select one or more symbols not inserted 
in a wall, with Wall Insertion mode on

Selected symbols can be inserted into a wall by dragging them over the 
wall

Select one or more symbols inserted in a 
wall, with Wall Insertion mode off

The symbols are moved within the wall. When one of the objects in the 
selection reaches the end of the wall, none of the objects can be moved 
farther in that direction.
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Nudging Symbols in Walls
Moving Symbols in Walls with the Move Command
Moving Symbols in Walls with the Move by Points Tool
Editing Symbols in Walls

Nudging Symbols in Walls
Objects within a single wall can be nudged a small distance with a keyboard shortcut defined in the Edit tab of the 
Vectorworks Preferences (see “Edit Preferences” on page 49).
To nudge one or more symbols in a wall:

1. Select one or more symbols with the Selection tool; if multiple symbols are selected, they must be in the same 
wall.

2. Use the keyboard shortcut for nudging objects to move the symbols as needed. When one of the objects in the 
selection reaches the end of the wall, none of the objects can be moved farther in that direction.

~~~~~~~~~~~~~~~~~~~~~~~~~
Moving Symbols in Walls with the Selection Tool
Moving Symbols in Walls with the Move Command
Moving Symbols in Walls with the Move by Points Tool
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Moving Symbols in Walls with the Move Command
Symbols within a single wall can be moved with the Move command. 
To move one or more symbols in a wall:

1. Select the symbol(s) to move with either the Selection tool; if multiple symbols are selected, they must be in the 
same wall.

2. Select Modify > Move > Move.
The Move Selection dialog box opens. The fields available depend on whether the wall that contains the selected 
symbol(s) is straight or round.

Click to show/hide the parameters.

3. Click OK, and the symbols are moved as specified.

Parameter Description

Direction The preview window shows the direction the symbol(s) will be moved in the wall. To reverse 
the direction of the move, click the button to the left of the window.

Offset For straight walls, specify the distance along the wall to move the object(s). For round walls, 
specify either the Distance or the Angle between the old and new locations. The distance is 
measured along the outer arc of the round wall.

Click
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Moving Symbols in Walls with the Move by Points Tool
Symbols within a single wall can be moved, duplicated, and distributed along a specified distance with the Move by 
Points tool. The tool works in both 2D and 3D views.

Symbols can also be duplicated within walls with the Duplicate Symbol in Wall tool (see “Inserting Symbols 
with the Duplicate Symbol in Wall Tool” on page 253) and with the Duplicate Array command (see “Inserting 
Symbols in a Duplicate Array” on page 255).

The Move by Points tool has the following modes.

Moving Symbols in Walls with the Move or Distribute Mode
The Move and Distribute modes work the same way for symbols in walls as they do for other objects, except the vector 
that is specified by clicking is assumed to be along the wall. (See “Moving Objects with the Move or Distribute Mode” 
on page 1007 for details.)

To move, duplicate, and distribute selected symbols in a wall:

1. Select the symbol(s) in a wall to move and/or duplicate; if multiple symbols are selected, they must be in the same 
wall.

2. Click the Move by Points tool from the Basic palette and click Preferences from the Tool bar.
The Move by Points Settings dialog box opens. Select the desired settings and click OK.

Click to show/hide the parameters.

Mode Description

Move Moves and duplicates selected symbols according to the distance and direction specified by two 
mouse clicks

Distribute Moves and distributes duplicate symbols between the points specified by two mouse clicks
Reference 
Point

Moves selected symbols according to a clicked reference point and a specified offset distance 
from that point; the Preferences settings are not applicable when this mode is selected

Object 
Retention

Keeps the original symbols; this is the same as selecting the Retain option in the tool preferences

Parameter Description

Number of Duplicates Specifies the number of copies of the original object(s) to create (must be at least 
one); same as the Number of Duplicates field on the Tool bar

Move

Preferences

Distribute Object Retention

Reference Point

Number of Duplicates Preference



Inserting and Editing Symbols Within a Wall |  259
To select additional symbols or to change the currently selected symbol to move, duplicate, or distribute, press and 
hold the Alt key (Windows) or Cmd key (Mac) while shift-clicking additional objects or click-dragging the mouse 
around them to marquee select them; the Selection tool is activated in boomerang mode while the Alt or Cmd is 
being pressed.

3. Select either the Move or Distribute mode, depending on the desired outcome.
4. Click once to indicate the vector start point, and click again to indicate the vector end point. 

Symbols are duplicated or moved within the wall, in the direction and distance specified. If the wall is not long 
enough to accommodate the specified duplicates and spacing, the number of symbols and the distance between 
them is adjusted automatically.

Moving Symbols in Walls with the Reference Point Mode
Reference Point mode can work two ways; the first click can either indicate the object to be moved or the reference 
point from which the object will be offset.

To move selected symbols in a wall using a reference point:

1. Select the symbol(s) to move; if multiple symbols are selected, they must be in the same wall.
2. Click the Move by Points tool from the Basic palette, and select the Reference Point mode from the Tool bar.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the symbol and select Set Position from the context 
menu. The Move by Points tool is automatically selected, in Reference Point mode.
To select additional symbols or to change the currently selected symbol to move, press and hold the Alt key 
(Windows) or Cmd key (Mac) while shift-clicking additional objects or click-dragging the mouse around them to 
marquee select them; the Selection tool is activated in boomerang mode while the Alt or Cmd is being pressed.

3. Click to indicate either the reference point, or a point on the selected symbol.
The Enter Offset dialog box opens, displaying the distance between the clicked points. The fields available depend 
on whether the wall is straight or round.

4. For round walls, select whether to offset the symbol by Distance or by the Angle along the arc of the wall.
5. Change the offset distance or angle.
6. Select whether the first click made was the reference point or a point on the symbol to be moved.
7. Click OK. The selected symbol is moved along the wall as specified.
8. The setting for how the first click is interpreted remains set until it is changed.

~~~~~~~~~~~~~~~~~~~~~~~~~
Moving Symbols in Walls with the Selection Tool
Nudging Symbols in Walls
Moving Symbols in Walls with the Move by Points Tool
Editing Symbols in Walls
Moving Objects by Clicking with the Move by Points Tool

Original Object
Retain Keeps the original symbol(s); this option performs the same function as selecting 

the Object Retention button on the Tool bar
Leave Selected Keeps the original symbol(s) selected for further action

Parameter Description
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Editing Symbols in Walls
Once a symbol has been placed in a wall, you can flip the symbol in the wall, reposition it, or completely replace it. 
Symbols can also be dragged completely out of the wall.
To change how a symbol interacts with a wall:

1. Select Window > Palettes > Object Info.
The Object Info palette opens.

2. Select the desired symbol or symbols with the Selection tool.
The Object Info palette displays the symbol’s information. If several symbols are selected, only the common 
information can be changed.

3. Change the symbol’s settings as necessary.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Symbols
Adding a 3D Wall Hole Component to a Symbol Definition

Adding a 3D Wall Hole Component to a Symbol Definition
By adding a 3D wall hole component to a symbol definition, the symbol has the ability to cut holes of any shape in a 
wall. The geometry drawn to define the shape of the 3D hole can consist of any solid shape or shapes. If a wall hole 
component is included in a symbol definition, any existing 3D loci in the 3D component of the symbol are ignored.
To add a 3D wall hole component to a symbol definition:

1. Select a black symbol instance from the drawing. Right-click (Windows) or Ctrl-click (Mac) on the symbol, and 
select Edit 3D Wall Hole Component from the context menu to enter wall hole component editing mode.
It is also possible to select the symbol to edit from the Resource Browser, and select Resources > Edit, and then 
select 3D Wall Hole Component from the Edit Symbol dialog box. However, editing the symbol instance from 
the drawing allows you to see the drawing context when adding the wall hole component.

Parameter Description

Insert Changes the insertion point location in relation to the symbol position
Break Changes the wall break style where the symbol is inserted
Height Changes the height of the symbol in the wall
Flip Click to flip through a series of four rotations until the desired orientation is reached.

Alternatively, Right-click (Windows) or Ctrl-click (Mac) on the symbol and select Flip from the 
context menu.

Set 
Position

Activates the Move by Points tool in Reference Point mode; see “Moving Symbols in Walls with the 
Reference Point Mode” on page 259

Replace Opens the Choose a Symbol dialog box to allow selection of a replacement symbol; see “Replacing 
Existing Symbols” on page 247
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A colored border around the drawing window indicates that you are in an editing mode. The Exit Wall Hole 
Component command becomes available from the Modify menu, and the Exit Wall Hole Component button is 
visible in the top right corner of the drawing window.

2. Any solid shape(s) can be drawn to define the hole shape. The geometry must intersect the wall.
Select the 2D Polygon tool or Polyline tool from the Basic palette and trace the symbol outline to define the hole 
shape. Select Model > Extrude to create a 3D wall hole shape. Alternatively, create 3D wall hole geometry 
directly using 3D modeling tools. The wall hole geometry has a red pen style; this can be changed from the 
Attributes palette if desired.
Other drawing objects display, and can be snapped to, while in the editing mode (the Vectorworks display 
preference Show other objects while in editing modes must be enabled). The symbol being edited is displayed 
with its pen style attributes, to distinguish it from the rest of drawing.

3. Click Exit Wall Hole Component to return to the design layer.
Since the wall hole component was added to the symbol definition, all instances of the symbol will cut holes in 
walls according to the geometry drawn.

Applying Renderworks Textures to Wall Hole Components
Special texture parts for wall hole components can be applied from the Object Info palette (Renderworks product 
required). See “Applying a Texture to an Object” on page 1530. While editing the wall hole component, the Assign 
Part list on the Render tab of the Object Info palette lists three options for the different textures that can be applied to 
wall hole faces: Holes, Wall Left, and Wall Right.

Right-click (Windows) or Ctrl-click (Mac) 
and select Edit 3D Wall Hole Component 
from the context menu to enter wall hole 
component editing mode

In the editing mode, draw the 
geometry to create the 3D wall hole, 
and extrude it to create the wall hole 
shape

The 3D geometry creates the hole of 
the desired shape in the wall
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Each wall hole component can only have one texture part defined. Therefore, up to three different cutting objects 
would be necessary to apply three different texture parts to the wall hole faces.
~~~~~~~~~~~~~~~~~~~~~~~~~
Applying a Texture to an Object
Editing Symbol Definitions

Record Formats
Record formats, which store a wide range of data (like price or part numbers), can be attached to any object or symbol. 
Records attached to an object or symbol definition become a permanent part of it, remaining with the object or symbol 
even when it is imported or cut and pasted into another drawing. Several record formats can be attached to a single 
object or symbol, and record values can be individually changed for each object to which the record is attached. Record 
formats can be split and merged, to manage unwieldy or unnecessary formats.
In the Vectorworks Design Series products, record formats can be linked to an external database for automated, 
two-way communication; see “Database Connectivity” on page 1795.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Record Formats
Attaching Record Formats to Symbols and Objects
Editing Record Formats
Splitting and Merging Record Formats
Linking Text to Record Formats
Modifying Objects by Record Value

Creating Record Formats
Creating record formats in a drawing file is an important step to creating meaningful database rows in worksheets (see 
“Entering Data in Database Rows” on page 1339).
To create a new record format:

1. In the Resource Browser, select Resources > New Resource.
2. Select Record Format.

The Create Record Format dialog box opens.
3. Enter the Name of the Record Format.
4. Click New.

The Edit Field dialog box opens.
Click to show/hide the parameters.

Texture Part Result

Holes Applies the texture specified for the wall’s “Holes” part to the wall faces created by the cutting 
object

Wall Left Applies the texture specified for the wall’s “Left” part to the wall faces created by the cutting object
Wall Right Applies the texture specified for the wall’s “Right” part to the wall faces created by the cutting 

object

Parameter Description

Name Enter a name for the field, up to 63 characters
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5. Set the parameters and click OK to return to the Create Record Format dialog box.
6. For each additional field to add, repeat steps 4 through 6.
7. Click OK to return to the drawing area.

When an object is selected, the Data tab of the Object Info palette displays all records contained in the current 
drawing.

~~~~~~~~~~~~~~~~~~~~~~~~~
Attaching Record Formats to Symbols and Objects
Editing Record Formats
Splitting and Merging Record Formats
Linking Text to Record Formats
Modifying Objects by Record Value
Formatting Worksheet Cells
Database Connectivity

Attaching Record Formats to Symbols and Objects
Once a record format has been created, it can be attached to any object or symbol in the same drawing file as the record 
format. The Data tab of the Object Info palette indicates all record formats currently available to attach.
There are several methods of attaching record formats to symbols. Attach a record format to a single symbol instance, 
or to an object in the drawing, without affecting previous or future instances. Attach a record format to a symbol 

Type Select the type of field
Integer Select to use whole numbers ranging from -32,768 to 32,767.

Using Integer requires less memory than Number.
Boolean Select to use a data value of either True or False
Text Select to enter a string of characters (default option), such as a word or a sentence
Number Select to use numbers outside the range of Integer, fractions or decimals, or to specify a 

number format. Click Format to define the number format in the Number Format dialog 
box; click OK to return to the Edit Field dialog box.

General The default format
Decimal Uses decimal numbers; enter a value for the number of decimal places, and if desired, select 

to use commas as separators
Scientific Uses scientific numbers; enter a value for the number of decimal places
Fractional Uses fractional numbers; enter the rounding value for fractions
Percentage Uses percentages; enter a value for the number of decimal places
Dimension Uses dimension numbers
Dimension Area Uses dimension area format and displays the specified area units after the number
Dimension Volume Uses dimension volume format and displays the specified volume units after the number
Angle Determines the accuracy of angles and measurement system applied; measurement system 

is degrees, minutes, and seconds or decimal numbers up to eight decimal places
Date Uses dates; select the desired date format from the list

Default Enter the data value in the Default text box, if desired

Parameter Description
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definition that then applies to each symbol added to the drawing afterwards, or attach a record to a symbol definition 
and affect all existing and future symbol instances.
For global symbol changes, use the utility described in “Attaching Records” on page 273.

Attaching Record Formats to a Single Symbol Instance or Object
To attach (or detach) record formats to a single symbol or object in the drawing using the Object Info palette:

1. Select the symbol.
2. Select Window > Palettes > Object Info.

The Object Info palette opens.
3. Select the Data tab.

The Object Info palette lists all record formats in the drawing.
4. In the check box next to the desired record format(s), click to attach or deselect to detach the record format.

If attaching a record format, an X displays in the box and the record is attached to that instance of the symbol or 
object.
If detaching a record format, confirm the procedure.

To attach record formats to a symbol or object in the drawing using the Resource Browser:
1. Select the symbol(s) in the drawing.
2. From the Resource Browser, select the record format to be applied. Right-click (Windows) or Ctrl-click (Mac) and 

select Apply from the context menu. (Alternatively, double-click the record format resource to apply it to the 
selection or drag the record format resource onto a symbol or object.)

Attaching Record Formats to a Symbol Definition
There are two methods of attaching records to symbol definitions. The first method edits the symbol definition and 
allows records to be attached as well as default record values to be specified for the symbol definition. Existing symbol 
instances in the drawing are not affected. The second method attaches records to symbol definitions through the 
Resource Browser; both existing and future symbol instances are affected.
To attach record formats to a symbol definition by editing the symbol definition:

1. Select Window > Palettes > Resource Browser.
The Resource Browser opens.

2. Select a symbol definition.
3. Select Resources > Edit.
4. The Edit Symbol dialog box opens. Select the symbol component to edit, and click Edit.
5. In the Edit Symbol window, deselect all by clicking in an empty area of the window.
6. In the Object Info palette, click on the Data tab. 

When no items are selected, the Data tab displays *SYMBOL DEFAULTS* at the top.
7. Select the record to attach.

To attach multiple records to the same symbol definition, click on each of the records. 
The default Record Info value(s) of each Record Field can be set from the Data tab, affecting this symbol 
definition only without changing the record format resource; see “Editing Symbol Default Record Values” on 
page 267.

8. Click Exit Symbol at the top right of the Edit Symbol window.
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The attached record(s) is included with the symbol each time the symbol is placed in the drawing or imported into 
another drawing. Symbols already present in the drawing are unaffected.

To attach record formats to a symbol definition from the Resource Browser:
1. Select Window > Palettes > Resource Browser.

The Resource Browser opens.
2. Select a symbol definition.
3. Select Resources > Attach Record.

The Attach Record dialog box opens.
4. The record formats present in the drawing are listed. Select the records to attach to the symbol definition, and click 

OK.
5. Existing symbol instances, as any future symbols placed from the symbol definition, have the record format 

attached.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Record Formats
Editing Record Formats
Splitting and Merging Record Formats
Linking Text to Record Formats
Modifying Objects by Record Value
Database Connectivity
Global Symbol Commands
Working with Resources

Editing Record Formats
Record formats can be edited in a variety of ways, depending on the desired outcome.

Alternatively, make global changes with the symbol utilities (see “Changing One Record Format Field” on page 274 
and “Changing All Record Format Fields” on page 274).
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Default Record Formats
Viewing and Editing Object Records
Editing Symbol Default Record Values
Creating Record Formats
Editing Record Formats
Splitting and Merging Record Formats

Method Result

Edit the record format resource, changing the field 
list and/or default field values (see “Editing 
Default Record Formats” on page 266)

Future objects or symbols with the record attached reflect the 
changes; existing attached records are unaffected

Edit the field values of a record attached to a 
selected object (see “Viewing and Editing Object 
Records” on page 266)

Changes to field values affect the selected object only; the 
record fields cannot be changed. Existing and future objects 
with the record attached use the default values.

Edit the record field values of a symbol definition 
(see “Editing Symbol Default Record Values” on 
page 267)

Changes to field values affect future instances of the symbol. 
Existing symbols, other symbols with the record attached, and 
the record format resource are unaffected.
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Linking Text to Record Formats
Database Connectivity

Editing Default Record Formats
A record format’s fields and default values can be edited from the Resource Browser.
To edit record format values:

1. Select Window > Palettes > Resource Browser.
The Resource Browser opens.

2. Select the record format.
3. Select Resources > Edit.

The Edit Record Format dialog box opens.
Click to show/hide the parameters.

4. Select the record format field to edit and click Edit to change the default value, or click New or Remove to add or 
delete fields.

5. Click OK.
The edits do not affect existing values for attached records. Changes are applied to the default field values when 
attached to symbols or objects, or for future symbols with the record attached.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Record Formats
Editing Record Formats

Viewing and Editing Object Records
The Object Info palette Data tab is used to attach, view, and edit the record values for specific instances. 

If selecting multiple objects with different records attached, the Data tab displays records that are attached to 
objects with a grayed box, but does not indicate which records are attached to which objects. 
Resize the list boxes by selecting and dragging the resize bars between them.

To edit record field values for a selected object:
1. Select Window > Palettes > Object Info.

The Object Info palette opens.
2. Select the object.

Click the Data tab on the Object Info palette. The Object Info palette displays information about the record 
format(s) attached to the selected object(s). 

Click to show/hide the parameters.

Parameter Description

Name Displays the name of the current record format
Field list Lists the fields of the current record format
New Creates a new field (as described in “Creating Record Formats” on page 262)
Edit Edits the selected field
Remove Deletes the selected field
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3. Select the desired record in the Record Formats, and then the desired field in the Record Fields. Change the 
Record Info the default value.
This information applies to the selected object only; other new and existing objects with that record attached will 
still use the original (default) record format values. If a selected chair has a different part number from the default 
value that was entered in the record format, enter the new part number for that chair only. If the part number for all 
chairs has changed, edit the default record format instead.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Default Record Formats
Editing Symbol Default Record Values
Creating Record Formats
Editing Record Formats

Editing Symbol Default Record Values
The default values of a record attached to a symbol can be changed while editing a symbol definition (see “Editing 
Symbol Definitions” on page 247). This does not change the record format resource; if other symbols or objects have 
the record attached, they are unaffected. It does change the future default record values for that symbol.
To change the default field values of a symbol’s record format:

1. Select a symbol definition.
2. Select Resources > Edit.
3. Select the symbol component to edit, and click Edit.
4. In the Edit Symbol window, deselect all by clicking in an empty area of the window.
5. In the Object Info palette, click on the Data tab. 

When no items are selected, the Data tab displays *SYMBOL DEFAULTS* at the top.
6. Select the desired record in the Record Formats, and then the desired field in the Record Fields. Change the 

Record Info default value.
7. Click Exit Symbol at the top right of the drawing window to return to the drawing.

The default field values of the record format for that symbol definition have been changed.
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Default Record Formats
Creating Record Formats
Editing Record Formats

Parameter Description

Name Displays the name, if any, given to an object
Record 
Formats

Displays all records contained in the drawing; records attached to the selected object are indicated 
with an X in the check box to the left of the record name. If more than one object is selected, only 
the records attached to all objects display an X.

Record Fields Displays all the fields in the selected record; if a default value was assigned to the field, it displays 
after the field name. If no item is currently selected in the drawing, the label Record Field 
Defaults displays instead.

Record Info Edits the field values for the selected record; all entered values override any default values for the 
object
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Splitting and Merging Record Formats
Record format data can be manipulated, so that data from one record format can be split into two formats, or data from 
two record formats can be combined into one. No record data is lost during these transfers.

Splitting Record Formats
Record fields, and associated data, from one record format can be transferred to another new record format. This is 
useful, for example, when importing GIS data (Vectorworks Design Series required) with a significant number of 
record fields that may need to be reorganized.
To split a record format into two formats:

1. At least one record format must be present in the file. Select Tools > Records > Split Record Format.
The Split Record Format dialog box opens. Select the record format to edit from the Source Record Format list.

Click to show/hide the parameters.

2. Click to place a check mark next to the record fields that should be split from the selected format.
3. Enter a name for the new record format; it will contain the split record fields.
4. Click OK.

The indicated record fields (and associated data) are removed from the source record format and placed in the new 
record format, in record format order. All objects which had the original record format attached now have both the 
original record format and the new record format attached. No record fields and data are lost during this operation.

Merging Record Formats
The record fields, and associated data, from two record formats can be merged into one record format.
To merge two record formats:

1. At least two record formats must be present in the file. Select Tools > Records > Merge Record Formats.
The Merge Record Formats dialog box opens.

2. Select the format to be merged from the Merge Record Format list. 
The record fields from this record format will be merged, and this record format will be deleted.

3. Select the record format to receive the record fields that are merged. 
4. Click OK. 

The merged record fields are appended to the end of the receiving format’s record fields, in record format order. If 
there is a naming conflict and there are two fields with the same name, the transferred field name begins with an 
“_” (underscore). Any objects which had the first format attached now have the merged record attached instead. 
Any objects which already had the merged record attached now have the additional record fields included. The 
first Merge Record Format is deleted.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Record Formats

Parameter Description

Source Record Format Lists the record formats in the file; select the record format to edit
Fields to split Lists the record fields in the selected source format; click in the first column to select 

fields to be split out
New Record Format name Enter the name of the new record format to create. The split record fields are placed 

in the new record format.
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Editing Record Formats

Linking Text to Record Formats
The Link Text to Record command links the text within a symbol definition to a field of the attached record. This is 
particularly useful for labeling symbols in a drawing with unique information, such as a part list number or price. To 
use this command, symbols and record formats must already exist in the drawing file. The link is made within a 
symbol’s definition.
To link text to records within a symbol definition:

1. Edit the 2D symbol definition as described in “Editing Symbol Definitions” on page 247.
2. In the Edit Symbol window with nothing selected, create a line or block of text.

Ensure the text is formatted with the desired font and style. The actual text is not important at this point. If desired, 
create and assign a class to the text.

3. Select the text and place it in the exact location where the record data value is to display.
4. With the text still selected, select Tools > Records > Link Text to Record.

The Choose Field dialog box opens.

5. Select the record format from the Records list.
6. In the list of fields, select the field of the selected record to associate with the text.
7. Click OK.

Vectorworks adds the text object to the symbol definition, as well as all existing instances on the drawing. The 
default value of the selected field replaces the “dummy” text.

8. Click Exit Symbol at the top right of the drawing window to return to the drawing.
Place the symbol on the drawing. The text linked to the record displays the field information. If necessary, to edit 
the value for that particular instance, select the field where the text was assigned in the Object Info palette Data 
tab. In the Edit Field box, enter the text to display in the symbol; the linked field information displays on the 
attached symbol.

Text 

Records list

Field list
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Record Formats
Attaching Record Formats to Symbols and Objects
Editing Record Formats
Database Connectivity
Modifying Objects by Record Value

Modifying Objects by Record Value
This command modifies the color, size, or height of objects in a drawing based on the numeric value of a particular 
record field attached to the selected items. This can be useful for analyzing and comparing objects in a drawing.
To modify objects by record value:

1. Select Tools > Records > Modify by Record.
The Modify by Record Value dialog box opens.

Click to show/hide the parameters.

Parameter Description

Saved Settings Options
Settings Select <Active Settings> to use the settings currently selected in the dialog box; to use a 

set of saved settings, select them from the pull-down list
Save Opens a dialog box to name and save the currently selected settings so that they can 

quickly be selected as a set
Manage Opens the Manage Saved Sets dialog box to rename or delete sets of saved settings (see 

“Managing Saved Settings” on page 272)
Record Lists the record formats available for the applicable objects in the current drawing (based 

on the settings in the Apply to and Include components of fields). Select the record that 
contains the field you want to use.

Record Field Lists the fields available in the selected Record format; select the field to use to modify 
the objects

123-456789 

ODBC functionality
(Vectorworks Design 
Series required)
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Color Gradient Applies colors to the selected objects according to the numeric value in the Record 
Field. Use the fields in the Options box to select a gradient and enter a numeric range. 
The colors are automatically drawn from the gradient and assigned at equal intervals in 
the given range.

Color Gradient Options
Apply to Select the object attributes to which the specified colors will be applied: fill background 

or foreground, or pen background or foreground
Lower bound/Upper 
bound

Objects with a field value at or below the lower bound will be given the color at the start 
(left side) of the gradient. Objects with a value at or above the upper bound will be given 
the color at the end (right side) of the gradient. Objects with a value between the bounds 
will be given a color along the gradient.

Gradient Select the desired gradient from either the default content or the current file’s content (see 
“Resource Libraries” on page 219). The object colors will be taken from this gradient.

Color Ranges Applies colors to the selected objects according to the numeric value in the Record 
Field. Use the fields in the Options box to define each numeric range and the color to be 
used.

Color Range Options
Apply to Select the object attributes to which the specified colors will be applied: fill background 

or foreground, or pen background or foreground
Ranges list Lists the numeric ranges and associated colors that will be used to modify objects
Add/Edit To add a range, click Add. To edit a range, select a range from the list and click Edit (or 

double-click a value). The Edit Color Range dialog box opens.
Select a color, and then specify the Lower Bound and Upper Bound of field values to 
which the color will be applied. Click OK, and the range displays in the Ranges list.

Delete Select a range from the list and click Delete to remove it from the list
Color Value Applies colors to the selected objects according to the numeric value in the Record 

Field. Use the fields in the Options box to specify a color for each numeric value found 
among the selected objects.

Color Value Options
Apply to Select the object attributes to which the specified colors will be applied: fill background 

or foreground, or pen background or foreground
Values list Lists the numeric values of the selected field for the selected objects, and the associated 

colors that will be used to modify the objects
Edit Select a record field value from the list and click Edit (or double-click a value) to open 

the Edit Color Value dialog box.
To apply a color to objects with this value, select the Apply color option, and then select 
a color from the pull-down list. Click OK, and the Values list is updated.
To remove the color from objects with this value, access the Edit Color Value dialog box 
and deselect the Apply color option, Alternatively, deselect the Apply column on the 
Values list.

Resize Scales the selected objects by a specific amount; in the Options box, enter the Multiplier 
to apply to the value in the Record Field

Parameter Description
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2. Click OK.
3. The color, size, or height of the drawing objects are modified.

Managing Saved Settings
If you have saved settings to use with the Modify by Record command, use the Manage button on the Modify by 
Record Value dialog box to rename or delete these saved settings when needed.
To manage saved settings for the Modify by Record command:

1. Select Tools > Records > Modify by Record.
The Modify by Record Value dialog box opens.

2. Click Manage.
The Manage Saved Sets dialog box opens. Select the set to change.

Extrude Extrudes the selected objects by a specific amount; in the Options box, enter a Multiplier 
to apply to the value in the Record Field

Elevate 2D Polys Converts 2D polygons or polylines to 3D polygons, using the elevation value in the 
record attached to each polygon/polyline to determine its equivalent 3D polygon 
elevation. Normally, site model source data from external sources, such as GIS, contain 
elevation data in attached records, so this is an automated way of creating the 3D 
contours to use as the basis of a site model. If needed, specify a Multiplier value other 
than 1; the elevation value in the attached record is multiplied by the specified factor to 
determine the contour elevation.

Some GIS data is grouped. Ungroup the data, and select the option to Attach group 
records to the resultant ungrouped objects, so that each contour has individual 
data attached.

Apply to Select whether to apply the attributes to the entire drawing, or to the currently selected 
objects only

Include components of Optionally, select to apply the attributes to objects within groups and symbols, in addition 
to other objects. Groups and symbols are ignored if these checkboxes are not selected.

Parameter Description

This map of buildings and roads was modified according to the area value in 
each building’s record. The smallest areas have a yellow fill, medium-sized 
areas have a red fill, and the largest area has a brown fill.
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Click to show/hide the parameters.

3. Click OK to close the Manage Saved Sets dialog box. Click OK again to close the Modify by Record Value dialog 
box.

Global Symbol Commands
The symbol commands manipulate record data attached to symbols in libraries and perform global data changes. Use 
these commands to change the default record format values of the field(s) attached to multiple symbol definitions, 
either after importing a file from a different source or during normal project changes.
The symbol utilities support the following functions:

• “Attaching Records” on page 273
• “Detaching Records” on page 273
• “Changing One Record Format Field” on page 274
• “Changing All Record Format Fields” on page 274
• “Changing Symbol Attributes” on page 275
• “Listing Symbols and Folders” on page 275

Attaching Records
This command attaches the selected record format to all of the symbol definitions in a specified symbol folder.
To attach a record:

1. Select Tools > Records > Attach Record.
The Attach Record dialog box opens.

2. From the Symbol Folder list, select the criteria for attaching a record.
Select None to attach the record to the symbol definition(s) at the root of the symbol library (symbol definitions 
not in any folder). Select All to attach the record format to all of the symbol definition(s) in the file’s symbol 
library. Selecting a symbol folder changes all of the symbol definitions only in that folder and any subfolders.

3. From the Record Format list, select one of the record formats defined in the current file to be attached to the 
selected symbol definition(s).

4. Click OK.
Confirm the operation and the number of symbol definitions affected.
Symbol instances already on the drawing are not affected.

5. Click OK.
To quickly verify that a record has been attached to the symbol library, create a report. See “Creating Reports” on 
page 1316.

Detaching Records 
This command detaches the selected record format from all symbol definitions in a selected symbol folder.

Parameter Description

Rename Select and enter a new name for the saved set.
Delete Select to delete the set. You are prompted to confirm that you want to delete the saved set. 
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To detach a record:
1. Select Tools > Records > Detach Record.

The Detach Record dialog box opens.
2. From the Symbol Folder list, select None, All, or a symbol folder, if any.

Select None to detach the record from the symbol definition(s) at the root of the symbol library (symbol 
definitions not in any folder). Select All to detach the record format from all of the symbol definition(s) in the 
file’s symbol library. Selecting a symbol folder changes all of the symbol definitions only in that folder and any 
subfolders.

3. From the Record Format list, select one of the record formats defined in the current file to detach from the 
symbol library.

4. Click OK.
Confirm the operation and the number of symbol definitions affected.

Changing One Record Format Field
This command changes a specified field default value for a selected record format attached to symbol definitions. 
Symbols already placed on the drawing are unaffected.
To change one record format field:

1. Select Tools > Records > Change One Field.
The Change One Field dialog box opens.

2. From the Symbol Folder list, select None, All, or a symbol folder, if any.
Select None to change the record of the symbol definition(s) at the root of the symbol library (symbol definitions 
not in any folder). Select All to change the record format of all of the symbol definition(s) in the file’s symbol 
library. Selecting a symbol folder changes all of the symbol definitions only in that folder and any subfolders.

3. From the Record Format list, select the record format.
The Field Name selections depend on the record format selected.

4. Select the Field Name to change.
5. Enter the New Value.
6. Click OK.

Confirm the operation and the number of symbol definitions affected.

Changing All Record Format Fields
This command changes several or all default field values for a selected record format attached to symbol definitions. 
Symbols already placed on the drawing are unaffected.
To change several or all record format fields:

1. Select Tools > Records > Change All Fields.
The Change All Fields dialog box opens.

2. From the Symbol Folder list, select None, All, or a symbol folder, if any.
Select None to change the record of the symbol definition(s) at the root of the symbol library (symbol definitions 
not in any folder). Select All to change the record format of all of the symbol definition(s) in the file’s symbol 
library. Selecting a symbol folder changes all of the symbol definitions only in that folder and any subfolders.

3. From the Record Format list, select the record format.
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4. Click OK.
The Change Fields dialog box opens. The title bar displays the name of the record being edited.

5. Select the field name(s) to change and enter the new information.
All of the field names of the record format are listed. If the record file has more than 16 fields, click Next to 
continue viewing the remaining fields in the record.

6. After making the desired changes, click OK.
Confirm the operation and the number of symbol definition(s) affected.

Changing Symbol Attributes
This command assigns all of the objects within the selected symbol definitions to the specified class, and designates the 
objects to use any or all of the class attributes.
To change symbol attributes:

1. Select Tools > Utilities > Change Symbol Attrs.
The Change Symbol Attributes dialog box opens.

2. From the Symbol Folder list, select None, All, or a symbol folder, if any.
Select None to change the symbol attributes at the root of the symbol library (symbol definitions not in any 
folder). Select All to change the symbol attributes of all of the symbol definition(s) in the file’s symbol library. 
Selecting a symbol folder changes all of the symbol definitions only in that folder and any subfolders.

3. Select the Class to assign the symbol definition.
4. Select the class attributes to use, and indicate how to treat class attributes that are not used.

Either keep the object’s existing attributes, or use the current defaults if a class attribute is not specified.
5. Click OK.

Confirm the operation and the number of symbol definition(s) affected.

Listing Symbols and Folders
This command creates a text file list all of the symbol definitions and symbol folders within the active drawing.
To list symbols and folders:

1. Select Tools > Utilities > List Symbols.
The List Symbol dialog box opens.

2. Select either List Symbols and Folders or List Folders Only.
3. Click OK.

The Save File dialog box opens.
4. Enter a new file name or use the default name, and then click Save.

A text file is created listing the names of all the folders and, if chosen, symbols within the current file.
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Creating Shapes
Setting Parameters Before Creating Objects
Some of the creation tools can be used in conjunction with a properties or preferences dialog box. Not every tool 
includes this functionality.

To create objects and specify the properties before creation:
1. Double-click the desired tool (or press the tool’s shortcut key twice).

The tool’s properties or preferences dialog box opens.
2. Enter the desired criteria.
3. Click OK.

If Position At Next Click is selected, click the mouse to select the object’s location in the drawing.

Creating Objects from Shapes
The Create Objects from Shapes command uses an existing polyline or shape as the path for creating a variety of 
objects, as listed in the following table.

Object Product

ceiling grids Architect
guardrails Architect, Landmark
handrails Architect, Landmark
hardscape objects Landmark
landscape areas Landmark
landscape walls Landmark
lighting pipe Spotlight
linear material details Architect, Landmark
massing models Architect, Landmark
parking area Landmark
parking along path Landmark

Rectangle 
Tool
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In addition to these standard objects, the Create Objects from Shapes command supports custom path objects (custom 
path plug-in objects with a .vso extension). For details, see “Creating Custom Path Objects” on page 1789.

Walls created with the Create Objects from Shapes command use the current settings made active by the Wall 
tool (Vectorworks Architect or Landmark required), and slabs use the current Slab tool settings (Architect 
required). 
In the Vectorworks Fundamentals workspace, walls can be created from polygons using the Create Walls from 
Polygon command (see Creating Walls from a Polygon).

To create an object from a shape:
1. Draw a polyline or select an existing shape such as a line, rectangle, oval, polygon, arc/circle, rounded rectangle, 

polyline, or 3D polygon representing the path for creating the object.
2. With the item selected, select the Create Objects from Shapes command from the appropriate menu:

• Architect workspace: AEC > Create Objects from Shapes 
• Landmark workspace: Landmark > Create Objects from Shapes 
• Spotlight workspace: Modify > Create Objects from Shapes 
Alternatively, right-click (Windows) or Ctrl-click (Mac) and select Create Objects from Shapes from the context 
menu.
The Create Objects from Shapes dialog box opens.

3. Select the type of object and the creation parameters.
Click to show/hide the parameters.

piping runs Architect
plants Landmark
property lines Architect, Landmark
repetitive unit details Architect, Landmark
revision clouds Architect, Landmark, Spotlight
roadways Architect, Landmark
roadway (custom curb) Architect, Landmark
roadways (NURBS) Architect, Landmark
roadway (poly) Architect, Landmark
seating layouts Architect, Spotlight
site modifiers Architect, Landmark
slabs Architect
soft goods Spotlight
spaces Architect
stipple objects Architect, Landmark, Spotlight
walls Architect, Landmark, Spotlight

Object Product



Creating Lines |  279
4. Click OK. If Show Properties Dialog was selected, the object properties dialog box for the specified object type 
opens. Enter the appropriate parameters, and then click OK.
If you are creating guardrails or handrails and Continuous Spacing was selected in the Create Objects from 
Shapes dialog box, enter the distance between the first upright and the start of the shape in the 1st Upright 
Spacing field of the object properties dialog box. If Continuous Spacing was not selected, this value is applied to 
the first upright at the beginning of each segment of the shape. Also enter the spacing to maintain between 
uprights in the Upright Spacing field of the object properties dialog box.
The object is created from the shape and its parameters can be edited in the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Custom Path Objects

Creating Lines

Creating Single Lines
Use the Line tool to create single lines.

Parameter Description

Object Type Select the type of object to create based on the shape path; the parameters available vary 
based on the object type selected

Offset For guardrails, handrails, landscape walls, some roadway types, and walls, select whether 
to offset the object to the left, right, or centered on the shape; select Custom to enter a 
custom offset distance

Custom Offset For guardrails, handrails, landscape walls, some roadway types, and walls, specify the 
custom offset distance from the object, if any

Show Properties Dialog Select to display the Object Properties dialog box for the specified object type prior to 
creating the object; this field is not applicable for plant objects because the default place 
plant settings are used

Delete Source Shapes Select to delete the original path or shape after drawing the object
Preserve Records
(Vectorworks 
Architect or 
Landmark required)

If Delete Source Shapes is selected, select this option to apply record data from the 
source shape to the object that will be created

Continuous Spacing
(Vectorworks Architect 
or Landmark required)

Select to automatically maintain continuous spacing between uprights from one object to 
the next based on the Upright Spacing value for guardrails or handrails

Rotated and rendered for clarity
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Creating a Line from Start Point to End Point

To create a single line from its start point to its end point:

1. Click the Line tool from the Basic palette.
2. Click either the Constrained or Unconstrained mode.
3. To scale the line as you draw it, click Preferences from the Tool bar, and enter the scale factor (must be larger than 

zero). The created line will be the length of the line you draw multiplied by this number. For example, enter 2 to 
create a line twice as long as the drawn line, or enter .5 to create a line half as long as the drawn line. By default, 
the value is 1, which does not affect the line length.

4. Click Vertex mode.
5. Click at the line’s start point.
6. Click again to set the end point of the line. If you entered a scale factor other than 1, the length of the finished line 

is adjusted accordingly.

Creating a Line from the Center Point

To create a single line from its center point:

1. Click the Line tool from the Basic palette.

Mode Description

Constrained Constrains the line to be vertical, horizontal, and 30° or 45° from vertical or horizontal in 
any direction

Unconstrained Draws the line at any angle
Press and hold the Shift key to snap the line to predetermined angles

Vertex The first click is the start point of the line
Center The first click is the center point of the line; the line is drawn outward in both directions 

from the center point
Preferences Scales the length of the line by a specific amount as it is drawn

Unconstrained

Constrained

Preferences

Vertex

Center

Click 1

Click 2

With the Length Scale Factor set to 1.5, click the 
center of the filled arc to start the line, and then click 
a point on the edge of the filled arc

The finished line is 1.5 times longer 
than the radius of the filled arc
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2. Click either the Constrained or Unconstrained mode.
3. To scale the line as you draw it, click Preferences from the Tool bar, and enter the scale factor (must be larger than 

zero). The created line will be the length of the line you draw multiplied by this number. For example, enter 2 to 
create a line twice as long as the drawn line, or enter .5 to create a line half as long as the drawn line. By default, 
the value is 1, which does not affect the line length.

4. Click Center mode.
5. Click at the line’s center point.
6. Click again to set one of the line’s end points. If you entered a scale factor other than 1, the length of the finished 

line is adjusted accordingly.

Click here for a video tip on this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Double Lines
Creating a Break Line
Displaying and Reversing Object Direction
Marker Attributes

Creating Double Lines
The Double Line tool creates a wide variety of constrained and unconstrained double lines. Set the width between the 
double lines, the offset from the cursor, and whether to create components between the double lines.

To create double lines:

1. Click the Double Line tool from the Basic palette.
2. Click either the Constrained or Unconstrained mode.

Constrained lines are drawn at 30°, 45°, and 90° angles, and their complements are drawn in increments of 30°, 
and 45°.
Unconstrained lines can be drawn at any angle.
Press and hold the Shift key while drawing a line in Unconstrained mode to snap the line to predetermined angles.

3. Click the desired Offset mode to specify the offset method.

Using snapping points, locate the 
center of the circle and a point on the 
circle; click midway between them to 
start the line

Click a point on the circle 
to finish the line

Click 1

Click 2

Constrained

Preferences

Unconstrained

Top Control 
Line

Center Control Line Custom Control Line

Bottom 
Control Line

Separation Preference

http://www.youtube.com/watch?v=799CCsx3VuE
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4. Enter the distance between the double lines in the Separation field on the Tool bar.
5. Click the Preferences button to set other parameters.

Click to show/hide the parameters.
 

6. Click OK to accept the changes.
7. Click at the double line’s start point.
8. Click at the double line’s end point.

Click here for a video tip on this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Single Lines
Creating a Break Line
Applying Components Between Double Lines
Displaying and Reversing Object Direction
Marker Attributes

Applying Components Between Double Lines
To apply a component between the double lines:

1. In the Double Line Preferences dialog box, click Components.
The Components dialog box opens. Specify the component details.

Click to show/hide the parameters.

Offset Mode Description

Top Control Line The cursor draws the top line
Center Control Line Lines are equidistant from the line drawn by the cursor
Bottom Control Line The cursor draws the bottom line
Custom Control Line Specify an offset value from the line drawn by the cursor

Parameter Description

Separation Enter the distance between the double lines; same as the Separation field on the Tool bar
Control Offset For Custom Control line mode, enter the distance from the top line of the cursor. The 

distance must be less than the Separation distance between the double lines.
Options

Create Lines Creates parallel lines
Create Polygons Creates a double-line polygon with closed ends
Create Lines and 
Polygons

Creates parallel lines with a polygon between them; the polygon has a line weight of zero

Components Click to define components between the double lines

http://www.youtube.com/watch?v=qBBpr1r_VXg
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2. When the components have been defined, click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Double Lines

Creating a Break Line
The Break Line tool creates one of three types of break lines: straight, curved, or arc.

To draw a break line:

1. Click the Break Line tool from the Dims/Notes tool set.
2. Click in the drawing to place the break line and move the mouse to indicate the line length. Click again to set the 

end of the break line.
If this is the first break line placed in this session, the Break Line Object Properties dialog box opens. The settings 
displayed apply to all break lines created during this session and can be edited in the Object Info palette after 
placement.

3. Click OK.

 

4. The break line parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Preview Displays a preview of the components between the double lines, including the defined 
components; the preview is drawn from left to right, so the “top” of the preview, by default, 
indicates the left part of the double lines as they will be drawn. The arrow shows the drawing 
direction.

Overall Thickness The thickness of the double line with components is defined by the sum of the component 
thicknesses

Components Lists the components that form the structure of the double line, in order from left to right as 
displayed in the preview. To change the order of a component, click and drag within the # 
column.

The Core designation applies to walls, but not to double lines.
New Click to define the components between the double lines; see “Creating Wall Components” 

on page 513
Edit Opens the Wall Component Settings dialog box to edit the selected component’s thickness 

and attributes (you can also double-click on a component to open the Wall Component 
Settings dialog box) 

Delete Deletes the selected component; the double line thickness is adjusted accordingly

Parameter Description

Break Style Selects the style of the break line (Straight, Curved, or Arc)
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Single Lines
Creating Double Lines

Creating Rectangles
The Rectangle tool can be used to create rectangular shapes and has four modes available. The Push/Pull toggle mode 
is available in 3D views for instantly extruding the rectangle after creation. 

To create a square (1:1 rectangle), press and hold the Shift key while drawing. To create a rectangle with golden ratio 
proportions (approximately 1:1.618), press and hold Ctrl+Shift (Windows) or Cmd+Shift (Mac) while drawing.
The Ratio field in the Object Info palette displays square, golden, or the ratio of the sides of an unconstrained 
rectangle.

Creating a Rectangle by Corner to Corner

To create a rectangle by corner to corner:

1. Click the Rectangle tool from the Basic palette and click Corner to Corner from the Tool bar.
2. Click at the rectangle’s start point; this point becomes one corner of the rectangle. Move the mouse to the opposite 

corner until the desired size is previewed. 
3. Click to set a corner point on the rectangle. 

Break Width Indicates the width of the break only
Break Height Indicates the height of the break only
Break Radius Sets the radius of the break only
Number of Breaks Indicates whether a single or multiple break should be drawn

Mode Description

Corner to Corner Defines the rectangle by clicking two diagonal points
Center to Corner Defines the rectangle by the distance from the center to one corner
Midpoint to Corner Defines the rectangle by the distance from the midpoint of one side to an opposite 

corner
Three Point Rotated Creates a rectangle that is rotated by a specified angle
Push/Pull (3D views only) Instantly extrudes the rectangle after creation; available in 3D views

Parameter Description

Corner to Corner

Three Point RotatedCenter to Corner

Midpoint to Corner

Push/Pull 
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Creating a Rectangle by Center to Corner

To create a rectangle by center to corner:

1. Click the Rectangle tool from the Basic palette, and click Center to Corner from the Tool bar.
2. Click at the rectangle’s start point; this point becomes the center of the rectangle. Move the mouse to an opposite 

corner until the desired size is previewed.
3. Click to set a corner point on the rectangle.

Creating a Rectangle by Midpoint to Corner

To create a rectangle by midpoint to corner:

1. Click the Rectangle tool from the Basic palette, and click Midpoint to Corner from the Tool bar.
2. Click at the rectangle’s start point; this point becomes the center of one of the rectangle’s sides. Move the mouse to 

an opposite corner until the desired size is previewed.
Press the Alt key (Windows) or Option key (Mac) to orient the rectangle vertically.

3. Click to set a corner point on the rectangle.

Creating a Three Point Rotated Rectangle
Rotated rectangles are rectangles that are rotated at a specified angle.

To create a three point rotated rectangle:

1. Click the Rectangle tool from the Basic palette, and click Three Point Rotated from the Tool bar.
2. Click to set the start of the rectangle. Move the mouse to set the rotated angle.
3. Click to set the rotation angle. Move the mouse until the desired size is previewed.
4. Click to create the three point rotated rectangle; the bounding box position indicator in the Object Info palette 

matches the rotation of the rotated rectangle. (If multiple rotated rectangles are selected, the box position indicator 
matches the rotation of one rectangle.) 

Click 1

Click 2

Click 1

Click 2

Click 1

Click 2
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Creating Extruded Rectangles
A planar rectangle that has been created in a 3D view can be extruded immediately after creation.

To extrude a created rectangle:

1. Enable the Push/Pull toggle mode in the Tool bar for the Rectangle tool.
2. Create a rectangle using any of the modes described in the previous sections.
3. With the rectangle still selected, click, move the cursor, and then click to create the extrude. 

A planar rectangle can be extruded at any time with the Push/Pull tool. See “Direct Modeling with the Push/Pull 
Tool” on page 357.
The extrude height can be changed with the Reshape tool (see “Reshaping Extruded Objects and Solid 
Primitives” on page 1052), or modified in the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Rounded Rectangles
Push/Pull Mode of Planar Tools

Creating Rounded Rectangles
Rounded rectangles can be created with symmetrical, proportional, or unconstrained corner diameters.
Symmetrical corners have the same X and Y rounded corner diameters. Proportional corners are created as one third of 
the width and height of the rounded rectangle; for example, a rounded rectangle with a width of 6” and a height of 3” 
has a Diam X value of 2” and a Diam Y value of 1”. Rounded rectangles with both symmetrical and proportional 
corners have the same horizontal and vertical arc lengths. Unconstrained rounded rectangles can also be created using 
specific X and Y corner diameters.
Two modes are available. The Push/Pull toggle mode is available in 3D views for instantly extruding the rectangle 
after creation.

Click 1

Click 2

Click 3

Box position indicator

Click 1 Click 2
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Rounded Rectangle by Box

To create rounded rectangles by box:

1. Click the Rounded Rectangle tool from the Basic palette, and click Diagonal from the Tool bar.
2. Click the Preferences button.

The Round Rect Preferences dialog box opens.
Click to show/hide the parameters.

3. Specify the preferences and click OK.
4. Click to set the start point.
5. Click to set the end point of the rectangle.

Rounded Rectangle by Width and Height

To create rounded rectangles by width and height:

1. Click the Rounded Rectangle tool from the Basic palette, and click Rotated from the Tool bar. 

Mode Description

Diagonal Defines the dimensions of the box containing the rounded rectangle
Rotated Defines the width and height lengths to create the rounded rectangle, which can be 

rotated if desired
Push/Pull (3D views only) Instantly extrudes the rounded rectangle after creation; available in 3D views

Parameter Description

Corner Styles Select the method of rounding the rectangle corners
• Symmetrical: the corner diameters are identical in the X and Y direction
• Proportional: the corner diameters are one third of the rounded rectangle width and 

height
• Unconstrained: no constraints on the X and Y corner diameters

Corner Diameters For symmetrical or unconstrained rounded rectangle corner style, enter the corner X and 
corner Y diameter; symmetrical automatically keeps the same value for X and Y

Diagonal

Rotated

Preferences

Push/Pull

Click 1

Click 2
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2. Set the rounded rectangle preferences as described in “Rounded Rectangle by Box” on page 287.
3. Click to set the start point.
4. Click to define the rounded rectangle rotation angle and width.
5. Click to define the rounded rectangle height.

Creating Extruded Rounded Rectangles
A planar rounded rectangle that has been created in a 3D view can be extruded immediately after creation.

To extrude a created rounded rectangle:

1. Enable the Push/Pull toggle mode in the Tool bar for the Rounded Rectangle tool.
2. Create a rounded rectangle using any of the modes described in the previous sections.
3. With the rectangle still selected, click, move the cursor, and then click to create the extrude. 

A planar rectangle can be extruded at any time with the Push/Pull tool. See “Direct Modeling with the Push/Pull 
Tool” on page 357.
The extrude height can be changed with the Reshape tool (see “Reshaping Extruded Objects and Solid 
Primitives” on page 1052), or modified in the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Rectangles
Push/Pull Mode of Planar Tools

Creating Circles
The Circle tool has six modes and the Push/Pull toggle mode. 

Mode Description

Radius Defines the circle by its radius
Diameter Defines the circle by its diameter

Click 1

Click 2

Click 3

Click 1 Click 2

Radius

Diameter

Circle by Three Points

Tangent and Center

Point and Center

Circle from Three Lines

Push/Pull 
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To create a NURBS curve, draw a circle and then select Modify > Convert > Convert to NURBS.

Circle by Radius

To create a circle by radius:

1. Click the Circle tool from the Basic palette, and select the Radius mode.
2. Click to set the center of the circle.
3. Move the mouse to the desired radius and click to set the radius of the circle.

Circle by Diameter

To create a circle by diameter:

1. Click the Circle tool from the Basic palette, and select the Diameter mode.
2. Click to set the first point on the circle diameter.
3. Move the mouse to the desired diameter and click to set the diameter of the circle.

 

Circle by Three Points

To create a circle by three points:

1. Click the Circle tool from the Basic palette, and select the Circle by Three Points mode.
2. Click to set the first point on the circle diameter.
3. Move the mouse and click to set the second point on the circle and click again to set the third point on the circle.

Circle by Three Points Defines the circle by its circumference
Circle from Three Lines Defines the circle by making it tangent to two or three selected lines
Point and Center Defines the circle by a point on its circumference and then its center
Tangent and Center Defines the circle by defining a tangent to the circle and then its center
Push/Pull (3D views only) Instantly extrudes the circle after creation; available in 3D views

Mode Description

Click 1

Click 2

Click 1

Click 2
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Circle from Three Lines

To create a circle tangent to three lines:

1. Click the Circle tool from the Basic palette, and select the Circle from Three Lines mode.
2. Click to select the three lines or linear segments to which the circle will be tangent. Each line is highlighted as it is 

selected. The lines (or their extensions) must intersect in at least two places.
3. When the third line is selected, a preview of a tangent circle displays where the cursor is currently located. You 

can create circles tangent to two or three lines. In places where only two lines intersect, the size of the circle is 
controlled by the cursor location. Move the cursor until the desired tangent circle displays, and then click to set the 
circle.

 

Circle by Point and Center

To create a circle by point and center:

1. Click the Circle tool from the Basic palette, and select the Point and Center mode.
2. Click to set the first point on the circumference of the circle.
3. Move the mouse to the center of the circle and click to set the radius of the circle.

 

Click 1

Click 2
Click 3

A preview of the circle tangent to the 
selected lines (or their extensions) 
displays beneath the hand cursor

Move the cursor to preview other tangent circles Click to place the tangent circle

Click 1

Click 3

Click 2

Click 1
Click 2
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Circle by Tangent and Center

To create a circle by tangent and center:

1. Click the Circle tool from the Basic palette, and select the Tangent and Center mode.
2. Click to set the first point on the line tangent to the circle.
3. Click to set the second point on the line tangent to the circle, defining the tangent line.
4. Move the mouse to define the radius perpendicular to the tangent. Click to set the radius of the circle. It is not 

necessary to click on the center point; click anywhere along an axis parallel to the tangent. This allows you to set 
the radius based on other geometry, if desired.

 

Creating Extruded Circles
A planar circle that has been created in a 3D view can be extruded immediately after creation, creating a cylinder.

To extrude a created circle:

1. Enable the Push/Pull toggle mode in the Tool bar for the Circle tool.
2. Create a circle using any of the modes in the Tool bar.
3. With the circle still selected, click, move the cursor, and then click to create the extrude. 

A circle can be extruded at any time with the Push/Pull tool. See “Direct Modeling with the Push/Pull Tool” on 
page 357.
Cylinder height and radius can be changed with the Reshape tool (see “Reshaping Extruded Objects and Solid 
Primitives” on page 1052), the radius can be modified in the Object Info palette, and the resolution can be adjusted 
through the 3D Conversion Resolution setting (see “3D Preferences” on page 54).
Click here for a video tip on this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Circles
Push/Pull Mode of Planar Tools

Creating Ovals
The Oval tool has three modes available. The Push/Pull toggle mode is available in 3D views for instantly extruding 
the oval after creation.

Click 1 Click 2

Click 3

Click 1 Click 2

http://www.youtube.com/watch?v=xKIe44N2uWE
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Oval by Box

To create an oval by box:

1. Click the Oval tool from the Basic palette and select the Box mode.
2. Click to set the first point of the box containing the oval and then click again to set.

To create a true circle, press the Shift key while creating the oval.

Oval by Height and Width

To create an oval by width and height:

1. Click the Oval tool from the Basic palette and select the Height and Width mode.
2. Click to set the first point of the oval height, and then move the mouse to define the height.
3. Move the mouse, and then click to define the oval width.

Oval by Center

To create an oval by center:

1. Click the Oval tool from the Basic palette and select the Center mode.

Mode Description

Box Defines the dimensions of the box containing the oval
Height and Width Defines the height and width lengths to create the oval
Center Defines the center, then the major and minor radii to create the oval
Push/Pull (3D views only) Instantly extrudes the oval after creation; available in 3D views

Box

Height and Width

Push/Pull

Center

Click 1

Click 2

Click 1

Click 2

Click 3
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2. Click to set the center point of the oval, and then move the mouse and click to define one of the radii.
3. Move the mouse and then click to define the other radius.

Creating Extruded Ovals
A planar oval that has been created in a 3D view can be extruded immediately after creation.

To extrude a created oval:

1. Enable the Push/Pull toggle mode in the Tool bar for the Oval tool.
2. Create an oval using any of the modes in the Tool bar.
3. With the oval still selected, click, move the cursor, and then click to create the extrude. 

An oval can be extruded at any time with the Push/Pull tool. See “Direct Modeling with the Push/Pull Tool” on 
page 357.
The extrude height can be changed with the Reshape tool (see “Reshaping Extruded Objects and Solid 
Primitives” on page 1052), or modified in the Object Info palette.

Creating Arcs
The Arc tool, which creates circular arcs of any angle, has seven modes. Create an arc by radius, three points, tangent, 
two points and center, two points and radius, two end points and another point on the arc, or by arc length and 
optionally, chord length. The Push/Pull toggle mode is available in 3D views for instantly extruding the arc after 
creation.

Click here for a video tip on this topic (Internet access required).

Mode Description

Radius Defines the arc by its center
Three Points Defines the arc by clicking three points
Tangent to Line Defines the arc by defining a tangent to a line
Center Defines an arc by clicking two points and a center

Click 1
Click 2

Click 3

Click 1 Click 2

Radius

Specified RadiusTangent to Line

CenterThree Points

Arc Length

Point on Arc

Push/Pull 

http://www.youtube.com/watch?v=KhQNofR6jrE
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Either move the mouse to draw the arc or use the Data bar to enter an angle. Degrees start on the positive X axis (the 
“East” direction), and increase going counter-clockwise. (“East” is 0 degrees; “North” is 90 degrees; and “West” is 180 
degrees.) To draw a quarter-circle wall beginning at 0 degrees and ending at the 6 o’clock position, enter -90 (minus 90) 
degrees. Enter 270 to draw an arc three-quarters of a circle around.

To create a NURBS curve, draw an arc and then select Modify > Convert > Convert to NURBS.
To edit an arc, click the middle handle with the Selection tool and drag to change the arc radius. Press the Option key 
(Mac) or Alt key (Windows) to change the arc’s size.

Arc by Radius

To create an arc by its radius:

1. Click the Arc tool from the Basic palette, and select the Radius mode.
2. Click to set the center of the arc.
3. Click the start point of the arc. Move the mouse until the desired arc orientation and size is previewed.
4. Click to set the end point of the arc.

Arc by Three Points

To create an arc by three points:

1. Click the Arc tool from the Basic palette, and select the Three Points mode.
2. Click to set the start point of the arc.
3. Click to set the point for the arc to pass through. Move the mouse until the desired arc orientation and size is 

previewed.
4. Click to set the end point of the arc.

 

Specified Radius Defines an arc by two points and a specified radius
Point on Arc Defines an arc by two end points and another point on the arc
Arc Length Defines an arc by the arc length and specified chord length
Push/Pull (3D views only) Instantly extrudes the arc after creation; available in 3D views

Mode Description

Click 1

Click 2

Click 3

Click 2

Click 1

Click 3
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Arc Tangent to Line

To create an arc by tangent:

1. Click the Arc tool from the Basic palette, and select the Tangent to Line mode.
2. Click to set the start point of the arc.
3. Click to define the line to which the arc will be tangent. Move the mouse until the desired arc orientation and size 

is previewed.
4. Click to set the end point of the arc.

Use tangent snapping to assist with drawing the arc tangent to geometry; see “Snap to Tangent (2D Only)” on 
page 142.

Arc by Center

To create an arc by two points and center:

1. Click the Arc tool from the Basic palette, and select the Center mode.
2. Click to set the start point of the arc.
3. Click to set the end point of the arc.

As the cursor moves, the center of the arc is manipulated.
4. Click outside the arc to set the center.

Arc by Specified Radius

To create an arc by two points and a specified radius:

1. Click the Arc tool from the Basic palette, and select the Specified Radius mode.

Existing line to which 
arc will be tangent

Click 2 Click 1

Click 3

Tangent

Click 1

Click 2
Click 3

Completed arc
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2. Click to set the start point of the arc.
3. Click to set the end point of the arc.

The Arc Radius dialog box opens. Enter the length of the radius.
4. Click OK.

The arc is created.

Arc by Point on Arc

To create an arc by two end points and another point on the arc:

1. Click the Arc tool from the Basic palette, and select the Point on Arc mode.
2. Click to set the start point of the arc.
3. Click to set the end point of the arc.
4. Move the mouse until the desired arc shape and size is previewed, and then click to set the arc. To constrain the 

angle of the line between the arc endpoints, press the Shift key when drawing the arc.

 

Arc by Arc Length

To create an arc by arc length and chord length:

1. Click the Arc tool from the Basic palette, and select the Arc Length mode.
2. Click to set the start point of the arc.
3. Click to set the end point of the arc.

When the Shift key is pressed, the angle of the line between the arc endpoints (1st and 2nd clicks) is 
constrained, and the chord defining the arc height is perpendicular to the center of that line

Without the Shift key, the angle of the line between the arc endpoints (1st and 2nd clicks) is unconstrained, and the 
chord defining the arc height is an unconstrained line drawn from the second endpoint

Click 1

Click 1 Click 2

Click 3

Click 2

Click 3
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The Arc Length dialog box opens.
Click to show/hide the parameters.

4. Enter the desired parameters, and click OK to create the arc.

Creating Extruded Arcs
A planar arc that has been created in a 3D view can be extruded immediately after creation.

To extrude a created arc:

1. Enable the Push/Pull toggle mode in the Tool bar for the Arc or Quarter Arc tool.
2. Create an arc using any of the modes in the Tool bar.
3. With the arc still selected, click, move the cursor, and then click to create the extrude. 

An arc can be extruded at any time with the Push/Pull tool. See “Direct Modeling with the Push/Pull Tool” on 
page 357.
The extrude height and radius can be changed with the Reshape tool (see “Reshaping Extruded Objects and Solid 
Primitives” on page 1052), the radius can be modified in the Object Info palette, and the resolution can be adjusted 
through the 3D Conversion Resolution setting (see “3D Preferences” on page 54).

Creating Quarter Arcs
The Quarter Arc tool creates circular 90° arcs or 90° elliptical arc polyline objects. The Push/Pull toggle mode is 
available in 3D views for instantly extruding the arc after creation.

Quarter arcs are listed as polylines in the Object Info palette.

Parameter Description

Arc Length The drawn arc length is displayed, and can be changed; this allows you to create several 
arcs with the same chord length and varying arc lengths

Specify Chord Length Select to manually specify the chord length, changing the arc endpoint
Chord Length The chord length is the distance between the two end points of the arc; the arc length must 

be greater than the chord length

Completed arcClick 1 Click 2

Click 1 Click 2
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To create quarter arcs:

1. Click the Quarter Arc tool from the Basic palette.
2. Click at the start point for the arc.
3. Move the mouse until the desired arc shape and size is previewed, and then click to set the arc. To constrain the 

angle of the quarter arc to 45 degrees, press the Shift key when drawing the arc.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Arcs
Creating Extruded Arcs
Marker Attributes

Creating Polylines

Polyline Tool
The Polyline tool creates open and closed polylines—objects made of a series of connected arcs, curves, or lines.
While drawing a polyline, set the type of control point for each segment either by clicking on the desired mode while 
drawing or by using the keyboard shortcuts (see “Creating or Editing Workspaces” on page 1835) to select the desired 
mode. A polyline can have different combinations of vertices. Use a polyline to create planar shapes with internal 
holes.
The corners of the polyline can be “smoothed” with the Poly Smoothing commands (see “Smoothing Objects” on 
page 1019). Markers can be added with the Attributes palette (see “Marker Attributes” on page 1102). The Push/Pull 
toggle mode is available in 3D views for instantly extruding the polyline after creation.

Mode Description

Corner Vertex Creates polyline segments with straight lines and angled vertices at the control points. The 
type of vertex created is a corner vertex.

Bézier Vertex Creates polyline segments with curves pulled toward, but not touching the control points. The 
type of vertex created is a Bézier vertex.

Cubic Vertex Creates polyline segments with curves that pass through the control points. The type of vertex 
created is a cubic vertex.

Tangent Arc Creates polyline arc segments that are tangent to the previous segment (use tangent snapping 
to assist with drawing the tangent polyline; see “Snap to Tangent (2D Only)” on page 142). 
The type of vertex created is a radius vertex.

Point on Arc Creates polyline arc segments that are drawn by clicking three points: the start point, a point 
the arc passes through, and the end point; useful for tracing existing arcs. The type of vertex 
created is a radius vertex.

Click 1

Click 2

Corner Vertex

Bézier Vertex

Cubic Vertex

Arc Vertex Fillet

Preferences

Tangent Arc

Point on Arc Push/Pull
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To create a polyline:

1. Click the Polyline tool from the Basic palette.
2. Click to set the polyline’s start point. In Point on Arc mode, click again to set a point that the arc will pass through.
3. Click to set the end of the segment and the beginning of the next.

In Corner Vertex mode, press and hold instead of clicking to create a Bézier vertex instead of a Corner vertex.
4. Continue drawing segments in this manner until the polyline is complete.
5. Click the mouse at the start point to complete a closed polyline object (end point of the last segment is at the exact 

start point of the first segment), or double-click the mouse to complete an open polyline object (end point of the 
last segment is at a different location than the start point of the first segment).
Alternatively, after completing all but the final click, press the keyboard shortcut (K by default) to automatically 
close the polyline. The shortcut also closes path-based objects, such as hardscapes and spaces, that function 
similarly to the Polyline tool. See “Modifying Snapping and Mode Shortcuts” on page 1842 to change the 
shortcut.
When drawing a polyline or path-based object, move the mouse in the direction of the next-to-last click and press 
the shortcut key before clicking; the software extrapolates the correct alignment and position for a 90° corner and 
places the final two clicks to complete the shape. 

The resulting polyline object, whether open or closed, is a filled object. If desired, remove the fill through the 
Attributes palette to see objects behind the polyline.

Arc Vertex Fillet Creates polyline segments with curves that look like a fillet placed at the control points; click 
Preferences to set the radius of the fillet. The type of vertex created is an arc vertex.

Push/Pull (3D 
views only)

Instantly extrudes the polyline after creation; available in 3D views

Mode Description

While drawing a polyline, press
the U key to switch the mode used

to create the polyline

Closed polyline created using Corner Vertex and 
Tangent Arc modes

Tracing of existing arcs created using 
Point on Arc mode
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Edit polylines, changing their shape or their vertices, with the Reshape tool or the Object Info palette. The corners of 
the polyline can be “smoothed” with the Poly Smoothing commands (see “Smoothing Objects” on page 1019). 
Markers can be added with the Attributes palette (see “Marker Attributes” on page 1102).

A closed polyline, when extruded with the Model > Extrude command, accepts a fill or texture and displays as a 
solid object. An open polyline, when extruded, does not render as a solid. To close a polyline before extruding it, 
select the polyline. In the Object Info palette, select the Closed option to close the polyline.

Creating Extruded Polylines
A planar polyline that has been created in a 3D view can be extruded immediately after creation.

To extrude a created polyline:

1. Enable the Push/Pull toggle mode in the Tool bar for the Polyline tool.
2. Create a polyline using any of the modes in the Tool bar.
3. With the polyline still selected, click, move the cursor, and then click to create the extrude. 

A polyline can be extruded at any time with the Push/Pull tool. See “Direct Modeling with the Push/Pull Tool” on 
page 357.
The extrude height can be changed with the Reshape tool, or modified in the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Objects
Editing Vertex-Based Objects
Reshaping Extruded Objects and Solid Primitives
Closing and Opening Polygons and Polylines
Smoothing Objects
Push/Pull Mode of Planar Tools
Drawing Freehand Polylines
Simplifying Polygons and Polylines
Displaying and Reversing Object Direction

Drawing Freehand Polylines
Use the Freehand tool to draw a freehand polyline in a manner similar to drawing with a pen. Once the object is 
drawn, it can be reshaped.

Mode Description

Freehand Edit Reshapes the singularly selected polyline, polygon, rectangle, circle, or arc; for more 
information

Click 1 Click 2

Freehand Edit Preferences
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To draw a freehand polyline:

1. Click the Freehand tool from the Basic palette.
2. Click Preferences.

The Freehand Tool Preferences dialog box opens. Select the smoothing level when drawing a curve.
3. Click OK.
4. Click in the drawing to set the polyline start point. Move the mouse to create the desired freehand polyline shape.
5. Click again when the object is complete.

The number and placement of polyline vertices is determined by the object shape and specified degree of curve 
smoothing. For example, an object consisting of a series of arcs and curves created with a low degree of curve 
smoothing contains more vertices than a series of lines created with a high degree of curve smoothing.
Markers can be added with the Attributes palette (see “Marker Attributes” on page 1102).
By default, the Freehand tool applies a fill of “None.” Change the fill type before sweeping a freehand polyline, if 
rendering of the sweep volume is desired.

Reshaping Objects with the Freehand Tool
A polyline, polygon, rectangle, circle, or arc can be reshaped using the Freehand Edit mode of the Freehand tool. The 
direction of the curve drawn determines the new object shape. An edited object is converted to a polyline after editing 
is complete.

To reshape objects using the Freehand tool:

1. Select a valid object.
2. Click the Freehand tool from the Basic palette.
3. Click Freehand Edit mode from the Tool bar.
4. Click to draw the new curve, editing the valid object using the following curve direction guidelines:

Preferences Sets the smoothing level when drawing a curve. Increasing the degree of smoothing decreases 
the vertices, and therefore it is easier to reshape the curve. Decreasing the degree of smoothing 
increases the vertices which produces a more accurate representation of the curve. Select Off 
to draw the curve without using the smoothing feature.

Action Guidelines

Change existing curve

Mode Description

New Curve Direction Appended Curve

Original Curve Direction Discarded Curve

Retained Curve

New Curve
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5. Click again to finish drawing the freehand polyline edit. The valid object is edited and converted to a polyline.

Connect two points 
with new curve

Create closure with 
new curve

Add a new curve to an 
existing curve

Extend existing curve

Retain partial curve

Action Guidelines

New Curve Direction Appended Curve

Original Curve Direction Discarded Curve

Retained Curve

New Curve

New Curve Direction Appended Curve

Original Curve Direction Discarded Curve

Retained Curve

New Curve

New Curve Appended Curve

Original Curve Retained Curve New Curve

New Curve Direction Appended Curve

Original Curve Direction Discarded Curve

Retained Curve

New Curve

New Curve Direction Appended Curve

Original Curve Direction Discarded Curve

Retained Curve

New Curve
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~~~~~~~~~~~~~~~~~~~~~~~~~
Polyline Tool
Reshaping Objects
Closing and Opening Polygons and Polylines
Displaying and Reversing Object Direction

Creating 2D Polygons
There are several ways to create 2D polygons. Single-line polygons, double-line polygons, and regular polygons can be 
created; a polygon always has square vertices and is composed of a series of straight line segments. A polygon that 
represents a curve will require more vertices (and more complexity) than a polyline.
Polygons can be created automatically from existing geometry, which is especially useful for illustrating the elements 
of a hidden-line rendered viewport.
~~~~~~~~~~~~~~~~~~~~~~~~~
2D Polygon Tool
Double-Line Polygon Tool
Regular (Equal-sided) Polygon
Creating Extruded Polygons
Marker Attributes
Closing and Opening Polygons and Polylines
Simplifying Polygons and Polylines
Displaying and Reversing Object Direction

2D Polygon Tool
The 2D Polygon tool creates open and closed polygons with single lines. Polygons can have as few as three vertices or 
as many as 32,767 vertices. The 2D Polygon tool can also automatically create polygons by filling or outlining existing 
geometry, to easily annotate a drawing graphically by outlining, filling, or texturing (with an image or gradient fill) the 
new polygons.
Three modes are available. The Push/Pull toggle mode is available in 3D views for instantly extruding the polygon 
after creation.

Creating Single-line 2D Polygons

To create a single-line 2D polygon:

1. Click the 2D Polygon tool from the Basic palette, and select Vertex from the Tool bar.

Mode Description

Vertex Creates a polygon by clicking to set each vertex
Inner Boundary Creates a polygon out of existing geometry by clicking within the boundary of an object
Outer Boundary Creates a polygon out of the outer boundary of existing geometry by defining geometry 

with a lasso marquee
Push/Pull (3D views only) Instantly extrudes the polygon after creation; available in 3D views

Vertex

Outer BoundaryInner Boundary

Push/Pull 
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2. Click to set the polygon’s start point (first vertex).
3. Click at each vertex.
4. Double-click at the final vertex to end an open polygon, or click at the starting vertex (a point cue displays) to end 

a closed polygon (the first and last vertex are automatically joined).

Alternatively, after completing all but the final click, press the keyboard shortcut (K by default) to automatically 
close the polygon. The shortcut also closes path-based objects that function similarly to the Polygon tool. See 
“Modifying Snapping and Mode Shortcuts” on page 1842 to change the shortcut.
When drawing a 2D polygon or path-based object, move the mouse in the direction of the next-to-last click and 
press the shortcut key before clicking; the software extrapolates the correct alignment and position for a 90° 
corner and places the final two clicks to complete the shape.

Creating a Polygon from an Inner Boundary
The 2D Polygon tool can create a new polygon based on the inner boundary of existing geometry. Existing geometry 
refers to visible objects and solids in the active layer (within the active working plane) or the viewport cache of a 
hidden-line rendered viewport in Edit Annotation mode. The stacking order of the 2D objects does not apply; objects 
that are overlapped by other objects can still have their boundaries considered. If the object is a polyline (open or 
closed), a polygon with holes, or is curved, a polyline is created instead of a polygon.

Polygons cannot be created from symbols. Convert the symbol to a group, and then ungroup.

To create a 2D polygon from the inner boundary of existing geometry:

1. Click the 2D Polygon tool from the Basic palette, and select Inner Boundary from the Tool bar.
If desired, set the attributes in the Attributes palette (fill style, pen style, line and line endpoint style). The 
attributes of the polygon can also be specified after creation.

2. Click over one or more objects to create a polygon based on the inner boundary of the 2D objects and/or faces of 
solids in the active plane. Different methods of using the 2D Polygon tool will achieve different results.

Modification Method

Create a polygon Click to place the polygon
Add to a polygon as it is created Press the Shift key while clicking over existing adjacent geometry to add to the 

polygon
Apply the attributes of an existing 
object to the new polygon

Select the existing object and press the Option key (Mac) or the Alt key 
(Windows) while clicking to create the new polygon(s)

Click 1

5

Click 2 4

3

Click 6
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To speed up the polygon fill for complex images, zoom in on the area first.
The polygon overlays the existing geometry, and the original objects are unchanged
Another way to create planar objects from faces is with the Extract Surface mode of the Extract tool. See “Extracting 
Geometry” on page 345.

Creating a Polygon from an Outer Boundary
The 2D Polygon tool can create a polygon based on the outer boundary of existing geometry. Existing geometry refers 
to visible objects in the active layer (within the active working plane) or the viewport cache of a hidden-line rendered 
viewport in Edit Annotation mode. The stacking order of 2D objects does not apply; objects that are overlapped by 
other objects can still have their boundaries considered. If the object is a polyline (open or closed), a polygon with 
holes, or is curved, a polyline is created instead of a polygon.

Polygons cannot be created from symbols. Convert the symbol to a group, and then ungroup.

To create a 2D polygon from the outer boundary of existing geometry:

1. Click the 2D Polygon tool from the Basic palette, and select Outer Boundary from the Tool bar.
If desired, set the attributes in the Attributes palette (fill style, pen style, line and line endpoint style). The 
attributes of the polygon can also be specified after creation.

2. Click in the drawing and drag to create the lasso marquee. A polygon is created based on the outer boundary of 
any 2D objects on the active plane completely enclosed within the marquee. Alternatively, press the Option key 
(Mac) or Alt key (Windows) while creating the marquee, and the polygon is based on the outer boundary of any 
co-planar 2D objects that are encountered by the marquee.

Create polygons from overlapping objects

Shift-click on a series of objects to create a single polygon
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Creating Boundary Polygons in a Hidden Line Rendered Viewport
The creation of polygons based on the inner and outer boundaries of existing geometry is very useful for graphically 
annotating the elements of a sheet layer viewport that is rendered with hidden line rendering. (Sheet layer viewports are 
described in “Creating Sheet Layer Viewports” on page 1616.)

To create a 2D polygon from the inner/outer boundary of existing geometry in a viewport:

1. Create a sheet layer viewport from a design layer as described in “Creating a Sheet Layer Viewport from a Design 
Layer” on page 1616.

2. For the Rendering mode of the viewport, select Hidden Line. Update the viewport rendering by clicking Update 
from the Object Info palette.

3. Edit the viewport in annotation mode by selecting Modify > Edit Viewport.
The Edit Viewport dialog box opens. Select Annotations and Display Viewport Cache.

4. Click OK to enter viewport annotation mode.
5. Click the 2D Polygon tool from the Basic palette, and select Inner Boundary or Outer Boundary from the Tool 

bar.
If desired, set the attributes in the Attributes palette to the desired fill settings (Fill Style, Pen Style, Line and Line 
Endpoint Style). The attributes of the polygon can also be specified after creation.
Apply an image fill to the polygon to simulate a texture (see “Using Image Fills” on page 1119).

6. Because the viewport is rendered with hidden line and the viewport cache is used for annotations, any of the 
objects in the drawing can be used as the basis for new polygons. If in Inner Boundary mode, click the paint 
bucket cursor on the desired drawing objects. If in Outer Boundary mode, create a lasso marquee to include the 
desired objects. A 2D polygon is created based on the inner or outer boundary of the geometry.

The 2D Polygon tool works on 2D objects in the design layer. It does not apply to 2D objects or annotations that 
have been added to the sheet layer.

7. Click Exit Viewport Annotation at the top right corner of the drawing window to return to the sheet layer.
An alert dialog box may ask if keeping the viewport cache is necessary. The viewport cache can be removed, if 
desired, as it is no longer necessary for creating the polygons.
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Creating Extruded Polygons
A planar polygon that has been created in a 3D view can be extruded immediately after creation.

To extrude a created polygon:

1. Enable the Push/Pull toggle mode in the Tool bar for the Polygon or Regular Polygon tool.
2. Create a polygon using any of the modes in the Tool bar.
3. With the polygon still selected, click, move the cursor, and then click to create the extrude. 

A polygon can be extruded at any time with the Push/Pull tool. See “Direct Modeling with the Push/Pull Tool” on 
page 357.
The extrude height can be changed with the Reshape tool (see “Reshaping Extruded Objects and Solid 
Primitives” on page 1052), or modified in the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating 2D Polygons
Regular (Equal-sided) Polygon
Push/Pull Mode of Planar Tools
Closing and Opening Polygons and Polylines
Simplifying Polygons and Polylines
Extracting Geometry

Double-Line Polygon Tool
Use the Double-Line Polygon tool to create a wide variety of open or closed polygons that have two parallel lines, a 
double-lined polygon with a width, or two parallel lines with a polygon fill. Double-line polygons can have as many as 
32,767 vertices.

To create a double-line polygon:

1. Click the Double-Line Polygon tool from the Basic palette.

Mode Description

Top Control Line The cursor creates the right line
Center Control Line Creates lines equidistant from the cursor
Bottom Control Line The cursor creates the left line
Custom Control Line Specify an offset value

Click 1 Click 2

Top Control Line Preferences

Center Control Line Custom Control Line

Bottom Control Line

Separation Preference
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2. Select the offset method.
3. Enter the distance between the double lines in the Separation field on the Tool bar.
4. Click the Preferences button to specify any other parameters.

Click to show/hide the parameters.

5. Click OK.
6. Click to set the polygon’s start point (first vertex).
7. Click at each vertex.
8. Double-click to mark the polygon’s end point (final vertex).

~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Components Between Double Lines
2D Polygon Tool
Creating Double Lines
Regular (Equal-sided) Polygon
Displaying and Reversing Object Direction

Regular (Equal-sided) Polygon
Use the Regular Polygon tool to create single-line closed polygons in which all sides of the polygon are the same 
length.The Push/Pull toggle mode is available in 3D views for instantly extruding the polygon after creation.

 

Parameter Description

Separation Enter the distance between the double lines; same as the Separation field on the 
Tool bar

Control Offset For the Custom Control Line mode, enter the distance from the top/right line of the 
cursor

Options
Create Lines Creates a series of lines
Create Polygons Creates a double-line polygon
Create Lines and 
Polygons

Creates parallel lines with a polygon between them; the polygon has a line weight 
of 0

Components Click to define components between the double lines

Click 1

5
Click 2

43

6

Inscribed

Number of Sides Preference

Circumscribed 

Edge

Push/Pull
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Press and hold the Option (Mac) or Ctrl (Windows) key while drawing to toggle between circumscribed and inscribed 
modes.

Regular Polygon by Inscription

To create a regular polygon by inscription:

1. Click the Regular Polygon tool from the Basic palette and click Inscribed from the Tool bar.
2. Enter the Number of Sides for the polygon (a number from 3 to 4000).
3. Click to set the center of the polygon.
4. Click to set the corner radius.

Regular Polygon by Circumscription

To create a regular polygon by circumscription:

1. Click the Regular Polygon tool from the Basic palette and click Circumscribed from the Tool bar.
2. Enter the Number of Sides for the polygon (a number from 3 to 4000).
3. Click to set the center of the polygon.
4. Click to set the edge radius.

Regular Polygon by Edge

To create a regular polygon by edge:

1. Click the Regular Polygon tool from the Basic palette and click Edge from the Tool bar.
2. Enter the Number of Sides for the polygon (a number from 3 to 4000).

Mode Description

Inscribed Creates a polygon by drawing its radius to a corner 
Circumscribed Creates a polygon by drawing a radius to the mid-point of a side
Edge Creates a polygon by drawing one of its sides
Push/Pull (3D views only) After the polygon is created, click the selected polygon and drag to extrude it

Click 1

Click 2

Click 1

Click 2
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3. Click to set a corner of the polygon.
4. Click to set an adjacent corner of the polygon and define an edge.

~~~~~~~~~~~~~~~~~~~~~~~~~
2D Polygon Tool
Double-Line Polygon Tool
Creating Extruded Polygons
Push/Pull Mode of Planar Tools
Displaying and Reversing Object Direction

Creating 3D Polygons
The 3D Polygon tool creates polygons that have a location in 3D space, but no height. The polygon can be created 
through any 3D point, not necessarily constrained to the working plane.

To create a planar 3D polygon:

1. Click the 3D Polygon tool from the 3D Modeling tool set.
2. Click to set the polygon’s start point (first vertex).
3. Click at each vertex.
4. Double-click at the final vertex to end an open polygon; click at the starting vertex (a point cue displays) to end a 

closed polygon (the first and last vertex are automatically joined).

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Extruded Polygons
Closing and Opening Polygons and Polylines
Displaying and Reversing Object Direction

Closing and Opening Polygons and Polylines
When created, 2D and 3D polygon and polyline objects can be either open or closed. For polylines, you can also use 
the Hide Next Edge button on the Object Info palette, or use the Hide or Show Edges mode of the Reshape tool to 
hide specific edges of the object after creation, which opens a closed object.
Use the Closed setting on the Object Info palette to change the current state of the object.

Click 1 Click 2

Click 1

Click 2 43

Click 8 Click 9

7 6
5

http://www.youtube.com/watch?v=YbRW7-f-sJQ
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The Closed setting is available for objects created with the following tools:

If a polygon or polyline is open, select the Closed setting to close it; any edges that were hidden are also closed.

If a polygon or polyline is closed, deselect the Closed setting to open it. The last segment of the object to be drawn is 
removed (for polygons) or hidden (for polylines).
For polylines, the last segment of the object must be between vertices created with Corner Vertex, Tangent Arc, or 
Point on Arc modes; otherwise, the polyline cannot be opened by deselecting the Closed setting. To open a segment 
other than the last segment, use the Hide or Show Edges mode of the Reshape tool.

• Freehand • Double-Line Polygon

• Polyline • Regular Polygon

• 2D Polygon • 3D Polygon

• Triangle

Click here to close the open
polyline object

When the Closed setting is selected, the open and hidden edges of the polygon are closed

Hidden edge

Open edge
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~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Objects

Creating Triangles 
The Triangle tool has three modes. The steps for drawing the triangle are the same for each mode; the only difference 
is the fields that display in the dialog box that opens.

 

To create a triangle:

1. Click the Triangle tool from the Basic palette and select the desired mode.
2. Click to set the first and second points of the first side.

The Triangle Settings dialog box opens; the fields available depend on the mode that was selected.
3. The length of the first side of the triangle displays. Enter the remaining fields as required for the selected mode 

and click OK. The following restrictions apply.

4. Two possible triangles display; click the triangle to keep.

Mode Restriction

Three Sides The sum of the lengths of any two sides of the triangle must be greater than the 
remaining side

Two Sides and Included Angle The angle must be less than 180 degrees
Two Angles and Common Side The sum of the two angles must be less than 180 degrees

When the Closed setting is deselected, the last 
segment to be drawn is opened

To hide a different segment, use the Reshape tool in 
Hide or Show Edges mode

Three Sides Two Angles and Common Side

Two Sides and Included Angle

Click 2

Click two points to define the 
first side of the triangle

After you enter the required side lengths and 
angles, two possible triangles display; click 
the triangle to keep

Click 1
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Click here for a video tip on this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Closing and Opening Polygons and Polylines

Creating Spirals
The Spiral tool draws an Archimedes spiral. The number of turns, distance per turn, start radius and thickness can be 
specified, as well as the number of points used to define the curve. Use the alignment modes on the Tool bar to 
temporarily override the insertion point. These modes change the alignment of the insertion point along the X axis of 
the bounding box surrounding the spiral.

For information on using the Offset Insertion and Wall Insertion modes, see “Offset Symbol Insertion Mode” on 
page 245 and “Wall Insertion Mode” on page 246.

To draw a spiral:

1. Click the Spiral tool from the Basic palette.
2. Select the insertion type and alignment from the Tool bar.
3. Click to define the center of the spiral.

If this is the first time a spiral is placed in this session, the Spiral Properties dialog box opens. These parameters 
apply to subsequently created spirals; they can be changed later by accessing them from the Object Info palette.

4. Specify the spiral properties.

Click to show/hide the parameters.

Spiral Alignment Mode Description

Align Object Left Moves the insertion point to the left edge of the spiral’s bounding box, along the 
original X axis

Align Object Center Moves the insertion point to the center of the spiral’s bounding box, along the original 
X axis

Align Object Right Moves the insertion point to the right edge of the spiral’s bounding box, along the 
original X axis

Align Object Origin Leaves the insertion point at the actual or original position

Spiral Alignment Modes

Standard Insertion

Offset Insertion

Wall Insertion

Preferences

Distance per turn

Start radius

Thickness

http://www.youtube.com/watch?v=TqMsDKnq-D0&list=UUN7uzhu-ljLJOe6a0J-fBcQ
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5. Click OK.
A spiral with the specified parameters is placed on the drawing.
To create a 3D spiral, see “Creating Helix-Spirals” on page 355.
Click here for a video tip on this topic (Internet access required).

Creating Loci
A locus is a reference point that is used to draw and measure objects. Loci do not print. 

Turn on Snap to Objects from the Snapping palette to snap to loci (see “Object Snapping” on page 134).

2D Locus Tool
The 2D Locus tool places a 2D locus in a drawing. Because they are merely movable reference points, loci cannot be 
reshaped or resized.

To place a 2D locus:

1. Click the 2D Locus tool from the Basic palette.
2. Click to place the locus.

The locus properties can be edited from the Object Info palette.

3D Locus Tool
The 3D Locus tool places a snappable 3D locus or reference point onto the drawing. Like 2D loci, they are reference 
points. They can be moved, but they cannot be reshaped and they do not print.

To place a 3D locus:

1. Click the 3D Locus tool from the 3D Modeling tool set.
2. Click to place the locus.

The locus is placed on the working plane unless it is snapped to an object. The locus properties can be edited from 
the Object Info palette.

Creating Spheres
The Sphere tool creates spheres using one of three modes.

Parameter Description

Distance per Turn Enter the distance between the outer edges of each turn in the spiral
Number of Turns Specify the number of turns which determine the total sweep angle of the spiral; one turn 

equals 360 degrees
Start Radius Enter the distance from the center to the beginning of the spiral
Increment (deg) Specify the number of points used to define the curve; the higher the increment, the fewer the 

number of points (for example, an increment of five degrees means 360/5=72 points per turn)
Thickness Specify the thickness value of the area between the outer and inner edge of the turn

http://www.youtube.com/watch?v=BORbFKdoCDQ&list=UUN7uzhu-ljLJOe6a0J-fBcQ
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The sphere radius can be changed with the Reshape tool (see “Reshaping Extruded Objects and Solid Primitives” on 
page 1052), the radius can be modified in the Object Info palette, and the resolution can be adjusted through the 3D 
Conversion Resolution setting (see “3D Preferences” on page 54).

Sphere by Radius

To create a sphere by radius:

1. Click the Sphere tool from the 3D Modeling tool set, and select the Radius mode.
2. Click to set the center of sphere base.
3. Move the mouse to the desired radius and click to set the radius of the sphere base. The radius can also be set in 

the Data bar.

Sphere by Diameter

To create a sphere by diameter:

1. Click the Sphere tool from the 3D Modeling tool set, and select the Diameter mode.
2. Click to set the first point on the sphere base diameter.
3. Move the mouse to the desired diameter and click to set the diameter of the sphere base.

Mode Description

Radius Defines the base of the sphere by radius
Diameter Defines the base of the sphere by diameter
Center and Radius Defines the base of the sphere by center (according to the height above the working 

plane) and radius

Radius Center and Radius

Diameter

Click 1

Click 2
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Sphere by Center and Radius

To create a sphere by center and radius:

1. Click the Sphere tool from the 3D Modeling tool set, and select the Center and Radius mode.
2. Click to set the center of the sphere base on the working plane.
3. Move the mouse and click to set the height of the sphere above the working plane.
4. Move the mouse to the desired radius and click to set the radius of the sphere base. The radius can also be set in 

the Data bar.
The center and height, relative to the working plane, of the sphere is automatically established if the first click is on a 
snap point—for example a 3D locus or vertex on another 3D object.
When in a non-isometric view, the sphere is created centered on the working plane.

Creating Hemispheres
The Hemisphere tool creates hemispheres using one of three modes.

Click 1

Click 2

Click 1

Click 2

Click 3

Radius Up Radius

Diameter
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The hemisphere radius can be changed with the Reshape tool (see “Reshaping Extruded Objects and Solid Primitives” 
on page 1052), the radius can be modified in the Object Info palette, and the resolution can be adjusted through the 3D 
Conversion Resolution setting (see “3D Preferences” on page 54).

Hemisphere by Radius

To create a hemisphere by radius:

1. Click the Hemisphere tool from the 3D Modeling tool set, and select the Radius mode.
2. Click to set the center of the hemisphere base.
3. Move the mouse to the desired radius and click to set the radius of the hemisphere base. The radius can also be set 

in the Data bar.

Hemisphere by Diameter

To create a hemisphere by diameter:

1. Click the Hemisphere tool from the 3D Modeling tool set, and select the Diameter mode.
2. Click to set the first point on the hemisphere base diameter.
3. Move the mouse to the desired diameter and click to set the diameter of the hemisphere base.

Mode Description

Radius Defines the base of the hemisphere by radius
Diameter Defines the base of the hemisphere by diameter
Up Radius Defines the base of the hemisphere by center and rotation

Click 1

Click 2
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Hemisphere by Up Radius

To create a hemisphere by up radius:

1. Click the Hemisphere tool from the 3D Modeling tool set, and select the Up Radius mode.
2. Click to set the center of the hemisphere base.
3. Move the mouse to the desired radius and click to set the rotation and top of the hemisphere.

Creating Cones
The Cone tool creates cones using one of two modes.

When in a non-isometric view, the height of the cone is set in the Set Extrusion Height dialog box. In an isometric 
view, the cone height can be set by dragging with the mouse or entering the height in the Data bar. For more 
information on the different views, see “Using Standard Views” on page 1141.

Mode Description

Radius and Height Defines the base of the cone by radius and tip of the cone by height
Radius and Tip Defines the base of the cone by radius and, if desired, snaps the tip of the 

cone to a point

Click 1

Click 2

Click 1

Click 2

Radius and Height Radius and Tip
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The cone height can be changed with the Reshape tool (see “Reshaping Extruded Objects and Solid Primitives” on 
page 1052), the radius can be modified in the Object Info palette, and the resolution can be adjusted through the 3D 
Conversion Resolution setting (see “3D Preferences” on page 54).

Cone by Radius and Height

To create a cone using radius and height:

1. In a 3D isometric view, click the Cone tool from the 3D Modeling tool set, and select the Radius and Height 
mode.

2. Click to set the center of the cone base.
3. Move the mouse to the desired radius and click to set the radius of the cone base. The radius can also be set in the 

Data bar.
4. Move the mouse and click to set the cone height.

Cone by Radius and Tip

To create a cone using radius and tip:

1. Ensure that Snap to Object and Smart Points snapping is enabled (see “Setting Snapping Parameters” on 
page 131).

2. In a 3D isometric view, click the Cone tool from the 3D Modeling tool set and select the Radius and Tip mode.
3. Click to set center of the cone.
4. Move the mouse to the desired radius and click to set the radius of the cone base. The radius can also be set in the 

Data bar.
5. Using snapping, snap the top of the cone to a snap point on another 3D object. A preview object displays. Click to 

create the cone.

Click here for a video tip on this topic (Internet access required).

Click 1

Click 2

Click 3

Click 3

Click 1

Click 2

http://www.youtube.com/watch?v=b5ZSF9aO5-Y
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Advanced Object Creation
NURBS Curves and Surfaces
Non-Uniform Rational B-Spline (NURBS) is a mathematical formulation that represents the geometry of curves, 
circles, arcs, and surfaces in 3D space. Free-form curves and surfaces can be created and edited with a high level of 
both flexibility and precision.
A NURBS curve generally consists of a degree value and weighted control points, or vertices. The curve passes 
between the vertex points; the degree determines how many points affect the curve. The direction indicates the starting 
and ending points of the curve as it was drawn, which can affect the outcome of certain operations.

Increasing the relative weight of one of the vertices means the vertex has more of an influence on the curve and “pulls” 
the curve towards that vertex.

The Reshape tool can be used to move a vertex or several vertices, changing the shape of the curve (see “Reshaping 
NURBS Curves” on page 1054).

Increasing the degree of a NURBS curve proportionally increases the number of vertices, allowing for more flexibility 
in drawing the curve, but also more complexity due to the numerous weights affecting the curve.

The same principles that apply to a NURBS curve apply to a surface. A NURBS surface is a grid, or mesh, of weighted 
control points in the U and V directions.

NURBS curve
Degree = 3
Vertices = 6
Weight of each vertex = 1

NURBS curve
Degree = 3
Vertices = 6
Weight of selected vertex = 8
Weight of remaining vertices = 1

NURBS curve
Degree = 10
Vertices = 27
Weight of each vertex = 1

NURBS surface
U Degree = 2
V Degree = 2
Vertices = 9
Weight of each vertex = 1

V direction

U direction
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Increasing the degree of a NURBS surface in the U and/or V direction increases the number of vertices, adding 
flexibility as well as complexity.

A NURBS surface also has a direction, or normal, which affects the outcome of certain operations, such as fillet surface 
creation. Iso-parametric curves indicate the U and V direction, and edge curves are drawn along the edges, helping to 
visualize the NURBS surface.

Each vertex on the surface can have a weight which “pulls” the surface towards the weighted vertices. 

The Reshape tool can move a single vertex or a row of vertices, deforming the surface (see “Reshaping NURBS 
Surfaces” on page 1055).

Both NURBS curves and surfaces can be defined by control points or by interpolation points. The curve or surface 
passes between control points or through interpolation points.

NURBS surface
U Degree = 6
V Degree = 6
Vertices = 49
Weight of all each vertex = 1

Iso-parametric curve

Edge

NURBS surface
U Degree = 6
V Degree = 6
Vertices = 49
Weight of selected vertex = 100
Weight of remaining vertices = 1

Surface V vertices moved with Reshape tool
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Interpolated curves and surfaces may be easier to modify. See “Creating NURBS Curves” on page 328 and 
“Interpolated NURBS Surfaces” on page 329.
Complex, free-form shapes can be created with NURBS curves and NURBS surfaces. The shapes can then be 
combined, clipped, added to, trimmed, extended, analyzed, and otherwise modified as described in these sections.

Click here for a video tip on this topic (Internet connection required).
~~~~~~~~~~~~~~~~~~~~~~~~~
3D Power Pack Cursors
Selecting the Edges and Faces of a Solid
Displaying Surface Normals
Displaying and Reversing Object Direction
Editing a Fillet/Chamfer or Shell Object
Surface Geometry Requirements
Converting to NURBS
NURBS Surface Properties

3D Power Pack Cursors
Special cursors display during certain operations to help determine the current mouse function; they do not display 
when an active selection is about to occur.

~~~~~~~~~~~~~~~~~~~~~~~~~
NURBS Curves and Surfaces
Selecting the Edges and Faces of a Solid
Displaying Surface Normals
Displaying and Reversing Object Direction
Editing a Fillet/Chamfer or Shell Object
Surface Geometry Requirements

Cursor/Operation Where Used

Edge Selection Extract tool’s Point and Curve modes, Chamfer Edge tool, and the Fillet Edge tool

Face Selection Extract tool’s Surface modes, Shell Solid tool, Push/Pull tool, as well as the Chamfer Edge 
and Fillet Edge tools with the Select Faces option turned on.

Press the Alt key (Windows) or Option key (Mac) to select the back faces of solid objects.
Curve Selection Loft Surface tool, Project tool, and Push/Pull tool

Surface Selection Project tool

Control point Interpolation point

http://www.youtube.com/watch?v=KWRfW0pQSVg
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Converting to NURBS

Selecting the Edges and Faces of a Solid
Several 3D Power Pack tools require the selection of edges or faces of a solid. For example, the Extract tool’s Extract 
Surface mode, the Push/Pull tool, and the Shell Solid tool require face selection. The Chamfer Edge and Fillet Edge 
tools can require both face and edge selection. 
The color and opacity used for pre-selection highlighting is set by the Object Highlighting - Tool Highlighting 
preference in the interactive settings. See “Selection and Pre-selection Indicators” on page 114 and “Configuring 
Interactive Display” on page 116.

Selecting Edges
The cursor changes to an arrowhead when on or near an edge, and the edge is highlighted for selection. If more than 
one edge is near the cursor, the nearest edge is highlighted. Click the edge to select it.
The cursor also changes to an arrowhead when on or near an iso-parametric curve for the Extract tool in Extract 
Iso-parametric Curves mode.

 

Selecting Faces
When the cursor is over a face, the face geometry is highlighted, making it very easy to determine which face will be 
selected. Click on a face to select it.

Action Description

Select more than one edge Press the Shift key and select the edges
Deselect a selected edge Click on the edge again with the Shift key pressed
Deselect edges that have been selected Click on an empty area
Deselect the last selection Press the Backspace key, or double-click on the edge

Arrow cursor (away
from edge)

Arrowhead cursor
(on or near edge)

Iso-parametric
curve

Multiple edges 
selected



NURBS Curves and Surfaces |  325
Multiple faces can be selected while pressing the Shift key, much like the edge selection described earlier. Deselecting 
faces is also similar to deselecting edges.

Face selection can also be an edge-based selection. When the cursor is on or near an edge or near an iso-parametric 
curve, you can select the face on either side of the edge depending on the cursor position. Face highlighting helps 
determine which face will be selected. 
Normally, only the front surfaces of a solid object can be selected directly. To select the back face of a solid, press the 
Option key (Mac) or the Alt key (Windows) during face selection.

If the cursor is positioned over more than one back face and the desired face to select is difficult to determine, the 
Select Face dialog box opens to specify the face. Click Next or Prev until the desired face is highlighted. Click OK to 
select the face.

~~~~~~~~~~~~~~~~~~~~~~~~~
NURBS Curves and Surfaces
3D Power Pack Cursors
Displaying Surface Normals

Wireframe 3D face selection Rendered 3D face selection 2D face selection 

Face already 
selected

Face will be
selected

Press Option (Mac)/Alt
(Windows) to select the back

face
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Displaying and Reversing Object Direction
Editing a Fillet/Chamfer or Shell Object
Surface Geometry Requirements
Configuring Interactive Display
Converting to NURBS

Displaying Surface Normals
The surface normal of NURBS surfaces can be displayed in order to clarify the surface direction and facilitate the 
creation of fillet surfaces (see “Creating a Fillet Surface” on page 338), shell solids (see “Shell from a NURBS 
Surface” on page 371), and the sectioning of solids (see “Section Solids” on page 1086).
To display the surface normal of a NURBS surface:

1. Select one or more NURBS surfaces.
2. In the Object Info palette, select Show Normal. The NURBS surface normal displays as a red arrow.

 

If desired, click Reverse Normal when a single NURBS surface is selected to reverse the direction of the surface 
normal. The arrow changes direction accordingly to indicate the new direction.

~~~~~~~~~~~~~~~~~~~~~~~~~
NURBS Curves and Surfaces
3D Power Pack Cursors
Selecting the Edges and Faces of a Solid
Displaying and Reversing Object Direction
Editing a Fillet/Chamfer or Shell Object
Surface Geometry Requirements
Converting to NURBS

Displaying and Reversing Object Direction
The direction of lines, polylines, 2D/3D polygons, and NURBS curves can be displayed and reversed, if desired, to 
help perform 3D operations and make end marker placement predictable.
To display the direction of an object:

1. Select one or more objects.
2. In the Object Info palette, select Show Direction. The object’s direction displays as a red arrow.

 

If desired, click Reverse Direction with one or more objects selected to reverse the direction of the object(s). The 
arrow indicates the new direction.
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~~~~~~~~~~~~~~~~~~~~~~~~~
NURBS Curves and Surfaces

Editing a Fillet/Chamfer or Shell Object
A fillet, chamfer, or shell object follows certain editing conventions.
The set of edges or faces used to create the fillet/chamfer or shell cannot be changed once the operation is performed; 
edges or faces cannot be deleted from or added to the existing set. To add or delete edges or faces, first ungroup the 
object, and then perform the operation again.

The properties that can be changed from the Object Info palette include the thickness of a shell, direction of shelling 
(inside/outside), the radius of a fillet or setback distance of a chamfer. In the case of variable radius fillets, the 
percentage of length and radius value at each point can be edited. However, only the parameters of the topmost object 
can be changed.
For example, if a shell is created, and then some of the shell edges are filleted, only the fillet parameters can be changed 
directly from the Object Info palette. To change the shell thickness, the fillet object must first be ungrouped. To change 
the original extrusion, both the fillet and the shell must be ungrouped. Once changes have been made, reapply the shell 
and fillet.

The Modify > Edit Group command cannot be used for these objects.
~~~~~~~~~~~~~~~~~~~~~~~~~
3D Power Pack Cursors
Selecting the Edges and Faces of a Solid
Surface Geometry Requirements

Surface Geometry Requirements
Some surface geometry can contain degenerate patches, singularities, or self-intersections. These types of surfaces 
could potentially be produced with the Reshape tool, Loft Surface tool, or Create Surface from Curves command, 
and can produce undesirable results in the finished model. Surface operations, such as trim and stitch surfaces, split, 
and other operations, like creating contours and solid operations, may not be able to manipulate these types of surfaces.

Decomposing such surfaces may help by separating the surfaces into NURBS surfaces without discontinuities. 
See “Decomposing Objects and Surfaces” on page 1020.

~~~~~~~~~~~~~~~~~~~~~~~~~
NURBS Curves and Surfaces

Converting to NURBS
The Convert to NURBS command converts planar objects and 3D polygons into NURBS curves, and converts the 
faces of solids to NURBS surfaces. This is a quick way of creating NURBS curves from circles and arcs, or NURBS 
surfaces from an extrusion, sweep, or other solids.

Fillet operation performed Ungroup to change 
existing set of edges

Fillet operation performed 
with new set of edges
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To convert to NURBS curves or surfaces:
1. Select the object or solid to convert to NURBS surfaces.
2. Select Modify > Convert > Convert to NURBS.

The selection is converted to NURBS surface(s) or a NURBS curve, as reflected in the Object Info palette.
If the solid consisted of several faces, the conversion results in a group of NURBS surfaces. Select Modify > Ungroup 
to access the individual NURBS surfaces that make up the solid.
~~~~~~~~~~~~~~~~~~~~~~~~~
NURBS Curves and Surfaces
3D Power Pack Cursors
Selecting the Edges and Faces of a Solid
Displaying Surface Normals

Creating NURBS Curves
NURBS (Non-Uniform Rational B-Splines) are used to create curves in 3D space. They can also be used as defining 
objects for extrusions along a path.
NURBS curves can be created using one of two modes. Specify the NURBS curve degree prior to selecting a mode.

NURBS curves can also be created from planar objects by converting them to NURBS; see “Converting to 
NURBS” on page 327. 

Setting the NURBS Curve Degree
The curve degree affects the number of vertices created; the higher the degree value, the greater the number of vertices.

To specify the NURBS curve degree:

1. Click the NURBS Curve tool from the 3D Modeling tool set, and click NURBS Curve Degree Setting from the 
Tool bar.
Alternatively, double-click the NURBS Curve tool to open the Curve Degree dialog box.

2. The Curve Degree dialog box opens. Specify the curve degree for the NURBS Curve tool to use. Click OK.
Set the degree value to 1 to create a NURBS curve with linear segments (similar to a 3D polygon). A linear 
NURBS curve can be used to measure an object from point to point in a 3D view.

NURBS Curve by Interpolation Point

To create a NURBS curve by interpolation point:

1. Click the NURBS Curve tool from the 3D Modeling tool set, and select the Interpolation Point mode.
2. Click to set the first point on the curve.
3. Click to set the point through which the curve passes.

Interpolation Point

Control Point NURBS Curve 
Degree Setting
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Continue clicking to add more interpolation points, extending the curve.

4. Double-click to set the end point of the curve.

NURBS Curve by Control Point

To create a NURBS curve by control point:

1. Click the NURBS Curve tool from the 3D Modeling tool set, and select the Control Point mode.
2. Click to set the first point on the curve.
3. Click to set the point that the curve pulls toward but does not touch.

Continue clicking to add more control points, extending the curve.

4. Double-click to set the end point of the curve.
~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping NURBS Curves
NURBS Curves and Surfaces

NURBS Surfaces

Interpolated NURBS Surfaces
As described in “Creating NURBS Curves” on page 328, NURBS curves can be created by interpolation points or 
control points. Similarly, a NURBS surface can be created by interpolation points. An interpolated surface is a NURBS 
surface that passes through a two-dimensional array of 3D interpolation points. Regular NURBS surfaces are defined 
by their control points, which may not lie on the surface and can be difficult to use for reshaping the surface (it is 
difficult to know how much the control point should be moved in order to reshape the surface by a specific distance). 
Because interpolation points lie on the surface, it is much easier to modify these points with the Reshape tool or the 
Object Info palette, and have the surface pass through the points.
An interpolated surface can be created, or an existing untrimmed NURBS surface can be converted to an interpolated 
surface, for easier reshaping.

When an interpolated surface is used in another operation, such as a Boolean operation or trimming, the surface 
becomes a control point surface.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating an Interpolated Surface
Converting to an Interpolated Surface
Creating a Loft Surface
NURBS Curves and Surfaces

Interpolation point

Control point
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Creating an Interpolated Surface
A new interpolated NURBS surface can be created with the Create Interpolated Surface command.
To create an interpolated surface:

1. Select Model > 3D Power Pack > Create Interpolated Surface.
2. Click to define the start of the interpolation point row, and then click again to define the end of the row. Click a 

third time to define the column of interpolation points.

The Create Interpolated Surface dialog box opens.
3. Specify the number of interpolation points and degree of flexibility to create for both the U and V direction.

Click to show/hide the parameters.

4. Click OK to create the interpolated surface. Select Show Vertices in the Object Info palette to display the 
interpolation points. Use the Reshape tool to reshape the interpolated NURBS surface.

~~~~~~~~~~~~~~~~~~~~~~~~~
Interpolated NURBS Surfaces
Converting to an Interpolated Surface
Reshaping NURBS Surfaces

Parameter Description

U Direction
Number of Points Specifies the number of interpolation points (up to 1000) to create in the U direction; this 

number must be greater than the U degree number
Degree Indicates the flexibility of the surface in the U direction, from 1 to 28; a larger number 

results in a more variable surface
V Direction

Number of Points Specifies the number of interpolation points (up to 1000) to create in the V direction; this 
number must be greater than the V degree number

Degree Indicates the flexibility of the surface in the V direction, from 1 to 28; a larger number 
results in a more variable surface
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NURBS Curves and Surfaces

Converting to an Interpolated Surface
An existing untrimmed NURBS surface can be converted to an interpolated NURBS surface for easier reshaping.
To convert an untrimmed NURBS surface to an interpolated surface:

1. Select an untrimmed NURBS surface.
2. Select Model > 3D Power Pack > Create Interpolated Surface.

The Create Interpolated Surface dialog box opens, with a suggested number of interpolation points and degree 
values for the conversion. These parameters can be changed.

3. Click OK to create the interpolated surface. Select Show Vertices in the Object Info palette to display 
interpolation points. Use the Reshape tool to reshape the interpolated NURBS surface.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating an Interpolated Surface
Converting to an Interpolated Surface
Reshaping NURBS Surfaces
NURBS Curves and Surfaces

Creating a Loft Surface
The Loft Surface tool creates complex shapes from two or more NURBS curve cross sections with no rail, with a rail 
and one or more cross sections, or with two rails and one cross section. A rail is a guide NURBS curve which 
determines the resulting shape, in the one rail mode. In Birail Sweep mode, the rails do not need to intersect the cross 
sections.
Three modes are available.



  332 | NURBS Surfaces
Similar to the Multiple Extrude command, the Loft Surface tool normally creates a 3D object (a generic solid) from a 
series of other objects (in this case, NURBS curves). Unlike Multiple Extrude, the cross sections do not need to be 
equally spaced, and the resulting profile can be manipulated to avoid self-intersection and to control twist.

This tool can potentially create surfaces which cannot be further manipulated in the 3D Power Pack. See “Surface 
Geometry Requirements” on page 327.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Loft Surface Using No Rails
Loft Surface Using One Rail
Loft Surface Using Two Rails
NURBS Surface Properties
Creating a NURBS Surface by Revolving a Profile Along a Rail
NURBS Curves and Surfaces

Loft Surface Using No Rails

To create a loft surface from two or more NURBS curve cross sections:

1. Click the Loft Surface tool from the 3D Modeling tool set, and then select No Rail from the Tool bar.
2. Click on each cross section. The cursor changes into an arrowhead when over a valid cross section. The point 

nearest to the click is selected.

The proposed curve alignment displays in red as each section is selected.
Cross sections are created using NURBS curves which do not need to be the same shape or planar. All NURBS 
curves must be either closed or open objects, not a mixture of the two. 3D loci can be used in a loft, but must 
display at the ends of the loft.

3. Once all curves are selected, press Enter or click the check mark button on the Tool bar.

Mode Description

No Rail Creates a loft surface using two or more NURBS curve cross sections
One Rail Creates a loft surface using a NURBS curve rail and one or more NURBS curve cross sections
Birail Sweep Creates a loft surface using two NURBS curve rails and one NURBS curve cross section

No Rail Birail Sweep

One Rail

http://www.youtube.com/watch?v=-nHjf3h8h78&list=UUN7uzhu-ljLJOe6a0J-fBcQ
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The Loft Creation dialog box opens. Specify the desired loft creation settings.
Click to show/hide the parameters.

Parameter Description

Select Curve Selects the previous or next cross section curve. Reverse changes the direction 
of the curve to twist or untwist the loft surface.

Reverse Click to reverse the curve direction
Select Alignment by Point Selects the previous or next point on the selected cross-section curve. If the 

cross section does not have any corners, this option is disabled. 
Select Alignment by Percentage Selects points along a geometrically continuous cross section (such as a circle) 

by a specified percentage, or by adjusting the slider
Ruled Creates a linearly interpolated object

Closed Creates a loft surface that closes in on itself. Because the start point cannot be 
selected as the end point of a loft, the Closed option automatically completes 
the connection.

Create Solid Creates a solid loft surface with capped ends; deselect to create a group of 
NURBS surfaces instead of a generic solid

Keep Curves Retains the cross sections after the loft is created
Preview Displays the proposed loft surfaces based on the current settings

Cross section Loft surface without 
Closed option

Loft surface with 
Closed option
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4. Click OK to close the dialog box and create the loft surface(s).
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Loft Surface

Loft Surface Using One Rail

To create a loft surface using one NURBS curve rail:

1. Click the Loft Surface tool from the 3D Modeling tool set, and then select One Rail from the Tool bar.
2. Click on the rail, and then click on each cross section.

3. Once all curves are selected, press Enter or click the check mark button on the Tool bar.
The Loft Creation dialog box opens.

4. Specify the desired loft creation settings (see “Loft Surface Using No Rails” on page 332).
5. Click OK to close the dialog box and create the loft surface(s).

The rail NURBS curve should intersect all cross-section curves if there is more than one curve.
When a single cross section is used, the curve is swept along the rail and the cross section does not need to 
intersect the rail.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Loft Surface

Rail
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Loft Surface Using Two Rails

To create a loft surface using two NURBS curve rails:

1. Click the Loft Surface tool from the 3D Modeling tool set, and then select Birail Sweep from the Tool bar.
2. Click on each rail, and then click on the cross section. The cross-section profile curve does not need to intersect 

the rail curves.
In this mode, only one cross section can be selected.

3. Once the profile curve is selected, press Enter or click the check mark button on the Tool bar.
The Loft Creation dialog box opens.

4. Specify the desired loft creation settings (see “Loft Surface Using No Rails” on page 332).
5. Click OK to close the dialog box and create the loft surface(s).

The loft surface is created differently depending on whether the profile curve is open or closed, and how the start/end of 
the rails touch the profile curve. In certain instances, the click order (which rail is clicked first) and location (part of the 
profile curve that is clicked) will produce a different loft surface.

Rails
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Loft Surface

Creating Surfaces from Curves
The Create Surface from Curves command creates a NURBS surface from a network of single closed curves 
(including closed 2D objects) or two or more open NURBS curves. These NURBS curves can be planar or non-planar, 
but NURBS in the U direction must intersect NURBS in the V direction at only one point.

This command can potentially create surfaces which cannot be further manipulated in the 3D Power Pack. See 
“Surface Geometry Requirements” on page 327.

To create a NURBS surface from curves:
1. Draw two or more open NURBS curves to create an enclosed region.
2. Select the NURBS objects being used to create the NURBS surface.
3. Select Model > 3D Power Pack > Create Surface from Curves.

A NURBS surface is created. 

Status of Profile Curve and Rails Effect of Rail Click Order/Profile Click Location

Open Profile Curve

Start/end of one of the rails touches the start/
end of the open profile

The rail click order and profile click location do not affect the loft 
surface creation

Start/end of the rails do not touch the start/end 
of the open profile, or do not touch the open 
profile at all

Both the rail click order and the location where the profile is 
clicked affect how the loft surface is created

Closed Profile Curve

Start/end of one of the rails touches the closed 
profile curve

The click order and location do not affect the loft surface creation

Start/end of the rails do not touch the closed 
profile at all

The click order affects how the loft surface is created

Rails do not touch the open profile curve

Rails

Top rail clicked first, then bottom rail, and 
then the top of the profile curve

OR
Bottom rail clicked first, then top rail, and 

then the bottom of the profile curve

Top rail clicked first, then bottom rail, and 
then the bottom of the profile curve

OR
Bottom rail clicked first, then top rail, and 

then the top of the profile curve

Rails

Rails do not touch the closed profile curve

Top rail clicked first, then bottom 
rail, and then the profile curve

Bottom rail clicked first, then top 
rail, and then the profile curve
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Multiple open NURBS that form both boundary and interior curves can be used to create a NURBS surface, but 
must have an equal number of intersections.

A NURBS surface is not created if there is more than one intersection created by the selected curves, creating multiple 
enclosed regions. It is also not created if there is an intersection between selected curves in the same parametric 
direction or if there are an unequal number of intersections.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Loft Surface
Creating a Drape Surface
Creating a Fillet Surface
Creating Planar Caps
Creating a NURBS Surface by Revolving a Profile Along a Rail
NURBS Surface Properties
NURBS Curves and Surfaces

Creating a Drape Surface
You can automatically create a rectangular, draped NURBS surface over an object, up to a specific Z plane value. This 
is useful for representing surfaces including curtains, tablecloths, product packaging, and (with Vectorworks Architect 
or Landmark) site models.
To create a drape surface:

1. Select one or more objects to be draped.

Only one enclosed region allowed Intersection between curves in the 
same parametric direction

Unequal number of intersections



  338 | NURBS Surfaces
2. Select Model > 3D Power Pack > Create Drape Surface.
The Create Drape Surface dialog box opens.

Click to show/hide the parameters.

3. Specify the desired parameters, and click OK to create the drape surface.

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Loft Surface
Creating Surfaces from Curves
Creating a Fillet Surface
Creating Planar Caps
Creating a NURBS Surface by Revolving a Profile Along a Rail
NURBS Surface Properties
NURBS Curves and Surfaces

Creating a Fillet Surface
The Create Fillet Surface command creates a surface between two selected surfaces, trimming the original surfaces by 
default.
This command is useful for sheet metal design (for example, for car bodies) to provide a smooth transition between two 
adjacent surfaces—perhaps for aesthetic quality or because of a manufacturing requirement.
To create a fillet surface at the intersection of two selected NURBS surfaces:

1. Select two NURBS surfaces. The position of the fillet surface depends on the normal of the NURBS surfaces; 
select Show Normal in the Object Info palette to display the surface normals (see “Displaying Surface Normals” 
on page 326).

Parameter Description

Number of Points Specifies the number of control points on the drape surface; the greater the number of 
points, the closer the drape surface is to the object

U Direction Enter the number of points to create in the U direction; this number must be greater than 3
V Direction Enter the number of points to create in the V direction; this number must be greater than 3

Plane Z Value Specify the base level of the drape surface (how far down the bottom of the drape goes), 
which must be less than the highest Z coordinate of the object

http://www.youtube.com/watch?v=pG7k2Kfe-W8
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2. Select Model > 3D Power Pack > Create Fillet Surface.
The Fillet Surface Preferences dialog box opens. Enter the desired Fillet Radius, and then select the trim and 
cross section type for the fillet.
The following trim type examples use a circular cross section type, and the cross section examples use an edge 
tangency trim type. The original surfaces are trimmed.

Click to show/hide the parameters.

Parameter Description

Fillet Radius Specifies the radius of the fillet surface
Trim Type

Edge Tangency Creates a blend between the minimal and maximal intersections on each end of the fillet

Minimal Trims the fillet surface to the minimal intersecting areas on the face boundaries
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Maximal Trims the fillet surface to the maximal intersecting areas on the face boundaries

None Generates the entire fillet without trimming the fillet surface

Cross Section Type
Circular Creates a fillet surface with a circular cross section

Linear Creates a fillet surface with a linear cross section

Parameter Description
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3. Click OK.
A NURBS fillet surface is created between the two objects.
The position of the fillet surface depends on the surface normals. The fillet is created differently if the Reverse 
Normal button is clicked for one or both of the surfaces in the Object Info palette.

Tangent 
Continuous 
Blend

Creates a fillet surface with a tangent continuous G1 cross section

Curvature 
Continuous 
Blend

Creates a fillet surface with a curvature continuous G2 cross section

Trim Original 
Surfaces

Creates a fillet surface and trims the original surfaces where they connect to the fillet 
surface

Parameter Description

Trim Original Surfaces selected Trim Original Surfaces deselected

Fillet surface after reversing the 
normal of the vertical surface



  342 | NURBS Surfaces
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Loft Surface
Creating Surfaces from Curves
Creating a Drape Surface
Creating Planar Caps
Creating a NURBS Surface by Revolving a Profile Along a Rail
NURBS Surface Properties
NURBS Curves and Surfaces

Creating Planar Caps
The Create Planar Caps command closes off the ends of open-ended solids by creating planar NURBS surfaces. 
These surfaces can then be added to the rest of the surfaces with the Add Solids command.
To create planar caps:

1. Select the open-ended solid.

2. Select Model > 3D Power Pack > Create Planar Caps.
Planar NURBS surfaces are created to close off the ends of the solid.

3. If desired, add the solid and the planar cap surfaces by selecting them all and choosing Model > Add Solids.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Loft Surface
Creating Surfaces from Curves
Creating a Drape Surface
Creating a Fillet Surface
Creating a NURBS Surface by Revolving a Profile Along a Rail
NURBS Surface Properties
NURBS Curves and Surfaces

Creating a NURBS Surface by Revolving a Profile Along a Rail
Complex NURBS surfaces can be created by revolving a profile along a guide curve (rail). This is an alternate, and 
sometimes easier, method of creating NURBS surfaces than using the Loft Surface tool, especially when creating 
tent-like structures.
The Revolve with Rail command creates the NURBS surface by revolving a planar NURBS curve about an axis. The 
revolution is guided by a rail curve on a plane perpendicular to the plane containing the profile curve and axis.

Planar caps moved for clarity
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To create a NURBS surface with profile and rail:
1. Create the axis, rail and profile out of NURBS curves. 

Conditions must meet the following requirements:
• The axis must be a linear NURBS curve
• The profile must be a planar NURBS curve
• The profile cannot intersect the axis, though it can touch
• The axis must lie on the same plane as the profile
• The rail must be a planar NURBS curve that lies on a plane perpendicular to the plane containing the axis and 

profile
2. Select Model > 3D Power Pack > Revolve with Rail. Select, in order, the axis, profile, and rail.

3. The NURBS surfaces are automatically created.

The rail defines the extent of the revolution. An open rail curve generates surfaces until the rail ends.

 

Profile

Rail

Axis

Click 1

Click 2

Click 3
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Loft Surface
Creating Surfaces from Curves
Creating a Drape Surface
Creating a Fillet Surface
Creating Planar Caps
NURBS Surface Properties
NURBS Curves and Surfaces

NURBS Surface Properties
The properties of a NURBS surface are displayed in the Object Info palette, where they can also be edited. NURBS 
surfaces can also be reshaped with the Reshape tool; see “Reshaping Objects” on page 1043 for more information.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
NURBS Curves and Surfaces
Creating a Loft Surface
Creating Surfaces from Curves
Creating a Drape Surface
Creating a Fillet Surface
Creating Planar Caps
Creating a NURBS Surface by Revolving a Profile Along a Rail

Parameter Description

Move Select Entire Object to edit all the vertices of the surface, Vertex Only to edit only 
the selected vertex, U Vertices to edit all of the vertices in a row in the U direction, 
and V Vertices to edit all of the vertices in a row in the V direction

Edit U/V Scrolls through the vertices of the selected NURBS surface in either the U parametric 
direction or V parametric direction

X, Y, Z / X’,Y’,Z’ Depending on the selection in the Move list, displays the position of the current 
surface or vertex; edit the values to change the surface/vertex position 

U Degree/ V Degree A NURBS surface is defined mathematically by two parameters, U and V, which 
increase or decrease along certain directions called the U and V parametric 
directions. The two directions are perpendicular to each other.
Increasing the U or V Degree value adds vertices in that parametric direction; the 
vertices can then be manipulated.

Weight NURBS curves and surfaces are represented mathematically by weighted control 
points. The weight value can be anywhere between .01 and 100. A weight above 1 
pulls the curve or surface toward the control point; a weight below 1 has the reverse 
effect.

Reverse Normal Flips the surface normal direction
Untrim Creates a NURBS surface, if the surface has been trimmed
NURBS Surface 
parameters (display only)

Displays the NURBS surface parameters

Show Vertices Select to display the surface’s vertices
Show Normal Displays the surface normal as a red arrow for the selected NURBS surface
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3D Power Pack Cursors

Extracting Geometry
The Extract tool can be used to extract geometry from the edge or surface of a NURBS surface or solid object, leaving 
the original unmodified. The extracted geometry can then be used for snapping or for other surface operations.

To extract geometry from the edge or surface of a NURBS surface or solid object:

1. In the desired view, click the Extract tool from the 3D Modeling tool set, and then select the desired mode from 
the Tool bar.

2. If Extract Iso-parametric Curves mode was selected, skip to step 4. For all other modes, click Preferences from 
the Tool bar.
The Extract Preferences dialog box opens.

Click to show/hide the parameters.

Mode Description

Extract Point Extracts 3D loci from the edges of a NURBS surface or solid object. 3D loci are 
placed at the start, end, and mid-points of the selected edges. For circular edges, 
a 3D locus is created at the circle center as well.

Extract Curve Extracts a NURBS curve from the edge of a solid object
Extract Iso-parametric Curves Extracts an iso-parametric curve from the surface of a solid object
Extract Surface Extracts a NURBS surface from the face of a solid
Preferences Provides options for extracting tangent entities, faces, or all entities; the specific 

items extracted depends on which mode is selected. These options have no effect 
in Extract Iso-parametric Curves mode.

Parameter Description

Select Tangent Entities In Extract Point or Extract Curve mode, extracts loci or curves from tangentially 
connected edges of the selected object; in Extract Surface mode, extracts surfaces 
from tangentially connected faces of the selected object

Select Faces In Extract Point or Extract Curve mode, extracts loci or curves from all edges of 
the selected face(s)

Select All Entities In Extract Point or Extract Curve mode, extracts loci or curves from all edges of 
the selected object; in Extract Surface mode, extracts surfaces from all faces of 
the selected object

Extract Point

Extract Curve

Extract Iso-parametric Curves

Extract Surface

Preferences
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3. Specify the desired preferences and click OK.
Select the edge(s) or surface(s) from which geometry will be extracted. To select multiple edges or surfaces, hold 
the Shift key while selecting. To select the back faces of solids, press the Alt key (Windows) or Option key (Mac).
See “Selecting the Edges and Faces of a Solid” on page 324 for information on selecting surfaces.

4. Press Enter or click the check mark button on the Tool bar to extract the 3D loci, curves, or surfaces.
To edit extracted groups, select Modify > Ungroup.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Polygon from an Inner Boundary
NURBS Curves and Surfaces

Create Planar Objects In Extract Surface mode, creates planar objects from faces by extracting the 
geometry of a planar face. For example, create a polyline extracted from the face 
of a wall. The polyline could then have a hatch applied to simulate the appearance 
of brick in 3D views.

Another way to create planar objects from faces is with the Polygon from Inner 
Boundary mode of the 2D Polygon tool.

Parameter Description

Extracted curve moved for clarityIn Extract Iso-parametric Curve mode, click the 
hemisphere surface to select curve(s)

Extracted surface moved for clarityIn Extract Surface mode, with the Select Tangent 
Entities preference selected, click an interior surface to 
select all tangent interior surfaces
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Analyzing NURBS Curves and Surfaces
The Analysis tool provides proximity, intersection, and curvature information for NURBS curves and surfaces.
Two modes are available.

Determining NURBS Curve and Surface Proximity
In Proximity mode, the Analysis tool places a 3D locus at the minimum distance or intersection between two NURBS 
curves, a NURBS curve and NURBS surface, and a 3D locus and NURBS curve or surface. The tool places a NURBS 
curve at the intersection of two NURBS surfaces.

To analyze NURBS proximity or intersection:

1. Click the Analysis tool from the 3D Modeling tool set, and then select Proximity from the Tool bar.
2. Click on a NURBS curve, NURBS surface, or 3D locus, and then click on another NURBS curve or surface.

A 3D locus is placed on each NURBS curve at the closest minimum distance or intersecting points between the 
two items, or a NURBS curve is placed at the intersection of two NURBS surfaces.

Determining NURBS Curvature, Tangents, and Normals
In Interrogation mode, the Analysis tool provides curvature parameters for NURBS curves and NURBS surfaces. It 
also shows curvature circles and tangent and normal curves interactively, for any point on the existing curve or surface. 

Mode Description

Proximity Determines the minimum distance between NURBS curves/surfaces and 3D loci, or the 
intersection between NURBS curves/surfaces

Interrogation Interactively determines the curvature of NURBS curves and surfaces and displays curvature 
parameters

Proximity Interrogation

NURBS curve placed at the 
intersection of two NURBS 
surfaces

Locus points placed at the 
minimum distance from a 3D 
locus point to both a NURBS 
curve and a NURBS surface

NURBS curve

Locus points placed at each intersection between 
a NURBS curve and NURBS surface
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Optionally, you can add these curves to the drawing; the tool can also place two 3D loci for each curvature circle: one 
locus where the circle meets the NURBS curve or surface, and one at the center of the circle.

Analyzing NURBS Curves

To determine the curvature of a NURBS curve, or create a tangent curve:

1. Click the Analysis tool from the 3D Modeling tool set, and then select Interrogation from the Tool bar.
2. Click on the NURBS curve of interest, and then move the cursor along the curve to display the curvature circle (in 

red) and tangent curve (in blue) at the cursor position.

3. Click the curve to obtain curve properties at a specific location along the curve. The Curve Properties dialog box 
opens, displaying curvature parameters for that location.

Click to show/hide the parameters.

4. To add a curvature circle or tangent curve to the drawing, select the appropriate options and click OK. If you 
select multiple items, they are created as a group.

Analyzing NURBS Surfaces

To determine the curvature of a NURBS surface, or create a normal curve:

1. Click the Analysis tool from the 3D Modeling tool set, and then select Interrogation from the Tool bar.
2. Click on the NURBS surface of interest and move the cursor along the surface to display the curvature circles (in 

red) and normal curve (in blue) at the cursor position.

Option Description

Create Curvature Circle Adds the NURBS curve displaying in red to the drawing
Locus at center of 
curvature

Adds a 3D locus at the point where the curvature circle meets the NURBS curve, and 
another locus at the center of the circle

Create Tangent Curve Add the NURBS curve displaying in blue to the drawing
Length Specifies the length of the tangent curve

Tangent curve Curvature circle

Original NURBS curve

Click a point on the existing NURBS curve and select 
Create Tangent Curve to place a curve at that point
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3. Click again to obtain surface properties at a specific location along the surface. The Surface Properties dialog box 
opens, displaying curvature parameters for that location.

Click to show/hide the parameters.

4. To add curvature circle(s) or a normal curve to the drawing, select the appropriate options and click OK. If you 
select multiple items, they are created as a group.

~~~~~~~~~~~~~~~~~~~~~~~~~
NURBS Curves and Surfaces

Rebuilding NURBS Curves and Surfaces
The number of vertices in one or more selected NURBS curves or untrimmed surfaces can be changed with the 
Rebuild NURBS command. Reducing vertices simplifies the geometry, making it easier to manipulate, and increases 
the speed and ease-of-use for other objects that are based upon it.
To rebuild a NURBS curve or surface:

1. Select the NURBS curve(s) or surface(s).
2. Select Model > 3D Power Pack > Rebuild NURBS.

The Rebuild NURBS dialog box opens. Enter the number of points to use; specifying fewer points simplifies the 
NURBS curve or surface, but increases the difference between the original geometry and the rebuilt geometry.

Click to show/hide the parameters.

Option Description

Create Curvature Circles Adds the NURBS curve(s) displaying in red to the drawing
Loci at centers of curvature Adds a 3D locus at the point where the curvature circle(s) meet the NURBS 

surface, and another locus at the center of each circle
Create Normal Curve Add the NURBS curve displaying in blue to the drawing

Length Specifies the length of the normal curve

Original NURBS surface

Curvature circles

Normal curve

Click a point on the existing NURBS surface and select 
Create Curvature Circles to place curves at that point
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3. Click OK to rebuild the NURBS curve(s) or surface(s).

~~~~~~~~~~~~~~~~~~~~~~~~~
NURBS Curves and Surfaces

Splitting or Trimming NURBS Surfaces
The Project tool projects a 2D object or NURBS curve onto a NURBS surface, and then splits the NURBS surface or 
trims the NURBS surface according to the region selected. This allows nonlinear splitting or trimming of surfaces to 
create different shapes or cut a hole in an object.

Parameter Description

Number of Points Specifies the number of points to use; for a NURBS curve, enter the number of points, 
which must be at least 3

U Direction For a NURBS surface, enter the number of points to use along the U direction; this 
number must be at least 3

V Direction For a NURBS surface, enter the number of points to use along the V direction; this 
number must be at least 3

Keep Original Retains the original curve or surface, and adds a new, rebuilt curve or surface
Maximum Deviation After clicking Preview, displays the maximum deviation between the original and rebuilt 

surface or curve
Preview Displays a preview of the new, rebuilt curve or surface 

Mode Description

Split Splits a NURBS surface with a projection
Trim Trims a NURBS surface with a projection
Add Adds a projection to a NURBS surface

Add Upward In Add mode, adds the projection in the profile plane normal direction
Add Downward In Add mode, adds the projection in the opposite direction from the profile 

plane normal direction
Add Both Directions In Add mode, adds the projection in both the profile plane normal direction 

and the opposite direction

Split Add Both Directions

Trim

Add

Add Upward

Add Downward
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~~~~~~~~~~~~~~~~~~~~~~~~~
Project and Split
Project and Trim
Project and Add
Creating a Rib
Splitting Objects and NURBS Surfaces with the Split Tool
NURBS Curves and Surfaces

Project and Split

To split a NURBS surface with a projection:

1. In the desired view, draw a 2D object or NURBS curve on top of a NURBS surface.

If the object to be projected is an open NURBS curve or open 2D object, both end points must be outside the 
NURBS surface.

2. Click the Project tool from the 3D Modeling tool set, and then select Split from the Tool bar.
3. Click on the splitting object, and then click on the NURBS surface.

The splitting object is projected onto the NURBS surface, resulting in a group of NURBS surfaces.
~~~~~~~~~~~~~~~~~~~~~~~~~
Selecting the Edges and Faces of a Solid
Splitting or Trimming NURBS Surfaces
Splitting Objects and NURBS Surfaces with the Split Tool

Project and Trim

To trim a NURBS surface with a projection:

1. In the desired view, draw a 2D object or NURBS curve on top of a NURBS surface.

Objects ungrouped and 
separated for clarity
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If the object to be projected is an open NURBS curve or an open 2D object, both end points must be outside the 
NURBS surface.

2. Click the Project tool from the 3D Modeling tool set, and then select Trim from the Tool bar.
3. Click on the trimming object, and then click on the NURBS surface. The cursor changes into the pointing hand 

cursor. Click on the side of the intersection to be trimmed away.

The trimming object is projected onto the NURBS surface, and the region selected to be trimmed away is removed 
from the NURBS surface at the point of intersection, resulting in a group of NURBS surfaces.

~~~~~~~~~~~~~~~~~~~~~~~~~
Selecting the Edges and Faces of a Solid
Splitting or Trimming NURBS Surfaces

Project and Add

To add a projection to a NURBS surface:

1. In the desired view, draw a 2D object or NURBS curve on top of a NURBS surface.

The 2D object or NURBS curve must be closed and planar.
2. Click the Project tool from the 3D Modeling tool set.
3. Select Add from the Tool bar. Select the appropriate direction mode so that the projection direction intersects the 

NURBS surface (Add Upward, Add Downward, or Add Both Directions).
The projection direction must intersect with the NURBS surface, or no projection is created.

Select the project and trimming object Select the NURBS surface Select the region to be trimmed
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4. Click on the object to add; the projection direction is indicated by a red arrow. Click on the NURBS surface.

The object’s projection is added to the NURBS surface at the point of intersection, creating a generic solid.

~~~~~~~~~~~~~~~~~~~~~~~~~
Selecting the Edges and Faces of a Solid
Splitting or Trimming NURBS Surfaces

Creating a Rib
The Add mode of the Project tool can be used to create ribs.

To create a rib:

1. In the desired view, draw a 2D object or NURBS curve on top of a solid.

The 2D object or NURBS curve must be closed and planar.
2. Click the Project tool from the 3D Modeling tool set, and then select Add from the Tool bar.
3. Select the appropriate projection direction mode.
4. Click on the object to add, and then click on the solid.
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The rib profile is projected until it meets the next surface it encounters. The profile is trimmed at the extremities 
automatically.

~~~~~~~~~~~~~~~~~~~~~~~~~
Selecting the Edges and Faces of a Solid
Splitting or Trimming NURBS Surfaces

Extending NURBS Curves and Surfaces
NURBS curves and surfaces can be extended by a specified distance with the Extend NURBS command.

Closed NURBS curves and trimmed NURBS surfaces cannot be extended. In addition, a NURBS surface cannot 
be extended in the direction (U or V) that it is closed.

To extend a NURBS curve or surface:
1. Select the NURBS curve or surface to extend.
2. Select Model > 3D Power Pack > Extend NURBS.

The Extend NURBS dialog box opens. Select the end point (for NURBS curves) or edge (for NURBS surfaces) to 
extend. On the drawing, the selected edge or end point is displayed in red. Select the type of extension to make and 
specify the extension distance.

Click to show/hide the parameters.

Parameter Description

Select End Point/Edge Click the arrows to select the end point or edge to extend. The selected end point or 
edge is displayed in red on the drawing.

Linear Extension Extends the edge or end point tangentially 
Smooth Extension Extends the edge or end point by continuing the current curvature
Distance Specifies the extension distance
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3. Click Preview to check the extension, and then click OK to extend the NURBS curve or surface.

~~~~~~~~~~~~~~~~~~~~~~~~~
Selecting the Edges and Faces of a Solid
NURBS Curves and Surfaces

Creating Helix-Spirals
The Create Helix-Spiral command creates a helix-shaped or spiral-shaped 3D object from one or more path objects. 
The paths can be 2D objects or NURBS curves.
To create a helix or spiral:

1. Select the object(s) to use as the path. 
2. Select Model > 3D Power Pack > Create Helix-Spiral.

The Helix-Spiral Creation dialog box opens.
Click to show/hide the parameters.

Preview Click to see a preview of the extension in red

Parameter Description

Use Turns Select to create a helix/spiral by a specified number of turns along the path
Turns Enter the total number of turns to be created along the path

Use Pitch Select to create a helix/spiral by pitch
Pitch Enter the pitch value (the distance between successive turns)

Start Radius Enter the radius of the perpendicular starting circle
End Radius Enter the radius of the perpendicular ending circle. To create a helix, enter a value matching 

the start radius. To create a spiral, enter a different value.
Start Angle Enter the starting point of the twist on the starting circle
Reverse Direction Select to change the rotation direction of the helix/spiral from clockwise to 

counter-clockwise or vice-versa

Parameter Description

Linear Extension Smooth Extension

Smooth ExtensionLinear Extension
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3. Specify the object parameters, and click OK.
A helix or spiral is created.

A helix or spiral object can be used, without further conversion, as a path object for the Extrude Along Path 
command.
Ungrouping a helix-spiral object results in a NURBS curve.

Creating Contours
Contours are intersections of a solid or surface with a plane passing through the line specified with the Create 
Contours tool. This tool creates contours at specified intervals, which can then be used to create a loft surface in order 
to re-create a solid shape.

To create contours:

1. Click the Create Contours tool from the 3D Modeling tool set, and then select Preferences from the Tool bar to 
specify the contour interval.
To create a single contour, specify a Contour Increment of zero.

2. Click OK.
3. Click and drag to indicate the position of the intersecting plane.

The contours, a group of NURBS curves, are created.

Flatten Select to flatten the helix/spiral into a 2D spiral. Use Pitch is not available with this option.
Parameter Description

Spiral objectHelix object
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Direct Modeling with the Push/Pull Tool
The Push/Pull tool interactively reshapes planar geometry, creating bosses (protrusions) or cutouts on solids by adding 
or subtracting volume from a solid. The volume is created or subtracted by extruding a face in Extrude Face mode, 
including all the geometry present on a face in Move Face mode, or extruding a planar NURBS curve (or group of 
closed, non-intersecting NURBS curves) in Sub-Face mode.
Three modes are available.

To preserve the primitive profile geometry of an extrude, right-click (Windows) or Ctrl-click (Mac) on the extrude 
and select Edit from the context menu. See “Object Editing Mode” on page 1004.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Face-based Addition or Subtraction
Moving the Face of a Solid
Curve-based Addition or Subtraction
NURBS Curves and Surfaces

Face-based Addition or Subtraction
The Extrude Face mode creates perpendicular faces as volume is added or subtracted. Objects that can be modified 
include 2D planar objects, NURBS curves, and the planar face of any solid.

To add to or subtract from a solid in Extrude Face mode:

1. Click the Push/Pull tool from the 3D Modeling tool set, and then select Extrude Face from the Tool bar.
2. Click on the desired planar face, planar object, or NURBS curve.

If needed, the Select Face dialog box opens to help select the correct face, as described in “Selecting the Edges and 
Faces of a Solid” on page 324. To select the back faces of solids, press the Alt key (Windows) or Option key 
(Mac) while selecting. When the correct face is selected, click OK.

3. The cursor changes to a double-headed arrow. Move the cursor to expand (Add mode) or decrease (Subtract 
mode) the solid volume, or create an extrusion from the 2D planar object or NURBS curve. The cursor direction 
determines whether volume is added or subtracted. The distance of the protrusion or cutout can also be specified 
by entering a value in the Distance field on the Tool bar or floating data bar. The new solid is previewed on the 
drawing.

Mode Description

Extrude Face Selects the planar face of a solid, a 2D planar object, or NURBS curve, to add to or subtract 
volume, creating perpendicular faces

Move Face Extends the planar face of a solid, adding or subtracting the face along with any geometry 
present on the face

Sub-Face Selects a curve or group of curves to add to or subtract volume from a solid

Extrude Face Sub-Face

Move Face

http://www.youtube.com/watch?v=Y1YlhYbYpgQ&list=UUN7uzhu-ljLJOe6a0J-fBcQ
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4. Click at the desired location to edit the solid.
~~~~~~~~~~~~~~~~~~~~~~~~~
Direct Modeling with the Push/Pull Tool
Moving the Face of a Solid
Curve-based Addition or Subtraction 

Moving the Face of a Solid
The Move Face mode extends the face of a solid, extruding the surrounding or adjacent geometry as the face moves.

To move the face of a solid in Move Face mode:

1. Click the Push/Pull tool from the 3D Modeling tool set, and then select Move Face from the Tool bar.
2. Click on the desired planar face. 

If needed, the Select Face dialog box opens to help select the correct face, as described in “Selecting the Edges and 
Faces of a Solid” on page 324. To select the back faces of solids, press the Alt key (Windows) or Option key 
(Mac) while selecting. When the correct face is selected, click OK.

3. The cursor changes to a double-headed arrow. Move the cursor to extend the face and its geometry. The distance 
can also be specified by entering a value in the Distance field on the Tool bar or floating data bar. The new solid is 
previewed on the drawing.

4. Click at the desired location to edit the solid.

~~~~~~~~~~~~~~~~~~~~~~~~~
Direct Modeling with the Push/Pull Tool
Face-based Addition or Subtraction
Curve-based Addition or Subtraction 
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Curve-based Addition or Subtraction

To add or subtract from a solid in Sub-Face mode:

1. Click the Push/Pull tool from the 3D Modeling tool set, and then select Sub-Face from the Tool bar.
2. Select the NURBS curve or group of NURBS curves that will be used to create the protrusion or cutout, and then 

select the solid.
3. The cursor changes to a double-headed arrow. When an open NURBS curve is coplanar with the solid face and 

also splits the face of the solid, each split section can be moved individually. Move the cursor to expand (Add 
mode) or decrease (Subtract mode) the solid volume. The cursor direction determines whether volume is added 
or subtracted. The distance of the protrusion or cutout can also be specified by entering a value in the Distance 
field on the Tool bar or floating data bar. The new solid is previewed on the drawing.
In Subtract mode, the distance value can exceed the solid perimeter; the cutout operation is only performed on the 
selected solid.

 

4. Click at the desired location to edit the solid.
~~~~~~~~~~~~~~~~~~~~~~~~~
Direct Modeling with the Push/Pull Tool
Face-based Addition or Subtraction
Moving the Face of a Solid

Tapering Faces
The Taper Face tool tapers faces of solid objects to a specified angle, with respect to a selected reference plane. This 
allows you to quickly and easily explore different solid shapes.

Each coplanar face can be moved individually
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Two modes are available.

To taper a face of a solid:

1. Click the Taper Face tool from the 3D Modeling tool set, and then select a mode from the Tool bar.
2. Click to select an object or face of an object that will be used to determine the pivot point for the taper operation. 

This can be a 2D object such as a rectangle, the planar face of a solid (including the solid being tapered), or a 
planar NURBS curve or solid edge. Valid objects are highlighted when the cursor tracks over them.
Press the Alt (Windows) or Option (Mac) key to select an object or face that is behind another object.

3. Next, move the cursor to highlight the face to taper, and click to select it. In Tangent Faces mode, both the clicked 
face and the faces tangent to it are selected.
Press the Alt (Windows) or Option (Mac) key to select a back face of an object.

4. Drag to display a preview of the taper. Alternatively, to taper to a precise angle, press the Tab key and enter a 
negative or positive number in the Data bar; press Enter (Windows) or Return (Mac) to display a preview of the 
taper.

5. Click, or press Enter to complete the taper operation. The result is a generic solid object.

Mode Description

Tangent Faces Tapers the picked face and any faces that are tangent to it, as a group; for solids with curved sides
Picked Face Tapers only the picked face

Tangent Faces Picked Face

Click to select the 
reference plane object

Click to select the 
face to taper

Drag to the desired 
taper angle and click

Click 1

Click 2 Click 3
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Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Tapering a Solid or NURBS Surface

Deforming Solids and NURBS Surfaces
The Deform tool reshapes solid objects and NURBS surfaces to allow for easy exploration of sculptural shapes. The 
tool twists, tapers, bulges, and bends existing solid objects; the resulting objects are generic solids.

Five primary modes are available. Two additional modes are activated depending on the primary mode selected.

~~~~~~~~~~~~~~~~~~~~~~~~~
Twisting an Entire Solid or NURBS Surface
Twisting the Faces of a Solid
Tapering a Solid or NURBS Surface
Creating a Bulged Solid or NURBS Surface

Mode Description

Twist Solid Twists the selected solid or NURBS surface to a specified angle
Twist Face Twists the selected face and the adjacent and tangent faces of a solid to a specified angle
Taper Solid Tapers the selected solid or NURBS surface to a specified ratio
Bulge Solid Bulges the selected solid or NURBS surface according to a specified ratio
Bend Solid Bends the selected solid or NURBS surface to a specified angle
Symmetric Deforms the solid symmetrically
Finite Length Deforms the solid within the length specified by the bend spine; the portion of the shape beyond 

the bend spine maintains the original tangency

The original object is an 
extruded NURBS curve

In Tangent Faces mode, all of the 
side faces are tangent to each other, 
so they are tapered as a group

In Picked Faces mode, only 
the front face is selected and 
tapered

Twist Solid Finite Length 

Twist Face Bulge Solid Symmetric

Taper Solid Bend Solid

http://www.youtube.com/watch?v=lABAxpBHfgg
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Bending a Solid or NURBS Surface

Twisting an Entire Solid or NURBS Surface

To twist a solid or NURBS surface:

1. Click the Deform tool from the 3D Modeling tool set, and then select Twist Solid mode.
2. As you move the mouse over 3D objects, they are highlighted to indicate they can be modified. Click to select the 

solid or NURBS surface.
Shift-click to select more than one object to twist.

3. A protractor feedback graphic displays around the cursor. Position the protractor on the appropriate twist plane, 
and click at the center point of the twist.
The protractor graphic displays only when an object is selected. To position the protractor as desired, you may 
need to activate a specific plane using the Active Planes list on the View bar. 
The center point of the twist can be located away from the object being twisted.

4. The protractor graphic remains at the click point, and the twist axis line appears. As you move the cursor, the 
protractor rotates, and the twist reference line appears and previews the starting point for the twist. Click to place 
the reference line.

5. As you move the cursor, the twist angle line tracks the cursor, and a preview of the twisted object displays. 
Objects can be twisted more than 360 degrees.

6. Click to complete the operation. The result is a generic solid object.

~~~~~~~~~~~~~~~~~~~~~~~~~
Twisting the Faces of a Solid
Deforming Solids and NURBS Surfaces

In Twist Solid mode, the entire 
solid object is twisted

90° clockwise 450° clockwise

Click 1

Click 2
Click 3

Click 4
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Twisting the Faces of a Solid

To twist the faces of a solid:

1. Click the Deform tool from the 3D Modeling tool set, and then select Twist Face mode. A protractor feedback 
graphic displays around the cursor.

2. As you move the protractor over 3D objects, the faces to be twisted are highlighted. Position the protractor on the 
appropriate face, and click at the center point of the twist.
The protractor is oriented according to the face normal. Face mode twists the selected face and all adjacent and 
tangent faces as indicated by the highlight.

3. The protractor graphic remains at the click point, and the twist axis line appears. As you move the cursor, the 
protractor rotates, and the twist reference line appears and previews the starting point for the twist. Click to place 
the reference line.

4. As you move the cursor, the twist angle line tracks the cursor, and a preview of the twisted object displays. 
5. Click to complete the operation. The result is a generic solid object.

~~~~~~~~~~~~~~~~~~~~~~~~~
Twisting an Entire Solid or NURBS Surface
Deforming Solids and NURBS Surfaces

Tapering a Solid or NURBS Surface

In Twist Face mode, only the 
selected face and the adjacent 
and tangent faces are twisted

Click 1
Click 2

Click 3
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To taper a solid or NURBS surface:

1. Click the Deform tool from the 3D Modeling tool set, and then select Taper Solid mode. 
Symmetric mode is selected by default; a four-way arrow feedback graphic displays around the cursor, and an 
equal amount of taper applies to both the drag direction and its perpendicular direction. If an asymmetrical taper is 
desired, deselect Symmetric mode on the tool bar; a two-way arrow feedback graphic displays, and the taper 
applies only to the drag direction; its perpendicular direction has no taper.
The Symmetric mode status can also be changed at any time during the operation.

2. As you move the mouse over 3D objects, they are highlighted to indicate they can be modified. Click to select the 
solid or NURBS surface.
Shift-click to select more than one object.

3. A four-way or two-way arrow feedback graphic displays around the cursor. Position the arrow graphic at the 
desired taper center, and click.
The arrow graphic displays only when an object is selected. To position the arrows as desired, you may need to 
activate a specific plane using the Active Planes list on the View bar. 
The taper center can be located away from the object being tapered.

4. The arrow graphic remains at the click point, and the taper axis line appears. As you move the cursor, the arrows 
rotate to indicate the direction of the taper, and the taper reference line previews the starting point for the taper. 
Click to place the reference line.

5. As you move the cursor, the taper ratio line tracks the cursor, and a preview of the tapered object displays. 
To taper to a precise ratio, press the Tab key and enter a positive number in the Data bar. The original shape ratio 
is 1; numbers below 1 taper inward, while numbers above 1 taper outward. Press Enter to display a preview of the 
taper.

6. Click to complete the operation. The result is a generic solid object.

~~~~~~~~~~~~~~~~~~~~~~~~~
Tapering Faces
Deforming Solids and NURBS Surfaces

Click 1 Click 2
Click 3

Click 4

Symmetric taper Asymmetric taper
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Creating a Bulged Solid or NURBS Surface
The Deform tool’s Bulge Solid mode can be used to create a convex or concave shape.

To create a bulge in a solid or NURBS surface:

1. Click the Deform tool from the 3D Modeling tool set, and then select Bulge Solid mode. 
Symmetric mode is selected by default; a four-way arrow feedback graphic displays around the cursor, and an 
equal amount of bulge applies to both the drag direction and its perpendicular direction. If an asymmetrical bulge 
is desired, deselect Symmetric mode on the tool bar; a two-way arrow feedback graphic displays, and the bulge 
applies only to the drag direction; its perpendicular direction has no bulge.
The Symmetric mode status can also be changed at any time during the operation.

2. As you move the mouse over 3D objects, they are highlighted to indicate they can be modified. Click to select the 
solid or NURBS surface.
Shift-click to select more than one object.

3. A four-way or two-way arrow feedback graphic displays around the cursor. Position the arrow graphic at the 
desired bulge center and click.
The arrow graphic displays only when an object is selected. To position the arrows as desired, you may need to 
activate a specific plane using the Active Planes list on the View bar. 
The bulge center can be located away from the object being bulged.

4. The arrow graphic remains at the click point, and the bulge axis line appears. As you move the cursor, the arrows 
rotate to indicate the direction of the bulge, and the bulge reference line previews the starting point for the bulge. 
Click to place the reference line.

5. As you move the cursor, the bulge ratio line tracks the cursor, and a preview of the bulged object displays. 
To create the bulge to a precise ratio, press the Tab key and enter a positive number in the Data bar. The original 
shape ratio is 1; numbers below 1 bulge inward, while numbers above 1 bulge outward. Press Enter to display a 
preview of the bulge.

6. Click to complete the operation. The result is a generic solid object.

Click 1
Click 2

Click 3
Click 4
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~~~~~~~~~~~~~~~~~~~~~~~~~
Deforming Solids and NURBS Surfaces

Bending a Solid or NURBS Surface

To bend a solid or NURBS surface:

1. Click the Deform tool from the 3D Modeling tool set, and then select Bend Solid mode. 
Symmetric mode is selected by default; the bend applies to both the positive and negative direction of the bend 
spine. If an asymmetrical bend is desired, deselect Symmetric mode on the tool bar; the bend applies only to the 
positive direction of the bend spine. 
Finite Length mode is selected by default; the bend applies only to the finite length of the bend spine. To bend the 
entire object, deselect Finite Length mode on the tool bar.
The Symmetric mode and Finite Length mode status can also be changed at any time during the operation.

2. As you move the mouse over 3D objects, they are highlighted to indicate they can be modified. Click to select the 
solid or NURBS surface.
Shift-click to select more than one object.

3. A protractor feedback graphic displays around the cursor. Position the protractor on the appropriate bend spine 
starting point, and click. 
The protractor graphic displays only when an object is selected. To position the protractor as desired, you may 
need to activate a specific plane using the Active Planes list on the View bar. 

4. The protractor remains at the click point, and the protractor normal line appears. As you move the cursor, the 
protractor rotates and the bend spine appears; the line previews the bend spine’s end point. Click to place the bend 
spine.
If Finite Length mode is selected, the bend spine, which is defined by click 2 and click 3, delimits the section to 
bend.

5. As you move the cursor, the bend spine tracks the cursor, and a preview of the bent object displays. 

Symmetric bulge Asymmetric bulge
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To bend to a precise angle, press the Tab key and enter a negative or positive number in the Data bar; press Enter 
to display a preview of the bend.

6. Click to complete the operation. The result is a generic solid object.

~~~~~~~~~~~~~~~~~~~~~~~~~
Deforming Solids and NURBS Surfaces

Chamfering Solid Edges
The Chamfer Edge tool modifies the edge of a solid with a linear cross section. Edges are usually modified during the 
detailed design phase of a project to provide a more realistic or aesthetic appearance to a model.

To chamfer the edges of a solid:

1. Click the Chamfer Edge tool from the 3D Modeling tool set, and then select Preferences on the Tool bar.
The Chamfer Edge Preferences dialog box opens.

Click to show/hide the parameters.

Parameter Description

Setback Specify the distance by which the faces are set back
Alternatively, enter a value in the Setback field on the Tool bar

Select Tangent Entities Choose this option to select tangentially connected edges and faces for chamfering

Click 1

Click 2

Click 3

Click 4

Symmetric mode selected
Finite Length mode selected

Symmetric mode selected
Finite Length mode deselected

Symmetric mode deselected
Finite Length mode selected

Symmetric mode deselected
Finite Length mode deselected
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2. Enter your chamfer preferences, and click OK.
3. For tangent entity selections, select the tangentially connected edges and faces to be modified. For face selections, 

select the faces to be modified. To select multiple edges or surfaces, hold the Shift key while selecting. To select 
the back faces of solids, press the Alt key (Windows) or Option key (Mac).
See “Selecting the Edges and Faces of a Solid” on page 324 for information on selecting surfaces.
When Select All Edges is enabled, clicking on one of the highlighted edges selects all the edges for chamfering.

4. Press Enter or click the check mark button on the Tool bar to perform the edge modification.

The Setback value for the chamfered edge can be edited through the Object Info palette. 
Once the modification is complete, the edge set used to create the modification cannot be changed. The modified 
edge can be ungrouped, and a new modification with different edges can be created.
If one modification has been created over another, the first modification cannot be edited in the Object Info palette 
unless the last one is ungrouped (see “Editing a Fillet/Chamfer or Shell Object” on page 327).

A chamfer edge operation may fail due to any of the following:
• Complex surface geometry adjacent to an edge or corner involved in the modification
• An attempt to modify one edge in a sequence of tangential edges (select all the edges for a better chance of 

success)
• An attempt to modify without selecting all the edges at a vertex

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Filleting Solid Edges
NURBS Curves and Surfaces

Filleting Solid Edges
The Fillet Edge tool modifies the edge of a solid with a circular cross section. Edges are usually modified during the 
detailed design phase of a project to provide a more realistic or aesthetic appearance to a model.

To fillet the edges of a solid:

1. Click the Fillet Edge tool from the 3D Modeling tool set, and then select Preferences on the Tool bar.
The Fillet Edge Preferences dialog box opens.

Click to show/hide the parameters.

Select Faces Choose this option to select faces for chamfering
Select All Edges Selects all the edges of the solid for the chamfer operation

Parameter Description

Before chamfering After chamfering Results rendered

http://www.youtube.com/watch?v=Q8NhaHYXAnE
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2. Enter your fillet preferences, and click OK.
3. For tangent entity selections, select the tangentially connected edges and faces to be modified. For face selections, 

select the faces to be modified. To select multiple edges or surfaces, hold the Shift key while selecting. To select 
the back faces of solids, press the Alt key (Windows) or Option key (Mac).
See “Selecting the Edges and Faces of a Solid” on page 324 for information on selecting surfaces.
When Select All Edges is enabled, clicking on one of the highlighted edges selects all the edges for filleting.

4. Press Enter or click the check mark button on the Tool bar to perform the edge modification.

The Radius value for the filleted edge can be edited through the Object Info palette. For the fillet by variable radius, 
press the Edit arrow buttons to highlight each point along the edge for editing.

Once the modification is complete, the edge set used to create the modification cannot be changed. The modified 
edge can be ungrouped, and a new modification with different edges can be created.

Parameter Description

Select Tangent Entities Choose this option to select tangentially connected edges and faces for filleting
Constant Radius Create a filleted surface based on a constant radius

Radius Indicate the radius of the fillet edge
Alternatively, enter a value in the Constant Radius field on the Tool bar

Select Faces Choose this option to select faces for filleting
Select All Edges Selects all the edges of the solid for the fillet operation

Variable Radius Create a filleted surface based on a variable radius
Length (%) Enter the length up to the point as a percentage of the total edge length (for example, 50)
Radius Enter the radius value at the corresponding percentage of length value (for example, 1”)
Set Click to add a length/radius pair or modify the currently selected pair
Delete Click to delete the selected length/radius value
Reverse Reverses the order of the radius values; the radius values that were at the shortest 

percentage length are switched to the longest percentage length, and vice versa

Before filleting After filleting with a constant radius Results rendered

After filleting with a variable radius Results renderedBefore filleting
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If one modification has been created over another, the first modification cannot be edited in the Object Info palette 
unless both are first ungrouped (see “Editing a Fillet/Chamfer or Shell Object” on page 327).

A fillet edge operation may fail due to any of the following:
• Complex surface geometry adjacent to an edge or corner involved in the modification
• A radius value that is too large
• An attempt to modify one edge in a sequence of tangential edges (select all the edges for a better chance of 

success)
• An attempt to modify without selecting all the edges in a vertex

~~~~~~~~~~~~~~~~~~~~~~~~~
Chamfering Solid Edges
NURBS Curves and Surfaces

Creating a Shell from Solids, NURBS Surfaces, and Planar Objects
The Shell Solid tool creates a hollow shell from a solid object or gives thickness to NURBS surfaces and planar 
objects. Most injection-molded plastic parts have a shell.
~~~~~~~~~~~~~~~~~~~~~~~~~
Shell from a Solid Object
Shell from a NURBS Surface
Shell from a Planar Object
NURBS Curves and Surfaces

Shell from a Solid Object

To create a shell solid from a solid object:

1. Click Shell Solid from the 3D Modeling tool set, and then select Preferences on the Tool bar.
The Shell Solid Preferences dialog box opens.

Click to show/hide the parameters.

2. Enter your shell preferences, and click OK.
3. Click on the face of the object where the shell will be created. To select multiple surfaces, hold the Shift key while 

selecting. To select the back faces of solids, press the Alt key (Windows) or Option key (Mac).
See “Selecting the Edges and Faces of a Solid” on page 324 for information on selecting surfaces.

4. Press Enter or click the check mark button on the Tool bar to create the shell.

Parameter Description

Shell
Inside Creates an interior shell
Outside Creates an exterior shell

Thickness Enter the thickness of the shell wall
Alternatively, enter a value in the Thickness field on the Tool bar

Select Tangent Faces Selects a tangentially connected chain of faces
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Click here for a video tip on this topic (Internet connection required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Shell from a NURBS Surface
Shell from a Planar Object
Editing a Fillet/Chamfer or Shell Object
NURBS Curves and Surfaces

Shell from a NURBS Surface

To create a shell solid from a NURBS surface:

1. Click Shell Solid from the 3D Modeling tool set, and then select Preferences on the Tool bar.
2. Enter your shell preferences as described in “Shell from a Solid Object” on page 370, and click OK.

For NURBS surfaces, the Inside setting extends the shell solid in the opposite direction from the surface’s normal, 
and the Outside setting extends the shell solid in the direction of the surface’s normal.

3. Click on the NURBS surface to thicken. To select multiple surfaces, hold the Shift key while selecting.
4. Press Enter or click the check mark button on the Tool bar to create the shell.

~~~~~~~~~~~~~~~~~~~~~~~~~
Shell from a Planar Object
Editing a Fillet/Chamfer or Shell Object
NURBS Curves and Surfaces
Displaying Surface Normals

Shell from a Planar Object

To create a shell solid from a planar object:

1. Click Shell Solid from the 3D Modeling tool set, and then select Preferences on the Tool bar.
2. Enter your shell preferences as described in “Shell from a Solid Object” on page 370, and click OK.

For planar objects, the Inside/Outside setting determines on which side of the plane the shell solid will be 
extended; the direction depends on several factors related to the object’s creation, geometry, and placement in the 
document.

3. Click on the planar object to thicken. To select multiple objects, hold the Shift key while selecting.

http://www.youtube.com/watch?v=PewZWOhLXoE
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4. Press Enter or click the check mark button on the Tool bar to create the shell.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing a Fillet/Chamfer or Shell Object
Shell from a NURBS Surface

Stitching and Trimming Surfaces
The Stitch and Trim Surfaces command creates a generic solid from several intersecting surfaces (including NURBS 
surfaces or solids such as extrudes or sweeps).

This command may not be able to manipulate certain types of surface geometry. See “Surface Geometry 
Requirements” on page 327.

To stitch and trim intersecting surfaces:
1. Select the intersecting surfaces.

The surfaces must enclose a volume.
2. Select Model > 3D Power Pack > Stitch and Trim Surfaces.

The surfaces enclosing the volume are stitched together and then trimmed, resulting in a generic solid.

~~~~~~~~~~~~~~~~~~~~~~~~~
Selecting the Edges and Faces of a Solid
NURBS Curves and Surfaces
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Converting to Generic Solids
Solid objects created using such commands as Add Solid, Subtract Solid, and tools such as Fillet Edge, Chamfer 
Edge, and Shell Solid, contain a history composed of the original elements used to make the new object. This also 
includes any editing performed with other solids operations. The Convert to Generic Solids command removes this 
history from the solid objects, reducing the file size (though the object is no longer editable).
For example, use this command on a copy of the final drawing to reduce file size when sending a file to a print bureau.
To convert an object into a generic solid:

1. Select the solid object(s) to convert.
2. Select Modify > Convert > Convert to Generic Solids.
3. A warning dialog box opens. Click OK to convert the object(s).

The object is converted.
If objects are selected that cannot be converted, a dialog box opens stating that these objects have been deselected.

Unfolding Surfaces
The Unfold Surfaces command creates flattened, 2D representations of developable surfaces. A developable surface is 
curved in one dimension only, so that it is able to be flattened into a plane with no distortion. For example, cones and 
cylinders can be unfolded, but spheres cannot.
To unfold surfaces:

1. Select one or more developable NURBS surfaces or CSG objects that represent developable surfaces.
2. Select Model > 3D Power Pack > Unfold Surfaces.

A polyline in the shape of each unfolded surface is created and placed in the active layer. Each polyline has the 
same class and attributes as the surface from which it was created.
The Unfold Surfaces command works on a single NURBS surface or a solid containing tangentially-connected 
NURBS surfaces. If the item does not successfully unfold, use the Extract tool to extract a NURBS surface from 
the item, and unfold that surface.

Click here for a video tip about this topic (Internet access required).

Creating a Surface Array
The Create Surface Array command duplicates 2D or 3D geometry onto a planar object or NURBS surface. This 
allows you to easily create free-form surfaces with geometric patterns, curtain walls, open framework, and more.

http://www.youtube.com/watch?v=crcdsPLAgBM
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The following base surface objects are allowed.

The following table describes the types of objects that can be used as array items, as well as the method used to project 
the objects onto the base surface.

To create a surface array:
1. Select a planar object or NURBS surface to be the base of the array object. Optionally, also select the 2D or 3D 

geometry that will be duplicated on that surface (alternatively, edit the surface array object after creation to add the 
array geometry).

• Arc • Polyline

• Circle • Rectangle

• Oval • Rounded rectangle

• Polygon • NURBS surface

Array Item Projection Method

Solid
Sweep
Text

Project by center of bounding cube

Symbol instance Project by symbol origin
2D/3D Locus
Arc
Bitmap
Line
Oval
Polygon
Polyline
Rectangle
Rounded rectangle

Project by object definition points (the result is always a planar object)

Extrude/multi-extrude Project profile object by definition points
3D Poly
Extrude along path
Mesh
NURBS curve
NURBS surface

Project by each vertex (the result may not be planar)

Group Project member objects as described above; all members of the group must be legal 
array objects



Creating a Surface Array |  375
2. Select Model > Create Surface Array.
The Create Surface Array dialog box opens.

Click to show/hide the parameters.

Parameter Description

Select a base surface object If multiple objects were selected, by default, the largest object is highlighted in red, 
which indicates that it is selected to be used as the base surface. Click the Next or 
Prev button to highlight a different object. The buttons are unavailable if only one 
object was selected.

Origin X’ Factor Enter the X offset of the array pattern’s origin from the center of the base surface. 
The value must be a number between -1 and 1. For example, to shift each array 
item to the right by half of the item’s length along the X axis, enter 0.5.

Origin Y’ Factor Enter the Y offset of the array pattern’s origin from the center of the base surface. 
The value must be a number between -1 and 1. For example, to shift each array 
item down by a quarter of the item’s length along the Y axis, enter -0.25.

Pattern Rotation Enter a rotation angle for the array pattern
X and Y Repetition 
Parameters

For both the X and Y axes, specify how the array objects are to be repeated

Repetition Mode X’ / Y’ Select whether to repeat array objects on the base surface based on a No. of 
Repetitions, or a Fixed Distance per object

No. of Repetitions X’ / Y’ If Repetition Mode is set to Number of Repetitions, enter the number of times the 
array object is to be repeated along the X or Y axis. The array objects are resized as 
necessary to fit the base surface.

Fixed Distance X’ / Y’ If Repetition Mode is set to Fixed Distance, enter the length of each array object 
along the X or Y axis. The number of array objects is adjusted as necessary to fit 
the base surface.

Offset X’ / Y’ Factor Enter a number to control the space between the array objects. The distance from 
the center of one array item to the center of the next item (in the same row or 
column) is the factor times the array item’s size. For example, if the array item is 
12” total, and the Offset X’ Factor is 1.25, the distance from the center of one item 
to the next in the same row is 15” (12 x 1.25). If the offset factor is 1, the array 
items in that row or column touch each other; if the factor is negative, the array 
items overlap.

Shift X’ / Y’ Factor Enter a number to shift the position of the array objects from one row or column to 
the next. The distance from the center of one array item to the center of an array 
item in the next row or column is the factor times the array item’s size. For 
example, if the array item is 12” total, and the Shift Y’ Factor is 0.25, the distance 
from the center of one item to the center of the item to the right (in the next 
column) is 3” (12 x 0.25). If the shift factor is 0 (zero), the array items are aligned.

Edge Conditions Specify how to handle array objects that extend beyond the boundary of the base 
surface: allow the objects to Overlap the edge, Omit those objects from the array, or 
Trim the objects at the boundary

Display Base Surface Select whether to display or hide the base surface
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3. Enter the surface array parameters, and click OK to create the object.

Scale Z’ Value When selected, the array objects are automatically scaled along the Z axis, 
proportional to how much the objects are scaled along the X and Y axes (to fit the 
base surface). When deselected, the array objects have the same Z value as the 
original array item.

Parameter Description

The base surface is a yellow rectangle, and the 
array item is a blue extrude

Surface array with 5 repetitions along both the X and Y 
axes. Offset factors are set to 1, so there are no gaps 
between the array items. Shift factors are set to 0, so the 
array items are aligned.

No. of Repetitions set to X=7 and Y=4, and offset 
factor set to 1.5 for both X and Y axes

Shift X’ Factor set to 0.5, and Display 
Base Surface deselected

Origin Y’ Factor = 0;
the array is centered at 
the base surface origin

Origin Y’ Factor = 0.5;
the center of the array is 
offset above the origin by 
half the width of an array 
item

Origin Y’ Factor = 1;
the center of the array is 
offset above the origin 
by the full width of an 
array item
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Click here for a video tip about this topic (Internet access required).

Editing a Surface Array
After a surface array has been created, you can edit its properties from the Object Info palette. All of the parameters 
that are available during the array creation can be changed. You can also change which side of the base surface the 
array is applied to (Switch Z’ Direction).
You cannot edit the surface array geometry directly; use the Edit Surface Array command to edit the base surface and 
array components individually.
To edit a base surface or array item:

1. Select the surface array, and then select Modify > Edit Surface Array.
2. From the Choose component dialog box, select whether to edit the base surface or the array items.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the surface array and select Edit Base Surface or Edit 
Array Items from the context menu.

3. The Edit window displays the item to be edited. A colored border around the drawing window indicates the 
editing mode is active.

4. Reshape the geometry, change the attributes, and move, add, or remove items as needed. Keep in mind that only 
one item can be used as the base surface. Also, the base surface and array item(s) must be one of the allowed 
objects types described previously.

5. Click the Exit button in the top right corner of the drawing window to return to regular drawing mode and update 
the surface array.

~~~~~~~~~~~~~~~~~~~~~~~~~
Object Editing Mode

Creating Auto Hybrid Objects
Converting 3D geometry into an auto hybrid object allows the object to appear as desired in 2D plan view, while 
leaving the 3D appearance unchanged. This is particularly important for Building Information Model (BIM) workflows 
and for those who model free-form 3D geometry, but need plan drawings as well. The auto hybrid’s settings provide 
complete control over its 2D display attributes, with separate, classed parameters for the appearance of the cut plane 
and extents below and above the cut plane.

Scale Z’ Value deselected Scale Z’ Value selected

Original array 
item geometry

http://www.youtube.com/watch?v=iZtMpNzJj70
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To create an auto hybrid object:
1. Select the 3D geometry to convert to an auto hybrid object. 

Valid objects include: extrudes, tapered extrudes, multiple extrudes, extrude along path objects, 3D polygons, 
sweep objects, meshes, solids, NURBS surfaces, and 3D-only symbols and 3D plug-in objects.

2. If not in Top/Plan view, select View > Standard Views > Top Plan.
The auto hybrid’s 2D appearance settings are only visible in Top/Plan view.

3. With the object selected, select the Create Auto Hybrid command from the appropriate menu:
• Architect workspace: AEC > Create Auto Hybrid 
• Landmark workspace: Landmark > Architectural > Create Auto Hybrid 
• Spotlight workspace: Spotlight > Architectural > Create Auto Hybrid 

4. The object is converted into an auto hybrid.
5. To set the location of the cut plane and specify the appearance of the auto hybrid, click 2D Appearance from the 

Object Info palette.
The 2D Appearance dialog box opens. Click on the Cut Plane tab and set the desired parameters.

Click to show/hide the parameters.

Parameter Description

Elevation Sets the elevation of the cut plane; the cut plane is the intersection of an imaginary 
XY plane and the object geometry. Specify whether the elevation is relative to the 
layer, or to the story (Vectorworks Architect required). The cut plane is set to this 
fixed elevation and does not move with the object; instead, if you move the object’s 
elevation, the cut plane displays in a different location along the object. If the cut 
plane does not intersect the object, the cut plane does not display, but the object does.

Display Cut Plane Select to display the cut plane of the auto hybrid object
Class Select the class to use from the current list of classes, select New to create a new 

class, or select <Contained Object Class(es)> to place the cut plane in the same 
class(es) as the 3D contained object(s).

Fill
None Uses no fill for the cut plane
Use 2D Attributes of 
Contained Object(s)

Uses the fill attributes of the original converted object(s) for the cut plane

Extents below 
cut plane Cut plane

Extents above 
cut plane

Auto hybrid object in Top/Plan view
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6. Click on the Below Cut Plane/Above Cut Plane tabs to set the appearance of the auto hybrid below/above the cut 
plane.

Click to show/hide the parameters.

Use Class 2D Attributes Uses the Class selection for the cut plane fill attributes
Pen

Use 2D Attributes of 
Contained Object(s)

Uses the pen attributes of the original converted object(s) for the cut plane

Use Class 2D Attributes Uses the Class selection for the cut plane pen attributes
Show as Reflected Ceiling 
Plan

When selected, displays all the auto hybrid geometry as if looking up, rather than 
looking down; applies to all tabs

3D Conversion Resolution Sets the segmentation resolution used to display curved portions of the auto hybrid; 
this setting is independent of the 3D conversion resolution Vectorworks preference 
and applies to all tabs

Smoothing Angle When Display Extents Below/Above Cut Plane is selected on either the Below Cut 
Plane or Above Cut Plane tab, set a value to reduce the number of facets displayed in 
the geometry. For values greater than zero, facet lines are removed between any two 
faces of an object that are within that degree angle of each other; applies to all tabs.

Generate Intersecting 
Lines

When Display Extents Below/Above Cut Plane is selected on either the Below Cut 
Plane or Above Cut Plane tab, select to generate lines between intersecting geometry 
or deselect to omit intersecting lines; applies to all tabs.

This option may make generating an auto hybrid object slower.
Save Current Settings as 
Defaults

Applies the current settings from all tabs as default parameters when creating auto 
hybrid objects

Parameter Description

Display Extents Below/
Above Cut Plane

Select to display the extents of the object below/above the cut plane

Range Choose how much of the object to display
Infinite Displays the entire object below/above the cut line
Finite Depth/Height Displays the object below the cut line up to the specified depth/above the cut line up to 

the specified height

Parameter Description

Original Top/Plan view of 
office chair (comprising 90 
meshes)

Office chair auto hybrid 
object with Smoothing 
Angle setting = 5°
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Class Select the class to use from the current list of classes, select New to create a new class, or 
select <Contained Object Class(es)> to place the object below/above the cut plane in the 
same class(es) as the 3D contained object(s)

Fill
None Uses no fill for the area below/above the cut plane
Use 2D Attributes of 
Contained Object(s)

Uses the fill attributes of the original converted object(s) for the area below/above the cut 
plane

Use Class 2D Attributes Uses the Class selection for the fill attributes of the area below/above the cut plane
Pen
Use 2D Attributes of 
Contained Object(s)

Uses the pen attributes of the original converted object(s) for the area below/above the 
cut plane

Use Class 2D Attributes Uses the Class selection for the pen attributes of the area below/above the cut plane
Dashed Hidden Line 
(Below Cut Plane only)

Select to display a dashed hidden line representation of the geometry below the cut plane

Dash Style When Display Extents Below Cut Plane and Dashed Hidden Line are selected, select 
the dash style for the hidden line display.

The default dash style is the same as the document default for hidden line rendering.
Dash Shade When Display Extents Below Cut Plane and Dashed Hidden Line are selected, select 

the dash shade for the hidden line display.
The default dash shade is the same as the document default for hidden line 
rendering.

Include Hidden Lines 
(Above Cut Plane only)

Select to display the hidden lines of the geometry above the cut plane

Show as Reflected 
Ceiling Plan

When selected, displays all the auto hybrid geometry as if looking up, rather than looking 
down; applies to all tabs

3D Conversion 
Resolution

Sets the segmentation resolution used to display curved portions of the auto hybrid; this 
setting is independent of the 3D conversion resolution Vectorworks preference and 
applies to all tabs

Smoothing Angle When Display Extents Below/Above Cut Plane is selected, set a value to reduce the 
number of facets displayed in the geometry. For values greater than zero, facet lines are 
removed between any two faces of an object that are within that degree angle of each 
other; applies to all tabs.

Parameter Description

Top/Plan view of auto 
hybrid object with Dashed 
Hidden Line selected 

Mesh object in Top/Plan 
view
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7. Click OK.

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing an Auto Hybrid Object

Editing an Auto Hybrid Object
The properties and 2D appearance of an auto hybrid object can be edited from the Object Info palette. You cannot edit 
the 3D geometry contained in the auto hybrid geometry directly; use the Edit Auto Hybrid command to edit the 
geometry.
To edit an auto hybrid object:

1. Select the auto hybrid object, and then select Modify > Edit Auto Hybrid.
Alternatively, right-click (Windows) or Ctrl-click (Mac) on the auto hybrid and select Edit from the context menu, 
or simply double-click on the auto hybrid object.

2. The Edit window displays the item to be edited. A colored border around the drawing window indicates the 
editing mode is active.

3. Reshape the geometry, change the attributes, and perform any solid operations as needed. 
4. Click the Exit Auto Hybrid button in the top right corner of the drawing window to return to regular drawing 

mode and update the auto hybrid.
5. On the Object Info palette, the elevation of the cut plane can be easily changed, and the auto hybrid can be set to 

display in 2D views only, or in both 2D and 3D views. Only auto hybrids with 3D geometry are exported to IFC.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Auto Hybrid Objects
Object Editing Mode

Generate Intersecting 
Lines

When Display Extents Below/Above Cut Plane is selected, select to generate lines 
between intersecting geometry or deselect to omit intersecting lines; applies to all tabs.

This option may make generating an auto hybrid object slower.
Save Current Settings 
as Defaults

Applies the current settings from all tabs as default parameters when creating auto hybrid 
objects

Parameter Description

Modeled wall in 3D Original plan view of modeled wall Modeled wall converted to auto hybrid

http://www.youtube.com/watch?v=5QymidUZicI
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Text
Inserting Text
Use the Text tool to create both single lines and blocks of text in your drawings. Once created, text objects can be 
moved, duplicated, duplicated in an array, and rotated. The text bounding box can be resized to adjust a block’s height 
or width. Text is placed relative to the specified alignment point, not the bounding box.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Default Text Attributes
Creating a Line of Text
Creating Text Blocks
Creating Rotated Text
Creating Text with a Tight Fill
Adding Tabs to Text
Pasting Text
Modifying Text
Checking Spelling
Finding and Replacing Text
Using Text Styles

Setting the Default Text Attributes
The default text attributes are applied to all text as it is added in the current drawing or any other. A text style applies a 
saved group of attribute settings. Select a text style as the default, or leave the text un-styled and set the default text 
attributes individually.

Text styles can also be assigned to classes, to make it easier to create a consistent look for text that is embedded in 
dimensions, callouts, and other annotation objects.

To set the default text attributes:
1. Ensure that no objects or text are selected in the drawing.

Mode Description

Horizontal Creates horizontal text lines and text blocks
Rotated Creates text blocks at an angle
Tight Fill If a fill is applied to the text object, the fill displays only behind the text on any given line; 

blank lines have no fill
Text Style list Applies a stored set of attributes to text as it is created, including the font, size, spacing, font 

style, alignment, and color

Horizontal Text Style list

Rotated Tight Fill
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If needed, click the selection arrow on an empty portion of the drawing.
2. Click the Text tool from the Basic palette.
3. From the Tool bar, set the Tight Fill mode as desired.
4. To set the default appearance of text, do one of the following:

• From the Tool bar, select any Text Style other than <Un-Styled>.
• From the Tool bar, select the <Un-Styled> Text Style. Then from the Text menu, either select Format Text to 

set several attributes from one dialog box, or select individual options as desired. See “Formatting Text” on 
page 389 for descriptions of the available options.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Line of Text
Creating Text Blocks
Creating Rotated Text
Creating Text with a Tight Fill
Using Text Styles

Creating a Line of Text
Use the Text tool to create a single line of text, such as a page header.

To type a single line of text:

1. Click the Text tool from the Basic palette, and select Horizontal from the Tool bar.
2. From the Tool bar, set the Tight Fill mode and Text Style as desired.
3. Click to designate the text insertion point; a text editing box with a blinking cursor displays.
4. Enter the text. Text wrapping is off by default, so the text box automatically expands as you type.
5. When the text line is complete, press the Esc key.

~~~~~~~~~~~~~~~~~~~~~~~~~
Modifying Text
Setting the Default Text Attributes
Creating Text Blocks
Creating Rotated Text
Creating Text with a Tight Fill
Using Text Styles

Creating Text Blocks
Use the Text tool to create a block of text, when more than a line of text is necessary.

To create a block of text:

1. Click the Text tool from the Basic palette, and select Horizontal from the Tool bar.
2. From the Tool bar, set the Tight Fill mode and Text Style as desired.
3. Click and drag to create a text box of the approximate width needed.

A text editing box with a blinking cursor displays. The position of the text cursor indicates the horizontal 
alignment of the text to be placed.
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4. Enter the text. Text wrapping is on by default, so the text automatically wraps to the next line when it reaches the 
edge of the text box. To end the current paragraph and start a new one in the current text block, press Enter.

5. When the text block is complete, press the Esc key.
~~~~~~~~~~~~~~~~~~~~~~~~~
Adding Tabs to Text
Modifying Text
Setting the Default Text Attributes
Creating a Line of Text
Creating Rotated Text
Creating Text with a Tight Fill
Using Text Styles

Creating Rotated Text
The Rotated mode of the Text tool creates text at an angle. Text objects can also be rotated after they are created; see 
“Rotating Objects” on page 1022 for details.

To create rotated text:

1. Click the Text tool from the Basic palette, and select Rotated from the Tool bar.
2. From the Tool bar, set the Tight Fill mode and Text Style as desired.
3. Click and drag the mouse to specify the angle and width of the text box, and release the mouse button to set. If 

needed, move the mouse to adjust the text box position along a line perpendicular to the text box. Click again to 
set the position.
When drawing in rotated plan view (Vectorworks Design Series required), set angle snapping to snap to the plan 
rotation angle (see “Angle Snapping” on page 136) and display the Rotated Plan cue. If the text is created to the 
same angle as the plan, when the plan is unrotated, the text will align with the world coordinate system.

4. A text editing box with a blinking cursor displays.
To always create and edit rotated text in a horizontal text box, select Edit text horizontally by default on the Edit 
tab of the Vectorworks preferences (see “Edit Preferences” on page 49).

5. Enter the text. The text automatically wraps to the next line when it reaches the edge of a text box. To end the 
current paragraph and start a new one in the current text block, press Enter.

6. When the text block is complete, press the Esc key.

~~~~~~~~~~~~~~~~~~~~~~~~~
Adding Tabs to Text
Modifying Text

Release

Click and drag; release the 
mouse button to set the box 
width and angle

Move the mouse to adjust the box 
position along the red perpendicular 
line; click again to set the position

Click 1

Click 2

Enter the text

Click to make the box 
horizontal temporarily
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Setting the Default Text Attributes
Creating Text Blocks
Creating a Line of Text
Using Text Styles

Creating Text with a Tight Fill
The Tight Fill mode of the Text tool modifies the fill applied to a text object so that the fill displays only behind the text 
on any given line. Blank lines have no fill.

To create text with a tight fill:

1. Click the Text tool from the Basic palette, and select Tight Fill from the Tool bar.
2. From the Tool bar, select either the Horizontal or Rotated mode, and set the Text Style as desired.
3. From the Attributes palette, select the fill for the text object (unless the selected text style has a background fill).
4. Click and drag to create a text box of the approximate width needed.

A text editing box with a blinking cursor displays. The position of the text cursor indicates the horizontal 
alignment of the text to be placed.

5. Enter the text. The text automatically wraps to the next line when it reaches the edge of a text box. To end the 
current paragraph and start a new one in the current text block, press Enter.

6. When the text block is complete, press the Esc key.

~~~~~~~~~~~~~~~~~~~~~~~~~
Adding Tabs to Text
Modifying Text
Setting the Default Text Attributes
Creating Rotated Text
Using Text Styles

Adding Tabs to Text
Left-aligned tabs can be inserted into text during creation and editing.

To add tabs to text:

1. Click the Text tool from the Basic palette.
2. Enter or edit the desired text; press the Tab key to place tabs within the text where needed.
3. On the text box ruler, by default one tab stop is defined and displays with a black marker (at 0.5 inch for Imperial, 

or at 12.5 mm for Metric documents). Additional gray tab stops display at regular intervals to the right of the black 
tab stop. Adjust the tab stops as follows:
• Click and drag a black tab stop to adjust its location.

Text with a yellow tight fill on top of 
an oval with a pattern fill
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• The spacing between the gray tab stops adjusts automatically as you move the left-most black tab stop. The 
gray tab stops display to the right of the right-most black tab stop.

• To have more control over the spacing between tab stops, click anywhere on the ruler to create one or more 
new black tab stops. Black tab stops can be moved independently.

• To remove a black tab stop, drag it off the ruler. If there is only one black tab stop, it cannot be deleted.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Text Blocks
Creating Rotated Text

Pasting Text
To move text between Vectorworks files, select Edit > Copy, and then Edit > Paste. Text is added exactly as copied, 
including any formatting. If you define a text block before pasting, the text pasted into the block is wrapped to fit 
within the text block. If the scale of the original layer and the new layer are different, the text size changes accordingly; 
for example, if you copy 16 point text from a 1:1 layer and paste it to a 4:1 layer, the text changes to 4 points. This also 
means that any styled text you paste to a different layer scale becomes un-styled; reapply the text style to restore the 
proper text size.
When you paste text from a different program, click on the drawing using the Text tool first. If you paste text without 
first establishing an insertion point, each line of text is brought in as an individual text block. Embedded graphics are 
not supported and are removed when the text block is pasted into the Vectorworks file. In addition, multi-aligned text is 
converted to the current default alignment.

Modifying Text
Once a text object is created, you may need to make changes, such as add words, change the font color, or change the 
margins. Changes can be applied to a portion of the text or to the whole object. A text object can even be converted into 
polylines and extruded, or converted to a 3D path object. Depending on what changes are required, either select the text 
object with the Selection tool or activate the text editing mode.

Text Editing Mode
To add, edit, or delete text in a text box, or to change the attributes of a portion of the text, the text editing mode must 
be active. To activate editing mode, double-click on the text object with the Selection tool, or click on it with the Text 
tool. Alternatively, right-click (Windows) or Ctrl-click (Mac) the text, and select Edit from the context menu.
Editing mode is indicated by a purple highlighted box with a ruler at the top. The units on the ruler reflect the current 
document units and layer scale.

Gray tab stops move automatically when the
left-most black tab stop moves

Click and drag a black tab stop to move it
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The standard keyboard shortcuts for Mac and Windows apply in the text editing box. For example, use Command+B 
(Mac) or Ctrl+B (Windows) to apply bold formatting.

• On Mac, and on Windows systems where GDI+ imaging is enabled, rotated text can be edited in place, or you can 
use the rotation button on the right side of the text editing box to display the text box horizontally for easier 
editing.

• If GDI+ imaging is disabled on Windows, rotated text automatically switches to a horizontal position in editing 
mode. The text box also switches position automatically if the current view is not Top/Plan.

When the edits are complete, press the Esc key.

Editing Text Objects
To edit the properties of a text object (such as font or spacing), select it with the Selection tool. An X displays at the 
text alignment point. If the Wrap Text option is enabled, a triangular margin marker displays along the right, left, or 
both margins, depending upon the alignment setting.
Once the text object is selected, you can move it, or change the object’s properties, such as alignment or text style.

 

The text object can also be resized and rotated similar to other 2D objects, using the reshape handles.

Click the rotation 
button to unrotate or 
re-rotate the text box

Alignment Point Margin Marker
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~~~~~~~~~~~~~~~~~~~~~~~~~
Formatting Text
Changing Other Text Features
Converting Text to Polylines
Creating Text Along a Path
Checking Spelling
Finding and Replacing Text

Formatting Text
The Format Text command modifies multiple text attributes from a single dialog box. Individual attributes also can be 
changed with various commands on the Text menu, including font, size, font style, alignment, spacing, and 
capitalization (lower case, UPPER CASE, and Title Caps). All attributes are available on the Object Info palette, as 
well. Some objects have the ability to select the font formatting while setting the object attributes.
Formatting can be applied to an entire text block or to selected characters and words. If no text is selected, the settings 
become the defaults for the Text tool.
To quickly apply the same set of text attributes to several objects, set up a text style. You can apply the text style to 
objects directly, or you can assign the text style to a specific class. See “Using Text Styles” on page 393 for details.
To format text:

1. To select the text to change, do one of the following:
• To format the entire text box, select the text object with the Selection tool.
• To format a word, double-click the text object to activate the editing mode; then double-click anywhere within 

the word to highlight it.
• To format a line, double-click the text object to activate the editing mode; then triple-click anywhere within the 

line to highlight it.
• To format a section of the text, double-click the text object to activate the editing mode; then highlight the 

desired text by dragging over it.
To exit the text editing mode when text is highlighted, press the Esc key.

2. Once the text is selected, do one of the following:
• From the Text menu, select the text option to change.
• Select the option to change from the Object Info palette.
• Select Text > Format Text. Alternatively, right-click (Windows) or Ctrl-click (Mac) the text, and select 

Format Text from the context menu. The Format Text dialog box opens.
Click to show/hide the parameters.

Drag the middle handle left
to widen the text box;

the height adjusts
automatically

Press the Alt (Windows) or
Option key (Mac) while

dragging a handle to rotate
the text box
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Recent Font List
Recently used fonts are stored for quick access. When you select Text > Font, the eight most recently used fonts 
display at the top of the font list (with the most recent font listed first), followed by an alphabetical list of all available 
fonts. In addition, when the Object Info palette contains a Font field, the top of the drop-down list is populated with the 
eight most recently used fonts, followed by an alphabetical list of the available fonts. Fonts changes made within the 
Format Text dialog box or Object Info palette also update the recent font list.

Transferring Formats with the Eyedropper Tool
Use the Eyedropper tool to quickly copy text formats from one text object and apply them to another object. See 
“Transferring Attributes” on page 1095.
~~~~~~~~~~~~~~~~~~~~~~~~~
Changing Other Text Features
Converting Text to Polylines

Parameter Description

Style Displays the style of the currently selected item(s). If multiple items with different styles are selected, 
<Un-Styled> is selected.
Select a style from the list; the remaining parameters change to match the settings for that style. If you 
change any of the other parameters after selecting a style, the style reverts to <Un-Styled>.

Save Opens the Assign Name dialog box to save the current settings as a new style. Enter a name for the 
style and click OK.

The new style is automatically assigned the current solid pen and fill color that are set as the 
default for new objects in the Attributes palette.

Font Displays the font of the currently selected item(s) and lists all available, installed fonts. This field is 
blank when multiple items with different fonts are selected.
Select a font from the list, or type the first letter(s) of the desired font to highlight the closest match in 
the list.

Size Displays the size and unit measurement (points, millimeters, or inches) of the currently selected 
item(s). This field is blank when multiple items with different size/unit measurement are selected.
Enter a size and select a unit measurement (points, millimeters, or inches). 

Spacing Displays the line spacing of the currently selected item(s). If multiple items with different spacing are 
selected, Other is selected.
Select one of the standard spacing options, or select Other and specify a size and unit measurement 
(points, millimeters, or inches) of your own.

Font Style Displays the font style of the currently selected item(s). If multiple items are selected and they have 
different settings for a particular style, the selection box displays an indeterminate state:

 (Windows) or  (Mac).
Specify the desired options. Outline and Shadow options are available for Mac only. Superscript and 
Subscript are disabled when the entire text block is selected.

Alignment Displays the alignment of the currently selected item(s). If multiple items with different alignments are 
selected, the Alignment fields are blank.
Specify the horizontal and vertical alignment.

Preview Previews text font, size, and style
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Changing Other Text Features
In addition to text format, other text features can be modified as needed.

• Use the Capitalization command to set all letters to lowercase, uppercase, or title case. Select the text and then 
select Text > Capitalization.

• Use the Attributes palette to apply color to text. Select the text and then choose a solid pen color.
• Use the Attributes palette to apply a fill to a text box. Select the text box and then choose a fill style and/or solid 

fill color. Add lines or spaces before and after the text to extend the box.
• Use the Attributes palette to apply opacity to both the text and fill of a text object. Select the text box and then 

choose an opacity setting.
• Use the Object Info palette to change the following text features.

• Use one of various methods to rotate a text box. Select the text box and then use the Rotate command, Rotate 
tool, or Selection tool. See “Rotating Objects” on page 1022 for details.

Setting Special Text Sizes
To change text to a different standard size, you can select a size from either the Text menu or the Object Info palette. To 
set a non-standard text size, such as 60 pt, or 1 page inch, use the Set Size command.
To specify the text size:

1. Select Text > Size > Set Size. Alternatively, select Set Size from the Size list on the Object Info palette.
The Set Text Size dialog box opens.

2. Select the desired unit of measure, enter the font Size, and then click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
The Attributes Palette
Formatting Text

Converting Text to Polylines
The Convert Text to Polylines command converts text created with TrueType or OpenType fonts into polylines. After 
it is converted, the text is no longer a font and can be edited just like any other polyline. This is useful for creating 3D 

Object Info Palette Field Change

X and Y Moves the text box along the X and Y axis
Width Adjusts the text box width
Rotation Rotates the text box
Wrap Text Enables or disables text wrapping
Tight Fill For filled text objects, enables or disables the tight fill option
Tracking Adjusts the horizontal spacing between the selected characters. To change the spacing for 

all characters, select the text object. To change the spacing for specific characters, 
double-click the text object to enter editing mode, and then select the characters to 
change.
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text objects. By their nature, TrueType and OpenType fonts are defined by Bézier curves and arc points. These same 
definitions are used to convert the text objects.

The text conversion is not affected by the conversion resolution setting in the Vectorworks Preferences dialog box. 
However, if the converted polyline is extruded, the 3D resolution setting in this same dialog box affects how the 
polyline is extruded.

To convert text to polylines:
1. Select the text (lines or blocks) to convert.
2. Select Text > Convert Text to Polylines.

The text is converted into a group of polylines.
3. To extrude the polylines, creating 3D text, select the group of polylines. Ungroup them by selecting Modify > 

Ungroup.
4. Select all of the individual polylines and select Model > Extrude.

The Create Extrude dialog box opens.
5. Specify the extrusion length and click OK.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Text Along a Path

Creating Text Along a Path
The Text Along Path command converts text created with TrueType or OpenType fonts into polylines, and places 
them along a specified path. The appearance of the path object can be adjusted after placement.
To create 3D text along a path:

1. Select the text and a path object. The text must be a single line, and the path must be long enough for the text, or 
text along path conversion will not occur.

2. Select Text > Text Along Path.
The Text Along Path dialog box opens. Specify the options for creating the text along the path.

Click to show/hide the parameters.

Parameter Description

Text Size Specifies text size options
Preserve Height 
and Width

Maintains the aspect ratio of the text, keeping width and height parameters the same as they 
were in the original text

Scale Width Only Changes the width of the text to fit the path, but does not change the height accordingly 
(resulting in wider, shorter text, depending on the path)

Scale Height and 
Width

Changes the width of the text to fit the path, and then changes the text height to match 
(resulting in wider, tall text, depending on the path)

Create Text As Specifies the format for converting the text
Curves Converts the text into a group of polylines (if the path is drawn on the active layer plane) or 

NURBS curves (if the path has a Z height or a Rot about Path greater than 0)
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3. Click OK. The selected text follows the path object, and the original path object is deleted. 

The Text Along Path parameters can be edited in the Object Info palette. The parameters are identical to those in 
the Text Along Path dialog box, with two additional parameters.

Click to show/hide the parameters.

To edit the path object, select Modify > Edit Text Along Path, and then select Path. The path object can be edited 
with the Reshape tool. To reverse the direction of the path object, click Reverse Direction; this affects the text 
placement above or below the path.

~~~~~~~~~~~~~~~~~~~~~~~~~
Converting Text to Polylines

Using Text Styles
A text style is a resource that specifies text attributes, including the font, size, line spacing, font style, text alignment, 
and text and background colors. Text styles make it easy to apply a consistent look to all text throughout a file; if you 
change a text style, all objects that use the style are updated at once. A text style can be applied to objects created with 
the Text tool, as well as to the text portions of other objects, such as dimensions, callouts, and other annotation objects.

Not all features or plug-in objects can make use of a text style. For example, worksheets and space objects have 
text components, but they cannot use text styles.

A text style can also be part of a class definition, so that all items in that class have the same style. This makes it easy to 
apply the same text style to all dimensions, for example. See “Setting Class Properties” on page 179.
Some basic text styles are provided with the Vectorworks program as default content; these display on the Text Style 
list on the Tool bar when the Text tool is active. In addition, you can create custom text styles for your own use, or to 
share with coworkers. Because they are resources, text styles can be exported and imported into another file, copied 
among files, and shared via workgroup referencing. For more information about default content, see “Resource 
Libraries” on page 219. For more information about using custom resources, see “Accessing Existing Resources” on 
page 229 and “Creating Resource Libraries” on page 220.

Click here for a video tip about this topic (Internet access required).

Surfaces Converts the text into a group of NURBS surfaces
Extrusions Converts the text into a group of extrude objects; specify the Height of the extruded letters

Parameter Description

Above Path Places the bounding box of the letters directly above the path; “above” depends on the direction 
that the path was drawn. Deselect this option to place the letters “below” the path. Depending on 
the path and letters, the appearance of the text may be improved by switching it above or below 
the path.

Rot About Path Indicates the angle of rotation about the path, using the path as a rotation axis

Parameter Description

http://www.youtube.com/watch?v=DN7hxDDxHoA
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Creating Text Styles
Create custom text styles as needed. These are saved with the current file, and they can also be exported into other files 
or added to resource libraries.
To create a new text style:

1. Do one of the following:
• In the Resource Browser, select Resources > New Resource; select Text Style from the list of resource types.
• Click the Text tool from the Basic palette, and select New from the Text Style list on the Tool bar.
The Create Text Style dialog box opens.
Alternatively, select Text > Format Text to open the Format Text dialog box. Set the parameters as needed, click 
Save, and enter a name for the new style. See “Formatting Text” on page 389.

Click to show/hide the parameters.

2. Click OK to create the resource.
The new text style is saved with the file and displays in the Resource Browser under Text Styles. Text styles also 
display on the Tool bar when the Text tool is active, and on the Object Info palette when an object that uses text 
styles is selected.

Applying Text Styles
Text styles can be applied from several different places in the Vectorworks program. They can be applied to text 
objects, or to the text portions of several other objects, such as dimensions, callouts, and other annotation objects.

• From the Resource Browser, drag and drop a text style onto an object.
• Select all or part of a text object, or another object that uses text styles, and select a Text Style from the Object 

Info palette.
• Add a text style to a class definition, and then apply that class to an object.
• Select all or part of a text object, or another object that uses text styles, select Text > Format Text, and then select 

a Style from the Format Text dialog box.

Parameter Description

Style Name Enter a name for this text style
Font Select a font from the list, or type the first letter(s) of the desired font to highlight the closest match 

in the list
Size Enter a size and select a unit measurement (points, millimeters, or inches)
Spacing Select one of the standard spacing options, or select Other and specify a size and unit measurement 

(points, millimeters, or inches) of your own
Font Style Specify the desired options. Outline and Shadow options are available for Mac only
Alignment Specify the horizontal and vertical alignment
Color Select a color for the Text (see “Selecting a Color from a Color Palette” on page 1135).

To have a background fill behind the text, select the Background option and also specify a color. 
To have no background fill, deselect the Background option.

Preview Previews text font, size, style, text color, and background color, if applicable
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• With no objects selected, click the Text tool, and select a Text Style from the Tool bar. This sets the default text 
style that will be used when new objects are created.

Other Features of Text Styles
• Although text style resources can include a color, some types of objects do not use the text style color. For 

example:
• Text, callouts, and general notes always use the text style color.
• Dimensions and other annotation objects always use the current pen color.

• If an object’s text style comes from its class definition, the text style displays as <Class Text Style>.
• Text with no style applied displays <Un-Styled> as the text style. If you change any of the attributes of styled text 

(for example, if you change the size from 16 points to 18 points), the text style automatically becomes 
<Un-Styled>. Text also becomes un-styled if you apply the <Un-Styled> option to it, but the text attributes remain 
the same.

• If you move styled text to a layer that has a different scale from the original layer, the text will be scaled 
accordingly, and it automatically becomes <Un-Styled>; reapply the text style if you want to restore the original 
text size.

• The alignment, spacing, and background color attributes of a text style are only applied if an entire text object is 
selected; these attributes are ignored if you apply a style to a portion of a text object.

• If a text object contains text with multiple styles, the text object itself does not display a text style in the Object 
Info palette. The styled portions of text within the object are still updated if the text style resource is changed.

Editing Text Styles
If you change a text style resource, all objects in the file that use the style are updated at once.
To edit a text style:

1. From the Resource Browser, select the text style, and then select Resources > Edit.
The Edit Text Style dialog box opens.

2. Edit the parameters as described in “Creating Text Styles” on page 394 and click OK.
The text style definition and all objects in the file that use the text style are updated.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Text

Green text is style 1 and blue text is style 2

Because it contains 
two text styles, the text 
object itself displays 
no Text Style
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Modifying Text

Checking Spelling
Check the spelling of either selected text or all the text in a file with the Check Spelling command. Spelling in text 
blocks, symbols, records, worksheets, and viewports can be checked. Available dictionaries include:

Dictionaries can be edited and added.
~~~~~~~~~~~~~~~~~~~~~~~~~
Checking the Spelling
Correcting Spelling Errors
Spelling Check Options
Adding and Editing Dictionaries-

Checking the Spelling
To check the spelling of a selected object:

1. Select the object.
2. Select Text > Check Spelling.

Alternatively, right-click (Windows) or Ctrl-click (Mac) the text, and select Check Spelling from the context 
menu.

3. If a spelling error is detected, the Selection Spelling Check dialog box opens so that corrections can be made.
To check the spelling of all text in the file:

1. Ensure that no objects are selected.
2. Select Text > Check Spelling.

The Spelling Check Filter dialog box opens.
Click to show/hide the parameters.

3. Select the items to have spelling checked, and then click OK. If a spelling error is detected, the Document 
Spelling Check dialog box opens so that corrections can be made.
If no spelling errors are detected, a message displays to indicate that the spelling check is complete.

• Danish • Dutch • English (American) • English (British)

• Finnish • French • German • Italian

• Norwegian • Portuguese (Brazilian) • Portuguese (Iberian) • Spanish

• Swedish

Parameter Description

Text Blocks Checks text contained in text blocks
Symbols Checks text contained in symbol definitions
Records Checks text contained in records
Worksheets Checks text contained in worksheets
Viewports Checks text annotations contained in viewports
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~~~~~~~~~~~~~~~~~~~~~~~~~
Correcting Spelling Errors
Adding and Editing Dictionaries

Correcting Spelling Errors
If a spelling error is found, either the Selection Spelling Check (when checking a selection) or the Document Spelling 
Check (when checking all text) dialog box opens. Both dialog boxes contain the same options.
Click to show/hide the parameters.

The spelling of layers, classes, symbol names, object names, script palette names, dimension text, locked objects, 
or records attached to locked objects is not checked.

Spelling Check Options
Click the Options button in the Spelling Check dialog box to customize the spelling check function. The Spelling 
Check Options dialog box opens.
Specify the types of misspelled words for the spelling checker to find. If a check box is not selected, the spelling 
checker ignores errors for that category of words. Examples include:

Customize the spelling checker to reduce unnecessary spelling checks in your typical files. Click OK to return to the 
Selection Spelling Check or Document Spelling Check dialog box.

Parameter Description

Spelling error in Identifies the location of the object containing the potential spelling error
Not in Dictionary Lists the potentially misspelled word; if none of the suggested corrections in the 

Suggestions list is an acceptable replacement, type the correction into the Not in 
Dictionary field (or delete the word by leaving the field blank). Then click Change or 
Change All to replace the error with the typed word. The word is replaced and the spelling 
check resumes.

Suggestions Suggests the closest matching word(s) from the dictionary
Change / Change All Select one of the suggested words from the list of Suggestions to replace the misspelled 

word and click Change. The misspelled word is replaced with the suggested word. 
Alternatively, press Enter with the suggestion selected. To replace all occurrences of the 
same error in the file, click Change All. The word is replaced and the spelling check 
resumes.

Ignore / Ignore All If the word is spelled correctly, but it is not present in the dictionary, click Ignore to leave 
the word as is and continue the spelling check. Click Ignore All to ignore all occurrences of 
the word in the file. The word is ignored and the spelling check resumes.

Learn Click to add the word to the dictionary; this allows the spelling checker to recognize all 
future occurrences of the word

Options Click to customize the spelling check options; see “Spelling Check Options” on page 397
Done Click to discontinue the spelling check; all changes up to that point are saved, but can be 

undone by selecting Edit > Undo

• Capitalized words: Canada • Words in all caps: ANGLE

• Words with mixed case: VectorScript • Words with numbers: Q4
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Adding and Editing Dictionaries
The user dictionary, UserDictionary.txt, is a text file located in [Vectorworks]\Plug-Ins\Dictionaries. It can be edited, if 
desired. When manually editing a dictionary, type the word followed by a tab and the letter “i” to indicate that the 
spelling checker should ignore the word.
Additional dictionaries, such as a foreign language dictionary, can be added by placing the dictionary file into the 
[Vectorworks]\Plug-Ins\Dictionaries folder. The spelling checker automatically uses all the dictionaries with the .clx 
extension in the folder to check the spelling. However, the addition of multiple dictionaries can slow down the spelling 
check process.

Click here for a video tip about this topic (Internet access required).

Finding and Replacing Text
The Find-Replace Text command searches for and optionally replaces text strings within a Vectorworks file. It can 
search for and replace text strings within text objects, record fields, and worksheet cells.
Use this command to find a text item, replace it, search for more occurrences, or replace all occurrences. All settings 
are retained from one use to the next, including find and replace text strings.
To find-replace text:

1. Select Text > Find-Replace Text.
The Find or Replace Text dialog box opens.

Click to show/hide the parameters.

Parameter Description

Action Locates and, if selected, replaces a given text string with a new text string
Find Next Finds the next occurrence of the text string
Replace Next Replaces the next occurrence of the text string
Replace All 
Selected

Replaces all selected occurrences of the text string

Replace All Replaces all occurrences of the text string
Look in Searches for occurrences in the specified parts of the document

Text Objects Searches in all text objects
Record Fields Searches in all record fields, including Callout objects
Worksheets Searches in all worksheets; appears dimmed if Replace All Selected is chosen, since there 

is no selection attribute for a worksheet
Find String Enter text string to search for
Replace With Enter replacement text string; dimmed if Find Next is selected
Options Specifies the depth of the search

Active Layer Only Searches in the active layer only
All Layers Searches on all layers within the document, regardless of visibility
Visible Layers 
Only

Searches in all currently visible layers

Case-sensitive Searches for text that exactly matches the criteria, including capitalization

http://www.youtube.com/watch?v=9GkZYkzfCyU
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2. Enter the desired search and, if using, replace criteria.
3. Click Find/Replace.

Creating Hyperlinks
The Hyperlink tool inserts a hyperlink object in the drawing, for navigating to saved views or sheet layers in the file, 
opening other files or folders, or launching applications or web sites. The hyperlink can consist of text and/or geometry, 
and can be created from a custom symbol; symbols can be page based or world based. Hyperlink properties are easy to 
customize and they can be batch edited from a worksheet. Hyperlinks to websites and sheet layers can be exported to a 
PDF file (Vectorworks Design Series required); hyperlinks to sheet layers are functional when the sheet layers are 
exported as a batch to a single PDF file.

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting a Hyperlink
Editing Hyperlinks

Inserting a Hyperlink

To insert a hyperlink object:

1. Click the Hyperlink tool from the Dims/Notes tool set.
2. Click Preferences from the Tool bar to specify the hyperlink parameters.

Alternatively, double-click on the Hyperlink tool.
The Hyperlink Settings dialog box opens. The parameters in the Details area depend on the selected Function.

Click to show/hide the parameters.

Parameter Description

Layout Select the desired appearance of the hyperlink
Symbol Select a symbol from the hyperlink symbols available in the file and the default content 

symbols provided. (Default content is automatically imported into the current file at the 
point of use and displays in the Resource Browser; see “Resource Libraries” on 
page 219.) Symbols can be page based or world based; default hyperlink symbols are 
page based.
#Hyperlinktext# indicates the area of the symbol that displays the Label text. 

Edit Symbol The selected symbol can be edited for use in this file. Clicking Edit Symbol exits the 
Hyperlink Settings dialog box, and the Edit window displays for editing the symbol’s 
2D component (a colored border around the drawing window indicates the editing mode 
is active). Reshape the geometry, change attributes, add text, paste images, and perform 
other editing operations, and then click Exit Symbol to return to the drawing.
The hyperlink symbols in the drawing can also be edited from the Resource Browser; 
see “Editing Symbol Definitions” on page 247.
Edited symbols are available for selection from the Symbol list.

http://www.youtube.com/watch?v=aWTnrMK-QRw 
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3. Select the hyperlink symbol and function, and then click OK.
On the Tool bar, the current hyperlink function and target displays.

4. Click in the drawing to insert the hyperlink object.
5. To execute the hyperlink, Ctrl-click (Windows) or Cmd-click (Mac) on the hyperlink, or click Open Link from 

the Object Info palette or context menu of a selected hyperlink object.
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Hyperlinks
Editing Symbol Definitions

Editing Hyperlinks
The Object Info palette of a selected hyperlink object displays its currently assigned Function and Target. Click Open 
Link to execute the hyperlink’s function. Click Edit to open the Hyperlink Settings dialog box and specify the 
hyperlink properties as described in “Inserting a Hyperlink” on page 399. Other methods of accessing the Hyperlink 
Settings dialog box include double-clicking on the hyperlink or pressing Ctrl-click (Mac) or right-click (Windows) and 
selecting Edit from the context menu.
If a link is invalid or broken, the Object Info palette displays a message in red text, and an alert displays when the 
hyperlink is executed. Edit the hyperlink settings to specify a valid target.
The hyperlink symbol definition can be edited from the Resource Browser (see “Editing Symbol Definitions” on 
page 247); this affects all instances of the symbol.
It can be tedious to edit multiple hyperlinks in large projects. In this type of situation, use scripted commands or create 
a report containing the hyperlink objects by selecting Tools > Reports> Create Report. See “Creating Reports” on 
page 1316. In the resulting worksheet, columns labeled “Editable” can be changed, for convenient editing.

New Symbol Opens the New Symbol dialog box; provide a name for the new hyperlink symbol and 
click OK to return to the Hyperlink Settings dialog box. A new text-only hyperlink 
symbol is automatically created and added to the resources in the file. This new custom 
hyperlink symbol can then be selected from the Symbol list and edited by clicking Edit 
Symbol.

Details
Label Enter the text to display for the hyperlink
Function Select the hyperlink function

Open Webpage Launches the specified website in the default browser; enter the URL in Webpage
Launch Application Launches the specified application; click Browse to select the application. Choose 

whether the path to the application should be saved as absolute or relative. To set a 
relative path, the Vectorworks file must exist on the same volume as the application.

Open Document Opens a file, such as a movie or image; click Browse to select the file. Choose whether 
the path to the file should be saved as absolute or relative. To set a relative path, the 
Vectorworks file must exist on the same volume as the file to open.

Open Folder Opens the specified folder; click Browse to select the folder. Choose whether the path 
to the folder should be saved as absolute or relative. To set a relative path, the 
Vectorworks file must exist on the same volume as the folder to open.

Activate Saved View Displays the specified saved view; select the view from the Saved View list
Activate Sheet Layer Activates the specified sheet layer; select the sheet layer from the Sheet Layer list

Parameter Description
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Exporting Hyperlinks to PDF
Only hyperlinks that open a web page or navigate to a sheet layer are functional when exported to a PDF file. 
To obtain successful hyperlinks to sheet layer targets, the file must be exported with the File > Publish command. The 
sheet layer containing the hyperlink, as well as the target sheet layers, need to be exported to a single PDF file so that 
the links can be executed. Export PDFs as separate files must be deselected in the Publish dialog box.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting a Hyperlink
Editing Symbol Definitions
Exporting PDF Files
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Space Planning
The Vectorworks Architect product performs space planning and programming studies, and creates schematic floor 
plans.
These features can be combined in various ways depending on your preferred workflow:

• To begin the design process, draw the spaces. Reposition and reshape the spaces as needed to develop a schematic 
floor plan. Then create the walls automatically from those spaces.

• Begin with a solid model, and then create the exterior walls from the model.
• Create the walls first, and then create the space objects automatically to determine the areas enclosed by the walls.
• Using space programming, import an adjacency matrix that was provided by a client, and automatically create a 

bubble diagram and a stacking diagram. Reshape and reposition the space objects in the bubble diagram to create 
a floor plan, and then create the walls automatically from the spaces.

• Create the initial schematic design with polylines instead of spaces, and then convert the polylines to spaces.
• Create the model with stories, and associate the net/gross volume of the spaces along with the stories.

Use the Space tool to create a schematic floor plan. The Vectorworks Architect product can then automatically create 
walls from those spaces. To track room finish data on a schedule, add finish information to the spaces. If necessary, IFC 
data (including extended space properties used by the General Services Administration) can be attached to the spaces. 
The net and gross volume of a space can be associated with story elevation, so that as story layer levels change, the 
space volume adjusts accordingly.
If walls or polylines that represent spaces already exist in the drawing, use space planning commands to create spaces 
from the walls or polylines.
When creating and updating spaces, the visibility of walls can affect the spaces, depending on the situation and action:

• When creating spaces, only visible walls are taken into account
• When updating existing spaces (clicking Update Boundary from the Object Info palette), only visible walls are 

taken into account
• When existing spaces are regenerated, for example due to changed space labels, a new height value, or moved 

walls, wall visibility has no effect on automatically bounded spaces, because the spaces are already associated 
with the walls.

See “Editing Space Boundaries” on page 434 for more information.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Spaces with the Space Tool
Space Settings
Creating Walls from Spaces
Creating Spaces from Walls
Creating Spaces from Polylines
Getting Floorplan Information from a Solid Model
Editing Space Boundaries
Programming Studies

Creating Spaces with the Space Tool
Spaces are path objects that have the characteristics of a building space or room, which include information such as the 
space name, number, finish information, and height. The space label is drawn using a pre-defined or user-defined 
symbol, can display not only name and number, but virtually any desired information. Space objects automatically 
calculate their area, volume, and perimeter.
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The Room Name Simple tool (in the Dims/Notes tool set) creates a text label only; it does not attach room finish, 
area, IFC, or GSA information to a space object.

To draw a free-standing space with the Space tool, select either the Rectangle or the Polyline mode. If the walls are 
already drawn, select the Picked Walls mode or Inner Boundary mode to create a space bounded by visible walls.

Mode Description

Picked Walls Creates a space object based on a closed set of selected walls
Inner Boundary Creates a space object in a clicked area that is bounded by visible walls
Rectangle Draws a rectangular space object 
Polyline Draws a polyline space object; as with a polyline, select one of six types of control points for 

the vertices from the Tool bar
Pick Up Attributes Picks up the attributes of a space that is clicked upon.

The properties that are transferred can be customized; see “Space Settings: Advanced 
Settings Pane” on page 416 for details.

Apply Attributes Transfers the space attributes that have been picked up with the Pick Up Attributes mode to a 
space that is clicked upon.

Press the Ctrl key (Windows) or the Option key (Mac) when you click to toggle between 
the Pick Up Attributes and Apply Attributes modes.

Corner Vertex For Polyline mode, creates the space using polyline segments with straight lines and angled 
vertices at the control points

Bézier Vertex For Polyline mode, creates the space using polyline segments with curves pulled toward, but 
not touching the control points

Cubic Vertex For Polyline mode, creates the space using polyline segments with curves that pass through 
the control points

Tangent Arc For Polyline mode, creates the space using polyline segments that are tangent to the previous 
segment

Point on Arc For Polyline mode, creates the space using polyline segments that are drawn by clicking three 
points: the start point, a point the arc passes through, and the end point

Arc Vertex For Polyline mode, creates the space using polyline segments with curves that look like a 
fillet placed at the control points

Fillet Radius For Polyline mode, sets the fillet radius when the Arc Vertex mode is selected
Preferences Sets the default parameters that are used for each new space object

Inner Boundary

Corner 
Vertex

Bézier 
Vertex

Cubic 
Vertex

Arc Vertex  PreferencesPolyline

Fillet 
Radius

Rectangle

Apply 
Attributes

Pick Up 
Attributes

Tangent Arc

Point on ArcPicked Walls
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Creating Spaces from Existing Walls
Spaces can be automatically created by first selecting the enclosing walls or by clicking within the boundary of a closed 
set of visible walls. The spaces are automatically associated with their bounding walls.

Alternatively, select AEC > Space Planning > Create Spaces from Walls to create spaces from a set of enclosed 
walls on a specified design layer (see “Creating Spaces from Walls” on page 430).

To create a space within a selected set of visible walls:

1. Click the Space tool from the Space Planning tool set or the Building Shell tool set.
2. From the Attributes palette, set the 2D attributes for the space (fill, pen, opacity, and line thickness).
3. From the Tool bar, select Preferences. Set the default parameters for the space objects.
4. From the Tool bar, select Picked Walls mode.
5. Click on each wall that forms the wall set and press Enter, or click the check mark button on the Tool bar. The 

space is created with the attributes and settings you specified.
6. Add information specific to the space.

To create a space within a closed set of visible walls:

1. Click the Space tool from the Space Planning tool set or the Building Shell tool set.
2. From the Attributes palette, set the 2D attributes for the space (fill, pen, opacity, and line thickness).
3. From the Tool bar, select Preferences. Set the default parameters for the space objects.
4. From the Tool bar, select the Inner Boundary mode.
5. Click in an open area of the drawing that is bounded by walls; the walls must be visible, joined together, and on 

layers that have the same layer scale as the space layer. The space is created with the attributes and settings you 
specified.

6. Add information specific to the space.

Drawing Spaces with the Space Tool

To draw a space with the Space tool:

1. Click the Space tool from the Space Planning tool set or the Building Shell tool set.

Office 1
AREA: 100.0 sq ft

Office 2
AREA: 100.0 sq ft

Office 3
AREA: 100.0 sq ft

Lobby
AREA: 116.5 sq ft
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2. From the Attributes palette, set the 2D attributes for the space (fill, pen, opacity, and line thickness).
3. From the Tool bar, select Preferences. Set the default parameters for the space objects.
4. From the Tool bar, either select the Rectangle mode, or select the Polyline mode and then select the type of control 

point for the polyline vertices.
5. Draw the space as follows:

• For a rectangular space, click to begin the rectangle, and then click again to finish the rectangle and create the 
space.

• For a polyline space, click to begin the polyline, and then click to set each polyline vertex. Click on the start 
point to end the polyline and create the space.

The space is created with the attributes and settings you specified.
6. Add information specific to the space.

Adding Information to Spaces
After all spaces have been created, select specific spaces and add more information to them on the Object Info palette, 
such as a space name and room finishes. The items that are changed most frequently are available on the Shape tab. To 
access the full set of space properties, click the Settings button to open the Space Settings dialog box.

The properties that are available on the Object Info palette are determined by the Advanced Settings pane on the 
Space Settings dialog box. See “Space Settings: Advanced Settings Pane” on page 416 for details.

Copying Attributes to Other Spaces
If several spaces need to have attributes in common, such as the same space name and room finishes, copy the 
attributes from an existing space and apply them to the other spaces.

To copy attributes to other spaces:

1. Click the Space tool from the Space Planning tool set or the Building Shell tool set, and then from the Tool bar, 
select Preferences.

2. From the Space Settings dialog box, select the Advanced Settings pane.
3. Select the attributes to transfer between spaces from the Eyedropper Transfer Properties window (see “Space 

Settings: Advanced Settings Pane” on page 416 for details).
4. Select the Pick Up Attributes mode from the Tool bar. Click the space with the attributes you want to transfer.
5. Select the Apply Attributes mode from the Tool bar, and click each space that should have those attributes.

Alternatively, press the Ctrl key (Windows) or the Option key (Mac) while you click to activate the Apply 
Attributes mode.

~~~~~~~~~~~~~~~~~~~~~~~~~
Space Settings
Editing Space Boundaries
Adding Information to Spaces

Space Settings
Use the Space tool’s Preferences to set the default parameters for space objects before you create them, including the 
label style, automatic numbering, boundary calculations, and 3D graphic attributes. For maximum control over the 



Space Settings |  407
display of spaces, you can set default classes for the label, label leader line, 2D attributes, 3D attributes, and the entire 
space object. Preference settings are an easy way to apply common, consistent settings to all spaces.

The space’s 2D graphic attributes are not taken from the Preferences settings. Instead, set the appropriate fill and 
pen styles in the Attributes palette before you create the spaces.

Once the spaces have been created, use the Object Info palette to edit the properties of individual spaces, including 
space name and occupant, room finishes, and any additional data attached to the space. The items that are changed 
most frequently are available on the Shape tab. To access the full set of space properties, click the Settings button to 
open the Space Settings dialog box.

The properties that are available on the Object Info palette are determined by the Advanced Settings pane on the 
Space Settings dialog box. See “Space Settings: Advanced Settings Pane” on page 416 for details.
To reduce the time required to regenerate space objects after properties are edited, Vectorworks only regenerates 
the space components that are changing and only recalculates the bounds of the spaces if necessary. To force the 
complete regeneration of edited space objects, select Tools > Utilities > Reset all Plug-Ins.

The fields that display on the Space Settings dialog box are slightly different, depending on whether you access the 
dialog box with the Preferences mode of the Space tool or with the Settings button on the Object Info palette.
The settings are grouped into several panes of related parameters. Select each group of parameters from the list in the 
left pane of the dialog box; the parameters display in the center pane.
The right pane of the dialog box always displays a preview of the space label(s) based on the current settings. To edit 
the appearance of any of the space labels (for example, to change the font size or the pen color), click the label’s Edit 
Layout button at any time.
A few controls can be edited directly from the Object Info palette, as described in “Space Properties” on page 417.

Space Settings: Preview
Click to show/hide the parameters.

Space Settings: Numbering Pane
Click to show/hide the parameters.

Parameter Description

Space Label Preview Dynamically displays a preview of the space label(s) with the currently selected 
parameters; see “Space Settings: Space Label 1, 2, and 3 Panes” on page 412

Space Label 1 previews by default. Space Label 2 and Space Label 3 preview only if 
Enable multiple labels is selected on the Advanced settings pane and Display Space 
Label is selected on the Space Label 2/3 pane.

Edit Layout Click to enter object editing mode to edit the format of the specified label; see “Object 
Editing Mode” on page 1004
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Space Settings: Occupancy Pane
Click to show/hide the parameters.

Parameter Description

Space Number When you set the default preferences for the Space tool, if the Space Number Style is 
Manual, leave this field blank and add the numbers to spaces after they are created. For all 
other numbering styles (auto-numbering), the field displays the Next value and cannot be 
edited.
When you edit a space using the Settings button from the Object Info palette, if the Space 
Number Style is Manual, enter a number for this space. For all other numbering styles 
(auto-numbering), the field displays the space’s assigned number and cannot be edited.

Space Number Style Specifies the type of numbering to use on space objects.
• Select Manual to enter a number for each space manually in the Space Number field.
• Select Counter Only to have the Vectorworks program automatically assign the next 

available number to each space as it is created.
• If custom number styles were created, they display at the bottom of the list; select the 

style to use to auto-number each space as it is created.
Edit Number Styles Opens the Edit Number Style dialog box to create or edit number styles. See “Custom 

Number Styles” on page 418 for details.
Auto-Number Settings Specify the following values if auto-numbering is in use (that is, Space Number Style is 

not set to Manual)
Start value Specifies the numeric value to assign to the first new space
Increment Specifies the amount to increment the numeric value of each new space; this number is 

automatically added to the Next value each time a space is created
Next value Specifies the numeric value to assign to the next new space that is created
Validate 
Auto-Numbering

Available only when you edit a space using the Settings button from the Object Info 
palette (not when you set the default preferences for the Space tool); opens the Validate 
Auto-Numbering dialog box to adjust the automatic space numbers. See “Validating 
Auto-Numbering” on page 419 for details.

Parameter Description

Space Type Identifies a space as either Normal (for example, a room) or Full Floor (the entire floor 
of a building)



Space Settings |  409
Space Name Specifies the space name; the spaces in an adjacency matrix are listed by space name, 
and the space name can also be used in space labels. Select a name from the list, or select 
Custom and enter a name in the field below the pull-down list.
The top portion of the list contains the space names that are currently used in the 
drawing. The lower portion of the list displays all available space names that are still 
unused, compiled from lists in the Vectorworks program folder, your user folder, and 
your designated workgroup folder.
To customize a space name list, select Edit List from the bottom of the list to open the 
Edit Space - Space Name List dialog box. See “Editing Lists of Space Names and 
Occupant Organizations” on page 420.

Occup. Organization Specifies the organization associated with the occupant; the spaces in the stacking 
diagram are grouped by the organization name.
This field is very similar to the Space Name field above. The list is separated into 
sections based on whether the available names are currently in use. Select a name from 
the list, or select Custom and enter a name in the field below the pull-down list. 
To customize an occupant organization list, select Edit List from the bottom of the list to 
open the Edit Space - Occ Organization List dialog box.

Occupant Name Specifies the individual occupant name
Proposed Area Specifies the programmed area for the space

Parameter Description

Allows entry of a custom
name for this drawing only

Names currently used in
this drawing

Names available (from all lists),
but not currently used in this

drawing

Opens a dialog box for editing
the list of available names
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Space Settings: 2D Boundaries & Area Pane
Many parameters on this pane are available only if the space is connected to adjacent walls.
Click to show/hide the parameters.

Assign Zones Click the column to the left of a zone name to select it. Up to five zones of different types 
can be assigned to a space; only one zone can be assigned from each zone type (HVAC, 
Preservation, Security, and so on).

When you edit a space from the Object Info palette, click the Assign Zones button 
to open a dialog box with the same zone information that displays on the 
Occupancy pane.

To customize the zones list, click New to open the Create Zone dialog box.
• To add a zone to an existing zone type, select the Zone Type, enter the Zone Name, 

and click OK.
• To create a new zone type, select Add New Zone Type from the Zone Type list, enter 

a name, and click OK.
To delete a zone, click the zone name, and click Delete to remove the zone from the list.

The IFC Zones command attaches IFC data to space zones. See “Assigning IFC 
Data to Space Zones” on page 1748.

GSA Occupancy If Enable GSA is selected (Advanced Settings pane), opens the GSA Occupancy dialog 
box to enter the data required for GSA projects (see “GSA Data” on page 429). When the 
drawing is complete, select File > Export > Export IFC Project to save the file in IFC 
format.

Parameter Description

Boundary Display
Show 2D Boundary Displays the polyline that represents the space; if this option is selected, also select an 

option for the 2D Boundary Display.
2D Boundary Display Specifies what to display for the space: Inside Walls less Columns, Inside Wall Faces, 

Wall Centerlines, Net Boundary, or Gross Boundary. A Net boundary is defined by the 
inside face of the surrounding walls; the Gross boundary display is defined by the 
Gross Boundary Def. setting.

If the area and perimeter values for the space are used in a worksheet, the values 
always match the displayed boundary.

Parameter Description
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Space Settings: 3D Boundaries Pane
Click to show/hide the parameters.

Gross Net Boundary
Gross Boundary Def. Specifies the definition to use for the gross boundary: Wall Centerlines, Building Gross, 

Outer Wall Core, Center Wall Core, BOMA Rentable, or Custom.
If Outer Wall Core or Center Wall Core is selected but the wall has no core 
component, the space boundary is defined by the outer edge or center, respectively, 
of the entire wall.

The Custom option is only available for an existing space object surrounded by walls. If 
Custom is selected, click Edit Gross Custom to open the Edit Custom Gross Boundary 
dialog box.
Do one of the following:
• Select each wall in the display window, and then select the appropriate bounding 

definition for it.
• Click Reset Gross Boundary to set all boundaries for the space to one of five pre-set 

options (Centerlines of All Walls; Centerlines of Interior Walls, Outer Core 
Component of Exterior Walls; Centerlines of Interior Walls, Center Core Component 
of Exterior Walls; Centerlines of Interior Walls, Inside Face of Exterior Walls; 
Centerlines of Interior Walls, Outside Face of Exterior Walls).

Net Boundary Definition Specifies the definition to use for the net boundary: Inside of Walls, or Custom.
If Custom is selected, click Edit Net Custom to open the Edit Custom Net Boundary 
dialog box:
Enter an amount to offset the space boundary from the wall. When the space is edited 
from the Object Info palette and it contains wall projections, columns, and/or pilasters, 
also choose whether to exclude wall projections and column “islands” from the area 
calculation.

Area Calculation
Net Area Modifier Adjusts the net area value by the specified percentage
Gross Area Modifier Adjusts the gross area value by the specified percentage

Calculate Room 
Dimensions

Automatically calculates the Length and Width dimensions of the space object; when 
deselected, the Length and Width can be entered manually

Length/Width Displays the dimensions of the space; when Calculate Room Dimensions is 
deselected, the Length and Width can be entered manually. Manual changes affect the 
display of the length and width values, but do not change the actual dimensions of the 
space object.

Parameter Description
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Space Settings: Space Label 1, 2, and 3 Panes
As many as three space labels can be independently formatted and positioned for each space. The Space Label 1 pane is 
available by default; to add the Space Label 2 and Space Label 3 panes to the dialog box, select Enable multiple labels 
on the Advanced Settings pane (see “Space Settings: Advanced Settings Pane” on page 416).
Click to show/hide the parameters.

Parameter Description

Show 3D Select to display the space volume boundaries in 3D

Volume Display Select whether to display the Net or Gross volume; the actual net or gross volume 
depends on the height boundary selections and any offsets

Height Net / Gross 
Height

Height Directly sets the desired net or gross height of the space. When the space height is 
determined manually by this method, the Top Bound property of the space is 
automatically set to Layer Elevation, and the Top Offset value is modified accordingly.
When the top of the space is bound by the layer wall height value or by a story level, the 
space height displays automatically.

Top Bound Sets the vertical reference that determines the top of the space.
The Layer Wall Height value is set by the design layer (see “Setting Design Layer 
Properties” on page 165).
Alternatively, the top of the space can be bound by one of the story levels defined for the 
story or the story above it. By setting the top of the space to a level type, if the elevation 
of the associated story changes, the height of the space changes automatically to match.

Top Offset Sets the offset of the top of the space from its specified top bound height 
Bottom Bound Sets the vertical reference that determines the bottom of the space. Alternatively, the 

bottom of the space can be bound by one of the story levels defined for the story or the 
story below it. By setting the bottom of the space to a level type, if the elevation of the 
associated story changes, the height of the space changes automatically to match.

Bottom Offset For the bottom of the space, sets the offset from its specified bottom bound height
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Space Settings: Leader Line Pane
Parameters to position the leader line for space label 1 are available by default; leader line parameters for space labels 2 
and 3 are available only if Enable multiple labels is selected on the Advanced Settings pane. The leader lines’ class 
and appearance are set on the 2D Attributes pane (see “Space Settings: 2D Attributes Pane” on page 414).
Click to show/hide the parameters.

Parameter Description

Display Space Label Select to display the space label on the drawing
Each label that is displayed is added to the Space Label Preview column on the right 
side of the dialog box.

Class Select a class for the entire space label, or select New to create a new class (see “Creating 
Classes” on page 177).
Alternatively, when you set the default preferences for the Space tool, select <Space 
Class> which places the label in the same class as the space object.
Individual elements of the space label may be assigned to different classes, as well.

To control the visibility of each space label separately, assign each label to a 
different class.

Space Label Symbol Select the symbol to use for the space label from the list of symbols available in this 
document.

To create a new text-based symbol, or to designate another symbol within the 
document as a space label, click Manage Space Labels.

Space Label Angle Enter an angle to rotate the label, if desired
Fields list The fields defined for the label symbol display; when a field is selected from the list, the 

field is highlighted in red in the Space Label Preview pane. To edit a field, select it from 
the list, and then do the following:
• To use a different piece of data for a label (for example, to show the gross area instead 

of the net area), select the new definition from the Format Field list.
From the Space Label pane, you can only edit the fields currently on the list. To add 
or delete fields, you must edit the label symbol.

• To change the prefix or suffix that will display along with the field value on the label, 
click Edit to open the Edit Format dialog box. Enter the desired values and click OK.

Manage Space Labels Opens the Manage Space Labels dialog box to create, rename, duplicate, or delete the 
space label symbols for this document; see “Customizing Space Labels” on page 421 for 
details

Save As Default Opens a dialog box to save the current space label settings to a template file in your user 
folder, which makes it one of the available labels for new documents. Enter a name for 
the label and click OK. The template file is created (or updated) automatically in the 
space stamp file in the user folder’s default library (see “Resource Libraries” on 
page 219).
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Space Settings: 2D Attributes Pane
These settings apply to the space object only; the space label is a symbol, which can be edited with the Edit 
Layout button, or from the Resource Browser (see “Editing Existing Space Labels” on page 422).

Click to show/hide the parameters.

Parameter Description

Display Leader Line 
1/2/3

Select to display a leader line for the corresponding space label

Start Point on Space Specifies whether to start the leader line on the space’s anchor point or edge
End Point on Label Specifies where to end the leader line relative to the space label.

Auto position: Automatically centers the leader line end point on the closest center point of 
the space label’s bounding box.
Custom: Adds a control point at the end of the leader line; the control point can be moved 
to define where the leader line ends. This option is available only if an existing space is 
being edited, not as a default setting for new spaces.
Nearest Locus: Ends the leader line on the space label locus point nearest to the space’s 
anchor point. This option is available only if the chosen space label symbol contains one or 
more loci.

Parameter Description

Space Object Class Select a class for the entire space object, or select New to create a new class.
2D Boundary When you set the default preferences for the Space tool, only the Class parameter is 

available for the 2D Boundary, because the fill and pen attributes are determined by the 
Attributes palette.
When you edit a space using the Settings button from the Object Info palette, all of the 2D 
boundary parameters are available.

Class Select a class for the 2D boundary, or select New to create a new class.
Alternatively, select <Space Class>, which places the boundary in the same class as the 
space object.

Fill Style Select a fill style for the space object, and then customize the fill using the additional fields 
that display. For example, select the color for a solid fill, or select a hatch from the list of 
those available. For hatch, tile, gradient, and image fills, click Edit to open a dialog box for 
editing the fill. To use the fill specified for the selected class, select Class Style.

Pen Select the pen style for the space object, and then customize the pen using the additional 
fields that display. For example, select the thickness for a solid pen, or select a color for a 
dash pen. To use the pen specified for the selected class, select Class Style.

Opacity Use the slider or enter a percentage to specify the opacity of the space object, or click Use 
Class Opacity to use the opacity setting for the selected class.

Leader Line If the label is placed outside the space boundary, a leader line is drawn automatically
Class Select a class for the leader line, or select New to create a new class.

Alternatively, select <Space Class>, which places the leader line in the same class as the 
space object.
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Space Settings: 3D Attributes Pane
Click to show/hide the parameters.

Space Settings: Room Finishes Pane
Click to show/hide the parameters.

Pen Select the pen style for the leader line, and then customize the pen using the additional 
fields that display. For example, select the thickness for a solid pen, or select a color for a 
dash pen. To use the pen specified for the selected class, select Class Style.

Marker Start/End To include start or end markers for the leader line, check the appropriate box(es). Then 
select the style for the markers, or select Custom to create a new marker style.

Parameter Description

Class Select a class for the 3D attributes of the space object, or select New to create a new class.
Alternatively, select <Space Class>, which places the 3D attributes in the same class as the 
space object.

Fill Style Select a fill style for the space object, and then customize the fill using the additional fields 
that display. For example, select the color for a solid fill, or select a hatch from the list of 
those available. For hatch, tile, gradient, and image fills, click Edit to open a dialog box for 
editing the fill. To use the fill specified for the selected class, select Class Style.

Pen Select the pen style for the space object, and then customize the pen using the additional 
fields that display. For example, select the thickness for a solid pen, or select a color for a 
dash pen. To use the pen specified for the selected class, select Class Style.

Texture To use a texture for the space object, select a texture from the list of those available. To use 
the texture specified for the selected class, select Class Style.

Parameter Description

On Room Finish Schedule Includes the space object in the Room Finish Schedule; if enabled, select the 
appropriate finishes for the ceiling, walls, base trim, and floor of the space object.

Alternatively, to assign room finishes to multiple existing spaces at the same 
time, select the desired spaces and click Assign Room Finish in the Object 
Info palette. This opens the Assign Room Finishes dialog box, which has the 
same functionality as the Room Finishes pane.

Ceiling Select a finish for the space object’s ceiling.
The top portion of the list contains the ceiling finishes that are currently used in the 
drawing. The lower portion of the list displays all available ceiling finishes that are 
still unused, compiled from lists in the Vectorworks program folder, your user 
folder, and your designated workgroup folder.

North, East, South, and 
West Walls

Select a finish for each of the space object’s walls.
The top portion of the list contains the wall finishes that are currently used in the 
drawing. The lower portion of the list displays all available wall finishes that are 
still unused, compiled from lists in the Vectorworks program folder, your user 
folder, and your designated workgroup folder.

Parameter Description
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Once the room finish information is entered, add the Room Finish Schedule to the drawing file.

Space Settings: Additional Data Pane
Click to show/hide the parameters.

Space Settings: Advanced Settings Pane
Click to show/hide the parameters.

Base Trim Select a finish for the space object’s base trim.
The top portion of the list contains the base trim finishes that are currently used in 
the drawing. The lower portion of the list displays all available base trim finishes 
that are still unused, compiled from lists in the Vectorworks program folder, your 
user folder, and your designated workgroup folder.

Floor Select a finish for the space object’s floor.
The top portion of the list contains the floor finishes that are currently used in the 
drawing. The lower portion of the list displays all available floor finishes that are 
still unused, compiled from lists in the Vectorworks program folder, your user 
folder, and your designated workgroup folder.

Remarks Allows entry of additional remarks about the finishes
Edit Finishes Opens the Edit Room Finishes dialog box

Parameter Description

Fields list You can attach data to the space object and display the information in a space label, or in 
a worksheet. All available fields display in a list, along with any data that has been 
entered for the fields.
For most fields, simply click the field name in the list, and then enter the desired data in 
the entry field that displays below the list of field names. To attach data that is not 
available on the list, you can use up to ten Additional Info fields; click Rename User 
Fields to name these fields.
The Room ID and Formula fields have additional functionality. The Room ID allows you 
to specify an identifier based on a formula that can include data fields from the space as 
well as user-defined static text. This ID can then be used as a variable in a space tag 
symbol. For example, you might define a space’s Room ID using the design layer and 
space number fields as variables.

Rename User Fields If you entered data for any of the Additional Info fields, click this button to open the 
Rename User Fields dialog box and enter names for the fields.
When you click OK, a message displays that the change will be applied to all space 
objects that use that field.

Use IFC Data When the file is saved in IFC format, includes the IFC data for the space object 
IFC Data If Use IFC Data is selected, opens the IFC Data dialog box to enter the data for various 

space properties (see “Viewing and Editing IFC Data” on page 1748). When the drawing 
is complete, select File > Export > Export IFC Project to save the file in IFC format.

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Space Properties
Using Auto-Numbering
Editing Lists of Space Names and Occupant Organizations
Customizing Space Labels
Room Finishes
Customizing the Space Settings
GSA Data
Creating Spaces with the Space Tool
Editing Space Boundaries

Space Properties
The space parameters are described in “Space Settings” on page 406. Only the parameters that are different are 
described here.
Click to show/hide the parameters.

Parameter Description

Enable GSA Includes the GSA data for the space object when the file is saved in IFC format; 
click GSA Occupancy (on the Occupancy pane) to assign the GSA Occupancy 
information for the space. See “GSA Data” on page 429.

Enable multiple labels Adds Space Label 2 and Space Label 3 panes to the Space Settings dialog box; see 
“Space Settings: Space Label 1, 2, and 3 Panes” on page 412. When this option is 
selected, parameters for leader lines 2 and 3 are also added to the Leader Line pane.

Make picked up attributes 
the default

When the Pick Up Attributes mode of the Space tool is used, the attributes selected 
in the Eyedropper Transfer Properties list are set as the default for new spaces. If the 
2D Boundary Attributes are selected, the picked up attributes will be set as the 
default in the Attributes palette. This allows you to create new spaces with the same 
attributes as an existing space.

Eyedropper Transfer 
Properties

Specifies which properties of a space object will be transferred when the Pick Up 
Attributes and Apply Attributes modes of the Space tool are used. The available 
attributes display in the Attribute column, grouped by category. To see the attributes 
in a category, click the disclosure arrow to the left of the attribute name.
Click the Use column next to an item to select it; if the item is a category heading, 
such as Finishes, all items in the category are selected.

Space Properties on Object 
Info Palette

Specifies which properties of a space object will be displayed for editing on the 
Object Info palette. The available properties display in the Property column, 
grouped by category. To see the properties in a category, click the disclosure arrow to 
the left of the property name.
Click the Show column next to an item to select it; if the item is a category heading, 
such as Occupancy, all items in the category are selected.

Restore Default Properties Resets the space properties on the Object Info palette to the default settings
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Using Auto-Numbering
The Vectorworks Architect program can automatically number spaces as they are created, or you can enter numbers 
manually. If you use the auto-numbering feature, the Numbering pane of the Space Settings dialog box has additional 
features to customize numbers and to adjust numbers when needed.

Custom Number Styles
You can create custom space numbers that contain information other than just a counter, such as the floor the space is 
on, or what zone the space is in.
To create, edit, or delete a number style:

1. Select the Space tool, and then click Preferences on the Tool bar.
2. On the Space Settings dialog box, select Numbering from the left pane to display the Numbering pane.
3. Click Edit Number Styles to add, edit, or delete the available number styles.

The Edit Number Style dialog box opens.
Click to show/hide the parameters.

Parameter Description

Assign Zones
(Occupancy section)

Opens the Assign Zones dialog box, which has the same functionality as the Assign 
Zones section of the Occupancy pane of the Space Settings dialog box

Auto-Boundary Specifies whether the space object is associated with a set of walls, or whether its 
boundaries were created manually. For an auto-bounded space, if the walls are edited 
(whether moved, reshaped, or replaced, or due to a change in the wall style, the wall 
thickness, or the wall components), the space edge path updates automatically.

Update Boundary
(2D Boundaries & Area 
section)

Available only if Auto-Boundary is enabled.
Updates the boundary of the space to match the surrounding walls after visible walls are 
added, deleted, or moved; also updates the boundary if a custom space boundary 
definition is changed (for example, if the space boundary is offset from the walls).

Assign Room Finish
(Room Finish section)

Available only if On Room Finish Schedule is enabled; opens the Assign Room 
Finishes dialog box, which has the same functionality as the Room Finishes pane of the 
Space Settings dialog box.

This option is available when multiple spaces are selected, so the same finishes can 
easily be assigned to all selected space objects.

Matrix Order
(Additional Data section)

Specifies the location of the space object in the adjacency matrix
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4. Edit the number styles as follows:
• To add a new number style, type a style name into Space Number Style, and add a Prefix and/or Suffix if 

desired. Click Save; the number style is added to the Style Name/Style Definition/Saved in list.
• To edit a number style, select it from the Style Name/Style Definition/Saved in list and then edit the Prefix 

and/or Suffix as needed. Click Save to save the changes.
• To delete a number style, select it from the list and then click Delete.

5. When all editing is complete, click OK to close the Edit Number Style dialog box.

Validating Auto-Numbering
Occasionally the auto-numbering may need adjustment. For example, if a space is deleted after creation, one of the 
numbers will be missing from the sequence. If a space was duplicated, its number may be used twice for the same label 
type. The Vectorworks Architect program can help you detect and correct such problems.
To validate auto-numbering:

1. Select the space object.
2. From the Object Info palette, click the Settings button to open the Space Settings dialog box, and then select the 

Numbering pane.
3. Click Validate Auto-Numbering.

The Validate Auto-Numbering dialog box opens. 
Click to show/hide the parameters.

4. If there is a message next to a space number, select it and then click the correction button that displays beneath the 
list.

Parameter Description

Space Number Style Enter a descriptive name for the number style
Prefix / Suffix Specifies additional information to display before and/or after the space number. If a prefix 

or suffix is desired, enter text and/or select one or more items from the list of variables to 
the right of the fields to insert automatically generated data.
For example, your number style might have the floor the space is on, followed by a period 
and the automatically assigned space number. In the Prefix field, select the Floor variable, 
and then type a period; the space number variable is added to the definition automatically.

Style Name/Style 
Definition/Saved in

Displays the parameters of number styles that exist in the document. Select an item from 
the list to edit it.

Parameter Description

Total Counter of this Tag / 
Start Value / Increment

For the selected space object, displays the total number of space objects that use the 
same label, along with the start value and increment set for auto-numbering

Ctr / Space Number Each space object that uses the same label as this space displays in a list, which 
shows the space’s current counter (Ctr) and Space Number. The list also includes an 
entry if a number in the sequence is missing.

Correction button 
(name varies)

When a list item with a numbering error is selected, a button to correct the problem 
displays below the list.
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5. When all problems have been corrected, click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
Space Settings
Creating Spaces with the Space Tool

Editing Lists of Space Names and Occupant Organizations
The Occupancy pane of the Space Settings dialog box has Space Name and Occup. Organization fields from which 
you can select values to assign to spaces. The names are collected from files in the Vectorworks application folder, your 
user folder, and any folder designated as your workgroup folder.
From the Vectorworks application folder, the default content from the standard occupant organization and space name 
libraries is always available. These lists are called “BOMA Standard Occupant Organizations.txt” and “Generic Space 
Names.txt.” You cannot modify these lists, but you can import and export items from them. Use the Space Settings 
dialog box to create custom versions of these lists, or to create new lists, as needed. Edits are automatically saved to 
your user folder.
In a workgroup environment, create space name and occupant organization lists and place them in a shared location. 
The folder structure must be the same as that of the default content libraries. See “Customizing the Space Settings” on 
page 428.
To edit a list of space names or occupant organizations:

1. Select the Space tool, and then click Preferences on the Tool bar.
Alternatively, select an existing space object, and from the Object Info palette, click the Settings button.

2. On the Space Settings dialog box, select Occupancy from the left pane to display the Occupancy pane.
3. Click Space Name or Occup. Organization, and select Edit List from the bottom of the list.

The appropriate editing dialog box opens.
4. Select the list to view.

• To view items from the list in the current document, click Active Document.
• To view items from a list external to the drawing file, click Default Folder, and then select from the List 

options. Lists from the Vectorworks application folder, your user folder, and your designated workgroup folder 
display.

5. Edit, import, or export items as described in the following table. The options available depend on what type of list 
you are editing.

Message Problem Correction

missing A number in the sequence is missing Click Close Gaps to renumber all spaces that fall 
after the gap in the sequence

Value invalid (< Start) The space’s current number is less 
than the start value

Click Assign valid value to automatically 
renumber the spaces as needed

(multiple) Multiple spaces have this number Click Increase by Increment to automatically 
renumber the space

Edit Function Applicable Files Procedure

Rename the list User lists Click Rename, enter the new list name, and click OK. The list name 
in the edit dialog box changes.
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6. Click OK to save the changes and close the edit dialog box. If you changed an external list, a message displays the 
path in your user folder where the edited file was saved; click OK.

7. Click OK to close the Space Settings dialog box.
~~~~~~~~~~~~~~~~~~~~~~~~~
Resource Libraries
Customizing the Space Settings
Space Settings
Creating Spaces with the Space Tool

Customizing Space Labels
The Vectorworks Architect product provides several space labels, which you can use or modify as needed. You can also 
create new custom labels, import a space label symbol from another document, or convert a symbol in the current 
document into a space label.
Custom space labels are symbols that are designated as space labels from the Space Settings dialog box. Like any other 
symbol, by default a custom label is only available in the document in which it is created. To make a custom space label 
available from the Space Settings dialog box for all of your documents, use the Save as Default option to save the label 

Change the list order Active document, 
user lists

Click the item number and drag it up or down to the desired position.

Add an item Active document, 
user lists

Click New.
• If the active document list or a user list is selected, a blank item is 

added to the current list. Enter a name in the Item Value field.
• If a list from the application folder or a workgroup folder is 

selected, an alert displays, and you are prompted to add the item to 
a list in your user folder instead. Answer Yes to open a dialog box 
to add an item.
Enter a name in the Item Value field. To create a new file, select 
Save to New File and enter a unique name. To add to an existing 
file, select Add to Current File and select a file from the 
pull-down list. Click OK to display the new item and list.

Edit an item name Active document, 
user lists

Select the item and enter the new name in the Item Value field.

Delete an item Active document, 
user lists

Select the item and click Delete. The item is removed from the list, 
and the items below it on the list are renumbered.

Import items User, workgroup, and 
application lists

Select one or more items and click Import. The items are added to 
the Active Document list.

Export items Active document, 
user, workgroup, and 
application lists

Select one or more items and click Export to open the export dialog 
box.
To create a new file, select Export to New File and enter a unique 
name. To add to an existing file, select Add to Current File and 
select a file from the pull-down list. Click OK to complete the 
export.

Edit Function Applicable Files Procedure
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to a template file. The Space Default template file is created in your user folder automatically, in 
[User Folder]\Libraries\Defaults\.
To share custom space labels with a workgroup, create a template file that contains the labels (see “Creating Space 
Labels” on page 423). Place the file in the workgroup’s default labels folder. The labels then display on the list of 
available symbols on the Space Label pane of the Space Settings dialog box. See “Customizing the Space Settings” on 
page 428.

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Existing Space Labels
Creating Space Labels
Converting Symbols into Space Labels

Editing Existing Space Labels
You can easily make minor adjustments to an existing space label. For example, you might adjust the font style or 
color, or change the graphics that are included in the symbol.
To modify an existing space label symbol:

1. Do one of the following:
• From the Space Label pane of the Space Settings dialog box, select the label to be edited; a preview of it 

displays on the right side of the dialog box. Click Edit Layout to open the symbol editing window.
• If the label displays in the Symbols/Plug-in Objects group in the Resource Browser, select it and then select 

Resources > Edit. From the Edit Symbol dialog box, select the 2D Component option, and click Edit to open 
the symbol editing window.

2. In the symbol editing window, edit the text formatting, graphic components, and attributes of the symbol as 
needed. Note that a space label is a page-based symbol, which means that its size in the editing window is the 
same as it will be when inserted into the drawing.

Space label symbol

http://www.youtube.com/watch?v=eO9V7C65ENk
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3. When the changes are complete, click Exit Symbol.
4. The symbol definition and all instances of the label in the drawing are updated automatically.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating New Symbols
Creating Space Labels

Creating Space Labels
If none of the available space labels are suitable, create a new label.
To create a new space label:

1. From the Space Planning tool set or the Building Shell tool set, select the Space tool.
2. From the Tool bar, click Preferences to open the Space Settings dialog box.
3. Select the desired space label pane, and click Manage Space Labels. The Manage Space Labels dialog box opens.

4. Click New Text Tag; the New Text Tag dialog box opens to the Data Fields tab.
5. All available data fields for spaces display in the list on the left. Select the fields to be used in the symbol, and 

click Add (or click Add All) to move them to the list on the right. To remove fields from the symbol list, select 
them and click Remove (or click Remove All). Alternatively, double-click a field name to move it from one list to 
the other.

Item Description

Symbols list The left side of the dialog box displays a list of all space label symbols currently available, 
along with the current status of each:
• “Default” symbols are those available from default content, but not yet used in the drawing; 

once a default space label symbol is used, it is imported into the drawing file’s resources and 
the status becomes Specified. Default symbols cannot be renamed or deleted.

• “Specified” symbols are currently used in the drawing.
• “Unspecified” symbols are currently in the drawing file’s resources, but not yet used or saved 

as a default.
Symbol preview The top right side of the dialog box displays a preview of the selected symbol; if a label field 

has not been defined yet, a red “Not specified” message displays on the image
New Text Tag Opens the New Text Tag dialog box, to create a new space symbol; proceed with step 4

New Symbol Tag Opens the New Symbol Tag dialog box, to designate a symbol in the current document as a 
space symbol. 

Rename Opens the Rename Label dialog box; enter a new name for the symbol and click OK.
If the selected symbol has a “Default” status, a message displays that it cannot be renamed.

Duplicate Opens the Duplicate Label Symbol dialog box; enter a name for the duplicate symbol and click 
OK.

Delete Opens the Delete Space Label dialog box. Specify whether to delete the space symbol from the 
symbol library entirely, or to keep the symbol, but remove the space label definition from it 
(this removes the label from the list of current space label choices). Click OK to delete the 
label.
If the selected symbol has a “Default” status, a message displays that it cannot be deleted.
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6. In the list of selected symbol fields on the right, each field is assigned a sequential number, which corresponds to 
a variable in the symbol layout (for example, #2#). To change a field’s number, click its number column, and drag 
the field up or down to the desired location on the list.

7. Select the Attributes tab to specify how all fields in the symbol will display.

8. Click OK to save the changes and return to the Manage Space Labels dialog box. Click OK again to return to the 
applicable space label pane.

9. Complete the definition of the label.
10. To save the label to your template, select the Save as Default option.
11. To change the appearance of the label (for example, to rearrange the data fields or to add graphic elements), click 

Edit Layout to open the symbol editing window.
The symbol is a group object, in which each defined field is a text block that contains text in the following format: 
#(natural number)#. You may ungroup the blocks and move them or change their attributes, but do not change the 
contents of the text blocks.
In the following example, the top part of the symbol is a center-aligned text block that contains a variable for field 
1; the Space Number will be assigned to this field. The bottom part of the label has a text block that contains a 
variable for field 2; the Occupant Name field will be assigned to this field. Another text block was added, which 
serves as a label for the occupant name. A rectangle and a line were also added to enhance the label.

12. When the edits are complete, click Exit Symbol. The new label is now available to assign to spaces for this 
document.

Item Description

Font Select a font for the field text from the list of fonts available on the system
Size Select a font size from the list of standard sizes available in points. To enter a custom point 

size, or to enter a size in different units, select Set Size to open the Set Text Size dialog box. 
Enter a Size, and then select the appropriate Unit: Points, Page Millimeters, or Page Inches.

Style Select a style for the field text from the list of styles available. On Mac, select Custom Style to 
open the Custom Style dialog box, to specify a different combination of styles.

Alignment Select a type of alignment for the field text: Left, Center, Right, or Standard (justify)
Fill Select a fill for the background of the field text objects: None, Pattern, or Solid. Alternatively, 

to assign the fill by text object class, select Class Style.
Color If a Solid fill was selected, select the fill color
Pattern/Fore/Back If a Pattern fill was selected, select the Pattern, and the foreground and background colors
Text Color Select a color for the field text

Text block for field 1 variable

Text block for field 2 variableStatic text block
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Converting Symbols into Space Labels
If you already have a symbol you want to use, you can convert it for use as a space label.
To convert a symbol into a space label:

1. Ensure that the symbol includes a text block for each piece of space object data you want to display on the label. 
The text in each field block should be in the following format: #(natural number)#. The example below has four 
fields. Apply the font, size, style, alignment, and fill and pen style desired to each text block.
Also, ensure that the space label symbol is specified as having world-based units (not page-based).

2. From the Space Planning tool set or the Building Shell tool set, select the Space tool.
3. From the Tool bar, click Preferences to open the Space Settings dialog box.
4. Select the desired space label pane, and click Manage Space Labels. The Manage Space Labels dialog box opens.
5. Click New Symbol Tag; the New Symbol Tag dialog box opens.
6. The available symbols and symbol folders in the current document display; symbols already defined as space 

labels do not display. Locate and select the symbol to be used for the new label, and click OK.
7. On the Manage Space Labels dialog box, notice that the preview window shows that the fields are not specified 

yet. Click OK to return to the Space Settings dialog box.
8. Complete the definition of the data fields. The new label is now available to assign to spaces for this document.
9. To save the label to your template, select the Save as Default option.

~~~~~~~~~~~~~~~~~~~~~~~~~
Space Settings: Space Label 1, 2, and 3 Panes
Customizing Space Labels
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Room Finishes

Creating, Editing, and Deleting Room Finishes
The Room Finishes pane of the Space Settings dialog box has Ceiling, Base Trim, Floor, and North/South/East/West 
Wall fields from which you can select values to assign to spaces. The names are collected from files in the Vectorworks 
application folder, your user folder, and any folder designated as your workgroup folder.
From the Vectorworks application folder, the default content from the room finish libraries is always available. You 
cannot modify these lists, but you can import and export items from them. Use the Space Settings dialog box to create 
custom versions of these room finish lists, or to create new lists, as needed. Edits are automatically saved to your user 
folder.
In a workgroup environment, create room finish lists and place them in a shared location. The folder structure must be 
the same as that of the default content libraries. To edit a room finish list:

1. Select the Space tool, and then click Preferences on the Tool bar.
2. On the Space Settings dialog box, select Room Finishes from the left pane to display the Room Finishes pane.

Alternatively, select one or more existing space objects and click Assign Room Finish in the Object Info palette 
to open the Assign Room Finishes dialog box. (If the button is not enabled, select On Room Finish Schedule.) If 
room finishes are different for multiple selected space objects, the options display as a blank. Any edits to that 
parameter affect all of the selected spaces.

3. Click Edit Finishes to add, edit, or delete the available room finishes.
The Edit Room Finishes dialog box opens.

4. Select the list of room finishes to view.
• To view items from the current document, click Document Finishes, and then select from the Location 

options (ceiling, walls, baseboard, or floor).
• To view items from a list external to the drawing file, click Default Finishes, and then select from the 

Location options. Lists from the Vectorworks application folder, your user folder, and your designated 
workgroup folder display.

5. Edit, import, or export items as described in the following table. The options available depend on what type of list 
you are editing.

Edit Function Applicable Files Procedure

Rename the list User lists Click Rename, enter the new list name, and click OK. The list name 
in the edit dialog box changes.

Change the list order Active document, 
user lists

Click the item number and drag it up or down to the desired position.
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6. Click OK to save the changes and close the edit dialog box. If you changed an external finish list, a message 
displays the path in your user folder where the edited file was saved; click OK.

7. Click OK to close the Space Settings dialog box.
~~~~~~~~~~~~~~~~~~~~~~~~~
Resource Libraries
Customizing the Space Settings
Space Settings
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Assigning a Room Finish
Room finishes can be applied to space objects (see “Creating Spaces from Existing Walls” on page 405). The 
information displays in the Room Finish Schedule and in the Room Finish Legend (see “Records and Schedules” on 
page 1859).
To assign finishes to a space object:

1. Select an existing space object.

Add an item Active document, 
user lists

Click New.
• If an active document list or user list is selected, a blank item is 

added to the current list. Enter a Key and Description.
• If a list from the application folder or a workgroup folder is 

selected, an alert displays, and you are prompted to add the item 
to a list in your user folder instead. Answer Yes to open a dialog 
box to add an item.
Enter a Key and Description. To create a new file, select Save to 
New File and enter a unique name. To add to an existing file, 
select Add to Current File and select a file from the pull-down 
list. Click OK to display the new item and list.

Edit an item Key or 
Description

Active document, 
user lists

Select the item and enter the new value in the appropriate field. The 
Key is the ID that displays for the selected finish in the space label 
(if applicable), Room Finish Legend, and Room Finish Schedule. 
Description text displays for the selected finish in the Room Finish 
Legend.

Delete an item Active document, 
user lists

Select the item and click Delete. The item is removed from the list, 
and the items below it on the list are renumbered.

Import items User, workgroup, and 
application lists

Select one or more items and click Import. The items are added to 
the appropriate list in the current document.

Export items Active document, 
user, workgroup, and 
application lists

Select one or more items and click Export to open the export dialog 
box.
To create a new file, select Export to New File and enter a unique 
name. To add to an existing file, select Add to Current File and 
select a file from the pull-down list. Click OK to complete the 
export.

Edit Function Applicable Files Procedure
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2. In the Object Info palette, select On Room Finish Schedule to add the finish information to the Room Finish 
Schedule. Click Assign Room Finish.
The Assign Room Finishes dialog box opens.
Alternatively, click Settings to open the Space Settings dialog box, and select the Room Finishes pane.

Click to show/hide the parameters.

3. Select the desired finishes for each part of the room and click OK. The information is associated with the selected 
space object.

4. The Room Finish Schedule can be added to the drawing from the VA Create Schedule command or the Resource 
Browser. From the Resource Browser, open the default architectural reports file from the [Vectorworks]\Libraries 
folder. Drag the Room Finish Schedule worksheet to the drawing. The worksheet is populated with information 
from the objects in the current drawing.To add a legend for the Room Finish Schedule, use the Create Rm Finish 
Legend command.

~~~~~~~~~~~~~~~~~~~~~~~~~
Resource Libraries
Creating, Editing, and Deleting Room Finishes
Creating a Room Finish Legend
Creating Schedules
Space Settings
Creating Spaces with the Space Tool

Customizing the Space Settings
When you edit the space name, occupant organization, and room finish lists, the changes are saved to text files in your 
user folder. In a workgroup environment, you can create a set of files that contain standard settings for your office and 
share them with coworkers over a network.
To access the shared content, another Vectorworks user simply designates that folder as a workgroup folder in his or her 
Vectorworks Preferences. Then, when the user creates spaces in a drawing, the space name, occupant organization, and 
room finish list items are collected from files in the Vectorworks program folder, the user folder, and any folder 
designated as a workgroup folder.
To create custom space settings:

1. In the Space tool’s preferences, customize the space name, occupant organization, and room finish lists as needed. 
The appropriate files are created in the user data folder specified in your Vectorworks preferences (see “User 
Folders Preferences” on page 57).

2. To share the custom files with a workgroup, put the files on the network in a workgroup folder. When coworkers 
set up this workgroup folder in their Vectorworks preferences, they also have access to the files (see “Sharing 
Custom Content Using Workgroup Folders” on page 216). The folder structure must be the same as the default 

Parameter Description

Ceiling Lists all of the defined finish items for ceilings
North, East, South, and West Walls Lists all of the defined finish items for each wall
Base Lists all of the defined finish items for baseboards
Floor Lists all of the defined finish items for floors
Finish Remarks Allows entry of additional remarks about the finishes
Edit Finishes Opens the Edit Room Finishes dialog box
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content room finish, standard occupant organization, and space name libraries provided in 
[Vectorworks]\Libraries. For example, to add a custom space name library, place the file in your workgroup 
default space name folder: [Workgroup]\Libraries\Defaults\Space - Space Name.

3. To share custom space labels with a workgroup, save the labels to your template file (see “Creating Space Labels” 
on page 423). Place the file in the workgroup’s default space stamp folder.

4. Remove the custom files you created from your user folder if you intend to use the workgroup settings. Remember 
that the contents of the user folder have priority over the contents of the workgroup folder.

~~~~~~~~~~~~~~~~~~~~~~~~~
Space Settings: Occupancy Pane
Custom Number Styles
Editing Lists of Space Names and Occupant Organizations
Customizing Space Labels
Creating, Editing, and Deleting Room Finishes

GSA Data
The General Services Administration in the United States has set deliverables standards that require that projects be 
delivered in IFC format. In addition, they require that certain additional GSA-specific data be included with spaces.
To specify GSA data for a space object:

1. Select an existing space object.
2. In the Object Info palette, click Settings to open the Space Settings dialog box.
3. Select the Advanced Settings pane, and then click Enable GSA.
4. Select the Occupancy pane, and then click GSA Occupancy.

The GSA Occupancy dialog box opens.
Click to show/hide the parameters.

5. Enter the GSA data for the space object and click OK.
6. When the drawing is complete and all required GSA data has been entered, select File > Export > Export IFC 

Project to save the file in IFC format.

GSA Spatial Program BIM Requirements
A GSA spatial program BIM has some specific modeling requirements. Use the following guidelines to create an 
optimal IFC export from the Vectorworks program, that is compatible with all GSA guidelines and standards.

Parameter Description

OmniClass Select the federal agency classification for the space by its function; to see the subclasses 
beneath a heading, click the disclosure arrow to the left of the heading

Space Category Select the GSA category for the space; the numeric code for the category displays to the left
Space Type Select the GSA code that describes the usage of the space; a description of the code displays to 

the right
Occupant Select the federal agency code and name for the organization that will occupy the space; to see 

the subclasses beneath a heading, click the disclosure arrow to the left of the heading
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General
• Reduce, eliminate, or deactivate (by hiding appropriate classes) the 3D components of objects that do not 

contribute to the spatial definition of the model. While the IFC data format does support a number of “non-spatial” 
or “non-structural” items, they are not required for the current GSA spatial program BIM.

• Ensure that all wall intersections are correctly configured, so that an automatically bound space object can 
properly detect room extents.

• Ensure that all space objects have the following settings in the Object Info palette: 
• 2D Boundary Display (2D Boundaries & Area section) is set to “Net Boundary”
• 2D Net Boundary Definition (2D Boundaries & Area section) is set to “Inside Face of Walls”
• Show 3D (3D Boundaries section) is enabled
• The Volume Display of the 3D boundary is set to “Net,” and the height is set to properly represent the full 

height of the space, either manually, or based on story-aware settings

Columns and Pilasters
The GSA requires a “net” space boundary that wraps around pilasters and free-standing concrete columns, excluding 
them from the area calculations. However, the space boundary should not wrap around steel columns, or columns 
embedded in a wall; these should be ignored.
To create a GSA BIM-compatible vertical support, use either the Column or Pilaster tool. A column is restricted to 
symmetrical square or oval plan geometry. A pilaster must be set to Architectural, or Structural and Architectural, to 
comply with GSA requirements. The space boundary will wrap around the extents of these structures.
Columns that are exposed steel wide flanges or H-shapes do not need to be excluded from the GSA BIM area. If a 
structural steel column is required, use extruded plan geometry inside a hybrid symbol to create the column; the 
column will be recognized as 3D geometry, but it will not be excluded from the GSA BIM area in the space object.

Shafts
Per GSA guidelines, a shaft that has a floor penetration greater than nine square feet should be designated as its own 
space.
If this shaft is bounded completely by walls, simply create a space object inside the shaft. If the shaft is not bounded by 
walls, use the Wall tool’s <Virtual wall> style to create a boundary; once the shaft is surrounded with virtual walls, 
create spaces in the room and shaft.
~~~~~~~~~~~~~~~~~~~~~~~~~
Space Settings
Creating Spaces with the Space Tool
Creating Columns and Pilasters

Creating Spaces from Walls
Floor plans can be created by first creating walls, and then automatically creating spaces to determine the area of each 
room or the gross area defined by the wall perimeter.
To create spaces from walls:

1. Create the walls and ensure that they are properly joined.



Creating Spaces from Walls |  431
2. From the Attributes palette, set the 2D attributes for the spaces (fill, pen, opacity, and line thickness).
3. Select the Space tool, and from the Tool bar, select Preferences. Set the default parameters for the space objects.
4. Select AEC > Space Planning > Create Spaces from Walls. The Create Spaces from Walls dialog box opens. 

Specify how to create the spaces, the minimum area for creating spaces, and their location.
Click to show/hide the parameters.

5. Click OK to create the spaces on the destination layer.

Parameter Description

Create Room Spaces Creates space objects for each room defined by the walls in the source layer
Create Gross Floor Space Creates a single space object equivalent to the entire outer boundary of the walls 

in the source layer
Source Layer Specifies the layer that contains the walls
Destination Layer Indicates the layer on which to create the spaces
Minimum area Specifies the threshold for creating a space; spaces will be created only for areas 

above this value
Create Spaces from Selected 
Walls Only

Creates spaces only from selected walls; deselect to create spaces from all the 
walls in the source layer
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Spaces are created for all areas enclosed by walls, or for the gross area defined by boundary of the walls. Default 
room name information is set and should be edited to complete the floor plan.

After the spaces are created, the original walls can still be modified. To update the spaces to conform to the new walls, 
select the Create Spaces from Walls command again. The existing spaces are reshaped without losing any space 
parameters that have already been specified.

If the original spaces were not drawn perfectly straight, select the Create Walls from Spaces command with the 
Constrain Straight Walls option. Now that the walls are straight, select the Create Spaces from Walls command 
to straighten the spaces.

~~~~~~~~~~~~~~~~~~~~~~~~~
Space Settings
Creating Spaces with the Space Tool

Creating Spaces from Polylines
During the initial stages of a design, it may be easier to work with polylines instead of spaces. Use the Modify > Add/
Clip/Intersect/Combine into Surface commands to modify the polylines to create the desired shapes. Once the 
polyline shapes are finalized, convert them into spaces to take advantage of the additional features that space objects 
provide, such as labels, area calculations, room finishes, and so on.
To convert polylines into spaces:

1. From the Attributes palette, set the 2D attributes for the spaces (fill, pen, opacity, and line thickness).
2. Select the Space tool, and from the Tool bar, select Preferences. Set the default parameters for the space objects.
3. Select the polylines to convert into spaces. This command also converts rectangles, rounded rectangles, polygons, 

arcs, circles, and ovals into spaces.
4. Select AEC > Space Planning > Create Spaces from Polys. The selected items are converted into spaces.

1 - Space

2 - Space

3 - Space

4 - Space

Office 2
77.9 sq ft

Office 1
327.8 sq ft

Office 3
94.7 sq ft
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Another option is to draw a polyline and then select the Create Objects from Shapes command (see “Creating 
Polylines” on page 298 and “Creating a Stacking Diagram” on page 442).
~~~~~~~~~~~~~~~~~~~~~~~~~
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Creating Spaces with the Space Tool

Getting Floorplan Information from a Solid Model
If a solid model has been used to develop a massing study, information can be extracted from the model to begin work 
on the floorplans. Specifically, gross area polylines can be created automatically for each building level directly from 
the solid model with the Model to Floorplan command. A stacking diagram can display the sum of the areas of these 
polylines, which makes it easy to determine the amount of floor area provided by a solid model before creating the 
floorplans. In addition, exterior walls can be created automatically. If the model changes after the polylines and walls 
are created, run the Model to Floorplan command again to update the polylines and walls.
To create a floorplan from a model:

1. Select the model. The solid model should be a CSG solid (addition, subtraction, union), solid primitive (sphere, 
hemisphere, cone, cylinder), extrude, or multiple extrude.
This command cannot be used in Top/Plan view. Select the model from a 3D view.

2. Select AEC > Space Planning > Model to Floorplan.
The Model to Floorplan dialog box opens. Specify the layers to include and set the type of floorplan elements to 
create.

Click to show/hide the parameters.

3. Click OK to create the floorplan objects. If selected, polylines, walls, and a stacking diagram are placed on the 
drawing. To update the floorplan objects based on model changes, select the Model to Floorplan command again.

Parameter Description

Layer list Lists the layers with heights that intersect the solid. Select the design layer(s) to 
include in the floorplan, and deselect layers, such as sheet layers or site model layers, 
which should not be included in the floorplan. A selected layer displays with a check 
mark.

Create Gross Area Polylines For each selected layer, creates a polyline from the exterior perimeter of the model
Create Stacking Diagram Creates a stacking diagram showing the available area on each layer (see “Creating a 

Stacking Diagram” on page 442)
Create walls Creates walls based on the model perimeter

Position Creates exterior walls based on the model perimeter, along the inside, outside, or 
center of the perimeter

Wall Style Specify a wall style to use for the exterior walls from either the default content or the 
current file’s content
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Resource Libraries

Editing Space Boundaries
Once a space is created, its boundary is edited differently depending on the current Auto-Boundary setting. 

• If Auto-Boundary is enabled, the space is associated with a set of walls, regardless of whether the walls are 
visible. When the walls that surround the space change, in many cases, the space updates automatically.

• If Auto-Boundary is disabled, the space must be edited directly as a path object.
Each space has a control point that indicates the label location. If the space is auto-bounded, it also has a separate 
“anchor” control point that locates the space within its boundary. The anchor control point is typically in the center of 
the space’s bounding box, so it may be directly on top of the label control point. (If you create the space with Inner 
Boundary mode, the anchor is placed where you click to create the space.)
To move a label or an anchor, click the control point and drag it to a new location; click again to move the point. If a 
label is moved outside of the space boundary, a line is drawn to connect the label to the space automatically.

To edit a space with Auto-Boundary enabled:
1. Add, delete, or move the associated walls. 
2. The spaces and labels update automatically, unless you are adding a new wall that affects an existing space or 

removing a wall that surrounds a space.
• If walls have been moved, the wall settings (thickness or components) have changed, or you move, edit, or 

delete an associated column or wall feature, the associated space object(s) and labels update automatically. 
• If walls that are associated with a space are deleted, the space changes from an auto-bound space to a manual 

space. The space can be associated with new walls.
• If walls have been added, update the space object(s). Select one or more spaces, and then click Update 

Boundary from the Object Info palette. The location of the updated space is based on the position of the 
anchor point; other areas created by the dividing wall remain empty.

Alternatively, select AEC > Space Planning > Update Space Boundaries to update all spaces, whether or not 
they are selected.

Kitchen

Floor 1

Floor 2
Lobby

Office
Total Used/Available:

10 Walk-in Closet
11

Bedroom 3
10

Bedroom 3

Click the control point of the space label and 
drag it outside the space boundary

Click to place the label; a line is automatically drawn from the 
space boundary to the new position of the control point

Walk-in Closet
11

Label control point Label control point
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3. The boundary of the space adjusts to match the surrounding walls; if the space label anchor point is now outside 
the space, a line is drawn automatically from the label to the space. 
In cases where architects may have adjacent spaces in a design that are not explicitly separated by an actual wall, 
the <Virtual wall> wall style (a wall without width or height) gives the user a boundary for space objects to see 
when Auto-Boundary is enabled, primarily for IFC export.

To edit a space with Auto-Boundary disabled:
• To add, subtract, and change vertices, edit the polyline with the Reshape tool.
• The space object is a path object and some parameters cannot be edited directly from the Object Info palette. To 

make changes to the space path object, including changing its dimensions, select Modify > Edit Space. For 
example, you can reshape, add, clip, intersect, and combine into surfaces. Click Exit Path to return to the 
drawing.

Converting Space Boundary Associations
Converting to Manual Mode

Auto-bounded spaces can be converted to manual mode, releasing them from their association with walls. 
To convert auto-bounded spaces to manual spaces:

1. Select the auto-bounded space. In the Object Info palette, the Auto-Boundary mode displays Auto-Bounded.
2. Select Manual from the Auto-Boundary list.

The space is disassociated from its wall set, though it remains in place.

Converting to Auto-Bounded Mode Using Anchor Points

Manually bounded spaces can be converted to auto-bounded mode by automatically associating them with the 
surrounding walls.
To convert manual spaces to auto-bounded spaces:

1. Select the manual space(s). In the Object Info palette, the Auto-Boundary mode displays Manual.
2. Select Auto-Boundary from the Auto-Boundary list.

The space object(s) is regenerated using the anchor point(s) to find the surrounding walls and associate them with 
the space(s).

Converting to Auto-Bounded Mode by Picking Boundaries

Manually drawn spaces can be associated with a set of walls, converting them to auto-bounded mode. Similarly, an 
auto-bounded space can be associated with a new set of walls by this method.
To convert manual spaces to auto-bounded spaces:

1. Select the manual space. In the Object Info palette, the Auto-Boundary mode displays Manual.
2. Select Pick Boundary from the Auto-Boundary list.

The Space tool is automatically activated, and Inner Boundary mode is selected (Picked Walls mode can also be 
selected).

3. For Inner Boundary mode, click in an open area of the drawing that is bounded by walls. For Picked Walls mode, 
click on each wall that forms the wall set and press Enter, or click the check mark button on the Tool bar.

4. The manual space is associated with the wall set. Its location and size may change as it is bounded by the wall set.
~~~~~~~~~~~~~~~~~~~~~~~~~
Converting Space Boundary Associations
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Programming Studies
The Vectorworks Architect product provides several tools for creating and managing space programming study 
information in both tabular and graphical formats, including an adjacency matrix, bubble diagram, and stacking 
diagram.
In an adjacency matrix worksheet, information is used to automatically create the following items in the drawing:

• a bubble diagram, containing space objects for each space in the matrix, with the appropriate area and department 
information, and space links connecting the spaces, with line weights indicating the strength of the relationship 
between the spaces

• an adjacency matrix diagram
• an adjacency score object, showing the total lengths of all the space links
• a stacking diagram

The space objects are square when they are first created, but they can be reshaped with the Reshape tool. The spaces 
can be repositioned to create clusters of related spaces.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating an Adjacency Matrix
Creating a Bubble Diagram
Creating a Stacking Diagram

Creating an Adjacency Matrix
Adjacency matrices specify, in tabular format, the spaces and area requirements that must be incorporated into a design. 
In addition, the relationships among the various spaces are identified. Spaces which should be located next to each 
other are strongly related, while spaces which can or should be separated have a weak relationship.
An adjacency matrix is typically developed in a spreadsheet program and imported into a Vectorworks file. An 
adjacency matrix can also be created in a worksheet in a Vectorworks file, exported as a tab-delimited file, and then 
imported back into a Vectorworks file to create an adjacency matrix.

Adjacency matrix

Bubble diagram

Stacking diagram

Adjacency score
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Creating an Adjacency Matrix Worksheet
Importing an Adjacency Matrix Spreadsheet
Inserting an Adjacency Matrix

Creating an Adjacency Matrix Worksheet
To create an adjacency matrix worksheet:

1. From the Resource Browser, select Resources > New Resource > Worksheet. 
2. Create the adjacency matrix, using every other row for space names and areas, and alternate rows for specifying 

the relationships among the spaces.

Any third-party spreadsheet program that can save a tab- or comma-delimited text file can be used to create the 
adjacency matrix. Ensure that there is at least one cell containing data on each spreadsheet row. Certain 
spreadsheet programs do not export rows without data, which could disrupt the expected sequence of data in the 
file as it is imported into the Vectorworks file.

3. Click File > Export > Export Worksheet to export the worksheet as a tab- or comma-delimited file.
4. Click OK and specify the name and location of the file.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Worksheets
Importing an Adjacency Matrix Spreadsheet

Importing an Adjacency Matrix Spreadsheet
To import an adjacency matrix:

1. Ensure that the file to be imported is a tab- or comma-delimited file.
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2. Select AEC > Space Planning > Import Adjacency Matrix. The Import Adjacency Matrix dialog box opens. 
Specify the adjacency matrix file import options.

Click to show/hide the parameters.

3. Click OK to import the adjacency matrix. If this is the first time an adjacency matrix, stacking diagram, spaces, or 
space links are placed in the file, the object properties dialog box opens for each type of object. Accept the default 
values and click OK.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting an Adjacency Matrix

Inserting an Adjacency Matrix
An adjacency matrix diagram can also be created manually with the Adjacency Matrix tool, based on spaces and 
space relationships currently in the file.

To insert an adjacency matrix diagram:

1. Click the Adjacency Matrix tool from the Space Planning tool set.
2. Click at the desired location for the adjacency matrix.
3. Click again to set the matrix rotation. If this is the first time an adjacency matrix diagram is placed on the drawing, 

the object properties dialog box opens. Specify the default preferences, which apply to all adjacency matrix 
diagrams placed subsequently in this drawing. Properties can be edited later in the Object Info palette. Click OK.
The adjacency matrix is created. If no space objects currently exist in the drawing, an adjacency matrix place 
holder is created.

Parameter Description

External Filename Enter the name of the adjacency matrix file or click Browse to specify its location; a sample 
file is specified by default

Header Rows Specifies the number of rows in the spreadsheet that do not include space or space relationship 
information

Row Spacing Set this to 0 (zero) if there is a space name on every row or set this to 1 if there is a space name 
on every other row in the drawing file

Field Delimiter Specifies the delimiter that was used to separate fields for the spreadsheet
Column Numbers 
and Preview

Specifies the columns to include in the adjacency matrix as well as their position

Department Select to include department number information and specify its column number
Space Select to include area name information and specify its column number
Area Select to include the space area information and specify its column number
Relationships Select to include the space relationship information and specify its column number

Preview Displays the data in the selected columns
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The adjacency matrix is more than just a presentation graphic, because it dynamically shows what is in the drawing. 
The adjacency matrix updates automatically when spaces or space links change.
The Rotation, Height Scale and Width Scale parameters of an adjacency matrix can be edited in the Object Info 
palette.
To adjust the order of adjacency matrix spaces, change the Matrix Order number in the Object Info palette for the 
relevant space object.
~~~~~~~~~~~~~~~~~~~~~~~~~
Space Properties
Creating an Adjacency Matrix

Creating a Bubble Diagram
A bubble diagram is a graphical view of the data from a space planning spreadsheet. Spaces are connected by space 
links that represent the relationships among the spaces. Thick links indicate a strong relationship between the spaces, 
while weak relationships are drawn with thin lines. The efficiency of the bubble diagram layout can be determined by 
calculating its adjacency score.
A bubble diagram is inserted into a drawing automatically when an adjacency matrix is imported (see “Importing an 
Adjacency Matrix Spreadsheet” on page 438). A bubble diagram can also be created manually by linking spaces with 
the Space Link tool.
~~~~~~~~~~~~~~~~~~~~~~~~~
Linking Spaces
Calculating the Adjacency Score

Linking Spaces

To link spaces:

1. Create spaces as described in “Creating Spaces with the Space Tool” on page 403.
2. Click the Space Link tool from the Space Planning tool set.
3. Click on the first space to link, and then on the second space. The space link is automatically created.
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The space links update dynamically as the spaces are moved around in the drawing.
To change the strength of a link, select it and change the Strength value (from 1 to 18) in the Object Info palette.
~~~~~~~~~~~~~~~~~~~~~~~~~
Calculating the Adjacency Score

Calculating the Adjacency Score
The adjacency score object displays a numerical value that represents the efficiency of the space layout. The score 
value is determined by first multiplying the link length times strength for each space link, and then calculating the sum 
of these values for all the space links in the file. The lower the score, the more efficient the layout.

To insert an adjacency score object:

1. Click the Adjacency Score tool from the Space Planning tool set.
2. Click in the document to set the object location.
3. Click a second time to set the object rotation.

If spaces or space link objects are deleted, the adjacency score object value is not automatically updated. Slightly 
move any space or adjacency score object in the document to reset the adjacency score object value.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Bubble Diagram

Office
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Creating a Stacking Diagram
A stacking diagram provides a floor-by-floor representation of the total amount of area taken up by all the spaces on the 
floors. It is useful for balancing the allocation of spaces among several floors.
A stacking diagram is inserted into a drawing automatically when an adjacency matrix is imported (see “Importing an 
Adjacency Matrix Spreadsheet” on page 438). A stacking diagram can also be inserted manually with the Stacking 
Diagram tool. The stacking diagram is based on spaces and space relationships currently in the file.

To insert a stacking diagram:

1. Click the Stacking Diagram tool from the Space Planning tool set.
2. Click at the desired location for the stacking diagram. Click again to set the diagram rotation. If this is the first 

time a stacking diagram is placed on the drawing, the object properties dialog box opens. Specify the default 
preferences, which apply to all stacking diagrams placed subsequently in this drawing. Properties can be edited 
later in the Object Info palette. Click OK.

3. The stacking diagram is created.
The layers are “stacked” on the basis of their layer elevation values, which can be changed in the Organization 
dialog box (Tools > Organization).
If no space objects currently exist in the drawing, a stacking diagram place holder is created.

Like the adjacency matrix, the stacking diagram dynamically shows what is in the drawing. The stacking diagram 
updates automatically when spaces or space links are changed. In addition, fill attributes assigned to spaces are 
reflected in the stacking diagram automatically.
The Rotation, Height Scale and Width Scale parameters of an adjacency matrix can be edited in the Object Info 
palette. In addition, the Gap Scale parameter controls the distance between the stacking diagram rows. Show Totals 
toggles the display of the total amount of space used.
The stacking diagram is arranged in rows that correspond to the layers of the drawing. The spaces present in each layer 
are shown in separate rows; the layer name and total area used are displayed to the left of each row.
Spaces in the stacking diagram are grouped by Department name (set for each space in the Object Info palette). 
Adjacent spaces with the same Department name are separated by thin lines.

Spaces and area allocated to
“Top Floor” layer

Spaces and area allocated to
“Bottom Floor” layer

Thinner lines separate 
spaces with the same 
department number



Structural Elements
Structural Shapes and Details
Several commonly used structural steel shapes are available as 2D objects. 3D equivalents of these objects are also 
available in the Vectorworks Design Series products. Since the 2D and 3D parameters are nearly identical, all 
parameters are documented with the 2D objects for convenience. Two additional 2D/3D structural shapes are also 
available in the Vectorworks Design Series products: bulb flat and Z-section, as well as four additional series (ANZ, 
BSI, DIN, and JIS).

The Update Plug-in Objects command may need to be run on files containing structural shapes that were created 
in an earlier version of Vectorworks software. This command converts the structural shapes to the latest format; 
see “Migrating from Previous Versions” on page 28.

~~~~~~~~~~~~~~~~~~~~~~~~~
Angle
Channel
I-beam
Rectangular Tubing
Round Tubing
Square Tubing
Tee
Wide Flange
Shaft Break
Shaft Break 2
Slot
Batt Insulation
Bulb Flat
Z-Section

Angle

To create an angle object:

1. Click the Angle tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the angle properties and click OK.
Click to show/hide the parameters.

Toe R. (Side A)

Toe R. 
(Side B)

Fillet 
Radius

Length of Side B
Insertion

Point

Length of 
Side A Fillet 

Radius

Thickness
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Structural Shapes and Details

Parameter Description

Series Select the desired series to display the appropriate nominal sizes
Size Select the angle size
Place Locus at 
Centroid

Select whether to draw a locus at the centroid of the 2D angle

Length (Vectorworks 
Design Series 
required)

Enter the length of the 3D angle

Custom Size Select this option to enable fields for specifying a custom angle size
Length of Side A/
B

Displays the length of angle sides A and B, or if Custom Size is selected, allows entry of a 
custom value

Thickness Displays the thickness of the angle sides, or if Custom Size is selected, allows entry of a 
custom value

Toe R. (Side A/B) Displays the toe radius value for sides A and B, or if Custom Size is selected, allows entry 
of a custom value 

Fillet Radius Displays the fillet radius value, or if Custom Size is selected, allows entry of a custom 
value

Section Properties Section properties are automatically calculated and displayed based on inch units for 
imperial shapes and millimeter units for metric shapes (regardless of the units selected and 
Show Unit Mark setting in the Units dialog box)

Area Displays the angle area
About Axis X-X/Y-Y

Moment of Inertia Displays the moment of inertia about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes

Section Modulus Displays the section modulus about both the horizontal (X-X) and vertical (Y-Y) centroidal 
axes

Radius of 
Gyration

Displays the radius of gyration about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes

About Axis Z-Z
Radius of 
Gyration

Displays the least radius of gyration about the principal (Z-Z) axis

Tan (Alpha) Displays the tangent of the angle of the principal axis from the vertical
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Channel

To create a channel object:

1. Click the Channel tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the channel properties and click OK.
Click to show/hide the parameters.

Parameter Description

Series Select the desired series to display the appropriate nominal sizes
Size Select the channel size
Draw Free Height 
Lines

Select whether to draw the 2D channel with free height lines

Place Locus at 
Centroid

Select whether to draw a locus at the centroid of the 2D channel

Length (Vectorworks 
Design Series 
required)

Enter the length of the 3D channel

Custom Size Select this option to enable fields for specifying a custom channel size
Depth Displays the depth between endpoints, or if Custom Size is selected, allows entry of a 

custom value
Flange Width Displays the flange width, or if Custom Size is selected, allows entry of a custom value
Flange Thickness Displays the flange thickness, or if Custom Size is selected, allows entry of a custom value
Flange Angle 
(Deg.)

Displays the flange angle degrees, or if Custom Size is selected, allows entry of a custom 
value

Web Thickness Displays the web thickness of the channel, or if Custom Size is selected, allows entry of a 
custom value

Toe Radius

Free 
Height

Web 
Thickness

Flange Thickness

Flange Angle

Depth

Fillet 
Radius

Insertion
Point

Flange 
Width

Flange Width/2
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Structural Shapes and Details

I-beam

To create an I-beam object:

1. Click the I-Beam tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the I-beam properties and click OK.
Click to show/hide the parameters.

Toe Radius Displays the toe radius value, or if Custom Size is selected, allows entry of a custom value 
Fillet Radius Displays the fillet radius value, or if Custom Size is selected, allows entry of a custom 

value
Section Properties Section properties are automatically calculated and displayed based on inch units for 

imperial shapes and millimeter units for metric shapes (regardless of the units selected and 
Show Unit Mark setting in the Units dialog box)

Area Displays the channel area
About Axis X-X/Y-Y

Moment of Inertia Displays the moment of inertia about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes

Section Modulus Displays the section modulus about both the horizontal (X-X) and vertical (Y-Y) centroidal 
axes

Radius of 
Gyration

Displays the radius of gyration about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes

Parameter Description

Toe Radius

Free Height
Web

Thickness

Flange Thickness

Flange Angle

Depth

Fillet
Radius

Insertion 
PointFlange 

Width

Flange Width/4
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Structural Shapes and Details

Parameter Description 

Series Select the desired series to display the appropriate nominal sizes
Size Select the I-beam size
Length (Vectorworks 
Design Series 
required)

Enter the length of the 3D I-beam

Draw Center Line Select whether to draw the 2D I-beam with center lines
Draw Free Height 
Lines

Select whether to draw the 2D I-beam with free height lines

Place Locus at 
Centroid

Select whether to draw a locus at the centroid of the 2D I-beam

Custom Size Select this option to enable fields for specifying a custom I-beam size
Depth Displays the depth between endpoints, or if Custom Size is selected, allows entry of a 

custom value
Flange Width Displays the flange width, or if Custom Size is selected, allows entry of a custom value
Web Thickness Displays the web thickness of the flange, or if Custom Size is selected, allows entry of a 

custom value
Flange Thickness Displays the flange thickness, or if Custom Size is selected, allows entry of a custom value
Flange Angle 
(Deg.)

Displays the flange angle in degrees, or if Custom Size is selected, allows entry of a 
custom value

Fillet Radius Displays the fillet radius value, or if Custom Size is selected, allows entry of a custom 
value 

Toe Radius Displays the toe radius value, or if Custom Size is selected, allows entry of a custom value
Section Properties Section properties are automatically calculated and displayed based on inch units for 

imperial shapes and millimeter units for metric shapes (regardless of the units selected and 
Show Unit Mark setting in the Units dialog box)

Area Displays the I-beam area
About Axis X-X/Y-Y

Moment of Inertia Displays the moment of inertia about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes

Section Modulus Displays the section modulus about both the horizontal (X-X) and vertical (Y-Y) centroidal 
axes

Radius of 
Gyration

Displays the radius of gyration about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes
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Rectangular Tubing

To create a rectangular tubing object:

1. Click the Rectangular Tubing tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the rectangular tubing properties and click OK.
Click to show/hide the parameters.

Parameter Description

Series Select the desired series to display the appropriate nominal sizes
Size Select the rectangular tubing size
Length (Vectorworks 
Design Series 
required)

Enter the length of the 3D rectangular tubing

Draw Center Lines Select whether to draw the 2D rectangular tubing with center lines
Place Locus at 
Centroid

Select whether to draw a locus at the centroid of the 2D rectangular tubing

Custom Size Select this option to enable fields for specifying a custom rectangular tubing size
Width Displays the width of the tubing, or if Custom Size is selected, allows entry of a custom 

value
Height Displays the height of the tubing, or if Custom Size is selected, allows entry of a custom 

value
Wall Thickness Displays the wall thickness of the tubing, or if Custom Size is selected, allows entry of a 

custom value
Inside Fillet 
Radius

Displays the inside fillet radius value, or if Custom Size is selected, allows entry of a 
custom value

Section Properties Section properties are automatically calculated and displayed based on inch units for 
imperial shapes and millimeter units for metric shapes (regardless of the units selected and 
Show Unit Mark setting in the Units dialog box)

Area Displays the rectangular tubing area

Height

Width
Inside
Fillet

Radius

Insertion
Point

Wall
Thickness
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Structural Shapes and Details

Round Tubing

To create a round tubing object:

1. Click the Round Tubing tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the round tubing properties and click OK.
Click to show/hide the parameters.

About Axis X-X/
Y-Y

Moment of Inertia Displays the moment of inertia about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes

Section Modulus Displays the section modulus about both the horizontal (X-X) and vertical (Y-Y) centroidal 
axes

Radius of 
Gyration

Displays the radius of gyration about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes

Parameter Description

Series Select the desired series to display the appropriate nominal sizes
Size Select the round tubing size
Length (Vectorworks 
Design Series 
required)

Enter the length of the 3D round tubing

Draw Center Lines Select whether to draw the 2D round tubing with center lines
Place Locus at 
Centroid

Select whether to draw a locus at the centroid of the 2D round tubing

Custom Size Select this option to enable fields for specifying a custom round tubing size

Parameter Description

Outside Diameter

Insertion 
Point

Wall
Thickness
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Structural Shapes and Details

Square Tubing

To create a square tubing object:

1. Click the Square Tubing tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the square tubing properties and click OK.
Click to show/hide the parameters.

Outside Diameter Displays the outside diameter of the tubing, or if Custom Size is selected, allows entry of a 
custom value

Wall Thickness Displays the wall thickness of the tubing, or if Custom Size is selected, allows entry of a 
custom value

Section Properties Section properties are automatically calculated and displayed based on inch units for 
imperial shapes and millimeter units for metric shapes (regardless of the units selected and 
Show Unit Mark setting in the Units dialog box)

Area Displays the round tubing area
About Axis X-X/Y-Y

Moment of Inertia Displays the moment of inertia about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes

Section Modulus Displays the section modulus about both the horizontal (X-X) and vertical (Y-Y) centroidal 
axes

Radius of 
Gyration

Displays the radius of gyration about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes

Parameter Description

Series Select the desired series to display the appropriate nominal sizes
Size Select the square tubing size

Parameter Description

Width

Width
Inside

Fillet R.

Insertion
Point

Wall
Thickness
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Structural Shapes and Details

Length (Vectorworks 
Design Series 
required)

Enter the length of the 3D square tubing

Place Locus at 
Centroid

Select whether to draw a locus at the centroid of the 2D square tubing

Draw Center Lines Select whether to draw the 2D square tubing with center lines
Custom Size Select this option to enable fields for specifying a custom square tubing size

Width Displays the width of the tubing, or if Custom Size is selected, allows entry of a custom 
value

Wall Thickness Displays the wall thickness of the tubing, or if Custom Size is selected, allows entry of a 
custom value

Inside Fillet R. Displays the inside fillet radius value of the tubing, or if Custom Size is selected, allows 
entry of a custom value

Section Properties Section properties are automatically calculated and displayed based on inch units for 
imperial shapes and millimeter units for metric shapes (regardless of the units selected and 
Show Unit Mark setting in the Units dialog box)

Area Displays the square tubing area
About Axis X-X/Y-Y

Moment of Inertia Displays the moment of inertia about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes

Section Modulus Displays the section modulus about both the horizontal (X-X) and vertical (Y-Y) centroidal 
axes

Radius of 
Gyration

Displays the radius of gyration about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes

Parameter Description
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Tee

To create a tee object:

1. Click the Tee tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the tee properties and click OK.
Click to show/hide the parameters.

Parameter Description 

Series Select the desired series to display the appropriate nominal sizes
Size Select the tee size
Length (Vectorworks 
Design Series 
required)

Enter the length of the 3D tee

Draw Center Line Select whether to draw the 2D tee with center lines
Place Locus at 
Centroid

Select whether to draw a locus at the centroid of the 2D tee

Custom Size Select this option to enable fields for specifying a custom tee size
Depth Displays the depth between endpoints, or if Custom Size is selected, allows entry of a 

custom value
Flange Width Displays the flange width, or if Custom Size is selected, allows entry of a custom value
Web Thickness Displays the web thickness, or if Custom Size is selected, allows entry of a custom value
Flange Thickness Displays the flange thickness, or if Custom Size is selected, allows entry of a custom value
Web Slope (Deg.) Displays the web slope in degrees, or if Custom Size is selected, allows entry of a custom 

value

Fillet 
Radius

Web Slope

Insertion
Point Flange Thickness

Depth

Flange Width

Depth/2

Web Thickness

Toe Radius

Flange 
Scope

Flange 
Width/4

Flange 
Radius
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Wide Flange

To create a wide flange object:

1. Click the Wide Flange tool from the Detailing tool set.

Flange Slope 
(deg.)

Displays the flange slope in degrees, or if Custom Size is selected, allows entry of a 
custom value

Toe Radius Displays the toe radius value, or if Custom Size is selected, allows entry of a custom value
Flange Radius Displays the flange radius value, or if Custom Size is selected, allows entry of a custom 

value
Fillet Radius Displays the fillet radius value, or if Custom Size is selected, allows entry of a custom 

value
Section Properties Section properties are automatically calculated and displayed based on inch units for 

imperial shapes and millimeter units for metric shapes (regardless of the units selected and 
Show Unit Mark setting in the Units dialog box)

Area Displays the tee area
About Axis X-X/Y-Y

Moment of Inertia Displays the moment of inertia about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes

Section Modulus Displays the section modulus about both the horizontal (X-X) and vertical (Y-Y) centroidal 
axes

Radius of 
Gyration

Displays the radius of gyration about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes

Parameter Description 

Flange Thickness

Fillet Radius

Free Height

Flange Thickness

Depth

Insertion 
Point

Flange Width (Top)

Flange Width (Bottom)

Web Thickness
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2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 
object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the wide flange properties and click OK.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Structural Shapes and Details

Parameter Description 

Series Select the desired series to display the appropriate nominal sizes
Size Select the wide flange size
Length (Vectorworks 
Design Series 
required)

Enter the length of the 3D wide flange

Draw Center Line Select whether to draw the 2D wide flange with center lines
Draw Free Height 
Lines

Select whether to draw the 2D wide flange with free height lines

Place Locus at 
Centroid

Select whether to draw a locus at the centroid of the 2D wide flange

Custom Size Select this option to enable fields for specifying a custom wide flange size
Depth Displays the depth between endpoints, or if Custom Size is selected, allows entry of a 

custom value
Flange Width 
(Top) / (Bottom)

Displays the top and bottom flange width of the wide flange, or if Custom Size is selected, 
allows entry of a custom value

Web Thickness Displays the web thickness, or if Custom Size is selected, allows entry of a custom value
Flange Thickness Displays the flange thickness, or if Custom Size is selected, allows entry of a custom 

value
Fillet Radius Displays the fillet radius value, or if Custom Size is selected, allows entry of a custom 

value
Section Properties Section properties are automatically calculated and displayed based on inch units for 

imperial shapes and millimeter units for metric shapes (regardless of the units selected and 
Show Unit Mark setting in the Units dialog box)

Area Displays the wide flange area
About Axis X-X/Y-Y

Moment of Inertia Displays the moment of inertia about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes

Section Modulus Displays the section modulus about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes

Radius of Gyration Displays the radius of gyration about both the horizontal (X-X) and vertical (Y-Y) 
centroidal axes
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Shaft Break 

To insert a Shaft Break object:

1. Click the Shaft Break tool from the Detailing tool set.
2. Click to define the start point, click again to define the end point and rotation, and drag the cursor and click to set 

the width.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Structural Shapes and Details

Shaft Break 2

To insert a shaft break 2 object.

1. Click the Shaft Break 2 tool from the Detailing tool set.
2. Click to define the start point, click again to define the end point and rotation, and drag the cursor and click to set 

the width. If this is the first time the object is placed in the drawing, an object properties dialog box opens. These 
parameters apply to subsequently created objects; they can be changed later by accessing them from the Object 
Info palette. 

Parameter Description

Shaft Diameter Specify the diameter of the shaft break object
Width of Break Specify the width of the shaft break object
Configuration Select Solid or Hollow

Wall Thickness For hollow shaft break configurations, indicate the thickness of the shaft wall 

Wall Thickness

Shaft Diameter

Width of Break

Solid Hollow
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3. Specify the object properties and click OK.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Structural Shapes and Details

Slot

To insert a slot:

1. Click the Slot tool from the Detailing tool set.
2. Click to define the start point of the slot, click again to define the end point and rotation, and drag the cursor and 

click to set the slot width.

Click to show/hide the parameters.

Parameter Description

Shaft Diameter Specify the diameter of the shaft break object
Width of Break Specify the width of the shaft break object
Configuration Select Solid or Hollow

Wall Thickness For hollow shaft break configurations, indicate the thickness of the shaft wall 

For Shaft Break 2, click and drag the control point, and then 
click in a different location to create a double shaft break (this 
control point does not display for Shaft Break)

Width

Diameter

Thickness

Solid Hollow
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Batt Insulation
The Batt Insulation tool draws a planar insulation fill along a line. This tool is useful for creating custom details. The 
insulation can be placed within a wall, where it automatically adjusts to the length of the wall.

A better method of creating insulation fills, especially for walls, is to use a tile fill, which scales and rotates within 
walls and slab and wall components.

To create batt insulation:

1. Click the Batt Insulation tool from the Detailing tool set.
2. Click to mark the beginning of the insulation fill and then click again to mark the end of the object. If this is the 

first time the tool is used in this session, the Properties dialog box opens. Specify the preferences to use for this 
tool during this session, and then click OK. The parameters can be changed later in the Object Info palette.

3. The created batt insulation can be dragged into an existing wall.

Click to show/hide the parameters.

Parameter Description

Width Specify the width of the slot object
Length Specify the width of the slot object
Show Center Line When selected, draws the slot with center line(s)

Parameter Description

Insert When inserted in walls, aligns the insertion point of the batt insulation with the 
containing wall’s center line or left or right edge

Break When inserted in walls, select the type of wall break for the batt insulation
Height When inserted in walls, sets the height of the insulation from the bottom of the wall
Flip When inserted in walls, flips the orientation of the batt insulation
Set Position When inserted in walls and with Size to Wall Length selected, sets the insulation to fit 

along the length of the wall. The Move By Points tool is activated automatically; if Size 
to Wall Length is deselected, set the offset of the batt insulation along the wall as 
described in “Moving Symbols in Walls with the Reference Point Mode” on page 259.

Click Set Position for a Batt Insulation in Wall object, to fit the 
insulation to the wall; Size to Wall Length must be enabled

Click
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Defining Tiles
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Bulb Flat

To create a bulb flat object: 

1. Click the Bulb Flat tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the bulb flat properties and click OK.

Length Specifies the length of the batt insulation, when Size to Wall Length is deselected
Thickness Sets the width of the batt insulation
Offset Sets the offset of the batt insulation from its insertion point
Folds/Unit Thk. Sets the thickness of the insulation folds
Size to Wall Length When inserted in walls, automatically sets the length of the batt insulation to match the 

wall length
Add to Start/End Specifies an offset from the start or end of the wall, when the batt insulation is sized to fit 

the wall length
Solid Fill Applies a solid fill to the background of the batt insulation; set the fill color from the 

Attributes palette

Parameter Description

Bulb Angle

Bulb Height

Thickness

Width

Fillet
Radius

Insertion Point

Bulb 
Width

Fillet
Radius

Bulb 
Radius

Bulb Radius
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Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Structural Shapes and Details

Parameter Description 

Series Select the desired series to display the appropriate nominal sizes
Size Select the bulb flat size
Length (3D 
only)

Enter the length of the 3D bulb flat

Place Locus at 
Centroid (2D 
only)

Select whether to draw a locus at the centroid of the 2D bulb flat

Custom Size Select this option to enable fields for specifying a custom bulb flat size
Width Displays the bulb flat width, or if Custom Size is selected, allows entry of a custom value
Thickness Displays the bulb flat thickness, or if Custom Size is selected, allows entry of a custom value
Bulb Height Displays the bulb height, or if Custom Size is selected, allows entry of a custom value
Bulb Width Displays the bulb width, or if Custom Size is selected, allows entry of a custom value
Bulb Radius Displays the bulb radius value, or if Custom Size is selected, allows entry of a custom value
Fillet Radius Displays the fillet radius value, or if Custom Size is selected, allows entry of a custom value
Bulb Angle 
(Deg.)

Displays the bulb angle in degrees, or if Custom Size is selected, allows entry of a custom 
value

Section 
Properties

Section properties are automatically calculated and displayed based on inch units for imperial 
shapes and millimeter units for metric shapes (regardless of the units selected and Show Unit 
Mark setting in the Units dialog box)

Area Displays the bulb flat area
About Axis X-X/
Y-Y

Moment of 
Inertia

Displays the moment of inertia about both the horizontal (X-X) and vertical (Y-Y) centroidal 
axes

Section 
Modulus

Displays the section modulus about both the horizontal (X-X) and vertical (Y-Y) centroidal 
axes

Radius of 
Gyration

Displays the radius of gyration about both the horizontal (X-X) and vertical (Y-Y) centroidal 
axes
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Z-Section

To create a Z-section object: 

1. Click the Z-Section tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the Z-section properties and click OK.
Click to show/hide the parameters.

Parameter Description 

Series Select the desired series to display the appropriate nominal sizes
Size Select the Z-section size
Length (3D only) Enter the length of the 3D Z-section
Place Locus at 
Centroid (2D 
only)

Select whether to draw a locus at the centroid of the 2D Z-section

Custom Size Select this option to enable fields for specifying a custom Z-section size
Depth Displays the depth between endpoints, or if Custom Size is selected, allows entry of a custom 

value
Flange Width 
(Top) / 
(Bottom)

Displays the top and bottom flange width, or if Custom Size is selected, allows entry of a 
custom value

Web 
Thickness

Displays the web thickness, or if Custom Size is selected, allows entry of a custom value

Flange 
Thickness

Displays the flange thickness, or if Custom Size is selected, allows entry of a custom value

Toe Radius 
(Top) / 
(Bottom)

Displays the top and bottom toe radius value, or if Custom Size is selected, allows entry of a 
custom value

Flange Width 
(Bottom)

Depth
Fillet

Radius

Insertion Point

Web Thickness

Flange Width 
(Top)

Toe Radius (Bottom)

Toe Radius 
(Top)

Flange Thickness
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Framing
The Vectorworks Architect software includes a suite of tools for developing framing plans. There are tools for framing 
roofs, walls, and floors. Both architects and builders can take advantage of these tools to visualize framing details while 
still in the design stage of a project, to generate framing detail drawings, and to develop material take-off lists. The 
Simple Beam Calculator command is also available for analysis of a simply-supported beam with a single load.
A roof face area worksheet can also be added to the drawing from the VA Create Schedule command or the Resource 
Browser. From the Resource Browser, open the default architectural reports file from the [Vectorworks]\Libraries 
folder that is included with the Vectorworks Architect product (see “Resource Libraries” on page 219). Drag the Roof 
Face Area worksheet to the drawing. The worksheet is populated with information from the objects in the current 
drawing.
~~~~~~~~~~~~~~~~~~~~~~~~~
Framing a Roof
Creating Framing Members
Framing a Floor
Framing a Wall
Simple Beam Calculator

Framing a Roof
A roof object can be automatically framed with rafters, collars (collar beams), ridges, and other roof elements with the 
Roof Framer command. The command creates framing member objects. If Enable Auto-classing is selected in the 
Standard Naming dialog box, all roof framing members will be automatically placed in the Structural-Framing class.
This command does not work on roof face objects.
To automatically frame a roof:

1. Select the roof object.
2. Select AEC > Framing > Roof Framer.

Fillet Radius Displays the fillet radius value, or if Custom Size is selected, allows entry of a custom value
Section 
Properties

Section properties are automatically calculated and displayed based on inch units for imperial 
shapes and millimeter for metric shapes (regardless of the units selected and Show Unit Mark 
setting in the Units dialog box)

Area Displays the Z-section area
About Axis X-X/
Y-Y

Moment of 
Inertia

Displays the moment of inertia about both the horizontal (X-X) and vertical (Y-Y) centroidal 
axes

Section 
Modulus

Displays the section modulus about both the horizontal (X-X) and vertical (Y-Y) centroidal 
axes

Radius of 
Gyration

Displays the radius of gyration about both the horizontal (X-X) and vertical (Y-Y) centroidal 
axes

Parameter Description 
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The Roof Framer dialog box opens.
3. Select the tab for the type of roof framing element to create, and select the check box to create the framing 

element. More than one type can be selected at the same time; other framing elements can be added later.
An individual framing element can be added with the Framing Member tool, available from the Detailing tool 
set.

4. Enter the framing parameters for each desired framing element as described in the following sections.
5. For each selected roof framing element, click Object Attributes to specify its appearance.

The Attributes dialog box opens. See “Applying Object Attributes” on page 1093 for information on applying 
graphic attributes, and “Applying and Mapping Textures” on page 1527 for information on texture parameters.

Click to show/hide the parameters.

6. Click OK to return to the Roof Framer dialog box.
7. Click OK to frame the roof.

Parameter Description

Graphic Attributes Each graphic attribute can be set by the class style or to specific settings. If set by the 
class style, the attributes are controlled by the class selected in the Roof Framer dialog 
box for the framing element.

Fill Select Class Style to use the class style for the fill attribute, choose None to apply no fill, 
or choose a fill style

Pen Select Class Style to use the class style for the pen attribute, choose None to apply no 
pen, or choose a solid/dash or pattern style

Line Thickness Select Class Thickness to use the class style for the line thickness attribute, choose Set 
Thickness to specify the line thickness, or select a line thickness 

Texture (Renderworks 
required)

Select Class to use the class texture for the framing element (see “Applying Object 
Textures by Class” on page 1542), choose None to apply no texture, or choose Select to 
set the texture parameters 

Texture Select the texture to apply from either the default content or the current file’s content; 
see “Resource Libraries” on page 219

Map Type Select the texture map type
Radius For sphere and cylinder maps, sets the texture radius; the default radius is the same as the 

3D object radius. Increasing this value reduces the size of the texture on the object.
Start/End Cap Applies the texture to the start and end caps of the framing element
Repeat 
Horizontally/ 
Vertically

Repeats the texture in a horizontal and/or vertical direction

Scale Factor Enter a scale value to determine the texture size when projected onto the object
Horizontal/Vertical 
Offset

Sets the start location of the texture horizontally and vertically

Rotation Sets the angle of texture rotation; enter a rotation value from 0 to 360 degrees 
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The Attributes Palette
Creating Framing Members
Creating Rafters
Creating Collars
Creating Plates
Creating Purlins
Creating Ridges
Creating Trimmers
Creating Hip and Valley Rafters
Custom Frame Element Sizes

Creating Rafters
To create rafters:

1. In the Roof Framer dialog box, click the Rafters tab, and select Create Rafters.
2. Specify the rafter parameters.

Click to show/hide the parameters.

Parameter Description

Rafter Size Specifies the rafter size in width x height, in current file units. Sizes can be edited by 
selecting Edit List (see “Custom Frame Element Sizes” on page 470).

Dormer Rafter Size If the roof contains dormer windows, enter the size, in Width x Height, of the dormer rafters 
Minimum Spacing Specifies the minimum distance allowed between rafters
Maximum Spacing Specifies the maximum distance allowed between rafters; for consistent rafter spacing of 

the entire roof, the Minimum and Maximum Spacing values should be equal
Set top of Rafters to

Top of Roof 
object

Matches the tops of the rafters to the top of the roof object

Bottom of Roof 
object

Treats the roof object as a roof deck and matches the tops of the rafters to the bottom of the 
roof

Match Rafters across 
Ridges/Hips/Valleys

Select to ensure that opposing rafters meet on the roof ridges, hips, and valleys
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3. Click OK to create the rafters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Framing a Roof
Setting Class Properties
Custom Frame Element Sizes

Creating Collars
To create collars (collar beams):

1. In the Roof Framer dialog box, click the Collars tab, and select Create Collars.
2. Specify the collar parameters.

Click to show/hide the parameters.

Class Select a class for the roof element to control its appearance and visibility. The classes 
present in the drawing are listed; alternatively select the currently active class or create a 
new class from the Organization dialog box by clicking Classes (see “Classes” on 
page 176).

Classes Edits class attributes
Object Attributes Specifies the rafter attributes

Parameter Description

Style Select the collar style; flush collars or collar ties will only connect to the common rafters, joist 
collars connect to both common and jack rafters
• Joist: tie beam that rests on the bearing wall and overlaps the rafters
• Flush Collar: tie collar that is flush to the rafters, usually attached to the rafters with metal 

plates
• Collar Tie: tie collar that scabs onto the rafters and is attached with nails, bolts, and so on

Size Specifies the collar size in width x height, in current file units. Sizes can be edited by selecting 
Edit List (see “Custom Frame Element Sizes” on page 470).

Spacing Select the collar spacing (Every Rafter, Every Other Rafter, and Every Third Rafter)

Parameter Description

Rafter Size

Minimum Spacing
Maximum Spacing
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3. Click OK to create the collars.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Class Properties
Framing a Roof
Custom Frame Element Sizes

Creating Plates
To create plates:

1. In the Roof Framer dialog box, click the Plates tab, and select Create Plates.
2. Specify the plate parameters.

Click to show/hide the parameters.

Location For joist or collar tie styles, specifies the location of the collars in reference to the rafters. For 
flush collar style, the location is automatically set to Middle.

• Middle places one collar at the center of the rafter for flush collar and joist styles, and one 
collar on each side of the rafter for the collar tie style

• Left/Right places a single collar on the designated side of the rafter for joist or collar tie 
styles. Joists and collar ties extend to the intersection of the rafter tops.

Elevation AFF Specifies the elevation above finished floor of the bottom of the collars. If Flush Collar or 
Collar Tie is selected for Style, the default elevation is two-thirds of the roof height. Joist style 
is automatically set to 0.

Class Select a class for the roof element to control its appearance and visibility. The classes present in 
the drawing are listed; alternatively select the currently active class or create a new class from 
the Organization dialog box by clicking Classes (see “Classes” on page 176).

Classes Edits class attributes
Object Attributes Specifies the collar attributes

Parameter Description

Size Specifies the plate size in width x height, in current file units. Sizes can be edited by 
selecting Edit List (see “Custom Frame Element Sizes” on page 470).

Rafter Connection
Flush to Top of Plate Select to set rafters flush to the top of the plate

Parameter Description

Size

Elevation AFF
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3. Click OK to create the plates.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Class Properties
Framing a Roof
Custom Frame Element Sizes

Creating Purlins
To create purlins:

1. In the Roof Framer dialog box, click the Purlins tab, and select Create Purlins.
2. Specify the purlin parameters.

Click to show/hide the parameters.

Notched for Plate Select to notch the rafters to set on the plate; enter the Notch Depth, by default this is 
set to 1.5”

The depth of the notch should not exceed one-third of the rafter depth
Class Select a class for the roof element to control its appearance and visibility. The classes 

present in the drawing are listed; alternatively select the currently active class or 
create a new class from the Organization dialog box by clicking Classes (see 
“Classes” on page 176).

Classes Edits class attributes
Object Attributes Specifies the plate attributes

Parameter Description

Purlin Size Specifies the purlin size in width x height, in current file units. Sizes can be edited by 
selecting Edit List (see “Custom Frame Element Sizes” on page 470).

Elevation of First 
Purlin

Specifies the elevation above finished floor of the bottom of the lowest purlin

Elevation of Last 
Purlin

Sets the elevation from the top of the roof to the last purlin

Create Purlins by:
Number of Purlins Indicates the number of purlins to create; the purlins are evenly spaced between the first 

and last purlins

Parameter Description

Size
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3. Click OK to create the purlins.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Class Properties
Framing a Roof
Custom Frame Element Sizes

Creating Ridges
To create ridges:

1. In the Roof Framer dialog box, click the Ridges tab, and select Create Ridges.
2. Specify the ridge parameters.

Click to show/hide the parameters.

Distance Between 
Purlins

Specifies the distance between purlins; the number of purlins created is based on this value

Purlin Position
Top of Rafter Matches the tops of the purlins to the top of the roof object, as for roof tile supports
Bottom of Rafter Matches the tops of the purlins to the bottom of the roof, as when the purlins support the 

rafters
Purlins Start at the 
Lower End of the 
Rafter

Sets the elevation of the first purlin to start from the lower end of the rafter

Rotate Purlins to 
Roof Slope

Rotates the purlins so that they match the slope of the roof

Bearing inset Specifies the depth at which the purlin is notched into the rafters; if purlins are rotated this 
field appears dimmed since the inset only applies to horizontal purlins

Class Select a class for the roof element to control its appearance and visibility. The classes 
present in the drawing are listed; alternatively select the currently active class or create a 
new class from the Organization dialog box by clicking Classes (see “Classes” on 
page 176).

Classes Edits class attributes
Object Attributes Specifies the purlin attributes

Parameter Description

Size

Elevation of first purlin

Elevation of last purlin

Distance between purlins
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3. Click OK to create the ridges.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Class Properties
Framing a Roof
Custom Frame Element Sizes

Creating Trimmers
To create trimmers:

1. In the Roof Framer dialog box, click the Trimmers tab, and select Create Trimmers.
2. Specify the trimmer parameters.

Click to show/hide the parameters.

Parameter Description

Ridge Size Specifies the ridge size in width x height, in current file units. Sizes can be edited by 
selecting Edit List (see “Custom Frame Element Sizes” on page 470).

Ridge Elevation Specifies the ridge elevation options
Flush to Top of Rafters Indicates that the top of the ridge should be the same as the top of the rafters
Notched into rafters, 
depth

Specify the depth that the ridge is notched into the rafters

Flush to Bottom of 
Rafters

Indicates that the bottom of the ridge should be the same height as the bottom of the 
plumb cut on the rafters

Specify AFF Indicates the height of the bottom of the ridge, above the finished floor
Flush to Top of Hips Sets the top of the ridge to be the same as the top of the hips

Class Select a class for the roof element to control its appearance and visibility. The classes 
present in the drawing are listed; alternatively select the currently active class or 
create a new class from the Organization dialog box by clicking Classes (see 
“Classes” on page 176).

Classes Edits class attributes
Object Attributes Specifies the ridge attributes

Size
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3. Click OK to create the trimmers.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Class Properties
Framing a Roof
Custom Frame Element Sizes

Creating Hip and Valley Rafters
To create hip and valley rafters:

1. In the Roof Framer dialog box, click the Hips/Valleys tab, and select Create Hips and Valleys.
2. Specify the hip and valley rafter parameters.

Click to show/hide the parameters.

Parameter Description

Trimmer Size Specifies the trimmer size in width x height, in current file units. Sizes can be edited by 
selecting Edit List (see “Custom Frame Element Sizes” on page 470).

Set top of Trimmers to
Top of Roof object Matches the tops of the trimmers to the top of the roof object
Bottom of Roof 
object

Treats the roof object as a roof deck and matches the tops of the trimmers to the bottom 
of the roof

Class Select a class for the roof element to control its appearance and visibility. The classes 
present in the drawing are listed; alternatively select the currently active class or create a 
new class from the Organization dialog box by clicking Classes (see “Classes” on 
page 176).

Classes Edits class attributes
Object Attributes Specifies the trimmer attributes

Parameter Description

Hip/Valley Size Specifies the size of the hip and valley rafters in width x height, in current file units. 
Sizes can be edited by selecting Edit List (see “Custom Frame Element Sizes” on 
page 470).

Set top of Hips and Valleys 
to

Top of Roof object Matches the tops of the hips and valleys to the top of the roof object

Size
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3. Click OK to create the hip and valley rafters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Class Properties
Framing a Roof
Custom Frame Element Sizes

Custom Frame Element Sizes
The size of the framing elements can be selected from a pre-set list, or the list can be edited to contain desired or 
custom sizes.
To edit the size list of the frame elements:

1. From the Size field in one of the framing element tabs of the Roof Framer dialog box, select Edit List.
The Edit Size List dialog box opens, listing the currently available sizes of the roof element.

Click to show/hide the parameters.

2. Click OK to edit the size list.
The text files which populate the size lists in the framing element dialog boxes can also be edited. The text files 
are located in [Vectorworks]\Plug-Ins\VW_Arch\Data.

Bottom of Roof object Treats the roof object as a roof deck and matches the tops of the hips and valleys to 
the bottom of the roof

Class Select a class for the roof element to control its appearance and visibility. The classes 
present in the drawing are listed; alternatively select the currently active class or 
create a new class from the Organization dialog box by clicking Classes (see 
“Classes” on page 176).

Classes Edits class attributes
Object Attributes Specifies the hip and valley rafter attributes

Parameter Description

Add Adds a size to the list; specify the width and height of the new size
Remove Deletes the currently selected size
Edit Edits the currently selected size; enter the new width and height parameters
Move Up/Move Down Changes the order of the sizes by moving the selected size up or down in the list

Parameter Description

Size
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~~~~~~~~~~~~~~~~~~~~~~~~~
Framing a Roof

Creating Framing Members
The Framing Member tool draws framing elements for rafters, beams, joists, and framing members with a horizontal 
projection.
For a file created in a version of Vectorworks software prior to 2009, board, joist, rafter, and original framing member 
objects are considered to be “legacy” objects. To convert them to the current functionality of the framing member tool, 
select Tools > Utilities > Update Plug-in Objects; see “Migrating from Previous Versions” on page 28. 

To create a framing member:

1. Select the Framing Member tool from the Detailing tool set.
2. Click to begin drawing the linear framing member object. Click to set the length of the object.

If this is the first time the object is inserted in this session, the Object Properties dialog box opens. These 
parameters apply to subsequent placements of the object and can be changed in the Object Info palette. Click OK.

3. The framing member object is drawn. 
The starting point and direction in which the framing member is drawn determine which end is which. When a 
single framing member object is selected in Top/Plan view, a blue arrow is placed at the starting point and 
indicates the object’s direction.

Click to show/hide the parameters.

Parameter Description

Rotation Specifies the angle of the framing member object
Span Specifies the horizontal projection of the framing member in the floor plan; for rafters, 

specifies the horizontal distance from the inside surface of the supporting wall to the 
inside surface of the ridge board.

The Span, Length, and Pitch parameters are interdependent and are automatically 
calculated. When the span value is changed, the length is recalculated; the pitch 
remains fixed.

Length Specifies the length of the framing member
When the length value is changed, the pitch is recalculated; the span remains fixed.

Span = 18’
Length = 18’

Span = 18’
Length = 20’-9 5/8”
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Width Indicates the framing member profile width
Height Sets the framing member profile height
Type Select the form of framing element: rafter, solid beam, wood floor truss, open-web steel 

joint, cold-formed steel channel, steel section, or custom profile
Structural Use Provides a label describing how the framing member is used.

To specify your own structural use name, click Other. The Enter Special Structural Use 
dialog box opens; enter text for the structural use of this framing member and click OK.

Volume Displays the calculated volume of the framing member
Volume Units Select the units for calculating the framing member volume: board feet, cubic feet, cubic 

meters, or the default volume units set for the file (see “Units” on page 68)
Quantity Label Describes the standard material size required for the specified framing member, for use in 

quantity worksheets.
When there is no standard material size that accommodates a specified 
measurement, the label displays a ?. You can edit the Lumber Sizes.txt file (located 
in [Vectorworks]\Plug-ins\VW_Arch\Data\Lumber Sizes.txt) to add material sizes 
that are available in your locale. Restart the Vectorworks software after editing 
the .txt file for the changes to take effect.

Pitch Specifies the slope of the framing member along its span
When the pitch value is changed, the length is recalculated; the span remains fixed.

Beginning/Ending 
miter

Specifies the miter angle at each end of the framing member. This is the angle that the 
framing member is cut, in plan.

Beginning/Ending 
bevel

Specifies the bevel angle at each end of the framing member. This is the angle that the 
framing member is cut, in elevation.

2D Display Select the 2D display method for the framing member: solid, centerline, width, or width 
with centerline

Show Label Displays the text entered in Label Text as a label next to the 2D representation of the 
framing member. After placement, adjust the text position with the control point.

Label Text Enter the text to display in 2D as a label
Vertical Reference If you change the vertical reference from top, center, or bottom, the Change Vertical 

Reference dialog box opens; if the object position is maintained, the framing member 
remains stationary and the placement line is adjusted. If the defining line is maintained, 
the framing member object moves accordingly.

Rafter
Bearing inset Specifies the offset distance of the framing member’s bearing point (insertion point) from 

its end
Overhang Specifies the additional length that the framing member extends past its end

Parameter Description

Label control point
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Eave Style Select vertical, horizontal, double, or square eave profile
Fascia Height For double eave styles, specifies the height of the end of the framing member profile
Upper Notch Offset/
Depth

Indicates the size of an optional notch located at the top of the framing member

Solid Beam
Draw 2D Hangers Displays 2D graphics indicating framing hangers at start, end, both, or none
Roll Angle Specifies the angle the framing member rotates about its cross-section axes
Wood Floor Truss
Draw 2D Hangers Displays 2D graphics indicating framing hangers at start, end, both, or none
Flange Height Sets the height of the truss top and bottom chords; the chord width is set by the object 

width
Web Width/Height Specifies the size of the truss web components; if Use Solid Web is selected, the Web 

Width parameter specifies the thickness of the solid web
Panel Spacing Indicates the spacing of the truss “panels” (subdivisions)
Draw Verticals Displays vertical web components between each sloping web component
Use Solid Web Toggles the web component configuration between “open-web” and solid, “I-beam” style
Open-Web Steel Joist
Flange Height Sets the height of the truss top and bottom chords; the chord width is set by the object 

width
Web Width/Height Specifies the size of the truss web components
Gauge Sets the thickness of the top and bottom chords
Panel Spacing Indicates the spacing of the truss “panels” (subdivisions)
Draw Verticals Displays vertical web components between each sloping web component
Bottom Bearing Toggles the configuration of the truss between top chord and bottom chord bearing
Cold-formed Steel 
Channel
Draw 2D Hangers Displays 2D graphics indicating framing hangers at start, end, both, or none
Flange Height Specifies the length of the top and bottom flange extensions
Gauge Sets the thickness of the framing member
Roll Angle Specifies the angle the framing member rotates about its cross-section axes
Steel Section
Roll Angle Specifies the angle the framing member rotates about its cross-section axes
Select Structural 
Shape

Click to open the Select Structural Shape dialog box to select the structural shape to use 
for steel sections. Select the structural shape from the default content or the current file’s 
content. Select the shape’s series and size, and click OK.

Structural Shape data Displays the selected structural shape symbol name, series, and size
Custom Profile

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Resource Libraries

Framing a Floor
Use the Create Joists from Poly command to create the joist and perimeter objects necessary to frame a floor. If the 
floor is a slab object, select the slab component to serve as a boundary for the joist area. The command creates framing 
member objects.
To frame a floor:

1. Select a slab, polygon, polyline, or floor object.
If a stairwell hole exists in the floor, solid beam framing member objects are used for the headers.

2. Select AEC > Framing > Create Joists from Poly.
The Create Joist from Poly dialog box opens.

Click to show/hide the parameters.

Profile Symbol Def Displays the selected profile symbol name
Choose Profile 
Symbol

For custom structural profiles, click Choose Profile Symbol to select a structural profile 
symbol from the default content or the current file’s content. Select a symbol from the 
graphical list of Symbols and click OK.
The profile name displays in the Object Info palette.

Roll Angle Specifies the angle the framing member rotates about its cross-section axes

Parameter Description

Use Slab Component If a slab is selected, its components display in the list. Select a component to 
serve as the boundary for the joist area; the joists are created at the same elevation 
as the selected slab component.

Draw Joists Creates joist objects for floor framing
Elevation of Top of Joist Sets the elevation relative to the layer elevation value for the top of the joist
Center-to-Center Spacing Specifies the spacing from the center of one joist to the center of the next joist
Class Select a class for the joists to control their appearance and visibility. The classes 

present in the drawing are listed; alternatively, create a new class by selecting 
New, or select the currently active class.

Set Joist Properties Opens the Set Joist Properties dialog box; proceed with step 3
Set Joist Attributes Opens the Set Joist Attributes dialog box; proceed with step 5
Draw Perimeter Framing 
Members

Draws framing members around the perimeter of the floor

Elevation of Top of Framing Sets the elevation relative to the layer elevation value for the top of the perimeter 
framing

Class Select a class for the framing members to control their appearance and visibility. 
The classes present in the drawing are listed; alternatively, create a new class by 
selecting New, or select the currently active class.

Parameter Description
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3. Select whether to draw joists and/or perimeter framing members for the floor framing. Then, specify the properties 
of the joists and the perimeter framing. Click Set Joist Properties or click Set Framing Member Properties.
The Set Joist Properties or Set Framing Member Properties dialog box opens. The available parameters depend on 
the Type of joist or framing member selected.

Click to show/hide the parameters.

Set Framing Member 
Properties

Opens the Set Framing Member Properties dialog box; proceed with step 3

Set Framing Member 
Attributes

Opens the Set Framing Member Attributes dialog box; proceed with step 5

End Condition of Joists at 
Perimeter

Select the type of condition for the ends of the joists where they connect to the 
perimeter framing: Inside Face, Centerline, or Outside Face

Corner Condition of Perimeter Select the type of condition for the corners of the perimeter framing: lapped or 
mitered joints

Delete Source Geometry Deletes the original source object after the framing is created

Parameter Description

Width Specifies the joist or framing member profile width
Height Specifies the joist or framing member profile height
Type Select the form of the joist or framing member element: rafter, solid 

beam, wood truss, open-web steel joist, cold-formed steel channel, steel 
section, or custom profile

Profile Symbol Def For custom profiles, displays the selected profile symbol name
Choose Profile Symbol For custom profiles, click Choose Profile Symbol to select a structural 

profile symbol from the default content or the current file’s content. 
Select a symbol from the graphical list of Symbols and click OK.
The profile name displays in the Object Info palette.

2D Display Select the 2D display method: solid, centerline, width, or width with 
centerline

Show Label Displays the text entered in Label Text as a label next to the 2D 
representation of the joist or framing member

Label Text Enter the text to display in 2D as a label
Vertical Reference
(Rafter, Solid Beam, Wood Truss, 
Open-Web Steel Joist, Cold-formed 
Steel Channel, Steel Section)

Select whether the object’s defining line is at the top, center, or bottom

Draw 2D Hangers
(Solid Beam, Wood Truss, Cold-formed 
Steel Channel)

Displays 2D graphics indicating framing hangers at start, end, both, or 
none

Parameter Description
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4. Click OK to set the joist or perimeter framing member properties.
5. Specify the attributes of the joists and the perimeter framing. Click Set Joist Attributes or click Set Framing 

Member Attributes.
The Set Joist Attributes or Set Framing Member Attributes dialog box opens. The dialog boxes are identical 
whether setting joist or perimeter framing attributes, and contain a Graphic Attributes tab and Texture tab 
(Renderworks required).

Click to show/hide the parameters.

Flange Height
(Wood Truss, Open-Web Steel Joist, 
Cold-formed Steel Channel)

Sets the height of the truss top and bottom chords; the chord width is set 
by the object width

Web Width/Height
(Wood Truss, Open-Web Steel Joist, 
Cold-formed Steel Channel)

Specifies the size of the truss web components; if Use Solid Web is 
selected (wood truss only), the Web Width parameter specifies the 
thickness of the solid web

Gauge
(Open-Web Steel Joist, Cold-formed 
Steel Channel)

Sets the thickness of the top and bottom chords

Panel Spacing
(Wood Truss, Open-Web Steel Joist)

Indicates the spacing of the truss “panels” (subdivisions)

Draw Verticals
(Wood Truss, Open-Web Steel Joist)

Displays vertical web components between each sloping web 
component

Bottom Bearing
(Open-Web Steel Joist)

Toggles the configuration of the truss between top chord and bottom 
chord bearing

Use Solid Web
(Wood Truss)

Toggles the web component configuration between “open-web” and 
solid, “I-beam” style

Section Type
(Steel Section)

Select the type of structural shape for the steel section: Angle, Bulb Flat, 
Channel, I-beam, Rectangular Tubing, Round Tubing, Square Tubing, 
Tee, or Wide Flange

Section Series
(Steel Section)

Select the series type for the steel section

Section Shape
(Steel Section)

Select the size of the steel section

Parameter Description

Graphic Attributes Each graphic attribute can be set by the class style or to specific settings. If set by the 
class style, the attributes are controlled by the class selected in the Create Joists from Poly 
dialog box.

Fill Select Class Style to use the class style for the fill attribute, choose None to apply no fill, 
or choose a fill style

Parameter Description
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6. Click OK to set the joist or perimeter framing member attributes.
7. Click OK to close the Create Joist From Poly dialog box.
8. If joists are to be created, an alert dialog box requests the selection of two points to set the joist orientation. Click 

OK to close the dialog box and click two points to indicate the desired joist orientation.
9. The joists and/or perimeter framing member objects are created. In addition, a Joist Take-Off worksheet is 

automatically created and added to the Resource Browser.
The framing member parameters can be edited in the Object Info palette. These parameters are identical to those 
of a single framing member object.

~~~~~~~~~~~~~~~~~~~~~~~~~
Resource Libraries
The Attributes Palette
Creating Framing Members

Framing a Wall
The Vectorworks Architect product creates a highly detailed estimate of the placement and number of studs needed to 
frame walls. In addition to showing stud placement in a framing diagram, the Wall Framer command also 
automatically generates frame elevation drawings and two different worksheets, Frame TakeOff and Frame Wall Info.

Pen Select Class Style to use the class style for the pen attribute, choose None to apply no pen, 
or choose a solid/dash or pattern style

Line Thickness Select Class Thickness to use the class style for the line thickness attribute, choose Set 
Thickness to specify the line thickness, or select a line thickness

Texture (Renderworks 
required)

Select Class to use the class texture for the framing element (see “Applying Object 
Textures by Class” on page 1542), choose None to apply no texture, or choose Select to 
set the texture parameters 

Texture Select the texture to apply from either the default content or the current file’s content
Map Type Select the texture map type
Radius For sphere and cylinder maps, sets the texture radius; the default radius is the same as the 

3D object radius. Increasing this value reduces the size of the texture on the object.
Start/End Cap Applies the texture to the start and end caps of the framing element
Repeat 
Horizontally/ 
Vertically

Repeats the texture in a horizontal and/or vertical direction

Scale Factor Determines the texture size when projected onto the object; either enter a scale value or 
use the slider to change the scale

Horizontal/Vertical 
Offset

Sets the start location of the texture horizontally and vertically

Rotation Sets the angle of texture rotation; either enter a rotation value from 0 to 360 degrees or use 
the slider to change the rotation angle

Parameter Description
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To use the wall framer:
1. Ensure that the walls have the desired height. If necessary, change the wall height.
2. Select AEC > Framing > Wall Framer.

If a framing model has not yet been created, the New Framing Model dialog box opens. Enter a name for the 
framing model design layer (up to eight characters).

3. Click Create.
The Wall Framing dialog box opens. Select the desired settings for the framing model.

Click to show/hide the parameters.

The framing diagram and the 3D model representations also include symbols and inserted items, such as doors and 
windows.

4. Click Options.
The Wall Class dialog box opens. Enter the framing parameters for each wall class.

Parameter Description

Model Name Select the framing model layer to be used
New Opens the New Framing Model dialog box to create a new model
Delete Deletes the currently selected model. Click Yes to delete the selected model. This 

operation cannot be undone. This command cannot be used if there is only one model in 
the document.

Framer Output
3D Model Creates a 3D model layer, complete with the placement of studs, top plates, sole plates, 

and other components required for framing
2D Model Creates framing plan and framing diagram layers. The framing plan is a top view of the 

wall showing the sole plate and stud placement and is drawn in a layer that parallels the 
layers in the framing model. The top plates are removed to show the stud placement. The 
framing diagram is an elevation view showing the sole plate, top plates, and stud 
placement. The framing diagram is drawn in a new design layer and generates as many 
layers as needed.

Worksheets Creates two sets of worksheets. The first set provides details on the framing results, 
including a list of studs sorted by layer, class, frame, and size (Frame TakeOff). The 
second set provides a summary of frame information, sorted similarly, but providing 
area and linear footages itemized for each framed wall (Frame Wall Info).

Frame the following 
layers

Select which layer(s) contain wall data to frame

Options Opens the Wall Class dialog box to allow the editing of wall class values; see step 4
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Click to show/hide the parameters.

5. Click OK to return to the Wall Framing dialog box.
6. Click OK to create the framing model.

The program creates the estimated framing for the walls and any other output information requested.
The 2D results display in Top/Plan view without a top plate. To view the results with a top plate, switch to another 
view such as Front, Back, Left, or Right.
To view the 3D results, switch to a view such as Left Isometric or Right Isometric.
The Framer TakeOff and Framer Wall Info worksheets, if created, display in the drawing area.

Parameter Description

Wall Class
Name Lists the classes that contain walls to be framed; walls in the classes in this list are 

included in the framing model. The framing parameters for each class are displayed 
beneath.

New Click to add an additional wall class to the list to be framed
Delete Deletes the currently selected wall class from the list to be framed. Click Yes to delete the 

selected class. This operation cannot be undone.
Stud Spacing Enter the center-to-center distance between studs in this wall class
Sheet Stock Width Enter the width of the wall sheathing; this is the horizontal sheathing dimension
Max Plate Length Enter the length of lumber to be used for top and bottom frame members in this wall class
Sheet Stock Height Enter the width of the wall sheathing; this is the vertical sheathing dimension
Lumber

Nominal Select the lumber type to use for this wall class; the default types are 2” x 4”, 2” x 6”, and 
2” x 10”

New Click to create a new nominal lumber type; enter the name and click OK; then, with the 
new type selected in the Nominal list, enter the lumber dimensions in Size

Delete Deletes the currently selected nominal lumber type. Click Yes to delete the selected 
lumber type. This operation cannot be undone. This command cannot be used if there is 
only one lumber type in the document.

Size Enter the true short dimension for the lumber
by Enter the true long dimension for the lumber

Output Options
Fire Blocking Select to have extra blocking added to this wall class between studs on walls that are 

shorter than the sheet stock height
Double End Studs Select to have two studs, rather than one stud, placed at each wall end in this wall class
Double Top Plate Select to have two plates, rather than one plate, placed at top of each wall in this wall 

class
Double Bottom Plate Select to have two plates, rather than one plate, placed at the bottom of each wall in this 

wall class
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Inserting Ceiling Grid Objects

Use the Ceiling Grid tool to insert a ceiling grid object containing tiles with user-specified length, width, and 
placement angle. A ceiling grid object can also be created by drawing a polyline and then selecting the Create Objects 
from Shapes command (see “Creating Objects from Shapes” on page 277).

To insert a ceiling grid object:

1. Click the Ceiling Grid tool from the Furn/Fixtures tool set or the MEP tool set.
2. Click in the drawing file to set the start point of the ceiling grid object, and then click to set the position of each 

additional vertex. Click the last point to complete creation of the ceiling grid object. If the polyline is open, the 
program automatically completes it.
The Ceiling Grid object properties dialog box opens. Click OK to accept the default settings.

3. Use the Reshape tool to modify the locations of the vertices after object creation, or use the vertex editing controls 
on the Object Info palette to move the vertices or change the degree of vertices. The tiles are automatically 
adjusted to fit the new shape.

Click to show/hide the parameters.

For information on editing object vertices, see “Reshaping Objects” on page 1043.

Parameter Description

Angle Specify the tile placement angle
Tile Width Specify the tile width
Tile Length Specify the tile length
Vertex parameters Edits the ceiling grid object path vertices; see “Editing Vertex-Based Objects” on 

page 1002



Floors and Slabs
Creating Floors
The Floor command can be used to create not only floors, but also decks, patios, stages, platforms, and lofts. The 
command converts any 2D drawing object into a hybrid (2D/3D) object of any shape and thickness. The source object 
must be flat and must also be parallel to the active layer plane.
To create a floor:

1. Select the 2D object to turn into a floor.
2. Select the Floor command from the appropriate menu:

• Fundamentals workspace: Model > AEC > Floor
• Architect workspace: AEC > Floor
• Landmark workspace: Landmark > Architectural > Floor
• Spotlight workspace: Spotlight > Architectural > Floor
The Create Floor dialog box opens.

Click to show/hide the parameters.

3. Click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
Framing a Floor

Creating Slabs
The Slab tool creates architectural floor slabs. Slabs can be drawn manually or they can be based on, and associated 
with, an existing set of walls. The method of associating slab components with wall components can be specified, to 
create accurate and detailed cross-section views.

To draw a free-standing slab manually with the Slab tool, select the Polyline mode. If the walls are already drawn, 
select the Picked Walls mode or Inner Boundary mode to create a slab bounded by visible walls. 

Parameter Description

Bottom Z Specifies the distance above the active layer plane that the floor will begin (the Bottom Z 
height). In most cases, use the default of 0, which starts the floor on the active layer plane.

Thickness Sets the floor thickness

Inner Boundary
Corner 
Vertex

Bézier 
Vertex

Cubic 
Vertex

Arc Vertex  PreferencesPolyline

Fillet 
Radius

Tangent Arc

Point on 
Arc

Picked Walls
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~~~~~~~~~~~~~~~~~~~~~~~~~
Drawing Slabs Manually
Creating Automatically Bounded Slabs from Existing Walls
Converting Slab Boundary Associations
Using Slab Styles
Creating Slab Components
Editing Slabs
Creating Floors

Drawing Slabs Manually

To draw a manual slab object that is not associated with any walls:

1. Click the Slab tool from the Building Shell tool set, and select Polyline mode from the Tool bar.
2. To draw an unstyled slab, select <Unstyled> from the Slab Style list on the Tool bar. To create a styled slab, select 

it from the Tool bar Slab Styles list, which displays the slab style resources in this file as well as default slab 
styles. Create a new slab style by clicking Preferences from the Tool bar; see “Creating Slab Styles” on page 486.

3. Select a polyline drawing mode. See “Polyline Tool” on page 298.
A slab can also be created by drawing a polyline and then selecting the Create Objects from Shapes command 
(see “Creating Objects from Shapes” on page 277).

4. Similarly to drawing a polygon, create a closed slab shape. 
Double-click while drawing to close the slab automatically. 

Mode Description

Picked Walls Defines the perimeter of a slab based on a closed set of selected walls
Inner 
Boundary

Creates a slab object in a clicked area that is bounded by visible walls

Polyline Draws a polyline slab object; as with a polyline, select one of six types of control points for the 
vertices from the Tool bar

Corner Vertex For Polyline mode, creates the slab using polyline segments with straight lines and angled 
vertices at the control points

Bézier Vertex For Polyline mode, creates the slab using polyline segments with curves pulled toward, but not 
touching the control points

Cubic Vertex For Polyline mode, creates the slab using polyline segments with curves that pass through the 
control points

Tangent Arc For Polyline mode, creates the slab using polyline segments that are tangent to the previous 
segment

Point on Arc For Polyline mode, creates the slab using polyline segments that are drawn by clicking three 
points: the start point, a point the arc passes through, and the end point

Arc Vertex For Polyline mode, creates the slab using polyline segments with curves that look like a fillet 
placed at the control points

Fillet Radius For Polyline mode, sets the fillet radius when the Arc Vertex mode is selected
Preferences Sets the default parameters that are used for each slab object
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Every slab contains a component designated as the datum component. The top of this component is the 
Z-reference datum, and is fixed vertically (it does not change with any changes to the slab thickness or definition). 
The reference datum of the slab can be set to the active layer elevation value, or set to be bound by one of the story 
levels defined for the story or the story below it. By setting the slab datum to a level type, if the elevation of the 
associated story changes, the datum of the slab changes automatically to match. 

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Automatically Bounded Slabs from Existing Walls
Converting Slab Boundary Associations
Using Slab Styles
Creating Slab Components
Editing Slabs
Creating Slabs

Creating Automatically Bounded Slabs from Existing Walls
Slabs can be automatically created by first selecting the enclosing walls or by clicking within the boundary of a closed 
set of visible walls. The slabs are automatically associated with their bounding walls. 

Use classes to distinguish interior and exterior walls to easily place slabs associated with the correct wall set.
Every slab contains a component designated as the datum component. The top of this component is the Z-reference 
datum, and is fixed vertically (it does not change with any changes to the slab thickness or definition). The reference 
datum of the slab can be set to the active layer elevation value, or set to be bound by one of the story levels defined for 
the story or the story below it. By setting the slab datum to a level type, if the elevation of the associated story changes, 
the datum of the slab changes automatically to match. 
The slab edge path is defined by the outside or inside face of the walls, or by components within the wall, as defined by 
the slab component properties. If the walls are edited (whether moved, reshaped, or replaced, or due to a change in the 
wall style, the wall thickness, or the wall components), the slab edge path updates automatically. However, if the walls 
are edited so significantly that the slab cannot retain its association, you have the option to create a manual slab from 
the automatically bounded slab. 
Because the walls and slab are associated, section views display accurately. When creating a section view, similar 
component fills can be merged to display as a single unit (see “Advanced Sheet Layer Viewport Properties” on 
page 1642).
Once an automatically bounded slab is created, it can be moved to another layer and still retain its association with the 
walls.

To create an automatically bounded slab within a selected set of visible walls:

1. Click the Slab tool from the Building Shell tool set, and select Picked Walls mode from the Tool bar.

Click 1

Click 2 Click 3

Click 5Click 4
3D view
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2. To draw an unstyled slab, select <Unstyled> from the Slab Style list on the Tool bar. To create a styled slab, select 
it from the Tool bar Slab Styles list, which displays the slab style resources in this file as well as default slab 
styles. Create a new slab style by clicking Preferences from the Tool bar.

3. Click on each wall that forms the wall set and press Enter, or click the check mark button on the Tool bar.
4. The slab is created.

To create a slab within a closed set of visible walls:

1. Click the Slab tool from the Building Shell tool set, and select Inner Boundary mode from the Tool bar.
2. To draw an unstyled slab, select <Unstyled> from the Slab Style list on the Tool bar. To create a styled slab, select 

it from the Tool bar Slab Styles list, which displays the slab style resources in this file as well as default slab 
styles. Create a new slab style by clicking Preferences from the Tool bar.

3. Click in an open area of the drawing that is bounded by walls; the walls must be visible, joined together, and on 
layers that have the same layer scale as the slab layer. 

4. The slab is created.

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Drawing Slabs Manually
Converting Slab Boundary Associations
Creating Slab Styles
Using Slab Styles
Creating Slab Components
Editing Slabs

Click 1

Click 2

Click 3

Click 4

With exterior walls visible, click to place a 
concrete-style slab

Send the created slab to the back (Modify > Send > 
Send to Back) for Top/Plan view

http://www.youtube.com/watch?v=fYwjbTpdvis
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Creating Slabs

Converting Slab Boundary Associations

Converting to Automatically Bounded Mode
Manually drawn slabs can be associated with a set of walls, converting them to automatically bounded mode. Similarly, 
an automatically bounded slab can be associated with a new set of walls by this method.
To convert manual slabs to automatically bounded slabs:

1. Select the manual slab. In the Object Info palette, the Bounding mode displays Manual.
2. Click Pick Boundary from the Bounding list.

The Slab tool is automatically activated, and Inner Boundary mode is selected (Picked Walls mode can also be 
selected).

3. For Inner Boundary mode, click in an open area of the drawing that is bounded by walls. For Picked Walls mode, 
click on each wall that forms the wall set and press Enter, or click the check mark button on the Tool bar.

4. The manual slab is associated with the wall set. Its location and size may change as it is bounded by the wall set.

Converting to Manual Mode
Automatically bounded slabs can be converted to manual mode, releasing them from their association with walls. 
To convert automatically bounded slabs to manual slabs:

1. Select the automatically bounded slab. In the Object Info palette, the Bounding mode displays Auto-Bounded.
2. Click Manual from the Bounding list.
3. The slab is disassociated from its wall set, though it remains in place.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Using Slab Styles
Unstyled slabs can be created; in a new file, the default unstyled slab includes a single component. The attributes of an 
unstyled slab can be changed from the Attributes palette. The use of slab styles, however, facilitates drawing slabs by 
saving the slab preferences settings so that they can be easily applied to other slabs. Slab styles are resources that can 
be imported into other files and shared as office standards. Slab styles, textures, and hatches are provided as default 
content (default content is automatically imported into the current file at the point of use and displays in the Resource 
Browser). Setting and saving the dynamic height information of a slab in its slab style is a convenient way of 
automatically setting the defined height condition when using slabs with stories.
If a selected slab style’s parameters are edited, the slab style automatically changes to unstyled, indicating that the 
edited style must be saved as a new style to save changes (alternatively, the changes can be applied as an unstyled slab, 
and not get saved).
Unused slab styles can be purged; see “Purging Items from a File” on page 1011. 
~~~~~~~~~~~~~~~~~~~~~~~~~
Resource Libraries
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Creating Slab Styles

To create a slab style:

1. Click the Slab tool from the Building Shell tool set, and click Preferences from the Tool bar.
The Slab Preferences dialog box opens.

Click to show/hide the parameters.

2. Click Edit Slab Attributes to define the slab attributes in Top/Plan view.

Parameter Description

Slab Style To modify an existing slab style, select the Slab Style from either the default content or 
the current file’s content. Alternatively, select Unstyled as the slab style and set the 
parameters.

Save Preferences as 
Slab Style

Saves the current preference settings as a new slab style. The Assign Name dialog box 
opens; enter a slab style name and click OK 

Preview Displays a sectioned preview of the slab structure, including any defined components. 
The top of the preview indicates the top part of the slab as it will be drawn.

Overall Thickness Displays the thickness of the slab. The slab thickness is always determined by the 
thickness of its components; a slab always has one component by default. 

Edit Slab Attributes Opens the Slab Attributes dialog box, to specify the slab fill, pen, and opacity settings
Components Lists the components that form the structure of the slab, in order from top to bottom as 

displayed in the preview. To change the order of a component, click and drag within the 
# column.

Datum One of the slab components is designated as the datum component by clicking in the 
Datum column. A check mark indicates that the component is the datum component. 
The top of this component is the Z-reference datum, and is fixed vertically (it does not 
change with any changes to the slab thickness or definition)

Other Component 
settings

The remaining columns in the component list display the component thickness, edge 
offset method, and class setting

New Opens the Slab Component Settings dialog box to define the components of the slab; 
see “Creating Slab Components” on page 491 for information on creating components

Edit Opens the Slab Component Settings dialog box to edit the selected component’s 
thickness and attributes (alternatively, double-click on a component to open the Slab 
Component Settings dialog box) 

Duplicate Duplicates the selected slab component; the duplicate is added to the component list 
right below the originally selected component

Delete Deletes the selected slab component; the slab thickness is adjusted accordingly
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The Slab Attributes dialog box opens. The slab attributes of an unstyled slab are initially set to the parameters 
displayed in the Attributes palette. If they are changed here, the Attributes palette reflects the changed attributes of 
the selected slab (after exiting the Slab Preferences dialog box).
Fill, pen, and opacity can be set by class rather than by the attributes in the Slab Attributes dialog box. If the slab 
class is changed later, the slab changes to use the attributes of the new class. Slab attributes cannot be overridden 
on a per-instance basis; if a slab style uses class attributes, all slabs of that style must use class attributes. 
However, slabs of the same slab style can be placed in different classes.

Click to show/hide the parameters.

3. Click OK to return to the Slab Preferences dialog box.
4. Click the Insertion Options tab to set the slab insertion options. 

Click to show/hide the parameters.

5. Click the Textures tab to select textures for the slab parts (Renderworks required). 
Click to show/hide the parameters.

Parameter Description

Fill
Style Specify the slab fill attributes. Select None for no fill, or Class Style to set the slab fill 

attributes by class rather than by the parameters in the Slab Attributes dialog box. 
Selected hatch, gradient, or image fills, if not already present in the file, are imported and 
added to the Resource Browser (default content is automatically imported into the current 
file at the point of use and displays in the Resource Browser).

Pen
Style Specify the slab pen attributes. Select None for no pen, Line Type to select a complex 

line type, or Class Style to set pen attributes by class rather than by the parameters in the 
Slab Attributes dialog box.

Thickness When a pen style has been selected, specify the line thickness. If Line Type is selected as 
the pen style, also select the line type to use.

Opacity
Use Class 
Opacity

Sets slab opacity by class rather than by the parameters in the Slab Attributes dialog box

Opacity Specifies the transparency of the slab; drag the slider to the left to increase the 
transparency, or enter a percentage directly in the box to the right of the slider

Parameter Description

Datum LayerZRef Sets the slab’s datum height to be defined by the layer elevation, or set it to be bound 
by one of the story levels defined for the story or the story below it. By setting the 
slab datum to a level type, if the elevation of the associated story changes, the datum 
of the slab changes automatically to match.

Datum Offset from Layer 
Z

Specifies the offset (positive or negative) of the slab’s datum component from the 
layer elevation (see “Setting Design Layer Properties” on page 165) 

Class Specifies the default class for the slab
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6. Click the Data tab to specify slab record information, which is IFC-compliant and can be included in a slab style 
schedule. These fields are optional; enter text only where desired.

7. Click Save Preferences as Slab Style.
The Assign Name dialog box opens.

8. Enter a unique name for the slab style and click OK.
If the slab style name already exists, you are prompted to cancel and select a different name, or replace existing 
slabs with the slab style applied with the edited slab style. If you are replacing slab styles, the Slab Replacement 
dialog box opens; specify the slab replacement properties.

9. The new slab style is saved with the file and is listed under Slab Styles in the Resource Browser as well as the Slab 
Style list in the Tool bar.
A new slab style can also be created by clicking Resources > New Resource > Slab Style in the Resource 
Browser. A slab style created in this way is not associated with the current slab preference setting, but can be 
applied later.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Parameter Description

Use Component Textures Uses the textures defined for the slab components to texture the slab 
This option can also be selected for an existing slab from the Render tab of the 
Object Info palette.

Use Object Textures Uses the textures defined below for the slab parts (see “Applying a Texture to an 
Object” on page 1530 for information on applying textures to an object with parts) 

Part Applies the texture selected in Texture to the selected parts of the slab
Revert to Overall If a part was assigned a texture but it should inherit its texture from Overall instead, 

select the part and click Revert to Overall. The part moves back below the divider, 
and (from Overall) displays as its texture name. 

Texture Applies the selected texture to the selected Part. 
Textures can also be set from the Render tab of the Object Info palette. Textures 
applied from the Object Info palette override the textures set here.

No Texture Does not apply a texture to the selected Part
Class Texture Sets the slab to use the texture specified by the slab’s class. The class texture is set 

from the Other tab in the Edit Classes dialog box. Any slabs with that slab style use 
class textures for that part of the slab (unless overridden). Class Texture can also be 
chosen for a selected slab in the Render tab of the Object Info palette.

Choose Texture Choose a texture for the selected Part from the default content or the current file’s 
content (see “Resource Libraries” on page 219). Textures set here override the object 
class textures. 
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Editing Slab Styles
To edit a slab style:

1. Select the slab style from the Resource Browser and click Resources > Edit.
The Edit Slab Style dialog box opens.

2. Edit the slab and component parameters.
If a new slab style Name is specified, it replaces the selected slab style name (similar to selecting Rename from 
the Resources menu).

3. Click OK.
4. If slabs with that style already exist in the drawing, the Slab Replacement dialog box opens.

The slab style to apply cannot be selected (the edited style is applied). 
5. Click OK to edit the slab style.

Changes apply to any existing slabs in the drawing with the edited slab style, and will be used for any subsequent 
slabs created with that slab style.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Applying Slab Styles
By a variety of methods, slab styles can be selected for a slab before drawing it, or applied to existing slabs. Once a slab 
style has been selected for a slab, the Attributes palette is no longer available for changing slab attributes; attributes are 
set as part of the style.
To apply a slab style prior to creating the slab:

1. Select the Slab tool from the Building Shell tool set.
2. Select the desired style from the Slab Style list on the Tool bar. The available slab styles are from either the default 

content or the current file’s content.
Alternatively, click Preferences from the Tool bar. In the Slab Preferences dialog box, select the Slab Style.

To apply a slab style from the Resource Browser prior to drawing the slab:
1. Ensure that no slabs are selected.
2. Select a slab style in the Resource Browser, and click Resources > Apply.

Alternatively, double-click on the slab style in the Resource Browser.
3. The Slab tool is automatically made active and the selected slab style is applied to the slab as it is drawn.

To apply a slab style to an existing slab from the Object Info palette:
1. Select one or more slabs.



  490 | Creating Slabs
2. From the Object Info palette, select the slab Style. To apply a different (default) style, select Replace.
To apply a slab style to an existing slab from the Resource Browser:

1. Select one or more slabs.
2. Select the slab style from the Resource Browser and click Resources > Apply. Alternatively, drag the selected 

slab style from the Resource browser to the slab and click on the slab selection.
The Slab Replacement dialog box opens. The slab style list is disabled (the style selected in the Resource Browser 
is applied). 

3. Click OK.
A styled slab can be converted to an unstyled slab.
To remove a slab style:

1. Select one or more slabs to un-style.
2. From the Object Info palette, select Convert to Unstyled Slab.

The slab is released from its style; its attributes can be edited from the Attributes palette.
~~~~~~~~~~~~~~~~~~~~~~~~~
Resource Libraries
Creating Slabs
Creating Slab Styles
Editing Slab Styles
Replacing Slab Styles
Creating Slab Components
Editing Slabs

Replacing Slab Styles
Slab styles applied to existing slabs can be replaced with a different slab style. 

A slab replacement situation may also occur if pasting a styled slab from another file. 
To replace a slab style:

1. Select one or more slabs.
2. From the Object Info palette, select Replace from the Style list.

The Slab Replacement dialog box opens. Specify the new slab style. The red line indicates the datum component 
of each slab style; replacement is aligned to the datum. 

Click to show/hide the parameters.

If slabs with different slab styles were selected for replacement, the current slab preview is blank and components 
do not display.

Parameter Description

Slab style list From the list, select the slab style that will replace the current style
Previews The left preview shows the current slab style, and the right preview shows the replacement 

slab style selected in the slab style list. Preview slabs are drawn from top to bottom, so the 
top of the preview indicates the top part of the slab as it will be drawn.

Replacement 
options

Select whether to replace the current settings for slab height, class designations, and texture 
assignments (Renderworks required for textures) with those of the new slab
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3. Click OK to replace the slab style of the selected slab(s).
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Creating Slab Components
Slab components define the sections that make up a slab. For example, to indicate that a slab is made up of gypsum 
board ceiling, wood framing, and a plywood deck, define a component for each of these items to illustrate their 
location. Slab components can be offset from the edges of the walls (automatically bounded slabs) or the edge of the 
slab (manual slabs); their appearance can be specified for cross-section views, and they can be textured (Renderworks 
required), creating realistic section views and rendered views, as well as accurate slab material estimates. The area and 
volume of slab components (minus any holes cut) can be calculated in worksheets; see “Worksheet Functions” on 
page 1344).

The overall thickness of a slab is equal to the sum of its components. Component fill and pen style are only displayed in 
section viewports.

To define slab components prior to drawing the slab:

1. Click the Slab tool from the Building Shell tool set, and click Preferences from the Tool bar.
The Slab Preferences dialog box opens.

2. On the Definition tab, click New. 
The Slab Component Settings dialog box opens. Specify the component name, thickness, edge offset, and 
appearance in section views and rendered views.

Click to show/hide the parameters.

Parameter Description

Definition
Name Provide a name for the component, which displays in the Components list in the Slab 

Preferences dialog box
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3. Click OK to create the component and return to the Slab Preferences dialog box.

Class Select a class for the component to control its appearance and visibility. The classes 
present in the drawing are listed; alternatively, create a new class by selecting New, or 
select the class named <Object Class>, which places the component in the same class as 
the slab object.

Thickness Specifies the component’s thickness; the thickness of a slab is the sum of its components. 
A component must have a thickness greater than 0.

Edge Offset The method of offsetting the component from the edge of the slab depends on whether the 
slab is an automatically bounded slab, associated with a set of walls, or a slab drawn 
manually. The edge offset setting displays for each component in the component list on 
the Definition tab of the Slab Preferences dialog box.

Auto-Bound Sets the component edge to the inner or outer face of the wall, outer face of the inner wall 
component, inner face of the outer wall component, or inner face/outer face/center of the 
wall component designated as the core component

Manual Specifies the offset of the component from the edge of the slab
Texture (Renderworks 
required)

No Texture Does not apply a texture to the component
Class Texture Sets the component to use the texture specified by the component’s class. The class 

texture is set from the Other tab in the Edit Classes dialog box; see “Setting Class 
Properties” on page 179.

Choose Texture Select a texture for the component from the default content or the current file’s content 
(see “Resource Libraries” on page 219).

Section Fill Specifies the component appearance in section views
Style Specify the slab fill attributes. Select None for no fill, or Class Style to set component fill 

attributes by class rather than by the parameters in the Slab Component Settings dialog 
box. Selected hatch, gradient, or image fills, if not already present in the file, are imported 
and added to the Resource Browser (default content is automatically imported into the 
current file at the point of use and displays in the Resource Browser). See “Resource 
Libraries” on page 219 and “Fill Attributes” on page 1098.

Use a tile fill with Fit to Wall selected, to represent insulation fill. See “Defining 
Tiles” on page 1112.

Section Pen Specifies the component appearance in section views
Style Specify the slab pen attributes. Select None for no pen, Line Type to select a complex line 

type, or Class Style to set component pen attributes by class rather than by the parameters 
in the Slab Component Settings dialog box. Selected line types, if not already present in 
the file, are imported and added to the Resource Browser (default content is automatically 
imported into the current file at the point of use and displays in the Resource Browser). 
See “Resource Libraries” on page 219 and “Pen Attributes” on page 1100.

Thickness When a pen style has been selected, specify the line thickness; see “Line Thickness 
Attributes” on page 1101. If Line Type is selected as the pen style, also select the line type 
to use.

Parameter Description
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The slab’s Overall Thickness value changes to be determined by its components. As components are defined, 
they display in the preview. Click and drag a component in the # column to change its order.

4. To save the component settings with the slab settings as a slab style, click Save Preferences as Slab Style.
5. Click OK.

Once created, the components of a selected slab can be edited by clicking Components from the Object Info 
palette.

Defining Components for Existing Slabs
To define or edit slab components for an existing, unstyled slab:

1. Select the slab(s).
2. From the Object Info palette, click Components.

The Components dialog box opens.
Click to show/hide the parameters.

3. Click New or Edit, and define or edit the components as described in “Creating Slab Components” on page 491.
4. Click OK to return to the Components dialog box.
5. Click OK. The new component definition is applied to the selected slab(s).

~~~~~~~~~~~~~~~~~~~~~~~~~
Resource Libraries
The Attributes Palette
Defining Tiles
Setting Class Properties
Creating Slabs
Creating Slab Styles
Using Slab Styles

Parameter Description

Preview Displays a preview of the slab structure, including the defined components 
Overall 
Thickness

The thickness of a slab with components is defined by the sum of the component thicknesses

Components Lists the components that form the structure of the slab, in order from top to bottom as displayed 
in the preview. To change the order of a component, click and drag within the # column.

Datum One of the slab components is designated as the datum component by clicking in the Datum 
column. A check mark indicates that the component is the datum component. The top of this 
component is the Z-reference datum, and is fixed vertically (it does not change with any changes 
to the slab thickness or definition)

New Opens the Slab Component Settings dialog box to define the components of the slab as described 
previously in this section

Edit Opens the Slab Component Settings dialog box to edit the selected component’s thickness and 
attributes (you can also double-click on a component to open the Slab Component Settings dialog 
box) 

Duplicate Duplicates the selected slab component; the duplicate is added to the component list right below 
the originally selected component; the slab thickness is adjusted accordingly

Delete Deletes the selected slab component; the slab thickness is adjusted accordingly
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Editing Slabs
Slabs are path-based objects and can be reshaped, added to, and clipped. For example, a slab may need a hole clipped to 
accommodate a flight of stairs, or may need area added to represent a balcony.

Reshaping Slabs

To reshape a slab:

1. Click the Reshape tool from the Basic palette.
Alternatively, double-click on the slab to activate the Reshape tool.

2. Click one of the modes from the Tool bar.
See “Reshaping Objects” on page 1043.

3. The datum component is selected for reshaping; any editing applies to the entire slab.

Clipping a Slab
When clipping a slab, select whether the clip operation should affect the entire slab or only certain components.
To clip a slab:

1. Create a closed 2D object to represent the clipping object. The object must overlap the slab.
2. Select both the slab and the clipping object.
3. Select Modify > Clip Surface.
4. The Clip shape from slab dialog box opens. Select whether to clip the entire slab, or choose the components to be 

clipped by selecting them. 
5. Click OK.

Clip applied to entire slab Clip applied to top component only

Isometric views
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Adding to the Slab Surface
When adding to a slab, select whether the add operation should affect the entire slab or only certain components.
To add to a slab:

1. Create a closed 2D object to represent the add surface. The object must overlap the slab.
2. Select both the slab and the add surface object.
3. Select Modify > Add Surface.
4. The Add Shape to Slab dialog box opens. Select whether to add to the entire slab, or choose the components to be 

added to by selecting them.
5. Click OK.

Modifying the Clipping/Adding Shape
The original editing object used to clip or add to the slab can be modified.
To modify the editing object:

1. Select the slab.
2. Select Modify > Edit Slab.

A colored border around the drawing window indicates that you are in an editing mode. The Exit Slab command 
becomes available from the Modify menu, and the Exit Slab button is visible in the top right corner of the 
drawing window. The editing object is selected.

3. Move, delete, or reshape the editing object (new editing objects cannot be added, however). The slab is locked and 
cannot be edited.

4. Click Exit Slab to return to the drawing.

Add applied to entire slab Add applied to bottom component only

Isometric views
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Walls
All Vectorworks products have tools and commands to design straight and round walls. Some of the tools and 
commands in the Vectorworks Design Series products are similar to those available in the Vectorworks Fundamentals 
product, but with extended capabilities required for architectural design. Walls can be drawn using the Wall tool and 
Round Wall tool, or created automatically from objects that exist in the drawing, including spaces, polygons, and 
shapes. The Vectorworks Architect and Landmark products also include the ability to create curtain walls.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Creating Walls
Use the wall tools to draw straight or round standard walls or, in the Vectorworks Architect and Landmark products, 
curtain walls, and to join those walls to other walls. Each wall segment is treated as a separate object. Either 
automatically join walls together when drawing them, or join them after drawing by using one of the joining options. 
Other wall options include the ability to add component lines and fills to walls, cap and trim them, and insert symbols 
(such as doors and windows) into them. You can also add and delete peaks in a wall, if the elevation changes from one 
end of the wall to the other.
Additional wall parameters are available only in the Architect and Landmark products. These products add the ability 
to create, save, and use wall styles and to create new wall or component classes during wall creation and editing. In the 
Vectorworks Architect product, walls and their components also have the ability to have their top and bottom 
boundaries set to the levels of the story, or the levels of the story above or below the current wall story.
There are four ways to position the wall in relation to the control line; the control line can be set relative to either the 
wall or an optional core component. Straight walls can be drawn in either Polygon mode or Rectangle mode. These 
modes are activated by the buttons on the Tool bar.

Vectorworks Fundamentals Vectorworks Architect, Landmark, or Spotlight

Wall tool and Round Wall tool located 
in the Walls tool set

Wall tool and Round Wall tool, located in the Building Shell tool set, 
with extended capabilities in the Vectorworks Architect and Landmark 
products

Modify > Create Polys from Walls AEC > Create Polys from Walls
Landmark > Architectural > Create Polys from Walls
Spotlight > Architectural > Create Polys from Walls

Modify > Create Walls from Polygon AEC > Create Objects from Shapes (with extended capabilities)
Landmark > Create Objects from Shapes
Modify > Create Objects from Shapes in Spotlight 
AEC > Space Planning > Create Walls from Spaces 
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See “Wall Direction” on page 506 for details on how the starting point and direction in which the wall is drawn 
determines the wall’s interior and exterior sides.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Mode Description

Left Control Line Walls are drawn along their left sides
Center Control Line Walls are drawn from the center
Right Control Line Walls are drawn along their right sides
Custom Control Line / 
Custom Wall Offset

Walls are drawn from an offset point specified in wall preferences. Setting the offset to 
be negative offsets the wall to the right of the center line, a positive offset is to the left. 
Setting a wall offset is most effective when drawing walls containing components.

Wall Control Line Sets the control line relative to the wall
Core Component 
Control Line

Sets the control line relative to the wall component that has been designated as the core 
component in the wall preferences

Polygon Mode Draws a straight wall or wall system by clicking at each corner to create a custom shape, 
similar to the Polygon tool

Rectangle Mode Draws a rectangular wall system with two clicks, similar to the Rectangle tool’s Corner 
to Corner mode

Preferences Sets the physical parameters of the wall
Arc Creation Controls Select the arc creation method to use when drawing round walls; for more information on 

arc creation modes, see “Creating Arcs” on page 293

Left Control
Line

Right Control Line

Custom Control Line

Preferences

Round Wall Arc 
Creation Controls

Center Control Line

Left Control
Line

Right Control Line Preferences

Straight Walls

Round 
Walls

Wall Control Line

Wall Control Line

Core Component 
Control Line

Custom Wall Offset

Polygon Mode

Rectangle Mode
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Drawing Straight Walls
The Wall tool creates a hybrid wall object, simultaneously adding both a 2D and a 3D version of the wall to the 
drawing. Walls can be drawn in Top/Plan or in a 3D view. Standard walls or curtain walls (Vectorworks Architect or 
Landmark required) can be created.

Create walls by drawing them with the mouse, or by using a mouse-Data bar combination (see “Using the Data Bar” on 
page 125). The following directions assume that the walls are drawn with the mouse.

If walls are drawn using the Data bar, the Control Line mode setting determines whether the dimensions entered 
are for the left, center, or right edge of the wall, or a custom location.

To create straight walls:

1. Select the Wall tool from the appropriate tool set:
• Fundamentals workspace: Walls tool set
• Design Series workspaces: Building Shell tool set

2. Click the desired Control Line mode, and click either Polygon or Rectangle mode, as desired (see “Creating 
Walls” on page 497).

3. In the Vectorworks Architect or Landmark product, to draw with an unstyled wall, select <Unstyled> from the 
Wall Style list on the Tool bar. If the desired styled wall resource has already been created, select it from the Tool 
bar list or double-click on the resource in the Resource Browser and proceed to Step 6.

4. Click Preferences from the Tool bar.
The Wall Preferences dialog box opens. This dialog box can be accessed any time afterward to modify default wall 
settings. Walls can also be drawn first, and then the parameters can be set later from the Object Info palette. 

Click to show/hide the parameters.

Parameter Description

Wall Style 
(Vectorworks Design 
Series required)

Select a wall style for the wall; see “Using Wall Styles” on page 507. Alternatively, select 
<Unstyled> to create the wall without linking the parameters to a wall style. 

If a selected wall style's parameters are edited in the Wall Preferences dialog box, the 
wall style automatically changes to unstyled, indicating that the edited style must be 
saved as a new style to save changes (alternatively, the changes can be applied as an 
unstyled wall, and they are not saved).

2D wall segment

3D walls
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5. Click Edit Wall Attributes to specify the wall attributes.
The Wall Attributes dialog box opens. The wall attributes of an unstyled wall are initially set to the parameters 
displayed in the Attributes palette. If they are changed here, the Attributes palette reflects the changed attributes of 
the selected wall (after exiting the Wall Preferences dialog box).
Fill, pen, and opacity can be set by class rather than by the attributes in the Wall Attributes dialog box. If the wall 
class is changed later, the wall changes to use the attributes of the new class. Wall attributes cannot be overridden 
on a per-instance basis; if a wall style uses class attributes, all walls of that style must use class attributes. 
However, walls of the same wall style can be placed in different classes.

Click to show/hide the parameters.

Save Preferences as 
Wall Style 
(Vectorworks Design 
Series required)

Saves the current preference settings as a new wall style. The Assign Name dialog box 
opens; enter a wall style name and click OK (see “Creating Wall Styles” on page 508).

Wall Type
(Vectorworks 
Architect or 
Landmark required)

Select whether to create a standard wall or a curtain wall. Standard walls are described in 
this section. Curtain walls are described in “Creating Curtain Walls” on page 522.

Preview Displays a preview of the wall structure, including any defined components; the preview 
wall is drawn from left to right, so the “top” of the preview, by default, indicates the left part 
of the wall as it will be drawn. The arrow shows the wall direction.

Overall Thickness Displays the thickness of the wall. The thickness of a wall with components is defined by 
the sum of the component thicknesses. When components have been defined, this parameter 
becomes read-only. If a wall contains no components, enter the wall thickness.

Edit Wall Attributes Opens the Wall Attributes dialog box, to specify the wall fill, pen, opacity, and wall cap 
settings

Components Lists the components that form the structure of the wall, in order from left to right as 
displayed in the preview. To change the order of a component, click and drag within the # 
column.

Core One of the wall components can optionally be designated as a core component by clicking 
in the Core column. A check mark indicates that the component is the core component. 
When the Auto join walls Vectorworks preference is enabled, components also 
automatically join based on the core component specified for each wall.

Other Component 
settings

The remaining columns in the component list display the component thickness and class 
setting

New Opens the Wall Component Settings dialog box to define the components of the wall; see 
“Creating Wall Components” on page 513 for information on creating components

Edit Opens the Wall Component Settings dialog box to edit the selected component’s thickness 
and attributes (alternatively, double-click on a component to open the Wall Component 
Settings dialog box) 

Duplicate Duplicates the selected wall component; the duplicate is added to the component list right 
below the originally selected component

Delete Deletes the selected wall component; the wall thickness is adjusted accordingly

Parameter Description
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6. Click OK to return to the Wall Preferences dialog box. If components are to be added to the wall, click New to 
define each component (see “Creating Wall Components” on page 513). The Overall Thickness is then defined 
by the thickness of the wall components.
In the Vectorworks Architect and Landmark products, wall components can be assigned to a class; this allows 
maximum flexibility since the component classes can be shown or hidden separately from the wall class. Select a 
class for the wall component to control its appearance and visibility. The classes present in the drawing are listed; 
alternatively, create a new class by selecting New, or select the class named <Object Class> which places the 
component in the same class as the wall. By default, components are assigned to the wall class. 
In the Vectorworks Fundamentals product, wall components are automatically assigned to the <Object Class> and 
are always in the same class as the wall. 
When a component is in an invisible class, its fill and lines are hidden. Invisible components on the interior and 
exterior of a wall cause the wall’s lines and fill to adjust to the visible components only, making the wall appear 
thinner than its actual width. This allows walls to show only their structural components, for example. If all 
components are invisible, the wall displays at its full thickness, without components.

Parameter Description

Fill
Style Specify the wall fill attributes. Select None for no fill, or Class Style to set the wall fill 

attributes by class rather than by the parameters in the Wall Attributes dialog box. 
Selected hatch, gradient, or image fills, if not already present in the file, are imported and 
added to the Resource Browser (default content is automatically imported into the current 
file at the point of use and displays in the Resource Browser). See “Resource Libraries” 
on page 219.

Pen
Style Specify the wall pen attributes. Select None for no pen, Line Type to select a complex 

line type, or Class Style to set pen attributes by class rather than by the parameters in the 
Wall Attributes dialog box.

Thickness When a pen style has been selected, specify the line thickness. If Line Type is selected as 
the pen style, also select the line type to use.

Opacity
Use Class Opacity Sets wall opacity by class rather than by the parameters in the Wall Attributes dialog box
Opacity Specifies the transparency of the wall; drag the slider to the left to increase the 

transparency, or enter a percentage directly in the box to the right of the slider
Wall Caps

Use Wall Line 
Attributes

Uses the attributes of the wall line for the wall caps

Use Component Line 
Attributes

Uses the attributes of the components (left line) for the wall caps

Wall with all components visible Wall with only structural 
component visible

Wall with only finish 
components visible
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The Hide Details preference can be used to hide wall components based on scale (Vectorworks Design Series 
required); see “Hiding Wall Components” on page 517.

7. Click the Insertion Options tab to set the wall insertion options.
Curtain walls have slightly different parameters; see “Creating Curtain Walls” on page 522.

Click to show/hide the parameters.

8. Click the Textures tab to select textures for the wall parts (Renderworks required).
Textures for curtain walls are controlled by the frame and panel settings on the Definition tab; see “Creating 
Curtain Walls” on page 522.

Click to show/hide the parameters.

Parameter Description

Height
Height Directly sets the desired height of the wall. When the wall height is determined manually by 

this method, the Top Bound property of the wall is automatically set to Layer Elevation, 
and the Top Offset value is modified accordingly.
When the top of the wall is bound by the layer wall height value, the wall height updates 
automatically.

Top Bound Sets the vertical reference that determines the top of the wall.
The Layer Wall Height value is set by the design layer (see “Setting Design Layer 
Properties” on page 165).
Additional options are available for the Vectorworks Architect product. The top of the wall 
can be bound by one of the story levels defined for the story or the story above it. By setting 
the top of the wall to a level type, if the elevation of the associated story changes, the height 
of the wall changes automatically to match.
The default wall styles automatically assign a top bound level type to the wall, assuming 
that stories will be used in the file. However, this can be changed by selecting a different 
option.

Top Offset Sets the offset of the top of the wall from its specified top bound height.
Bottom Bound Sets the vertical reference that determines the bottom of the wall; Layer Elevation is the 

only option available unless the Vectorworks Architect product is installed.
Additional options are available for the Vectorworks Architect product. The bottom of the 
wall can be bound by one of the story levels defined for the story or the story below it. By 
setting the bottom of the wall to a level type, if the elevation of the associated story 
changes, the height of the wall changes automatically to match.
The default wall styles automatically assign a bottom bound level type to the wall, 
assuming that stories will be used in the file. However, this can be changed by selecting a 
different option.

Bottom Offset For the bottom of the wall, sets the offset from the layer elevation
Caps Select whether a wall segment is capped at the start point, the end point, both ends, or has 

no caps at all
Class Specifies the default class for the walls
Control Offset If using the Custom Control Line wall mode, enter the offset value for the control line
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9. Click the Data tab to specify wall record information, which is IFC-compliant and can be included in a wall style 
schedule (Vectorworks Architect or Landmark required). These fields are optional; enter text only where desired.

10. When the wall parameters have been specified, and any changes saved as a wall style resource if desired 
(Vectorworks Design Series required), click OK.
In the Design Series, a saved or selected wall style is saved as a resource in the file, and appears in the Resource 
Browser and in the Wall Style list on the Tool bar. See “Creating Wall Styles” on page 508.

11. If Polygon mode is selected, click at the starting point of the first wall section.
12. Click to end the first wall section.

To continue creating walls, click at the end of each additional wall section.
13. Double-click to finish the wall if the start point and end point are not at the same location; otherwise, click at the 

starting location (a SmartCursor cue displays) to finish the wall.
Alternatively, after completing all but the final click, press the keyboard shortcut (K by default) to automatically 
close the polygonal wall network. See “Modifying Snapping and Mode Shortcuts” on page 1842 to change the 
shortcut.

Parameter Description

Use Component 
Textures

Uses the textures defined for the wall components to texture the wall 
This option can also be selected for an existing wall from the Render tab of the Object 
Info palette

Use Object Textures Uses the textures defined below for the wall parts (see “Applying a Texture to an Object” on 
page 1530 for information on applying textures to an object with parts) 

Part Applies the texture selected in Texture to the selected parts of the wall 
Revert to Overall If a part was assigned a texture but it should inherit its texture from Overall instead, select 

the part and click Revert to Overall. The part moves back below the divider, and (from 
Overall) displays as its texture name. 

Texture Applies the selected texture to the selected Part. 
Textures can also be set from the Render tab of the Object Info palette. Textures applied 
from the Object Info palette override the textures set here. 

No Texture Does not apply a texture to the selected Part
Class Texture Uses the texture defined by the wall’s class. The class texture is set from the Other tab in the 

Edit Classes dialog box. Any walls with that wall style use class textures for that part of the 
wall (unless overridden). Class Texture can also be chosen for a selected wall in the Render 
tab of the Object Info palette.

Choose Texture Choose a texture for the selected Part from the default content or the current file’s content 
(see “Resource Libraries” on page 219). Textures set here override the object class textures. 
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When drawing a wall network, move the mouse in the direction of the next-to-last click and press the shortcut key 
before clicking; the software extrapolates the correct alignment and position for a 90° corner and places the final 
two clicks to complete the wall network.

Click 1

Click 5

Click 2

Click 4

Click 3

Click 1

Click 2

Click 3

Click 4

Click 5

Walls drawn in Top/Plan view

Walls drawn in a 3D view

Drawing straight walls with Polygon mode

Click 1
Click 2

Click 3

Move the mouse in the direction of the 
next-to-last click, and press the shortcut key 
(K by default) 

The software places the final two clicks 
to complete the wall network with a 90° 
corner

Click 1
Click 2

Click 3
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14. If Rectangle mode is selected, click at the wall’s start point; this becomes one corner of the rectangular wall 
system. Move the mouse to the opposite corner until the desired size is previewed.

15. Click to set a corner point on the wall system. Four walls are created. 
When the Vectorworks preference Auto join walls is on, walls drawn in Rectangle mode that overlap or touch 
each other interact, so complex wall systems can be drawn quickly. See “Automatically Joining Walls in 
Rectangle Mode” on page 543 for the rules that define these interactions.

The properties of a wall can be edited in the Object Info palette; see “Wall Properties” on page 535. 
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Walls
Creating Curtain Walls
Wall Direction
Using Wall Styles
Automatically Joining Walls
Creating Wall Components
Editing Walls
Creating Walls from a Polygon
Applying Wall Textures
The Attributes Palette

Drawing Round Walls
Round, 2D-3D hybrid walls can be created and joined to straight walls. The Round Wall tool is essentially a 
combination of the Wall tool and Arc tool functions. It creates a round wall with the same features and elements as 
straight walls. Walls can be drawn in Top/Plan or in a 3D view. Standard walls or curtain walls can be created

Round walls preferences include all of the same parameters as straight walls.

To create round walls:

1. Select the Round Wall tool from the appropriate tool set:

Walls drawn in Top/Plan view Walls drawn in a 3D view

Drawing straight walls with Rectangle mode

Click 1

Click 2

Click 1

Click 2

3D view 2D view
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• Fundamentals workspace: Walls tool set
• Design Series workspaces: Building Shell tool set

2. Click the desired Offset mode (see “Creating Walls” on page 497).
3. Click Preferences (parameters are described in “Drawing Straight Walls” on page 499.)
4. Click OK when the round wall preferences have been set.
5. Click to set the center point of the wall arc.
6. Click the mouse to begin drawing the wall, or use the Data bar to enter an angle. For more information on arc 

creation modes, see “Creating Arcs” on page 293.
7. Click to end the wall.

Click here for a video tip on this topic (Internet connection required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Wall Direction
Automatically Joining Walls
Creating Wall Components
Editing Walls

Wall Direction
The starting point and the direction in which the wall is drawn determine a wall’s “sides.” Think of yourself standing at 
the wall’s start point and then walking along the top of the wall in the direction of the next point. The side to your left 
would be designated the left side, and the side to your right the right side. These left and right side designations are 
used when applying textures to the walls.
Drawing walls in a clockwise direction is always recommended. The wall styles available in the Vectorworks Design 
Series expect the exterior of the wall to be on the left side.

New walls drawn with Rectangle mode are drawn in a clockwise direction, regardless of click placement. (See 
“Automatically Joining Walls in Rectangle Mode” on page 543 for a description of wall direction when the 
Subtract option is used.)

Click 1

Click 2
Click 3

In Top/Plan view, arrows indicate the current wall direction

For walls drawn in a 
clockwise direction, the left 

side is the exterior

Left 
(exterior)

Right
(interior)

http://www.youtube.com/watch?v=dGS5CGd9iu4
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To reverse the wall direction, click Reverse Sides from the Object Info palette.
~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Wall Textures

Using Wall Styles
Unstyled walls can be used in the Vectorworks Architect and Landmark products. The attributes of an unstyled wall can 
be changed from the Attributes palette. The use of wall styles, however, facilitates drawing walls by saving the wall 
preferences settings so that they can be easily selected as the default style when drawing new walls, or so that they can 
be applied to existing walls. Wall styles are resources that can be imported into other files and shared as office 
standards.
A wall style contains a significant amount of information:

• Wall composition and structure (components for standard walls, and frames and panels for curtain walls)
• Insertion options (height constraints, caps, classing)
• Wall attributes (fill, pen, line weight, classing, texture resources (Renderworks required), hatch resources)
• Vertical wall constraints (by layer elevation, layer wall height or, for the Vectorworks Architect program, story 

layer levels)
• Component constraints, for standard walls
• Other non-geometric data (wall style name, thermal data, product data, and so on)

Because a wall style contains so much information, it can be time-consuming to create one from scratch. However, a 
variety of wall styles are provided as default content (default content is automatically imported into the current file at 
the point of use and displays in the Resource Browser; see “Resource Libraries” on page 219). 
Depending on how you use wall styles and which product is in use, usually only one type of wall style, simple or 
constrained, is needed. Wall styles provided by the Wall or Round Wall tool in a blank file are simple wall styles that 
use the conventional method of determining the top and bottom wall height according to the layer elevation or layer 
wall height. However, constrained wall styles are provided in templates named with a BIM prefix; these are available 
for Vectorworks Architect users from the Use document template list in the Create Document dialog box. These wall 
styles are constrained to the story level settings in those templates, and they provide additional wall detail, accuracy, 
and flexibility. More information on using wall styles and story levels with BIM is available for drawings set up with 
metric units and with imperial units.
A selected wall can be converted to an unstyled wall by selecting Convert to Unstyled Wall from the Style list in the 
Object Info palette. The component settings of unstyled walls can be edited by clicking Components from the Object 
Info palette. When a wall becomes unstyled, it loses all its non-geometric data. An unstyled wall’s properties can be 
converted into a new wall style with a right-click (Windows) or Ctrl-click (Mac) on the wall; select New Wall Style 
from Unstyled Wall.
The insertion options of a styled wall (including wall height, constraints, class, and caps) are properties that can be 
changed from the Object Info palette without requiring a new style definition.
Unused wall styles can be purged; see “Purging Items from a File” on page 1011.
~~~~~~~~~~~~~~~~~~~~~~~~~
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Replacing Wall Styles
Creating Walls
Setting Up the Building Structure with Stories

http://download2.nemetschek.net/www_misc/bim/BIM-Templates-in-Vectorworks-2015-SI.pdf
http://download2.nemetschek.net/www_misc/bim/BIM-Templates-in-Vectorworks-2015-IMP.pdf
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Creating Wall Styles

To create a straight wall style:

To create a round wall style:

1. Select the Wall or Round Wall tool from the Building Shell tool set, and then click Preferences from the Tool 
bar.
The Wall Preferences dialog box opens.

2. To modify an existing wall style, select the Wall Style from either the default content or the current file’s content. 
Alternatively, select Unstyled as the wall style and set the parameters.

3. Specify the wall and component parameters as described in “Creating Walls” on page 497, and “Drawing Straight 
Walls” on page 499.
The attributes of an unstyled wall can be saved as a wall style. Set the Eyedropper Preferences to pick up all wall 
attributes and select the Pick Up Sets Defaults option. The Eyedropper tool can then be used to pick up wall 
attributes from an unstyled wall and add the settings to the Wall Preferences dialog box, where the settings can be 
saved as a style.

4. Click Save Preferences as Wall Style.
The Assign Name dialog box opens.

5. Enter a unique name for the wall style and click OK.
If the wall style name already exists, you are prompted to cancel and select a different name, or replace existing 
walls with the wall style applied with the edited wall style. If you are replacing wall styles, the Wall Replacement 
dialog box opens; specify the wall alignment properties.

6. The new wall style is saved with the file and is listed under Wall Styles in the Resource Browser as well as the 
Wall Style list in the Tool bar.
A new wall style can also be created by clicking Resources > New Resource > Wall Style in the Resource 
Browser. A wall style created in this way is not associated with the current wall preference setting, but can be 
applied later.
Worksheets listing the current wall styles and wall areas in the drawing can be added to the drawing from the VA 
Create Schedule command (in the Architect workspace) or the Resource Browser. From the Resource Browser, 
open the default architectural reports file from the [Vectorworks]\Libraries folder that is included with the 
Vectorworks Architect product (see “Resource Libraries” on page 219). Drag the Wall Area and/or Wall Style 
Report worksheet to the drawing. The worksheet is populated with information from the objects in the current 
drawing.
A wall style resource can be exported; see “Exporting Custom Resources” on page 234. If the wall style is 
exported to the default Walls~Slabs folder within the user folder, the exported file must be placed within a 
subfolder, or it won’t be included in the list of available wall styles.

~~~~~~~~~~~~~~~~~~~~~~~~~
Resource Libraries
Editing Wall Styles
Applying Wall Styles
Replacing Wall Styles
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Editing Wall Styles

To edit a straight wall style:

To edit a round wall style:

1. Select the wall style from the Resource Browser and click Resources > Edit.
The Edit Wall Style dialog box opens.

2. Edit the wall and component parameters as described in “Creating Walls” on page 497, and “Drawing Straight 
Walls” on page 499.
If a new wall style Name is specified, it replaces the selected wall style name (similar to selecting Rename from 
the Resources menu).

3. Click OK.
4. If walls with that style already exist in the drawing, the Wall Replacement dialog box opens.

The wall style to apply cannot be selected (the edited style is applied). Select the wall alignment properties (see 
“Replacing Wall Styles” on page 510).

5. Click OK to edit the wall style.
Changes apply to any existing walls in the drawing with the edited wall style, and will be used for any subsequent 
walls created with that wall style.

~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Wall Styles
Replacing Wall Styles

Applying Wall Styles
By a variety of methods, wall styles can be selected for a wall before drawing it, or applied to existing walls. Once a 
wall style has been selected for a wall, the Attributes palette is no longer available for changing wall attributes; 
attributes are set as part of the style.
To apply a wall style prior to drawing the wall:

1. Select the Wall tool or Round Wall tool from the Building Shell tool set.
2. Select the desired style from the Wall Style list on the Tool bar. The available wall styles are from either the 

default content or the current file’s content.
Alternatively, click Preferences from the Tool bar. In the Wall Preferences dialog box, select the Wall Style.

To apply a wall style from the Resource Browser prior to drawing the wall:
1. Ensure that no walls are selected.
2. Select a wall style in the Resource Browser, and click Resources > Apply.

Alternatively, double-click on the wall style in the Resource Browser.
3. The Wall tool is automatically made active and the selected wall style is applied to the wall as it is drawn. (If a 

round wall is desired, select the Round Wall tool from the Building Shell tool set.)
To apply a wall style to an existing wall from the Object Info palette:

1. Select one or more walls.
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2. From the Object Info palette, select the wall Style from either the default content or the current file’s content; see 
“Resource Libraries” on page 219.
To apply a different (default) style, select Replace.

To apply a wall style to an existing wall from the Resource Browser:
1. Select one or more walls.
2. Select the wall style from the Resource Browser and click Resources > Apply. Alternatively, drag the selected 

wall style from the Resource browser to the wall and click on the wall selection.
The Wall Replacement dialog box opens.

3. Select the wall alignment properties. The wall style list is disabled (the style selected in the Resource Browser is 
applied). 

4. Click OK.
A styled wall can be converted to an unstyled wall.
To remove a wall style:

1. Select one or more walls to un-style.
2. From the Object Info palette, select Convert to Unstyled Wall.

The wall is released from its style; its attributes can be edited from the Attributes palette.
~~~~~~~~~~~~~~~~~~~~~~~~~
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Replacing Wall Styles
Wall styles applied to existing walls or curtain walls can be replaced with a different wall style. 

A wall replacement situation may also occur if pasting a styled wall from another file. You can select a 
replacement wall style and how to align the styles for the pasted walls.

To replace a wall style:
1. Select one or more walls.
2. From the Object Info palette, select Replace from the Style list.

The Wall Replacement dialog box opens. Specify the new wall style, and then select a component (or the wall) 
from the current and replacement structure lists. Specify the alignment option for each selection; the preview 
updates, with a red line showing the replacement alignment.

Click to show/hide the parameters.

Parameter Description

Wall style list From the list, select the wall style that will replace the current style
Previews The left preview shows the current wall style, and the right preview shows the replacement 

wall style selected in the wall style list. Preview walls are drawn from left to right, so the 
“top” of the preview, by default, indicates the left part of the wall as it will be drawn.
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If walls with different wall styles were selected for replacement, the current wall preview is blank and components 
are not listed. Wall alignment can only occur for the left, center, or right of the selected wall(s).

3. Click OK to replace the wall style of the selected wall(s).
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Wall Styles
Applying Wall Styles

Creating Wall End Caps
The Wall End Cap tool creates both standard and custom component wrapping at the end of a wall. It has three modes:

Setting Wall End Cap Preferences

To set wall end cap preferences:

1. Click the Wall End Cap tool from the Building Shell tool set.

Align lists On the left, the current wall structure is listed; the right list displays the replacement wall 
structure. Select one wall component from each list and specify its alignment options. The 
previews update with red lines to show how the replacement wall will align with the 
current wall.

Alignment options Select an option for aligning the current structure to the replacement structure
Replacement options Select whether to replace the current settings for wall height, class designations, and 

texture assignments (Renderworks required for textures) with those of the new wall. 
Texture replacement does not apply to curtain walls.

Curtain Wall Frames 
and Panels (curtain 
walls required)

Specify how to handle frames and panels when replacing a curtain wall style

Update Frames 
and Panels

Updates the existing frames and panels to use the frame and panel settings defined in the 
new curtain wall style (custom frame spacing and panel size is not changed)

Delete and 
Recreate Frames 
and Panels

Clears all existing frames and panels and recreates the curtain wall using the grid definition 
of the replacement curtain wall style

Mode Description

Component Wrap Automatically wraps the selected component, creating a standard wall cap
Add Creates a custom wall end cap by adding
Clip Creates a custom wall end cap by removing
Preferences Sets whether to create wall caps inside or outside the wall endpoint

Parameter Description

Component
Wrap

Clip

Add

http://www.youtube.com/watch?v=TQh70ElGIvo
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2. Click Preferences from the Tool bar.
The Wall End Cap Settings dialog box opens.
Determine whether to create the wall end caps outside the wall endpoint. Deselect the option to create the wall end 
caps inside the wall endpoint, so that the wall length does not extend past the original length.

3. Click OK.
This option is also available from the Object Info palette for existing wall end caps.

Creating a Standard Wall End Cap

To create a standard end cap by wrapping a component:

1. Click the Wall End Cap tool from the Building Shell tool set.
2. Click Component Wrap from the Tool bar.
3. Click to select a component within the wall. This component wraps along the wall end.
4. Click to select the component where the wrapping should end.

The component wraps around the wall end to the end point.

Wall End Cap Properties
An End Cap in Wall object is created by the Wall End Cap tool. This object, while distinct from the wall, moves with 
the wall and adjusts if the wall is resized. The object can be dimensioned, reported in wall schedules, and exported as 
part of the wall. 
The wall cap uses the line weight of the source component, and its 3D geometry is of the same height as the source 
component.
The Extend Cap Past Wall Endpoint option can be changed from the Object Info palette.

Adding a Custom Wall End Cap

To create a custom wall end cap by adding a shape to a component:

1. Create a 2D, closed shape to represent the wall end cap. The object must intersect the end of the wall.
2. Click the Wall End Cap tool from the Building Shell tool set.
3. Click Add from the Tool bar.
4. Click to select a component within the wall. This component style is used to create the wall end cap.
5. Click to select the shape.
6. The shape is added to the component and the wall end, creating the custom wall cap.

Click 1

Click 2

Click 1
Click 2
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Clipping to Create a Custom Wall End Cap

To create a custom end cap by clipping a shape from a component:

1. Create a 2D, closed shape to represent the wall end cap. The object must intersect the end of the wall.
2. Click the Wall End Cap tool from the Building Shell tool set.
3. Click Clip from the Tool bar.
4. Click to select a component within the wall. This component style is used to create the wall end cap.
5. Click to select the shape.
6. The shape is subtracted from the component, creating the custom wall cap.

Click here for a video tip on this topic (Internet connection required).
~~~~~~~~~~~~~~~~~~~~~~~~~
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Creating Wall Components
Wall components define the sections that make up a standard wall. For example, to indicate that a wall is made up of 
studs, inner drywall, outer sheathing, and then a siding material, define a component for each of these items to illustrate 
their location. Wall components can be offset at the top or the bottom of the wall, individually constrained relative to 
the wall, the layer, or, for Vectorworks Architect users, to story levels. Components can be textured (Renderworks 
required), creating realistic section views and rendered views, as well as accurate wall material estimates. The area and 
volume of wall components can be calculated in worksheets; see “Worksheet Functions” on page 1344).

Click 1

Click 2

Click 1

Click 2

http://www.youtube.com/watch?v=xhv96yD-vAg
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The overall thickness of a wall is equal to the sum of its components. Component fill and pen style are only displayed 
in Top/Plan view (except for section viewports in the Vectorworks Design Series products).
Use the Eyedropper tool to copy wall component settings from one wall to another (see “Transferring Attributes” on 
page 1095).

Additional wall capabilities are available in the Vectorworks Architect and Landmark products. Curtain walls do 
not have components.

Wall components can be defined prior to drawing the wall in Wall Preferences mode, or after drawing the wall, from 
the Object Info palette.

Wall components can also be edited from Wall Preferences mode. Editing a component from wall preferences 
does not affect existing walls.
Click here for a video tip about this topic (Internet access required).

Defining Components for New Walls
To define a wall component prior to drawing the wall:

1. Select the Wall tool or Round Wall tool from the appropriate tool set, and then click Preferences from the Tool 
bar.
• Fundamentals workspace: Walls tool set
• Design Series workspaces: Building Shell tool set
The Wall Preferences dialog box opens.

2. On the Definition tab, click New. 
The Wall Component Settings dialog box opens. Specify the component thickness, name, and parameters. 

Click to show/hide the parameters.

Parameter Description

Definition
Name Provide a name for the component, which displays in the Components list in the 

Wall Preferences dialog box
Class In the Vectorworks Architect or Landmark product, select a class for the component 

to control its appearance and visibility (see “Creating Walls” on page 497). The 
classes present in the drawing are listed; alternatively, create a new class by 
selecting New, or select the class named <Object Class>, which places the 
component in the same class as the wall object.
The Vectorworks Fundamentals product can display classes set in a Vectorworks 
Design Series product. <Object Class> indicates that the component assumes the 
same class setting as that of the wall.

Thickness Specifies the component’s thickness; the thickness of a wall is the sum of its 
components. A component must have a thickness greater than 0.

Component Top
Relative to Wall Sets the top of the component relative to the top of the wall

http://www.youtube.com/watch?v=pkBqHikFGvo
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Relative to Story 
(Vectorworks Architect 
required to set to story 
levels)

Select the vertical reference that determines the top of the component from the Top 
Bound list.
The Layer Wall Height or Layer Elevation value is set by the design layer (see 
“Setting Design Layer Properties” on page 165).
Additional options are available for the Vectorworks Architect product. The top of 
the component can be bound by one of the story levels defined for the story or the 
story above it. Select the level from the Top Bound list. By setting the top of the 
component to a level type, if the elevation of the associated story changes, the 
height of the component changes automatically to match. 

Top Offset Specifies an additional offset distance for the component from the top of the wall
Follow Top Wall Peaks The component follows the wall peaks at the top of the wall

Component Bottom
Relative to Wall Sets the bottom of the component relative to the bottom of the wall
Relative to Story 
(Vectorworks Architect 
required to set to story 
levels)

Select the vertical reference that determines the bottom of the component from the 
Bottom Bound list. Layer Elevation is the only option available unless the 
Vectorworks Architect product is installed.
Additional options are available for the Vectorworks Architect product. The bottom 
of the component can be bound by one of the story levels defined for the story or 
the story below it. By setting the bottom of the component to a level type, if the 
elevation of the associated story changes, the height of the component changes 
automatically to match.

Bottom Offset Specifies an additional offset distance for the component from the bottom of the 
wall

Follow Bottom Wall Peaks The component follows the wall peaks at the bottom of the wall
Fill

Style Specify the wall fill attributes. Select None for no fill, or Class Style to set the 
component fill attributes by class rather than by the parameters in the Wall 
Component Settings dialog box. Selected hatch, gradient, or image fills, if not 
already present in the file, are imported and added to the Resource Browser (default 
content is automatically imported into the current file at the point of use and 
displays in the Resource Browser). See “Resource Libraries” on page 219.

Use a tile fill with Fit to Wall selected, to represent insulation fill. See 
“Defining Tiles” on page 1112.

Texture (Renderworks 
required)

No Texture Does not apply a texture to the component
Class Texture Sets the component to use the texture specified by the component’s class. The class 

texture is set from the Other tab in the Edit Classes dialog box; see “Setting Class 
Properties” on page 179.

Choose Texture Select a texture for the component from the default content or the current file’s 
content (see “Resource Libraries” on page 219). 

Parameter Description
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3. Click OK to create the component and return to the Wall Preferences dialog box.
The wall’s Overall Thickness value changes to be determined by its components. As components are defined, 
they display in the preview. Click and drag a component in the # column to change its order.

4. Click OK.

Defining Components for Existing Walls
To define or edit wall components for an existing, unstyled wall:

1. Select the wall(s).
2. From the Object Info palette, click Components.

The Components dialog box opens.
Click to show/hide the parameters.

3. Click New or Edit, and define or edit the components as described previously.
4. Click OK to return to the Components dialog box.

Left Pen/Right Pen Select a style for the left and right sides of the component. Select None for no pen, 
Line Type to select a complex line type, or Class Style to set the component pen 
attributes by class rather than by the parameters in the Wall Component Settings 
dialog box.

Thickness When a pen style has been selected, specify the line thickness; see “Line Thickness 
Attributes” on page 1101. If Line Type is selected as the pen style, also select the 
line type to use.

Parameter Description

Preview Displays a preview of the wall structure, including the defined components; the preview wall is 
drawn from left to right, so the “top” of the preview, by default, indicates the left part of the wall 
as it will be drawn. The arrow shows the wall direction.

Overall 
Thickness

The thickness of a wall with components is defined by the sum of the component thicknesses

Components Lists the components that form the structure of the wall, in order from left to right as displayed in 
the preview. To change the order of a component, click and drag within the # column.

Core One of the wall components can optionally be designated as a core component by clicking in the 
Core column. A check mark indicates that the component is the core component. When the Auto 
join walls Vectorworks preference is enabled, components also automatically join based on the 
core component specified for each wall. See “Automatically Joining Walls” on page 542.

New Opens the Wall Component Settings dialog box to define the components of the wall as described 
previously in this section

Edit Opens the Wall Component Settings dialog box to edit the selected component’s thickness and 
attributes (you can also double-click on a component to open the Wall Component Settings dialog 
box) 

Duplicate Duplicates the selected wall component; the duplicate is added to the component list right below 
the originally selected component

Delete Deletes the selected wall component; the wall thickness is adjusted accordingly

Parameter Description
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5. Click OK. The new component definition is applied to the selected wall(s).
~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Wall Textures
The Attributes Palette
Joining Wall Components

Hiding Wall Components
The Hide details preference prevents wall components from being drawn at or below a pre-set layer scale factor, 
creating a cleaner drawing when printing at small scales. For example, if the scale factor is set to 1:48, components in 
walls do not display on any layer set to 1/4” or smaller.
To hide wall components:

1. Select File > Document Settings > Document Preferences.
The Document Preferences dialog box opens. 

2. Select Hide details when layer scale <= 1:. Enter a scale factor in the scale field.
3. Click OK.

~~~~~~~~~~~~~~~~~~~~~~~~~
Joining Wall Components
Creating Wall End Caps
Creating Walls

Fitting Walls to Defined Geometry
In the Vectorworks Architect and Landmark products, standard walls and curtain walls can be set to the layer height at 
creation. After creation, they can be automatically extended upward or downward to fit to defining geometry such as 
the site model, roofs, floors, or NURBS surfaces.
To fit walls to defined geometry:

1. Select the straight or curved wall(s) to be fit.

Wall components shown at 1:2 scale Wall components hidden at 1:48 scale
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2. With the wall(s) selected, select the Fit Walls to Objects command from the appropriate menu.
• Architect workspace: AEC > Fit Walls to Objects
• Landmark workspace: Landmark > Architectural > Fit Walls to Objects
The Fit Walls to Objects dialog box opens. Specify the location of the wall object and indicate the fit parameters.

Click to show/hide the parameters.

3. Click OK to fit the wall(s) to the constraining object indicated.
Walls or portions of walls which lie outside the constraining object retain their height as set in the Object Info 
palette. Walls which have had peaks added (with the Reshape tool) do not have the peaks reset if the peaks lie 
outside the constraining object. Walls with a bottom fit to the site model retain a level top rather than a fixed 
height; the top of the wall does not vary with the bottom.

Parameter Description

Constrain tops of selected walls to objects Fits walls to objects at the top of the wall(s)
Fit to objects on Specifies the layer of the defining geometry for the tops of the wall(s); 

this geometry can consist of roofs, floors, slabs, 3D polygons, 
extrusions, or NURBS surfaces 

Wall top embedding depth Specifies the distance that the wall penetrates the object. This can avoid 
problems such as gaps; for very thick walls, a negative embedding 
depth may be necessary so that the wall does not protrude from the 
object.

Constrain bottoms of selected walls to 
objects

Fits walls to object at the bottom of the wall(s)

Fit to objects on Select the layer of the defining geometry for the bottom of the wall(s)
Include Site Models on selected layer Select to conform the bottom of the wall(s) to the shape of the 

underlying site model
Curved wall fit interval For curved walls, sets the increment for fitting the wall
Wall fitting reference Select the part of the wall to fit to the constraining object (Center, Left, 

or Right)

Roof moved to show walls before being fit to roof
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Walls

Creating Walls from Objects
For flexibility in the design process, walls can be created automatically based on existing objects in the drawing 
including spaces, polygons and shapes. Likewise, some object types can be created from walls.

Creating Walls from Spaces
Once the floor plan has been developed with multiple spaces, the interior and exterior walls can be automatically 
created.
To create walls from spaces:

1. Ensure that space objects are present in the drawing. To automatically create walls with a 3D height, specify a 
delta-Z value for the design layer where the walls will be created.

2. Select AEC > Space Planning > Create Walls from Spaces. 
The Create Walls from Spaces dialog box opens. Specify the style of walls to create and their location.

Click to show/hide the parameters.

Parameter Description

Create Walls from Selected 
Spaces Only

Select to allow walls to be created from selected spaces; deselect to create walls 
from all the spaces in the source layer

Source Layer Specifies the layer containing the space objects
Destination Layer Indicates the layer on which to create the walls
Place Exterior Walls Select how to align the exterior walls with the spaces

Along Inside of Spaces Creates the exterior walls along the inside of the space polylines; select this 
option if the spaces represent the gross area 

Along Outside of Spaces Creates the exterior walls along the outsides of the space polylines; select this 
option if the spaces represent the net area

Along Centerline of Spaces Creates the exterior walls centered along the outside edges of the space 
polylines

Using Wall Control Offset Creates exterior walls that are offset as determined by the Exterior Wall Style
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The available wall styles are defined by wall style resources (see “Using Wall Styles” on page 507).
3. Click OK to create the walls on the destination layer.

Exterior and interior walls are applied automatically to the spaces. Round walls approximating the curves are used 
for Bézier and cubic spline vertices in the space objects.

~~~~~~~~~~~~~~~~~~~~~~~~~
Resource Libraries
Space Settings
Creating Spaces with the Space Tool
Creating Spaces from Walls

Creating Walls from a Polygon
Walls can be created from a polygon.

In the Vectorworks Design Series products, walls can be created by drawing a polyline or shape and then selecting 
the Create Objects from Shapes command (see “Creating Objects from Shapes” on page 277).

To create walls from a polygon in Vectorworks Fundamentals:
1. Draw or select the polygon to become the basis for the walls.
2. Select Modify > Create Walls from Polygon.

The Create Walls from Poly dialog box opens. Select the desired wall parameters.
Click to show/hide the parameters.

Exterior / Interior Wall Style Select a wall style for the exterior and interior walls from either the default 
content or the current file’s content

Constrain straight walls to vertical 
or horizontal

Select to create straight vertical or horizontal walls out of spaces that are not 
perfectly vertical or horizontal

If they are within ___ degrees 
of vert/hor

Indicates the threshold for constraining walls; walls that deviate from vertical or 
horizontal within the number of degrees specified are automatically straightened

Combine Collinear interior walls Select to draw multiple, collinear interior walls as a single wall

Parameter Description

Original spaces not 
drawn straight

Resulting walls constrained 
horizontally and vertically

97.9 sq ft

100.0 sq ft 95.6 sq ft 100.0 sq ft 95.6 sq ft

97.9 sq ft

Office 2

Office 1

Office 3

Lobby
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3. Click OK.
The wall(s) are created based on the original polygon and the specified parameters.

Creating a Polygon or Polyline from Walls
You can create a polygon or polyline based on either the gross area or net area of walls. This is useful for calculating 
the area of a room, for example, or for using color to differentiate among rooms.
To create a polygon or polyline based on the perimeter of the walls:

1. Select the walls to use for the polygon or polyline. Multiple walls can be selected to create several polygons or 
polylines at the same time.

 

2. Select the Create Polys from Walls command from the appropriate menu:
• Fundamentals workspace: Modify > Create Polys from Walls
• Architect workspace: AEC > Create Polys from Walls
• Landmark workspace: Landmark > Architectural > Create Polys from Walls
• Spotlight workspace: Spotlight > Architectural > Create Polys from Walls
The Create Polys from Walls dialog box opens.

Parameter Description

Wall position relative to edge 
of poly

Specifies whether the wall position should be centered on the polygon, inside the 
polygon, or outside the polygon

Use existing wall style Specifies whether to create the walls using the existing wall style
Use existing wall thickness Specifies whether to create the walls using the existing wall thickness or specify a 

new Thickness value
Use existing wall height Specifies whether to create the walls using the existing wall height or specify a new 

Height value
Assign to class Select the class into which the walls should be placed
Delete Source Poly Deletes the source polygon after the walls are created
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Click to show/hide the parameters.

3. Set the parameters and click OK.
The polygon or polyline is created, leaving the original walls unchanged.

Creating Curtain Walls
In the Vectorworks Architect and Landmark products, the capabilities of the Wall and Round Wall tools are expanded 
to create curtain walls. Curtain walls consist of frames that contain panels; often, the panels are made of glass, but they 
can also be opaque or decorative. The Vectorworks program models the frames, panels, and connections according to 
real-world architectural standards. Since the curtain wall is based on the Wall tool, it can take advantage of all the 
benefits of the Wall tool, such as resizing, editing, joining, using walls as the basis of slabs and spaces, bounding by 
story level, inserting plug-in objects, and more. Doors and windows have special capabilities when they are inserted 
within curtain walls so that all the design elements work together.

Click here for a video tip about this topic (Internet access required).

Parameter Description

Gross Area Polys Creates a polygon or polyline from the exterior perimeter of the selected walls
Net Area (Room) Polys Creates a polygon or polyline from the interior perimeter of the selected walls

Polygons and polylines shaded and moved for clarity

http://www.youtube.com/watch?v=U3FncqV_BRg&list=UUN7uzhu-ljLJOe6a0J-fBcQ
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To create straight curtain walls:

To create round curtain walls:

1. Select the Wall or Round Wall tool from the appropriate tool set:
• Fundamentals workspace: Walls tool set
• Design Series workspaces: Building Shell tool set

2. Click the desired Offset mode (see “Creating Walls” on page 497).
3. To draw with an unstyled wall, select <Unstyled> from the Wall Style list on the Tool bar. If the desired styled 

wall resource has already been created, select it from the Tool bar list or double-click on the resource in the 
Resource Browser and proceed to Step 6. Curtain walls have specific wall styles; the default styles begin with the 
prefix CW for easy identification.

4. Click Preferences from the Tool bar.
The Wall Preferences dialog box opens. This dialog box can be accessed any time afterward to modify default wall 
settings. 
Curtain walls consist of a repeating grid of frames and panels. Specify the number of horizontal and vertical 
frames that make up one section of the curtain wall, and then specify the appearance of the frames and the panels 
within that grid. The defined section is repeated over the length and height of the wall.
Curtain walls can be drawn first, and if not using a wall style, the parameters can be set later from the Object Info 
palette by clicking Curtain Wall Grid. The Curtain Wall Grid dialog box opens, to edit the parameters of the 
unstyled curtain wall. However, editing unstyled walls by this method may clear existing frames and panels, and 
recreate the curtain wall grid.

Click to show/hide the parameters.
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Parameter Description

Wall Style 
(Vectorworks Architect 
or Landmark required)

Select a wall style for the wall; see “Using Wall Styles” on page 507. Alternatively, 
select <Unstyled> to create the curtain wall without linking the parameters to a wall 
style. 

If a selected wall style's parameters are edited in the Wall Preferences dialog box, 
the wall style automatically changes to unstyled, indicating that the edited style 
must be saved as a new style to save changes (alternatively, the changes can be 
applied as an unstyled wall, and they are not saved).

Save Preferences as 
Wall Style 
(Vectorworks Architect 
or Landmark required)

Saves the current preference settings as a new wall style. The Assign Name dialog box 
opens; enter a wall style name and click OK (see “Creating Wall Styles” on page 508).

Wall Type Select whether to create a standard wall or a curtain wall. Curtain walls are described in 
this section. Standard walls are described in “Creating Walls” on page 497.

Definition
Grid Preview Displays a preview of the grid structure; the preview wall is drawn in a Front view
Vertical/Horizontal 
Gridlines

In the vertical and horizontal direction, add gridlines to the grid by clicking Add and 
entering the spacing distance. To change the grid order, use the cursor to drag and drop 
the items in the # column. Remove a selected gridline by clicking Delete. The preview 
area displays the horizontal and vertical gridlines.

Spacing Sets the distance from the selected gridline to the next gridline; select a gridline to 
change its value

Add Adds a horizontal or vertical gridline to the curtain wall frame; by default, the currently 
selected spacing value is used for the new gridline

Delete Removes the selected horizontal or vertical gridline from the curtain wall frame
Frame Settings Opens the Frame Settings dialog box, to set the type of frames and their appearance; see 

“Setting Curtain Wall Frame Parameters” on page 526
Panel Settings Opens the Panel Settings dialog box, to set the type of panels and their appearance; see 

“Setting Curtain Wall Panel Parameters” on page 528
Wall Thickness Sets the standard frame depth for the curtain wall. This value displays when determining 

the frame and panel settings, for reference.
To avoid errors where walls join, keep the wall thickness and frame thickness 
values similar.

Offset Reference Specifies the offset reference point for frame and panel offsets; the actual offset 
distances are set in the Frame Settings and Panel Settings dialog boxes

Wall Opacity Sets the opacity of the curtain wall in Top/Plan view
Use Class Opacity Sets wall opacity by class rather than by the parameters in the Wall Preferences dialog 

box
Opacity Specifies the transparency of the wall; drag the slider to the left to increase the 

transparency, or enter a percentage directly in the box to the right of the slider
Insertion Options
Height
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5. When the curtain wall parameters have been specified, and any changes saved as a wall style resource if desired, 
click OK. A saved or selected wall style is saved as a resource in the file, and appears in the Resource Browser 
and in the Wall Style list on the Tool bar.

6. If Polygon mode is selected, click at the starting point of the first curtain wall section. 
7. Click to end the first wall section.

To continue creating curtain walls, click at the end of each additional wall section.

Height Directly sets the desired height of the wall. When the wall height is determined manually 
by this method, the Top Bound property of the wall is automatically set to Layer 
Elevation, and the Top Offset value is modified accordingly.
When the top of the wall is bound by the layer wall height value, the wall height updates 
automatically.

Top Bound Sets the vertical reference that determines the top of the wall.
The Layer Wall Height value is set by the design layer (see “Setting Design Layer 
Properties” on page 165).
Additional options are available for the Vectorworks Architect product. The top of the 
wall can be bound by one of the story levels defined for the story or the story above it. 
By setting the top of the wall to a level type, if the elevation of the associated story 
changes, the height of the wall changes automatically to match.
The default curtain wall styles automatically assign a top bound level type to the wall, 
assuming that stories will be used in the file. However, this can be changed by selecting 
a different option.

Top Offset Sets the offset of the top of the wall from its specified top bound height
Bottom Bound Sets the vertical reference that determines the bottom of the wall; Layer Elevation is the 

only option available unless the Vectorworks Architect product is installed.
Additional options are available for the Vectorworks Architect product. The bottom of 
the wall can be bound by one of the story levels defined for the story or the story below 
it. By setting the bottom of the wall to a level type, if the elevation of the associated 
story changes, the height of the wall changes automatically to match.
The default curtain wall styles automatically assign a bottom bound level type to the 
wall, assuming that stories will be used in the file. However, this can be changed by 
selecting a different option.

Bottom Offset For the bottom of the wall, sets the offset from the layer elevation
Caps Select whether a wall segment is capped at the start point, the end point, both ends, or 

has no caps at all
Class Specifies the default class for the walls
Curtain Wall Cut Plane Defines the Z-height, relative to the layer where the curtain walls are drawn, for drawing 

the Top/Plan view of the curtain wall
Control Offset If using the Custom Control Line wall mode, enter the offset value for the control line
Textures Textures for curtain walls are controlled by the frame and panel settings
Data Specifies wall record information, which is IFC-compliant and can be included in a wall 

style schedule. These fields are optional; enter text only where desired.

Parameter Description
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8. Double-click to finish the curtain wall if the start point and end point are not at the same location; otherwise, click 
at the starting location (a SmartCursor cue displays) to finish the wall.

9. Alternatively, if Rectangle mode is selected, click at the wall’s start point; this becomes one corner of the 
rectangular wall system. Move the mouse to the opposite corner until the desired size is previewed.

10. Click to set a corner point on the wall system. Four walls are created. 

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Curtain Wall Frame Parameters
Setting Curtain Wall Panel Parameters
Editing Curtain Walls
Wall Properties
Creating Walls

Setting Curtain Wall Frame Parameters
The frame settings and appearance are controlled individually for each frame location, for maximum flexibility when 
setting the frame parameters.

Curtain walls can be drawn first, and if not using a wall style, the parameters can be set later from the Object Info 
palette by clicking Curtain Wall Grid. The Curtain Wall Grid dialog box opens, to edit the parameters of the 
unstyled curtain wall. However, editing unstyled walls by this method may clear existing frames and panels, and 
recreate the curtain wall grid.

To set the curtain wall frame appearance:
1. From the Definition tab of the Wall Preferences dialog box, or when editing a curtain wall style, click Frame 

Settings.
The Frame Settings dialog box opens.

Click to show/hide the parameters.

Parameter Description

Frame category Select a category of frame element to define, and then set its parameters. The starting and 
ending frames, top and bottom frames, and the inner horizontal and vertical frames can 
each be defined separately, for maximum flexibility. Multiple categories can be selected at 
one time for quickly defining common parameters.

Definition

Walls drawn in a 3D view
Drawing straight curtain walls with Rectangle mode 
in Top/Plan view

Click 1

Click 2

Click 1

Click 2
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Type Select the type of frame
• Full-Depth: Standard, normal frame
• Capped Full-Depth: Standard frames with caps; specify the Cap Depth
• Butt-Glazed: Standard frame that is concealed behind the panels, creating the 

appearance that the panels are joined without a frame
• Brake Metal: Corner frame, or segmented frame for round walls; in a straight wall, 

behaves like a full-depth frame
• Capped Brake Metal: Combines the properties of a capped frame and brake metal 

frame; specify the Cap Width if different from the overall width
• Virtual: Hidden frame; this is useful for piecing together curtain wall units, especially 

when vertically stacked. A virtual top frame appears to butt up against the bottom frame 
of the curtain wall above it.

Preview Displays a labeled diagram of the selected frame type; the numbers indicated on the 
diagram correspond to the labeled parameters below the preview, for easy identification

Width Sets the width of the frame
Depth Select how the frame depth is specified. If set to Use Wall Thickness, the frame is set to 

the thickness of the curtain wall as specified in the Curtain Wall Grid or Wall Preferences 
dialog box (the thickness is displayed). Alternatively, set a Custom Depth and enter the 
value.

Panel Inset Determines the overlap between the frame and the neighboring panels, for both Top/Plan 
and 3D views. The allowable inset distance can vary from 0, for a frame without a notch, 
to half the width of the frame, where the panels meet in the middle of the frame.

Cap Depth (capped 
types only)

Specifies the cap depth, relative to the frame depth

Cap Width 
(capped brake 
metal type only)

Sets the width of the cap for a brake metal frame, allowing the cap and the frame to have 
different widths

Offset Reference Displays the offset reference that was selected in the Curtain Wall Grid or Wall 
Preferences dialog box

Offset Shifts the frame position relative to the offset reference. Enter a positive value to shift the 
frame to the right side of the wall as drawn, or enter a negative value to shift the frame to 
the left side of the wall. To center the frame on the wall, select Center Line as the Offset 
Reference in the Curtain Wall Grid or Wall Preferences dialog box, and use an offset of 0.

Half Width on Wall 
Boundary

Creates a frame of half the width on the wall boundary. This is useful for piecing together 
curtain wall units, especially for end-to-end curtain wall joins. 
This option only applies to capped full depth, full depth, and butt-glazed frames that lie on 
the start, end, top, or bottom wall boundary.

Parameter Description
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2. Click OK.
The parameters can be edited from the Object Info palette; see “Wall Properties” on page 535. The Cut Plane 
parameter determines the height for displaying the curtain wall in Top/Plan view.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Curtain Walls
Editing Curtain Walls
Applying Object Attributes
Assigning IFC Data to Objects

Setting Curtain Wall Panel Parameters
The panel settings and appearance are specified in the Panel Settings dialog box.

If setting up curtain wall preferences, these parameters are available from the Definition tab of the Wall 
Preferences dialog box. For an existing curtain wall, they are available from the Curtain Wall Grid dialog box.

To set the curtain wall panel appearance:
1. From the Object Info palette of a selected curtain wall, click Curtain Wall Grid.

Segment Round 
Wall (round wall 
required)

This parameter only applies to round curtain walls with full-height, vertical frames. 
Normally, this option should be selected, to create a wall with straight panels that follow 
the arc shape, for a rounded effect. However, by deselecting this option for certain 
standard or corner frames within a curtain wall, a straight segment can be created that 
does not follow the arc, for a straight panel of glass that is part of the rounded wall.

Frame/Cap Class The frame and the caps in each frame category can be placed in distinct classes to control 
their appearance and visibility. Select the class to use from the current list of classes, 
create a new class, or select <Object Class> to place the frame or cap in the same class as 
the curtain wall.

Frame/Cap Attributes Each attribute can be set by the class style or to specific settings. If set by the class style, 
the attributes are controlled by the class selected for the curtain wall, frame, or cap.

Frame/ Cap Fill Select Class Style to use the class style for the fill attribute, choose None for no fill, or 
choose a fill style

Frame/Cap Pen Select Class Style to use the class style for the pen attribute, choose None for no pen, or 
choose a solid/dash or pattern style

Frame/Cap Texture 
(Renderworks 
required)

Click No Texture to apply no texture, Class Texture to use the class texture for the frame 
or cap, or click Choose Texture to select the texture to apply from either the default 
content or the current file’s content; see “Resource Libraries” on page 219

IFC Attaches IFC data to the curtain wall frames for exporting to IFC format

Parameter Description

The two blue frames have the Segment Round Wall 
option deselected, resulting in a straight section of panels
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The Curtain Wall Grid dialog box opens.
2. Click Panel Settings.

The Panel Settings dialog box opens.
Click to show/hide the parameters.

3. Click OK.

Parameter Description

Definition
Type Select the kind of panel to place between the frames. Glazed panels are typical glass panels, 

and spandrel panels are opaque. Spandrel face panels are decorative panels. Open panels 
provide empty space between the frames.

Preview Displays a labeled diagram of the selected panel type; the numbers indicated on the 
diagram correspond to the labeled parameters below the preview, for easy identification

Thickness Specifies the panel thickness. The inset is controlled by the Panel Inset parameter in the 
Frame Settings dialog box. The combination of panel Thickness and Panel Inset 
parameters creates the channel for the panel inserted in the frame.

Use Infill
(spandrel and 
spandrel face only)

Allows the area to the right (inside of the curtain wall as drawn) and between the frames to 
be filled. The attributes of the infill panel are determined by the panel.

Infill Depth Specifies the additional depth of the infill panel
Face Depth 
(spandrel face only)

Sets the depth of the spandrel face

Wall Thickness Displays the Wall Thickness value from the Curtain Wall Grid or Wall Preferences dialog 
box for reference

Offset Reference Displays the offset reference that was selected in the Curtain Wall Grid or Wall Preferences 
dialog box

Offset Shifts the panel position relative to the offset reference. Enter a positive value to shift the 
panel to the left side of the wall as drawn, or enter a negative value to shift the frame to the 
right side of the wall. To center the panel on the wall, select Center Line as the Offset 
Reference in the Curtain Wall Grid or Wall Preferences dialog box, and use an offset of 0.

Panel/Face Class The panel and the spandrel face (if selected as a panel type) can be placed in distinct classes 
to control their appearance and visibility. Select the class to use from the current list of 
classes, create a new class, or select <Object Class> to place the panel or spandrel face in 
the same class as the curtain wall.

Panel/Face Fill Select Class Style to use the class style for the fill attribute, choose None for no fill, or 
choose a fill style

Panel/Face Pen Select Class Style to use the class style for the pen attribute, choose None for no pen, or 
choose a solid/dash or pattern style

Panel/Face Texture 
(Renderworks 
required)

Click No Texture to apply no texture, Class Texture to use the class texture for the panel or 
spandrel face, or click Choose Texture to select the texture to apply from either the default 
content or the current file’s content; see “Resource Libraries” on page 219

IFC Attaches IFC data to the curtain wall panels for exporting to IFC format
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Curtain Walls
Editing Curtain Walls
Applying Object Attributes
Assigning IFC Data to Objects

Creating Wall Features
Once a standard round or straight wall has been created, features such as projections and recesses can be added to it. 
Create wall features from 2D or 3D objects, as well as symbols. By default, 2D objects are extruded to span the height 
of the wall; offsets from the top and bottom of the wall can be specified as needed. Use 3D objects, such as sweeps or 
other solids, to create more complicated features. Use symbols to be able to update multiple instances of a feature with 
a single edit.

It it not recommended to create wall features that are applied to the entire length of the wall, such as battered 
walls, or wall caps.

Unlike a symbol, a wall feature is actually part of the wall geometry. A wall feature interacts with the wall components, 
it renders along with the rest of the wall, and if it was created from a 2D object, it automatically adjusts when the wall 
height changes. Because wall features interact with wall components, wall features cannot be created for curtain walls.

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
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Creating Wall Projections
To create wall projections:

1. Create the closed 2D or 3D solid object with which to modify the wall. The geometry of the object must define an 
area or volume that has no self-contacts, no self-intersections, and no edges that fold back on themselves.

2. For a 2D object, simply make sure that the object overlaps the wall, and that the view is Top/Plan. For a 3D object, 
first create the object at the appropriate height in relation to the bottom of the wall (Z axis); then set the 
appropriate X and Y axis location so that the object overlaps the wall.

http://www.youtube.com/watch?v=GruIZWVmHV4
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3. With both the wall and the modifier object selected, choose the Create Wall Projection command from the 
appropriate menu:
• Architect workspace: AEC > Create Wall Projection 
• Landmark workspace: Landmark > Architectural > Create Wall Projection 
• Spotlight workspace: Spotlight > Architectural > Create Wall Projection 
Alternatively, for 2D objects only, select Modify > Add Surface.
The Create Wall Feature Projection dialog box opens; different fields display depending on whether a 2D or 3D 
modifier object was selected. 

Click to show/hide the parameters.

4. Set the parameters and click OK.

Parameter Description

Feature Component From the list of components currently in the wall, select a component to be applied to the 
area of the feature object. Otherwise, select <Object> to use the object’s own fill, or select 
<None> if the feature is intended to be a hole in the wall (for example, to create an opening 
for an object that is not part of the wall).

Left Side Wrap (2D 
objects only)

Select the first component to wrap around the feature on the left side of the wall; this can be 
<None>, or any component to the left of the Feature Component (higher in the list). All 
components to the outside of the Left Side Wrap component also wrap.

Right Side Wrap (2D 
objects only)

Select the first component to wrap around the feature on the right side of the wall; this can 
be <None>, or any component to the right of the Feature Component (lower in the list). 
All components to the outside of the Right Side Wrap component also wrap.

Offset From Wall Top 
(2D objects only)

Specifies the distance from the top of the wall where the wall feature ends in 3D views

Use Profile as Core 
(2D objects only)

Select this option to use the area of the original 2D object as the core of the wall feature; 
other wall components will wrap around the core, which may make the projection larger 
than the original object. Deselect this option to limit the area of the projection to the area of 
the original 2D object.

Cut Plane (3D objects 
only)

Specifies the distance from the bottom of the wall at which a section slice is taken of the 
3D object and is used to represent the wall feature in Top/Plan view.

If the 3D object does not run the whole height of the wall, be sure that this value 
actually intersects the 3D object; otherwise the object will not appear in Top/Plan 
view.

Use Object 3D 
Attributes (3D objects 
only)

Select this option to display the surfaces created by the feature object with its own 
attributes when it is rendered in 3D; when deselected, the wall’s attributes are used on 
those surfaces

Show Extents Below/
Above Cut Plane (3D 
objects only)

In addition to the 3D section specified by the Cut Plane value, shows the outline of the 
part of the 3D object below and above the cut plane; the pen attributes of this 
representation can be edited (see “Wall Feature Properties” on page 533)

Preview Changes the view of the wall feature to match the current parameter settings, without 
saving the settings
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Creating Wall Recesses
To create a wall recess:

1. Create the closed 2D or 3D solid object with which to modify the wall. The geometry of the object must define an 
area or volume that has no self-contacts, no self-intersections, and no edges that fold back on themselves.

2. For a 2D object, simply make sure that the object overlaps the wall in Top/Plan view. For a 3D object, first create 
the object at the appropriate height in relation to the bottom of the wall (Z axis); then set the appropriate X and Y 
axis location so that the object overlaps the wall.

3. With both the appropriate wall and the modifier object selected, choose the Create Wall Recess command from 
the appropriate menu:
• Architect workspace: AEC > Create Wall Recess 
• Landmark workspace: Landmark > Architectural > Create Wall Recess 
• Spotlight workspace: Spotlight > Architectural > Create Wall Recess 
Alternatively, for 2D objects only, select Modify > Clip Surface.
The Create Wall Feature Recess dialog box opens; different fields display depending on whether a 2D or 3D 
modifier object was selected.

Click to show/hide the parameters.

Parameter Description

Left Side Wrap (2D 
objects only)

Select the first component to wrap around the feature on the left side of the wall; this can be 
<None>, or any component to the left of the Feature Component (higher in the list). All 
components to the outside of the Left Side Wrap component also wrap.

Right Side Wrap (2D 
objects only)

Select the first component to wrap around the feature on the right side of the wall; this can 
be <None>, or any component to the right of the Feature Component (lower in the list). 
All components to the outside of the Right Side Wrap component also wrap.

Creating a wall projection feature from a 2D polygon 
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4. Select the options for the wall feature, and click OK.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Wall Feature Properties
After a wall feature has been created, it can be edited in the Object Info palette. Alternatively, right-click (Windows) or 
Ctrl-click (Mac) on the feature and select Properties from the context menu.
In addition to the parameters available when the feature is created, the following options are available.
Click to show/hide the parameters.

Offset From Wall Top 
(2D objects only)

Specifies the distance from the top of the wall where the wall feature ends in 3D views

Cut Plane (3D 
objects only)

Specifies the distance from the bottom of the wall at which a section slice is taken of the 3D 
object and is used to represent the wall feature in Top/Plan view.

If the 3D object does not run the whole height of the wall, be sure that this value 
actually intersects the 3D object; otherwise the object will not appear in Top/Plan 
view.

Preview Changes the view of the wall feature to match the current parameter settings, without 
saving the settings

Parameter Description

Flip Flips the wall feature to the other side of the wall
Set Position Activates the Move by Points tool in Reference Point mode, to move the wall feature a 

specified distance along the length of the wall (see “Moving Objects with the Reference 
Point Mode” on page 1008)

Parameter Description

Creating a wall recess feature from a 3D sweep 
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Editing Wall Features
Similar to symbols, the original 2D or 3D object (or symbol) can be edited after the wall feature is created. For 
example, the location or shape of the object can be changed.
To access the editing mode, double-click the wall feature. Alternatively, right-click (Windows) or Ctrl-click (Mac) on 
the feature and select Edit from the context menu. To delete the wall feature, delete the original object from which the 
wall feature was created. Click Exit Wall Feature to exit the editing mode.
Also similar to symbols, wall features can be moved and duplicated in various ways in both straight and round walls. 
See the following topics:

• “Moving Symbols in Walls with the Selection Tool” on page 256
• “Nudging Symbols in Walls” on page 257
• “Moving Symbols in Walls with the Move Command” on page 257
• “Moving Symbols in Walls with the Move by Points Tool” on page 258
• “Duplicate Array” on page 1014

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Wall Projections
Creating Wall Features
Creating Walls

Edit Extents 
Attributes (3D object 
projections only)

If Show Extents Below Cut Plane or Show Extents Above Cut Plane is selected, opens the 
Extents Attributes dialog box to allow editing of the 3D object outlines shown for the areas 
below and above the cut plane

Parameter Description



Editing Walls |  535
Editing Walls

Wall Properties
Edit the properties of selected straight or round walls and their components, as well as curtain walls (Vectorworks 
Architect or Landmark required), in the Object Info palette. To change the wall attributes, use the Attributes palette. 
Certain parameters are available for standard walls or for curtain walls only. Settings on the Render tab (Renderworks 
required) are not available for curtain walls, since the textures of frames and panels are specified separately. Curtain 
walls use the Edit Curtain Wall tool to adjust the frames and panels.
Click to show/hide the parameters.

Parameter Description

Shape tab
Style In the Vectorworks Fundamentals product, all walls are unstyled. The Vectorworks 

Architect or Landmark product is required to select other wall styles; see “Creating Walls” 
on page 497.

Thickness
Thickness Displays the overall thickness of the wall; the thickness of a wall without components is 

determined by the wall attributes. The thickness of a wall with components is defined by 
the sum of the component thicknesses.

Vis Thick Displays the visible wall thickness, while accounting for component visibility settings. 
Invisible components on the interior and exterior of the wall cause the wall to appear 
thinner than its actual length, for display purposes.

Height
Height Directly sets the desired height of the wall. When the wall height is determined manually 

by this method, the Top Bound property of the wall is automatically set to Layer 
Elevation, and the Top Offset value is modified accordingly.
When the top of the wall is bound by the layer wall height value, the wall height displays 
automatically.

Top Bound Sets the vertical reference that determines the top of the wall.
The Layer Wall Height value is set by the design layer (see “Setting Design Layer 
Properties” on page 165).
Additional options are available for the Vectorworks Architect product; see “Creating 
Walls” on page 497.

Top Offset Sets the offset of the top of the wall from its specified Top Bound height.
Bottom Bound Sets the vertical reference that determines the bottom of the wall; Layer Elevation is the 

only option available unless the Vectorworks Architect product is installed
Bottom Offset For the bottom of the wall, sets the offset from the layer elevation

Caps Select whether a wall segment is capped at the start point, the end point, both ends, or has 
no caps at all

Attr 
(standard wall required)

When the wall is capped, specifies whether the wall cap attributes comes from the wall 
line attributes or the component line attributes

Components
(standard wall required)

Edits the wall components of unstyled walls (see “Creating Wall Components” on 
page 513)
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Reshaping Walls
Use the Reshape tool in a view other than Top/Plan to edit the wall height, change the elevation of wall peaks, add 
vertices to create peaks in a wall, and delete vertices that have been added. Use the Selection tool to change the wall 
length. Symbols remain where placed when a wall is reshaped.
In the following situations, the Reshape tool displays 2D Reshape modes; the vertices at either end of the wall can be 
moved, to change the wall length and/or location. See “2D Reshape Modes” on page 1044.

• In Top/Plan view
• When multiple walls are selected
• When a wall and other objects are selected
• When a marquee has been drawn

In any 3D view, when only a single wall is selected, the Reshape tool has three modes available.

Walls can also be trimmed using the Trim tool; see “Trim Tool” on page 1060.

Cut Plane 
(curtain wall required)

Sets the height for the display of the Top/Plan appearance of the curtain wall

Curtain Wall Grid 
(curtain wall required)

Opens the Curtain Wall Grid dialog box, for editing the curtain wall frame and panel 
settings as described in “Creating Curtain Walls” on page 522

Reverse Sides Reverses the direction of the wall sections (see “Wall Direction” on page 506); walls 
should be drawn in a clockwise direction

Render tab
(Renderworks, standard 
walls required)
Mode Select whether to texture the wall according to textures defined for the wall (By Object) or 

according to textures defined for the components (By Component). See “Applying a 
Texture to an Object” on page 1530, “Applying Wall Textures” on page 1544, and 
“Creating Wall Components” on page 513.

Mode Description

Reshape 3D Walls Adjusts the position of a selected wall vertex
Add 3D Wall Peaks Adds a vertex to a wall for reshaping purposes
Delete 3D Wall Peaks Deletes a wall vertex

Parameter Description

Reshape 3D Walls

Add 3D Wall Peaks

Delete 3D Wall Peaks
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Changing Wall Length

To change a wall’s length:

1. Select the wall to reshape.
2. Click the Selection tool from the Basic palette. 

Single Object Interactive Scaling mode must be enabled.
3. Position the cursor over an end selection handle, and click.

In a 3D view, the handles are at the base of the wall.
4. Move the mouse to lengthen or shorten the wall.
5. Click when the wall is at the desired length.

Wall length can also be changed with the Reshape tool in Top/Plan view. In a 3D view, draw a marquee with the 
Reshape tool to enclose the wall vertex in a marquee that is co-planar with the bottom wall elevation. Select the wall 
with the Reshape tool. The available modes switch to the 2D reshape modes, and 2D reshape functionality is enabled 
(see “2D Reshape Modes” on page 1044). This allows the wall length to be adjusted, even when in a 3D view.
~~~~~~~~~~~~~~~~~~~~~~~~~
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With the Selection tool, drag the handle at the base of the wall to 
lengthen or shorten the wall
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Changing Wall Height

To change the height of the wall:

1. In a 3D view, select the wall to reshape.
2. Click the Reshape tool from the Basic palette, and select Reshape 3D Walls mode.
3. Position the cursor over one of the handles in the middle of the top or bottom of the wall, and click.

When the cursor is over a reshape handle, the standard arrow cursor changes into a double-headed, unfilled arrow.
4. Move the mouse to adjust the wall.
5. Click at the desired location.

In the Object Info palette, the height change displays as a top or bottom offset value.
~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Walls

Changing Wall Peak Height

To change the height of a peak on the wall:

1. In a 3D view, select the wall to reshape.
2. Click the Reshape tool from the Basic palette, and select Reshape 3D Walls mode.
3. Position the cursor over one of the handles on the ends of the top or bottom of the wall, and click.

When the cursor is over a reshape handle, the standard arrow cursor changes into a double-headed, unfilled arrow.
4. Move the mouse to adjust the wall.
5. Click at the desired location.

With the 3D Reshape cursor, drag a handle in the 
middle to change the wall height
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Changing the height of a wall peak does not change the height of the wall.
~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Walls

Adding a Vertex to Walls

To add a vertex to a wall:

1. In a 3D view, select the wall that requires a peak (vertex).
2. Click the Reshape tool from the Basic palette, and select Add 3D Wall Peaks mode.
3. Position the cursor over an end point on one of the corners or an existing vertex, and click.

When the cursor is over an end point, the standard arrow cursor changes into a single-headed, filled arrow with 
shaded boxes on either side of the shaft.

4. Move the mouse to add a vertex to the top or bottom of the wall.
A vertex can be moved to any location along the same wall as long as the location does not pass another existing 
vertex.

5. Click when the vertex is at the desired location.

To reshape a curved wall to match a planar surface, use the Subtract Solids or Intersect Solids command with an 
object that matches the plane of the roof.

~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Walls

With the 3D Reshape cursor, drag a handle on the end of the top 
or bottom of the wall to reshape the wall

With the Add Peak cursor, click-click an end point to add a peak (Front 
view depicted)

The top of the wall is now flush with 
the bottom of the roof



  540 | Editing Walls
Deleting a Wall Vertex

To delete a control point:

1. In a 3D view, select the wall with the peak (vertex) to be deleted.
2. Click the Reshape tool from the Basic palette, and select Delete 3D Wall Peaks mode.
3. Position the cursor over the vertex to delete.

When the cursor is over a vertex, the standard arrow cursor changes into a single-headed, filled arrow with a 
hollow diamond in the shaft.

4. Click on the vertex.
The vertex is removed and the wall is reshaped to the remaining vertices.

~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Walls

Changing Round Wall Radius

To change the radius of a round wall:

1. Select the round wall to edit.
2. Click the Selection tool from the Basic palette.
3. Position the cursor over the center control point, and click.
4. Move the mouse to change the radius, and click to set the end point.

Flip the round wall arc by dragging toward, and through, the arc center.
~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Walls

With the Delete Peak cursor, click a 
vertex to delete it

Wall with two vertices removedWall with two unnecessary vertices 
(Front view depicted)

Move the control point to 
change the round wall radius
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Removing Wall Breaks
The Remove Wall Breaks tool cleans up any wall breaks or gaps that were created during editing. For example, when 
creating a new wall that joins an existing wall, if the new wall is later deleted, a break in the remaining wall displays at 
the joint. The Remove Wall Breaks tool can remove the break and any end caps.

To remove wall breaks:

1. Click the Remove Wall Breaks tool from the appropriate tool set.:
• Fundamentals workspace: Walls tool set
• Design Series workspaces: Building Shell tool set
Alternatively, right-click (Windows) or Ctrl-click (Mac) on the wall and select Remove Break from the context 
menu.

2. Click and drag to create a marquee box around the wall break or end cap to remove.
The wall break or end cap is automatically removed.

~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Walls
Joining Walls
Joining Walls with the Fillet Tool

Moving Connected Walls
The Selection tool has an additional mode, Connected Walls, in the Vectorworks Architect and Landmark products. 
This mode automatically maintains the connection between the wall being moved and adjoining walls. The involved 
wall angles remain constrained throughout the move. While dragging a wall, you can enter precise offset distances in 
the Offset field of the Tool bar.
The Connected Walls mode does not apply to Y-joined walls or round walls.

Connections between T-joined walls and L-joined walls are also maintained if they are moved using the Move or 
Nudge command, or moved and/or duplicated using the Duplicate Array command or the Move by Points tool, 
as long as the ends of the moved or duplicated walls overlap with the walls to which they were originally 
connected.

To move a wall while maintaining its connection to adjacent walls:

1. Click the Selection tool from the Basic palette.
2. Select Connected Walls from the Tool bar.
3. Click on the desired wall and drag it to a new location; alternatively, change the wall length by editing the L value 

in the Object Info palette (polar coordinates), or by editing a dimension value. The walls stay connected during the 
move.
When you move a wall connected between two other walls, the wall being moved is resized to maintain the 
connection. A T- or L-joined wall, when moved beyond the end of the connected wall, disconnects the walls.

Click 1

Click 2

Connected Walls
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End-to-end walls joined as an L-join move together as a single wall.

For corner joined walls, all involved walls are resized to maintain the connection. A wall cannot be moved in such 
a way that its length equals zero.

To move a collection of walls without changing the walls relative to each other, deselect the Connected Walls 
mode, and then move the walls.

~~~~~~~~~~~~~~~~~~~~~~~~~
Moving Objects
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Automatically Joining Walls
The Vectorworks preference Auto join walls automatically joins walls at corners and intersections, and automatically 
heals the mitered ends of walls when they are separated from one another. For T joins, the break in the side of the wall 
is healed. Walls can be in either 2D or 3D view.

Original walls Walls separated and 
ends automatically 
healed

Walls separated but 
ends not automatically 
healed

When drawing walls with auto join on, connected 
walls are highlighted to show which walls will join



Editing Walls |  543
When a core component has been set for walls with components, the components also automatically join. Core 
components, as well as the other components, join uncapped if they have the same fill, and capped otherwise.
To set the Auto join walls preference:

1. Select Tools > Options > Vectorworks Preferences.
2. On the Edit tab, select Auto join walls.
3. Click OK.

Automatically Joining Walls in Rectangle Mode
When the Vectorworks preference Auto join walls is on, walls drawn in Rectangle mode that are parallel and overlap 
or touch each other interact. The drawing operation can be performed using the default Add option, which combines 
interacting walls, or using the Subtract option, which deletes interacting wall segments. A set of rules determines these 
interactions.

The existing walls that interact with the new walls are highlighted while drawing.

Add option

The existing overlapped wall remains, and the new overlapping wall is not created.

If the new wall extends the existing wall and has the same style, the existing wall is extended and the new wall is not 
created. If the new wall has a different style, it is created.

Subtract option–press and hold Alt (Windows) or Option (Mac) while drawing

The overlapped portion of the existing wall is deleted, and the new overlapping wall is not created.

Two walls are created

Two existing walls remain

Two walls are created

One existing wall remains

One existing wall with the same 
style is extended

One existing wall remains

Three walls with a 
different style are created
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If the new wall extends the existing wall and has the same style, the existing wall is extended and the new wall is not 
created.

If the new wall partially extends and partially overlaps an existing wall, the overlapping portion is deleted and the 
extending portion is created with the new wall.

When a wall subtraction requires that the existing walls change direction to maintain the correct orientation, the wall 
direction changes automatically (see “Wall Direction” on page 506).

~~~~~~~~~~~~~~~~~~~~~~~~~
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Joining Walls

Two walls are created

The overlapped
portions of two

existing walls are
deleted; the

overlapping new
walls are not

created

One existing wall with the same 
style is extended

Two walls are created

The overlapping portion of the
existing wall is deleted

The overlapping portion of the
existing wall is deleted

The extension is created
with the new wall

The direction of these
three walls is reversed
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Joining Wall Components
Edit Preferences

Joining Walls
The Wall Join tool joins straight or curved wall segments not already connected using the Auto join walls preference. 
(See “Automatically Joining Walls” on page 542 for information on Auto join walls.) There are three modes for 
joining walls and two end cap modes.

To temporarily activate this tool, right-click (Windows) or Ctrl-click (Mac) on a wall, and select Join from the 
context menu. The tool defaults to the mode used previously with the tool.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
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Automatically Joining Walls

T Wall Joins
T Join mode lengthens or shortens the first wall segment selected until it intersects with the second wall segment 
selected. As only the first wall is altered, this mode does not create corner joins.

To join walls with the T Join mode:

1. Click the Wall Join tool from the appropriate tool set:
• Fundamentals workspace: Walls tool set
• Design Series workspaces: Building Shell tool set
Alternatively, right-click (Windows) or Ctrl-click (Mac) on the first wall to join and select Join from the context 
menu. 

Mode Description

T Join Lengthens or shortens one wall segment until it intersects with the second wall segment 
selected; creates Y joins by joining the first selected wall to two sections of an existing L join

L Join Joins the closest ends of two walls to create a corner
X Join Joins two wall segments at the point where they intersect
Uncapped Join Applies an uncapped join to wall join operations
Capped Join Applies a capped join to wall join operations

L Join

T Join

Uncapped Join

Capped JoinX Join

http://www.youtube.com/watch?v=vc5t9Dy0tCc
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2. Click T Join from the Tool bar.
3. Select the wall segment that must change length to intersect with the other wall.
4. Select the second wall segment to join.

To create a T join to an existing corner, join the wall segment to the perpendicular corner segment. This creates a clean 
join between the walls.

~~~~~~~~~~~~~~~~~~~~~~~~~
Joining Walls
Joining Walls with the Fillet Tool

Y Wall Joins
Y wall joins are not automatically created when you use the Auto join walls preference. (See “Edit Preferences” on 
page 49 for information on Auto join walls.) Instead, use the T Join mode to create Y wall joins.

To create a Y wall join of three wall segments:

1. Click the Wall Join tool from the appropriate tool set:
• Fundamentals workspace: Walls tool set
• Design Series workspaces: Building Shell tool set
Alternatively, right-click (Windows) or Ctrl-click (Mac) on the first wall to join and select Join from the context 
menu.

2. Click T Join from the Tool bar.
3. Select the wall segment that must change length to abut the two previously joined wall segments.
4. Select one of the two wall segments to join.

The wall segments are joined.

Click 1

Click 2

In both cases, two walls are already corner joined; the third wall is joined to the 
perpendicular segment of the existing corner join.

Click 1

Click 1

Click 2

Click 2
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L Wall Joins
L Join mode joins the closest ends of two walls to create a corner, or joins two walls end to end. Both wall lengths are 
automatically resized as necessary to meet cleanly.

To join walls with the L Join mode:

1. Click the Wall Join tool from the appropriate tool set:
• Fundamentals workspace: Walls tool set
• Design Series workspaces: Building Shell tool set
Alternatively, right-click (Windows) or Ctrl-click (Mac) on the wall and select Join from the context menu.

2. Click L Join from the Tool bar.
3. Select the first wall segment to join.
4. Select the second wall segment to join. For corner joins, the location of the clicks defines the direction of the L.

The wall lengths are automatically resized and joined.

~~~~~~~~~~~~~~~~~~~~~~~~~
Joining Walls
Joining Walls with the Fillet Tool

X Wall Joins
X Join mode joins two wall segments at the point where they intersect. Because neither wall segment’s length is 
altered, the two segments must already intersect in order to use this mode.

Click 1

Click 2

Joining walls end to end

Click

Click

Click

Click
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To join walls with the X Join mode:

1. Click the Wall Join tool from the appropriate tool set:
• Fundamentals workspace: Walls tool set
• Design Series workspaces: Building Shell tool set
Alternatively, right-click (Windows) or Ctrl-click (Mac) on the wall and select Join from the context menu.

2. Click X Join from the Tool bar.
3. Select the wall segment to become non-load bearing.
4. Select the wall segment to become load bearing.

The first wall segment selected is split into two walls segments, which are joined to the load bearing wall.
~~~~~~~~~~~~~~~~~~~~~~~~~
Joining Walls
Joining Walls with the Fillet Tool

Joining Walls with the Fillet Tool
The Fillet tool, located on the Basic palette, joins two wall segments by creating a round wall between them. See 
“Creating Fillets and Chamfers” on page 1077.

~~~~~~~~~~~~~~~~~~~~~~~~~
Joining Walls

Joining Wall Components
The Component Join tool joins the selected components between two straight wall segments; components within 
pre-existing joined wall segments can also be joined. There are three modes for joining wall components.

Mode Description

T Join Extends or shortens one wall component segment until it intersects with a second wall 
component segment

Click 1

Click 2

Click 

Click

L Join

T Join Capped Join
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Components can be joined to the edge of walls instead of specific components in Capped Join mode.
Normally, when you join walls with the Wall Join tool, and the Auto join walls preference is enabled, the components 
automatically join correctly. A core component must be set. (See “Joining Walls” on page 545.) 
The Component Join tool is useful for adjusting components that did not join as desired when walls were connected, 
even in complex wall joins.

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
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T Join Mode
The T Join mode extends or shortens one wall component segment until it intersects with a second wall component 
segment. As only the first component is extended, this mode will not create corner type joins. (For those, use the L join 
mode.)

To join wall components with the T Join mode:

1. Click the Component Join tool from the Building Shell tool set.
2. Click T Join from the Tool bar.
3. Select the component within the wall segment to join. The component is highlighted.
4. Select the second wall segment to join. The component to be joined is highlighted.

L Join Joins the closest ends of two wall components to create a corner
Capped Join Applies a capped join to the component being joined

Mode Description

Click 1

Click 2

http://www.youtube.com/watch?v=G3R1MzCAlts
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5. Repeat steps 3 and 4 for each component within the wall segment that needs to be joined.
~~~~~~~~~~~~~~~~~~~~~~~~~
Joining Wall Components
Capped Join Mode
Hiding Wall Components

L Join Mode
The L Join mode joins the closest ends of two wall components to create a corner. Both component lengths are 
extended or shortened, as necessary, until they meet cleanly.

To join wall components with the L Join mode:

1. Click the Component Join tool from the Building Shell tool set.
2. Click L Join from the Tool bar.
3. Select the component within the wall segment to join.
4. Select the second wall segment to join. The component to be joined is highlighted.

5. Repeat steps 3 and 4 for each component within the wall segment that needs to be joined.
~~~~~~~~~~~~~~~~~~~~~~~~~
Joining Wall Components
T Join Mode
Capped Join Mode
Hiding Wall Components

Capped Join Mode
Like the T Join mode, the Capped Join mode extends or shortens one wall component until it intersects with a second 
component. The component end is capped at the point where it joins the other wall.

To join wall components with the Capped Join mode:

1. Click the Component Join tool from the Building Shell tool set.
2. Click Capped Join from the Tool bar.
3. Select the component within the wall segment to join.
4. Select the second wall segment to join. The component to be joined is highlighted.

Click 1

Click 2
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5. Repeat steps 3 and 4 for each component within the wall segment that needs to be joined.
~~~~~~~~~~~~~~~~~~~~~~~~~
Joining Wall Components
Hiding Wall Components

Editing Curtain Walls
The Edit Curtain Wall tool manipulates the frames and panels of curtain walls. Once a curtain wall is selected with 
the tool, the modes allow you to select frames and panels; delete frames and panels; add, split, and combine frames; 
move frame and panel sets along a wall; and edit frame and panel settings.
When a curtain wall is selected with the Selection tool, two context menu commands become available. The Edit 
Using Reshape Tool command activates the Reshape tool to reshape the walls as described in “Reshaping Walls” on 
page 536. The Edit Using Edit Curtain Wall Tool command activates the Edit Curtain Wall tool.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Curtain Wall Frames
Editing Curtain Wall Panels
Adding New Frames to a Curtain Wall
Splitting Curtain Wall Frames
Combining Curtain Wall Frames
Moving a Curtain Wall Grid
Changing Selected Frame or Panel Settings

Mode Description

Select Frame Selects one or more frames
Select Panel Selects one or more panels
Add Frame Inserts new frames into the curtain wall
Split Frame Splits a frame into multiple pieces, so that one portion of the frame can be independently 

moved, edited, or deleted
Combine Frames Combines two collinear frames into a single frame
Move Grid Moves an entire set of frames and panels relative to the curtain wall
Settings Selected frame or panel parameters can be edited

Click 1

Click 2

Select Panel

Select Frame Settings

Split Frame

Add Frame Combine Frames

Move Grid
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Creating Curtain Walls

Editing Curtain Wall Frames

To select and manipulate curtain wall frames:

1. Click the Edit Curtain Wall tool from the Building Shell tool set, and click Select Frame mode from the Tool 
bar.

2. Select the curtain wall to edit.
3. Select the frame or frames to edit, move, or delete.

The Edit Curtain Wall tool works similarly to the Selection tool. Frames can be selected for editing in a variety 
of ways.When a single frame is selected, end handles allow the frame to be reshaped.

4. A single, selected frame can be reshaped, moved by dragging, copied, or deleted. The frame must be connected on 
both ends to another frame. If deleting or moving a frame causes any frames to become disconnected, they are 
automatically extended until they join a frame.
Selected frames can be deleted by pressing delete, or alternatively, right-click (Windows) or Ctrl-click (Mac) on 
the frame and select Delete Frames from the context menu.
Selected frames can be evenly distributed relative to the wall. Frames must be horizontal or vertical, and at least 
three frames must be selected. Right-click (Windows) or Ctrl-click (Mac) on the frames and select Distribute 
Frames from the context menu. The frames on the ends of the selection do not move.

Method Selection Action

Click Standard selection method; selects a single object only
Shift-click Selects multiple objects as each object is clicked; also can be used to deselect one or 

more objects without affecting other selected objects
Option-drag (Mac) or 
Ctrl-drag (Windows)

Places a copy of the object where the mouse button is released

Rectangle marquee Selects all objects that are completely contained within the marquee
Shift-marquee Reverses the selection status of objects inside a marquee; if objects inside the marquee 

are selected, this method deselects those objects
Option-marquee 
(Mac) or Alt-marquee 
(Windows)

Selects all objects that the marquee passes through, as well as those contained within the 
marquee
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Panels automatically adjust to conform to the new frame positions.
5. The settings of selected frames can be edited by clicking the Settings mode from the Tool bar.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the frame and select Edit Frames from the context 
menu.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Curtain Walls

Editing Curtain Wall Panels

To select and manipulate curtain wall panels:

1. Click the Edit Curtain Wall tool from the Building Shell tool set, and click Select Panel mode from the Tool bar.
2. Select the curtain wall to edit.
3. Select the panel or panels to edit. Panels cannot be moved; the position of the panels is determined by the frames. 

Selecting panels is very similar to selecting frames; see “Editing Curtain Wall Frames” on page 552.
4. The settings of selected panels can be edited by clicking the Settings mode from the Tool bar.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the frame and select Edit Panels from the context 
menu.

When one or more curtain wall panels are selected, a door or window can be easily inserted. Right-click (Windows) or 
Ctrl-click (Mac) on the panel and select Insert Window or Insert Door from the context menu. The window or door is 
automatically inserted as a curtain wall window or door, and sized to fit within the selected panel or panels.
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Curtain Walls
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Adding New Frames to a Curtain Wall

To add new curtain wall frames:

1. Click the Edit Curtain Wall tool from the Building Shell tool set, and click Add Frame mode from the Tool bar.
2. Select the curtain wall to edit.
3. Click at the start point of the new frame, and then click on the end point of the new frame. The start and end points 

must be placed on existing frames.
Press the Shift key to constrain the placement of the second point of the frame horizontally or vertically.

4. The frame is added, acquiring its attributes from the curtain wall grid settings.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Curtain Walls

Splitting Curtain Wall Frames

To split curtain wall frames:

1. Click the Edit Curtain Wall tool from the Building Shell tool set, and click Split Frame mode from the Tool bar.
2. Select the curtain wall to edit.
3. Click on a frame to split it into sections.

A frame can only be split at a frame intersection. A red split cursor displays to indicate locations where the frame 
can be split.

4. The frame is split, and the resulting sections can be dragged, deleted, or have their settings changed independently.

Click 1

Click 2

At an intersection, click on the frame to split The frame is split into two sections In this example, one of the split frames was deleted



Editing Curtain Walls |  555
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Curtain Walls

Combining Curtain Wall Frames

To combine two collinear curtain wall frames:

1. Click the Edit Curtain Wall tool from the Building Shell tool set, and click Combine Frame mode from the Tool 
bar.

2. Select the curtain wall to edit.
3. Click each of the two frames to be combined. Frames must be collinear.

At a four-way frame intersection, it may be necessary to split a perpendicular frame to be able to join collinear 
frames.

4. One frame is created. The attributes of the first clicked frame apply to both frames once they are combined.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Curtain Walls

Moving a Curtain Wall Grid
The frames and panels of a curtain wall form a grid or pattern relative to the wall. Moving the grid along the wall can 
be useful to center a grid pattern on a wall.

To move the curtain wall grid relative to the wall:

1. Click the Edit Curtain Wall tool from the Building Shell tool set, and click Move Grid mode from the Tool bar.
2. Select the curtain wall to edit.
3. Click to set a reference point for the grid.
4. Move the cursor to shift the entire grid of frames and panels, along with any doors and windows, relative to the 

wall.
The frames and panels shift to the left or right along the wall. A preview of the grid displays.

5. Click to set the new location of the curtain wall grid.

Click 2
Click 1

Click on the first frame Click on the second frame The frames are combined
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~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Curtain Walls

Changing Selected Frame or Panel Settings
The Settings mode changes the settings of either frames or panels that have been selected with the Select Frame or 
Select Panel mode of the Edit Curtain Wall tool.

To change curtain wall frame or panel settings:

1. Click the Edit Curtain Wall tool from the Building Shell tool set.
2. Select the curtain wall to edit.
3. Using either Select Frame mode or Select Panel mode of the Edit Curtain Wall tool, select the frames or panels 

to edit.
4. Click Settings mode from the Tool bar.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the frame or panel and select Edit Frames or Edit 
Panels from the context menu.

5. The Frame Settings or Panel Settings dialog box opens. Change the frame or panel settings as described in 
“Setting Curtain Wall Frame Parameters” on page 526 or “Setting Curtain Wall Panel Parameters” on page 528.
The Frame Settings dialog box, when opened in this way, does not include the frame category selection on the left, 
since the frames to edit have already been selected.

6. Click OK.
The frame or panel settings are changed.

Click 1
Click 2

Click to set a reference point Move the grid; a preview displays. Click to set 
the new grid position.

The grid is shifted relative to the wall
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~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Curtain Walls
Editing Curtain Wall Frames
Editing Curtain Wall Panels

Creating Columns and Pilasters
The Vectorworks Fundamentals product and all Vectorworks Design Series products include a basic architectural 
column object (for aesthetic and space-defining purposes). In the Architect product, the column object offers additional 
structural capabilities, and a pilaster object is provided. 
In the Architect product, columns and pilasters can be architectural in nature, structural in nature, or both. Use the 
Column tool or Pilaster tool to draw an object that not only reflects the architectural appearance of a column/pilaster, 
but also defines it in structural terms that can be used in an engineering analysis of the building. Structural and 
architectural elements can be displayed or hidden, as desired. The column ID can also, optionally, be placed on the 
drawing. Additionally, in the Architect product, the column/pilaster can be exported to IFC format for exchange with 
structural analysis programs. 
A pilaster can be placed in a wall (however, a column cannot be placed in a wall). A pilaster inserted in a wall can set 
its architectural height relative to the wall.
Tool access varies depending on the Vectorworks product installed:

To create a column:

To create a pilaster:

1. Click the Column tool or the Pilaster tool from the appropriate tool set:
• Fundamentals workspace: Walls tool set
• Design Series workspaces: Building Shell tool set

2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time a 
column/pilaster is placed in the drawing, the object properties dialog box opens. These parameters apply to 
subsequently created columns/pilasters; they can be changed later by accessing them from the Object Info palette. 

3. Specify the column/pilaster properties and click OK.
To create a circular or square shaft, capital, or base, enter the same value for the width and depth.

Basic Column Parameters 

The basic column object is available with the Vectorworks Fundamentals, Landmark, and Spotlight products.

Vectorworks Product Tool Set / Tool

Fundamentals Walls > Column (basic column)
Architect and Designer Building Shell > Column (architectural column with additional capabilities)
Architect and Designer Building Shell > Pilaster 
Landmark and Spotlight Building Shell > Column (basic column)
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Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using 
options on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 and 
“Formatting Text” on page 389.

Use Center Marks Select this option to size the cross at the column insertion point and enter the Center 
Mark Size

Height Directly sets the desired height of the column, including base and capital (if any). When 
the column height is determined manually by this method, the Top Bound property of 
the column is automatically set to Layer Elevation, and the Top Offset value is modified 
accordingly.
When the top of the column is bound by the layer wall height value, the wall height 
updates automatically.

Top Bound Sets the vertical reference that determines the top of the column.
The Layer Wall Height value is set by the design layer (see “Setting Design Layer 
Properties” on page 165)
Additional options are available for the Vectorworks Architect product.

Top Offset Sets the offset of the top of the column from its specified top bound height. If setting the 
boundary of the top of the column to the layer elevation, enter the column’s height for 
the Top Offset; if setting the height of the top of the column to the default wall height, 
specify any offset above or below the layer’s default wall height.

Bot Bound Sets the vertical reference that determines the bottom of the column; Layer Elevation is 
the only option available unless the Vectorworks Architect product is installed

Bot Offset For the bottom of the column, sets the offset from the layer elevation
Shaft Type Select to draw the column with an oval or rectangular shaft type
Shaft Width Enter the shaft width
Shaft Depth Enter the shaft depth
Shaft Corner Radius For rectangular shaft type, enter the corner radius of the shaft

Base

Shaft

Capital
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Architect Column and Pilaster Parameters 

The architect column and pilaster objects are available with the Vectorworks Architect and Designer products.

Shaft Taper Select whether to draw the column with a classic or straight taper, or no taper
Taper Width For a straight or classic taper, enter the taper width
Taper Depth For a straight or classic taper, enter the taper depth
Use Capital Select whether to add a capital to the column

Capital Type Select to draw the column with an oval, oval mushroom, rectangular, or rectangular 
mushroom capital

Capital Width Enter the capital width
Capital Depth Enter the capital depth
Capital Height Enter the capital height
Capital Corner Radius For rectangular capital type, enter the corner radius of the capital

Use Base Select whether to add a base to the column
Base Type Select an oval or rectangular base type
Base Width Enter the base width
Base Depth Enter the base depth
Base Height Enter the base height
Base Corner Radius For rectangular base type, enter the base corner radius
Base Divisions Enter the number of divisions for the base
Divider Depth/Height For more than one base division, enter the depth and height for each divider

Get Finishes/Classes Click to open the Get Finishes/Classes dialog box to select the class to use for 
rendering the 3D shaft, capital, and base of the column

Shaft Finish Displays the class to use for rendering the 3D shaft (selected in the Get Finishes/Classes 
dialog box)

Capital Finish If Use Capital is selected, displays the class to use for rendering the 3D capital (selected 
in the Get Finishes/Classes dialog box)

Base Finish If Use Base is selected, displays the class to use for rendering the 3D base (selected in 
the Get Finishes/Classes dialog box)

Parameter Description
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Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using 
options on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 
and “Formatting Text” on page 389.

Use Center Marks Select this option to size the cross at the column/pilaster insertion point and enter the 
Center Mark Size

Use Component Select whether to use only architectural components, only structural components, or a 
combination of architectural and structural components for the column/pilaster. 
Depending on the selection, different options are available. 
When both Architectural and Structural components are selected, the height of the 
architectural and structural components can be set individually.

Use Wall Height
(Pilaster only, inserted in 
wall)

For architectural only or architectural and structural components, select to draw the 
architectural pilaster height equal to the wall height. This option is only available when 
a pilaster has been inserted into a wall.

Height 
(Architectural Only or 
Structural Only)

Directly sets the desired height of the column/pilaster’s architectural or structural 
component, including base and capital (if any). When the height is determined 
manually by this method, the Top Bound property of the column/pilaster is 
automatically set to Layer Elevation, and the Top Offset value is modified accordingly.
When the top of the column/pilaster is bound by the layer wall height value or by a 
story level, the column/pilaster height updates automatically.

Column 

Pilaster 

Column Pilaster 

Bottom Plate

Top Plate
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Arch Height
(Architectural and 
Structural)

When architectural components are included with structural, directly sets the desired 
height of the column/pilaster’s architectural component, including base and capital (if 
any). When the height is determined manually by this method, the Top Bound property 
of the column/pilaster is automatically set to Layer Elevation, and the Top Offset value 
is modified accordingly.
When the top of the column/pilaster is bound by the layer wall height value or by a 
story level, the column/pilaster height updates automatically.

Struct Height
(Architectural and 
Structural)

When structural components are included with architectural, directly sets the desired 
height of the column/pilaster’s structural component, including top plate and base plate 
(if any). When the height is determined manually by this method, the Top Bound 
property of the column/pilaster is automatically set to Layer Elevation, and the Top 
Offset value is modified accordingly.
When the top of the column/pilaster is bound by the layer wall height value or by a 
story level, the column/pilaster height updates automatically.

Top Bound Sets the vertical reference that determines the top of the object.
The Layer Wall Height value is set by the design layer (see “Setting Design Layer 
Properties” on page 165)
Additional options are available for the Vectorworks Architect product. The top of the 
object can be bound by one of the story levels defined for the story or the story above it. 
By setting the top of the object to a level type, if the elevation of the associated story 
changes, the height of the object changes automatically to match.

Top Offset Sets the offset of the top of the object from its specified top bound height 
Bot Bound Sets the vertical reference that determines the bottom of the object; Layer Elevation is 

the only option available unless the Vectorworks Architect product is installed.
Additional options are available for the Vectorworks Architect product. The bottom of 
the object can be bound by one of the story levels defined for the story or the story 
below it. By setting the bottom of the object to a level type, if the elevation of the 
associated story changes, the height of the object changes automatically to match.

Bot Offset For the bottom of the object, sets the offset from its specified bottom bound height
Arch. Comp. Class For Architectural Only or Architectural and Structural components, displays the class 

for the architectural components of the column/pilaster (selected in the Get Finishes/
Classes dialog box)

Parameter Description
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Arch Offset X / Arch 
Offset Y
(Column only)

For Architectural and Structural components, specify the distance to offset the 
architectural component of the column from the insertion point, in the X and Y 
directions

The 2D column’s insertion point always coincides with the center marks (if any) 
and the center of the structural component (if any), and the architectural 
component is offset from the insertion point as specified by these properties

Struct Offset X / 
Struct Offset Y
(Pilaster only)

For Architectural and Structural components, specify the distance to offset the 
structural component of the pilaster from the insertion point, in the X and Y directions 

The 2D pilaster’s insertion point always coincides with the face of the wall, 
centered on the architectural component; the structural component and center 
marks (if any) are offset from the insertion point, as specified by these properties

Struct Offset Z For Architectural and Structural components, specify the distance to offset the 
structural component of the column/pilaster from the architectural component, in the Z 
direction

Parameter Description
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Shaft Type For Architectural Only or Architectural and Structural components, select to draw the 
column/pilaster with an oval or rectangular shaft type

Shaft Width For Architectural Only or Architectural and Structural components, enter the shaft 
width

Shaft Depth For Architectural Only or Architectural and Structural components, enter the shaft 
depth

Shaft Corner Radius For Architectural Only or Architectural and Structural components, enter the corner 
radius for a rectangular shaft type

Shaft Taper For Architectural Only or Architectural and Structural components, select whether to 
draw the column/pilaster with a classic or straight taper, or no taper

Taper Width For a straight or classic taper, enter the taper width
Taper Depth For a straight or classic taper, enter the taper depth

Shaft Finish For Architectural Only or Architectural and Structural components, displays the class 
to use for rendering the 3D shaft (selected in the Get Finishes/Classes dialog box)

Use Capital For Architectural Only or Architectural and Structural components, select whether to 
add a capital to the architectural component

Capital Type Select to draw the column/pilaster with an oval, oval mushroom, rectangular, or 
rectangular mushroom capital

Capital Width Enter the capital width
Capital Depth Enter the capital depth
Capital Height Enter the capital height
Capital Corner Radius For rectangular capital type, enter the corner radius of the capital
Capital Finish For Architectural Only or Architectural and Structural components, displays the class 

to use for rendering the 3D capital (selected in the Get Finishes/Classes dialog box)
Use Base For Architectural Only or Architectural and Structural components, select whether to 

add a base to the architectural component
Base Type Select an oval or rectangular base type
Base Width Enter the base width
Base Depth Enter the base depth
Base Height Enter the base height
Base Corner Radius For rectangular base type, enter the base corner radius
Base Divisions Enter the number of divisions for the base
Divider Depth / Height For more than one base division, enter the depth and height for each divider
Base Finish For Architectural Only or Architectural and Structural components, displays the class 

to use for rendering the base (selected in the Get Finishes/Classes dialog box)
Column ID For Structural Only or Architectural and Structural components, enter the Column ID 

(for reporting purposes, and optionally to be displayed in the drawing)

Parameter Description
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Display Column ID Select this option to display the column ID on the drawing; the ID text is placed at the 
insertion point of the column/pilaster, at the center of a control point. Click and drag the 
control point to move the ID to the desired location on the drawing. The ID text 
attributes can be modified using the Text menu commands.

Column ID Class Displays the class to use for the column ID text (selected in the Get Finishes/Classes 
dialog box)

Get Finishes/Classes Click to open the Get Finishes/Classes dialog box to select the class to use for 
attributes of the 3D shaft, capital, and base of the column and to select the class for the 
column ID text (if applicable) and the architectural and/or structural components of the 
column/pilaster (as applicable, based on the component type specified); in addition to 
classes present in the drawing, architectural component classes include the 
Wall-Interior and Structural-Columns class standards and structural component classes 
include the Structural-Columns class standard. Alternatively, create a new class by 
selecting New, or select the class named <Object Class> which places the item in the 
same class as the column or pilaster object.

Struct Type For Structural Only or Architectural and Structural components, select whether the 
structural component is made of concrete, wood, or steel

Struct Shape For Structural Only or Architectural and Structural components, specify whether the 
concrete or wood structural shape is oval or rectangular

Struct Width For Structural Only or Architectural and Structural components, enter the width of the 
concrete or wood structural component

Struct Depth For Structural Only or Architectural and Structural components, enter the depth of the 
concrete or wood structural component

Struct Corner Radius For Structural Only or Architectural and Structural components, enter the structural 
corner radius for a rectangular structural shape

Select Structural Shape For Structural Only or Architectural and Structural components, click to open the 
Select Structural Shape dialog box to select the structural shape to use for steel 
structural types. Select the structural shape from the default content or the current file’s 
content (see “Resource Libraries” on page 219). Select the shape’s series and size, and 
click OK.

Struct Shape / Struct 
Series / Struct Size

For Structural Only or Architectural and Structural components, displays the selected 
steel structural shape symbol name, series, and size

Struct Height For Structural Only or Architectural and Structural components, specify the overall 
height of the structural column/pilaster, including base plate and top plate (if any)

Struct Rotation For Structural Only or Architectural and Structural components, enter the number of 
degrees to rotate the structural component

Struct Clearance For Architectural and Structural components, specifies the clearance around the 
structural component that will be subtracted from the architectural component

Struct. Comp. Class For Structural Only or Architectural and Structural components, displays the class for 
the structural component of the column/pilaster (selected in the Get Finishes/Classes 
dialog box)

Use Top Plate For Structural Only or Architectural and Structural components, select whether to add a 
plate to the top of the structural component

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Exporting Columns and Pilasters to IFC Format

Exporting Columns and Pilasters to IFC Format
In the Vectorworks Architect product, columns and pilasters can be exported to IFC format for exchange with structural 
analysis programs. If the column/pilaster has both architectural and structural components enabled, the object is 
exported as an IfcColumn and the architectural component is exported as an IfcCovering with an IfcCoveringType of 
Cladding. If the column/pilaster has only an architectural or structural component enabled, the object is exported as an 
IfcColumn.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Columns and Pilasters
IFC Format Interoperability
GSA Spatial Program BIM Requirements

Creating Pillars
The Pillar command converts any closed 2D shape—rectangle, circle, oval, or polygon—into a pillar. In addition, use 
it on open 2D shapes, such as lines and polylines, to create a flat, screen-like object. These objects include such things 
as movie screens, room dividers, and moving walls. Once created, a pillar can be joined to a wall. 

To create a pillar:
1. Click on the object to convert.
2. Select the Pillar command from the appropriate menu: 

TP Shape Select to draw either an oval or rectangular top plate
TP Width Enter the width of the top plate
TP Depth Enter the depth of the top plate
TP Thickness Enter the thickness of the top plate
TP Corner Radius For a rectangular top plate, enter the corner radius

Use Base Plate For Structural Only or Architectural and Structural components, select whether to add a 
plate to the bottom of the structural component

BP Shape Select to draw either an oval or rectangular base plate
BP Width Enter the width of the base plate
BP Depth Enter the depth of the base plate
BP Thickness Enter the thickness of the base plate
BP Corner Radius For a rectangular base plate, enter the corner radius

Parameter Description

3D view 2D view 
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• Fundamentals workspace: Model > AEC > Pillar
• Architect workspace: AEC > Pillar
• Landmark workspace: Landmark > Architectural > Pillar
• Spotlight workspace: Spotlight > Architectural > Pillar
The Pillar Preferences dialog box opens.

3. Enter a pillar height.
4. Click OK.

After creation, the pillar can be edited by selecting Modify > Edit Pillar. See “Object Editing Mode” on 
page 1004.

~~~~~~~~~~~~~~~~~~~~~~~~~
Joining Pillars and Walls

Joining Pillars and Walls
Walls and pillars can be joined together. Any number of walls can connect to the pillar as long as space exists on the 
pillar.
The pillar needs to be joined to the end of a wall; it cannot be added to an existing wall intersection such as the corner 
of L-joined or T-joined walls.

To join a pillar to a wall:
1. Click on the pillar.
2. Draw the walls.

If the Auto-join feature is enabled, then the walls automatically connect to the pillar.
If the Auto-join feature is disabled, then click the Wall Join tool from the Walls tool set or the Building Shell tool 
set and join the walls to the pillar.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Pillars
Automatically Joining Walls

2D view3D view



Roofs
There are two ways to create a roof for a structure:
• The Roof Face command converts any closed 2D object into a roof face object.
• The Create Roof command creates a roof object by selecting the object(s) that the roof will be based upon 

(including walls, polygons and polylines).
Use the Roof Face command to create hybrid (2D/3D) roof structures from any closed 2D object. This is an easy way 
to create a slab or flat roof. You can also use this command to create a uniquely shaped roof, such as a gable roof over a 
round structure. Roof faces created with this command can be connected to other roof faces; roof faces can contain 
elements like gables and skylights.
The Create Roof command creates a roof object with multiple faces based on specified parameters. A great variety of 
roof types can be created by this method, and they can include roof elements such as gables and skylights. Once the 
walls of a structure are complete, select the walls that the roof will be based upon, and specify the roof parameters. 
Alternatively, select a polygon or polyline as the basis for the roof.
The roof can be created in the same design layer as the wall structure, or in a different layer. If the walls and roof are on 
different layers, create a viewport to view the walls and roof together.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Roof Faces
Creating Roof Objects

Creating Roof Faces
To create a roof face:

1. Draw the 2D object that is the basis for the roof. Any enclosed 2D object can be used, such as enclosed arcs, 
polylines, rectangles, circles, and ovals.

2. With the object selected, select the Roof Face command from the appropriate menu:
• Fundamentals workspace: Model > AEC > Roof Face
• Architect workspace: AEC > Roof Face
• Landmark workspace: Landmark > Architectural > Roof Face
• Spotlight workspace: Spotlight > Architectural > Roof Face
The Create Roof Face dialog box opens. Specify the roof slope creation method, edge and hole miter options, and 
roof parameters.

Click to show/hide the parameters.

Parameter Description

Roof Slope Indicates the roof slope creation method and criteria
Angle Creates a roof slope based on an angle; specify the Angle
Rise over Run Creates a roof slope based on rise over run values; specify the Rise and Run. The rise is 

the distance along the Y axis the roof rises above the Z height, and run is the distance 
along the X axis for the roof to reach that height.

2nd Click Height Creates a roof slope based on a mouse click position (this option only available in Top/
Plan view). Enter the Height for the second mouse click.

Edge Miter Indicates the miter type for the roof edge
Vertical Creates the roof edge perpendicular to the active layer plane
Horizontal Creates the roof edge parallel to the active layer plane
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3. Click OK.
4. Click-drag the mouse across the 2D object to draw a line that defines the roof axis; click again to complete the 

line. An arrow displays on one side of the line, indicating which side of the object will be the high side of the roof.
5. Point the mouse to the side of the roof that will be highest, and then click again. The roof axis line displays 

selection handles, and the arrow pointing to the high side of the roof turns blue, indicating that the roof face is 
complete.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing and Reshaping Roof Faces
Connecting Roof Faces
Creating Cutouts in a Roof Face
Adding Roof Elements to Roof Objects and Roof Faces
Roofs
Applying a Texture to an Object

Editing and Reshaping Roof Faces
Once a roof face has been created, there are several ways to edit it:

Double Creates the roof edge with a horizontal and vertical miter; specify the Horizontal and 
Vertical lengths

Square Creates the lower edge of the roof face perpendicular to the roof surface, regardless of the 
roof angle

Hole Miter Specifies miter options for a roof cutout
Vertical Cutout edges are perpendicular to the active layer plane
Splayed The bottom edge of a cutout is perpendicular to the active layer plane, and the top edge of 

a cutout of is parallel to the active layer plane
Square Cutout edges are perpendicular to the roof surface

Axis Z Sets the roof height at the axis
Angle For angled roof slopes, indicates the roof slope angle
Rise/Run For rise over run roof slopes, specifies the rise and run values
Height Indicates the height of the second mouse click when the roof slope is specified with that 

option
Thickness Specifies the roof thickness
Vertical/Horizontal For double miters, specifies the horizontal and vertical miter lengths

Parameter Description

3D view2D view
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• Edit the roof face parameters (such as the angle or eave type) in the Object Info palette.
• Change the roof’s basic 2D object shape using the Edit Roof command. (Be careful not to use the Ungroup 

command, as this permanently changes the roof face back into the original 2D object.) Use the Exit Roof 
command to complete the change.

• Move the roof face axis using the Selection tool in Top/Plan view.
• Change the roof face angle using the Reshape tool (best in Front or Back view).

The roof angle must be between 0° and 85° to be changed by the Reshape tool.
• Add gable windows or skylights as described in “Adding Roof Elements to Roof Objects and Roof Faces” on 

page 581.
The roof face properties can be edited from the Object Info palette. The roof face parameters are described in “Creating 
Roof Faces” on page 567. Only the parameters which are different are described here.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing a Group
Reshaping Objects
Applying a Texture to an Object

Connecting Roof Faces
Use either the Single Object Connect or the Dual Object Connect mode of the Connect/Combine tool to trim roof 
faces that intersect or to extend one roof face to another. If the roof faces have different thicknesses, there is an option 
to adjust the thicknesses to match automatically.

To connect two roof faces:

1. Click the Connect/Combine tool from the Basic palette, and select either Single Object Connect or Dual Object 
Connect from the Tool bar.

2. If the roof faces have different thicknesses, set the Use Vertical Thickness of Subject Roof Face option on the 
Tool bar as appropriate.
• To automatically adjust the roof face thickness of the second clicked roof face to match the vertical thickness 

of the first clicked roof face, select Use Vertical Thickness of Subject Roof Face.
• To connect the roof faces without adjusting the thickness, de-select the option.

3. Click the first, and then the second, roof face to connect.

Parameter Description

Dormer Settings When the roof face includes one or more dormers, their parameters can be set. Parameter 
settings affect all dormers in the roof face.

Wall Thickness Sets the thickness of the walls in the dormer
Roof Thickness Sets the thickness of the dormer roof

Single Object Connect

Dual Object Connect

Use Vertical Thickness of Subject Roof Face
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The result of the operation depends on the mode selected, the positions of the roof faces, and the portion of the 
roof faces clicked upon.

Creating Cutouts in a Roof Face
Use the Clip Surface command to add a cutout to a roof face. A cutout, for example, can be used to add a hole for a 
chimney that overlaps two or more faces of the roof.

For non-intersecting faces, the first 
clicked face is extended to meet the 
second clicked face

Click 2

Click 1

For intersecting faces, the first 
clicked face is trimmed to keep 
the clicked portion

Click 2
Click 1

Single Object Connect mode 

For intersecting faces, both faces are 
trimmed and the clicked parts of the 
faces are kept

Click 2

Click 1

Click 2

Click 1

For non-intersecting faces, both faces 
are extended or trimmed to join

Dual Object Connect mode 

With Use Vertical Thickness of Subject Roof Face enabled, the thickness of the boundary face 
(clicked second) changes to match the vertical thickness of the subject face (clicked first)

Click 2

Click 1
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The edges of the cutout are mitered according to the selections made in the Create Roof Face dialog box during the 
creation of the roof face.
To add a cutout to a roof face:

1. Select the roof face.
2. Create an object with the dimensions for the cutout and place it where the cutout will be located.
3. Select both objects.
4. Select Modify > Clip Surface.

This creates the cutout in the roof face, leaving behind the object used to make the cutout.
5. Select the object used to make the cutout and delete it.

~~~~~~~~~~~~~~~~~~~~~~~~~
Adding Roof Elements to Roof Objects and Roof Faces
Creating Cutouts in a Roof Object

Creating Roof Objects

To create a roof object:
1. Select the walls, polygon, or polyline that the roof will be based upon.

3D view2D view

3D view 2D view
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Shift-click to select multiple walls. If the building has an attachment, such as a garage, that will have a different 
roof structure, then select only the desired walls.

2. Select the Create Roof command from the appropriate menu.
• Fundamentals workspace: Model > AEC > Create Roof
• Architect workspace: AEC > Create Roof
• Landmark workspace: Landmark > Architectural > Create Roof
• Spotlight workspace: Spotlight > Architectural > Create Roof
The Create Roof dialog box opens. Enter the desired criteria to create the roof object. The parameters are 
illustrated in the roof diagram. Certain default parameters are suggested based on the selected roof parameters.

Click to show/hide the parameters.

3. Click OK.
A hip roof is created over the selected object(s) using the criteria set in the Create Roof dialog box. The roof can 
be changed to a gable or Dutch hip shape; see “Changing the Roof Edge Shape” on page 573.

Parameter Description

Eave Profile Select the roof edge appearance
• Square: angled fascia, soffit edges
• Vertical: vertical fascia, angled soffit edges
• Horizontal: no fascia, horizontal soffit edges
• Double: vertical fascia, horizontal soffit edges

(1) Vertical Specifies the vertical length for a double miter eave
(2) Horizontal Specifies the horizontal length for a double miter eave
(3) Thickness Specifies the roof thickness
(4) Bearing Inset Specifies how far the bearing wall cuts into the roof
(5) Roof Pitch Specifies the roof pitch as an angle or rise:run ratio; click Calculate for an automatic 

calculation based on bearing height, eave height, and eave overhang 
(6) Bearing Height Specifies the height of the rafter plate or top plate above the wall layer elevation where 

the roof will be supported; click Calculate for an automatic calculation based on roof 
pitch, eave height, and eave overhang

(7) Eave Height Specifies the height of the lowest portion of the roof; click Calculate for an automatic 
calculation based on roof pitch, bearing height, and eave overhang

(8) Eave Overhang Specifies the distance that the roof extends beyond the bearing wall; click Calculate for 
an automatic calculation based on roof pitch, bearing height, and eave height

Layer Assigns the roof object to a layer. By default, the roof is created in the active design layer. 
To create the roof in a different layer, select an existing layer from the list, or select New 
Layer to create a new layer.

Class Assigns the roof object to a class. The standard roof class, Roof-Main, is available as an 
option and if it is selected, it is created in the file if it did not already exist. Alternatively, 
select Class to create a new class.

Create Accessories 
(Vectorworks Architect 
required)

Adds an attic, soffit, or fascia to the roof object; see “Adding Roof Accessories” on 
page 579

Retain Original Objects Retains the source object(s) that formed the basis of the roof
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Editing Roof Objects
Once a roof object has been created, there are multiple ways to edit it:

• Change roof edge shapes (such as hip or gable) using the Selection tool and the Edit Roof Settings dialog box.
• Create cutouts in the roof using the Clip tool or Clip Surface command.
• Reshape the roof object using the Reshape tool.
• Add an accessory: attic, soffit, or fascia (Vectorworks Architect required)

Additionally, the roof object parameters can be edited from the Object Info palette. Wall settings on the Object Info 
palette apply to all gable or Dutch hip walls in the roof; to adjust each gable wall individually, use the Edit Roof 
Settings dialog box.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Changing the Roof Edge Shape
Reshaping Roof Objects
Adding Roof Elements to Roof Objects and Roof Faces
Creating Cutouts in a Roof Object
Adding Roof Accessories
Applying Roof Textures

Changing the Roof Edge Shape
By default, a hip roof is created with eave edges all around. Specific roof edges can be changed to a gable or Dutch hip 
shape.

Parameter Description

Bearing Inset Specifies how far the bearing wall cuts into the roof
Thickness Specifies the roof thickness (normally, this is the perpendicular thickness; when a roof 

has different slopes, the vertical thickness can be specified)
Applies To When a roof has different slopes, the vertical thickness can be specified to avoid 

incorrect roof intersections. Select Vertical Thickness and enter the Thickness value
Eaves Specify the eave type
Vertical For Double Miter types, enter the vertical length of the eave
Gable Walls An alert displays if you change these settings; confirm that you want to override the 

original settings
Show Walls When gable walls exist, specifies whether the gable wall shows or is invisible
Thickness When gable walls exist, specifies the gable wall thickness

Dutch Hip Walls An alert displays if you change these settings; confirm that you want to override the 
original settings

Show Walls When Dutch hip walls exist, specifies whether the Dutch hip wall shows or is invisible
Thickness When Dutch hip walls exist, specifies the Dutch hip wall thickness
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To change the roof edge shape:
1. Select the roof with the Selection tool.

Selection handles display for the roof.
2. Click on the selection handle of the edge to be edited.

The Edit Roof Settings dialog box opens.
3. Change the roof parameters and select Entire Roof to apply the edits to all sections of the roof. If Entire Roof is 

not selected, the edits apply to the edge of the roof that was clicked.
Click to show/hide the parameters.

4. Click OK to change the roof edge settings.

Changing a Hip Roof to a Gable Roof
To change a hip roof into a gable roof:

1. Select the roof with the Selection tool.
Selection handles display for the roof.

Parameter Description

Roof Edge Shape Select the basic shape of this roof edge: Eave, Gable, or Dutch Hip. The default is a 
hip roof, with an “Eave” edge on all sides.
When this setting is changed, the available parameters and roof diagram reflect the 
selected roof edge shape.

Wall Thickness
(Gable and Dutch Hip only)

Specifies the thickness of the wall created for gable and Dutch hip roof edges

Show Wall
(Gable and Dutch Hip only)

Select this option to show the wall created for gable and Dutch hip roof edges; when 
deselected, the wall is invisible

Gable Overhang
(Dutch Hip only)

Specifies how the gable wall on top of the Dutch hip face will be cut; enter zero for a 
flat gable wall, or enter the number of inches the gable wall will be inset from the 
gable roof edge

Gable Inset
(Dutch Hip only)

Specifies how far the gable wall on top of the Dutch hip face will be from the edge of 
the hip face

Pitch
(Eave and Dutch Hip only)

Specifies the roof pitch as an angle or rise:run ratio; click the calculator for an 
automatic calculation based on bearing height, eave height, and eave overhang

Bearing Height Specifies the height of the rafter plate or top plate above the wall layer elevation where 
the roof will be supported; click the calculator for an automatic calculation based on 
pitch, eave height, and eave overhang

Eave Height Specifies the height of the bottom-most portion of the roof; click the calculator for an 
automatic calculation based on pitch, bearing height, and eave overhang

Eave Overhang Specifies the distance that the roof extends beyond the bearing wall, click the 
calculator for an automatic calculation based on pitch, bearing height, and eave height

Entire Roof
(Eave and Dutch Hip only)

Select this option to apply the edited roof parameters to all available roof sections
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2. Click on the selection handle of the face to change into a gable wall.
The Edit Roof Settings dialog box opens.

3. Select the Gable option.
A diagram and parameters for a gable edge display.

4. Change the parameters as described in “Changing the Roof Edge Shape” on page 573, and click OK.
A triangular wall is placed when the gable roof is created.

Changing a Hip Roof to a Dutch Hip Roof
To change a hip roof into a Dutch hip roof:

1. Select the roof with the Selection tool.
Selection handles display for the roof.

2. Click on the selection handle of the face to change into a Dutch hip face.
The Edit Roof Settings dialog box opens.

3. Select the Dutch Hip option.
A diagram and parameters for a Dutch hip edge display.

4. Specify a Gable Inset value to create the Dutch hip face, and change other settings as described in “Changing the 
Roof Edge Shape” on page 573.

5. Click OK.
A triangular wall is placed when the Dutch hip roof is created.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Roof Objects
Creating Cutouts in a Roof Object
Reshaping Roof Objects
Adding Roof Elements to Roof Objects and Roof Faces

Creating Cutouts in a Roof Object
You can use both the Clip Surface command and the Clip tool to clip holes in a roof object.
To create a cutout with the Clip Surface command:

1. Draw one or more 2D cutout shapes (rectangle, circle, oval, polygon, polyline, or arc) on the roof object.
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2. Select the cutout object(s) and the roof object.
3. Select Modify > Clip Surface.
4. The shapes are cut out of the roof, and the clip objects are selected.
5. Delete the clip objects.

To create a cutout with the Clip tool:

1. Select the roof object.
2. Click the Clip tool from the Basic palette.
3. From the Tool bar, select the Exclusion mode, and then select the appropriate clipping shape (rectangle, polygon, 

or circle).
4. Click and drag to create a marquee box.

The roof is clipped as defined by the clipping shape.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Roof Objects
Creating Cutouts in a Roof Face

Reshaping Roof Objects
A roof object can be reshaped in a 2D or 3D view with the Reshape tool. The roof edge, roof ridge, and roof slope can 
be changed.

In Top/Plan view, the Reshape tool can be used for basic roof shape editing; see “2D Reshape Modes” on 
page 1044. However, the Reshape tool should be used in a 3D view to edit the roof edge and roof ridge location.

Five modes are available when both the Reshape tool and a roof object is selected in a 3D view.

Mode Description

Move Vertex Adjusts the position of a selected roof vertex, constrained horizontally or vertically in 
combination with the Z-axis Constrain and XY Plane Constrain modes

Add Vertex Adds a peak (vertex) to a roof
Delete Vertex Deletes a roof peak (vertex)

Move Vertex

Add Vertex XY Plane Constrain

Z-axis Constrain

Delete Vertex
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Reshaping the Roof Along the X and Y Axis

To reshape the roof horizontally:

1. In a 3D view, select the roof object.
2. Click the Reshape tool from the Basic palette, and select the XY Plane Constrain mode.
3. Position the cursor over a roof handle.

When the cursor is over a handle, the standard arrow cursor changes into an unfilled, four-way arrow.
4. Click-drag the handle to change the roof handle location, or enter specific X and Y distance values in the Data bar.

The roof edge, ridge, or eave handle location can be changed. The handle movement is constrained along the X or 
Y axis (the active layer plane); the height of the roof element cannot be changed in this mode.
Change the slope of a roof face by moving the ridge handle. If the reshape results in a roof slope that approaches 
or exceeds 90 degrees, you are prompted to create a gable wall if desired.

5. Click when the handle is at the desired location.

Reshaping the Roof Along the Z Axis

To change the height of a roof ridge or eave:

1. In a 3D view, select the roof object.
2. Click the Reshape tool from the Basic palette, and select the Z-axis Constrain mode.

XY Plane Constrain In 3D Reshape mode, reshapes the roof object horizontally, constrained along the X and/or Y 
axes

Z-axis Constrain In 3D Reshape mode, reshapes the roof object along the Z axis to change the height of a roof 
ridge or eave

Mode Description

Rendered View
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3. Position the cursor over a roof ridge or eave handle.
When the cursor is over a handle, the standard arrow cursor changes into two-way hollow arrow.

4. Click-drag the handle to change the roof handle location, or enter the specific Z axis distance in the Data bar.

The roof ridge or eave handle location can be changed. The handle movement is constrained along the Z axis 
(vertically); only the height of the roof element can be changed in this mode.

5. Click when the handle is at the desired location.

Adding a Roof Vertex

To add a vertex to a roof:

1. In a 3D view, select the roof for adding the vertex.
2. Click the Reshape tool from the Basic palette, and select Add Vertex mode.
3. Position the cursor over one of the edge or eave handles.

The standard arrow cursor changes into a single-headed, filled arrow with shaded boxes on either side of the shaft.
4. Click-drag the mouse to add a vertex to the roof edge or eave.
5. Click when the vertex is at the desired location.

The roof is automatically reshaped to accommodate the new vertex.

Deleting a Roof Vertex

To delete a vertex from a roof:

1. In a 3D view, select the roof with the vertex to be deleted.
2. Click the Reshape tool from the Basic palette, and select Delete Vertex mode.
3. Position the cursor over the eave vertex to delete.

The standard arrow cursor changes into a single-headed, filled arrow with a hollow diamond in the shaft.
4. Click the vertex.

The vertex is removed and the roof is reshaped to the remaining vertices.



Adding Roof Accessories |  579
~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Objects
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Adding Roof Accessories
In the Vectorworks Architect product, attic, soffit, and fascia roof accessories can be inserted when a roof object is 
being created, or they can be added, modified, or deleted later on. If the roof is reshaped, the accessories are 
automatically regenerated to suit the new shape.
The accessories are part of the roof object. To modify or remove them later on, select the roof object, and change the 
accessory settings from the Object Info palette.
Roof accessories cannot be added to roof face objects. See “Creating Roof Objects” on page 571.
To add roof accessories:

1. With the appropriate walls selected, select AEC > Create Roof.
The Create Roof dialog box opens.

2. Click Create Accessories.
The Create Roof Accessories dialog box opens.

Click to show/hide the parameters.

3. Select the accessories to be added to the roof object.
4. For each selected accessory, click the corresponding settings button.

A dialog box displays with parameters for that accessory.
5. Enter accessory parameters as described in the following sections and click OK to return to the Create Roof 

Accessories dialog box.
6. Repeat steps 4 and 5 until all desired accessory parameters have been entered.

Parameter Description

Insert Attic Select to add an attic to the roof
Attic Settings Opens the Edit Attic Settings dialog box for specification of attic parameters
Insert Soffit Select to add a soffit to the roof
Soffit Settings Opens the Edit Soffit Settings dialog box for specification of soffit parameters
Insert Fascia Select to add fascia to the roof
Fascia Settings Opens the Edit Fascia Settings dialog box for specification of fascia parameters
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7. From the Create Roof Accessories dialog box, click OK to return to the Create Roof dialog box; click OK again to 
create the roof object with the selected accessories.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Roof Objects
Inserting an Attic
Inserting a Soffit
Inserting Fascia

Inserting an Attic
To add an attic accessory to a roof:

1. From the Create Roof Accessories dialog box, select Insert Attic, and click Attic Settings.
The Edit Attic Settings dialog box opens.

Click to show/hide the parameters.

2. Enter the attic parameters and click OK to return to the Create Roof Accessories dialog box.

~~~~~~~~~~~~~~~~~~~~~~~~~
Adding Roof Accessories

Inserting a Soffit
The soffit accessory has a “pork chop” profile.
To add a soffit accessory to a roof:

1. From the Create Roof Accessories dialog box, select Insert Soffit, and click Soffit Settings.
The Edit Soffit Settings dialog box opens.

Click to show/hide the parameters.

Parameter Description

Full Height Specifies that the attic space is the full height of the attic area
Partial Height Specifies that the attic space is the height entered in the box provided

Roof with soffit and fascia addedRoof with no accessories
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2. Enter the soffit parameters and click OK to return to the Create Roof Accessories dialog box.

~~~~~~~~~~~~~~~~~~~~~~~~~
Adding Roof Accessories

Inserting Fascia
The fascia accessory has a rectangular profile.
To add a fascia accessory to a roof:

1. From the Create Roof Accessories dialog box, select Insert Fascia, and click Fascia Settings.
The Edit Fascia Settings dialog box opens.

Click to show/hide the parameters.

2. Enter the fascia parameters and click OK to return to the Create Roof Accessories dialog box.

~~~~~~~~~~~~~~~~~~~~~~~~~
Adding Roof Accessories

Adding Roof Elements to Roof Objects and Roof Faces
Once a roof object or a roof face has been created, roof elements, such as dormer windows and skylights, can be added.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Dormer Windows
Creating Skylights

Parameter Description

Recess Specifies the distance between the bottom edges of the roof rafters and the soffit
Trim Depth Specifies the distance between the outer edges of the rafters and inside edge of the 

soffit

Parameter Description

Fascia Width Specify a width for the fascia accessory
Fascia Height Specify a height for the fascia accessory
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Creating Dormer Windows

You can create a wide variety of dormer windows in roof objects and roof faces. There are five styles to select from: 
trapezium, gable, shed, hip, and bat; each gable type has unique parameters. The editing parameters available in the 
Edit Roof Element dialog box depend on the style of dormer chosen.

Dormer walls are always drawn in a clockwise direction for easy texture application.
To create a gable dormer window in a roof object or roof face:

1. Select View > Standard Views > Top/Plan.
2. Select Window > Palettes > Resource Browser.
3. Select a window symbol.

The window must be a symbol, not a plug-in object.
4. Select Resources > Make Active. The Symbol Insertion tool is automatically activated from the Basic palette.
5. Click to place the symbol in the roof object or roof face.

The Edit Roof Element dialog box opens.
6. Click Edit Dormer.
7. Select the dormer style.

The parameters automatically change according to the selected dormer style, with values for placing the dormer at 
the location specified with the mouse click.

Click to show/hide the parameters.
 

Parameter Dormer Style Description

Center vertically All Places the center of the window symbol in the center of the available 
vertical space in the front face of the dormer; the normal insertion point 
is not used

Offset from top All Locates the top of the window symbol a set distance from the top of the 
dormer face; the normal insertion point is not used

Height offset All Indicates the vertical distance from the top of the point of engagement 
with the roof, or where the roof and the dormer meet, to the bearing 
point, which is usually along the top of the bearing wall

Building line offset All Specifies the distance from the building outline to the plan center of the 
window symbol
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8. Click OK.
The gable dormer with window is created and placed according to the parameters specified. A hole is 
automatically created in the roof where the dormer walls exist.
When a gable dormer is created on a roof face, the Object Info palette of a selected roof face object contains two 
additional Dormer Settings parameters, Wall Thickness and Roof Thickness. These thickness values apply to the 
dormer(s) in the roof face.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Dormer Windows

Offset from corner All Sets the distance from the corner of the roof to the center of the dormer; 
the roof corner that the measurement is taken from is always to the left 
of the dormer when facing it

Top width Trapezium, Bat Determines the width of the top roof and sets the front face’s trapezoid 
shape; the front face is always symmetrical when using this option

Right slope Trapezium, Gable, 
Hip

Determines the angle of the right edge of the front face; the front face 
can be asymmetrical when using this option

Left slope Trapezium, Gable, 
Hip

Specifies the angle of the left edge of the front face. Along with the 
Right Slope, this dimension determines the top width of the front face. 
Right Slope must be selected for this option to be available.

Bottom width Trapezium, Gable, 
Bat

Sets the width of the bottom edge of the front face; works in conjunction 
with either the Top Width or the Left and Right Slope entries and is 
required

Slope Trapezium, Shed, 
Bat

Indicates the angle of the pitch of the top dormer roof as measured from 
a horizontal line

Width Gable, Shed, Hip Horizontal distance of the front face of the dormer
Front Slope Hip Indicates the angle of the pitch of the front face of the dormer roof as 

measured from a vertical line
Height All Specifies the elevation height of the front face of the dormer; determines 

the plan depth of the dormer
Top width Bat Indicates the width of the top of the roof as measured along the front 

face of the dormer
Bottom Height Bat Distance from the bottom of the dormer to the beginning of the 

compound curves of the roof as measured along the front face of the 
dormer

Depth All Sets the plan distance from the point of engagement with the roof to the 
front face of the dormer; determines the elevation height of the front 
face of the dormer

Overhang Gable, Shed, Hip Amount of roof extension past the dormer’s front roof face
Control Point Bat Point where the two curves of the roof meet. This option controls the 

location of that point from the side edge of the dormer as measured 
along the roof. The location of this point determines the depth of the 
curves that make up the roofline.

Parameter Dormer Style Description

http://www.youtube.com/watch?v=NH3Z2mke4fk
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Editing Dormer Windows
Once created, the dormer window parameters can be edited. 
To edit a dormer window:

1. Select the dormer.
Selection handles display around the roof or roof face and at the location of each dormer.

2. Position the cursor over the selection handle for the dormer and click.
The Edit Roof Element dialog box opens.

3. Select Edit Dormer and change the desired parameters as described in “Creating Dormer Windows” on page 582.
To remove the dormer completely, select Remove Object.

4. Click OK.

Creating Skylights

A full skylight, complete with a window symbol, can be placed in the roof object or roof face.
A 3D-only window symbol is required for creating a skylight. An existing hybrid symbol can be converted to a 3D 
symbol; place the symbol in the drawing and set its parameters, and then switch to a 3D view. Select the symbol, 
and then select Modify Convert > Convert to Group. Select the Convert all sub-objects option in the Convert 
to Group Options dialog box. With the group selected, choose Modify > Create Symbol to create a 3D symbol 
from the group, and select the On Edge option for Insert in Walls.
When creating your own skylight symbols, set the insertion point of the symbol at the back and center of the 
symbol.

The insertion point of the symbol determines whether a skylight will be flush or surface-mounted.
Top view Left view Front view

Insertion point



Adding Roof Elements to Roof Objects and Roof Faces |  585
Inserting a Skylight
To insert a skylight:

1. Select Window > Palettes > Resource Browser.
2. Select a 3D symbol to use in the skylight. Hybrid and 2D window symbols will not work for skylights, though 

hybrid symbols can be used to create a cutout.
3. Select Resources > Make Active, or double-click on the symbol. The Symbol Insertion tool is automatically 

activated from the Basic palette.
4. Switch to Top/Plan view.
5. Click to place the symbol in the desired location in the roof object or roof face.

The Edit Roof Element dialog box opens.
6. Click Edit Skylight.

The skylight parameters are displayed.
Click to show/hide the parameters.

7. Click OK to create the skylight (or cutout).
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Skylights

Editing Skylights
To edit a skylight:

1. Select the skylight.
A selection handle displays at the skylight location.

2. Position the cursor over the selection handle for the skylight and click.

Parameter Description

Offset from corner Specifies the distance from the edge of the roof to the center of the skylight symbol
Offset from building line Sets the distance from the edge of the building to the center of the skylight symbol
Do not insert symbol Select to create a cutout in the roof without inserting the window symbol
Remove object Deletes the skylight from the roof
Edit dormer Accesses the dormer parameters instead of the skylight parameters

Square miter flush-mounted Square miter surface-mounted
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The Edit Roof Element dialog box opens, with the skylight parameters displayed.
3. Edit the parameters as described in “Inserting a Skylight” on page 585.

To remove the skylight completely, select Remove object.
4. Click OK.

The drawing area displays the specified changes for the selected skylight.
The skylight miter parameters can be changed from the Object Info palette.

Skylight Miter Description

Vertical Cuts the roof vertically at both the top and bottom of the skylight

Splayed Cuts the roof horizontally at the top of the skylight, and vertically at the bottom

Square Cut Cuts the roof perpendicular to the roof at both the top and bottom of the skylight



Windows
In the Vectorworks Design Series products, the window object is inserted with the Window tool. In the Vectorworks 
Fundamentals product, the window object is inserted from an object library through the Resource Browser. All 
Vectorworks products include a window object containing parameters similar to those described here. The Vectorworks 
Architect and Landmark products include enhanced capabilities.
The Vectorworks Architect and Landmark products also include window symbols in standard sizes and various 
configurations, ready to install in walls. These products also include the ability to insert windows into curtain walls as 
special “curtain wall windows.” Additionally, the Vectorworks Architect product provides extensive libraries of 
window symbols, listed by configuration and size.

The Update Plug-in Objects command may need to be run on files containing windows that were created in an 
earlier version of the Vectorworks Architect or Landmark product. This command converts the windows to the 
latest format; see “Migrating from Previous Versions” on page 28.

A window can be customized by adjusting various parameters, and then saved as a symbol so that its parameters are 
preset upon insertion. This eliminates the need to repeatedly apply parameters, maximizes memory efficiency, and 
allows global editing of symbols. See “Creating New Symbols” on page 239.
If a custom window is unique (that is, it has only one instance) in a project, creating a symbol from it is unnecessary. 
However, making a symbol of the installed window makes it easy to reuse it in other drawings should there be a need to 
do so in the future.
After the symbol is created, it can be selected from the Window Settings dialog box (by selecting Use Symbol 
Geometry as described in “Window Settings: General Pane” on page 595), where it can take advantage of functionality 
such as embedded IDs and data, cavity wrapping, splays, and wall offsets. To enable automatic ID labeling, from the ID 
Tag pane of the settings dialog box, select Include on Schedule, and specify the ID parameters. If necessary, set the 
class to which the ID is assigned to visible. Alternatively, set the automatic ID labeling through the ID Label tool; see 
“Using the ID Label Tool” on page 1262.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Windows in Vectorworks Fundamentals
Inserting Windows in Vectorworks Design Series

Inserting Windows in Vectorworks Fundamentals
To insert a window in Vectorworks Fundamentals:

1. Insert a window symbol from the Resource Browser (see “Inserting Symbols” on page 242). The direction of a 
window inserted in a wall can be changed later by clicking Flip on the Object Info palette or from the context 
menu.
A library with an editable window symbol is included with the Vectorworks Fundamentals product. If this content 
was not downloaded during installation, download it at any time by selecting Help > Download Content (see 
“Resource Libraries” on page 219).
The Window tool is available for Vectorworks Fundamentals software but is not present in the Fundamentals 
workspace. It can be added to the Fundamentals workspace (see “Creating or Editing Workspaces” on page 1835) 
and subsequently used to insert window objects.

2. Click the Settings button on the Object Info palette to open the Window Settings dialog box. Select each pane and 
specify the window parameters. Click OK to set the window parameters and close the dialog box. 
Several features of the window are described as “interior” or “exterior.” These include trim, shutters, and 
wall-wrap parts. These elements are determined based on the internal and external faces of the wall, not on the 
window’s exterior direction. The left side of the wall (as viewed along the wall direction) is always “exterior,” and 
the right side is “interior” (see “Wall Direction” on page 506). Flipping the window does not flip these elements.
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Window Settings: Preview
Click to show/hide the parameters.

Window Settings: General Pane
Click to show/hide the parameters.

Window Settings: 2D Visualization Pane
Click to show/hide the parameters.

Parameter Description

3D Preview Dynamically displays a 3D preview of the window with the currently selected parameters
View Select the standard view for the 3D preview of the window
Render Select the render mode for the 3D preview of the window

Top/Plan Preview Dynamically displays a Top/Plan preview of the window with the currently selected 
parameters

Parameter Description

Top Shape Select the shape of the top of the window
Transom Select whether to add a transom above the window; transom parameters are set from the 

Transom pane
Rise When applicable for the selected Top Shape, enter the distance between the start of the 

top shape to the top of the window
Spring Enter the distance traveled above the bottom pane before the top shape starts; if Square is 

selected as the Top Shape, the spring is the total height
Sash Select the window type. Depending on the selection, a variety of window settings are 

enabled or disabled automatically, as described in the following sections. 
Use Symbol 
Geometry

Select Use Symbol Geometry and click Browse to select a window symbol from the 
current file’s resources. Select a symbol from the graphical list of Symbols and click OK. 
The symbol Name displays in the Window Settings dialog box and the preview is updated 
with the selected symbol.

When a symbol is selected, all fields pertaining to the window’s geometry are 
disregarded; however, parametric values are still available for scheduling and 
reporting purposes only.

Size Reference: Unit 
Size

For a unit size window, the width/height of the window is measured at the outside of the 
jamb; it includes the transom and sash. Set the Width and Height.

Elevation in Wall Enter the window elevation
Elevation Reference Select either the sill or the head of the window as the elevation reference point
Plan Wall Offset Enter the distance to offset the window insertion point from the centerline of the wall

Parameter Description

Show Plan Detail Select to display all the window details in Top/Plan view 
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Window Settings: 3D Visualization Pane
3D Visualization options are not enabled for the Opening Sash configuration.
Click to show/hide the parameters.

Window Settings: ID Tag Pane
Click to show/hide the parameters.

Draw Wall Lines Select whether to draw wall lines at all times; wall lines are drawn in the Ceiling-Main 
class to easily create reflected ceiling plans 

Set Attributes By Select whether to set the 2D graphic attributes and visibility of the listed window parts by 
Object, Line Style, or Class. 

• Object: disables line style and weight controls for individual parts, and uses the line 
style and weight settings for the window object.

• Line Style: controls line style and weight for the individual parts; these settings 
override the window object’s settings.

• Class: sets the line style and weight of individual parts by class. Select a class for 
each part to control its visibility and appearance. The classes present in the drawing 
are listed; alternatively, create a new class. Select the window class to place the part 
in the same class as the window object.

Parameter Description

3D Hinge Direction 
Marker

Show Interior/
Exterior Marker

Select to draw lines representing the hinge direction of the window sashes on the interior/
exterior side of the window in 3D

Use Hinge Marker 
Class Attributes

Select to set the hinge direction marker’s attributes by class

Hinge Direction 
Marker Class

Select a class to control visibility and, if Use Hinge Marker Class Attributes is selected, 
appearance. The classes present in the drawing are listed; alternatively, create a new class. 
Select the default window class to place the part in the same class as the window object. 

Marker Points 
Towards

Set the hinge direction marker to point toward the hinge or toward the handle

Show 3D Open Select to draw 3D window sashes as open at the specified Open Angle 
Clerestory Enabling Clerestory draws the window as dashed if the sill is higher than the specified 

elevation and draws the window as non-breaking (solid) if the sill is below the specified 
Dash Height

Parameter Description

Include on Schedule Select whether to include this window’s information in the window schedule and also set 
the window ID tag to visible

ID Prefix Assigns alphanumeric information before the numerical label value; adding prefix 
information is optional

Parameter Description
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Window Settings: Jamb and Sash Pane
Click to show/hide the parameters.

ID Label Assigns a numerical value to the ID; this number increments automatically if the 
auto-increment option is chosen in the ID Settings dialog box (see “Using the ID Label 
Tool” on page 1262)

ID Suffix Assigns alphanumeric information after the label value; adding suffix information is 
optional

ID Class Select a class to control visibility and, if Use ID Class Attributes is selected, appearance. 
The classes present in the drawing are listed; alternatively, create a new class. Select the 
default window class to place the part in the same class as the window object.

Use ID Class 
Attributes

Select to use the ID class attributes for the bubble line, leader line, and leader line marker

Keep ID Horizontal When selected, automatically rotates the ID so that it is horizontal
Bubble Shape Select the ID tag bubble shape
Bubble Size Enter the minimum bubble size (this value represents the bubble size times the layer 

scale; the bubble shape is maintained relative to the text inside it for ID bubble uniformity 
throughout the drawing file)

Bubble Line 
Attributes

Select the bubble line attributes and weight, or select Set Thickness to open the Set 
Thickness dialog box for creating a custom line thickness

Show Leader Select to draw a leader line from the ID tag to the window object
Line Attributes Select the leader line attributes and weight, or select Set Thickness to open the Set 

Thickness dialog box for creating a custom line thickness
Include Marker Select whether to include a marker for the ID leader line and choose the desired style 

from the marker list, or select Custom to create a custom marker. Select Edit Marker 
List to open the Edit Marker List dialog box; see “Editing the Marker List” on page 1103.

Parameter Description

Jamb
Jamb Width Enter the face width of the window jamb (parallel to the wall)
Jamb Depth Enter the depth of the window jamb (perpendicular to the wall)
Use Wall Depth Select to set the jamb depth to the overall wall depth

Sash
Sash Width Enter the sash width
Sash Depth Enter the sash depth
Unequal Sash To create a double hung window with an unequal sash height, select to customize the top 

sash height, and enter the desired scale factor for the sash.
Select to customize the width of the left and right sliders for a picture window slider, and 
enter the desired scale factor for the sashes. The sash scale factor applies to both the left 
and right sliders.

Parameter Description
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Window Settings: Sill Pane
Click to show/hide the parameters.

Window Settings: Transom Pane
Click to show/hide the parameters.

Window Settings: Trim Pane
Click to show/hide the parameters.

Shim Gap Enter the distance between the jamb exterior face and the rough opening (for the Opening 
Sash configuration, the Shim Gap is automatically set to 0)

Masonry Module Enter the masonry module dimension

Parameter Description

Include Sill Select whether to include a sill 
Sill Type: Timber Specify the sill lip thickness, amount of keep for the sill, sill height, total sill depth, sill 

extension width, stool lip thickness, and stool nose dimension

Parameter Description

Sash
Sash Width Enter the transom sash width
Sash Depth Enter the transom sash depth

Mullion
Mullion Width Enter the transom mullion width
Mullion Depth Enter the transom mullion depth

Muntins
Pattern Select the transom muntin pattern
Vertical/Horizontal 
Bars

For colonial muntins, enter the number of vertical/horizontal muntin bars
Prairie and renaissance muntins come with pre-set configurations; therefore, any 
number of Vertical/Horizontal Bars specified are disregarded

Bar Depth/Width Enter the transom muntin bar width/depth
Bar Offset Enter the transom muntin bar offset
Number of Rays For sunburst patterns, enter the number of muntin rays

Parameter Description

Include Interior/
Exterior Trim

Select whether to include interior/exterior trim

Width/Depth Enter the interior/exterior trim width and depth

Parameter Description
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Window Settings: Muntins Pane
Click to show/hide the parameters.

Window Settings: Interior Wall Detail Pane
Click to show/hide the parameters.

Window Settings: Exterior Wall Detail Pane
Click to show/hide the parameters.

Include Trim 
Under Stool/Sill

Select whether to include interior/exterior trim along the window bottom

Parameter Description

Top Sash/Bottom 
Sash

Select which sashes should have muntins applied to them

Pattern Select the muntin pattern
Vertical/Horizontal 
Bars

For colonial muntins, enter the number of vertical/horizontal muntin bars
Prairie and renaissance muntins come with pre-set configurations; therefore, any 
number of Vertical/Horizontal Bars specified are disregarded

Bar Depth/Width Enter the muntin bar width/depth
Bar Offset Enter the muntin bar offset
Number of Rays For sunburst patterns, enter the number of muntin rays

Parameter Description

Number of 
Components

Specify the number of interior wall components to wrap; when interior wall components 
are specified, the window enables a control point to set the wrapping point

Splay Wall Select whether to splay the interior wall; the splay can be specified either as an angle/
diagonal or with width and depth values

(1) Splay Angle Enter the interior wall splay angle
(2) Splay Diagonal Enter the interior wall splay diagonal value
(3) Splay Width Enter the interior wall splay width
(4) Splay Depth Enter the interior wall splay depth

Parameter Description

Interior control point
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Window Settings: Classes Pane
The visibility of the overall 3D window is controlled by the Class setting on the Object Info palette; part settings are 
controlled from the Window Settings dialog box.
Click to show/hide the parameters.

Window Settings: Data Pane
Certain data fields represent calculated values and cannot be edited; as a result, the Field Name and Field Value appear 
dimmed for those data fields.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Windows
Inserting Windows in Vectorworks Design Series
Window Properties
Creating Window Schedules
Creating a Custom Window Sash Opening

Parameter Description

Number of 
Components

Specify the number of exterior wall components to wrap; when exterior wall components 
are specified, the window enables a control point to set the wrapping point

Splay Wall Select whether to splay the exterior wall; the splay can be specified either as an angle/
diagonal or with width and depth values

(1) Splay Angle Enter the exterior wall splay angle
(2) Splay Diagonal Enter the exterior wall splay diagonal value
(3) Splay Width Enter the exterior wall splay width
(4) Splay Depth Enter the exterior wall splay depth

Parameter Description

Window parts Select a class for each window part to control its fill color and/or texture and visibility. 
The classes present in the drawing are listed; alternatively, create a new class. Select the 
window class to place the part in the same class as the window object. 

Parameter Description

Field Name Select the data field from the list and its name displays beneath the list; information 
associated with the Field Name can be specified in the Field Value area. The user fields 
can include additional user-defined information with the window. 

Field Value Enter data for use in the window schedule

Exterior control point
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Window Terminology Specific to the United Kingdom
Editing Symbols in Walls

Inserting Windows in Vectorworks Design Series

To insert a window:

1. Select the Window tool from the Building Shell tool set.
Alternatively, if placing a curtain wall window into a curtain wall (Vectorworks Architect or Landmark required), 
select a panel with the Edit Curtain Wall tool, and then right-click (Windows) or Ctrl-click (Mac) on the panel 
and select Insert Window from the context menu. The window is automatically inserted as a curtain wall window.

2. If this is the first time a window is inserted into the drawing, or if you wish to change the default preferences that 
apply to subsequently placed windows, click Preferences from the Tool bar. 
The Window Settings dialog box opens. The settings are grouped into several panes of related parameters, which 
are listed on the left side of the dialog box. Select each pane and specify the window parameters. Click OK to set 
the window parameters and close the dialog box. These parameters can be edited for placed windows from the 
Object Info palette, as described in “Window Properties” on page 606.

3. Click in the drawing area or in a wall (standard wall or curtain wall) to set the insertion point of the window, and 
click again to set the rotation. When inserting a window into a wall, place the second click on the exterior side of 
the wall to establish the exterior direction of the window. The direction of a window inserted in a wall can be 
changed later by clicking Flip on the Object Info palette.
Several features of the window are described as “interior” or “exterior.” These include trim, shutters, and 
wall-wrap parts. These elements are determined based on the internal and external faces of the wall, not on the 
window’s exterior direction. The left side of the wall (as viewed along the wall direction) is always “exterior,” and 
the right side is “interior” (see “Wall Direction” on page 506). Flipping the window does not flip these elements.
If you are inserting a corner window, place the window in a wall that is attached to another wall. Once parameters 
are set, the window moves to the nearest corner automatically. This represents one half of the corner window 
assembly. 

Window Settings: Preview
Click to show/hide the parameters.

Parameter Description

3D Preview Dynamically displays a 3D preview of the window with the currently selected parameters
View Select the standard view for the 3D preview of the window
Render Select the render mode for the 3D preview of the window

Top/Plan Preview Dynamically displays a Top/Plan preview of the window with the currently selected 
parameters



Inserting Windows in Vectorworks Design Series |  595
Window Settings: General Pane
Click to show/hide the parameters.

Parameter Description

Window Shape Select the window shape
All window shapes other than rectangular are fixed glass; only the appropriate 
parameters on each pane of the Window Settings dialog box are available for these 
fixed glass shapes.

Top Shape Select the shape of the top of the window
Transom Select whether to add a transom above the window; transom parameters are set from the 

Transom pane
Rise When applicable for the selected Top Shape, enter the distance between the start of the 

top shape to the top of the window
Spring Enter the distance traveled above the bottom pane before the top shape starts; if Square is 

selected as the Top Shape, the spring is the total height
Sash Select the window type. Depending on the selection, a variety of window settings are 

enabled or disabled automatically, as described in the following sections. 
For the Vectorworks Architect or Landmark product, to create a simple opening in a wall 
for defining a window break without creating any geometry to represent the window, 
select the Opening option. To define a custom window sash, select Custom Sash and click 
Custom Sash Options to open the Custom Sash Options dialog box.

Use Symbol 
Geometry

Select Use Symbol Geometry and click Browse to select a window symbol from the 
current file’s resources. Select a symbol from the graphical list of Symbols and click OK. 
The symbol Name displays in the Window Settings dialog box and the preview is updated 
with the selected symbol.

When a symbol is selected, all fields pertaining to the window’s geometry are 
disregarded; however, parametric values are still available for scheduling and 
reporting purposes only.

Size Reference Select the appropriate option to define the window width and height; the Size Reference 
selection automatically updates the Width and Height fields, but does not change the size 
of the window:
• Sash Opening - this represents the window opening including the sash and glass, but 

excluding the transom and jamb; this is typically used to show the window opening for 
emergency exit purposes

• Unit Size - this represents the current overall window width and height, including the 
transom and sash; this is the default setting for imperial units

• Rough Opening - this represents the current overall window width and height, 
including the transom, sash, and shim gap (for the Opening Sash configuration, the 
Size Reference is automatically changed to Rough Opening); this is the default setting 
for metric units

Vectorworks Architect or Landmark product required for Unit Size and Rough 
Opening.
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Window Settings: 2D Visualization Pane
Click to show/hide the parameters.

Window Settings: 3D Visualization Pane
3D Visualization options are not enabled for the Opening Sash configuration.
Click to show/hide the parameters.

Width/Height The width/height of the window is measured based on the Size Reference selection:
• Sash Opening - width/height is measured at the outside of the sash
• Unit Size - width/height is measured at the outside of the jamb
• Rough Opening - width/height measures the rough opening

For circle, half circle, hexagon, and octagon shaped windows, the height parameter 
is disabled, and the parameter is automatically calculated based on the window’s 
width.

Elevation in Wall Enter the window elevation
Elevation Reference Select either the sill or the head of the window as the elevation reference point
Plan Wall Offset Enter the distance to offset the window insertion point from the centerline of the wall
Curtain Wall Window 
(Vectorworks 
Architect or 
Landmark required)

Indicates that the window will be placed in a curtain wall, where its width and height are 
based on the surrounding panel size and the bottom frame where it is placed. A curtain 
wall window does not have as many available parameter options as a standard window. 
Configurations are limited to those that apply to curtain wall placement.

Parameter Description

Show Plan Detail Select to display all the window details in Top/Plan view 
Draw Wall Lines Select whether to draw wall lines at all times; wall lines are drawn in the Ceiling-Main 

class to easily create reflected ceiling plans 
Set Attributes By Select whether to set the 2D graphic attributes and visibility of the listed window parts by 

Object, Line Style, or Class. 
• Object: disables line style and weight controls for individual parts, and uses the line 

style and weight settings for the window object.
• Line Style: controls line style and weight for the individual parts; these settings 

override the window object’s settings.
• Class: sets the line style and weight of individual parts by class. Select a class for 

each part to control its visibility and appearance. The classes present in the drawing 
are listed; alternatively, create a new class. Select the window class to place the part 
in the same class as the window object.

Visibility Classes 
(Vectorworks 
Architect or 
Landmark required)

Select a class for each listed part to control its visibility and appearance. The classes 
present in the drawing are listed; alternatively, create a new class. Select the window class 
to place the part in the same class as the window object. 

Parameter Description
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Window Settings: ID Tag Pane
Click to show/hide the parameters.

Parameter Description

3D Hinge Direction 
Marker

Show Interior/
Exterior Marker

Select to draw lines representing the hinge direction of the window sashes on the interior/
exterior side of the window in 3D

Use Hinge Marker 
Class Attributes

Select to set the hinge direction marker’s attributes by class

Hinge Direction 
Marker Class

Select a class to control visibility and, if Use Hinge Marker Class Attributes is selected, 
appearance. The classes present in the drawing are listed; alternatively, create a new class. 
Select the default window class to place the part in the same class as the window object. 

Marker Points 
Towards

Set the hinge direction marker to point toward the hinge or toward the handle

Show 3D Open Select to draw 3D window sashes as open at the specified Open Angle 
Clerestory Enabling Clerestory draws the window as dashed if the sill is higher than the specified 

elevation and draws the window as non-breaking (solid) if the sill is below the specified 
Dash Height

Parameter Description

Include on Schedule Select whether to include this window’s information in the window schedule and also set 
the window ID tag to visible

ID Prefix Assigns alphanumeric information before the numerical label value; adding prefix 
information is optional

ID Label Assigns a numerical value to the ID; this number increments automatically if the 
auto-increment option is chosen in the ID Settings dialog box (see “Using the ID Label 
Tool” on page 1262)

ID Suffix Assigns alphanumeric information after the label value; adding suffix information is 
optional

ID Class Select a class to control visibility and, if Use ID Class Attributes is selected, appearance. 
The classes present in the drawing are listed; alternatively, create a new class. Select the 
default window class to place the part in the same class as the window object.

Use ID Class 
Attributes

Select to use the ID class attributes for the bubble line, leader line, and leader line marker

Keep ID Horizontal When selected, automatically rotates the ID so that it is horizontal
Bubble Shape Select the ID tag bubble shape
Bubble Size Enter the minimum bubble size (this value represents the bubble size times the layer 

scale; the bubble shape is maintained relative to the text inside it for ID bubble uniformity 
throughout the drawing file)

Bubble Line 
Attributes

Select the bubble line attributes and weight, or select Set Thickness to open the Set 
Thickness dialog box for creating a custom line thickness
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Window Settings: Corner Window Pane
Vectorworks Architect or Landmark product required. Corner Window options are not enabled for non-rectangular 
window shapes or for curtain wall windows.
Click to show/hide the parameters.

Show Leader Select to draw a leader line from the ID tag to the window object
Line Attributes Select the leader line attributes and weight, or select Set Thickness to open the Set 

Thickness dialog box for creating a custom line thickness
Include Marker Select whether to include a marker for the ID leader line and choose the desired style 

from the marker list, or select Custom to create a custom marker. Select Edit Marker 
List to open the Edit Marker List dialog box; see “Editing the Marker List” on page 1103.

Show Tag in 3D View 
(Vectorworks 
Architect or 
Landmark required)

Select to display the ID tag in 3D views

Horizontal Offset If Show Tag in 3D View is selected, enter the horizontal offset of the 3D ID tag relative 
to the bottom left corner of the rough opening when looking at the exterior side of the 
window (a positive value moves the tag inside the opening relative to the starting corner; 
a negative value moves the tag outside the opening relative to the starting corner)

The ID tag is offset slightly from the outside face of the window sash. The size and 
shape of the text and bubble, if present, will match the plan settings, and the text will 
always be right reading from the outside of the wall. The bubble will scale with text 
scaling in viewports.

Vertical Offset If Show Tag in 3D View is selected, enter the vertical offset of the 3D ID tag relative to 
the bottom left corner of the rough opening when looking at the exterior side of the 
window (a positive value moves the tag inside the opening relative to the starting corner; 
a negative value moves the tag outside the opening relative to the starting corner)

Parameter Description

Corner Window Select this option to redraw the current window as a corner window.
Settings that do not apply to a corner window may be disabled or changed when the 
corner window option is selected.
When you click OK to exit the Window Settings dialog box, the window is moved to the 
corner of the wall to which it is most closely located. To complete the corner window, 
insert another one into the adjacent, attached wall.

Corner windows do not work in tandem with one another. When you make 
adjustments to one window, you will also need to update the other. This can be 
accomplished quickly with the Eyedropper tool or from the Object Info palette. 
When you make adjustments to the wall containing a corner window, the window 
moves along with the wall and remains locked in the corner position. When 
adjusting the angle of the wall, the miter is automatically adjusted in most cases; if a 
corner window object does not automatically update, temporarily change a 
parameter in the Object Info palette to force a reset of the window object.

Parameter Description
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Window Settings: Jamb and Sash Pane
Jamb and Sash options are not enabled for the Opening Sash configuration.
Click to show/hide the parameters.

Corner Condition Select Flush Glass to draw the glass right to the edge of the wall and wrap it around the 
corner, select Mitered Sash to draw the window with a mitered sash in the corner, select 
Corner Post to draw the window with a post in the corner, or select Opening to create a 
simple opening in a wall for defining a window break without creating any geometry to 
represent the window (the Sash configuration is automatically also changed to Opening). 
For windows with a corner post, specify the Size of the post and its Offset within the 
wall. 

Parameter Description

Jamb
Jamb Width Enter the face width of the window jamb (parallel to the wall)
Jamb Depth Enter the depth of the window jamb (perpendicular to the wall)
Use Wall Depth Select to set the jamb depth to the overall wall depth
Use Jamb 
Extension 
(Vectorworks 
Architect or 
Landmark 
required)

Select this field to specify a jamb extension to fill any gap between the interior face of the 
jamb and the interior face of the wall; enter the desired Jamb Extension Width 

In 2D views, extensions use the Jamb line styles and weights; in 3D views, the 
extension fill color and/or textures and visibility are controlled by the Interior Jamb 
class.

Sash
Sash Width Enter the sash width
Sash Depth Enter the sash depth
Sash Offset 
(Vectorworks 
Architect or 
Landmark 
required)

Enter the offset of the sash relative to the jamb depth (a positive value moves the sash 
toward the window exterior; a negative value moves the sash toward the window interior)

Sash Width Offset 
(Vectorworks 
Architect or 
Landmark 
required)

Enter the sash width offset relative to the jamb width (leaving the default value of 0 keeps 
the sash adjacent to the jamb, and a positive value makes the sash intersect the jamb; a 
negative value is not permitted)

Glass Offset 
(Vectorworks 
Architect or 
Landmark 
required)

Enter the glass offset relative to the sash depth (a positive value moves the glass toward 
the window exterior; a negative value moves the glass toward the window interior)

Parameter Description
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Window Settings: Sill Pane
Sill options are not enabled for the Opening Sash configuration or for non-rectangular window shapes, or for curtain 
wall windows.
Click to show/hide the parameters.

Window Settings: Transom Pane
Transom options are not enabled for the Opening Sash configuration or for non-rectangular window shapes, or for 
curtain wall windows.
Click to show/hide the parameters.

Unequal Sash To create a double hung window with an unequal sash height, select to customize the top 
sash height, and enter the desired scale factor for the sash.
Select to customize the width of the left and right sliders for a picture window slider, and 
enter the desired scale factor for the sashes. The sash scale factor applies to both the left 
and right sliders.

Shim Gap Enter the distance between the jamb exterior face and the rough opening (for the Opening 
Sash configuration, the Shim Gap is automatically set to 0)

Show Shim Gap in 
Plan (Vectorworks 
Architect or 
Landmark required)

Select whether to display the shim gap in Top/Plan view

Masonry Module Enter the masonry module dimension

Parameter Description

Include Sill Select whether to include a sill and select the sill style type
Timber Specify the sill lip thickness, amount of keep for the sill, sill height, total sill depth, sill 

extension width, stool lip thickness, and stool nose dimension
Masonry 
(Vectorworks 
Architect or 
Landmark 
required)

Specify the sill lip thickness, amount of keep for the sill, rise dimension, sill height, total 
sill depth, and sill extension width

Brick 
(Vectorworks 
Architect or 
Landmark 
required)

Specify the sill lip thickness, rise dimension, total sill depth, sill extension width, stool lip 
thickness, and stool nose dimension

Parameter Description

Sash
Sash Width Enter the transom sash width
Sash Depth Enter the transom sash depth

Parameter Description
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Window Settings: Trim Pane
Trim options are not enabled for the Opening Sash configuration or for curtain wall windows.
Click to show/hide the parameters.

Window Settings: Lintel Pane
Vectorworks Architect or Landmark product required. Lintel options are not enabled for the Opening Sash 
configuration or for non-rectangular window shapes, or for curtain wall windows.
Click to show/hide the parameters.

Window Settings: Muntins Pane
Muntin options are not enabled for the Opening Sash configuration or for non-rectangular window shapes.
Click to show/hide the parameters.

Mullion
Mullion Width Enter the transom mullion width
Mullion Depth Enter the transom mullion depth

Muntins
Pattern Select the transom muntin pattern
Vertical/Horizontal 
Bars

For colonial muntins, enter the number of vertical/horizontal muntin bars
Prairie and renaissance muntins come with pre-set configurations; therefore, any 
number of Vertical/Horizontal Bars specified are disregarded

Bar Depth/Width Enter the transom muntin bar width/depth
Bar Offset Enter the transom muntin bar offset
Number of Rays For sunburst patterns, enter the number of muntin rays

Parameter Description

Include Interior/
Exterior Trim

Select whether to include interior/exterior trim

Width/Depth Enter the interior/exterior trim width and depth
Include Trim 
Under Stool/Sill

Select whether to include interior/exterior trim along the window bottom

Parameter Description

Include Lintel Select to add a lintel above the window or transom
Int./Ext. Protrusion Enter the interior and exterior lintel protrusion
(1) Thickness Enter the lintel thickness
(2) Angle Enter the lintel angle
(3) Drop Enter the length of the lintel drop

Parameter Description
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Window Settings: Interior Shutters Pane
Vectorworks Architect or Landmark product required. Interior Shutter options are not enabled for the Opening Sash 
configuration or for non-rectangular window shapes, or for curtain wall windows.
Click to show/hide the parameters.

Parameter Description

Top Sash/Bottom 
Sash

Select which sashes should have muntins applied to them

Pattern Select the muntin pattern
Vertical/Horizontal 
Bars

For colonial muntins, enter the number of vertical/horizontal muntin bars
Prairie and renaissance muntins come with pre-set configurations; therefore, any 
number of Vertical/Horizontal Bars specified are disregarded

Bar Depth/Width Enter the muntin bar width/depth
Bar Offset Enter the muntin bar offset
Number of Rays For sunburst patterns, enter the number of muntin rays
Custom Top Sash 
Muntins 
(Vectorworks 
Architect or 
Landmark required)

For a double hung window with an unequal sash and colonial muntins, select to customize 
the top sash, and enter the desired number of horizontal bars

Parameter Description

Include Interior 
Shutters

Select whether to include interior shutters 

Use Custom Width If Square is selected as the Top Shape, select whether the interior shutters should be a 
width other than the default value (1/2 the width of the window) and enter the desired 
custom width

Frame Depth Enter the depth for the interior shutters
Offset from Jamb Enter the offset distance from the interior edge of the window jamb that shutters will be 

positioned when fully opened
Panel Shutter Select to create paneled shutters

Panel Frame Width Enter the rail and stile width of the paneled shutter
Number of Panels Select One panel per sash to divide shutters at sash divisions or select to divide panels 

equally by the Custom number of panels specified
Custom Shutter Click Choose Symbol to select a custom shutter symbol from default content; see 

“Resource Libraries” on page 219
Custom shutters must be 3D-only symbols made from generic solids, saved in the 
default content location. 
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Window Settings: Exterior Shutters Pane
Vectorworks Architect or Landmark product required. Exterior Shutter options are not enabled for the Opening Sash 
configuration or for non-rectangular window shapes, or for curtain wall windows.
Click to show/hide the parameters.

Window Settings: Centerline Marker Pane
Vectorworks Architect or Landmark product required. Centerline Marker options are not enabled for curtain wall 
windows.
Click to show/hide the parameters.

Parameter Description

Include Exterior 
Shutters

Select whether to include exterior shutters 

Use Custom Width If Square is selected as the Top Shape, select whether the exterior shutters should be a 
width other than the default value (1/2 the width of the window) and enter the desired 
custom width

Frame Depth Enter the depth for the exterior shutters
Offset from Jamb Enter the offset distance from the interior edge of the window jamb that shutters will be 

positioned when fully opened
Panel Shutter Select to create paneled shutters

Panel Frame Width Enter the rail and stile width of the paneled shutter
Number of Panels Select One panel per sash to divide shutters at sash divisions or select to divide panels 

equally by the Custom number of panels specified
Custom Shutter Click Choose Symbol to select a custom shutter symbol from default content; see 

“Resource Libraries” on page 219
Custom shutters must be 3D-only symbols made from generic solids, saved in the 
default content location. 

Parameter Description

Centerline Marker Select to display a centerline marker in Top/Plan view.
Size Set the size of the centerline
Class Select a class to control visibility. The classes present in the drawing are listed; 

alternatively, create a new class. Select the default window class to place the part in the 
same class as the window object.

Line Attributes Select the line attributes and weight, or select Set Thickness to open the Set Thickness 
dialog box for creating a custom line thickness. If Use Class Attributes is selected, the 
line attributes are set by the part’s class

Include Marker Select whether to include a marker and choose the desired style from the marker list, or 
select Custom to create a custom marker. Select Edit Marker List to open the Edit 
Marker List dialog box; see “Editing the Marker List” on page 1103. If Use Class 
Attributes is selected, the marker attributes are set by the part’s class.

Use Class 
Attributes

Select to set the centerline marker’s attributes (including marker style) by class rather 
than the parameters in the Window Settings dialog box
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Window Settings: Interior Wall Detail Pane
Interior Wall Detail options are not enabled for non-rectangular window shapes or for curtain wall windows.
Click to show/hide the parameters.

Window Settings: Exterior Wall Detail Pane
Exterior Wall Detail options are not enabled for non-rectangular window shapes or for curtain wall windows.
Click to show/hide the parameters.

Parameter Description

Number of 
Components

Specify the number of interior wall components to wrap; when interior wall components 
are specified, the window enables a control point to set the wrapping point

Splay Wall Select whether to splay the interior wall; the splay can be specified either as an angle/
diagonal or with width and depth values

(1) Splay Angle Enter the interior wall splay angle
(2) Splay Diagonal Enter the interior wall splay diagonal value
(3) Splay Width Enter the interior wall splay width
(4) Splay Depth Enter the interior wall splay depth

Parameter Description

Number of 
Components

Specify the number of exterior wall components to wrap; when exterior wall components 
are specified, the window enables a control point to set the wrapping point

Splay Wall Select whether to splay the exterior wall; the splay can be specified either as an angle/
diagonal or with width and depth values

(1) Splay Angle Enter the exterior wall splay angle
(2) Splay Diagonal Enter the exterior wall splay diagonal value
(3) Splay Width Enter the exterior wall splay width
(4) Splay Depth Enter the exterior wall splay depth

Interior control point

Exterior control point
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Window Settings: Classes Pane
The visibility of the overall 3D window is controlled by the Class setting on the Object Info palette; part settings are 
controlled from the Window Settings dialog box.
Click to show/hide the parameters.

Window Settings: Data Pane
Certain data fields represent calculated values and cannot be edited; as a result, the Field Name and Field Value appear 
dimmed for those data fields.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Windows
Window Properties
Creating Window Schedules
Creating a Custom Window Sash Opening
Window Terminology Specific to the United Kingdom

Creating a Custom Window Sash Opening
In the Vectorworks Architect and Landmark products, a custom window sash opening can be created for selection in 
the Window Settings dialog box. A rectangular sash opening can contain any number of rectangular sashes.
To create a custom window sash opening:

1. From the General pane of the Window Settings dialog box, select the Custom Sash operation and click Custom 
Sash Options.
The Custom Sash Options dialog box opens for selecting and specifying the sash opening parameters. As 
parameters are defined, the preview dynamically displays the configuration operations of the sashes filling the 
opening.

Click to show/hide the parameters.

Parameter Description

Window parts Select a class for each window part to control its fill color and/or texture and visibility. 
The classes present in the drawing are listed; alternatively, create a new class. Select the 
window class to place the part in the same class as the window object. 

The Vectorworks Architect and Landmark products have a more comprehensive list 
of window parts available to be assigned a class.
For windows with an Opening Sash configuration, in a 3D view, a no fill/no pen 
weight extrude completely fills the wall in place of the window; this extrude is 
placed in the Interior Jamb class and is filtered out in IFC export operations. Change 
the class settings to control the visibility of the extrude, as needed.

Parameter Description

Field Name Select the data field from the list and its name displays beneath the list; information 
associated with the Field Name can be specified in the Field Value area. The user fields 
can include additional user-defined information with the window. 

Field Value Enter data for use in the window schedule



  606 | Inserting Windows in Vectorworks Design Series
2. Click OK to close the Custom Sash Options dialog box and return to the Window Settings dialog box. The 
Window Settings dialog box preview is updated with the customization results.

~~~~~~~~~~~~~~~~~~~~~~~~~
Window Settings: General Pane
Window Terminology Specific to the United Kingdom

Window Properties
To edit window parameters, click Settings from the Object Info palette, double-click the window to open the Window 
Settings dialog box, or right-click (Windows) or Ctrl-click (Mac) on a window and select Edit from the context menu.
When multiple window objects are selected for editing, and if the parameter settings of the selected objects are 
different, parameters display in an “indeterminate state.” Any values changed through the dialog box are changed for 
all the selected objects.
Window objects can also be edited in the Object Info palette. If the window has been inserted as a plug-in object, most 
settings from the Window Settings dialog box display. If the window is a black symbol made from a window object, 
fields pertaining to window geometry do not display. See “Symbol Types” on page 237.
For the Vectorworks Architect and Landmark products, most, but not all, parameters can be edited from both the 
Window Settings dialog box and the Object Info palette for ease of access. The fields in the Object Info palette are 
named similarly (but not always identically) to those in the Window Settings dialog box, and roughly reflect the order 
in which settings are entered in the dialog box, for ease of editing. Curtain wall windows have limited parameter 
options.
For the Vectorworks Fundamentals and Spotlight products, certain frequently used parameters are available to be edited 
directly in the Object Info palette, and do not necessarily reflect the order in which settings are entered in the dialog 
box. All other parameters are edited only from the Window Settings dialog box.

Parameter Description

Num. of Rows/Columns Specify the number of rows and columns in the sash opening (the total number of 
sashes cannot exceed 64)

Overall Width/Height Displays the overall width and height of the custom sashes
Mullion Width/Depth Displays the mullion width and depth
Selected Sash The currently active sash displays in red to indicate that it is selected 

Width/Height For the active sash, specify the desired Width and Height
Operation For the active sash, choose the desired window type
Include Muntins Select whether to include muntins for each sash
Lock Sash 
Configuration

When selected, locks the sash dimensions and operation

Unequal Sash To create a double hung window with an unequal sash height, select to customize 
the top sash height, and enter the desired scale factor for the sash; to customize the 
horizontal top sash muntins, see “Window Settings: Muntins Pane” on page 601.
Select to customize the width of the left and right sliders for a picture window 
slider, and enter the desired scale factor for the sashes. The sash scale factor applies 
to both the left and right sliders.

<< or >> Click << or >> to move backward or forward to activate sashes for dimension and 
operation specification
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The window parameters are described in “Inserting Windows in Vectorworks Fundamentals” on page 587 and 
“Inserting Windows in Vectorworks Design Series” on page 594. Only the parameters that are different are described 
here.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Windows in Vectorworks Fundamentals
Inserting Windows in Vectorworks Design Series
Creating New Symbols
Moving Objects
Window Terminology Specific to the United Kingdom

Creating Window Schedules
The Window Schedule can be added to the drawing from the VA Create Schedule command (see “Records and 
Schedules” on page 1859) or the Resource Browser. From the Resource Browser, open the default architectural reports 
file from the [Vectorworks]\Libraries folder that is included with the Vectorworks Architect product (see “Resource 
Libraries” on page 219). Drag the Window Schedule worksheet to the drawing. The worksheet is populated with 
information from the window objects in the current drawing (note that corner windows are counted as two separate 
windows in the worksheet). To edit the worksheet after it has been created, see “Using Worksheets” on page 1319.
Users of the Vectorworks Landmark and Spotlight products can also create the worksheet by creating a report for 
objects with a window record. To create the report from Landmark select Tools > Reports > Create Report; from 
Spotlight select Spotlight > Reports > Create Report.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Windows in Vectorworks Fundamentals
Inserting Windows in Vectorworks Design Series
Moving Objects
Window Terminology Specific to the United Kingdom

Window Terminology Specific to the United Kingdom
Certain window terminology varies in the United Kingdom. The window object is automatically localized in the 
Vectorworks program for users with a United Kingdom serial number; however, since the documentation is not 
localized, the terminology does not match. This table shows how the terms are mapped.

Parameter Description

Flip Click to flip the orientation of windows inserted in a wall
Set Position Click to activate the Move by Points tool in Reference Point mode and move the 

window by a specified distance from a reference point

U.S. Term (in Documentation) U.K. Term (in Vectorworks Program)

Transom Fanlight
Rough Opening Structural Opening
Muntins (Leaf and Transom) Glazing Bars
Colonial (Muntin Style) Georgian
Prairie w/sunburst (Muntin Style) Prairie w/ Fan Top
Colonial w/sunburst (Muntin Style) Georgian w/Fan Top
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~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Windows in Vectorworks Fundamentals
Inserting Windows in Vectorworks Design Series
Creating a Custom Window Sash Opening

Mullion (Transom) Transom Bar
Trim Architraves
Interior Trim Interior Architraves
Exterior Trim Exterior Architraves
Masonry Opening (Data) Nearest Full-Module of Masonry
Window Configurations Window Configurations

Fixed Glass Fixed Light
Single Hung Sliding Sash (lower)
Double Hung Sliding Sash (upper and lower)
Casement Side-Hung Casement
Bi-Parting Casement Double-Hung Casement
Awning Top-Hung Casement
Hopper Bottom-Hung Casement

U.S. Term (in Documentation) U.K. Term (in Vectorworks Program)



Doors
In the Vectorworks Design Series products, the door object is inserted with the Door tool. In the Vectorworks 
Fundamentals product, the door object is inserted from an object library through the Resource Browser. All 
Vectorworks products include a door object containing parameters similar to those described here. The Vectorworks 
Architect and Landmark products include enhanced capabilities. 
The Vectorworks Architect and Landmark products also include door symbols in standard sizes and various 
configurations, ready to install in walls. These products also include the ability to insert doors into curtain walls as 
special “curtain wall doors.” Additionally, the Vectorworks Architect product provides extensive libraries of door 
symbols, listed by configuration and size.

The Update Plug-in Objects command may need to be run on files containing doors that were created in an 
earlier version of the Vectorworks Architect or Landmark product. This command converts the doors to the latest 
format; see “Migrating from Previous Versions” on page 28.

A door can be customized by adjusting various parameters, and then saved as a symbol so that its parameters are preset 
upon insertion. This eliminates the need to repeatedly apply parameters, maximizes memory efficiency, and allows 
global editing of symbols. See “Creating New Symbols” on page 239.
If a custom door is unique (that is, it has only one instance) in a project, creating a symbol from it is unnecessary. 
However, making a symbol of the installed door makes it easy to reuse it in other drawings should there be a need to do 
so in the future.
After the symbol is created, it can be selected from the Door Settings dialog box (by selecting Use Symbol Geometry 
as described in “Door Settings: General Pane” on page 618), where it can take advantage of functionality such as 
embedded IDs and data, cavity wrapping, splays, and wall offsets. To enable automatic ID labeling, from the ID Tag 
pane of the settings dialog box, select Include on Schedule, and specify the ID parameters. If necessary, set the class to 
which the ID is assigned to visible. Alternatively, set the automatic ID labeling through the ID Label tool; see “Using 
the ID Label Tool” on page 1262.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Doors in Vectorworks Fundamentals
Inserting Doors in Vectorworks Design Series

Inserting Doors in Vectorworks Fundamentals
To insert a door in Vectorworks Fundamentals:

1. Insert a door symbol from the Resource Browser (see “Inserting Symbols” on page 242). The direction of a door 
inserted in a wall can be changed later by clicking Flip on the Object Info palette or from the context menu.
A library with an editable door symbol is included with the Vectorworks Fundamentals product. If this content 
was not downloaded during installation, download it at any time by selecting Help > Download Content (see 
“Resource Libraries” on page 219).
The Door tool is available for Vectorworks Fundamentals software but is not present in the Fundamentals 
workspace. It can be added to the Fundamentals workspace (see “Creating or Editing Workspaces” on page 1835) 
and subsequently used to insert door objects.

2. Click the Settings button on the Object Info palette to open the Door Settings dialog box. Select each pane and 
specify the door parameters. Click OK to set the door parameters and close the dialog box. 
Several features of the door are described as “interior” or “exterior.” These include trim and wall-wrap parts. 
These elements are determined based on the internal and external faces of the wall. The left side of the wall (as 
viewed along the wall direction) is always “exterior,” and the right side is “interior” (see “Wall Direction” on 
page 506). Flipping the door does not flip these elements.
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Door Settings: Preview
Click to show/hide the parameters.

Door Settings: General Pane
Click to show/hide the parameters.

Parameter Description

3D Preview Dynamically displays a 3D preview of the door with the currently selected parameters
View Select the standard view for the 3D preview of the door
Render Select the render mode for the 3D preview of the door

Top/Plan Preview Dynamically displays a Top/Plan preview of the door with the currently selected 
parameters

Parameter Description

Size Reference: Leaf 
Size

For a leaf size door, the width/height of the door leaf is measured at the inside of the 
jamb; set the Width and Height

Use Symbol 
Geometry

Select Use Symbol Geometry and click Browse to select a door symbol from the current 
file’s resources. Select a symbol from the graphical list of Symbols and click OK.
The symbol Name displays in the Door Settings dialog box and the preview is updated 
with the selected symbol.

When a symbol is selected, all fields pertaining to the door’s geometry are 
disregarded; however, parametric values are still available for scheduling and 
reporting purposes only.

Top Shape Select the shape of the top of the door
Transom Select whether to add a transom above the door; transom parameters are set from the 

Transom pane
Rise Enter the distance between the start of the top shape to the top of the door (not applicable 

for Square and Round Top Shape)
Spring Enter the distance traveled above the floor before the Top Shape begins
Offset in Wall Enter the distance to offset the door insertion point from the centerline of the wall
Configuration Select the general door configuration. Depending on the selection, a variety of door 

settings are enabled or disabled automatically, as described in the following sections. 
Operation Select the advanced operation for a sliding or complex swing door, where “O” represents 

a fixed door and “X” represents an operating door



Inserting Doors in Vectorworks Fundamentals |  611
Door Settings: 2D Visualization Pane
Click to show/hide the parameters.

Door Settings: 3D Visualization Pane
3D Visualization options are not enabled for the Opening Configuration.
Click to show/hide the parameters.

Door Settings: ID Tag Pane
Click to show/hide the parameters.

Parameter Description

Show Plan Detail Select to display all the door details in Top/Plan view
Draw Wall Lines Select whether to draw wall lines at all times; wall lines are drawn in the Ceiling-Main 

class to easily create reflected ceiling plans
Set Attributes By Select whether to set the 2D graphic attributes and visibility of the listed door parts by 

Object, Line Style, or Class. 
• Object: disables line style and weight controls for individual parts, and uses the line 

style and weight settings for the door object.
• Line Style: controls line style and weight for the individual parts; these settings 

override the door object’s settings.
• Class: sets the line style and weight of individual parts by class. Select a class for 

each part to control its visibility and appearance. The classes present in the drawing 
are listed; alternatively, create a new class. Select the door class to place the part in 
the same class as the door object.

Parameter Description

3D Hinge Direction 
Marker

Select to draw lines representing the 3D hinge direction

Show Interior/
Exterior Marker

Select to draw lines representing the hinge direction of the door leaves on the interior/
exterior side of the door in 3D

Use Hinge Marker 
Class Attributes

Select to set the hinge direction marker’s attributes by class

Hinge Direction 
Marker Class

Select a class to control visibility and, if Use Hinge Marker Class Attributes is selected, 
appearance. The classes present in the drawing are listed; alternatively, create a new class. 
Select the default door class to place the part in the same class as the door object.

Marker Points 
Towards

Set the hinge direction marker to point toward the hinge or toward the handle

Draw 3D Open Select to draw 3D doors as open at the specified Open Angle
3D Detail Level Select the level of detail to include for 3D doors.

In Low and Medium settings, some door details are not drawn in 3D views; these 
settings simplify the appearance for viewing the drawing at a small scale.
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Door Settings: Jamb Pane
Jamb options are not enabled for the Opening Configuration.
Click to show/hide the parameters.

Parameter Description

Include on Schedule Select whether to include this door’s information in the door schedule and also set the 
door ID tag to visible; see “Creating Door Schedules or Worksheets” on page 631

ID Prefix Assigns alphanumeric information before the numerical label value; adding prefix 
information is optional

ID Label Assigns a numerical value to the ID; this number increments automatically if the 
auto-increment option is chosen in the ID Settings dialog box (see “Using the ID Label 
Tool” on page 1262)

ID Suffix Assigns alphanumeric information after the label value; adding suffix information is 
optional

ID Class Select a class to control visibility and, if Use ID Class Attributes is selected, appearance. 
The classes present in the drawing are listed; alternatively, create a new class. Select the 
default door class to place the part in the same class as the door object.

Use ID Class 
Attributes

Select to use the ID class attributes for the bubble line, leader line, and leader line marker

Keep ID Horizontal When selected, automatically rotates the ID so that it is horizontal
Bubble Shape Select the ID tag bubble shape
Bubble Size Enter the minimum bubble size (this value represents the bubble size times the layer 

scale; the bubble shape is maintained relative to the text inside it for ID bubble uniformity 
throughout the drawing file)

Bubble Line 
Attributes

Select the bubble line attributes and weight, or select Set Thickness to open the Set 
Thickness dialog box for creating a custom line thickness

Show Leader Select to draw a leader line from the ID tag to the door object
Line Attributes Select the leader line attributes and weight, or select Set Thickness to open the Set 

Thickness dialog box for creating a custom line thickness
Include Marker Select whether to include a marker for the ID leader line and choose the desired style 

from the marker list, or select Custom to create a custom marker. Select Edit Marker 
List to open the Edit Marker List dialog box; see “Editing the Marker List” on page 1103.

Parameter Description

Width Enter the face width of the door jamb (parallel to the wall)
Depth Enter the depth of the door jamb (perpendicular to the wall)
Use Wall Depth Select to set the jamb depth to the overall wall depth
Shim Gap Enter the distance between the jamb exterior face and the rough opening (for the Opening 

Configuration, the Shim Gap is automatically set to 0)
Masonry Module Enter the masonry module dimension
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Door Settings: Leaf Pane
Leaf options are not enabled for the Opening Configuration.
Click to show/hide the parameters.

Astragal Flange / 
Depth

Use these two dimensions to determine the size of the astragal flange or depth (enter zero 
to display without an astragal flange); enabled if Swing Bi-part is selected in the 
Configuration field on the General pane

Parameter Description

Leaf Select the desired leaf type
Solid
Thickness Enter the thickness of the door slab
Top Rail Width Enter the width of the top door rail
L/R Stile Width Enter the width of the left and right stile
Bottom Rail Width Enter the width of the bottom door rail
Vertical/Horizontal 
Panels

Enter the number of vertical/horizontal panels in the door

Mid Stile Width Enter the width of any interim stiles
Set Top Panel Height Select to make the top door panel a different height than the other panels and specify the 

desired Panel Height
Glass The Glass leaf type enables the options specific to glass doors on this pane, such as 

Muntin Style; it does not make the door leaves render as transparent glass. To make 
the glass render properly, apply a Glazing class on the Classes pane.

Thickness Enter the thickness of the door slab
Top Rail Width Enter the width of the top door rail
L/R Stile Width Enter the width of the left and right stile
Bottom Rail Width Enter the width of the bottom door rail
Muntin Style Select the muntin style 
Vertical/Horizontal 
Bars

Enter the number of vertical/horizontal muntin bars

Bar Width/Depth Enter the muntin bar width/depth
Panel
Thickness Enter the thickness of the door slab
Top Rail Width Enter the width of the top door rail

Parameter Description

Astragal 
Depth

Astragal
Flange
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Door Settings: Lights Pane
Lights options are not enabled for the Opening Configuration.
Click to show/hide the parameters.

Door Settings: Transom Pane
Transom options are not enabled for the Opening Configuration. 
Click to show/hide the parameters.

L/R Stile Width Enter the width of the left and right stile
Bottom Rail Width Enter the width of the bottom door rail
Vertical/Horizontal 
Panels

Enter the number of vertical/horizontal panels in the door

Mid Stile Width Enter the width of any interim stiles
Set Top Panel Height Select to make the top door panel a different height than the other panels and specify the 

desired Panel Height

Parameter Description

Include Sidelights Select to include sidelights 
Left/Right Width Enter the left/right sidelight width
Sash Width Enter the sidelight and transom sash width
Sash Depth Enter the sidelight sash depth
Mullion Width Enter the sidelight mullion width
Mullion Depth Enter the sidelight mullion depth

Include Muntins Select whether to add muntins to the sidelights
Style Select the sidelight muntin style
Vertical/Horizontal 
Bars

Enter the number of vertical/horizontal muntin bars 

Bar Width Enter the sidelight muntin bar width

Parameter Description

Sash Width Enter the transom sash width
Sash Depth Enter the transom sash depth
Mullion Width Enter the transom mullion width
Mullion Depth Enter the transom mullion depth
Include Muntins Select whether to add muntins to the transom

Style Select the transom muntin style
Vertical/Horizontal 
Bars

Enter the number of vertical/horizontal muntin bars 

Parameter Description
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Door Settings: Trim Pane
Trim options are not enabled for the Opening Configuration.
Click to show/hide the parameters.

Door Settings: Hardware Pane
Hardware options are not enabled for the Opening Configuration.
Click to show/hide the parameters.

Door Settings: Kick Plates Pane
Kick Plates options are not enabled for the Opening Configuration or for curtain wall doors.
Click to show/hide the parameters.

Door Settings: Interior Wall Detail Pane
Click to show/hide the parameters.

Bar Width Enter the transom muntin bar width
Bar Offset Enter the muntin bar offset for Prairie muntins

Parameter Description

Include Interior/
Exterior Trim

Select whether to include interior/exterior trim

Width/Depth Enter the interior/exterior trim width and depth

Parameter Description

Include Hardware Select to include a door hardware set with the door object; see “Assigning, Creating, 
Editing, and Deleting Door Hardware Sets” on page 629. 

View Hardware Click to open the View Door Hardware Set dialog box to view the parameters for the 
currently selected door hardware set; click OK to return to the Door Settings dialog box

Manage Hardware Click to open the Door Hardware Library dialog box to assign, create, edit, or delete door 
hardware sets

Parameter Description

Interior/Exterior Kick 
Plate

Select to include a kick plate on either side of the leaf

Height Set the height of the kick plate
While the height is variable, the kick plate’s distance from the right, left and bottom 
edges of the door is a fixed value of one inch/25.4 mm.

Class Select a class to control visibility. The classes present in the drawing are listed; 
alternatively, create a new class. Select the default door class to place the part in the same 
class as the door object.

Parameter Description
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Door Settings: Exterior Wall Detail Pane
Click to show/hide the parameters.

Door Settings: Classes Pane
The visibility of the overall 3D door is controlled by the Class setting on the Object Info palette; part settings are 
controlled from the Door Settings dialog box.
Click to show/hide the parameters.

Parameter Description

Number of 
Components

Specify the number of interior wall components to wrap; when interior wall components 
are specified, the door enables a control point to set the wrapping point

Splay Wall Select whether to splay the interior wall; the splay can be specified either as an angle/
diagonal or with width and depth values

(1) Angle Enter the interior wall splay angle
(2) Diag Enter the interior wall splay diagonal value
(3) Width Enter the interior wall splay width
(4) Depth Enter the interior wall splay depth

Parameter Description

Number of 
Components

Specify the number of exterior wall components to wrap; when exterior wall components 
are specified, the door enables a control point to set the wrapping point

Splay Wall Select whether to splay the exterior wall; the splay can be specified either as an angle/
diagonal or with width and depth values

(1) Angle Enter the exterior wall splay angle
(2) Diagonal Enter the exterior wall splay diagonal value
(3) Width Enter the exterior wall splay width
(4) Depth Enter the exterior wall splay depth

Interior control 
point

Exterior
control

point
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Door Settings: Data Pane
Certain data fields represent calculated values and cannot be edited; as a result, the Field Name and Field Value appear 
dimmed for those data fields.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Doors
Inserting Doors in Vectorworks Design Series
Door Properties
Door Terminology Specific to the United Kingdom
Editing Symbols in Walls

Inserting Doors in Vectorworks Design Series

To insert a door in Vectorworks Design Series:

1. Select the Door tool from the Building Shell tool set.
Alternatively, if placing a curtain wall door into a curtain wall (Vectorworks Architect or Landmark required), 
select a panel with the Edit Curtain Wall tool, and then right-click (Windows) or Ctrl-click (Mac) on the panel 
and select Insert Door from the context menu. The door is automatically inserted as a curtain wall door.

2. If this is the first time a door is inserted into the drawing, or if you wish to change the default preferences that 
apply to subsequently placed doors, click Preferences from the Tool bar. 
The Door Settings dialog box opens. The settings are grouped into several panes of related parameters, which are 
listed on the left side of the dialog box. Select each pane and specify the door parameters. Click OK to set the door 
parameters and close the dialog box. These parameters can be edited for placed doors from the Object Info palette, 
as described in “Door Properties” on page 631.

Parameter Description

Door parts Select a class for each door part to control its visibility. The classes present in the drawing 
are listed; alternatively, create a new class. Select the door class to place the part in the 
same class as the door object.

The Architect and Landmark products have a more comprehensive list of door parts 
available to be assigned a class.
For doors with an Opening Configuration, in a 3D view a no fill/no pen weight 
extrude completely fills the wall in place of the door; this extrude is placed in the 
Interior Jamb class. Change the class settings to control the visibility of the extrude, 
as needed

Parameter Description

Field Name Select the data field from the list and its name displays beneath the list; information 
associated with the Field Name can be specified in the Field Value area. The user fields 
can include additional user-defined information with the door. 

Field Value Enter data for use in the door schedule
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3. Click in the drawing area or in a wall to set the insertion point of the door, and click again to set the rotation. The 
direction of a door inserted in a wall can be changed later by clicking Flip on the Object Info palette or from the 
context menu.
Several features of the door are described as “interior” or “exterior.” These include trim and wall-wrap parts. 
These elements are determined based on the internal and external faces of the wall. The left side of the wall (as 
viewed along the wall direction) is always “exterior,” and the right side is “interior” (see “Wall Direction” on 
page 506). Flipping the door does not flip these elements.

Door Settings: Preview
Click to show/hide the parameters.

Door Settings: General Pane
Click to show/hide the parameters.

Parameter Description

3D Preview Dynamically displays a 3D preview of the door with the currently selected parameters
View Select the standard view for the 3D preview of the door
Render Select the render mode for the 3D preview of the door

Top/Plan Preview Dynamically displays a Top/Plan preview of the door with the currently selected 
parameters

Parameter Description

Size Reference Select the appropriate option to define the door width and height; the Size Reference 
selection automatically updates the Width and Height fields, but does not change the size 
of the door:
• Leaf Size - this represents the door width and height that measures to the inside of the 

jamb, excluding the jamb, transom, and sidelights; this is the default setting for 
imperial units

• Unit Size - this represents the current overall door width and height that measures to 
the outside of the jamb, including the jamb, transom, and sidelights

• Rough Opening - this represents the current overall door width and height that 
measures to the outside of the jamb, including the jamb, transom, sidelights, and shim 
gap (for the Opening Configuration, the Size Reference is automatically changed to 
Rough Opening); this is the default setting for metric units

Vectorworks Architect or Landmark product required for Unit Size and Rough 
Opening.

Width/Height The width/height of the door is measured based on the Size Reference selection:
• Leaf size - width/height of the door leaf is measured at the inside of the jamb
• Unit Size - width/height is measured at the outside of the jamb
• Rough Opening - width/height measures the rough opening
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Door Settings: 2D Visualization Pane
Click to show/hide the parameters.

Use Symbol 
Geometry

Select Use Symbol Geometry and click Browse to select a door symbol from the current 
file’s resources. Select a symbol from the graphical list of Symbols and click OK.
The symbol Name displays in the Door Settings dialog box and the preview is updated 
with the selected symbol.

When a symbol is selected, all fields pertaining to the door’s geometry are 
disregarded; however, parametric values are still available for scheduling and 
reporting purposes only.

Top Shape Select the shape of the top of the door
Transom Select whether to add a transom above the door; transom parameters are set from the 

Transom pane
Rise Enter the distance between the start of the top shape to the top of the door (not applicable 

for Square and Round Top Shape)
Spring Enter the distance traveled above the floor before the Top Shape begins
Offset in Wall Enter the distance to offset the door insertion point from the centerline of the wall
Configuration Select the general door configuration. To create a simple opening in a wall for defining a 

door break without creating any geometry to represent the door, select the Opening option 
(Vectorworks Architect or Landmark required). Depending on the selection, a variety of 
door settings are enabled or disabled automatically, as described in the following sections. 

Operation Select the advanced operation for a sliding or complex swing door, where “O” represents 
a fixed door and “X” represents an operating door

Unequal Leaf
(Vectorworks 
Architect or 
Landmark required)

For bi-part and double acting configurations, select this option to insert a door with leaves 
of unequal widths

Width Leaf 1/2 When Unequal Leaf is selected, enter the width of the first door leaf; the width of the 
second door leaf is calculated automatically and displayed in as the Width Leaf 2 value

Curtain Wall Door 
(Vectorworks 
Architect or 
Landmark required)

Indicates that the door will be placed in a curtain wall, where its width and height are 
based on the surrounding frames where it is placed. A curtain wall door does not have as 
many available parameter options as a standard door. Configurations are limited to those 
that apply to curtain wall placement.

Parameter Description

Show Plan Detail Select to display all the door details in Top/Plan view
Draw Wall Lines Select whether to draw wall lines at all times; wall lines are drawn in the Ceiling-Main 

class to easily create reflected ceiling plans

Parameter Description
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Door Settings: 3D Visualization Pane
3D Visualization options are not enabled for the Opening Configuration.
Click to show/hide the parameters.

Door Settings: ID Tag Pane
Click to show/hide the parameters.

Set Attributes By Select whether to set the 2D graphic attributes and visibility of the listed door parts by 
Object, Line Style, or Class. 

• Object: disables line style and weight controls for individual parts, and uses the line 
style and weight settings for the door object.

• Line Style: controls line style and weight for the individual parts; these settings 
override the door object’s settings.

• Class: sets the line style and weight of individual parts by class. Select a class for 
each part to control its visibility and appearance. The classes present in the drawing 
are listed; alternatively, create a new class. Select the door class to place the part in 
the same class as the door object.

Visibility Classes
(Vectorworks 
Architect or 
Landmark required)

Select a class for each listed part to control its visibility and appearance. The classes 
present in the drawing are listed; alternatively, create a new class. Select the door class to 
place the part in the same class as the door object.

Parameter Description

3D Hinge Direction 
Marker

Select to draw lines representing the 3D hinge direction

Show Interior/
Exterior Marker

Select to draw lines representing the hinge direction of the door leaves on the interior/
exterior side of the door in 3D

Use Hinge Marker 
Class Attributes

Select to set the hinge direction marker’s attributes by class

Hinge Direction 
Marker Class

Select a class to control visibility and, if Use Hinge Marker Class Attributes is selected, 
appearance. The classes present in the drawing are listed; alternatively, create a new class. 
Select the default door class to place the part in the same class as the door object.

Marker Points 
Towards

Set the hinge direction marker to point toward the hinge or toward the handle

Draw 3D Open Select to draw 3D doors as open at the specified Open Angle
3D Detail Level Select the level of detail to include for 3D doors.

In Low and Medium settings, some door details are not drawn in 3D views; these 
settings simplify the appearance for viewing the drawing at a small scale.

Parameter Description

Include on Schedule Select whether to include this door’s information in the door schedule and also set the 
door ID tag to visible; see “Creating Door Schedules or Worksheets” on page 631

Parameter Description
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ID Prefix Assigns alphanumeric information before the numerical label value; adding prefix 
information is optional

ID Label Assigns a numerical value to the ID; this number increments automatically if the 
auto-increment option is chosen in the ID Settings dialog box (see “Using the ID Label 
Tool” on page 1262)

ID Suffix Assigns alphanumeric information after the label value; adding suffix information is 
optional

ID Class Select a class to control visibility and, if Use ID Class Attributes is selected, appearance. 
The classes present in the drawing are listed; alternatively, create a new class. Select the 
default door class to place the part in the same class as the door object.

Use ID Class 
Attributes

Select to use the ID class attributes for the bubble line, leader line, and leader line marker

Keep ID Horizontal When selected, automatically rotates the ID so that it is horizontal
Bubble Shape Select the ID tag bubble shape
Bubble Size Enter the minimum bubble size (this value represents the bubble size times the layer 

scale; the bubble shape is maintained relative to the text inside it for ID bubble uniformity 
throughout the drawing file)

Bubble Line 
Attributes

Select the bubble line attributes and weight, or select Set Thickness to open the Set 
Thickness dialog box for creating a custom line thickness

Show Leader Select to draw a leader line from the ID tag to the door object
Line Attributes Select the leader line attributes and weight, or select Set Thickness to open the Set 

Thickness dialog box for creating a custom line thickness
Include Marker Select whether to include a marker for the ID leader line and choose the desired style 

from the marker list, or select Custom to create a custom marker. Select Edit Marker 
List to open the Edit Marker List dialog box; see “Editing the Marker List” on page 1103.

Show Tag in 3D View
(Vectorworks 
Architect or 
Landmark required)

Select to display the ID tag in 3D views

Horizontal Offset Enter the horizontal offset of the 3D ID tag relative to the bottom left corner of the rough 
opening when looking at the exterior side of the door (a positive value moves the tag 
inside the opening relative to the starting corner; a negative value moves the tag outside 
the opening relative to the starting corner)

The ID tag is offset slightly from the outside face of the door leaf. The size and shape 
of the text and bubble, if present, will match the plan settings, and the text will 
always be right reading from the outside of the wall. The bubble will scale with text 
scaling in viewports.

Vertical Offset Enter the vertical offset of the 3D ID tag relative to the bottom left corner of the rough 
opening when looking at the exterior side of the door (a positive value moves the tag 
inside the opening relative to the starting corner; a negative value moves the tag outside 
the opening relative to the starting corner)

Parameter Description



  622 | Inserting Doors in Vectorworks Design Series
Door Settings: Jamb Pane
Jamb options are not enabled for the Opening Configuration or for curtain wall doors.
Click to show/hide the parameters.

Door Settings: Leaf Pane
Leaf options are not enabled for the Opening Configuration.
Click to show/hide the parameters.

Parameter Description

Width Enter the face width of the door jamb (parallel to the wall)
Depth Enter the depth of the door jamb (perpendicular to the wall)
Use Wall Depth Select to set the jamb depth to the overall wall depth
Use Jamb Extension
(Vectorworks 
Architect or 
Landmark required)

Select this field to specify a jamb extension to fill any gap between the interior face of the 
jamb and the interior face of the wall; enter the desired Jamb Extension Width 

In 2D views, extensions use the Jamb line styles and weights; in 3D views, the 
extension fill color and/or textures and visibility are controlled by the Int. Jamb 
class.

Shim Gap Enter the distance between the jamb exterior face and the rough opening (for the Opening 
Configuration, the Shim Gap is automatically set to 0)

Show Shim Gap in 
Plan
(Vectorworks 
Architect or 
Landmark required)

Select whether to display the shim gap in Top/Plan view

Masonry Module Enter the masonry module dimension
Astragal Flange / 
Depth

Use these two dimensions to determine the size of the astragal flange or depth (enter zero 
to display without an astragal flange); enabled if Swing Bi-part is selected in the 
Configuration field on the General pane

Parameter Description

Leaf Select the desired leaf type
Solid
Thickness Enter the thickness of the door slab
Include Vision Panels
(Vectorworks 
Architect or 
Landmark required)

Select to include vision panel(s)

Astragal 
Depth

Astragal
Flange
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Vision Panel Shape Select the shape of the vision panel(s)
Bottom Offset Enter an offset value, measured from the bottom of the leaf to the bottom of the lowest 

vision panel
Right Offset Enter an offset value, measured from the edge of the leaf to the nearest edge of the vision 

panel.
For the most common door configurations, this parameter is measured from the 
unhinged edge of the leaf, which is the right edge in Vectorworks’ default front view 
in the 3D preview. However, with some of the more complex, multi-part door 
configurations, the offset is measured from different points to provide correct 
alignment of vision panels. Consult the 3D Preview to confirm the appearance.

Panel Height/
Width

Enter the height/width of the individual vision panel(s)
Panel Width is enabled only for the rectangle and oval vision panel shapes. For 
square and round, the width is automatically set equal to the height.

Number of Panels Enter the number of vision panels
Separation For leafs with more than one vision panel, enter the vertical offset between panels
Set Top Panel 
Height

For leafs with more than one vision panel, select to make the top vision panel a different 
height than the other panels and specify the desired Panel Height

Add Vision Panels 
to Unequal Leaf

For doors with an unequal leaf, select to include vision panels with the same parameters 
on the smaller leaf as well as the main leaf.

Glass The Glass leaf type enables the options specific to glass doors on this pane, such as 
Muntin Style; it does not make the door leaves render as transparent glass. To make 
the glass render properly, apply a Glazing class on the Classes pane.

Thickness Enter the thickness of the door slab
Top Rail Width Enter the width of the top door rail
L/R Stile Width Enter the width of the left and right stile
Bottom Rail Width Enter the width of the bottom door rail
Muntin Style Select the muntin style 
Vertical/Horizontal 
Bars

Enter the number of vertical/horizontal muntin bars

Bar Width Enter the muntin bar width
Bar Depth
(Vectorworks 
Architect or 
Landmark required)

Enter the muntin bar depth

Bar Offset
(Vectorworks 
Architect or 
Landmark required)

Enter the muntin bar offset for Prairie muntins

Panel
Thickness Enter the thickness of the door slab
Top Rail Width Enter the width of the top door rail

Parameter Description
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Door Settings: Lights Pane
Lights options are not enabled for the Opening Configuration or for curtain wall doors.
Click to show/hide the parameters.

L/R Stile Width Enter the width of the left and right stile
Bottom Rail Width Enter the width of the bottom door rail
Vertical/Horizontal 
Panels

Enter the number of vertical/horizontal panels in the door

Mid Stile Width Enter the width of any interim stiles
Set Top Panel Height Select to make the top door panel a different height than the other panels and specify the 

desired Panel Height
Single Top Panel
(Vectorworks 
Architect or 
Landmark required)

Select to specify only one panel across the top of the leaf, regardless of the number of 
panels below

Glazing in Top Panels 
(Vectorworks 
Architect or 
Landmark required)

Select to insert glazing in the top panel(s)

Muntin Style Select the muntin style 
Vertical/Horizontal 
Bars

Enter the number of vertical/horizontal muntin bars

Bar Width/Depth Enter the muntin bar width/depth
Bar Offset Enter the muntin bar offset for Prairie muntins

Custom
(Vectorworks 
Architect or 
Landmark required)
Thickness Enter the thickness of the door slab
Custom Leaf Select the leaf type from the default content; see “Resource Libraries” on page 219. 

Custom leaves must be 3D-only symbols made from generic solids, saved in the 
default content location. 

Parameter Description

Include Sidelights Select to include sidelights 
Left/Right Width Enter the left/right sidelight width
Sash Width Enter the sidelight and transom sash width
Sash Depth Enter the sidelight sash depth
Mullion Width Enter the sidelight mullion width
Mullion Depth Enter the sidelight mullion depth

Parameter Description



Inserting Doors in Vectorworks Design Series |  625
Door Settings: Threshold Pane
Vectorworks Architect or Landmark product required. Threshold options are not enabled for the Opening 
Configuration.
Click to show/hide the parameters.

Door Settings: Transom Pane
Transom options are not enabled for the Opening Configuration or for curtain wall doors. 
Click to show/hide the parameters.

Include Muntins Select whether to add muntins to the sidelights
Style Select the sidelight muntin style
Vertical/Horizontal 
Bars

Enter the number of vertical/horizontal muntin bars 

Bar Width Enter the sidelight muntin bar width
Bar Depth
(Vectorworks 
Architect or 
Landmark 
required)

Enter the sidelight muntin bar depth

Bar Offset
(Vectorworks 
Architect or 
Landmark 
required)

Enter the muntin bar offset for Prairie muntins

Parameter Description

Include Threshold Select whether to include a threshold 
(1) Depth (Int)/(2) 
Depth (Ext)

Enter the interior and exterior threshold depth

(3) Overall Depth Enter the overall threshold depth
(4) Offset Enter how far to offset the threshold from the center of the door jamb
(5) Thickness Enter the threshold thickness
(6) Nosing Enter the threshold nosing height
Threshold Under 
Leaf

Select to limit the threshold to under the leaf; otherwise, to extend the threshold beyond 
the inside of the jamb, enter the desired Extension width (this amount is applied to each 
side of the threshold, and negative values are not permitted)

Parameter Description

Sash Width Enter the transom sash width
Sash Depth Enter the transom sash depth
Mullion Width Enter the transom mullion width

Parameter Description
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Door Settings: Trim Pane
Trim options are not enabled for the Opening Configuration or for curtain wall doors.
Click to show/hide the parameters.

Door Settings: Lintel Pane
Vectorworks Architect or Landmark product required. Lintel options are not enabled for the Opening Configuration or 
for curtain wall doors.
Click to show/hide the parameters.

Door Settings: Hardware Pane
Hardware options are not enabled for the Opening Configuration.
Click to show/hide the parameters.

Mullion Depth Enter the transom mullion depth
Include Muntins Select whether to add muntins to the transom

Style Select the transom muntin style
Vertical/Horizontal 
Bars

Enter the number of vertical/horizontal muntin bars 

Bar Width Enter the transom muntin bar width
Bar Depth
(Vectorworks 
Architect or 
Landmark 
required)

Enter the transom muntin bar depth

Bar Offset Enter the muntin bar offset for Prairie muntins

Parameter Description

Include Interior/
Exterior Trim

Select whether to include interior/exterior trim

Width/Depth Enter the interior/exterior trim width and depth

Parameter Description

Include Lintel Select to add a lintel above the door or transom 
Int. / Ext. 
Protrusion

Enter the interior and exterior lintel protrusion 

(1)Thickness Enter the lintel thickness
(2)Angle Enter the lintel angle
(3)Drop Enter the length of the lintel drop

Parameter Description
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Door Settings: Kick Plates Pane
Kick Plates options are not enabled for the Opening Configuration or for curtain wall doors.
Click to show/hide the parameters.

Door Settings: Centerline Marker Pane
Vectorworks Architect or Landmark product required. Centerline markers options are not enabled for curtain wall 
doors.
Click to show/hide the parameters.

Parameter Description

Include Hardware Select to include a door hardware set with the door object; see “Assigning, Creating, 
Editing, and Deleting Door Hardware Sets” on page 629.

View Hardware Click to open the View Door Hardware Set dialog box to view the parameters for the 
currently selected door hardware set; click OK to return to the Door Settings dialog box

Manage Hardware Click to open the Door Hardware Library dialog box to assign, create, edit, or delete door 
hardware sets

Parameter Description

Interior/Exterior Kick 
Plate

Select to include a kick plate on either side of the leaf

Height Set the height of the kick plate
While the height is variable, the kick plate’s distance from the right, left and bottom 
edges of the door is a fixed value of one inch/25.4 mm.

Class Select a class to control visibility. The classes present in the drawing are listed; 
alternatively, create a new class. Select the default door class to place the part in the same 
class as the door object.

Parameter Description

Centerline Marker Select to display a centerline marker in Top/Plan view.
Size Set the size of the centerline
Class Select a class to control visibility. The classes present in the drawing are listed; 

alternatively, create a new class. Select the default door class to place the part in the same 
class as the door object.

Line Attributes Select the line attributes and weight, or select Set Thickness to open the Set Thickness 
dialog box for creating a custom line thickness. If Use Class Attributes is selected, the 
line attributes are set by the part’s class

Include Marker Select whether to include a marker and choose the desired style from the marker list, or 
select Custom to create a custom marker. Select Edit Marker List to open the Edit 
Marker List dialog box; see “Editing the Marker List” on page 1103. If Use Class 
Attributes is selected, the marker attributes are set by the part’s class.

Use Class 
Attributes

Select to set the centerline marker’s attributes (including marker style) by class rather 
than the parameters in the Door Settings dialog box
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Door Settings: Interior Wall Detail Pane
Interior wall detail options are not enabled for curtain wall doors.
Click to show/hide the parameters.

Door Settings: Exterior Wall Detail Pane
Exterior wall detail options are not enabled for curtain wall doors.
Click to show/hide the parameters.

Show Centerline 
Marker on Larger 
Leaf

For bipart swing doors with leafs of unequal size, select to center the line on the larger 
leaf instead of the opening

Parameter Description

Number of 
Components

Specify the number of interior wall components to wrap; when interior wall components 
are specified, the door enables a control point to set the wrapping point

Splay Wall Select whether to splay the interior wall; the splay can be specified either as an angle/
diagonal or with width and depth values

(1) Angle Enter the interior wall splay angle
(2) Diag Enter the interior wall splay diagonal value
(3) Width Enter the interior wall splay width
(4) Depth Enter the interior wall splay depth

Parameter Description

Number of 
Components

Specify the number of exterior wall components to wrap; when exterior wall components 
are specified, the door enables a control point to set the wrapping point

Splay Wall Select whether to splay the exterior wall; the splay can be specified either as an angle/
diagonal or with width and depth values

(1) Angle Enter the exterior wall splay angle

Parameter Description

Interior control 
point

Exterior
control

point
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Door Settings: Classes Pane
The visibility of the overall 3D door is controlled by the Class setting on the Object Info palette; part settings are 
controlled from the Door Settings dialog box.
Click to show/hide the parameters.

Door Settings: Data Pane
Certain data fields represent calculated values and cannot be edited; as a result, the Field Name and Field Value appear 
dimmed for those data fields.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Doors
Inserting Doors in Vectorworks Fundamentals
Door Properties
Creating Door Schedules or Worksheets
Door Terminology Specific to the United Kingdom

Assigning, Creating, Editing, and Deleting Door Hardware Sets
A door hardware set can be assigned to the door, and a door operator device (such as a knob or lever) can be selected to 
display on the 3D door from default content.

(2) Diagonal Enter the exterior wall splay diagonal value
(3) Width Enter the exterior wall splay width
(4) Depth Enter the exterior wall splay depth

Parameter Description

Door parts Select a class for each door part to control its visibility. The classes present in the drawing 
are listed; alternatively, create a new class. Select the door class to place the part in the 
same class as the door object.

The Architect and Landmark products have a more comprehensive list of door parts 
available to be assigned a class.
For doors with an Opening Configuration, in a 3D view a no fill/no pen weight 
extrude completely fills the wall in place of the door; this extrude is placed in the 
Interior Jamb class and is filtered out in IFC export operations. Change the class 
settings to control the visibility of the extrude, as needed

Parameter Description

Field Name Select the data field from the list and its name displays beneath the list; information 
associated with the Field Name can be specified in the Field Value area. The user fields 
can include additional user-defined information with the door. 

Field Value Enter data for use in the door schedule

Parameter Description
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To assign, create, edit, or delete a door hardware set:
1. From the Hardware pane of the Door Settings dialog box, select Include Hardware and click Manage 

Hardware. 
The Door Hardware Library dialog box opens for selecting a door hardware set and door operator device.

Click to show/hide the parameters.

If the Door Hardware Library.txt file (in [Vectorworks]\VW_Arch\Data\Prefs_Def) is already in use, the Add and 
Remove buttons on the Door Hardware Library dialog box are disabled and the Edit button changes to a View 
button. A Read Only heading will display in the title bar of the Door Hardware Library dialog box and the Edit 
Door Hardware Set dialog box is also disabled until the file is writable again.

2. Select Edit or Add.
The Edit or Add Door Hardware Set dialog box opens. The Add dialog box is similar to the Edit dialog box except 
that all fields are blank.

Click to show/hide the parameters.

3. Complete each field with the desired information to add a new door hardware set, or edit the desired fields to 
change an existing door hardware set.

4. Click OK, and then click Done to return to the Door Settings dialog box.
The applied information appears in the door hardware legend generated (see “Creating Schedules” on page 1864).

~~~~~~~~~~~~~~~~~~~~~~~~~
Resource Libraries

Parameter Description

Title Bar Displays the name of the current preference set (see “Working with Project Preference Sets” 
on page 1866)

Door hardware set 
list

Lists all defined door hardware sets

Add Creates a new hardware set
Remove Removes the selected hardware set from the library (this action cannot be undone)
Edit Edits the currently selected hardware set

Parameter Description

Description Indicates the name of the door hardware set
Hdw Set ID Indicates the unique ID value assigned to the door HW Set field in the door schedule
Hinge Qty Indicates the number of hinges
Hinge Type Indicates the hinge type
Lockset Type Indicates the lockset type
Closer Type Indicates the closer type
Stop Type Indicates the stop type
Key Code Indicates the key code
Notes Contains any pertinent notes about the door operator device
Symbol List the available door hardware to assign to the door from the default content
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Door Settings: Hardware Pane
Creating Door Schedules or Worksheets

Door Properties
To edit door parameters in the Door Settings dialog box, click Settings from the Object Info palette, double-click the 
door to open the Door Settings dialog box, or right-click (Windows) or Ctrl-click (Mac) on a door and select Edit from 
the context menu. 
When multiple door objects are selected for editing, and if the parameter settings of the selected objects are different, 
parameters display in an “indeterminate state.” Any values changed through the dialog box are changed for all the 
selected objects.
Door objects can also be edited in the Object Info palette. If the door has been inserted as a plug-in object, most settings 
from the Door Settings dialog box display. If the door is a black symbol made from a door object, fields pertaining to 
door geometry do not display. See “Symbol Types” on page 237.
For the Vectorworks Architect and Landmark products, most, but not all, parameters can be edited from both the Door 
Settings dialog box and the Object Info palette for ease of access. The fields in the Object Info palette are named 
similarly (but not always identically) to those in the Door Settings dialog box, and roughly reflect the order in which 
settings are entered in the dialog box, for ease of editing. Curtain wall doors have limited parameter options.
For the Vectorworks Fundamentals and Spotlight products, certain frequently used parameters are available to be edited 
directly in the Object Info palette, and do not necessarily reflect the order in which settings are entered in the dialog 
box. All other parameters are edited only from the Door Settings dialog box.
The door parameters are described in “Inserting Doors in Vectorworks Fundamentals” on page 609 and “Inserting 
Doors in Vectorworks Design Series” on page 617. Only the parameters that are different are described here.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Doors in Vectorworks Fundamentals
Inserting Doors in Vectorworks Design Series
Creating New Symbols
Moving Objects
Door Terminology Specific to the United Kingdom

Creating Door Schedules or Worksheets
In the Vectorworks Architect product, the door schedule and/or door hardware legend can be added to the drawing from 
the VA Create Schedule command (see “Creating Schedules” on page 1864) or the Resource Browser. From the 
Resource Browser, open the default architectural reports file from the [Vectorworks]\Libraries folder that is included 
with the Vectorworks Architect product (see “Resource Libraries” on page 219). Drag the door schedule or door 
hardware legend worksheet to the drawing. The worksheet is populated with information from the objects in the current 
drawing. To edit the worksheet after it has been created, see “Using Worksheets” on page 1319.
Users of the Vectorworks Landmark and Spotlight products can also create the worksheet by creating a report for 
objects with a door record. To create the report from Landmark, select Tools > Reports > Create Report; from 
Spotlight, select Spotlight > Reports > Create Report.

Parameter Description

Flip Click to flip the orientation of doors inserted in a wall
Set Position Click to activate the Move by Points tool in Reference Point mode and move the 

door by a specified distance from a reference point
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~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Doors in Vectorworks Design Series
Door Properties
Moving Objects
Door Terminology Specific to the United Kingdom

Door Terminology Specific to the United Kingdom
Certain door terminology varies in the United Kingdom. The door object is automatically localized in the Vectorworks 
program for users with a United Kingdom serial number; however, since the documentation is not localized, the 
terminology does not match. This table shows how the terms are mapped.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Doors in Vectorworks Fundamentals
Inserting Doors in Vectorworks Design Series

U.S. Term (in Documentation) U.K. Term (in Vectorworks Program)

Transom Fanlight
Rough Opening Structural Opening
Muntins (Leaf, Sidelight, Transom) Glazing Bars
Colonial (Muntin Style) Georgian
Mullion (Transom) Transom Bar
Trim Architraves
Interior Trim Interior Architraves
Exterior Trim Exterior Architraves
Masonry Opening (Data) Nearest Full-Module of Masonry
Door Configurations Door Configurations

Swing Simple Single Leaf
Swing Bi-Part Double Leaf
Pocket Simple Pocket Single
Pocket Bi-Part Pocket Bi-Parting
Bi-Fold Simple Bi-Fold Single
Bi-Fold Bi-Part Bi-Fold Double
Double Acting Double-Swing Double-Leaf

Leaf Types Leaf Types
Solid Flush
Glass Glazed



Stairs
Inserting Stairs
The Vectorworks Fundamentals, Landmark, and Spotlight workspaces include a Simple Stair tool for drawings that do 
not require a complex stair object. The Vectorworks Architect, Landmark, and Designer products include the Stair tool, 
and the workspaces can be edited to add the Simple Stair tool. 
These tools allow you to build a stair with various geometries. The stair is a hybrid object, offering control over the 2D 
plan appearance, as well as the 3D component, for plan and presentation drawings. The Stair tool includes many 
options, details, and configurations, and performs many stair design chores automatically.

The Stair tool provides a set of common configurations (straight, L-shaped, U-shaped, O-shaped, and circular). It 
allows the creation of “styles” from sets of parameters controlling groups of geometry and display attributes, to be 
saved and recalled for use in other stair instances. The stair can be set to determine its own floor-to-floor height based 
on the layers the stair connects, and can take advantage of a project set up with stories. The stair can have separate 
lower floor and upper floor graphical representations. This avoids having to draw stairs on two different layers, and edit 
them separately, to completely represent the same physical staircase. Stair break options can be set differently on each 
layer, to get exactly the desired look in Top/Plan view. The entire stair configuration can be saved as a symbol, to be 
used again or shared with others, establishing a library of stair standards. Stair parameters can also be copied from one 
stair to another. While the geometric variation of the stair is restrained, the control over 2D and 3D graphic attributes is 
high. Stairs can be created as 2D only objects or as hybrid objects.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Simple Stair
Creating a Stair
Transferring Stair Properties

Creating a Simple Stair
A simple stair object is available to add a basic stair representation to the drawing in the Vectorworks Fundamentals, 
Landmark, and Spotlight workspaces. Vectorworks Architect, Landmark, and Designer products contain a more 
advanced stair tool for designs that require complex, detailed stairs (see “Inserting Stairs” on page 633).

To insert a simple stair:

1. Click the Simple Stair tool from the appropriate tool set:
• Fundamentals workspace: Wall tool set
• Landmark and Spotlight workspaces: Building Shell tool set

2. Click to place the simple stair in the drawing, and click again to set the stair’s rotation. If this is the first time a 
stair is placed in the drawing, the stair object properties dialog box opens. Set the parameters, which apply to 
subsequently created stairs.
The stair parameters can also be edited from the Object Info palette.
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Click to show/hide the parameters.

Parameter Description

Style Select the stair style: standard, indented, open riser, or masonry
Width Specifies the width of the staircase
Flr-Flr Height Specifies the height of the staircase from floor to floor
Max Riser Indicates the horizontal maximum thickness of the riser
Tread Depth/Height Sets the tread depth (front to back) and the tread height
Nosing Depth Specifies the nosing depth
Config Select the stair configuration: straight, straight with a landing, left and right landings, and 

left and right double-back stairs with landings (even and irregular)
Landing Tread Indicates how many steps occur before the landing (does not apply to even double back 

stairs)
Separation For double back style stairs, sets the separation distance between the flights
Offset 1/2 For stairs with landings, indicates the distance to offset the landing from the stairs on 

each side of the landing
Curved Landing Creates curved landings; the radius matches the stair width
Stringer Width/Offset Sets the stringer width (thickness) on each side of the stair, and specifies the distance 

between the outside of the stair tread to the outside of the stringers
Draw Lower Stair 
Break

Hides a portion of the stair with a stair break, so that the lower portion of the stair can be 
displayed in 2D

Show Data Select to display the number of risers and riser height along with the path-of-travel 
arrow; an Up or Down arrow must be selected in Arrows for stair data to be displayed 

Draw Top Tread Specify whether the stair should include a tread at the same level as the upper floor it 
serves

Create 3D Creates a 3D version of the stair to display in views other than Top/Plan
Left/Right Rail Adds handrails to the left and right of the staircase
Rail Height/Width Sets the height and width for the railing(s)
Arrows Select whether to display the path-of-travel arrow, and in which direction
Step/Rail/Stringer 
Finish

Select the Class to assign to the steps, railing(s), and stringers
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Creating a Stair
The Stair tool is available in the Vectorworks Architect, Landmark, and Designer workspaces. If the stair will have a 
lower layer and upper layer representation, or if its total rise will be defined by layer or story elements, it should be 
inserted on the layer representing the lower of the two floors it connects.

To insert a stair:

1. Click the Stair tool from the Building Shell tool set.
Five modes are available.

2. Select Insert mode and then click Preferences from the Tool bar before placing the stair to set the default stair 
parameters. Click OK to set the stair parameters and close the Stair Settings dialog box.
Alternatively, insert the default stair and then click Settings from the Object Info palette, or simply double-click 
on an existing stair, to set the stair parameters.

3. When the stair configuration parameters on each tab are set, consider whether to save the stair as a symbol.

Mode Description

Insert Inserts a stair with the parameters specified in Preferences
Pick up Picks up selected attributes from a stair to be transferred to another stair; attributes are 

selected in the stair preferences
Apply Transfers selected attributes from one stair to another; attributes are selected in the stair 

preferences and picked up in Pick up mode.
Update Updates all stairs in the drawing, which is necessary when layer scale has changed and a 

change to the stair’s schematic representation is also required
Preferences Opens the Stair Settings dialog box, to set default stair parameters

Insert

Pick up

Preferences

Update

Apply 
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If the same customized stair is to be used numerous times in a drawing, or will be used in another drawing or by 
another designer, this eliminates the need to repeatedly apply parameters, maximizes memory efficiency, and 
allows global editing of symbols. See “Creating New Symbols” on page 239.
If you don’t wish to create a symbol, the stair attributes can easily be transferred. 

4. Click in the drawing to insert the stair. Click again to set the stair’s rotation.
To edit stair parameters for a placed stair, click Settings from the Object Info palette, double-click the stair to open the 
Stair Settings dialog box, or right-click (Windows) or Ctrl-click (Mac) on a stair and select Edit from the context menu. 
Depending on the stair settings, certain parameters are available directly from the Object Info palette.
Each tab of the stair parameters is described in the following sections. As the parameters are defined, the preview 
dynamically displays the stair appearance. 

• “Stair Settings: General Tab” on page 636
• “Stair Settings: Geometry Tab” on page 638
• “Stair Settings: 2D Graphics Tab” on page 644
• “Stair Settings: Construction Tab” on page 648
• “Stair Settings: Railings Tab” on page 650
• “Stair Settings: Graphic Attributes Tab” on page 654
• “Transferring Stair Properties” on page 660

~~~~~~~~~~~~~~~~~~~~~~~~~
Managing Stair Styles
Saving a Stair as a Symbol
Setting Minimum and Maximum Values for Stair Geometry Parameters
Stair Properties
Transferring Stair Properties
Inserting Stairs

Stair Settings: General Tab
1. Click the General tab to set the stair configuration.

Select a predefined configuration as the basis for the new stair. The general configuration can be based on either 
pre-defined default content symbols, custom default files in the user folder, a saved symbol in the current file, or 
by selecting a typical stair configuration.
• From the Symbol Selection list, select an initial stair configuration from the current file, custom defaults, or 

from the standard configurations. Once a selection has been made, a symbol selection list allows the symbol or 
predefined symbol to be selected from the file, custom, or default content (see “Resource Libraries” on 
page 219).

• Click Select Standard Configuration to select an initial stair configuration that most closely matches the type 
of stair to create. The Select a Stair Configuration dialog box opens; select one of the configurations. If there 
are any current stair parameters that should be saved and transferred to the new stair, select the category or 
categories from Transfer settings from current stair.

When the stair configuration has been selected, the available parameters on the tabs change to reflect the selection.
2. Once the initial configuration has been selected, change parameters as necessary to define the stair.

Minimum and maximum value ranges can be set for the stair angle, tread depth, riser height, and step length.
Click to show/hide the parameters.
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3. If you switch to another stair configuration after making parameter changes on any tab, the New Stair dialog box 
opens.
Switching to a new configuration loses any parameter settings that have already been made. The settings from the 
current stair configuration can be transferred to the new stair if needed. Select the settings to transfer, or click All 
to select all settings and None to deselect all the settings.

~~~~~~~~~~~~~~~~~~~~~~~~~
Stair Settings: Geometry Tab

Parameter Description

General Settings
Component Select whether to create a 2D only or hybrid 2D/3D object
Class Select a class for the stair. The classes present in the drawing are listed; alternatively, 

create a new class by selecting New, select the currently active class, or select a default 
class name. 

Orientation For stairs with oblique/winder treads, specifies the side of the stair with the shortest 
tread depth; for L- and U-Stairs, determines the direction of travel

General Geometry Specify overall parameters for the stair configuration. These general parameters can be 
set here or on the Geometry tab.
Values entered here are also set on the Geometry tab. For stairs with multiple flights, the 
Stair Width value entered on the General tab is applied to all flights on the Geometry 
tab.

Lock button For any parameter, locks the parameter value, forcing the other parameters to recalculate 
to automatically adjust

Preview Displays a preview of the current stair configuration
Preview for Select either a detailed or schematic view for the preview
Stair detail status
(in parentheses)

Stair details may be hidden at certain layer scales, depending on the detail display 
setting on the Display tab of the document preferences (see “Document Display 
Preferences” on page 60).
Depending on the setting, the status indicates whether stair details will display for stairs 
in the drawing, or shows the scale required for the details to display.

View Select a view for the preview from the list of standard views; 3D views are not available 
for a 2D only stair

Render Mode Select a render mode for the preview from the list of available modes
Calculate Forces the stair object the recalculate based on the current set of parameter values
Previous Stair Loads the parameter values of the most recently created stair
Save as Symbol Creates a symbol based on the current settings
Use Minimum/
Maximum Values

Enables the use of minimum/maximum settings.
Normally, this option should be enabled to create stairs with valid proportions and 
settings that meet standard requirements. However, during the initial design phase, it 
may be convenient to temporarily disable the settings while exploring various geometry 
and design possibilities.

Edit Opens the Min./Max. Settings dialog box
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Stair Settings: 2D Graphics Tab
Stair Settings: Construction Tab
Stair Settings: Railings Tab
Stair Settings: Graphic Attributes Tab
Managing Stair Styles
Saving a Stair as a Symbol
Setting Minimum and Maximum Values for Stair Geometry Parameters
Stair Properties
Transferring Stair Properties
Creating a Stair
Inserting Stairs

Stair Settings: Geometry Tab
1. Click the Geometry tab to set both basic and detailed stair geometry based on the configuration selected on the 

General tab. The geometry parameters automatically influence each other; entering a few desired parameters 
causes the remaining parameters to adjust accordingly.
The diagrams next to each parameter indicate the relevant area of the stair.

Click to show/hide the parameters.

Parameter Description Applies to

Lock button For any parameter, locks the parameter value, forcing the 
other parameters to recalculate to automatically adjust

All

Link button Links stair flight widths so that they are set to the same 
value automatically; enter a value for one of the widths, and 
click Link to enter the same value for all linked flights

Stairs with multiple flights

Total Rise: By 
Value or By 
Layer Elevation

Sets the floor-to-floor height of the stair by either a value or 
by layer elevation settings of the layers/levels it connects. If 
by layer elevation, the Total Rise By Layer Elevations 
dialog box opens; see Step 2. 

All

Tread Depth(G) Specifies the average depth of the stair tread, measured from 
the face of the riser to the face of the next riser. Also known 
as the “going.”

All

Riser Height(R) Indicates the average height of the stair risers All
Step 
Length(2R+G)

Displays the step length, which is calculated as 2 * the Riser 
Height (R) + Tread Depth (G)

All

Stair Width Sets the overall width of the stair Stairs with a single flight
Stair Width 1/2/
3/4/5

Sets the width of each flight of stairs Stairs with multiple flights
L-Stair, Single Landing
L-Stair with winders
U-Stair, Single/Double Landings
U-Stair with winders
Double-U Stair, Double Landings
Triple-L Stair, Triple Landings
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Length Specifies the total length of the stair, measured from the 
nosing of the starting tread to the end of the last tread

Straight Stairs (all)
L-Stair, Single Landing
L-Stair with winders (all)
U-Stair, Single/Double Landings
U-Stair with winders (all)
Circular Stair

Walk Line 
Length

Indicates the length of the line that determines the direction 
of the stair and is the critical line from which the tread 
depth, oblique dimensions, and other values are calculated

Straight Stairs (all)
L-Stair, Single Landing
L-Stair with winders (all)
U-Stair, Single/Double Landings
U-Stair with winders (all)
Circular Stair

Draw Top Tread When enabled, the top tread is drawn; its parameters can be 
specified independently from the rest of the stair. Select the 
parameter from the list, and enter its value.

All

Min. Inside 
Tread Depth

Specifies the minimum allowable tread depth value for 
oblique, winder, or fixed angle winder stair treads

All

Walk Line Offset 
Options

Sets the walk line location
• Walk Line by Offset: Sets the distance to offset the 

walk line from the inside of the stair; enter the offset 
value

• Walk Line on Center: For stairs with fewer than two 
stair widths, sets the walk line offset to 0.5 times the 
stair width

• Walk Line Centered on All Flights: For stairs with 
several flights, sets the walk line offset to 0.5 times the 
stair width, centering the walk line for all flights. 
If the stair has different flight widths, the walk line 
displays centered for all flights, but the calculation of 
treads and winders is based on the first flight only.

• Walk Line Centered on First Flight: For stairs with 
several flights, sets the walk line offset to 0.5 times the 
stair width. For stairs with winders, the walk line is 
centered based on the first flight only.

All

Oblique Bottom 
Tread

Offsets the distance of the front edge of the first tread from 
the start of the overall length of the stair (as measured along 
the walk line)

All

Oblique Top 
Tread

Offsets the distance of the front edge of the last tread from 
the start of the overall length of the stair (as measured along 
the walk line)

All

Parameter Description Applies to
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Top/Bottom 
Treads

Opens the Top/Bottom Treads dialog box to access certain 
parameters: 

• Draw Top Tread: Select to draw the top tread and set 
the parameters independently from the rest of the stair

• Minimum Inside Tread Depth: Specifies the 
minimum allowable tread depth value for oblique, 
winder, or fixed angle winder stair treads

• Oblique Bottom Tread: Offsets the distance of the 
front edge of the first tread from the start of the overall 
length of the stair (as measured along the walk line)

• Oblique Top Tread: Offsets the distance of the front 
edge of the last tread from the start of the overall length 
of the stair (as measured along the walk line)

Double-U Stair, Double Landings
Triple-L Stair, Triple Landings

Num. of Risers Sets the number of risers for the stair Straight, Single Flight Run
L-Stair, Winder
U-Stair, Single/Double Winder 
Return
Circular Stair

Num. of Risers 1 Sets the number of risers for the first or bottom flight of 
stairs

Straight, Single/Double Landings
L-Stair, Single Landing
U-Stair, Single/Double Landings
Double-U Stair, Double Landings
Triple-L Stair, Triple Landings

Num. of Risers 2 Sets the number of risers for the second or middle flight of 
stairs

Straight, Single/Double Landings
L-Stair, Single Landing
U-Stair, Single/Double Landings
Double-U Stair, Double Landings
Triple-L Stair, Triple Landings

Num. of Risers 3 Sets the number of risers for the third flight of stairs Straight, Double Landing
U-Stair, Double Landings
Double-U Stair, Double Landings
Triple-L Stair, Triple Landings

Num. of Risers 4 Sets the number of risers for the fourth or top flight of stairs Triple-L Stair, Triple Landings
Landing Length 
1

Indicates the landing length Straight, Single/Double Landings
L-Stair, Single Landing
U-Stair, Single/Double Landings

Landing Length 
2

Sets the length of the second landing Straight, Double Landing
U-Stair, Double Landing

Side 1 Indicates the overall outside length of the stair, as measured 
from the start or bottom of the stair to the outside corner of 
the landing

L-Stair, Single Landing
U-Stair, Single/Double Landings
Double-U Stair, Double Landings
Triple-L Stair, Triple Landings

Parameter Description Applies to
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2. If setting the stair Total Rise by layer elevation instead of by a specific value, the height of the stair can be 
constrained by layer or story elements at its top and bottom boundaries; the lower floor and upper floor indicate 
the two stories the stair connects. Adjusting a bounding element causes the height of the stair to automatically 
change accordingly. 

Side 2 Indicates the overall outside length of the stair, as measured 
from the outside corner of the landing to the end or top of 
the stair, or to the outside corner of the next landing

L-Stair, Single Landing
U-Stair, Single/Double Landings
Double-U Stair, Double Landings
Triple-L Stair, Triple Landings

Side 3 Indicates the overall outside length of the stair, as measured 
from the outside corner of the landing to the end or top of 
the stair, or to the outside corner of the next landing

U-Stair, Single/Double Landings
Double-U Stair, Double Landings
Triple-L Stair, Triple Landings

Side 4 Indicates the overall outside length of the stair, as measured 
from the outside corner of the landing to the end or top of 
the stair, or to the outside corner of the next landing

Double-U Stair, Double Landings
Triple-L Stair, Triple Landings

Side 5 Indicates the overall outside length of the stair, as measured 
from the outside corner of the landing to the end or top of 
the stair

Double-U Stair, Double Landings

Offset 1 Specifies the distance from the front edge of the landing or 
last riser of the first flight to the inside corner of the first 
landing

L-Stair, Single Landing
U-Stair, Single/Double Landings, 
Fixed Angle Winder stairs
Double-U Stair, Double Landings
Triple-L Stair, Triple Landings

Offset 2 Specifies the distance from the inside corner of the landing 
to the back edge of the landing or first riser of the next flight

U-Stair, Double Landings,
Fixed Angle Winder stairs
Double-U Stair, Double Landings
Triple-L Stair, Triple Landings

Offset 3 Specifies the distance from the front edge of the landing or 
last riser of the second flight to the inside corner of the 
second landing

U-Stair, Double Landings,
Double Fixed Angle Winder
Double-U Stair, Double Landings
Triple-L Stair, Triple Landings

Offset 4 Specifies the distance from the inside corner of the second 
landing to the back edge of the second landing or first riser 
of the next flight

U-Stair, Double Landings, 
Double Fixed Angle Winder
Double-U Stair, Double Landings
Triple-L Stair, Triple Landings

Offset 5 Specifies the distance from the front edge of the landing or 
last riser of the third flight to the inside corner of the third 
landing

Triple-L Stair, Triple Landings

Offset 6 Specifies the distance from the inside corner of the third 
landing to the back edge of the third landing or first riser of 
the next flight

Triple-L Stair, Triple Landings

Outside 
Diameter

Sets the diameter measured from the outside of the stair Circular Stair

Inside Diameter Sets the diameter measured from the inside of the stair Circular Stair
Sweep Sets the angle of the arc formed by the walk line Circular Stair

Parameter Description Applies to
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Select By Layer Elevation; the Total Rise by Layer Elevations dialog box opens.
Click to show/hide the parameters.

Click OK to set the stair total rise.
3. The Preview contains two preview graphics.
• The lower preview graphic displays a detailed section/elevation view of the treads and risers, and indicates the 

current rise angle.

• The upper preview graphic displays the Top/Plan view and is interactive. 
• Click on an upper or lower tread to set the oblique tread parameters for the highlighted treads.
• L- and U-Stairs have clickable red areas at the corner of the landing. Click each area to set corner parameters 

for the inside and outside corners of the landing. The Stair Landing Corners dialog box opens. For 
configurations that allow angles other than 90 degrees, enter the desired Angle between flights; the corner 
style parameters update automatically. For each corner, set the Corner Style to the desired angle, or round the 
corner by specifying a chamfer or fillet value. 

Parameter Description

Top Bound Sets the vertical reference that determines the top of the stair.
The Layer Wall Height value is set by the design layer (see “Setting Design Layer 
Properties” on page 165).
Alternatively, the top of the stair can be bound by one of the story levels defined for 
the story or the story above it. By setting the top of the stair to a level type, if the 
elevation of the associated story changes, the height of the stair changes 
automatically to match.

Top Offset Sets the offset of the top of the stair from its specified top bound height 
Bottom Bound Sets the vertical reference that determines the bottom of the stair.

Alternatively, the bottom of the stair can be bound by one of the story levels defined 
for the story or the story below it. By setting the bottom of the stair to a level type, if 
the elevation of the associated story changes, the height of the stair changes 
automatically to match.

Bottom Offset For the bottom of the stair, sets the offset from its specified bottom bound height
Z of Top Bound Displays the elevation value of the stair’s upper boundary
Z of Bottom Bound Displays the elevation value of the stair’s lower boundary
Calculated Total Rise Displays the calculated total rise value for the stair based on the stair’s upper and 

lower boundaries

Rise angle
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• For Double-U and Triple-L configurations, some parts of the stair may overlap in the Top/Plan preview, 
making it difficult to select and edit the intended corner parameters. Before clicking the red areas to set corner 
parameters for these configurations, select whether the preview displays the Upper part of stair or Lower 
part of stair. 

• For fixed angle winder stair configurations, click on the stair winder to set the winder parameters. The Winder 
Parameters dialog box opens. Specify the number of treads for the winder section of the stair, and select 
whether the winder tread depths should match the tread depths for the straight parts of the stair. If maintaining 
a constant tread depth is desired, the minimum winder tread depth may need to be adjusted to prevent errors.

Stair Geometry Errors
The Geometry tab allows values to be locked, which forces other parameters to recalculate while maintaining 
appropriate calculated values for the stair. Occasionally, a invalid entry is attempted, which generates an error due to 
other locked values. An alert dialog box notifies you of the error and offers several possible options to avoid it.
Situations which can generate an alert include:

• The total rise calculation is based on multiplying the number of risers by the riser height, and therefore cannot be 
edited without changing one of the values. Similarly, the number of risers or riser height cannot be edited when the 
total rise is locked.

• The total rise of the stair and the stair length (or sweep angle, for circular stairs) impact other values such as tread 
depth, riser height, and the number of risers. When the length/sweep angle is locked, it may become impossible to 
obtain valid entries for the other parameters. Since the stair length or sweep angle is a multiple of the tread depth, 
one cannot be edited when the other is locked.

Parameter to be edited Locked Unlocked Resolution

Total rise Riser Height Num. of Risers Change the riser height or the total rise and number 
of risers as suggested, or return to previous values

Total rise Num. of Risers Riser Height Modify the riser height, or the riser height and the 
number of risers as suggested, or return to previous 
values

Total rise Riser Height and 
Num. of Risers

N/A Change the riser height and/or the number of risers 
as suggested, or return to previous values

Riser height Total rise N/A Modify the total rise, or the riser height and number 
of risers as suggested, or return to previous values

Number of risers Total rise N/A Change the total rise, or the riser height/step length, 
or the riser height and number of risers as 
suggested, or return to previous values 

Parameter to be edited Locked Resolution

Total rise Length or Sweep 
Angle

Change the number of risers and step length, or unlock the length/
sweep angle as suggested, or return to previous values

Tread depth Length or Sweep 
Angle

Modify the length/sweep angle, and/or change the number of risers 
and the tread depth as suggested, or return to previous values

Length or Sweep 
Angle

Tread Depth Change the tread depth, and/or the number of risers, or change the 
risers and length/sweep angle as suggested, or return to previous 
values
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~~~~~~~~~~~~~~~~~~~~~~~~~
Stair Settings: General Tab
Stair Settings: 2D Graphics Tab
Stair Settings: Construction Tab
Stair Settings: Railings Tab
Stair Settings: Graphic Attributes Tab
Managing Stair Styles
Saving a Stair as a Symbol
Setting Minimum and Maximum Values for Stair Geometry Parameters
Stair Properties
Transferring Stair Properties
Creating a Stair
Inserting Stairs
Setting Up the Building Structure with Stories

Stair Settings: 2D Graphics Tab
The remaining four stair configuration tabs have a method of saving and recalling each tab’s settings or style. The 
settings on the tab can be saved as a set and then loaded, replacing the current tab parameters. 

1. Click the 2D Graphics tab to set the stair’s 2D appearance on lower and, if desired, upper floors. The lower floor is 
always the floor where the stair has been placed. Selecting display options for the upper floor is optional; the 
upper floor representation is usually on another layer, and can be specifically selected here. These parameters 
apply only to the Top/Plan view, and do not affect the 3D appearance of the stair.

Click to show/hide the parameters.

Parameter Description

2D Graphic Styles Saves and recalls styles from a saved set
View Determines the view to apply the parameters to the stair; depending on drawing settings 

like layer scale and the document preference Hide details, the detailed or schematic 
view status is displayed

Detailed Applies the 2D graphic parameters to stairs in a detailed layer scale view 
Schematic Applies the 2D graphic parameters to stairs in a schematic scaled view
Accept for all 
Views

Applies the 2D graphic parameters to stairs in all views (detailed and schematic)

Stair Break Settings Sets the stair break parameters; select the stair break configuration, and then refine the 
display with the additional parameters

Break Elevation Sets the Z-height (relative to Layer Z=0) for the stair break
Break Line Angle Specifies the angle of the break line, measured from the leading edge of the tread/riser
Break Lines 
Separation

Sets the distance between the pair of parallel break lines, measured in page scale units

Break Line 
Extensions

Indicates how far to extend the break lines past the sides of the stair

Draw Outlines at 
Break

When selected, draws boundary outlines around the stair object
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Show Markers at 
Break

When selected, adds start and end markers to the walk line above and below the stair 
break

End of Walk Line 
is:

Sets the end of the walk line at either the last tread before the stair break or directly at 
the break

2D Graphics Settings Controls the display of the walk line, nosing, stringers, headroom outline, and railings in 
Top/Plan view only

Show Nosing/Riser 
Offset

Displays the stair nosing and riser offset

Show Tread Offset Displays the left and right tread offset
Show Stringers Displays the stair stringers
Show Headroom 
Outline

Displays the headroom outline; specify the headroom height above the stair

Show Handrail Displays the handrail (railing parameters are set on the Railings tab)
Show Top Rail Displays the top rail of the handrail and/or guardrail
Show Posts Displays railing posts
Show Railing above 
Stair Break

Displays the railing above the stair break

Lower Floor The stair always displays on the lower floor (the floor where it has been placed); set the 
display of stair breaks, walk lines, arrow directions, and stair text

Display Stair Select the stair display configuration for the lower floor
• Plain (no Break): Does not draw a stair break; the stair is drawn as set by the 2D 

attributes on the Graphic Attributes tab
• Solid with Break: Draws a stair break; the stair is drawn as set by the 2D attributes 

and 2D Stair Break on the Graphic Attributes tab, but line styles remain solid
• Below Break Only: Draws a stair break; all geometry above the stair break is hidden
• Above Break Only: Draws a stair break; all geometry below the stair break is hidden
• Break, Dashed Above: Draws a stair break; all line styles above the stair break are 

automatically dashed according to the settings on the Graphics Attributes tab
• Break, Dashed Below: Draws a stair break; all line styles below the stair break are 

automatically dashed according to the settings on the Graphics Attributes tab
• Dashed Above Only: Draws a stair break; all line styles above the stair break are 

automatically dashed according to the settings on the Graphics Attributes tab
• Dashed Below Only: Draws a stair break; all line styles below the stair break are 

automatically dashed according to the settings on the Graphics Attributes tab
Walk Line Below/
Above Stair Break

When selected, draws a walk line below/above the stair break. For Plain (no break) 
Display Stair style, draws a walk line the full length of the stair. When a walk line is 
indicated, select whether to display a start and/or end marker on the ends of the walk 
line (to show markers at a break, Show Markers at Break must be enabled). Set the 
arrow direction. The marker style is set on the Graphic Attributes tab.

Draw Entire Break For Below Break Only and Dashed Below Only, select whether to draw the top of the 
stair break line, in addition to the bottom of the stair break line (which is always shown)

Parameter Description
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2. Click Stair Data for the lower, and optionally, the upper floor, to set the display of the 2D stair information text.
The Stair Data Settings dialog box opens. The stair configuration determines the number of available run or flight 
parameters. Stair data text appearance is set on the Graphic Attributes tab.

Click to show/hide the parameters.

Stair Data Opens the Stair Data Settings dialog box, for setting the appearance of stair text on the 
lower floor (see Step 2)

Upper Floor Select to display the stair on the upper floor in both detailed and schematic views, and 
set the display of stair breaks, walk lines, arrow directions, and stair text for the upper 
floor

Layer Specify the layer where the upper floor representation of the stair will be displayed. This 
selection affects both the detailed and schematic display of the stair on the upper floor. It 
is not related to the total rise stair height selection on the General or Geometry tab.

Upper floor stair 
configuration

The Display Stair, walk line, and Stair Data options function the same as for the lower 
floor

Break Offset Adjusts the position of the stair break along the walk line. Enter a positive or negative 
offset to position the break without any gaps between upper and lower floors.

Preview Displays a preview of the upper and lower floors of the 2D stair with the parameters 
applied

Parameter Description

Show Numbers of 
Risers

When selected, displays the riser numbers for the stair.
Specify the text position and offset for the flight and the step, and set the text rotation.

Position in flight For straight stairs, indicate whether riser numbers display on the center, left, or right of 
the flight. For other stairs, indicate whether riser numbers display centered, or on the 
inner or outer side of the stair flight. The Offset value sets the distance between the riser 
numbers and the stair boundary.

Position in step Sets the riser position centered on the step or at the start of the tread. The Offset value 
sets the distance between the riser numbers and the start of the tread, for numbers at the 
start of the tread only.

Parameter Description
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The position of the stair run and note text can be adjusted by moving its control point.

3. Click OK to return to the Stair Settings dialog box.
~~~~~~~~~~~~~~~~~~~~~~~~~
Stair Settings: General Tab
Stair Settings: Geometry Tab

Rotation Specifies the rotation of the riser numbers

Run For each available run of stairs with multiple flights, select whether to include text for the 
total rise, average riser height, average tread depth, arrow direction (Up or Down, 
depending on walk line direction), and/or walk line length. As each item is selected for 
display, its code appears in the text box; text can also be typed between items. Select Line 
Break to add a carriage return between items. Set the angle of the text.

Note For the entire stair, select whether to include text for the total rise, average riser height, 
average tread depth, arrow direction (Up or Down, depending on walk line direction), 
and/or walk line length. As each item is selected for display, its code appears in the text 
box; text can also be typed between items. Select Line Break to add a carriage return 
between items. Set the angle of the text.

Parameter Description

Horizontal in stair: riser numbers 
always remain horizontal

Vertical in stair: riser numbers 
always remain vertical

Aligned to edge: riser numbers 
rotate by flight angle

Aligned to tread: riser numbers 
rotate with tread angle

Perpendicular to tread: riser numbers 
remain perpendicular to tread edge

Text control point
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Stair Settings: Construction Tab
Stair Settings: Railings Tab
Stair Settings: Graphic Attributes Tab
Managing Stair Styles
Saving a Stair as a Symbol
Setting Minimum and Maximum Values for Stair Geometry Parameters
Stair Properties
Transferring Stair Properties
Creating a Stair
Inserting Stairs

Stair Settings: Construction Tab
The settings on the tab can be saved as a set and then loaded, replacing the current tab parameters.

Click the Construction tab to specify stair construction parameters. The parameters displayed depend on the 
selected construction configuration.

Click to show/hide the parameters.

Parameter Description Applies to

Construction 
Styles

Saves and recalls styles from a saved set All

View Determines the view to apply the parameters to the stair; depending 
on drawing settings like layer scale and the document preference Hide 
details, the detailed or schematic view status is displayed

All

Detailed Applies the construction parameters to stairs in a detailed layer scale 
view 

All

Schematic Applies the construction parameters to stairs in a schematic scaled 
view

All

Accept for all 
Views

Applies the construction parameters to stairs in all views (detailed and 
schematic)

All

Construction 
Configuration

Select the type of construction for the stair All

Solid Stair Models the stair structure as single, monolithic geometry, but still 
includes treads and risers

All

Stringer 
Underneath

Models the stair structure as one, two, or three stringers (carriages) 
underneath that support the treads and risers above them. If three 
stringers are specified, the third will automatically be centered 
between the others, not the edge of the steps.

All

Stringer 
Outside

Models the stair structure as two stringers (carriages) on either side of 
the stair which support the treads and risers above them

All

Concrete Stair Models the stair structure as monolithic, without separate treads or 
risers

All

Circular Stair For circular stair configurations, select to obtain circular stair 
construction parameters

All
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Construction 
Settings

All

Upper Floor 
Thickness

Wraps the 3D stair geometry at the top of the stair around the edge of 
the floor slab by the indicated distance, correctly terminating all parts 
related to the construction type

All

Lower Floor 
Thickness

Wraps the 3D stair geometry at the bottom of the stair around the edge 
of the floor slab by the indicated distance, correctly terminating all 
parts related to the construction type. If set to 0 (zero) truncates the 
stair geometry so the bottom of the stair rests on top of the slab

All

Landing 
Thickness

Specifies the thickness of the stair landing, excluding any treads. The 
landing thickness plus the tread thickness is equal to the distance from 
the top of the tread to the bottom of the landing (solid stairs) or 
stringer (stringer underneath)

Stairs with a single 
landing

Landing 
Thickness 1

Specifies the thickness of the first stair landing, excluding any treads Stairs with two 
landings

Landing 
Thickness 2

Specifies the thickness of the second stair landing, excluding any 
treads

Stairs with two 
landings

Solid 
Structure 
Thickness

When selected, draws 3D geometry below the treads and risers 
representing the structural mass of the stair. Specify the distance from 
the rear face to the inside edge where the riser and tread meet.

Solid
Concrete

Tread 
Thickness

When selected, draws 3D stair tread geometry; specify the tread 
thickness

Solid
Stringer Underneath
Stringer Outside

Riser 
Thickness

When selected, draws 3D stair riser geometry; specify the riser 
thickness

Solid
Stringer Underneath
Stringer Outside

Nosing/Riser 
Offset

When selected, draws both 2D and 3D stair nosing geometry; set the 
distance that the nosing extends past the riser face over the preceding 
tread

All

Create Top 
Riser and 
Nosing

For stairs with the Draw Top Tread option disabled on the Geometry 
tab, select whether to display the top riser and tread nosing in 3D 
views

All

Offset Right 
(or Inner 
Offset)

Offsets the stair body from the right/inner edge of the stair treads and 
riser by the distance specified; as determined by the stair width, 
configuration, and orientation

Solid
Stringer Underneath

Offset Left (or 
Outer Offset)

Offsets the stair body from the left/outer edge of the stair treads and 
riser by the distance specified; as determined by the stair width, 
configuration, and orientation

Solid
Stringer Underneath

Stringer 
Depth

Sets the stringer’s structural clear depth Stringer Underneath
Stringer Outside

Stringer 
Width

Sets the thickness (width) of the stringer Stringer Underneath
Stringer Outside

Parameter Description Applies to
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~~~~~~~~~~~~~~~~~~~~~~~~~
Stair Settings: General Tab
Stair Settings: Geometry Tab
Stair Settings: 2D Graphics Tab
Stair Settings: Railings Tab
Stair Settings: Graphic Attributes Tab
Managing Stair Styles
Saving a Stair as a Symbol
Setting Minimum and Maximum Values for Stair Geometry Parameters
Stair Properties
Transferring Stair Properties
Creating a Stair
Inserting Stairs

Stair Settings: Railings Tab
The settings on the tab can be saved as a set and then loaded, replacing the current tab parameters.

Click the Railings tab to set the stair’s handrail and guardrail parameters. The Railings tab is divided into three 
panes. On the left, the handrail and guardrail categories display, along with each current setting for the left, right, 
or both sides of the stair. Handrail and guardrail parameters are set separately. Click a disclosure arrow to reveal 
handrail or guardrail parameter categories. Select a category to edit its parameter settings in the middle pane. On 
the right, three previews display the railing cross-section, top/plan stair view, and isometric stair view.

Click to show/hide the parameters.

Stringer 
Distance

For stairs with one stringer, specifies the stringer’s offset distance 
from the center of the stair

Stringer Underneath

Tread/Stringer 
Offset

Sets the tread’s offset distance from the bottom of the stringer’s depth, 
as measured to the back, bottom edge of the tread

Stringer Outside

Stringer 
Extension at 
Stair Bottom

Specifies the distance that the stringer extends past the front edge of 
the starting (bottom) tread

Stringer Outside

Stringer 
Extension at 
Stair Top

Specifies the distance that the stringer extends past the front edge of 
the last (top) tread

Stringer Outside

Column When selected, adds a central column All, when stair 
configuration is 
Circular Stair

Custom 
Column 
Height

Specifies the central column height for spiral stairs All, when stair 
configuration is 
Circular Stair

Custom 
Column 
Diameter

Specifies the central column diameter for spiral stairs All, when stair 
configuration is 
Circular Stair

Outside 
Nosing

Sets the value for the tread nosing at the outside diameter of a circular 
stair

Circular stair, when 
stair configuration is 
also circular stair

Parameter Description Applies to
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Parameter Description

Railing Styles Saves and recalls styles from a saved set
View Determines the view to apply the parameters to the stair; depending on drawing settings 

like layer scale and the document preference Hide details, the detailed or schematic 
view status is displayed

Detailed Applies the railing parameters to stairs in a detailed layer scale view 
Schematic Applies the railing parameters to stairs in a schematic scaled view
Accept for all 
Views

Applies the railing parameters to stairs in all views (detailed and schematic)

Accept Settings for Select the railing to which the current settings apply
Right/Left or 
Inside/Outside 
Railing

Applies the parameters to the selected side only

Both Sides Applies the parameters to railings on both sides
Handrail 
Show Handrail When selected, adds a handrail to the stair and enables the handrail parameters; Show 

displays for the handrail settings
Position

Height Sets the vertical distance from the leading edge of the tread/nosing to the top of the 
handrail

Handrail Position Select whether the railing is on the stair or next to the stair
Offset to Tread 
Edge

Indicates the distance between the edge of the stair (the solid structure or the stringers) 
and the handrail

Top Rail
Profile Type Select the basic geometry of the top rail

• Line: A 3D polyline serves as the railing profile
• Flat: A 3D polygon with width, but no height, serves as the railing profile
• Round: The cross-section is round, controlled by width
• Rectangular: The cross-section is rectangular, controlled by width and height

Width Sets the width for flat, rough, and square top railing geometry
Height Sets the height of rectangular top railing geometry
Bottom Extension Specifies the distance the top rail extends past the leading edge of the first tread or start 

of the stair; select whether the bottom extension is horizontal to the bottom riser or 
slopes with the stair

Top Extension Specifies the distance the top rail extends past the leading edge of the last/top tread/end 
of the stair; select whether the top extension is horizontal to the bottom riser or slopes 
with the stair

Guardrail 
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Show Guardrail When selected, adds a guardrail to the stair and enables the guardrail parameters; Show 
displays for the guardrail settings

Position
Height Sets the vertical distance from the leading edge of the tread/nosing to the top of the 

guardrail
Guardrail Position Select whether the railing is on the stair or next to the stair
Offset to Tread 
Edge

Indicates the distance between the edge of the stair (the solid structure or the stringers) 
and the guardrail

Top Rail
Create Top Rail Select whether to create a top rail on the guardrail
Profile Type Select the basic geometry of the top rail

• Line: A 3D polyline serves as the railing profile
• Flat: A 3D polygon with width, but no height, serves as the railing profile
• Round: The cross-section is round, controlled by width
• Rectangular: The cross-section is rectangular, controlled by width and height

Width Sets the width for flat, rough, and square top railing geometry
Height Sets the height of rectangular top railing geometry
Start at Bottom Defines where the top rail of the guardrail begins

• At Post: The top rail begins at the first post
• At Tread: The top rail begins at the stair tread
• Extend Tread by: Sets a specific distance the top rail extends past the leading edge 

of the first tread or start of the stair. Select whether the bottom extension is horizontal 
to the bottom riser or slopes with the stair.

End at Top Defines where the top rail of the guardrail ends
• At Post: The top rail ends at the last post
• At Tread: The top rail ends at the stair tread
• Extend Tread by: Sets a specific distance the top rail extends past the leading edge 

of the last/top tread/end of the stair. Select whether the bottom extension is horizontal 
to the bottom riser or slopes with the stair.

Frame
Create Frame Select whether to create a frame on the guardrail
Frame Type Sets the geometry for the area below the top rail, and between posts

• Frame: Adds a frame to support the frame bars; the frame must include at least one 
of the top, bottom, or left-right vertical supports

• Panel: Adds a solid panel below the top rail
Top/Bottom/
Left-Right Verticals

Select options to include in the frame

Parameter Description
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Offset to Top Rail Indicates the perpendicular distance between the bottom of the top railing, and the top 
of the frame or panel

Offset to Stair Sets the perpendicular distance between the leading edge of the tread/nosing or the 
bottom of the frame or panel

Profile Type For Frame types, sets the frame cross-section geometry
• Line: A 3D polyline serves as the railing profile
• Flat: A 3D polygon with width, but no height, serves as the railing profile
• Round: The cross-section is round, controlled by width
• Rectangular: The cross-section is rectangular, controlled by width and height

Width Sets the width of the frame or panel
Height Sets the height of rectangular profiles

Frame Bars
Create Horizontal 
Bars

Select whether to create horizontal frame bars

Create Vertical Bars Select whether to create vertical frame bars
Profile Type Sets the cross-section geometry of the frame bars

• Line: A 3D polyline serves as the frame bar profile
• Flat: A 3D polygon with width, but no height, serves as the frame bar profile
• Round: The cross-section is round, controlled by thickness
• Rectangular: The cross-section is rectangular, controlled by thickness and depth

Thickness Sets the thickness of round and square frame bar profiles
Depth Sets the depth of rectangular frame bar profiles
Maximum Distance Specifies the maximum distance between centerlines of frame bar geometry, setting the 

spacing of the frame bars
Posts

Create Posts Select whether to create vertical supports of the top rail and frames
Shape Sets the geometry of the guardrail posts

• Line: A 3D polyline serves as the post profile
• Flat: A 3D polygon with width, but no depth, serves as the post profile
• Round: The cross-section is round, controlled by width
• Rectangular: The cross-section is rectangular, controlled by width and depth

Width Sets the width for flat, round, and rectangular posts
Depth Sets the depth of rectangular posts
Arrangement Determines how to place the posts
On each Tread Places one post at the midpoint of the tread depth for each tread
Distance (approx.) Specifies the distance between each post

Parameter Description
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Stair Settings: General Tab
Stair Settings: Geometry Tab
Stair Settings: 2D Graphics Tab
Stair Settings: Construction Tab
Stair Settings: Graphic Attributes Tab
Managing Stair Styles
Saving a Stair as a Symbol
Setting Minimum and Maximum Values for Stair Geometry Parameters
Stair Properties
Transferring Stair Properties
Creating a Stair
Inserting Stairs

Stair Settings: Graphic Attributes Tab
The settings on the tab can be saved as a set and then loaded, replacing the current tab parameters.

1. Click the Graphic Attributes to specify the appearance of stair components.
Click to show/hide the parameters.

Placement Links the post positions on the left and right sides of the stair based on one of these 
methods:
• Each side individually: The post positions are calculated separately for each side of 

the stair based on the approximate Distance value
• Left side has priority: The left side post distances are calculated based on the 

approximate Distance value; the posts on the right are placed symmetrically
• Right side has priority: The right post distances are calculated based on the 

approximate Distance value; the posts on the left side are placed symmetrically
On each Corner Places a post at each landing corner, regardless of the distance set
Min Distance Specifies the minimum distance between a corner post and the next adjacent post on a 

landing
Previews Three preview panes display:

• The detailed plan and elevation view of a representative portion of the railing system
• An overall top/plan view of the stair
• An isometric view of the stair, when Component is set to 2D and 3D on the General 

tab

Parameter Description

Attributes Styles Saves and recalls styles from a saved set
View Determines the view to apply the parameters to the stair; depending on drawing settings 

like layer scale and the document preference Hide details, the detailed or schematic 
view status is displayed

Detailed Applies the graphic attributes to stairs in a detailed layer scale view 

Parameter Description
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2. The graphic attributes of each item is displayed, and can be set by double-clicking on the item’s line.

Schematic Applies the graphic attributes to stairs in a schematic scaled view
Accept for all 
Views

Applies the graphic attributes to stairs in all views (detailed and schematic)

Graphic Attribute 
Settings

Lists all geometry and text parameters that have graphic attributes settings, divided by 
2D and 3D attributes. Click the disclosure arrow to reveal further parameters under 
certain categories.
Each category’s current class, fill, pen, line style, line thickness, opacity, and if 
applicable, texture is displayed. Double-click on a line to set attributes.
Select a class for each stair component to control its appearance and visibility. The 
classes present in the drawing are listed; alternatively, create a new class by selecting 
New, select the currently active class, select the default class name, or select the class 
named <Stair Class> which places the stair component in the same class as the stair 
object.

2D Walk Line and 
Marker Attributes

In addition to the class, pen, fill, and other “typical” attributes, the walk line and 
markers have specific parameters 

The Double Line, Oval, and Filled Arrowhead marker styles are available 
especially for stair walk lines to meet DIN requirements

Start Marker Sets the graphics for the beginning of the walk line arrow that indicates the Up direction 
of travel on the stair, from the bottom tread, or start, of the stair

End Marker Sets the graphics for the end of the walk line arrow that indicates the Up direction of 
travel on the stair, at the top, or end, of the stair

Fit to tread depth Fits the line end marker of the walk line to the depth of the tread

Set Class Style Sets each attribute (fill, pen, line style, line thickness, opacity, and texture) of all stair 
components to the “By Class” setting. The attributes are then controlled by the class 
assigned to the component. (See “Setting Class Attributes” on page 181.) To set only 
the opacity by class, select the Use Class Opacity option when defining the graphic 
attributes for each category.

Remove Class Style Removes the “By Class” setting for each attribute of all stair components. The attributes 
are then controlled by the individual attribute settings made for each component.

Apply to all Stairs Applies all the attribute settings of the current stair to all stairs in the file, including 
symbol definitions and stairs that may be within groups.

Use caution when selecting this option, as it affects all stairs in the file.

Parameter Description

Fit to tread 
depth enabled

Fit to tread 
depth disabled



  656 | Creating a Stair
An attributes dialog box with the name of the item is displayed. See “The Attributes Palette” on page 1093 for 
information on setting attributes.

3. Set the attributes and click OK to return to the Graphic Attributes tab.
~~~~~~~~~~~~~~~~~~~~~~~~~
Stair Settings: General Tab
Stair Settings: Geometry Tab
Stair Settings: 2D Graphics Tab
Stair Settings: Construction Tab
Stair Settings: Railings Tab
Managing Stair Styles
Saving a Stair as a Symbol
Setting Minimum and Maximum Values for Stair Geometry Parameters
Stair Properties
Transferring Stair Properties
Creating a Stair
Inserting Stairs

Managing Stair Styles
In the Stair Settings dialog box, the 2D Graphics, Construction, Railings, and Graphic Attributes tabs have the option 
of saving the current tab’s settings as a style that can be recalled later. The stair minimum/maximum settings can also 
be saved as a style set.

Saving Parameter Styles
To save tab settings as a style:

1. When the tab parameters have been set, click Save (located in the Styles area at the top left of the tab).
The Save Style dialog box opens.

Click to show/hide the parameters.

2. Click OK to save the style set.
The new style name appears in the Styles list.

Recalling a Saved Style
To recall a saved style:

Select the style from the Styles list. Any currently set parameters are replaced by those of the saved style set. The 
Styles list contains saved styles as well as a limited number of default styles.

Managing Styles
Styles can be renamed and deleted. 

Default styles (located in the application folder) cannot be renamed or deleted.
To manage styles:

1. Click Manage Styles (located in the Styles area at the top left of the tab).

Parameter Description

Create New Style Saves the settings in a new style set; enter the set name
Replace Style Replaces the selected style with the current set of parameters
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The Styles dialog box opens, listing all currently saved style sets and their saved location.
Click to show/hide the parameters.

2. Click OK to return to the Stair Settings dialog box.
~~~~~~~~~~~~~~~~~~~~~~~~~
Saving a Stair as a Symbol
Setting Minimum and Maximum Values for Stair Geometry Parameters
Transferring Stair Properties
Inserting Stairs

Saving a Stair as a Symbol
The stair configuration, along with all its parameters, can be saved as a symbol for use again in the current file or in 
another “library” file. The stair is saved as a red symbol and becomes a plug-in object with pre-set parameters when 
inserted. See “Symbols” on page 237.
To save the stair as a symbol:

1. From the Stair Settings dialog box, click Save as symbol.
The Save Stair dialog box opens.

Click to show/hide the parameters.

2. Select whether to save the stair symbol in the current file or in a library file.
• To save the symbol in a library file, select Save as template in library file and enter a name for the symbol

Parameter Description

Rename Opens the Rename Style dialog box, to rename the currently selected style name. Enter the 
new name for the style. Click OK to return to the Styles dialog box.

Delete Deletes the selected style

Parameter Description

Destination Select whether to save the stair symbol in the current file or in a library file available in 
the user folder

Save as symbol in 
current document

Saves the stair as a symbol in the current file

Save as template in 
library file

Saves the stair symbol to a custom default library file located in the user folder; the exact 
location is displayed upon saving

Name Enter a name for the symbol
Symbol Folder Select the symbol folder from the available hierarchy in the current file; subfolder lists 

are displayed for the selected folder
Symbol folder list Displays available subfolders for the selected symbol folder; select a location for saving 

the new stair symbol
New Folder Creates a new symbol folder in the current file; provide a folder name
Browse Browses the subfolder contents of the currently selected symbol folder
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• To save the symbol in the current file, select Save as symbol in current document, enter a name for the 
symbol, and select a symbol folder destination for the symbol by double-clicking on the selected symbol folder 
name

3. Click OK.
• If the symbol was saved in the user default library, it is available from the General tab’s Symbol Selection list 

under the Custom Defaults category. Library files can be shared among users.

• If the symbol was saved in the current file, it is available from the General tab’s Symbol Selection list under 
the Current Document category, and also from the Resource Browser. Symbols can be shared by exporting 
them from the Resource Browser (see “Exporting Custom Resources” on page 234).

~~~~~~~~~~~~~~~~~~~~~~~~~
Managing Stair Styles
Setting Minimum and Maximum Values for Stair Geometry Parameters
Transferring Stair Properties
Inserting Stairs

Setting Minimum and Maximum Values for Stair Geometry Parameters
When setting stair parameters, a geometry “envelope” can be set to specify the allowable value ranges for tread depth, 
riser height, step length, and stair angle. Setting these values can assist with creating proportional stair geometry that 
complies with standards.

During the initial phases of design, it may be convenient to temporarily disable the minimum/maximum 
restrictions by deselecting Use Minimum/Maximum Values from the Stair Settings dialog box.

The stair minimum/maximum settings can be saved as a style set and then loaded, replacing the current dialog box 
parameters.
To set minimum and maximum stair parameter ranges:

1. From the Geometry pane of the Stair Settings dialog box, click Edit.
The Min/Max Settings dialog box opens.

Click to show/hide the parameters.
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2. Set the geometry minimum and maximum values and click OK. 
~~~~~~~~~~~~~~~~~~~~~~~~~
Managing Stair Styles
Saving a Stair as a Symbol
Transferring Stair Properties
Inserting Stairs

Stair Properties
Certain stair parameters can be edited directly from the Object Info palette, depending on the settings of the selected 
stair. These parameters display when the Total Rise of the stair is set by Layer Elevation, or the stair has an upper floor 
representation. All of the stair parameters can be edited by clicking Settings from the Object Info palette.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Stair Settings: Geometry Tab
Stair Settings: 2D Graphics Tab
Transferring Stair Properties
Setting Design Layer Properties
Creating a Stair

Parameter Description

Min/Max Styles Saves and recalls styles from a saved set
Values Specify the minimum and maximum values for the tread depth, riser height, and step 

length. Additionally, set the maximum angle (steepness) for the entire stair. For fixed 
angle winder stairs, set the minimum tread depth value.

Parameter Description

Top Bound Sets the vertical reference that determines the top of the stair.
The Layer Wall Height value is set by the design layer (see “Setting Design Layer 
Properties” on page 165).
Alternatively, the top of the stair can be bound by one of the story levels defined for the 
story or the story above it. By setting the top of the stair to a level type, if the elevation 
of the associated story changes, the height of the stair changes automatically to match.

Top Offset Sets the offset of the top of the stair from its specified top bound height 
Bottom Bound Sets the vertical reference that determines the bottom of the stair. 

Alternatively, the bottom of the stair can be bound by one of the story levels defined for 
the story or the story below it. By setting the bottom of the stair to a level type, if the 
elevation of the associated story changes, the height of the stair changes automatically to 
match.

Bottom Offset For the bottom of the stair, sets the offset from its specified bottom bound height
Upper Layer If an upper floor representation of the stair is enabled, specify the layer to display the 

representation. 
Settings Opens the Stair Settings dialog box, to edit all of the stair parameters
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Transferring Stair Properties
Specific stair parameters can be transferred from one stair to another.

To transfer stair attributes:

1. Click the Stair tool from the Building Shell tool set and select Pick up mode from the Tool bar.
2. Click Preferences from the Tool bar to set the transfer parameters.

The transfer attributes cannot be accessed when clicking Settings from the Object Info palette.
3. Click the Transfer tab.

Click to show/hide the parameters.

4. Select the attributes to transfer, and select whether the attributes should become Stair tool defaults and/or should 
also apply to all stairs in the file.

5. Click OK.
6. In Pick up mode, click on the stair with the desired attributes.

The cursor changes to an eyedropper, and the source stair is highlighted in red.
7. Move the cursor to the target stair, and click Apply mode from the Tool bar.

Press the Option (Mac) or Ctrl (Windows) key to switch between the Pick up and Apply modes.
8. Click on the target stair to transfer the selected attributes.

~~~~~~~~~~~~~~~~~~~~~~~~~
Managing Stair Styles
Saving a Stair as a Symbol
Setting Minimum and Maximum Values for Stair Geometry Parameters
Inserting Stairs

Inserting Escalators
A basic escalator can be inserted, with its height defined automatically from its top and bottom layer boundaries.

To insert an escalator:

1.  Select the Escalator tool from the Building Shell tool set.
2. The escalator is a point object; click once to insert the escalator, and then again to set the rotation.

If this is the first time the tool is used in this session, the Escalator Properties dialog box opens. Specify the 
preferences to use for this tool during this session, and then click OK. 

Parameter Description

Attributes Select the stair attributes to transfer; selected attributes display with a check mark
All/None Selects/deselects all the attributes with a single click
Picked up values 
become stair defaults

When the selected attributes are picked up in Pick up mode, they also become the 
default parameters for the Stair tool

Accept for all Stairs in 
Drawing

The most recently picked up, selected attributes, are applied to all stairs in the file
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The parameters can be changed in the Object Info palette after insertion. 
Click to show/hide the parameters.

Parameter Description

Height
Height Directly sets the desired height of the escalator. When the escalator height is 

determined manually by this method, the Top Bound property of the escalator is 
automatically set to Layer Elevation, and the Top Offset value is modified accordingly.
When the top of the escalator is bound by the layer wall height value or by a story level, 
the escalator height displays automatically.

Top Bound Sets the vertical reference that determines the top of the escalator.
The Layer Wall Height value is set by the design layer (see “Setting Design Layer 
Properties” on page 165).
Alternatively, the top of the escalator can be bound by one of the story levels defined 
for the story or the story above it. By setting the top of the escalator to a level type, if 
the elevation of the associated story changes, the height of the escalator changes 
automatically to match.

Top Offset Sets the offset of the top of the escalator from its specified top bound height 
Bot Bound Sets the vertical reference that determines the bottom of the escalator. Alternatively, the 

bottom of the escalator can be bound by one of the story levels defined for the story or 
the story below it. By setting the bottom of the escalator to a level type, if the elevation 
of the associated story changes, the height of the escalator changes automatically to 
match.

Bot Offset For the bottom of the escalator, sets the offset from its specified bottom bound height
Type Select a generic escalator or one of the common escalator types
Slope angle Select from the common slope angles available for an escalator
Floor depth above Indicates the depth of the floor-to-ceiling construction on the upper floor being 

serviced by the escalator; this parameter affects the size of the headroom and pit in Top/
Plan view

Step width Select a common step width configuration
Horizontal lead in Select the number of horizontal escalator steps at the bottom of the escalator
Balustrade type Select the type of geometry that encloses the sides of the escalator and supports the 

moving handrail
Section cut Select whether to display the escalator with a section break going up or down, or 

without a break
Draw 3D In 3D views, represents the escalator with a 3D polygon
Show pit Indicates whether the extents of the minimum required pit below the escalator display 

in Top/Plan view
Show headroom Indicates whether the extents of the minimum required headroom above the escalator 

display in Top/Plan view
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Inserting Ramps

To insert a ramp:

1. Select the Ramp tool from the Building Shell tool set.
2. The ramp is a point object; click once to place the lower end of the ramp, and then again to set the rotation.

If this is the first time the tool is used in this session, the Object Properties dialog box opens. Specify the 
preferences to use for this tool during this session, or accept the defaults.
When the ramp configuration has been selected, the available parameters in the dialog box change to reflect the 
selection.

3. Click OK.
The parameters can be changed in the Object Info palette after insertion.

Click to show/hide the parameters.

Override Maximum 
Allowable Span

Overrides the maximum allowable length of the selected escalator type; this parameter 
is affected by the horizontal lead-in and slope angle values, as well as the selected 
escalator type 

Override Maximum 
Height Limit

Overrides the maximum allowable floor-to-floor height of the selected escalator type; 
this parameter is affected by the horizontal lead-in and slope angle values, as well as 
the selected escalator type 

Parameter Description

Style Select a either a standard (simple board) or masonry ramp style
Width Set the ramp’s width
Height Set the ramp’s height
Rise over Run Set the ramp’s rise over run value. 

The rise is the distance along the Y axis the ramp rises above the Z height, and run 
is the distance along the X axis for the ramp to reach that height. This value can be 
entered as a fraction, and the Vectorworks software will convert it to a decimal.

Thickness For a standard style ramp, set the ramp’s thickness
Config Select the ramp’s configuration from the list of preformatted options
Landing Height Set the landing’s height above the finished floor, if applicable
Offset 1 For ramps with a landing, set a distance, if applicable, to offset the bottom of the upper 

ramp away from the top of the lower ramp
Offset 2 For ramps with a landing, set a distance, if applicable, to offset the bottom of the upper 

ramp toward the top of the ramp
Curved landing Select to make the landing curved
2D Stair Break Select to create a break line in the 2D view
Create 3D Select to create a 3D view

Parameter Description



Inserting Handrails |  663
Inserting Handrails
Handrails can be inserted independently of those available as part of the Stair tool.

To insert a straight handrail:

To insert a curved handrail:

1. Select either the Straight Handrail tool or Curved Handrail tool from the Furn/Fixtures tool set.
2. The handrails are point objects; click once to place the handrail and then again to set the rotation.

If this is the first time the tool is used in this session, the Object Properties dialog box opens. Specify the 
preferences to use for this tool during this session, or accept the defaults.

3. Click OK. 
The parameters can be changed in the Object Info palette after insertion.

Click to show/hide the parameters.

Left Rail Select to provide a handrail on the left side (facing the top of the ramp)
Right Rail Select to provide a handrail on the right side (facing the top of the ramp)
Rail H Set the handrail height above the ramp surface
Rail W Set the handrail width
Arrows (2D view) For 2D views, select whether to provide an arrow pointing up or down, or no arrow

Parameter Description

Length For a straight handrail, set the overall length
Overall Angle For a curved handrail, set the overall angle of the curve
Radius For a curved handrail, set the radius of the curve
Top Rail Width Set the width of the top rail
Top Rail Thk Set the thickness (height) of the top rail
Inter Rail Width Set the width of the lower horizontal rails
Inter Rail Thk Set the thickness (height) of the lower horizontal rails
Starting Upright Select to place an upright flush with the start of the horizontal rails
Ending Upright Select to place an upright flush with the end of the horizontal rails
1st Upright Spacing Set the distance before the first upright (not counting the starting upright, if one is 

included)
Upright Spacing Set the spacing, measured on center, between all subsequent uprights
Upright Width Set the width of the uprights
Upright Depth Set the depth of the uprights
Caps Select to add caps to one or both ends

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Stair Settings: Railings Tab

1st Horizontal Height/
Spacing

Set the height/spacing of the first horizontal rail (not counting the top rail), measured 
down from the top of the handrail

Horizontal Spacing Set the spacing, measured on center, between all subsequent horizontal rails
Overall Height Set the overall height of the handrail
Rise Set the rise from one end of the handrail to the other
Start Miter For a straight handrail, set the angle in degrees of the miter at the beginning of the top 

rail
End Miter For a straight handrail, set the angle in degrees of the miter at the end of the top rail
Top Rail/Uprights/
Intermediate Rails

Select the class from the current list of classes, or select New to create a new class (see 
“Creating Classes” on page 177)

Parameter Description
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Inserting Cabinets
All Vectorworks products include three types of cabinets for inserting in a drawing file—base, wall, and utility 
cabinets. In the Vectorworks Fundamentals product, the cabinet objects are inserted from an object library through the 
Resource Browser. In the Vectorworks Design Series products, the cabinet objects are inserted with the various cabinet 
tools. Cabinet door and drawer handles are provided as default content (default content is automatically imported into 
the current file at the point of use and displays in the Resource Browser; see “Resource Libraries” on page 219).

To insert a base cabinet:

To insert a utility cabinet: 

To insert a wall cabinet:

1. Select the Base Cabinet or Utility Cabinet or Wall Cabinet tool from the Furn/Fixtures tool set.
2. Click in the drawing file or wall to set the insertion point of the cabinet, and click again to set the rotation.

If this is the first time a cabinet of this type is placed in the drawing, the Object Properties dialog box opens.
3. Specify the default properties which apply to cabinets subsequently placed in this document. Cabinet properties 

can be edited later in the Object Info palette.

Base Cabinet Parameters

Click to show/hide the parameters.

Parameter Description

Flip When inserting a cabinet in a wall, click to flip the cabinet orientation
Position When inserting a cabinet in a wall, click to set the position of the cabinet; in the Position 

Symbol in Wall dialog box, enter the distance from the symbol’s insertion point to the 
selected corner of the wall

Style Select the cabinet style
End Finish Select the cabinet finish
Blind Specify the direction of the blind, or none
Length Enter the cabinet length
Uneven Length 
Corner

Select whether the cabinet has an uneven length corner, and if so, enter the left corner 
length

Height / Depth Enter the cabinet height and depth
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Door mounting Select the cabinet door mounting style
Draw Drawer Select whether to draw the cabinet drawer(s)

Drawer Style Specify the drawer style
Number of Doors Select the number of cabinet doors
Door Style Select the cabinet door style
Panel Style Select the door panel style
Arch Height Factor Specify the proportion of the arch height in relation to the door width (a larger value 

produces a taller arch)
Door Swing Specify the door swing direction
Rail and Stile 
Width

Select the rail and stile width

Bevel Edge Select whether to bevel the outside door and drawer edges
Bevel Inside Select whether to bevel the inside door and drawer edges

Reveals Enter the Top, Mid, Bottom, Side, and Center reveal height or width
Number of Shelves Enter the number of shelves
Draw Kick Select whether to draw a kick

Kick Height / 
Depth

Specify the kick height and depth

Draw Counter Select whether to draw a counter
Back Splash Specify where to place the back splash, or none
Splash Height Enter the back splash height
Splash Thickness Enter the back splash thickness
Counter Thickness Enter the counter thickness
Overhang Enter the counter overhang length
Reveal Enter the thickness for the bottom portion of the counter

Show Detail Select whether to draw various cabinet details. Select the cabinet door, kick, and/or 
counter class, or none 

Door Handle Height Enter the door handle height
Door / Drawer 
Handles

Click Door Handles or Drawer Handles to select a handle from the default content (see 
“Resource Libraries” on page 219); select a symbol from the graphical list of Symbols and 
click OK (or select the No Pull symbol to remove the door or drawer handles)

Parameter Description
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Utility Cabinet Parameters

Click to show/hide the parameters.

Parameter Description

Flip When inserting a cabinet in a wall, click to flip the cabinet orientation
Position When inserting a cabinet in a wall, click to set the position of the cabinet; in the Position 

Symbol in Wall dialog box, enter the distance from the symbol’s insertion point to the 
selected corner of the wall

Length Enter the cabinet length
Height / Depth Enter the cabinet height and depth
Door Mounting Select the cabinet door mounting style
Number of doors Select the number of cabinet doors
Door Swing Specify the door swing direction
Door Style Select the cabinet door style
Panel Style Select the door panel style
Mullion Style Select the cabinet mullion style, or none
Handle Height Enter the door handle height
Number of Shelves Enter the number of shelves
Upper Door Height Enter the upper cabinet door height
Upper Door Style Select the upper cabinet door style
Upper Panel Style Select the upper cabinet door panel style
Upper Mullion Style Select the upper cabinet mullion style, or none
Upper Handle Height Enter the upper cabinet door handle height
Upper Number of 
Shelves

Enter the number of shelves in the upper cabinet

Arch Height Factor Specify the proportion of the arch height in relation to the door width (a larger value 
produces a taller arch)

Rail and Stile Width Select the rail and stile width
Bevel Edge Select whether to bevel the outside door and drawer edges
Bevel Inside Select whether to bevel the inside door and drawer edges

Reveals Enter the Top, Mid, Bottom, and Side reveal measurement height or width
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Wall Cabinet Parameters 

Click to show/hide the parameters.

Draw Kick Select whether to draw a kick
Kick Height / 
Depth

Specify the kick height and depth

Show Detail Select whether to draw various cabinet details. Select the cabinet, door, kick, and/or glazing 
class, or none

Handles Click Handles to select a handle from the default content (see “Resource Libraries” on 
page 219); select a symbol from the graphical list of Symbols and click OK (or select the 
No Pull symbol to remove the handles)

Parameter Description

Flip When inserting a cabinet in a wall, click to flip the cabinet orientation
Position When inserting a cabinet in a wall, click to set the position of the cabinet; in the Position 

Symbol in Wall dialog box, enter the distance from the symbol’s insertion point to the selected 
corner of the wall

Style Select the cabinet style
End Finish Select the cabinet finish
Blind Specify the direction of the blind, or none
Length Enter the cabinet length
Uneven Length 
Corner

Select whether the cabinet has an uneven length corner, and if so, enter the Left Corner 
Length

Height / Depth Enter the cabinet height and depth
AFF Enter the cabinet height above the finished floor
Door 
mounting

Select the cabinet door mounting style

Number of Doors Select the number of cabinet doors
Door Swing Specify the door swing direction
Door Style Select the cabinet door style
Panel Style Select the door panel style

Parameter Description
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4. Click OK to set the cabinet parameters and close the Object Properties dialog box.

Inserting Toilet Stalls
The Toilet Stall tool provides you with a flexible tool for creating a variety of toilet stalls for public restrooms. Toilet 
stall fixtures are provided as default content (default content is automatically imported into the current file at the point 
of use and displays in the Resource Browser; see “Resource Libraries” on page 219).

 To insert a toilet stall:

1. Select the Toilet Stall tool from the Furn/Fixtures tool set.
2. Click in the drawing file or wall to set the insertion point of the toilet stall, and click again to set the rotation. The 

direction of the toilet stall can be changed later by clicking Flip in the Object Info palette or from the context 
menu if the toilet stall is inserted in a wall, or by using the context menu commands to rotate the toilet stall if it is 
not.
If this is the first time a toilet stall is placed in the drawing, the Object Properties dialog box opens. Specify the 
default properties which apply to toilet stalls subsequently placed in this document. Toilet stall properties can be 
edited later in the Object Info palette.

Click to show/hide the parameters.

Mullion Style Select the cabinet mullion style, or none
Number of 
Shelves

Enter the number of shelves

Arch Height 
Factor

Specify the proportion of the arch height in relation to the door width (a larger value produces a 
taller arch)

Handle Height Enter the door handle height
Rail and Stile 
Width

Select the rail and stile width

Bevel Edge Select whether to bevel the outside door and drawer edges
Bevel Inside Select whether to bevel the inside door and drawer edges

Reveals Enter the Top, Bottom, Side, and Center reveal measurement height or width
Glazing Select the glazing class or none
Show Detail Select whether to draw various cabinet details. Select the cabinet and/or door class or none
Handles Click Handles to select a handle from the default content (see “Resource Libraries” on 

page 219); select a symbol from the graphical list of Symbols and click OK (or select the No 
Pull symbol to remove the handles)

Parameter Description

Number of Stalls Select the number of stalls to place together as a single, grouped object
Stall Width Enter the stall width
Stall Depth Enter the stall depth
Partition Thickness Enter the thickness for the stall partitions

Parameter Description
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3. Click OK to set the toilet stall parameters and close the Object Properties dialog box.
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Symbols in Walls

Clg Height
(Floor and Clg Mtd or 
Ceiling Mtd only)

Enter the height for ceiling-mounted stall supports

Partition Type Select the mounting type for the stall partitions
If none is selected for Partition Type, all parameters related to partitions, 
doors, or grab bars will not have any visible effect on the toilet stall

Left Partition Deselect to remove the left partition from the stall. If you have multiple stalls, this 
will only remove the farthest left partition.

Dividing Partition Select to include partitions between each stall
Right Partition Deselect to remove the right partition from the stall. If you have multiple stalls, this 

will only remove the farthest right partition.
Front Partition Deselect to remove the front partition from the stall. If the door is set to the front 

partition, the door is also removed. 
Door Select to include doors on each stall
Door Closed in 3D Select to display the stall door as closed in 3D views. Deselect to have the stall door 

open at an angle.
Show Door In Select which partition for the door to be a part of, if any. Doors cannot be set to the 

right or left partitions if there are multiple stalls in the toilet stall group.
Door Swing Select the direction the door opens
Door Width Enter the door width
Door Offset Enter the door offset from the partition
Fixture Position Select the position of the fixture within the stall
Show 2D Accessible Icon Display the accessible symbol in 2D view
Show Turning Circle Display the turning circle for wheelchair access in 2D view

The turning circle requires a minimum clear space in the stall 62” wide by 60” 
deep

Left/Rear/Right Grab Bar Select to place a grab bar on the stated side of the stall
Show Fixture Select to show the toilet fixture
Choose Fixture Select the desired toilet fixture from either the default content or the current file’s 

content. Select a symbol from the graphical list of Symbols and click OK.

Parameter Description



MEP Objects
HVAC
The Heating, Ventilating, and Air Conditioning (HVAC) tools and objects available in the Vectorworks Architect 
product add HVAC ducts and diffusers in a variety of configurations to a drawing. These geometric models can 
represent a variety of actual items. For example, the diffuser object can have its dimensions and parameters set to 
develop many differently sized diffusers, including industry standard sizes that can be predefined.
HVAC objects are available in [Vectorworks]\Libraries. These objects are accessed through the Resource Browser and 
consist of hybrid 2D/3D representations of common HVAC duct work elements. See “Using the Resource Browser” on 
page 221.
Duct work objects include optionally displayed labels and elevation marker tags. The label contents are determined by 
a user-defined string of values, such as width and height (obtained automatically) and any text desired. The elevation 
marker tag indicates the top and bottom above the finish floor of an HVAC duct work item; Show 3D Detail must be 
enabled to display the elevation marker tag. Both the HVAC label and elevation marker tag can be easily moved by 
dragging its control point to the correct location.

A diffuser report, containing a diffuser, register, and grille schedule, can be included. It can be added to the drawing 
from the VA Create Schedule command or the Resource Browser. From the Resource Browser, open the default 
architectural reports file from the [Vectorworks]\Libraries folder that is included with the Vectorworks Architect 
product. Drag the Diffuser Report worksheet to the drawing. An HVAC Diffuser, Register and Grille worksheet, 
populated with information from the objects in the current drawing, is automatically created.
For more information on labels, elevation marker tags, and HVAC reports, refer to the Duct_Object.pdf file included in 
[Vectorworks]\Extras.
~~~~~~~~~~~~~~~~~~~~~~~~~
Resource Libraries

Specify whether the duct is insulated
and/or lined and indicate the thickness

of the lining/insulation

Specify rectangular, round, or oval 
duct types (some ducts have 
additional options)

This value is added to top and 
bottom elevations, allowing ducts to 
be measured from the floor rather 
than the ceiling

Control Points

Label

Elevation Marker
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Electrical and Communication Circuiting
The communications and electrical circuiting tools and objects available in the Vectorworks Architect product add 
electrical and communication objects, including panels and disconnects, to a drawing. The circuiting tools link these 
objects, creating a communication or electrical circuit.
~~~~~~~~~~~~~~~~~~~~~~~~~
Electrical and Communication Objects
Circuiting Tool
Editing Circuits
Comm Device Tool
Conductor Sizing Calculator Command
Conduit Sizing Calculator Command
Creating Piping Runs

Electrical and Communication Objects
Electrical and communication objects are available from the MEP tool set and in specific object libraries (see 
“Resource Libraries” on page 219). These objects are accessed through the Resource Browser, and consist of hybrid 
2D/3D representations of common electrical devices. These symbols already have the correct records attached for 
proper circuiting. See “Using the Resource Browser” on page 221.
It is also possible to create custom electrical symbols, panels and disconnects; attaching the correct record to these 
symbols makes them circuitable. See “Creating Custom Electrical and Communication Symbols” on page 683 for 
information.

Naming Panels
When inserting panels (electrical or communication) from object libraries, give each panel its own name so that it can 
be uniquely identified by the Circuiting tool.
To identify an inserted panel with a unique name:

1. Insert the panel from the Resource Browser.
2. With the panel still selected, click the Data tab in the Object Info palette. Provide the unique panel name under the 

Panel record information.

Click on the default
name to edit it

Click on the Panel record
to change the name

Provide a unique name for
the panel by typing it here
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Circuiting Tool
Once electrical or communication panels and objects have been inserted, the Circuiting tool links the objects by 
assigning each item a circuit number and associating it with a panel board.

The symbol or object that is being circuited must be on a visible (not grayed) layer. If the symbol is not on the 
active layer, the symbol is copied to the active layer, and then the record information is attached. This is designed 
so that an electrical engineer can use workgroup referencing to access architectural layers with preliminary outlet 
locations. The engineer can then copy those outlets to the proper layer without re-entering data.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Circuit
Adding to a Circuit

Creating a Circuit

To create a circuit:

1. Click the Circuiting tool from the MEP tool set.
2. Click on the first item to be circuited.

If selecting a custom symbol without a Circuiting record attached, the tool attaches the record to the current 
symbol, as well as to all subsequent symbols in the circuit. In this case, specify whether an electrical or 
communication circuit is being created.
When creating a circuit, do not include the panel symbol.
Based on the item’s record, the tool determines whether this is an electrical or communication device. The 
Circuiting Tool dialog box opens.

Click to show/hide the parameters.

Parameter Description

Circuit Information Enter the circuit information (used on the panel schedule)
Panel Select the associated panel
Circuit # Enter the circuit number
Trip Enter the trip rating
Wire Size Enter the size of the wire
Conduit Size Enter the conduit size
V.A./Watts Enter the total V.A./Watts rating
Remarks Enter remarks for the circuit
Check Voltage and Phase of 
Circuit Items

Select to verify that the voltage and phase of circuited items is correct

Draw circuiting lines Select to draw connecting circuiting lines
Overwrite existing object data Select to apply the current object information to all objects in the circuit
Object Data Enter parameters for the object being circuited

Phase/Pole Enter the number of phases/poles
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3. Enter the desired information for the circuit and the objects in the circuit, and click OK.
The information is transferred to the object’s record.

4. Continue clicking on the items to be circuited in the order the circuit loop should be drawn.
5. To complete the circuit, click in an empty area of the drawing. Confirm that you wish to place the Home Run 

marker.
The Circuiting tool generates a Home Run marker and phases are denoted as specified.

Adding to a Circuit

To add an item to an existing circuit:

1. Click the Circuiting tool from the MEP tool set.
2. Click the communication or electrical device from which to begin the new circuit connection.

A notice displays, asking if additional items are to be added to this circuit. Click Yes.

3. Click the item to add to the circuit, and then select the next item in the circuit.

To complete the circuit, click away from any selectable objects. A notice displays asking if you wish to continue. 
Click No to end this procedure.
If adding an item at the end of a circuit, place the third click anywhere on the drawing. The item is chained to the 
item that previously had the Home Run marker attached. A notice displays, confirming whether to place the Home 
Run. Click Yes. The Circuiting tool generates a Home Run marker and phases are denoted.

Voltage Enter the voltage
V.A./Watts Enter the V.A./Watts for this object
Remarks Enter remarks for the object

Parameter Description

Circuit
Home Run marker

Click 1

Click 2

Click 3
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Editing Circuits 
The Edit Circuiting tool modifies existing circuit information. Use this tool to reassign circuit numbers and update the 
information attached to the circuited elements.

To edit existing circuits or a circuited item:

1. Click the Edit Circuiting tool from the MEP tool set.
2. Click on the circuited item to be edited.

The Edit Circuit Tool dialog box opens.
Click to show/hide the parameters.

3. Select the operation to perform.
If there are multiple records attached to this item, select the record to edit from the Circuit To Edit list. The record 
information displays in the Circuit Tool dialog box.

4. Click OK.

Parameter Description

List of editing operations Selects the editing operation to perform.
Select Edit circuit information only to edit the information which applies to the 
entire circuit. Select Edit selected item only or Edit all items on the circuit to 
enter edits which apply only to the selected circuiting item or edit both circuit and 
circuited object information. Select Delete selected item only or Delete entire 
circuit to delete the circuited item from the circuit or delete the entire circuit (the 
circuited items remain on the drawing).

Circuit to Edit Selects the specific circuit to edit; available if selected item has multiple circuit 
assignments associated with it

Circuit Information Enter the circuit information (used on the panel schedule)
Panel Name Select the associated panel
Circuit # Enter the circuit number
Trip Enter the trip rating
Wire Size Enter the size of the wire
Conduit Size Enter the conduit size
V.A./Watts Enter the total V.A./Watts rating
Remarks Enter remarks about the circuit
Check Voltage and Phase of 
Circuit Items

Select to verify that the voltage and phase of circuit items is correct

Item Data Enter parameters for the object being circuited
Phase/Pole Enter the number of phases/poles
Voltage Enter the voltage
V.A./Watts Enter the V.A./Watts for this object
Remarks Enter remarks for the object
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Comm Device Tool
The Comm Device tool inserts an indicator and basic specifications to indicate the type and location of a 
communications device.

To insert a communications device:

1. Select the Comm Device tool from the MEP tool set.
2. Click to place the object into a wall and click again to set the rotation of the object. 

If this is the first time a communications device has been placed on the drawing, the Object Properties dialog box 
opens. Before placing the object, specify the preferences to use for this tool during this session, or accept the 
default values.

3. Click OK. 
Object instances can be modified in the Object Info palette after insertion.

Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using options 
on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 and 
“Formatting Text” on page 389.

2D Scale Factor Set the size of the communications device indicator; increase the scale value to obtain a 
larger object. Indicators maintain a constant size regardless of the drawing scale.

Config Select the configuration of the communications device, which is indicated by a 
preformatted shape

Config Label Type the label for the communications device
Mtg Height AFF Set the mounting height above the finished floor

Telephone Data Sound

Staff PushbuttonNurse CallClockFire AlarmPaging

Data/Voice TV/Cable Watchman

Bell TransformerBell/Buzzer Electric Door OpenerChime
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~~~~~~~~~~~~~~~~~~~~~~~~~
Electrical and Communication Objects

Sizing Calculators
The Vectorworks Architect product provides sizing calculators for performing calculations and adding drawing 
specifications without leaving the program.
The software includes a standard database of wire specifications used for the Conductor Sizing and Conduit Sizing 
calculators. The database contains the names, dimensions, and physical properties of a selected group of wiring types.
~~~~~~~~~~~~~~~~~~~~~~~~~
Conductor Sizing Calculator Command
Conduit Sizing Calculator Command
Creating Piping Runs

Conductor Sizing Calculator Command
The Conductor Sizing Calculator reports the correct wire size for a given load, based on a single conductor and the 
length of travel.
To perform conductor sizing calculations: 

1. Select AEC > Electrical > Conductor Sizing Calc.
The Conductor Sizing Calculator dialog box opens.

Click to show/hide the parameters.

Show 3D Detail Select to show a communications device wall plate in 3D views. If Show 3D Detail is not 
selected, a 3D locus will indicate the device’s location in 3D views.

Parameter Description

Calculate Select the type of calculation to perform
Phase Factor Specifies the phase factor
Wire Properties Enter the known conductor parameters; values returned by the calculation will 

appear dimmed
Type/Manuf. Select the wire type or manufacturer
Size/Part Number Select the wire size or the manufacturer part number
Sectional area of the wire, 
cmil

Enter the cross sectional area of the conductor wire in cmils

Approximate AWG Enter the approximate AWG (American Wire Gauge) of the conductor
Resistance of conductor 
material at 75c

Enter the resistance of the conductor material at 75c

Temperature (c) Enter the operating temperature in Celsius
Amps Enter the amp rating
Length (ft.) Enter the conductor length in feet

Parameter Description
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2. Select the type of calculation to perform, based on the current parameters, from the Calculate list.

3. Enter the required values in the fields. Fields where the result will be displayed appear dimmed. Some calculations 
require the selection of the wire type or manufacturer, as well as the wire size or part number. When all the 
required parameter values are complete, the Calculate button becomes available; click to perform the calculation.

4. The calculation results are displayed. Select another calculation to perform or click Close to exit.

Conduit Sizing Calculator Command
The Conduit Sizing Calculator reports the proper size conduit(s) required for a given set of wires.
To perform conduit sizing calculations:

1. Select AEC > Electrical > Conduit Sizing Calc.
The Conduit Sizing Calculator dialog box opens.

Click to show/hide the parameters.

Type Select whether the conductor type is Aluminum or Copper, and then enter an 
Alpha value if other than standard

Voltage Drop Select whether the voltage drop is a Percentage or Absolute. If a percentage, 
enter the value.

Voltage Enter the working voltage
Calculate Performs the selected calculation

Calculation Description

Wire Size Provides the sectional area of the wire (cmil) and the approximate AWG for wire 
sizes below 250 kcmil

Ohms/ft/cmil-ft Calculates the resistance per sectional area of wire
Voltage Drop Calculates the voltage drop across the length of the conductor, either as a 

percentage or absolute value
Phase Factor Provides the phase factor value of the conductor
Voltage Calculates the voltage value of the conductor
Ampacity Determines the amp rating of the conductor
Length of Run Calculates the allowable length of the conductor specified for the load given

Parameter Description

Conductor Item
Type/Manufacturer Using the information contained in the wire specifications database, select a wire type or 

manufacturer
Size/Part Number Select a wire size or part number
Number of 
conductors

Enter the number of conductors of this type and size

Parameter Description
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2. When calculations are complete, click Close.

Creating Piping Runs
Determine the section lengths and amount of material required for piping runs. Piping runs can be drawn by clicking 
the Piping Run tool from the MEP tool set, by drawing a polygon and selecting the Create Piping Runs command, or 
by drawing a polyline and selecting the Create Objects from Shapes command (see “Creating Objects from Shapes” 
on page 277).
To create a piping run:

1. Draw one or more polygons to represent the piping run.
2. With the polygon(s) selected, choose AEC > Electrical > Create Piping Runs.

The piping run results are displayed and can be edited in the Object Info palette. An existing piping run can be 
reshaped with the Reshape tool, and the path polyline can be edited by selecting Edit from the context menu (see 
“Object Editing Mode” on page 1004).

Click to show/hide the parameters.

C-S Area of 
conductor in sq 
inches

The cross-sectional area of the specified conductor displays

Add >> Click to include the specified conductors in the conduit
Remove Click to removed a selected conductor from the Conductors Currently in Conduit list
Clear All Click to remove all conductors from the Conductors Currently in Conduit list
Conductors Currently 
in Conduit

Displays a list of conductors currently included in the conduit

Conduit Type Select a conduit type
Number of conduits Specify the number of conduits
Conduit stuff 
percentage

Specify a conduit stuff percentage; the percentage suggested by the software can be 
modified

Results
Actual Conduit Size 
required in inches

Displays the actual size of conduit required

Nominal Conduit 
(Trade) size 
required in inches

Displays the nominal (trade) size of conduit required

Parameter Description

Conduit Size Specifies the diameter of the conduit
Material Select the piping run material from the list; this selection can be displayed in the piping run tag
Remarks Specify any remarks to be displayed in the piping run tag

Parameter Description
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The piping run does not count turns at a junction box (at the location of an electrical object).

Panel Scheduling and Diagramming

Creating a Panel Schedule
The Create Panel Schedule command generates panel schedules based on the circuiting information assigned to the 
file. If necessary, modify the dimensions and layout of the panel to conform to existing office standards.
To create a panel schedule:

1. Select Tools > Reports > Create Panel Schedule.
The Create Panel Schedule dialog box opens. Specify the panel schedule criteria and click OK.

Click to show/hide the parameters.

Show Tag Select to display the piping run Conduit Size and Material

Show Remarks Select to display the piping run Remarks; Show Tag must be selected in order to display the 
remarks

Length Displays the length of the piping run
Section Length Specifies the length of piping run sections; edit this parameter to determine various piping run 

requirements
Num of Runs Specify the number of runs; increase the number to estimate the additional material required for a 

project
Num of 
Sections

Displays the number of sections required

Couplings Displays the number of couplings required
Turns Specifies the type of turns to use for the piping run corners

Use Bends Bends the conduit and includes the bend in the length
Use Elbows Counts the number of 45° and 90° elbows and displays the number

Radius Specify the bend radius
45s / 90s Displays the number of elbow turns (when Use Elbows is selected)

Parameter Description

Panel list Select a panel from the list of available panels for creating the schedule
Place in worksheet Select to place scheduling information in a worksheet resource named with the 

panel name
Place in Document Select to place a panel schedule on the drawing
Choose Schedule Indicates the location for placing the panel schedule on the drawing

Layer Specifies the layer for placing the schedule

Parameter Description

1/2” Aluminum Rigid 12 AWG
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2. If placing the schedule on the drawing, click at the desired location.

If placing the panel schedule in a worksheet, a worksheet is created with the panel name.
If circuiting changes are made, delete the outdated panel schedule and repeat the create panel schedule procedure.

~~~~~~~~~~~~~~~~~~~~~~~~~
Changing the Panel Schedule Format
Creating Panel Riser Diagrams

Changing the Panel Schedule Format
To format a panel schedule:

1. Select Tools > Reports > Create Panel Schedule.
The Create Panel Schedule dialog box opens.

2. Select the panel schedule and its location.
3. Click Edit.
4. The Schedule Formatting dialog box opens. Select the schedule to format from the Schedule list. A list of 

available fields and, if applicable, the schedule’s printed name displays.
Click to show/hide the parameters.

Class Specifies the class for the schedule
Panel Style Select the panel formatting style from the list
Edit Changes the panel schedule formatting

Parameter Description

Schedule Select the schedule to format
Printed Name Specifies the name that is printed on the schedule 
Available Fields Lists all possible schedule column items
Schedule Columns Lists, in order, all included schedule columns
Move > Moves a selected item from the Available Fields list to the Schedule Columns list
< Move Moves a selected item from the Schedule Columns list back to the Available Fields list
Move Up / Move Down Moves a selected item in the Schedule Columns list to adjust the list order
Printed Schedule Width Specifies the total width of all schedule columns when printed

Parameter Description
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The columns shown in the Column Order list appear in the schedule in order.
Panel schedule formatting is stored as a worksheet named “Panel Schedule Fmt.” This worksheet can be imported, 
using the Resource Browser, into other files where the same formatting is desired.

5. Click OK to return to the Create Panel Schedule dialog box. Click OK to place the schedule with the specified 
format.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Panel Schedule
Creating Panel Riser Diagrams

Creating Panel Riser Diagrams
Panel riser diagrams summarize the electrical panels and disconnects in a project file.
To create a panel riser diagram:

1. Select Tools > Reports > Create Panel Riser Diag.
2. Click on the drawing to place the panel(s) at that location.

Panels and disconnects can be rearranged, edited and annotated; graphics can be added to complete the panel riser 
diagram. If the panels are regenerated, any edits are lost. Once the panels have been generated, they can be 
arranged into a completed panel diagram, as seen in the following illustration:

Column Headers Displays the current font, style, and size for header information in the schedule. Click 
Change to edit the font format.

Body Displays the current font, style, and size for body text in the schedule. Click Change to 
edit the font format.

Parameter Description

A panel displays the Panel Name, Number of Phases/Poles, 
Voltage, Amps, Number of spaces, Device Name, and 
Circuit where it is connected

A disconnect displays the Disconnect 
Name, Number of Phases/Poles, 
Voltage, Amps, Device Name, and 
Circuit where it is connected
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Panel Schedule
Changing the Panel Schedule Format

Creating Custom Electrical and Communication Symbols
The Vectorworks Architect product includes many pre-defined electrical and communication objects in its object 
library files. However, there is no need to be restricted to these objects; creating custom panel and circuiting symbols is 
also possible.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Custom Panels
Creating Custom Circuit Symbols

Creating Custom Panels
Electrical, communication, and disconnect panel symbols can be created specifically to fulfill a custom requirement.
To create a panel symbol:

1. Draw the object to represent the panel.
2. Convert the object into a symbol by selecting Modify > Create Symbol. Provide a name for the panel. See 

“Creating New Resources” on page 228.
3. The panel symbol requires both a panel and circuiting record. If the file does not contain panel and circuiting 

records, create the records according to the following formats.

Panel Record 

Field Type Contents

Name Text Must be unique
Type Text Must be Electrical, Communication, or Disconnect
Phase Integer 1
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Circuiting Record 

4. Select the symbol from the Resource Browser, and then click Resources > Edit.
The Edit Symbol dialog box opens.

5. Click 2D Component, and then click Edit.
6. In the Edit Symbol window, deselect all symbol components.
7. Attach the panel record to the symbol by selecting it from the Data tab in the Object Info palette. Enter the panel 

information by selecting a record field and entering its record information; the circuiting tools will use this 
information.

Volts Text 117
Amps Integer 100
# of Spaces Integer 20
Panel Header Line 1 Text Text placed on Panel Schedule
Panel Header Line 2 Text Text placed on Panel Schedule

Field Type Contents

Name Text None
Circuit # Integer 0
Wire Size Text 0
Trip Integer 0
Conduit Size Text 1/2
V.A./Watts Integer 0
Remarks Text Panel
Phase/Pole Integer 2
Voltage Text 0
Circuit Type Integer 1 for electrical device, 2 for communication device
UID Text 0
ID Text 0

Field Type Contents
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Click to show/hide the parameters.

8. Attach the circuiting record to the symbol and enter the circuiting information by selecting a record field and 
entering its record information; the circuiting tools will use this information.

Parameter Description

Name The Name field changes for each symbol later, when it is placed on the drawing
Type Specifies Electrical, Communication, or Disconnect
Other Panel Parameters Enter specific information about the panel
Panel Header Line 1/2 Text specified here is placed on the panel schedule
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Click to show/hide the parameters.

9. Click Exit Symbol at the top right of the drawing window.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Custom Circuit Symbols

Creating Custom Circuit Symbols
Electrical and communication circuit symbols can be created specifically to fulfill a custom requirement.
To create a circuit symbol:

1. Draw the object to represent the circuitable symbol. 
2. Convert the object into a symbol by selecting Modify > Create Symbol. Provide a name for the circuitable item. 

See “Creating New Resources” on page 228.
3. If the file does not contain a circuiting record, create the record according to the following format.

Parameters Description

Name Leave this field blank
Circuit # Enter 0 (zero) for this parameter
Other Circuit Parameters Enter specific information about the circuit
Circuit Type Set to 1 for an electrical symbol, and to 2 for a communication symbol
UID Enter 0 (zero) for this parameter

Field Type Contents

Name Text None
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4. Select the symbol from the Resource Browser, and then click Resources > Edit.
The Edit Symbol dialog box opens.

5. Click 2D Component, and then click Edit.
6. In the Edit Symbol window, deselect all symbol components.
7. Attach the circuiting record to the symbol by selecting it from the Data tab in the Object Info palette. Fill out the 

circuiting information by selecting a record field and entering its record information; this information is displayed 
and edited by the circuiting tools.

Click to show/hide the parameters.

Circuit # Integer 0
Wire Size Text 0
Trip Integer 0
Conduit Size Text 1/2
V.A./Watts Integer 0
Remarks Text Panel
Phase/Pole Integer 2
Voltage Text 0
Circuit Type Integer 1 for electrical device, 2 for communication device
UID Text 0
ID Text 0

Field Type Contents
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8. If the symbol requires more than one circuit, create and attach a second identical record named Circuiting 
Record-1.

9. Click the Exit Symbol button located at the top right of the drawing window.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Custom Panels

Parameters Description

Name Leave this field blank
Circuit # Enter 0 (zero) for this parameter
Other Circuit Parameters Enter specific information about the circuit
Circuit Type Set to 1 for an electrical symbol, and to 2 for a communication symbol
UID Enter 0 (zero) for this parameter



Site Modeling
Sitework Overview
The sitework-related commands allow the development of complex 2D and 3D models of site terrain in the 
Vectorworks Architect and Landmark products. The Vectorworks Landmark product contains certain additional 
commands.
The source data for a site model is the 3D information used to create a representation of the existing site. The 
information can be in the form of 3D loci, 3D polygons, or surveyor data. The site model object created from the source 
data contains both 2D and 3D site information, and it can be copied to other layers and files. Special “snapshot” copies 
of the site model allow different forms of site model to be shown side by side.
Once generated, two forms of the site model can be displayed—the existing site model and the proposed site model. 
The existing site model is a direct representation of the source data, including any existing site modifications. The 
proposed site model is the existing site model, plus the geometric effects of proposed site modifiers, such as roads and 
pads. The existing and proposed site models can be displayed or hidden at creation or from the Object Info palette.
Site models use the Triangulated Irregular Network (TIN) method to connect input data. This method can work with 
data that are scattered and in clumps—they do not have to be organized in a rectangular grid. The model uses all the 
data, without doing approximations, to create a network of triangles. These triangles form the terrain model; the model 
then performs interpolation to calculate the threading of contour lines.
After generation, the site model is cached so that updating occurs more efficiently; however, large file sizes can result. 
See “Setting Document Preferences” on page 60.
To upgrade a site model from a previous version of the Vectorworks program, see “Migrating from Previous Versions” 
on page 28.
~~~~~~~~~~~~~~~~~~~~~~~~~
Site Model Source Data
Creating the Site Model
Setting Site Model Properties

Site Model Source Data
There are four commands available to input source data into a drawing for the development of a site model; each uses a 
different type of source information.

• Import Survey File
• 2D Polys to 3D Contours
• 3D Polys to 3D Loci (Vectorworks Landmark only)
• Grid Method Entry

In addition, stake objects, 3D loci, or 3D polygons can be used directly as the source data for the site model. No 
conversion is necessary before using this type of source data.
The Modify by Record command can convert 2D polygons or polylines with attached record elevation data directly to 
3D contours at the proper elevation. See “Modifying Objects by Record Value” on page 270.
Before you create the site model, check the source data with the Validate 3D Data command to ensure that a valid site 
model will be created.
~~~~~~~~~~~~~~~~~~~~~~~~~
Importing Source Data from an External File
Adding Source Data with 2D Polygons
Converting 3D Polygons to 3D Loci
Adding Source Data by Grid Method Entry
Validating 3D Source Data



  690 | Site Model Source Data
Simplifying 3D Polygons

Importing Source Data from an External File
Site model source data can be generated by tabular coordinate information from an external file. This file must be a text 
file with fields delimited by separators in one of the formats available.
To import survey information for use as source data:

1. On the layer to receive the imported data, select Active Layer Scale from the drawing context menu to set the 
scale, or select the File > Document Settings > Document Setup command (see “Document Setup” on page 76).

2. Select the Import Survey File command from the appropriate menu:
• Architect workspace: AEC > Survey Input > Import Survey File
• Landmark workspace: Landmark > Survey Input > Import Survey File 
The standard Open File dialog box opens. Select the file to import.

3. The Import Survey File dialog box opens. Specify the file format options, scrolling through each line of data if 
necessary, and set the file import options.

Click to show/hide the parameters.

4. Click OK.
As each line of the file is read, either 3D loci or stake objects are inserted into the drawing at the coordinates specified 
by the file. If this is the first time a stake object has been inserted in the drawing, the Object Preferences dialog box 
opens. Accept the defaults and click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating the Site Model

Parameter Description

Data from selected file Displays the first line of data in the selected file
Line # Displays the line number of the data displayed; click the < or > button to check each line in 

the file
File format Select the file format of the imported file

Units Select the unit of the imported file
Field separator Specifies the file field delimiter

Tab delimited Select if fields are separated by tabs
Other character If fields are not separated by tabs, select Other character and then enter the character 

separating each field
Import Options

Create Stake 
Objects

Places stake objects to represent each 3D point in space, with text to display the elevation 
when in Plan view (see “Inserting Stake Objects” on page 769). Stake objects include the 
appropriate Easting, Northing, and Elevation values.
For big sets of source data, creating large numbers of stake objects could result in 
performance issues. It may be preferable to create 3D loci instead.

Create 3D Locus 
Objects (imports 
only location)

Places 3D loci, which contain only location information (X, Y, and Z coordinate)
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Modifying Objects by Record Value

Adding Source Data with 2D Polygons
Another way to generate the site model source data is to draw, trace, or import 2D polygons representing contours; then 
use the 2D Polys to 3D Contours command to convert the polygons to 3D polygons.

The Modify by Record command can convert 2D polygons or polylines with attached record elevation data 
directly to 3D contours at the proper elevation. See “Modifying Objects by Record Value” on page 270.

To generate source data with the 2D Polys to 3D Contours command:
1. Create or import the 2D polygons representing contour lines.

Polylines cannot be used. If contours are drawn with polylines, convert them to polygons first with the Modify > 
Convert > Convert to Polygons command.

2. Select the 2D Polys to 3D Contours from the appropriate menu:
• Landmark workspace: Landmark > Survey Input > 2D Polys to 3D Contours
• Architect workspace: AEC > Survey Input > 2D Polys to 3D Contours
The 2D Poly to 3D Contour Setup dialog box opens. Enter the first elevation and change in elevation between 
contour lines, and then select the type of object to be created.

Click to show/hide the parameters.

3. Click OK.
The Set Elevation dialog box opens, and the first polygon in the drawing order is highlighted. If necessary, use the 
Up or Dn buttons to set the elevation of the highlighted polygon, and then click Next. When prompted, indicate 
whether to delete the original 2D polygons.

Click to show/hide the parameters.

4. Repeat for all of the polygons in the drawing.
To interrupt this process, click Done. To resume setting elevations, select the starting polygon and select the 2D 
Polys to 3D Contours command.

Either 3D polygons or loci are created from the 2D polygons, with Z values equal to the assigned elevations. These Z 
values can be edited in the Object Info Palette if they are incorrect.

Parameter Description

Start Elevation Indicates the elevation of the lowest contour in the drawing
Interval Specifies the change in elevation from one contour line to the next
Create 3D Polygons/3D Loci Select whether to create 3D polygons or 3D loci

Parameter Description

Up/Dn Changes the elevation of the selected polygon
Use same height as prev. Sets the elevation for successive polygons to the same value
Next Selects the next polygon
Done Stops setting polygon elevations; click when all the polygon elevations have been 

specified
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~~~~~~~~~~~~~~~~~~~~~~~~~
Validating 3D Source Data
Simplifying 3D Polygons
Creating the Site Model

Converting 3D Polygons to 3D Loci
The 3D Polys to 3D Loci command converts the vertices of 3D polygons into 3D loci. These loci can then be used to 
create the site model.
To create 3D loci from 3D polygons:

1. Select the 3D Polys to 3D Loci command from the appropriate menu:
• Designer workspace: AEC > Survey Input > 3D Polys to 3D Loci
• Landmark workspace: Landmark > Survey Input > 3D Polys to 3D Loci
The 3D Poly to 3D Loci Command dialog box opens.

2. To remove the 3D polygons, select Delete original 3D polygons.
3. Click OK. The vertices of any 3D polygons located in the current layer are converted to 3D loci. The loci retain 

the Z values of the original polygons. These 3D loci can then serve as source data for the site model, or can be 
converted to stake objects and modify an existing site model.

~~~~~~~~~~~~~~~~~~~~~~~~~
Validating 3D Source Data
Creating the Site Model
Converting 3D Loci to Stake Objects

Adding Source Data by Grid Method Entry
The Grid Method Entry command creates a rectangular grid of points on the screen, and prompts you to enter the 
elevations of those points. The Create Site Model command then creates a topographical model based on those points.
Use this method when the source data is extracted from a paper map. Draw a grid on the map, and then determine the 
elevation of each grid intersection by interpolation between adjacent contour lines. Use these elevation values to create 
the grid.
To generate source data using grid method entry:

1. Select the Grid Method Entry command from the appropriate menu:
• Architect workspace: AEC > Survey Input > Grid Method Entry
• Landmark workspace: Landmark > Survey Input > Grid Method Entry
When prompted, click at the upper left corner of the grid.

2. After the starting point is picked, the Point Entry Grid Setup dialog box opens.
Enter the number of rows and columns of points to be created, as well as the distance between the points (Grid 
Spacing), and then click OK. A grid of red 3D loci is created.

Original 3D polygons Resulting 3D loci



Site Model Source Data |  693
3. The Enter Z Values dialog box opens.
The first point on the drawing, at the upper left hand corner, is automatically selected. Enter the elevation of the 
point, and click Next. The elevation is applied to that point, and then the second point in that row is automatically 
selected. Enter the elevation for that point; continue until elevations have been entered for all of the points in the 
grid, and then click Done.

~~~~~~~~~~~~~~~~~~~~~~~~~
Validating 3D Source Data
Simplifying 3D Polygons
Creating the Site Model

Validating 3D Source Data
Use the Validate 3D Data command before you create the site model, to check the 3D source data for errors. Even if a 
site model already exists, the source data can be checked. If problems occur due to erroneous site model source data, 
error alerts are automatically displayed. A site model with errors can still be created; however, results may not be as 
expected.
The following problems can generate errors:

• Duplicate 3D data points or polygons
• 3D data points that are coincident or vertically placed
• Crossing contours (3D polygons) in the 3D source data

To validate 3D source data:
1. Select the source data (3D loci, 3D polygons, or stake objects) to be checked.
2. Select the Validate 3D Data command from the appropriate menu:

• Architect workspace: AEC > Terrain >Validate 3D Data
• Landmark workspace: Landmark > Validate 3D Data

3. If the source data are valid, a dialog box states that no problems were found. Proceed with creating the site model 
as described in “Creating the Site Model” on page 694.

4. If there are errors in the source data, the Problems with Site Model Source Data dialog box opens.
Problems encountered are listed, and some conditions have an associated button for correcting each error by 
modifying or deleting the erroneous data.
If a site model already exists, the problem data can be viewed by selecting the site model and selecting Modify > 
Edit Site Model, or right-clicking (Windows) or Ctrl-clicking (Mac) and selecting Edit Site Model Source Data 
from the context menu. Problem data conditions are highlighted and annotated.

5. When problem correction is complete, click Close.
Select Validate 3D Data again to ensure that the errors have been corrected.

~~~~~~~~~~~~~~~~~~~~~~~~~
Simplifying 3D Polygons
Correcting Site Modifier Errors

Simplifying 3D Polygons
If the existing site model was created from 3D polygons (not 3D loci), you can reduce processing time by removing 
redundant polygon vertices within a specified tolerance. For example, this removes extra vertices in straight or 
nearly-straight segments of imported 3D polygons used as source data. This feature does not significantly change the 
appearance of the site model, but it can dramatically decrease the time it takes to process the model.
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The Simplify 3D Polygons command available in Vectorworks Architect and Landmark is specialized for certain 
site model workflows. To simplify 2D polygons, 3D polygons, and polylines in other workflows, see “Simplifying 
Polygons and Polylines” on page 1090.

To remove redundant 3D polygon vertices:
1. Select the 3D polygon(s). (The original polygons remain unchanged.)
2. Select the Simplify 3D Polygons command from the appropriate menu:

• Architect workspace: AEC > Terrain > Simplify 3D Polygons 
• Landmark workspace: Landmark > Simplify 3D Polygons 
The Simplify Selected 3D Polygons dialog box opens.

3. Enter a Simplification Tolerance value, and select a layer from the Put Simplified Result in Layer list.
4. Click OK.

Redundant vertices are removed from the 3D polygon(s) and the results are sent to the layer specified.
~~~~~~~~~~~~~~~~~~~~~~~~~
Validating 3D Source Data
Simplifying Polygons and Polylines

Creating the Site Model

Creating a Site Model from the Source Data
Once source data has been obtained for the site model, the site model can be created. After generation, the site model is 
cached so that updating occurs more efficiently; however, large file sizes can result. See “Document Display 
Preferences” on page 60.
To create a site model from source data:

1. Ensure that valid source data exists. The site model can be created from 3D loci, 3D polygons, stake objects, or by 
one of the methods described in “Site Model Source Data” on page 689. Verify that there are no problems with the 
source data with the Validate 3D Data command (see “Validating 3D Source Data” on page 693).

2. Select the source data.
3. Select the Create Site Model command from the appropriate menu:

• Architect workspace: AEC > Terrain > Create Site Model
• Landmark workspace: Landmark > Create Site Model
The Site Model Settings dialog box opens. Specify the site model parameters.

Click to show/hide the parameters.

Parameter Description

Site Model Name Enter a name for the site model object
Keep Original Source 
Data in Layer

Leaves a copy of the source data in the layer (the site model always retains a copy of 
the source data in its profile group). This parameter displays only during initial site 
model creation.

Settings
Minor Contour Interval Specifies the standard contour line placement interval
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Major Contour 
Multiple

Specifies the placement interval of major (heavy) contour lines

Start Contour Offset Controls the starting elevation of the 2D contours 

Maximum Elevation Specifies the highest contour elevation to be displayed. No contours are created if the 
maximum elevation is lower than the minimum elevation, but this can be useful for cut 
and fill calculations (for example, for pond or backfill volumes).

If a site model update will result in contours exceeding the minimum/maximum 
range, an alert displays, allowing the range to be adjusted.

Minimum Elevation Specifies the lowest contour elevation to be displayed
Datum Elevation Indicates the reference elevation used to define the bottom of a site model when the 3D 

Mesh Solid style is selected in 3D Display Settings; set to zero for normal cut and fill 
calculations

Flow Arrow Spacing Determines the placement of the flow arrows
3D Grid Spacing Sets the grid (mesh) size for 3D display; also determines flow arrow placement
Smoothing Interval When selecting a triangulation method for 2D and/or 3D site model display, sets the 

distance for adding new points to the contours. Certain site models, since they are 
created from randomly-located origin points, may have an uneven triangulation 
distribution. Smoothing forces the site model to create an even distribution of data 
points along each contour line, simulating even sampling. Enter zero to use the original 
contour points for triangulation. Low values may result in long calculation times.

2D Display Settings
Display Select whether to display the existing site model only, proposed site model only, or 

both existing and proposed site models. The display option can be changed later from 
the Object Info palette.

Existing Only Displays only the existing model, including any site modifiers that apply to the existing 
site model

Proposed Only Displays only the proposed model (the current model changed by any site modifiers 
that apply to the proposed site model)

Proposed + Existing Displays both the proposed model and the existing model; this option is useful when 
using the site model for a grading plan, with different existing and proposed 
topographical line styles

Style Select a 2D site model display mode
2D Contour Draws contour lines
2D Contour (smoothed) Smooths contour lines

Parameter Description

Start Contour Offset = 0
Minor Contour Interval = 1 
Major Contour Interval = 5

Start Contour Offset = 1
Minor Contour Interval = 1 
Major Contour Interval = 5

Start Contour Offset = 0.5
Minor Contour Interval = 1 
Major Contour Interval = 5
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2D Contour (colored 
elevations)

Draws contour lines and colors the elevations for conducting an elevation analysis 
(elevation analysis parameters are specified by clicking Graphic Properties and 
selecting the Site Analysis tab)

2D Contour (colored 
slopes)

Draws 2D contour lines by triangulation, according to the specified Smoothing 
Interval, and colors the slopes within specified angle ranges for conducting a slope 
analysis

2D Triangle Represents the surface as triangular facets
2D Triangle (colored 
slopes)

For 2D triangle display, colors the slopes within specified angle ranges for conducting 
a slope analysis (slope analysis parameters are specified by clicking Graphic 
Properties and selecting the Site Analysis tab)

2D Triangulated 
Contours

Draws 2D contour lines by triangulation, according to the specified Smoothing 
Interval

Show Flow Arrows Adds arrows to show the downward direction for drainage analysis
Show Labels Labels major 2D contour line elevations

Parallel to the topo line When labels are selected for display, labels are parallel to the topography lines
Draw Site Border Draws a closed 2D polygon along the site border (outer edge) of the site model
3D Display Settings
Display Select the 3D site model display. The display option can be changed later from the 

Object Info palette.
No 3D Display Displays only the 2D site model, with no 3D component
Existing Only Displays the existing 3D site model
Proposed Only Displays the proposed 3D site model
Cut and Fill Displays the 3D cut and fill volumes. Areas where existing and proposed site models 

are the same are represented by a flat area. Cut areas display as a depression in the 3D 
surface, and fill areas display as a raised area in the 3D surface. (Select cut and fill 
colors by clicking Graphic Properties and selecting the Site Model tab.)

Style Select a 3D site model display mode
3D Contour Draws the site model using horizontal 3D polygons
3D Grid Draws the site model using a regular grid (mesh) of horizontal four point rectangles, 

spaced by the 3D Grid Spacing value; the mesh can be colored, filled, and rendered 
with shadows

3D Mesh solid Groups 3D triangles to form a Vectorworks mesh; a skirt and bottom are added to 
create a valid solid

3D Triangle Generates 3D triangles with the Triangulated Irregular Network (TIN) method; this 
method is the most accurate, as it involves no interpolation

3D Triangles (colored 
slopes)

Generates 3D triangles with the Triangulated Irregular Network (TIN) method, and 
colors the slopes within specified angle ranges for conducting a slope analysis

3D Extruded Contour Creates horizontal solids with a thickness equal to the contour interval; top edges run 
along contour lines or the site border. This creates a “layer cake” or “chipboard model” 
effect.

Parameter Description
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4. Click OK.
A site model is created in the active layer and displays as specified.

~~~~~~~~~~~~~~~~~~~~~~~~~
Site Model Source Data
Setting Site Model Graphic Properties
Site Model Properties
Creating a Site Model Snapshot

Setting Site Model Graphic Properties
The site model 2D and 3D graphic display properties can be specified to obtain the desired graphic component colors 
and line styles. In addition, specify the colors for elevation and slope analyses, and for the 3D cut and fill volume 
representation. These graphic properties can be set when the site model is first created, or changed later from the Object 
Info palette.
To set the site model graphic properties:

1. When creating a new site model, click Graphic Properties from the Create Site Model dialog box. To edit a 
current site model, click Site Model Settings from the Object Info palette, double-click the site model, or 
right-click (Windows) or Ctrl-click (Mac) on a site model and select Edit from the context menu to open the Site 
Model Settings dialog box, and then click Graphic Properties from the Site Model Settings dialog box.
The Graphic Properties dialog box opens. 

2. On the Site Model tab, the 2D (existing and proposed) and 3D site model display can be completely customized by 
selecting the class and color for all components, as well as the line type, line thickness, and, for certain 
components, marker style. Double-click on a line to set attributes, or select the item and click Edit.

3D Triangulated 
Contours

Draws 3D contour lines by triangulation, according to the specified Smoothing 
Interval

3D Triangulated 
Contours (colored 
slopes)

Draws 3D contour lines by triangulation, according to the specified Smoothing 
Interval, and colors the slopes within specified angle ranges for conducting a slope 
analysis

Show 3D Grid Superimposes a 3D grid on the model; specify the grid spacing value in Spacing
Fill Displays 3D grid squares with a fill; Show 3D Grid does not need to be selected to 

display a filled grid
Show 3D Contour Superimposes a 3D contour on the model
Use Site Modifiers on

All Layers Modifies the proposed site model with modifiers from any layer in the file
Visible Layers Only Modifies the proposed site model with modifiers from visible layers only; modifiers on 

invisible layers do not affect the site model
Same Layer as Site 
Model only

Modifies the proposed site model with modifiers that exist only on the site model layer

Graphic Properties Specifies the site model appearance, along with slope and elevation analysis 
parameters

Parameter Description
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An Attributes dialog box opens. Select an overall class for each site model component to control its appearance 
and visibility. The classes present in the drawing are listed; alternatively, create a new class by selecting New, or 
select the class named <Site Model Class> which places the site model component in the same class as the site 
model object.
Each attribute (color, line type, line thickness, and marker) can be set to the “By Class “setting. The attributes are 
then controlled by the class assigned to the component. (See “Setting Class Attributes” on page 181.)

3. On the Site Analysis tab, set the slope and elevation analysis graphic parameters. A slope analysis shows the slope 
change of the site model with color ranges indicating the steepest to the shallowest slope. An elevation analysis 
shows the elevation change of the site model as a gradient of color from the minimum to the maximum elevation.

Click to show/hide the parameters.

Parameter Description

Slope Colors Specify the slope analysis settings
Number of slope 
categories

Indicate the number of slope levels to use in the analysis

Category __ maximum 
slope %

For each category, indicate the maximum slope percentage and its associated color; 
slopes below the specified percentage will be colored as specified

Slopes exceeding 
maximum category

Slopes above the maximum category’s percentage will receive the selected color

Elevation Colors Specify the elevation analysis color settings; a color gradient from the minimum to 
the maximum elevation is applied to the site model for the elevation analysis

Minimum Elevation 
Color

Select the starting color for the lowest elevation

Major contour

Minor contour

2D Contour style

Site border

Flow arrow

2D Triangle style

3D Grid style 3D Mesh Solid style Cut and Fill volumes
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4. Click OK to close the Graphic Properties dialog box.
5. To display a slope analysis, select a 2D display style of 2D or 3D Triangle (colored slopes), 2D Contour (colored 

slopes), or 3D Triangulated Contours (colored slopes) for the site model. To display an elevation analysis, select a 
2D display style of 2D Contour (colored elevations) for the site model.

Create a snapshot of the site model to easily display a slope or elevation analysis along with the site model (see 
“Creating a Site Model Snapshot” on page 704).

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Site Model from the Source Data
Site Model Properties
Cropping a Site Model
Creating a Site Model Snapshot
Sending Objects to the Site Model Surface

Setting Site Model Properties

Site Model Properties
The site model object can be copied, cut, pasted, rotated, and deleted like other objects. In 2D Top/Plan view, the 2D 
Display selected for the site model is shown; if both existing and proposed models are selected for display, they are 
superimposed. In any 3D view, the 3D Display selected (if any) is shown.
If the Renderworks product is installed, the site model can be textured from the Render tab of the Object Info palette. 
The texture is applied to the surface of the site model, and is scaled to fit the site model bounding box.
To see the original source data that were used to create the site model, select Modify > Edit Site Model, or select Edit 
Site Model Source Data from the site model context menu. Changes can be made to the source data, and the source 
data can be validated (see “Validating 3D Source Data” on page 693). Return to the site model by clicking Exit Source 

Maximum Elevation 
Color

Select the starting color for the highest elevation

2D Cut & Fill Area Draws a polygonal representation of the cut and fill over the 2D representation of 
the site model with the specified colors

Cut Volume Area Color Select the color for the volume that is cut from the site model
Fill Volume Select the color for the volume of fill required for the site model

Parameter Description

Slope analysis Elevation analysis
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Data at the top right of the drawing window. Click Update in the Object Info palette, or select Update from the site 
model context menu, to reflect any source data changes in the site model.

Select the Create Drape Surface command to create a “smoothed” version of the site model contours (see 
“Creating a Drape Surface” on page 337).

Once generated, the site model is cached so that updating occurs more efficiently; however, large file sizes can result. 
See “Document Display Preferences” on page 60.
In addition to the Site Model Settings dialog box, you can change many parameters of a selected site model from the 
Object Info palette.
Click to show/hide the parameters.

Parameter Description

Site Model 
Settings

Opens the Site Model Settings dialog box. The settings here (and the related graphic 
properties settings) are identical to those specified at site model creation. 

The option to keep or delete original source data is only available at site model creation.
Update Updates the site model and any associated snapshots, when the existing site data has changed 

or site modifiers have been added or changed
Create a Snapshot Creates a snapshot of the site model with the current site model settings, for displaying 

different versions of the site model
2D Display Select the display type for the 2D site model
2D Style Select the display style for the 2D site model
3D Display Select the display type (or no display) for the 3D site model
3D Style Select the display type for the 3D site model
Area Display Type Select the units for displaying the projected and surface areas for existing and proposed site 

models
Projected Area Displays the projected area (the area projected in plan view) of the site model
Surface Area 
(Existing)

Displays the 3D surface area of the existing site model

Surface Area 
(Proposed)

Displays the 3D surface area of the proposed site model (when one exists)

Update Cut and 
Fill Calculations

Recalculates the site model cut and fill; after modifying and updating the proposed site 
model, click to view the resulting cut and fill volumes (see “Creating a Spoil Pile Area” on 
page 714). When the calculated volumes indicate that updating is necessary, click to display 
the latest results.

Volume Display 
Type

Select the units for displaying the cut and fill volumes (or allows cut and fill volumes to be 
hidden, if desired)

Volume (Existing) Displays the total volume of the existing site model
Volume 
(Proposed)

Displays the total volume of the proposed site model

Cut Volume When the proposed site model has been modified by a site modifier, displays the volume cut 
from the site model 

Fill Volume When the proposed site model has been modified, displays the volume of fill added to the 
site model 
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~~~~~~~~~~~~~~~~~~~~~~~~~
Updating a Site Model
Cropping a Site Model
Reshaping the Site Model
Editing Contour Labels
Creating a Site Model Snapshot
Sending Objects to the Site Model Surface
Creating the Site Model

Updating a Site Model
If a site modifier object is moved or modified on any layer, the site model displays as an out-of-date site model with a 
red and white striped border. This indicates that the site model requires updating.
To update the selected site model:

1. Select the site model.
2. On the Object Info palette, click Update. 

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the site model and select Update from the context 
menu.

3. The selected site model is updated.

If the update causes the site model contours to fall outside the minimum/maximum elevation range specified in the 
site model settings, an alert displays, allowing the range to be adjusted.

~~~~~~~~~~~~~~~~~~~~~~~~~
Site Model Properties

Net C&F Volume Displays the net cut or fill volume, indicating whether fill is required or extra cut volume 
needs to be removed from the site 

Total C&F 
Volume

Displays the sum of the cut and fill volumes

Error Count When site modifier errors prevent the site model from updating correctly, displays the 
number of errors in red; see “Correcting Site Modifier Errors” on page 754

Show Errors Select to display site modifier error icons on the drawing, or deselect to hide the icons

Parameter Description
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Cropping a Site Model
The site model can be cropped by a custom site border shape. This allows you to limit the area of the site model, 
without permanently excluding the original extents of the source data. The original site model can easily be restored by 
editing the site model crop object.
To crop a site model:

1. Right-click (Windows) or Ctrl-click (Mac) on the site model and select Edit Site Model Crop from the context 
menu.

2. In site border editing mode, any existing site border object is selected. Move the site border, or use the Reshape 
tool to reshape (edit) the site border object; see “Reshaping Objects” on page 1043. The site border object can also 
be deleted and a new site border object can be created from any closed 2D shape.
To remove the cropping from a site model, delete the site border object. This restores the site model to its original 
bounds.

3. When the site border is ready, click the Exit Site Model Crop button (or select Modify > Exit Site Model Crop) 
to return to the drawing.

4. The site border crops the site model object.
With the Draw Site Border option selected in the site model settings, the site border displays in Top/Plan view. 
Adjust the color of the site border in the graphic properties of the site model settings.

~~~~~~~~~~~~~~~~~~~~~~~~~
Site Model Properties
Creating a Site Model Snapshot
Reshaping the Site Model
Creating the Site Model

Reshaping the Site Model
The edge of a selected site model displays a crop or border (select Draw Site Border in the Site Model Settings to 
draw a 2D polygon on the edge of the site model in Top/Plan view). In Vectorworks Architect or Landmark, the 
Reshape tool reshapes the crop. This is similar to editing the site model crop object as described in “Cropping a Site 
Model” on page 702.

To reshape the site model crop:

1. Select the site model.
2. Click the Reshape tool from the Basic palette, and click Edit Site Model Crop from the Tool bar.
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3. Reshape the site model crop as described in “Reshaping Objects” on page 1043. Crop vertices can be repositioned, 
added, and deleted.
The site model crop is immediately reshaped. No updating is necessary.

~~~~~~~~~~~~~~~~~~~~~~~~~
Cropping a Site Model
Site Model Properties

Editing Contour Labels
To change the font size of the contour labels, set the size from the Text > Size menu, and then click Update in the 
Object Info palette of a selected site model.
Normally, contour labels are distributed along the major contour lines at regular intervals. Occasionally, this is not 
desirable and a label needs to be moved. When a site model is selected, two additional modes are available for the 
Reshape tool. These modes allow the contour labels to be repositioned, added, and removed. 

Show labels must be selected in the Site Model Settings dialog box. 

To edit contour labels:

1. Select the site model.
2. Click the Reshape tool from the Basic palette, and click Edit Site Model Label Position from the Tool bar.

Each label on the major contours of the site model displays with a control point.

3. Use the Move Label Handle mode to move the label along the current contour line. Add Label mode adds a label 
along the contour line; click to add a label at that location. Finally, click on a label control point in Delete Label 
mode to remove the contour label.

Use the Move Polygon Handles mode of the Reshape tool in Edit Site Model Crop 
mode to move the site model crop vertex, reshaping the crop

By default, this contour label was placed 
in a crowded area of the drawing
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Only one contour label can be edited at a time. The Reshape tool marquee modes have no effect on contour label 
operations. See “Reshaping Objects” on page 1043 for more information. 
If the site model changes later, the relative label positions are preserved, reducing the need to reposition them 
again.

~~~~~~~~~~~~~~~~~~~~~~~~~
Site Model Properties
Creating a Site Model Snapshot
Reshaping the Site Model
Creating the Site Model

Creating a Site Model Snapshot
Creating a snapshot of the site model allows several display styles of the site model to be viewed at one time. The 
snapshot views cannot be edited directly; however, if the original site model is modified, the changes apply to all 
related snapshots automatically upon updating.

To create a site model snapshot:
1. Set the properties of the site model as desired for the snapshot. The snapshot’s appearance is based on the current 

site model settings, and its location is based on the original source data.
2. From the Object Info palette of a selected site model, click Create a Snapshot.
3. The snapshot is created on the active layer, over the original site model. The Object Info palette of a selected 

snapshot displays the parameters of the original site model, and cannot be changed for the snapshot (with the 
exception of the display units).

4. Any changes to the original site model are reflected in associated snapshots when clicking Update in the Object 
Info palette of the selected original site model.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Site Model from the Source Data
Updating a Site Model
Site Model Properties

Move Label Handle mode moves 
the contour label along the contour 
line; click to place it in its new 
location

Click on a contour line in Add Label 
mode to place a new label at that 
location

Click on a label control point in 
Delete Label mode to remove the 
label
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Sending Objects to the Site Model Surface
Trees, parking areas, retaining walls, site retaining modifiers, and other site objects may need to be placed on the 
surface of the model. For this purpose, use the Send to Surface command.

This command is effective for 3D loci, 3D polygons, extrudes, sweeps, meshes, slabs, light objects, walls, and 
symbols with a 3D component. If a 2D polyline or 2D polygon is selected, it will first be converted into its 3D 
equivalent before being sent to the surface.

To send an object to the surface:
1. Make the layer with the site model object the active layer.
2. Place the object on the active layer plane and move it to the desired location on the site model.
3. Select the Send to Surface command from the appropriate menu:

• Architect workspace: AEC > Terrain > Send to Surface
• Landmark workspace: Landmark > Send to Surface 
Alternatively, right-click (Windows) or Ctrl-click (Mac) on the object and select Send to Surface from the context 
menu (Vectorworks Landmark required).

4. If the object is a retaining wall or pad with retaining edge site modifier, the Send to Surface dialog box opens. 
Select the method of sending the object to the surface of the site model, and click OK.

Click to show/hide the parameters.

5. The correct Z value is given to the object’s insertion point, bottom-most point, or specified portion, placing the 
object on the surface of the site model.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Site Model from the Source Data
Site Model Properties

Site Model Modification Overview
As discussed in “Sitework Overview” on page 689, when the site model is generated, two different display modes of 
the site model object are available—existing and proposed. The existing site represents the site prior to your project; 
the proposed site incorporates the project’s changes. To modify the site model, use the Site Modifiers tool, along with 

Parameter Description

Elevate the retaining edge Sets the existing vertices of the retaining edge or retaining wall left/right edge to the 
surface elevation

Fit the retaining edge Fits the retaining edge or retaining wall left/right edge to the surface of the site 
model, modifying existing vertices and/or adding new vertices

Elevate the pad Sets the elevation of the retaining edge pad or retaining wall pad to the surface 
elevation; the edges remain unchanged
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other site modification tools in the Vectorworks program; a site modifier can be applied to either the existing or 
proposed site model.
Site modifiers can be placed on any layer. The site model properties specify whether modifiers in another layer can 
affect the site model (see “Creating the Site Model” on page 694). You might put various site modifiers on separate 
layers, for example, so that you can show each modifier’s effect on the site model individually. When a site modifier is 
placed in the drawing, the Site-DTM-Modifier class is created automatically.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Pad
Creating a Pad with a Retaining Edge
Creating Grade Limits
Creating a Spoil Pile Area
Creating a Texture Bed
Creating Custom Site Modifiers
Creating Roads
Creating NURBS Roadways
Creating Landscape Walls
Creating Hardscape Objects
Showing and Hiding Site Modifiers
Correcting Site Modifier Errors
Drawing Property Lines
Analyzing the Site Model
Obtaining Site Model Data

Creating a Pad
A pad is a 3D polygon representing the shape of an element which is to be added to, and normally, modifies, the site 
model. The modifier can be applied to the existing or proposed site model; the site model is modified when the site 
model is updated. Draw a pad with the Site Modifiers tool, or draw a polyline and then select the Create Objects from 
Shapes command to change it to a pad object (see “Creating Objects from Shapes” on page 277).

To create a pad:

1. Click the Site Modifiers tool from the Site Planning tool set.
2. Draw the pad object. Pads can be drawn closed or open (open pads are sometimes called “break lines”).

If this is the first time the Site Modifiers tool has been used, the Object Properties dialog box opens. Accept the 
defaults and click OK.

3. In the Object Info palette, select Pad in the Config field.
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4. If the pad is sloping, enter the Slope value (positive for rising, negative for falling), and select the slope definition 
unit (Angle or Percent in the SlopeDef field).
A slope arrow is automatically drawn on the pad, indicating the direction of the slope. The bull’s-eye at the start of 
the slope arrow indicates the zero elevation point of the sloping pad. Select the control points of the slope arrow to 
move either end. Deselect Show Slope Arrow to hide the slope arrow.

Click to show/hide the parameters.

The Site Modifiers tool generates a 3D pad polygon modifier that is always planar.
5. Normally, create grade limits around the pad.

Parameter Description

Config Indicates the type of modifier object
Elevation Sets the reference elevation of the pad at its control point; if a Z-height is also specified, the 

resulting elevation is additive
Slope Determines the angle of the pad; if the value is zero, the pad has no slope, and the following two 

parameters are not displayed
SlopeDef Select Angle or Percent to determine the slope units
Apply To Specifies whether the site modifier applies to the existing or proposed site model
Show Slope 
Arrow

If selected, displays a modifiable slope arrow and the current slope in Top/Plan view; Show 
Slope Arrow only displays if the slope is a value other than zero

 

Update 
Calculations

Updates the area and volume calculations displayed in the Object Info palette for the area of the 
site model located under the site modifier

Site model area 
and volume data

Displays the area and volume information for the site model area located under the site modifier; 
select the units for the area and volume. For more information, see “Site Model Properties” on 
page 699.

Reference Elevation control point

Slope directional 
control point

Pad 

Grade limits

Site modifiers before updating the site model
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6. The site model requires updating to reflect the pad modification. Select the site model and click Update from the 
Object Info palette.

For predictable results, pads should not overlap. All pads should be either completely inside or completely outside 
of all grade limits. Pads, including those that may be incorporated into plug-in objects (such as landscape walls) 
cannot cross outside the grade limits.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Pad with a Retaining Edge
Creating Grade Limits
Creating Grade Limits Automatically
Creating Custom Site Modifiers
Updating a Site Model

Creating a Pad with a Retaining Edge
A pad with a retaining edge is similar to a regular pad site modifier, but it includes an additional configuration that 
defines an edge around the pad, allowing the terrain to be shaped around the pad. For example, the retaining edge can 
be used to adjust the terrain around a hardscape, offering precise control over the cut and fill amounts.
The modifier can be applied to the existing or proposed site model; the site model is modified when the site model is 
updated. Draw a pad with the Site Modifiers tool, or draw a polyline and then select the Create Objects from Shapes 
command to change it to a pad object (see “Creating Objects from Shapes” on page 277).

To create a pad with a retaining edge:

1. Click the Site Modifiers tool from the Site Planning tool set.
2. Draw the pad object; the retaining edge is added automatically.

If this is the first time the Site Modifiers tool has been used, the Object Properties dialog box opens. Accept the 
defaults and click OK.

3. In the Object Info palette, select Pad with Retaining Edge in the Config field.

The existing site model is indicated 
with dashed lines in this example

The proposed site model has been modified 
by the pad, but only the area within the 
grade limit area has been changed

2D view Rendered 3D view
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4. If the pad is sloping, enter the Slope value (positive for rising, negative for falling), and select the slope definition 
unit (Angle or Percent in the SlopeDef field).
A slope arrow is automatically drawn on the pad, indicating the direction of the slope. The bull’s-eye at the start of 
the slope arrow indicates the zero elevation point of the sloping pad. Select the control points of the slope arrow to 
move either end. Deselect Show Slope Arrow to hide the slope arrow.

Click to show/hide the parameters.

The Site Modifiers tool generates a 3D pad polygon modifier that is always planar.
5. The retaining edge modifier is drawn separately, and it can be used to control the depression around the pad. 

Reshape the retaining edge either from the Object Info palette or with the Reshape tool.

Parameter Description

Config Indicates the type of modifier object
Elevation Sets the reference elevation of the pad at its control point; if a Z-height is also specified, the 

resulting elevation is additive
Slope Determines the angle of the pad; if the value is zero, the pad has no slope, and the following 

two parameters are not displayed
SlopeDef Select Angle or Percent to determine the slope units
Apply To Specifies whether the site modifier applies to the existing or proposed site model
Show Slope 
Arrow

If selected, displays a modifiable slope arrow and the current slope in Top/Plan view; Show 
Slope Arrow only displays if the slope value is other than zero

 

Update 
Calculations

Updates the area and volume calculations displayed in the Object Info palette for the area of 
the site model located under the site modifier

Site model area 
and volume data

Displays the area and volume information for the site model area located under the site 
modifier; select the units for the area and volume. For more information, see “Site Model 
Properties” on page 699.

Vertex 
parameters

Edits the path vertices; see “Editing Vertex-Based Objects” on page 1002

Move Select the portion of the retaining edge modifier to edit (vertex or edge), and then edit its Z 
value, or scroll through its vertices with the left and right arrows and change the selected 
vertex Z value

Edit For vertex selection made in Move, scrolls through the vertices, highlighting the currently 
selected vertex. Click the center button to highlight the selected vertex.

Z Sets the elevation of the modifier item selected in Move or the vertex selected in Edit

Reference Elevation control point

Slope directional 
control point
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• The Object Info palette vertex parameters include the ability to edit the Z value of the selected retaining 
modifier vertex or retaining modifier edge.

• The retaining edge site modifier can be reshaped with the Reshape tool, similar to reshaping walls (see 
“Reshaping Walls” on page 536). Move vertices, and add or delete vertices to reshape the retaining edge.

• The Send to Surface command can be used to send either the retaining modifier edge or the pad to the surface 
of the site model.

6. The site model requires updating to reflect the pad modification. Select the site model and click Update from the 
Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Pad
Creating Grade Limits
Creating Grade Limits Automatically
Creating Custom Site Modifiers
Sending Objects to the Site Model Surface
Updating a Site Model
Site Model Properties
Creating Objects from Shapes

Creating Grade Limits
Grade limits define the area of topographical transition between existing site data and the site modifiers enclosed 
within the grade limits; they can be thought of as a “limit of construction.” Outside the grade limits, the site remains 
unchanged; within the grade limits, the site model is defined by the pads. Grade limits can overlap, but cannot 
completely enclose, another grade limit area. Grade limits should not cross a pad or spoil pile.
Grade limits are created automatically around certain site modifiers, such as massing models. Grade limits can also be 
created automatically from pads (Vectorworks Landmark required). To draw grade limits manually, use the Site 
Modifiers tool, or draw a polyline and then select the Create Objects from Shapes command (see “Creating Objects 
from Shapes” on page 277).

To create grade limits:

1. Click the Site Modifiers tool from the Site Planning tool set.
2. Draw the grade limit area around a site modifier, such as a pad.

Add a vertex to the retaining edge 
with the Reshape tool

Change the elevation of a retaining 
edge vertex with the Reshape tool
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If this is the first time the Site Modifiers tool has been used, the Object Properties dialog box opens. Accept the 
defaults and click OK.

3. In the Object Info palette, select Grade Limits from the Config field.
Click to show/hide the parameters.

4. The site model requires updating to reflect the grade limit modification. Select the site model and click Update 
from the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Grade Limits Automatically
Creating Custom Site Modifiers
Updating a Site Model

Creating Grade Limits Automatically
Because grade limits are often associated with a pad or other type of site modifier, the Vectorworks Landmark product 
can create grade limits automatically around a site modifier, based on specific parameters. Grade limits can be created 
with a gradual sloping transition from the existing site contours to the modifier, placed at a variable or fixed distance 
from the modifier. The grade limits cut and fill the site model to create a constant slope (batter slope).
To create grade limits automatically around one or more site modifier(s):

1. Select the site modifier(s) which require the grade limits. Valid modifiers include pads, road objects, massing 
models, and landscape walls.

2. Select the Create Grade Limits from Pad command from the appropriate menu: 
• Designer workspace: AEC > Terrain > Create Grade Limits from Pad

Parameter Description

Config Indicates the type of modifier object
Apply To Specify whether the grade limits apply to the existing or proposed site model
Show 3D In 3D views, represents the grade limits with a 3D polygon; deselect this option to hide 

this geometry
Update Calculations Updates the area and volume calculations displayed in the Object Info palette for the area 

of the site model located under the site modifier
Site model area and 
volume data

Displays the area and volume information for the site model area located under the site 
modifier; select the units for the area and volume. For more information, see “Site Model 
Properties” on page 699.

Pad 

Grade limits

Site modifiers before updating the site model
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• Landmark workspace: Landmark > Create Grade Limits from Pad
The Create Grade Limits from Pad dialog box opens. Select the grade limit parameters.

Click to show/hide the parameters.

3. Click OK to create the grade limits.
4. Select the site model and click Update from the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Updating a Site Model

Parameter Description

Grade Limits Offset Control
Distance Creates the grade limits at a fixed offset distance
Batter Slope Creates variable offset grade limits based on slope (the slope variation determines 

the offset; the grade limits are located at the intersection of the slope and the 
existing terrain)

Max. Offset Sets the fixed offset distance for Distance offset control, or specifies the maximum 
offset distance allowed for Batter Slope offset control

Max. Slope For Batter Slope offset control, specifies the maximum allowable slope (in 
degrees)

Slope Control Options
Use Midpoints Enables additional testing points for a more uniform slope
Test Increment Specifies the number of midpoints to test; a smaller increment distance increases the 

accuracy of the slope calculations, but can also increase the time to create the grade 
limits (the minimum increment is 12”)

Pad

Grade limits
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Creating a Pad from Grade Limits
With Vectorworks Landmark, a pad modifier can automatically be created within defined grade limits. The pad is 
placed so that the cut and fill amounts of the underlying proposed site model are set equally, helping site designers start 
with a balanced solution. Batter slope angles can be different on the different sides of the modifier.
Certain restrictions apply when creating the pad:

• The polygon that defines the grade limit area must be closed. If more than one grade limit area is selected, all the 
grade limit polygons must be closed. (To close the polygon, select the grade limit and then select Closed in the 
Object Info palette.)

• If more than one grade limit is selected, the created pads must have a uniform batter slope. To set the batter slopes 
individually, select only one grade limit object at a time.

• The grade limit area must be fully enclosed within a site model.
• The specified batter slope or slopes cannot be too small to create the pad; slope values that are too low prevent 

balanced cut and fill.
To create a pad automatically from the grade limits:

1. Select one or more grade limit objects.
2. Select the Create Pad from Grade Limits command from the appropriate menu: 

• Designer workspace: AEC > Terrain > Create Pad from Grade Limits
• Landmark workspace: Landmark > Create Pad from Grade Limits
The Create Pad from Grade Limits dialog box opens, and if necessary, the view temporarily changes to optimally 
display the area. Specify a uniform batter slope for the entire pad, or scroll with the Prev and Next buttons to set 
the slope individually for each side of the pad. The slope value(s) must be greater than 0 but less than 90 degrees.

Click to show/hide the parameters.

3. Click OK.
The resulting pad modifier is created and selected.
Individual slope values are retained for each grade limit object. The values can be reused for the creation of a new 
pad by selecting the grade limit object, and then selecting Create Pad from Grade Limits again.

Parameters Description

Uniform Applies the batter slope value equally to all sides of the pad
Per side Sets a slope value for the selected side of the pad

Select a side Scrolls through each side of the pad; enter an individual slope value for each selected side
Data display method Select the method of specifying the slope value: 

• Angular: specifies the slope in degrees, radians, or gradians (example: 26.7°)
• Rise-over-run: specifies the slope as a ratio of vertical change to horizontal change 

(example: 1:3)
• Percent: specifies the slope as a grade percentage (example: 50%)
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Pad
Creating a Pad with a Retaining Edge
Updating a Site Model

Creating a Spoil Pile Area
A spoil pile refers to an area where excess earth is used to help balance the cut and fill, so that the site does not require 
earth to be moved in or out. A spoil pile area applies an even thickness of cut or fill for the site. To create a spoil pile, 
either use the Site Modifiers tool, or draw a polyline and then select the Create Objects from Shapes command (see 
“Creating Objects from Shapes” on page 277).
To create a spoil pile area:

1. Create the site model and add any modifiers, such as pads and roads, and update the proposed site model by 
clicking Update from the Object Info palette of the selected site model.

2. The initial cut and fill volumes are displayed in the Object Info palette.
3. Click the Site Modifiers tool from the Site Planning tool set.
4. Draw the spoil pile area.

If this is the first time the Site Modifiers tool has been used, the Object Preferences dialog box opens. Accept the 
defaults and click OK.

5. In the Object Info palette, select Spoil Pile from the Config field. Adjust the elevation of the spoil pile up or down 
depending on whether fill is required or excess fill is present.

Click to show/hide the parameters.

Parameter Description

Config Indicates the type of modifier object

Grade limits Pad
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6. Select the site model and click Update from the Object Info palette.

7. With the site model still selected, click Update Cut and Fill Calculations from the Object Info palette.
Evaluate the results of the spoil pile by checking the Net C&F Volume results in the Object Info palette of the 
selected site model. If the spoil pile elevation needs adjustment, select the spoil pile and enter a new Elevation 
value in the Object Info palette. Then select the site model, click Update, and then click Update Cut and Fill 
Calculations.

8. Continue adjusting the spoil pile elevation until a balanced cut and fill volume is achieved.
Display the 3D cut and fill volumes by selecting Cut and Fill as the 3D Display in the Object Info palette of a 
selected site model. The cut and fill colors are specified on the Site Model tab of the Graphic Properties dialog 
box. In addition, a 2D polygonal representation of the cut and fill area can be displayed by selecting 2D Cut & 
Fill Area from the Site Analysis tab.

~~~~~~~~~~~~~~~~~~~~~~~~~
Site Model Properties
Setting Site Model Graphic Properties
Inserting Stake Objects
Updating a Site Model

Creating a Texture Bed
The texture bed site modifier converts a 2D polygon into an area of the drawing that can be textured. For example, 
texture a lawn with grass, a terrace with bricks, or a sand trap with sand for a photorealistic rendered appearance. To 

Elevation Sets the reference elevation of the spoil pile; a positive elevation is reported as fill volume, 
while a negative elevation is reported as cut volume, when calculating the underlying existing 
or proposed site model

Apply To Specifies whether the site modifier applies to the existing or proposed site model
Show 3D In 3D views, represents the spoil pile with a 3D polygon; deselect this option to hide this 

geometry
Update 
Calculations

Updates the area and volume calculations displayed in the Object Info palette for the area of the 
site model located under the site modifier

Site model area 
and volume data

Displays the area and volume information for the site model area located under the site 
modifier; select the units for the area and volume. 

Parameter Description

Spoil pile
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draw a texture bed, either use the Site Modifiers tool, or draw a polyline and then select the Create Objects from 
Shapes command (see “Creating Objects from Shapes” on page 277).

The Renderworks product is required for creating and rendering texture beds.

To create a texture bed:

1. Click the Site Modifiers tool from the Site Planning tool set.
2. Draw the texture bed.
3. In the Object Info palette, select Texture Bed from the Config field.

Click to show/hide the parameters.

See “Textures and Shaders” on page 1505 for more information on textures.
4. The site model requires updating to reflect the texture bed modification. Select the site model and click Update 

from the Object Info palette.
5. Render the model with a Renderworks render mode to see the texture bed.

Parameter Description

Config Indicates the type of modifier object
Elevation Sets the reference elevation of the texture bed above the site model surface; normally, set this 

value to zero. The texture is designed to lie on the surface of the site model when the texture 
bed is set to an elevation of zero.

Apply To Specifies whether the site modifier applies to the existing or proposed site model
Texture from 
Class

The classes present in the drawing are listed; alternatively, create a new class by clicking New, 
or select the class named <Site Modifiers Class> to derive the texture and its associated 
surface hatch from the class of the site modifier. The indicated class should have a texture 
applied on the Other tab, with Use Textures/Surface Hatches At Creation selected. See 
“Applying Object Textures by Class” on page 1542.

Show 3D In 3D views, enabling this option represents the texture bed with a 3D polygon; deselect this 
option to hide the geometry and display the texture bed only with its texture

Update 
Calculations

Updates the area and volume calculations displayed in the Object Info palette for the area of 
the site model located under the site modifier

Site model area 
and volume data

Displays the area and volume information for the site model area located under the site 
modifier; select the units for the area and volume. For more information, see “Site Model 
Properties” on page 699.
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Mapping Images on the Site Model
Images can be mapped to the surface of the site model; for example, use an aerial image of the site. Unlike the texture 
bed, which is a site modifier, mapping of an image texture occurs from the Render tab of the Object Info palette, and is 
adjusted with the Attribute Mapping tool. 

The Renderworks product is required for mapping images.
To map images on the site model:

1. Create an image texture as described in “Creating Image-based Shaders” on page 1508.
2. Select the site model. From the Object Info palette, select the image texture from the Texture list on the Render 

tab.
3. Switch to a 3D view from the Views > Standard Views menu, and render the site model to view the mapped 

image.
4. Click the Attribute Mapping tool from the Visualization tool set to position, move, resize, and rotate the image 

texture. Mapping adjustments are constrained to the 2D texture space plane; the image cannot be skewed or tilted.

~~~~~~~~~~~~~~~~~~~~~~~~~
Textures and Shaders
Applying a Texture to an Object
Direct Texture Mapping
Rendering with Vectorworks
Rendering with Renderworks
Updating a Site Model

Creating Custom Site Modifiers
As the Site Modifiers tool creates a pad, grade limits, spoil pile, or texture bed site modifier, the site modifier contains 
geometry that is placed in the Site-DTM-Modifier class. It is also possible to create site modifiers with polygons and 
NURBS curves; placing them in the Site-DTM-Modifier class causes them to modify the proposed site model.

Texture bed
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The type of site modifier created depends on the object.
• A 2D polygon acts like grade limits;
• A 3D polygon or NURBS curve acts like a pad.

To obtain uniform sloping sides on an open 3D polygon used as a swale or break line, place the 3D polygon in the 
Site-DTM-Modifier class, and select Create Grade Limits from Pad (Vectorworks Landmark required). See 
“Creating Grade Limits Automatically” on page 711.

Creating a Massing Model
The Massing Model tool creates a building shell for illustrative purposes. This is an easy way to create a representative 
or context building when a detailed building is not required. Building models can also be created by drawing a polyline 
and then selecting the Create Objects from Shapes command (see “Creating Objects from Shapes” on page 277). A 
massing model can be a site modifier.

To create a massing model:

1. Click the Massing Model tool from the Site Planning tool set.
2. Click to begin drawing the outline of the building. Continue clicking to draw the shell polyline. Double-click, or 

click once at the start point, to end the polyline.

3. The massing model parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Name Enter a building name for labeling
Show in Plan Select whether to show the building roof or footprint in Plan view
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Label Select a text label, if any, for the building shell in Plan view; move the text control 
point to reposition the text

Height Specifies the building height (to the eave)
Floor Count Specifies the number of floors in the building
Floor Usage Data Opens the Floor Usage Data dialog box, for reporting the usage of massing model 

floors. This is useful in worksheets, for example, when reporting the usage data of the 
floors using the ‘FloorUsageData’ parameter (see “Worksheet Functions” on 
page 1344). The number of floors listed depends on the Floor Count (if the Floor 
Count is reduced later, floor usage data will be lost).
By default, each floor’s usage is “Unspecified.” To specify the floor usage data, select 
each floor and enter the Usage Data for that floor. 

A semi-colon cannot be used in the usage data, because this is the delimiter for 
the FloorUsageData function.

Wall Class Select a class to use for wall style attributes
Use Custom Roof from 
Profile

Select to create a custom roof. The first roof created by the object is used as the default 
custom roof; if the number of stories has changed, the height of the custom roof needs 
to be manually adjusted.

Roof Overhang Specifies the distance the roof extends from the building
Roof Thickness Indicates the roof thickness
Roof Class Select a class to use for hipped roof style attributes
Pitched Roof Select to add a roof to the building shell

Eave Style Select an eave style from the list
Roof Slope Specifies the roof pitch angle in degrees

Draw Floors Select to draw floors in the building
Slab Thickness Specifies the floor thickness

Display Shadow in Plan 
View

Select to display a shadow based on the roof outline in Top/Plan view. Document-wide 
settings from the Plan Shadows pane on the Document Preferences dialog box are 
applied. Click Shadow Settings to open the Document Preferences dialog box to 
review and edit the settings (see “Plan Shadows Preferences” on page 63).

Use Site Modifiers Adds a pad and grade limits to the base of the building and allows the building to 
modify the site model

Use Grade Limits Uses grade limits to define the site modifier modification area
Grade Limits Off. Sets the offset of the grade limits from the massing model

Gross Area Displays the gross area value for all the floors

Parameter Description

Text control point
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4. If the massing model is used as a site modifier, the proposed site model requires updating. Select the site model 
and click Update from the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Custom Massing Model Roof
Updating a Site Model

Creating a Custom Massing Model Roof
If the standard flat or pitched massing model roof is not sufficient for portraying a more specific type of model, the roof 
geometry can be customized.

To create a custom massing model roof:

1. Create the massing model as described in “Creating Landscape Walls” on page 737.

2. Select Use Custom Roof from Profile.
3. Select Modify > Edit Massing Model to enter roof profile editing mode.

In this mode, the roof can be selected and modified by standard editing methods used in the Vectorworks program; 
see “Editing Objects” on page 997. The Reshape tool can also be used.
The first roof created by the object is used as the default custom roof; if the number of stories has changed, the 
height of the custom roof needs to be manually adjusted. A pitched roof is treated as a roof object; edit its 
parameters as described in “Editing Roof Objects” on page 573. Eaves can be changed to gables, for example.
The geometry of a pitched roof can be further edited by selecting Modify > Edit Group and creating cut-outs; see 
“Creating Cutouts in a Roof Object” on page 575. Geometry can be added to the roof (a dome or cupola), or 
subtracted from the roof using 3D tools. Click the Exit Group button (or select Modify > Exit Group) to return 
to the roof profile editing mode.
Deleting the existing custom roof causes a copy of the current standard roof, pitched or flat, to be placed in the 
group when the group is exited.

Vertex parameters Edits the object vertices. See “Editing Vertex-Based Objects” on page 1002.
Parameter Description
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4. When the roof edits have been made, click the Exit Profile button (or select Modify > Exit Profile) to return to 
the drawing.

Changes to the massing model may require manual updates to the custom roof; select the massing model and select 
Modify > Edit Massing Model to make any changes.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Massing Model
Editing a Group
Editing Roof Objects

Creating Roads
The Vectorworks Architect and Landmark products offer a variety of different tools and commands for creating roads, 
depending upon the complexity of the roadway. A road object can be set to be a site model modifier, and changes the 
proposed site model when the site model is updated.

• The Roadway (Poly) tool is the most straightforward, yet flexible way of creating a roadway in the Vectorworks 
Architect and Landmark products.

• The Roadway (Custom Curb) tool joins roadways for Vectorworks Architect and Landmark users. This tool can 
model exits, merges, traffic circles, intersections, cul-de-sacs, dead ends, and more.

• The Roadway (NURBS) tool offers an alternative way of inserting a road on a site model, and is available in both 
the Vectorworks Architect and Landmark products.

• The Vectorworks Landmark product includes commands that create a roadway from a polyline in several steps, 
with complete control over each step.

• For simple roadway representations in the Vectorworks Architect and Landmark products, build sections of a road 
with the Roadway (Straight) and Roadway (Curved) tools, and connect them with the Roadway (Tee) tool.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Polyline Roadways
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Joining Roadways with a Custom Curb
Creating NURBS Roadways
Creating a Roadway with the Vectorworks Landmark Commands
Creating and Joining Straight and Curved Roadways

Creating Polyline Roadways
The Roadway (Poly) tool available creates a road defined by a path polyline or polygon. In Top/Plan view, the curbs 
and pavement are represented by filled polygons. In 3D views, extrudes are generated to represent the curbs and 
pavement. Polyline roadways can also be created by drawing a polyline or polygon and then selecting the Create 
Objects from Shapes command (see “Creating Objects from Shapes” on page 277). 

To create a road with the Roadway (Poly) object:

1. Click the Roadway (Poly) tool from the Site Planning tool set.
2. Click to begin drawing the roadway polyline path; click to set each polyline vertex. Double-click the mouse to 

create an open path polyline, or click at the start point (or press K) to complete a closed polyline. For more 
information on polylines, see “Creating Polylines” on page 298.

3. If this is the first time a polyline roadway is placed on the drawing, the object properties dialog box opens. Specify 
the default preferences, which apply to all polyline roadways placed subsequently in this drawing. Click OK.

4. The parameters of the Roadway (Poly) can be edited from the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Paving Width/Thickness Sets the width and thickness of the roadway paving

Curb Width/Height Sets the width and height of the roadway curb

Show Joints Displays the roadway joints (the hidden sides where there is no curb) as dashed lines
Show Stations Stations report the road elevation at intervals along the roadway. Select the option to 

show station information along the roadway curves at corner vertices; in Top/Plan 
view, the display includes the segment index (the number of the station, counted from 
the start of the roadway polyline) and the station offset from the beginning of the road 
curve. In 3D views, a locus displays.

Paving width

Paving thickness

Curb width

Curb height
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Create Pad for Site Model Creates an embedded pad site modifier around the road, following the road curvature 
and the elevation defined at each station point. A path polyline with many vertices will 
have less segmentation when the pad is created; increase the number of vertices with 
the Reshape tool if necessary to reduce the segmentation. The 3D resolution selected 
in the Vectorworks preferences determines the resolution of curved segments of the 
roadway.

A site model must exist under the roadway object to create a pad modifier.
Create Grade Limits for 
Site Model

Creates an embedded grade limits site modifier around the road.
A site model must exist under the roadway object to create a grade limits 
modifier.

Grade Limits Method When creating grade limits around the road, select whether to specify the grade by 
offset or by slope

Grade Limits Off For offset grade limits, specifies the offset distance of the grade limits area on all sides 
of the road

Grade Limits Slope For slope grade limits, specifies the slope as an angle in document units, as a rise:run 
ratio (using : as the delimiter), or as a percentage, using the % symbol as a suffix. The 
grade limits object is created on all sides of the road so that the slope of the underlying 
site model is equal to the specified value.

Paving/Curb/Stations 
Class

Select a class for each category of roadway geometry, to control the appearance and/or 
visibility. The classes present in the drawing are listed; alternatively, create a new class 
by selecting New, select the default class name (roadway items are placed in the 
Site-Paving class category), or select the class named <Roadway (Poly) Class>, which 
places the paving item in the same class as the roadway object.

Set Stations Opens the Redistribute Stations dialog box, for creating stations along the road at a 
specific spacing value. Enter the spacing distance and click OK. Any previous station 
points are cleared, and new stations are created.
The station spacing value can be used in worksheet reports. If the roadway is reshaped, 
the station points are redistributed, and elevations are adjusted accordingly.

Clear Stations Removes all station points from the selected roadway
Send Stations to Surface Opens the Send Stations to Surface dialog box, for creating stations along the road at a 

specific spacing value, while also setting the elevation of the station points to the 
surface of the site model. Any previous station points are cleared, and new stations are 
created.
The station spacing value can be used in worksheet reports. If the roadway is reshaped, 
the station points are redistributed, and elevations are adjusted accordingly.

Align Stations Vertically Opens the Align Stations Vertically dialog box, which displays the grade between 
specified station points. Enter the station point starting number and ending number 
(Station 1 is the station at the beginning of the roadway). The selected stations are 
highlighted on the drawing. Click OK. The stations between the starting and ending 
stations are fit to the slope grade.

Vertex parameters Edits the vertices of the path object that the roadway is based upon; see “Editing 
Vertex-Based Objects” on page 1002. The elevation of station points can also be 
viewed and edited by selecting Stations from the Move list.

Parameter Description
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5. If necessary, use the Reshape tool to modify the locations of the vertices after object creation, or use the vertex 
editing controls on the Object Info palette to move the vertices, or change the elevation of station points.

6. Update the site model. Select the site model and click Update from the Object Info palette.
~~~~~~~~~~~~~~~~~~~~~~~~~
Updating a Site Model
Creating Roads

Joining Roadways with a Custom Curb
The Roadway (Custom Curb) tool creates sections of roadways that join other roadways in various ways, such as 
intersections, exits, merges, traffic circles, intersections, cul-de-sacs, dead ends, and more.
The tool creates a free-form roadway shape that is extremely flexible, and can be reshaped to fit the needs at the 
particular location. The curb can be hidden along the sides of the roadway object, where it connects to other roadways.
Custom curb roadways can also be created by drawing a polyline or polygon and then selecting the Create Objects 
from Shapes command (see “Creating Objects from Shapes” on page 277). 

To create a custom curb roadway:

1. Click the Roadway (Custom Curb) tool from the Site Planning tool set.
2. Click to set the starting point of the roadway. Click again to set the ending point. These clicks determine the initial 

length and orientation of the curb roadway. When selected, the roadway displays with two control points which 
define the length and orientation.

3. Use the Reshape tool to reshape the curb roadway as described in “Reshaping Objects” on page 1043. Roadway 
vertices can be repositioned, added, and deleted; however, the two control points that define the roadway cannot 
be reshaped. The Change Vertex mode of the Reshape tool can switch vertices to arc vertices to use curves in the 
curb roadway. The Hide or Show Edges mode of the Reshape tool can hide and show the portions of the curb 
where the roadway intersects with other roadway objects.
The curb roadway can be reshaped while in path editing mode. Select Modify > Edit Roadway (Custom Curb), 
or right-click (Windows) or Ctrl-click (Mac) on the curb roadway and select Edit Path from the context menu. 

Roadway parameters Displays roadway parameters for the selected road, such as area and length
Parameter Description

Click 1

Click 2
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4. The Roadway (Custom Curb) parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

5. If the roadway sections include pads or grade limits, and a site model exists, select the site model and click 
Update from the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Updating a Site Model
Creating Roads

Parameter Description

Road Length For worksheet reporting purposes, specifies the length of the roadway; however, 
this setting has no effect on the actual road length, which is edited by adjusting the 
control points with the Selection tool

Paving Width For worksheet reporting purposes, specifies the width of the roadway; however, 
this setting has no effect on the actual road width, which is edited by adjusting 
vertices with the Reshape tool

Curb Height/Width Indicates the width and height of the roadway curb
Paving Thickness Sets the thickness of the road paving
Rise Sets the difference in height between the start and end of the roadway segment
Show Joints Displays the roadway joints (the hidden sides where there is no curb) as dashed 

lines
Use Site Modifiers Creates a pad and grade limits to modify the site model
Create Grade Limits for Site 
Model

Uses grade limits to define the site modifier modification area

Left/Right Grade Limits Off Controls the grade limit offset distance on either side of the road
Paving/Curb Class Select a class for each category of roadway geometry, to control the appearance 

and/or visibility. The classes present in the drawing are listed; alternatively, create 
a new class by selecting New, select the default class name (roadway items are 
placed in the Site-Paving class category), or select the Roadway (Custom Curb) 
class, which places the paving item in the same class as the curb roadway object.

Reshape the curb roadway with the 
various modes of the Reshape tool
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Creating NURBS Roadways
The Roadway (NURBS) tool uses NURBS curves to define the road shape. However, the Roadway (NURBS) object 
does not represent accurate alignments of low-speed roadways, which are typically constructed with arcs (constant 
radius) and tangents (straight lines); use the Roadway (Poly) tool for this.
NURBS roadways can also be created by drawing a polyline or polygon and then selecting the Create Objects from 
Shapes command (see “Creating Objects from Shapes” on page 277).
Here is a suggested process for creating a NURBS roadway:

• Create the roadway.
• Select the Send to Surface command to set the road to the existing terrain.
• Select Redistribute and Smooth Curve from the Object Info palette of the selected roadway once or twice to 

smooth out the road slightly, so it does not follow every hill and valley in the existing terrain.
• Manually reshape the road in 3D as required (to match other road elevations, garage elevations, and so on).
• Only select Redistribute Stations for more or fewer station annotations. Fewer stations are easier to work with 

when sketching and reshaping, but a road construction company might require more stations to be specified. 
Redistribute Stations is also useful to ensure that the station spacing is equal after reshaping the road.

To create a road with the Roadway (NURBS) object:

1. Click the Roadway (NURBS) tool from the Site Planning tool set.
The following modes are available.

See “Creating NURBS Curves” on page 328.
2. Click in the drawing file to set the start point of the road, and then click to set the position of each additional 

NURBS vertex. Double-click the last point to complete creation of the roadway (NURBS) object.
3. If this is the first time a NURBS roadway is placed on the drawing, the object properties dialog box opens. Specify 

the default preferences, which apply to all NURBS roadways placed subsequently in this drawing. Click OK.
4. The Roadway (NURBS) properties can be edited in the Object Info palette.

Click to show/hide the parameters.

Parameter Description

Z height Adjusts the elevation of the entire road
Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using 
options on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 
and “Formatting Text” on page 389.

Road Length Displays the length of the road

NURBS Curve by 
Interpolation Point

NURBS Curve by Control Point

NURBS Curve 
Degree Setting

Preferences
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5. If necessary, use the Reshape tool to modify the locations of the vertices after object creation, or use the vertex 
editing controls on the Object Info palette to move the vertices or change the degree of vertices.

6. Update the site model. Select the site model and click Update from the Object Info palette.

Paving Width Specifies the overall width of the paved road surface (without curbs)
Paving Height Specifies the road paving thickness (without curbs)
Curb Width Specifies the curb or shoulder width
Curb Height Specifies the curb or shoulder height
Left Guardrail Adds a guardrail to the left side of the road
Right Guardrail Adds a guardrail to the right side of the road
Show Stations The NURBS curve vertices are used as the station points; select to display the station 

points. In 2D, stations display as loci with text displaying the point elevation. In 3D, the 
stations display as round stakes.

Create Pad for Site 
Model

Creates a pad modifier for the Roadway (NURBS) object 

Create Grade Limits for 
Site Model

Creates a grade limits modifier for the Roadway (NURBS) object, to control the zone 
where the terrain transitions between the existing elevation and the road elevation

Grade Limits Method Specify whether to create offset or sloped grade limits 
Grade Limits Off. When creating offset grade limits, specify the distance from the road to the grade limits
Grade Limits Slope When creating sloped grade limits, specify the batter slope

Paving/Curb Class Select a class for each category of roadway geometry, to control the appearance and/or 
visibility. The classes present in the drawing are listed; alternatively, create a new class 
by selecting New, select the default class name (roadway items are placed in the 
Site-Paving class category), or select the Roadway (NURBS) class, which places the 
paving item in the same class as the NURBS roadway object.

Redistribute Stations Redistributes the stations at a specified spacing interval
Redistribute and Smooth 
Curve

Redistributes the station points at a specified spacing interval and smooths the NURBS 
curve

Send Stations to Surface Click to set the Z value of the stations to the surface of the site model. The stations can 
be set to either the surface of the existing site model, or to the surface of the proposed 
site model, which may have been altered by modifiers. 
If the stations are sent to the surface of a proposed site model which has been changed 
by modifiers, it may be necessary to deselect Create Pad for Site Model and Create 
Grade Limits for Site Model for the Roadway (NURBS) in order to prevent site 
modifier errors caused by crossing pads or grade limits.

Align Stations Vertically Sets the elevation of the indicated station points to a specific plane. As the starting and 
ending stations are indicated, a red line previews the included station points. The % 
Grade indicates the grade that will be set between station points.

NURBS curve 
parameters

Edits the roadway NURBS curve

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Updating a Site Model
Creating Roads

Creating a Roadway with the Vectorworks Landmark Commands
The Vectorworks Landmark road commands create a roadway with a multi-step procedure. The centerline of the road is 
defined with a polyline, and then stakes are added. The elevation of the stakes, which are initially set to the surface of 
the site model, can be modified before the road is created. Finally, the site model is updated and modified by the road 
object.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating the Road Centerline
Placing Station Points Along the Road Polyline
Setting Stake Elevations
Creating the Road

Creating the Road Centerline
The road design elements can be created on a separate layer to facilitate modifications later.

To create the road centerline:

1. If desired, create a new layer for the road by selecting Tools > Organization. The layer scale should be the same 
as the site model layer scale. Set the site model layer to visible, and select View > Layer Options > Show/Snap 
Others.

2. Using the Polyline tool, create a polyline that represents the road shape.
For more information on polylines, see “Creating Polylines” on page 298.
Interior vertices of the polyline must be arc-smoothed (no Bézier or cubic vertices). 
Smooth vertices with the Modify > Poly Smoothing > Arc Smoothing command.
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The road must be contained within the site model grade limits.
~~~~~~~~~~~~~~~~~~~~~~~~~
Placing Station Points Along the Road Polyline
Setting Stake Elevations
Creating the Road

Placing Station Points Along the Road Polyline
The Vectorworks Landmark product places station points (stake objects) along the selected polyline at a specified 
interval.
To place station points:

1. Select the polyline, and then select the Station on Polyline command from the appropriate menu: 
• Designer workspace: AEC > Roads > Station on Polyline.
• Landmark workspace: Landmark > Roads > Station on Polyline

2. The Place Station Points Along Polyline dialog box opens. This command places stations at 100’ (or 30.48 m) 
intervals. In addition, partial station points can be placed at smaller intervals. Enter the interval between partial 
stations and select a labeling option for the curve information.

Click to show/hide the parameters.

Parameter Description

Partial station interval Indicates the spacing interval between partial station points
Create individual curve labels Creates curve data tables at each polyline curve. 

The curve labels include the following data:

Create circular curve data table Creates a Station Worksheet with the curve data; the worksheet number 
corresponds to the polyline number

No Curve Data No curve data tables or tangent guide lines are created

Point of Curvature (PC)
Point of Tangency (PT)
Point of Intersection (PI)
Included Angle (I)
Tangent Distance (T)
Radius (R)
Length of Curve (L)
Chord (C)
Center of Curve (O)
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3. Click OK to create the station points along the polyline. If this is the first time a stake has been placed in the file, 
the Object Properties dialog box opens. Accept the default values and click OK. Stake properties are described in 
“Inserting Stake Objects” on page 769.
Each station point is labeled. If curve data tables were created, they can be selected and moved if necessary.

4. The stakes have all been set to the elevation of the site model; the next step is to automatically set the road stake 
elevations as described in “Setting Stake Elevations” on page 730.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Stake Objects
Creating the Road Centerline
Setting Stake Elevations
Creating the Road

Setting Stake Elevations 
In “Placing Station Points Along the Road Polyline” on page 729, the stake elevations were set according to the site 
model; in real situations, a road is often set to a grade other than natural grade. The Align Stakes Vertically command 
sets the elevation of the stakes to a specific plane.
To set the stake elevations with a linear alignment:

1. Set the elevation of only one of the terminal stakes (one of the stakes at the ends of the segment to align) by 
selecting the stake and entering its elevation in the Object Info palette. If a site model was present when the 
Station on Polyline command was executed, the elevation of the stake is set to the proposed site model elevation 
for reference.

2. In the segment to align, press the Shift key to select both the first and last stake (the stakes at either end of the 
desired elevation alignment), and then select the Align Stakes Vertically command from the appropriate menu:
• Designer workspace: AEC > Roads > Align Stakes Vertically
• Landmark workspace: Landmark > Roads > Align Stakes Vertically
The Align Stakes Vertically dialog box opens.

3. Enter either a slope value as a rise over run ratio for the road (using a forward slash (/) as a delimiter), or the 
elevation of the last stake, and click OK.

Curve data table Station point (stake)

Tangential guide line
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The elevations of the stakes located between the selected stakes are set to the specified plane.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating the Road Centerline
Placing Station Points Along the Road Polyline
Inserting Stake Objects
Creating the Road

Creating the Road
This procedure creates the road by automatically making a single polyline roadway, or by creating curved or straight 
road objects between each stake. The road follows the centerline polyline, and is set to the elevations specified by the 
stakes.
To create the road:

1. Select the center polyline or any of the station points, and select the Create Road from Stakes command from the 
appropriate menu: 
• Designer workspace: AEC > Roads Create Road from Stakes
• Landmark workspace: Landmark > Roads > Create Road from Stakes
The Create Road from Stakes dialog box opens. Enter the road parameters.

Click to show/hide the parameters.

2. Click OK. The polyline and stakes are used to create a Roadway (Poly) object, or a series of road section between 
adjacent stakes. If this is the first time a road (or a straight or curved road) has been created in the file during this 
session, the Object Properties dialog box opens. Accept the default values and click OK in both dialog boxes.

3. If a single roadway was created, create a pad and grade limits for the roadway to modify the site model by 
selecting the options on the Object Info palette. See “Creating Polyline Roadways” on page 722.
If a set of straight and curved roads was created, the straight and curved sections of the road need to become site 
modifiers by selecting the road sections and then selecting Use Site Modifiers in the Object Info palette. Use the 
Custom Selection command to select the straight and curved road sections; see “Creating Custom Selection 
Scripts” on page 1771. The grade limits offset can be set manually, or the grade limits can be turned off and 

Parameter Description

Select the result type
A single Roadway (Poly) object Creates the road as a Roadway (Poly) object
A set of Roadway (Curve) and Roadway 
(Straight) objects

Creates the road as a series of curved and straight roadway objects 
along the stations

Width Specifies the road width between the curbs
Curb Height/Width Specifies the height and width of the road curbs
Paving Thickness Sets the thickness of the road paving
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created separately using the Create Grade Limits from Pad command (see “Creating Grade Limits 
Automatically” on page 711). When site modifiers are used, each road section contains a pad (see “Creating a 
Pad” on page 706 and “Creating Grade Limits” on page 710).

Stakes should not be moved (except in elevation) when using the Create Road from Stakes command. If an 
additional stake is required, add a vertex point to the polyline, provide an elevation value, and run the Create 
Road from Stakes command again.

4. The proposed site model requires updating. Select the site model and click Update from the Object Info palette.
If the road was created on a different layer from the site model, click Site Model Settings from the Object Info 
palette and ensure that Use Site Modifiers on All Layers is selected.
The proposed site model is updated. If Use Site Modifiers was selected for the road sections, the contour lines are 
adjusted to rise or fall to meet the level of the road.
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~~~~~~~~~~~~~~~~~~~~~~~~~
Updating a Site Model
Creating Roads

Creating and Joining Straight and Curved Roadways
Simple roadway tools allow you to assemble and join straight and curved roadway sections. The roadway tools can 
modify the site model.

To create a straight roadway section:

To create a curved roadway section:

To create a roadway intersection:

1. Click the Roadway (Straight) tool, Roadway (Curved) tool, or Roadway (Tee) tool from the Site Planning tool 
set.
The desired tool depends on the portion of roadway section to create.

2. Create the roadway section in the drawing.
• If placing a straight roadway section, click once to define the starting point of the road, and then click again to 

set the ending point. 
• If placing a curved or tee roadway section, click to place the object in the drawing, and click again to set the 

object’s rotation. 
3. If this is the first time the object is placed in the drawing, an object properties dialog box opens. These parameters 

apply to subsequently created objects; they can be changed later by accessing them from the Object Info palette. 
4. Continue to assemble the roadway by placing curved and straight sections, as well as tee intersections.
5. The roadway properties can be edited in the Object Info palette. 

Use class settings to add a solid fill color to the road
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Click to show/hide the parameters.

6. If the roadway sections include pads or grade limits, and a site model exists, select the site model and click 
Update from the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Updating a Site Model

Parameter Description

Z Sets the elevation of the first stake in the roadway segment
Radius (curved and tee roads) Specifies the arc radius (measured to the center of the road) of a curved roadway 

segment; the locus indicates the center of the arc (or for tee roads, indicates the 
center of each arc)

Width (curved roads) Sets the width of a curved roadway segment
Throat Width (tee roads) Indicates the width of a tee “throat” section
Road Length (straight roads) Specifies the length of a straight roadway segment
Paving Width (straight roads) Sets the width of a straight roadway segment
Curb Height/Width Indicates the width and height of the roadway curb
Paving Thickness Sets the thickness of the road paving
Rise Sets the difference in height between the start and end of the roadway segment
Show Joints Displays the roadway joints (the hidden sides where there is no curb) as dashed 

lines
Use Site Modifiers Creates a pad and grade limits to modify the site model
Left/Right Grade Limits Off. 
(curved and straight roads)

Controls the grade limit offsets on either side of the road

Sweep (curved and tee roads) Sets the degree (arc angle) of the sweep of the segment
Draw Gutter Curb (tee roads) Draws a curb on the gutter side of a tee roadway; deselect the option to hide the 

curb
Gutter Width (tee roads) Specifies the width of the gutter for tee roadways
Paving/Curb Class Select a class for each category of roadway geometry, to control the appearance 

and/or visibility. The classes present in the drawing are listed; alternatively, create 
a new class by selecting New, select the default class name (roadway items are 
placed in the Site-Paving class category), or select the Roadway class, which 
places the paving item in the same class as the roadway object.

Throat widthGutter width

Gutter side

Roadway (Tee)
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Creating Roads
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Creating Landscape Walls
The Vectorworks Architect and Landmark products include the ability to create a stepped wall. The Vectorworks 
Landmark program also contains the ability to create a retaining wall site modifier, and several ways of creating 
landscape walls with the landscape wall tools. The stepped wall and retaining wall site modifier are based on walls 
created with the Wall or Round Wall tool, offering the benefits and flexibility of the architectural wall tools.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Stepped Walls
Creating Retaining Walls
Landscape Wall Tools

Creating Stepped Walls
Stepped walls add wall peaks to existing walls created with the Wall tool or Round Wall tool. The existing wall can be 
a single wall or a chain of multiple wall segments that are L-joined to each other. Stepped walls can have a constant rise 
at each interval, or conform to underlying terrain with a variable rise, such as free-standing landscape walls or fences.

To create a stepped wall:
1. Select the wall or multiple, L-joined walls.
2. Select the Create Stepped Wall command from the appropriate menu:

• Architect workspace: AEC > Create Stepped Wall 
• Landmark workspace: Landmark > Architectural > Create Stepped Wall 
The Create Stepped Wall dialog box opens. Set the stair parameters.
The options available depend on the selected Step Style (even steps or terrain steps). If the parameters are set so 
that the steps are uneven, the top step is truncated.

Click to show/hide the parameters.

Step rise

Step length

Total length

Total rise

Even step wall depicted
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3. Click OK to create the stepped wall.

Parameter Description

Even Steps Creates a stepped wall with a constant rise and wall peaks at even intervals
Preview Previews the selected configuration
Total Length Displays the total length of the stepped wall to be created
Number of Steps Displays the total number of steps to be created
Calculator The steps are created based on three parameters: step length, step rise, and total rise. 

Based on the entry of two of these parameters, the third is automatically calculated. 
Click to place the calculator at the parameter that should be automatically calculated, 
and enter the values for the other two parameters.

Step Length Sets the length of one step
Step Rise Sets the rise of one step
Total Rise Specifies the total rise value
Apply Steps to Steps can be applied to either the top or bottom of the wall, or both

Top of Wall Steps apply to the top of the wall
Horizontal Offset Specifies the horizontal offset of the top steps; positive values move the steps to the 

left, while negative values move them to the right. This allows the last step to be shorter 
or longer, for example.

Bottom of Wall Steps apply to the bottom of the wall
Horizontal Offset Specifies the horizontal offset of the bottom steps; positive values move the steps to the 

left, while negative values move them to the right.
Reverse Direction Sets whether steps should be started from the beginning of the wall (option is 

deselected) or end of the wall (option is selected)
Terrain Steps
Total Length Displays the total length of the stepped wall to be created
Number of Steps Displays the total number of steps to be created
Step Length Sets the length of one step
Vertical Offset Specifies the offset distance from the terrain surface; an offset of zero keeps the steps at 

the surface, while a positive value raises them above the surface
Apply Steps to

Top of Wall Applies steps to the top of the wall, mirroring the terrain
Horizontal Offset Specifies the horizontal offset of the top steps; positive values move the steps to the 

left, while negative values move them to the right. This allows the last step to be shorter 
or longer, for example.

Bottom of Wall Terrain steps are always applied to the bottom of the wall, since the steps follow the 
terrain

Horizontal Offset Specifies the horizontal offset of the bottom steps; positive values move the steps to the 
left, while negative values move them to the right.

Place Steps Above Terrain The steps are reversed so that they are above the terrain
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The Send to Surface command can be used on walls; it sets the bottom Z value at the start of the wall to the 
existing terrain surface (see “Sending Objects to the Site Model Surface” on page 705).

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Walls
L Wall Joins
Creating Retaining Walls
Landscape Wall Tools

Creating Retaining Walls
A retaining wall site modifier can be created based on existing walls created with the Wall tool or Round Wall tool. 
The existing wall can be a single wall or a chain of multiple wall segments that are L-joined to each other. The retaining 
wall created can modify the site model, and the terrain can be sculpted as desired around the retaining wall.

Once created, the retaining wall site modifier is not associated with the wall object used to create it.
To create a retaining wall site modifier:

1. Select the wall or multiple, L-joined walls.
While walls are typically be used as the basis for creating a retaining wall, other valid selections include a 
hardscape object or an extrude object.

2. Select the Create Retaining Wall Site Modifier command from the appropriate menu: 
• Designer workspace: AEC > Terrain > Create Retaining Wall Site Modifier
• Landmark workspace: Landmark > Create Retaining Wall Site Modifier
The Create Retaining Wall Site Modifier dialog box opens. Set the initial location of the site modifiers within the 
retaining wall. There are three distinct areas that can modify the site model:
• the pad at the bottom of the wall, which can be offset from the top or bottom of the wall, or simply follow the 

terrain
• the left and right side edges of the wall, which can be offset from the top or bottom of the wall, or follow the 

terrain
• the starting and ending edges of the wall
The left and right sides of the wall are determined by the wall direction as it was drawn.

Click to show/hide the parameters.

Parameter Description

Diagram This wall schematic shows the location of the pad modifier at the bottom of the 
wall (1), the left (2) and right (3) edge modifiers, and the start (4) and end (5) edge 
modifiers; it also shows the wall start and end, which determines the wall direction and 
therefore which edge is left and right

Pad Specifies the vertical offset and shape of the modifier pad; the modifier can be offset 
from the top or bottom of the wall and follow top or bottom wall peaks, or can simply 
follow the current terrain. The pad offset can control the cut and fill values produced by 
the site modifier.

Offset Below Wall Top Sets the pad modifier to be offset below the top of the wall by the specified value
Follow Top Wall Peaks The modifier shape follows the wall peaks at the top of the wall. If a wall has vertical 

peaks, the modifiers will be nearly vertical.
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3. Click OK to create the retaining wall site modifier. The original wall(s) remain in the drawing; the site modifier is 
a new, separate object.

4. Update the site model to apply the changes (select the site model and click Update from the Object Info palette).

Editing Retaining Walls

Retaining wall parameters can be edited from the Object Info palette.
Click to show/hide the parameters.

Offset Above Wall Bottom Sets the pad modifier to be offset above the bottom of the wall by the specified value
Follow Bottom Wall Peaks The modifier shape follows the wall peaks at the bottom of the wall. If a wall has 

vertical peaks, the modifiers will be nearly vertical.
Follow Terrain The pad modifier follows the terrain location (offset and shape) along the bottom of the 

wall
Side Edges
Left/Right Modifier Edge Select whether to create the edge modifier objects on the left and/or right sides of the 

retaining wall. Edge modifiers sculpt the terrain at the left or right of the retaining wall 
sides according to the parameters set. The modifier can be offset from the top or bottom 
of the wall and follow top or bottom wall peaks, or can simply follow the current 
terrain.

Offset Below Wall Top Sets the edge modifier to be offset below the top of the wall by the specified value
Follow Top Wall Peaks The modifier shape follows the wall peaks at the top of the wall. If a wall has vertical 

peaks, the modifiers will be nearly vertical.
Offset Above Wall 
Bottom

Sets the edge modifier to be offset above the bottom of the wall by the specified value

Follow Bottom Wall 
Peaks

The modifier shape follows the wall peaks at the bottom of the wall. If a wall has 
vertical peaks, the modifiers will be nearly vertical.

Follow Terrain The edge modifier follows the terrain location (offset and shape) along the side of the 
wall

Start/End Edges The start and end edge modifiers define how the terrain wraps around the retaining wall 
sides

Include Start Modifier 
Edge

Select whether to create an edge modifier object at the starting edge of the wall

Include End Modifier 
Edge

Select whether to create an edge modifier object at the ending edge of the wall

Parameter Description

Retaining wall site 
modifier created

Site model updated
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The retaining wall site modifier consists of four modifier edges, joined by common vertices. The left and right edges of 
the retaining wall site modifier can be reshaped with the Reshape tool, similar to reshaping walls (see “Reshaping 
Walls” on page 536). Move vertices, and add or delete vertices to reshape the retaining wall.

The start and end edges cannot be directly edited with the Reshape tool. However, a vertex added to the left or right 
edge can be edited by the Reshape tool (select Start/End Modifier Edge from the Move list in the Object Info palette, 
and click Add Vertex). Adding vertices to the start and end edges allows them to be reshaped as needed.

The Send to Surface command can be used to send either the retaining wall modifier edge or the pad to the surface of 
the site model. 
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Walls
Wall Direction
Reshaping Walls
Joining Walls

Parameter Description

Apply To Select whether the retaining wall modifies the existing or proposed site model
Width Determines the distance between the left and right edges of the retaining wall
Pad Offset Specifies the offset of the pad from the Z elevation of the retaining wall site modifier 

object itself; the offset can control the cut and fill values produced by this site modifier
Include Left/Right/Start/
End Modifier Edge

Toggles the modification of the site model by the selected modifier edge parameters

Vertex parameters Edits the path vertices; see “Editing Vertex-Based Objects” on page 1002
Move Select the portion of the retaining wall modifier to edit, and then edit its Elevation, or 

scroll through its vertices with the left and right arrows and change the selected vertex 
Elevation 

Edit For vertex selections made in Move, scrolls through the vertices, highlighting the 
currently selected vertex. Click the center button to highlight the selected vertex.

Elevation Sets the elevation of the modifier item selected in Move or the vertex selected in Edit

Site model updatedReshape right edge with the Reshape tool in a 3D view

Pad modifier vertex

Vertex shared by start
modifier and right modifier

Vertex added to start edge
can be moved by the

Reshape tool
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Creating Stepped Walls
Landscape Wall Tools
Reshaping Objects
Sending Objects to the Site Model Surface
Updating a Site Model

Landscape Wall Tools
The Vectorworks Landmark program includes three tools for creating landscape walls.
A landscape wall object (retaining wall) can be set to be a site model modifier. It changes the proposed site model when 
the site model is updated. 
To draw straight, arc, and Bézier landscape walls, either use the landscape wall tools, or draw a polyline and then select 
the Create Objects from Shapes command (see “Creating Objects from Shapes” on page 277). Place the different 
types of landscape walls next to each other to achieve a particular design or effect. 

To create a row of straight and curved landscape walls, use the Create Objects from Shapes command.

Straight Landscape Walls

To insert a straight landscape wall:

1. Click the Landscape Wall tool from the Site Planning tool set.
2. Click and drag to define the length and angle of the landscape wall. Click again to set the end point. If this is the 

first time the tool is used during this session, the Object Properties dialog box opens. Accept the default values and 
click OK.
The straight landscape wall parameters can be edited in the Object Info palette.

Click to show/hide the parameters.

Top width

Left pitch Right pitch

Cross section
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Arc Landscape Walls

To insert an arc landscape wall:

1. Click the Landscape Wall Arc tool from the Site Planning tool set.
2. Click to define the placement of the arc landscape wall and click again to set the rotation. If this is the first time the 

tool is used during this session, the Object Properties dialog box opens. Accept the default values and click OK.
The arc landscape wall parameters can be edited in the Object Info palette.

Click to show/hide the parameters.

Parameter Description

Z Elevation of starting point of wall
Rot Angle of rotation of wall
Length Total length of all wall sections in the object
Top Width Width of wall at top (see diagram)
Step Height When the wall starting point and ending point are different, this parameter indicates the 

height of the step between sections
Wall Height Wall height above Z value
Rise Difference in height between wall starting and ending points
Left/Right Pitch Angle of wall on left and right sides (see diagram); for a straight wall with site modifiers, 

the left side is always the side that retains earth
Use Site Modifiers Adds a pad and grade limits to each wall section and allows the landscape wall to modify 

the site model
Use Grade Limits Uses grade limits to define the site modifier modification area
Left/Right Grade 
Limits Off.

Controls the grade limit offsets on either side of the wall (applies only when site 
modifiers are used)

Show Joints Displays the connecting joints between wall sections

Parameter Description

Z Elevation of starting point of wall
Radius Radius of all wall sections
Top Width Width of wall at top (see diagram)

Top Width

Inside pitch Outside pitch

Arc sweep 
angle

Ra
diu

s

Cross section
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Bézier Landscape Walls

To insert a Bézier landscape wall:

1. Click the Landscape Wall Bézier tool from the Site Planning tool set.
2. Click and drag to define the length and angle of the landscape wall. Click again to set the end point. If this is the 

first time the tool is used during this session, the Object Properties dialog box opens. Accept the default values and 
click OK.

3. Adjust the control points of the Bézier wall by clicking and dragging to obtain the desired curvature.

The Bézier landscape wall parameters can be edited in the Object Info palette.

Click to show/hide the parameters.

Step Height When the wall starting point and ending point are different, this parameter indicates the 
height of the step between sections

Wall Height Wall height above Z value
Rise Difference in height between wall starting and ending points
Inside/Outside Pitch Angle of wall on the inside and outside (see diagram); for an arc wall with site modifiers, 

the side of the wall that retains earth must be selected in Retained Side
Show Joints Displays the connecting joints between wall sections
Retained Side For an arc wall with site modifiers, select the side of the wall that retains earth
Arc Sweep Angle, in degrees, of arc (see diagram)
Use Site Modifiers Adds a pad and grade limits to each wall section and allows the landscape wall to modify 

the site model
Use Grade Limits Uses grade limits to define the site modifier modification area
Inside/Outside Grade 
Limits Off.

Controls the grade limit offsets on either side of the wall (applies only when site modifiers 
are used)

Parameter Description

Control points

Top width

Left pitch Right pitch

Cross section
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Stepped Walls

Creating Hardscape Objects
A hardscape object is comprised of paved areas with joint patterns and optional borders. A boundary hardscape or 
pathway hardscape can be created. To draw a hardscape object, either use the Hardscape tool, or create a polyline and 
then select the Create Objects from Shapes command (see “Creating Objects from Shapes” on page 277). The 
hardscape object can modify the site model.
The following modes are available. 

Parameter Description

Z Elevation of starting point of wall
Wall Length Total length of all wall sections
Top Width Width of wall at top (see diagram)
Wall Height Wall height above Z value
Resolution Select a 3D display resolution; low resolution displays fastest, but high resolution provides the 

best quality
Rise Difference in height between wall starting and ending points
Left/Right Pitch Angle of wall on left and right sides (see diagram); for a Bézier wall with site modifiers, the left 

side is always the side that retains earth
Show Joints Displays the connecting joints between wall sections
Use Site 
Modifiers

Adds a pad and grade limits to each wall section and allows the landscape wall to modify the 
site model

Use Grade Limits Uses grade limits to define the site modifier modification area
Left/Right Grade 
Limits Off.

Controls the grade limit offsets on either side of the wall (applies only when site modifiers are 
used)

Mode Description

Boundary Configuration Creates a hardscape with a boundary configuration, defining an area with an optional 
border

Pathway Configuration Creates a hardscape along a path
Pathway Edge options For the pathway configuration, sets where to create the pathway in relation to the drawn 

polyline
Polyline creation options Selects the method for drawing the polyline upon which the hardscape object is based; 

see “Creating Polylines” on page 298.

Pathway Configuration

Boundary 
Configuration

 Preferences

Pathway Edge 
options

Polyline creation 
options
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To create a hardscape object:

1. Click the Hardscape tool from the Site Planning tool set.
2. Click Preferences from the Tool bar to specify the default Hardscape tool parameters for this session.

The Hardscape Object Settings dialog box opens. Enter the hardscape parameters.
Click to show/hide the parameters.

Preferences Sets the default preferences for the hardscape object

Parameter Description

Definition
Name Enter a name for the hardscape object, which displays as the ID in the ID tag
Tag Display Select whether to display the hardscape tag to the right or left of the leader line, without a 

leader line (floating), or not at all
Tag Style Select the ID tag display style.

• Select Name Only to display the name of the hardscape object only (as defined in the 
Name field)

• Select Name-Area(s) to display the hardscape object name, area and, if applicable, the 
area of the border

• Select Name-Area(s)-Perim to display the hardscape object name, perimeter length and, if 
applicable, the area of the border. 

Tag Class Select a class for the hardscape tags, to control the tag appearance (line and marker style) 
and visibility. The classes present in the drawing are listed; alternatively, create a new class 
by selecting New, select the default class name, or select the class named <Hardscape 
Class> which places the tag in the same class as the hardscape object.

Display Tag Line 
Marker

Displays a marker at the end of the leader line; specify the marker style by editing the 
hardscape tag class (see “Setting Class Properties” on page 179)

Snap Tag to 
Hardscape Edge

Select this option to automatically align the endpoint of the tag with the edge or corner of the 
hardscape that is nearest to the shoulder point of the tag

Mode Description
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Joint Pattern Select the main hardscape joint pattern. The Set Joint Pattern Options dialog box opens 
when Flagstone, Pavers-Grid, or Pavers-Running is selected. Enter the pattern size; click the 
Lock button to create a symmetrical pattern, or deselect the Lock button to create an 
asymmetrical pattern. Specify the pattern angle.

Alternatively, select a hatch, stipple, or tile resource from either the default content or the 
current file’s content (see “Resource Libraries” on page 219 or “Defining Hatches” on 
page 1105).
Click OK. For hatch, stipple, or tile fills, the selected resource’s name displays beneath the 
Joint Pattern list.

The joint pattern origin is editable and has a control point marked with a red locus for 
identification.

Area Class Select a class for the joint pattern, to control its appearance and visibility. The classes 
present in the drawing are listed; alternatively, create a new class by selecting New, or select 
the default class, Site-Hardscape Comp-Main Joint.

Configuration Sets the boundary and pathway parameters for the hardscape object
Boundary/
Pathway

Boundary defines the hardscape object with a user-defined polyline as the outer edge of the 
hardscape object (for example, to define regular or irregular patio areas), while Pathway 
defines the hardscape object with a user-defined polyline as an alignment for a linear path

Parameter Description

Pattern Angle

Pattern Size

Joint Pattern
Origin

None Flagstone Pavers-Grid

Pavers-Running Hatch Stipple

Boundary Pathway

Offset

Width
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The Stipple joint patterns are a processor-intensive action for large hardscape objects and can significantly 
increase regeneration time. 
When drawing a hardscape object with a curved boundary, speed the regeneration time by setting the 2D 
conversion resolution in Vectorworks preferences to low (see “Edit Preferences” on page 49).

3. Click OK.

Width Width of the pathway hardscape object
Offset Sets the offset of the pathway centerline from the placement line

Draw Border Select to include a border pattern along the edges of the hardscape object
Width Enter the width of the border
Joint Pattern Select the border paving pattern. The Enter Value dialog box opens when Spaced Joints is 

selected; enter the desired joint spacing value. Alternatively, select a hatch, stipple, or tile 
resource from either the default content or the current file’s content.
Click OK. For hatch, stipple, or tile fills, the selected resource’s name displays beneath the 
Joint Pattern list.
Similar to the main hardscape joint pattern, the border hardscape joint pattern origin is 
editable. It has a control point marked with a green locus for identification.

Background Color Click the color box to select the desired border color
Border Class Select a class for the border joint pattern, to control its appearance and visibility. The classes 

present in the drawing are listed; alternatively, create a new class by selecting New, or select 
the default class, Site-Hardscape Comp-Border Joint.

Pathway Borders Select the border configuration for pathway hardscape objects with borders

Draw 3D Specify 3D hardscape object parameters
3D Type The hardscape object can act as a 3D slab object or as a pad or texture bed site modifier for a 

site model. Select the type of 3D modifier to create. Select Slab or Pad Modifier if the 
paving area is flat. Select Texture Bed Modifier if the paving area covers an area of the site 
with topographical changes. For more information, see “Site Model Modification 
Overview” on page 705. Select None to not display the hardscape object in 3D views.

Thickness For a slab or pad, enter the thickness parameter
Main Texture Select the texture resource for the hardscape object or assign it by class; the displayed 

textures are from either the default content or the current file’s content. The texture origin 
and rotation are automatically set to match the 2D fill origin and rotation for the main 
texture area.

Border Texture Select the texture resource for the border object or assign it by class; the displayed textures 
are from either the default content or the current file’s content. The texture origin and 
rotation are automatically set to match the 2D fill origin and rotation for the border.

Parameter Description

Left

Direction of
placement polyStart

Right

End
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4. Click the appropriate mode in the Tool bar to specify the creation method of the hardscape object. Select whether 
to create a boundary or pathway hardscape object.
The hardscape configuration can also be changed after creation from either the Hardscape Object Settings dialog 
box or the hardscape context menu commands (see “Converting the Hardscape Object to a Boundary or Pathway 
Configuration” on page 751).
For information on the Polyline tool modes, see “Creating Polylines” on page 298.

5. Click to set the hardscape object’s start point.
6. Click to set the end of the segment and the beginning of the next. Continue drawing segments in this manner until 

the hardscape object is complete. Return to the start point (for boundary configurations), or simply double-click 
(for either pathway or boundary configurations) to finish creating the hardscape object.

7. When classing the subcomponents of the hardscape object, such as for the joints or tags, the class visibility of the 
specified class controls the visibility of the corresponding subcomponent. The class attributes are only applied to 
the corresponding subcomponent when the Use at Creation option is selected for the class. For example, if the 
Joint Class is set to the Site-Hardscape Comp-Main Joint class, and that class specifies a hatch Fill Style, edit the 
class and select the Use at Creation option to apply the fill attribute.

8. If the hardscape 3D Type is set to Pad Modifier or Texture Bed Modifier, update the site model to apply the 
modification. Select the site model and click Update from the Object Info palette.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing the Hardscape Object Settings
Editing Hardscape Object Fills
Applying Colors
Updating a Site Model
Setting Class Attributes

Editing the Hardscape Object Settings
The parameters can be edited for selected hardscape objects through the Hardscape Settings button on the Shape tab 
of the Object Info palette. To modify the default hardscape object settings, click the Preferences button on the Tool bar.
Many of the parameters are identical to those used to create the hardscape object (see “Creating Hardscape Objects” on 
page 745). However, certain parameters are accessible in the Object Info palette only.
Click to show/hide the parameters.

Parameter Description

Shape Tab
Hardscape Settings Click to edit the selected hardscape object. If more than one hardscape object is selected 

for editing, the Hardscape Settings button appears dimmed; select a single hardscape 
object to access the Hardscape Object Settings dialog box for editing parameters.

Save Hardscape Click to save the selected hardscape object as a symbol; for more information, see 
“Saving the Hardscape Object Settings” on page 752. If more than one hardscape object 
is selected for editing, the Save Hardscape button appears dimmed; select a single 
hardscape object to save it as a symbol.

Definition
Hardscape Name Specifies the name assigned to the hardscape object

http://www.youtube.com/watch?v=t5PKnfTu50c
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Draw Border Includes a border pattern along the edges of the hardscape object
Border Width Enter the width of the border
Path Width Width of the pathway hardscape object
Path Offset Sets the offset of the pathway centerline from the placement line
Joint Pattern Size X/
Y

Specifies the size of the joint pattern units, for flagstone, pavers-grid, and pavers-running 
joint patterns

Joint Pattern Angle Specifies the rotation angle of the joint pattern
Border Pattern Size Sets the width of the spaced joints, when spaced joints are selected for the border
Border Pattern 
Angle

Enter the angle of the pattern inside the border

Main Unit Price Sets the price per square unit for the main hardscape material, for use in worksheets
Main Price Code Specifies the main hardscape price code
Border Unit Price Sets the price per square unit for the border material, for use in worksheets
Border Price Code Specifies the hardscape border price code

Tag
Tag Display Select whether to display the hardscape tag to the right or left of the leader line, without a 

leader line (floating), or not at all
Tag Style Select the ID tag display style.

• Select Name Only to display the name of the hardscape object only (as defined in the 
Name field)

• Select Name-Area(s) to display the hardscape object name, area and, if applicable, the 
area of the border

• Select Name-Area(s)-Perim to display the hardscape object name, perimeter length 
and, if applicable, the area of the border.

Tag Class Select a class for the hardscape tags, to control the tag appearance (line and marker style) 
and visibility. The classes present in the drawing are listed; alternatively, create a new 
class by clicking New, or select the class named <Hardscape Class> which places the tag 
in the same class as the hardscape object.

Tag Approach Angle Specifies the angle of the leader line, from 0 to 360°
Tag Shoulder Angle When a tag shoulder line is enabled, sets the angle of the shoulder line, from 0 to 360°
Tag Text Alignment Select whether the tag text is aligned on top of a continuation of the leader line, or 

centered vertically at the end of the leader line
Snap Tag to 
Hardscape Edge

Select this option to automatically align the endpoint of the tag with the edge or corner of 
the hardscape that is nearest to the shoulder point of the tag

Display Tag Line 
Marker

Displays a marker at the end of the leader line; specify the marker style by editing the 
hardscape tag class (see “Setting Class Properties” on page 179)

Draw 3D

Parameter Description
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To set individual border segments to invisible for boundary hardscapes or cut-out holes, select the hardscape 
object, and then click the Reshape tool. Select Hide or Show Edges mode. Click the midpoint of the hardscape 
border segments or the cut-out hole to hide. Repeat this process to set the border segments back to visible, if 
necessary.
To quickly determine the left and right side of a pathway hardscape object, select the hardscape object and click 
the middle button next to the Vertex field on the Shape tab of the Object Info palette; while the button is clicked, 
the first vertex of the hardscape object is highlighted with a red box.
When classing the subcomponents of the hardscape object, such as for the joints or tags, the class visibility of the 
specified class controls the visibility of the corresponding subcomponent. The class attributes are only applied to 
the corresponding subcomponent when the Use at Creation option is selected for the class. For example, if the 
Joint Class is set to the Hardscape - Component - Main Joint class, and that class specifies a hatch Fill Style, edit 
the class and select the Use at Creation option to apply the fill attribute. See “Setting Class Attributes” on 
page 181.

Reshaping the Hardscape Object
Double-click the hardscape object to activate the Reshape tool, or select the Reshape tool from the Basic palette. 
Select the object handles to reshape the hardscape object. For more information, see “Reshaping Objects” on 
page 1043.

Converting the Hardscape Object to a Boundary or Pathway Configuration
After creation, a boundary hardscape object can be converted to a pathway hardscape object, and similarly, a pathway 
configuration can be converted to a boundary configuration. The conversion preserves the appearance, but the path of 
the object changes.

3D Type The hardscape object can act as a 3D slab object or as a pad or texture bed site modifier 
for a site model. Select the type of 3D modifier to create. Select Slab or Pad Modifier if 
the paving area is flat. Select Texture Bed Modifier if the paving area covers an area of 
the site with topographical changes. For more information, see “Site Model Modification 
Overview” on page 705. Select None to not display the hardscape object in 3D views.

3D Thickness For a slab or pad, enter the thickness parameter
Information

Main Area Displays the size of the main area
Border Area Displays the size of the border area
Footprint Area Displays the area of the entire footprint of the hardscape
Main Perimeter Displays the perimeter measurement of the main area polyline
Border Perimeter Displays the perimeter of the border only
Footprint Perimeter Displays the perimeter measurement of the entire footprint polyline

Vertex parameters Edits the vertices of the path object that the hardscape is based upon; see “Editing 
Vertex-Based Objects” on page 1002

Render Tab
Texture If a 3D Type was selected in the Hardscape Object Settings dialog box, the Texture 

drop-down list is enabled for the main area texture (border textures must be set in the 
Hardscape Object Settings dialog box)

Parameter Description
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To convert a boundary hardscape object to a pathway hardscape configuration:
1. Select the boundary hardscape object.
2. Right-click (Windows) or Ctrl-click (Mac) on the hardscape object and select Convert to Pathway from the 

context menu.
To convert a pathway hardscape object to a boundary hardscape configuration:

1. Select the pathway hardscape object.
2. Right-click (Windows) or Ctrl-click (Mac) on the hardscape object and select Convert to Boundary from the 

context menu.
Alternatively, click Hardscape Settings from the Object Info palette of a selected hardscape object, and select the 
configuration.

Hardscape Tag Appearance
Hardscape tags can be adjusted in several ways.

• When hardscape tags are required, their default appearance is normally specified in the hardscape object settings. 
• Individual hardscape tags can then be changed for selected hardscape objects by adjusting the hardscape tag 

parameters in the Object Info palette.
• The hardscape tag class controls the appearance of the leader/shoulder lines, as well as the marker style.
• To align hardscape tags for improved readability, use the Align/Distribute Leader Lines command (see 

“Aligning and Distributing Leader Lines” on page 1035).
• If an individual tag needs to be repositioned, hardscape tags also have two control points for adjusting the shoulder 

length, tag shoulder angle, and tag location; or the shoulder location, leader line length, and tag approach angle.

Saving the Hardscape Object Settings

Once the hardscape object is set to the desired appearance, the settings can be saved for future use or importing into 
other files, by saving the hardscape object. When you insert a hardscape from the Resource Browser, all its object 
settings are preset.

Boundary hardscape object (closed path) Pathway hardscape object (open path)

Adjusts shoulder length, tag shoulder 
angle, and tag location

Adjusts shoulder location, leader line 
length, and tag approach angle

When Snap Tag To 
Hardscape Edge is 
deselected, specifies 
where the tag ends



Creating Hardscape Objects |  753
To save the selected hardscape object settings:
1. Select a hardscape object.
2. In the Object Info palette, click Save Hardscape.

The Enter String dialog box opens.
3. Enter a unique name.
4. Click OK.

The hardscape object is saved in the “Hardscapes” symbol folder in the Resource Browser. Boundary and pathway 
hardscape objects are assigned unique thumbnail view icons for easy identification. For more information on the 
Resource Browser, see “Using the Resource Browser” on page 221.

5. To use a saved hardscape object, double-click on it in the Resource Browser. Alternatively, drag the saved 
hardscape onto an existing hardscape to apply the saved settings.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Hardscape Objects
Editing Hardscape Object Fills

Editing Hardscape Object Fills
Hardscape object fills can be changed through the Attributes palette. If a joint pattern was specified, the joint pattern is 
drawn over the fill attribute of the hardscape object. The main joint pattern origin is editable and has a control point 
marked with a red locus for identification; the border joint pattern uses a green locus.
To change the appearance of a hatch fill, edit the hatch definition as described in “Editing Hatch Definitions” on 
page 1111. Change the size or angle of a hatch fill by temporarily switching to a Pavers-Running pattern, setting the 
Pattern Size X, Y and/or Pattern Angle values, and then switching back to the selected hatch.
Hardscape objects can also use images and gradients as fills. Use the Attribute Mapping tool to adjust the fill 
direction and size. For more information on using image or gradients, see “The Attributes Palette” on page 1093; for 
more information on using the Attribute Mapping tool, see “Mapping Fills with the Attribute Mapping Tool” on 
page 1123.
If the subcomponents of the hardscape object are classed, such as for the joints or tags, the class visibility of the 
specified class controls the visibility of the corresponding subcomponent. The class attributes are only applied to the 
corresponding subcomponent when the Use at Creation option is selected for the class. For example, if the Joint Class 
is set to the Hardscape - Component - Main Joint class, and that class specifies a hatch Fill Style, edit the class and 
select the Use at Creation option to apply the fill attribute. See “Setting Class Attributes” on page 181.

The angle or origin point of a hardscape fill can be adjusted. Move the control point at the center of the hardscape 
to control the origin point of the paving pattern (including a hatch) and change the Joint Pattern Angle value to 
adjust the angle.
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When joining bordered hardscape objects with similar borders, use the Add Surface command (see “Add 
Surface” on page 1082).
To coordinate the joint patterns of several hardscape objects, configure the hardscape objects with the same 
settings and drag their main pattern origin control points (marked with the red locus) to a common location.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Hardscape Objects

Showing and Hiding Site Modifiers
In the Vectorworks Landmark product, site modifiers such as pads, grade limits, and portions of roads and landscape 
walls can be made hidden or visible. The modifications to the proposed site model are still visible even when the 
modifier is hidden.
To show or hide site model modifiers:

1. Select View > Show > Show or Hide Site Modifiers.
2. If site modifiers were hidden, they are displayed; if they were visible, they become hidden.

Correcting Site Modifier Errors
If site modifier errors are detected when the site model is updated, an icon displays at the location of each error.
The following modifier problems can generate errors:

• Pad which does not lie inside the grade limits
• Pad intersecting grade limits or the site border
• Two intersecting pads
• Spoil pile intersecting the site border
• Spoil pile intersecting grade limits or the site border
• Two intersecting spoil piles
• Texture bed intersecting the site border
• Two intersecting texture beds
• Locus which does not lie inside the grade limits

Set joint patterns of all 
hardscape objects to same point

Boundary
hardscape Path 

hardscape

Boundary 
hardscape 
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If these errors exist, the site model can still be modified; however, results may not be as expected. It may be better to 
resolve the errors and update the site model again before proceeding.
When the site model object is selected, the Object Info palette’s Error Count field displays the number of errors, and 
an icon displays at the location of each error. Hold the cursor over an icon to display a SmartCursor cue that describes 
the error. Resolve the errors by making adjustments to prevent all intersecting modifiers.

To hide the icons from view (but not resolve the underlying errors), deselect Show Errors on the site model’s 
Object Info palette.

Update the site model to ensure that all errors have been corrected.
~~~~~~~~~~~~~~~~~~~~~~~~~
Validating 3D Source Data
Site Model Properties

Drawing Property Lines
Use the Property Line tool to draw property lines. Alternatively, use one of the following methods.

• Draw a polyline and then select the Create Objects from Shapes command (see “Creating Objects from Shapes” 
on page 277).

• Draw arcs and lines, select Modify > Compose to create a single polyline, and then select the Create Objects 
from Shapes command.
Click here for a video tip about this topic (Internet access required).

Property Line Tool
The Property Line tool interactively creates property boundaries from surveyor’s descriptions. The resulting polyline 
is composed of line and/or arc segments. The closing error can be automatically drawn and measured. Each segment 
can be individually labeled with distance and bearing; a curve data worksheet displays curve data.

To create property lines using the Property Line tool:

1. Click the Property Line tool from the Site Planning tool set.
2. Click to set the starting point of the first property segment.

A red bull’s-eye is placed on the drawing to mark the starting point; the Define Property Line dialog box opens.
3. Specify the segment parameters and click Add to update the drawing file; the bull’s-eye cursor moves to the end 

of the segment. Continue to add or remove segments as needed.
Click to show/hide the parameters.

Parameter Description

Line Specify whether the current segment is a line

http://www.youtube.com/watch?v=uRj8ZIFJ-LE
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4. Click OK to create the property line.
If this is the first time the Property Line tool has been used, the Object Preferences dialog box opens. Accept the 
defaults and click OK.

Bearing Enter the azimuth or bearing of the line segment; if entering a bearing, a variety of 
formats are supported. Use spaces (N 10 30 0 E), degrees—d for degrees, m for 
minutes, and s for seconds (N10d0m0s E), or decimal degrees (N 10.5d 0m 0s E).

Distance Enter the distance of the line segment
Curve Specify whether the current segment is a curve

Start Tangent to 
Previous

Forces the back tangent to be collinear with the previous segment

Back Tangent Enter the azimuth of the back tangent of this curve; a variety of formats are supported. 
Use spaces (10 30 0), degrees—d for degrees, m for minutes, and s for seconds 
(10d0m0s), or decimal degrees (10.5d 0m 0s).

Radius Enter the radius of the curve segment
Arc Dist Select to use the distance along the arc

Chord Dist Select to use the distance between the point of tangency and the point of curvature

Tangent Dist Select to use the distance from the end point of the last segment to the point of the 
intersection of the curve 

Delta Angle Select to use the central angle of the curve as measured from the center of the arc

Chord Bear. Select to use the bearing of the arc chord
Forward Tangent Displays the forward tangent value
Counter-Clockwise Select to draw the curve Counter-Clockwise

Remove Click to remove the selected segment from the property line
Update Click to update the parameters for the current segment
Add Click to add a segment to the property line
< Previous / Next > Click to move backward and forward through the segments
Automatically create 
closing segment

Select to automatically create the final segment between the last point and the first

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Property Lines

Editing Property Lines
Edit property lines by using the Reshape tool, or by clicking the Edit with Dialog button in the Object Info palette. 
Additional parameters can also be modified in the Object Info palette. See “Reshaping Objects” on page 1043 for 
information on using the Reshape tool for editing.
To edit property lines using the Object Info palette:

1. Select the property line.
2. Modify the parameters in the Object Info palette.

Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using options 
on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 and 
“Formatting Text” on page 389.

Name Enter a property line name
Number Enter a property line number
Area Displays the area of the property line
Perimeter Displays the length of the property line perimeter 
Show Name Select to display the property line name
Show Number Select to display the property line number
Show Area Select to display the area of the property line, along with a leader line
Area Units If using Imperial drawing units, select Acres or Square Feet; if using metric drawing 

units, select Hectares or Square Meters
Decimals Indicates the number of decimal places to display for the property line area
Text Rotation Specifies the text rotation degrees
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For information on editing object vertices, see “Reshaping Objects” on page 1043.
3. If the property line was designated to be a texture bed on the site model, select Tools > Organization. On the 

Classes tab, select the class designated as the texture bed class, and assign it a distinctive fill color, or, if the 
Renderworks product is installed, a texture. Select the site model and click Update from the Object Info palette; 
the property line displays as a texture bed on the site model. Switch to a 3D view and render for the full effect.

4. When Annotate Segments is selected and curve data exists, a curve data worksheet is automatically created, 
showing curve data in worksheet form. Select Window > Worksheets to display the worksheet, or view it from 
the Resource Browser.

~~~~~~~~~~~~~~~~~~~~~~~~~
Property Line Tool

Analyzing the Site Model

Reporting Site Model Volume
The individual cut and fill calculations for a site model can be listed in a report for verification.
To list site model volume:

1. Select the site model to analyze. Only one site model can be analyzed at a time.
2. Select the Create Site Volume List command from the appropriate menu:

• Architect workspace: AEC > Terrain > Create Site Volume List
• Landmark workspace: Landmark > Create Site Volume List 
The Create Site Model Volume List dialog box opens. On the Columns tab, select the columns of site model data 
to include in the report.

Click to show/hide the parameters.

Fill Behind Text Select to display a fill behind text
Annotate Segments Select to annotate each segment of the property line

Annotation Style When Annotate Segments is selected, indicate the annotation information to display
Angle Format Select whether the annotations display in Azimuth or Bearing angle format
Show as Texture Bed on 
Site Model

Select to display the property line as a texture bed on the site model (see “Creating a 
Texture Bed” on page 715)

Texture Bed Class If Show as Texture Bed was selected, specify the texture bed class
Edit with Dialog Click to display the Define Property Line dialog box for editing the property line; see 

“Drawing Property Lines” on page 755 for information on parameters
Vertex parameters Edits the property line path vertices; see “Editing Vertex-Based Objects” on page 1002

Parameter Description

Available Columns Lists the columns that can be selected for inclusion in the report
Selected Columns Lists the columns to be included in the report; to change the list order, use the cursor 

to drag and drop the items to move in the # column.

Parameter Description
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3. On the Grade Limits Modifiers tab, select the grade limits site modifiers to include in the report calculations.
Click to show/hide the parameters.

Add > Adds one or more selected item(s) from the available list to the end of the Selected 
Columns list

Add All >> Adds all available columns to the end of the Selected Columns list
< Remove Removes one or more selected item(s) from the Selected Columns list
<< Remove All Removes all column items from the Selected Columns list
Column Parameters

Triangle Index Creates a numeric index for each triangle that makes up the site model Triangulated 
Irregular Network (TIN)

Existing Surface Area Lists the surface area of each triangle in the existing site model
Proposed Surface 
Area

Lists the surface area of each triangle in the proposed site model

Projected Area Lists the projected area of the common (existing and proposed) site model triangles
Existing Volume Lists the volume of each triangle (extruded to the existing site model’s Minimum 

Elevation plus its Datum Elevation)
Proposed Volume Lists the volume of each triangle (extruded to the proposed site model’s Minimum 

Elevation plus its Datum Elevation)
Cut Volume Compares the existing and proposed volume for each triangle in the site model, and 

displays the extra volume present in the proposed model
Fill Volume Compares the existing and proposed volume for each triangle in the site model, and 

displays the volume removed from the proposed model
Net Cut & Fill 
Volume

Lists the fill volume minus the cut volume for each triangle in the site model

Total Cut & Fill 
Volume

Lists the fill volume plus the cut volume for each triangle in the site model

Parameter Description

Available Grade 
Limits Modifiers

Lists the grade limit-type site modifiers in the drawing; grade limits modifiers are 
identified by an assigned number

Selected Grade Limits 
Modifiers

Lists the site modifiers to be included in the report calculations

Add > Adds one or more selected item(s) from the available list to the end of the Selected 
Grade Limits Modifiers list

Add All >> Adds all available modifiers to the end of the Selected Grade Limits Modifiers list
< Remove Removes one or more selected item(s) from the Selected Grade Limits Modifiers list
<< Remove All Removes all items from the Selected Grade Limits Modifiers list
Show Modifier When a numbered grade limits modifier is highlighted, selects the associated site 

modifier in the drawing, and zooms in so the site modifier is easily identifiable

Parameter Description
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4. On the Options tab, choose report output parameters.
Click to show/hide the parameters.

5. Click OK to create the site model volume report.

Zone of Visual Influence Analysis
This type of analysis creates a representation of shadowed and lighted areas as seen from a specified point of view.
To perform a zone of visual influence analysis:

1. Select the site model to analyze.
2. Select the Zone of Visual Influence command from the appropriate menu: 

• Designer workspace: AEC > Terrain > Zone of Visual Influence
• Landmark workspace: Landmark > Zone of Visual Influence.
The Zone of Visual Influence dialog box opens. Specify the analysis parameters.

Click to show/hide the parameters.

3. Click OK. 
4. Click on the site model to indicate the observation point. 

Modifier Parameters
Outside Grade 
Limits

Includes all areas of the site model surface without any modifiers

Grade Limits 
Modifier __

Each grade limits site modifier in the drawing is identified with a number. If you have 
provided a name for the site modifier on the Data tab of the Object Info palette, the 
name displays in parentheses

Parameter Description

Show Data for Unmodified 
Site Model Surface

When selected, the report includes the entire surface of the site model. Deselect this 
option to exclude the unchanged surface between the existing and proposed site 
models from the report.

Create Text File Creates a tab-delimited text file of the report, which can easily be imported into a 
spreadsheet program for further manipulation. Specify the name of the text file and the 
location to save it in.

Create Triangle Group Creates a group containing subgroups of polygons and volumetric data text for each 
triangle that makes up the site model triangulated network. For complex site models, a 
significant amount of information is displayed; adjust text size of the entire selected 
group with Text > Size.

Create Worksheet Adds a Volume List worksheet containing the volume data to the current file

Parameter Description

Select Site Model Select the site model to analyze
View height above Site 
Model

Represents the view point elevation for the study. For example, 60 inches (152.4 cm) is 
often used as a standard eye level when standing.

Parameter Description
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5. Click again to perform the analysis.
A light source is automatically inserted, and the layer is rendered to complete the analysis. Dark regions indicate 
areas that cannot be seen from the specified observation point at that viewing level.

~~~~~~~~~~~~~~~~~~~~~~~~~
Reporting Site Model Volume

Obtaining Site Model Data

Site Model Section
Use the Site Model Section command to create a profile or sectional views of the site.
To create a site model section:

1. Draw or select a 2D polygon or polyline to define the section alignment. In the Vectorworks Landmark product, if 
you are selecting a previously drawn polyline with station points (such as a road or Roadway (NURBS) object), a 
station point profile can be created.

The polygon or polyline vertices must be contained within the limits of the site model.
2. With the polygon or polyline selected, select the Site Model Section command from the appropriate menu:

• Architect workspace: AEC > Terrain > Site Model Section
• Landmark workspace: Landmark > Site Model Section
The Create Site Model Section dialog box opens. Specify the site model section parameters.

Observation 
point

Zone of Visual Influence analysis
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Click to show/hide the parameters.

3. Click Formatting.
The Site Model Section Formatting dialog box opens. Specify the formatting for the site model section graphic.

Click to show/hide the parameters.

Parameter Description

Create section on layer Specify the layer where the section will be placed
Draw Background Grid Select to draw a background grid, and click the color box to specify the grid color
Draw Existing Site Profile Select to draw a profile for the existing site model, and click the color box to 

specify the profile color
Draw Proposed Site Profile Select to draw a profile for the proposed site model, and click the color box to 

specify the profile color
Draw Selected Station Profile
(Vectorworks Landmark 
required) 

Select to draw a profile of the station points, and click the color box to specify the 
profile color; this option is available only if a polyline associated with station 
points (such as a road) is selected 

Station Points
Draw points at polygon 
vertices

If the selected polygon does not contain stake objects, select to create station 
points at the polygon vertices; this option is available only if a station polyline is 
selected

Draw points at interval If the selected polygon does not contain stake objects, select to create station 
points at the specified interval

Draw points at existing stakes
(Vectorworks Landmark 
required)

When stakes exist along the profile polygon, station points are automatically 
created for the stakes; this option is available only if a polyline with station points 
(such as a road) is selected

Formatting Click to specify the section graphic formatting

Parameter Description

Display Scale Factor Specifies the site model scale factor; the layer scale factor is entered by default
Vertical Magnification Factor Sets an independent scale factor for the Y axis of the graphic
Vertical Margin Specifies the distance, in page units, between the highest and lowest points in the 

graph and the graph margins
Horizontal Margin Specifies the distance, in page units, between the graph start and end and the graph 

margins
Draw Legend Text Indicates whether to create a legend for the graph; legend text is color coded to 

match the section profiles
Legend point size Specifies the size, in points, of the legend text

Draw Elevations Indicates whether to display the elevation of the profiles along the station points
Elevation point size Specifies the size, in points, of the elevation text

Station Point Labels
(Vectorworks Landmark 
required)

Sets the type of label, if any, to apply to the station points on the background grid
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4. Click OK to return to the Create Site Model Section dialog box.
5. Click OK to create the sectional view of the site. If the site model changes, the site model section needs to be 

recreated.

~~~~~~~~~~~~~~~~~~~~~~~~~
Calculating Grade
Inserting Stake Objects

Calculating Grade
The Grade tool annotates terrain slopes on site plan documents.
Networks of grade objects can be created to show slope characteristics across a surface. Grade objects can be used in 
conjunction with a site model, and can modify the site model. In addition, 3D loci can be generated from grade object 
elevations, and used as the basis of creating a site model.
The Grade tool has three modes:

Profile Line Weight Specifies the thickness of the profile lines
Station Line Weight Specifies the thickness of the station lines

Mode Description

Insert Draws a grade object based on set elevation parameters or a site model
Edit Elevation Changes the elevation value of one or more existing grade objects
Update Updates all grade objects in the drawing, applying current preference settings and updating 

any overlapped elevation points
Preferences Sets the default global preferences for the grade object

Parameter Description

Legend

Station point labels
(Landmark required)Station lines

Profile 
lines

Elevations

Insert

Edit Elevation

Update

Preferences
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~~~~~~~~~~~~~~~~~~~~~~~~~
Specifying Global Grade Object Preferences
Inserting Grade Objects
Editing Elevation
Analyzing Grade
Creating Loci from a Grade Object

Specifying Global Grade Object Preferences
The grade indicator appearance for all grade objects in the file can be specified globally. 

To set global grade object appearance:

1. Click the Grade tool from the Site Planning tool set.
2. Click Preferences from the Tool bar. Alternatively, select an existing grade object; click Settings from the Object 

Info palette, double-click the grade object, or right-click (Windows) or Ctrl-click (Mac) on a grade object and 
select Edit from the context menu.
The Grade Settings dialog box opens. Click the Global Settings tab and enter the desired settings.

Click to show/hide the parameters.

Parameter Description

Display Settings (global)
Arrow Line Length Specifies the length of the grade directional arrow, in page units
Arrow Offset Sets the distance of the grade directional arrow from the grade line, in page units
Grade Def. Select the type of display for the slope (percent, permille, run/rise ratio, rise/run ratio, 

or angle)
Precision Sets the displayed precision for the slope value

Directional Indicator 
Attributes (global)

Pen/Style Select the pen style and line thickness for the grade directional arrow. Alternatively, 
select Class style in the Pen list. The pen, color, style, and marker are then determined 
by the class attributes of the grade object.

Color Click the color box to select the grade directional arrow color
End Marker Specifies the marker type for the end of the grade directional arrow
Opacity Sets the opacity of the grade directional arrow; drag the slider to the left to decrease 

opacity, or enter an opacity percentage
Use Class Opacity The opacity of the arrow can be set by the class of the grade object

Reshape Setting (global)
Preserve Grade if one 
point is not connected

Preserves the grade of a reshaped grade object, and recalculates the elevation. 
This preference works only if at least one end point of the reshaped grade object is not 
connected to another grade object; the elevation of the unconnected end point is 
changed. If both end points of the reshaped grade object are connected to other grade 
objects, the grade is changed and the elevations are preserved to maintain continuity 
with the connected grade objects.
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3. Click OK to set the global grade indicator attributes.
4. Click Update from the Tool bar to update all grade objects in the drawing with the global settings.

~~~~~~~~~~~~~~~~~~~~~~~~~
Calculating Grade
Applying Object Attributes
Inserting Grade Objects
Analyzing Grade

Inserting Grade Objects

To insert a grade object:

1. Click the Grade tool from the Site Planning tool set, and select Insert mode from the Tool bar.
2. Click to set the start of the grade. Move the mouse and click again to set the end point.

The Grade Settings dialog box opens. Click the Object Properties tab and enter the desired settings.
Click to show/hide the parameters.

Analyze Grade Objects Uses grade objects to analyze the slope or elevation

Parameter Description

General Given two parameters, the grade parameters are calculated for the remaining parameters. 
Enter the two known parameters to calculate and display the other grade parameters.
The initial elevation of the first and/or second points of the grade object is determined by 
these methods:
• If an existing grade object is under one of the points, the elevation of the existing 

grade object is used
• If a stake object is under one of the points, its elevation is used
• If a site model is under one of the points, the calculated elevation of the point is used
• If none of the above occurs, the elevation of the last created grade object is used

Parameter 1 Select the first known parameter (Elevation 1, Elevation 2, Downward Grade in %, 
Upward Grade in %, Downward Ratio (rise/run), Upward Ratio (rise/run), or elevation 
change) and enter the value(s) associated with the parameter

Parameter 2 Select the second known parameter (available choices depend on the first parameter 
selected), and enter the value associated with the parameter

Parameter Display The remaining parameters are calculated and displayed, including the grade length 

Parameter Description
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Graphics Sets the graphic appearance of the grade object. The appearance of the indicator, grade 
definition, and precision is set in the global settings (see “Specifying Global Grade 
Object Preferences” on page 764).
Once created, each graphic element of the grade object has its own control point. Move a 
control point to adjust the position of the text and indicator. 

Elevation marker 
symbol

Select the symbol to use to indicate the elevation marker at each end of the grade object; 
grade symbols are also provided as default content (default content is automatically 
imported into the current file at the point of use and displays in the Resource Browser; 
see “Resource Libraries” on page 219)

Scale Scales the elevation marker with respect to the layer scale by the specified scale factor; a 
Factor of less than one decreases the size of the marker while a Factor of more than one 
increases its size

Show Slope Value Displays the grade value
If the value does not display, increase the text size by selecting Text > Size.

Show Projected 
Length/Surface 
Length Value

Displays the projected grade length/surface length and the slope arrow; the slope arrow 
always indicates the downward slope direction. Enter a prefix for the value, if desired. 
The projected length is the distance between the points as measured along a horizontal 
projection; the surface length is the distance between the points as measured along the 
surface, which facilitates a more accurate calculation for purchasing materials.

If both Show Projected Length Value and Show Surface Length Value are 
selected, both values are displayed along the grade object, with a slash (/) in 
between them (prefix + projected length/prefix + surface length)

Show Elevation 
Value

Displays the elevation value at each end of the grade object

Draw Line Draws a slope line to represent the distance between the two elevation points
Site Model 
Grade Object Mode

Use Grade Object 
Heights

Uses the elevation values specified in the General parameters

Use Heights from 
Site Model

When the grade is drawn over a site model, the elevation of the first and second points is 
derived from either the existing or proposed site model. The values in the General 
parameters do not apply. The grade object updates with the site model.

Parameter Description
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3. Click OK.
Grade objects can be edited from the Object Info palette. Commonly-required parameters can be accessed directly 
from the Object Info palette, or click Settings to change any of the parameters of selected grade objects. 
Alternatively, edit the settings of a grade object by double-clicking on it, or right-click (Windows) or Ctrl-click 
(Mac) on a grade object and select Edit from the context menu.
Grade objects can be used together, using an existing grade object as a reference for another grade object. Either 
move the endpoint of one grade object onto the line of another grade object, or create a new grade object with an 
end point on an existing grade object. The existing grade object is split at the new endpoint, creating a network of 
overlapping grade objects. The elevation of the shared point is interpolated from the slope of the existing object; if 
an elevation point is updated, all overlapping grade objects automatically update. Click Update mode from the 
Tool bar of the Grade tool to force an update of all overlapping grade objects.

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Calculating Grade
Specifying Global Grade Object Preferences
Editing Elevation
Analyzing Grade
Creating Loci from a Grade Object
Site Model Section
Inserting Stake Objects

Change Site Model 
(Use Grade as Pad 
Modifier)

Uses the grade object as a site modifier object; the elevation values specified in the 
General parameters are applied to either the existing or proposed site model. Update the 
site model to apply the changes (select the site model and click Update from the Object 
Info palette). 

Apply To
Existing/Proposed 
Site Model

Selects the site model to provide elevation values when Use Heights from Site Model is 
selected, or the site model to be modified when Change Site Model is selected

Parameter Description

Click 1

Click 2

http://www.youtube.com/watch?v=YmUZ2Yn7T_A&list=UUN7uzhu-ljLJOe6a0J-fBcQ
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Editing Elevation
If the elevation changes after one or more grade objects have been placed, there is no need to replace the existing grade 
object(s). Change the elevation of one end of a grade object, or offset the elevation of selected (or all) grade objects in 
the drawing.

Elevation marker symbols must be at a valid scale to edit elevations. If the Edit Elevation dialog box does not 
open, increase the marker scale factor for the grade object.

To edit grade object elevation:

1. Click the Grade tool from the Site Planning tool set, and select Edit Elevation mode from the Tool bar.
2. Click at the start or end of a grade object.

On the Edit Elevation dialog box, edit the grade as needed.
Click to show/hide the parameters.

3. Click OK to edit the elevation of the grade object(s).
~~~~~~~~~~~~~~~~~~~~~~~~~
Calculating Grade
Specifying Global Grade Object Preferences
Inserting Grade Objects
Analyzing Grade
Creating Loci from a Grade Object

Analyzing Grade
Grade objects can be used to analyze the slope objects in a drawing and identify critical slopes. Grade objects that are 
outside specified slope or elevation ranges are highlighted or selected.

To perform a grade analysis:

1. Click the Grade tool from the Site Planning tool set.
2. Click Preferences from the Tool bar. Alternatively, click Settings from the Object Info palette of a selected grade 

object.
The Grade Settings dialog box opens. Click the Global Settings tab and specify the grade analysis parameters.
Global attribute display of the slope indicator is described in “Specifying Global Grade Object Preferences” on 
page 764

Click to show/hide the parameters.

Parameter Description

Elevation at Selected End Marker Changes the elevation for the selected end of the grade object
Offset Selected Grade Objects Adjusts the elevation of all selected grade objects by the specified amount
Offset All Grade Objects Adjusts the elevation of all grade objects in the file by the specified amount

Parameter Description

Analyze Grade Objects
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3. Click OK. Grade objects that do not meet the criteria are considered critical, and are highlighted and/or selected, 
as specified.

~~~~~~~~~~~~~~~~~~~~~~~~~
Calculating Grade
Specifying Global Grade Object Preferences
Inserting Grade Objects
Editing Elevation
Creating Loci from a Grade Object
Setting Site Model Graphic Properties

Creating Loci from a Grade Object
One or more grade object(s) can be used to place 3D loci on the current layer. The 3D loci can then be used to create 
stake objects or a site model.
To create 3D loci from stake object elevations:

1. Select one or more grade objects.
2. Select the Create 3D Loci at Grade Points command from the appropriate menu: 

• Designer workspace: AEC > Terrain > Create 3D Loci at Grade Points
• Landmark workspace: Landmark > Create 3D Loci at Grade Points
A 3D locus is placed at the ends of each selected grade object. The Z-value of the loci match the associated 
elevation of the grade start or end point.

~~~~~~~~~~~~~~~~~~~~~~~~~
Calculating Grade
Inserting Grade Objects
Creating the Site Model
Converting 3D Loci to Stake Objects

Inserting Stake Objects
Stake objects represent a 3D point in space, with text to display the elevation, coordinate points, or other information. 
Using a stake object, the elevation information for a point on the site model can be determined and labeled. A stake 
object can be used as a site modifier. If the design layer is georeferenced, a stake object can be used as a geographic 
marker.

Mark Objects Select the action to take when critical grade objects are identified
Highlight Critical 
Objects

Click the color box to select the highlight color for grade objects that meet the criteria

Select Critical Objects Selects all grade objects that meet the criteria
Criteria Specifies the criteria for critical grade objects

Grade out of range (%) Sets a range of acceptable slope values; grades outside of the range are considered to be 
critical

Elevations out of range Sets a range of acceptable elevation values; elevations outside of the range are 
considered to be critical

Show intersections Specifies that any intersecting grade objects should be considered critical

Parameter Description
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The following modes are available.

To insert a stake object:

1. Click the Stake tool from the Site Planning tool set, and select the mode from the Tool bar.
2. Click on the site model to place the stake object, or draw a temporary polygon to place a series of stake objects at 

each click point and double-click to end the series.
If this is the first time the Stake tool has been used, the Object Properties dialog box opens. Accept the defaults 
and click OK.
To automatically increment the ID parameter when placing new stake objects, select Auto ID Numbering and 
specify an Initial ID Number. Otherwise, leave Auto ID Numbering unselected and specify the default ID 
Number for stake objects.

3. The stake objects are added to the drawing at the elevation specified in the Tool bar.
Select the Send to Surface command to set the stake elevation to that of the site model surface (see “Sending 
Objects to the Site Model Surface” on page 705).

4. If the stake objects are site modifiers, update the site model to apply the changes (select the site model and click 
Update from the Object Info palette.).

5. Move the control point to adjust the label and leader line position. If there are several stake objects, use the Align/
Distribute Leader Lines command to improve readability (see “Aligning and Distributing Leader Lines” on 
page 1035).

6. The stake properties can be edited in the Object Info palette.

 

Click to show/hide the parameters.

Mode Description

Standard Insertion Inserts a single stake object
Offset Insertion Inserts a stake at each vertex of the drawn polygon shape
Preferences Sets the default preferences for the stake object
Elevation Sets the default elevation value for stake objects

Standard Insertion

Offset Insertion

Elevation

Preferences

Label and leader
line control point
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Parameter Description

Z-value Specifies the stake elevation.
To create road stakes with the Vectorworks Landmark product, set the elevation of 
the first stake along the polyline; the elevation of the remaining stakes is 
automatically calculated (as described in “Setting Stake Elevations” on page 730).

Rotation Rotates the stake object indicator and the label (if applicable) around the stake object 
indicator’s center

Mode
Include as site model 
data

Uses the stake as site model data if it is located in the source data layer (select when 
using stakes to create a site model)

Set elev to site model Sets the stake elevation to the existing site model elevation
Use as 2D graphic only Treats the stake like a text box and does not include 3D information such as elevation
Site modifier object Treats the stake object as a site modifier, which has an effect on the site model 

Site Model When the stake object is used as a site modifier, specifies whether it affects the 
existing or proposed site model

Style Selects the graphic style of the stake object indicator

Mark Offset X Offsets the stake object indicator from the insertion point along the X axis
Mark Offset Y Offsets the stake object indicator from the insertion point along the Y axis
Mark Rotation Rotates the stake object indicator around its center
Label Reference Selects the type of information to display in the label; select No Label to display no 

text. The available label fields depend on the label reference selected.

Label Position Specifies the alignment of the label, and which side to place the leader line (when 
displayed):
• Auto: Automatically determines whether to place the text on the left or right, 

depending on the position of the label related to the stake’s location
• Right: Places the text to the right of the label control point and left-justifies the text
• Left: Places the text to the left of the label control point and right-justifies the text
• Center: Centers the text on the label control point

Description For description type labels, enter description text
ID Prefix For ID type labels, enter a prefix to display before the ID number

 None Triangle Filled 
Triangle

Circle Dot Cross Tick 
Mark

Circle 
Cross

ID Elevation Description ID/
Description

Description/
Elevation

Stationing 
Data

Coordinate 
Point (NE)

Coordinate 
Point (EN)

Coordinate 
Point (XY)

No Label

ID/
Elevation
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ID Suffix For ID type labels, enter a suffix to display after the ID number
Auto ID Numbering Select to automatically increment the ID number parameter when inserting new stake 

objects
(Initial) ID Number For ID type labels, specify the ID number. When Auto ID Numbering is selected, 

the ID Number field changes to Initial ID Number, and ID numbers will be 
automatically incremented beginning with the initial number specified. When Auto 
ID Numbering is not selected, specify the default ID Number for stake objects.

Station Point Data For Stationing Data labels, indicates the station point data for the selected stake 
object

Coordinate Point Coordinate point type labels can show the stake’s distance from a point of origin 
(user origin), or they can show the stake’s geographic position (latitude and 
longitude) if the design layer is georeferenced (see “GIS and Georeferencing” on 
page 775).
• To display distance, specify Document Units, Feet, or Meters as the Coordinate 

Units. The Coordinate Point (NE - Northing-Easting) and Coordinate Point (EN - 
Easting-Northing) options display the distance prefixed with the direction (N, W, 
S, E). The Coordinate Point (XY) option displays the distance prefixed with the 
file coordinates (X, Y).

• To display longitude and latitude, specify Decimal Degrees or Degrees/Minutes/
Seconds as the Coordinate Units.

If the stake object or user origin moves, the coordinates automatically update to 
reflect the change.

Coordinate Units For coordinate point type labels, specifies the units to use for the coordinates.
• Select Document Units, Feet, or Meters to show the stake’s position relative to the 

user origin of this drawing.
• If the design layer is georeferenced, select Decimal Degrees or Degrees/Minutes/

Seconds to show the stake’s geographic position.
Coordinate Prec When coordinate point type labels are set for units of Feet, Meters, Decimal Degrees 

or Degrees/Minutes/Seconds, specifies the precision with which the measurements 
will be labeled

Show Elevation For coordinate point type labels, select to display the elevation below the other 
coordinates

Elevation Units Specifies the units to use for the elevation.
• Select Document Units, Feet, or Meters to show the stake’s position relative to the 

user origin of this drawing.
• If the design layer is georeferenced, select Decimal Degrees or Degrees/Minutes/

Seconds to show the stake’s geographic position.
Elevation Prec For coordinate point type labels where the elevation value was selected to display, 

and the specified elevation units are Feet, Meters, Decimal Degrees or Degrees/
Minutes/Seconds, specifies the precision with which the measurements will be 
labeled

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Converting 3D Loci to Stake Objects
Site Model Section
Calculating Grade
Creating the Site Model
Updating a Site Model
Aligning and Distributing Leader Lines

Converting 3D Loci to Stake Objects
3D loci can be converted to stake objects, which can then be used to modify a site model. This is useful when survey 
data, in the form of 3D loci, need to modify an existing or proposed site model.
To create stake objects from 3D loci:

1. Select the 3D loci.
2. Select Modify > Convert > Stake Object from 3D Locus.

The Convert to Stake Object dialog box opens. Set the properties for new stakes.
Click to show/hide the parameters.

Show Unit Mark Select to display the unit mark along with the unit value
If Document Units are set for Coordinate Units, the unit mark visibility is 
determined by the document setting.

Display Leader Line Adds a leader line from the label to the stake object (adjust the leader line position by 
moving the leader line control point)

Scale Factor Determines the size of the stake object indicator

Parameter Description

Mode Select the type of stake object(s) to create:
• Include as site model data: Uses the stake as site model data if it is located in the 

source data layer (select when using stakes to create a site model)
• Set elev to site model: Sets the stake elevation to the existing site model elevation
• Use as 2D graphics only: Treats the stake like a text box and does not include 3D 

information such as elevation
• Site modifier object: Treats the stake object as a site modifier, which has an effect on 

the selected site model 
Site Model Select the site model which the stakes affect
Style Selects the graphic style of the stake object

Parameter Description

 None Triangle Filled 
Triangle

Circle Dot Cross Tick MarkCircle 
Cross
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3. Click OK to create the stake objects. 
If the stake objects are site modifiers, update the site model to apply the changes (select the site model and click 
Update from the Object Info palette). 
See “Inserting Stake Objects” on page 769 for additional stake object parameters that can be edited from the 
Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Stake Objects
Updating a Site Model

Label Reference Selects the type of information to display in the label; select No Label to display no text. 
The available label fields depend on the label reference selected.

ID Prefix For ID type labels, enter a prefix to display with the ID
Auto ID Numbering Select to automatically increment the ID number parameter when inserting new stake 

objects
(Initial) ID Number For ID type labels, specify the ID number. When Auto ID Numbering is selected, the ID 

Number field changes to Initial ID Number, and ID numbers will be automatically 
incremented beginning with the initial number specified. When Auto ID Numbering is 
not selected, specify the default ID Number for stake objects

Description For description type labels, enter description text
Station Point Data For Stationing Data labels, indicates the station point data for the selected stake object
Coordinate Units Coordinate point type labels show the stake’s distance from a point of origin (user origin). 

This field specifies the units (document units, feet, or meters) to use for the coordinates.
Display Leader Line Adds a leader line from the label to the stake object (adjust the leader line position by 

moving the leader line control point)
Scale Factor Determines the size of the label display
Delete Source Loci Deletes the original loci that were converted

Parameter Description

ID Elevation Description ID/
Description

Description/
Elevation

Stationing 
Data

Coordinate 
Point (NE)

Coordinate 
Point (EN)

No Label

ID/
Elevation

Coordinate 
Point (XY)



GIS and Georeferencing
In the Vectorworks Architect and Landmark products, there are several features for importing and exporting GIS 
(geographic information system) data, and for georeferencing Vectorworks drawings.
For a small-scale architectural or landscape project, you might want to accurately import information related to the 
project site, such as property boundaries or municipal utility resources.
For a larger scale map project, you might import multiple shapefiles and image files and arrange them into maps, 
adding colors, symbols, and notes based on database information. You might then export files for use in other GIS 
software.
Both the Vectorworks Architect and Landmark products can store georeferencing information for design layers, as well 
as import and export georeferencing information related to shapefiles and image files. The Vectorworks Landmark 
product has additional features to make common GIS operations easier, including tools for adding graticule and great 
circle objects to a drawing.

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Entering Georeferencing Information for the Document
Entering Georeferencing Information for a Design Layer
Replacing Objects with Symbols
Moving an Object to a Specific Location
Creating a Graticule
Creating a Great Circle
Projection Options
Importing and Exporting Georeferenced Raster Images
Importing in Shapefile Format
Exporting in Shapefile Format

Entering Georeferencing Information for the Document
Georeferencing options are complex; what works for architectural workflows may not be suitable for GIS workflows. 
Different regions of the Earth have different geographical requirements.
Since the earth is not a perfect sphere, it is not a straightforward process to project a map onto the earth’s surface, or 
transfer an object onto the surface. Projections are mathematical formulas that translate the shape of the earth onto a 2D 
page. Because the translation loses data, different projections represent the longitudinal and latitudinal coordinates of 
the non-uniform sphere onto the page.
When georeferencing is enabled, each design layer stores information that describes the mapping of that layer’s 
Cartesian coordinate system onto a geographic coordinate system of latitude and longitude. The origin offset 
determines how the projection relates to the internal origin (the center of the drawing in the Vectorworks file); this 
offset can be turned off at the document level or at the layer level for GIS workflows.
If all or most design layers will have the same georeferencing information, use the Georeferencing command to set the 
parameters for the document. After the default document georeferencing is set, edit each design layer to enable 
georeferencing, and to customize the settings for individual layers, if needed.
Layers without georeferencing will be assumed to be in the Equirectangular projection, which maps latitude and 
longitude directly onto the X-Y axis. The origin will represent 0°, 0°, and the scale will be equal to that of the Earth’s 
scale of latitude and longitude at the Equator. Some georeferencing tools do not work properly on design layers that are 
not georeferenced.
To set georeferencing for a document:

1. Select File > Document Settings > Georeferencing. The Document Georeferencing dialog box opens.
Click to show/hide the parameters.

http://www.youtube.com/watch?v=1Dbxq2LcQ3c
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Parameter Description

Adjust origin and orientation 
of georeferenced data to match 
document coordinates

Offsets the location of the georeferenced data so that it matches the way that the 
projection relates to the drawing’s internal origin. Normally, enable the option for 
architectural documents which center and orient around geographical latitude/
longitude coordinates; deselect the option when working with raw GIS data (shape 
files), when no offset is needed, and the center of the data set is also considered to 
be the center of the projection.

Latitude/Longitude Specifies the latitude and longitude at the document origin (0,0); enter decimal 
degrees, or degrees/minutes/seconds (for example, 39.18, 39° 10’ 32”, or 39d 10m 
32s) preceded by a minus (-) sign when appropriate

Angle to True North Specifies which direction is north from the document origin; use an azimuth 
degree measurement (0° is along the Y axis, 90° is along the positive X axis)

Projection Select the appropriate projection type, based on the drawing’s scale and purpose; 
additional parameters that are required to map to the selected projection display in 
the area below this field. See “Projection Options” on page 783 for details about 
projections.
Alternatively, select the WKT (Well Known Text) option and specify any other 
projection or coordinate system that is supported by GDAL (Geospatial Data 
Abstraction Library) in the WKT markup language.

For the Vectorworks Architect product, only the Lat/Lon Document Units, 
Universal Transverse Mercator, and State Plane Coordinate System (NAD83) 
options are available.

Ellipsoid Select the appropriate reference ellipsoid used to create the projection (applies to 
all projections except State Plane Coordinate System NAD83 and NAD27)

UTM Grid Zone/
Hemisphere

For the Universal Transverse Mercator (UTM) projection, select the UTM grid 
zone and UTM hemisphere that apply to this drawing

State/Zone For a State Plane Coordinate System (NAD83 or NAD27) projection, select the 
state and zone that apply to this drawing

Center Latitude/Longitude Specify the latitude and longitude of the center of the selected projection (applies 
to Equirectangular, Azimuthal Equidistant, Transverse Mercator, Cassini-Soldner, 
Gnomonic, or Stereographic projections)

Scale For the Transverse Mercator projection, specify the scale factor along the central 
longitude; for the Stereographic projection, specify the scale factor at the central 
point

Standard Parallel 1/2 For the Lambert Conformal Conic projection, enter the two standard parallels to 
use for the projection
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2. Click OK to save the georeferencing settings.
3. Enable georeferencing for each design layer that requires it, as described in “Entering Georeferencing Information 

for a Design Layer” on page 777.

Entering Georeferencing Information for a Design Layer
Use the Edit Design Layers dialog box to enable georeferencing for the layers that will use it. Options set here can 
override the georeferencing options set for the document. Once you have a georeferenced design layer, you can import 
georeferenced files into it, as well as export images or shapefiles that include georeferencing information.

To accurately measure items on a georeferenced design layer, use the Great Circle tool (from the Site Planning 
tool set), instead of the dimension tools from the Dims/Notes tool set. See “Creating a Great Circle” on page 781.

To enable georeferencing for a design layer:
1. Select Tools > Organization to open the Organization dialog box. From the Design Layers tab, select the layer(s) 

to be changed, and click Edit.
2. From the Edit Design Layers dialog box, select Georeferenced. The current projection for the layer displays 

below that field; the default is the current projection setting for the document.

Transformation mode Select the appropriate option for transforming the layer objects when the layer’s 
projection type is changed:
• Do not transform this layer’s geometry: Layer objects will not be transformed 

when the layer’s projection is changed
• Transform all geometry individually: Best for projecting geographic data, 

such as municipal boundaries, roads, rivers, and locations on a map
• Move and rotate all geometry as a group: Best for projecting non-geographic 

drawing objects, such as architectural plans
Reset Discards any edits made and returns all fields to their former values

Parameter Description
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3. To edit the georeferencing information, click Edit Georeferencing.
The Georeferencing dialog box opens, from which you can choose either to use the same settings used for the 
document overall, or to enter custom settings. If you choose to use custom settings for this design layer, enter the 
remaining fields as described for the Document Georeferencing dialog box.
When your entries are complete, click OK to save the settings and return to the Edit Design Layers dialog box.

Click to show/hide the parameters.

4. Click OK to enable georeferencing for the design layer. The selected projection displays in the Organization 
dialog box.

~~~~~~~~~~~~~~~~~~~~~~~~~
Entering Georeferencing Information for the Document

Parameter Description

This layer is georeferenced
by the document Specifies that the georeferencing information for this design layer is the same as the 

settings for the document. Click Edit Document Georeferencing to view or change 
the current document settings on the Document Georeferencing dialog box.

by custom settings Specifies that the georeferencing information for this design layer is different from the 
settings for the document (or no document settings were entered). To copy the 
georeferencing information from an existing layer, click Copy from Layer to open 
the Copy Georeference from Layer dialog box; select a design layer and click OK.

Settings fields and 
Transformation mode

See “Entering Georeferencing Information for the Document” on page 775

Reset Discards any edits made and returns all fields to their former values

When Georeferenced is
selected, the current

design layer projection
displays
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Creating a Graticule
Creating a Great Circle
Projection Options

Replacing Objects with Symbols
The Replace with Symbol command converts a selected object into a specified symbol. The symbol can use the 
records provided with the original object, the records associated with the replacement symbol, or both. If an imported 
Shapefile contains data markers that indicate the location of certain types of objects, you can convert the markers into a 
symbol that better suits your drawing. 
To replace an object with a symbol:

1. Select the object(s) to be replaced.
2. Select Modify > Convert > Replace with Symbol.
3. The Choose a Symbol dialog box opens.
4. Select a symbol, and then select whether to use the original object records and the replacement symbol records.
5. Click OK, and then confirm that you want to replace all selected objects.

~~~~~~~~~~~~~~~~~~~~~~~~~
Entering Georeferencing Information for a Design Layer

Moving an Object to a Specific Location
You can move an object in a georeferenced file to a different geographic location.
To move an object geographically:

1. Select the object(s) to be moved.
2. Select Modify > Move > Move Geographic.

The Move Geographic dialog box opens.
Click to show/hide the parameters.

Parameter Description

Move to location Select to move the selected object(s) to the specified Latitude and Longitude
Latitude/Longitude Specifies the latitude and longitude to which the object will be moved; enter decimal 

degrees, or degrees/minutes/seconds (for example, 39.18, 39° 10’ 32”, or 39d 10m 32s) 
preceded by a minus (-) sign when appropriate
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3. Click OK to move the object(s).
~~~~~~~~~~~~~~~~~~~~~~~~~
Entering Georeferencing Information for a Design Layer

Creating a Graticule
Use the Graticule tool to place a reference grid object over the drawing. Unlike a grid that is based on X and Y 
coordinates, the graticule lines are based on longitude and latitude lines that are inferred from the layer projection.

To create a graticule:

1. From the Site Planning tool set, select the Graticule tool.
2. From the Tool bar, click the Preferences button.

The Graticule Properties dialog box opens.
Click to show/hide the parameters.

Move relative Select to move the selected object(s) from the current location using the specified 
Azimuth and Distance

Azimuth/Distance Specifies the direction in degrees (0° is the Y axis, 90° is the X axis), and the distance the 
object will be moved, in document units

Mode Description

Polyline creation 
options

Selects the method for drawing the polyline that will bound the graticule object; see 
“Creating Polylines” on page 298. 

Fillet Radius If the Arc Vertex mode is selected, specifies the fillet radius to use
Preferences Sets the default parameters to be used for the tool

Parameter Description

Latitude
Major Lines Interval Sets the distance (in degrees) between the major latitude lines
Minor Line Spacing Sets the number of minor lines to draw between the major latitude lines

Longitude
Major Lines Interval Sets the distance (in degrees) between the major longitude lines
Minor Line Spacing Sets the number of minor lines to draw between the major longitude lines

Label
Label Major Lines Places a label on each major latitude and longitude line
Label Minor Lines Places a label on each minor latitude and longitude line

Parameter Description

Preferences

Polyline creation options Fillet Radius
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3. Click OK to save the default graticule settings.
4. From the Tool bar, select the type of polyline to use as the boundary for the graticule.
5. Click on the drawing to create the polyline boundary in the approximate location of the latitude and longitude lines 

you specified. Make the polyline larger than the graticule will be, so the graticule will not be cut by the polyline. 
When you complete the polyline, a graticule object is created over the specified location.
The Vectorworks software automatically calculates the minimum and maximum values for the latitude and 
longitude using the geometry and location of the defined polyline. These values can be edited later in the Object 
Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Entering Georeferencing Information for a Design Layer

Creating a Great Circle
Use the Great Circle tool to place a great circle object over the drawing. Unlike a 2D dimension that shows the linear 
distance between X and Y coordinates in 2D, a great circle is an arc that shows the shortest distance between two points 
on the sphere-shaped Earth. Use the Great Circle tool (instead of a 2D dimension tool) to measure distances in a 
georeferenced drawing.

Label Style Specifies whether the degrees on the labels are in decimal or degrees/minutes format
Attributes Specifies the pen color and line style for the major and minor lines

Parameter Description

PreferencesConstrained Line

Unconstrained Line
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To create a great circle:

1. From the Site Planning tool set, select the Great Circle tool.
2. From the Tool bar, click the Preferences button.

The Great Circle Properties dialog box opens.
Click to show/hide the parameters.

3. Click OK to save the default great circle settings.
4. From the Tool bar, select whether to use the Constrained Line or Unconstrained Line mode when drawing the 

great circle.
5. Click on the drawing at the beginning point of the great circle, and click again at the ending point to create the 

object.

~~~~~~~~~~~~~~~~~~~~~~~~~
Entering Georeferencing Information for a Design Layer

Mode Description

Constrained Line Constrains the line to be vertical, horizontal, and 30° or 45° from vertical or horizontal in 
any direction

Unconstrained Line Draws the line at any angle
Press and hold the Shift key to snap the line to predetermined angles

Preferences Sets the default parameters to be used for the tool

Parameter Description

Show Distance Places a distance measurement on the drawing
Distance Unit Select the unit to use for the distance measurement

Show Angle Places an angle measurement on the drawing
Angle Format Select whether to use an azimuth or bearing format for the angle display

Reverse Reverses the direction of the angle measurement
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Projection Options
For the Vectorworks Landmark product, there are several options for the type of geographic projection to use for 
georeferenced design layers. The Vectorworks Architect product has fewer options, because projection is generally less 
important for drawings on an architectural scale. For larger maps drawn with the Vectorworks Landmark product, 
however, the proper projection can be very important.
On the Document Georeferencing and the Georeferencing dialog boxes, the projections at the top of the Projection list 
are variations based upon the basic types, which display at the bottom of the list. For example, the Plate Carrée option 
is based upon the Equirectangular projection. The following table describes the basic projection types.

Projection Type Description

Equirectangular Simplest projection, good for maps of the entire world. Latitude and longitude lines are straight 
and equally spaced.
The Lat/Lon Document Units projection is Equirectangular, centered around the equator and 
prime meridian, and scaled such that one document unit represents one degree of latitude and 
longitude.
The Plate Carrée projection is Equirectangular, centered around the equator and prime meridian, 
and scaled in real-world units.

Variations of basic 
projections

Basic projection 
options
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Azimuthal 
Equidistant

Good for areas centered around a given point, roughly equal in height and width. Straight lines 
drawn from the center point represent the accurate geographic distance.

Transverse 
Mercator

Excellent for mapping narrow (north-south) areas around a chosen longitude. Very great 
distortion farther east and west. Center longitude defines the chosen meridian; center latitude 
should be close to the area being mapped. Scale should be 1 or close to it (for example .9996).
The Universal Transverse Mercator projection is Transverse Mercator defined by 6° longitude 
zones.
In the US State Plane Coordinate System (SPCS) projections, most US state zones are either 
Transverse Mercator or Lambert Conformal Conic, depending on the shape of the state and its 
zones. There are two systems, based on two different North American Datums: NAD27 (now 
obsolete) and NAD83 (the current standard).

Cassini-Soldner Good for mapping narrow (north-south) areas around the central longitude. Distorts shapes 
farther east and west.

Projection Type Description
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Gnomonic Good for navigational maps and small areas around a chosen point. All straight lines represent 
great circles (shortest geographical distance).

Lambert 
Conformal 
Conic

Good for mapping wide (east-west) areas between chosen parallels. Distortion increases farther 
from the chosen parallels.
In the US State Plane Coordinate System (SPCS) projections, most US state zones are either 
Transverse Mercator or Lambert Conformal Conic, depending on the shape of the state and its 
zones. There are two systems, based on two different North American Datums: NAD27 (now 
obsolete) and NAD83 (the current standard).

Stereographic Good for mapping polar areas. Parameters define the center point, which is 90 latitude for the 
North Pole or -90 latitude for the South Pole. Other points can be used. Scale should be 1 or 
very close to it (for example .9996).

Projection Type Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Entering Georeferencing Information for a Design Layer
Entering Georeferencing Information for the Document



Plants
Creating Plant Definitions
The Plant tool in the Vectorworks Landmark product both defines and places plant objects. The plant database 
maintains an extensive set of plant data that can be used in plant definitions.
Placing plants is extremely flexible. Place plants pre-defined with species information and appearance settings, or add 
generic plants to the drawing and re-assign them to a specific plant species later in the design process. A selected plant 
can be placed individually or in multiples. Once placed, a plant group can be changed into individual plants, or 
individual plants can be grouped. In addition, defined and undefined plant masses can be created according to several 
methods.
A plant definition includes the specific 2D and 3D plant appearance, parameters, and botanical data. Plants are defined 
by editing a current definition or by creating a duplicate of a current definition. The plant definition is specified by 
entering parameters or by loading (and editing) botanical data from the plant database. 
When the Vectorworks Landmark product is installed, a generic plant objects library is included. In addition, 2D and 
3D plant symbols are provided as default content (default content is automatically imported into the current file at the 
point of use and displays in the Resource Browser; see “Resource Libraries” on page 219). The resources in the Plant 
Defaults.vwx file are available in the Plant Settings dialog box.

When plants are defined, the definition parameters apply by default; individual plant settings can be changed before the 
plant is inserted on the drawing, in the Plant Settings dialog box, or after placement, in the Object Info palette.

Click here for a video tip about this topic (Internet access required).

To create a plant definition:

1. Click the Plant tool from the Site Planning tool set.
2. The Plant Settings dialog box opens automatically if plants have not yet been placed in the drawing. Otherwise, 

click Preferences from the Tool bar.
The Plant Settings dialog box opens.

3. On the Definition pane, select a plant symbol that is close in appearance to the new plant.
Plants can be placed with just this basic information; see “Adding Plants to the Design” on page 793. The plant 
definition can be edited later if desired.

http://www.youtube.com/watch?v=2ZMnrda8OJ4
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4. Click Edit Definition from any pane in the Plant Settings dialog box to edit the current definition, or click 
Duplicate from the Definition pane to create a new plant definition based on the selected plant. Alternatively, to 
edit a plant definition, select a plant from the drawing, select Edit from the Resources menu or the plant context 
menu, and select Definition.
Whether creating a new plant from a duplicate, or editing a current plant definition, the Edit Plant Definition 
dialog box opens, displaying the selected plant symbol. Provide a name for the plant symbol, and then specify the 
plant parameters on each tab to define the plant. As the parameters are defined, the preview dynamically displays 
the plant appearance. 
Although the Edit Plant Definition dialog box and the Plant Settings dialog box appear similar, keep in mind that 
the plant definition parameters define the default plant settings. The default plant settings can be changed at 
placement, allowing for variations of the same plant definition.
To automatically add plant information from the plant database, click Get Plant Data (see “Using Plant List Data 
in Vectorworks Landmark” on page 815).
The plant definition’s geometry can be based on a symbol present in the file or from default plant content, from 
drawing objects in the file, or from another plant; see “Creating Plant Geometry” on page 791.

5. When the default plant parameters have been defined, click OK to return to the Plant Settings dialog box. From 
there, additional plants can be defined, and a plant can be selected for placement.
When using workgroup referencing, the plant definitions must exist in the same file as the site model they 
reference, so that their Z values can be set to the site model surface.
Plant resources can be exported from the Resource Browser or by selecting Export Plant from the plant context 
menu; see “Exporting Custom Resources” on page 234.

Each pane of the plant definition dialog box is described in the following sections.

Plant Definition: Preview
Every pane of the plant definition displays the Plant Symbol Name and previews, allows botanical data to be obtained 
from the plant database, and provides the option to obtain the 2D and 3D plant geometry from a symbol. The previews 
update as the plant definition changes.
Click to show/hide the parameters.

Plant Definition: Insertion Options Pane
Specify the default insertion options for the plant definition on the Insertion Options pane. 

Parameter Description

Plant Symbol Name Enter a name for the plant symbol; this name displays in the Resource Browser
Get Plant Data Opens the Get Plant Data dialog box; select a plant to add its data to the current plant 

definition (see “Using Plant List Data in Vectorworks Landmark” on page 815)
Preview Dynamically previews the plant appearance, showing how it will appear when added to 

the drawing with the Plant tool
Top/Plan Preview Displays the 2D component of the plant symbol 
3D OpenGL 
Preview

Displays the 3D component of the plant symbol, if one has been added to the symbol 
definition (image props, such as those provided by xFrog®, can be used as 3D plant 
geometry)

Copy from Symbol Obtains the plant geometry from a symbol in the file or from default content; see 
“Creating Plant Geometry from a Symbol” on page 791
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If plant data were obtained from the plant database, the plant database values are displayed. Values and settings entered 
on this tab become the default for the plant definition. These default values can be changed for individual plants.
Click to show/hide the parameters.

Plant Definition: Schedule Pane
Click the Schedule pane to specify default plant values for display and reporting.
If plant data were obtained from the plant database, the plant database values are displayed. Values and settings entered 
on this tab become the default for the plant definition. These default values can be changed for individual plants.
Click to show/hide the parameters.

Plant Definition: Render Pane
Click the Render pane to specify the 2D plant styles. These effects display in Top/Plan view only; plant shadows do not 
display in worksheet images. A document preference makes it easy to give plans a uniform appearance by applying a 
document-wide shadow style to all plants and massing models in a drawing (see “Plan Shadows Preferences” on 
page 63). Even when a document preference is set, plant definitions can be edited on the Render pane to customize the 
drawing’s appearance. The outline, massing, and shadow parameters can be toggled for all plants in a document by 
selecting View > Show > Show or Hide Plant Styles. 
Values and settings entered on this tab become the default for the plant definition. These default values can be changed 
for individual plants.
Click to show/hide the parameters.

Parameter Description

Spread Specifies the default plant spread diameter (the maximum width of the mature plant, as 
drawn) for both single and multiple plant placement

Height Sets the default height of the typical mature plant at insertion
Spacing Sets the default spacing between plants at insertion, for the Poly-Edge Spaced, 

Rectangular Array, and Triangular Array insertion modes

Parameter Description

Latin Name Specifies the plant genus and species
Common Name Specifies the plant common name or names
Plant/TagID Identifies the plant with a unique code; this code appears in the plant list and on ID tags, if 

selected (see “Plant ID Codes” on page 799 for the definition of common code categories)
Scheduled Size Indicates the plant caliper or container size; displays in the Plant List worksheet 
Quantity Type Select the quantity unit for the plant; quantity can be defined as unit count, dripline area, or 

border area
Price Code (SKU) Specifies the price code entry in Stock Keeping Units (SKU)
Price Indicate the plant cost per unit of quantity; the plant cost and quantity are reflected in the 

Extended Price calculation in the Plant List worksheet
Schedule comments Specifies default comments about the plant that display in the Plant List worksheet
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Parameter Description

Plant Massing
Mass Outline Select a plant outline style

The outline’s pen attributes can be changed for selected plant objects in the Attributes 
palette.

Mass Plants Hides the details of plants that overlap to easily create a plant mass. A continuous outline 
is created around overlapping plants, and internal details are hidden. The 2D appearance of 
the massed group is controlled by the back polygon in the plant symbol group, so massing 
could cause the plant to display without a fill color. (An alternative way of hiding plant 
details is to use the Plant-Components classes to control the visibility of elements within 
the plant symbol.)

Plants that contain bitmap images cannot be massed.

Plant Shadow in 
Plan View

Specifies special shadow effects that display in Top/Plan view only

No Shadow Select to omit shadows from the Top/Plan view
Use Document 
Preference Settings

Select to use the settings from the Plan Shadows pane on the Document Preferences dialog 
box; click Settings to review or edit these document-wide shadow settings (see “Plan 
Shadows Preferences” on page 63)

Custom Select to create a custom shadow setting for this plant object
Offset Enter a value for the shadow offset
Offset Units Select the shadow offset units.

Factor of Object Height calculates the offset based on the object’s height and the 
offset value.

Angle Set the shadow angle by entering a value between -180° to 180° or by using the slider.
0° is straight up.

Fill Style Select a fill style for the shadow
Color/Resource/
Class

Depending on the fill style selected, select a fill color, resource (hatch, image, gradient, 
tile), or class for the shadow

No Outline One Sketch 
Outline

Two Sketch 
Outlines

Three Sketch 
Outlines

Tight Outline

Details hidden for massingPlant details displayed
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Plant Definition: Plant Data Pane
Click the Plant Data pane to view the plant database information for the plant.
To add botanical data from a plant list to the plant definition, click Get Plant Data and select a plant (see “Using Plant 
List Data in Vectorworks Landmark” on page 815). 
To change the plant data for the current plant definition only (without changing the plant list data), click on the 
parameter and click Edit. Enter the new value in the Edit Field dialog box and click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Plant Geometry
Adding Plants to the Design
Editing Plants
The Plant Database
Plant Graphics

Creating Plant Geometry
The plant geometry in a plant definition can easily be created from another symbol, from drawing objects, or from 
another plant.

Creating Plant Geometry from a Symbol
To create plant geometry from another symbol:

1. Begin to create a plant definition as described in “Creating Plant Definitions” on page 787.
2. From the Edit Plant Definition dialog box, click Copy from Symbol.

The Copy From Symbol dialog box opens. Select the plant content file and then the symbol that has the geometry 
to copy and choose whether to copy the 2D, 3D, or both components of the symbol geometry.

Click to show/hide the parameters.

Opacity Set the shadow opacity by entering a value between 0 and 100% or by using the slider
Use Class Opacity Select to use the class’s opacity setting (see “Setting Class Properties” on page 179)

Parameter Description

Plant content file list From the list browser, select the plant content file that contains the symbol to 
copy; symbols in the selected plant content file are used to populate the Symbol 
list.
The Vectorworks Landmark software is installed with a basic selection of default 
plant symbols to get you started. Select Help > Download Content to download 
many more plant symbols in the free content libraries provided and/or add your 
own custom plant symbols (see “Resource Libraries” on page 219). Once added 
to the library, the appropriate plant content files automatically appear in the list 
browser.

The list browser displays content located in [Vectorworks or User]/
Libraries/Objects-Landscape & Site/Plant Imagery 2D+3D; check the 
filepath if the expected content does not display.

Parameter Description
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3. Click OK to copy the selected geometry from the symbol to the current plant definition.

Creating Plant Geometry from Drawing Objects
To create plant geometry from drawing objects:

1. Select the 2D, and optionally, 3D drawing objects to use in a new plant definition.
A plant symbol can be created from another symbol. The xFrog plant images can be used as a basis for the 2D 
geometry.

2. Select the Create New Plant command from the appropriate menu: 
• Designer workspace: AEC > Plants > Create New Plant
• Landmark workspace: Landmark > Create New Plant
Alternatively, right-click (Windows) or Ctrl-click (Mac) in the drawing, with the geometry or plant symbol 
selected, and select Create New Plant from the document context menu.
The Edit Plant Definition dialog box opens, with the plant symbol name as “Untitled Plant.”

3. Specify the plant definition parameters, similar to creating a new definition (see “Creating Plant Definitions” on 
page 787).

4. Click OK to create the new plant.
If no 3D geometry was originally included, the plant symbol contains a 3D locus by default. Once the plant has 
been created, edit the 3D component of the plant symbol to add the 3D geometry. See “Editing Symbol 
Definitions” on page 247 for information on editing symbol components. Image props, such as those provided by 
xFrog, can be used as 3D plant geometry. 

Creating Plant Geometry from an Existing Plant
To create plant geometry from an existing plant:

1. Select the existing plant with geometry to convert to a new plant symbol.
2. Select the Create New Plant command from the appropriate menu: 

• Designer workspace: AEC > Plants > Create New Plant
• Landmark workspace: Landmark > Create New Plant
Alternatively, select Create Plant from Object from the plant context menu, or select the plant to duplicate from 
the Resource Browser, and select Resources > Duplicate, and then Resources > Edit.
The Edit Plant Definition dialog box opens, with the plant name symbol as “Untitled Plant.”

Symbol list Select the symbol that has the geometry to copy. The list displays the symbols in 
the current document or selected plant content file; select a different plant 
content file from the list browser to display additional options. 

Explore (Windows) / Reveal in 
Finder (Mac)

Click to find the selected file in the Windows Explorer / Mac OS Finder

Use only the 2D component of 
the symbol

Copies only the 2D component of the selected symbol to the plant definition

Use only the 3D component of 
the symbol

Copies only the 3D component of the selected symbol to the plant definition

Use the 2D and the 3D 
components of the symbol

Copies both the 2D and 3D components of the selected symbol to the plant 
definition

Parameter Description
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3. The plant graphics and parameters are based on the original plant. Specify new plant definition parameters, similar 
to creating a new definition (see “Creating Plant Definitions” on page 787).

4. Click OK to create the new plant.

Adding Plants to the Design
Plant placement in the Vectorworks Landmark program is very flexible. Generally, plants are defined first, and then 
placed; plant parameters are set by the definition, but if necessary, certain parameters can be changed in the Plant 
Settings dialog box before placement, or in the Object Info palette after placement. This allows variations of the same 
plant definition, which is an essential part of a landscape designer’s workflow. Another way of placing plants is to 
place “generic” plants from the default content, and create plant definitions for them later.
In addition to the appearance and parameters defined for plants, the Plant tool can place plants in several 
configurations, from single plants to arrays of plants. When setting parameters after placement, an array of plants is 
considered to be a single “plant” in the Object Info palette. Plants can also created by drawing a polyline and then 
selecting the Create Objects from Shapes command (see “Creating Objects from Shapes” on page 277).

Mode Description

Single Plant Placement Places a single specified plant at each mouse click

Poly-Vertex Placement Places plants at each clicked polygon vertex

Poly-Edge Spaced Places plants along the drawn polygon at the Spacing distance specified in the 
definition or settings

Single Plant
Placement

Poly-Vertex Placement Rectangular 
Array

Poly-Edge 
Spaced

PreferencesTriangular 
Array

Pickup
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To place plants on the drawing:

1. Click the Plant tool from the Site Planning tool set and select the plant to place.
The Plant Settings dialog box opens automatically if there are no plants in the Resource Browser. Otherwise, click 
Preferences from the Tool bar to select the plant to place, and specify the plant settings if they are different from 
the definition. The plant settings are described in the following sections.
The plant to place can also be selected by its plant symbol name from the Plant ID list on the Tool bar. The plant 
resources in the active drawing display alphabetically at the top of the list; the remaining plants are from the 
default content resources. 
Double-click a plant from the Resource Browser to activate the Plant tool and place the selected plant.
The Plant tool uses these settings until they are changed again by selecting a different plant ID from the Tool bar, 
clicking Preferences from the Tool bar, or until Pickup mode is selected, which changes the default settings to 
those of a selected existing plant.

2. Select the plant placement mode from the Tool bar. 

Rectangular Array Fills the drawn polygon with plants in a rectangular array at the Spacing distance 
specified in the definition or settings

Triangular Array Fills the drawn polygon with plants in a triangular array at the Spacing distance 
specified in the definition or settings

Pickup Sets the default plant settings to match those of a selected existing plant
Preferences Opens the Plant Settings dialog box, for specifying the plant to place, its placement 

options, and its definition
Plant ID Selects a plant for placement by its ID (Plant Symbol Name)

Mode Description
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3. Depending on the placement method selected, either click in the drawing to place a single plant, or draw a 
polygon. As the Plant tool is clicked in the drawing, a preview of the plant spread is displayed to help with plant 
placement.
The Plant tool parameters are retained so that the successive placement of plants is easily accomplished.

Each pane of the plant settings is described in the following sections. As the parameters are defined, the preview 
dynamically displays the plant appearance. 
Do not be confused by the similar appearance of the Plant Settings dialog box and the Edit Plant Definition dialog box; 
keep in mind that the plant definition parameters define the default plant settings. The default plant settings can be 
changed at placement if needed, allowing for variations of the same plant definition. Default plant settings that do not 
require editing can be left as defined by the plant definition.

Plant Settings: Definition Pane
The Definition pane can be used to select the plant definition for placement by the Plant tool. From any pane, you can 
also edit the plant definition parameters or create a duplicate of the plant definition, as described in “Creating Plant 
Definitions” on page 787.
Click to show/hide the parameters.

Plant Settings: Insertions Options Pane
The Insertion Options pane displays the default plant insertion settings from the plant definition. To override the plant 
definition parameters, select the parameter check box and enter the custom value. In addition, if the plant should be 
included in plant report worksheets, select On Plant List.
Click to show/hide the parameters.

Parameter Description

Definition Select the plant definition to insert from the graphical plant symbol list. The list displays 
the symbols in the current document or selected plant content file; select a different plant 
content file from the list browser to display additional options.

Latin Name/Common 
Name

Displays the selected plant’s definition information

Duplicate Click to create a duplicate plant based on the selected plant’s definition; see “Creating 
Plant Definitions” on page 787

Plant Content File list From the list browser, select the plant content file that contains the plant definition to 
insert; plant definitions in the selected plant content file are used to populate the 
Definition list.
The Vectorworks Landmark software is installed with a basic selection of default plant 
definitions to get you started. Select Help > Download Content to download many more 
plant definitions in the free content libraries provided and/or add your own custom plant 
content (see “Resource Libraries” on page 219). Once added to the library, the 
appropriate plant content files automatically appear in the list browser.

The list browser displays content located in [Vectorworks or User]/Libraries/
Objects-Landscape & Site/Plant Tool-Symbol+Definition Library; check the 
filepath if the expected content does not display.
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Plant Settings: Annotation Pane
Select plant display parameters on the Annotation pane.
Click to show/hide the parameters.

Parameter Description

Custom Spread Specifies the plant spread diameter (the maximum width of the mature plant, as drawn) 
for both single and multiple plant placement

Custom Height Sets the height of the typical mature plant at insertion
Custom Spacing Sets the spacing between plants at insertion, for the for the Poly-Edge Spaced, 

Rectangular Array, and Triangular Array insertion modes
On Plant List Includes the plant in plant report worksheets

Parameter Description

Polygon 
Display

For multiple plant placements, changes the display of the boundary or center polygon defining the 
plant cluster shape. 

Tick Style Select a tick mark (plant center mark) style

Tick Size Specifies the tick mark size

None Centers - solid Centers - dashed

Boundary - solid Boundary - dashed Gapped - solid Gapped - dashed

Cross Dot
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Plant Settings: Render Pane
The Render pane displays the default render settings from the plant definition. The Use Plant Definition settings 
indicate that the plant definition render settings apply; see “Plant Definition: Render Pane” on page 789. To override 
the plant definition parameters, select the Custom outline and massing option, and/or select the No Shadow, Use 
Document Preference Settings, or Custom shadow setting. 

Plant Settings: Tag Pane
Set the display of the plant ID tags on the Tag pane. To create a custom plant tag, see “Creating a Custom Plant Tag” on 
page 798. After creation, the plant tag’s appearance can be modified via the Plant Settings Tag pane, Object Info 
palette, tag class settings, and the control point locations on the drawing (see “Plant Tag Appearance” on page 800). 
Click to show/hide the parameters.

Plant Rotation For multi-plant placements, orients the plants in the horizontal direction, rotates the plants along 
the line created by the drawn polygon, or rotates the plants randomly, creating a more natural 
appearance

Plant Scale Keeps the plants at a fixed size, or randomly varies the plant scale according to the specified 
percentage of variation

Parameter Description

Display Select On to display a plant tag to the right or left of the leader line; set the left or right position 
with the tag Shoulder Angle.

Class Select a class for the plant tags, to control the tag appearance (line and marker style) and 
visibility. The classes present in the drawing are listed; alternatively, create a new class by 
selecting New, or select the default class name. 

Approach 
Angle

Specifies the angle of the leader line, from 0 to 360°. Setting the same angle for several selected 
plants aligns their leader lines, for an attractive planting plan (see “Aligning and Distributing 
Leader Lines” on page 1035).

Parameter Description

Plants rotated along the line Plants randomly rotated along the line

Plants randomly rotated and scaled
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Plant Settings: Schedule Pane
The Schedule pane displays the default schedule settings from the plant definition; see “Plant Definition: Schedule 
Pane” on page 789. To override the plant definition parameters, select the parameter check box and enter the custom 
value. 
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Plants
Creating Plant Definitions
Creating Plant Geometry
The Plant Database
Plant Graphics
Converting Plant Clusters

Creating a Custom Plant Tag
In addition to providing several predefined plant tags, Vectorworks Landmark allows designers to create custom plant 
tags.

1. From the Tag pane of the Plant Settings dialog box, select Set Custom Tag from one of the Top / Center / 
Bottom fields. Settings for the plant tag currently displaying in this field are displayed in the Set Custom Tag 
dialog box.
The Set Custom Tag dialog box opens.

Shoulder Angle When a tag shoulder line is enabled, sets the angle of the shoulder line and, if selected, tag 
display, from 0 to 360°. To display the plant tag to the left, specify an angle greater than 90 or 
less than 270 degrees. To display the plant tag to the right, specify an angle less than 90 or 
greater than 270 degrees. Setting the same angle for several selected plants aligns their shoulder 
lines, for an attractive planting plan. 

Bubble Specifies the bubble style, if any, for displaying quantity or quantity and Plant ID with the plant 
tag

Top / Center / 
Bottom

The custom tags present in the drawing and the predefined plant record field combinations for 
tags are listed. Specify the information to display on each level of the plant tag, or select None to 
hide a level of the plant tag. For the center level, select Continuation Line to continue the 
shoulder as a dividing line between the top and bottom tag information. Alternatively, select Set 
Custom Tag to define a custom plant tag (see “Creating a Custom Plant Tag” on page 798).

Enable Tag 
Shoulder Line

Adds a shoulder line to the leader line; adjust the shoulder angle with the shoulder control point, 
or by entering a tag Shoulder Angle

Snap Tag to 
Plant Centers

Snaps the end of the leader line to the center of the plant; deselect to adjust the endpoint location 
manually

Display Tag 
Line Marker

Displays a marker at the end of the leader line; specify the marker to use by editing the plant tag 
class (see “Setting Class Properties” on page 179)

Parameter Description

Circle Circle (Quantity 
only)

Hexagon Hexagon 
(Quantity only)

Rectangle Round



Adding Plants to the Design |  799
If editing an existing tag through the Object Info palette, the selected tag’s data displays.
2. Select values from predefined plant record fields in the order they should be listed, and type the delimiter text to 

place between the fields. Select <New Line> to start the next tag item on a new line. Up to six different 
combinations of fields, delimiters, and new line separators can be used. Entering a custom tag in the Top field of 
the Plant Settings dialog box will insert the custom tag above the reference line, a custom tag in the Center field 
will replace the reference line, entering a custom tag in the Bottom field will appear below the reference line.
The Tag Appearance field displays a static text preview of the custom tag. To preview a tag in its entirety, 
click-drag the bottom right corner of the dialog box to resize it.

3. Click OK.
4. Repeat steps 1 through 3 for the other Top / Center / Bottom fields on the Plant Settings dialog box, as 

appropriate, to complete creation of the custom tag.
~~~~~~~~~~~~~~~~~~~~~~~~~
Plant Settings: Tag Pane
Plant Tag Appearance
Adding Plants to the Design

Plant ID Codes
The meaning of commonly used plant ID code categories is provided.

Plant ID Code Meaning

A-# Annual #
CTD Conifer Tree Display
CTG Conifer Tree Generic
ETD Evergreen Tree Display
ETG Evergreen Tree Generic
G-# Grasses #
OT-M Ornamental Tree Massed
OTD Ornamental Tree Display
OTF Ornamental Tree Flowering
OTG Ornamental Tree Generic
OTM Ornamental Tree Multi-Stem
OTP Ornamental Tree Patio
P-1 — P-9 Perennials
P1 — P4 Palms
SD-# Shrub Display #
SD# Shrub Deciduous #
SDM Shrub Display Massed
SG# Shrub Evergreen #
SG Shrub Generic
SN# Shrub Needle #
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Editing Plants

Plant Properties
Plant properties are displayed, and can be edited, in the Object Info palette. As plants are placed, they take on the 
properties of the associated plant definition and/or the properties in the Plant Settings dialog box. Changes made in the 
Object Info palette for the selected plants apply to those individual plants only; changes are not reflected in the plant 
definition.

For multi-plant placement options, edit the polygon defining the plant with the Reshape tool if necessary; the 
plant placement automatically adjusts to fit the new shape.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Plant Tag Appearance
Editing Plant Attributes
Replacing Plants
Modifying Plant Clusters

Plant Tag Appearance
Plant tag appearance and placement is flexible, and can be adjusted in several ways, including through the plant 
settings, Object Info palette, tag class settings, and the control point locations on the drawing. 

STG Shade Tree Generic
STL Shade Tree Large
STM Shade Tree Massed
STP Shade Tree Patio
STS Shade Tree Street

Parameter Description

Plant Settings Opens the Plant Settings dialog box, for viewing and editing plant parameters
Definition Displays the plant definition parameters and allows the spacing to be edited as described in 

“Plant Settings: Insertions Options Pane” on page 795
Replace Plant Opens the Replace Plant dialog box; select the plant to replace the currently selected plant or all 

plant instances. (Alternatively, select Replace Plant from the plant context menu.)
Annotation/
Render

Edits the plant annotation parameters as described in “Plant Settings: Annotation Pane” on 
page 796 and the render parameters as described in “Plant Definition: Render Pane” on 
page 789

Tag Edits the plant tag parameters as described in “Plant Settings: Tag Pane” on page 797
Vertex 
parameters

Edits the plant vertices for multi-plant placements; see “Editing Vertex-Based Objects” on 
page 1002

Plant ID Code Meaning
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• Individual plant tags can then be changed for selected plants by adjusting the plant tag parameters in the Object 
Info palette. For example, selected plants in one area of a planting plan look more uniform when they all use the 
same tag approach and tag shoulder angle. 

• The plant tag class controls the appearance of the leader/shoulder lines, as well as the marker style.
• To move the plant tags of several selected plants at once, click the Unrestricted Interactive Scaling mode of the 

Selection tool.
• To align plant tags for improved readability, use the Align/Distribute Leader Lines command (see “Aligning and 

Distributing Leader Lines” on page 1035).
• If an individual tag needs to be repositioned, plant tags also have several control points for adjusting the tag text 

and leader line and shoulder position and angle.

~~~~~~~~~~~~~~~~~~~~~~~~~
Plant Settings: Tag Pane

Editing Plant Attributes
Plants are hybrid symbols, containing a 2D symbol, and optionally, a 3D symbol. As plant definitions are created, the 
plant symbol is automatically imported into the current file and appears in the Resource Browser. Plants are “red” 
plug-in object symbols (see “Symbol Types” on page 237 for information on symbol types). The 2D and 3D plant 
graphics are scaled by the plant definition height and spread parameters.
Because plants are red symbols, plant attributes cannot be directly set or modified from the Attributes palette. Instead, 
edit the plant symbol components.
To edit plant symbol attributes:

1. Select the plant symbol in the Resource Browser. Select Resources > Edit, or select Edit from the Resource 
Browser context menu.
Alternatively, select a plant in the drawing window, and double-click or select Edit from the context menu.
The Edit Plant dialog box opens.

Click to show/hide the parameters.

Parameter Description

2D/3D Graphics Edits the 2D or 3D symbol components (geometry, or shape, and attributes like color and line 
weight) as described in “Editing Symbol Definitions” on page 247

Definition Edits the definition of the plant symbol as described in “Creating Plant Definitions” on 
page 787)

Adjusts endpoint location and tag approach 
angle when tag is not snapped to plant center

Adjusts shoulder location, 
leader line length, and tag 
approach angle

Adjusts shoulder length, tag shoulder
angle, and tag location

Appearance specified by tag bubble 
parameter

Appearance specified by plant 
definition tag top/center/bottom 
parameters
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2. Edits to the 2D or 3D components immediately affect all instances of the symbol. Changes to the plant definition 
affect all future instances of the plant.

Replacing Plants
When replacing plants, select whether to replace the current plant only, or all instances of the selected plant.
To replace plants:

1. Select the plant(s) to replace, or select a plant that is a representative of the plant instances to replace.
2. From the Object Info palette, click Replace Plant.

Alternatively, Right-click (Windows) or Ctrl-click (Mac) on the plant and select Replace Plant from the context 
menu.
The Replace Plant dialog box opens.

Click to show/hide the parameters.

3. Click OK to replace the plant(s) or all the plant instances with the new plant.
~~~~~~~~~~~~~~~~~~~~~~~~~
Adding Plants to the Design
Creating Plant Definitions

Modifying Plant Clusters
Plants placed in a multiple placement mode of the Plant tool are associated as a cluster. The cluster moves together, 
and parameter changes affect all plants in the cluster. However, it is possible to dissociate the cluster to make individual 
plant changes. In addition, new clusters can be created with different combinations of plants. Clustering identical plants 
which are in close proximity can be desirable for labeling and identification purposes.

Converting Plant Clusters
One or more plant clusters can be disassociated to change individual plant parameters or location.
To convert a plant cluster to individual plants:

1. Select the plant cluster or clusters to convert.
2. Select the Change Plant Grouping command from the appropriate menu: 

• Designer workspace: AEC > Plants > Change Plant Grouping
• Landmark workspace: Landmark > Change Plant Grouping

Path For multiple plant placements, selects the boundary or center polygon defining the plant 
cluster shape, and automatically activates the Reshape tool for editing the path

Parameter Description

Graphical plant list Select the replacement plant from the list of plant symbols in the file and in default content
Selected Plants 
Only

Replaces the selected plant(s) with the new plant

All Instances Replaces all instances of the plant with the new plant. This does not affect the plant 
definition of the replaced plant, but simply replaces all plants of one type with another.

Parameter Description
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Alternatively, right-click (Windows) or Ctrl-click (Mac) on the plant cluster and select Change Plant Grouping 
from the context menu.

3. If one plant cluster is selected, the plants in the cluster are automatically converted to individual plants.
4. If more than one plant cluster is selected, the Choose Mode dialog box opens.
5. Select Convert Selection into Individual Plants.
6. Click OK. The plants are converted, retaining their original plant type; they can be moved and changed 

individually.

Combining Plants
Individual plants and plant clusters can be combined into a single plant cluster. The converted cluster will be a 
multi-plant placement at polygon corners.
To convert plants to a plant cluster:

1. Select the individual plants, plant clusters, or combination of individual plants and clusters to convert.
2. Select the Change Plant Grouping command from the appropriate menu: 

• Designer workspace: AEC > Plants > Change Plant Grouping
• Landmark workspace: Landmark > Change Plant Grouping
Alternatively, right-click (Windows) or Ctrl-click (Mac) on the plant and select Change Plant Grouping from the 
context menu.

3. If the selection consists of individual plants of the same type, they are automatically converted to a single plant 
cluster.

4. If individual and clustered plants are selected, the Choose Mode dialog box opens.
5. Select Combine Plants into One Single Plant.
6. Individual and clustered plants of the same type are automatically converted to a single plant cluster.

If the selection consists of more than one plant type, the Please Choose Plant dialog box opens.
7. All the plants in the selection will be converted to one of the plant types. Select the plant type from the list and its 

Plant Spread value is displayed. Click OK.
8. The selected plants are converted to a single cluster of identical plant types.
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Plants are clustered based on their drawing order. If the joining polygon of the resulting plant is not as expected, 
change the drawing order of the plants prior to joining them.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Replacing Plants
Creating Plant Definitions

The Plant Database
The plant database provided with the Vectorworks Landmark product manages an extensive list of plant names and 
botanical information which can be used to associate specific plant data with plant definitions.
The plant database is a stand-alone FileMaker® application that opens in a separate window. The benefits of using the 
FileMaker database for plant data management include improved navigation, editing, searching, and filtering, as well 
as the ability to import data from industry-standard sources. At installation, a large set of plant records is provided.
FileMaker is a comprehensive data-management program. The details of every menu command and option are beyond 
the scope of this manual. However, all relevant information for using FileMaker in conjunction with the Vectorworks 
Landmark product is presented. Familiarity with FileMaker is not required to use the database or to manage botanical 
data, and to use that data in the Vectorworks program. The full version of FileMaker can also be used when working 
with the plant database. For in-depth information about FileMaker, including product documentation, visit 
www.filemaker.com and navigate to the Support area. (The plant database may not contain all the functionality 
documented for the full version of FileMaker.)
The general workflow consists of managing the botanical information in the plant database application, and from there, 
creating the plant lists to be used in the Vectorworks Landmark product.
~~~~~~~~~~~~~~~~~~~~~~~~~
Accessing the Plant Database
Importing Plant Database Information
Viewing Plant Database Records
Searching for Plants
Managing Plant Database Records
Accessing Plant Information from the Internet
Creating Plant Lists for Vectorworks Landmark
Using Plant List Data in Vectorworks Landmark
Plant Database Field Mapping

Accessing the Plant Database
Accessing the plant database for the first time requires initial setup.

http://www.filemaker.com
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To access the plant database for the first time:
1. Select the VW Plants Database command from the appropriate menu: 

• Designer workspace: AEC > Plants > VW Plants Database
• Landmark workspace: Landmark > VW Plants Database
Alternatively, right-click (Windows) or Ctrl-click (Mac) in the drawing and select VW Plants Database from the 
context menu.
The Choose Plant Database Location dialog box opens.

2. Indicate where the plant database information is to be located. By default, the plant database is stored locally, in 
the user folder of the computer where the Vectorworks software is installed. Larger offices that wish to share the 
plant database among several computers can store and access the plant database from a workgroup folder located 
on a central computer or server. Alternatively, select Browse for database folder and then click Browse to 
specify the desired location.
If this is the first time the plant database is being accessed and it does not yet exist in the specified location, the 
database is automatically created in that location. Whenever the plant database is opened in the future, it will use 
the data from that location. The location can be changed at any point by selecting the Choose VW Plants 
command from the appropriate menu: 
• Designer workspace: AEC > Plants > Choose VW Plants
• Landmark workspace: Landmark > Choose VW Plants 
It is possible to maintain several plant databases and switch among them with this command. 

3. Click OK. The creation of a new plant database location may take a few moments. 
The VW Plants dialog box may open. Specify a user name for the FileMaker application.

4. Click OK.
The Vectorworks Landmark plant database opens, in a separate window.
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Once the plant database has been set up, it is accessed immediately when selecting Landmark > VW Plants 
Database. The plant database can also be accessed when creating a plant definition, by clicking Open VW Plants 
from the Get Plant Data dialog box.

~~~~~~~~~~~~~~~~~~~~~~~~~
The Plant Database

Importing Plant Database Information
A default set of plant database records is provided at installation. The plant database supports several data formats for 
import, including tab-delimited files, Excel® spreadsheets, .xml files, and many others. The import folder feature 
allows movies and images to be imported. In addition, plant lists from previous versions of the Vectorworks program 
can be imported.
To import plant database information:

1. Open the plant database as described in “Accessing the Plant Database” on page 804.
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2. Select the File > Import Records database command. Files, folders, or .xml files can be imported. Select this 
command to import plant lists from Vectorworks program versions prior to 12.
To import plant data from Vectorworks versions 2008 through 2012, first select the File > Convert VW Plants 
database command to convert the plant data to the most recent FileMaker format. Then, import the data with 
Import Records.
To import plant lists from Vectorworks 12.x, select the File > Import Vectorworks 12 Plant List database 
command.

3. After specifying the location of the file(s) to import, field mapping is required to import the data correctly into the 
current database. (For Vectorworks 12.x plant lists, field mapping is automatically performed.)
The important mapping fields for proper use in the Vectorworks Landmark product are described in “Plant 
Database Field Mapping” on page 817. If more information is required, consult the Support area of 
www.filemaker.com.
Click here for a video tip about this topic (Internet access required).

Adding Additional Plant Data
Additional plant datasets may be located in the Plant Database\VW Plants\Additional Datasets folder. These files 
typically contain regional plant sets provided by a distributor or other plant sets installed with the Vectorworks 
Landmark software. The field matching has already been performed for these data sets, and they are easy to add to the 
plant database.
To add plant data from the Additional Datasets folder:

1. Open the plant database as described in “Accessing the Plant Database” on page 804.
2. Select the File > Add Additional Plant Data database command.

Select the file to import. Field mapping is automatic, and the plant information is added to the plant database.
~~~~~~~~~~~~~~~~~~~~~~~~~
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Viewing Plant Database Records
Each plant entry and its associated botanical information is considered a “record” in FileMaker. Several view modes 
display the records in ways designed to facilitate performing related tasks. When the plant database first opens, the 
records operate in Browse mode, with Forms displayed.
To familiarize yourself with the different display modes, and view the plant records in a variety of ways:

1. Open the plant database as described in “Accessing the Plant Database” on page 804.
2. Select the View > Status Toolbar database command to enable viewing controls and status at the top of the record 

form. Many of these items can also be found on the View and Records menu.

3. From the Status toolbar and the View menu, select the view mode and layout options depending on the task to 
accomplish.

Select data, list, or
web layout

View the previous or the next
record (Browse or Preview

modes)

Scroll through 
the records

Displays the current record number; 
enter a record number to display

Select form, list, or 
table view

Print preview

Displays the records found/total number of plant records 
and their sort status, and toggles the found display

Quick FindFind menu

http://www.filemaker.com
http://www.youtube.com/watch?v=25IiALtIYC8 
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Searching for Plants
The plant database can be searched from Quick Find in the Status toolbar or by switching the view to Find mode. 
Quickly search by entering text or repeating a recent search, or conduct flexible, sophisticated searches by combining 
search criteria. Search criteria can be saved and managed, making it easy to re-create plant lists.

Quick Find Search
Quick find searches the plant records for text.

Mode or View 
Option

Description

View Mode
Browse Displays plant record information and allows editing
Find Displays a blank form for specifying search criteria
Preview Displays plant record information as it will be printed

View as Form Displays each record as an individual form or “page”
View as List Displays records consecutively in a scrollable list
View as Table Displays each record as an item in a table, for sorting and reordering
Layout

Data View Displays plant record information
List View Displays limited plant data for each plant, for sorting and reordering
Web View Displays a special browser (using the default system browser) for locating plant images and 

information
Records Found 
toggle and status

After a search, the green toggle button displays an approximate pie chart and the number of 
records found; click the green pie chart button to toggle the display to records that are not in 
the found set. The sort status is also indicated.

Show All Clears the results from a search, displaying all records
New Record Adds a plant record to the database
Delete Record Deletes the currently selected record from the database
Find Switches to Find mode layout, for searching
Find menu Allows searches to be saved, modified, recalled, and cleared
Sort Opens the Sort Records dialog box, for determining the sort order for the plant records, or for 

unsorting the records
Quick Find Searches for the text entered or recent searches, without switching to Find mode
Preview Displays the records in a Print Preview mode
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To perform a quick find search:
1. Type one or more search terms into the Quick Find field in the Status toolbar.
2. Press Enter.
3. The records that contain the search terms are displayed.

To quickly repeat a previous search, click on the Quick Find menu and select the search term used previously.

Find Mode
Find mode performs a more advanced search based on specific criteria. Searches can be saved and managed.

To search for plants in Find mode and manage found sets:
1. Open the plant database as described in “Accessing the Plant Database” on page 804.
2. Select the View > Find Mode database command or click Find from the Status toolbar. Alternatively, select Find 

> Create New Find.
A blank form opens and the display switches to Find mode. Find mode functions are available from the Status 
toolbar.

Quick Find menu

Quick Find field

Find menu
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3. Enter the criteria for searching.
Examples include searching for the Latin name “Liatris,” Light Range “Sun,” with a Height > 3-5 ft. 
Click the Omit button in the Status toolbar (or select the Omit options from the Records menu) to exclude, rather 
than search for, the criteria. Use the Operators list for even more specific searches.

4. Click Perform Find from the Status toolbar, or press Enter.
5. The view mode automatically switches to Browse, and the records that meet the search criteria are displayed.
6. To save the current set of search criteria, select Find > Save Current Find.

Other search criteria set maintenance can be performed from the Find menu, to modify, edit, clear, and select 
saved searches. A previously saved search is executed by selecting its name from the Find menu.
To return to viewing all the plant records, select the Records > Show All Records database command or click 
Show All from the Status toolbar.

~~~~~~~~~~~~~~~~~~~~~~~~~
The Plant Database
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Managing Plant Database Records

Editing Plant Records
Plant database records can be edited in Browse mode, whether in form, list, or table view (see “Viewing Plant Database 
Records” on page 807).
To edit plant records:

1. Open the plant database as described in “Accessing the Plant Database” on page 804.
2. Select the View > Browse Mode database command.
3. Select the plant record to edit by scrolling or searching.
4. Changes made to the fields and check boxes are automatically saved.

Useful edits include:
• Marking a plant as a Favorite (to search for favorite plants later)
• Indicating the Project Information (to track plants by project)
• Adding custom information to drop-down lists
• Placing an image, video, audio, pasted text, or link to an embedded object into one of three containers; 

right-click on an image container to access the options
• Adding image credits and data source information to avoid copyright issues
• Adding extra plant or project information that is useful in the Vectorworks program
Switch between metric and imperial units for the Height and Spread fields with the Edit > Options > Use 
Imperial Value Lists or Use Metric Value Lists database commands.

Project ID numbers and favorites can be easily be added to all plants found by a search, with the Records > Add 
Project ID and Records > Mark As Favorite database commands. These fields export to the Vectorworks program 
and are useful for tracking and finding plants. If the Project ID is no longer needed at the completion of a project, 
search for all plants with that ID and then select the Records > Delete Project ID database command to remove it.

Image container
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Adding Plant Records
To add a plant to the plant database list:

1. Open the plant database as described in “Accessing the Plant Database” on page 804.
2. Select the View > Browse Mode database command.
3. Select the Records > New Record database command or click New Record from the Status toolbar.

New records are appended to the end of the record set.
4. Enter the plant information. Information is saved automatically.

Deleting Plant Records
To remove a plant from the plant database list:

1. Open the plant database as described in “Accessing the Plant Database” on page 804.
2. Locate the record or records to delete, by searching or scrolling.
3. Select the Records > Delete Record database command or click Delete Record from the Status toolbar to delete 

an individual record, or Records > Delete Found Records to delete a found set of records.
Confirm the deletion; this action cannot be undone.

~~~~~~~~~~~~~~~~~~~~~~~~~
The Plant Database

Accessing Plant Information from the Internet
If access to the Internet is available, plant images and information are easily obtained from within the plant database 
window. Images can be copied directly into the database (image credits can also be specified). 
To access plant information from the Internet:

1. Open the plant database as described in “Accessing the Plant Database” on page 804.
2. Locate the plant record that requires images or information.
3. Select the View > Swap Data View/Web View database command to toggle to web view, or select the Web Data 

layout from the Status toolbar.
In web view, a search is automatically conducted for the current plant based on its Latin name, and information 
about it, as well as images, are displayed from different sources.
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4. Click on the web view tabs to find plant information from the various sources. The available sources may depend 
on regional settings provided by a distributor.

5. Click the buttons to navigate through the web pages of each tab or to reset the view to the initial search (based on 
the Latin name).

6. To easily copy an image from the Internet to the plant database, select Copy (Windows) or Copy Image (Mac) 
from the image context menu. Then select Paste from the image container context menu. Image credits can be 
added in the Image Credits area under the images, to avoid copyright issues.
Image files can also be saved and inserted into the database later, as described in “Editing Plant Records” on 
page 811.

Back Reset

Forward
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7. Select the View > Swap Data View/Web View database command, or change the layout from the Status toolbar, 
to return to the database view.

~~~~~~~~~~~~~~~~~~~~~~~~~
The Plant Database

Creating Plant Lists for Vectorworks Landmark
Plant lists are the connection between the FileMaker plant database and the Vectorworks Landmark product. Creating 
plant lists from the entire set, or from found sets, in the plant database allows that data to be attached to plants in the 
Vectorworks program. Create as many plant lists as necessary; the appropriate plant list is selected for the plant 
definition. The data attached to a plant becomes part of the plant definition, and can be added to planting plans and 
displayed by plant ID tags.
Plant lists are created from the plant database; plant lists can also be created automatically based on plant category.
To create a plant list from the plant database:

1. Open the plant database as described in “Accessing the Plant Database” on page 804.
2. Search for the plants to include in the plant list (see “Searching for Plants” on page 808). The plant list is created 

from a found set of records, or from all the plant records. Larger plant lists take longer to load into the 
Vectorworks program.

3. Select the File > Create Vectorworks Plant List database command.
The Create Plant List dialog box opens. Provide a name for the plant list.

4. Click OK.
The plant list file is a tab-delimited file saved in the location of the plant database.
Click here for a video tip about this topic (Internet access required).

http://www.youtube.com/watch?v=4f88rpQmhVI
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Plant Lists from Categories
To create plant lists based on plant category:

1. Open the plant database as described in “Accessing the Plant Database” on page 804.
2. Select the File > Create Category Plant Lists database command.

A plant list is created for each category. If there are no plants found for a category, no list is created for that 
category. Plants without a category assigned, or with a custom category, are not included. In addition, an “All” 
plant list contains all plants regardless of category.

3. The plant lists are tab-delimited files saved in the location of the plant database.

Plant Lists for Existing Tree Species
By default, all plants in the tree Category of the database are included in the Species Data dialog box for access by the 
Existing Tree tool. If desired, search the plant database for the trees you require, and then add only these trees to the 
existing tree species list.
To create a custom existing tree species list:

1. Open the plant database as described in “Accessing the Plant Database” on page 804.
2. Search for the trees to include in the existing tree species list (see “Searching for Plants” on page 808). 
3. Select the File > Create ‘Existing Tree’ List database command. This customizes the existing tree list to use only 

the plants found in the database search.
~~~~~~~~~~~~~~~~~~~~~~~~~
The Plant Database
Specifying Existing Tree Species Information

Using Plant List Data in Vectorworks Landmark
Plant list information is available to plant definitions from the Plant Data tab.
To use plant list data in a plant definition:

1. Create the plant definition as described in “Creating Plant Definitions” on page 787.
2. In the Edit Plant Definition dialog box, click Get Plant Data.

The Get Plant Data dialog box opens.
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Click to show/hide the parameters.

Parameter Description

Plant List Select the plant list that contains the required plant information; all plant lists created from 
the plant database and saved in the database location are listed. A progress bar indicates 
the status of the plant list import when it is used for the first time, and allows the import to 
be canceled.

Open VW Plants Opens the Vectorworks plant database, for locating plant information and creating plant 
lists

Explore Opens Explorer (Windows) or Finder (Mac) to the folder containing generated plant lists
Name List Display Toggles between plant list display by Latin name or common name
Name Find Finds a plant in the plant name list by matching typed characters
Name List Lists the plants included in the currently selected plant list. Select a plant to view its 

botanical information on the right, and to use that data in the plant definition.
Plant Data Displays the botanical information (from the plant database) for the plant selected in the 

name list
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3. Select the plant name and data to include in the plant definition, and click OK.
4. The Plant Data tab displays the data from the plant database.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Plant Lists for Vectorworks Landmark
Creating Plant Definitions

Plant Database Field Mapping
When plant data is imported into the plant database with the File > Import Records > File database command, field 
mapping is required (see “Importing Plant Database Information” on page 806). Certain fields must be used during 
mapping for the plant list to function properly when exported for use with the Vectorworks Landmark product. All 
significant Vectorworks fields have a VW prefix.

Target Field Name Notes or Example Values Target Field Name Notes or Example Values

VW Autumn Color VW Height
VW Bloom Time Also referred to as Season VW Landscape Use Border, Hedge, Shade 

Tree...
VW Category Shrubs, Herbs, Trees... VW Latin Name Also known as the plant 

botanical name
VW Climate Zone Arid, Semi Arid, Dry... VW Light Range Deep Shade, Shade, Sun, 

Full Sun
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Documenting Existing Trees
The Vectorworks Landmark product includes the Existing Tree tool, for documenting the existing trees on a site. 
Details about each tree can be provided, including information such as species, condition, life expectancy, significance, 
and action to be taken. The 2D and 3D appearance of the trees can be specified, indicating the root and tree protection 
zones, with detailed plant ID tags and graphics for retained and removed trees, and the ability to select a 3D trunk and 
canopy shape. A report including the relevant information can be automatically created. 

VW Code VW Other Tolerance
VW Comments 1 VW Other Use
VW Comments 2 VW Persistence Deciduous, 

Semi-Evergreen, 
Evergreen...

VW Comments 3 VW pH Range Acidic, Adaptable
VW Common Name VW Price
VW Favorites VW Region
VW Flower 
Characteristics

Double, Erect, Fragrant, 
Horizontal...

VW Region Notes

VW Flower Color VW Season Notes
VW Foliage 
Characteristics

Aromatic, Broad-leaf, 
Evergreen, Fronds, Small 
leaves...

VW Size Notes

VW Foliage Color VW Soil Range Bark, Sand, Sandy loam, 
Potting soil...

VW Fruit 
Characteristics

Acorns, Berry, Catkins, 
Cones

VW Spread

VW Fruit Color VW Tolerances Cold Frost, Drought, Heat...
VW Growth Habit Arching, Broad-domed, 

Columnar, Climber...
VW Used in Project

VW Hardy Zone 1 – 11 (from USDA zone 
mapping)

VW User notes

Target Field Name Notes or Example Values Target Field Name Notes or Example Values
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Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Existing Tree Workflow
Placing Existing Trees
Specifying Existing Tree Species Information
Setting 2D Existing Tree Appearance
Specifying an Irregular Canopy
Setting 3D Existing Tree Appearance
Existing Tree Autonumbering and ID Tags
Customizing Existing Trees
Creating Schedules Automatically

Existing Tree Workflow
When placing existing trees into the drawing, the following workflow is recommended:

• Initialize the plant database if it has not yet been opened, by selecting Landmark > Choose VW Plants. See 
“Specifying Existing Tree Species Information” on page 824 and “The Plant Database” on page 804. This action 
populates the list of existing trees so that species information can be selected.

• Click the Existing Tree tool from the Site Planning tool set, and then select Preferences from the Tool bar to open 
the Object Properties dialog box for the existing tree. Set the defaults for the placement of existing trees, including 
automatic numbering, ID tag, 2D and 3D appearance (including the selection of 2D component symbols), and 
species information.

• While setting the default properties for the Existing Tree tool, specify classing wherever possible to be able to 
control the visibility of classed elements (easily accomplished from the Navigation palette) as well as specify 
appearance by class for many of the elements. 

• Select Tools > Organization to open the Organization dialog box. On the Classes tab, navigate to the classes 
related to the existing tree, and specify their appearance. Classes should be set to Use at Creation. For canopy and 
trunk classes, set the texture (Renderworks required) or color to display in 3D views. Set the marker and line style 
of the tag class if a marker is to be displayed.

• When placing existing trees, keep in mind that the selected 2D component symbols will not display until an 
Action has been specified. This helps you determine at a glance which trees still require an action to be set.

http://www.youtube.com/watch?v=AEyBb8YIjGk
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• The parameters of groups of selected trees, or trees on a specific layer, or all trees can be set in a single operation 
by using the Apply Properties in the various existing tree dialog boxes.

• Indicate the location of important and less important areas of the site by specifying the significance of each tree or 
group of trees.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Placing Existing Trees

To place an existing tree:

1. Click the Existing Tree tool from the Site Planning tool set.
If this is the first time the object has been placed in this session, the Object Properties dialog box opens. Set the 
default existing tree properties before placing trees, or place the tree and then edit its parameters in the Object Info 
palette.

2. Click in the drawing to place the existing tree. Click again to set the rotation.

The appearance of the existing tree may not match its 2D settings until certain parameters have been specified in 
the Object Info palette. For example, until the Action is specified, the tree does not display with the symbol set for 
Retain or Remove; the significance must be set for the significance color to display.

The existing tree properties can be edited from the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Get Species Data Opens the Species Data dialog box, to obtain botanical information from the plant 
database; see “Specifying Existing Tree Species Information” on page 824

Botanical Name/ 
Common Name

Displays the tree’s botanical and common name, when obtained by clicking Get Species 
Data; alternatively, enter the botanical and common name if not using the plant database 
information

Tag and Number 
Options

Opens the Tag and Number Options dialog box, to set the plant ID tag and automatic 
numbering options; see “Existing Tree Autonumbering and ID Tags” on page 831

Tree No Displays the tree’s autonumber, when autonumbering is enabled; alternatively, if 
autonumbering is not selected, enter an ID number for the tree

Origin Specifies whether the tree is an endemic, native, or exotic species
Height Sets the height of the tree
Irregular Canopy Size Opens the Irregular Canopy Size dialog box, to specify the plan shape of an irregular 

canopy rather than use the regular canopy diameter method; see “Specifying an Irregular 
Canopy” on page 828. 

Click in the center of the trunk to 
obtain a control point, and drag it to 
change the trunk location
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North Angle 
(irregular canopy 
shape)

Rotates an irregular canopy to enable the North, East, South, and West dimensions of the 
canopy to be correctly aligned to the points of a compass

Canopy Max. Diam
(regular canopy shape)

Sets the tree’s maximum canopy diameter

Also Use Canopy Min. 
Diameter 
(regular canopy shape)

Enables the canopy minimum diameter option, which allows an additional smaller 
canopy size to be specified, for tree canopy shapes that are oval rather than circular

Canopy Min. Diam Specifies the minimum dimension of the canopy; the oval canopy shape is created within 
the specified maximum and minimum values. The 3D solid shape is also affected.

Canopy Rotate 
(regular canopy shape)

Sets the rotation angle of the tree canopy; this is useful when the canopy is an elliptical or 
uneven shape

First Branch Hgt Indicates the height of the lowest (first) branch; this determines the bottom position of the 
3D canopy

DBH Specifies the diameter of the tree trunk at breast height. Adult breast height is considered 
to be 51 – 55” (1.3 – 1.4 m) above the ground. The DBH value also determines the initial 
diameter of the critical and primary root zones.
A tree with multiple stems displays with the number of stems after the DBH value, which 
cannot be edited. Because a this kind of tree does not have a single central trunk, the 
DBH is calculated differently, by calculating the square root of the sum of each stem’s 
squared diameter value.

Multiple Stems Opens the Multiple Stem Calculator dialog box, for trees with more than one central 
trunk or stem. Select Use Multiple Stems, and then specify the diameter of each stem or 
trunk to include in the DBH calculation. The DBH is automatically calculated, but can be 
adjusted if necessary.

Root Display Sets whether to display the critical and/or primary root zones, the root ball zone only, or 
no root zones. Specify the appearance of the zones by clicking 2D Properties (see 
“Setting 2D Existing Tree Appearance” on page 825). The root zones move with the tree 
trunk location.

Critical Root Diam Specifies the diameter of the critical root zone; initially, this value is set to 2.5 times the 
DBH, but the value can be changed. A changed value is reset if the Root Display is 
turned off; set the value to 0 (zero) to re-apply the DBH factor.

Primary Root Diam Specifies the diameter of the primary root zone; initially, this value is set to 5 times the 
DBH, but the value can be changed. A changed value is reset if the Root Display is 
turned off; set the value to 0 (zero) to re-apply the DBH factor.

Parameter Description

Primary root zone

Critical root zone
Root ball
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Ball Diameter When the root ball is set to display, indicates the diameter of the root ball
Tree Protection Select how to display the area around the tree that protects the tree; see “Specifying the 

Tree Protection Zone” on page 828
TPZ Cnr Radius 
(irregular zones)

When the tree protection zone editing mode is enabled for irregular protection zones, 
specifies the corner radius of the protection zone; set to a smaller value to simulate sharp 
corners

TPZ Radius 
(circular zones)

For a circular or 12 x DBH tree protection zone, displays the radius of the zone

TPZ Area Displays the calculated area of the tree protection zone
Condition Indicates the condition of the tree: excellent, good, average, poor, or custom

Custom Condition When a custom condition is selected, enter the custom tree condition
SULE Indicates the Safe Useful Life Expectancy (SULE) rating for the tree. A custom life 

expectancy value can be entered.
Custom SULE When a custom SULE is selected, enter the custom life expectancy

Significance Specifies the significance of the existing tree. This selection causes the significance color 
set in the 2D Properties dialog box to display. A custom significance can be set.

Custom 
Significance

When a custom significance is selected, enter the custom tree significance. 
To preserve the ability to set and display the significance color automatically, select one 
of the provided significance values, and then select Custom. Keep the initial default 
significance word, and then enter any custom information. For example, to use the 
Hazardous category, but add custom comments, select Hazardous, and then Custom. The 
word “Hazardous” displays for Custom Significance. After the word Hazardous, add 
your custom comment, such as “Hazardous - remove immediately.” By retaining the 
word Hazardous at the start of the custom comment, the significance color selected for 
Hazardous still displays.

Action/Comment Indicates the action to be taken for the tree. The category selected (Retain, Transplant, or 
Remove) determines the symbol to display based on the selections made in the 2D 
Properties dialog box. A custom action can be set.
When transplanting a tree, set the original tree Action to Transplant - Original location. 
Copy the tree, disabling its automatic numbering properties and manually assigning it to 
the same Tree No. as the original tree. Move the copy to the new tree location and set the 
Action for the copy to Transplant - Proposed location.

Custom Action When a custom action is selected, enter the custom action to take for the tree. 
To preserve the ability to automatically set the displayed symbol, select one of the 
provided actions, and then select Custom. Keep the initial default action category, and 
then enter any custom information. For example, to use the Remove category, but add 
custom comments, select Remove, and then Custom. The word “Remove” displays for 
Custom Action. After the word Remove, add your custom comment, such as “Remove - 
storm damaged.” By retaining the word Remove at the start of the custom comment, the 
symbol selected for Remove still displays.

Additional arborist 
fields

These specialized fields only display when enabled in the Additional Fields dialog box; 
each tree can be rated according to whether it meets arborist criteria

Parameter Description
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Form This refers to the shape of the tree, from uniform (excellent) to lopsided (poor)
Structure Trees with excellent structural integrity, growing in native habitat, rate higher than less 

stable trees or trees not growing in typical habitat for the tree type
Vigor This describes the health of the tree and whether it is growing well, with no pests and 

with good structure and form
Diam. at Buttress The diameter at buttress is the diameter of the trunk measured immediately above the 

base of the tree where the trunk mostly becomes parallel, as shown by the red line in this 
example:

Show Structural 
Root Zone

The Structural Root Zone (SRZ) refers to the circular area around the base of a tree that is 
required for the structural stability of the tree. The appearance of the SRZ indicator is set 
by the Critical Root Zone parameters (Critical Line Color/Style in the 2D Properties).

Calc’d SRZ Radius Displays the structural root zone radius value in meters, which is calculated based on the 
diameter at buttress value (D) according to the following formula:

If the calculated value is less than the Minimum SRZ radius specified in the Additional 
Fields dialog box, the minimum value is displayed instead.

Reduced Level/Age/
Year Planted/Date 
Assessed/Location/
Notes

These parameters provide additional information about the tree and can be included in 
reports. Notes can be selected for display in the tree tag. The field names can be edited, 
and additional fields can be added, by clicking Additional Fields.

2D Properties Opens the 2D Properties dialog box, to set display options for the 2D symbol 
components, significance colors, and the root zone and tree protection zone attributes; see 
“Setting 2D Existing Tree Appearance” on page 825

3D Properties Opens the 3D Properties dialog box, to set the 3D canopy and trunk display options; see 
“Setting 3D Existing Tree Appearance” on page 829

Additional Fields Opens the Additional Fields dialog box, for customizing Object Info palette fields, 
adding custom fields, and including arborist parameters to worksheet reports

Parameter Description

SRZ radius (m) D 50×( )0.42 0.64×=
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Specifying Existing Tree Species Information
The species information for existing trees is obtained from the Vectorworks Landmark plant database; see “The Plant 
Database” on page 804. If the plant database has not yet been opened, its default location needs to be set.
To specify botanical data from the Vectorworks plant database:

1. If it has not yet been opened, initialize the plant database by selecting the Choose VW Plants command from the 
appropriate menu: 
• Designer workspace: AEC > Plants > Choose VW Plants

Custom Field 
Labels and 
Visibility

The first six default fields from the Object Info palette can be edited to use different field 
names, and four additional fields can be named.
Regardless of the names used for the fields, the worksheet formulas for displaying them 
remain fixed; mouse over each field to see its associated formula in the help text.
• Field 1: =(“Existing Tree”.“RL”)
• Field 2: =(“Existing Tree”.“Age”)
• Field 3: =(“Existing Tree”.“Year Planted”)
• Field 4: =(“Existing Tree”.“DateAssessed”)
• Field 5: =(“Existing Tree”.“Location”)
• Field 6: =(“Existing Tree”.“Comments”)
• Field 7 – Field 10: =(“Existing Tree”.“Fieldx”) where x is the field number

Display Select how many fields to display in the Object Info palette
Additional Arborist 
Fields

Displays specialized arborist parameters in the Object Info palette

Display Form, 
Structure, and Vigor

Displays these fields in the Object Info palette

Display Buttress, 
Structural Root 
Zone, etc.

Displays these fields in the Object Info palette

Minimum SRZ 
radius

Specifies the minimum required Structural Root Zone (SRZ) radius; if the calculated 
SRZ radius is less than this value, this value is used instead

Apply Properties The custom fields can be applied to a single tree, to all trees in the drawing, and as the 
tool default settings.
• This object only: Applies the properties to the currently selected existing tree
• All objects in file: Applies the properties to all existing trees in the drawing
• This object + file defaults: Applies the properties to the currently selected existing tree 

and sets the properties as the default properties for the Existing Tree tool. Existing 
trees placed by the tool after clicking OK will have these properties applied.

• All objects in file + file defaults: Applies the properties to all existing trees in the 
drawing and sets the properties as the default properties for the Existing Tree tool. 
Existing trees placed by the tool after clicking OK will have these properties applied.

Parameter Description
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• Landmark workspace: Landmark > Choose VW Plants. 
The Choose Plant Database Location dialog box opens. Select the plant database location as described in 
“Accessing the Plant Database” on page 804.
By default, all plants in the tree Category of the database are included in the Species Data dialog box for access 
by the Existing Tree tool. If desired, search the plant database for the trees you require, and then select the File > 
Create ‘Existing Tree’ List database command. This customizes the existing tree list to use only the plants found 
in the database search.

2. From the Object Info palette of a selected existing tree, click Get Species Data.
The Species Data dialog box opens, listing tree species information. Species can be easily added to the list.
If the list is blank, the plant database location was not initialized.

Click to show/hide the parameters.

3. Select the species from the list, and click OK. 
The Object Info palette displays the species information.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Setting 2D Existing Tree Appearance
The 2D appearance controls the symbol for the tree and trunk, and also sets the attributes of the significance status, 
primary and critical root zones, and tree protection zones. The settings apply to the selected tree or a variety of other 
selection options, and can be set as the default 2D attributes for the drawing. This is a powerful way to control the 2D 
appearance of all existing trees in the layer or drawing in one operation.

Parameter Description

Species list Lists the botanical and common name of the trees contained in the existing tree list; 
click either heading to sort. Black text indicates species that appear in the Existing 
Trees.txt file located in the Plant Database folder within the user folder. Blue text 
indicates species that you have added to the list.

Botanical Name/
Common Name

Displays the botanical and common name of the selected tree; to add a tree to the list, 
enter its botanical information and click Add Tree to Existing Tree List

Remove Tree from 
Existing Tree List

Removes the selected custom (blue text) tree species from the list. Black text indicates 
default species, which cannot be removed from the existing tree list.

Add Tree to Existing 
Tree List

Adds the current Botanical Name and Common Name to the existing tree list. Edit a 
default entry if needed, or add a new species to the list. Custom (added or edited) 
species display with blue text.
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Using classes for the significance colors, root zone, and tree protection zone is recommended. The visibility of 
these elements is easy to control with classes. See “Classes” on page 176.

Existing tree symbols are provided as default content (default content is automatically imported into the current file at 
the point of use and displays in the Resource Browser; see “Resource Libraries” on page 219). The resources in the ET 
Symbols.vwx file are available in the 2D Properties dialog box.
To set the existing tree 2D appearance:

1. From the Object Info palette of a selected existing tree, select 2D Properties. Alternatively, double-click on an 
existing tree.
The 2D Properties dialog box opens.

Click to show/hide the parameters.

Parameter Description

Use 2D Component 
Symbols

Uses 2D symbol components to display the tree. The tree symbol displayed in the 
drawing depends on the Action specified in the Object Info palette.

Tree Retain Select the symbol to display for a tree that is retained (the associated Object Info palette 
Action is Retain)

Tree Remove Select the symbol to display for a tree to be removed (the associated Object Info palette 
Action is Remove)

Tree Trunk Select the tree trunk symbol for either retained or removed trees
Transplanted Trees Select the symbol to display for the existing position of a tree to be transplanted (the 

associated Object Info palette Action is Transplant - Original location); select the symbol 
to display for the new position of the transplanted tree (the associated Object Info palette 
Action is Transplant - Proposed Location). Specify the tree trunk symbol for transplanted 
trees in both the original and new locations.

Use Significance 
Colors

Applies significance colors to the tree to indicate its relative importance on the site. The 
significance color used depends on the Significance selected in the Object Info palette.

Significance rating 
colors

For each significance rating, select the color to display. For more information on colors, 
see “Applying Colors” on page 1132.

Display Specifies where to place the significance color.

Use the significance color as a tree fill for complex plans with multiple trees, to 
easily distinguish significance categories for densely forested areas.

Class If desired, select a class to control the display of the significance indicators. The classes 
present in the drawing are listed, or select the default class, Exist Tree-Significance. Class 
attributes control all indicator attributes with the exception of the fill color (any fill colors 
selected here override the class settings).

Root Zone Attributes Applies line colors and styles to the primary and critical root zone indicators. Root zones 
must be selected for display in the Object Info palette.

Indicator beside tree ID Circle around trunk Tree fill color
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2. Click OK.
Certain 2D properties depend on selections made in the Object Info palette for each existing tree, and are not 
applied immediately. For example, the symbol specified in Tree Remove does not display unless Remove is 
selected as the Action for the tree. 
The symbols for retained and removed trees are scaled by the canopy height and diameter specified in the Object 
Info palette. The original and proposed symbols for a transplanted tree are scaled by the DBH parameter.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Applying Colors

Primary Line Color/
Style

Select the color and line style for the primary root zone line

Critical Line Color/
Style

Select the color and line style for the critical root zone line

Class If desired, select a class to control the display of the root zone indicators. The classes 
present in the drawing are listed, or select the default class, Exist Tree-Root Zones. The 
line attributes set here override the class settings.

Tree Protection 
Attributes

Applies a line color and style to the tree protection zone indicator. The tree protection 
zone must be selected for display in the Object Info palette.

TPZ Line Color/
Style

Select the color and line style for the tree protection zone line

Class If desired, select a class to control the display of the tree protection zone indicator. The 
classes present in the drawing are listed, or select the default class, Exist Tree-TPZ. Any 
line attributes set here override the class settings.

Apply Properties The various 2D properties can be applied to a single tree, all trees in the layer or drawing, 
and as the tool default settings

Apply list Select the method to apply the properties.
• To this object only: Applies the properties to the currently selected existing tree
• To all objects on all layers: Applies the parameter categories selected in Properties to 

Apply to all existing trees in the drawing
• To all objects on active layer only: Applies the parameter categories selected in 

Properties to Apply to all existing trees in the current layer
• To all selected objects on all layers: Applies the parameter categories selected in 

Properties to Apply to selected existing trees in the drawing
• To all selected objects on active layer only: Applies the parameter categories selected 

in Properties to Apply to selected existing trees in the current layer
Also apply as the 
document defaults

Sets the selected 2D properties as the default properties for the Existing Tree tool. 
Existing trees placed by the tool after clicking OK will have these properties applied.

Properties to Apply When applying properties to more than just the currently selected tree, select which 
properties to globally apply

Parameter Description
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Specifying the Tree Protection Zone
The tree protection zone is the area around the tree that should be fenced off, or preserved, to protect the tree. The tree 
protection zone moves with the tree trunk location. The zone can be irregular or circular; irregular zones can be 
reshaped. The TPZ Area displays the calculated area for the entire tree protection zone.
To specify the tree protection zone:

From the Object Info palette of a selected existing tree, select the type of tree protection zone.
Click to show/hide the parameters.

An irregular tree protection zone may need to extend beyond the initial boundary shape. To reshape the tree protection 
zone:

1. Select Edit Irregular Zone from the Tree Protection parameter.
The tree protection zone displays with editing handles.

2. Drag the handles to reshape the zone. Adjust the radius at the corners of the zone with the TPZ Cnr Radius value, 
which only displays during zone editing.

3. When reshaping is finished, select Display Irregular Zone from the Tree Protection parameter.
~~~~~~~~~~~~~~~~~~~~~~~~~
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Specifying an Irregular Canopy
Since trees are not always perfectly symmetrical, the Existing Tree tool allows an irregular canopy shape to be defined 
by setting the measurements, in four different directions, from the center of the trunk to the edge of the canopy. 

If the trunk had previously been repositioned by moving its control point, it is reset to the default position when an 
irregular canopy is selected. The trunk cannot be offset for irregular canopy shapes.

To specify an irregular canopy shape:
1. From the Object Info palette of a selected existing tree, select Irregular Canopy Size. 

Zone Description

None Does not display a tree protection zone
Display Irregular Zone Displays the tree protection zone as an irregular shape which can be reshaped as 

needed to represent the zone
Edit Irregular Zone Allows an irregular zone to be reshaped as described below
Display Circular Zone Displays the tree protection zone as a circle around the tree trunk; set the circle 

radius with TPZ Radius 
Display using 12x DBH Displays a circular tree protection zone that is calculated based on 12 times the 

diameter at breast height (DBH) parameter

Drag the resize handle to reshape 
the tree protection zone
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The Irregular Canopy Size dialog box opens. Specify the canopy size in four directions.
Click to show/hide the parameters.

2. Click OK. The 2D and 3D appearance of the tree displays with an irregular canopy shape, roughly based on the 
selected symbol definition.
The irregular shape can be oriented differently by entering a North Angle offset in the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Documenting Existing Trees

Setting 3D Existing Tree Appearance
The 3D appearance controls the symbol for the tree and trunk in 3D views. The settings apply to the selected tree or a 
variety of other selection options, and can be set as the default 3D attributes for the drawing. This is a powerful way to 
control the 3D appearance of all existing trees in the layer or drawing in one operation. Showing trees in a 3D view is 
also useful for creating shadow diagrams (Renderworks required).

Using classes for the tree canopy shape and trunk is recommended. The attributes (color or texture) of these 
elements are easy to control with classes (Renderworks is required to use textures). The class color or texture must 
be set to Use at Creation. See “Classes” on page 176.

Existing tree symbols are provided as default content (default content is automatically imported into the current file at 
the point of use and displays in the Resource Browser; see “Resource Libraries” on page 219). The resources in the ET 
Symbols.vwx file are available in the 3D Properties dialog box.
Image props, such as those provided by xFrog, can be used as 3D tree geometry. However, canopy height and canopy 
diameter changes in the Object Info palette do not affect the geometry of image props.
To set the existing tree 3D appearance:

1. From the Object Info palette of a selected existing tree, select 3D Properties. 
The 3D Properties dialog box opens.

Click to show/hide the parameters.

Parameter Description

Use Canopy Offsets from 
Center of Trunk

Select to specify an irregular canopy shape

North/East/South/West For each direction, specify the distance from the center of the trunk to the edge of 
the canopy

Color shader texture combined with noise transparency shader
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Parameter Description

Create 3D Geometry Select whether to create 3D geometry for the existing tree
Canopy Shape Select the symbol to display for the 3D canopy
Trunk Shape Select the symbol to display for the 3D trunk shape. Short trunks extend to the First 

Branch Hgt value indicated in the Object Info palette, while long trunks extend into the 
canopy. If using a canopy texture that is partially transparent, use a long trunk shape for a 
more realistic appearance. A curved shape gives the trunk a flanged appearance near the 
ground; random selections are slightly more free-form in shape. 

Optional Class Names
3D Canopy If desired, select a class to control the appearance and visibility of the canopy. The classes 

present in the drawing are listed, or select the default class, Exist Tree-3D Canopy. 
3D Trunk If desired, select a class to control the appearance and visibility of the trunk. The classes 

present in the drawing are listed, or select the default class, Exist Tree-3D Trunk.
Apply textures to 
classes 
(Renderworks 
required)

When the canopy and/or trunk appearance is defined by classes, determines whether to 
apply the texture set for the class. In drawings with many external trees, performance may 
be improved by turning off the class texture. As the project becomes complete, apply the 
classes for optimal presentation.

Apply Properties The various 3D properties can be applied to a single tree, all trees in the layer or drawing, 
and as the tool default settings

Straight Short Curved ShortStraight Long

Curved Long Random Curved LongRandom Curved Short
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2. Click OK.
The 3D canopy shape is affected by changes in the Object Info palette for height, diameter, irregular canopy 
shape, First Branch Hgt, and DBH values.

~~~~~~~~~~~~~~~~~~~~~~~~~
Documenting Existing Trees

Existing Tree Autonumbering and ID Tags
Existing tree tags can contain an automatic numbering ID as well as tree information. Set up the new tree 
autonumbering properties first, to automatically number the trees according to the settings as they are placed on the 
drawing. Autonumbering can also be changed after placement on a tree-by-tree basis.
To set autonumbering and ID tag information for existing trees:

1. From the Object Info palette of a selected existing tree, select Tag and Number Options. 
The Tag and Number Options dialog box opens.

Click to show/hide the parameters.

Apply list Select the method to apply the properties.
• To this object only: Applies the properties to the currently selected existing tree
• To all objects on all layers: Applies the properties to all existing trees in the drawing
• To all objects on active layer only: Applies the properties to all existing trees in the 

current layer
• To all selected objects on all layers: Applies the properties to selected existing trees in 

the drawing
• To all selected objects on active layer only: Applies the properties to selected existing 

trees in the current layer
Also apply as the 
document defaults

Sets the 3D properties as the default properties for the Existing Tree tool. Existing trees 
placed by the tool after clicking OK will have these properties applied.

Parameter Description

Auto Number New Trees Sets autonumbering defaults for trees to be placed on the drawing. Deselect the option if 
autonumbering is not desired.

Leading Zeros Specify the number of leading zeros to use for the autonumber. Using leading zeros 
allows correct sorting in worksheets.

New Tree Prefix/
Suffix

Specifies a prefix and or/suffix, if any, before and after the autonumber

Auto number 
duplicated trees

When selected, existing trees that are copied or duplicated (with the Duplicate 
command, or by clicking and dragging with the Option (Mac) or Ctrl (Windows) key 
pressed) receive their own autonumber 

Separate numbering 
on each layer

Restarts the autonumbering series for each layer of the drawing

Parameter Description
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Auto Number This Tree Sets autonumbering properties for the currently selected tree; deselect to manually enter 
a number in Full ID Number instead of using an autonumber. When displaying 
transplanted trees, for example, the same number is needed for the tree representation in 
the original and new locations. For one of the representations, deselect Auto Number 
This Tree and enter the identical number in the Full ID Number. 

If Auto number duplicated trees is not selected, Auto Number This Tree is 
automatically disabled when an autonumbered tree is duplicated.

Leading Zeros Specifies the number of leading zeros to use for the autonumbering of the selected tree
This Tree Prefix/
Suffix

Specifies a prefix and or/suffix, if any, before and after the autonumber for the selected 
tree

Full ID Number Displays the selected tree’s autonumber; deselect Auto Number This Tree to specify a 
custom ID Number

ID Tag Options Specifies how to display existing tree ID tags
Snap tag to edge of 
trunk

Snaps the end of the leader line to the edge of the trunk; deselect to adjust the endpoint 
location manually

Display marker at end 
of tag leader

Adds a marker to the leader line endpoint. The marker style is controlled by the ID tag 
class.

Enable tag shoulder 
line

Adds a shoulder to the leader line 

Shoulder Angle Sets the angle of the ID text and shoulder
Display Specifies the information to display in the tag; each item displays on its own line. The 

Notes information is set in the Object Info palette.
Class If desired, select a class to control the appearance (color of text and attributes of the 

leader line, as well as marker style) and display of the ID tag. The classes present in the 
drawing are listed, or select the default class, Exist Tree-Tags. 

Apply To Select the method to apply the numbering and ID properties.
• To this object only: Applies the properties to the currently selected existing tree
• To all objects on all layers: Applies the properties to all existing trees in the drawing
• To all objects on active layer only: Applies the properties to all existing trees in the 

current layer
• To all selected objects on all layers: Applies the properties to selected existing trees in 

the drawing
• To all selected objects on active layer only: Applies the properties to selected existing 

trees in the current layer
Also apply as the 
document defaults

Sets the tag and numbering properties as the default properties for the Existing Tree 
tool. Existing trees placed by the tool after clicking OK will have these properties 
applied.

Also apply position of 
ID tag

Also applies the position of the ID tag and leader line from the currently selected tree to 
the existing trees set in Apply To

Full ID Number If Auto Number This Tree is not selected, manually enter a number for the selected 
tree

Parameter Description
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2. Click OK.
Existing tree tag appearance and placement is flexible, and can be adjusted in several ways, including through the 
Object Info palette, tag class settings, and the control point locations on the drawing. 

• When existing tree tags are required, define their appearance in the Tag and Number Options dialog box. Apply 
the ID tag options to all existing trees and to the document defaults.

• Individual tags can then be changed for selected existing trees by clicking Tag and Number Options from the 
Object Info palette. For example, selected trees in one area of a planting plan look more uniform when they all use 
the same tag approach and tag shoulder angle. Set the Shoulder Angle and then select Also apply position of ID 
tag.

• The existing tree tag class controls the appearance of the leader/shoulder lines, as well as the marker style.
• To move the plant tags of several selected plants at once, click the Unrestricted Interactive Scaling mode of the 

Selection tool.
• If an individual tag needs to be repositioned, plant tags also have several control points for adjusting the tag text 

and leader line and shoulder position and angle.
• Align and distribute the leader lines for improved readability with the Align/Distribute Leader Lines command 

(see “Aligning and Distributing Leader Lines” on page 1035)

~~~~~~~~~~~~~~~~~~~~~~~~~
Documenting Existing Trees

Customizing Existing Trees
Existing trees are hybrid symbols, containing a 2D symbol component, and optionally, a 3D symbol component. The 
default existing tree symbols are located in the default content included with the Vectorworks Landmark product in 
Vectorworks\Libraries (see “Resource Libraries” on page 219). As 2D and 3D settings are made, the associated tree 
symbols are automatically imported into the current file and appear in the Resource Browser. 
As with any resource, the symbols can be edited through the Resource Browser, and these edits apply to the current file. 
Alternatively, custom existing tree symbols can be added to the default ET Symbols.vwx file, either directly or by 
exporting edited tree symbols to the file (duplicate and rename the symbols from the Resource Browser first, so that the 
original symbols are not overwritten). For more information on symbol operations in the Resource Browser, see 
“Working with Resources” on page 225. See “Exporting Custom Resources” on page 234 for information on exporting 
resources.

Adjusts endpoint location 
and tag approach angle

Adjusts shoulder location, 
leader line length, and tag 
approach angle

Adjusts shoulder length, tag shoulder
angle, and tag location Contents specified by ID Tag Options 

Display parameter

Adjusts trunk location (regular canopy shape only)
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These naming conventions ensure that any custom symbols are available for selection in the 2D and 3D Properties 
dialog boxes:

• Symbol names for retained trees, or the new location of transplanted trees, must begin with 1. (the number 1, 
followed by a period)

• Symbol names for removed trees, or the original location of transplanted trees, must begin with 2.
• Symbol names for the 2D tree trunk must begin with 3.
• Symbol names for the 3D canopy must begin with 4.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Symbol Definitions
Using the Resource Browser
Documenting Existing Trees

Plant Graphics
In addition to plant placement with the Plant tool, there are additional ways of representing plant masses on a planting 
plan. Large, defined planting areas containing specific plants can be created with the Landscape Area tool. Undefined 
plant masses and groups can be added with the Plant Line and Vegetation Line commands. To further change the 
appearance of the planting plan, all plant styles can be displayed or hidden.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Landscape Areas
Creating a Plant Line
Creating a Vegetation Line
Show/Hide Plant Styles

Creating Landscape Areas
Landscape areas consist of large, defined regions of plant combinations, useful for conceptual planning and specifying 
large planting or reforestation areas, when individual plant symbols do not need to be drawn. Plant information from a 
landscape area is based on plant symbol data, and is included in plant list worksheets. If a site model is present, the 
landscape area is calculated based on the site model and displays in the Landscape Area Settings dialog box.
A landscape area can also be created without plant information specified, for use as a general ground cover or mulch 
area with a label showing the total area required.
Landscape area objects can also be created by drawing a polyline and then selecting the Create Objects from Shapes 
command (see “Creating Objects from Shapes” on page 277).

To create a landscape area:

1. Click the Landscape Area tool from the Site Planning tool set. 
2. Click Preferences from the Tool bar to specify or change the default landscape area parameters.

The Landscape Area Settings dialog box opens.
Click to show/hide the parameters.

Parameter Description

Tag Information Specifies the landscape area tag format
Name Provides a name for the landscape area, which can be displayed in the tag
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Tag Display Select On to display a landscape area tag to the right or left of the leader line; set the left or 
right position with the Tag Text Angle

Tag Class Specifies the class for the landscape area tag, or allows a new class to be created for the tag
Tag Line Angle Specifies the angle of the leader line, from 0 to 360°
Tag Text Angle When a landscape area tag is set to display, sets the tag text display angle, from 0 to 360°. To 

display the area tag to the left, specify an angle greater than 90 or less than 270 degrees. To 
display the area tag to the right, specify an angle less than 90 or greater than 270 degrees. 

Tag Header Select the information to display in the first line of the landscape tag, or select None to hide 
the top portion of the ID tag; select Set Custom Tag to define a custom landscape area tag 
(see “Creating a Custom Landscape Area Tag” on page 838)

Tag Body Select the information to display in the main portion of the landscape tag, or select None to 
hide this portion of the ID tag; select Set Custom Tag to define a custom landscape area tag 
(see “Creating a Custom Landscape Area Tag” on page 838)

Area Units Select the units for calculating the landscape area; this is set to the file units by default (see 
“Units” on page 68), but can be changed

Display Tag Line 
Marker

Displays a marker at the end of the leader line; specify the marker to use by editing the tag 
class properties (see “Setting Class Properties” on page 179)

Graphics
3D Display Select a 3D display option for the landscape area; in 3D views, plants conform to the surface 

of the site model if one exists
2D Only Does not create a 3D representation of the landscape area; the landscape area displays in top/

plan view only
3D Plants When the landscape area contains plant symbols with an image prop 3D component, 

switching to a 3D view displays the image props in a rectangular array, for a realistic 3D 
view. Plant density is determined by the distribution or percentage specified for the 
landscape area. 3D loci are placed when the plant definitions do not have a 3D component.

3D Poly Creates a 3D polygon at a default elevation of 0, and can display a fill color when rendered. 
Alternatively, assign the landscape area a texture from the Render tab of the Object Info 
palette (Renderworks required)

Texture Bed Creates a texture bed for the 3D representation of the landscape area. If there is more than 
one site model in the file, the texture bed conforms to the site model that is in the same layer 
as the landscape area, if there is one. Apply a texture to the landscape area (Renderworks 
required). Select the site model and click Update from the Object Info palette; the landscape 
area displays as a texture bed on the site model

Border Style Specifies the type of border for the edge of the landscape area
Standard Sets the landscape area border to a single line
Plant Cloud Draws the landscape area border with a convex or concave cloud shape; specify the cloud 

billow type and the billow parameters. In addition to selecting the billow size and height, the 
billow variability sets the variation between the smallest and largest billows.

Plant Line Creates a freehand plant line border for the landscape area; for a rougher plant line border, 
specify a short segment length with high segment thickness

Parameter Description
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3. Specify the plants included in the landscape area, as well as their frequency. Click Add to specify or Edit to 
change an included plant and its distribution rate or percentage value. The total percentage of all plants in the 
landscape area should be 100 when finished.
The Edit Plant Information dialog box opens.

Click to show/hide the parameters.

Plant 
Information

Specifies how to calculate the plant quantities of the combined plants in the landscape area, 
for tag display as well as planting plan worksheets; select Distribution Rate or Percentage

Distribution Rate 
(automatic 
coverage area %)

Calculates plant quantity based on plant distribution rate. As each plant is added to the list of 
plants in the landscape area, its rate per area or from the center is specified; the percentage of 
each plant in the landscape area is calculated automatically.

Distribution Rate 
(custom coverage 
area %)

Calculates plant quantity based on plant distribution rate. As each plant is added to the list of 
plants in the landscape area, its rate per area or from the center is specified, as well as the 
percentage of each plant in the landscape area. This option allows plants to be merged within 
the landscape area.

Percentage Calculates plant quantity based on plant percentage of the total. As each plant is added to the 
list of plants in the landscape area, its percentage is specified. The plant distribution rate 
must be the same for all plants in the landscape area; specify the rate and units to use.

Landscape Area Displays the landscape area value based on the surface area of the site model found if one 
exists, or based on the landscape area polyline if no site model is present. The units for the 
display are specified by Area Units.

Plant list Displays the plants included in the landscape area, including each plant’s distribution rate 
and percentage of the plant total. The plant order can be changed by click-dragging an item 
in the # column to a new position; this affects the plant list order in the plant tag body.

Add Click to open the Edit Plant Information dialog box, to add a plant to the list of plants in the 
landscape area, and specify its distribution rate or percentage

Edit Click to open the Edit Plant Information dialog box, to edit the selected plant; a different 
plant symbol can be selected, or the plant distribution rate or percentage changed

Delete Click to delete the selected plant from the list of plants in the landscape area

Parameter Description

Plant symbol list To include plant information in the landscape area, select a symbol to insert from the 
graphical list. The list displays the symbols in the current document or selected plant 
content file; select a different plant content file from the list browser to display additional 
options.

Latin Name/Common 
Name/Plant/Tag ID

Displays the selected plant’s definition information

Rate If Distribution Rate was selected in the Landscape Area Preferences dialog box, 
indicate the plant distribution value and units. This distribution value is used to calculate 
the plant quantity for each plant type in the landscape area. 

Parameter Description
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4. Click OK, and then click OK again to close the Landscape Area Preferences dialog box.
5. Click on the appropriate mode in the Tool bar to select the boundary creation method of the landscape area.

For more information on the Polyline tool modes, see “Creating Polylines” on page 298.
6. Click to set the landscape area’s start point.
7. Click to set the end of the segment and the beginning of the next. Continue drawing segments in this manner until 

the landscape area object is complete.

The appearance of the landscape area is controlled by several methods.
• Change the landscape area parameters from the Object Info palette, including specifying a general unit price (for 

indicating the price per square unit in worksheets), price code (such as a SKU number) and vertex parameters; 
click Landscape Area Settings from the Object Info palette to change landscape area information and other 
preference parameters

• Change the landscape area 2D attributes from the Attributes palette
• Change the landscape area tag appearance by editing its parameters in the Object Info palette, editing the tag class 

properties, and/or moving tag control points (similar to a plant tag; see “Plant Tag Appearance” on page 800)
• To align landscape area tags for improved readability, use the Align/Distribute Leader Lines command (see 

“Aligning and Distributing Leader Lines” on page 1035).
• Reshape the landscape area by double-clicking on it. The Reshape tool is automatically activated, to reshape the 

object directly in the drawing.

Percentage If Percentage was selected in the Landscape Area Preferences dialog box, indicate the 
percentage of this plant in the landscape area. Using a fixed distribution rate for all 
plants, the percentage is used to calculate the plant quantity for each plant type in the 
landscape area. The total value of all plants must add up to 100%.

Plant Content File list From the list browser, select the plant content file that contains the plant definition to 
insert; plant definitions in the selected plant content file are used to populate the plant 
symbol list.
The Vectorworks Landmark software is installed with a basic selection of default plant 
definitions to get you started. Select Help > Download Content to download many more 
plant definitions in the free content libraries provided and/or add your own custom plant 
content (see “Resource Libraries” on page 219). Once added to the library, the 
appropriate plant content files automatically appear in the list browser.

The list browser displays content located in [Vectorworks or User]/Libraries/
Objects-Landscape & Site/Plant Tool-Symbol+Definition Library; check the 
filepath if the expected content does not display.

Parameter Description

Landscape Area-6857.103 sq ft
50%-Colorado Blue Spruce
20%-Sweet Birch
30%-Shademaster Honey locust

2D landscape area 3D landscape area with 3D plants
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• Right-click (Windows) or Ctrl-click (Mac) on the landscape area object and select Edit from the context menu. 
The Edit Landscape Area dialog box opens. Either edit the settings of the selected landscape area, or edit the shape 
of the object path with the Reshape tool.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Custom Landscape Area Tag

Creating a Custom Landscape Area Tag
In addition to providing several predefined landscape area tags, Vectorworks Landmark allows designers to create 
custom landscape area tags.

1. From the Tag Information pane of the Landscape Area Settings dialog box, select Set Custom Tag from either the 
Tag Header or Tag Body fields. Settings for the landscape area tag currently displaying in this field are displayed 
in the Set Custom Tag dialog box.
The Set Custom Tag dialog box opens.
If editing an existing tag through the Object Info palette, the selected tag’s data displays.

2. Select values from the predefined plant record fields (including an empty string to skip the field value) in the order 
they should be listed, and type the delimiter text that will appear between values. A combination of up to six 
landscape area values and plant record fields can be specified for the Tag Header and Tag Body fields.
The Tag Appearance field displays a static text preview of the custom tag. To preview a long tag in its entirety, 
Click-drag the bottom right corner of the dialog box to resize it.

3. Click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Landscape Areas

Creating a Plant Line
The Plant Line command creates a freehand plant line along a line, polyline, or polygon. It can be used to represent a 
single undefined plant, line of plants, or general plant mass. No specific plant symbol information is included in a plant 
line; use the Landscape Area tool if defined plant areas are necessary (see “Creating Landscape Areas” on page 834).
To create a plant line:

1. Select the object (line, polyline, or polygon) with the Selection tool.
2. Select the Plant Line command from the appropriate menu: 

• Designer workspace: AEC > Plants > Plant Line
• Landmark workspace: Landmark > Plant Line
The Plant Line dialog box opens. Suggested values are based on the selection’s perimeter.

Click to show/hide the parameters.

Parameter Description

Segment Length Maximum length of each plant line segment; longer segments create a rougher plant line 
appearance

Thickness Maximum perpendicular distance of each segment; a higher thickness value results in a 
rougher plant line appearance

http://www.youtube.com/watch?v=VHrrtAkl0PE
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3. Select the desired plant line parameters and click OK. The plant line is created. If desired, apply colors, textures, 
and other attributes to the plant line with the Attributes palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
The Attributes Palette

Creating a Vegetation Line
The Vegetation Line command creates a vegetation line around a selection of closed objects or symbols. It can be used 
to represent a massed collection of undefined vegetation.
To create a vegetation line:

1. Select the closed objects or symbols that will form the basis of the vegetation line. The items should overlap.

2. Select the Vegetation Line command from the appropriate menu: 
• Designer workspace: AEC > Plants > Vegetation Line
• Landmark workspace: Landmark > Vegetation Line
The Vegetation Line dialog box opens. Select the type of vegetation line to create, and whether the original objects 
should be deleted or retained.

Click to show/hide the parameters.

Corner Types Specifies the type of corner to create between segments; each type produces a different 
plant line effect

Delete original Select to remove the object that forms the basis of the plant line

Parameter Description

Normal Corner Type
Segment Length: 0.16
Thickness: 0.0251

Cubic Corner Type
Segment Length: 0.0516
Thickness: 0.251

Bézier Corner Type
Segment Length: 0.16
Thickness: 0.251

Arc Corner Type
Segment Length: 0.0516
Thickness: 0.251

Random Corner Type
Segment Length: 0.0516
Thickness: 0.0251

Plant Line command     Plant Line command
executed twice               executed three times
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3. Click OK to create the vegetation line. If desired, apply colors, textures, images, hatches, gradients and other 
attributes to the vegetation line with the Attributes palette. See “The Attributes Palette” on page 1093 for more 
information on applying attributes.

The vegetation line can be assigned to a class (with the desired attributes). The original plant symbols can remain 
hidden by a vegetation line with a solid fill; however, the underlying vegetation can be revealed by hiding the 
vegetation line class.

Show/Hide Plant Styles
The Show or Hide Plant Styles command controls the visibility of the outline, massing, and shadow parameters set on 
the Render pane of a plant definition (see “Plant Definition: Render Pane” on page 789), on the Render pane of the 
plant settings (see “Plant Settings: Render Pane” on page 797), as well as on the Object Info palette. 
These effects display in Top/Plan view only. In a complex drawing with many plants, these settings can take a 
significant amount of time to display and edit, and it is useful to toggle the effects on and off.
To show or hide the plant styles:

1. Select View > Show > Show or Hide Plant Styles.
2. If the plant styles are currently hidden, this command displays the outline, massing, and shadows of all plant 

objects with those parameters set.
If the plant styles are currently visible, this command hides the effects. The Outline selection is saved for the 
plants, even when hidden.

Parameter Description

Standard Vegetation Line Creates an outline based on the outer perimeter of the selections
Cloud Vegetation Line Creates a cloud outline based on the parameters specified

Minimum/Maximum 
Radius

Specifies the minimum and maximum radius of each arc in the cloud

Billow Height Specifies the cloud billow height factor
Delete Original Select to delete the original selection of objects when creating the vegetation line

Standard Vegetation Line Cloud Vegetation Line



Irrigation
The irrigation tools in the Site Planning tool set insert generic drip emitters, irrigation heads, and irrigation lines into 
the drawing.

A selection of standard pre-configured manufacturer’s irrigation products are available through the Resource Browser, 
and are located in the default irrigation libraries from the [Vectorworks]\Libraries folder that is included with the 
Vectorworks Landmark product (see “Resource Libraries” on page 219).
For more information on the Resource Browser, see “Using the Resource Browser” on page 221.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting a Drip Emitter
Inserting an Irrigation Head
Inserting an Irrigation Line
Show/Hide Spray Pattern
Creating Schedules Automatically

Inserting a Drip Emitter
A generic drip emitter can be inserted into the drawing with the Drip Emitter tool. Alternatively, use a drip emitter 
from one of the irrigation object libraries.

To insert a drip emitter:

1. Click the Drip Emitter tool from the Site Planning tool set.
2. Click in the drawing to insert the drip emitter. Click again to set the rotation.

The first time the tool is used, the Drip Emitter Properties dialog box opens. Accept the default parameters and 
click OK to insert the drip emitter.

3. The drip emitter properties can be changed in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Manufacturer Displays the manufacturer’s name or “Generic”
Model Displays the manufacturer’s model number
Type Options include Pressure Compensating and Non-Pressure Compensating
Head Style Selects the type of emitter head (Micro-Spray, Drip Manifold, or Sub-surface Drip)
Spray Nozzle For Micro-Spray head style, indicates the arc degrees of spray
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Inserting an Irrigation Head
A generic irrigation head can be inserted into the drawing with the Irrigation Head tool. Alternatively, use an 
irrigation head from one of the irrigation object libraries.

To insert an irrigation head:

1. Click the Irrigation Head tool from the Site Planning tool set.
2. Click in the drawing to insert the irrigation head. Click again to set the rotation.

The first time the tool is used, the Irrigation Head Properties dialog box opens. Accept the default parameters and 
click OK to insert the irrigation head.

3. The irrigation head properties can be changed in the Object Info palette.
Click to show/hide the parameters.

Working Pressure Displays the water line pressure, for use in worksheets
Flow Rate Displays the flow rate per hour in either metric or imperial units
Unit Selects the units for the display of flow rate
Scale Factor Determines the size of 2D drip emitter display
Microtube 
Control

For Sub-surface Drip head style only, displays the coordinates of microtube placement. 
Coordinates 1X/Y position the control point that defines the microtube’s Bézier curve; 
coordinates 2X/Y position the control point that defines the microtube’s end point.
Alternatively to entering coordinates, you can position the control points manually. The 
Sub-surface drip emitter contains control points in the center of the symbol; position the first 
control point to determine the microtube end point, and the second to define the curvature.

Parameter Description

Manufacturer Manufacturer’s name or “Generic”
Model Manufacturer’s model number
Spray Pattern Selections include Circular, Rectangular, and Special
Head Type Indicates a Fixed Spray or Rotary sprinkler
Body Spray head height (for use in worksheets)
Nozzle Manufacturer’s nozzle type

Parameter Description

Click in the center of the drip emitter 
to obtain the control point, and click 
again to place the end point

Click a third time in the center of the drip 
emitter to obtain the second control point, 
and click again to define the curvature

Click 1

Click 2

Click 3

Click 4
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The spray pattern can be hidden and displayed with the Show or Hide Spray Pattern command (see “Show/Hide 
Spray Pattern” on page 844).

Inserting an Irrigation Line
An irrigation line can be inserted into the drawing with the Irrigation Line tool. Alternatively, use an irrigation line 
from one of the irrigation object libraries.

To insert an irrigation line:

1. Click the Irrigation Line tool from the Site Planning tool set.
2. Click and drag to define the length of the irrigation line. 

The first time the tool is used, the Irrigation Line Properties dialog box opens. Accept the default parameters and 
click OK to insert the irrigation line.

3. The irrigation line properties can be changed in the Object Info palette.
Click to show/hide the parameters.

Spray Radius or 
Width

For circular spray patterns, displays the radius of the spray; for rectangular spray patterns, 
displays the spray width

Length of Rect 
Spray

Displays the length of a rectangular spray pattern

Show Spray 
Pattern

Select to display the irrigation spray pattern

Spray Arc Indicates the arc of the spray pattern and determines the spray pattern display
Trajectory Angle (in degrees) of water as it is thrown from the spray head (for use in worksheets)
Working Pressure Water line pressure (in psi or kg/cm3) for use in worksheets
Spacing Indicates triangular or square spacing
Precipitation Rate Number of inches or millimeters of water placed over a certain area per hour, for use in 

worksheets
Head Scale Factor Determines the size of 2D irrigation head display
Unit Specify either Metric or Imperial units

Parameter Description

Length Displays irrigation line length
Type Indicates the irrigation line material (PVC, PE, Galvanized Steel, or Copper)
Diameter Displays irrigation tubing diameter
Has Sleeve Select if the irrigation line has a sleeve
Sleeve Diameter When the Has Sleeve option is selected, indicates the tubing diameter of the sleeve

Parameter Description
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Show/Hide Spray Pattern
The Show or Hide Spray Pattern command controls the visibility of the spray pattern of irrigation head objects.
To show or hide the spray pattern:

1. Select View > Show > Show or Hide Spray Pattern.
2. If the spray patterns are currently hidden, this command causes the spray pattern of all irrigation head objects to 

become visible. In the Object Info palette, Show Spray Pattern is selected automatically.
If the spray patterns are currently visible this command causes the spray pattern of all irrigation head objects to 
become hidden. In the Object Info palette, Show Spray Pattern is automatically deselected.

~~~~~~~~~~~~~~~~~~~~~~~~~
Irrigation



Parking Tools
A basic parking tool, Parking Spaces, creates simple parking space graphics in any Vectorworks workspace. 
Two additional parking tools available in Vectorworks Landmark, Parking Area and Parking Along Path, create 
parking spaces automatically within a defined area or along a path. The parking tools allow for islands, accessible 
spaces, head-in (angled) parking, parallel parking, and access lanes; a parking schedule counts the total number of 
parking spaces for each type of parking tool.
Alternatively, in Vectorworks Landmark, draw a polyline and then select the Create Objects from Shapes command 
(see “Creating Objects from Shapes” on page 277). 

Parking areas and parking along path objects can be sent to a site model surface with the Send to Surface 
command, but they do not modify the site model.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Parking Spaces
Creating a Parking Area
Creating Parking Along a Path
Creating Parking Reports

Creating Parking Spaces

To create basic parking spaces:

1. Select the Parking Spaces tool from the appropriate tool set:
• Architect and Landmark workspaces: Site Planning tool set
• Spotlight workspace: Building Shell tool set

The Parking Space tool is available for Vectorworks Fundamentals software but is not present in the Fundamentals 
workspace. It can be added to the Fundamentals workspace (see “Creating or Editing Workspaces” on page 1835).

2. Click once to place the parking spaces object. Click again to set the object rotation.
If this is the first time the object is inserted in this session, the Object Properties dialog box opens. These 
parameters apply to subsequent placements of the object and can be changed in the Object Info palette. Click OK.

3. A basic parking spaces object is placed in the drawing.
Parking space parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using options 
on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 and 
“Formatting Text” on page 389.

Space Style Select the type of parking space:
• Single Bay: Draws spaces on one side of the header stripe
• Double Bay: Draws spaces on both sides of the header stripe
• Parallel: Creates parallel spaces (along a curb, for example) instead of head-in parking

http://www.youtube.com/watch?v=dOJQkJFsz4A
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~~~~~~~~~~~~~~~~~~~~~~~~~
Parking Tools

No. of Standard 
Spaces

Specify the number of spaces to create

Space Width Indicates the parking space width
Space Length Indicates the parking space length (for parallel spaces, this is the length along the curb)
Space Angle For single and double bay parking, specifies the angle of each parking space
Header Style Select the header style:

• Straight: The header stripe remains straight
• Angled: The header stripe stays perpendicular to the space angle

No. of Accessible 
Spaces

Specifies the number of spaces with a different width applied for accessibility

Accessible Width Sets the space width for accessible spaces
Accessible Location Indicates whether the location of the accessible space(s) is at the beginning or end of the 

parking row
Show Accessible 
Symbol

Select to show an accessible parking symbol in each designated parking space.
Vectorworks software includes an international standard accessibility symbol that can 
be edited by the user.

Add Accessible Aisle 
Spaces

Select to add aisle spaces adjacent to accessible parking spaces

Aisle Width Enter a value for the accessibility aisle width
Aisle Location Select an aisle location relative to the accessible parking spaces
Aisle Fill Click to open the Choose Fill dialog box, and select the aisle fill from options present in 

the drawing (see “Fill Attributes” on page 1098)
Show Header Stripe Toggles the display of the parking header stripe
Show Start Stripe Toggles the display of the side of the first parking space
Show End Stripe Toggles the display of the side of the last parking space
Space Numbering Adds a parking space number to each parking space; spaces are numbered from left to right 

and top to bottom
Start Numbering At Specifies the starting number to begin parking space numbering

Show Bumpers Toggles the display of the parking space bumpers (stops)
Show 3D Stripes Toggles the display of the parking spaces in a 3D view

Parameter Description
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Creating a Parking Area

To create a parking area:

1. Select the Parking Area tool from the Site Planning tool set.
2. Click to begin drawing the parking polyline; click to set each polyline vertex. Click the mouse at the start point to 

complete a closed polyline, or double-click the mouse to create an open polyline. For more information on 
polylines, see “Polyline Tool” on page 298.
If this is the first time the object is inserted in this session, the Object Properties dialog box opens. These 
parameters apply to subsequent placements of the object and can be changed in the Object Info palette. Click OK.

3. The parking spaces are automatically created within the area defined by the polyline.

Once created, the parking area can be edited by several methods. 
• Adjust the parking space origin by dragging the parking area control point. 
• Reshape the parking area polyline with the Reshape tool. 
• Set a solid fill color for the parking area and a solid pen color for the space numbers through the Attributes palette. 
• Change the parking space numbering font, size, and style with the Text menu, or assign a text style.
• The parking area displays in a 3D view; if desired, assign a texture to the parking area with the Render tab of the 

Object Info palette (Renderworks required).
Parking area parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using options 
on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 and 
“Formatting Text” on page 389.

Lane Width Specifies the width of the lane between rows of parking spaces
Row Angle Sets the angle for the parking header stripe
Space Width Indicates the width of each parking space
Space Length Indicates the length of each parking space
Space Angle Specifies the angle of each parking space

Click 1

Click 2 Click 3

Click 5
Click 4

Control pointParking Area tool in Corner Vertex mode
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Parking Tools
Creating Parking Islands

Creating Parking Islands
Many parking areas include islands where trees are planted or parking spaces are otherwise separated. By using the 
Clip Surface command, the parking area can be adjusted to account for parking islands, or for accessible parking. The 
parking spaces automatically adjust for the presence of the parking islands.
To create parking islands within a parking area:

1. Draw the 2D clipping objects on the parking area.
2. Select the clipping objects and the parking area. See “Clip Surface” on page 1083 for more information.
3. Select Modify > Clip Surface.

The parking area is clipped, removing the areas under the clipping objects.
4. Delete the clipping objects. 

The parking area automatically adjusts for the removed spaces, renumbering the parking spaces.

Show Header Stripe Toggles the display of the parking header stripe
Show Perimeter Toggles the display of the original polyline
Space Numbering Adds a parking space number to each parking space; spaces are numbered from left to 

right and top to bottom
Start Num At Specifies the starting number to begin parking space numbering
Num Spaces Displays the number of parking spaces created

Parameter Description

Aerial parking lot photo with parking area superimposed
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Although the Parking Space tool offers several parameters for easily defining accessible parking spaces, the Clip 
Surface technique can also be used to create accessible spaces. Do not remove the clipping object after clipping; 
apply the same fill color and then apply an accessible parking graphic image to the area. Accessible spaces created 
this way are not counted in parking space reports.

~~~~~~~~~~~~~~~~~~~~~~~~~
Parking Tools

Creating Parking Along a Path

To create parking along a path:

1. Select the Parking Along Path tool from the Site Planning tool set.
2. Click to begin drawing the parking polyline path; click to set each polyline vertex. Double-click the mouse to 

create an open path polyline, or click at the start point to complete a closed polyline. For more information on 
polylines, see “Polyline Tool” on page 298.
If this is the first time the object is inserted in this session, the Object Properties dialog box opens. These 
parameters apply to subsequent placements of the object and can be changed in the Object Info palette. Click OK.

3. The parking spaces are automatically created along the polyline path.

Click 1

Click 2

Double-click

Parking Along Path tool in Bézier Vertex mode
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Once created, the parking along path object can be edited by selecting the parking object; then select Modify > Edit 
Parking Along Path and reshape the parking area polyline with the Reshape tool; click Exit Path to return to the 
drawing. 
Parking along path parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Parking Tools

Creating Parking Reports
Parking report worksheets can be created for each type of parking tool: parking areas, parking along path objects, and 
parking spaces. If using a combination of parking types, a report may be needed for each type.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using options 
on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 and 
“Formatting Text” on page 389.

Space Width Indicates the width of each parking space. Spaces along a curve may widen along the 
length of the space; the space width is defined as the minimum width between the two 
sides.

Space Length Indicates the length of each parking space
Space Numbering Adds a parking space number to each parking space; spaces are numbered from left to 

right and top to bottom
Start Num At Specifies the starting number to begin parking space numbering
Num Spaces Displays the number of parking spaces created

Spaces on Left of Poly Includes spaces along the left side of the parking path
Spaces on Right of 
Poly

Includes spaces along the right side of the parking path

Aerial parking lot photo with curved parking 
along path superimposed

http://www.youtube.com/watch?v=IENEgNNygGU&list=UUN7uzhu-ljLJOe6a0J-fBcQ
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To create a parking report schedule:
1. Select Tools > Reports > Create Report.
2. Select the type of parking from the Listing objects with record list, and select the columns to include in the 

worksheet.
See “Creating Reports” on page 1316 for more information.

3. Click OK to create the report.
The worksheet calculates the total number of spaces for all parking objects of the same type.

~~~~~~~~~~~~~~~~~~~~~~~~~
Parking Tools
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Lighting Design
Lighting Design Workflow
The Vectorworks Spotlight product provides the lighting designer with all the tools necessary to plan and create a light 
plot and its associated paperwork. The following general workflow is recommended.

1. Create a template file that you can use to start new design files, or from which you can import standard elements 
into other files. The template can contain all of the resources, classes, and design layers you use on a regular basis. 
You might also set options you commonly use, such as the default object attributes and page size. It is 
recommended that you plan to place the stage, focus points, and scenic elements on separate design layers; plan to 
place the lighting positions, lighting instruments, and accessories together on one layer. All design layers should 
use the same scale. Select the File > Save As Template command to save the file.

2. Create a new project file from your template file.
3. Select the File > Document Settings > Spotlight Preferences command to set default lighting device parameters, 

and to specify whether universe assignment should be handled automatically. If you use Lightwright, set up 
automatic data exchange; this creates a file with the same name as the Vectorworks file with an .xml file 
extension, which you can then open in Lightwright. Changes that you make in both the Lightwright and 
Vectorworks programs are shared seamlessly.

4. Copy or import design elements (such as theater architecture or scenic designs) from other files, as needed. From 
a Vectorworks file, you can paste or import items directly into your file (you might want to apply your own classes 
to them first). Alternatively, create a design layer viewport to reference an external Vectorworks file; your file will 
be updated automatically if the external file changes, and the external classes will not be imported into your file. 
The Vectorworks program can also import drawing elements from several file types, such as DXF/DWG, PDF, and 
SketchUp.

5. Use the Lighting Pipe, Lighting Pipe Ladder, Straight Truss, and Curved Truss tools to create lighting 
position geometry. You can also draw your own 2D or 2D/3D geometry. Select the Spotlight > Object 
Conversion > Convert to Light Position command to convert each object into a light position. From the Object 
Info palette, enter a Z value to indicate the height of each position.

6. To use the same geometry for multiple lighting positions, select the option to create a symbol when you convert 
the geometry. Make the symbol active in the Resource Browser, and then use the Lighting Position tool to insert 
additional lighting positions.

7. Use the Focus Point tool to create focus areas. In step 10, you will assign these focus points to specific lighting 
instruments.

8. Select the Label Legend Manager command to create label legends for your lighting instruments. The label 
legend specifies which data fields to display for the instruments, as well as how the fields are laid out.

9. Select the Lighting Instrument tool to place lighting instruments on the lighting positions. Thousands of 
instrument symbols are available for import, from resource libraries provided with the Vectorworks application, 
from subscription libraries available through Vectorworks Service Select, and from third-party providers. 
The lighting instruments in the Vectorworks Spotlight product represent more than simply a graphical symbol. An 
instrument contains design information, such as labels, focus, position, channel, and color. Instruments are labeled 
with lighting information according to the label legend format. Use the standard instrument symbols, or convert 
your own custom symbols to instruments.
You can also draw your own instrument symbols as needed. The position and instrument height are filled in 
automatically according to the lighting position. 
From the Object Info palette, specify the instrument purpose, color, and dimmer.

10. Select the Spotlight > Focus Instruments command to specify a focus point for each instrument.
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11. Use the Lighting Accessory tool to add accessories to lighting instruments. As with lighting instruments, a wide 
variety of accessory symbols are available for import, or you can draw your own.

12. Fine-tune the lighting design using the following tools and commands:
• Select the Draw Beam option in the Object Info palette and check the light beam and field for each lighting 

instrument.
• Use the Photometer and Photometric Grid tools to check the footcandles present at specific spots on the 

stage.
• Use the Align and Distribute Items tool to more precisely align instruments to their positions.
• Select the Spotlight > Visualization > Create Plot and Model View command to automatically create a 3D 

model for a selected vertical or angled lighting position. This creates a design layer viewport on a model layer, 
which can be rotated to show the lighting position accurately in sections and elevations.

13. Use the Soft Goods tool to insert curtains, borders, scrims, and pipe-and-drape assemblies where needed.
14. Generate paperwork for yourself and others using one or more of the following commands:

• Select the Spotlight > Reports > Generate Paperwork command to create an instrument schedule and other 
typical electrician paperwork from within the Vectorworks program.

• Select the Spotlight > Reports > Create Report command to create a database worksheet, which allows you 
to edit lighting instrument data in a spreadsheet format from within the Vectorworks program.

• If you use the Lightwright automatic data exchange feature, your exchange file is ready to share when needed.
15. Use the Instrument Summary tool to create a summary graphic of the instruments and accessories that are used 

in the light plot. To create a summary graphic for a selected lighting position, click Insert Position Summary in 
the Object Info palette. To compare the required totals to current inventory, select the Spotlight > Reports > 
Lighting Inventory Setup command to enter inventory information.

16. Use commands on the View menu (Create Viewport, Create Detail Viewport, Create Section Viewport) to 
create the viewports you want to print or export, such as the main light plot, detail views, section views, and 
hanging cards. Show or hide classes and layers, and add title blocks, borders, dimensions, and notes as needed.

17. Print or export the sheet layers, as needed. The File > Publish command allows you to easily publish selected 
sheet layers to a printer, or to PDF, DXF/DWG, DWF, and image files. You can also save the publish settings and 
use them again later. The File > Export menu has options for exporting to several additional file types.

Spotlight Terminology
In Vectorworks, you use the Lighting Instrument tool to place a lighting instrument on the drawing. Optionally, you 
can use the Lighting Accessory tool to place a lighting accessory on the drawing, and associate it with the appropriate 
instrument. Because they are so closely linked, all instrument and accessory objects are referred to as “lighting 
devices” when they are edited in the Object Info palette, Properties dialog box, or Lighting Device dialog box. The 
Device Type field indicates whether an accessory or instrument is being edited. A lighting accessory has a type of 
Accessory or Static Accessory; any other Device Type indicates a lighting instrument.
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~~~~~~~~~~~~~~~~~~~~~~~~~
Light Plot Structure
Creating Lighting Positions
Inserting Lighting Positions
Setting Up Instrument Label Legends
Adding Lighting Instruments
Inserting Multi-circuit Instruments
Editing Lighting Instruments
Adding Accessories
Instrument and Accessory Specifications
Ganging Instruments
Focusing Instruments
Obtaining Photometric Data
Lighting Symbol Maintenance
Creating Instrument Summaries
Generating Paperwork
Spotlight Setup

Light Plot Structure
A structured system of layers and classes makes selecting, viewing, and printing items considerably easier. When 
creating a light plot, develop a standard layer and class structure, along with a system for assigning items to the 
appropriate layers and classes. Some objects include the ability to be automatically assigned to classes.
For more information on layers and classes, see “Layers” on page 161 and “Classes” on page 176.
We recommend that you place the stage, focus points, and scenic elements in separate design layers; place the lighting 
positions, lighting instruments, and accessories together on one layer. Select Tools > Organization and click the 
Design Layers tab to create and manage layers.

Use the same scale for all the design layers.
Place light plot items in their own classes. This allows you to globally turn off the display of certain classes for viewing 
and printing. Select Tools > Organization and click the Classes tab to create and manage classes. Lighting devices can 
be automatically assigned to classes determined at setup; see “Lighting Device Setup” on page 95.
Vectorworks automatically creates certain classes to control instrument label visibility. These include the Label class 
and its subclasses, and the Setup Notes class.

Layer and Class Examples
An example of the use of layers and classes would be a show file with all of the scenery on a single design layer, and 
classes created to represent Act 1 and Act 2. When adding scenic elements, place them on the scenery design layer, and 
assign them to either the Act 1 or Act 2 class. With this structure, use layer visibility to view only the scenery design 
layer, and class visibility to turn the Act 1 or Act 2 classes on and off. This method allows you to view the position of 
the set pieces in each act independently.
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Another way to take advantage of structuring is to also use classes for the lighting devices. In a situation with multiple 
shows in repertory, assign each device to the class of the show where it is used. This allows you to display each show’s 
devices independently of the other shows.

Creating Lighting Positions
Lighting positions in represent the hanging points for instruments; they should be placed on the light plot before the 
instruments are added. Lighting positions manage the numbering of instruments according to the instruments’ location 
on the lighting position.

Defining the lighting positions first is useful because once the space has been created, with the stage and lighting 
positions defined, the file can be used as a template for future light plots in that space. For more information on creating 
templates, see “Creating Templates” on page 75.

Place the lighting positions in their own design layer and in their own classes. A drawing structure based on layers 
and classes facilitates selecting, viewing, and printing the light plot.

Creating a lighting position is generally a two-step process. First, insert or draw the geometry of the lighting position. 
Then, convert the geometry into an intelligent lighting position object, ready for instrument placement.
Several different types of objects can be used as the basis for a lighting position object:

• Lighting pipes
• Lighting pipe ladders
• Straight trusses
• Curved trusses
• Custom 2D or 2D/3D geometry that you draw

To convert multiple objects to a single lighting position, group the objects first. Once the geometry is complete, convert 
it into an intelligent lighting position object with the Convert to Light Position command. You have the option to 
create a symbol from the geometry, or to embed the geometry into the object. If you choose to create a symbol, you can 
use it to insert multiple positions with the Lighting Position tool. If this is a uniquely shaped lighting position, or if you 
want to be able to edit the geometry more easily, choose instead to keep the geometry.

Scenery position for Act 1 Scenery position for Act 2
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Use the Lighting Position tool to insert symbols from the current file, the symbol libraries, or a Favorites file.
~~~~~~~~~~~~~~~~~~~~~~~~~
Placing Lighting Pipe Objects
Placing Lighting Pipe Ladders
Inserting a Straight Truss
Inserting a Curved Truss
Truss Configuration Requirements
Creating a Lighting Position Object
Inserting Lighting Positions

Placing Lighting Pipe Objects
Insert and configure a lighting pipe object with the Lighting Pipe tool.

To insert a lighting pipe object:

1. Click the Lighting Pipe tool from the Spotlight tool set.
Alternatively, create a polyline and then select the Create Objects from Shapes command (see “Creating Objects 
from Shapes” on page 277).

2. Click in the drawing area to begin drawing the lighting pipe.
If this is the first time a lighting pipe has been placed on the drawing, the Properties dialog box opens. Specify the 
preferences to use for this tool during this session, and then click OK.

3. To draw a multi-segment pipe, click to set the end of one segment and start the next.
Create a curved pipe by changing the vertex type (see “Creating Polylines” on page 298).

4. Double-click to complete the lighting pipe polyline.
The lighting pipe parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Total Pipe Length Specifies the total length of the lighting pipe; for a single-segment lighting pipe, the 
length can be edited by changing this value. (Change the segment length or edit 
multi-segment pipes with the Reshape tool.)

Arc Radius For single-segment curved pipes, specifies the radius of the arc
Position Name Enter the name to be used for the symbol when converting the pipe to a lighting 

position
Location Optionally, specifies the location for use in reports
Pipe

Draw Pipe Shows or hides the 2D component of the lighting pipe
Line Type Select either a single or double line for Top/Plan views
Diameter Sets the pipe diameter for all views
End Marker Specifies whether to display the end(s) of the pipe with an end marker in Top/Plan 

view
Tick Mark
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Draw Tick Marks Creates evenly-spaced marks to assist with lighting instrument placement
Draw Loci Adds a 2D and 3D locus at the tick mark positions for visibility in 3D views
Centers Specifies the distance between tick mark centers
Centered on Spaces the tick marks based on the total length of the pipe, or based on each segment 

of a pipe that is considered divided into two equal sections
Origin Starts the tick mark placement at the center of the pipe or split equally from the center 

of the pipe

Type Select Line or Dot as the 2D tick mark indicator
Size Specifies the length of line tick marks or the diameter of dot tick marks
Gap Length Adds a gap on either side of the tick mark; specify the gap length
Offset Specify a positive or negative value to shift the tick marks right or left from their 

centers
Align Tick Marks to 
Grid

Aligns the center tick mark with the snap grid (see “Grid Snapping” on page 133); 
this does not change the tick mark spacing but it may change the Offset value 

Footprint/3D
Show Footprint Creates a 2D projection of the 3D component in Top/Plan view; this is useful if the 

lighting pipe is offset or rotated
Align 3D with Footprint When selected, aligns the 3D component and the footprint in 3D views. This is the 

default behavior for the hybrid object to appear correctly in both 2D and 3D views. 
Deselecting this option and setting offset and rotation values is useful only for 
workflows where a hybrid appearance is not critical; however, lights placed in one 
view may not appear positioned correctly in all views.

Origin Offset X/Y Offsets the 3D component from its origin along the X/Y axes
Rotation Rotates the 3D component about its origin
I Rotation Rotates the 3D component along the I axis (parallel to the width)
J Rotation Rotates the 3D component along the J axis (perpendicular to the lighting pipe); a 

positive value pivots the pipe up, away from the ground
Classes

Auto-Class Uses the class specified in Settings as the root class for the lighting pipe components; 
this root class is automatically set as the prefix for the sub-classes

Pipe Select a class for the lighting pipe to control its fill color and/or texture and visibility. 
The classes present in the drawing are listed; alternatively, create a new class by 
selecting New, select the default class name, or select the class named <Lighting Pipe 
Class> which places the pipe in the same class as the lighting pipe object (specified in 
Settings).

Parameter Description

On Center Split Center
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To use the lighting pipe as a lighting position, convert it to a lighting position object; see “Creating a Lighting Position 
Object” on page 865.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Lighting Positions
Creating Lighting Positions

Placing Lighting Pipe Ladders
Insert and configure a lighting pipe ladder with the Lighting Pipe Ladder tool.

To insert a lighting pipe ladder:

1. Click the Lighting Pipe Ladder tool from the Spotlight tool set.
2. Click in the drawing area to insert the ladder. The ladder is a rectangular object, and can be inserted in Center-line 

Placement mode or Edge Placement mode.

If this is the first time a lighting pipe ladder has been placed on the drawing, the Properties dialog box opens. 
Specify the preferences to use for this tool during this session, and then click OK.

Tick Marks Select a class for the tick marks to control their fill color and/or visibility. The classes 
present in the drawing are listed; alternatively, create a new class by selecting New, 
select the default class name, or select the class named <Lighting Pipe Class> which 
places the tick marks in the same class as the lighting pipe object (specified in 
Settings).

End Marker Select a class for the end markers to control their fill color and/or visibility. The 
classes present in the drawing are listed; alternatively, create a new class by selecting 
New, select the default class name, or select the class named <Lighting Pipe Class> 
which places the end markers in the same class as the lighting pipe object (specified 
in Settings).

Footprint Select a class for the footprint to control its fill color and/or visibility. The classes 
present in the drawing are listed; alternatively, create a new class by selecting New, 
select the default class name, or select the class named <Lighting Pipe Class> which 
places the footprint in the same class as the lighting pipe object (specified in 
Settings).

Settings Opens the Lighting Pipe Settings dialog box, to set the default class for the lighting 
pipe.
Select the Make default for new documents option to always use the specified class 
as the default class for lighting pipe objects in new files.

Vertex Parameters Edits the pipe vertices; see “Editing Vertex-Based Objects” on page 1002

Placement Mode Description

Center-line Click once, and then again, to define the width through the center of the ladder. Click 
again to specify the width of half the ladder.

Edge Click once, and then again, to define the length along the edge of the ladder. Click again 
to specify the grid ladder width.

Parameter Description
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The lighting pipe ladder parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Ladder Width/ Height Specifies the lighting pipe ladder dimensions
Guides Select how to draw the ladder based on the preview guide rectangle: on the ladder 

center, inside, or outside
Number of Rungs Specifies the number of ladder rungs

Evenly Spaced Rungs Spaces the rungs evenly within the ladder frame; deselect to specify custom rung 
spacing

Custom Rung Spacing Opens the Custom Rung Spacing dialog box, to specify the spacing between each 
ladder rung.
Enter the distance between the rungs; the first and final distances are automatically 
calculated. Click Calculate Even Spacing to automatically space the rungs evenly, 
as a starting point for spacing or to reset the values.

Position Name Enter the name to be used for the symbol when converting the ladder to a lighting 
position

Location Optionally, specifies the location for use in reports
Pipe

Draw Pipe Shows or hides the 2D component of the lighting pipe ladder
Line Type Select either a single or double line for Top/Plan views
Diameter Sets the pipe diameter for all views

Tick Mark
Draw Tick Marks Creates evenly-spaced marks to assist with lighting instrument placement
Draw Loci Adds a 2D and 3D locus at the tick mark positions for visibility in 3D views
Centers Specifies the distance between tick mark centers
Origin Starts the tick mark placement at the center of one side of the ladder or split equally 

from the center of one of the ladder sides

Type Select Line or Dot as the 2D tick mark indicator
Size Specifies the length of line tick marks or the diameter of dot tick marks
Gap Length Adds a gap on either side of the tick mark; specify the gap length
Offset Specify a positive or negative value to shift the tick marks right or left from their 

centers
Align Tick Marks to Grid Aligns the center tick mark with the snap grid (see “Grid Snapping” on page 133); 

this does not change the tick mark spacing but it may change the Offset value 
Footprint/3D

On Center Split Center
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To use the lighting pipe ladder as a lighting position, convert it to a lighting position object; see “Creating a Lighting 
Position Object” on page 865.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Lighting Positions
Creating Lighting Positions

Inserting a Straight Truss
Straight truss parameters are illustrated by the following diagram.

Show Footprint Creates a 2D projection of the 3D component in Top/Plan view; this is useful if the 
lighting pipe ladder is offset or rotated

Align 3D with Footprint When selected, aligns the 3D component and the footprint in 3D views. This is the 
default behavior for the hybrid object to appear correctly in both 2D and 3D views. 
Deselecting this option and setting offset and rotation values is useful only for 
workflows where a hybrid appearance is not critical; however, lights placed in one 
view may not appear positioned correctly in all views.

Origin Offset X/Y Offsets the 3D component from its origin along the X/Y axes
Rotation Rotates the 3D component about its origin
I Rotation Rotates the 3D component along the I axis (parallel to the width)
J Rotation Rotates the 3D component along the J axis (perpendicular to the lighting pipe 

ladder); a positive value pivots the ladder up, away from the ground
Classes

Auto-Class Uses the class specified in Settings as the root class for the lighting pipe ladder 
components; this root class is automatically set as the prefix for the sub-classes

Pipe Select a class for the lighting pipe ladder to control its fill color and/or texture and 
visibility. The classes present in the drawing are listed; alternatively, create a new 
class by selecting New, select the default class name, or select the class named 
<Lighting Pipe Ladder Class> which places the pipe in the same class as the lighting 
pipe ladder object (specified in Settings).

Tick Marks Select a class for the tick marks to control their fill color and/or visibility. The 
classes present in the drawing are listed; alternatively, create a new class by selecting 
New, select the default class name, or select the class named <Lighting Pipe Ladder 
Class> which places the tick marks in the same class as the lighting pipe ladder 
object (specified in Settings).

Footprint Select a class for the footprint to control its fill color and/or visibility. The classes 
present in the drawing are listed; alternatively, create a new class by selecting New, 
select the default class name, or select the class named <Lighting Pipe Ladder 
Class> which places the footprint in the same class as the lighting pipe ladder object 
(specified in Settings).

Settings Opens the Lighting Pipe Ladder Settings dialog box, to set the default class for the 
lighting pipe ladder.
Select the Make default for new documents option to always use the specified 
class as the default class for lighting pipe ladder objects in new files

Parameter Description
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To add a straight truss to the light plot:

1. Click the Straight Truss tool from the appropriate tool set.
• Spotlight workspace: Spotlight tool set
• Designer workspace: Detailing tool set

2. Click in the drawing area where the truss will be located and draw a line to indicate the length of the truss. If this 
is the first time a straight truss has been placed on the drawing, the Properties dialog box opens. Specify the 
preferences to use for this tool during this session, and then click OK. 
The straight truss properties can be edited later in the Object Info palette.

Trusses are 2D/3D hybrid objects. Complex trusses can increase the time required to render the model in 3D.
Click to show/hide the parameters.

Parameter Description

Length Specifies the length of the truss in drawing units
Profile Select the truss profile from the list
Connection Select the type of connection from the list
Connection Interval Indicates the distance for dividing the truss into component sections
Folding Select to indicate a folding truss
Pre Rigged Select whether to include a light bar
Height/Width Shows height and width values for the truss
Chord Profile Select round or square chord tubing
Chord Width Shows the diameter of round chords or the width of square chords
Ladder Bar Spacing Specifies the interval of the ladder bars

Connection interval

Chord

Lacing

Straight truss

Straight folding truss

Ladder bar

Ladder bar spacing

Incomplete connection 
interval (red)

Truss length Width

Height

Left view straight 
truss

Click 1

Click 2
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A connection interval shorter than the defined interval length is displayed in red when Highlight is selected.
To use the truss as a lighting position, convert it to a lighting position object; see “Creating a Lighting Position Object” 
on page 865.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting a Curved Truss
Truss Configuration Requirements
Inserting Lighting Positions
Creating Lighting Positions

Inserting a Curved Truss
Curved truss parameters are illustrated by the following diagram.

To add a curved truss to the light plot:

1. Click the Curved Truss tool from the appropriate tool set:
• Spotlight workspace: Spotlight tool set.
• Designer workspace: Detailing tool set

2. Click to define the truss insertion point. Click again to set the rotation of the curved truss. If this is the first time a 
curved truss has been placed on the drawing, the Properties dialog box opens. Specify the preferences to use for 
this tool during this session, and then click OK.

Ladder Bar Profile Select round or square ladder bar tubing
Top/Side Ladder Bar 
Diameter

Indicates the diameter of the top and side ladder bar tubing; enter 0 to draw no 
ladder bar

Lacing Profile Select round or square lacing tubing
Top/Side Lacing Diameter Indicates the diameter of the top and side lacing tubing. Enter 0 to draw no lacing.
Hanging Angle Indicates the angle of the truss between the stage or floor and the hanging point
Rotation Specifies the rotation about the truss axis
Show 3D Detail Select to render the truss with greater 3D detail
Highlight Displays odd sized truss divisions in red
Message Provides information about the truss placement and indicates successful placement

Parameter Description

Chord

Lacing

Curved Truss

Ladder bar

Ladder
spacing arc

Segment arc
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The curved truss properties can be edited later in the Object Info palette.
Trusses are 2D/3D hybrid objects. Complex trusses can increase the time required to render the model in 3D.

Click to show/hide the parameters.

If the final segment of a truss is shorter than the defined interval length, it is displayed in red when Highlight is 
selected.
To use the truss as a lighting position, convert it to a lighting position object; see “Creating a Lighting Position Object” 
on page 865.

Rotating a Curved Truss
A curved truss can be rotated with the Rotate tool.
To rotate a curved truss:

1. Select the truss. In the Object Info palette, select Draw 3D Only.
2. Click the Rotate tool from the Basic palette.
3. Click to set a fulcrum line; click to end. Move the cursor to rotate the truss, and then click to set the rotation.

Parameter Description

Radius Specifies the radius of the truss measured from the truss center line
Total Arc Indicates the total angle covered by the truss in degrees
Segment Arc Specifies the interval in degrees for dividing the truss into component sections 
Connection Select the type of connection from the list
Profile Select the truss profile from the list
Height/Width Shows height and width values for the truss
Chord Profile Select round or square chord tubing
Chord Width Specifies the diameter of round chords or the width of square chords
Ladder Spacing Arc Specifies the interval of the ladder bars in degrees
Ladder Profile Select round or square ladder bar tubing
Top/Side Ladder Bar 
Diameter

Specifies the diameter of the top and side ladder bar tubing. Enter 0 to draw no ladder 
bar.

Lacing Profile Select round or square lacing tubing
Top/Side Lacing Diameter Specifies the diameter of the top and side lacing tubing. Enter 0 to draw no lacing.
Show 3D Detail Select to render the truss with greater 3D detail
Highlight Displays odd sized truss divisions in red
Message Provides information about the truss placement and indicates successful placement
Draw 3D only Select to display only the 3D component of the truss
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Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
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Truss Configuration Requirements
A great deal of flexibility is incorporated in the Spotlight truss object. However, in order to create a valid truss, the 
wide variety of configurations leads to certain restrictions in the application of truss properties.
If a truss is drawn that does not meet these requirements, an alert message is generated.

• The width and height of the truss must be greater than three times the chord width
• The truss hanging angle must be between -90° and +90°
• A triangular truss must form a valid triangle
• The chord diameter must be greater than zero
• A pre-rigged truss cannot have lacing
• A pre-rigged truss cannot be folding
• Only box trusses can be pre-rigged
• A folding truss cannot have top lacing
• Folding is not allowed on a stacking truss
• Top lacing is not allowed on a stacking truss
• The top brace diameter must be less than or equal to the chord width
• The side brace diameter must be less than or equal to the chord width
• The connection interval must be greater than the ladder bar spacing
• Ladder bar spacing must be greater than three times the top brace size
• If the section is too small, lacing may not be drawn

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting a Straight Truss
Inserting a Curved Truss

Creating a Lighting Position Object
As described in “Creating Lighting Positions” on page 856, you can create lighting position geometry by placing a 
Spotlight lighting pipe, ladder, or truss object. You can also create your own geometry for conversion. At a minimum, a 
lighting position object requires at least a 2D component; it also requires a 3D component to display correctly in 3D 
views. If a 2D only or 3D only object is selected when you execute the command, you will be prompted to confirm that 
you wish to proceed with the conversion.

http://www.youtube.com/watch?v=BXXtnSSZGlI 
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When you have placed the geometry in the drawing, convert it to a lighting position object. Choose whether to create a 
symbol from the geometry, or to simply embed the geometry in the object. If you embed the geometry, it is easier to 
edit later. If you create a symbol, it is available in the Resource Browser, where you can easily insert it into the drawing 
again with the Lighting Position tool, or reference or export it to other files. For more information about symbols, see 
“Symbols” on page 237.
To convert lighting position geometry to a lighting position object:

1. To convert multiple objects to a single lighting position, select Modify > Group and group the objects first.
2. Select the geometry.
3. Select Spotlight > Object Conversion > Convert to Light Position.
4. The Enter Text dialog box opens; specify the name of the lighting position, and then click OK.
5. An alert dialog box opens; click the desired option.

• Create Symbol converts the selected object to a lighting position symbol that remains inserted in the drawing. 
(If multiple items were selected for conversion, each object is converted one at a time.) The symbol is 
automatically named using the lighting position name followed by -Sym (as in FOH-Sym), and it becomes the 
active symbol in the Resource Browser.

• Use Geometry converts the selected object to a lighting position object. (If multiple items were selected for 
conversion, each object is converted one at a time.)

6. If you created a symbol, you can use the Lighting Position tool to insert additional lighting positions with the 
same symbol, if required. See “Inserting Lighting Positions” on page 866.

Once a lighting position is created, lighting instruments can be placed on it. See “Adding Lighting Instruments” on 
page 873.

Editing Lighting Position Geometry
If the lighting position object is not a symbol, you can edit it from the Object Info palette.
To edit lighting position geometry:

1. Select the lighting position object, and click Edit Position Geometry from the Object Info palette. Alternatively, 
right-click (Windows) or Ctrl-click (Mac) on the object, and select Edit from the context menu.

2. The editing window opens, containing the object to be edited. A colored border around the drawing window 
indicates that you are in an editing mode. Edit the object as needed, and then click the Profile Exit button in the 
top right corner of the drawing window to update the object and return to the normal drawing mode.

To replace the lighting position geometry with an existing symbol:
Select the lighting position object, and enter the name of the symbol in the Symbol Name field in the Object Info 
palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Lighting Positions

Inserting Lighting Positions 
Use the Lighting Position tool to insert a lighting position symbol from the Resource Browser. This can be a symbol 
that you have created, or it can be one of the symbols imported from the libraries included with the Vectorworks 
Spotlight software ([Vectorworks]\Libraries); see “Resource Libraries” on page 219.
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To insert a lighting position symbol:

1. Click the Lighting Position tool from the Spotlight tool set.
2. Select the desired lighting position symbol from the Resource Browser and choose Resources > Make Active to 

make it the active symbol definition. Alternatively, double-click on the symbol to activate it.
3. Click in the drawing to insert the active lighting position symbol definition, and then click again to set the lighting 

position rotation.
If you insert the lighting position symbol without first clicking on the Lighting Position tool, the symbol is 
inserted by the Symbol Insertion tool. However, the lighting position functionality will not be present. When 
correctly inserted, the Object Info palette displays “Lighting Position” for the selected lighting position.
Once the Lighting Position tool has been selected, it remains selected by default so that lighting positions can be 
repeatedly inserted. To place non-lighting position symbols after placing lighting positions, switch to the Symbol 
Insertion tool.

4. A different type of lighting position can be placed by changing the active symbol definition and continuing to use 
the Lighting Position tool.

The lighting position object parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

 

Parameter Description

Z (Height) For 3D lighting positions, specifies the height
Rotation Specifies the rotation angle of the lighting position
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using options 
on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 and 
“Formatting Text” on page 389.

Position Name Specifies the name of lighting position symbol
Location Optionally, specifies the location for use in reports
Show Name Displays the Position Name on the drawing
Insert Position 
Summary

Inserts an instrument summary, filtered for the current lighting position; see “Creating an 
Instrument Summary for a Lighting Position” on page 966

Starting Number Specifies the starting number for instrument auto-numbering
Increment Specifies the increment for auto-numbering instruments
Numbering Direction Specifies the page relative numbering direction
Multi-Circuit 
Numbering

Specifies the multi-circuit numbering format for multi-circuit instruments:
• AlphaNum: Numbers the multicircuit instruments with A1, A2, A3...
• Num.Alpha: Numbers the multicircuit instruments with 1.A, 1.B, 1.C...
• Num.Num: Numbers the multicircuit instruments with 1.1, 1.2, 1.3...

 Auto Number Select to automatically number instruments and multi-circuit instruments on the lighting 
position
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The Z value of a lighting position can only be specified for lighting positions with 3D geometry. However, the Z 
value can be specified for the lighting instruments placed on any type of lighting position (2D, 3D, or hybrid). A 
lighting position created from a symbol or plug-in object automatically assumes the Z value of the original object.
If a lighting position is copied, it is automatically renamed; any associated duplicated lighting instruments are 
associated with the new lighting position. Deleting a lighting position does not delete the associated lighting 
instruments.
If instruments are moved to a different lighting position, the lighting position name is automatically updated for 
the instruments and the Z-height of the instruments is calculated automatically based on the lighting position 
Z-height.

~~~~~~~~~~~~~~~~~~~~~~~~~
Instrument Numbering
Creating Lighting Positions

Setting Up Instrument Label Legends
Label legends specify the labels and label formatting for lighting instruments on the light plot. Multiple label legends 
can be defined and then selectively applied to different instruments. The active label legend is applied to instruments as 
they are placed, or a label legend can be selected for existing instruments from the Object Info palette. Label legends 
are 2D screen plane objects. (See “Planar Modes of 2D Objects: Screen Plane and Layer Plane” on page 152).

Click here for a video tip about this topic (Internet access required).

Label Classes
Each label is automatically placed in its own Label class. This allows the labels to be globally turned on and off. For 
example, if the designer is printing the light plot for an electrician, the “Label-Purpose” class of labels can be hidden so 
that only electrical information labels are shown.
The labels display the lighting instrument object information. The instrument Object Info palette also shows this 
information (see “Lighting Instrument Properties” on page 877).

Using the Label Legend Manager
The Label Legend Manager controls the setup and modification of the instrument label styles. Select Spotlight > Label 
Legend > Label Legend Manager to set up the legends for the light plot. The Label Legend Manager dialog box 
opens.
Click to show/hide the parameters.

Symbol Name If the lighting position object is symbol-based, displays the name of the symbol used to 
create the lighting position. If the lighting position object is not symbol-based, enter the 
name of an existing symbol to replace the current geometry with the symbol.

Edit Position 
Geometry

When the lighting position is not symbol-based, edits the geometry of the lighting position 
object; see “Editing Lighting Position Geometry” on page 866

Parameter Description

http://www.youtube.com/watch?v=iqP_kiXZ83c
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Creating Label Legends
To create a new legend:

1. In the Label Legend Manager dialog box, click Add. 
The Add New Legend dialog box opens. Select the labels for placement and specify their attributes. Indicate the 
instrument symbol to use when formatting the label legend, and select whether the legend rotates with the 
instrument.

Click to show/hide the parameters.

Parameter Description

Active To activate the default legend for lighting instruments, select the label legend and click 
in the Active column. The active legend is indicated with a check mark.
Any new instruments created will use the active legend as the default label legend; the 
legend name is displayed in the instrument Object Info palette, and can be changed at 
any time (see “Changing the Instrument Label Legend” on page 885).

Legend Name Lists the file’s current legends
Add Creates a new label legend and specifies the labels to include, as well as their attributes 
Remove Deletes the selected label legend; the active label legend cannot be removed
Edit Fields Edits the labels included in the selected legend, along with their attributes 
Edit Layout Specifies the position of the labels in relation to an instrument 

Parameter Description

Legend Name Provide a name for the new legend by typing it in the Legend Name field. A name must 
be entered before closing the dialog box.

Attributes
Use Click to select an item to appear in the label legend. A check mark indicates the label is 

included. Click again to remove the label from use.
Attribute Lists the possible labels that can be selected for inclusion in the label legend
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Custom container symbols can be added to the list of available containers. Draw a container object, and then click 
Modify > Create Symbol. Enter a name for the container; click OK. In the Move Symbol dialog box, specify the 
location of the Containers folder and click OK. The symbol is added to the list of available containers. Any 
symbol can be placed in the containers folder and used as a label container. The pre-defined container symbols can 
also be edited and customized.
Container attributes can be determined by the label text or lighting device; see “Lighting Device Setup” on 
page 95.

2. When all the label items and attributes have been specified for the legend, click OK. The new legend name 
displays in the Legend Name list in the Label Legend Manager dialog box.

3. Once the legend has been created, it needs to be formatted. See “Formatting the Label Legend” on page 871.
~~~~~~~~~~~~~~~~~~~~~~~~~
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Editing Label Legends
To edit a legend:

1. In the Label Legend Manager dialog box, select the legend, and then click Edit Fields. The Edit Label Legend 
dialog box opens. See “Creating Label Legends” on page 869 for a description of the legend parameters.

Right_Reading For each label, select whether it will always be right-reading or allowed to rotate with the 
instrument. A check mark indicates the field is right-reading; deselect to allow the field to 
rotate with the instrument.

Container Type Select the container for each label by clicking in the Container field until the desired 
container is displayed.

Lighting Instrument 
Layout Symbol

Specifies a symbol to use for label placement when editing the label layout; by default, 
the active symbol is selected. Click Choose to open the Choose an Instrument Symbol 
dialog box, where a different symbol can be selected from the current file’s resources.

Non-Rotating Specifies whether the label legend rotates with the instrument, or remains stationary as 
the instrument rotates

Parameter Description

Right Reading selected Right Reading deselected

Non-Rotating selectedNon-Rotating deselected
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To identify which legend needs to be edited before opening the Label Legend Manager, Right-click (Windows) or 
Ctrl-click (Mac) on the lighting device and select Locate Label Legend in Resource Browser from the context 
menu.
The legend name displays at the top of the dialog box, and cannot be changed from here.
To rename a label legend, locate it in the Resource Browser in the Label Legends folder of the current file 
(navigate there manually or use the Locate Label Legend in Resource Browser context menu command). When 
the label legend is highlighted, Right click (Windows) or Ctrl-click (Mac) and select Resources > Rename. (Any 
existing instruments that use the old legend name will lose their labels.)

2. The currently selected label items have a check mark next to the label name. Select any additional label items to 
appear in the legend by clicking in the Use column. To deselect a label item, click the associated check mark in the 
Use column; the check mark is removed.

3. Lighting Instrument Layout Symbol displays the name of the symbol currently used in the label legend. To use a 
different symbol, click Choose to open the Choose an Instrument Symbol dialog box. Select a new reference 
symbol from the resources present in the drawing and click OK.
When you change the instrument’s reference symbol, the symbol’s appearance on the drawing will not change. 
However, the change will be reflected within the label legend; the name shown on the Edit Label Legend dialog 
box will update, as will the appearance of the symbol in the layout editor (see “Formatting the Label Legend” on 
page 871).

4. Click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
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Formatting the Label Legend
Once a label legend has been created, format it so that the labels are displayed in specific positions. The labels, 
containers, and layout symbol are selected when creating the label legend; see “Creating Label Legends” on page 869.
To format the label legend:

1. In the Label Legend Manager dialog box, select the legend, and then click Edit Layout. 
Alternatively, Right-click (Windows) or Ctrl-click (Mac) on a lighting device and select Locate Label Legend in 
Resource Browser from the context menu. The label legend associated with that lighting device is highlighted in 
the Resource Browser. Right-click (Windows) or Ctrl-click (Mac) on the highlighted label legend, and select Edit 
from the context menu. The Edit Symbol dialog box opens. Select 2D Component and click Edit. (See “Editing 
Symbol Definitions” on page 247 for additional information about the Edit Symbol dialog box.)
The Edit Symbol window opens, where the default position and format of the labels is specified for instruments 
that use this label legend. The name of the current label legend is displayed at the top of the Edit Symbol window. 
The instrument used for the layout is either the symbol selected in Lighting Instrument Layout Symbol or the 
active symbol at the time the legend was created.
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2. The labels selected for the legend display to the left of the instrument diagram. Drag each label to its position on or 
around the instrument. The label’s formatting can be set by selecting the label, and then using the Object Info 
palette or the Text menu to select the label’s font, size, style, and justification. The label stacking order can be 
changed with the Modify > Send commands; the instrument is part of the stacking order. Change the color of the 
label by selecting it and applying a solid pen color from the Attributes palette. 
If necessary, the labels placed outside the bounding box of the instrument are adjusted so they are always placed at 
an absolute distance from the instrument. For example, a label placed six inches in front of an instrument always 
appears six inches in front of any instrument to which the label is applied. The position of a label placed upon an 
instrument is scaled so it is in the same relative position whether the instrument is larger or smaller than the one 
used for formatting. A label placed at the center of the instrument is always at the center.

3. When the labels are set, click Exit Symbol in the upper right corner of the window to return to the drawing. The 
formatting and position of the labels applies to all instruments that use this legend.

Repositioning Labels
Labels should normally be repositioned through the Label Legend Manager. On a complex light plot, however, a label 
can be hidden by the nearest object. If that occurs, click on the instrument to select it, and then click on the instrument 
label control point, located at the center of the label, with the Selection tool. Drag the label to another location. This 
one-time repositioning does not affect the label legend.

 

Name of legend
currently being

edited

Drag labels 
into position

Labels available
for instrument

Fresnel color information obscured 
by other lighting instrument

Fresnel color information now visible

Label control point
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Creating a Label Legend from an Existing Instrument
If labels have been repositioned and the arrangement is suitable to use as a label legend for other instruments, you can 
create a new label legend from a selected lighting instrument’s legend. The current label arrangement and instrument 
rotation are used for the new label legend.
To create a label legend based on an existing instrument:

1. Select the lighting instrument. The instrument must already have a label legend attached.
2. Select Spotlight > Label Legend > Create Label Legend from Instrument.
3. Provide a unique name for the new label legend. 

By default, the instrument’s existing label legend is appended with a -1 (or with the next available number) as a 
suggested name.

4. Click OK.
The new label legend is created, and it is automatically assigned to the selected instrument. The instrument 
specified in Symbol Name in the Object Info palette of the selected instrument becomes the representative 
lighting device for the label legend.

Importing Label Legends from Another File
Label legends from another file created with the Vectorworks Spotlight product can be imported into the current file. 
Import the Label Legends symbol folder contents from the original file into the new file with the Import command in 
the Resource Browser; place the legends into the Legends folder. The imported label legends are listed in the Label 
Legend Manager. See “Importing a Symbol or Symbol Folder” on page 252.
~~~~~~~~~~~~~~~~~~~~~~~~~
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Adding Lighting Instruments
Instruments can be inserted from the thousands of symbols provided in symbol libraries, or created as custom symbols 
that you convert into lighting instruments.

• In the Resource Browser, either select one of the lighting symbols from the symbol libraries or one of the symbols 
you have created in this file or a Favorites file. Insert the symbol with the Lighting Instrument tool to place a 
lighting instrument object on the light plot. This method is described in “Inserting Instruments” on page 875.

• Convert custom geometry to a lighting instrument. This method is described in “Creating a Lighting Instrument 
Symbol” on page 874.
The instrument symbols from the libraries included with the Vectorworks Spotlight product contain all the 
required attribute information. When creating or using your own symbols with the Vectorworks Spotlight product, 
see “Lighting Instrument Specifications” on page 890.
An existing lighting instrument with specific parameters can be saved as a red symbol (a preformatted resource). 

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Lighting Instrument Symbol
Inserting Instruments
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Creating a Lighting Instrument Symbol 
Vectorworks Spotlight provides hundreds of lighting symbols; however, it is not necessary to use only these 
pre-defined symbols. Create a Spotlight instrument out of a currently selected symbol—once the symbol is converted 
to an instrument, the instrument functionality is present and the label legend is attached. 

See “Lighting Instrument Specifications” on page 890 for more information and restrictions on using custom 
symbols for lighting instruments, and information on attaching the Light Info Record.

To create a lighting instrument:
1. Convert the object to a symbol by selecting Modify > Create Symbol. 

Symbols can have a separate 2D and 3D representation.The lighting instrument object automatically uses the 
appropriate portion of the symbol. At a minimum, the symbol must have at least a 2D component; it also requires 
a 3D component to display correctly in 3D views. For information on symbols, see “Creating New Symbols” on 
page 239.

2. Select the symbol or symbols.
3. Select Spotlight > Object Conversion > Convert to Instrument.

The selected symbol is converted into a lighting instrument that remains inserted in the drawing. The active label 
legend, if any, is applied to the instrument(s); see “Using the Label Legend Manager” on page 868 for more 
information. The instrument properties can be changed through the Object Info palette; some of the instrument 
parameters may need to be entered.
If creating multi-circuit instruments, first create each instrument’s symbol (see “Multi-circuit Instrument 
Specifications” on page 894). Then insert the multi-circuit instruments as described in “Instrument and Accessory 
Specifications” on page 890.
Select the instrument from the Resource Browser as an active symbol definition and use the Lighting Instrument 
tool to insert again if required (see “Inserting Instruments” on page 875).

Creating a Preformatted Lighting Resource
Any instrument that has been inserted from a library or converted from a symbol can be saved as a red symbol. Its 
appropriate default values are retained, and when inserted from the Resource Browser, the instrument picks up the 
lighting position and active label legend. For more information on red symbols, see “Symbol Types” on page 237.
To create a lighting instrument resource with pre-defined parameters:

1. Select a current instrument and ensure that all its parameters have been specified as desired. 
In the Object Info palette, set the Use Legend parameter to None and delete the lighting position (Position 
parameter). Set the Z height of the instrument to 0.
Set a label legend name to use a specific label legend, rather than the current one, upon insertion. If the label 
legend is not in the file at the time of symbol insertion, it is automatically imported. 

2. With the instrument selected, select Modify > Create Symbol.
The Create Symbol dialog box opens. Provide a name for the new symbol. For information on symbols, see 
“Creating New Symbols” on page 239.

3. Select Convert to Plug-in Object, and then click OK.
4. Click OK to create the symbol. 

If the Move dialog box opens, specify the location of the resource.
5. The lighting symbol is saved in the Resource Browser as a red symbol. When the symbol is inserted, it functions 

as a plug-in object and the saved parameters are retained.
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~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Instruments
Editing Lighting Instruments
Spotlight Setup
Lighting Instrument Specifications

Inserting Instruments
Use Lighting Instrument tool to insert an existing instrument symbol. This can be a symbol that you have created, 
located in a Favorites file or the current file, or it can be one of the symbols imported from the libraries included with 
the Vectorworks Spotlight software ([Vectorworks]\Libraries); see “Resource Libraries” on page 219. When the 
Vectorworks Spotlight product is installed, lighting instrument symbols are also provided as default content. Default 
content is automatically imported into the file and displays in the Resource Browser.
For information on importing symbols, see “Accessing Existing Resources” on page 229.

To insert a lighting instrument:

1. From the Resource Browser, double-click on the instrument symbol to insert. This automatically activates the 
symbol and selects the Lighting Instrument tool from the Spotlight tool set.
Alternatively, select the instrument symbol from the Resource Browser and choose Resources > Make Active to 
make it the active symbol definition. The Lighting Instrument tool is automatically selected.

2. Click once to insert the active instrument symbol definition, and then again to determine the instrument rotation. 
By default, the active Label Legend is applied to the instrument. 

If an instrument symbol is accidentally inserted by the Symbol Insertion tool, the instrument functionality will 
not be present. When correctly inserted, the Object Info palette displays “Lighting Device” for the selected 
instrument.
Once the Lighting Instrument tool has been selected, it remains selected by default so that instruments can be 
repeatedly inserted.

3. Place instruments on a lighting position to add them to that lighting position and allow auto-numbering. A 
different type of instrument can be placed by double-clicking on another instrument symbol definition and 
continuing to use the Lighting Instrument tool.
Once instruments have been inserted, they continue to automatically associate with the nearest lighting position 
within a specified Pick Radius set in the Spotlight preferences. To avoid instruments changing their lighting 
position association as they are moved, disable automatic positioning.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Lighting Instruments
Setting Up Instrument Label Legends
Inserting Lighting Positions
Spotlight Setup
Creating a Lighting Instrument Symbol
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Inserting Multi-circuit Instruments 
Lighting instruments can be inserted as multi-circuit instruments that act as a group while retaining their individual 
parameters and labels.
As an example, a three-cell Cyc light consisting of different colors can be inserted as a single multi-circuit instrument 
that can be easily positioned. However, each light in the multi-circuit instrument retains its own information, which is 
displayed in its label legend. When generating paperwork, each cell of the instrument is listed individually.
The Lighting Instrument tool inserts multi-circuit instruments.

The Spotlight > Object Conversion > Convert to MultiCircuit command is no longer required when inserting 
multi-circuit instruments, although it is still available.

To insert a multi-circuit instrument:

1. Create a multi-circuit symbol out of instrument symbols (left, center, and right components), or locate a 
multi-circuit symbol in the Resource Browser.
See “Creating New Symbols” on page 239.

The multi-circuit symbol must consist only of other symbols to be properly inserted as a multi-circuit instrument. 
Otherwise, the Lighting Instrument tool treats it as a single circuit instrument.

2. Click the Lighting Instrument tool from the Spotlight tool set.
3. Select Resources > Make Active to make the multi-circuit symbol the active symbol definition. Alternatively, 

double-click on the symbol to activate it.
4. Click once to insert the active multi-circuit instrument symbol definition, and then again to determine the 

multi-circuit instrument rotation. By default, the active Label Legend is applied to each part of the multi-circuit 
instrument. The multi-circuit instrument is numbered according to the lighting position settings.

The Spotlight > Object Conversion > Convert to MultiCircuit command can add a selected instrument to the 
multi-circuit instrument. To undo a conversion to a multi-circuit instrument, select the multi-circuit instrument and 
then the Convert to MultiCircuit command.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Lighting Positions
Inserting Instruments

Multi-circuit symbol

The instruments retain their individual 
information but move as a single unit
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Editing Lighting Instruments
Once lighting instruments have been inserted (normally, on a lighting position), many of the parameters of one or more 
selected instruments can be changed from the Object Info palette and Lighting Device dialog box, and the color, 
numbering, alignment, and other options can be controlled.

To select all lighting instruments focused on a particular focus point, right-click (Windows) or Ctrl-click (Mac) on 
the focus point and select Select Focused Lighting Devices from the context menu. The focus point and any other 
selected objects are deselected automatically to facilitate faster editing of the lighting instrument(s). 

~~~~~~~~~~~~~~~~~~~~~~~~~
Lighting Instrument Properties
Changing Instrument Properties
Advanced Light Properties
Lighting Instrument Color
Instrument Numbering
Replacing Instruments
Changing the Instrument Label Legend
Refreshing Instrument and Light Position Data
Aligning Instruments
Find and Modify

Lighting Instrument Properties
Instrument (or accessory) parameters can be viewed and edited in the Object Info palette.
The parameters that display on the Shape tab of the Object Info palette depend on the settings made in Spotlight 
preferences; see “Specifying Lighting Device Parameter Display” on page 98.
Double-click on a lighting device, or click Edit from the Object Info palette or the context menu of one or more 
selected devices. The Lighting Device dialog box opens, facilitating instrument parameter modifications; see 
“Changing Instrument Properties” on page 880. Advanced light properties, which include turning the associated light 
source on, are available by editing the light source embedded within the instrument; see “Advanced Light Properties” 
on page 881.
For a custom instrument symbol without an information record attached, enter the required instrument object 
parameters (see “Attaching the Light Info Record and Light Info Record M” on page 893). An entry is not required for 
every field.
Click to show/hide the parameters.

 

Parameter Description

XYZ/IJK 
Location/
Rotation

Changes the instrument’s location and rotation; the instrument labels rotate with the instrument 
unless Right-Reading was selected in the Label Legend Manager (see “Formatting the Label 
Legend” on page 871). In a 3D view, if an instrument is associated with a focus point, the 
instrument, along with any accessories, rotates automatically so that it points to the focus point.

Edit Opens the Lighting Device dialog box, for editing the parameters of one or more lighting 
devices

Device Type Displays the type of object that is selected; normally, instruments are Light device types 
(Moving Light, Device, Practical, SFX, Power, and Other are also considered Light types). 
Accessories such as color frames, barn doors, and top hats are Static Accessory types; 
accessories that require a control channel, such as color scrollers, are Accessory types.
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Instrument Type Displays the specific type of lighting instrument
Wattage Indicates the power consumed by the instrument
Purpose Specifies the purpose for using
Position Displays the name of the lighting position 
Unit Number Identifies the instrument location on the lighting position
Color Specifies the gel color number according to manufacturer code, RGB values, color name from 

the file, or web (hex) codes; when the light associated with the instrument is turned on, Color 
specifies the actual light color. Use + between color numbers to indicate combinations of two or 
more colors. See “Lighting Instrument Color” on page 882
The color setting can affect the display of the lighting device color, depending on the Spotlight 
preferences. See “Lighting Device Setup” on page 95

Dimmer Specifies the dimmer or DMX address number of the instrument
Channel Specifies the channel number of the instrument
Address Specifies the absolute address of the instrument. If Automatically assign Universe is selected 

in the Spotlight Preferences dialog box, this field is used to automatically populate the Universe 
and U Address fields.

Universe Indicates the DMX group of the dimmer; this is set automatically if the Spotlight file is set up to 
assign the universe. See “Universe Assignment in Vectorworks Spotlight” on page 99

U Address When the universe is automatically assigned, displays the address assigned within the universe
Circuit Number Indicates the circuit number where instrument is plugged in
Circuit Name Specifies the name of bundled circuit group
System Specifies the letter describing the control system (Lightwright-compatible parameter)
User Field 1 – 6 Provides user-defined fields; use these extra fields to keep track of any desired data (see 

“Specifying Lighting Device Parameter Display” on page 98)
Num Channels Identifies the number of control channels used by the instrument
Frame Size Indicates the dimensions of the color cut
Field Angle Sets the field angle of the instrument’s light beam
Field Angle 2 Specifies the second field angle for an elliptical light source
Beam Angle Sets the beam angle of the instrument’s light beam
Beam Angle 2 Specifies the second beam angle for an elliptical light source
Weight Specifies the instrument weight
Gobo 1 Indicates the gobo texture number for the first gobo

Specifying the gobo texture by clicking Edit in the Object Info palette provides a graphical 
method of selecting textures from the default content

Gobo 1 Rotation Sets the rotation angle of gobo texture 1
Gobo 2 Indicates the gobo texture number for the second gobo
Gobo 2 Rotation Sets the rotation angle of gobo texture 2
Gobo Shift Adjusts the position of the instrument gobos to the front or rear

Parameter Description
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For instruments and accessories, do not provide a name on the Data tab. The instrument or accessory Unique ID 
Number (UID) is automatically entered and must be used as the instrument or accessory name.

~~~~~~~~~~~~~~~~~~~~~~~~~
Changing Instrument Properties
Editing Lighting Instruments

Mark Provides a user-defined label (Lightwright-compatible parameter)
Draw Beam Select to draw an accurate wireframe representation of the light beam; the light beam is drawn 

based on the instrument parameters, and can be used to check whether the stage and focus areas 
have been adequately lit (see “Drawing Light Beam Representations” on page 899). Spotlight 
setup can globally specify the appearance and display of the elements in the light beam (angles 
and centerline).

Draw Beam as 
3D Solid

Generates a light beam that appears solid when rendered

Use Vertical 
Beam (Focus 
Point required)

By default, draws the wireframe beam in a vertical orientation when possible, when either 
Draw Beam or Draw Beam as 3D Solid is selected. When deselected, the beam is usually 
drawn in a horizontal orientation.

Show Beam at In a 2D view, select whether to draw the beam as it crosses the focus point, at the falloff 
distance as projected through the focus point, or in both areas

Replace with 
Active Symbol

Replaces the selected instrument with the current active symbol (see “Replacing Instruments” 
on page 884)

Refresh Labels Refreshes instrument labels if label changes have been made 
Falloff distance Specifies how far the wireframe light beam is drawn beyond the focus point; the Focus 

Instruments command sets this value to the distance between the focus point object and 0
Lamp Rotation 
Angle

Indicates the rotation angle of the virtual elliptical light source, from 0 to 90°

Shutter 
parameters

Controls the angle and depth of top, left, right, and bottom shutter cuts. Each shutter is located 
at 90º intervals around the lighting instrument, and can be adjusted +/- 45º. The shutter depth 
ranges from 0 to 100%, with 100% cutting through the center of the light source.

Symbol Name Displays the name of the symbol used to create the instrument or accessory
Use Legend Select the label legend to apply from the list of label legends in the file (see “Using the Label 

Legend Manager” on page 868)
Automatically 
Flip Front & 
Back Legend 
Text

Select to mirror the label legend along the X axis of the lighting instrument

Automatically 
Flip Left & Right 
Legend Text

Select to mirror the label legend along the Y axis of the lighting instrument

Focus Specifies the focus point for the lighting instrument. The focus point must be defined first (see 
“Focusing Instruments” on page 897). 

Set 3D 
Orientation

Specifies the X/Y position of the instrument at the hanging point, for 3D views only

Parameter Description
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Specifying Lighting Device Parameter Display
Spotlight Setup
Advanced Light Properties

Changing Instrument Properties
To edit the properties of a lighting instrument or accessory:

1. Select one or more lighting instruments.
2. From the Object Info palette or the context menu, select Edit, or simply double-click a single instrument selection.

The Lighting Device dialog box opens. The lighting device parameters are described in “Lighting Instrument 
Properties” on page 877. Only the parameters which are different are described here.

Click to show/hide the parameters.

3. Click the Light Information tab.
Click to show/hide the parameters.

Parameter Description

Position Lists the lighting positions in the file; select one for the lighting instrument, or select the ellipsis 
(...) to create a new lighting position name 

If a new position is named, a lighting position of that name must then be created in the file
Color Specifies the gel color number according to manufacturer code, RGB values, color name from the 

file, web (hex) codes, color combination, or the color selected from the color box (see “Applying 
Colors” on page 1132). The selected color is added to the file’s active document color palette, and 
can be specified for a selected lighting device by its name.
When the light associated with the instrument is turned on, Color specifies the actual light color 
(see “Lighting Instrument Color” on page 882).
The color setting can affect the display of the lighting device color, depending on the Spotlight 
preferences. See “Lighting Device Setup” on page 95.

Focus Lists the focus points in the file; select one for the lighting instrument, or select the ellipsis (...) to 
create a new focus point name

If a new focus point is named, a focus point of that name must then be created in the file
Use Legend Select the label legend to apply from the list of label legends in the file (see “Using the Label 

Legend Manager” on page 868)
Symbol 
Name

Lists the instrument or accessory symbols from the current file’s resources; select a different 
symbol for the lighting instrument or accessory from the resources imported into the file

Get 
Resource

Opens the Import External Resource dialog box; select an instrument or accessory symbol from 
either the default content or the current file’s content

Previous/
Next

When more than one device is selected, displays the parameters of the previous or next device in 
the selection

Apply to All When more than one device is selected, and the parameters of the first device in the selection are 
displayed, applies only the parameters that have been modified to all the devices in the selection
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4. Click the Shutters tab to set the shutter cut information.
Specify the depth and angles for the top, left, right, and/or bottom shutters. Each shutter is located at 90º intervals 
around the lighting instrument, and can be adjusted +/- 45º. The shutter depth ranges from 0 to 100%, with 100% 
cutting through the center of the light source.

5. Click the User Data tab to edit user field value information.
User data fields and any default values display here and the default values can be edited by selecting a field name 
and entering the new value in Value.

6. Click OK to apply the changes to the selection.
The properties of one or more selected devices or objects can also be edited from the Shape tab of the Object Info 
palette (see “Lighting Instrument Properties” on page 877). 
A selected lighting device or a selection of devices can be cut, copied, and pasted with the Edit menu commands. See 
“Editing Objects” on page 997 for more information on the basic editing commands.
~~~~~~~~~~~~~~~~~~~~~~~~~
Lighting Instrument Properties
Advanced Light Properties
Drawing Light Beam Representations
Editing Lighting Instruments
Spotlight Setup
Resource Libraries

Advanced Light Properties
More advanced control over the lighting instrument properties is possible by editing the light source embedded within 
the instrument. Turn the lighting instrument on and off by editing the embedded light.
To edit the embedded light source:

1. Select the lighting instrument(s).
2. From the lighting instrument context menu, select Edit Light.

The Light Properties dialog box opens. These parameters offer full control over the light source, and are described 
in “Light Source Properties” on page 1578. The Renderworks product is required for certain parameters.
Various light parameters are disabled, because they are controlled by the lighting device object instead.
Select a light Kind of Custom to associate a light distribution file with the light. Note that light distribution files 
and theatrical lighting manufacturers may not specify output in the same way.

3. To enable the light properties, turn the light on in the Properties dialog box or from the Visualization palette, or 
right-click (Windows) or Ctrl-click (Mac) on the instrument and select Turn On from the context menu.

~~~~~~~~~~~~~~~~~~~~~~~~~
Lighting Instrument Properties
Light Source Properties

Parameter Description

Get Data from 
Symbol

Obtains the light information from the Light Info record attached to the symbol definition

Get Resource Opens the Import External Resource dialog box; select a gobo texture symbol from either the 
default content or the current file’s content (see “Inserting Gobo Projections” on page 973)
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Drawing Light Beam Representations
Editing Lighting Instruments

Lighting Instrument Color
The gel color of a lighting instrument is specified by the Color parameter in the Object Info palette or Lighting Device 
dialog box. Define the color by one of these methods.

• RGB values separated by commas (such as 191, 49, 26); values must be between 0 and 255 
• Manufacturer color codes, by manufacturer name or abbreviation and color number (such as Gam 650, G 650, 

G-650, or G650)
• Name of the color as specified in the file’s color palettes (see “Applying Colors” on page 1132)
• Web hex values prefixed by the pound sign (such as #003366)
• Combinations of two or more colors (such as R46+R10); the resultant calculated color combination displays, just 

as when combining actual color filters. Invalid single colors are treated as white when calculating color 
combinations.

Acceptable manufacturer names and abbreviations are shown in the following table.

To draw a colored light beam for the lighting instrument, see “Drawing Light Beam Representations” on page 899.

The color setting can affect the display of the lighting device color, depending on the Spotlight preferences. See 
“Lighting Device Setup” on page 95.

Manufacturer Product Name Abbreviation

Rosco Roscolux R, X
Rosco Supergel R, S, RS
Rosco E-Color E, RE
Rosco CalColor R, RC
Rosco Cinegel R, RCG
Rosco Cinelux R, RCL
Rosco Storaro R, RSO
Lee Filter Lee L
Gam Gam G
Apollo Apollo A, AP
GoboMan GoboMan GM
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~~~~~~~~~~~~~~~~~~~~~~~~~
Lighting Instrument Properties
Editing Lighting Instruments
Drawing Light Beam Representations
Spotlight Setup

Instrument Numbering
Instruments can be numbered automatically according to lighting position order, or manually according to specified 
settings.

Numbering Instruments Automatically
Instruments can numbered according to the lighting position automatic numbering parameters).
To automatically number the instruments on a lighting position:

1. Select the lighting position.
2. From the Object Info palette, specify the Starting Number, Increment, Numbering Direction, and, for 

multi-circuit instruments, the Multi-Circuit Numbering. 
3. Click Auto Number.

The instruments are automatically numbered. The Unit Number in the Object Info palette of a selected lighting 
instrument displays its number, which can be changed to override the automatic number.
To display the numbers on the drawing, specify a label legend that includes the Unit Number in the label. See 
“Setting Up Instrument Label Legends” on page 868.

To automatically number all instruments assigned to a lighting position:
Select Spotlight > Auto Number Positions to globally automatically number the lighting instruments in the 
drawing based on the settings in each lighting position.
If lighting positions are selected when the command is activated, only the instruments on the selected lighting 
positions are numbered.

~~~~~~~~~~~~~~~~~~~~~~~~~
Numbering Instruments Manually
Inserting Lighting Positions
Editing Lighting Instruments

Numbering Instruments Manually 
Instruments do not have to be numbered according to the lighting position’s automatic numbering feature. The 
Number Instruments command provides a method of numbering instruments by unit number and other parameters 
that automatically increment. In addition, the command can automatically increment several other instrument 
parameter fields.

Numbering Selected Instruments
To number selected instruments manually:

1. Select the instrument(s) to be numbered.
2. Select Spotlight > Number Instruments. 

The Number Instruments dialog box opens.
Click to show/hide the parameters.
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3. Click OK.
The selected instruments are numbered, and any fields automatically specified, in the selected direction.

Numbering Instruments by Clicking
To number instruments manually in the order they are selected:

1. Select Spotlight > Number Instruments.
2. Specify the field and numbering parameters as described in “Numbering Selected Instruments” on page 883.
3. In the Direction list, select Manual (the manual direction is selected automatically if no instruments were 

selected). 
4. Click OK, and click the instruments to be numbered one by one. To stop numbering instruments, click in an empty 

area of the drawing.
~~~~~~~~~~~~~~~~~~~~~~~~~
Instrument Numbering
Editing Lighting Instruments

Replacing Instruments 
An individual instrument can be replaced by another type of instrument by choosing the new active symbol in the 
Resource Browser, and then selecting Replace with Active Symbol in the Object Info palette.
However, this process would be time-consuming for multiple instruments. By using the Replace Instrument 
command, all the instruments of a particular type can easily be replaced with another type of instrument. Alternatively, 
a selection of instruments can be replaced with another type of instrument. 

Replacing All Instruments of One Type
To replace all the instruments of one type:

1. Select Spotlight > Replace Instrument. 
The Replace Instruments dialog box opens.

2. Click Replace All, and then specify the instrument type to be replaced by selecting it from the list.

Parameter Description

Field Name Select the field name to automatically increment
Universe is not available when automatic universe assignment is enabled; see “Universe 
Assignment in Vectorworks Spotlight” on page 99.

Prefix/Start#/ 
Suffix/
Increment

Specify a prefix for the numbering if desired, the starting number, an optional suffix, and the 
increment value. For example, a Starting Number of 2, Increment of 2, and Suffix of A 
numbers the instruments as follows: 2A, 4A, 6A, and so on.

Use # Chans Instead of specifying a constant increment value, the increment can be based on the number of 
channels assigned to the instrument 

Direction The numbering direction is relative to the page; click the desired numbering direction. Select 
Manual to number the instruments by clicking, instead of by selection; see “Numbering 
Instruments by Clicking” on page 884.

Multi-Circuit 
Numbering

Select the numbering format for multi-circuit instrument numbering; these are identical to the 
selections made when specifying automatic numbering for multi-circuit instruments (see 
“Inserting Lighting Positions” on page 866)
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3. In the Symbol Folders list, select the location of the replacement instrument type. Select the specific instrument 
type from the Symbols list.

4. Click OK. All instruments of the type specified are replaced with the selected instrument type.

Replacing Selected Instruments
To replace selected instruments:

1. Select the instruments to be replaced.
2. Select Spotlight > Replace Instrument. 

The Replace Instruments dialog box opens.
3. Click Replace selected instruments.
4. Specify the location of the replacement instrument type in the Symbol Folders list. Select the specific instrument 

type from the Symbols list.
5. Click OK. The selected instruments are replaced with the specified instrument type.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Lighting Instruments
Inserting Instruments

Changing the Instrument Label Legend
As instruments are placed on the light plot, the active label legend is assigned to them by default. However, the legend 
can be changed for a selection of instruments.
To change the instrument label legend:

1. Select one or more instruments.
2. Click on the Spotlight > Label Legend > Assign Legend to Instruments command.

The Assign Legend to Instruments command is also available from the object context menu for selected 
instruments. Right-click (Windows) or Ctrl-click (Mac) to quickly access the command.
The Assign Legend to Instruments dialog box opens.

3. Select the new label legend for the instruments.
4. Click OK; the new label legend is applied to the selection.

The label legend can also be changed for an individual instrument by selecting the instrument, and then selecting 
the legend name from the Use Legend list in the Object Info palette.
Use the Find and Modify command to quickly generate a custom selection of specific instruments and apply the 
new legend to the selected instruments (see “Find and Modify” on page 887).

~~~~~~~~~~~~~~~~~~~~~~~~~
Using the Label Legend Manager
Adding Lighting Instruments

Refreshing Instrument and Light Position Data
The Spotlight > Refresh Instruments command updates light position information and instrument labels to reflect 
any changes that have been made. This ensures that all current data is displayed; it is a good idea to select this 
command before printing the light plot.
Two-fers do not get updated with the instrument information when the Refresh Instruments command is selected.
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The Refresh Instruments command is also available from the document or object context menu. Right-click 
(Windows) or Ctrl-click (Mac) to quickly access the command.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Lighting Instruments
Using the Label Legend Manager
Adding Lighting Instruments

Aligning Instruments
Lighting instruments can be automatically aligned and distributed along a specified guide line with the Align and 
Distribute Items tool.

To align and/or distribute instruments along a line:

1. Select the objects to be aligned or distributed.
2. Click the Align and Distribute Items tool from the Spotlight tool set.
3. Click to define the beginning of the guide line, and click to end.

The Align and Distribute dialog box opens.
The instruments can be aligned and distributed according to several options.

Click to show/hide the parameters.
 

Parameter Description

Just Align The instruments are aligned, but their distribution is not changed

Along line on centers Aligns and distributes selected objects along the guide line using a specified spacing setting 
between the center point of the instruments

Evenly between 
points

The instruments are aligned and distributed evenly between the guide line points, starting 
with instruments at the beginning of the guide line

Original instrument alignment and distribution
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4. Click OK to align or distribute the instruments according to the selected option.
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Lighting Instruments
Adding Lighting Instruments

Find and Modify
Custom selection criteria can be defined to quickly and easily search for instruments, lighting positions, and 
accessories and to perform an action upon the search results.
To find and modify objects:

1. Select Spotlight > Find and Modify. 
The Find and Modify dialog box opens.

2. Select the type of object to be searched and specify the change(s) to occur to the items found.
Click to show/hide the parameters.

 

Evenly inside points The instruments are aligned and distributed evenly between the guide line points, starting 
with spacing at the beginning of the guide line

Parameter Description

Find All Select the type of object to be searched, and then specify the criteria for the search. For 
example, find all instruments with a circuit number of 66. The list of values is filtered as the 
criteria are defined.

Change the __ field 
to __

A specific parameter value can be changed to a new value by clicking Change, selecting the 
parameter, and entering the new value. Instruments on a particular circuit can be changed to 
another circuit, for example.

Replace them with 
this symbol

Click Replace to change the found items to the item specified in the list. For example, find 
all instruments with a particular purpose, and change them to be of the same instrument 
type.

Assign this Label 
Legend

The label legend for found instruments can be changed by clicking Assign and selecting the 
new label legend

Renumber the __ 
field from __ 
starting at__

The renumber operation changes the numbering values for the specified item and location. 
Enter the starting number value for the change. For example, change the numbering for all 
PAR instruments on Electric #2 to begin with 12.

Copy the __ field 
to the __ field

One parameter from the searched item can be copied to another parameter by selecting the 
parameters from the lists in the Copy operation. For example, copy the circuit number to the 
dimmer number or the dimmer number to the channel number.

Change the class to 
__

Change the class of the found items by clicking Change the Class to

Parameter Description
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3. Once the find and modify criteria have been defined and action(s) specified, click OK. The selected change(s) will 
occur to the items located by the search.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Lighting Positions
Adding Lighting Instruments
Adding Accessories

Adding Accessories
Accessories can be inserted from the many symbols provided in symbol libraries, or created as custom symbols that 
you convert into accessories.

• In the Resource Browser, either select one of the accessory symbols from the existing symbol libraries or one of 
the symbols you have created in this file or a Favorites file. Insert the symbol with the Lighting Accessory tool to 
place the accessory object on the light plot. This method is described in “Inserting Accessories” on page 889.

• Convert custom geometry into an accessory. This method is described in “Creating an Accessory” on page 888.
The accessory symbols from the libraries included with the Vectorworks Spotlight product include all the required 
attribute information and have the correct accessory type assigned (Accessory or Static Accessory). To create or 
use your own symbols, see “Accessory Specifications” on page 894.

Lighting instrument accessories, such as color frames, barn doors, and top hats, are placed on the same design layer as 
the instruments. Accessories such as color frames, barn doors, and top hats have a Device Type of Static Accessory. 
Accessories that require a control channel, such as color scrollers, have a Device Type of Accessory.
An instrument can have multiple accessories in the same location (most accessories are placed at the front of an 
instrument). It can also have several accessories in different locations. Once an accessory has been associated with an 
instrument, the instrument controls the accessory.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating an Accessory
Inserting Accessories

Creating an Accessory
The Vectorworks Spotlight program provides accessory symbols; however, it is not necessary to use only the 
pre-defined symbols. Create an accessory out of a currently selected symbol—once the symbol is converted to an 
accessory, the accessory functionality is present. See “Accessory Specifications” on page 894 for restrictions on using 
symbols for accessories.
To create an accessory:

1. Draw the accessory, and then convert the object to a symbol by selecting Modify > Create Symbol.

Just Select Them The found item(s) can simply be selected by clicking Just Select Them
Just Deselect Them Deselect the items found by the custom search by clicking the Just Deselect Them option
Delete Them Delete the items found by the custom search by clicking the Delete Them option
Item Count Displays an item count of the objects meeting current criteria at the bottom of the Find and 

Modify dialog box

Parameter Description
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Symbols can have a separate 2D and 3D representation. The accessory object automatically uses the appropriate 
portion of the symbol. At a minimum, the symbol must have at least a 2D component; it also requires a 3D 
component to display correctly in 3D views. For information on symbols, see “Creating New Symbols” on 
page 239.

2. Select the symbol(s).
3. Select the lighting instrument to associate with the accessory or accessories.

Only one instrument can be selected.
4. Select Spotlight > Object Conversion > Convert to Accessory. 

The selected symbol is converted into an accessory and remains inserted in the drawing. It is associated with the 
selected lighting instrument. The accessory properties can be changed through the Object Info palette; some of the 
accessory information may need to be entered.
Accessories such as color frames, barn doors, and top hats should have a Device Type of Static Accessory. 
Accessories that require a control channel, such as color scrollers, should have a Device Type of Accessory.

Select the accessory from the Resource Browser as an active symbol definition and use the Lighting Accessory 
tool to insert it again if required (see “Inserting Accessories” on page 889).
To associate an accessory with a different lighting instrument, or associate an accessory that was never properly 
associated, select the accessory and the instrument to associate, and then select Spotlight > Object Conversion > 
Convert to Accessory.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Accessories
Adding Accessories

Inserting Accessories
Existing accessory symbols are inserted with the Lighting Accessory tool. This can be a symbol that you have created, 
located in a Favorites file or the current file, or it can be one of the symbols imported from the libraries included with 
the Vectorworks Spotlight software ([Vectorworks]\Libraries); see “Resource Libraries” on page 219.
For more information on importing symbols, see “Importing a Symbol or Symbol Folder” on page 252.

To insert an accessory:

1. From the Resource Browser, double-click on the accessory symbol to insert. This automatically activates the 
symbol and selects the Lighting Accessory tool from the Spotlight tool set.
Alternatively, select the accessory symbol from the Resource Browser and choose Resources > Make Active to 
make it the active symbol definition. The Lighting Accessory tool is automatically selected.

2. Click once to insert the active accessory symbol definition, and then again to determine the accessory rotation. 
The cursor changes to a bull’s eye. Click on the instrument which will be associated with the accessory.
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Because the accessory is controlled by the associated instrument, the items move together. However, an accessory 
can be positioned on its own by selecting it and dragging.
If an accessory symbol is accidentally inserted by the Symbol Insertion tool, the accessory functionality will not 
be present. If correctly inserted, the Object Info palette displays “Lighting Device” (with a Device Type of 
Accessory or Static Accessory) for the selected accessory.
Once the Lighting Accessory tool has been selected, it remains selected by default so that accessories can be 
repeatedly inserted. To place non-instrument symbols after placing accessories, switch to the Symbol Insertion 
tool.

Accessory Properties
The accessory Object Info palette parameters are nearly identical to those of an instrument, because it requires many of 
the same parameters. The Device Type is Static Accessory or Accessory.

Entering a parameter in the accessory Object Info palette will not change the associated instrument parameters. 
For more information on the Object Info palette parameters, see “Lighting Instrument Properties” on page 877.
When a lighting instrument is deleted, its associated accessory is also deleted.
~~~~~~~~~~~~~~~~~~~~~~~~~
Adding Accessories

Instrument and Accessory Specifications
Custom symbols can be created and used in addition to the pre-defined standard symbol sets. Create an instrument, 
accessory, or lighting position out of a currently selected symbol by converting it with the commands in the Spotlight 
menu.
Certain rules apply when creating lighting and accessory symbols.
~~~~~~~~~~~~~~~~~~~~~~~~~
Lighting Instrument Specifications
Multi-circuit Instrument Specifications
Accessory Specifications

Lighting Instrument Specifications
Special rules apply when creating a symbol to be converted to a lighting instrument.

Symbol Characteristics
Symbols should be hybrid (2D/3D) so that they display properly in both 2D and 3D views. At a minimum, the symbol 
must contain a 2D component, which must be a screen plane representation and not a 2D planar object. 

2D Characteristics

Create the 2D view of the symbol using as few polygons and lines as possible. If possible, use a single polyline rather 
than individual line segments. All instruments should be drawn with the front of the instrument (the end which emits 
light) oriented towards the top of the drawing. The symbol below was created from these few constituent parts:
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The line weight of the symbol is also a consideration; the instruments need to stand out when printed. The outer 
perimeter of the symbol should have a line weight of at least 1/2 point (7 mils). Interior details should use a lighter line 
weight.
The 2D representation should have a solid fill so that it obscures information under the symbol. The size of the 
instrument should be accurate based on the real instrument it represents. While drawing the instrument, keep the level 
of detail as minimal as possible. The goal is to be able to distinguish instruments from one another, not to create a 
detailed plan view of each instrument.
For instruments with multiple configurations, it is acceptable to use simple graphical differences to distinguish among 
the models. For example, use the following variations to separate the different versions of a symbol:

3D Characteristics

The 3D portion of the instrument should be drawn as if it is hung straight down (along the Z-axis) with the yoke 
oriented along the Y-axis. The top of the instrument should be oriented towards the top of the drawing. An easy way to 
generate a reasonable 3D instrument body is to sweep the 2D portion of the symbol. The segment angle of the sweep 
should be between 20 and 40°. See “Sweeping Objects” on page 1042 for more information.

Keep the 3D symbol simple. It should be solid. The model should be accurately sized, but without minute details like 
handles, grommets, fins, louvers, cords, and knobs. These items can add significantly to the rendering time required, 
and are not necessary to distinguish among instruments.
The 3D model should consist of three parts: the body, a yoke, and a clamp or base. Any subparts should be made into a 
single object or group for each of these pieces. The body represents the part of the instrument where light is emitted; 
the yoke connects the body to the base, and the base consists of either a base motor unit for moving lights or a clamp or 
other hanging device for other lights. The clamp can be imported from the symbol library provided with the Spotlight 
program. Place a 3D locus within the body of the instrument. 
All the parts should be aligned as shown; the yoke rotates about the Z-axis, and the body rotates at the height of the 
locus point.

Altman         6 x 9           6 x 12         6 x 16           6 x 22

360° sweep
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Insertion Point
Align the 2D and 3D views so that the hanging points of both versions line up.
The insertion point of the 2D/3D hybrid symbol in Top/Plan view should represent the hanging location of the 
instrument. The 3D insertion point should be the hanging point (center of the clamp or base).
Create the symbol as described in “Creating New Symbols” on page 239.

Attaching the Parts Record
Attach the Parts record to each of the three pieces of the 3D instrument model: body, yoke, and base or clamp.
To attach the Parts record:

1. In the Resource Browser, import the Parts record from one of the instrument library files included with the 
Spotlight program.
Locate the record and select Resources > Import to bring the record into the current file.

2. Select the new symbol, and select Modify > Edit Symbol.
3. In the Edit Symbol window, select the body, yoke, or base/clamp.
4. Click on the Data tab in the Object Info palette. Attach the Parts record to the part by selecting the check box.

5. Edit the record by selecting the appropriate record field and changing its value to True. For example, select the 
yoke, attach the Parts record, and change the Yoke record field to True. 

6. Repeat steps 3 – 5 for each of the three parts of the instrument model.
7. Click Exit Symbol at the upper right corner of the window to return to the drawing.

Body

Yoke

Clamp

3D Locus
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Attaching the Light Info Record and Light Info Record M
Attach the Light Info record to the lighting instrument symbol, with field names that match the names of the fields in 
the instrument object. Not all the fields are required, but the desired fields for the instrument object to read should be 
included. Filling the instrument type field with the manufacturer’s name and model name for the particular instrument 
is recommended.
The Light Info M record provides metric measurements of the weight and frame size of the instrument object. This is 
needed for instruments that could be used in either imperial and metric drawings.
To attach the light info record:

1. In the Resource Browser, import the Light Info Record and Light Info Record M from one of the instrument 
library files included with the Spotlight program.
Locate the records and select Resources > Import to bring the records into the current file.

2. Select the new symbol, and select Modify > Edit Symbol.
3. In the Edit Symbol window, click on an empty location so that nothing is selected.
4. Click on the Data tab in the Object Info palette. Attach the Light Info Record and Light Info Record M to the 

symbol defaults by selecting the check boxes. Then edit the records by selecting the record field and entering its 
record information.

The Candlepower, Beam Angle, and Field Angle parameters affect the photometric grid and photometer object 
calculations. The Beam Angle and Field Angle parameters affect the Draw Beam feature.
Normally, do not include text labels with the instrument, as these are handled by the instrument object. An 
exception can be made to distinguish different models or lamps of an instrument. For example, create three 
versions of a single PAR64 symbol by adding MFL, WFL, and NSP text blocks.
Symbols should be named with the model name of the lighting instrument.

5. Turning the lighting instrument’s light on in the Visualization palette includes a spot light as part of the lighting 
instrument. While editing the symbol, the spot light can be added, and accurate lighting information specified with 
the parameters in Use Emitter. See “Adding Light Sources” on page 1574 for information on adding a spot light 
and setting accurate lighting parameters.

6. Click Exit Symbol at the upper right corner of the window to return to the drawing. 
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As an alternative to the process of manually editing the symbol definition to attach the Light Info (and/or Light 
Info M) record, use the Lighting Symbol Maintenance command as described in “Lighting Symbol 
Maintenance” on page 959. Add the symbol by clicking New, and the Light Info record is automatically attached 
to it. Once in the maintenance list, the record data can be easily edited.

~~~~~~~~~~~~~~~~~~~~~~~~~
Multi-circuit Instrument Specifications
Accessory Specifications

Multi-circuit Instrument Specifications
Multi-circuit instruments represent a special case of the instrument object. Each symbol drawn should represent a 
single element of the multi-circuit instrument. An instrument that is at the end of the multi-circuit strip should look 
different from the instruments that are in the center. Place the number of symbols required to create the multi-circuit 
instrument. For example, place four symbols (two ends and two middle) to create a four-circuit cyc unit.

The multi-circuit symbol must consist only of other symbols to be properly inserted as a multi-circuit instrument. 
Otherwise, the Lighting Instrument tool treats it as a single circuit instrument. 
Attach the light info record to the individual instruments within the multi-circuit unit by the same method as for an 
individual lighting instrument.
The multi-circuit lighting device focuses in 3D in the same way as individual lighting devices (see “Lighting 
Instrument Specifications” on page 890). The yoke is created from portions of the individual instrument symbols. The 
3D locus, placed within the container multi-circuit symbol, is used as a common rotation axis for the entire 
multi-circuit unit.

~~~~~~~~~~~~~~~~~~~~~~~~~
Lighting Instrument Specifications
Attaching the Light Info Record and Light Info Record M
Inserting Multi-circuit Instruments

Accessory Specifications
The accessory symbol should be a 2D/3D hybrid object. At a minimum, the symbol must contain a 2D screen 
representation. Keep the accessory representation as simple as possible to reduce rendering time.

1. Convert symbols to instruments 2. Convert instruments to multi-circ instrument

Base Yoke

Common rotation
axes

Lighting devices
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The 3D portion of the accessory should be drawn as if it is hung straight down (along the Z-axis). The top of the 
accessory should be oriented towards the top of the drawing. 3D geometry should be drawn below the Z-axis to 
properly align with the front of the lighting instrument. 
The Object Info palette for accessories and lighting instruments looks identical, but the Device Type differs for 
accessories (Accessory or Static Accessory).
Accessories should have a record attached for storing the default accessory values. The record should not contain fields 
that vary from instance to instance of an accessory. For example, do not add a Color Scroller channel field value unless 
that channel is used by all the color scrollers in the file.
The attached record should consist of the following fields:

A Parts record is not required for an accessory.
~~~~~~~~~~~~~~~~~~~~~~~~~
Lighting Instrument Specifications

Ganging Instruments
Two-fers gang two or more instruments together on one circuit, dimmer, channel, or dimmer and channel.

The ganging field parameter value(s) should match. If not, the value(s) from the first selected instrument are used.

To gang two or more instruments:

1. Click the Ganging tool from the Spotlight tool set.
Click Preferences from the Tool bar to set the default tool preferences, if desired.

2. Click on the first, and then the second, instrument to be ganged together. If more than two instruments are to be 
ganged together, continue clicking on each instrument in succession.

3. Click to set the offset distance of the two-fer label.

Field Description

Instrument 
type

Accessory name; this can be a specific manufacturer’s model name or number, or a generic name for 
the accessory, such as 6” Top Hat

Accessory 
type

Generic accessory category; in some cases, this can be similar, or identical to the instrument type 
(example accessory types include Top Hat, Barn Door, Color Scroller, Gobo Rotator, and Color 
Frame)

Wattage Amount of power consumed by the accessory
Weight Accessory weight
Other Add fields as desired; these fields are read into the Lighting Device object if the field name in the 

accessory record matches the field name of the Lighting Device object

1. Click on 1st instrument 2. Click on 2nd instrument

3. Click to set offset
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If the field values of the instruments do not match, confirm that this is acceptable in the Notice dialog box which 
opens. 

4. Click OK. The instruments are ganged together with one or more two-fer objects.

The properties of a two-fer are displayed, and can be edited, in the Object Info palette.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Instruments

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the style 

associated with the class, select <Class Text Style>. To format the text using options on the Text 
menu, select <Un-Styled>. See “Using Text Styles” on page 393 and “Formatting Text” on 
page 389.

Update Insts Select to update the ganged instruments. Changes to one instrument are updated for the other 
ganged instrument. Also updates two-fer counts in the position summary inventory report.

Corner Style Select the corner style for the two-fer object (Square, Arc, or Bézier)
Gang By Indicate whether to gang by Channel, Dimmer, Circuit (name and number), or dimmer and 

channel
Field Value Enter the value for the two-fer label. (For example, if ganging by channel number, enter a 

channel number of 80.) This new value updates the former value for dimmer or channel in the 
instrument record. If ganging by circuit or channel and dimmer, enter the two values separated 
by a comma.

Show Label Select to display the two-fer label or labels with the ganged values
Use Container Select to place the label or labels in a container; if ganged by dimmer and channel, the same 

container is used for both labels. By default, the label legend container from the first selected 
instrument is used, but this can be overridden by specifying a container name.

Container Name The container name must exactly match one of the container symbol names located in the 
Resource Browser (normally, these are in the Containers folder)
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Focusing Instruments
To focus a lighting instrument assembly and beam on a particular area or object, a focus point needs to be defined.
The focus point can also be used to create Magic Sheets that show the instruments focused on a particular area (see 
“Magic Sheets” on page 970). In addition, the focus point can be used as one of the criteria for finding instruments with 
the Find and Modify command (see “Find and Modify” on page 887). It is also possible to select all lighting devices 
assigned to a particular focus point for quick editing (see “Editing Lighting Instruments” on page 877).

Creating a Focus Point Object
An object defined as a focus point specifies where instrument assemblies and light beams should be directed. If the 
focus point is moved, any instruments that are aimed at it update their focus position based on the focus point 
information.
Like lighting positions and instruments, focus points should be inserted on their own design layer, to facilitate 
selection, viewing, and printing. Alternatively, it is acceptable to insert the focus points on the same design layer as the 
scenic elements. Focus points can also be inserted into their own classes.

A 3D stage object can be used as a focus point for lighting instruments by naming it as the focus point in the 
instrument Object Info palette (see “Lighting Instrument Properties” on page 877).

To create a focus point object:

1. Click the Focus Point tool from the Spotlight tool set.
2. Click Preferences from the Tool bar to specify the default focus point settings. These settings can be changed later 

for existing focus points from the Object Info palette.
The Focus Point Properties dialog box opens.

Click to show/hide the parameters.

3. Click on the plot to insert the focus point object.
4. The Place Focus Point dialog box opens. Enter the name of the focus point, the focus height above the stage floor, 

and then click OK.

Parameter Description

Show Focus Point Name Select whether to display the focus point name along with the focus point shape
Focus Point Shape Select a shape for the focus point.

• Standard Hybrid: an octagon in both Top/Plan view and 3D views
• Standard 2D: an octagon in Top/Plan view and a 3D locus in 3D views
• Standard 3D: a 2D locus in Top/Plan view and an octagon in 3D views
• Locus Points Only: a 2D locus point in Top/Plan view and a 3D locus in 3D views 

(does not display in rendered views)
• Default content: Existing focus shape symbols are provided as default content 

(default content is automatically imported into the current file at the point of use and 
displays in the Resource Browser; see “Resource Libraries” on page 219).
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The focus point name is required later to specify the focus point for the lighting instruments.
The name of a focus point can be changed on the Data tab of the Object Info palette, and can be updated in the 
drawing file by selecting Reset on the Shape tab of the Object Info palette. Place focus points in their own class so 
they can be easily hidden for a 3D rendering. Alternatively, select Standard 2D or Locus Points Only for the Focus 
Point Shape.

~~~~~~~~~~~~~~~~~~~~~~~~~
Assigning a Focus Point to a Lighting Instrument
Drawing Light Beam Representations

Assigning a Focus Point to a Lighting Instrument 
One or more instruments and/or multi-circuit instruments can be focused on a focus point. The focus point is used to 
draw light beam representations (see “Drawing Light Beam Representations” on page 899), calculate photometric 
values (see “Obtaining Photometric Data” on page 899) and for rendering gobo projections (see “Gobo Projection 
Requirements” on page 976). In 3D views, the instrument rotates to point automatically at the focus point.
With the Focus Instruments at Next Click context menu command, selected lighting instruments can quickly focus 
on an existing focus point, or create one using the current focus point properties. Alternatively, use the Focus 
Instruments command to select an existing focus point, or create one and set its properties at that time.
To focus the lighting instrument(s) at the next click with the context menu command:

1. Select the instrument(s).
2. Right-click (Windows) or Ctrl-click (Mac) in an open area of the drawing, and select Focus Instruments at Next 

Click from the context menu.
3. To create a new focus point for the instrument(s), click in the drawing. The current focus point properties are used, 

and a unique name is automatically assigned to the new focus point; see “Creating a Focus Point Object” on 
page 897. Alternatively, click on an existing focus point or locus.
The instrument(s) are assigned to the new or existing focus point.
If you place a new focus point on an existing 3D object while in a 3D view, the focus point automatically adopts 
the Z value of the click.

To focus the lighting instrument(s) with the menu command:
1. Select the instrument(s). 
2. Select Spotlight > Focus Instruments. 

Alternatively Right-click (Windows) or Ctrl-click (Mac) on the selected instrument, and select Focus 
Instruments from the context menu.
The Focus Instruments dialog box opens. Select an existing focus point, or select Next Click to create a new focus 
point with the next mouse click and click OK.
If Next Click is selected, the New Focus Point dialog box opens. Specify the name and height of the focus point.
To change the focus point of a single instrument, enter the name of the new focus point in the Focus field of the 
Object Info palette (see “Lighting Instrument Properties” on page 877).
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Focus Point Object
Drawing Light Beam Representations

Drawing Light Beam Representations
Once the focus point of instruments has been specified, light beam representations can be drawn. Wireframe light beam 
representations can be controlled by class; see “Lighting Device Setup” on page 95.
To turn on the light beam for one or more instruments:

1. Select the instrument(s).
Use the Select Focused Lighting Devices context menu to quickly select all lighting devices assigned to a focus 
point (see “Changing Instrument Properties” on page 880).
An instrument must have a focus point in order to draw a light beam representation (see “Assigning a Focus Point 
to a Lighting Instrument” on page 898). Elliptical light sources require secondary beam and field angles. The 
Focus Instruments command inserts a default falloff distance for elliptical light sources.

2. Select Draw Beam from the instrument Object Info palette (see “Lighting Instrument Properties” on page 877).

An accurate wireframe representation of the light beam’s spread and location on the stage is drawn, oriented to the 
focus point. The light beam of instruments used for general wash lighting can also be drawn; however, a focus 
point is still required in order to draw the light beam representation.

3. Select Draw Beam as 3D Solid from the instrument Object Info palette to see the light beam as a solid cone of 
light. The Color specified in the Object Info palette or Lighting Device dialog box determines the solid color (see 
“Lighting Instrument Color” on page 882). The class of the light beam can also determine its appearance and 
optionally, texture (Renderworks required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Focus Point Object
Assigning a Focus Point to a Lighting Instrument

Obtaining Photometric Data
Vectorworks can determine and display the surface illumination values of the stage at a specific location (Photometer 
object) or along a grid (Photometric Grid object).
For photometric values to be measured, the lighting instrument(s) must have a designated focus point.

Light beam
Top/Plan view

Light beam
3D view
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~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting a Photometric Grid
Inserting a Photometer
Using Photometric Threshold Settings
Assigning a Focus Point to a Lighting Instrument

Inserting a Photometric Grid 
The Photometric Grid is a is a three-click rectangular object, and can be inserted in Center-line Placement mode or 
Edge Placement mode.

To insert a photometric grid:

1. Ensure that each lighting instrument contributing to the illumination is focused.

The light beams do not have to be drawn for calculations to be made.
2. Click the PhotoGrid tool from the Spotlight tool set and click the desired placement mode from the Tool bar.
3. Click in the drawing area to insert the photometric grid.

If this is the first time a photometric grid has been placed on the drawing, the object properties dialog box opens. 
Specify the preferences to use for this tool during this session, and then click OK.
The photometric grid properties can be changed in the Object Info palette.

Click to show/hide the parameters.

Placement Mode Description

Center-line Click once, and then again, to define the width through the center of the grid. Click again to 
specify the width of half the grid.

Edge Click once, and then again, to define the length along the edge of the grid. Click again to specify 
the grid width.

Center-line
Placement

Edge 
Placement
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After placing the photometric grid, set the grid’s Z value on the Object Info palette; illumination values vary 
depending on the grid’s elevation.

~~~~~~~~~~~~~~~~~~~~~~~~~
Obtaining Photometric Data
Inserting a Photometer
Using Photometric Threshold Settings
Assigning a Focus Point to a Lighting Instrument

Inserting a Photometer 

To insert a photometer:

1. Ensure that each lighting instrument contributing to the illumination is focused.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using 
options on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 and 
“Formatting Text” on page 389.

Show Elevation Select to display the grid elevation along with the photometric values
Show Zero Select to display elevation values of zero
Calculate Using Only 
Visible Beams

Select to determine the photometric values based on only instruments with Draw Beam 
selected; this reduces calculation time

Use Threshold Settings Select to display the grid with colors that correspond to the specified threshold ranges
Lower Threshold Specify the illumination value at the lower end of the range; values below this level are 

displayed in green, and values between the lower and upper threshold are displayed in 
tan

Upper Threshold Specify the illumination value at the upper end of the range; values above this level are 
displayed in blue

Grid Spacing X Specifies the spacing of photometric values in the X direction
Grid Spacing Y Specifies the spacing of photometric values in the Y direction
Grid Width X Specifies the length of the grid in the X direction; available in Object Info palette only
Grid Width Y Specifies the length of the grid in the Y direction
Refresh Refreshes the grid display after changes have been made to the lighting conditions
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The light beams do not have to be drawn for calculations to be made.
2. Click the Photometer tool from the Spotlight tool set.
3. Click to place the photometer in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

4. Specify the object properties and click OK.
Click to show/hide the parameters.

After placing the photometer, set the its Z value on the Object Info palette; illumination values vary depending on 
the photometer’s elevation.

~~~~~~~~~~~~~~~~~~~~~~~~~
Obtaining Photometric Data
Inserting a Photometric Grid
Using Photometric Threshold Settings
Assigning a Focus Point to a Lighting Instrument

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using options 
on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 and 
“Formatting Text” on page 389.

Show Elevation Select to display the object’s elevation along with the photometric value
Show Zero Select to display an elevation value of zero
Calculate Using Only 
Visible Beams

Select to determine the photometric value based on only instruments with Draw Beam 
selected; this reduces calculation time

Use Threshold 
Settings

Select to display the object in a color that corresponds to the specified threshold ranges

Lower Threshold Specify the illumination value at the lower end of the range; values below this level are 
displayed in green, and values between the lower and upper threshold are displayed in tan

Upper Threshold Specify the illumination value at the upper end of the range; values above this level are 
displayed in blue

Reset Refreshes the photometer display after changes have been made to the lighting conditions
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Using Photometric Threshold Settings
Vectorworks’ photometric grid and photometer calculate and display the illumination values at the elevation point. The 
values are displayed in either foot candles (Imperial) or lux (Metric), depending on the units selected in File > 
Document Settings > Units. 
If Use Threshold Settings is selected in the Object Info palette, colors indicate the illumination range according to the 
Lower/Upper Threshold values set in the Object Info palette.

The photometric grid and photometer range colors can be changed. See “Customizing Photometric Threshold 
Colors” on page 904.

 

To evaluate the illumination values at different heights, change the elevation of the photometric object in the 
Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Obtaining Photometric Data

Color Description

Gray Illumination value of zero
Green Illumination value between zero and Lower Threshold
Tan Illumination value between Lower and Upper Threshold
Blue Illumination value above Upper Threshold

Photometric Grid
Lower Threshold = 150FC
Upper Threshold = 350 FC

Photometer
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Customizing Photometric Threshold Colors

Customizing Photometric Threshold Colors
Both the photometer and photometric grid use colors that correspond to the specified threshold ranges (see “Obtaining 
Photometric Data” on page 899). These colors can be changed if desired.
To edit the photometric threshold color values:

1. Select Tools > Plug-ins > Plug-in Manager.
The Plug-in Manager opens. Click on the Built-in Plug-ins tab and select either PhotoGrid or Photometer.

2. Click Customize.
The Customize Plug-in dialog box opens. Click on the Strings tab.

3. Select Resource ID “4000: Threshold Color Indices.” Click Edit.
4. The Edit Strings dialog box opens. Select one of the indices and click Edit to specify a new color value for the 

threshold index.

The values correspond to index values of the color palette. For more information on color palette selector values, 
see the Miscellaneous Selectors section of the developer-oriented documentation located at http://
developer.vectorworks.net 

5. When the desired threshold index color selector values have been edited, click OK to accept the changes, and then 
continue to click OK until you can close the Plug-In Manager dialog box.

~~~~~~~~~~~~~~~~~~~~~~~~~
Obtaining Photometric Data

Inserting Soft Goods 
The Soft Goods tool inserts theater and event planning draperies such as curtains, borders, scrims, and pipe-and-drape 
assemblies. Soft goods objects are drawn along a path, so they can be straight, curved, or in any configuration for total 
flexibility; the path can be edited after placement. The 3D appearance of soft goods objects can be set for a realistic 
appearance, or display more schematically. The materials used to create the soft goods configuration can be included in 
a report for cost estimation (see “Creating Reports” on page 1316). Text labels identify the components of the soft 
goods object.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Curtains and Borders
Inserting Pipe-and-Drape Assemblies
Setting Soft Goods 3D Display Options
Formatting Soft Goods Object Labels

ID Corresponding Threshold Index

4000 Zero level
4001 Levels below the Lower Threshold value
4002 Levels between the Lower and Upper Threshold values
4003 Levels above the Upper Threshold value

http://developer.vectorworks.net
http://developer.vectorworks.net
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Inserting Curtains and Borders 
The Soft Goods tool creates a curved or straight stage curtain or border. To draw a curtain, either use the Soft Goods 
tool, or create a polyline and then select the Create Objects from Shapes command (see “Creating Objects from 
Shapes” on page 277). 

To insert a curtain or border:

1. Click the Soft Goods tool from the appropriate tool set:
• Spotlight workspace: Spotlight tool set
• Designer workspace: Detailing tool set

2. Click Preferences from the Tool bar to specify or change any default Soft Goods tool parameters.
The Soft Goods Object Properties dialog box opens. 

3. Select either Curtain or Border from the Function list, and specify any other default parameters for this session.
4. Click OK.
5. Click on the appropriate mode in the Tool bar to select the creation method of the soft goods object.

The Corner Vertex or Point on Arc modes are recommended. For more information on the Polyline tool modes, 
see “Creating Polylines” on page 298.

6. Click to set the soft goods object’s start point.
7. Click to set the end of the segment and the beginning of the next. Continue drawing segments in this manner until 

the curtain or border object is complete.
Once created, the soft goods object can be reshaped by double-clicking on it. The Reshape tool is automatically 
activated, to reshape the object directly in the drawing.
The curtain or border parameters can be edited in the Object Info palette. However, certain parameters are not 
available for borders.



  906 | Inserting Soft Goods
Click to show/hide the parameters.

Parameter Description

Function Select either Curtain or Border (for pipe-and-drape assembles, see “Inserting 
Pipe-and-Drape Assemblies” on page 907)

Adjustable Length Specifies the length of a straight curtain or border
Height Indicates the height of the curtain or border
Show Centerline In Top/Plan view, displays the curtain center line or the border reference line
Add Track Draws the curtain track

Track Width Sets the width of the curtain track
Show Traveler Pull Shows the traveler pull on the left or right of the track, or hides the traveler pull

Open From For curtains, creates an opening in the curtain at the center or at one of the ends. Select 
None to hide all openings in the curtain.

Width When a curtain opening has been selected, specifies the width of the opening
Show Ghost Curtain Displays the open section of the curtain with dotted lines in Top/Plan view

Reverse Side For borders, switches the curtain to the other side of the center reference line
Running Length For curved curtains, shows the total curtain length
Stock Drape Width Specifies the width of an individual drape panel
Total Drape Count Displays the number of drape panels required based on the specified stock drape width
Simple 2D Temporarily simplifies the Top/Plan view of the curtain or border, showing it as a line
Simple 3D Temporarily simplifies the 3D view of the curtain or border, showing it as a flat surface
Pleat Width Indicates the distance between pleats
Pleat Depth Indicates the depth of the curtain pleats
Flip Pleats Switches the positive and negative portions of the pleats
Adjust Starting For borders, offsets the starting point of the border
Adjust Ending For borders, offsets the ending point of the border
3D Curtain Options Opens the 3D Curtain Options dialog box, for setting the appearance of the curtain in 

3D. An image (Renderworks required) or color can be set. To create a scrim, select 
Scrim from the Soft Goods Options list.

Pleat 
depth

Adjustable length

Track Curtain opens 
from center

Pleat width

Centerline
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~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Pipe-and-Drape Assemblies
Setting Soft Goods 3D Display Options
Formatting Soft Goods Object Labels
Inserting Soft Goods

Inserting Pipe-and-Drape Assemblies 
The Soft Goods tool creates pipe-and-drape assemblies typically used in event planning, such as when creating 
temporary booths in a convention center. To draw a pipe-and-drape assembly, either use the Soft Goods tool, or create 
a polyline and then select the Create Objects from Shapes command (see “Creating Objects from Shapes” on 
page 277). 

Current Option Displays the currently selected 3D option
Location Enter notes about the curtain or border location, if desired
Material Color Enter notes about the curtain or border color (does not affect the curtain appearance)
Material Type Enter notes about the curtain or border material (does not affect the curtain appearance)
Top Finish Select the finish for the top of the curtain or border

Spacing Sets the spacing for tie, hook, or grommet finishes
Bottom Finish Select the finish for the bottom of the curtain or border
Sides Finish Select the finish for the sides of the curtain or border
Fullness % Specifies the curtain or border fullness information (does not affect curtain appearance)
Lining Enter notes about the curtain or border lining material
Note Enter any miscellaneous information required, such as stock number or other data
Class Soft Goods Parts When first selected, automatically creates classes for the different parts of the curtain or 

border, for appearance and visibility control. This allows portions of the curtain or 
border to be set to visible, grayed, or invisible. Once the classes have been created, this 
check box toggles whether class visibility changes apply to the selected curtain or 
border.

Parts Classes Prefix When soft goods parts are classed, creates a prefix for the class names so that they are 
sorted together

Text Options Opens the Text Options dialog box, to enable the display and format the text of labels; 
see “Formatting Soft Goods Object Labels” on page 912

Default Text Positions Text labels can be moved by dragging their control point; this option returns them to 
their default locations

Update Updates the object when changes have been made to the Object Info palette parameters
Vertex Parameters Edits the vertices of the path object that the curtain is based upon; see “Editing 

Vertex-Based Objects” on page 1002

Parameter Description
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To insert a pipe-and-drape assembly:

1. Click the Soft Goods tool from the appropriate tool set:
• Spotlight workspace: Spotlight tool set
• Designer workspace: Detailing tool set

2. Click Preferences from the Tool bar to specify or change any default Soft Goods tool parameters.
The Soft Goods Object Properties dialog box opens. 

3. Select Pipe-and-Drape from the Function list, and specify any other default parameters for this session.
4. Click OK.
5. Click on the appropriate mode in the Tool bar to select the creation method of the soft goods object.

For more information on the Polyline tool modes, see “Creating Polylines” on page 298.
6. Click to set the soft goods object’s start point.
7. Click to set the end of the segment and the beginning of the next. Continue drawing segments in this manner until 

the pipe-and-drape assembly is complete.
Once created, the soft goods object can be edited by selecting the object, and then selecting Modify > Edit Soft 
Goods. Reshape the soft goods polyline with the Reshape tool; click Exit Profile to return to the drawing.
The pipe-and-drape assembly parameters can be edited in the Object Info palette.

Click to show/hide the parameters.

Parameter Description

Function Select Pipe-and-Drape
Adjustable Length Specifies the length of a straight pipe-and-drape assembly

Slider

Base plate
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Height Indicates the height of the pipe-and-drape assembly
Show Centerline In Top/Plan view, displays the center line of the pipe-and-drape assembly
Draw Slider(s) Draws the soft goods slider segments at the top of the assembly
Slider Options The number of sliders (panel segments) created depends on the Adjustable Length of 

the entire assembly, the selected Slider Options range, and the Target Length 
specified. Select from a list of standard slider size ranges, or select Custom to create a 
non-standard slider size and enter the number of panels to include.

Target Length Sets the desired slider length within the range specified in Slider Options. If Custom 
was selected for the Slider Options, enter the specific length for the slider.

Actual Length Displays the calculated slider length used for the segments
Slider Total Displays the actual number of slider segments used; if Custom was selected for the 

Slider Options, specify the number of slider segments desired
Running Length Displays the total length of the pipe-and-drape assembly
Base Plate Size Select from a list of standard base plate sizes, or choose the rounded boom base
End Hardware Select whether to include end hardware (base plate and upright) at each end of the 

assembly
First Plate Shift When a base plate is included at the start of the assembly, select whether it is centered on 

the upright (None), or shifted towards the inside (In) or outside (Out). This option does 
not apply to a boom base.

Last Plate Shift When a base plate is included at the end of the assembly, select whether it is centered on 
the upright (None), or shifted towards the inside (In) or outside (Out). This option does 
not apply to a boom base.

Upright/Plate Total Displays the number of uprights and base plates in the assembly
Show 3D Uprights Displays the upright hardware in 3D views; deselect this option for faster rendering
Stock Drape Width Specifies the width of an individual drape panel
Total Drape Count Displays the number of drape panels required based on the specified stock drape width
Simple 2D Temporarily simplifies the Top/Plan view of the pipe-and-drape assembly, showing it as 

a line
Simple 3D Temporarily simplifies the 3D view of the pipe-and-drape assembly, showing it as a flat 

surface
Pleat Width Indicates the distance between pleats
Pleat Depth Indicates the depth of the pleats
Flip Pleats Switches the positive and negative portions of the pleats
3D Curtain Options Opens the 3D Curtain Options dialog box, for setting the appearance of the 

pipe-and-drape assembly in 3D. An image (Renderworks required) or color can be set
Current Option Displays the currently selected 3D option

Location Enter notes about the pipe-and-drape assembly location, if desired
Material Color Enter notes about the pipe-and-drape assembly color (does not affect the drapery 

appearance)

Parameter Description
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To create an opening in the pipe-and-drape assembly, edit the vertex parameters in the Object Info palette. Select 
the vertex prior to the opening as described in “Editing Vertex-Based Objects” on page 1002, and then click Hide 
Next Edge.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Curtains and Borders
Setting Soft Goods 3D Display Options
Formatting Soft Goods Object Labels
Inserting Soft Goods

Setting Soft Goods 3D Display Options 
Select an image texture (Renderworks required) or color to display on the curtain, border, or pipe-and-drape assembly 
in 3D views. A curtain object can also be made to look like a scrim; pipe-and-drape assemblies can have alternating 
panel colors. The Vectorworks Spotlight product includes a number of sample image textures, or you can create your 
own textures (image textures or other textures; see “Creating Textures” on page 1505). The settings made here override 
any class settings made, if the soft goods object is assigned to a class; an alert dialog box displays if there is a conflict. 

Material Type Enter notes about the pipe-and-drape assembly material (does not affect the drapery 
appearance)

Note Enter any miscellaneous information required, such as stock number or other data
Class Soft Goods Parts When first selected, automatically creates classes for the different parts of the curtain or 

border, for appearance and visibility control. This allows portions of the curtain or 
border to be set to visible, grayed, or invisible. Once the classes have been created, this 
check box toggles whether class visibility changes apply to the selected curtain or 
border.

Parts Classes Prefix When soft goods parts are classed, creates a prefix for the class names so that they are 
sorted together

Text Options Opens the Text Options dialog box, to enable the display and format the text of labels; 
see “Formatting Soft Goods Object Labels” on page 912

Default Text Positions Text labels can be moved by dragging their control point; this option returns them to 
their default locations

Update Updates the object when changes have been made to the Object Info palette parameters
Vertex Parameters Edits the vertices of the path object that the curtain is based upon; see “Editing 

Vertex-Based Objects” on page 1002.

Parameter Description
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To set the 3D display options:
1. Select a curtain, border, or pipe-and-drape assembly (Vectorworks Spotlight required). From the Object Info 

palette, click 3D Curtain Options.
The 3D Curtain Options dialog box opens. Select the display from the Soft Goods Options list and then choose 
the formatting options.

Click to show/hide the parameters.

Parameter Description

Soft Goods Options Select the type of display for the soft goods material:
• Opaque: Displays with a solid color
• Scrim: Displays with a partly transparent color
• Image (Renderworks required): Displays an image or assigned texture
• Multi-Color: Displays each panel of the pipe-and-drape assembly with an 

alternating solid color
Opaque 

Opaque or Scrim 
Color

Specifies the color of the soft goods object in 3D views; click the color box to select the 
color

Scrim 
Opaque or Scrim 
Color

Specifies the color of the soft goods object in 3D views; click the color box to select the 
color

Image
(Renderworks 
required)
Image Select the image texture to display on the soft goods object, from the current file’s 

textures
Image Adjustments If the selected image does not have the desired size or position in the Preview, adjust its 

scale or position
Scale Increases or decreases the image scale
Horizontal Shift Shifts the image horizontally to the left or right
Vertical Shift Shifts the image vertically up or down

Flip Image Flips the image
Preview Displays the image selected for the soft goods object
Multi-Color 
(pipe-and-drape 
only)
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2. Click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Curtains and Borders
Inserting Pipe-and-Drape Assemblies
Formatting Soft Goods Object Labels

Formatting Soft Goods Object Labels 
A variety of soft goods object labels can be included on the drawing.
To select labels for display and format the text:

1. Select a soft goods object. From the Object Info palette, click Text Options.
The Text Options dialog box opens.

Click to show/hide the parameters.

2. Specify the text label elements and formatting, and then click OK.
Once the label has been added to the drawing, it can be moved by clicking and dragging the label control point (unless 
Automatically Position Text was selected in the Text Options). Click Default Text Positions from the Object Info 
palette of a selected soft goods object to restore the text label to its original location.

Multi-Color Properties Lists the colors, in order, that will alternate on the pipe-and drape assembly panels
To change the order of the colors, click in the # column and drag the color to a new 
position in the list.

Panel Color Specifies a panel color; click the color box to select the color
Name Enter a name for the specified color
Add Color Adds the Panel Color to the Multi-Color Properties list, to be included among the 

panel colors. If a color has been changed, replaces the changed color in the list.
Remove Color Removes the selected color from the Multi-Color Properties list

Parameter Description

Optional Elements to 
Show

Select items to add to the text label; different label elements are available for curtains or 
borders and pipe-and-drape assemblies

Text Attributes
Stack Text Separates each selected label element by placing it in its own line of text; deselect this 

option to create a single line for all the selected elements
Automatically 
Position Text

Automatically places the label with the soft goods object; deselect this option to be able 
to reposition the label by dragging the label control point

Keep Text 
Horizontal

Maintains the text in a horizontal position even when the object is rotated; deselect this 
option to rotate the label along with the object

Include Element 
Labels

Includes the name of the element along with the value; deselect this option to display 
the parameter value only

Text formatting 
options

Specify the text size, color, and alignment

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Curtains and Borders
Inserting Pipe-and-Drape Assemblies
Setting Soft Goods 3D Display Options

Inserting Video Screen Objects
Video screen objects, such as televisions, projectors, and screens, are often a required part of visualizing a room layout 
for event planning, and are occasionally needed for theater productions. The Vectorworks Spotlight product 
automatically helps with the calculations required for placement, image size, and viewing area; it can also display a 
“glowing” image on the screen for a realistic look (Renderworks required). The video objects can be labeled with 
calculated information and certain objects display the optimum viewing area.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting a Television Object
Inserting an LED Screen
Inserting a Video Screen Object
Inserting a Blended Screen and Projector
Setting the Image on the Video Screen
Formatting Video Screen Object Labels

Inserting a Television Object 
The television object simulates CRT and flat screen televisions.

To insert a television:

1. Click the Television tool from the Spotlight tool set.
2. Click once in the drawing to set the object’s position. Click again to set the object’s rotation.
3. If this is the first time a television is placed on the drawing, the object properties dialog box opens. Specify the 

default preferences, which apply to all televisions placed subsequently in this drawing. Properties can be edited 
later in the Object Info palette. Click OK.

Label control point
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The television object’s parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

TV Type Select the type of TV: flat panel, CRT, or CRT curved
Screen Aspect Select the aspect ratio of the screen: 4:3 (Standard) or 16:9 (Wide screen); curved CRT 

screens cannot have a 16:9 aspect ratio 
Casing Select the television model from the default content (see “Resource Libraries” on 

page 219); available models depend on the selected TV Type and Screen Aspect
Width (image) Displays the width of the screen image area
Height (image) Displays the height of the screen image area
Show Coverage Zone 
(2D only)

Indicates the viewing area based on the screen size; observers within the area should be 
able to see the screen

Zone Reference Calculates the coverage zone based on screen width, height, or diagonal measurement
Viewing Angle Indicates the maximum viewing angle of the screen relative to dead-on
Near Multiplier Specifies the multiplier of the reference dimension to determine the extent of the near 

coverage zone
Far Multiplier Specifies the multiplier of the reference dimension to determine the extent of the far 

coverage zone
Edit Screen Image 
(Renderworks 
required)

Opens the Edit Screen Image dialog box to select the image for screen display. 

Screen Image Displays the name of the current screen image
Add Adjustable 
Stand

For flat panel televisions, adds a stand to the screen casing

Stand Height Specifies the height measurement from the base of the stand to the bottom of the screen 
casing

Near coverage zone

Far coverage zone
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~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Image on the Video Screen
Formatting Video Screen Object Labels

Inserting an LED Screen 
The Light-emitting Diode (LED) object simulates a variety of low-resolution LED screens in arrays on a base structure.

To insert an LED screen or array:

1. Click the LED Screen tool from the Spotlight tool set.
2. Click once in the drawing to set the object’s position. Click again to set the object’s rotation.
3. If this is the first time LED screens are placed on the drawing, the object properties dialog box opens. Specify the 

default preferences, which apply to all LED screens placed subsequently in this drawing. Properties can be edited 
later in the Object Info palette. Click OK.

The LED screen parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Class Television 
Parts

When first selected, automatically creates classes for the different parts of the television 
and, if selected, stand, for appearance and visibility control. This allows portions of the 
television or stand to be set to visible, grayed, or invisible. Once the classes have been 
created, this check box toggles whether class visibility changes apply to the selected 
television.

Parts Classes 
Prefix

When screen parts are classed, creates a prefix for the class names so that they are sorted 
together

Note Adds a note, which can be placed on the drawing with the Text Options 
Text Options Opens the Text Options dialog box, to enable the display and format the text of labels; see 

“Formatting Video Screen Object Labels” on page 929
Update Updates the object when changes have been made to the Object Info palette parameters

Parameter Description
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Parameter Description

Module Shape Select a shape for the screen modules in the array

Tile Flat Creates rectangular-shaped modules
Tile Cap Creates rectangular-shaped modules with frosted caps
Disk Flat Creates round modules
Disk Cap Creates round modules with frosted caps
Tube Creates tube-shaped modules
Dome Creates dome-shaped modules

Width Specifies the width of each module in the array
Height For tiled arrays, sets the height (length) of each module in the array
Cap Depth For capped arrays, sets the depth of each module’s cap
Tube Orientation For tube arrays, specifies whether the tubes are oriented vertically or horizontally
Length For tube arrays, sets the length of one of the tube modules

Build Array Based 
On

Module Counts 
and Spacing

Sets the size of the entire LED array based on the number of modules specified in the 
horizontal and vertical directions, as well as the horizontal and vertical spacing distance set 
between the modules

Overall 
Dimensions and 
Spacing

Sets the size of the entire LED array based on the specified array width and height, as well 
as the horizontal and vertical spacing between the modules; the screen count is 
automatically calculated

Overall 
Dimensions and 
Module Counts

Sets the size of the entire LED array based on the specified array width and height, as will 
as the number of modules specified in the horizontal and vertical directions; the spacing is 
automatically calculated

Tile Flat Tile Cap Disk Flat

Disk Cap Tube Dome
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Array Width/Height Specifies the width and height of the entire LED array, when the array is based on overall 
dimensions

Horizontal/Vertical 
Spacing

Specifies the spacing between modules in the horizontal and vertical directions, when the 
array is based on spacing parameters

Horizontal/Vertical 
Count

Specifies the number of modules in the horizontal and vertical directions, when the array is 
based on the module counts

Module Total Displays the total calculated number of modules in the array
Width/Height (Calc.) Displays the calculated width and height of the array, when determined by module count 

and spacing
H/V Spacing (Calc.) Displays the calculated module spacing in the horizontal and vertical directions, when the 

array is determined by the overall dimensions and module counts
H/V Count (Calc.) Displays the total number of modules in the horizontal and vertical directions, when the 

array size is determined by the overall dimensions and module spacing
Pixels Per Module H/
V

Specifies the number of horizontal or vertical pixels for each module (for calculation 
purposes only; does not affect the module display)

Array Size (Pixels) Displays the total number of pixels for the entire LED array
Base Structure Select a base structure for the array, or select None to display only the module(s); modify 

the appearance of the structure by selecting Class LED Array Parts and then editing the 
structure class

Blocks Creates a structure of individual blocks bases for each module
Frame Creates a single frame for the entire array
Curtain Creates a single background for the array
Web Creates a webbed structure behind the modules
Vert. Strips Places the LED modules in vertical columns
Horiz. Strips Places the LED modules in horizontal rows
None Does not create a base structure for the array; displays only the LED modules

Base Width Specifies the width of blocks, vertical or horizontal strips, or the entire frame
Base Height Specifies the height of blocks, vertical or horizontal strips, or the entire frame

Parameter Description

Blocks Frame Curtain

Web Vert. Strips Horiz. Strips
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~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Image on the Video Screen
Formatting Video Screen Object Labels

Inserting a Video Screen Object 
Video screen objects consist of a video screen and optional front or rear projector.

Base Depth Specifies the depth of blocks, vertical or horizontal strips, or the entire frame
Horizontal Inset Sets the horizontal distance (margin) between the horizontal edge of the base structure and 

the array
Vertical Inset Sets the vertical distance (margin) between the vertical edge of the base structure and the 

array
Pleat Width For curtain or web structures, specifies the pleat width of the curtain (2D only for web 

structures)
Pleat Depth For curtain or web structures, specifies the pleat depth of the curtain (2D only for web 

structures)
Webbing Width For web structures, sets the width of the connecting web segments

Tilt Specifies the tilt angle of the screen array
Edit Array Image 
(Renderworks 
required)

Opens the Edit Screen Image dialog box

Array Image Displays the name of the current screen image
Simple 3D Creates a single textured 3D polygon to represent the screen modules; this speeds 

rendering when each module does not need to be shown individually
Class LED Array 
Parts

When first selected, automatically creates classes for the different parts of the LED screen 
and, if selected, the base structure., for appearance and visibility control. This allows 
portions of the screen or base to be set to visible, grayed, or invisible. Once the classes 
have been created, this check box toggles whether class visibility changes apply to the 
selected LED array.

Parts Classes 
Prefix

When screen parts are classed, creates a prefix for the class names so that they are sorted 
together

Note Adds a note, which can be placed on the drawing with the Text Options 
Text Options Opens the Text Options dialog box, to enable the display and format the text of labels; see 

“Formatting Video Screen Object Labels” on page 929
Default Text 
Positions

Restores text labels to their default positions

Update Updates the object when changes have been made to the Object Info palette parameters

Parameter Description
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To insert a video screen:

1. Click the Video Screen tool from the Spotlight tool set.
2. Click once in the drawing to set the object’s position. Click again to set the object’s rotation.
3. If this is the first time a video screen is placed on the drawing, the object properties dialog box opens. Specify the 

default preferences, which apply to all video screens placed subsequently in this drawing. Properties can be edited 
later in the Object Info palette. Click OK.

The height of the video screen and associated projector(s) depends on several factors. 
• The Z value entered in the Object Info palette determines the distance from the active layer plane to the bottom of 

the screen (including the border). 
• When the screen includes legs, the legs are drawn on the active layer plane unless a Floor Height value has been 

specified. The Floor Height distance shifts the floor, and therefore the legs, by that amount from the layer plane.
• Projector stands are inserted relative to both the Vertical Shift and Floor Height values, allowing stands to be 

shifted up or down from the screen’s floor as set by the Floor Height value.
The video screen object’s parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Screen Type Select the screen type: rear or front projector, or LED screen
Screen Aspect Select one of the standard screen aspect ratios, or choose custom screen dimensions
Stock Size Select one of the standard screen sizes based on height x width measurements
Width (image) Displays the width of the screen image area (without the screen border or frame) for 

standard screen sizes. For custom screens, enter the screen width; the screen height is 
automatically calculated for all custom screens (except rect. all custom dimensions).

Height (image) Displays the height of the screen image area (without the screen border or frame) for 
standard screen sizes. For custom screens, enter the screen height; the screen width is 
automatically calculated for all custom screens (except rect. all custom dimensions).

Diagonal (calc) Displays the calculated diagonal screen size
Diameter (image) For Round Custom screens, indicates the screen diameter
Frame Select the type of border around the image area: No Frame, a Frame with a specified 

thickness, or a flat Border Only
Border Width(s)
Top/Bottom/Left/
Right

For Frame and Border Only types, specify the width of the frame or border for each side 
of the frame or border
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Depth For Frame type, indicate the thickness of the frame
Edge For Frame type, sets the distance between the screen and the front face of the screen’s 

frame
Screen Tilt When no Screen Legs are selected, specifies the tilt of the screen in degrees. Positive 

values tilt the top of the screen away from the viewer, and negative values tilt it toward 
the viewer.

Total Clearance Displays the total vertical clearance height required by the complete video screen object 
from the floor to the top of the screen, including any border, dress kit, valence, or other 
accessories

Show Coverage Zone 
(2D only)

Indicates the viewing area based on the screen size; observers within the area should be 
able to see the screen

Zone Reference Calculates the coverage zone based on screen width, height, or diagonal measurement
Viewing Angle Indicates the maximum viewing angle of the screen relative to dead-on
Near Multiplier Specifies the multiplier of the reference dimension to determine the extent of the near 

coverage zone
Far Multiplier Specifies the multiplier of the reference dimension to determine the extent of the far 

coverage zone
Screen Support Select the type of screen support: None, Goalpost (includes two legs, and is similar to 

commercial “fastfold” systems), Tripod (creates a “roll-up” type support arrangement), 
Roll-Down Case, or Roll-Up Case

Show Feet For Goalpost configurations, select how the feet of the frame display: Both, Front, Back, 
or None

Depth For case supports, specifies the size of the case drawn at the top (roll-down case) or 
bottom (roll-up case) of the video screen; the case length is determined by the screen size

Motor For case supports, adds space to the case for the motor; select whether the motor is 
located on the right or the left, or select None for manually operated screens

Opening For case supports, sets the location on the case where the screen exits the case; select 
Front, Center, or Back

Add Dress Kit When Goalpost or Tripod screen legs are selected, adds a “dress kit” of draperies to 
conceal the projector (rear) and supports from audience view

Dress Kit Color Select the color of the dress kit draperies
Left Leg Width Indicates the width of the drapery on the left side of the screen

Parameter Description

Far coverage zone

Near coverage zone
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Right Leg Width Indicates the width of the drapery on the right side of the screen
Valence Height Sets the height of the drapery above the screen
Border Overlap Indicates the amount of overlap of the dress kit drapery over all sides of the screen’s 

border
Pleat Width Specifies the width of each pleated section of the left, right, and valence draperies
Pleat Depth Specifies the depth of the pleats for the left, right, and valence draperies

Hide Screen Toggles the display of the screen geometry
Edit Screen Image 
(Renderworks 
required)

Opens the Edit Screen Image dialog box 

Screen Image Displays the name of the current screen image
Show Projector Toggles the display of the projector unit
Show Projection 
Cone

Toggles the display of the projection cone

Projector Model Select the projector model from the default content (see “Resource Libraries” on 
page 219)

Projector Aspect For screens with a portrait orientation, select a standard projector aspect ratio
L/R Shift Shifts the projector to the left or right relative to the screen
Horiz. Offset Angle Displays the angle of offset from the projector to the screen, measured side to side on the 

horizontal plane and based on the L/R Shift value
Horiz. Offset Perc. Displays the angle of offset from the projector to the screen as a percentage
Point at Screen Center When the projector has been shifted to the left or right, keeps the projector pointed at the 

center of the screen 
Projector Tilt Sets the tilt of the projector, in degrees, relative to the horizontal plane
Place Based On Sets the position of the projector either based on a fixed lens size or the projection 

distance
Projection Dist. When Distance is selected for the projector placement, enter a distance value or click and 

drag the projectors on the drawing to set the distance
Lens Select a standard fixed or zoom lens size, or choose Custom. When the projector is placed 

based on distance, this displays the calculated lens size.
Zoom Factor For zoom or custom lenses, sets the lens zoom factor

Show Zoom Range For zoom lenses, indicates the optimal area on the drawing where the projector should be 
placed, to achieve the desired image size within the zoom range of the lens

Parameter Description

Zoom range 
indicator
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Vertical Position Select the projector placement mode:
• Screen Center: The center of the projector lens aligns with the screen center
• Align to Top: The top of the projector body aligns with the top of the top of the screen 

border
• Align to Bottom: The bottom of the projector body aligns with the bottom of the screen 

border
• Stand: Places the projector on a stand selected in Stand Model
• Rigged: Places the projector at a height specified in Floor Height with the bottom of 

the projector at the Trim height 
• Specific Shift: Shifts the projector relative to the screen center by the Vertical Shift 

distance, as measured from the center of the projector lens
Vertical Shift For projectors on a stand or with a specific shift, specifies the distance between the floor 

(as set by the Floor Height) and the stand or projector (this allows stands or projectors to 
be placed on a plane shifted up or down from the screen)

Stand Model For projectors on a stand, select the projector stand model from the default content (see 
“Resource Libraries” on page 219)

Floor Height For rigged projectors or projectors on a stand, indicates the distance from the active layer 
plane to the floor, effectively shifting the floor by the indicated height

L/R Shift For projectors on a stand, shifts the stand to the left or right, relative to the projector
F/B Shift For projectors on a stand, shifts the stand to the front or back, relative to the projector
Trim (bottom) For rigged projectors, indicates the location of the bottom of the projector
Vert. Offset Angle Displays the vertical offset angle of the projector to the screen, based on the vertical 

position of the projector
Vert. Offset Perc. Displays the vertical offset angle of the projector to the screen as a percentage

Multiple Projector When there is more than one projector, select whether they are stacked or side-by-side
Horiz Space For side-by-side multiple projectors, sets the distance between the projectors
Offset Distance For side-by-side multiple projectors, sets the offset distance between the screen and the 

second projector, relative to the first projector
Class Video Screen 
Parts

When first selected, automatically creates classes for the different parts of the video 
screen for appearance and visibility control. This allows portions of the video screen, 
projector, and other elements to be set to visible, grayed, or invisible. Once the classes 
have been created, this check box toggles whether class visibility changes apply to the 
selected video screen object.

Parts Classes Prefix When screen parts are classed, creates a prefix for the class names so that they are sorted 
together

Note Adds a note, which can be placed on the drawing with the Text Options 
Text Options Opens the Text Options dialog box, to enable the display and format the text of labels; see 

“Formatting Video Screen Object Labels” on page 929
Default Text 
Positions

Restores text labels to their default positions

Update Updates the object when changes have been made to the Object Info palette parameters

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Image on the Video Screen
Formatting Video Screen Object Labels

Inserting a Blended Screen and Projector 
The blended screen simulates projection screens that require multiple projectors to produce one large image.

To insert a blended screen and projector(s):

1. Click the Blended Screen tool from the Spotlight tool set.
2. Click once in the drawing to set the object’s position. Click again to set the object’s rotation.
3. If this is the first time a blended screen is placed on the drawing, the object properties dialog box opens. Specify 

the default preferences, which apply to all blended screens placed subsequently in this drawing. Properties can be 
edited later in the Object Info palette. Click OK.

When you insert a blended screen, a Blended Screen object is created. Once the parameters of the blended screen and 
projectors have been set, click Insert Projectors from the Object Info palette to create the projectors associated with 
that screen. The blended screen settings control the initial projector settings, though each projector can then be set 
independently (by changing parameters like text position or cone display) if needed. Moving or rotating a blended 
screen after the projectors have been inserted also moves or rotates the associated projectors. 

Use caution when clicking Insert Projectors if projectors have already been inserted; this deletes existing 
projectors and their parameter settings.

The height of the blended screen and associated projectors depends on several factors. 
• The Z value entered in the Object Info palette determines the distance from the active layer plane to the bottom of 

the screen (including the border). 
• When the screen includes legs, the legs are drawn on the active layer plane unless a Floor Height value has been 

specified. The Floor Height distance shifts the floor, and therefore the legs, by that amount from the layer plane.
• Projector stands are inserted relative to both the Vertical Shift and Floor Height values, allowing stands to be 

shifted up or down from the screen’s floor as set by the Floor Height value.
The blended screen and blended projector object parameters can be edited in the Object Info palette.

Blended Screen Parameters
Click to show/hide the parameters.

Parameter Description

Screen Type Select either front or rear projector
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Screen Name Provide a name for the screen object; associated blended projectors identify the screen 
by this name; if the name is already in use, the name that was already in use changes 
automatically

Width (image) Enter the width of the screen image area (without the screen border or frame)
Height (image) Enter the height of the screen image area (without the screen border or frame)
Screen Size (pixels) Displays the total screen size based on the screen dimensions
Frame Select the type of border around the image area: No Frame, a Frame with a specified 

thickness, or a flat Border Only
Border Widths
Top/Bottom/Left/
Right

For Frame and Border Only types, specify the width of the frame or border for each side 
of the frame or border

Depth For Frame type, indicate the thickness of the frame
Edge For Frame type, sets the distance between the screen and the front face of the screen’s 

frame
Screen Tilt When Add Folding Legs is selected, specifies the tilt of the screen in degrees. Positive 

values tilt the top of the screen away from the viewer, and negative values tilt it toward 
the viewer.

Total Clearance Displays the total vertical clearance height required by the complete blended screen 
object from the floor to the top of the screen, including any border, dress kit, valence, or 
other accessories

Screen Aspect (calc) Displays the aspect ratio of the screen
Show Coverage 
Zone (2D only)

Indicates the viewing area based on the screen size; observers within the area should be 
able to see the screen

Zone Reference Calculates the coverage zone based on screen width, height, or diagonal measurement
Viewing Angle Indicates the maximum viewing angle of the screen relative to dead-on
Near Multiplier Specifies the multiplier of the reference dimension to determine the extent of the near 

coverage zone
Far Multiplier Specifies the multiplier of the reference dimension to determine the extent of the far 

coverage zone

Parameter Description

Near coverage zone

Far coverage zone
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Screen Support Select the type of screen support: None, Goalpost Legs (includes two legs, and is 
similar to commercial “fastfold” systems), or Roll-Down Case

Show Feet For Goalpost Legs, select how the feet of the frame display: Both, Front, Back, or None
Depth For Roll-Down Case support, specifies the size of the case drawn at the top (roll-down 

case) or bottom (roll-up case) of the video screen; the case length is determined by the 
screen size

Motor For Roll-Down Case support, adds space to the case for the motor; select whether the 
motor is located on the right or the left, or select None for manually operated screens

Opening For Roll-Down Case support, sets the location on the case where the screen exits the 
case; select Front, Center, or Back

Add Dress Kit When goalpost legs are selected, adds a “dress kit” of draperies to conceal the projector 
(rear) and supports from audience view

Dress Kit Color Select the color of the dress kit draperies
Left Leg Width Indicates the width of the drapery on the left side of the screen
Right Leg Width Indicates the width of the drapery on the right side of the screen
Valence Height Sets the height of the drapery above the screen
Border Overlap Indicates the amount of overlap of the dress kit drapery over all sides of the screen’s 

border
Pleat Width Specifies the width of each pleated section of the left, right, and valence draperies
Pleat Depth Specifies the depth of the pleats for the left, right, and valence draperies

Edit Screen Image 
(Renderworks 
required)

Opens the Edit Screen Image dialog box

Screen Image Displays the name of the current screen image
Projector Model Select the projector model from the default content (see “Resource Libraries” on 

page 219); specify the projector settings, which apply to all projectors upon insertion
Projector Aspect Select the projector aspect ratio
Proj. Resolution Select the projector pixel resolution
Overshoot % Specifies the total amount of top and bottom overshoot to be discarded when using 

narrow aspect projectors to achieve a certain pixel blend
Projector Tilt Sets the tilt of the projector, in degrees, relative to the horizontal plane
Place Based On Sets the position of the projector either based on a fixed lens size or the projection 

distance
Projection Dist. When Distance is selected for the projector placement, enter a distance value or click 

and drag the projectors on the drawing to set the distance
Lens Select a standard fixed or zoom lens size, or choose Custom. When the projector is 

placed based on distance, this displays the calculated lens size.
Zoom Factor For zoom or custom lenses, sets the lens zoom factor

Parameter Description
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Vertical Position Select the projector placement mode:
• Screen Center: The center of the projector lens aligns with the screen center
• Align to Top: The top of the projector body aligns with the top of the top of the screen 

border
• Align to Bottom: The bottom of the projector body aligns with the bottom of the 

screen border
• Stand: Places the projector on a stand selected in Stand Model
• Rigged: Places the projector at a height specified in Floor Height with the bottom of 

the projector at the Trim height 
• Specific Shift: Shifts the projector relative to the screen center by the Vertical Shift 

distance, as measured from the center of the projector lens
Vertical Shift For projectors on a stand or with a specific shift, specifies the distance between the floor 

(as set by the Floor Height) and the stand or projector (this allows stands or projectors 
to be placed on a plane shifted up or down from the screen)

Stand Model For projectors on a stand, select the projector stand model from the default content (see 
“Resource Libraries” on page 219)

Floor Height For rigged projectors or projectors on a stand, indicates the distance from the active 
layer plane to the floor, effectively shifting the floor by the indicated height

Trim (bottom) For rigged projectors, indicates the location of the bottom of the projector
Multiple Projector When there is more than one projector (identical paired projectors for each section of 

the screen), select whether they are stacked or side-by-side
Horiz Space For side-by-side multiple projectors, sets the distance between the projectors

Area Horiz. Count Sets the number of areas into which the screen is divided; if the value entered is too 
small, the lowest possible number of areas is automatically set

Area Width Displays the width of each screen area
Area Height Displays the height of each screen area
Proj. Spacing Displays the distance between projectors, measured from the center of each projector 

lens
Overlap (meas.) Displays the amount of screen area overlap, measured in distance units
Overlap (pixels) Displays the amount of screen area overlap, measured in pixels
Overlap (%) Displays the amount of screen area overlap, as a percentage
Show Projection 
Cones

Toggles the display of the projection cone for all projectors associated with the screen

Class Blended 
Screen Parts

When first selected, automatically creates classes for the different parts of the blended 
screen for appearance and visibility control. This allows portions of the screen, 
projector, and other elements to be set to visible, grayed, or invisible. Once the classes 
have been created, this check box toggles whether class visibility changes apply to the 
selected video screen object.

Parts Classes Prefix When screen parts are classed, creates a prefix for the class names so that they are 
sorted together

Parameter Description
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Blended Projector Parameters
Click to show/hide the parameters.

Note Adds a note, which can be placed on the drawing with the Text Options 
Insert Projectors Inserts the required number of blended projectors based on the specified parameters; 

these projectors are associated with the blended screen. The projector model specified 
in Projector Model, and its associated parameters, apply to all inserted projectors.

Text Options Opens the Text Options dialog box, to enable the display and format the text of labels; 
see “Formatting Video Screen Object Labels” on page 929

Default Text 
Positions

Restores text labels to their default positions 

Update Updates the blended screen object and its associated projectors when changes have been 
made to the screen’s Object Info palette parameters; this also refreshes the associated 
projector information without changing individual blended projector parameters such as 
text options

Parameter Description

Screen Name Displays the name of the screen with which the projector is associated
Screen Parameters Displays the main screen parameters set by the blended screen
Show Projection Cone Toggles the display of the projection cone for this projector only
Projector Model Select the projector model from the default content (see “Resource Libraries” on 

page 219); by default, the projector model specified for the blended screen is selected, 
but can be overridden for individual blended projectors

Show Centerline 
(Area)

Displays the projector centerline in Top/Plan view

L/R Shift For projectors on a stand, shifts the stand to the left or right, relative to the projector
F/B Shift For projectors on a stand, shifts the stand to the front or back, relative to the projector
Horiz. Offset Angle Displays the angle of offset from the projector to the screen, measured side to side on 

the horizontal plane and based on the L/R Shift value
Horiz. Offset Perc. Displays the angle of offset from the projector to the screen as a percentage
Point at Screen Center When a L/R shift has been applied to the projector, rotates the projector body so that the 

projection remains pointed at the center of the projection cone area
 Tilt Sets the tilt of the projector, in degrees, relative to the horizontal plane
Place Based On Sets the position of the projector either based on a fixed lens size or the projection 

distance
Projection Dist. When Distance is selected for the projector placement, enter a distance value or click 

and drag the projectors on the drawing to set the distance
Lens Select a standard fixed or zoom lens size, or choose Custom. When the projector is 

placed based on distance, this displays the calculated lens size.
Zoom Factor For zoom or custom lenses, sets the lens zoom factor

Parameter Description
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Show Zoom Range For zoom lenses, indicates the optimal area on the drawing where the projector should 
be placed, to achieve the desired image size within the zoom range of the lens

Vertical Position Select the projector placement mode:
• Screen Center: The center of the projector lens aligns with the screen center
• Align to Top: The top of the projector body aligns with the top of the top of the screen 

border
• Align to Bottom: The bottom of the projector body aligns with the bottom of the 

screen border
• Stand: Places the projector on a stand selected in Stand Model
• Rigged: Places the projector at a height specified in Floor Height with the bottom of 

the projector at the Trim height 
• Specific Shift: Shifts the projector relative to the screen center by the Vertical Shift 

distance, as measured from the center of the projector lens
Vertical Shift For projectors on a stand or with a specific shift, specifies the distance between the floor 

(as set by the Floor Height) and the stand or projector (this allows stands or projectors 
to be placed on a plane shifted up or down from the screen)

Stand Model For projectors on a stand, select the projector stand model from the default content (see 
“Resource Libraries” on page 219)

Floor Height For rigged projectors or projectors on a stand, indicates the distance from the active 
layer plane to the floor, effectively shifting the floor by the indicated height

Trim (bottom) For rigged projectors, indicates the location of the bottom of the projector
Vert. Offset Angle Displays the vertical offset angle of the projector to the screen, based on the vertical 

position of the projector
Vert. Offset Perc. Displays the vertical offset angle of the projector to the screen as a percentage
Multiple Projector When there is more than one projector (identical paired projectors for each section of 

the screen), select whether they are stacked or side-by-side
Horiz Space For side-by-side multiple projectors, sets the distance between the projectors

Note Adds a note, which can be placed on the drawing with the Text Options 
Text Options Opens the Text Options dialog box, to enable the display and format the text of labels; 

see “Formatting Video Screen Object Labels” on page 929
Default Text Positions Restores text labels to their default positions
Update Updates the object when changes have been made to the Object Info palette parameters

Parameter Description

Zoom range 
indicator
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~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Image on the Video Screen
Formatting Video Screen Object Labels

Setting the Image on the Video Screen
Select an image to display on the video screen or LED screen (Renderworks required). The Vectorworks Spotlight 
product includes a number of sample images, or you can create your own textures. Textures must use an image color 
shader with constant reflectivity to display on the video screen (see “Creating Textures” on page 1505).
To set the video screen image:

1. Select a video screen object, blended screen, or LED screen object. From the Object Info palette, click Edit 
Screen Image or Edit Array Image.
The Edit Screen Image or Edit Array Image dialog box opens.

Click to show/hide the parameters.

2. If needed, adjust the image scale, and shift the image horizontally or vertically until it appears correctly in the 
preview, and then click OK. 

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Video Screen Objects
Inserting an LED Screen
Formatting Video Screen Object Labels

Formatting Video Screen Object Labels
A variety of video screen object labels can be included on the drawing. Different options are available depending on the 
video screen object.
To select labels for display and format the text:

1. Select a video screen object. From the Object Info palette, click Text Options.
The Text Options dialog box opens.

Parameter Description

Screen Image Select the screen image to display on the television, LED, or video screen from either 
the default content (see “Resource Libraries” on page 219) or the current file’s textures. 

Image Adjustments If the selected image does not have the desired size or position in the Preview, adjust its 
scale or position

Scale Increases or decreases the image scale
Horizontal Shift Shifts the image horizontally to the left or right
Vertical Shift Shifts the image vertically up or down

Tile Image Repeats the image over the screen; deselect to show only a single instance of the image; 
does not apply to LED screens

Preview Displays the screen image at the correct aspect ratio for the video screen
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2. Specify the text labels and formatting, and then click OK.
Once the labels have been added to the drawing, they can be moved by clicking and dragging the label control point. 
Click Default Text Positions from the Object Info palette of a selected video object to restore the text labels to their 
original locations.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Video Screen Objects

Inserting Speakers and Speaker Arrays
Audio objects, including speakers and arrays of speakers, are often a required part of visualizing a room or stage layout 
for event planning and entertainment design, and can also be needed for theater productions. Vectorworks creates 
speaker system layout drawings and can perform basic audio coverage analysis. The speakers and speaker arrays can be 
labeled with information and calculated data and can display the optimum listening area for up to three ranges.

Text Option Description

Coverage Zone Displays the near and far coverage zone distances and multipliers at the specified text size 
and color

Image Dimensions Displays the screen image dimensions, and if selected, the image size, screen clearance, 
and aspect ratio values, at the specified text size, color, and alignment. If desired, the 
image dimension text order can be changed from the default height x width to width x 
height instead, by selecting Swap Dimension Order.

Lens Information Displays the projector lens size at the specified text size, color, and alignment
Projection Distance Displays the distance from the projector to the screen at the specified text size, color, and 

alignment. Select the options to show the straight (plan) distance in 2D, direct distance 
(projector throw distance) in 2D, and/or actual distance in 3D. A dimension line can be 
included; specify the marker size. 

Projector IDs Labels the projector body with the entered ID information (such as projector name), at the 
specified text size and color. Any Note text is not displayed, but stores internal 
information about the projector. 

Multiple Projector Tag Displays the multiple projector layout for stacked projectors at the specified text size and 
color

Show Array 
Dimensions

For LED screen arrays, displays the overall array dimensions and total number of modules 
at the specified text size, color, and alignment

Note Show the text entered for Note in the Object Info palette of the video screen object, at the 
specified text size, color, and alignment. A Note Label prefix can also be included; enter 
the contents of the prefix.

Keep Text Horizontal Maintains the text in a horizontal position even when the object is rotated; deselect this 
option to rotate the label along with the object

Fill Text Background Allows a text background fill to be used for all video screen text; by default, white is used 
as the fill color. To specify a different fill color, select the Object Info palette option to 
class the parts of the video screen object, and then select a fill color for the class of the 
video screen text. The class should be set to Use at Creation.

Label control point
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The Vectorworks Spotlight software comes with default speaker data located in the audio tools folders of the 
[Vectorworks]\Libraries folder that is included with the Vectorworks Spotlight product (see “Resource Libraries” on 
page 219). You can also save speaker data to a library file, which can be shared with others, and you can import speaker 
data from other files. The file(s) must be located within the Audio Tools\Speakers or Audio Tools\Bumpers folders.

Another way to share speakers or speaker arrays is to create symbols from them and import the symbol into 
another file.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Speakers
Inserting Speaker Arrays
Formatting Speaker Object Labels

Inserting Speakers 
Individual speakers that are not part of an array are inserted with the Speaker tool. Manually-inserted speakers can be 
placed as single speakers, or as several speakers arranged in a column. A variety of supports and labeling options are 
available. Use a speaker type and information with pre-set data from the speaker library file located in the 
[Vectorworks]\Libraries folder that is included with the Vectorworks Spotlight product (see “Resource Libraries” on 
page 219), or create a speaker with custom data and save it to the library for future use and sharing.

To insert a speaker:

1. Click the Speaker tool from the Spotlight tool set.
2. Click once in the drawing to set the object’s position. Click again to set the object’s rotation.
3. If this is the first time a speaker is placed on the drawing, the object properties dialog box opens. Specify the 

default preferences, which apply to all speakers placed subsequently in this drawing. Properties can be edited later 
in the Object Info palette. Click OK.

The speaker object’s parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Speaker arrays Speaker
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Parameter Description

Type Select a speaker from the default speaker data available in the library file; alternatively, 
select <Generic> to create a speaker with custom data and then save the speaker as a 
custom speaker in the library file. 
Select Import to import predefined speaker data only (such as width and weight) from a 
default content library file or other file containing speakers. The Import Speaker Type 
dialog box opens to select the file and type. A symbol is not imported from the file; only 
data is added.

Brand Specifies the speaker manufacturer
Model Specifies the manufacturer’s information
Front Width/Height Indicates the width and height of the front face of the speaker
Back Width/Height Indicates the width and height of the back face of the speaker; the back face cannot be 

larger than the front face
Depth Specifies the speaker depth
Flip Orientation Rotates the speaker 90° to place the speaker on its side
Tilt Reference When the speaker is in an array, sets the reference for tilting the speaker to either the 

front or back face
Weight Indicates the weight of the speaker
Self-Powered Indicates whether the speaker uses an internal or remote amplifier
Expand Dispersion 
Features

When selected, allows you to enter range notes and dispersion area information for up to 
three ranges; deselect to enter only Overall information

Range 1/2/3 Enter notes for three dispersion ranges, such as a frequency range, key frequency, or 
crossover point. When Expand Dispersion Features is deselected, the range is 
automatically set to Overall and only one set of notes can be entered.

Horiz./Vert. 
Dispersion

Enter the horizontal and vertical dispersion angle(s), from 0 to 180°; ranges 2 and 3 are 
only available when Expand Dispersion Features is selected

Throw Distance Sets the throw distance reference for the dispersion lines; ranges 2 and 3 are only 
available when Expand Dispersion Features is selected

Save Type to Library Saves the current speaker configuration as a new speaker type; enter the name of the 
speaker type. This custom speaker can then be selected from the Type list.

Delete Type from 
Library

Removes the speaker currently selected in Type from the library file; the current 
parameters remain as set, and the type becomes <Generic>

Listening Height Sets the listening height reference for the dispersion lines. Listening height must be less 
than the speaker’s elevation (Z value).



Inserting Speakers and Speaker Arrays |  933
Show Dispersion 
Range 1/2/3

Draws the top, bottom, left, and right dispersion lines, along with a center reference line, 
for each of the three dispersion ranges selected for display (or the Overall range if 
expanded dispersion is not selected). An outline or hatch pattern representing the 
listening area coverage “shadow” is drawn when the throw distance and the vertical 
dispersion and tilt angles allow the speaker to cover the area at or below the Listening 
Height.

Show Dispersion 
Hatch

Displays hatch fills in the coverage shadow of each enabled dispersion range

Support Select the support method for the speaker. The options are for reference only, except for 
Tripod, which creates a tripod floor stand in the drawing, and Ground-Stacked, which 
allows speakers in an array to be ground-stacked rather than flown.

Stand Height For tripod support, sets the height of the floor stand
Tilt Difference Displays the tilt difference between the selected speaker and the one above it
Actual Tilt Angle Specifies the tilt angle of the speaker, from -90 to 90°
Location Indicates the speaker location (such as Downstage Right)
Purpose Indicates the purpose of the speaker (such as Center Fill)
Rack Enter notes about the rack driving the speaker
Drive Line Indicates information about the drive line feeding the signal to the speaker
Column ID An individual speaker can optionally be part of a column of speakers or in a speaker 

array. This specifies the column ID. Speakers in the same column receive a stacked 
Column ID when Arrange Column is clicked.

Position in Column When speakers are arranged in a column or array, indicates the speaker’s position in the 
stack. Position 1 is the top speaker.

Arrange Column Provides selected speakers with a Column ID in order of their arrangement, based on 
their elevation (Z value); calculates tilt differences, and assigns each speaker a Position 
in Column number 

Notes Enter miscellaneous notes such as rental source or stock number

Parameter Description

Dispersion line

Coverage shadow
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~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Speakers and Speaker Arrays
Formatting Speaker Object Labels
Inserting Speaker Arrays

Inserting Speaker Arrays 
Large venues require the use of speaker arrays, which consist of speakers stacked in a column and topped by a bumper 
(top mounting bracket). Up to three different types of speakers can be included in an array. The speakers can each be 
tilted differently to provide maximum audio coverage for the audience.

To insert a speaker array:

1. Click the Speaker Array tool from the Spotlight tool set.
2. Click once in the drawing to set the object’s position. Click again to set the object’s rotation.
3. If this is the first time a speaker array is placed on the drawing, the object properties dialog box opens. Specify the 

default preferences, which apply to all arrays placed subsequently in this drawing. Properties can be edited later in 
the Object Info palette. Click OK.

4. A bumper is inserted on the drawing. From the Object Info palette, click Configure Array.
The Array Detail and Configuration dialog box opens. Specify the bumper parameters on the Bumper tab.

Click to show/hide the parameters.

Class Speaker Parts When first selected, automatically creates classes for the different parts of the speaker, 
for appearance and visibility control. This allows portions of the cabinets, grills, and 
other elements to be set to visible, grayed, or invisible. Different textures can be applied 
to the different part classes (Renderworks required), for a highly realistic appearance. 
Once the classes have been created, this check box toggles whether class visibility 
changes apply to the selected speaker object. You may need to click Update to view any 
changes.

Parts Classes Prefix When speaker parts are classed, enter a prefix for the class names so that they are sorted 
together

Text Options Opens the Text Options dialog box, to enable the display and format the text of labels; 
see “Formatting Speaker Object Labels” on page 939

Default Text Position Restores text labels to their default positions 
Update Updates the object when changes have been made to the Object Info palette parameters. 

For example, you may need to refresh the display when toggling Class Speaker Parts on 
and off, when the attributes of the speaker parts have been set by class.

Parameter Description
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5. On the Speaker A, B, and C tabs, configure up to three types of speakers for inclusion in the array. If speaker B 
and/or C are not to be included, select a Type of None on those tabs.

Click to show/hide the parameters.

Parameter Description

Definition
Type Select a bumper from the default bumper data available in the library file; alternatively, 

select <Generic> to create a bumper with custom data and then save the bumper as a 
custom bumper in the library file. 
Select Import to import predefined bumper data only (such as width and weight) from a 
default content library file or other file containing bumpers. The Import Bumper Type 
dialog box opens to select the file and type. A symbol is not imported from the file; only 
data is added.
Select None to have no bumper included in the speaker array, such as for ground-stacked 
speakers or speakers with built-in hardware for installation.

Brand Specifies the bumper manufacturer
Model Specifies the manufacturer’s information
Save Type to 
Library

Saves the current bumper configuration as a new bumper type; enter the name of the 
bumper type. This custom bumper can then be selected from the Type list.

Delete Type from 
Library

Removes the speaker currently selected in Type from the library file; the current 
parameters remain as set, and the type becomes <Generic>

Attributes

Total Width Indicates the width of the entire bumper
Rear Width Sets the width of the bumper at the back of the bumper
Total Depth Specifies the total depth of the bumper
Side Depth Sets the depth of the bumper at the side
Thickness Specifies the thickness of the bumper
Hardware Width Sets the width of the bumper hardware (brackets)
Weight Specifies the bumper weight

Preview Displays a preview of the bumper, which updates as parameters change; the arrow 
indicates the front face

Total depth

Total width

Rear width

Side depth
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Parameter Description

Definition
Type Select a speaker from the default speaker data available in the library file; alternatively, 

select <Generic> to create a speaker with custom data and then save the speaker as a 
custom speaker in the library file. 
Select Import to import predefined speaker data only (such as width and weight) from a 
default content library file or other file containing speakers. The Import Speaker Type 
dialog box opens to select the file and type. A symbol is not imported from the file; only 
data is added

Brand Specifies the speaker manufacturer
Model Specifies the manufacturer’s information
Save Type to 
Library

Saves the current speaker configuration as a new speaker type; enter the name of the 
speaker type. This custom speaker can then be selected from the Type list.

Delete Type from 
Library

Removes the speaker currently selected in Type from the library file; the current 
parameters remain as set, and the type becomes <Generic>

Attributes
Front Width/Height Indicates the width and height of the front face of the speaker
Back Width/Height Indicates the width and height of the back face of the speaker; the back face cannot be 

larger than the front face
Depth Specifies the speaker depth
Flip Orientation Rotates the speaker 90° to place the speaker on its side
Tilt Reference For speakers in an array, sets the reference for tilting the speaker to either the front or back 

face

Weight Indicates the weight of the speaker
Self-Powered Indicates whether the speaker uses an internal or remote amplifier

Dispersions
Override Vertical 
Dispersion(s) with 
Array Angles

Calculates the dispersion based on the array’s Angle Relative to Preceding value for each 
speaker set on the Array tab, rather than the individual speaker’s vertical dispersion angles

Expanded Dispersion When selected, allows you to enter range notes and dispersion area information for up to 
three ranges; deselect to enter only Overall information

Range 1/2/3 Enter notes for three dispersion ranges, such as a frequency range, key frequency, or 
crossover point. When Expanded Dispersion is deselected, the range is automatically set 
to Overall and only one set of notes can be entered

Horiz./Vert. 
Dispersion

Enter the horizontal and vertical dispersion angle(s), from 0 to 180°; ranges 2 and 3 are 
only available when Expanded Dispersion is selected

Throw Distance Sets the throw distance reference for the dispersion lines; ranges 2 and 3 are only available 
when Expanded Dispersion is selected

Preview Displays a preview of the speaker, which updates as parameters change; the arrow 
indicates the front face
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6. Set up the array configuration on the Array tab.
Click to show/hide the parameters.

7. Click OK to create the speaker array. From the Object Info palette, click Insert Speakers to add the speakers to 
the drawing.

The speaker array properties can be edited in the Object Info palette. To edit the array, select the bumper. Individual 
speakers can be selected and certain parameters can be set independently, but since the speakers are controlled by the 
array, many of their parameters are not available (see “Inserting Speakers” on page 931 for parameter descriptions). 
Click to show/hide the parameters.

Parameter Description

Array Support Specify how the speaker array is supported: Flown-Motors, Flown-Crank Lift, 
Ground-Stacked, or Tripod. Flown arrays place the speakers below the bumper. 
Ground-stacked arrays are inserted above the bumper. Arrays supported by a tripod do not 
include a bumper.

Bumper Type Displays the bumper type that was selected on the Bumper tab (does not apply to 
tripod-supported arrays)

Bumper Angle Sets the angle of the bumper, establishing a starting angle for the top mounting (does not 
apply to tripod-supported arrays)

First Speaker Shift Controls the offset of the speaker stack from the bumper. Enter a positive value to shift the 
speaker stack towards the rear of the bumper; enter a negative value to offset the speaker 
stack towards the front of the bumper.

Tripod Height For tripod-supported arrays, specifies the height at the top of the tripod
Definition Lists the speakers that make up the array and their relative and actual dispersion angles, in 

order from top to bottom starting from below the bumper. Add speakers to the list by 
selecting one or more from the Speaker Types to Add list, and then clicking Add/Swap 
Speaker(s). To re-order the speakers, click the # column of the speaker to be moved, and 
drag it up or down the list. A horizontal line indicates where the speaker will be inserted in 
the current order. 

Speaker Types to Add Lists the speaker(s) defined on the Speaker tabs. These speakers are available for 
placement in the array. 

Add/Swap Speaker(s) Adds one or more selected speakers to the array; to swap speakers, select the speaker(s) to 
be replaced in the Definition list first. To add speakers without swapping, ensure that no 
speakers are highlighted in the Definition list.

Type Counts Lists the number of each type of speaker, as well as the total number of speakers, included 
in the array

Delete Speaker(s) Deletes the speaker(s) selected in the Definition list
Angle Relative to 
Preceding

Sets the angle of the speaker(s) selected in the Definition list. Individual speakers have 
range dispersion angle settings, but these can be overridden to use this angle set for the 
array instead. The Rel° and Act° angles in the Definition list update to reflect the current 
speaker angles.

Preview Displays a preview of the speaker array, which updates as parameters change; the arrows 
indicate the front face



  938 | Inserting Speakers and Speaker Arrays
Parameter Description

Array Details
Column ID Specifies a name for the bumper-speaker combination that makes up the array
Location Indicates the array location (such as Downstage Right)
Purpose Indicates the purpose of the array (such as Center Fill)
Rack Enter notes about the rack driving the speaker
Drive Line Indicates information about the drive line feeding signal to the speaker
Notes Enter miscellaneous notes such as rental source or stock number

Configure Array Opens the Array Detail and Configuration dialog box, to view and edit speaker array 
parameters

Current Types Lists the bumper and speakers that make up the array, along with speaker counts
Total Weight Displays the total weight of all the array components, including the bumper; click Insert 

Speakers if not displayed
Bottom Box Trim Displays the vertical trim of the bottom speaker; click Insert Speakers if not displayed
Listening Height Sets the listening height reference for the speakers’ dispersion lines. Listening height must 

be less than any speaker’s elevation (Z value).
Override A/B/C Vert. 
Disp. with Array 
Angles

Calculates the dispersion based on the array’s Angle Relative to Preceding value for each 
speaker set on the Array tab, rather than the individual speaker’s vertical dispersion angles 

Show Dispersion for 
Range 1/2/3

Draws the top, bottom, left, and right dispersion lines for each of the three dispersion 
ranges selected for display, for each speaker (or the Overall range if expanded dispersion 
is not selected). When applicable, a center reference line is drawn for each of the three 
dispersion ranges, for each of the speaker models in the array. An outline or hatch pattern 
representing the listening area coverage “shadow” is drawn when the throw distance and 
the vertical dispersion and tilt angles allow the speaker to cover the area at or below the 
Listening Height.

Show Dispersion 
Hatch

Displays hatch fills in the coverage shadow of each enabled dispersion range

Class Speaker Array 
Parts

When first selected, automatically creates classes for the different parts of the speaker, for 
appearance and visibility control. This allows portions of the cabinets, grills, and other 
elements to be set to visible, grayed, or invisible. Different textures can be applied to the 
different part classes (Renderworks required), for a highly realistic appearance. Once the 
classes have been created, this check box toggles whether class visibility changes apply to 
the selected speaker object. You may need to click Update to view any changes.
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~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Speakers and Speaker Arrays
Formatting Speaker Object Labels
Inserting Speakers

Formatting Speaker Object Labels 
A variety of speaker and speaker array labels can be included on the drawing. Different options are available for 
speakers and speaker arrays. A speaker array, as well as the individual speakers that make up the array, can be labeled.
To select labels for display and format the text:

1. Select a speaker or speaker array object (bumper). From the Object Info palette, click Text Options.
The Text Options dialog box opens.

Click to show/hide the parameters.

2. Specify the text label elements and formatting, and then click OK.

Parts Classes Prefix When speaker parts are classed, enter a prefix for the class names so that they are sorted 
together

Insert Speakers The first time the speaker array is created, click Insert Speakers after exiting the Array 
Detail and Configuration dialog box, to add the speakers to the array

Text Options Opens the Text Options dialog box, to enable the display and format the text of labels; see 
“Formatting Speaker Object Labels” on page 939

Default Text Position Restores text labels to their default positions 
Update Updates the object when changes have been made to the Object Info palette parameters. 

For example, you may need to refresh the display to update the dispersion ranges and 
hatch after overriding the dispersion calculations.

Parameter Description

Optional Elements to 
Show

Select items to add to the text label; different label elements are available for speakers and 
speaker arrays

Show Element Labels Includes the name of the element along with the value; deselect this option to display the 
parameter value only

Text Attributes
Keep Text 
Horizontal

Maintains the text in a horizontal position even when the object is rotated; deselect this 
option to rotate the label along with the object

Fill Text 
Background

Allows a text background fill to be used for all speaker object text; by default, white is 
used as the fill color. To specify a different fill color, select the Object Info palette option 
to class the parts of the speaker object, and then select a fill color for the class of the 
speaker text. The class should be set to Use at Creation.

Text formatting 
options

Specify the text size, color, and alignment

Parameter Description
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Once the label has been added to the drawing, it can be moved by clicking and dragging the label control point. Click 
Default Text Position from the Object Info palette of a selected speaker or array object to restore the text label(s) to the 
original location.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Speakers and Speaker Arrays
Inserting Speakers
Inserting Speaker Arrays

Inserting a Stage Lift
A stage lift object can be added to a drawing to represent the typical adjustable support device commonly found on 
stage for supporting speakers, trusses, and other stage equipment. The stage lift can be shown extended or collapsed, 
with a specific appearance and fork position, and can be labeled.

To insert a stage lift:

1. Click the Stage Lift tool from the Spotlight tool set.
2. Click once in the drawing to set the object’s position. Click again to set the object’s rotation.
3. If this is the first time a stage lift is placed on the drawing, the object properties dialog box opens. Specify the 

default preferences, which apply to all stage lifts placed subsequently in this drawing. Properties can be edited 
later in the Object Info palette. Click OK.

The stage lift parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Stored When selected, folds the stage lift and fully retracts the mast; forks and support legs are 
placed in the stored position. Certain parameters are not available when the stage lift is in 
stored position.

Fork Position Select whether the forks are in the up or down position, or whether the lift has no forks

Label control point

2D view 3D view Stored 3D view
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~~~~~~~~~~~~~~~~~~~~~~~~~
Formatting Stage Lift Labels

Formatting Stage Lift Labels 
A variety of stage lift labels can be included on the drawing. Text must be entered into the associated field of the Object 
Info palette for the label to be included.
To select labels for display and format the text:

1. Select a stage lift object. From the Object Info palette, click Text Options.
The Text Options dialog box opens.

Click to show/hide the parameters.

Height Sets the height of the forks; the mast extends automatically to add height to the stage lift, up 
to the maximum possible height

Maximum Height Displays the maximum possible height that can be set for the forks, when all mast sections 
have been extended

Width Specifies the spacing of the forks, as measured inside the forks; set the width to 0 to hide 
the forks, but keep the crossbar visible

Orientation Select whether the forks are oriented horizontally or vertically
Forks Select gray or black for the color of the forks
Mast Select black or silver for the color of the mast

3D Colors
Legs and Base Select gray or black for the color of the legs and base when the lift is viewed in 3D
Hardware Select silver or black for the color of the hardware when the lift is viewed in 3D

Name, Lift Type, 
Location, Load Type, 
Load Weight, Note

Adds information which can be placed on the drawing with the Text Options 

Class Stage Lift Parts When first selected, automatically creates classes for the different parts of the stage lift for 
appearance and visibility control. This allows portions of the stage lift to be set to visible, 
grayed, or invisible. Once the classes have been created, this check box toggles whether 
class visibility changes apply to the selected stage lift object.

Parts Classes 
Prefix

When stage lift parts are classed, creates a prefix for the class names so that they are sorted 
together

Text Options Opens the Text Options dialog box, to enable the display and format the text of labels; see 
“Formatting Stage Lift Labels” on page 941

Default Text Position Restores text labels to their default positions
Update Updates the object when changes have been made to the Object Info palette parameters

Parameter Description

Elements to Show Select items to add to the text label
Text Attributes

Parameter Description
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2. Specify the text label elements and formatting, and then click OK.
Once the label has been added to the drawing, it can be moved by clicking and dragging the label control point. 
Click Default Text Position from the Object Info palette of a selected stage lift object to restore the text label(s) to 
the original location.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting a Stage Lift

Inserting Stage Structures
Vectorworks includes several different types of rectangular, round, and free-form stage structures, along with the 
specialized, industry-standard steps and ramps to access them. These theatrical and event staging structures can range 
from simple, basic forms to complex structures with customized textures for a realistic appearance (Renderworks 
required). The event design commands also make use of these structures.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting a Stage Deck
Inserting a Stage Plug
Inserting Stage Steps
Inserting a Stage Ramp

Inserting a Stage Deck
The Stage Deck tool inserts rectangular and rounded portable stage structures into a drawing. The type, shape, size, 
appearance, and presence of railings can be customized. Place several stage decks to create a large stage area.

Keep Text 
Horizontal

Maintains the text in a horizontal position even when the object is rotated; deselect this 
option to rotate the label along with the object

Fill Text 
Background

Allows a text background fill to be used for all stage lift text; by default, white is used as the 
fill color. To specify a different fill color, select the Object Info palette option to class the 
parts of the stage lift object, and then select a fill color for the class of the stage lift text. The 
class should be set to Use at Creation.

Text formatting 
options

Specify the text size, color, and alignment

Parameter Description

Label control point
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To insert a stage deck:

1. Click the Stage Deck tool from the Spotlight tool set.
2. Click once in the drawing to set the object’s position. Click again to set the object’s rotation.
3. If this is the first time a stage deck is placed on the drawing, the object properties dialog box opens. Specify the 

default preferences, which apply to all stage decks placed subsequently in this drawing. Properties can be edited 
later in the Object Info palette. Click OK.

The stage deck parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Deck Shape Creates a rectangular or round stage
Height Specifies the overall stage height
Depth/Width 
(rectangular shape)

Specifies the dimensions of a rectangular stage deck

Radius/Diameter/
Sweep Angle (round 
shape)

Specifies the size of a round stage deck

Top Surface Area Displays the calculated surface area of the stage
Structure Select the type of stage construction, from simple to complex

Deck Details
Hide Deck For the Legs-Braced structure types, hides the deck and shows the braced leg supports 

only
Top Thickness Sets the thickness of the deck.

The thickness of the deck cannot be set for Border and Simple stage deck structures.
Top Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options
Trim Height Sets the height of the trim around the stage

Legs-Basic Legs-Braced 
(rectangular shape only)

Folding (rectangular 
shape only)

Deck Only Border Simple
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Trim Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options
Border Color/Texture For the Border structure type, displays the texture (Renderworks required) or color 

selected in the 3D Options
Leg/Structure Details

Diameter For structure types with legs, sets the diameter of the leg supports
Profile For structure types with legs, select a round, square, or octagonal shape for the legs
Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options
Reference Spacing For Legs-Basic and Legs-Braced, sets an approximate spacing value for the legs; the 

exact spacing is determined automatically by evenly dividing the length of the deck
Total Legs For structure types with legs, displays the number of legs
Add Casters For the Legs-Basic and Legs-Braced (rectangular shape only) structure types, adds 

casters to the legs to create a rolling platform
Wheel Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options

Rail Details All railing bars are automatically evenly spaced
Front/Back/Left/
Right (rectangular 
shape)

Select the type of railing to add to each side of the stage deck, or select None for no 
railing

Parameter Description

Straight Box Open Box Filled Toe

Straight + Toe Box Open + Toe Box Filled + Toe
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Start Radius/ End 
Radius/ Arc (round 
shape)

For round deck shapes, select the type of railing to add to each side of the stage deck, or 
select None for no railing. Rounds decks are limited to Straight, Toe, or Straight + Toe 
railing types.

Height Sets the height of the top of the railing
Add’l Horiz. Bars
(Straight and Straight 
+ Toe)

Specifies the number of additional horizontal bars to add to the railing

Add’l F/B Uprights 
(rectangular shape)

For rectangular deck shapes, adds additional vertical bars to the front and back rails

Add’l L/R Uprights 
(rectangular shape)

For rectangular deck shapes, adds additional vertical bars to the left and right rails

Add’l Radii Uprights 
(round shape)

For round deck shapes, adds additional vertical bars to the start and end radius rails

Add’l Arc Uprights 
(round shape)

For round deck shapes, adds additional vertical bars to the arc rails

Profile Select a round, square, or octagonal shape for the railings
Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options

Class Stage Deck Parts When first selected, automatically creates classes for the different parts of the stage deck, 
for appearance and visibility control. This allows portions of the stage deck to be set to 
visible, grayed, or invisible. Once the classes have been created, this check box toggles 
whether class visibility changes apply to the selected stage deck object.

Parts Classes Prefix When stage deck parts are classed, creates a prefix for the class names so that they are 
sorted together

Purpose/ Set Cart ID Enter information about the stage which can be placed on the drawing with Text 
Options (does not affect the stage appearance)

Note Adds a note, which can be placed on the drawing with the Text Options
3D Options Specifies the appearance of applicable deck elements in 3D views. The 3D Options 

dialog box opens.
For each available portion of the stage, either select the color from the Color list, or, 
when Renderworks is installed, select Custom Texture and then select the texture from 
the Texture list. The Object Info palette displays the color or texture selections in the 
relevant section.

The appearance of Simple stage decks is set from the Attributes palette.

Parameter Description

Arc railing

Start radius railing

End radius railing
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~~~~~~~~~~~~~~~~~~~~~~~~~
Formatting Stage Labels
Inserting a Stage Plug

Inserting a Stage Plug
The Stage Plug tool inserts custom shaped stage structures into a drawing. The type, shape, size, and appearance can be 
customized.

To insert a stage plug:

1. Click the Stage Plug tool from the Spotlight tool set.
2. Click on the appropriate mode in the Tool bar to select the boundary creation method of the stage.

For more information on the Polyline tool modes, see “Creating Polylines” on page 298.
3. Click to set the stage’s start point.
4. Click to set the end of the segment and the beginning of the next. Continue drawing segments in this manner until 

the stage object is complete.
5. If this is the first time a stage plug is placed on the drawing, the object properties dialog box opens. Specify the 

default preferences, which apply to all stage plugs placed subsequently in this drawing. Properties can be edited 
later in the Object Info palette. Click OK.

The stage plug can be reshaped with the Reshape tool; see “Reshaping Objects” on page 1043. The stage plug 
parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Text Options Opens the Text Options dialog box, to enable the display and format the text of labels; 
see “Formatting Stage Labels” on page 948

Default Text Positions Restores text labels to their default positions
Update Updates the object when changes have been made to the Object Info palette parameters

Parameter Description

Stage Height Specifies the overall stage height
Top Surface Area Displays the calculated surface area of the stage

Parameter Description
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Structure Select the type of stage construction

Deck Details
Top Thickness Sets the thickness of the deck.

The thickness of the deck cannot be set for Border and Simple stage plug 
structures.

Top Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options
Trim Height Sets the height of the trim around the stage
Trim Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options

Leg Details
Diameter For the Legs-Basic structure type, sets the size of the leg supports
Profile For the Legs-Basic structure type, select a round, square, or octagonal shape
Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options
Reference Spacing For the Legs-Basic structure type, sets an approximate spacing value for the legs; the 

exact spacing is determined automatically by evenly dividing the length of the deck
Total Legs For the Legs-Basic structure type, displays the number of legs
Add Casters For the Legs-Basic structure type, adds casters to the legs to create a rolling platform
Wheel Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options

Class Stage Plug Parts When first selected, automatically creates classes for the different parts of the stage 
plug, for appearance and visibility control. This allows portions of the stage plug to be 
set to visible, grayed, or invisible. Once the classes have been created, this check box 
toggles whether class visibility changes apply to the selected stage plug object.

Parts Classes Prefix When stage plug parts are classed, creates a prefix for the class names so that they are 
sorted together

Purpose/ Set Cart ID Enter information about the stage which can be placed on the drawing with Text 
Options (does not affect the stage appearance)

Note Adds a note, which can be placed on the drawing with the Text Options

Parameter Description

Legs-Basic Deck Only

Border Simple
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~~~~~~~~~~~~~~~~~~~~~~~~~
Formatting Stage Labels
Inserting a Stage Deck

Formatting Stage Labels
A variety of stage labels can be included on the drawing. For some options, text must be entered into the associated 
field of the Object Info palette for the label to be included.
To select labels for display and format the text:

1. Select a stage deck or stage plug object. From the Object Info palette, click Text Options.
The Text Options dialog box opens.

Click to show/hide the parameters.

3D Options Specifies the appearance of applicable deck elements in 3D views. The 3D Options 
dialog box opens.
For each available portion of the stage, either select the color from the Color list, or, 
when Renderworks is installed, select Custom Texture and then select the texture from 
the Texture list. The Object Info palette displays the color or texture selections in the 
relevant section.

The appearance of Simple stage plugs is set from the Attributes palette.
Text Options Opens the Text Options dialog box, to enable the display and format the text of labels; 

see “Formatting Stage Labels” on page 948
Default Text Positions Restores text labels to their default positions
Update Updates the object when changes have been made to the Object Info palette parameters

Parameter Description

Elements to Show
Available options Lists available labels that can be included; the distance units for some of the labels can be 

displayed with both primary and secondary units. Select whether to use the default drawing 
units or choose a different unit from the list.

Include “+” with 
Height

For labels with height values, adds a “+” prefix to the measurement

Show Element 
Labels

Includes the name of the element along with the value; deselect this option to display the 
parameter value only

Text Attributes
Keep Text 
Horizontal

Maintains the text in a horizontal position even when the object is rotated; deselect this 
option to rotate the label along with the object

Fill Text 
Background

Allows a text background fill to be used for all stage object text; by default, white is used as 
the fill color. To specify a different fill color, select the Object Info palette option to class 
the parts of the stage object, and then select a fill color for the class of the stage text. The 
class should be set to Use at Creation.

Parameter Description
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2. Specify the text label elements and formatting, and then click OK.
Once the label has been added to the drawing, it can be moved by clicking and dragging the label control point. Click 
Default Text Positions from the Object Info palette of a selected stage object to restore the text label(s) to the original 
location.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting a Stage Deck
Inserting a Stage Plug

Inserting Stage Steps
The Stage Steps tool inserts portable steps typically used with temporary stage structures into a drawing. The type, 
shape, size, appearance, and presence of railings can be customized.

To insert stage steps:

1. Click the Stage Steps tool from the Spotlight tool set.
2. Click once in the drawing to set the object’s position. Click again to set the object’s rotation.
3. If this is the first time a set of stage steps is placed on the drawing, the object properties dialog box opens. Specify 

the default preferences, which apply to all stage steps placed subsequently in this drawing. Properties can be 
edited later in the Object Info palette. Click OK.

The stage step parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Text formatting 
options

Specify the text size, color, and alignment
Parameter Description

Label control point
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Parameter Description

Structure Select the style of stage steps; self-adjusting steps have a fixed stringer length and 
number of steps, and the step rise automatically adjusts to fit the stage height. For the 
other types of steps, the step parameters are determined according to the selected 
Create Based On option.

Create Based On When steps are not self-adjusting, specifies the method used to determine the step 
parameters, either by setting stage height and number of steps, or by setting the 
number of steps and the step rise. Depending on the selection, certain step parameters 
become available, while the other parameters are calculated for display.
• Stage Height and Number of Steps: Calculates the height of the steps and the rise 

automatically based on the height of the stage and the specified number of steps
• Number of Steps and Step Rise: Calculates the height of the steps and the stage 

height based on the specified number of steps and the step rise
Stage Height Sets or displays the height of the stage
Step Unit Width Specifies the width of each step
Stringer Length 
(Self-adjusting steps)

Specifies the length of the stringers for self-adjusting steps

Stringer Width 
(self-adjusting and open 
free-standing steps)

Sets the width of the stringers for steps with stringers

Stringer Type (open 
free-standing steps)

Select whether the stringers are located inside and under the treads, or outside the 
treads (the stringer width setting affects the available step area)

Add’l Stringers (open 
free-standing steps)

Adds one or more additional support stringers to the steps, spaced evenly based on 
step width

Side Stringer Indent (open 
free-standing steps, inside 
stringers only)

Moves the outer stringers in (underneath the steps) on each side of the stair by the 
specified distance

Step Details

Self-Adjusting Solid Free-Standing

Open Free-Standing Simple

Frame Free-Standing
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Number of Steps Specifies the number of steps
Add Top Step at Stage 
Height

Adds an additional step at the top of the flight, set to the same height as the stage

Top Step Height Displays the height of the top step
Single Step Rise Sets the distance from one step to the next
Step Thickness Specifies the thickness of each step
Single Step Depth Specifies the depth of each step
Nosing Depth (open 
free-standing steps)

Sets the nosing distance (the depth the step protrudes from the stringer)

Top Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options
Trim Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options
Pitch (Calculated)
Angle Displays the pitch of the stair as an angle
Ratio (rise:run) Displays the pitch of the stair as a rise-over-run ratio
Percent (Grade) Displays the pitch of the stair as a grade percentage
Leg/Structure Details
Profile (frame 
free-standing steps)

For the Legs-Basic structure type, select a round, square, or octagonal shape

Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options
Rail Details
Show Left/ Right Rail Select whether to show a rail on the left only, right only, or both sides. Rail parameters 

apply to both sides.
Height Specifies the height of the top rail
Add’l Whole Rails 
(simple, solid 
free-standing, or open 
free-standing steps)

Adds one or more additional rail sets to the steps, spaced evenly based on step width; 
this parameter is only available when both left and right rails are selected for display

Add’l Horiz Bars Adds additional horizontal bars to the rails; not available for self-adjusting steps
Add’l Uprights Adds additional upright bars to the rails; not available for self-adjusting steps
Profile Select a round, square, or octagonal rail shape
Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options
Draw Arrow Select whether to display an arrow in Top/Plan view; the arrow can point up or down. 

In the Text Options, select the arrow text label to display the word “Up” or “Down” 
on the drawing.

Arrow Size When drawing an arrow, sets the arrow head size in drawing units
Class Stage Steps Parts When first selected, automatically creates classes for the different parts of the stage 

steps, for appearance and visibility control. This allows portions of the steps to be set 
to visible, grayed, or invisible. Once the classes have been created, this check box 
toggles whether class visibility changes apply to the selected stage steps object.

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Formatting Stage Step Labels

Formatting Stage Step Labels
A variety of stage step labels can be included on the drawing. For some options, text must be entered into the associated 
field of the Object Info palette for the label to be included.
To select labels for display and format the text:

1. Select a stage steps object. From the Object Info palette, click Text Options.
The Text Options dialog box opens.

Click to show/hide the parameters.

Parts Classes Prefix When stage steps parts are classed, creates a prefix for the class names so that they are 
sorted together

Set Cart ID Enter information about the steps which can be placed on the drawing with Text 
Options (does not affect the steps’ appearance)

Note Adds a note, which can be placed on the drawing with the Text Options
3D Options Specifies the appearance of applicable step elements in 3D views. The 3D Options 

dialog box opens.
For each available portion of the steps, either select the color from the Color list, or, 
when Renderworks is installed, select Custom Texture and then select the texture 
from the Texture list. The Object Info palette displays the color or texture selections 
in the relevant section.

The appearance of Simple stage steps is set from the Attributes palette.
Text Options Opens the Text Options dialog box, to enable the display and format the text of labels; 

see “Formatting Stage Step Labels” on page 952
Default Text Positions Restores text labels to their default positions
Update Updates the object when changes have been made to the Object Info palette 

parameters

Parameter Description

Elements to Show
Available options Lists available labels that can be included; the distance units for some of the labels can be 

displayed with both primary and secondary units. Select whether to use the default drawing 
units or choose a different unit from the list.

Arrow Label When an up or down arrow is selected for Draw Arrow in the Object Info palette, adds an 
“Up” or “Down” label to the drawing in Top/Plan view

Include “+” with 
Height

For labels with height values, adds a “+” prefix to the measurement

Show Element 
Labels

Includes the name of the element along with the value; deselect this option to display the 
parameter value only

Text Attributes

Parameter Description
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2. Specify the text label elements and formatting, and then click OK.
Once the label has been added to the drawing, it can be moved by clicking and dragging the label control point. Click 
Default Text Position from the Object Info palette of a selected stage steps object to restore the text label(s) to the 
original location.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Stage Steps

Inserting a Stage Ramp
The Stage Ramp tool inserts the type of portable ramp typically used with temporary stage structures into a drawing. 
The type, shape, size, appearance, and presence of railings can be customized.

To insert a stage ramp:

1. Click the Stage Ramp tool from the Spotlight tool set.
2. Click once in the drawing to set the object’s position. Click again to set the object’s rotation.
3. If this is the first time a stage ramp is placed on the drawing, the object properties dialog box opens. Specify the 

default preferences, which apply to all stage ramps placed subsequently in this drawing. Properties can be edited 
later in the Object Info palette. Click OK.

The stage ramp parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Keep Text 
Horizontal

Maintains the text in a horizontal position even when the object is rotated; deselect this 
option to rotate the label along with the object

Fill Text 
Background

Allows a text background fill to be used for all stage steps object text; by default, white is 
used as the fill color. To specify a different fill color, select the Object Info palette option to 
class the parts of the stage steps object, and then select a fill color for the class of the steps’ 
text. The class should be set to Use at Creation.

Text formatting 
options

Specify the text size, color, and alignment

Parameter Description

Label control point

Floor length

Ramp length
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Parameter Description

Structure Select the style of stage ramp

Height Sets the height of the top of the ramp
Width Specifies the width of the ramp, not including any rails
Create Based On Specifies the method used to determine the ramp parameters, by setting ramp length, 

floor length, or pitch. Depending on the selection, certain ramp parameters become 
available, while the other parameters are calculated for display.
• Ramp Length: Calculates the floor length and the pitch automatically based on the 

specified ramp length
• Floor Length: Calculates the ramp length and the pitch automatically based on the 

specified floor length
• Pitch Angle: Calculates the ramp length and the floor length automatically based 

on the specified pitch angle
• Pitch Ratio: Calculates the ramp length and the floor length automatically based 

on the specified pitch ratio
• Pitch Percent: Calculates the ramp length and the floor length automatically based 

on the specified pitch percentage
Ramp Length Sets or displays the length of the ramp
Floor Length Sets or displays the length from the bottom of the ramp to the top of the ramp, as 

projected to the floor
Pitch
Angle Sets or displays the pitch of the ramp as an angle
Ratio (rise:run) Sets or displays the pitch of the ramp as a rise-over-run ratio
Percent (Grade) Sets or displays the pitch of the ramp as a grade percentage

Legs Solid

Truck Ramp Simple

Ramp Only
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Ramp Deck Details
Top Thickness Specifies the thickness of the ramp 
Top Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options
Trim Height Sets the thickness of the ramp trim
Trim Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options
Leg/Structure Details
(ramp with legs only)
Diameter Sets the diameter of the ramp legs
Profile Select a round, square, or octagonal shape for the legs
Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options
Reference Spacing Sets an approximate spacing value for the legs; the exact spacing is determined 

automatically by evenly dividing the length of the ramp
Total Legs Displays the number of legs
Rail Details
Show Left/ Right Rail Select whether to show a rail on the left only, right only, or both sides. Rail parameters 

apply to both sides.
Height Specifies the height of the top rail
Add’l Whole Rails Adds one or more additional rail sets to the ramp, spaced evenly based on ramp width; 

this parameter is only available when both left and right rails are selected for display
Add’l Horiz Bars Adds additional horizontal bars to the rails
Add’l Uprights Adds additional upright bars to the rails
Profile Select a round, square, or octagonal rail shape
Color/Texture Displays the texture (Renderworks required) or color selected in the 3D Options
Draw Arrow Select whether to display an arrow in Top/Plan view; the arrow can point up or down. 

In the Text Options, select the arrow text label to display the word “Up” or “Down” 
on the drawing.

Arrow Size When drawing an arrow, sets the arrow head size in drawing units
Class Stage Ramp Parts When first selected, automatically creates classes for the different parts of the stage 

ramp, for appearance and visibility control. This allows portions of the ramp to be set 
to visible, grayed, or invisible. Once the classes have been created, this check box 
toggles whether class visibility changes apply to the selected stage ramp object.

Parts Classes Prefix When stage ramp parts are classed, creates a prefix for the class names so that they are 
sorted together

Set Cart ID Enter information about the ramp which can be placed on the drawing with Text 
Options (does not affect the stage appearance)

Note Adds a note, which can be placed on the drawing with the Text Options

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Formatting Stage Ramp Labels

Formatting Stage Ramp Labels
A variety of stage ramp labels can be included on the drawing. For some options, text must be entered into the 
associated field of the Object Info palette for the label to be included.
To select labels for display and format the text:

1. Select a stage ramp object. From the Object Info palette, click Text Options.
The Text Options dialog box opens.

Click to show/hide the parameters.

3D Options Specifies the appearance of applicable ramp elements in 3D views. The 3D Options 
dialog box opens.
For each available portion of the ramp, either select the color from the Color list, or, 
when Renderworks is installed, select Custom Texture and then select the texture 
from the Texture list. The Object Info palette displays the color or texture selections 
in the relevant section.

The appearance of Simple stage steps is set from the Attributes palette.
Text Options Opens the Text Options dialog box, to enable the display and format the text of labels; 

see “Formatting Stage Step Labels” on page 952
Default Text Positions Restores text labels to their default positions
Update Updates the object when changes have been made to the Object Info palette 

parameters

Parameter Description

Elements to Show
Available options Lists available labels that can be included; the distance units for some of the labels can be 

displayed with both primary and secondary units. Select whether to use the default drawing 
units or choose a different unit from the list.

Arrow Label When an up or down arrow is selected for Draw Arrow in the Object Info palette, adds an 
“Up” or “Down” label to the drawing in Top/Plan view

Include “+” with 
Height

For labels with height values, adds a “+” prefix to the measurement

Show Element 
Labels

Includes the name of the element along with the value; deselect this option to display the 
parameter value only

Text Attributes
Keep Text 
Horizontal

Maintains the text in a horizontal position even when the object is rotated; deselect this 
option to rotate the label along with the object

Parameter Description
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2. Specify the text label elements and formatting, and then click OK.
Once the label has been added to the drawing, it can be moved by clicking and dragging the label control point. Click 
Default Text Positions from the Object Info palette of a selected stage ramp object to restore the text label(s) to the 
original location.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting a Stage Ramp

Fill Text 
Background

Allows a text background fill to be used for all stage ramp text; by default, white is used as 
the fill color. To specify a different fill color, select the Object Info palette option to class 
the parts of the ramp object, and then select a fill color for the class of the ramp text. The 
class should be set to Use at Creation.

Text formatting 
options

Specify the text size, color, and alignment

Parameter Description

Label control point
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Lighting Symbol Maintenance 
Manage, edit, and update the symbols and data for all the lighting symbols in the file from a single location. Easily spot 
inconsistencies and missing data, and fix the issues for all existing symbols or just for future symbol placement.
To maintain the data and symbols for all the lighting symbols in the file:

1. Select Spotlight > Reports > Lighting Symbol Maintenance.
The Lighting Symbol Maintenance dialog box opens.

Click to show/hide the parameters.

Parameter Description

Lighting symbol list Lists all symbols in the file with a Light Info (or Light Info M, for metric 
measurements) record attached. The columns display the data contained in the 
attached Light Info record. Sort the symbols in ascending or descending alphabetical 
order by clicking in the first column header.

New Opens the Choose a Symbol dialog box, listing all the symbol definitions in the file 
without the Light Info (or Light Info M) record attached. Select a symbol to add the 
Light Info record to the symbol definition and add the symbol to the maintenance list, 
where its data can then be edited.

Edit Opens the Edit Instrument Data dialog box, displaying the record data for the selected 
row(s) (alternatively, double-click on the row to edit). 

Replace Opens the Choose a Symbol dialog box, listing all the symbol definitions in the file 
that are not in the maintenance list. Select a symbol to replace the symbol from the 
currently selected row of the maintenance list. The existing data from the selected row 
remain unchanged; only the symbol is replaced. 

Delete Deletes the Light Info (or Light Info M) record from the symbol in the currently 
selected row of the maintenance list, and removes the row from the list. The symbol is 
not removed from the file, but the symbol no longer appears in reports about the 
lighting device. 

Remove Unused Removes the Light Info (or Light Info M) record from all symbols in the maintenance 
list which are currently not used in a lighting device. The items are removed from the 
maintenance list, but the symbols are not removed from the file.
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2. When finished with lighting symbol maintenance tasks, click OK. 
3. If any lighting instrument data has changed, but Update all lighting devices was not selected, an alert message 

displays. 
Click Yes to update all existing and future symbol instances in the file. Select No to update only future symbol 
instances.

Lighting Inventory Setup
The current status of available lighting device inventory is specified with the Lighting Inventory Setup command. 
The number of available devices can be included in instrument summaries.
To establish and maintain inventory counts:

1. Select Spotlight > Reports > Lighting Inventory Setup.
The Lighting Inventory Setup dialog box opens.

2. Select each device type row, and enter the number of available instruments in the Quantity. 
The devices can be sorted by clicking in the Type column header.

3. Click OK.
The inventory report can be included as a report when generating paperwork.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Instrument Summaries
Generating Paperwork

Creating Instrument Summaries
Statistics on the instruments and accessories used in the light plot help with show organization. Instrument summaries 
can be created for the all instruments (see “Creating an Instrument Summary” on page 961), and/or for specific lighting 
positions (see “Creating an Instrument Summary for a Lighting Position” on page 966). The summary, which can be 
custom formatted, can show the symbol thumbnail and name, the number of each kind of instrument and accessories in 
use, display total counts, and add special elements like notes, column breaks, circuit summaries, typical label legend 
layout, and other items. Counting can be subtotaled to count instrument bodies and lenses. Symbols which have the 
same instrument type are counted together, allowing for alternate versions of a single type. The summary can compare 
its information to the current inventory so that the designer can determine how many instruments remain in the 
inventory, or whether more instruments have been specified than are currently present in the inventory.

Copy All Types to Model 
Names

For uniformity, copies the data from the Inst Type column to the Model Name 
column. This eliminates inconsistencies and missing model name data.

Update all lighting devices When selected, the symbol definition edits that have been made affect all existing and 
future symbol instances in the file, potentially changing existing lighting devices in 
the drawing. Deselect the option to only affect future symbol placement.

Parameter Description



Creating Instrument Summaries |  961
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating an Instrument Summary
Creating an Instrument Summary for a Lighting Position

Creating an Instrument Summary

To create an instrument summary:

1. Click the Instrument Summary tool from the Spotlight tool set.
2. Click Preferences from the Tool bar. 

Column Offset

Item Spacing

Text Distance

Total Bodies

Left Margin

Text Width
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The Instrument Summary Settings dialog box opens. Default parameter settings made here, both for global 
instrument summaries and lighting position summaries, apply to instrument summaries placed later in the file. 
These default sets are saved separately and are in effect depending on how the summary is inserted. Taking the 
time to establish the defaults makes it much easier to insert summaries for lighting positions or for the entire 
drawing with the desired defaults already specified.

Click to show/hide the parameters.

Parameter Description

Summary Defaults for Select whether to specify the default settings for the summary when inserting it with the 
Instrument Summary tool (select Instruments) or from a lighting position (select 
Positions). 
This option is not available from the Object Info palette after the summary has been 
placed.

Build List Opens the Build Summary List dialog box, for specifying the components to include in 
the summary

Width Sets the total width of the summary
Column Offset Sets the distance between columns
Instruments
Hide Unused Types When selected, excludes instrument symbols which are not currently used in the drawing 

(these instruments use a blue font in the Build Summary List dialog box), and only 
displays symbols which are used by a lighting device

Show Symbols Includes a thumbnail graphic of each lighting instrument symbol in the key
Auto Rotate Orients symbols automatically to minimize the amount of space required
Scale Scales symbols by the specified proportion; this allows the instrument summary to be 

placed on a sheet layer without displaying the symbols at 1:1 scale
Show Wattages Appends “@ [wattage]” to the instrument type. 

A blank wattage or a wattage of 0 does not display.
Show Weights Displays the unit's weight, as set in the default parameters of the symbol (in the Light Info 

Record, or for metric drawings, Light Info Record M)
Show Lamp Types Displays the lamp type (lamp specification or ANSI code), as set in the default parameters 

of the symbol (in the Light Info Record)
Show Counts Displays a count value for each instrument type

Compare to 
Inventory

Compares and displays the counts against the total number of units of each type as 
calculated in the inventory (see “Lighting Inventory Setup” on page 960)

Left Margin Sets the maximum distance to the left of the summary insertion point for the symbols to 
display, in page units

Item Spacing Specifies the vertical distance between instrument graphics, in page units. Additional 
distance is automatically added if the symbol is larger than the spacing.

Text Distance Sets the distance between the summary insertion point and the text origin, in page units
Text Width Sets the maximum width of text before it wraps, in page units
Headers

Section Align Aligns the list header to the left or center
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3. Click Build List to select the elements to be included in the summary. 
The Build Summary List dialog box opens, to specify what is listed in the summary. You can add instrument 
symbols in use, instrument symbols present in the file (but not currently in the drawing), and formatting elements 
such as column headers, notes, and circuit summaries.
Click on each type of component and move the desired elements to the Component List. To change the order, 
click in the first column and drag the item to the desired position in the list, or click Sort Symbols to sort them 
alphabetically.

Size/Style Specifies the text formatting for the header
Color Summary

Show Swatch When a color summary is included, adds a color swatch for each color used in the drawing
Border

Style Select the style of border for the summary, or whether to omit the border
Separation For the double border style, sets the distance between the lines
Padding The distance, in page units, between the bounding box of the summary and the border

Title
Show Title Displays a title for the instrument summary
Text Specify the title text to display
Position Select where to locate the summary title with respect to the border
Font/Size/Style Specifies the text formatting for the title

Parameter Description
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Click to show/hide the parameters.

Parameter Description

Available Components Swaps the display of available components among used instruments, unused 
instruments, and other summary items

Used Instrument 
Symbols

Lists all symbols that are currently in use by a lighting device

Unused Instrument 
Symbols

Lists all the symbols in the file that are currently not in use by a lighting device (unused 
symbols display in blue so they can be distinguished from the used symbols in the 
Component List)

Other Elements Lists summary and display elements which can be added to customize the summary; 
certain items require the specification of additional customization options after adding 
them to the Component List
• Column break: Begins a new column in the summary
• Column Headers: Adds a “Symbol and Description” header to each column
• Begin subtotal: Indicates the start of a subtotal count section
• End subtotal: Indicates the end of a subtotal count section; the subtotal value is 

placed at this location.
If a subtotal cannot be calculated, nothing is displayed in the summary.

• Header: Adds a section header
• Divider: Places a horizontal separator across the column; separator does not extend 

into the border padding area
• Full divider: Places a horizontal separator across the column; separator extends to 

the border
• Note: Adds text that is aligned with the symbol text
• Typical symbol: Places a selected symbol that is normally the reference symbol 

used for label legends
• Color summary: Adds a summary of all the gel colors used, with color, gel size, and 

counts (select Show Swatch in the Instrument Summary Settings dialog box or 
Object Info palette to include a color swatch)

• Circuit summary: Adds a summary of the circuits in use (usually only included 
with lighting position summaries)

• Position Height: Displays the position height value, when the instrument summary 
is filtered by position. (When not filtered by position, or when position heights vary, 
the height value displays “Varies.”)

Available Components 
list

Lists the items that can be added to the instrument summary; the available items 
depend on the selection in Available Components. Sort the symbols in ascending or 
descending order by clicking in the first column header.

Display Components For symbols which consist of nested symbols, adds the nested symbols to the list
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4. If you have included other elements that require formatting, select each one from the Component List and click 
Options.
• For headers, position height headers, or notes, enter the header or note text.
• For typical symbol, select the symbol to indicate labels (usually a label legend symbol, located within the 

Label Legend symbol folder)
• For circuit summaries, the Circuit Summary Options dialog box opens to specify the circuit information to 

include in a lighting position summary. Specify the types of devices to count and how to count them, and enter 
the device amperage rating/voltage to obtain a report indicating the circuit type you will need for those devices.

Click to show/hide the parameters.

> Adds one or more selected item(s) from the Available Components list to the 
Component List. The items are added to the row above the selected row, or to the end 
of the list if nothing is selected.

Alternatively, double-click to add the item(s).
>> Adds all the items displayed in the Available Components list to the Component List. 
< Removes one or more selected item(s) from the Component List
<< Removes all the items from the Component List 
Component List Lists all the components, in order, to include in the instrument summary. Change the 

order by clicking in the first column and dragging to the desired location; sort in 
ascending or descending order by clicking in the first column header. The Circuits 
column displays specified circuit counts for multi-circuit instruments. Click in the NR 
column of a selected symbol to prevent the symbol from automatically rotating in the 
summary thumbnail display.

Number of Circuits Select multi-circuit instruments in the Component List, and enter the number of 
circuits used (these are displayed in the Circuits column). Rows without a specific 
number of circuits assume that one circuit is used.

Sort Symbols Click to sort all the components, including “other elements,” in alphabetical order
Options For “other elements,” opens a dialog box with special formatting options

Parameter Description

Header Enter the circuit summary header text
Count By Select whether to count the circuits by channel, dimmer, or circuit number
Twofer By Select the method for counting two-fered circuits as one circuit:

• None: Count all circuits, including ganged circuits
• Explicit: Count only two-fer circuits that were created by the Ganging tool
• Anywhere: Counts any two-fered circuits, including those created by the Ganging 

tool and any set of two or more lights that are on the same circuit

Parameter Description
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5. Click OK to return to the Build Summary List; continue specifying summary list options.
6. Click OK to close the Build Summary List dialog box and return to the Instrument Summary Settings dialog box.
7. Click OK.
8. Click in the drawing to place the instrument summary. Click again to set the rotation.

The instrument summary parameters can be edited from the Object Info palette. However, the Summary Defaults 
for option is not available since the summary already exists for instruments or lighting positions.
Filtering and refreshing are options that are available from the Object Info palette after an instrument summary has 
been added to the drawing.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating an Instrument Summary for a Lighting Position
Filtering Instrument Summary Contents
Creating Instrument Summaries

Creating an Instrument Summary for a Lighting Position
An instrument summary can be created for a lighting position rather than for the entire drawing.
To create an instrument summary for a selected lighting position:

1. Select the lighting position.

Amperage Ratings Specify the amperage ratings for the lighting devices, separating multiple values with a 
semi-colon (for example, 20;50 indicates 20A and 50A). Amperage rating is determined 
by a combination of a device’s wattage and voltage. 
Some examples include:
• With a voltage of 120V and an instrument with a 5000W rating, the instrument would 

go into the 50A circuit
• With a voltage of 120V and an instrument with a 500W rating, the instrument would 

go into the 20A circuit
• With a voltage of 120V and three 1000W instruments two-fered together, the 

instruments would go into the 50A circuit with two 50A two-fers
Voltage Specify the circuit voltage
Device Types Select the types of devices to count in the circuit summary; typically two or more 

summaries are included, combining selected device types and specific power 
requirements so that you know the amperage required per circuit for various device types

Parameter Description

Active Filters Displays the status of any summary filtering in effect
Filters Opens the Summary Filters dialog box, for specifying filtering of the summary items by 

lighting position, layer, class, or custom criteria
Refresh When instruments in the drawing, lighting positions, inventory counts, or other factors 

have changed, updates the instrument summary with the latest data

Parameter Description
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2. From the Object Info palette, click Insert Position Summary.
3. A position summary is added next to the lighting position. 

If a summary build list has never been specified in the file, a placeholder labeled Build List is placed instead, 
indicating that a build list has not yet been specified in the file and needs to be set.
The position summary uses the Summary Defaults for parameters for a position, as set up in the instrument 
summary settings, and the summary is filtered for the current lighting position. As instruments are added to the 
position, click Insert Position Summary to add the instruments to the end of the summary. To change specific 
instrument summary parameters, select the instrument summary and edit the parameters in the Object Info palette 
as described in “Creating an Instrument Summary” on page 961.
If you delete a lighting position, the associated instrument summary is also deleted.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Lighting Positions
Creating an Instrument Summary
Filtering Instrument Summary Contents
Creating Instrument Summaries

Filtering Instrument Summary Contents
Instrument summaries can be filtered to limit the contents by lighting position, layer, class, or specified criteria.
To filter the instrument summary contents:

1. Select an instrument summary.
2. From the Object Info palette, click Filters.

The Summary Filters dialog box opens. Each tab includes filtering options to limit the summary contents 
according to specified criteria. The selections made on each tab are additive.

Click to show/hide the parameters.

3. Click OK. 
The summary list is filtered. The Active Filters in the Object Info palette displays the current filters and/or criteria 
string.

Parameter Description

Position Click in the first column to select one or more lighting positions to use as a filter; instruments 
from lighting positions with a check mark are included

Add a Position Height header to the summary elements to include the position height for 
each lighting position.

Layers Click in the first column to select one or more layers to use as a filter; instruments from layers 
with a check mark are included

Classes Click in the first column to select one or more classes to use as a filter; instruments from classes 
with a check mark are included

Custom Specify custom filtering criteria by entering a criteria string, or by clicking Criteria and 
specifying the exact filtering criteria in the Criteria dialog box (which automatically creates the 
criteria string). For more information on specifying criteria, see “Entering Formulas in 
Worksheet Cells” on page 1335.
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating an Instrument Summary
Creating an Instrument Summary for a Lighting Position
Creating Instrument Summaries
Inserting Lighting Positions

Generating Paperwork 
The information to be included in the various schedules and reports, as well as the format of the reports, is specified in 
the Generate Paperwork dialog box. 

The Choose Schedule command automatically creates certain reports as preformatted worksheets; see “Creating 
Schedules Automatically” on page 1318.

To set up the schedule and report information:
1. Select Spotlight > Reports > Generate Paperwork. 

The Generate Paperwork dialog box opens.
2. Select the desired Schedules and Reports. Each schedule and report selected must be set up by clicking on its 

Setup button. The setup procedure is described in the following sections.
3. Configure the rest of the paperwork setup by entering the Header Configuration, Show Information and the 

Page properties. Click OK to generate the desired paperwork with the specified settings.
~~~~~~~~~~~~~~~~~~~~~~~~~
Schedule Setup
Inventory Reports
Magic Sheets
Color Cut List
Header Configuration
Show Information
Page Properties
Reviewing Generated Paperwork
Creating Schedules Automatically

Schedule Setup
The information to be included in the various schedules, as well as the format of the schedules, is specified in the 
Schedule Formatting dialog box. 
To set up the schedule contents and formatting:

1. Select Spotlight > Reports > Generate Paperwork. The Generate Paperwork dialog box opens.
2. Click the Setup button under the Schedules list. The Schedule Formatting dialog box opens.

Each schedule in the Schedule list is formatted in the same way. The formatting must be specified for each 
schedule by first selecting the schedule from the list and then specifying the format.
When selecting Available fields and Column Order, press and hold the Shift key to select multiple, contiguous 
items or press and hold the Ctrl key (Windows) or Command key (Mac) to select non-contiguous items.

Click to show/hide the parameters.
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3. After specifying the column information, order, and width, as well as the page formatting for each type of 
schedule to be generated, click OK to return to the Generate Paperwork dialog box. The schedule formatting is 
used when the paperwork is generated.
The Schedule formatting settings are saved in the file’s Schedule Formats worksheet. The worksheet, and all the 
formatting, can be imported into another file through the Resource Browser.

~~~~~~~~~~~~~~~~~~~~~~~~~
Generating Paperwork

Inventory Reports
An inventory report, showing the items currently placed on the light plot and the items available, can be included in the 
generated paperwork. The inventory report can be set up from the Generate Paperwork dialog box, or from the 
Spotlight > Reports > Lighting Inventory Setup command.
To include an inventory report:

1. Select Spotlight > Reports > Generate Paperwork, and then select Inventory from the Generate Paperwork 
dialog box. To create an inventory report that will separate instrument information according to lighting position, 
select Break Down by Position. 

2. Click the Setup button next to Inventory. The Lighting Inventory Setup dialog box opens.
3. Select each device type row, and enter the number of available instruments in the Quantity. 

The devices can be sorted by clicking in the Type column header.
4. Click OK to close the Lighting Inventory Setup dialog box and return to the Generate Paperwork dialog box.

~~~~~~~~~~~~~~~~~~~~~~~~~
Lighting Inventory Setup
Generating Paperwork

Parameter/Button Description

Printed Name Suggests a title for the top of the report of the selected schedule. Change the title, if 
desired, by typing in a new title for that schedule.

Available Fields Displays the items that can be included in the schedule
Schedule Columns Displays, in order, the columns that have been selected to appear in the schedule
Move > Adds a selected available item to the list of schedule columns
Move < Removes a column from the Schedule Columns list
Move Up/Move Down The most recently added item displays at the bottom of the Schedule Columns list, 

indicating that it is the last column in the report; to change the column order, select a 
column and click on the Move Up and Move Down buttons until it is in the desired order

Column Format For each column in the Schedule Columns list, select Wide, Medium, or Narrow from 
the Width list. These selections represent the relative widths of the columns in relation to 
the other columns. Since the schedule is automatically fit to the page, specifying the 
actual widths is unnecessary. The actual width of the column is dependent upon the 
number of columns as well as the final printed schedule size. 

Page Formatting Specifies the formatting of the Column Headers and report Body text; select the Font, 
Style, and Size for each. Click the Change button to open the Format Text dialog box for 
editing text parameters (see “Formatting Text” on page 389).
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Magic Sheets
Magic sheets are graphical representations of instruments on the plot; they can be broken down either by focus point or 
color. Magic sheets are invaluable for cueing a show. They are simple to set up and generate in the Vectorworks 
Spotlight product. 
To create a magic sheet:

1. Select Spotlight > Reports > Generate Paperwork, and then select Magic Sheets in the Generate Paperwork 
dialog box. 

2. Click the Setup button next to Magic Sheets. The Magic Sheet Setup dialog box opens. Specify the magic sheet 
setup parameters.

The Theatre Styles are editable symbols. Custom styles can be added into the file’s Theater Types folder using the 
Resource Browser.

3. Click OK to close the Magic Sheet Setup dialog box and return to the Generate Paperwork dialog box.
~~~~~~~~~~~~~~~~~~~~~~~~~
Generating Paperwork

Color Cut List
A color cut list in Vectorworks shows all the colors required by the show, and calculates the number of each cut size 
required per color.
To create a color cut list:

1. Select Spotlight > Reports > Generate Paperwork and then select Color Cut List in the Generate Paperwork 
dialog box.

2. If desired, select Break Down by Position to further break the color cut list down by lighting position.
~~~~~~~~~~~~~~~~~~~~~~~~~
Generating Paperwork

Header Configuration
In the Generate Paperwork dialog box, select the position of the header information specified in Show Information. 
For the Left, Center, and Right header positions, select the information to be displayed from the list (Designer, Show 
Name, and/or Date). If no header information is desired for the location, select None.
~~~~~~~~~~~~~~~~~~~~~~~~~
Generating Paperwork
Show Information

Action Description

Generates the magic sheets with 
lighting summarized by color

Click Color; each instrument of a particular color is shown in one view. 
The general Theatre Style needs to be selected from the list to be used 
as a reference for the color summaries.

Generates the magic sheets with 
lighting summarized by focus area

Click Area. All instrumentation that has a specified focus point will be 
included in the report. If desired, the magic sheet color number value 
can be displayed in an approximation of its gel color. Select Show 
Color Name in color.
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Show Information
In the Generate Paperwork dialog box, enter the name of the lighting Designer and the Show Name, if desired. Type 
the date of the show or event. To use today’s date, click Date. Select the show information’s position in the header in 
Header Configuration.
~~~~~~~~~~~~~~~~~~~~~~~~~
Generating Paperwork
Header Configuration

Page Properties
In the Generate Paperwork dialog box, enter the Page Height and Page Width values in the default file units. These 
values specify the print area (page width with printer margins). The width of the schedule columns is affected by this 
value.
If desired, a different unit can be used by specifying the value and the unit. For example, even if the default file units 
are centimeters, specify eight inches for the Page Properties by entering 8". Click OK to generate the selected 
schedules and reports in the format specified.
~~~~~~~~~~~~~~~~~~~~~~~~~
Generating Paperwork

Reviewing Generated Paperwork
Once the paperwork has been formatted and generated, it can be checked and printed.

Generated Magic Sheets
If Magic Sheets were generated, a new design layer is added to the file. Depending on the type of Magic Sheet 
generated, the new design layer is called Magic Sheet-Area or Magic Sheet-Color. The magic sheets are placed on 
this design layer, and formatted to the specified page size (select View > Zoom > Fit to Objects if the Magic Sheet 
items cannot be seen). If the light plot parameters are changed, the magic sheets must be regenerated to reflect the 
updates.

Paperwork Worksheets
The specified reports and schedules, once generated, display in the Resource Browser under the Worksheets heading of 
the current file.
For more information on worksheets, see “Worksheets” on page 1315.
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The following points should be remembered when working with generated paperwork:
• Edits to this type of worksheet do not update the light plot parameters.
• If the light plot parameters are edited, this type of report or schedule must be regenerated to reflect the updates.

Creating Hanging Cards
Lighting position hanging cards can be created.
To create hanging cards:

1. Set the design layer visibility by selecting Window > Palettes > Navigation and clicking the Design Layers tab. 
Set only the design layers with the desired lighting positions and instruments to visible.

2. Similarly, set class visibility by clicking the Classes tab and setting only the desired classes to visible.
3. Select View > Create Viewport. 

The Create Viewport dialog box opens. For more information on viewports, see “Creating Sheet Layer Viewports” 
on page 1616.

4. From the Create on Layer field, select the sheet layer for the viewport (or create a new sheet layer).
5. Select Display Planar Objects and Project Screen Objects, with Top/Plan view and Wireframe rendering. Click 

OK.
6. The viewport is created and the sheet layer displays.

7. Select Modify > Edit Viewport.
The Edit Viewport dialog box opens. Select Crop and click OK.
Alternatively, right-click (Windows) or Ctrl-click (Mac) the viewport and select Edit Crop from the context menu 
to crop the viewport.
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8. In crop viewport mode, draw a 2D shape to crop the desired lighting position.

To hide the cropping shape, set its line thickness to zero in the Attributes palette. Click Exit Viewport Crop at the 
top right of the drawing window to crop the viewport.

9. The cropped viewport displays on the sheet layer.

 

10. Several viewports can be created on the same sheet layer to display all the desired hanging cards. Changes to the 
design layer(s) are automatically reflected in the viewport.

11. Add lighting position summaries to the sheet layer as described in “Creating an Instrument Summary for a 
Lighting Position” on page 966; adjust the Scale of the displayed symbols so that they do not display at a 1:1 
scale, but are sized appropriately for the sheet layer.

Inserting Gobo Projections
A pattern, texture, or color can be placed on a lighting instrument and projected onto the stage in. This special light 
source and instrument combination is a gobo projection.
Lighting instruments with gobo projections cast a light beam that can be rendered by the Renderworks product. You 
can then preview the effect of the gobo projection texture(s) on the stage.
The Renderworks product must be installed to render gobo projections. For more information on rendering, see 
“Rendering the Drawing” on page 1569.
~~~~~~~~~~~~~~~~~~~~~~~~~
Gobo Texture Libraries
Creating Gobo Textures
Editing Gobo Texture Transparency Settings
Inserting a Gobo Projector
Showing Gobo Projections

Gobo Texture Libraries
The Vectorworks Spotlight product includes thousands of commercial gobo textures from Apollo, Lee, GAM, 
GOBOLAND, High End Systems, and Rosco. Through the Resource Browser, import the texture into the current file 
from one of the files located in the gobo textures folder of the [Vectorworks]\Libraries folder that is included with the 
Vectorworks Spotlight product (see “Resource Libraries” on page 219). To use the texture in a gobo projection, specify 
its name in the Object Info palette (see “Creating Gobo Textures” on page 974).
When the Vectorworks Spotlight product is installed, gobo textures are also provided as default content (default content 
is automatically imported into the file when selected while changing instrument properties, and displays in the 
Resource Browser; see “Editing Lighting Instruments” on page 877, and “Resource Libraries” on page 219.)
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Inserting a Gobo Projector
A gobo projector is a lighting instrument with a light source and gobo projector specified.

1. Insert a lighting instrument as described in “Inserting Instruments” on page 875.
2. In the Object Info palette of the selected instrument, click Edit.

The Lighting Device dialog box opens. This provides a convenient way of specifying parameters (see “Changing 
Instrument Properties” on page 880), although the parameters can also be entered directly in the Object Info 
palette.

3. On the Instrument Properties tab, specify a focus point for the instrument.
4. On the Light Information tab, for Gobo 1, enter the name of the gobo projection texture (if it has been imported 

into the file as a resource), or click Get Resource to select a gobo texture from the default content. Specify the 
Gobo 1 Rotation angle, if any.

5. If there is a second gobo texture, specify its parameters in Gobo 2.
6. Click OK.
7. Turn on the embedded light source for the lighting instrument. 

Either right-click on the light, and select Edit Light from the context menu to open the Properties dialog box (and 
click On), or turn on the light from the Visualization palette. 
To preview the effect of a color projection on the stage, indicate the Color name in the Object Info palette of a 
selected instrument, without specifying a gobo texture. Render the gobo projection to project the light on the focus 
point with the specified color. The colors can be selected from the color libraries installed with the Vectorworks 
Spotlight product. The color code must be entered in a “Manufacturer color value” format (for example, R101). If 
the color value cannot be found, the color defaults to white.

~~~~~~~~~~~~~~~~~~~~~~~~~
Changing Instrument Properties
Lighting Instrument Properties
Creating Gobo Textures
Editing Gobo Texture Transparency Settings
Showing Gobo Projections

Creating Gobo Textures 
In addition to the gobo images available in the pre-defined commercial gobo projection libraries, any square image can 
be converted into a gobo projection texture.
The Renderworks product must be installed in order to create gobo textures.
Most image-based textures are automatically compressed when imported into a Vectorworks file. Imported JPEG files 
retain the original JPEG data; all other image files are compressed using lossless PNG format.
To create a gobo texture:

1. Select Spotlight > Visualization > Create Gobo Texture.
The Create Gobo Texture dialog box opens.

Click to show/hide the parameters.
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For more information on editing textures, see “Editing Textures and Shaders” on page 1516.
2. Click OK. 

If a resource with an image is already present in the file, the Choose Image dialog box opens.
Click to show/hide the parameters.

3. Select the desired image file and click Open.
4. If Edit Texture was selected in Step 1, the Edit Texture dialog box opens. Select the desired options and click OK. 

Click OK again to close the Create Gobo Texture dialog box.
The texture resource is created and is listed in the Resource Browser.

5. Associate a defined texture with an instrument by entering the texture name in the Gobo 1 or Gobo 2 field of a 
selected instrument’s Object Info palette, and specify the Gobo Rotation, if any.
A texture can be saved in the default content file located in gobo textures folder of the [Vectorworks]\Libraries 
folder that is included with the Vectorworks Spotlight product (see “Resource Libraries” on page 219). Import the 
texture into the default file, or save a new default file within the folder.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Gobo Texture Transparency Settings
Inserting a Gobo Projector
Showing Gobo Projections

Editing Gobo Texture Transparency Settings
A gobo texture is a transparent image resource listed in the Resource Browser. The transparency settings can be edited 
after the gobo image has been specified, or at creation.
To edit a created gobo texture’s transparency:

1. Select the resource in the Resource Browser.
2. Select Resources > Edit to open the Edit Texture dialog box. The Image Transparency settings can be edited. For 

more information on editing textures, see “Editing Textures and Shaders” on page 1516.
The texture Size must be 2 inches.

Parameter Description

Enter a name for this 
texture

Specifies the gobo texture name

Edit Texture Edits the gobo texture transparency settings at creation. Once an image has been 
selected (as described in the following steps), the Edit Texture dialog box opens for 
editing texture transparency settings.

Parameter Description

Import an Image File Imports a new image. Click OK and proceed to Step 3.
Reuse an Image from 
Another Resource

Reuses a previously imported image; select the resource that contains the image. 
Click OK and proceed to Step 4.
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Gobo Textures
Inserting a Gobo Projector
Showing Gobo Projections

Showing Gobo Projections
The gobo textures and color of a selected light instrument can be projected in a rendered simulation. This rendered 
image allows you to preview the effect of the gobo texture.

Gobo Projection Requirements
To be able to project a gobo texture in Vectorworks Spotlight, the lighting instrument must:

• Have one or two gobo textures specified
• Be aimed at an existing focus area specified in the Focus field of the Object Info palette
• Have its associated light source turned on (either right-click on the light, and select Turn On from the context 

menu, or turn on the light from the Visualization palette)
• Have Draw Beam deselected in the Object Info palette

The following Vectorworks software requirements must be met:
• The design layer containing the instrument with gobo texture must also contain 3D geometry (any 3D object that 

is capable of accepting a Renderworks light) to project the texture
• The Renderworks product must be installed
• Either Fast Renderworks or Custom Renderworks can be used

For Custom Renderworks, at a minimum, Shadows and Textures must be selected in the custom Renderworks 
settings.

Size must be 2 inches

Click to edit Transparency
settings
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To select the custom settings, select View > Rendering > Custom Renderworks Options. For more information 
on Custom Renderworks settings, see “Custom Renderworks Options” on page 1600.

~~~~~~~~~~~~~~~~~~~~~~~~~
Projecting a Gobo Texture
Creating Gobo Textures
Editing Gobo Texture Transparency Settings
Inserting a Gobo Projector

Projecting a Gobo Texture
To project a gobo texture:

1. Make all the settings and meet all the requirements described in “Inserting a Gobo Projector” on page 974, and 
“Gobo Projection Requirements” on page 976.

2. Select View > Rendering > Custom Renderworks.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Gobo Textures
Editing Gobo Texture Transparency Settings
Inserting a Gobo Projector
Gobo Projection Requirements

Managing Scenes 
The levels, colors, positions, and focusing of all the instrument objects can be saved as a lighting scene. The scenes can 
then be used to create movies of the scene transitions.
~~~~~~~~~~~~~~~~~~~~~~~~~
Saving Scenes
Animating Scenes

Saving Scenes 
To save a scene:

1. After the lighting properties for all the instruments have been set correctly, select Spotlight > Visualization > 
Manage Scenes. The Manage Scenes dialog box opens.

2. In the Scenes list, the list of saved scenes is displayed. The scenes are sorted by the order in which they are 
entered. To save the current settings as a scene, click Save. The Save dialog box opens.

Click to show/hide the parameters.

Parameter Description

Scene Name Specifies the scene name
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3. Click Done to save the scene. It is added to the Scenes list.

Editing Scenes
To edit a scene:

1. Select the scene from the list in the Manage Scenes dialog box and click Edit. 
2. Make the desired change to the Scene Name or Number, or the Up/Down Time, then click Done to save the 

change. Confirm the changes.

Removing Scenes
To remove a scene:

1. Select the scene from the list in the Manage Scenes dialog box and click Remove. 
2. Confirm that you wish to remove the scene, then click Yes. The scene is removed from the Scenes list.

Restoring Scene Lighting Parameters
To restore lighting parameters from a scene:

1. Select the scene from the list in the Manage Scenes dialog box and click Go!. 
2. Confirm that the parameters are to be restored. The current light parameters are replaced by those from the scene. 

All current levels, colors, positions, and focus points for all the instruments will be replaced. Any information that 
has not been saved will be lost.

Animating Scenes 
In Vectorworks, a movie of scene settings can be created to preview the cue transition between the scenes. The contents 
of the active window, exactly as they display, are used to create the movie. Therefore, the images must be rendered 
before animating the scenes to accurately preview the lighting effect. These features cannot be used to accurately 
render all the lighting instruments on the stage for every scene.
To animate the scenes:

1. Set the rendering option parameters described in “Gobo Projection Requirements” on page 976.
2. Save the scenes as described in “Managing Scenes” on page 977.
3. Select Spotlight > Visualization > Animate Scenes. 
4. In the Choose Path dialog box, select a location and file name for the movie. Click Save to open the Animate 

Scenes dialog box.
5. Enter the parameters for the Start and End Scenes. Select the scene name from the list; its parameters display 

underneath. 
6. If desired, the scene can be edited by clicking the Edit Scene button. Change the Scene Name, Scene Number, 

Up Time and Down Time, and then click OK to confirm the changes. The Up Time and Down Time used to 
animate the scenes is taken from the End Scene.

7. To create the animation, enter the scene Hold for time in seconds for both the starting and ending scenes.

Scene Number Specifies the scene number
Up Time Enter the time allotted for the lights to increase in intensity, in seconds
Down Time Enter the time allotted for the lights to decrease in intensity, in seconds

Parameter Description
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8. Edit the movie settings by clicking the Compression Settings button. The Compression Settings dialog box 
opens.

9. Enter the Frames per second and Quality for the movie file and click OK.
10. When the scene animation settings are complete, click OK. The progress is displayed on the screen as the movie is 

created in the specified location, based on the settings that were entered.
11. To see the movie, locate the movie file and double-click to play it.
~~~~~~~~~~~~~~~~~~~~~~~~~
Managing Scenes
Gobo Projection Requirements

Creating Plot and Model Views
The Create Plot and Model View command automatically creates one or more design layer viewports of geometry to 
be viewed and rotated in a model layer. This allows users to create both a 2D lighting plan and model views with 
unique rotation angles, from the same geometry (lighting positions, trusses, lighting instruments, and associated 
geometry). This command represents a lighting design with non-horizontal lighting positions in Top/Plan view and a 
properly represented model in the model layer.
Model views can be created in two ways. If the command is run when no objects are selected, special “definition 
layers” are created for each instance of a lighting position, as well as the remaining non-architectural geometry, which 
is placed in another definition layer. The associated design layer viewports on the model layer can be rotated 
individually for that geometry, with great flexibility, or automatically set to a vertical orientation. Alternatively, run the 
command with one or more Vectorworks Spotlight objects selected; a single design layer viewport is created on the 
model layer, and its rotation can be automatically set to vertical if desired. This is useful, for example, when selected 
trusses need to be viewed in the model with the same vertical orientation.

Architectural geometry, such as floors and walls, cannot be rotated in the model layer.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Model Views of the Entire Plot
Creating Model Views of Selected Geometry

Creating Model Views of the Entire Plot
To create model views from all valid geometry in the plot layer:

1. From a plot layer that contains valid Vectorworks Spotlight objects (lighting positions, trusses, lighting 
instruments, and non-architectural 2D or 3D geometry or hybrid symbols), ensure that no items are selected.

2. Select Spotlight > Visualization > Create Plot and Model View.
The Create Plot and Model View dialog box opens.

Click to show/hide the parameters.

Parameter Description

Name Specifies a name for the definition layer(s); “Definition Layer” is the default name. 
Additional layers are based on the name set here, with an automatically incremented and 
appended number (Definition Layer-1, Definition Layer-2, and so on).

Model Layer Specifies where the model layer will be created; select a layer name from the list, or 
create a new layer. If New Model Layer is selected, you will be prompted to create a 
design layer after clicking OK.
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3. Click OK.
A design layer viewport is created for each lighting position instance and non-architectural geometry, replacing 
the original objects on the plot layer.
• If Separate was deselected, a single definition layer contains all Vectorworks Spotlight geometry.
• If Separate was selected, a definition layer exists for each instance of the Vectorworks Spotlight geometry. 
Finally, a model layer contains design layer viewports for rotation and proper positioning.

4. In the model layer, use the Rotate tool to orient the design layer viewports. See “Rotate Tool” on page 1022.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Plot and Model Views
Creating Model Views of Selected Geometry

Creating Model Views of Selected Geometry
To create model views from selected valid geometry in the plot layer:

1. From a plot layer that contains valid Vectorworks Spotlight objects (lighting positions, trusses, lighting 
instruments, and non-architectural 2D or 3D geometry or hybrid symbols), select the items to be rotated in a model 
view.

2. Select Spotlight > Visualization > Create Plot and Model View.
The Create Plot and Model View dialog box opens.

Click to show/hide the parameters.

3. Click OK.
A design layer viewport is created for the selected Vectorworks Spotlight geometry, replacing those objects on the 
plot layer; if Vertical was selected, the model view displays the design layer viewport in a vertical orientation. A 
single definition layer contains the original selected Vectorworks Spotlight geometry.

4. If Vertical was not selected, use the Rotate tool in the model layer to orient the design layer viewport. See “Rotate 
Tool” on page 1022.

Separate Creates a new definition layer for each valid lighting position and remaining 
non-architectural geometry, allowing each design layer viewport to rotate independently 
in the model view; deselect to create a single definition layer with all valid objects in a 
single design layer viewport 

Vertical Automatically sets all non-architectural geometry to a vertical orientation in the model 
layer

Parameter Description

Name Specifies a name for the definition layer; “Definition Layer” is the default name. 
Model Layer Specifies where the model layer will be created; select a layer name from the list, or 

create a new layer. If New Model Layer is selected, you will be prompted to create a 
design layer after clicking OK.

Separate This option is disabled when drawing items are selected
Vertical Automatically sets the selected item(s) to a vertical orientation in the model layer

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Plot and Model Views
Creating Model Views of the Entire Plot
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Event Design
The event design suite available in Vectorworks Spotlight contains automated tools to facilitate setting up a complete 
room layout for an event such as a banquet, presentation, or training session. Automatically create the room for the 
event, including the floor, walls, stage, steps, lectern, video screens, and seating. View the room setup in a rendered or 
plan view, and obtain a report on the total number of tables and chairs required for the event.
The event design suite uses objects to quickly and automatically create the room plan with only a few parameter 
settings required. However, due to the powerful nature of these objects, they can be specifically tailored through the 
Object Info palette to customize their appearance if needed.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating the Room
Creating the Stage
Creating Stage Stairs
Creating a Lectern
Creating a Video Screen
Creating Event Seating
Creating Event Views

Creating the Room
The first step of event design is usually creating the event room. Based on a simple 2D shape, the room and floor are 
created automatically according to specified parameters.
To create the room:

1. Create a closed 2D object (such as a rectangle, polyline, or polygon) to represent the room. The dimensions of the 
object should match the interior dimensions of the room to be created.

2. With the 2D object selected, select Event Design > Create Room.
The Create Room dialog box opens. Specify the properties and attributes of the walls and floor.

Click to show/hide the parameters.

Parameter Description

Walls Specify the wall attributes
Height Sets the wall height of the room’s walls
Class The wall attributes can be set by class, by choosing a class other than None. If desired, 

select a class from the list of classes in the file, or create a new class for the walls.
Leave the walls in the None class to set the remaining attributes from the dialog box.

Thickness Sets the wall thickness
Fill Hatch Sets a fill hatch for the walls from the file’s resources
Fill Color Sets the fill color for the walls
Pen Color Sets the pen color for the walls
Texture 
(Renderworks 
required)

Specifies the overall wall texture from either the default content or the current file’s 
content

Floor Specify the floor attributes
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3. Click OK. The room’s walls and floor are automatically created.

Wall and floor parameters can be edited in the Object Info palette; see “Editing Walls” on page 535 and “Creating 
Floors” on page 481.
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Walls
Creating Floors
Creating the Stage
Creating Stage Stairs
Creating a Lectern
Creating a Video Screen
Creating Event Seating
Creating Event Views
Setting Class Properties
Resource Libraries

Creating the Stage
Many event rooms contain a stage for viewing presentations. Based on the Stage Plug tool, a stage is automatically 
created according to specified parameters. 

The structure type of the stage plug is automatically set to Border.
To create the stage:

1. Create a closed 2D object (such as a rectangle, polyline, or polygon) to represent the stage. The dimensions of the 
object should match the dimensions of the stage to be created.

2. With the 2D object selected, select Event Design > Create Stage.
The Create Stage dialog box opens. Specify the stage properties and attributes.

Class The floor attributes can be set by class, by choosing a class other than None. If desired, 
select a class from the list of classes in the file, or create a new class for the floor.
Leave the floor in the None class to set the remaining attributes from the dialog box.

Fill Color Sets the fill color for the floor
Pen Color Sets the pen color for the floor
Texture 
(Renderworks 
required)

Specifies the floor texture from either the default content or the current file’s content

Parameter Description

Rendered 3D view for clarity
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Click to show/hide the parameters.

3. Click OK. The stage is automatically created.

Stage parameters can be edited in the Object Info palette; see “Inserting a Stage Plug” on page 946.
Right-click (Windows) or Ctrl-click (Mac) on the stage object and select Edit from the context menu. Edit the shape of 
the object path with the Reshape tool.

A stage can also be created by clicking the Stage Plug tool from the Spotlight tool set.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating the Room
Creating Stage Stairs
Creating a Lectern
Creating a Video Screen
Creating a Seating Layout
Creating Event Views
Resource Libraries

Creating Stage Stairs
Stairs or steps are usually required to provide access to the stage from the floor. The steps are automatically adjusted to 
meet the top of the stage. The stage stairs are based on the Stage Steps tool.

Parameter Description

Height Sets the height of the stage
Class The stage attributes can be set by class, by choosing a class other than None. If desired, 

select a class from the list of classes in the file, or create a new class for the stage. See 
“Setting Class Properties” on page 179.
Leave the stage in the None class to set the remaining attributes from the dialog box.

Fill Color Sets the fill color for the stage
Pen Color Sets the pen color for the stage
Top Texture 
(Renderworks 
required)

Specifies the texture for the top of the stage from either the default content or the current 
file’s content

Side Texture 
(Renderworks 
required)

Specifies the texture for the side of the stage from either the default content or the current 
file’s content

Rendered 3D view for clarity; room wall removed for visualization
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To add steps:
1. Select Event Design > Create Stair.

The Create Stair dialog box opens. 
Click to show/hide the parameters.

2. Click OK.
3. Click once in the drawing to set the stair position. Click again to set the stair rotation.

Stair parameters can be edited in the Object Info palette; see “Inserting Stage Steps” on page 949.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Stairs
Creating the Room
Creating the Stage
Creating a Lectern
Creating a Video Screen
Creating Event Seating
Creating Event Views

Creating a Lectern
After the stage and stairs have been added, a lectern can be quickly configured and placed. When placed on the stage, 
the lectern height is automatically adjusted to the top of the stage.

Parameter Description

Width Specify the width of the staircase
Style Set the type of stair to create: Simple, Self-Adjusting, Frame Free-Standing, Solid 

Free-Standing, or Open Free-Standing
Class The stair attributes can be set by class, by choosing a class other than None. If desired, 

select a class from the list of classes in the file, or create a new class for the stair. See 
“Setting Class Properties” on page 179.
Leave the stair in the None class to set the remaining attributes from the dialog box.

Fill Color Sets the fill color for the stair
Pen Color Sets the pen color for the stair
Texture (Renderworks 
required)

Specifies the stair texture from either the default content or the current file’s content; see 
“Resource Libraries” on page 219

Rendered 3D view for clarity
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To add a lectern:
1. Select Event Design > Create Lectern.

The Create Lectern dialog box opens.
Click to show/hide the parameters.

2. Click OK.
3. Click once in the drawing to set the lectern position. Click again to set the lectern rotation.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating the Room
Creating the Stage
Creating Stage Stairs
Creating a Video Screen
Creating Event Seating
Creating Event Views

Creating a Video Screen
As part of the event design setup, video screens are often necessary at events and can be quickly configured and placed.

Parameter Description

Choose Lectern Select one of the lecterns from the list; these are configured with default attributes and 
can be inserted as is. Alternatively, select a lectern shape to use as the basis for a new 
lectern symbol with customized attributes.

Custom Attributes Customizes the selected lectern’s default attributes, creating a new hybrid lectern symbol
New Symbol Name Provide a name for the new lectern symbol; the new symbol is added to the file’s 

resources
Class The lectern attributes can be set by class, by choosing a class other than None. If desired, 

select a class from the list of classes in the file, or create a new class for the lectern. See 
“Setting Class Properties” on page 179.
Leave the lectern in the None class to set the remaining attributes from the dialog box.

Fill Color Set the fill color for the lectern
Pen Color Set the pen color for the lectern
Texture (Renderworks 
required)

Specifies the lectern texture from either the default content or the current file’s content; 
see “Resource Libraries” on page 219

Rendered 3D view for clarity



  988 | Creating Event Seating
To add a video screen object:
1. Select Event Design > Create Screen.

The Create Screen dialog box opens.
2. Select the type of video screen object to insert, and click OK.
3. Click once in the drawing to set the video object position. Click again to set the object’s rotation.

Screen parameters can be edited in the Object Info palette; see “Inserting Video Screen Objects” on page 913.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting a Video Screen Object
Creating the Room
Creating the Stage
Creating Stage Stairs
Creating a Lectern
Creating Event Seating
Creating Event Views

Creating Event Seating
Once the event room has been defined, one of the last steps is to add seating for the event. A variety of event seating 
types can be automatically created. Seating can consist of chairs, tables, or tables and chairs. Seating fills a 2D shape in 
a user-defined arrangement with a “look-to” location defined by a focal point. Along with the event seating, a Seating 
Count worksheet is created.
To add seating:

1. Create the closed 2D shape (such as a polygon, rectangle, rounded rectangle, oval, arc/circle, or polyline) defining 
the boundary of the seating area. Objects with one or more holes can be selected; seating will not be placed where 
a hole exists.

2. With the object(s) selected, select Event Design > Create Event Seating.
The Create Event Seating dialog box opens.

Click to show/hide the parameters.

Parameter Description

Seating Arrangement Select the seating spacing and arrangement; any symbol can be selected for the different 
arrangement types, but normally, banquet seating consists of table and chair symbols, 
and classroom and theatre seating includes chair symbols. Classroom and theatre seating 
include an option to arrange the seats concentrically.

Rendered 3D view for clarity
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3. Click Customize Symbol to change the default appearance of the selected symbol if desired. This creates a new 
symbol that is added to the file’s resources.
The Customize Symbol dialog box opens.

Click to show/hide the parameters.

4. Click OK to return to the Create Event Seating dialog box. 
5. Click OK to create the event seating. The Select the Focus Method dialog box opens.

Banquet Typical seating arrangement for banquets, with offset tables spaced equally by the 
distance set in Table Spacing

Classroom Typical classroom seating arrangement with aligned rows of chairs, spaced according to 
the distances set in Seat Spacing and Row Spacing

Theatre Typical theatre seating arrangement with offset alternate rows of chairs, spaced 
according to the distances set in Seat Spacing and Row Spacing 

Table Spacing For banquet seating, indicates the distance between tables
Seat Spacing For classroom or theatre seating, sets the distance between seats in a row
Row Spacing For classroom or theatre seating, sets the distance between rows of seats
Concentric For classroom or theatre seating, specifies a circular layout for the rows
Seating Section Name Names the seating section for the seating layout worksheet
Seating Symbol Select one of the seating symbols from the list; these are configured with default 

attributes and can be inserted as is. Alternatively, select a symbol to use as the basis for a 
new seating symbol with customized attributes.

Customize Symbol Customizes the selected seating’s default attributes, creating a new hybrid seating 
symbol

Parameter Description

Chair/Table Attributes Sets the attributes for the chair and/or table symbol
Fill Color Sets the fill color for the chairs and/or tables
Pen Color Sets the pen color for the chairs and/or tables
Texture 
(Renderworks 
required)

Specifies the chair and/or table texture from either the default content or the current file’s 
content; see “Resource Libraries” on page 219

Preview Displays a preview of the symbol the attributes applied
Render Mode Select whether to preview the symbol in wireframe or OpenGL rendering mode
New Symbol Name Provide a name for the new seating symbol; the new symbol is added to the file’s 

resources. Names are automatically generated for nested table and chair symbols.
Class The seating attributes can be set by class, by choosing a class other than None. If desired, 

select a class from the list of classes in the file, or create a new class for the symbol. See 
“Setting Class Properties” on page 179.
Leave the seating in the None class to set the attributes from the dialog box.

Parameter Description
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6. Click Focus at Next Click to manually place the focal point for the seating, or click Automatically Focus to have 
the focal point created automatically. 
If Focus at Next Click was selected, click once to place the focal point.
All seats will face this point; table and chair symbols orient toward the point. For concentric seat layouts, the 
distance of the seat focal point from the 2D boundary object determines the radius of the concentric layout. Click 
close to the object for a smaller radius.

The event seating and a Seating Count worksheet are created, with automatically calculated seat and table counts. The 
Seating Count worksheet displays the number of seats and/or tables required for each seating section, as well as the 
total number of seats/tables needed for all sections. Nested symbols are counted in the worksheet, so tables and chairs 
are counted separately within a table and chair symbol. (If a symbol cannot be identified as a table or chair, it is counted 
as a chair.)
Seating parameters can be edited in the Object Info palette and have the same parameters as the Create Seating 
Layout command (see “Editing the Seating Layout” on page 992).
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Seating Layout
Creating the Room
Creating the Stage
Creating Stage Stairs
Creating a Lectern
Creating a Video Screen
Creating Event Views
Seating Layout Specifications

Creating a Seating Layout
The Create Seating Layout command creates a seating layout object from one or more selected polygons, rectangles, 
rounded rectangles, ovals, arcs/circles, or polylines. Seating can consist of chairs, tables, or tables and chairs. Seating 
fills the object(s) in a user-defined arrangement with a “look-to” location defined by a control point. Seating layout 
objects can also be created by drawing a polyline and then selecting the Create Objects from Shapes command (see 
“Creating Objects from Shapes” on page 277). Along with the seating layout, a Seating Count worksheet is created.
To create a seating layout object:

1. Create the shape defining the boundary of the seating area. Objects with one or more holes can be selected; seating 
will not be placed where a hole exists. Multiple shapes can be selected at one time (to create several seating 
sections, for example).

2. With the object(s) selected, select the Create Seating Layout command from the appropriate menu:
• Architect workspace: AEC > Create Seating Layout 
• Spotlight workspace: Spotlight > Architectural > Create Seating Layout 

Rendered 3D view for clarity; room wall removed for visualization



Creating a Seating Layout |  991
The Create Seating Layout dialog box opens.
Click to show/hide the parameters.

3. A default symbol can be created to represent the seating; select Create a new seat symbol called and provide a 
symbol name. Alternatively, select an appropriate seating symbol from either the default content or the current 
file’s content; see “Resource Libraries” on page 219. In addition to seat symbols, table symbols and table and 
chair symbols can be used.
See “Accessing Existing Resources” on page 229 for information on importing symbols into the Resource 
Browser.

4. Click OK to close the Create Seating Layout dialog box.
5. When prompted, click on the focal point for the seating. All seats will face this point; table and chair symbols 

orient towards the point.

For concentric seat layouts, the distance of the seat focal point from the object determines the radius of the 
concentric layout. Click close to the object for a smaller radius.
The seating layout object and a Seating Count worksheet are created, with automatically calculated seat and table 
counts.

The Seating Count worksheet displays the number of seats and/or tables required for each seating layout section, as 
well as the total number of seats/tables needed for all sections. Nested symbols are counted in the worksheet, so tables 
and chairs are counted separately within a table and chair symbol. (If a symbol cannot be identified as a table or chair, 
it is counted as a chair.)

Parameter Description

Create a new seat symbol called Creates a new seat symbol; provide the symbol name
Use an existing symbol Selects an existing seat symbol; specify the symbol from the list

Symbol Folders Specifies the location of seat symbols
Symbols Provides a graphical list of available seat symbols
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A seating layout can also be created by clicking the Seating Layout tool from the Furn/Fixtures tool set. Draw a 
polygon with the tool and complete the parameters which are identical to those described in “Editing the Seating 
Layout” on page 992. Alternatively, Spotlight users can use the Create Event Seating command on the Event 
Design menu to create a seating layout (see “Creating Event Seating” on page 988).

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing the Seating Layout
Seating Layout Specifications

Editing the Seating Layout
Seating layout parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using 
options on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 and 
“Formatting Text” on page 389.

Seat Spacing Specifies the distance between seats
Row Spacing Specifies the distance between rows of seats
Section Name Assigns a section name for use in the Seating Count worksheet
Concentric Select to draw a concentric seating arrangement

Offset Alternate Rows Offsets alternating rows (starting with the second row), so that the seats are staggered by 
a half seat width, or chairs and tables are spaced to prevent overlapping

Offset 1st Row Specifies an offset distance for the first row of seats
Focal Pt X/Y Indicates the coordinates of the seating look-to point
Focus Front Click to snap the seating layout’s focal point to the front. 

Because flexible seating areas can have multiple potential fronts, repeated clicks 
toggle the focal point around the seating area, to each possible front. The focal point 
snaps to the midpoint of each path segment that defines the seating area.

Draw Boundary Line Select to display the object used as the basis for the seating layout; deselect to hide the 
object and show the seats only

Draw Layout Lines Only Select to display the seating locations without showing the actual seat symbols

Linear Concentric
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Base Z Height Specifies the initial elevation of the first row of seating
Rise per Row Specifies the elevation increase for each row of seating (seating layout slope)
Display Seating Section 
Name

Displays the name of the seating section on the drawing, as set in Section Name

Display Seating Count Displays the number of seats in the section on the drawing, separated by table and chair 
counts

Show Seat Number Displays a seat number on each symbol; a table-and-chair symbol receives a single 
number

Starting Number Displays and sets the starting number for the first seating symbol in the section
Increment Specifies the seating number increment value

Use an increment value of 2 to number a section with all even or odd seat numbers.
Label Classes Assign the Section Name, Seating Count, and Seat Number labels to classes to control 

their appearance in viewports. Select a class present in the drawing or create a new class.
When a new class is created, it does not automatically become the active class. 
Class graphic attributes will be applied to the labels when Use at Creation is 
enabled for the class. (See “Setting Class Properties” on page 179.) 

Seating Count Select a method for limiting the number of seats permitted in a seating area, or leave the 
option Unlimited. If a limitation method is chosen, specify maximum values for the 
Seats per Row and Rows per Section. 
• Limit the Number of Seats creates no more than the maximum number of seats per 

row and rows per section specified, fit within the seating area boundaries.
• Notify When Count is Exceeded creates seats to fill the seating area but provides red 

warning text over the seating area when the seats per row and/or rows per section 
maximum values are exceeded.

• Specify the Number of Seats creates exactly the number of seats per row and rows per 
section specified. All rows are of uniform length; the seating area path is used only to 
determine an origin and rotation for the seating plan, not to shape or limit the seating 
area.

Chair Symbol Displays the seating symbol name used to create the seating layout
Chair Count Displays the number of seats used in the layout
Table Symbol Displays the table symbol name used to create the seating layout
Table Count Displays the number of tables used in the layout
Select Symbol Opens the Choose a Symbol dialog box, to replace the current seating symbol. Select the 

desired seating symbol from either the default content or the current file’s content, and 
then click OK; see “Resource Libraries” on page 219. When the Spotlight product is 
installed, the default content for event design seating is available.

Parameter Description
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The seating layout can be reshaped with the Reshape tool to add, subtract, and change vertices. The seats are 
automatically adjusted to fit the new shape. More sophisticated editing operations, such as adding, clipping, 
intersecting and combining into surfaces can be performed on the seating layout path object by selecting Modify > 
Edit Seating Layout.
The seating section name and seating count text position can be adjusted by moving the control point. Adjust the text 
font and size of the label and seat numbers with the commands from the Text menu.

If the seating orientation requires adjustment, the seat control point can be moved to readjust the seating focal point. 
The control point is referenced relative to the center of the seating layout. If two imaginary axis lines were placed over 
the seating layout as shown in the diagram, placing the control point in line with the center of the axes would orient the 
seats directly toward the control point.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Seating Layout
Seating Layout Specifications

Seating Layout Specifications
The Create Seating Layout command in Vectorworks Architect and Spotlight, as well as the event design suite in the 
Vectorworks Spotlight product, make use of table and chair symbols that are available from the default content. It’s also 
possible to make your own table, chair, and nested table and chair symbols for use with these features.

Symbol Characteristics
Symbols should be hybrid (2D/3D) so that they display properly in both 2D and 3D views. At a minimum, the symbol 
must contain a 2D representation.
Create the 2D view of the symbol using as few polygons and lines as possible. If possible, use a single polyline rather 
than individual line segments. The line weight of the symbol is also a consideration; the symbols need to stand out 
when printed. The outer perimeter of the symbol should have a line weight of at least 1/2 point (7 mils). Interior details 

Symbol Name Displays the chair or table and chair symbol used to create the seating layout
Vertex Parameters Edits the seating layout path vertices; see “Editing Vertex-Based Objects” on page 1002.

Parameter Description

Seat label
control point

Seat focal 
control point
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should use a lighter line weight. The 2D representation should have a solid fill so that it obscures information under the 
symbol.
Keep the 3D symbol simple. It should be solid. The model should be accurately sized, but without minute details. 
These items can add significantly to the rendering time required, and are not necessary to distinguish among 
instruments.
To create a table and chair symbol, create the chair and table symbols separately, and then create a symbol from the 
table and chair symbols, so that the table and chair symbols are nested symbols.

Attaching the Event Planning Record to Seating Symbols
Attach the Event Planning Record to the symbol, with the Type field indicating whether the symbol is a table or chair. 
This allows the Seating Count worksheet to accurately count tables and chairs. 
To attach the event planning record:

1. In the Resource Browser, import the Event Planning Record from the Seating.vwx default event planning library 
file.
Locate the Event Planning Record and select Resources > Import to bring the record into the current file.

2. Select the new seating symbol, and select Modify > Edit Symbol.
If attaching the record to nested table and chair symbols, select the table or chair, and select Modify > Edit 
Symbol again to edit the individual table or chair. After attaching the event planning record to one of the nested 
symbols, repeat the procedure to attach the record to the other symbol.

3. In the Edit Symbol window, click on a blank area so that nothing is selected.
4. Click the Data tab in the Object Info palette. Attach the Event Planning Record to the symbol defaults by selecting 

the check box. Then edit the record by selecting the record field and entering its record information. The Type 
field for tables should contain “Table“ for tables and “Chair” for chairs, for proper object identification and 
inclusion in worksheets.

5. Click Exit Symbol at the upper right corner of the window to return to the drawing. 
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Seating Layout
Event Design
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Creating Event Views
Once the desired elements of the event have been added to the room, it is often necessary to create views of the room to 
show to the client. The Create Views command automatically creates two sheet layers of the event layout: a 2D plan 
view and a rendered isometric view. The Plan View sheet layer displays the layout in a Top/Plan, Wireframe mode 
viewport, and includes the seating count worksheet. The Rendered View sheet layer displays the layout in an isometric 
viewport, rendered in OpenGL mode.
To create a 2D and 3D rendered view of the event layout:

1. Select Event Design > Create Views.
2. The views are automatically created. The rendered viewport may require updating; with the viewport selected, 

click Update from the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Using Standard Views
OpenGL
Creating the Room
Creating the Stage
Creating Stage Stairs
Creating a Lectern
Creating a Video Screen
Creating Event Seating

Plan view with seating count worksheet Rendered 3D view; room wall removed for visualization



Editing Objects
The Object Info Palette
The Object Info palette provides information about the selected object(s) in a Vectorworks drawing. The information 
displayed depends on the type of objects selected. In addition, the palette can be used to change object parameters.

Certain objects allow you to right-click (Windows) or Ctrl-click (Mac) on the object to edit and select Edit from the 
context menu to access appropriate editing functions for that object, or select Properties from the context menu to 
access the object’s properties dialog box. The object properties dialog box contains information specific to the selected 
object, similar to the Object Info palette. Double-clicking on an object performs the same function as selecting Edit 
from the context menu (it also reactivates the working plane on which a planar object was created).
The Object Info palette organizes data into three tabbed panes:

Object Info palette drop-down list items can be selected by using the mouse or by typing the first letter(s) of the desired 
item to highlight the closest match in the list (excluding class and layer lists).
Set the Object Info palette position, active pane upon opening, and Data pane separator position, as described in 
“Saving Initial Palette Positions and Settings” on page 1843. Save palette positions and settings by selecting Window 
> Palettes > Save Palette Positions. To revert the palette position and settings back to the settings established when 
the custom workspace was created (in the User Data and Preferences folder), click Reset Saved Settings from the 
Session tab of Vectorworks preferences (see “Session Preferences” on page 52).

Activating the Object Info Palette
To activate the Object Info palette with an object selected in the drawing area, select Window > Palettes > Activate 
Object Info Palette, or press the keyboard shortcut to activate the Object Info palette (Ctrl + ‘ (back quote) on 
Windows or Cmd + Option + C on the Mac). 

Tab Description

Shape Displays information about a selected object’s geometry, class, layer, and location
Data Lists any database records attached to a selected object
Render When the Renderworks product is installed, assigns and maps textures to 3D objects. Also 

controls mesh smoothing in OpenGL and Renderworks and sketch rendering styles.
Coordinate/
IFC menu 
(Design Series 
required)

Specifies options for displaying IFC data (Vectorworks Architect or Landmark required) and for 
the display of coordinates in rotated plan views (Vectorworks Design Series required). See 
“Assigning IFC Data to Objects” on page 1746 and “Rotating the Plan” on page 1163.

Coordinate/IFC menu 
(Vectorworks Design 
Series required)
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The keyboard shortcut allows you to quickly switch the focus from the drawing area to the first editable field on the 
active tab of the Object Info palette. Repeat the keyboard shortcut to switch the focus through the Object Info palette’s 
tabs. If the Object Info palette is not open, or is minimized (unpinned), the Object Info palette is opened, and then the 
first editable field is highlighted. The shortcut key can be set in the workspace editor.
~~~~~~~~~~~~~~~~~~~~~~~~~
Shape Tab
Data Tab
Render Tab

Shape Tab
Object properties can be directly edited through the Object Info palette from the Shape tab. Objects can also be edited 
with the tools on the Basic palette as described in the instructions for each tool.
The Shape tab always displays class and layer information. For most objects, Rotation displays, indicating the object’s 
orientation. The detailed object information that is also displayed depends on the type of object selected, and can be 
simple or very extensive depending on the object.

Assigning Objects to Classes and Layers
To assign an object to a class or layer:

1. Select one or more object(s) to assign to the same class and/or layer.
2. Select a class/layer from the list of classes/layers present in the drawing, or create a new class/layer.

When a new class or layer is created from the Object Info palette, any selected objects are assigned to the new 
class/layer, but the active class/layer does not change to the newly created class/layer.
Classes can be displayed in hierarchical order (up to four levels). To enable or disable hierarchical display, see 
“Session Preferences” on page 52.

Alternatively, objects can be assigned to classes and layers in the Navigation palette (Vectorworks Design Series 
required). 

1. Select one or more object(s) to assign to a class. 
2. Select the Classes tab or Design Layers tab from the Navigation palette. 
3. Right-click (Windows) or Ctrl-click (Mac) on the class/layer to assign the object(s) to and select Assign to 

Selection from the context menu.

Object Coordinates and Bounding Box Indicator
The Shape tab can display a selected object’s plane, coordinate, and bounding box information. The information 
displayed depends on the type of object, the active plane, and whether it is in a rotated plan view (Vectorworks Design 
Series required) or positioned relative to a working plane.
For 2D objects, the plane to which the object belongs is indicated by the Plane list, and can be changed by selecting 
another plane from the list. For example, a screen plane object can be turned into a layer plane object by selecting 
Layer. When a working plane is active, the object can be moved to it. (If a combination of 2D and 3D objects are 
selected, the Plane list selection applies only to the 2D objects.)
Symbols display the symbol’s name and units (whether world- or page-based). Symbols and solids can be scaled from 
the Object Info palette (see “Scaling Symbols from the Object Info Palette” on page 1064 and “Scaling Solids 
Asymmetrically” on page 1064.)
The Box Position indicator displays for certain 2D objects such as lines, walls, rectangles, and ovals. It represents the 
bounding box of the object, indicates which side is the width and height for objects with width and height, and uses a 
handle to indicate the fixed point about which the object can be resized. The handle is also the location from which the 
object coordinates are determined. When an object is rotated, the box position indicator rotates also, indicating the 
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approximate position of the object and, if applicable, the width and height sides. For rectangles, rounded rectangles, 
and ovals, when the Rotation angle is less than ±45° from 90° or 270°, the Vectorworks software automatically swaps 
the height and width markers for the Box Position indicator and the values in the Height and Width fields.
Different object coordinates display for an object depending on its plane, position, and plan rotation. 

When a Vectorworks Design Series product is installed, the coordinates menu preference also affects the display 
of coordinates in rotated plan view (see “Rotating the Plan” on page 1163).

Some 3D objects, such as 3D polygons, NURBS curves, meshes, 3D symbols, spheres, cones, hemispheres, and 3D 
loci, can display coordinates relative to the layer plane (X, Y, Z)—also called the user coordinate system—or the active 
working plane (X’, Y’,Z’), when a working plane is selected. Click the planes button to change the relative coordinate 
display.

Some symbols are page-based at creation or upon import. These do not display a Box Position indicator in the Object 
Info palette. (The object can only be resized symmetrically.) The coordinates are relative to the screen plane (X and Y), 
and 2D/3D symbols also show the Z coordinate for a streamlined workflow between views. 

View Coordinate Display

Top/Plan Coordinates are relative to the screen plane (X and Y); coordinates for 2D/3D symbols 
also include the Z coordinate for a streamlined workflow between views

3D view with working 
plane active

Coordinates are relative to the layer plane (X and Y) and to the active working plane 
(X’, Y’). The working plane coordinates display in the same color set for the working 
plane itself in the interactive preferences.

Rotated plan 
(Vectorworks Design 
Series required)

Coordinates are relative to the layer plane (X and Y) and to the rotated plan (Screen X 
and Screen Y). The rotated plan coordinates display in blue, as do the rulers.

Coordinates relative to
layer plane

Coordinates relative to
active working plane
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Some objects, such as lines and walls, can display and edit selected object information in either Cartesian or polar 
mode.

 

Viewing and Editing Single and Multiple Objects
The Shape tab allows either single or multiple objects to be edited.
To view and edit object information for a single object:

1. Select Window > Palettes > Object Info.
The Object Info palette opens.

2. Click the Shape tab.
3. Select the desired object.

Editable information for that object is displayed.
4. Change the desired information, using the keys as follows:

To view and edit object information for multiple objects:
1. Select Window > Palettes > Object Info.

The Object Info palette opens.
2. Click the Shape tab.
3. Select the desired objects.

Coordinate System Description

Cartesian Cartesian coordinates are the same as those used in the drawing area; values are based on 
positive and negative X and Y axes

Polar In polar mode, values are relative to the user origin. Angles are represented as positive or 
negative values from 0 to 180. Values from 180 to 359 are automatically converted to negative. 
0 is at the 3 o’clock position.

Key Function

Enter Save the entry and return the focus to the drawing area
Tab Save the entry and move the focus to the next editable field
Shift+Enter Save the entry and keep the focus in the same field, so that you can enter a different value if 

necessary

Cartesian coordinate
system

Polar coordinate
system
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4. To edit each object in a selection separately, click Multiple Edit. This switches to Individual Edit mode. Once in 
Individual Edit mode, use the Next arrow button to move forward through the selected objects and the Previous 
arrow button to move backward through the selections. Each object highlights briefly as it is selected. To be sure 
which object is currently selected, click the center circular button to highlight it again. If either arrow appears 
dimmed, the end of the selected objects in that order has been reached.

Alternatively, select multiple objects of the same type, and then modify them at one time in Multiple Edit mode. 
When several objects of the same type have been selected, the palette operates in “batch” editing mode. If the 
parameter settings of the objects are different, the field displays as blank, or a check box displays with an 
“indeterminate state.” Any parameter edits affect all the selected objects in multiple edit mode.

Some objects have more editable fields than others. If the Object Info palette is not fully extended when an object of 
this type is selected, scroll options are provided. To scroll up and down, click the scroll arrows, any area of the scroll 
bar, or click-drag the scroll box (Windows) or scroller (Mac).

Multiple Edit mode

Multiple objects selected

Number of objects selected

Previous object
Highlights currently 
selected object

Next object

Editing single object within multiple selection

Currently selected
object type

Individual Edit mode
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Editing Vertex-Based Objects
For vertex-based objects, functionality similar to the Reshape tool is available from the Object Info palette Shape tab, 
where values can be entered to move vertices (or the entire object) rather than manipulating them graphically with the 
tool. Similarly, click the buttons to add, delete, change the vertex type, or hide the next edge; the selected vertex is 
affected.

Use either the Selection tool or the Reshape tool from the Basic palette to select a vertex to edit. With the tool selected, 
Right-click (Windows) or Ctrl-click (Mac) on the vertex (if the SmartCursor is enabled, it snaps to each vertex and 
identifies the vertex type to assist with selection) and select Select Vertex in Object Info Palette from the context 
menu. 

For certain vertex-based objects, you may first need to select the item and select an edit command to enter object 
editing mode. A colored border around the drawing window indicates editing mode is active (see “Object Editing 
Mode” on page 1004). 

The X and Y coordinates of the selected vertex display for editing in the Object Info palette.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Layers
Creating Classes
The Object Info Palette
Using Arithmetic Expressions
2D Reshape Modes
Data Tab
Render Tab

Scroll bar

Scroll box

Scroll arrow

WindowsMac

Scroller

Scroll bar
Scroll arrow

Select whether to affect the entire object 
or the selected vertex only

Scrolls through the vertices,
highlighting the selected one;

press the center button to
highlight the selected vertex Displays the location of the selected 

vertex; edits the location of the entire 
object or selected vertex
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Data Tab
The Data tab lists all records in the drawing, along with check boxes showing which records are attached. The Object 
Info palette can be used to make changes to record settings for individual objects. 
To view and edit record information:

1. Select Window > Palettes > Object Info.
2. Click the Data tab.

3. Select the desired object in the drawing area.
The following information is displayed.

Click to show/hide the parameters.

Parameter Description

Name Displays the name, if any, given to an object
Record Format Database Connection 
(Deign Series and database connection 
required)

In the Vectorworks Design Series products, links record formats to an 
external database for automated, two-way communication.

Object Database Connection (Design 
Series and database connection required)

Links the object instance to the external database’s table rows

Record Formats Displays all the records that are active in the drawing; if any of these 
records are attached to the selected object, the box to the left of the 
record name displays an X. If more than one object is selected, only the 
records attached to all objects display an X.

Record Fields Provides a list of all the record fields if a record is attached to the 
selected object; if any field has a default value assigned, it displays after 
the field name. If no item is currently selected in the drawing, the label 
displays Record Field Defaults instead of Record Fields. 

ODBC functionality
(Vectorworks Design 
Series required)
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Resize the list boxes by selecting and dragging the resize bars between them.
See “Record Formats” on page 262 for more information on attaching, editing, and deleting record formats.

~~~~~~~~~~~~~~~~~~~~~~~~~
Shape Tab
Render Tab
The Object Info Palette
Database Connectivity

Render Tab
When the Renderworks product is installed, this tab is available for the assigning and mapping of textures to 3D objects 
(see “Applying a Texture to an Object” on page 1530 for a complete description of the parameters available on the 
Render tab). In two cases, parameters on the Render tab are available in Vectorworks Design Series products, even if 
Renderworks is not installed: if sketch rendering is active, the Sketch parameter is available, and mesh objects 
rendered in OpenGL can be smoothed using the Mesh Smoothing parameter.
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Textures and Shaders
Sketch Rendering
Applying Sketch Styles to an Object

Object Editing Mode
Various types of complex objects are edited within a special editing mode in which you edit the components that make 
up the object. When this editing mode is activated, an Edit window with a colored border displays in the drawing area. 
Once the edits are complete, exit the object to return to the regular drawing mode.
Depending on the type of object being edited, the Edit window can show the edited object in context with the other 
objects in the drawing.

• The Edit window shows only the object being edited for the following types of objects: extrudes, multiple 
extrudes, tapered extrudes, sweeps, meshes, floors, roof faces, and symbol definitions edited from the Resource 
Browser or from a sheet layer.

• The Edit window can show other objects from the drawing while the following types of objects are being edited: 
groups, solids, viewports, and symbol definitions that are edited by clicking a symbol instance in a design layer. 
To enable this feature, select the option to Show other objects while in editing modes in the Display tab of the 
Vectorworks preferences (see “Vectorworks Display Preferences” on page 50). To show the other objects in a less 
obtrusive way, also select the Gray other objects option.
The Show other objects while in editing modes preference does not work when editing a symbol definition from 
a flipped symbol instance; an alert message displays when this operation is attempted.

To set options for the object editing mode, use the Data Bar and Edit Group Options list on the Tool bar, or select 
Window > Edit Group Options. See “Data Bar and Edit Group Options” on page 127 for details.
To edit an object:

1. Select the object to edit.
2. Select Modify > Edit for the object (for example, Edit Symbol or Edit Extrude).

Record Info Edits the field values for the selected record; all entered values override 
any default values for the object

Parameter Description
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Alternatively, double-click on the object, or right-click (Windows) or Ctrl-click (Mac) on the object, and then 
select Edit from the context menu.

3. For certain objects, only one component of the object can be edited at a time. When one of these objects is 
selected, one of the following dialog boxes opens to allow you to select which component to edit. Select a 
component to edit and click OK.
• Symbol: Edit Symbol dialog box
• Viewport: Edit Viewport dialog box
• Path or profile object: Choose Component dialog box
Alternatively, right-click (Windows) or Ctrl-click (Mac) on the object, and select a command from the context 
menu to edit the component directly or, if permitted by the object type, to switch from editing one component to 
editing another. For example, to edit the path or profile of a plug-in object directly, select Edit Path or Edit 
Profile from the context menu.

4. The Edit window displays the item to be edited. A colored border around the drawing window indicates the 
editing mode is active. The Exit command becomes available from the Modify menu, and the Exit button is 
visible in the top right corner of the drawing window.

5. Make the changes to the object.
If other objects in the drawing are displayed, the objects on other layers respect the layer options settings (for 
showing and snapping to objects in other layers) and the layer visibility settings. Other objects on the same layer 
as the edited object are snappable. One exception to this is when editing page-based (green) symbols, which are 
edited at a 1:1 scale; other objects which are not at a 1:1 scale are not snappable.
In addition, the view can be switched between regular and unified view mode as needed. (See “Unified Layer 
View” on page 1152 for more information.)

6. Click the Exit button to return to the regular drawing mode. (If a nested object is being edited, the Exit button 
exits back to the next level.)

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing a Group
Editing Symbol Definitions

Moving Objects
Objects can be moved in several ways.

• Use the Move command (operates in the screen plane) or Move 3D command to move an object an exact distance.
• Use the Move by Points tool to move, duplicate, and distribute objects by clicking.
• Use the selection tools to select and drag objects to a new location.
• Nudge selected objects one pixel at a time, or by the snap grid (see “Edit Preferences” on page 49).

~~~~~~~~~~~~~~~~~~~~~~~~~
Moving Objects in the Screen Plane
Moving Objects in 3D Space
Moving Objects by Clicking with the Move by Points Tool
Moving Symbols in Walls with the Selection Tool
Nudging Symbols in Walls
Moving Symbols in Walls with the Move Command
Moving Symbols in Walls with the Move by Points Tool
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Moving Objects in the Screen Plane
For information about moving symbols in walls, see “Moving Symbols in Walls with the Move Command” on 
page 257.
To move an object in screen plane space with the Move command:

1. Select the object(s) to move.
2. Select Modify > Move > Move.

The Move Selection dialog box opens. Move the objects according to Cartesian or polar coordinates.
Click to show/hide the parameters.

3. Click OK. 
The object is moved in the screen plane according to the criteria specified.

~~~~~~~~~~~~~~~~~~~~~~~~~
Moving Objects

Moving Objects in 3D Space
To move an object with the Move 3D command:

1. Select the object(s) to move. 
2. Select Modify > Move > Move 3D.

The Move 3D Selection dialog box opens.
Click to show/hide the parameters.

3. Click OK. The object is moved in 3D space according to the criteria specified.
~~~~~~~~~~~~~~~~~~~~~~~~~
Moving Objects

Moving Objects by Clicking with the Move by Points Tool
Objects can be moved, duplicated, and distributed along a specified distance by clicking with the Move by Points tool. 
This tool also moves symbols within walls (see “Moving Symbols in Walls with the Move by Points Tool” on 
page 258).

Parameter Description

Cartesian Specify the distance to move the object; for Cartesian coordinates, select Cartesian and enter 
the X and Y Offset distances

Polar Specify the distance to move the object; for polar coordinates, select Polar and enter the 
Distance and Angle

Parameter Description

Cartesian Select the X, Y, Z (Cartesian) coordinate system
X, Y, Z Offset For Cartesian coordinates, specify the distance to move the object

Working Plane Select the X’, Y’, Z’ (working plane) coordinate system
X’, Y’, Z’ Offset For working plane coordinates, specify the distance to move the object
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Click here for a video tip on this topic (Internet access required).

Moving Objects with the Move or Distribute Mode

To move, duplicate, and distribute selected objects:

1. Select the object(s) to move and/or duplicate.
2. Click the Move by Points tool from the Basic palette and click Preferences from the Tool bar.

The Move by Points Settings dialog box opens. Select the settings and click OK.
Click to show/hide the parameters.

To select additional objects or to change the currently selected objects to move, duplicate, or distribute, press and 
hold the Alt key (Windows) or Cmd key (Mac) while shift-clicking or click-dragging the mouse around them to 
marquee select them; the Selection tool is activated in boomerang mode while the Alt or Cmd key is being 
pressed.

3. Select either the Move or Distribute mode, depending on the desired outcome.

Mode Description

Move Moves and duplicates selected objects according to the distance and direction specified by two 
mouse clicks

Distribute Moves and distributes duplicate objects between the points specified by two mouse clicks
Reference Point Moves selected objects according to a clicked reference point and a specified offset distance 

from that point; the Preferences settings are not applicable when this mode is selected
Object 
Retention

Keeps the original objects; this is the same as selecting the Retain option in the tool 
preferences

Parameter Description

Number of 
Duplicates

Specifies the number of copies of the original object(s) to create; same as the Number of 
Duplicates field on the Tool bar.
A value of 0 (zero) means that the original object will be moved; in this case, the Retain 
option below (and the Object Retention button on the Tool bar) have no effect.

Original Object
Retain Keeps the original object(s); this option performs the same function as the Object 

Retention button on the Tool bar
Leave Selected Keeps the original object(s) selected for further action

Move

Preferences

Distribute Object Retention

Reference Point

Number of Duplicates Preference

http://www.youtube.com/watch?v=URecILSbASg


  1008 | Moving Objects
4. Click once (anywhere on the drawing) to indicate the vector start point, and click again to indicate the vector end 
point. Duplicates are placed in the vector direction, at the distance specified by the click points, along the line 
defined by the click points. 

Moving Objects with the Reference Point Mode
Reference Point mode can work two ways; the first click can either indicate the object to be moved or the reference 
point from which the object will be offset.

To move selected objects using a reference point:

1. Select the object(s) to move.
2. Click the Move by Points tool from the Basic palette.

To select additional objects or to change the currently selected objects to move, duplicate, or distribute, press and 
hold the Alt key (Windows) or Cmd key (Mac) while shift-clicking or click-dragging the mouse around them to 
marquee select them; the Selection tool is activated in boomerang mode while the Alt or Cmd is being pressed.

Mode Number of 
Duplicates

Original Object 
Retained

Result

Move or 
Distribute

0 not applicable Moves the original object(s) to the location specified by clicking

Move or 
Distribute

1 No Moves the original object(s) to the location specified by clicking

Move or 
Distribute

1 Yes Creates one duplicate of the original object(s), placed at the location 
indicated by clicking

Move > 1 No Moves the original object(s), placing the original at the location 
specified by the first click, and placing the duplicates the same distance 
apart from each other along the vector created by the two click points

Move > 1 Yes Creates duplicates of the original object(s), placing the first duplicate at 
the location specified by the second click, and placing additional 
duplicates the same distance apart from each other along the vector 
created by the two click points

Distribute > 1 No Moves the original object(s), placing the original at the location 
specified by the first click, and distributing the duplicates between the 
two click points, and along the vector created by the two points

Distribute > 1 Yes Creates duplicates of the original object(s), distributing the duplicates 
between the two click points, and along the vector created by the two 
points

Move mode,
two duplicates,
retain original

Click 1

Click 2

Distribute mode,
two duplicates,
retain original

Click 1

Click 2
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3. Select the Reference Point mode from the Tool bar.
4. Click to indicate either the reference point, or a point on the selected object.

The Enter Offset dialog box opens.
5. The current Offset distance between the two click points displays. Enter the desired distance.
6. Select whether the first click made was the reference point or a point on the object to be moved.
7. Click OK. The selected object is moved as specified, along the line defined by the click points.
8. The setting for how the first click is interpreted remains set until it is changed.

~~~~~~~~~~~~~~~~~~~~~~~~~
Moving Objects

Cutting, Copying, and Pasting Objects

Cutting Objects
The Cut command removes an object from the drawing, temporarily storing the object in the clipboard.
To cut an object:

1. Select the object(s) to remove.
2. Select Edit > Cut.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the object, and select Cut from the object context 
menu.
The object is moved from the drawing to the clipboard.

Copying Objects
The Copy command copies an object to the clipboard, where it is temporarily stored. The original object remains on 
the drawing.
To copy an object:

1. Select the object(s) to copy.
2. Select Edit > Copy.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the object, and select Copy from the object context 
menu.
The program places a copy of the object in the clipboard.

Pasting Objects
The Paste command places the clipboard object(s) into the same drawing file, into another Vectorworks file, or into 
another software program’s file (if that program also has copy, cut, and paste commands). As long as the Vectorworks 

Click 1

Click 2Click the point from which to 
offset the selected object, click 
the object, and then enter the 
offset distance
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program remains open while the object is in the clipboard, the object retains all its object information for pasting into 
Vectorworks documents.

Some image quality can be lost when Vectorworks objects are pasted into other programs, or from other programs 
into a Vectorworks file.

To paste an object:
1. Open the file and layer where the object is to be added.
2. Select Edit > Paste.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the drawing area, and select Paste from the document 
context menu.
The program pastes the clipboard contents centered on the location of the last mouse click, unless the last mouse 
click is outside the current view. In that case, the contents are pasted at the center of the drawing. When you paste 
into a different Vectorworks file, the program automatically centers the clipboard contents in the drawing area.
When a raster image is pasted into a Vectorworks file, it is automatically compressed to PNG format to reduce the 
Vectorworks file size.

Paste as Bitmap
Like the Paste command, the Paste as Bitmap command places a copy of the clipboard contents in the active 
Vectorworks drawing file. However, Paste as Bitmap places the entire clipboard contents as a single bitmap object. 
Because the pasted clipboard content is now one item, individual objects (including symbols and text) can no longer be 
edited.
This command can be useful if there are multiple objects on the clipboard that you do not want to edit separately, or if 
the clipboard objects may lose some image quality if they are converted into Vectorworks objects.
To paste as a bitmap:

1. Open the file and layer where the object is to be added.
2. Select Edit > Paste as Bitmap.

Paste in Place
The Paste in Place command works exactly like the Paste command, except that the clipboard contents are pasted into 
the active drawing at the same coordinates (relative to the user origin) from which they were copied. When you paste to 
a sheet layer, remember that each sheet layer has its own user origin, which may be different from the origin of the 
layer where the object was copied (see “Internal Origin and User Origin” on page 72 for details).
To paste in place:

1. Open the file and layer where the object is to be added.
2. Select Edit > Paste in Place.

Changing Object Stacking Order
As objects are drawn, the program keeps track of their stacking order within the design layer. The first object created is 
at the back of the stack, and the most recent object created is at the front of the stack.
The send commands change the stacking order of objects within a layer. Objects can be sent forward to be in front of an 
overlapping object or sent backward to be behind an overlapping object. Also, objects can be sent all the way to the 
front or back of the stack in one step.
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To change the stacking order of an object:
1. Select the object to restack.
2. Select Modify > Send. Select the send method to use.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the object, and select Send from the object context 
menu.

The object’s stacking order is changed.

Removing Objects

Clearing Objects
The Clear command deletes any selected object or objects. It has the same effect as pressing the Delete key, meaning 
that the object(s) are not stored on the clipboard. The only way to retrieve a “cleared” object is to select Undo. This 
command provides an additional way of removing an object from the drawing without deleting the current contents of 
the clipboard.
To clear an object from the drawing:

1. Select the object or objects to remove from the drawing.
2. Select Edit > Clear.

~~~~~~~~~~~~~~~~~~~~~~~~~
Purging Items from a File

Purging Items from a File
The Purge command removes specified items from the drawing and reduces the file size. Unused layers, classes, and 
resources, as well as objects outside of the page boundaries can be removed from the file.
To purge items from a file:

1. Select Tools > Purge.
The Purge dialog box opens. Each type of item that can be purged is listed, along with the number of items that 
were found. Select the items to remove from the drawing file.

Method Description

Send to Front Sends the selected object to the front of stack
Send Forward Sends the selected object toward the front of the stack, in front of the next object in the stack that 

overlaps it; if no other object overlaps the selected object, the stacking order is not changed
Send to Back Sends the selected object to the back of the stack
Send 
Backward

Sends the selected object toward the back of the stack, behind the next object in the stack that 
overlaps it; if no other object overlaps the selected object, the stacking order is not changed
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Item Description

Unused Resources
Gradients Deletes any unused gradient resources
Hatches Deletes any unused hatch resource.

If a surface hatch’s associated texture is in use (Renderworks 
required), that hatch is also considered in use and is not purged.

Images Deletes any unused image resources
Line Types Deletes any unused line type resources
Record Formats Deletes any unused record format resources.

Also select Special Record Formats to delete unused record formats that 
store plug-in object default values. An alert prompts you to confirm that the 
default values should be deleted.

Renderworks Backgrounds
(Renderworks required)

Deletes any unused Renderworks background resources

Renderworks Styles 
(Renderworks required)

Deletes any unused Renderworks render style resources

Renderworks Textures
(Renderworks required)

Deletes any unused texture resources

Sketch Styles 
(Vectorworks Design Series 
required)

Deletes any unused sketch style resources

Slab Styles
(Vectorworks Architect required)

Deletes any unused slab style resources

Symbols Deletes any unused symbol resources.
Also select Special Symbols to delete the resources for plug-in object 
symbols and group symbols (those listed in red and blue in the Resource 
Browser). This will not delete any associated plug-in or group objects that 
have already been placed in the drawing. An alert prompts you to confirm 
that the special symbol resources should be deleted.

Text Styles Deletes any unused text style resources
Tiles Deletes any unused tile resources
Wall Styles
(Vectorworks Architect or 
Landmark required)

Deletes any unused wall style resources
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2. Click OK.
If Preview items that will be purged was selected, the Purge Preview dialog box opens. The Name and Type of 
each item that will be purged displays. Red and blue names indicate symbols that are defined to be inserted as 
plug-in objects and groups, respectively (see “Symbol Types” on page 237). For symbol definitions and empty 
symbol folders, the Location column indicates which resource folder currently contains the item. For objects that 
are outside of the page boundaries, the Location column indicates which sheet layer or design layer currently 
contains the item.
To prevent an item from being purged, click the column to the left of the item’s name to remove the check mark.

All • Checked box: All attributes in the Unused Resources group are selected; 
click to deselect all attributes in the group.

• Empty box: No attributes in the Unused Resources group are selected; 
click to select all attributes in the group.

• Box displays  (Windows) or   (Mac): One or more attributes in 
the Unused Resources group are not selected; click to select all attributes 
in the group.

The Special Record Formats and Special Symbols options are not 
automatically selected along with the other unused resources; they 
must be selected individually.

Other Items
Empty Layers Deletes any layers that do not contain any objects
Empty Story Layers
(Vectorworks Architect required)

Deletes any stories that do not contain any layers

Empty Symbol Folders Deletes any unused symbol folders
Unused Classes Deletes any unused classes
Objects Outside of Page 
Boundaries for

Deletes any objects that are totally outside the page boundaries; if an object 
is partially within the boundary, it will not be deleted. Objects can be 
deleted from the active layer only, from all design layers, and from all sheet 
layers.

All • Checked box: All attributes in the Other Items group are selected; click 
to deselect all attributes in the group.

• Empty box: No attributes in the Other Items group are selected; click to 
select all attributes in the group.

• Box displays  (Windows) or   (Mac): One or more attributes in 
the Other Items group are not selected; click to select all attributes in the 
group.

Preview items that will be purged Opens the Purge Preview dialog box after you click OK on the Purge dialog 
box; if needed, items can be removed from the purge list

Item Description
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3. Click OK to complete the purge.
4. If necessary, use the Undo command to undo the purge.

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Clearing Objects

Duplicating Objects

Duplicating Single
The Duplicate command makes a copy of an object or group of objects and places it on the drawing. Depending on the 
setting in Vectorworks preferences, the duplicated object or objects will either be offset or placed directly on top of the 
original.
To duplicate any object:

1. Select the object(s) to copy.
2. Select Edit > Duplicate.

The program places a copy of the selected object(s) in the drawing according to the settings in the Vectorworks 
preferences dialog box.
When objects with an offset are duplicated, the offset is maintained with the duplicate.

~~~~~~~~~~~~~~~~~~~~~~~~~
Duplicate Array
Duplicating Objects Along a Path

Duplicate Array 
The Duplicate Array command controls how many copies of selected objects are made and how these copies are 
arrayed, or placed, in the drawing.
For information about placing symbols in walls in a duplicate array, see “Inserting Symbols in a Duplicate Array” on 
page 255.

http://www.youtube.com/watch?v=Wvzb3mLUvok
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To create a duplicate array:
1. Select the object or objects to copy.
2. Select Edit > Duplicate Array.

The Duplicate Array dialog box opens. Select the desired duplication array Shape. The dialog box dynamically 
displays the appropriate fields based on the selected linear, rectangular, or circular array shape.

Linear Array

Click to show/hide the parameters.

Parameter Description

Number of Duplicates Specify the number of copies of the original object to create
First Duplicate’s Position 
Determined By

Specify the start point for the first copied object, by either specifying coordinates or 
placing the object with the mouse

Cartesian Offset To use Cartesian coordinates, click this option and specify the distance of the center of 
the copy from the center of the original object by entering X, Y, and Z coordinates. If 
the view is something other than Top/Plan, and the field Values Are With Respect to 
the is set to Working Plane, the labels on the coordinate fields are X’, Y’, and Z’ 
instead of X, Y, and Z. Z (or Z’) must be zero when only 2D screen objects are being 
duplicated.

Polar Offset This option is always enabled if 2D objects are selected. If 3D or hybrid objects are 
selected, or if both 2D and 3D objects are selected, this option is enabled only in Top/
Plan view. To use polar coordinates, click this option and specify the distance of the 
center of the copy from the center of the original object by entering r (radius), theta 
(angle), and Z coordinates; Z must be zero when only 2D screen objects are being 
duplicated.

Next Mouse Click and 
Z (or Z’)

This option is always enabled if 2D objects are selected. If 3D or hybrid objects are 
selected, or if both 2D and 3D objects are selected, this option is enabled only in Top/
Plan view. To place the copy with the mouse, select Next Mouse Click. To offset the 
first copy from the original object’s plane, enter a Z (or Z’) value; Z (or Z’) must be 
zero when only 2D screen objects are being duplicated.

Values Are With Respect 
to the

Specify whether the array should be built relative to the active layer plane or working 
plane

Resize Duplicates Select Resize Duplicates to resize each successive copy with the specified X Scale, Y 
Scale, and Z Scale values; to leave the copies at the same scale as the original object, 
ensure that Resize Duplicates is deselected

Rotate Duplicates Select Rotate Duplicates to rotate each successive copy at the specified Angle; to 
leave the copies at the same rotation as the original object, ensure that Rotate 
Duplicates is deselected

Original Object To include the original object in the array, select Retain; otherwise, the original object 
is deleted. To leave the original object selected after duplication, also click Leave 
Selected.

Linear Array Rectangular Array Circular Array
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Rectangular Array

Click to show/hide the parameters.

Circular Array

Click to show/hide the parameters.

Parameter Description

Number of Columns Specify the number of copies of the original object to create in the array’s X direction 
(active layer plane duplication) or X’ direction (working plane duplication)

Number of Rows Specify the number of copies of the original object to create in the array’s Y direction 
(active layer plane duplication) or Y’ direction (working plane duplication)

Number of Stacks Specify the number of copies of the original object to create in the array’s Z direction 
(active layer plane duplication) or Z’ direction (working plane duplication)

Distance Between 
Columns

Specify the distance between each column in the array (measured from the copied 
objects’ centers)

Distance Between Rows Specify the distance between each row in the array (measured from the copied 
objects’ centers)

Distance Between Stacks Specify the distance between each stack in the array (measured from the copied 
objects’ centers); this value must be zero when only 2D screen objects are being 
duplicated

Values Are With Respect 
to the

Specify whether the array should be built relative to the active layer plane or working 
plane

Resize Duplicates Select Resize Duplicates to resize each successive copy with the specified X Scale, Y 
Scale, and Z Scale values; to leave the copies at the same scale as the original object 
ensure that Resize Duplicates is deselected

Rotate Duplicates Select Rotate Duplicates to rotate each successive copy at the specified Angle; to 
leave the copies at the same rotation as the original object, ensure that Rotate 
Duplicates is deselected

Original Object To include the original object in the array, select Retain; otherwise, the original object 
is deleted. To leave the original object selected after duplication, also click Leave 
Selected.

Parameter Description

Number of Duplicates Specify the number of copies of the original object to create
Angle Between Duplicates Specify the angle of separation between the centers of each object in the array
Z (or Z’) Offset of 
Successive Duplicates

To offset copies from the original object’s plane, specify the distance between each 
successive copy. If the view is something other than Top/Plan, and Values Are With 
Respect to the is set to Working Plane, the label is Z’ instead of Z. Z and Z’ must be 
zero when only 2D screen objects are being duplicated.

Circle Center Point Specify the center point for the circular array, by either specifying coordinates or 
placing the array with the mouse
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3. Set the parameters and click OK.
If the array location is already specified, the program automatically places the duplicate array.
If Next Mouse Click was selected, move the mouse where the copies are to be placed, and click. For circular and 
rectangular arrays, click the mouse at the center of the array.

~~~~~~~~~~~~~~~~~~~~~~~~~
Duplicating Single
Duplicating Objects Along a Path

Duplicating Objects Along a Path
The Duplicate Along Path command creates and places several copies of an object or objects along an existing path.

If a 2D object and 3D path are selected, the 2D object is projected onto the path.

X and Y (or X’ and Y’) To place the array using coordinates, enter the X and Y coordinates of its center point. 
If the view is something other than Top/Plan, and Values Are With Respect to the is 
set to Working Plane, the labels on the coordinate fields are X’ and Y’ instead of X 
and Y.

Next Mouse Click This option is always enabled if 2D objects are selected; if 3D or hybrid objects are 
selected, or if both 2D and 3D objects are selected, this option is enabled only in Top/
Plan view. Select Next Mouse Click to place the array so that its center is at the next 
clicked point.

Values Are With Respect to 
the

Specify whether the array should be built relative to the active layer plane or working 
pane

Resize Duplicates Select Resize Duplicates to resize each successive copy with the specified X Scale, Y 
Scale, and Z Scale values; to leave the copies at the same scale as the original object, 
ensure that Resize Duplicates is deselected

Rotate Duplicates Select Rotate Duplicates to rotate each successive copy at either the Angle Between 
Duplicates or the specified Custom Angle; to leave the copies at the same rotation as 
the original object, ensure that Rotate Duplicates is deselected

Original Object To include the original object in the array, select Retain; otherwise, the original object 
is deleted. To leave the original object selected after duplication, also click Leave 
Selected.

Parameter Description

3D linear array with Z offset 
and resized duplicates

3D circular array with Z offset 
and rotated duplicates
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To duplicate objects along a path:
1. Select the object or objects to duplicate, and select the path object.

2. Select Edit > Duplicate Along Path.
The Duplicate Along Path dialog box opens.

Click to show/hide the parameters.

Parameter Description

Select a path object Click Prev or Next to select the object that represents the path; the selected path object is 
highlighted

Duplicate Placement Specifies the duplicate object placement parameters
Number of 
Duplicates

Creates the specified Number of duplicate objects, equally spaced along the path

Fixed Distance Duplicates objects at the fixed intervals specified in Distance
Start Offset Specifies the distance from the end of the path to the first duplicated object; enter zero to 

place the first object at the start of the path 
Curve Length Displays the length of the path object, for reference
Center object on path Centers original and duplicates along the path; deselect the option to maintain the 

position of the duplicates relative to the path

Tangent to path Rotates the duplicates so they are always tangent to the path

Grouped 2D objects and polyline path 3D object (in 3D view) and NURBS curve

Center object on path 
selected

Center object on path 
deselected

Tangent to Path 
selected

Tangent to Path 
deselected
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3. Click OK.
The duplicates are arrayed with their centers along the selected path object.

~~~~~~~~~~~~~~~~~~~~~~~~~
Duplicating Single
Duplicate Array

Smoothing Objects
The smoothing commands smooth all selected polygon and polyline vertices in one step, changing all vertices of the 
object into the selected vertex type. The commands also work on NURBS curves. The No Smoothing command 
changes smoothed vertices into cornered vertices.
To smooth an object:

1. Select the object(s) to smooth.
2. Select Modify > Poly Smoothing. Select the smoothing method to use.

The object is smoothed.

Keep original 
orientation

Maintains the original object’s position and rotates the duplicates tangent to the path, 
relative to the original object’s tangency angle

Preview Click to preview the effect of parameter changes before clicking OK

Method Description

No Smoothing Creates straight lines and corner vertices
Bézier Spline Smoothing Creates curves pulled towards but not touching the vertices
Cubic Spline Smoothing Creates curves that pass through the control points
Arc Smoothing Creates fillet-like curves at the control points. The arc radius is based on the 

current fillet radius of the Fillet tool (see “Fillet Tool” on page 1077). If no radius 
is set, the largest radius that can fit between each vertex is used.

Radius Smoothing Creates curved radius vertices, which are easier to reshape than arc vertices

Parameter Description

Keep original orientation 
selected

Keep original orientation 
deselected
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~~~~~~~~~~~~~~~~~~~~~~~~~
Simplifying Polygons and Polylines

Composing and Decomposing Objects and Surfaces

Composing Objects and Surfaces
The Compose command can combine NURBS surfaces, lines, arcs, open polygons, NURBS curves, NURBS arcs, and 
open 3D polygons into a single object. The endpoints of each object must be touching to use this command. Objects 
that are not touching are ignored.
Adjacent NURBS surfaces, which may have been split by the Split tool (see “Splitting Objects and NURBS Surfaces 
with the Split Tool” on page 1072), can be composed into a single NURBS surface with this command.
To compose adjacent objects or NURBS surfaces:

1. Select the objects or NURBS surfaces to be composed.
If a large number of objects are connected end to end, use the Edit > Select Connected Objects command to 
select them.

2. Select Modify > Compose. The objects are combined to create a single object or NURBS surface.

If there are multiple objects touching at the same endpoint, the two objects closest in stacking order are combined.
~~~~~~~~~~~~~~~~~~~~~~~~~
Selecting Connected Objects
Decomposing Objects and Surfaces

Decomposing Objects and Surfaces
The Decompose command can decompose NURBS surfaces, 2D polygons, 2D polylines, 3D NURBS curves created 
with the Compose command, and open 3D polygons.
Occasionally, surface creation methods like the Create Surface from Curves command can create a surface with 
internal discontinuities. Many of the 3D Power Pack tools and commands are not designed to work with these types of 
surfaces. The Decompose command can separate the surface into NURBS surfaces without discontinuities.
To decompose a NURBS surface or object into individual segments:

1. Select the NURBS surface or object to be decomposed.
2. Select Modify > Decompose.

Smoothed using Arc Smoothing
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The NURBS surface is separated into individual surfaces, or the object is separated into individual segments.

~~~~~~~~~~~~~~~~~~~~~~~~~
Composing Objects and Surfaces
Selecting Connected Objects

Selecting Connected Objects
The Select Connected Objects command can select objects that are connected end to end with one or more selected 
objects. Any combination of connected lines, arcs, open polygons, open polylines, open NURBS curves, open 3D 
polygons, walls, and open round walls can be selected. The endpoints of each object must be touching either directly or 
indirectly to use this command. Objects that are not touching are ignored.
This command can be useful when an imported DXF/DWG file contains a large number of small lines that are 
connected end to end and you want to compose them into a single object.
To select connected objects:

1. Select one or more objects to which the other objects to be selected are connected end to end.
2. Select Edit > Select Connected Objects.

The selected objects are highlighted; the Object Info palette indicates how many objects were selected.

~~~~~~~~~~~~~~~~~~~~~~~~~
Composing Objects and Surfaces

Locking and Unlocking Objects

Locking Objects
Objects in a drawing can be protected with the Lock command so that they cannot be accidentally moved, deleted, or 
edited. A locked object must be unlocked before any changes can be made to it.
To lock an object:

1. Select the object or objects to lock.
2. Select Modify > Lock.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the object, and select Lock from the object context 
menu.
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The Object Info palette indicates that the object is locked. Depending on the selection highlighting setting in 
Vectorworks preferences, the handles and/or highlighting also change to indicate that the object is now locked (see 
“Selection and Pre-selection Indicators” on page 114).

Unlocking Objects
Unlock an object or group of objects that was previously locked with the Unlock command. Unlocked objects can be 
copied, moved, deleted, or edited.
To unlock objects:

1. Select the object or objects to be unlocked.
2. Select Modify > Unlock

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the object, and select Unlock from the object context 
menu.
The Object Info palette no longer indicates that the object is locked. Depending on the selection highlighting 
setting in Vectorworks preferences, the handles and/or highlighting also change to indicate that the object is now 
unlocked (see “Selection and Pre-selection Indicators” on page 114).

Rotating Objects
There are several ways to rotate objects. Use the Rotate tool to rotate an object, or a duplicate of an object, directly 
with the mouse. Use the various Rotate commands to rotate the object by choosing a preset rotation, or by entering 
custom rotation information in a dialog box.

Certain objects, such as rectangles, rounded rectangles, ovals, bitmaps, and text objects, can be rotated with the 
Interactive Scaling mode of the Selection tool. Press the Alt key (Windows) or Option key (Mac) while dragging 
a reshape handle.

~~~~~~~~~~~~~~~~~~~~~~~~~
Rotate Tool
Preset Rotation Angles
Custom Rotation
3D Custom Rotation
Unrotating 3D Objects

Rotate Tool
The Rotate tool can rotate objects in the drawing. Double-clicking the tool when an object is selected opens the Rotate 
Object dialog box as described in “Custom Rotation” on page 1025.
The Rotate tool can rotate, or rotate and duplicate the selected object(s) about an axis or aligned relative to another 
object. 

 

Mode Description

Standard Rotates the selected object
Duplicate Creates a duplicate object and rotates it

Standard

Duplicate 

Standard Rotation

Alignment Rotation
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Click here for a video tip on this topic (Internet connection required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Standard Rotation
Rotation by Alignment
Rotating Objects

Standard Rotation

To rotate an object around a specified axis:

1. Select the object to rotate.
2. Click the Rotate tool from the Basic palette.

To select additional objects or to change the currently selected objects to rotate, press and hold the Alt key 
(Windows) or Cmd key (Mac) while shift-clicking or click-dragging the mouse around them to marquee select 
them; the Selection tool is activated in boomerang mode while the Alt or Cmd key is being pressed.

3. Select Standard or Duplicate from the Tool bar, depending on whether the original or a duplicate object is to be 
rotated.

4. In a 3D view, select Standard Rotation from the Tool bar.
By default, the rotation plane is that of the active working plane; the working plane orientation can be changed. If 
desired, select Screen Plane from the Active Plane list on the Tool bar to rotate in a plane parallel to the screen 
plane.

5. A protractor feedback graphic displays around the cursor. Position the protractor on the appropriate rotation plane, 
and click at the center point of the rotation.
The protractor graphic displays only when an object is selected.

6. The protractor graphic remains at the click point. As you move the cursor, the protractor rotates, and a dotted line 
from the rotation center to the cursor previews the axis of rotation. Click to define the axis of rotation.

7. As you move the cursor, a preview of the rotated object displays. Click to set the rotation angle.
The original object or its duplicate is rotated to the new position.

~~~~~~~~~~~~~~~~~~~~~~~~~
Rotating Objects

Standard Rotation (3D views only) Rotates the object about a defined axis
Alignment Rotation (3D views only) Rotates the object by aligning it with another object

Mode Description

Click 1
Click 3

Rotating an object using the Standard and Standard Rotation modes

Click 2

http://www.youtube.com/watch?v=1VDWtPvN-XI
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Rotation by Alignment

To rotate an object by aligning it with another object:

1. Select the object to rotate.
2. Select the Rotate tool from the Basic palette.

To select additional objects or to change the currently selected objects to rotate, press and hold the Alt key 
(Windows) or Cmd key (Mac) while shift-clicking or click-dragging the mouse around them to marquee select 
them; the Selection tool is activated in boomerang mode while the Alt or Cmd is being pressed.

3. Select Standard or Duplicate from the Tool bar, depending on whether the original or a duplicate object is to be 
rotated.

4. In a 3D view, select Alignment Rotation from the Tool bar.
5. A protractor feedback graphic displays around the cursor. Position the protractor on the appropriate rotation plane, 

and click at the center point of the rotation.
The protractor graphic displays only when an object is selected.

6. The protractor graphic remains at the click point. As you move the cursor, the protractor rotates, and a dotted line 
from the rotation center to the cursor previews the axis of rotation. Click to define the axis of rotation.

7. As you move the cursor, a preview of the rotated object displays. Click the desired point to align the object.
The original object or its duplicate is rotated to the new position.
For the alignment and preview to work properly, all three clicks must be positioned on a snap point.

~~~~~~~~~~~~~~~~~~~~~~~~~
Rotating Objects
Setting Snapping Parameters
Drawing with Snapping

Preset Rotation Angles
The rotate commands provide a number of ways to rotate objects in the screen plane without changing their base 
location in the drawing. Select one of the preset rotation angles, or specify a custom rotation angle.
To rotate at a specified angle:

1. Select the object(s) to rotate.
2. Select Modify > Rotate, and then the pre-set rotation.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the object(s), and select Rotate from the object 
context menu.

Click to show/hide the parameters.

Click 1 Click 2

Click 3

Rotating an object using the Standard and Alignment Rotation modes
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~~~~~~~~~~~~~~~~~~~~~~~~~
Rotating Objects

Custom Rotation
The center of rotation for this command is limited to the center of the object’s bounding box. The rotation is performed 
within the screen plane.
To rotate by a custom angle:

1. Select the object or objects to rotate.
2. Select Modify > Rotate > Rotate. Alternatively, double-click the Rotate tool.

The Rotate Object dialog box opens.
3. Enter the rotation angle.

The precision of the values that can be entered (degrees, minutes, and/or seconds) depends on the Units setting.
4. Click OK.

~~~~~~~~~~~~~~~~~~~~~~~~~
Rotating Objects

3D Custom Rotation
The precision of the rotation values that can be entered (degrees, minutes, and/or seconds) depends on the Units setting.
To rotate at custom angles in 3D:

1. Select the 3D object or objects to rotate.
2. Select Modify > Rotate > Rotate 3D.

The Rotate Object in 3D dialog box opens. Specify the rotation parameters.
Click to show/hide the parameters.

3. Click OK.

Parameter Description

Rotate Left 90º Rotates the selected object counter-clockwise 90º
Rotate Right 90º Rotates the selected object clockwise 90º
Flip Horizontal Flips the selected object about its center
Flip Vertical Flips the selected object vertically about its center

Parameter Description

Rotation Angle Enter the angle of rotation
Center of Rotation Specify the desired center of rotation

Working Plane Center Rotates using the center of the working plane
Object Center Rotates about the center of the selected object
Next Mouse Click Rotates around the next mouse click in the drawing window

Rotation Axis Select whether the rotation axis will be based on the Active Layer Plane or the 
Working Plane, and about which axis
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~~~~~~~~~~~~~~~~~~~~~~~~~
Rotating Objects

Unrotating 3D Objects
The Unrotate 3D Objects command returns any 3D object that has its own coordinate system to its upright position. 
Use the command to rotate symbols, extrudes, multiple extrudes, and sweeps so that they align with the world 
coordinate system. 
To unrotate a 3D object:

1. Select the 3D object or objects to unrotate.
2. Select Modify > Unrotate 3D Objects.

~~~~~~~~~~~~~~~~~~~~~~~~~
Rotating Objects

Mirroring Objects
The Mirror tool can mirror, or mirror and duplicate, objects across an axis line or across the working plane. 

 

Click here for a video tip on this topic (Internet connection required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Mirroring Objects Across an Axis
Mirroring Objects Across the Working Plane

Mirroring Objects Across an Axis

To mirror objects across an axis:

1. Select the object(s) to mirror.
2. Click the Mirror tool from the Basic palette.

To select additional objects or to change the currently selected objects to mirror, press and hold the Alt key 
(Windows) or Cmd key (Mac) while shift-clicking or click-dragging the mouse around them to marquee select 
them; the Selection tool is activated in boomerang mode while the Alt or Cmd key is being pressed.

3. Select Standard or Duplicate from the Tool bar, depending on whether the original object is to remain in place.

Mode Description

Standard Mirrors the selected object. The mirrored object is on the same plane as the original 
object.

Duplicate Creates a duplicate of the selected object and then mirrors the duplicate. The 
mirrored object is on the same plane as the original object.

Mirror Across Working 
Plane (3D views only)

Mirrors the selected object to the other side of the working plane; available in 3D 
views

Standard Mirror Across Working Plane

Duplicate

http://www.youtube.com/watch?v=o2XUPAvkVcc
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4. Click to set the beginning of the axis line. As you begin to drag the mouse to create the axis line, a preview of the 
mirrored object’s placement displays. Click again to set the end of the line. For objects in walls (such as doors or 
columns), the axis line is constrained to be perpendicular to the wall. 2D objects are previewed as vectors without 
fill and 3D objects are previewed in Wireframe mode, regardless of the current render mode.
The object or its duplicate is mirrored on the opposite side of the plane created by projecting the axis line onto the 
working plane.

The end points of the mirror axis line must occupy distinct points on the active working plane. In 3D views, 
mirroring will not work if the two points are coincident on the active plane.

For objects in walls, the mirrored object is placed in the wall, if there is room for it.

Mirror axis line

Standard mode previews the item’s mirrored placement on the other side of the axis line after the first click, then 
moves it at the second click

Mirror axis line

Duplicate mode previews the mirrored duplicate item’s placement on the other side of the axis line after the first 
click, then places the new object at the second click

Mirror axis line
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~~~~~~~~~~~~~~~~~~~~~~~~~
Mirroring Objects Across the Working Plane
Mirroring Objects

Mirroring Objects Across the Working Plane

To mirror objects across the working plane:

1. Select the object(s) to mirror.
2. Hybrid objects such as walls or columns must remain perpendicular to the active layer plane. If you are mirroring 

a hybrid object, set the working plane so that it intersects the active layer plane at 90 degrees.
3. Click the Mirror tool from the Basic palette.

To select additional objects or to change the currently selected objects to mirror, press and hold the Alt key 
(Windows) or Cmd key (Mac) while shift-clicking or click-dragging the mouse around them to marquee select 
them; the Selection tool is activated in boomerang mode while the Alt or Cmd key is being pressed.

4. Select Standard or Duplicate from the Tool bar, depending on whether the original object is to remain in place.
5. Click Mirror Across Working Plane mode.

The object or its duplicate is mirrored to the opposite side of the working plane. There is no need to create an axis 
line.

~~~~~~~~~~~~~~~~~~~~~~~~~
Mirroring Objects Across an Axis
Mirroring Objects

Mirror axis line

Duplicate mode creates a mirror duplicate 
of the door inserted into the wall

The working plane is
perpendicular to the

active layer plane

Duplicate mode creates a mirror duplicate of the column across the working plane
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Converting Objects
Objects can be converted in several ways.
~~~~~~~~~~~~~~~~~~~~~~~~~
Convert to Lines
Convert Copy to Lines
Convert to Polygons
Convert Copy to Polygons
Convert to 3D Polygons
Convert to Mesh
Converting to Generic Solids

Convert to Lines
The Convert to Lines command changes a single object into the series of lines needed to create it. For example, a 
rectangle is converted into four lines.
Circles and ovals can also be converted into numerous line segments. However, especially when converting circles, the 
accuracy of the line segments depends on the 2D conversion resolution setting chosen in the Vectorworks Preferences 
dialog box.
To convert an object to lines:

1. Select the object to convert.
2. Select Modify > Convert > Convert to Lines.
3. If the object can be rendered, select the wireframe, hidden line, or dashed hidden line rendering conversion option.
4. Click OK.

The object is converted into lines and each segment can be manipulated.

Convert Copy to Lines
The Convert Copy to Lines command works like the Convert to Lines command except that it first makes a copy of 
the object and then converts the copy into line segments. The original object remains intact.
To convert a copy of an object to lines:

1. Select the object to convert.
2. Select Modify > Convert > Convert Copy to Lines.
3. If the object can be rendered, select the wireframe, hidden line, or dashed hidden line rendering conversion option.
4. Click OK.

A copy of the object is converted into lines and each segment can be manipulated.
~~~~~~~~~~~~~~~~~~~~~~~~~
Convert to Lines
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Convert to Polygons
The Convert to Polygons command changes any object with a surface into the 2D polygon or series of polygons 
needed to create it.
Circles and ovals can also be converted. However, especially when converting circles, the accuracy of the polygons 
depends on the 2D conversion resolution setting chosen in the Vectorworks Preferences dialog box.
When most closed 3D geometry is converted to 2D polygons with the hidden line rendering option, back-facing 
polygons are discarded.
To convert an object to polygons:

1. Select the object to convert.
2. Select Modify > Convert > Convert to Polygons.
3. If the object can be rendered, select either the wireframe or hidden line rendering conversion option.
4. Click OK.

The object is converted to a group of polygons. To select an individual polygon, first select Modify > Ungroup.
~~~~~~~~~~~~~~~~~~~~~~~~~
Convert to 3D Polygons

Convert Copy to Polygons
The Convert Copy to Polygons command works like the Convert to Polygons command, except that it first makes a 
copy of the object and then converts the copy into 2D polygons. The original object remains intact.
To convert a copy of an object to polygons:

1. Select the object to convert.
2. Select Modify > Convert > Convert Copy to Polygons.
3. If the object can be rendered, select either the wireframe or hidden line rendering conversion option.
4. Click OK.

A copy of the object is converted to a group of polygons. To select an individual polygon, first select Modify > 
Ungroup.

~~~~~~~~~~~~~~~~~~~~~~~~~
Convert to Polygons

Convert to 3D Polygons
The Convert to 3D Polys command converts any 2D line or surface object, including polylines, polygons, circles, 
ovals, and rectangles, into a 3D polygon. Once converted, the new polygon contains a Z dimension, assigning it a place 
in 3D space. It can be rotated and manipulated with 3D tools. The new polygon will not, however, have a thickness.
When you convert two or more objects simultaneously, the converted objects are placed in a group.
To convert a 2D object to 3D polygons:

1. Select the 2D object or objects to convert.
2. Select Modify > Convert > Convert to 3D Polys.

~~~~~~~~~~~~~~~~~~~~~~~~~
Convert to Polygons
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Convert to Mesh
The Convert to Mesh command converts any extrude, multiple extrude, sweep, or wireframe object into a mesh 
object. Use the Object Info palette to edit the mesh object vertices. The command can also collect a number of separate 
3D polygons into a single mesh object.

A mesh object can contain up to 30,000 vertices.
To convert to mesh:

1. Select the 3D object to convert.
2. Select Modify > Convert > Convert to Mesh.

The object changes to a mesh object. To edit the mesh, select Modify > Edit Group and edit the 3D polygons that 
make up the mesh.

Grouping Objects
The Group command groups two or more individual objects (including text and symbols) together. The group of 
objects is then treated as a single object. For example, grouped objects can be moved to a different layer in one move. 
In addition, this command can group two or more groups of objects into a single group.

To group objects:
1. Select the objects (or groups) to be grouped.
2. Select Modify > Group.

The objects are grouped into one object, and the group is placed in the active class.
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing a Group
Ungrouping
Returning to Top Level

Editing a Group
Use the Modify > Edit Group command to edit individual objects in a group without ungrouping them. This command 
also edits a group of objects that is nested inside another group; each time the command is selected, the program moves 
one level deeper into the group. See “Object Editing Mode” on page 1004 for details.

Returning to Top Level
Use the Top Level command when editing nested groups, to return to the main drawing area in a single step.

Individual objects Grouped objects
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Select Modify > Top Level.
The program automatically exits all groups being edited and returns to the main drawing area.

Ungrouping
The Ungroup command ungroups objects or groups that were previously combined with the Group command. Nested 
groups must be ungrouped one at a time.

To ungroup a group of objects:
1. Select the group to ungroup.
2. Select Modify > Ungroup.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the group, and select Ungroup from the object context 
menu.

3. A plug-in object will lose its plug-in functionality if it is ungrouped. Confirm that the high-level objects should be 
ungrouped.
Also, if the group has attached records, you are prompted to attach the records to the ungrouped objects. Click Yes 
to transfer the records to each ungrouped item; click No to discard the record information.
If you transfer records to multiple ungrouped objects, you will have duplicates. This may be a problem if the 
original grouped object was being tracked on a worksheet, for example.

Aligning and Distributing Objects

Aligning and Distributing Objects in the Screen Plane
The Align/Distribute command aligns and distributes multiple objects in the screen plane. Alignment and distribution 
is based upon the vertical and horizontal axes, relative to the screen.
To align/distribute objects:

1. Select the objects to be aligned/distributed.
2. Select Modify > Align > Align/Distribute. The Align/Distribute Objects dialog box opens.

Alternatively, Right-click (Windows) or Ctrl-click (Mac) on one of the selected objects and select Align/
Distribute from the context menu. The most common align and distribute commands display on a flyout context 
menu. Select the desired command, or select Align/Distribute to open the Align/Distribute Objects dialog box.

Ungrouped objectsGrouped objects
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3. Select the object alignment/distribution criteria. Objects are only moved along the horizontal and vertical axes.
Click to show/hide the parameters.

 

4. Click OK. 
The program aligns/distributes the selected objects.

Loci and locked objects are special objects and behave differently when present during an alignment/distribution 
operation.
If a locus point is one of the selected objects, all objects are aligned relative to that locus. If there are multiple loci in the 
selection, then the loci are aligned/distributed like any other object.
Locked objects in a selection do not move. Other objects are aligned/distributed relative to the locked objects.

Parameter Description

Align Select to align items along the horizontal or vertical axis
Distribute Select to distribute items along the horizontal or vertical axis
Horizontal

Left Align/distribute by the left side of the selected objects
Center Align/distribute by the centers of the selected objects
Right Align/distribute by the right side of the selected objects
Spacing Distribute the spacing equally between the left and right sides of adjacent objects

Vertical
Top Align/distribute by the top of the selected objects
Center Align/distribute by the centers of the selected objects
Bottom Align/distribute by the bottom of the selected objects
Spacing Distribute the spacing equally between tops and bottoms of adjacent objects

Vertical Align/Distribute

Horizontal Align/Distribute
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~~~~~~~~~~~~~~~~~~~~~~~~~
Aligning and Distributing Objects in 3D
Aligning Objects to Grid
Aligning and Distributing Leader Lines

Aligning and Distributing Objects in 3D
Objects can be aligned and/or distributed in relation to each other in 3D space. 3D object alignment/distribution is 
based on either the ground or working plane.
The Align/Distribute 3D command aligns and distributes multiple objects. Alignment and distribution is based upon 
the X, Y, and Z axes of the active layer plane or the X’, Y’, and Z’ axes of the working plane.
Keep in mind the following points about this command:

• 3D loci and locked objects are special objects and behave differently when present during an alignment/
distribution operation.

• If a 3D locus point is one of the selected objects, all objects are aligned relative to that locus. If there are multiple 
loci in the selection, then the loci are aligned/distributed like any other object.

• Locked objects in a selection do not move. Other objects are aligned/distributed relative to the locked objects.
• 2D screen objects are ignored by the Align/Distribute 3D command.

To align/distribute objects in 3D:
1. Select the objects to be aligned/distributed.
2. Select Modify > Align > Align/Distribute 3D.

The 3D Object Align and Distribute dialog box opens. Select the alignment/distribution criteria.
Click to show/hide the parameters.

3. Click OK. 
The program aligns/distributes the selected objects.

~~~~~~~~~~~~~~~~~~~~~~~~~
Aligning and Distributing Objects in the Screen Plane
Aligning Objects to Grid

Parameter Description

Alignment/
Distribution Axes

Select whether to align/distribute about the active layer plane or the working plane

Align/Distribute Select Align and specify the coordinate value to use when aligning objects, or select Distribute 
to distribute objects

Minimum Align/distribute objects along the specified axis by the minimum coordinate value of each 
object

Center Align/distribute objects along the specified axis by the center coordinate value of each object
Maximum Align/distribute objects along the specified axis by the maximum coordinate value of each 

object
Spacing Distribute spacing between objects along the specified axis, ensuring that the space between the 

objects is equal along the axis
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Aligning Objects to Grid
The Align to Grid command aligns objects to the snap grid, placing the upper-left corner of each object at its closest 
grid point. The Align to Grid command can be used to realign objects to the snap grid when the grid’s settings have 
changed. It also aligns objects to the grid if they were either created with Snap to Grid snapping turned off or were 
moved off the grid after they were created.
To align an object to a grid:

1. Select the object or objects to align.
2. Select Modify > Align > Align to Grid.

The program aligns the object(s), placing the upper-left corner of each object at its closest grid point.
~~~~~~~~~~~~~~~~~~~~~~~~~
Aligning and Distributing Objects
Aligning and Distributing Leader Lines
Snap and Reference Grids

Aligning and Distributing Leader Lines
Many Vectorworks objects include tags with leader lines that point to specific items in a drawing. For drawings that 
have several such objects, you can align the leader lines to improve readability. The Align/Distribute Leader Lines 
command works on the following objects:

Vectorworks Fundamentals objects
• Callouts
Vectorworks Design Series objects
• Detail bubbles
• Elevation benchmarks
• Existing trees
• Hardscapes
• Landscape areas
• Leader lines
• Plants
• Redlines
• Stakes

To align leader lines:
1. Select the objects whose leader lines you want to align and/or distribute.
2. Select Modify > Align > Align/Distribute Leader Lines.

• If none of the selected objects can be processed by the command, a message displays, and the command is 
canceled.

• If one or more of the selected objects cannot be processed, a different message displays; you can either 
continue to align the remaining objects, or cancel the command from the dialog box that displays next.

3. The Align Leader Lines dialog box displays.
Click to show/hide the parameters.

Parameter Description

Horizontal Alignment
Align shoulder points Select to align the shoulder points of the selected leader lines
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4. Select the desired alignment options and click OK.
5. If one of the horizontal alignment options was selected, click and drag to draw a reference line along which to 

align the selected shoulder or label points; the line must not be horizontal. Click again to complete the reference 
line.

6. The objects are aligned as specified.

Align label points Select to align the label points of the selected leader lines. If this option is used in 
conjunction with Align shoulder points, all of the selected label points are also 
aligned to the label point of the topmost leader line.

Move shoulder points If Align shoulder points is not selected, and Align label points is selected, select this 
option to move both the label and shoulder points, keeping the current distance 
between those points for each line. Deselect this option to move only the label points, 
keeping the current shoulder point positions.

This setting does not apply to elevation benchmarks without an offset.
Vertical Distribution

None Select to leave the selected leader lines in the same vertical position when they are 
aligned horizontally

Parallel objective lines Select to move the shoulder points vertically, so that the target lines of all selected 
objects are parallel to the line of the topmost object. This option can be used with or 
without a horizontal alignment option.

This setting does not apply to elevation benchmarks.
Equal distance between 
shoulder lines

Select to move the shoulder points vertically, so that the vertical distance between the 
shoulder lines of all selected objects is equal to the distance between the lines of the 
two topmost objects. This option can be used with or without a horizontal alignment 
option.

Offsets may be added to elevation benchmarks or adjusted as needed.

Parameter Description

Label point

Shoulder point

Target point

Target line

Shoulder line
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~~~~~~~~~~~~~~~~~~~~~~~~~
Aligning and Distributing Objects in the Screen Plane
Aligning and Distributing Objects in 3D
Aligning Objects to Grid

Unaligned plant labels

Labels aligned with Align shoulder points (along 
red reference line), with Parallel target lines

Labels aligned with Align shoulder points (along red 
reference line), with Equal distance between shoulder lines

Labels aligned with Align shoulder points (along red 
reference line), with no vertical distribution

Labels aligned with Align label points (along red 
reference line), but no Move shoulder points

Labels aligned with Align label points (along red 
reference line), and Move shoulder points
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Extruding Objects

Single Extrude
The Extrude command changes 2D objects into 3D objects with a height. The type of object and its attributes 
determines the type of extrude that is produced. Lines are extruded as flat planes, while all other objects are extruded as 
wireframe 3D objects. While more than one object can be extruded at a time, grouped objects must first be ungrouped 
in order to be extruded. Objects that are locked must first be unlocked in order to be extruded.
Objects are extruded into the current viewing projection, so the extrusion direction is dependent on the current view. 
They can be rotated afterwards if desired. See “Rotate Tool” on page 1022 or “Preset Rotation Angles” on page 1024. 
The extruded object height can be edited interactively with the Reshape tool; see “Reshaping Extruded Objects and 
Solid Primitives” on page 1052 for more information.

When you extrude multiple objects at the same time, they are turned into a single 3D group of objects. To edit an 
individual object, either ungroup the set or use the Edit Extrude command to access the individual objects.
The Push/Pull tool can also be used to create extruded objects from planar objects; see “Direct Modeling with the 
Push/Pull Tool” on page 357.

To extrude an object:
1. Select the 2D object(s) to extrude.
2. Select Model > Extrude.

The Create Extrude dialog box opens.
3. Enter the Extrusion height and specify any change in size along the X and Y axes, and then click OK. 

~~~~~~~~~~~~~~~~~~~~~~~~~
Multiple Extrude
Extrude Along Path
Creating a Tapered Extrude
Face-based Addition or Subtraction

Multiple Extrude
A pyramid, sphere, or other 3D object can be created from a series of 2D objects using the Multiple Extrude 
command. Include a 2D locus, or several loci, in the selection to provide an extrusion reference point or points.

The process matches segments on each object to create the extrude. The segment order may be reversed for one or 
more of the objects, producing unexpected results (such as a twisted extrusion). If this occurs, convert the objects 
to open polygons prior to selecting the Multiple Extrude command.

To create a multiple extrude:
1. Select the 2D objects to extrude.
2. Select Model > Multiple Extrude.

The Create Extrude dialog box opens.
3. Enter the Extrusion height and specify the change in size along the X and Y axes. 
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4. Click OK. 
The program extrudes the set of objects/locus points by connecting one to another in their stacking order, turning 
the objects into a single 3D object.

~~~~~~~~~~~~~~~~~~~~~~~~~
Single Extrude
Extrude Along Path
Creating a Tapered Extrude

Extrude Along Path
The Extrude Along Path command extrudes profile objects along a given path. Profile objects can be 2D objects, 3D 
polygons, and NURBS curves. Profile objects cannot be non-planar, self-intersecting, or a mixture of 2D and 3D 
profiles. If the path is not a NURBS curve, it is converted into a NURBS curve during this operation. 

When you use the Edit Extrude Along Path command on a 3D object created using the Extrude Along Path 
command, a dialog box opens with the choice to either edit the original path or profile object.

To extrude along a path:
1. Select the object to be extruded, and the object to use as the path.

2. Select Model > Extrude Along Path.
The Extrude Along Path dialog box opens. Specify the extrusion parameters.

Click to show/hide the parameters.

Parameter Description

Select a path object Click the Next or Prev button to select the object that represents the path

2D locus
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Scaling options are available when the path object is a single continuous curve without sharp corners or 
discontinuities.

3. Click OK to extrude the object along the selected path.

4. The type of Scale, Shape/Scale Factor, Lock Profile Plane, and Fix Profile status of an extrude along path 
object can be edited in the Object Info palette.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Single Extrude
Multiple Extrude
Creating a Tapered Extrude

Creating a Tapered Extrude
A tapered extrude can be created from 2D objects, 3D polygons, and NURBS curves, circles, and arcs. (2D objects 
cannot be screen plane objects; change them to planar objects first. See “Planar Modes of 2D Objects: Screen Plane and 
Layer Plane” on page 152.)
This command easily creates wavy extrusions by entering a taper value of zero.The command also extrudes 2D objects 
into 3D objects with a defined taper. Use it to convert a single object or several objects at the same time. Once created, 
the height and taper can be edited in the Object Info palette.
The tapered extrude object height can be edited interactively with the Reshape tool; see “Reshaping Extruded Objects 
and Solid Primitives” on page 1052 for more information.
To create a tapered extrude:

1. Select the object(s) to turn into a tapered extrude.
2. Select Model > Tapered Extrude.

The Create Tapered Extrude dialog box opens.

Uniform Scale Scales the object linearly along the designated path; enter a Scale Factor of 1 to perform no 
scaling, or enter a positive scale factor other than 1 for uniform scaling

Exponential Scale Scales the object exponentially along the designated path; enter a Shape Factor of 0 to 
perform no scaling, or enter a shape factor other than 0 for exponential scaling

Lock Profile Plane Locks the orientation of the profile plane to the global Z axis, constraining the extrusion to be 
perpendicular to the XY plane

Fix Profile Maintains the original relative position and orientation of the profile object with respect to the 
path. Normally, this should be deselected, so that the profile is moved and rotated with respect 
to the path.

Parameter Description

Uniform scaling Exponential scaling
No scaling (scale 

factor 1)

http://www.youtube.com/watch?v=tCDaVyN3sY4
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3. Enter the Height (Z) of the extrude and the Taper Angle. A positive taper degree shrinks the object as it extrudes, 
while a negative taper degree widens the object.
Set a Taper Angle of 0 to create an extrusion with no taper.

4. Click OK to create the tapered extrude.

If a tapered extrude fails, the object reverts to the last known “good” value.
~~~~~~~~~~~~~~~~~~~~~~~~~
Single Extrude
Multiple Extrude
Extrude Along Path
Face-based Addition or Subtraction

Sweeping Objects
The Sweep command converts 2D objects into 3D cylindrical objects. Use it to convert a single object at a time, or to 
convert several selected objects. While more than one object can be swept at a time, grouped objects must first be 
ungrouped. Locked objects must first be unlocked in order to create a sweep.
A sweep has four basic elements: a centroid (locus), an arc angle, a segment angle, and a pitch. The locus acts as the 
sweep’s center of rotation. If a locus is not selected, the program sweeps the object around its left edge or point farthest 
on the left if more than one object is selected. A locus can be relocated or added after creation using the Edit Sweep 
command. The other three elements (arc angle, segment angle, pitch) can be edited after the sweep has been created 
through the Object Info palette.

If more than one object is selected when creating a sweep, the objects are automatically grouped. To edit an object 
within the sweep, use the Edit Sweep command.

To create a sweep:
1. Select the 2D object(s) to sweep and, if created, the locus.
2. Select Model > Sweep.

The Create Sweep dialog box opens. Enter the sweep criteria and click OK.
Click to show/hide the parameters.

 

Parameter Description

Size
Height Indicates the sweep height
Radius Indicates the sweep radius

Angles

NURBS curve extruded with zero Taper Angle
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Reshaping Objects
The Reshape tool reshapes an object after it has been created, by moving, removing, changing, or adding to its 
vertices. Change the length of objects (including dimensions), reshape single objects, or reshape multiple objects at 
once. Reshape polygons and polylines, including lines drawn with the Freehand tool (which are considered polylines). 
In addition, specify exact radius measurements for circular arc control points. The Reshape tool can also be used to 
reshape 3D solids, walls, roofs, NURBS curves and surfaces, and other objects.
The modes and functionality available for the Reshape tool depend on the currently selected object or objects, and the 
current view.

Click here for a video tip on this topic (Internet connection required).
~~~~~~~~~~~~~~~~~~~~~~~~~
2D Reshape Modes
3D Reshape Modes
Marquee Modes
Performing Multiple Reshapes
Converting Polyline Vertices from Arc to Radius

Start Angle Specifies the angle to begin the sweep; normally start at 0
Arc Angle Specifies the degree of the sweep. By default, objects are swept a full 360º.
Segment 
Angle

Indicates the number of segments that make up the sweep. The default is 36 segments, each one 
10º from the next on the arc. The angle setting must be a positive number. A large number of 
segments can slow down performance.

Pitch Sets the degree to which the sweep spirals. A sweep’s pitch is represented in the plus- or 
minus-height per revolution. For example, if the pitch is 1”, every revolution raises the object a 
single inch. The default is 0. 

Functionality Enabled Selection or View

2D reshape 2D planar or screen object(s), in any view
2D reshape Multiple objects selected, in any view, or a reshape marquee exists
3D reshape Single 3D polygon, 3D solid, NURBS curve, NURBS surface, section line (Vectorworks 

Design Series required), in any view
3D reshape Single wall, roof object, plug-in object with custom reshape behavior (such as the 

retaining wall site modifier, Vectorworks Design Series required), in a 3D view
2D reshape Wall, roof object, plug-in object in Top/Plan view
Marquee No selection

Parameter Description

Place locus to act as sweep 
centroid; select both

Object swept, rotated, and rendered

Create object

Locus point selected

http://www.youtube.com/watch?v=ZbJ2fNv9o5I
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2D Reshape Modes
The Reshape tool has six reshape modes when 2D functionality is enabled. It also has five control point modes for 
changing the existing vertex. In addition, the tool can operate in three marquee selection modes.

Mode Description

Move Polygon Handles Changes a shape by clicking and moving a vertex or midpoint handle
Move Edges Parallel Moves an edge parallel to its original position without changing the adjacent angles
Change Vertex Changes an existing vertex into a corner, Bézier, cubic, radius, or arc vertex
Add Vertex Adds a vertex as a corner, Bézier, cubic, radius, or arc vertex
Delete Vertex Removes the selected vertex
Hide or Show Edges Clicking on the midpoint hides the polyline or polygon segment; clicking on a vertex 

hides the segment that follows the vertex
Corner Point In Change Vertex mode, changes the vertex to a corner vertex; in Add Vertex mode, adds 

a corner vertex
Bézier Control Point In Change Vertex mode, changes the vertex to a Bézier vertex; in Add Vertex mode, adds 

a Bézier vertex
Cubic Spline Point In Change Vertex mode, changes the vertex to a cubic vertex; in Add Vertex mode, adds 

a cubic vertex
Radius (Point on Arc) 
Point

In Change Vertex mode, changes the vertex to a radius vertex; in Add Vertex mode, adds 
a radius vertex

Fillet (Circular Arc) 
Point

In Change Vertex mode, changes the vertex to an arc vertex; in Add Vertex mode, adds 
an arc vertex. Click Preferences from the Tool bar, enter a Fillet Radius in the Fillet 
Settings dialog box, and click OK (for the largest possible fillet, set the Fillet Radius to 
zero).

Rectangular Marquee Creates a rectangular marquee box around several vertices. Click to set the start point, 
drag the mouse in the desired direction, and release to set the end point. All vertices 
within the marquee are selected for performing a subsequent reshape operation.

Lasso Marquee Creates a free-form marquee around several vertices, allowing a more exact selection of 
vertices of irregular 2D shapes. Click to set the start point, drag the mouse in the desired 
direction, and release to set the end point. All vertices within the marquee are selected for 
performing a subsequent reshape operation.

Polygonal Marquee Creates a marquee with an irregular polygonal shape around several vertices. Click to set 
the start point, and then continue clicking to define the shape. Double-click to finish the 
marquee. All vertices within the marquee are selected for performing a subsequent 
reshape operation.

Move Edges 
Parallel

Delete 
Vertex

Hide or 
Show 
Edges

Add 
Vertex

Change 
Vertex

Cubic 
Spline 
Point

Corner 
Point

Bézier 
Control 
Point

Radius (Point 
on Arc) Point

Rectangular 
Marquee

PreferencesLasso 
Marquee

Polygonal 
Marquee

Fillet 
(Circular 
Arc) Point

Move Polygon 
Handles
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In addition to clicking the Reshape tool from the Basic palette, there are other ways to reshape 2D objects.
• Double-clicking eligible 2D objects (polylines, polygons, rectangles, rounded rectangles, and ovals) with the 

Selection tool automatically activates the Reshape tool. 
• 2D objects and symbols can be resized with the Single Object Interactive Scaling mode of the Selection tool; see 

“The Selection Tool” on page 109. 
• Certain objects (polylines, polygons, rectangles, rounded rectangles, circles, ovals, and arcs) can also be reshaped 

with the Freehand tool. See “Reshaping Objects with the Freehand Tool” on page 301.
Additional editing modes are available for certain other objects, such as a site model (Vectorworks Design Series 
required). Those specific modes are described in sections about editing or reshaping the object.

Functionality similar to the Reshape tool is available from the Object Info palette Shape tab; see “Editing 
Vertex-Based Objects” on page 1002.
~~~~~~~~~~~~~~~~~~~~~~~~~
Move Polygon Handles Mode
Move Edges Parallel Mode
Change Vertex Mode
Add Vertex Mode
Delete Vertex Mode
Hide or Show Edges Mode
Performing Multiple Reshapes
The Selection Tool
Smoothing Objects

Move Polygon Handles Mode
Select this mode to reshape a 2D rectangle, rounded rectangle, oval, polyline, polygon, or path object by moving one of 
its vertices or midpoint handles.

To reshape a 2D object by moving a vertex or midpoint handle:

1. Select the 2D shape to change.
2. Click the Reshape tool from the Basic palette.
3. Click the Move Polygon Handles mode from the Tool bar.
4. Click the vertex or handle to move. When the Reshape cursor displays, move the mouse to the new location.
5. Click to place the vertex/handle.

 

If an object cannot be reshaped with this tool, its handles do not display. 

Bézier
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~~~~~~~~~~~~~~~~~~~~~~~~~
Performing Multiple Reshapes
Reshaping Objects
Editing Vertex-Based Objects

Move Edges Parallel Mode
Select this mode to reshape a 2D rectangle, rounded rectangle, oval, polyline, polygon, or path object by moving edges 
without changing the adjacent angles.

To reshape a 2D object by moving edges:

1. Select the 2D shape to change.
2. Click the Reshape tool from the Basic palette. 
3. Click the Move Edges Parallel mode from the Tool bar.

Reshape handles appear at the midpoint of each editable edge and on each editable corner vertex. Only straight 
edges with straight adjacent segments can be reshaped with this mode; if an object or segment of an object cannot 
be reshaped, its handles do not display.

4. Click the reshape handle to move. When the Reshape cursor displays, move the mouse to the new location.
To offset the edges adjacent to the corner vertex by the same distance, hold the Option key (Mac) or Alt key 
(Windows) when moving the vertex. 

5. Click to place the edge/vertex.

Move Edges Parallel mode also reshapes open polygons; if the length of an open edge becomes zero, the extra 
vertices are removed and the shape becomes a closed polygon.

~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Objects
Editing Vertex-Based Objects

The moving edge changes 
length to maintain the 
adjacent angles

If the edge is moved beyond the 
angles’ intersection point, a 
self-intersecting polygon is created

Moving a midpoint handle

The new shape previewsThe edge to move 
and adjacent edges 
are highlighted

The two adjacent 
edges on each side 
of the vertex are 
highlighted

The new shape previews The edges adjacent 
to the vertex move 
parallel; the next 
edges extend to 
maintain the angle 
between the edges

If two or more 
vertices become 
coincident, the extra 
vertices are removed

Moving a corner vertex 
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Change Vertex Mode
Select this mode to change an existing vertex to a different type of control point: corner, Bézier, cubic, radius, or fillet 
(circular arc) point.

To reshape a 2D polyline or polygon by changing a vertex:

1. Select the polyline or polygon to change.
2. Click the Reshape tool from the Basic palette.
3. Click the Change Vertex mode from the Tool bar.
4. From the Tool bar, select the new type of control point for the vertex.

Change vertex does not work on a midpoint handle. Select only a vertex point.
5. Click on a vertex to change it to the new type.

~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Objects
Converting Polyline Vertices from Arc to Radius
Editing Vertex-Based Objects

Add Vertex Mode
Select this mode to add a vertex to the polygon/polyline. The vertex can be any of the following: corner, Bézier, cubic, 
radius, or fillet (circular arc).

To reshape a 2D polyline or polygon by adding a vertex:

1. Select the polyline or polygon to change.
2. Click the Reshape tool from the Basic palette.
3. Click the Add Vertex mode from the Tool bar.
4. From the Tool bar, select the type of control point for the new vertex.
5. Move the cursor to an existing vertex near the location where the new vertex is to be added. The cursor becomes 

an arrow with two black diamonds when a vertex can be added.
Clicking on the handle at a center point along an edge adds a new vertex exactly at that center point.

6. Drag the cursor to the desired location for the new vertex.
7. Click at the new location.

Click on the vertex when the Change Vertex cursor displays
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~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Objects
Editing Vertex-Based Objects

Delete Vertex Mode
An existing vertex on the polygon/polyline can be deleted.

To reshape a 2D polyline or polygon by deleting a vertex:

1. Select the polyline or polygon to change.
2. Click the Reshape tool from the Basic palette.
3. Click the Delete Vertex mode from the Tool bar.
4. Click on an existing vertex to delete it.

~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Objects
Editing Vertex-Based Objects

Hide or Show Edges Mode
Select this mode to hide, but not delete, a portion of the object’s boundary.

To hide or show the edge of a 2D polyline or polygon:

1. Select the polyline or polygon to change.
2. Click the Reshape tool from the Basic palette.
3. Click the Hide or Show Edges mode from the Tool bar.
4. Click a vertex near the edge to be hidden.

With the Add Vertex cursor, click-drag to the new location

With the Delete Vertex cursor, click the vertex to remove it
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Click again to show the hidden edge.
~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Objects
Editing Vertex-Based Objects

3D Reshape Modes
The Reshape tool changes the height and radius of an extruded object, tapered extrude, or a 3D object that is not a 
mesh object. In addition, use it to reshape walls (see “Editing Walls” on page 535), 3D polygons, and solid primitives 
(such as cylinders, hemispheres, cones, and spheres), reshape retaining walls (Vectorworks Design Series required), 
change the angle (rise/run) of roofs created with the Roof Face command, and reshape roof objects created with the 
Create Roof command (see “Reshaping Roof Objects” on page 576).
The Reshape tool generally has three modes when 3D functionality is enabled. Depending on the selected object, 
additional modes are available, as described in the associated sections. 

For some objects, such as 3D solids, the reshaping functionality is accessed directly from the drawing, and the 
marquee modes display in the tool bar.

~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Extruded Objects and Solid Primitives
Reshaping 3D Polygons
Reshaping NURBS Curves
Reshaping NURBS Surfaces
Reshaping Walls
Reshaping Roof Objects

Marquee Modes
When no objects are selected, the Reshape tool has three marquee modes to draw a planar marquee in any view.

Mode Description

Move Vertex Changes the location of a selected vertex or several vertices
Add Vertex Adds a vertex to the object
Delete Vertex Deletes a vertex from the object

With the Hide/Show Edges cursor, click a vertex near an edge to show or hide the edge

Move Vertex

Add Vertex

Delete Vertex
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Click-drag in the drawing to begin drawing a marquee around vertices for reshaping; the currently active marquee 
mode determines the marquee type that will be drawn. Regardless of what marquee mode is currently active, you can 
alternatively press and hold the Alt (Windows) or Option (Mac) key to draw a lasso marquee or press and hold 
Shift+Alt (Windows) or Shift+Option (Mac) to draw a polygonal marquee. 
As soon as a reshape marquee exists and an object is selected, the available modes switch to the 2D reshape modes, and 
2D reshape functionality is enabled (see “2D Reshape Modes” on page 1044). This allows 2D reshape behavior to be 
performed, even on a 3D object and in a 3D view, when the vertex is enclosed in the reshape marquee. For example, 
wall length can be changed with the Reshape tool in a 3D view, if the wall end vertex is enclosed within a reshape 
marquee that is co-planar with the bottom elevation of the wall.
3D objects can be moved if fully inside the marquee and in Top or Top/Plan view.
While using any marquee selection mode, if the vertices to be selected are surrounded by a filled object, first select the 
object(s) using the Selection tool. Press and hold the Shift key while drawing the marquee around the vertices; the 
currently active marquee mode determines the marquee type that will be drawn. The desired vertices are selected 
without the boundary object being selected.
Perform the desired reshape operation on the selected vertices.
~~~~~~~~~~~~~~~~~~~~~~~~~
Performing Multiple Reshapes
The Selection Tool

Performing Multiple Reshapes
Instead of individually reshaping the vertices of objects, one at a time, several vertices and even several objects can be 
reshaped at one time. In addition, vertices and holes can be deleted from objects. Multiple reshaping can be performed 
on lines, polylines, walls, dimensions, and polygons. Polygons include all regular and irregular polygons, as well as 
objects drawn with the Freehand tool. For example, use this function to resize walls without moving any of the doors 
or windows placed inside them, or affecting intersections with other walls.
2D planar objects must be co-planar and in the active plane to be reshaped; the selection marquee is drawn in the active 
plane. Multiple 3D objects cannot be reshaped at one time, but must be selected individually.
This function does not work on objects drawn with the Circle, Oval, or Arc tools.

Mode Description

Rectangular Marquee Creates a rectangular marquee box around several vertices. Click to set the start point, 
drag the mouse in the desired direction, and release to set the end point. All vertices 
within the marquee are selected for performing a subsequent reshape operation.

Lasso Marquee Creates a free-form marquee around several vertices, allowing a more exact selection of 
vertices of irregular 2D shapes. Click to set the start point, drag the mouse in the desired 
direction, and release to set the end point. All vertices within the marquee are selected for 
performing a subsequent reshape operation.

Polygonal Marquee Creates a marquee with an irregular polygonal shape around several vertices. Click to set 
the start point, and then continue clicking to define the shape. Double-click to finish the 
marquee. All vertices within the marquee are selected for performing a subsequent 
reshape operation.

Rectangular
Marquee

Lasso Marquee

Polygonal 
Marquee
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To resize objects with multiple reshape:

1. Select the objects to reshape.
2. Click the Reshape tool from the Basic palette, and select Move Polygon Handles from the Tool bar.

The cursor changes to a cross-hair.
3. Click and drag to create a rectangular marquee around multiple vertices of the objects to be resized or deleted.

To create a lasso marquee, press the Option (Mac) or Alt (Windows) key when creating the marquee. Press the 
Command and Option (Mac) or Ctrl and Alt (Windows) keys for polygonal marquee selection mode.

4. Change the location of the vertices by either clicking and dragging with the mouse or by using the Move 
command (see “Editing Object Surfaces” on page 1080). Alternatively, nudge the selected vertices by pressing the 
Shift and arrow keys.
To use the mouse, click-drag on the vertices and move them to the desired location. A preview displays the current 
and future location of the object vertices.

Press the Delete key (Mac) or Delete or Backspace keys (Windows) to delete the vertices or holes.
Alternatively, enter an exact length in the Data bar. Press the Tab key while still pressing the mouse button until 
the L field is highlighted, enter a value for the length, and release the mouse button.
Walls are resized with the wall intersections, doors, or other symbols maintained in place. The marquee remains 
visible until another tool or command is selected.

~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Objects
Converting Polyline Vertices from Arc to Radius
Reshaping Polylines

Converting Polyline Vertices from Arc to Radius
As of Vectorworks version 2012, a new type of polyline vertex, the radius vertex, simplifies the reshaping of polylines. 
Polylines from older versions may include arc vertices, which are harder to edit. Each vertex of a polyline can be 
changed to radius type with the Change Vertex mode of the Reshape tool, or by editing the vertex type in the Object 
Info palette. However, this is tedious if the object includes several arc vertices. The Convert Arc to Radius Polyline 
command is available to convert all of the arc vertices to radius vertices. Objects like hardscapes or slabs (Vectorworks 
Design Series required), which are based on path polylines, can benefit by converting their path polyline to contain 
radius vertices, because they become easier to reshape.
To convert arc vertices to radius vertices:

1. Select the polyline; for path-based objects, double-click on the object or select Modify > Edit [Object] to access 
the path in editing mode. See “Object Editing Mode” on page 1004.

2. Right-click (Windows) or Ctrl-click (Mac) on a polyline which contains at least one arc vertex, and select 
Convert Arc to Radius Polyline from the context menu.

3. The arc vertices of the polyline or path object are converted to radius vertices.

Create marquee to select multiple vertices, and then drag selected vertices to new location
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~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Objects
Editing Vertex-Based Objects
Reshaping Polylines
Change Vertex Mode
Smoothing Objects

Reshaping Polylines
Polylines can be reshaped in a manner that is similar to an Edit Group operation. The polyline itself is locked in this 
process, but holes can be added to it, filleted, chamfered, offset, duplicated, extracted, and deleted from it.
To reshape a polyline:

1. Select the polyline to change.
2. Select Modify > Edit Polyline.
3. Select polyline holes and move, delete, or reshape them. Add new holes to the polyline, or move a hole out of the 

polyline to extract it, creating individual polylines. 
The original polyline is locked and cannot be edited.

4. Click Exit Polyline to return to the drawing.

~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Objects
Editing Vertex-Based Objects
Smoothing Objects
Converting Polyline Vertices from Arc to Radius

Reshaping Extruded Objects and Solid Primitives
The Reshape tool changes the height, and when applicable, the radius of extrudes, cylinders, spheres, hemispheres, and 
cones, and the height and angle of tapered extrudes.

Radius vertices are easier to edit 
with the Reshape tool

Original polyline In Edit Polyline mode, a hole is added The polyline has been edited
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To reshape an extrude, cylinder, sphere, hemisphere, cone, or tapered extrude:

1. Select the object to reshape.
2. Click the Reshape tool from the Basic palette.

A resize handle is added to both top and bottom of an extruded object. Multiple resize handles are added around 
cylinder, sphere, hemisphere, and cone objects. For a tapered extrude object, one resize handle is added to its top 
for changing its height, and one to the side for changing its taper angle.
Tapered extrudes with a taper angle of zero have an additional resize angle at the bottom.

3. Click and drag the resize handle to change the object’s height, radius, or taper angle.
When the cursor is over a radius resize handle, the standard arrow cursor changes into a double-headed arrow. It 
changes to an unfilled double-headed arrow over a height resize handle.

4. Click again when the object is at the desired height, radius, or angle.
Alternatively, press the Tab key and enter a numeric value for the height, radius, or angle in the Data bar.

Alternatively, use the Push/Pull tool for these operations. Changing the top or bottom face of an extrude does not 
change the object type; it remains an extrude.

~~~~~~~~~~~~~~~~~~~~~~~~~
Reshaping Objects
Direct Modeling with the Push/Pull Tool

Reshaping 3D Polygons
The Reshape tool, located in the Basic palette, can manipulate and reshape 3D polygons.

To reshape 3D polygons:

1. Select the 3D polygon to reshape. Only one 3D polygon can be selected for reshaping at a time.
2. Click the Reshape tool from the Basic palette.

Select the mode from the Tool bar.

Mode Description

Move Vertex Changes the location of a selected vertex or several vertices
Add Vertex Adds a vertex to the object

Change the angle of a tapered 
extrude by dragging the side resize 
handle to the desired angle

Change the radius of a cylinder, sphere, 
hemisphere, or cone by dragging the resize 
handle to the desired radius

 With the Reshape cursor, drag the resize handle 
up (or down) to the desired extrude height

Move Vertex

Add Vertex

Delete Vertex
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3. Select a vertex. When the cursor is over a vertex, the standard arrow cursor changes to an unfilled, four-way 
arrow.

4. Reshape the 3D polygon.
• In Move Vertex mode, click-drag the mouse to move the vertex or vertices. The selected constraint mode restricts 

the movement to the working plane or to one of the axes. Release the mouse at the desired location. 
Alternatively, enter the exact coordinates in the Data bar. Press the Tab key, enter the coordinates, and then press 
Enter.

• To add a vertex in Add Vertex mode, move the cursor to an existing vertex near the location where the new vertex 
is to be added. The cursor becomes an arrow with two black diamonds when a vertex can be added. Drag the 
cursor to the desired location for the new vertex. Click at the new location.

• To delete a vertex in Delete Vertex mode, click on the vertex to delete.
Functionality similar to the Reshape tool is available from the Object Info palette Shape tab; see “Editing 
Vertex-Based Objects” on page 1002.

Reshaping NURBS Curves
The Reshape tool, located in the Basic palette, can manipulate and reshape NURBS curves.

To reshape NURBS curves:

1. Select the NURBS curve to reshape. To reshape multiple vertices, the curve must be a single, smooth continuous 
NURBS curve.

2. Click the Reshape tool from the Basic palette.
Select the mode from the Tool bar.

Delete Vertex Deletes a vertex from the object

Mode Description

Move Vertex Changes the location of a vertex or several vertices
Add Vertex Adds a vertex to the NURBS curve
Delete Vertex Deletes a vertex from the NURBS curve
Change Vertex Toggles an existing vertex between a corner vertex and smooth vertex

Mode Description

Z-axis ConstrainMove Vertex

Delete Vertex

Change Vertex

Working Plane 
Constrain

X-axis Constrain

Y-axis Constrain

Add Vertex
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3. Select a vertex. When the cursor is over a vertex, the standard arrow cursor changes to an unfilled, four-way 
arrow.
Alternatively, to select several vertices at one time in Move Vertex mode, click with the Shift key pressed or click 
and drag to create a marquee around the desired vertices. Position the cursor over one of the vertices.

4. Reshape the NURBS curve.
• In Move Vertex mode, click-drag the mouse to move the vertex or vertices. The selected constraint mode restricts 

the movement to the working plane or to one of the axes. Release the mouse at the desired location. 
Alternatively, enter the exact coordinates in the Data bar. Press the Tab key, enter the coordinates, and then press 
Enter.

• To add a vertex in Add Vertex mode, move the cursor to an existing vertex near the location where the new vertex 
is to be added. The cursor becomes an arrow with two black diamonds when a vertex can be added. Drag the 
cursor to the desired location for the new vertex. Click at the new location.

• To delete a vertex in Delete Vertex mode, click on the vertex to delete.
• Toggle the vertex between a corner vertex and a smooth vertex by clicking on the vertex in Change Vertex mode.

Functionality similar to the Reshape tool is available from the Object Info palette Shape tab; see “Editing 
Vertex-Based Objects” on page 1002.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating NURBS Curves
Reshaping Objects

Reshaping NURBS Surfaces
The Reshape tool, located in the Basic palette, can manipulate NURBS surface control points and to reshape NURBS 
surfaces. For example, a dome or bell-curve effect can be created by manipulating the vertices.

This tool can potentially create surfaces which cannot be further manipulated in the 3D Power Pack. See “Surface 
Geometry Requirements” on page 327.

To reshape a NURBS surface:

1. Select the NURBS surface to reshape.
2. Click the Reshape tool from the Basic palette.

Select the mode from the Tool bar.

Working Plane 
Constrain

Moves the selected vertex or vertices on a working plane

X-axis constrain Moves the selected vertex or vertices along the X axis
Y-axis constrain Moves the selected vertex or vertices along the Y axis
Z-axis constrain Moves the selected vertex or vertices along the Z axis

Mode Description
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To select one vertex or row of vertices, position the cursor over one of the NURBS surface vertices. When the 
cursor is over a vertex, the standard arrow cursor changes to an unfilled, four-way arrow.

To select several vertices at one time, click with the Shift key pressed or click and drag to create a marquee around 
the desired vertices.
If several vertices are selected, position the cursor over one of them.

3. Click-drag the mouse to move the vertex or vertices.
4. Release the mouse at the desired location.

Functionality similar to the Reshape tool is available from the Object Info palette Shape tab; see “Editing 
Vertex-Based Objects” on page 1002.
~~~~~~~~~~~~~~~~~~~~~~~~~
NURBS Surfaces
Reshaping Objects
Direct Modeling with the Push/Pull Tool

Mode Description

Move NURBS Surface Vertex Changes the position of the selected vertex or vertices only
Move NURBS Surface U Vertices Changes the position of all vertices in a row in the U direction
Move NURBS Surface V Vertices Changes the position of all vertices in a row in the V direction
Working Plane Constrain Moves the selected vertex or vertices on a working plane
X-axis Constrain Moves the selected vertex or vertices along the X axis
Y-axis Constrain Moves the selected vertex or vertices along the Y axis
Z-axis Constrain Moves the selected vertex or vertices along the Z axis

Z-axis ConstrainMove NURBS Surface
Vertex

Move NURBS Surface
U Vertices

Move NURBS Surface
V Vertices

Working Plane 
Constrain

X-axis Constrain

Y-axis Constrain
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Offsetting Objects 
The Offset tool either creates a duplicate object offset from the original, or offsets the selected object from its original 
location. Use this tool to easily create parallel objects, such as lines and walls. Also use it to produce a larger or smaller 
version of closed objects, such as ovals and connected walls. NURBS surfaces are offset by the offset distance along 
the surface normal direction.
The Offset tool can be used with the following objects.
Vectorworks Fundamentals Objects

Vectorworks Design Series Objects

The Offset tool has four modes, which are also options in the Offset Tool Preferences dialog box.

The 2D conversion resolution field, on the Edit tab of the Vectorworks Preferences dialog box, adjusts the degree 
of smoothing. The higher the conversion resolution, the higher the degree of smoothing, which produces a more 
accurate offset of objects. For more information on 2D conversion resolution, refer to “Edit Preferences” on 
page 49.

To offset one or more objects:

1. Select the object(s) to be offset, if desired.
2. Click the Offset tool from the Basic palette.
3. Click Preferences from the Tool bar.

The Offset Tool Preferences dialog box opens.
Click to show/hide the parameters.

• NURBS curves • NURBS surfaces

• Walls • Revision clouds

• Open 2D objects (arcs, lines, polylines) • Closed 2D objects (circles, ovals, rectangles, rounded 
rectangles, polylines, polygons)

• Hardscapes • Massing models • Property lines

• Seating layouts • Site modifiers • Spaces

• Stipples • Plants • Redlines

Parameter Description

Method
Offset by Distance Places the offset object at the specified Distance from the original location (same as 

selecting the Tool bar button and entering the distance on the Tool bar)

Offset by Distance

Offset by Point

Distance Preference (for Offset 
by Distance mode only)

Duplicate and Offset

Offset Original Object

Preferences
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4. Specify the desired preferences and click OK.
To select additional objects or to change the currently selected objects to offset (or duplicate and offset), press and 
hold the Alt key (Windows) or Cmd key (Mac) while shift-clicking or click-dragging the mouse around them to 
marquee select them; the Selection tool is activated in boomerang mode while the Alt or Cmd key is being 
pressed.

5. Depending on the offset preferences, do one of the following:

Depending on the offset preferences, either a duplicate object or the original object is placed at the offset location.

Offset by Point Places the offset object at a distance specified by a mouse click (same as selecting 
the Tool bar button)

Duplication
Duplicate and Offset Creates a duplicate of the object at the offset location (same as selecting the Tool bar 

button)
Offset Original Object Moves the original object to the offset location (same as selecting the Tool bar 

button)
Wall Offset

Offset from Center Line Offsets walls from the center line of the wall’s original location
Offset from Nearest 
Edge

Offsets walls from the nearest edge of the wall’s original location

Smooth Corners Rounds sharp corners in the offset object
Close Open Curves Draws lines at both ends of the offset and original objects, to create a closed shape 

from the open curves

Offset Method Description

Offset by Distance
Click on objects to 
offset

Select the object to be offset; the object is highlighted. Click to specify the offset 
location relative to the selected object, and to place the offset object. To continue 
offsetting objects, click another object to highlight it, and then click again to indicate 
the offset location.

Offset selected objects Click in the drawing to specify the offset location relative to the originally selected 
object, and to place the offset object. The offset object is now selected; to offset from 
that object, click again to indicate the offset location.

Offset by Point
Click on objects to 
offset

Select the object to be offset; the object is highlighted. Move the mouse to adjust the 
offset preview if necessary, and then click to place the offset object. To continue 
offsetting objects, click another object to highlight it, and then click again to indicate 
the offset location.

Offset selected objects Click to set the offset point (move the mouse to adjust the offset preview if 
necessary), and then click again to place the offset object. The offset object is now 
selected; to offset from that object, click again to indicate the offset location.

Parameter Description
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Click here for a video tip about this topic (Internet access required).

Trimming and Clipping Objects

Trim Command
Use the Trim command to trim lines or walls where they intersect with another object.
To trim objects:

1. If necessary, position the trimming object over the object(s) to be trimmed.
2. Select the trimming object.
3. Select Modify > Trim.
4. Click on the object to be trimmed.

The trim command is executed and the pieces can be moved independently.

Select the walls with the Selection tool, and then select the Offset tool. Select Offset by Distance mode, and set the 
offset Distance to 2’. Click outside the walls to offset them 2’ beyond the original location.

In Offset by Point mode, click the 
object to be copied and offset; the 
object is highlighted

Click the point where the offset is to 
be placed; a preview displays

Click again to place the offset object

For grouped objects, the offset result depends on where you click

Click on an open
area of the group

Click on an enclosed 
area of the group

http://www.youtube.com/watch?v=XhUKG4tZb0c
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~~~~~~~~~~~~~~~~~~~~~~~~~
Trim Tool
Clip Tool

Trim Tool
The Trim tool trims a portion of the object indicated. 2D objects that can be edited in this manner include lines, arcs, 
rectangles, rounded rectangles, circles, ovals, polylines, and polygons. Straight walls can also be trimmed to 
intersecting straight walls using the Trim tool. The walls are automatically joined, regardless of whether the 
Vectorworks preference Auto join walls is on.
The Trim tool has two modes that determine how the object is trimmed.

To trim a portion of an object:

1. Click the Trim tool from the Basic palette.
The standard arrow cursor changes into a hand.

2. Click the All Objects or Currently Selected Objects mode from the Tool bar.
3. Position the hand cursor over the object to be trimmed; the object to be trimmed is highlighted. Only one object 

can be trimmed at a time.
4. Click the portion of the object to be trimmed. 

The object is trimmed to intersecting coplanar objects/straight walls according to the mode selected.

Mode Description

All Objects The object is trimmed to all intersecting coplanar objects/straight walls regardless of 
the current selection

Currently Selected Objects The object is trimmed only to the intersecting coplanar object(s)/straight wall(s) that is 
currently selected

All Objects Currently Selected Objects
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To trim another portion of the same object, move the hand cursor to the desired location and click.
~~~~~~~~~~~~~~~~~~~~~~~~~
Trim Command
Clip Tool

Clip Tool
The Clip tool cuts out pieces from 2D objects, such as lines, arcs, rectangles, rounded rectangles, circles, ovals, 
polygons, and polylines. In addition, this tool can be used to split an object. The Clip tool operates on all selected 
objects in the active plane.

To clip objects:

1. Select the object or objects to cut.

Mode Description

Exclusion Cuts a hole in the object(s) according to the clipping object shape
Inclusion Trims everything away from the outside of the clipping object shape
Split Splits the object(s) and the clipping area into separate objects
Rectangle, Polygon, Circle Each mode can use one of the clipping shapes; select rectangle, polygon, or circle

All Objects mode
The object is trimmed to all intersecting 
coplanar objects regardless of the 
current selection

The 2D object or wall to be trimmed is 
highlighted when the hand cursor is 
over it

Currently Selected Objects mode
The object is trimmed only to the 
intersecting coplanar objects that are 
currently selected

All Objects mode
The wall is trimmed and joined to all 
intersecting straight walls regardless of 
the current selection

Currently Selected Objects mode
The wall is trimmed and joined to only 
the intersecting straight walls that are 
currently selected

Exclusion

Split

Inclusion Rectangle

Polygon

Circle
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2. Click the Clip tool from the Basic palette.
To select additional objects or to change the currently selected objects to clip, press and hold the Alt key 
(Windows) or Cmd key (Mac) while shift-clicking or click-dragging the mouse around them to marquee select 
them; the Selection tool is activated in boomerang mode while the Alt or Cmd key is being pressed.

3. Select the clipping mode and the clipping object shape.
4. Click and drag to create a marquee box. The marquee is defined on the active plane.

The object is clipped as defined by the clipping object shape.

Click here for a video tip on this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Trim Command
Trim Tool
Clip Surface

Resizing Objects

Fixed Point Resize Tool
The Fixed Point Resize tool resizes rectangles, rounded rectangles, polygons, circles, and ovals using a fixed point on 
the drawing as the point of reference. It is best used to scale an object relative to a particular location in the drawing. To 
rescale an object symmetrically or asymmetrically by a specific factor, use the Scale Objects command.

To resize an object:

1. Select the object or objects to change.
2. Click the Fixed Point Resize tool from the Basic palette.
3. Click on the point in the drawing to serve as the fulcrum.

To scale the resized object symmetrically, select a fulcrum point that is at the exact center of the object.
If the fixed point is not at the center of the object, the resized object changes proportions.

4. Click on an object edge and drag the object into its new size, shape, and/or location.

If the drag point is moved past the selected fulcrum, the object is reversed.

Click 1

Click 2

Click fulcrum point Click and drag to resize

http://www.youtube.com/watch?v=40yExk9WcMg
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The starting point for dragging cannot be the same as the fulcrum point or exactly horizontal or vertical to it.
~~~~~~~~~~~~~~~~~~~~~~~~~
Scaling Objects

Scaling Objects
The Scale Objects command rescales the X and/or Y dimension of any selected solid, object, or group, or rescales the 
selected items uniformly in the X,Y, and Z dimensions. The selected item is rescaled using its center point. The object 
can be rescaled by indicating a segment on the drawing and entering a new distance for the segment. If no objects are 
selected, the entire drawing can be scaled. Layer links cannot be scaled with this command.

Unless you are scaling the entire drawing, the Scale Objects command does not scale symbols directly, although 
it can scale symbols in object editing mode. Use the Object Info palette or the Selection tool to scale a symbol 
instance directly in the drawing, as described in “Scaling Symbols from the Object Info Palette” on page 1064. 

To scale objects:
1. Select the object(s) to scale.

If no objects are selected, all objects on all layers of the drawing are scaled.
2. Select Modify > Scale Objects.

The Scale Objects dialog box opens. Specify the scaling method and parameters.
Click to show/hide the parameters.

Parameter Description

Symmetric Scales uniformly along X, Y, and Z axes
X, Y, Z Factor Enter the scaling factor (for example, enter 2 to double or .5 to halve the scale)

Symmetric By 
Distance

Scales symmetrically using the ratio of the current and new distance values as a scale 
factor

Current Distance Enter the current distance to be scaled, or click the button to use a temporary tool to 
indicate the distance on the drawing

New Distance Enter the new value for the distance
Asymmetric Scales along only the specified X and Y axes; when asymmetrically scaling a solid, the 

current view must be aligned with the solid’s matrix for scaling to occur
X / Y Scaling 
Factor

Enter the scaling factor (for example, enter 2 to double or .5 to halve the scale)

Scale text Scales selected text to the new scaling factor
Entire drawing Scales all objects on all layers, including text, symbols, and hatches
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3. If specifying the scale factor with the Symmetric by Distance option, click the button to switch temporarily to the 
drawing. Click to indicate the start of the segment, move the mouse, and click to indicate the end of the segment. 
You are returned to the Scale Objects dialog box, and the Current Distance value has been specified. Enter the 
New Distance for the segment.

4. Click OK.

Scaling Solids Asymmetrically
Solids can be scaled asymmetrically, through both the Scale Objects command (see “Scaling Objects” on page 1063) 
and the Object Info palette. The internal components of the solid do not change, and the solid can still be edited after 
the scaling operation. Spheres, hemispheres, and cones cannot be scaled asymmetrically. 
In the Object Info palette, enter a scale factor in the X Scale, Y Scale, or Z Scale field to scale the selected solid along 
the specified axis.

A selected solid can also be scaled asymmetrically by selecting the Modify > Scale Objects command and entering an 
Asymmetric scale factor. However, the current view must be aligned with the solid’s matrix for scaling to occur.

Scaling Symbols from the Object Info Palette
Symbol instances placed in the drawing can be scaled from the Object Info palette; this is an advantage because 
different sizes of the same symbol do not require a new symbol for each size.

Symbols can also be scaled interactively with the interactive scaling mode of the Selection tool. See “The 
Selection Tool” on page 109.

To scale a symbol instance:
1. Select the symbol instance in the drawing area.
2. From the Object Info palette, select Symmetric or Asymmetric Scaling.
3. For Symmetric scaling, enter the scale Factor. For Asymmetric scaling, enter the scaling factor along the 

specified axis.
Page-based symbols can only be scaled symmetrically.

4. The symbol is resized. The Object Info palette displays Scaled at the top of the Shape pane for symbols that have 
been scaled. Other instances of the same symbol in the drawing remain unscaled.

Select a solid object

X axis Y axis Change the Object Info 
palette settings to scale the 
solid
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~~~~~~~~~~~~~~~~~~~~~~~~~
Object Editing Mode

Shearing Objects
The Shear tool simultaneously skews all of the vertices of a rectangle, rounded rectangle, polygon, circle, oval, or 
polyline, using a fixed point on the drawing as a point of reference. It is like placing a thumbtack on one point of an 
object, or the drawing, and reshaping every other object point except the one tacked down. The Shear tool can be used 
to fake a 3D perspective.

To shear an object:

1. Select the object or objects to change.
2. Click the Shear tool from the Basic palette.
3. Click on the point in the drawing to tack down.
4. Click on the object and drag the resize cursor to shear the object. A preview object displays.
5. Click to set the shear position.

Click here for a video tip on this topic (Internet connection required).

Joining Objects

Join Command
The Join command can be used to join two single lines, two double lines, or two walls together. Joined lines intersect 
but remain as individual objects.

Table is too long and too close to chair Table scaled along X axis

Click to tack down a point then drag the resize cursor to shear the object

http://www.youtube.com/watch?v=W_lppSBVD3A
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~~~~~~~~~~~~~~~~~~~~~~~~~
Join
Join and Fillet
Join (No Trim)

Join
To join walls, single lines, or double lines:

1. Select the two non-parallel walls, lines, or double lines to join.
2. Select Modify > Join > Join.

The selected walls/lines are joined together with any excess trimmed away.

Join and Fillet
To join and fillet double lines:

1. Select the two sets of non-parallel double lines to join.
2. Select Modify > Join > Join and Fillet.

If a fillet measurement has already been specified for this drawing, the two double lines are connected and filleted 
using the default value.
If a fillet measurement has not yet been specified for this drawing, the Fillet Settings dialog box opens. 
Enter the desired fillet radius and click OK to connect and fillet the lines.

Object Command Specifications

Individual Lines Join
Join (No Trim)

An individual line can be joined to another individual line

Double Lines Join
Join and Fillet

Double lines can be joined to another set of double lines or to a wall. Double 
lines drawn with the Create Polygons option (set in Double Line 
preferences) cannot be joined. Only the line elements of double lines drawn 
with the Create Lines and Polygons option can be joined.

Walls Join
Join (No Trim)

A wall can be joined to another wall or to double lines created with the 
Create Lines option (set in Double Line preferences). Walls will join to the 
line elements of double lines drawn with the Create Lines and Polygons 
option.
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The Fillet Settings dialog box is accessible from various locations in the Vectorworks program, whenever a fillet 
radius value can be set. A change to the radius value in one location changes the default setting in all locations.

~~~~~~~~~~~~~~~~~~~~~~~~~
Fillet Tool

Join (No Trim)
To join two overlapping walls or individual lines, without trimming away the excess:

1. Select the two non-parallel walls or lines to join.
2. Select Modify > Join > Join (no trim).

The selected walls/lines are joined without trimming any excess.

Combining and Connecting Objects

Connect/Combine Tool
The Connect/Combine tool joins objects by their endpoints or at their intersections using one of four modes.

Mode Description

Single Object Connect Trims or extends the first selected object to join a second or boundary object
This mode can be used to connect roof faces.

Dual Object Connect Trims or extends to join two objects at their endpoints or intersections 
This mode can be used to connect roof faces.

Dual Object Combine Trims or extends to join two objects into one object at their endpoints or intersections
Multiple Object Connect Designates the first selected object as a boundary, and then trims or extends multiple 

consecutively selected objects to join the boundary

Single Object Connect

Dual Object CombineDual Object Connect

Use Vertical Thickness of 
Subject Roof Face

Multiple Object Connect
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When connecting or combining a pair of NURBS, polylines, or open polygons by their endpoints, you may need to 
supply additional information to complete the process. In this situation, the Connect/Combine Options dialog box 
opens.

Use Vertical Thickness 
of Subject Roof Face

If the tool is being used to connect two roof faces that have different thicknesses, this 
option automatically adjusts the roof face thickness of the second clicked roof face to 
match the vertical thickness of the first clicked roof face.

Option Description

Mid-Point Connects/combines the two objects by joining the two endpoints midway between them

Blend Connects/combines the two objects by creating another object between them

Position Matching 
(NURBS curves and 
surfaces only)

Connects/combines two NURBS curves or surfaces by moving the first object’s selected end 
point to the selected end point of the boundary object (not available if the end points are 
coincident)

Tangency Matching 
(NURBS curves and 
surfaces only)

Connects/combines two NURBS curves or surfaces by making the first object’s selected end 
point tangent to the selected end point of the boundary object

Mode Description
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Click here for a video tip on this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Single Object Connect
Dual Object Connect
Dual Object Combine
Multiple Object Connect
Connecting Roof Faces

Single Object Connect
The Single Object Connect mode trims or extends one or more selected objects to join a boundary object. Only open 
objects, such as lines, arcs, open polygons, and NURBS curves and lines, can be connected. Closed objects, such as 
circles, rectangles, and closed polygons cannot be connected; they are treated as boundary objects.

This mode can also be used to connect roof faces; see “Connecting Roof Faces” on page 569.

Connecting Single Objects

To connect a single object to a boundary object:

1. Click the Connect/Combine tool from the Basic palette, and select Single Object Connect from the Tool bar.
2. Click on the object to connect, and then click on the boundary object. The first object is resized to join the 

boundary object.

Connecting Multiple Objects

To connect multiple selected objects to a boundary object:

1. Select the objects to be connected to a boundary object.
2. Click the Connect/Combine tool from the Basic palette, and select Single Object Connect from the Tool bar.
3. While pressing and holding Alt (Windows) or Option (Mac), click on one of the objects to connect, and then click 

on the boundary object. The selected objects are resized to join the boundary object.
Alternatively, use Multiple Object Connect mode to connect multiple objects to a boundary object (see “Multiple 
Object Connect” on page 1072).

Curvature Matching 
(NURBS curves and 
surfaces only)

Connects/combines two NURBS curves or surfaces by making the first object’s selected end 
point match the curvature of the selected end point of the boundary object

Option Description

http://www.youtube.com/watch?v=cHNanCltyyk
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~~~~~~~~~~~~~~~~~~~~~~~~~
Connect/Combine Tool

Dual Object Connect
The Dual Object Connect mode trims or extends two objects to connect them at their endpoints or intersections. Only 
open objects, such as lines and polylines, can be connected. Closed objects, except for NURBS surfaces, cannot be 
connected.

This mode can also be used to connect roof faces; see “Connecting Roof Faces” on page 569.

To connect two objects:

1. Click the Connect/Combine tool from the Basic palette, and select Dual Object Connect from the Tool bar.
2. Click the first, and then the second, object to connect.

The Connect/Combine Options dialog box opens. Select a method for resizing and connecting the two objects.
The two objects are resized to connect to each other.

Connection Type Example

2D object extended to boundary object

2D object trimmed at boundary object

NURBS surface to NURBS surface

Multiple selection connecting 2D 
objects to boundary object

Click 1

Click 2
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~~~~~~~~~~~~~~~~~~~~~~~~~
Connect/Combine Tool

Dual Object Combine
The Dual Object Combine mode trims or extends to combine two objects into a single object at their endpoints or 
intersections. Only open objects, such as lines and NURBS curves and surfaces, can be connected.

Connection Type Example

Mid-Point

Blend

Position Matching

Tangency Matching

Curvature Matching

Click 1

Click 2

NURBS surface being connected to NURBS surface
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To combine two objects:

1. Click the Connect/Combine tool from the Basic palette, and select Dual Object Combine from the Tool bar.
2. Click on the first, and then the second, object to combine.

The two objects are trimmed or extended if necessary and combined into one object.

~~~~~~~~~~~~~~~~~~~~~~~~~
Connect/Combine Tool

Multiple Object Connect
The Multiple Object Connect mode trims or extends multiple objects to join a selected boundary object. Only open 
objects, such as lines, arcs, open polygons, and NURBS curves and lines, can be connected. Closed objects, such as 
circles, rectangles, and closed polygons can only be used as boundary objects.

Alternatively, use the Alt (Windows) or Option (Mac) key in Single Object Connect mode to connect multiple 
objects to a boundary object (see “Single Object Connect” on page 1069).

To connect multiple objects to a boundary object:

1. Click the Connect/Combine tool from the Basic palette, and select Multiple Object Connect from the Tool bar.
2. Click on the boundary object, which becomes highlighted in red.
3. Position the cursor over the first object to trim or extend to the boundary; it becomes highlighted in red. Click to 

resize the object to join the boundary object.
4. Continue to click on objects to connect to the boundary. Each consecutively clicked object is connected, until you 

click in an empty space to deselect the boundary object.

~~~~~~~~~~~~~~~~~~~~~~~~~
Connect/Combine Tool

Splitting Objects and NURBS Surfaces with the Split Tool
The Split tool splits the following objects.

Click 1

Click 2

Tangent or curvature matching between two 
NURBS surfaces creates a single surface

The line and the arc are combined to 
form a single polyline object

The first click selects the 
boundary object

As each line is clicked, it is connected 
to the boundary object



Splitting Objects and NURBS Surfaces with the Split Tool |  1073
Vectorworks Fundamentals Objects

Vectorworks Design Series Objects

Splitting an object may change its type; for example, splitting a roof face creates a solid section, which can no 
longer be edited as a roof face.

The following modes are available for the Split tool.

Surfaces generated by successive splitting can be joined together with the Compose command (see “Composing 
and Decomposing Objects and Surfaces” on page 1020).
This tool may not be able to manipulate certain types of surface geometry (see “Surface Geometry Requirements” 
on page 327).
Click here for a video tip on this topic (Internet connection required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Point Split Mode

• 3D solid objects (extrudes, cones, cylinders, 
spheres, hemispheres)

• 2D objects (ovals, circles, rectangles, 
rounded rectangles, arcs, lines, polylines, 
polygons)

• Revision clouds • Pillars

• NURBS curves • Walls

• NURBS surfaces • Floors

• Viewports • Roof faces

• Property lines • Redlines

• Massing models • Stipples

• Site modifiers • Spaces

• Seating layouts • Hardscapes

Mode Description

Point Split Cuts an object or NURBS surface at a specified point
Line Split Splits an object or NURBS surface along a cutting line
Line Trim Splits an object or NURBS surface along a cutting line, and then keeps a designated side
All Objects For Line Split and Line Trim modes, splits all objects along a cutting line regardless of the 

current selection
Currently 
Selected 
Objects

For Line Split and Line Trim modes, splits only the currently selected objects along a cutting 
line

Line Trim

Point Split

Line Split All Objects

Currently 
Selected 
Objects

http://www.youtube.com/watch?v=wWknQRBcUUE
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Line Split Mode
Line Trim Mode
Splitting or Trimming NURBS Surfaces

Point Split Mode
The Point Split mode cuts an object at a specified location.

Splitting Objects by Point

To split an object at a specific point:

1. Click the Split tool from the Basic palette.
2. Click the Point Split mode from the Tool bar.
3. Click on the object at the point to be split.

If multiple objects are within range of the specified point, the Select Split Candidate dialog box opens.
Highlight the object to split by using the Next and Prev buttons.

4. The object is split into two pieces.

If the object is closed, as in a circle or rectangle, the object is converted so that its endpoints meet unjoined at the 
split. Some objects are not truly closed, and instead break into two segments.

Splitting NURBS Surfaces by Point

To split a NURBS surface in point split mode:

1. Click the Split tool from the Basic palette.
2. Click the Point Split mode from the Tool bar.
3. Click on the NURBS surface to split.

See “Selecting the Edges and Faces of a Solid” on page 324 for information on selecting surfaces.

Click
The wall is split into two separate 
pieces at the click location; the lower 
segment has been moved for clarity

Click to split the NURBS surface The surface is split at that point

The smaller surface has 
been moved for clarity
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The surface is split by iso-parametric curves passing through the click point along U and V parametric directions.
If the split point is on an existing iso-parametric curve, the surface is split in both directions (U and V).

~~~~~~~~~~~~~~~~~~~~~~~~~
Line Split Mode
Line Trim Mode
Splitting or Trimming NURBS Surfaces

Line Split Mode
The Line Split mode splits 2D objects, NURBS curves/surfaces, solids, and viewports along a screen plane cutting 
line. After the split, all the objects remain on the drawing.

To split an object(s) along a cutting line:

1. Click the Split tool from the Basic palette.
2. Click the Line Split mode from the Tool bar.
3. Click the All Objects or Currently Selected Objects mode from the Tool bar.
4. Draw a line through the object(s) to split; the object(s) to be split is highlighted.

The object(s) is split by the line, and all parts remain in place on the drawing.

Solids can also be split in Line Split mode.

Clicking once on the iso-parametric curve (shown in light gray) with the 
Split tool creates four split surfaces (in black)

The split objects have been 
moved for clarityAll Objects mode

The split object has been 
moved for clarityCurrently Selected Objects mode
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~~~~~~~~~~~~~~~~~~~~~~~~~
Point Split Mode
Line Trim Mode
Splitting or Trimming NURBS Surfaces

Line Trim Mode
The Line Trim mode splits 2D objects, NURBS curves/surfaces, solids, and viewports along a screen plane cutting 
line; it keeps a specified side, and trims away the other side.

To split and trim an object along a cutting line:

1. Click the Split tool from the Basic palette.
2. Click the Line Trim mode from the Tool bar.
3. Click the All Objects or Currently Selected Objects mode from the Tool bar.
4. Draw a line through the object(s) to split; the object(s) to be split is highlighted.
5. An arrow points to the side to be kept. Click to indicate which side of the split line to keep; the other side is 

trimmed away.
The object(s) is split by the line, and the indicated side remains.

Two solid sections have been moved and the image rotated for clarityAll Objects mode

One solid section has been 
moved for clarity

Currently Selected Objects mode

All Objects mode
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Solids can also be split in Line Trim mode.

~~~~~~~~~~~~~~~~~~~~~~~~~
Point Split Mode
Line Split Mode
Splitting or Trimming NURBS Surfaces

Creating Fillets and Chamfers

Fillet Tool
The Fillet tool adds a highly specific fillet (arc) between two objects in the drawing, making each of the fillet’s end 
points tangent to one of the objects. Apply fillets to lines, rectangles, polygons, polylines, circles, circular arcs, 
NURBS curves, 3D polygons, and walls. With rectangles, polygons, or polylines, the tool places a fillet between 
adjacent sides of the object. Holes in polylines can be filleted. In addition, this tool trims or splits objects at the fillet’s 
end points by selecting various fillet modes.
A fillet cannot be placed between parallel or concentric objects. If “split” or “trim” fillets are placed between a mixture 
of objects that can and cannot be split/trimmed, the fillet works only on the objects that can be split/trimmed, and 
ignores the others.

To place a fillet:

1. Click the Fillet tool from the Basic palette.
2. Click the desired mode from the Tool bar.

Currently Selected Objects mode

All Objects mode

Two remaining solids have 
been rotated for clarity

Two remaining solids have 
been rotated for clarity

Currently Selected Objects mode



  1078 | Creating Fillets and Chamfers
3. Enter the Fillet Radius to use in the Tool bar.
4. Click the object where the fillet will begin.
5. Click the object where the fillet will end.

To apply the fillet to all adjacent sides of an object, double-click.
If an object is too short, it extends to match the selected fillet radius.
Click here for a video tip on this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Chamfer Tool
Filleting Solid Edges

Chamfer Tool
The Chamfer tool places a chamfer, or line, between two objects or adjacent sides of an object, including rectangles, 
NURBS curves, polygons, 3D polygons, polylines, or line segments. A chamfer cannot be placed between parallel lines 
or NURBS curves.

Mode Description

Standard Places a fillet without affecting the original object; the fillet and the object must be grouped to 
form a single object

Split Places a fillet and splits the filleted object. If the fillet is between two objects, the fillet and the 
objects must be grouped to make a single object. If filleting the corners of a polygon, the fillet 
takes the place of the corner and becomes a part of the object.

Trim Places a fillet and trims the filleted object. If the fillet is between two objects, the fillet and the 
objects must be grouped to make a single object. If filleting the corners of a polygon, the fillet 
takes the place of the corner and becomes a part of the object.

Standard

Split

Trim

Fillet Radius Preference

http://www.youtube.com/watch?v=7D2gRJq2s70
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The tool has three modes: chamfers can be placed without affecting existing objects, they can split the existing objects 
at the chamfer endpoints, or they can trim (or extend) the existing lines to the chamfer endpoints.

To create a chamfer:

1. Click the Chamfer tool from the Basic palette.
2. Select the mode from the Tool bar.

3. To specify the chamfer size with a different method (for example, by a set chamfer length), click Preferences 
from the Tool bar. The Chamfer Settings dialog box opens. Enter the appropriate values and click OK.

Click to show/hide the parameters.

Mode Description

Standard Places a chamfer without affecting the original object; to create a single object, group the 
chamfer and the chamfered object together

Split Places a chamfer and splits the chamfered objects. This mode extends lines, if needed, for 
the chamfer to connect. To create a single object, group the chamfer and the chamfered 
object together. If the corner of a polygon is chamfered, the chamfer takes the place of the 
corner.

Trim Places a chamfer and trims the chamfered objects. If the corner of a polygon is chamfered, 
the chamfer takes the place of the corner. This mode extends lines, if needed, for the chamfer 
to connect.

Parameter Description

Entry Options Select a method for specifying the chamfer size; once selected, the required entry fields 
also display on the Tool bar for easy entry

Standard

Split

Trim

Preferences

Chamfer Preference Fields
(the available fields vary based on the entry option 
selected in the Chamfer Settings dialog box)
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4. Fields on the Tool bar indicate where the chamfer will be placed, according to the current settings in the chamfer 
preferences. Change the default values if necessary.

5. Click the object where the chamfer will begin.
6. Click the object where the chamfer will end.

The chamfer is drawn according to the mode selection.
Click here for a video tip on this topic (Internet required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Fillet Tool
Chamfering Solid Edges

Editing Object Surfaces

Editing 2D Object Surfaces
There are four commands for editing 2D and 2D/3D hybrid object surfaces: Intersect Surface, Add Surface, Combine 
into Surface, and Clip Surface. The Intersect, Add, and Clip commands have an equivalent context menu command 
accessed by a Ctrl-click (Mac) or right-click (Windows). Use these commands with the following objects.

Vectorworks Fundamentals Objects

• 2D primitive objects that can be filled and are not grouped (arcs, polygons, polylines, ovals, circles, rectangles, 
rounded rectangles)

• Revision clouds

First and Second Lines Enter the distances from the end of the First Line and Second Line at which to place 
the ends of the chamfer line

First Line and Angle Enter the distance from the end of the First Line at which to place one end of the 
chamfer line, and enter the Angle between the First Line and the chamfer line

Chamfer Line Length Enter the Chamfer Line Length

Parameter Description

http://www.youtube.com/watch?v=GXfN9dxE98M
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• Floors
• Roof faces
• Pillars

Vectorworks Design Series Objects

These commands work in any view, as long as the objects involved are in the same plane. If a combination of 2D and 
2D/3D hybrid objects (such as floors or pillars) will be used in an operation, the view must be set to Top/Plan. In Top/
Plan view, screen plane and layer plane are considered to be co-planar.
The equivalent 3D commands operate on solids and can be used in a view other than Top/Plan.
~~~~~~~~~~~~~~~~~~~~~~~~~
Intersect Surface
Add Surface
Combine into Surface
Clip Surface
Editing 3D Object Surfaces

Intersect Surface
The Intersect Surface command provides an easy way to create a new object that is the exact size and shape of the 
overlapping area of two co-planar objects.
To intersect surfaces:

1. Select the two overlapping objects to use to create a third object.
The new object’s properties are based on the object on the bottom of the stack of objects. If the bottom object is a 
2D primitive (such as a rectangle or circle), the new object will have its attributes. If the bottom object is 
something other than a 2D primitive (such as a floor or pillar), the new object will be the same type, with the same 
properties. If necessary, use the Send command to stack the objects to produce the desired attributes or object 
type.

2. Select Modify > Intersect Surface.
The new object is placed directly on top of the two original intersecting objects. To see the new object, select it 
and drag it to the side.

• Ceiling grids • Plants

• Massing models • Stipples

• Property lines • Redlines

• Site modifiers • Seating layouts

• Spaces • Hardscapes

• Parking Areas • Stages

• Slabs
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~~~~~~~~~~~~~~~~~~~~~~~~~
Editing 2D Object Surfaces
Editing 3D Object Surfaces

Add Surface
The Add Surface command creates a single object from two or more co-planar objects, as long as all of the following 
are true:

• The objects are not symbols.
• The objects touch or overlap each other.
• The objects are not locked or grouped.

Note that any open polygons will be converted to closed polygons.
To add surfaces:

1. Select the two or more objects to be combined.
The new object’s properties are based on the object on the bottom of the stack of objects. If the bottom object is a 
2D primitive (such as a rectangle or circle), the new object will have its attributes. If the bottom object is 
something other than a 2D primitive (such as a floor or pillar), the new object will be the same type, with the same 
properties. If necessary, use the Send command to stack the objects to produce the desired attributes or object 
type.

2. Select Modify > Add Surface.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing 2D Object Surfaces
Editing 3D Object Surfaces

Combine into Surface
The Combine into Surface command creates a new object that is formed from a group of objects. The objects must 
currently intersect and form a closed polygon or polyline shape. Depending on the types of objects selected and the 
location of the mouse click, you can create several different polygons or polylines from the same selection of objects. 
For example, with this set of three objects, the following polygon can be created:

In Top/Plan view, select the pillar 
(gray object on bottom) and the 
rectangle (white object on top)

Select Add Surface to combine 
the two surfaces into a single pillar 
object

Click here
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To combine surfaces:
1. Select the two or more closed objects to use to create a new polygon or polyline.
2. Select Modify > Combine into Surface.

The cursor changes into a paint bucket.
3. Place the paint bucket inside the area to be combined and click.

A single polygon or polyline object is created from the selected objects. The new object uses the current attributes.
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing 2D Object Surfaces
Editing 3D Object Surfaces

Clip Surface
The Clip Surface command trims the bottom object in a selection so that any areas overlapped by the top object are cut 
out of it. Objects must be co-planar. Multiple objects can be used as clipping objects in one operation. Symbols and 
grouped objects cannot be clipped or be used as clipping objects.
If there is a stack of more than two overlapping objects, then each object under the clipping object (the top object in the 
stack) will be clipped.
There are two important things to remember about this command:

• If the object to be clipped is an open polygon, it is automatically converted to a closed polygon before it is clipped.
• Depending on the objects selected, the command may change the bottom object’s type; for example, if a hole is 

clipped into a rectangle, the “clipped” rectangle is automatically changed into a polyline.
To clip a surface:

1. Ensure that the object to be clipped is the bottom object.
If necessary, change the objects’ order with the Send command (see “Changing Object Stacking Order” on 
page 1010).

2. Select the object to be clipped.
3. Select the clipping object.
4. Select Modify > Clip Surface.

The bottom object is clipped by the clipping object; the clipping object can be deleted if it is no longer needed. 

 

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing 2D Object Surfaces
Editing 3D Object Surfaces

In Top/Plan view, select the roof face 
(gray object on bottom) and the 
rectangle (white object on top)

Select Clip Surface, and then move 
the rectangle clipping object to 
reveal the modified roof face
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Editing 3D Object Surfaces
The 3D editing commands are similar to the 2D Add or Clip Surface commands, but for 3D objects. For 3D objects, 
the editing commands are: Intersect Solids, Add Solids, Subtract Solids, and Section Solids. Each of these commands 
has an equivalent context menu command accessed by a Ctrl-click (Mac) or right-click (Windows). 
Intersect Solids creates a single model from the volume created where two or more 3D objects intersect. Add Solids 
joins two or more 3D objects into a single model. Subtract Solids cuts (subtracts) a 3D object(s) from another 3D 
object, creating a new model. Section Solids discards a portion of solids or NURBS surfaces, allowing the creation of 
planar or stepped sections through a solid or surface.
These commands work with the following solid objects: extrudes, multiple extrudes, straight walls, sweeps, meshes, 
solid primitives (cylinders, hemispheres, spheres, and cones), and objects created using the 3D Polygon, Extruded 
Polygon, and Extruded Rectangle tool, provided the following applicable conditions are met.

2D objects must have a fill applied prior to being converted to 3D to be considered a solid object. If the converted 
3D object did not have a fill applied prior to conversion, it can be added using the Enter Group command to 
return to the original 2D object.

~~~~~~~~~~~~~~~~~~~~~~~~~
Add Solids
Intersect Solids
Subtract Solids
Section Solids
Editing 2D Object Surfaces

Add Solids
The Add Solids command joins two or more 3D objects into a single model.
To add solids in 3D:

1. Select two or more 3D objects to combine.
2. Select Model > Add Solids.

A single solid model is created from the objects.

Object Criteria

Sweeps Cannot contain lines, or be swept around a locus which is between the left and right bounds of 
the swept 2D primitive; if not swept around a locus, should have a vertical segment on the left 
edge

Helical Sweep Must be swept around a locus outside the left and right bounds of the object
Multiple Extrude Must have planar polygons
Meshes Cannot have interpenetrating polygons; every edge of every polygon in the mesh must be 

shared with one other polygon
Walls Must not have symbols that extend above the top or below the bottom of the wall
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~~~~~~~~~~~~~~~~~~~~~~~~~
Editing 3D Object Surfaces
Editing 2D Object Surfaces

Intersect Solids
The Intersect Solids command creates a single model from the volume created where two or more 3D objects 
intersect.
To intersect solids:

1. Select the two or more 3D objects to combine.
2. Select Model > Intersect Solids.

A single solid model is created from the objects; it is the size and shape of the overlapping volume of the selected 
objects.

 

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing 3D Object Surfaces
Editing 2D Object Surfaces

Subtract Solids
The Subtract Solids command cuts (subtracts) one or more 3D objects from another 3D object, creating a new model.

The subtracting object should extend beyond the surface of the original object.
To subtract solids:

1. Select both the object(s) to subtract and the object to subtract from (the base object).
2. Select Model > Subtract Solids.

The Select Object dialog box opens.
3. Use the forward and back arrows to select the base object, which is shown with a thick outline.

Deselect Retain Subtracting Objects to automatically delete the subtracting object, or select Retain Subtracting 
Objects to keep the object in place.

4. Click OK.
If Retain Subtracting Objects is not selected, a single solid model is created, with the subtracting object deleted.

If Retain Subtracting Objects is selected, a mass equal to the subtracting object is removed from the base object, 
but the subtracting object remains in place and can be manipulated independently.
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~~~~~~~~~~~~~~~~~~~~~~~~~
Editing 3D Object Surfaces
Editing 2D Object Surfaces

Section Solids
The Section Solids command discards a portion of solids or NURBS surfaces, allowing the creation of planar or 
stepped sections through a solid or surface. The sectioned surface can be “marked” by the sectioning surface color.

The sectioning surface must be larger than the base object.
To section a solid:

1. Select both the object to be sectioned (the base object), and the sectioning surface.
The operation will delete the portion of the base object on the same side as the sectioning surface’s normal; select 
Show Normal in the Object Info palette to display the surface normals (see “Displaying Surface Normals” on 
page 326). Click Reverse Normal in the Object Info palette if needed to achieve the desired results.

2. Select Model > Section Solids. 
The Select Object dialog box opens.

3. Select the sectioning surface. By default, the most recently created object is highlighted, but a different object can 
be selected by clicking the arrows.
Select Retain Sectioning Object to keep the object in place, or deselect Retain Sectioning Object to 
automatically delete the sectioning object.

4. Click OK.
If Retain Sectioning Object is not selected, a solid section is created, with the sectioning surface deleted.

If Retain Sectioning Object is selected, a solid section is created, but the sectioning surface remains in place and 
can be manipulated independently.
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The solid section parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing 3D Object Surfaces
Editing 2D Object Surfaces

Drafting Aids
The Drafting Aids menu contains several commands that create new arcs, lines, or rectangles that are based on existing 
objects, or simplify existing objects, to make drafting faster and easier.
~~~~~~~~~~~~~~~~~~~~~~~~~
Arc into Segments
Line into Segments
Create Dividing Lines
Even Divide
Simplifying Polygons and Polylines

Arc into Segments
The Arc into Segments command converts a selected arc or circle into an equal number of segments, or divides the arc 
or circle into segments of a given length. The segments can be drawn as lines or polygons; the original object remains 
unchanged.
To convert a circle or arc into segments:

1. Select the arc or circle to be converted.
2. Select Modify > Drafting Aids > Arc into Segments. The Arc into Segments dialog box opens.

Click to show/hide the parameters.

Parameter Description

Width/Depth/Height (display only) Displays the parameters of the solid section surface
Reverse Section Side Switches the remaining side of the solid being sectioned
Use Section Color Applies the color of the sectioning surface to the sectioned surface

Parameter Description

Method
Number of Segments Draws the specified number of equal segments along the arc
Segment Length Draws segments of the specified length along the arc
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3. Click OK to create the segments.

~~~~~~~~~~~~~~~~~~~~~~~~~
Line into Segments
Create Dividing Lines
Even Divide
Simplifying Polygons and Polylines

Line into Segments
The Line into Segments command converts a selected line into the indicated number of equal length segments. The 
original line can be converted, or an identical line placed on top of the original and converted. 
To convert a line into segments:

1. Select the line to be converted.
2. Select Modify > Drafting Aids > Line into Segments.

The Line into Segments dialog box opens.
Click to show/hide the parameters.

3. Set the parameters and click OK to draw either a new segmented line or convert the selected one.
~~~~~~~~~~~~~~~~~~~~~~~~~
Arc into Segments
Create Dividing Lines
Even Divide
Simplifying Polygons and Polylines

Create Dividing Lines
The Create Dividing Lines command creates lines that evenly divide the space between two existing lines. The 
existing lines can be angled or parallel to each other.
To create dividing lines:

1. Select Modify > Drafting Aids > Create Dividing Lines.

Options
Draw Polygon Draws the segments as polygons
Draw Lines Draws the segments as lines

Parameter Description

Place loci Places loci at the segment divisions
Break Line Into Segments Creates segments from the original line, converting it; deselect to place loci only
Leave Original Line Intact Retains the original line, and creates segments from a copy of the line
Number of Segments Specifies the number of segments to create

Parameter Description
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2. Select the two lines to create lines between.
3. Click to define first the starting point and then the ending point of the dividing lines. A perpendicular line (for 

parallel lines) or circle (for angled lines) indicates the edge along which the lines will start and end. If the starting 
point and ending point are on the same line or circle, loci will be created instead of lines.

4. When the Dividing Lines Settings dialog box opens, enter the number of equal divisions to create between the 
existing lines.

5. Click OK to create evenly spaced lines (or loci) between the existing lines.

~~~~~~~~~~~~~~~~~~~~~~~~~
Arc into Segments
Line into Segments
Even Divide
Simplifying Polygons and Polylines

Even Divide
The Even Divide command divides lines, arcs, circles, and rectangles into the specified number of subdivisions. You 
can choose whether or not to retain the original object.
To evenly divide lines, arcs, circles, and rectangles:

1. Select one or more objects to divide.
2. Select Modify > Drafting Aids > Even Divide.

The Even Divide dialog box opens.
Click to show/hide the parameters.

After you select the two lines, 
the next click indicates the 
starting edge for the dividing 
lines

Creating divisions between parallel lines 

Click another point to 
indicate the ending 
edge for the dividing 
lines

The specified number of 
divisions are created; in this 
case, two lines are added to 
create three divisions

The specified number of 
divisions are created; in this 
case, three loci are added to 
create four divisions

After you select the two lines, 
click two points anywhere on the 
same indicator circle to create 
loci instead of lines

Creating divisions between angled lines 
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3. Set the parameters and click OK to create new objects that are even subdivisions of the selected object(s).

~~~~~~~~~~~~~~~~~~~~~~~~~
Arc into Segments
Line into Segments
Create Dividing Lines
Simplifying Polygons and Polylines

Simplifying Polygons and Polylines
The Simplify Polys command simplifies 2D polygons, 3D polygons, and polylines by reducing the number of corner 
vertices. This operation can reduce the file size and shorten processing time while having a minimal effect on the shape 
of the polygons/polylines themselves. There are two methods for simplifying polygons/polylines: by the maximum 
deviation or by the minimum distance.
To simplify a polygon(s) or polyline(s):

1. Select the polygon(s) and/or polyline(s) to simplify.
2. Select Modify > Drafting Aids > Simplify Polys.

The Simplify Polys dialog box opens.
Click to show/hide the parameters.

Parameter Description

Number of Divisions for 
Line, Circle and Arc

Number of Divisions Specifies the number of even subdivisions to create from each selected line, circle, 
or arc (must be greater than 1)

Number of Divisions for 
Rectangle

Number of Divisions in 
Width

Specifies the number of even subdivisions to create along the width of each 
selected rectangle; enter 1 to create rectangles of the same width as the original 
rectangle

Number of Divisions in 
Height

Specifies the number of even subdivisions to create along the height of each 
selected rectangle; enter 1 to create rectangles of the same height as the original 
rectangle

Original Object
Retain Select to retain the original object from which the subdivisions are created; deselect 

to delete the original object
Leave Selected If the original object is retained, select this option to leave both the original object 

and the newly-created objects selected after the division operation. Deselect this 
option to leave only the newly-created objects selected after the operation.

In this example, four rectangles were created from the original rectangle; the width was divided into four 
even sections, and the height remained in one section (one rectangle moved for clarity)
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3. Set the parameters and click OK to simplify the polygon(s)/polyline(s).
The Simplify Polys command does not remove start and end vertices, and does not remove non-corner vertices 
unless multiple vertices exist at the same location. If you select the No Smoothing command first, Simplify Polys 
will then work on an object with these vertices.
The command works for stand-alone polygons/polylines. To simplify polygons/polylines located inside objects 
such as groups and symbol definitions, you must enter the object and simplify the polygon or polyline while in 
object editing mode (see “Object Editing Mode” on page 1004).

~~~~~~~~~~~~~~~~~~~~~~~~~
Drafting Aids
Arc into Segments
Line into Segments
Create Dividing Lines
Even Divide
Simplifying 3D Polygons
Smoothing Objects

Parameter Description

Simplify by
Maximum Deviation Select to remove the corner vertices within a specified maximum tolerable deviation 

between the original and the simplified polygon(s)/polyline(s)
Deviation Specify the maximum deviation value. 

A deviation value of zero removes all collinear vertices.
Minimum Distance Select to remove corner vertices located equal to or less than a specified minimum 

distance from adjacent vertices
Distance Specify the minimum distance value. 

A distance of zero removes all extra vertices existing at the same location.

This 398-foot red polyline imported from a site model has 3,130 vertices

This blue polyline was simplified with a maximum deviation of 12 inches 
and now has 76 vertices

This green polyline was simplified with a minimum distance of 12 inches 
and now has 309 vertices
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Applying Object Attributes
Attributes are characteristics that can be applied to 2D planar and screen objects in a drawing, including fill style, pen 
style, opacity, line thickness, and line end markers. Fill styles include solid colors, patterns (including foreground and 
background colors), hatches, tiles, gradients, and images. Pen styles include solid colors, patterns (including 
foreground and background colors), and line types.
There are various ways to apply attributes to objects:

• Use the Attributes palette to apply attributes to a selected object.
• Use the Attributes palette to set default attributes that will be applied as objects are created.
• Use the Eyedropper tool to transfer attributes from one object to another.
• Set up a class to use certain attributes when objects are created in that class or when the class is assigned to an 

existing object.
The attributes available on the Attributes palette can be customized. Fill and line patterns, line thickness, and line end 
marker style attributes can all be adjusted as needed; to reuse the custom attributes in other files, save them to a 
template file. Attributes that are resources (hatches, tiles, gradients, images, and line types) are even more flexible; they 
can easily be created, edited, reused in other files, and shared with coworkers. In addition, hatches, tiles, gradients, and 
images can be mapped to suit a specific object.
~~~~~~~~~~~~~~~~~~~~~~~~~
The Attributes Palette
Transferring Attributes
Fill Attributes
Pen Attributes
Opacity Attributes
Marker Attributes
Using Hatch Fills
Using Tile Fills
Using Gradient Fills
Using Image Fills
Mapping Fills with the Attribute Mapping Tool
Using Line Types
Applying Colors

The Attributes Palette
The Attributes palette applies attributes to objects, and displays the attributes currently applied to a selected object.
Select Window > Palettes > Attributes to open the Attributes palette.

Attributes can be applied to most 2D planar and screen objects, with a few exceptions. Line end markers can only be 
applied to open objects, such as lines, arcs, and polylines. Only pen color and opacity can be applied to text; however, a 
fill can be applied to the text box (the background behind the text).

Opacity

Fill Style

Pen Style

Line Thickness
Marker controls

Utility menu (Vectorworks Design Series required)

Pen Color

Fill Color
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If you are using the same attribute settings for several objects, create a class for those objects and apply the class 
attributes at creation. Class attributes can also be set for selected objects; see “Setting Class Attributes” on page 181.
Most of the attribute types (fill, pen, opacity, line thickness, and marker) are specified directly from the Attributes 
palette. Some of the settings available on the palette can be customized; fill and line patterns, line thickness, and line 
end marker styles can all be adjusted as needed.
Line types, and hatch, tile, gradient, and image fills are resources; you can select them from the default content in the 
Attributes palette (see “Resource Libraries” on page 219), or you can create or import custom resources and apply them 
from the Resource Browser.
In Vectorworks Design Series products, the Attributes palette has a utility menu that sets default and global attributes.

Setting Default Attributes
The default attributes for a document are the attributes that are automatically applied to each new object when it is 
created, unless a class attribute is assigned. These are the settings that display on the Attributes palette when no objects 
are selected.
When you first open a new document, set the default attributes to those you use most often. For example, you might 
adjust the fill and line colors, and line thickness.
The default attributes apply to the current document only. In addition, custom patterns that you create cannot be used in 
other documents. To save a set of default attributes or custom patterns for future use, set the attributes as desired and 
save the document as a template.
To set the default attributes for a document:

1. Ensure that no objects are selected.
2. Select Window > Palettes > Attributes.

The Attributes palette opens.
3. Select the desired attributes. Objects created after that point use those attributes by default.

The defaults can also be set with the Eyedropper tool (see “Transferring Attributes” on page 1095).

Setting Global and Default Attributes
The Attributes palette includes a utility menu for making changes to all the attributes at one time. A set of default 
attributes can be saved and then restored, and attributes can quickly be set to be “By Class,” or have all “By Class” 
settings removed.
To access the Attributes palette utility menu:

1. From the Attributes palette, click the Utility Menu button to open the Utility menu.

Command Description

Use Default Attributes Restores the default Attributes palette settings 
Set Default Attributes Saves all current parameter settings in the Attributes palette as the default set
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2. Select a utility command to set the default attributes or change the Attribute palette parameter settings.

Applying Attributes to Existing Objects
To apply attributes to existing objects:

1. Select the object or objects.
2. Select Window > Palettes > Attributes.

The Attributes palette opens.
3. Set the desired attributes for the object(s) from the Attributes palette.

The object’s attributes are updated.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Templates
Transferring Attributes
Fill Attributes
Pen Attributes
Opacity Attributes
Marker Attributes
Using Line Types
Applying Colors

Transferring Attributes
The Eyedropper tool transfers attributes from one object to another in a single step, including fill, pen, line, text, wall, 
and other attributes.

Press the Option (Mac) or Ctrl (Windows) key to switch between the Pick Up and Apply modes.

To transfer object attributes:

1. Click the Eyedropper tool from the Basic palette.

Make All Attributes 
By Class

Sets all Attributes palette parameters to be determined by the object’s class (see “Setting 
Class Attributes” on page 181)

Remove By Class 
Settings

Removes any “by class” settings for all Attributes palette parameters

Mode Description

Pick up Attributes Selects an object’s attributes
Apply Attributes Transfers selected attributes to another object
Preferences Sets the default parameters to be used for the tool
Settings Sets the group of parameters to be used for the tool-either the currently active settings, 

or a selection from the list of saved settings

Command Description

Apply Attributes

Pick up Attributes Settings list

Preferences
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2. Click Preferences from the Tool bar to specify the set of attributes to transfer. The Eyedropper Preferences dialog 
box opens.
Alternatively, select a set of saved attributes from the Settings list on the Tool bar.

3. Specify the attributes to be selected and applied by the Eyedropper tool, and click OK.
Click to show/hide the parameters.

Parameter Description

Saved Settings Options
Settings Select <Active Settings> to use the attributes currently selected in the dialog box; to use 

a set of saved attributes, select them from the pull-down list
Save Opens a dialog box to name and save the currently selected attributes so that they can 

quickly be selected as a set
Manage Opens the Saved Settings dialog box to rename or delete sets of saved tool attributes

All • Checked box: All attributes in the group are selected; click to deselect all attributes 
in the group.

• Empty box: No attributes in the group are selected; click to select all attributes in the 
group for transfer.

• Box displays  (Windows) or  (Mac): One or more attributes in the group are 
not selected; click to select all attributes in the group for transfer.

Fill Attributes Transfers fill attributes, including foreground and background colors, style (pattern, 
hatch, tile, gradient, or image fill), and texture

Pen Attributes Transfers pen foreground and background colors and style (solid, pattern, or line type)
Line Attributes Transfers line weight (thickness), presence of markers, and marker attributes
Text Attributes Transfers text attributes to another text object, dimension, or plug-in object, including 

font, size, font style, alignment, spacing, tab stops, and tracking. Only font, size, and 
font style settings can be transferred to dimension and plug-in objects.

Wall Attributes Transfers wall thickness and component settings for walls and round walls; components 
define wall thickness, so components cannot be transferred without also transferring the 
thickness parameter

Viewport Attributes Transfers viewport attributes to another viewport, including class and layer visibility 
settings, class and layer attribute overrides, and rendering properties (background and 
foreground rendering modes and options, lighting options, Renderworks background, 
light overrides and Renderworks styles). Other Properties refers to the remaining 
viewport options such as view, projection, scale, and advanced properties. Viewport 
attributes can be transferred between files; class, layer, and other resources specified in 
an attribute override are resolved by the name of the class, layer, or resource, 
respectively. 

Other Attributes
Record Transfers the database record attributes
Plug-in Parameters Transfers plug-in parameters between plug-in objects, including objects inserted in 

walls
Class Selects the class for transfer (makes the target object the same class as the source object)
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4. Click Pick Up Attributes from the Tool bar.
The cursor changes to an eyedropper.

5. Click the object that is the source of the attributes.
6. Click Apply Attributes from the Tool bar.

The cursor changes from an eyedropper to a paint bucket.
7. Click the target object for the attributes.

The attributes are transferred to the object.

To transfer attributes between files, the target objects, classes, records, textures, and other attributes must already 
be present in the target file. The Eyedropper tool does not create objects or attributes.
Click here for a video tip on this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
The Attributes Palette
Managing Saved Settings

Managing Saved Settings
If you have saved attributes to use with the Eyedropper tool, use the Manage button on the Eyedropper Preferences 
dialog box to rename or delete these saved settings when needed.

To manage saved settings for the Eyedropper tool:

1. Select the Eyedropper tool from the Basic tool palette, and then click Preferences on the Tool bar. The 
Eyedropper Preferences dialog box opens.

2. Click Manage.
The Saved Settings dialog box opens. Select the set of saved attributes to change.

Click to show/hide the parameters.

IFC Data (Vectorworks 
Architect or Landmark 
required)

Transfers IFC data to another object, while preserving unique IFC identifiers. If the 
object receiving the data does not yet have a unique identifier, it is automatically 
created.

Pick Up Sets Defaults Changes the default Attributes palette settings to match those of the source object; 
objects created from then on use the attributes of the source object

Use Class Attributes Transfers the “by-class” settings of the source object, provided the target object is in the 
same class as the source object

Object Opacity Transfers an object’s opacity setting

Parameter Description

Click source object for 
attributes

Click target object for 
attributes

The attributes are 
transferred

http://www.youtube.com/watch?v=Ds9CDQR5hnQ
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3. Click OK to close the Saved Settings dialog box. Click OK again to close the Eyedropper Preferences dialog box.
~~~~~~~~~~~~~~~~~~~~~~~~~
Transferring Attributes

Fill Attributes
Objects can be filled with a solid color, pattern (with foreground and background colors), hatch, tile, gradient, or image. 
Alternatively, set the object fill to None to create transparent objects with no fill.
Hatch, tile, gradient, and image fills can be customized to suit the object to which they are applied. The Attributes 
palette displays a button for each of these fills to open a settings dialog box for customizing the fill. In addition, you can 
use the Attribute Mapping tool to edit the size, position, and angle of an associative hatch, tile, gradient, or image fill 
that has been applied to an object (see “Mapping Fills with the Attribute Mapping Tool” on page 1123).

Parameter Description

Rename Select and enter a new name for the set of attributes. If the entered name is already assigned to 
another set of attributes, you are prompted to confirm that you want to replace the existing set 
with the set being saved.

Delete Select to delete the set of attributes. You are prompted to confirm that you want to delete the 
saved settings.

Fill Style Description

None No fill is applied
Solid Applies a solid fill to the selected object(s); click the color box to select the fill color. To set the color 

by class, select the Color by Class option from the color palette.
Pattern Applies a pattern fill to the selected object(s); click the pattern box to select the desired pattern, and 

then select the foreground color and background color from the color boxes next to the pattern. To set 
the pattern colors by class, select the Color by Class option from the color palette.
To create custom patterns for this file, see “Creating Custom Patterns for Fill and Pen Styles” on 
page 1099.

Hatch Applies a hatch fill to the selected object(s). Select the desired hatch from either the default content 
or the current file’s content (see “Resource Libraries” on page 219). If there are no hatches defined in 
the document and default content is not enabled, you are prompted to add a default hatch definition.
To customize the hatch fill for the selected object(s), click the Fill Hatch Settings button).

If the fill of the selected object has been edited, the fill name is highlighted in blue and “(local 
map)” is appended to the name.

For more information about how to create, edit, and customize hatches, see “Using Hatch Fills” on 
page 1104.
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~~~~~~~~~~~~~~~~~~~~~~~~~
The Attributes Palette
Creating Custom Patterns for Fill and Pen Styles

Creating Custom Patterns for Fill and Pen Styles
There are 72 patterns available to use as a fill or pen style in the Attributes palette. You can customize patterns 36 
through 71; patterns 0 through 35 cannot be edited. Customizations are saved with the file.
To reuse the custom patterns in other files, save the file as a template file. See “Creating Templates” on page 75 for 
more information.
To customize the patterns available in the current file:

1. Select File > Document Settings > Patterns.
The Edit Patterns dialog box opens. Patterns 36 through 71 can be selected from the list; select a pattern and edit it 
as desired.

Tile Applies a tile fill to the selected object(s). Select the desired tile fill from either the default content or 
the current file’s content (see “Resource Libraries” on page 219). If there are no tiles defined in the 
document and default content is not enabled, you are prompted to add a default tile definition.
To customize the tile fill for the selected object(s), click the Fill Tile Settings button.

If the fill of the selected object has been edited, the fill name is highlighted in blue and “(local 
map)” is appended to the name.

For more information about how to create, edit, and customize tiles, see “Using Tile Fills” on 
page 1111.

Gradient Applies a gradient fill to the selected object(s). Select the desired gradient from either the default 
content or the current file’s content (see “Resource Libraries” on page 219). If there are no gradients 
defined in the document and default content is not enabled, you are prompted to add a default 
gradient definition.
To customize the gradient fill for the selected object(s), click the Fill Gradient Settings button.
For more information about how to create, edit, and customize gradients, see “Using Gradient Fills” 
on page 1115.

Image Applies an image fill to the selected object(s). Select the desired image from either the default 
content or the current file’s content (see “Resource Libraries” on page 219). If there are no images 
defined in the document and default content is not enabled, you are prompted to import an image 
definition.
To customize the image fill for the selected object(s), click the Fill Image Settings button.
For more information about how to create, edit, and customize images, see “Using Image Fills” on 
page 1119.

Class Style The selected object(s) takes on the fill attribute set by the object’s class.
• If Use at Creation is enabled for the object’s class, the object’s fill style is automatically set by the 

class. 
• If Use at Creation is disabled for the class, the object only takes on the class style when the Class 

Style option is selected. 
See “Setting Class Attributes” on page 181.

Fill Style Description
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Click to show/hide the parameters.

2. When all edits are complete, click OK to save the customized patterns. The edited patterns are available from the 
Fill Pattern and Pen Pattern boxes on the Attributes dialog box, for the current file only.

~~~~~~~~~~~~~~~~~~~~~~~~~
Fill Attributes
Pen Attributes
Creating Templates

Pen Attributes
Pen attributes apply to object outlines, and can be a solid or pattern line of any thickness and color. Alternatively, apply 
a standard or custom line type, to add graphic elements to a line. Line types are resources that can include dashes, text, 
or any 2D object.

To apply color to text objects, select the Solid pen style, and set the appropriate color.
For more information about using color boxes in the Attributes palette, see “Applying Colors” on page 1132.

 

Parameter Description

Pattern Select a pattern to edit from the Pattern list, and then click in the editing box on the left to add and 
delete pixels; the edits display in the preview window to the right of the editing box

Revert Restores the pattern to its original settings (you must click this before you select another pattern or 
click OK)

Pen Style Description

None No pen is applied
Solid Applies a solid pen style to the selected object(s); click the color box to select the pen color. To set 

the color by class, select the Color by Class option from the color palette.
Select the line thickness for the pen from the Line Thickness list. To create custom line thicknesses 
for this file, see “Creating Custom Thicknesses for Lines” on page 1102.

Pattern Applies a patterned pen style to the selected object(s); click the fill pattern box to select the desired 
pattern, and then select the foreground color and background color from the color boxes next to the 
pattern. To set the pattern colors by class, select the Color by Class option from the color palette.
To create custom patterns for this file, see “Creating Custom Patterns for Fill and Pen Styles” on 
page 1099.

Line Type Applies a line type resource to the selected object(s). Click the color box to select the pen color. To 
set the color by class, select the Color by Class option from the color palette. Select the desired 
thickness from the Line Thickness list.
To create line type resources for this file, see “Using Line Types” on page 1128.

Class Style The object(s) takes on the pen attribute set by the object’s class. 
• If Use at Creation is enabled for the object’s class, the object’s pen style is automatically set by 

the class. 
• If Use at Creation is disabled for the class, the object only takes on the class style when the Class 

Style option is selected.
See “Setting Class Attributes” on page 181.
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~~~~~~~~~~~~~~~~~~~~~~~~~
The Attributes Palette
Creating Custom Patterns for Fill and Pen Styles
Creating Custom Thicknesses for Lines
Using Line Types
Applying Colors

Opacity Attributes
In addition to the overall layer opacity settings described in “Setting the Design Layer Opacity” on page 168, an 
opacity setting is available for individual objects. Opacity can be applied to any type of 2D object, including planar 
objects, 2D walls, text, worksheet backgrounds, and plug-in objects that include a 2D object.

If layer opacity is set in addition to object opacity, the results are additive; for example, a layer opacity of 50% and 
an object opacity of 50% will display the object at 25% opacity. Similarly, the opacity settings of nested and 
container objects are combined.

This feature is available on all Mac systems and on Windows systems that have the GDI+ imaging Vectorworks 
preference enabled. See “Vectorworks Display Preferences” on page 50.
To set the opacity of a 2D object:

1. Select the object(s) and click the Opacity button on the Attributes palette to open the Set Opacity dialog box.
2. Drag the Opacity slider to the left to decrease the opacity, or enter an opacity percentage (0-100) to the right of the 

slider. Alternatively, select Use Class Opacity to use the opacity value set by the object’s class.
If Use at Creation is enabled for the object’s class, the object’s opacity is automatically set by the class. If Use at 
Creation is disabled for the class, the object only takes on the class style when the Use Class Opacity option is 
selected. Class opacity can be overridden in viewports.

3. If desired, click Preview to view the results of the opacity setting.
4. Click OK to apply the opacity setting.

The opacity setting applies to 2D objects only. For a similar effect in 3D, a transparency shader can be applied with the 
Renderworks product (see “Textures and Shaders” on page 1505).
~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Class Properties
Drawing Straight Walls
The Attributes Palette

Line Thickness Attributes
Line thickness attributes apply to the pen style of an object. Apply line thickness attributes to 2D and 3D objects.
From the Attributes palette, select the line thickness from the Line Thickness list.
To add, remove, or edit the available line thickness values, select Tools > Options > Line Thickness. See “Creating 
Custom Thicknesses for Lines” on page 1102 for more information. To temporarily adjust the current line thickness 
setting, click Set Thickness from the Line Thickness list. The Set Thickness dialog box opens; select the Thickness 
Units, enter the Thickness Value, and click OK. 
Select Class Thickness to use the line thickness attributes set by the object’s class (see “Setting Class Attributes” on 
page 181).

• If Use at Creation is enabled for the object’s class, the object’s line thickness is automatically set by the class.
• If Use at Creation is disabled for the class, the object only takes on the class thickness when the Class Thickness 

option is selected. 
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Custom Thicknesses for Lines
Marker Attributes
The Attributes Palette

Creating Custom Thicknesses for Lines
You can customize the set of line thicknesses available from the Line Thickness list on the Attributes palette. The 
edited thicknesses are saved with your user preferences, so they are available from one Vectorworks session to the next.
To create custom line thicknesses for the Attributes palette:

1. Select Tools > Options > Line Thickness.
The Preferred Line Thickness dialog box opens. Select the preferred line thickness criteria.

Click to show/hide the parameters.

2. When all edits are complete, click OK to save the customized set of line thicknesses.
~~~~~~~~~~~~~~~~~~~~~~~~~
Using Line Types
Marker Attributes
Pen Attributes
The Attributes Palette

Marker Attributes
You can apply line start and line end markers to open objects, including lines, arcs, polylines, 2D polygons, and 
freehand lines. You can also apply line end markers to the leader lines on callout and dimension objects. Dimensions 
have other default markers assigned as part of the dimension standard setup, but these cannot be applied or removed 
through the Attributes palette.
In the Attributes palette, click the Line Start Marker Toggle button, the Line End Marker Toggle button, or both 
buttons to specify the end(s) to receive the displayed marker. When a marker is applied to an object, the toggle button is 
highlighted. To always use the same style for both ends of the object, also click the Marker Link Toggle button; 
whenever the marker style of one end is changed, the other end’s marker style automatically changes to match.
To switch to a different marker style, click Line Startpoint Style or Line Endpoint Style. Select a marker style from 
the list, or click Edit Marker List to create a new style. See “Editing the Marker List” on page 1103 for more 
information.
Select Class Style to use the marker attributes set by the object’s class.

Parameter Description

Units Select the Units to be used for the thickness of the edited line
New Enter the new thickness value to replace the current thickness value listed to its left

Select a
line thickness

Click to temporarily set the
current line thickness Click to apply the 

line thickness 
according to the 
object’s class
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• If Use at Creation is enabled for the object’s class, the object’s marker style is automatically set by the class.
• If Use at Creation is disabled for the class, the object only takes on the class style when the Class Style option is 

selected. 
See “Setting Class Attributes” on page 181.

Editing the Marker List
You can customize the set of markers available from the Line Startpoint Style and Line Endpoint Style settings on the 
Attributes palette. The edited markers are saved with your user preferences, so they are available from one Vectorworks 
session to the next.
To edit the marker list:

1. Select Tools > Options > Edit Marker List.
The Edit Marker List dialog box opens.

Click to show/hide the parameters.

Parameter Description

Current Marker 
Types

Lists the marker types that are available for selection when drawing; change the list order by 
clicking and dragging in the # column

New Creates a new marker type
Edit Edits the currently selected marker type
Delete Deletes the currently selected marker

A check mark indicates 
the active marker style

Click to select the marker style for
the object’s startpoint (left button)

and endpoint (right button)

Click to link the startpoint
and endpoint styles

Each marker type displays its 
style, length, width, angle, and 
thickness settings

Click to apply the active
marker style to the object’s

startpoint (left button)
and endpoint (right button)
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2. Click OK to save the list of available marker types.

Creating or Editing Marker Types
To create or edit marker types:

1. From the Edit Marker List dialog box, click New to create a new marker type, or click Edit to change the currently 
selected marker type.
The Edit Marker dialog box opens.

Click to show/hide the parameters.

2. Click OK to create or edit the marker.
The new marker is listed at the top of the marker types list.
Click here for a video tip on this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating or Editing Marker Types
Using Line Types
The Attributes Palette

Using Hatch Fills
Hatches can be applied to 2D planar and screen objects and walls (wall hatches are only visible in Top/Plan view).
There are two types of hatches: associative and non-associative. The appearance of both types of hatches are 
determined by hatch pattern definitions.

Parameter Description

Preview Displays a preview of the marker’s appearance
General Options Specifies the marker’s shape and style

Root Type Specifies the general shape of the marker
Fill For closed root types, specifies the type of fill
Base For triangular root types, specifies the shape of the base
Angle For triangular and hexagonal root types, indicates the angle of the root
Length Indicates the length of the marker, from base to tip
Width Specifies the marker width, for marker types that have a width
Half Tick For marker types except cone and lasso, displays half the marker on the indicated side
Tail For markers which can be reversed, flips the marker direction to create a tail marker

Thickness Options Specifies the marker pen thickness
Use Line Thickness Uses the same thickness as that of the associated line, adjusting automatically along 

with any line thickness changes
Use Dimension Slash 
Thickness

Uses the same thickness as the dimension slash, set on the Dimensions tab of the 
document preferences (see “Dimension Preferences” on page 61)

Use Custom Thickness Specifies a custom marker thickness and unit (mils, points, or millimeters)

http://www.youtube.com/watch?v=gwW0FlQcsIs
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Associative Hatches
Associative hatch fills are resources; you can select them from the default content in the Attributes palette (see 
“Resource Libraries” on page 219), or you can create or import custom resources and apply them from the Resource 
Browser (see “Accessing Existing Resources” on page 229).
There are two ways to customize the hatch to suit the object to which it is applied; use either the Fill Hatch Settings 
button in the Attributes palette, or use the Attribute Mapping tool to move, rotate, or scale the hatch (see “Mapping 
Hatch and Tile Fills” on page 1123).
Associative hatches can be specified as a default class attribute (see “Setting Class Properties” on page 179).

Non-associative Hatches
Non-associative hatches are placed on objects or areas of the drawing with the Hatch command. They obtain most of 
their attributes from hatch pattern definitions, but they do not use the color definitions for the lines that make up the 
hatch. Non-associative hatches obtain the color definitions from the current default attributes. They do not use any 
background definitions, and therefore have no background color. A non-associative hatch is similar to a screen that 
displays over other objects; the spaces between the lines are empty, and display portions of any objects behind the 
hatch.
Non-associative hatches are placed inside an area that is defined by selected objects or lines. The start point of the 
hatch is set with the Hatch command. Unlike associative hatches, non-associative hatches can be moved to another 
area or object. However, unless the new area is the same shape and size as the previous one, the pattern will not fit.
Non-associative hatches are groups that are not associated with an object. They do not rotate with the object or act like 
a fill. They can be broken down into their individual elements with the Ungroup command. For a non-associative 
hatch to become part of an object, it must be grouped with the object.
~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Hatches
Applying Associative Hatches
Applying Non-Associative Hatches
Editing Hatch Definitions
Mapping Hatch and Tile Fills
Fill Attributes

Defining Hatches
Both associative and non-associative hatches must be defined. A hatch definition is a repetition of the elements in a 
series of lines in all directions from the beginning point. Specify where the hatch line begins (the Start Point), where it 
stops (the Dash Factor), where it begins to repeat (the Repeat), and the distance separating the line from a neighboring 
line (the Offset); the pattern is repeated in all directions.
A hatch can consist of several levels, or layers, of pattern definitions. Each level is edited individually to create the 
overall hatch. (Hatch layers are named hatch levels in order to distinguish them from the layers in the drawing area.)
A new hatch can be created by editing an existing hatch; see “Editing Hatch Definitions” on page 1111.
To create a new hatch pattern definition:

1. Open the Resource Browser by selecting Window > Palettes > Resource Browser.
2. Select Resources > New Resource to display the list of new resource types.
3. Select Hatch.

The Edit Hatch dialog box opens.
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Click to show/hide the parameters.

Parameter Description

Name Enter a name for the hatch; this name identifies the hatch in the Resource Browser and in the 
Select Hatch dialog box (Modify > Hatch)

Active Select the active hatch level from the list. A level can also be selected by clicking on one of its 
pattern lines, or by using the keyboard right and left arrow keys. Levels are numbered in the order 
of creation. 

Cursor Switches between the pointer and pan functions. The pointer adjusts the four control handles in 
the hatch window. The pan moves the elements of the hatch around the preview window.

Zoom Zooms in and out by a factor of two. The center of the view remains at its current coordinates. 
The current zoom ratio is also displayed. The initial zoom setting when the dialog box opens 
corresponds to the best setting for editing Level 1.

View Select whether to view All Levels or only the Active Level; click Center to center the start point 
of the active level

Units Switches between Page and World settings for the hatch. Page is absolute in screen coordinates, 
where one inch in the hatch equals one inch on the screen (at 100% zoom). World sets the hatch 
to use the unit values for the layer where the hatch will be placed; for example, one inch in the 
hatch equals one inch in the drawing area as defined by the rulers (this may not equal one inch on 
the screen depending on the unit setting). When switching between Page and World, the hatch 
settings are adjusted for all levels to preserve the hatch appearance.

Rotate Select whether to rotate the hatch to match the orientation of any symbols or walls where it will 
be placed

Snap Radius Set the snap radius for snapping to the end points and mid points of pattern lines when moving a 
line by dragging
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The Start Point, Repeat, Dash Factor, and Offset functions correspond to the four control handles in the preview 
window. When a handle is moved, the corresponding function’s values change to reflect the move. The Shift key 
constrains the drag when using the control handles, affecting each of the four functions differently.
For the Start Point, Repeat, and Offset parameters, enter values according to either the polar coordinate system 
or the Cartesian system. The text box labels for these four controls change to correspond to the selection of 
Cartesian or polar.

Pen color Sets the color for the active level hatch lines; click the color box to select a color. Click Unique 
Colors to set a unique color for each level; click Same Color to apply the active level color 
selection to all levels.

Pen line weight Sets the hatch line weight for the current level. Click the line to select a weight from the list. 
Create a custom weight by selecting Set Thickness. The Set Thickness dialog box opens. Enter 
the Thickness Value and Thickness Units. Click Same Thickness to apply the active level line 
thickness to all levels.

Start Point Controls the location of the start of the first hatch line in relation to the hatch origin for the active 
level. The default mode uses polar coordinates (L = distance, A = angle). Enter values or move 
the Start Point handle in the preview window.

Repeat Sets the distance, for the active level, between the beginning of a segment and the beginning of 
the next collinear segment. Repeat directly relates to the Dash Factor, with the two determining 
if the line is dashed or solid, as well as the length of the dashes and line segments. The default 
mode uses polar coordinates (L = distance, A = angle). Enter values or move the Repeat handle in 
the preview window.

Dash Factor Represents, for the active level, the percentage of the distance between the Start Point and the 
Repeat that is shown as a line. Set to 1 to create a solid line. Enter a value or move the Dash 
Factor handle in the preview window.

Offset Determines the distance and direction between lines for the active level. The values entered are 
relative to the Start Point. The default mode uses polar coordinates (L = distance, A = angle). 
Enter values or move the Offset handle in the preview window.

Sketch Style For Vectorworks Design Series products, specifies a hatch sketch style; see “Applying Sketch 
Styles to Hatches” on page 1501

Background 
Fill

Select to use a background color and click the color box to select a color; background color 
applies only to associative hatches

Add/Remove 
Level

Click Add Level to create an offset duplicate of the active level. Alternatively, create a duplicate 
level by clicking and dragging the Start Point handle with the Option (Mac) or Alt (Windows) 
key. Click Remove Level to remove the active level.

Scale Opens the Scale Hatch Definition dialog box. Enter a Scaling Factor to change the hatch 
definitions for the active level (except for the Dash Factor value, which remains unchanged). 
Select Apply to All Levels to change the scale factor for all levels.

Undo The last five actions can be undone by clicking Undo
Redo Click to redo the last action that was undone. Must be clicked directly after an action was undone. 

Appears dimmed when there are no actions to undo.
Revert Returns the hatch definition to its status at the time the Edit Hatch dialog box was opened

Parameter Description
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4. Click OK. The new hatch definition is saved under the specified name.

Example: Creating a Brick Hatch
The following Edit Hatch values demonstrate how to create a brick pattern. The hatch requires two levels. The bricks 
will be 8”x 3” and the first set of lines will be the vertical components of the bricks. This procedure creates a hatch that 
scales appropriately when it is placed into a drawing.
All values are entered in World units and Cartesian mode.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Associative Hatches
Applying Non-Associative Hatches
Editing Hatch Definitions

Applying Associative Hatches
Apply hatches to specific objects using either the Attributes palette or the Resource Browser. Some objects have the 
ability to apply hatch settings while setting the object attributes.

Attributes can also be applied by class settings (see “Setting Class Attributes” on page 181) or transferred with the 
Eyedropper tool (see “Transferring Attributes” on page 1095).

Applying a Hatch from the Attributes Palette
To apply an associative hatch from the Attributes palette and specify the hatch settings:

1. Select the object(s), and then select Hatch from the Attributes palette fill list.

Coordinate System Description

Cartesian Cartesian coordinates are the same as those used in the drawing area, with positive and 
negative X and Y axes

Polar Defines the different hatch line segments by length and angle values. In polar mode, angles 
are represented as positive or negative values from 0 to 180. Values from 180 to 359 are 
automatically converted to negative. 0 is at the 3 o’clock position.

Parameter Level 1 Values Level 2 Values

Start Point X = 0, Y = 0 X = 0, Y = 0
Repeat X = 0, Y = 6 X = 2, Y = 0
Dash Factor 0.5 1
Offset X = 4, Y = 3 X = 0, Y = 3
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If no hatches are defined, and default content is not enabled in Vectorworks preferences, you are prompted to add 
a default hatch definition.

2. To change to a different hatch, click on the hatch list and select a different hatch from the list of default content or 
the current file’s content (see “Resource Libraries” on page 219).

3. To specify the settings for the current hatch, click the Fill Hatch Settings button next to the Fill Hatch list.
The Hatch Settings dialog box opens.

Click to show/hide the parameters.

4. If desired, click Preview to view the results of the fill settings.
5. Click OK to apply the fill settings.

Applying a Hatch from the Resource Browser
To apply an associative hatch from the Resource Browser:

1. Select the object(s).

Parameter Description

Hatch selector Select a hatch resource from either the default content or the current file’s content
Use Local Mapping Select to enable entry in the mapping fields, to customize the fill for this object; deselect to 

return to the default fill mapping.
The Attribute Mapping tool is an alternate way to create a local mapping; if an object’s fill 
is edited with the Attribute Mapping tool, the changes are reflected on this dialog box. 
Conversely, edits made on this dialog box are reflected in the position, size, and rotation of 
the mapping tool’s editing object.
By default, a hatch fill does not rotate with the filled object; select Use Local Mapping to 
keep the fill’s orientation relative to the object.

X/Y Offset Indicates the fill starting point coordinates relative to the center of the selection bounding 
box (in the file’s current units)

I/J Length Specifies the distance in the I/J direction for a single instance of the fill (in the file’s current 
units).
To maintain the aspect ratio of the fill when one length is changed, click the link button; the 
other length value changes automatically.

Rotation Specifies the angle of the fill
Flip Horizontally/
Flip Vertically

Select to flip the fill orientation horizontally, vertically, or both

Fill Hatch 
settings

Fill Hatch
list
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2. From the Resource Browser, select the resource to be applied. Right-click (Windows) or Ctrl-click (Mac) and 
select Apply from the context menu. (Alternatively, double-click the resource to apply it to the selection or drag 
the resource onto an object.)
The fill settings can be edited from the Attributes palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Transferring Attributes
Using Hatch Fills
Defining Hatches
Applying Non-Associative Hatches
Editing Hatch Definitions
Mapping Hatch and Tile Fills

Applying Non-Associative Hatches
To apply a non-associative hatch:

1. Select the object(s).
2. Select Modify > Hatch.

The Hatches dialog box opens.
Click to show/hide the parameters.

3. Select the hatch to apply from the Hatches list.
A preview of the hatch is displayed.

4. Click OK to return to the drawing area.
The cursor changes to a paint bucket.

5. Position the paint bucket on the object where the hatch should begin. Click to specify the hatch origin. Drag to 
specify the hatch orientation and click again.
The hatch fills the space from the paint bucket’s location to the boundary created by the object.
When a hatch is being applied to an object, the tip of the paint from the paint bucket marks the hatch origin. The 
hatch start point within the object can be precisely specified.

Parameter Description

Hatches list Lists the available hatches from the default content, the current file’s content, or from a 
referenced file (referenced hatches display in italics)

Hatch preview Displays a preview of the selected hatch at 100% zoom
New Opens the Edit Hatch dialog box, for creating a new hatch
Edit Opens the Edit Hatch dialog box, for editing or renaming an existing hatch
Duplicate Creates a copy of the selected hatch (button is disabled if referenced hatches are present) 
Delete Deletes the selected hatch
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~~~~~~~~~~~~~~~~~~~~~~~~~
Using Hatch Fills
Defining Hatches
Applying Associative Hatches
Editing Hatch Definitions

Editing Hatch Definitions
Changes to a hatch definition affect all associative instances of that hatch in the drawing file. Non-associative hatches 
are not affected.
To edit a hatch definition:

1. Select Window > Palettes > Resource Browser.
The Resource Browser opens.

2. Select the desired hatch. Right-click (Windows) or Ctrl-click (Mac), and select Edit from the context menu.
Alternatively, select a drawing object, select Modify > Hatch, and click Edit for the selected hatch in the Hatches 
dialog box.
The Edit Hatch dialog box opens.

3. Edit the hatch as described in “Defining Hatches” on page 1105.
4. Click OK to return to the drawing area.

Any associative instance of the edited fill in the drawing file changes according to the new definition.
~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Hatches
Applying Associative Hatches
Applying Non-Associative Hatches
Mapping Hatch and Tile Fills

Using Tile Fills
Tile fills are resources; you can select them from the default content in the Attributes palette (see “Resource Libraries” 
on page 219), or you can create or import custom resources and apply them from the Resource Browser (see 
“Accessing Existing Resources” on page 229).
There are two ways to customize the fill to suit the object to which it is applied; use either the Fill Tile Settings button 
in the Attributes palette, or use the Attribute Mapping tool to move, rotate, or scale the tile.
Tile fills can be applied to any type of 2D planar or screen object that accepts a fill, including walls (wall tiles only 
display in Top/Plan view), text boxes, worksheet backgrounds, and plug-in objects that include a 2D object.

Select the object After selecting the hatch, click the cursor 
at the desired insertion point. The hatch 
can be rotated during insertion.

Click again to place the 
hatch once it is oriented
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Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Tiles
Applying Tiles
Editing Tile Definitions
Mapping Hatch and Tile Fills
Fill Attributes
Transferring Attributes

Defining Tiles
A tile is a set of 2D geometric elements that repeats in all directions from a center point. The geometric elements can 
have color or fill (but not a tile fill), and the tile can also have a background color.
To create a tile definition:

1. Open the Resource Browser by selecting Window > Palettes > Resource Browser.
2. Select Resources > New Resource to display the list of new resource types.
3. Select Tile.

The New Tile dialog box opens.
Click to show/hide the parameters.

Parameter Description

Name Specifies a name for the tile resource; this name is displayed in the Resource Browser and 
Attributes palette

Units Specifies the units for the tile when it is used in a drawing:
• Page sets the tile size according to the page dimensions. When applied, the tile automatically 

scales relative to the page environment. This is useful for annotation objects that should 
always remain the same size on the “page,” regardless of the layer scale.

• World sets the tile size according to world dimensions; its size varies depending on the layer 
scale.

Rotate Rotates the tile fill according to the axis of any wall or symbol to which it is applied
In Wall Matches the tile rotation to the wall axis; select Fit to Wall to scale the tile fill to match the 

thickness of a wall, wall component, or slab component.
Enable the Fit to Wall option for insulation fills in walls, and wall or slab components.

In Symbol Matches the tile rotation to the symbol axis
Background Fill To have a background fill behind the tile geometry, select the Background Fill option and also 

specify a color.

http://www.youtube.com/watch?v=tPhH59belio
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4. Click OK to open a tile editing window. Draw the tile geometry with the desired colors and fills. When you create 
an object, eight partially transparent repetitions of the object display around it. You can add multiple objects to the 
pattern.

5. To adjust the tile pattern and spacing, click one of the repetitions and drag it as needed; click again to set the new 
position. To hide the tile repetitions during editing, Ctrl-click (Mac) or right-click (Windows) on an empty area of 
the editing window, and deselect the Display Tile Repetitions option on the context menu.

6. When you are done drawing the tile, click Exit Tile. The tile resource is saved with the specified name.
Tiles are saved in Vectorworks drawing files. If the file is not saved and the tile is not default content, the tile is 
lost when you exit the program.

~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Tiles
Editing Tile Definitions
Mapping Hatch and Tile Fills

Applying Tiles
Apply tiles to specific objects using either the Attributes palette or the Resource Browser. Some objects have the ability 
to apply tile settings while setting the object attributes.

Attributes can also be applied by class settings (see “Setting Class Attributes” on page 181) or transferred with the 
Eyedropper tool.

Applying a Tile from the Attributes Palette
To apply a tile from the Attributes palette and specify the tile settings:

1. Select the object(s), and then select Tile from the Attributes palette fill list.
If no tiles are defined, and default content is not enabled in Vectorworks preferences, you are prompted to add a 
default tile definition.

Click and drag one of the 
semi-transparent editing groups 
(a red box indicates the selected 
group) to modify the tile pattern, 
and click again to set the position

The objects you draw are 
opaque and are edited 
individually
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2. To change to a different tile, click on the tile list and select a different tile from the list of default content or the 
current file’s content (see “Resource Libraries” on page 219).

3. To specify the settings for the current tile fill, click the Fill Tile Settings button next to the Fill Tile list.
The Tile Settings dialog box opens.

Click to show/hide the parameters.

4. If desired, click Preview to view the results of the fill settings.
5. Click OK to apply the fill settings.

Applying a Tile from the Resource Browser
To apply a tile from the Resource Browser:

1. Select the object(s).
2. From the Resource Browser, select the resource to be applied. Right-click (Windows) or Ctrl-click (Mac) and 

select Apply from the context menu. (Alternatively, double-click the resource to apply it to the selection or drag 
the resource onto an object.)
The fill settings can be edited from the Attributes palette.

Parameter Description

Tile selector Select a tile resource from either the default content or the current file’s content
Use Local Mapping Select to enable entry in the mapping fields, to customize the fill for this object; deselect to 

return to the default mapping.
The Attribute Mapping tool is an alternate way to create a local mapping; if an object’s 
fill is edited with the Attribute Mapping tool, the changes are reflected on this dialog box. 
Conversely, edits made on this dialog box are reflected in the position, size, and rotation of 
the mapping tool’s editing object.
By default, a tile fill does not rotate with the filled object; select Use Local Mapping to 
keep the fill’s orientation relative to the object.

X/Y Offset Indicates the fill starting point coordinates relative to the center of the selection bounding 
box (in the file’s current units)

I/J Length Specifies the distance in the I/J direction for a single instance of the fill (in the file’s current 
units).
To maintain the aspect ratio of the fill when one length is changed, click the link button; the 
other length value changes automatically.

Rotation Specifies the angle of the fill
Flip Horizontally/
Flip Vertically

Select to flip the fill orientation horizontally, vertically, or both

Fill Tile 
settings

Fill Tile list
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~~~~~~~~~~~~~~~~~~~~~~~~~
Transferring Attributes
Defining Tiles
Editing Tile Definitions
Mapping Hatch and Tile Fills

Editing Tile Definitions
Changes to a tile definition affect all instances of that tile in the drawing file.
To edit a tile definition:

1. Select Window > Palettes > Resource Browser.
The Resource Browser opens.

2. Select the desired tile. Right-click (Windows) or Ctrl-click (Mac), and select Edit from the context menu.
3. The Edit Tile dialog box opens; select whether to edit the Geometry or Settings.

• If you edit the settings, the Edit Tile Settings dialog box opens next.
• If you edit the geometry, the tile editing window opens next to allow editing of the tile components.

4. Adjust the tile definition as described in “Defining Tiles” on page 1112.
5. Any instance of the edited fill in the drawing file changes according to the new definition.

~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Tiles
Applying Tiles
Mapping Hatch and Tile Fills

Using Gradient Fills
Gradient fills are resources; you can select them from the default content in the Attributes palette (see “Resource 
Libraries” on page 219), or you can create or import custom resources and apply them from the Resource Browser (see 
“Accessing Existing Resources” on page 229).
Gradients can be applied to any type of 2D planar or screen object that accepts a fill, including walls (wall gradients 
only display in Top/Plan view), text boxes, worksheet backgrounds, and plug-in objects that include a 2D object.
~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Gradients
Applying Gradients
Editing Gradient Definitions
Mapping Gradient Fills
Fill Attributes
Transferring Attributes

Defining Gradients
A gradient is a set of two or more colors that blend smoothly into one another, or into a different opacity. Gradients are 
defined and stored in the Resource Browser.
To create a gradient definition:

1. Open the Resource Browser by selecting Window > Palettes > Resource Browser.
2. Select Resources > New Resource to display the list of new resource types.
3. Select Gradient.
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The Gradient Editor dialog box opens. Specify a name for the gradient resource, and select the segment starting 
and ending colors and their opacity settings. Gradients can consist of several segments and more than two colors. 
To create a gradient with more than two colors, click in the color spot area. This adds a color spot and midpoint to 
the gradient. Each color spot has an opacity value.
Specify the location of a selected color spot or midpoint by dragging it into position, or entering its position in the 
Position field.

Click to show/hide the parameters.

4. Click OK to save the gradient resource with the specified name.
Gradients are saved in Vectorworks drawing files. If the file is not saved and the gradient is not default content, the 
gradient is lost when you exit the program.
~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Gradients
Editing Gradient Definitions
Mapping Gradient Fills

Parameter Description

Name Specifies a name for the gradient resource; this name is displayed in the Resource Browser and 
Attributes palette

Midpoint Point between two colors where each color/opacity is of equal intensity; a midpoint is 
associated with the color spot to its left. By default, the midpoint is placed equidistant between 
two color spots; but it can be dragged to another location.

Gradient Preview Displays the gradient in a preview bar
Color Spot Specifies the starting or ending color and opacity of each gradient segment. To specify the 

color, double-click on a color spot, or select a color spot and click Color. To add a new 
gradient segment, click in an empty location in the color spot area. A new color spot and 
midpoint are created. Drag a color spot to a new location in the color spot area; its associated 
color/opacity is retained. Remove a color spot and its associated midpoint by selecting the 
color spot dragging it from the color spot area.

Color Specifies the color of the selected color spot; click to select the color
Opacity For the selected color spot, drag the slider to the left to decrease the opacity, or enter an opacity 

percentage (0 – 100) to the right of the slider. A gray checkerboard pattern is revealed in the 
Gradient Preview as the opacity decreases.

To create an opacity gradient for a single color, specify the same color for all color spots 
and set the color spots to different opacities.

Position Indicates the position (0.0 – 1.0) of the selected color spot or midpoint; the midpoint position 
is relative to its location between two adjacent color spots

Gradient 
segment

Midpoint

Color spot
Gradient preview

Color spot area
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Applying Gradients
Gradient settings are specified through the Attributes palette and applied to 2D planar and screen objects through the 
Resource Browser or the Attributes palette. In addition, a gradient fill can be specified as a default class attribute (see 
“Setting Class Properties” on page 179). Some objects have the ability to apply gradient settings while setting the 
object attributes.

Applying a Gradient from the Attributes Palette
To apply a gradient resource from the Attributes palette and specify the gradient settings:

1. Select the object(s), and then select Gradient from the Attributes palette fill list. To change to a different gradient, 
click on the gradient preview and select a different gradient from the list of default content or the current file’s 
content (see “Resource Libraries” on page 219).

2. Specify the settings for the current gradient by clicking the Fill Gradient Settings button next to the gradient 
preview box.
The Gradient Settings dialog box opens.

Click to show/hide the parameters.

Parameter Description

Gradient selector Select a gradient resource from either the default content or the current file’s content
Repeat Select to repeat the gradient segment(s) over the object; deselect to apply a single instance of 

the gradient segment(s) to the object

Fill gradient 
settings

Gradient
preview

No repeat Repeat
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Apply To Select Each Object to apply the gradient to each selected object individually; choose 
Selection to apply the gradient across the selected objects, spanning the objects.

When applying a gradient across several selected objects, group the objects to retain the effect.
Type Select the gradient type from the list

Linear Applies the gradient to the selection with linear geometry

Radial Applies the gradient to the selection with circular geometry

Rectangular Applies the gradient to the selection with rectangular geometry

Angular Applies the gradient to the selection in a counterclockwise direction from the specified starting 
point

X/Y Offset Indicates the gradient starting point coordinates relative to the center of the selection bounding 
box (in the file’s current units)

Length Specifies the length of a single gradient segment (in the file’s current units)
Rotation Specifies the rotation of the gradient fill
Reverse Select to draw the colors in reverse order from the order specified in the Gradient Editor dialog 

box

Parameter Description

Each Object Selection
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3. If desired, click Preview to view the results of the gradient settings.
4. Click OK to apply the gradient settings.

Applying a Gradient from the Resource Browser
To apply a gradient resource from the Resource Browser:

1. Select the object(s).
2. From the Resource Browser, select the gradient to be applied. Right-click (Windows) or Ctrl-click (Mac), and 

select Apply from the context menu. (Alternatively, double-click the gradient resource to apply it to the selection 
or drag the gradient resource onto an object.)
The fill settings can be edited from the Attributes palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Transferring Attributes
Defining Gradients
Editing Gradient Definitions
Mapping Gradient Fills

Editing Gradient Definitions
Changes to a gradient definition affect all instances of that gradient in the drawing file.
To edit a gradient definition:

1. Select Window > Palettes > Resource Browser.
The Resource Browser opens.

2. Select the desired gradient. Right-click (Windows) or Ctrl-click (Mac), and select Edit from the context menu.
3. Adjust the gradient definition as described in “Defining Gradients” on page 1115.
4. Click OK to return to the drawing area.

Any instance of the edited fill in the drawing file changes according to the new definition.
~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Gradients
Applying Gradients
Mapping Gradient Fills

Using Image Fills
Image fill attributes are resources; you can select them from the default content in the Attributes palette (see “Resource 
Libraries” on page 219), or you can create or import custom resources and apply them from the Resource Browser (see 
“Accessing Existing Resources” on page 229).
Images can be applied to any type of 2D planar or screen object that accepts a fill, including walls (wall images only 
display in Top/Plan view), text boxes, worksheet backgrounds, and plug-in objects that include a 2D object.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Image Resources
Applying Image Resources
Mapping Image Fills
Fill Attributes
Transferring Attributes
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Creating Image Resources
Images resources are imported and stored in the Resource Browser.

You can also import an image directly (not for use as a resource). For example, you might import a sketch or a 
logo graphic into a drawing. See “Importing an Image File” on page 1680 for details.

To import an image for use as an image resource:
1. Open the Resource Browser by selecting Window > Palettes > Resource Browser.
2. Select Resources > New Resource to display the list of new resource types.
3. Select Image.
4. If a resource with an image is already present in the file, the Choose Image dialog box opens.

Click to show/hide the parameters.

5. The Open dialog box is displayed. Select the image file to use as an image resource, and click Open. 
6. If the image is in JPEG format, it is imported immediately. For images not in JPEG format, the Image Import 

Options dialog box opens. Specify the imported image options.
The current image information is displayed at the top, along with the image’s uncompressed size. Two 
compression methods are available; depending on the graphic, one of the methods may be more suitable. The 
compression method which produces the smallest file size is selected by default. Select the desired balance 
between compression and detail display. The resulting file size for each type of compression is displayed to help 
with the selection.
If the selected option results in a file size larger than the uncompressed size, the image is imported uncompressed.

7. Click OK to import the image with the selected compression type. The image resource is saved, by default, with 
the name of the original image file.

Image resources imported into the file that are not in JPEG format can be compressed by JPEG with the Compress 
Images command. See “Compressing Images” on page 1822.
~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Image Resources
Mapping Image Fills

Parameter Description

Import an Image File Imports a new image; click OK and proceed to Step 5.
Reuse an Image from 
Another Resource

Reuses a previously imported image; select the resource that contains the image. Click 
OK and proceed to Step 6.

Compression Method Description

JPEG Provides a high amount of compression, resulting in the smallest Vectorworks file size. 
However, fine detail may be obscured. JPEG compression is most suitable for 
photographic images.

PNG Provides a moderate amount of compression, while preserving image details; an image 
compressed as a PNG can also be imported as a 1-bit monochrome image by selecting 
Import as Black and White

Referencing options 
(Vectorworks Design 
Series required)

Images can be referenced; see “Referencing Resources” on page 213
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Applying Image Resources
Image settings are specified through the Attributes palette and applied to a 2D object through the Resource Browser or 
the Attributes palette. In addition, an image fill can be specified as a default class attribute (see “Setting Class 
Properties” on page 179). Some objects have the ability to apply image settings while setting the object attributes.

Applying an Image from the Attributes Palette
To apply an image resource from the Attributes palette and specify the image settings:

1. Select the object(s), and then select Image from the Attributes palette fill list. To change to a different image, click 
on the image preview bar and select a different image from the list of default content or the current file’s content 
(see “Resource Libraries” on page 219).

2. Specify the settings for the current image by clicking the Fill Image Settings button next to the image preview 
box.
The Image Settings dialog box opens.

Click to show/hide the parameters.

Parameter Description

Image selector Select an image resource from either the default content or the current file’s content
Repeat Select to repeat the image over the object; deselect to apply a single instance of the image 

to the object

Fill image 
settings

Image
preview

No repeat

Repeat
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3. If desired, click Preview to view the results of the image settings.
4. Click OK to apply the image settings.

The X and Y axes are file-based, relative to the center of the selected object(s). The I and J axes are image-based.

Applying an Image from the Resource Browser
To apply an image resource from the Resource Browser:

1. Select the object(s).
2. From the Resource Browser, select the image to be applied. Right-click (Windows) or Ctrl-click (Mac), and select 

Apply from the context menu. (Alternatively, double-click the image resource to apply it to the selection or drag 
the image resource onto an object.) 
The image settings can be edited from the Attributes palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Transferring Attributes
Creating Image Resources
Mapping Image Fills

Apply To Select Each Object to apply the image to each selected object individually; choose 
Selection to apply the image across the selected objects, spanning the objects.

When applying an image across several selected objects, group the objects to maintain the 
image.

X/Y Offset Indicates the image starting point coordinates relative to the center of the selection 
bounding box (in the file’s current units)

I/J Length Specifies the distance in the I/J direction for a single instance of the image fill (in the file’s 
current units).
To maintain the aspect ratio of the image when one length is changed, click the link button; 
the other length value changes automatically.

Rotation Specifies the angle of the image fill
Flip Horizontally/
Flip Vertically

Select to flip the image orientation horizontally, vertically, or both

Parameter Description

Each Object Selection

Center of
selected object

X/Y offset 
coordinates

Image



Mapping Fills with the Attribute Mapping Tool |  1123
Mapping Fills with the Attribute Mapping Tool
Use the Attribute Mapping tool to edit the size, position, and angle of an associative hatch, tile, gradient, or image fill 
that has been applied to an object.

If you are working in 3D and have the Renderworks product installed, you can use the Attribute Mapping tool to 
map textures directly in the drawing window. See “Direct Texture Mapping” on page 1535.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Mapping Hatch and Tile Fills
Mapping Gradient Fills
Mapping Image Fills
The Attributes Palette
Transferring Attributes
Applying and Mapping Textures

Mapping Hatch and Tile Fills

To modify an object’s tile or associative hatch fill:

1. Click the Attribute Mapping tool from the Basic palette or Visualization tool set.
2. Click on an object containing a tile or associative hatch fill. Only one object at a time can be edited.
3. An editing object with eight handles is placed over the fill. The fill origin is at the lower left corner of the editing 

object, where the red and green lines meet. 

4. Use the editing object to set the fill location, scale, and rotation angle. The fill can also be nudged.

Action Description

Edit the fill location Click in the editing object (anywhere except on a selection handle) and drag it to the desired 
location. Click to set.
To precisely locate the origin, click close to the lower left handle, and move the editing object 
as needed.

Hatch origin

http://www.youtube.com/watch?v=-CJGNUDH_J4


  1124 | Mapping Fills with the Attribute Mapping Tool
5. In the Attributes palette, the name of the fill is highlighted in blue, and “(local map)” is appended to the name.

Creating a New Resource from a Locally Mapped Hatch or Tile
A hatch or tile that has been edited with the Attribute Mapping tool is considered to be locally mapped. The edited 
hatch or tile can be saved as a new hatch or tile resource, retaining the mapping edits and allowing them to be applied 
to other objects.
To create a hatch or tile from a locally mapped associative hatch or tile:

1. Right-click (Windows) or Ctrl-click (Mac) on an object with a locally mapped tile or associative hatch, and select 
New Tile From Locally Mapped Tile or New Hatch From Locally Mapped Hatch from the context menu.

2. Provide a name for the new hatch or tile resource.
3. The new resource appears in the Resource Browser. The new hatch or tile definition has already been applied to 

the object, which is no longer considered to be locally mapped.
~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Hatches
Defining Tiles
Fill Attributes

Edit the fill scale Click on one of the corner selection handles, and drag to set the editing object to a new scale 
(or press the Tab key and enter a Scale value in the Data bar). Click to set.

 

Edit the fill rotation Click on one of the middle selection handles, and drag to rotate the editing object to the 
desired angle (or press the Tab key and enter a Rotation value in the Data bar); click to set the 
rotation.
• By default, the editing object rotates about the handle opposite the handle that was clicked 

on.
• To rotate about the fill origin, press the Shift key while rotating.
• To rotate about the center of the editing object, press the Ctrl key (Windows) or Command 

key (Mac) while rotating.

Action Description

Scale: 1.073

Rotation:-30.0°
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Mapping Gradient Fills

To modify an object’s gradient fill:

1. Click the Attribute Mapping tool from the Basic palette or Visualization tool set.
2. Click on an object containing a gradient fill. Only one object at a time can be edited.
3. An editing object with two handles is placed over the gradient.

4. Use the editing object to set the gradient origin location, i-axis length, and rotation angle. Hold down the Shift key 
to constrain the editing object line; the fill can also be nudged.

Action Description

Edit the location of the 
fill (gradient origin)

Click and drag the entire editing object, moving it to the desired location. Click to set.

Edit the gradient i-axis 
location

Click on a handle at the end of the editing object, and drag to set the editing object to a 
new length. Click to set.

 

Edit the gradient 
rotation

Click on a handle at the end of the editing object, and move to create a fulcrum line; 
click to set the rotation.
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~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Gradients
Fill Attributes

Mapping Image Fills

To modify an object’s image fill:

1. Click the Attribute Mapping tool from the Basic palette or the Visualization tool set.
2. Click on an object containing an image fill. Only one object at a time can be edited.
3. An editing object with eight handles is placed over the image.

4. Use the editing object to set the image origin location, i-axis and j-axis lengths, and rotation angle. The fill can 
also be nudged.

Action Description

Edit the location of the fill 
(image origin)

Click and drag the entire editing object, moving it to the desired location.

Edit the image i-axis and 
j-axis location

Click on a corner handle (the resize cursor displays) and drag the handle to the new 
size; holding the Shift key during this operation constrains the image aspect ratio. 
Click to set.
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Options in the Image Settings dialog box (accessed from the Attributes palette) also affect image attribute 
mapping. When the link button between the I Length and J Length fields is selected, the image cannot be flipped 
or mirrored by dragging the editing object’s handles vertically or horizontally; only diagonal dragging is allowed. 
Use the Flip Horizontally or Flip Vertically options in this dialog box to change the fill image orientation 
without moving or resizing the image.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Image Resources

Edit the image rotation Click on a side handle (the rotate cursor displays) and drag the handle to the new 
rotation angle (or press the Tab key and enter a Rotation value in the Data bar). Click 
to set. Press the Ctrl key (Windows) or Command key (Mac) while rotating to rotate 
about the image center. 

Flip the image 
horizontally or vertically

Click and drag a corner of the editing object past another corner of the editing object; 
click again to redraw the image within the new drawing area. Drag horizontally or 
vertically to flip the image in that direction; drag diagonally to flip the image both 
horizontally and vertically.

 

Action Description

Click here and drag
lower left handle of
editing object past
upper right handle

Click again to set the 
new orientation of 
the image fill
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Fill Attributes

Using Line Types
Line types are resources; you can select them from the default content in the Attributes palette (see “Resource 
Libraries” on page 219), or you can create or import custom resources and apply them from the Resource Browser (see 
“Accessing Existing Resources” on page 229).
From the Attributes palette, you can customize the line type to suit the object to which it is applied. Use the Line Type 
Settings button to adjust the line type scale or orientation, and adjust the Pen Color and Line Thickness as needed.
Line types can be applied to any type of 2D planar or screen object that has lines, including walls and plug-in objects.
~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Line Types
Applying Line Types
Editing Line Type Definitions

Defining Line Types
A line type is a set of 2D geometric elements that repeats along a line in both directions from a center point. The 
geometric elements can be a simple dash definition, or more complex 2D shapes with fill.
The color and thickness of the lines in a line type are not part of the resource definition. Once a line type is applied to 
an object, use the Attributes palette to set the color and thickness of the lines for that object. This allows more 
flexibility, so that you can have multiple objects that use the same line type, but use different colors, for example.
To create a line type definition:

1. Open the Resource Browser by selecting Window > Palettes > Resource Browser.
2. Select Resources > New Resource to display the list of new resource types.
3. Select Line Type.

The New Line Type dialog box opens.
Click to show/hide the parameters.

Parameter Description

Name Specifies a name for the line type resource; this name is displayed in the Resource Browser 
and Attributes palette

Simple Select this option to create a custom dashed line; you can either drag levers on the graph, or 
enter a specific line length and gap length for each dash section

Dash graph Levers indicate the distance (in page inches or page millimeters) between dash sections; a 
section consists of a line and a gap. To add a dash section, drag a new lever from the right 
edge of the dash graph; to delete a section, drag a lever from the rightmost section all the 
way to the right. A dash line type can have up to five sections.

<< or >> Selects a highlighted section for editing; alternatively, click a section to highlight it
Line Length Specifies the length of the line, in page units, for the highlighted dash section
Gap Length Specifies the length of the gap, in page units, for the highlighted dash section
Scale with line 
thickness

Maintains the proportion between the line type and the line thickness

Complex Select this option to create a line type with 2D graphic elements
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4. Click OK to save the settings.
• For a simple line type, the definition is complete, and the new line type displays in the Resource Browser.
• For a complex line type, a line type editing window opens. A red baseline across the middle of the window 

indicates the path of the line type, but it is not part of the line type geometry.
5. To create the complex line type, draw the line type geometry with the desired 2D objects, including fills and text 

(symbols and parametric objects are not allowed). All line type definitions have a black pen color and .03 mm line 
thickness. When you create an object, a partially transparent repetition of the object displays to the left and right of 
it. You can add multiple objects to the pattern.

6. To adjust the spacing of a complex line type, click one of the repetitions and drag it as needed; click again to set 
the new position. To hide the repetitions during editing, Ctrl-click (Mac) or right-click (Windows) on an empty 
area of the editing window, and deselect the Display Repetitions option on the context menu.

7. When you are done drawing the complex line type geometry, click Exit Line Type. The line type resource is 
saved with the specified name.
Line types are saved in Vectorworks drawing files. If the file is not saved and the line type is not default content, 
the line type is lost when you exit the program.

Page Based/World 
Based Units

Specifies the units for the line type when it is used in a drawing:
• Page sets the line type size according to the page dimensions. When applied, the line 

type automatically scales relative to the page environment. This is useful for annotation 
objects that should always remain the same size on the “page,” regardless of the layer 
scale.

• World sets the line type size according to world dimensions; its size varies depending on 
the layer scale.

Parameter Description

Click and drag one of the 
semi-transparent editing groups 
(a red box indicates the selected 
group) to modify the line type 
spacing, and click again to set 
the position

The objects you draw are opaque and 
are edited individually. This line type 
has two filled triangles with a line 
between them.
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Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Line Types
Editing Line Type Definitions

Applying Line Types
Apply line types to specific objects using either the Attributes palette or the Resource Browser.

Attributes can also be applied by class settings (see “Setting Class Attributes” on page 181) or transferred with the 
Eyedropper tool.

Applying a Line Type from the Attributes Palette
To apply a line type from the Attributes palette and specify the line type settings:

1. Select the object(s), and then select Line Type from the Attributes palette pen style list.
If no line types are defined, and default content is not enabled in Vectorworks preferences, you are prompted to 
add a default line type definition.

2. To change to a different line type, click on the line type list and select a different type from the list of default 
content or the current file’s content (see “Resource Libraries” on page 219).

3. Adjust the pen color and line thickness for the selected object(s) as needed.
4. If a complex line type is selected, customize it by clicking the Line Type Settings button next to the Line Type 

list. The Line Type Local Mapping Settings dialog box opens.
Click to show/hide the parameters.

Parameter Description

Line type selector Select a line type resource from either the default content or the current file’s content
Use Local Mapping Select to enable entry in the mapping fields, to customize the line type for this object; 

deselect to return to the default mapping

Sample line type applied to 
an object, with 1 mm line 
thickness and dark green 
pen color

Line Type Settings 
(complex line types only)

Line Type
list

Pen color

Line Thickness

http://www.youtube.com/watch?v=OLjlnYPTq94
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5. If desired, click Preview to view the results of the line type settings.
6. Click OK to apply the line type settings.

Applying a Line Type from the Resource Browser
To apply a line type from the Resource Browser:

1. Select the object(s).
2. From the Resource Browser, select the resource to be applied. Right-click (Windows) or Ctrl-click (Mac) and 

select Apply from the context menu. (Alternatively, double-click the resource to apply it to the selection or drag 
the resource onto an object.)

3. Adjust the pen color and line thickness for the selected object(s) as needed.
4. If a complex line type is selected, customize the line type settings from the Attributes palette as described in 

“Applying a Line Type from the Attributes Palette” on page 1130.
~~~~~~~~~~~~~~~~~~~~~~~~~
Transferring Attributes
Defining Line Types
Editing Line Type Definitions

Editing Line Type Definitions
Changes to a line type definition affect all instances of that line type in the drawing file.
To edit a line type definition:

1. Select Window > Palettes > Resource Browser.
The Resource Browser opens.

2. Select the desired line type. Right-click (Windows) or Ctrl-click (Mac), and select Edit from the context menu.
3. The Edit Line Type dialog box opens; select whether to edit the Geometry or Settings.

• If you edit the settings, the Edit Line Type Settings dialog box opens next; select whether to use page-based or 
world-based units. Click OK to return to the drawing area.

• If you edit the geometry, the line type editing window opens next to allow editing of the line components. 
Adjust the line type definition as described in “Defining Line Types” on page 1128.

4. Any instance of the edited line type in the drawing file changes according to the new definition.
~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Line Types
Applying Line Types

Segment Length Specifies the distance for a single instance of the line type (in the file’s current units). 
Objects in the line type will scale symmetrically when this is changed; for example, if the 
segment length is halved, each segment becomes half as long and half as tall.

Flip Horizontally/
Flip Vertically

Select to flip the line type orientation horizontally, vertically, or both

Parameter Description
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Applying Colors
The Color Palette set provides colors for selection and specifies which colors are available in a Vectorworks file. To 
access the Color Palette set from the Attributes palette, click on one of the Fill color boxes (select either a Solid or 
Pattern fill style) or on one of the Pen color boxes (select any Pen style).
A similar interface is available from other areas in the application where colors are specified, although the Color By 
Class option is only available when accessed from the Attributes palette.
See “Setting Default Colors and Palettes” on page 1133 for information on how to set up and activate color palettes.

Select an active color palette, and then select the color to apply. 
Select Color By Class to use the color attributes set by the object’s class. 

• If Use at Creation is enabled for the object’s class, the object’s color is automatically set by the class. 
• If Use at Creation is disabled for the class, the object only takes on the class color when the Color By Class 

option is selected. 
To find a named color on Windows, begin typing; the letters display in the named color display area and the closest 
color match is selected. Press the Tab key to cycle through the closest matches; pause for several seconds to restart the 
search. 
To find a named color on the Mac, type in the search bar under the named color display area. Search options are 
available from the Search bar menu.

• Ignore Case: when selected, search function will not be case sensitive
• Wrap Around: When selected, search function will search entire palette selection rather than starting from the 

currently selected color
• Contains: When selected, search function will search a color’s entire name for the entered text
• Starts With: When selected, search function will only show colors that begin with the entered text
• Full Word: When selected, search function will ignore partially matched words

After typing the name of the desired color, click the left and right arrows to cycle through the list of matching colors. 
Click Done to close the search bar, press Command-F to open the search bar again.
See “Setting Class Attributes” on page 181.

Active palettes

Colors in selected active
palette (Grid view)

Named color display area

Search bar (Mac only)
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~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Default Colors and Palettes
The Attributes Palette
Transferring Attributes

Setting Default Colors and Palettes
The Color Palette set opens when the Fill color or Pen color box is clicked from the Attributes palette. The Color 
Palette set provides colors for selection and specifies which colors are available in a Vectorworks file. Any set of 
unlimited colors can be included; colors are organized in standard and/or custom color palettes.
In a new file, the active document color palette is the only palette displayed in the Color Palette set, and it contains only 
the colors black and white. As colors are added to the file from color palettes as well as resources, the active document 
color palette expands to display all the colors used in the file.
To display and manage the colors available for the file:

1. From the Attributes palette, click on one of the color boxes for Fill color (either a Solid or Pattern fill style must be 
selected) or Pen color (any pen style can be selected). A similar interface is available from other areas in the 
application where colors are specified, although the Color By Class option is only available when accessed from 
the Attributes palette.
The Color Palette set opens, displaying the colors in the active color palette.

Click to show/hide the parameters.

Parameter Description

Color by Class When using the Color Palette set to specify an object’s color, causes the object to take on 
the color attribute set by the object’s class; see “Applying Colors” on page 1132

Standard Color Picker Opens the operating system’s color picker for selecting individual colors; see “Selecting 
Standard Operating System Colors” on page 1135

Color Palette Manager

Standard Color Picker
Pick Color

Utility Menu

Active color palettes

Color Palette set in a new file, showing the 
default active color palettes

Color Palette set in a file with active color 
palettes

Named color display area

Colors in selected active palette
(Grid view)

Search bar (Mac only)
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2. Either select a color from one of the file’s color palettes, or click off of the Color Palette set (in the drawing 
window, for example) to close the color window and set the file’s available colors.

Color Palette Utility Menu
The options selected from the color palette Utility Menu button at the bottom of the main Color Palette set indicate the 
color sorting and display.

To set the display and sorting of colors and palettes:

1. From the Color Palette set, click the Utility Menu button to open the Utility menu.

Pick Color Opens the Pick Color dialog box, for selecting a color from available color palettes; see 
“Selecting a Color from a Color Palette” on page 1135

Color Palette Manager Opens the Color Palette Manager dialog box, for managing available color palettes and 
activating additional palettes; see “Managing Color Palettes” on page 1136

Named color display 
area

Displays any color name information associated with the selected color.
This area also serves to find a named color in the active color palette. To easily find a 
named color, begin typing; the letters display in the named color display area and the 
closest color match is selected. Press the Tab key to cycle through the closest matches; 
pause for several seconds to start the search over.

Search Bar (Mac only) To find a named color on the Mac, type in the search bar under the named color display 
area. Search options are available from the Search bar menu.
●     Ignore Case: when selected, search function will not be case sensitive
●     Wrap Around: When selected, search function will search entire palette selection 
rather than starting from the currently selected color
●     Contains: When selected, search function will search a color’s entire name for the 
entered text
●     Starts With: When selected, search function will only show colors that begin with the 
entered text
●     Full Word: When selected, search function will ignore partially matched words
After typing the name of the desired color, click the left and right arrows to cycle through 
the list of matching colors. Click Done to close the search bar, press Command-F to open 
the search bar again.

Colors in active palette Displays the selected active palette’s available colors in either Grid or List view; these 
colors are available for use in the file

Active palettes Lists palettes which have been made active for the file with the Color Palette Manager; 
click on a palette name to display its colors for use

Utility Menu Opens a utility menu to control the color palette sorting and display

Menu/Command Action

View Color Palette as Select to view the colors in the Color Palette set as a grid of colored squares, or a list of 
colors and associated names. (In either view, color names are always shown in the display 
area above the colors as the mouse moves over the colors.)

Parameter Description
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2. Select a utility command to change the color palette display or sorting option.
~~~~~~~~~~~~~~~~~~~~~~~~~
Selecting Standard Operating System Colors
Selecting a Color from a Color Palette
Managing Color Palettes
Creating or Editing Custom Color Palettes
Applying Colors
Setting Default Colors and Palettes
Creating a Color Chart
The Attributes Palette

Selecting Standard Operating System Colors
When specifying or creating color palettes is not necessary, the operating system’s color picker adds individual colors 
to the active document color palette.

To select a standard operating system color:

1. From the Color Palette set, click the Standard Color Picker button.
The Colors (Mac) or Color (Windows) dialog box opens.

2. Select a color from among the standard operating system colors, and click OK.
3. The color is added to the active document color palette, and becomes available for use in the file.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Default Colors and Palettes
Selecting a Color from a Color Palette
Managing Color Palettes
Creating or Editing Custom Color Palettes
Applying Colors
Creating a Color Chart

Selecting a Color from a Color Palette
If a file requires colors beyond those available for the standard system color picker, but you do not wish to add and 
manage palettes in the Color Palette set, select a color from a specific color palette.

To add colors from a color palette:

1. From the Color Palette set, click the Pick Color button.

Sort Color Palette by Specify the sorting method for the active color palette; select Color to sort by hue (HSV 
values), Manual to sort according to the order set in the Color Palette Manager, or 
Alphabetical to sort in ascending or descending order by color name

Place Color Palettes at Select whether to display active color palettes at the top or bottom of the Color Palette set
Shrink Grid to Fit In Grid view, color lists of less than 16 rows can be displayed with a Color Palette set 

option that shrinks to fit the available colors

Menu/Command Action
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The Pick Color dialog box opens, listing the color palettes available. The Colors in Active Document palette is 
always available. Other palettes in the list either ship with the Vectorworks software, or have been added with the 
Color Palette Manager. The Vectorworks Fundamentals product ships with Classic Vectorworks Colors and 
Standard Vectorworks Colors palettes; many other palettes are available with Vectorworks Design Series products.

Click to show/hide the parameters.

2. Select a color palette from the left, and then select the color from the list or grid of colors on the right. 
3. Click OK to add the color to the active document palette, and make it available for use in the file.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Default Colors and Palettes
Selecting Standard Operating System Colors
Managing Color Palettes
Creating or Editing Custom Color Palettes
Applying Colors
Creating a Color Chart

Managing Color Palettes
The Color Palette Manager determines which color palettes are available in the main Color Palette set and the Pick 
Color dialog box. With the Color Palette Manager, create or import custom color palettes, activate palettes for use in 
the file, add and delete colors from custom color palettes, and purge unused colors.

To manage the file’s color palettes:

1. From the Color Palette set, click the Color Palette Manager button.
The Color Palette Manager dialog box opens. The palettes available here are located in the Color Palettes library 
of the default content; see “Resource Libraries” on page 219. The Vectorworks Fundamentals product ships with 
Classic Vectorworks Colors and Standard Vectorworks Colors palettes; many other palettes are available with 
Vectorworks Design Series products.

Click to show/hide the parameters.

Parameter Description

Color Palette list Lists the color palettes from which colors can be selected. Click on the header to sort the 
palettes in ascending/descending alphabetical order. Select a palette to display its colors on 
the right.

Color List Lists the colors in the selected palette; click on the header to sort by color or by color name. 
Select a color to add it to the Colors in the Active Document palette.

Color Grid Displays the colors in the selected palette as a grid; select a color to add it to the Colors in 
Active Document palette

Color Information Displays the color information of the selected color, including Name; Red, Green, Blue 
(RGB); Cyan, Magenta, Yellow, and Black (CMYK); and Hue, Saturation, and Value 
(HSV). This information also displays on a screen tip when you position the cursor over a 
color.
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2. When the list of color palettes and active color palettes is set, click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Default Colors and Palettes
Selecting Standard Operating System Colors
Selecting a Color from a Color Palette
Creating or Editing Custom Color Palettes
Applying Colors
Creating a Color Chart

Creating or Editing Custom Color Palettes
Custom color palettes can be created or edited from the Color Palette Manager.

Type the first few letters of a palette (or color, when the cursor is in the color list) to quickly select a color.
To create or edit a custom color palette:

1. Open the Color Palette Manager as described in “Managing Color Palettes” on page 1136.
2. Click New to create a new palette, or Edit to make changes to the currently selected palette.

The New Palette or Edit Palette dialog box opens.
Click to show/hide the parameters.

Parameter Description

Color palette list Lists the file’s available color palettes. Click on a header to sort the palettes by active 
status or color palette name. Click in the Active column of a selected palette to activate 
the palette and add it to the available palettes in the main Color Palette set. 

Color List Lists the colors in the selected palette; click on the header to sort by color or by color 
name

Color Grid Displays the colors in the selected palette as a grid
New Opens the New Palette dialog box
Edit Opens the Edit Palette dialog box
Duplicate Copies the selected color palette and appends an incrementing number to the copy name 

(change or rename the copied palette by clicking Edit)
Delete Deletes the currently selected color palette; only custom palettes can be deleted, but not 

the Colors in Active Document or standard color palettes
Purge Unused When the Colors in Active Document palette is selected, removes any colors that are not 

in use in the file from the Colors in Active Document palette.
Referenced colors remain in the active document color palette, even from an object 
that has been removed. Purging allows accumulated colors to be trimmed.

Parameter Description

Name Specifies a name for a new color palette, or edits the name of a custom color palette
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3. When the colors have been edited or added to the custom color palette, click OK.
The custom color palette is listed in the Color Palette Manager. By default, custom color palettes are saved in the 
user folder (see “User Folders Preferences” on page 57).

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Default Colors and Palettes
Selecting Standard Operating System Colors
Managing Color Palettes
Selecting a Color from a Color Palette
Applying Colors
Creating a Color Chart

Creating a Color Chart
This command creates a color chart in the active layer of the current file that reflects the colors in the color palette of 
the file. It can be used as a print color guide.
To create a color chart:

1. Select Tools > Utilities > Create Color Chart.
2. Confirm that a color chart of the active layer in the current file should be generated.

If desired, select Show color palette index numbers to show the color index numbers in the chart. The color chart 
should be viewed in Top/Plan.

Color List Lists the colors in the custom palette; click on the header to sort by number in the list, 
color, or color name. To change the order of the colors, click in the # column and drag the 
selected color up or down in the list. (Select Manual from the color palette Utility menu 
to sort the colors in the main Color Palette set in this order; see “Color Palette Utility 
Menu” on page 1134)

Color Grid Displays the colors in the custom palette as a grid
New Opens the New Color dialog box, for adding a new color from the operating system’s 

color picker
Edit Opens the Edit Color dialog box, for editing the selected color using the operating 

system’s color picker
Delete Deletes the currently selected color(s) from the custom color palette
Get Opens the Pick Color dialog box, for adding one or more colors selected from the 

available color palettes
Lighten Incrementally lightens the selected color
Darken Incrementally darkens the selected color
RGB Blend Blends two selected colors according to their Red, Green, Blue (RGB) values, to create 

the specified number of new colors (up to 1000)
HSV Blend Blends two selected colors according to their Hue, Saturation, and Lightness (HSV) 

values, to create the specified number of new colors (up to 1000)
Import Imports all the colors from the Colors in Active Document palette of another current 

version Vectorworks file

Parameter Description
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The index numbers are internal to the color palette and always remain in the same order.
~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Default Colors and Palettes
Selecting Standard Operating System Colors
Managing Color Palettes
Selecting a Color from a Color Palette
Creating or Editing Custom Color Palettes
Applying Colors
Transferring Attributes
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Viewing the Drawing
Using Standard Views
The items under View > Standard Views change the representation and the orientation of the drawing area. The view 
options can be divided into four basic categories:

 

 

To change among the different views:
Select View > Standard Views, and then select a view.

Category Description

2D View Select the Top/Plan command to view the drawing in 2D; use this for annotations, 
title blocks, and 2D illustrations. Rotated Top/Plan view (Vectorworks Design Series 
required) is only available from the View bar when a rotated top/plan view exists.

3D Elevations Use the Top, Front, Right, Bottom, Back, and Left commands to view 3D elevations
3D Representations Above 
the Active Layer Plane

Use the Right Isometric, Left Isometric, Right Rear Isometric, and Left Rear 
Isometric commands to view 3D representations above the active layer plane

3D Representations Below 
the Active Layer Plane

Use the Lower Right Isometric, Lower Left Isometric, Lower Right Rear 
Isometric, and Lower Left Rear Isometric commands to view 3D representations 
below the active layer plane

Top/Plan Top

Front Right

Bottom

Right Isometric Left Isometric Right Rear Isometric Left Rear Isometric

Lower Left Isometric Lower Right Rear Isometric Lower Left Rear IsometricLower Right Isometric

Back Left

Rotated Top/Plan - View bar only
(Vectorworks Design Series required)
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The view changes and a check mark displays in front of the active view in the Current View/
Standard Views list.
The reference for the view, whether working plane or active layer plane, may depend on the selection in the 
Working Planes palette (see “Working Plane View and Modes” on page 1178).
To switch views rapidly, use shortcuts on the numeric keypad. These shortcut keys also work to change the view 
of a selected viewport on a sheet layer.

When a rotated top/plan view exists (Vectorworks Design Series required), the keypad number 0 invokes the 
Rotated Top/Plan view instead of standard, unrotated Top/Plan view. Press the 0 key a second time to toggle to the 
standard unrotated Top/Plan view.
The View bar also provides quick access to the standard view commands. Click the Current View and select a 
standard view from the list that displays. If the view is something other than a standard view, “Custom View” 
displays as the current view.

Vectorworks Nomad
If you have a Vectorworks Service Select subscription, you can use the Vectorworks Nomad app to view and present 
your 3D drawings rendered in OpenGL on your iOS mobile device. Click here for more information.
~~~~~~~~~~~~~~~~~~~~~~~~~
Vectorworks Cloud Services

Projection
The projection commands alter the way the program displays the 3D geometry of the drawing on a 2D screen. 
The perspective-related projection commands add distortion to the drawing so that objects that are farther away appear 
smaller than objects that are closer. These views closely approximate how the 3D model would display in the real 
world. The perspective view can be uncropped or cropped (see “Cropped and Uncropped Perspective Views” on 
page 1144).

Keypad Number View

0 Top/Plan 
Rotated Top/Plan

1 Left Isometric
2 Front
3 Right Isometric
4 Left
5 Top
6 Right
7 Left Rear Isometric
8 Rear
9 Right Rear Isometric

Current View/Standard Views list

http://www.vectorworks.net/service-select/cloud-services/
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In addition to the standard 2D Plan projection, there are nine 3D projection modes.
To switch projection modes:

Select View > Projection, and then select a projection.

OpenGL and the Renderworks product do not support the Oblique projections; files with an OpenGL or 
Renderworks render mode are converted from an Oblique projection to Orthogonal projection when saved. To 
render Oblique projections, use one of the Polygon render modes, or use Hidden Line mode.
A Vectorworks preference sets the preferred projection, applied whenever the drawing is switched from Top/Plan 
into a 3D view; see “3D Preferences” on page 54.

In an uncropped perspective view, scrolling within the drawing, as well as using the Pan and Zoom tools, will result in 
perspective camera movement while the view remains centered in the window. When there are no objects in the current 
view to use as a reference during movement, a special indicator displays to help orient the movement.

The Translate View tool can also be used to move through a model and interactively adjust the perspective distortion 
while in a perspective projection; see “Translate View” on page 1149. 
~~~~~~~~~~~~~~~~~~~~~~~~~
Cropped and Uncropped Perspective Views

Projection Mode Description

2D Plan Matches the projection for a normal 2D drawing; use this view to draw 2D objects
Orthogonal Displays an undistorted 3D projection of the drawing—objects display at their 

exact size regardless of their distance from the active layer plane
Narrow Perspective Displays a projection of the drawing similar to a telephoto lens
Normal Perspective Displays a projection of the drawing similar to a portrait lens
Wide Perspective Displays a projection of the drawing similar to a wide angle or fisheye lens
Set Custom Perspective Select to set a custom perspective numerically. The Set Perspective Distance 

dialog box opens. Type the custom perspective value in the Distance field, and 
then click OK. The lower the value, the wider the angle of perspective.

Oblique Cavalier (30° or 45°) The Cavalier modes show an undistorted front view along with depth (also known 
as full-depth axonometric projections). The lines along the Z axis (which show the 
depth of an object) are represented in true length. This distorts the overall image of 
the object and makes it appear deeper. These modes make precise measurements 
possible, either from a printout of the drawing or from the screen image.

Oblique Cabinet (30° or 45°) The Oblique Cabinet modes (also known as half-depth axonometric projections) 
are similar to Oblique Cavalier. However, the depth lines are shortened by 50%. 
This distorts the actual length of these lines, but represents a more natural view of 
the object. These modes can still be used to take measurements of vectors 
perpendicular to the projection plan (along the Z axis) from a printed drawing, but 
the results must be multiplied by two to obtain the actual dimension.

The empty view indicator provides visual 3D 
navigation feedback when there are no objects in 

the uncropped perspective view
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Cropped and Uncropped Perspective Views

Perspective projection can be in an uncropped modeling view or in a cropped presentation view. The cropped 
perspective projection is set for the entire document on the Display tab of the Document Preferences dialog box; see 
“Document Display Preferences” on page 60.
In a cropped view, a clipping frame appears around the perspective view window, which is useful for presenting, for 
example, a model elevation in perspective view. Adjust the clipping frame by dragging the corners to increase or 
decrease the size of the window. In older Vectorworks version drawings, this was the only method available for 
displaying perspective views.
In an uncropped view, a shaded horizon representation is displayed in the background. The horizon provides a visual 
indication of the vertical position of the observer with respect to objects in the scene. The horizon does not print or 
export. The green color represents the ground below the horizon, and the blue color represents the sky above it, helping 
with orientation. The color of the ground and sky can be changed in the Interactive Appearance Settings dialog box; see 
“Configuring Interactive Display” on page 116.

Simulating Movement
Several tools simulate movement over and through the drawing.
When you use these tools, a rendered model may display with OpenGL rendering temporarily, even when set to render 
with a different render mode. When the movement stops, the program renders the new view of the model. Additionally, 
for a highly complex drawing, the program may temporarily remove some of the detail to speed up the movement. 
When the movement stops, the detail returns.
These tools have certain Tool bar buttons that are true modes, and others that act as command buttons. When some of 
these tools are in use, the Data bar provides display-only information to help orient the view.
~~~~~~~~~~~~~~~~~~~~~~~~~
Flyover
Walkthrough
Translate View
Rotating the 3D View
Using a SpaceNavigator Mouse
3D Preferences

Flyover
The Flyover tool simulates movement over and around a real-world model.

Uncropped perspective projection Cropped perspective projection
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To control the movements of the Flyover tool, drag the mouse around a selected center of rotation. 
The Tool bar buttons set the center of rotation.

To fly over a drawing:

1. Click the Flyover tool from the Basic palette, or from the 3D Modeling tool set or Visualization tool set.
2. Select the mode from the Tool bar.
3. In Interactive Origin mode, click to specify the center of rotation for the flyover movement.
4. The center of rotation is indicated by dashed axis lines.

To fly over the drawing, click on the drawing and drag in the direction of movement while you hold the mouse 
button. To stop the movement, release the mouse button. Alternatively, use shortcuts on the keyboard to fly over 
the drawing.

Mode Description

Interactive Origin Sets the center of rotation with a mouse click
Object Center Sets the center of rotation to the center of the selected objects; if no objects are 

selected, sets the center of rotation to the center of the visible objects
Active Layer Plane Origin Sets the center of rotation to the center of the active layer plane
Working Plane Origin Sets the center of rotation to the origin of the current working plane

Mouse Movement Shortcut Keys Description

Move left or right Turns left or right about the selected center of 
rotation

Move up or down Moves up or down about the selected center of 
rotation

Move in toward center Alt + move right (Win) or 
Option + move right (Mac)

Moves the view toward the center of rotation (in 
Perspective projection)

Move outward from center Alt + move left (Win) or 
Option + move left (Mac)

Moves the view outward from the center of 
rotation (in perspective projection)

Move down toward active layer 
plane

Alt + move up (Win) or 
Option + move up (Mac)

Moves down toward the active layer plane (in 
perspective or orthogonal projection)

Object Center

Working Plane Origin

Active Layer Plane Origin

Interactive Origin
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Activating the Flyover Tool Temporarily
While another tool is active, press and hold the mouse wheel button and the Ctrl key (Windows) or Control key (Mac) 
simultaneously to activate the Flyover tool. Orient the view as desired, and release the mouse. The previous tool 
becomes active again automatically.
This feature will not work properly if the wheel button is assigned a custom function in the mouse setup. For example, 
if the wheel button is set to perform a delete when clicked, a wheel click in the Vectorworks program deletes rather than 
activates the flyover tool. (The specific setting required for this feature depends on the type of mouse being used.)

Walkthrough
The Walkthrough tool simulates movement through a 3D model.

The tool operates in perspective projection. Three modes, the Viewer Height parameter, and various modifier keys 
provide flexibility to manipulate the viewer position and view angle before and during the walkthrough. 

Move up from active layer plane Alt + move down (Win) or 
Option + move down (Mac)

Moves up from the active layer plane (in 
perspective or orthogonal projection)

Shift key Constrains the rotation to the global Z axis, or to 
the Z’ axis of the active working plane (when 
Working Plane Mode is enabled on the View 
bar) 

Ctrl key (Win) or 
Command key (Mac)

Draws selected objects in full detail, and hides 
deselected objects (so that the redraws are faster)

Mode Description

Walk Moves the viewer through the drawing
Look Around Changes the view angle up, down, right, and left while the viewer remains stationary
Elevator Raises and lowers the viewer height

Mouse Movement Shortcut Keys Description

Viewer HeightWalk

Elevator

Look Around
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When the Walkthrough tool is in use, the Data bar displays the following information to help orient the view.
 

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Walking Through a Model
Looking Around a Model
Setting Viewer Height

Walking Through a Model

To conduct a walkthrough of a model:

1. Click the Walkthrough tool from the Visualization tool set and click Walk from the Tool bar.
The projection automatically switches to perspective.

2. Click on the drawing and hold the mouse button to perform the walkthrough. 
The first mouse click inside the drawing, indicated by a small cross, establishes the control point of the 
walkthrough. The control point lets you manage the pace of the walkthrough. The farther away from the control 
point the mouse moves, the faster the walkthrough. Return the mouse to the control point to slow or pause the 
movement. To stop the walkthrough, release the mouse button.

3. Move the mouse up (forward), down (backward), left, and right to walk through the drawing.
The Data bar provides real-time information about the walkthrough.
To change the viewing angle or viewer height as desired during the walkthrough, combine the movement with a 
modifier key.

 

Viewer Height Specify the viewer height above the ground plane. 
This value updates automatically after Elevator mode is used; it also reflects the viewer 
height as set by any other viewing tool.

Data Bar Description

Yaw Displays the angle (0 – 360 degrees) between the walking direction and the positive Y axis, to 
describe the direction of movement in the active layer plane. A yaw of 90 degrees indicates 
movement in the direction of the positive X axis. A yaw of 180 degrees indicates movement in 
the direction of the negative Y axis.

Pitch Displays the viewing angle. A value of 0 degrees indicates that the viewer is looking straight 
ahead; a value of 45 degrees indicates that the viewer is looking up at an angle 45 degrees from 
horizontal.

Viewer X/Y/Z Displays the position of the viewer relative to the active layer plane

Modifier Key Description

Alt key (Win) or 
Option key (Mac)

Move the mouse to change the look angle up/down (pitch) or right/left (yaw), following the 
mouse movement; the viewer’s position and height remain fixed.

Move the mouse at an angle to change both the pitch and yaw at the same time and 
create a sweeping view.

Mode Description

http://www.youtube.com/watch?v=iDsTRbCkppE
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Walkthrough
Looking Around a Model
Setting Viewer Height

Looking Around a Model

To look around a model from a fixed viewer point:

1. Click the Walkthrough tool from the Visualization tool set and click Look Around from the Tool bar.
The projection automatically switches to perspective.

2. Click on the drawing and hold the mouse button to look around. 
The first mouse click inside the drawing, indicated by a small cross, establishes the control point of the look 
around. The control point lets you manage the pace of the look around. The farther away from the control point the 
mouse moves, the faster the movement. Return the mouse to the control point to slow or pause the movement. To 
stop the look around, release the mouse button.

3. Move the mouse in the direction you want to look.
The Data bar provides real-time information while looking around.
To change the viewer height while looking around, if desired, press the Shift key and move the mouse up or down.

~~~~~~~~~~~~~~~~~~~~~~~~~
Walkthrough
Walking Through a Model
Setting Viewer Height

Setting Viewer Height

To change the viewer height:

1. Click the Walkthrough tool from the Visualization tool set and click Elevator from the Tool bar.
The projection automatically switches to perspective.

2. Click on the drawing and hold the mouse button while you move the mouse up or down. The Data bar provides 
real-time information about the viewer height.
The first mouse click inside the drawing, indicated by a small cross, establishes the control point of the movement. 
The control point lets you manage the pace of the movement. The farther away from the control point the mouse 
moves, the faster the movement. Return the mouse to the control point to slow or pause the movement. To stop the 
operation, release the mouse button.
Alternatively, if you know the desired viewer height, set the value in Viewer Height on the Tool bar. This field 
can be edited in any mode.

~~~~~~~~~~~~~~~~~~~~~~~~~
Walkthrough
Walking Through a Model
Looking Around a Model

Shift key Move the mouse to change the viewer height; the viewer’s X,Y position and viewing angle 
remain fixed

Modifier Key Description
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Translate View
The Translate View tool changes the view of a 3D model, especially when in a perspective projection.

 

Double-click the Translate View tool to refresh the drawing view.

To translate the view:

1. Click the Translate View tool from the Visualization tool set.
2. Depending on the selected mode, click on the drawing and drag while you hold the mouse button to translate the 

drawing from side to side or up and down, move in and out of the drawing, or adjust the perspective. To stop the 
movement, release the mouse button. 
Press the Ctrl key (Windows) or Command key (Mac) to draw selected objects in full detail, and hide deselected 
objects (so that the redraws are faster).
When the Translate View tool is in use, the Data bar displays the following information to help orient the view.

Mode Description

Translate View Moves the drawing along the screen X axis when the cursor moves left or right, and along 
the screen Y axis when the cursor moves up or down

Perspective Move 
In-Out

In perspective projection, drag the mouse up and down to move the view forward (closer) 
or backward (farther away) along the current sightline

Perspective 
Adjustment

In perspective projection, adjusts the distortion by moving the mouse up (more distorted) 
or down (less distorted); similar to creating a custom perspective view by selecting View > 
Projection > Set Custom Perspective

Data Bar Description

Viewer X/Y/Z Displays the position of the viewer relative to the active layer plane 
L/R Displays the movement to the left and right of an imaginary axis perpendicular to the screen
U/D Displays the movement up and down from an imaginary axis perpendicular to the screens
I/O Displays the movement in and out of the drawing along an imaginary axis perpendicular to 

the screen
Perspective distance In Perspective Adjustment mode, displays the perspective distance

Perspective Adjustment 

Perspective Move In-Out

Translate View
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~~~~~~~~~~~~~~~~~~~~~~~~~
Cropped and Uncropped Perspective Views

Rotating the 3D View
To rotate the 3D view, either use the Rotate View tool and the mouse, or specify rotation values with the Rotate 3D 
View command.

Rotating with the Mouse
The Rotate View tool rotates the view clockwise or counter-clockwise in 3D.
To control the movements of the Rotate View tool, drag the mouse or click one of the mode buttons. The first three 
Tool bar buttons set the center of rotation. The last two modes perform precise, incremental rotation movements in the 
direction specified.

To rotate the 3D view:

1. Click the Rotate View tool from the Visualization tool set.
2. Select the mode from the Tool bar.

 

3. To rotate the view, click on the drawing and drag while holding the mouse button. Move the cursor to rotate the 
view in the direction of the mouse movement. Release the mouse to stop the rotation. Alternatively, use the two 
Tool bar buttons.

 

Mode Description

Rotate Around Object Center Uses the center of selected objects as the rotation center
Rotate Around Active Layer Plane Center Uses the center of the active layer plane as the rotation center
Rotate Around Working Plane Center Uses the origin of the current working plane as the rotation center

Mode Mouse Movement/Key Description

Move left or right Rotates about the screen Y axis (or the screen Z axis if the 
mouse is at the perimeter of the drawing)

Move up or down Rotates about the screen Y axis (or the screen Z axis if the 
mouse is at the perimeter of the drawing)

Rotate Clockwise Each click rotates the view in a clockwise direction about the 
selected center of rotation

Rotate Counter-Clockwise Each click rotates the view in a counter-clockwise direction 
about the selected center of rotation

Ctrl key (Windows) or 
Command key (Mac)

Draws selected objects in full detail, and hides deselected 
objects (so that the redraws are faster)

Rotate 
Counter-Clockwise

Rotate Around
Object Center

Rotate Around Working 
Plane Center

Rotate Around Active 
Layer Plane Center

Rotate 
Clockwise
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When the Rotate View tool is in use, the Data bar displays the following information to help 
orient the view.

 

Rotating Precisely
The Rotate 3D View command provides a precise way to rotate the 3D view. Enter rotation values directly, or rotate 
the view in increments. A preview displays the rotation movements before the actual view is rotated.
To rotate the 3D view:

1. Select View > Rotate 3D View.
The Rotate 3D View dialog box opens.

Click to show/hide the parameters.

2. Specify the rotation criteria, and then click OK to rotate the 3D view as specified.

Using a SpaceNavigator Mouse
The Vectorworks program supports both the SpaceNavigator and SpaceExplorer editions of the 3Dconnexion 
SpaceNavigator™ mouse. The SpaceNavigator driver must be installed; see www.3dconnexion.com/support/
SpaceNavigator movement affects the current view; when you cycle through movement modes with the 
SpaceNavigator’s left button, the Vectorworks program’s Message bar displays a notice.
The effects of the SpaceNavigator mouse on the view depend on the current view and projection, as well as the selected 
mode.

For best results while navigating, render the drawing with OpenGL rendering.
Cycle through the SpaceNavigator modes for various types of navigation.

Data Bar Description

Azimuth Displays the active layer plane angle (in degrees) between the positive X axis and the direction 
from the selected center of rotation to the viewer

Elevation Displays the angle (in degrees) between the selected center of rotation and the plane which is 
parallel to the active layer plane and passes through the view origin

Roll Displays (in degrees) the amount of rotation about the selected rotation center

Parameter Description

Parameters are absolute Starts the view rotation from a top (absolute) view
Parameters are relative Starts the view rotation from the current view
Interactive Rotation

+, - X/Y/Z buttons The plus and minus buttons for each axis rotate the view by the increment specified
Angle Increment Specifies the rotation increment (in degrees) for the interactive rotation buttons

Rotation by Value
Rotation on X/Y/Z Specifies the rotation value (in degrees, minutes, and seconds) for the X, Y, and/or Z axes

SpaceNavigator Mode Description Vectorworks View or Projection

Using Walkthrough 
Navigation

Moves forward, back, left, right, up, and down; looks left, 
right, up, and down

Perspective

http://www.3dconnexion.com/support/
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~~~~~~~~~~~~~~~~~~~~~~~~~
Flyover
Walkthrough

Unified Layer View
The Unified View command accesses a modeling mode to view, snap to, select, and edit objects in multiple design 
layers within a unified 3D coordinate system. This mode is active by default to see the entire model and edit multiple 
objects across layers easily, or to align objects across layers, without having to create a viewport or use layer links.
In a unified view, the Vectorworks program aligns all visible design layers in the drawing file with the active layer, and 
displays them using the active layer’s scale, lighting options, render mode, and Renderworks background 
(Renderworks required). The unified view also provides a unified coordinate system; the Z coordinates of all objects 
are expressed relative to the active layer plane. Other layers are above or below the active layer, depending on their 
elevation’s relationship to the active layer. 
The active layer’s layer options setting (View > Layer Options) determines whether other layers can be rendered and 
snapped to, and whether objects on other layers can be selected and modified. For rendering, select Show Others or 
Gray Others. For both rendering and snapping, select Show/Snap Others or Gray/Snap Others. When Show/Snap/
Modify Others is selected, objects on other layers can be selected and they can be modified.

Click here for a video tip about this topic (Internet access required).

Setting Unified View Options
Set the unified view options to obtain the desired behavior.
To set unified view options:

1. Select View > Unified View Options. Alternatively, double-click the Unified View button on the View bar.
The Unified View Options dialog box opens.

Click to show/hide the parameters.

Using Unconstrained 
Navigation

Moves forward, back, left, right, up, and down; looks left, 
right, up, and down, and rolls left and right.
This mode is the most flexible, but can be challenging to 
control; decreasing axis sensitivity from the 
SpaceNavigator control panel is recommended (press the 
right Navigator button)

Perspective

Using Flyover 
Navigation

Functions like the Flyover tool, with spinning and tilting 
motions. If objects are selected, the fixed point of rotation 
is the objects’ center; otherwise, the fixed point of 
rotation is the internal origin

Perspective, Isometric

Using 2D Navigation Allows pan and zoom Top/Plan, Perspective, 
Isometric

Parameter Description

Display Screen Objects Displays screen plane objects from all visible objects in the unified view, and 
allows access to 2D tools

Only on Active Layer Only displays screen plane objects for the active layer

SpaceNavigator Mode Description Vectorworks View or Projection

http://www.youtube.com/watch?v=kvi5RiPf1Ts
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2. Set the parameters and click OK.

Unified View

To enable unified view:

1. Select View > Unified View. Alternatively, click the Unified View button on the View bar.
2. To return to a normal layer view, select View > Unified View again.

A check mark next to the Unified View command indicates that the feature is activated.

Restore Original Views when 
exiting Unified View mode

Returns layers to their original view status and Renderworks background 
when turning off unified view. When deselected, the layer views remain 
aligned when turning off unified view, and the current layer’s Renderworks 
background applies to all layers.

Ignore Layers with Different Scale Does not include layers with a scale that is different from the active layer in 
the view; select this option to hide annotation or detail layers

Show only Layers belonging to 
Stories

Displays only layers that belong to stories in the unified view; select this 
option to exclude layers, such as detail layers, from the view

Center View on Activated Layer When selected, centers the view on the active layer in unified view; the view 
does not shift when switching to another layer

Parameter Description

In normal layer view, the active layer is in a rotated view; other 
inactive layers are in Top and Left Isometric views

The Unified View command aligns all visible 
layers to the active layer’s rotated view
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Setting a 3D View
The Set 3D View command sets a precise 3D view at a specified viewing angle, height, and perspective. Normally, the 
command is executed from 2D Top/Plan view; however, the command can also set a 3D view from any of the 3D 
views.
To set a 3D view:

1. Select View > Set 3D View.
2. Click and draw a line to indicate the view direction; the line starting point indicates the viewer position and the 

line end point indicates the point the viewer is looking towards (look toward point).
The Set 3D View dialog box opens.

3. Specify the 3D view criteria.
Click to show/hide the parameters.

4. Click OK. The 3D view is adjusted as specified.

Parameter Description

Viewer Height Specifies the height of the viewer at the start point of the drawn line
Look Toward Height Specifies the height of the view destination at the end point of the drawn line
Perspective Select the desired perspective, or use the current setting to keep the perspective 

unchanged

With the layer options set to Show Others, all 
visible layers can be stacked and rendered

With the layer options set to Gray Others and 
OpenGL rendering, a transparent effect can be 
created for the grayed layers

With the layer options set to Show/Snap/Modify Others, 
objects on any layer can be selected and modified
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~~~~~~~~~~~~~~~~~~~~~~~~~
Setting a Camera View in Renderworks

Viewing a Model with the Clip Cube
The Clip Cube command allows you to temporarily clip away portions of a 3D model to see and work inside of the 
model. Only objects inside the cube are visible and snappable. Less clutter makes it easier to locate snap points or to 
view a specific region of interest in a large 3D model.
The clip cube feature only works in Wireframe and OpenGL rendering modes. Select objects in the area to view, and 
then select the Clip Cube command to create a cube that bounds those objects. Once the cube is created, use the 
Selection tool to push or pull the cube faces to adjust the size. Use the cube’s editing frame to rotate it or drag it to 
another location.
To use the clip cube feature:

1. In a 3D view, select the objects to be visible inside the cube. (If no objects are selected, the cube will bound all 
currently visible objects.)

2. Set the rendering mode to Wireframe or OpenGL.
3. Select View > Clip Cube.

Alternatively, add the Clip Cube shortcut button to the Tool bar; see “Setting Quick Preferences” on page 64.
The view is clipped to show only the area of the model that contains the selected objects; the objects are 
surrounded by a transparent cube. By default, cross-section areas of solid objects are displayed in red, along the 
plane where the clip cube cuts.

4. To modify the clip cube, click an edge on the cube with the Selection tool. An editing frame with X, Y, and Z axes 
displays on its bottom face. During editing, the view changes to show the objects within the cube at any given 
time.

5. Edit the objects within the clip cube as needed. Keep in mind the following:
• If you edit a symbol, the clip cube will be reset to the symbol boundary; when you exit the symbol editing 

mode, the cube returns to its original boundary.
• While the clip cube feature is enabled, you can create a different cube on each design layer. However, if the 

unified view feature is enabled, only one clip cube can be created.
6. To save the current clip cube view for later use, select View > Save View, and select the option to Save View 

Orientation (see “Creating Saved Views” on page 189).
7. Select the Clip Cube command again to disable the clip cube and return to a full model view on all design layers.

(A check mark next to the Clip Cube command indicates that the feature is activated.)
If you hold down the Ctrl key (Windows) or Command key (Mac) the next time you select the Clip Cube 
command, the last clip cube you had on this design layer is restored.

Action Description

To adjust the cube 
dimensions

Similar to the Push/Pull tool, a face of the cube becomes highlighted when the cursor is over 
it. Click a highlighted face and drag it as needed; click again to set to the new location.

To rotate the cube Click one of the four rotation handles on the edges of the editing frame on the bottom face of 
the clip cube. Drag to rotate the cube, and then click to set the new location.

To move the cube Click the move handle in the center of the editing frame. Drag to move the cube, and then 
click to set the new location.
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Creating a Section Viewport from a Clip Cube
After you create a clip cube, select the Selection tool, and then right-click (Windows) or Ctrl-click (Mac) a highlighted 
vertical face of the clip cube.
Select Create Section Viewport from the context menu. The Create Section Viewport dialog box opens.
Create the viewport either on a sheet layer or design layer, as follows:

• “Creating a Section Viewport on a Sheet Layer” on page 1625
• “Creating a Section Viewport on a Design Layer” on page 1628

By default, the cross-section areas are shown with red fill. These areas are in the Section Style class, if you want to 
change the fill color.

A 3D model with OpenGL rendering 
and unified view enabled; objects 
within the building are obscured

Select objects of interest, and then 
select View > Clip Cube to create a 
transparent cube around them; 
objects outside the cube become 
temporarily invisible

Click an edge on the 
clip cube to edit it

In editing mode, you can resize, 
rotate, and move the cube; the 
objects that are visible change 
according to the cube location

Click and drag a 
highlighted face to 
resize the cube

Click and drag a rotation 
handle on the edge of the 
editing frame to rotate the 
cube

Click and drag the move handle in 
the center of the editing frame to 
move the cube
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Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
X-ray Select Mode

Setting a Camera View in Renderworks
The Renderworks product contains a method of setting a camera view with the Renderworks Camera tool. Specific 
attributes, such as camera focal length, field of view, height, and aspect ratio can be set. 

To insert a Renderworks camera:

1. Select the Renderworks Camera tool from the Visualization tool set.
2. Click in the design layer to specify the camera location. Click again to indicate the camera look-to point.

If this is the first time a camera object has been inserted in this session, the Renderworks Camera Object 
Properties dialog box opens. Click OK.

3. Click Display Camera View in the Object Info palette, or simply double-click on the camera, to switch to the 3D 
camera view. To return to Top/Plan view, click Top/Plan View in the Object Info palette.

Right-click (Windows) 
or Ctrl-click (Mac) a 
highlighted face and 
select Create Section 
Viewport from the 
context menu

The length, depth, and height ranges 
of the section viewport match the 
dimensions of the clip cube

http://www.youtube.com/watch?v=v3KJ64mmS8Q
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4. The camera properties can be edited in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Camera Height Sets the camera height; at placement, the camera is set to a default height of 1500 mm 
or 5’0”. If a Z value is also specified for the camera object, the total camera height is the 
sum of the Z height and the Camera Height.

Look To Height Sets the height of the camera look-to point; at placement, the look-to height is set to a 
default height of 1500 mm or 5’0”. If a Z value is also specified for the camera object, 
the total look-to height is the sum of the Z height and the Look To Height.

Top/Plan View Switches to a Top/Plan view of the camera
Display Camera View Switches to display the 3D camera view (double-clicking on the camera in a 2D view 

also switches to camera view)
Fine Tune Camera View Opens the Perspective View Controls dialog box, for making fine adjustments to the 

camera view controls
Projection Select Perspective or Orthogonal projection for the camera view; Perspective creates a 

cropped or uncropped perspective view of the model from the camera view, while 
Orthogonal is useful for an elevation view (for example, a skewed elevation view of a 
building which is not in a standard view). Available parameters depend on the selected 
projection.

Render Mode Selects a render mode for the 3D camera view
Aspect Ratio Sets the aspect ratio of the perspective clipping window; the clipping window can also 

be set to the page size or to a custom aspect ratio
Custom Aspect When a custom Aspect Ratio is selected, enter the custom ratio
For Film Size of Specifies the camera film size, and determines the focal length of the camera (has no 

effect on the camera view)
Focal Length is Displays the camera focal length, based on film size
Field of View Specifies the view angle; set to a default angle of 65 degrees. Use the control point to 

set the view angle on the 2D camera with the mouse.
For DPI of Calculates the pixel size when exporting the camera view (has no effect on the camera 

view)
Pixel Size is Displays the pixel size based on the DPI setting
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Adjusting the Camera View
Linking the Camera View to a Sheet Layer Viewport
Setting a 3D View
Managing Lights and Cameras with the Visualization Palette
Projection

Adjusting the Camera View
The camera view settings can be fine tuned in real-time, and the display attributes specified.
To adjust the camera view:

1. Click Fine Tune Camera View from the Object Info palette of a selected camera object.

Crop Frame Scale % Scales the size of the clipping window frame, when in a cropped perspective projection, 
and also scales the perspective distance. As a result, both the crop frame and the 
drawing appear scaled.

Left/Right Tilt Angle Tilts the camera to the left or right, for more accurate perspective matching
Camera Name Specifies a name for the camera, which can be displayed or hidden in 2D view; move 

the camera name text control point to adjust the position of the name
Camera Display Select a camera display mode; the camera name only displays in 2D

• None: Hides the camera in 2D and 3D views, and hides the camera name
• 2D: Displays the camera in 2D view, but hides the camera name, and hides the 

camera in a 3D view
• 3D: Displays the camera’s perspective clipping window bounding box in 2D view, 

displays the camera in 3D view, and hides the camera name
• 2D + 3D: Shows the camera in 2D and 3D views, but hides the camera name
• 2D + Name: Shows the camera and camera name in 2D view, but hides the camera in 

3D views
• 3D + Name: Shows the camera in 3D view, shows the camera name in 2D view, but 

hides the camera in 2D view (displays a locus instead)
• 2D + 3D + Name: Shows the camera and camera name in 2D view, and shows the 

camera in 3D views
The 3D camera view displays the bounding box of the camera view, the view line, and 
the look-to end point. Displaying a camera in a 3D view allows it to be easily selected 
during design development, and it can be hidden later for final presentation

Auto Update 3D View When selected, automatically updates the 3D camera view with every parameter 
change; for complex models, deselect when making several parameter changes, and 
then either re-select Auto Update 3D View or click Display Camera View to update 
the camera view with any parameter changes

Auto Center 3D View Automatically centers the view when Display Camera View is clicked, or the camera 
is double-clicked

Parameter Description
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The Perspective View Controls dialog box opens. Either use the sliders or enter values to adjust the camera 
settings; changes are reflected automatically in the drawing. To interactively view changes as you move the 
sliders, render in wireframe or OpenGL render mode.
For Camera Height, Look To Height, and Camera Distance, the slider range is proportional to the displayed 
value. To expand the slider range, enter a larger value.

Click to show/hide the parameters.

2. A camera object can be copied to insert additional camera views. In addition, the 2D camera display attributes can 
be set by fill and pen foreground and background colors in the Attributes palette. Control points adjust the field of 
view angle, the look-to point, and the camera name location.

Parameter Description

Camera Height Moves the camera vertically
Look To Height Sets the height of the look-to point, which effectively tilts the camera vertically
Camera Pan Pans the camera, rotating it about its axis within a +/- 20 degree range, as if it were on a tripod
Camera Move 
Left/Right

Rotates the camera about the look-to point, within a +/- 20 degree range

Camera 
Distance

Moves the camera towards or away from the look-to point

Focal Length 
(zoom)

Acts like a zoom lens; sets the lens focal length, from 10 to 200 mm and changes the field of 
view angle

Perspective Increases or decreases the perspective effect, making the perspective lines vanish more or less 
steeply about the look-to point; works most effectively when the look-to point is at the center of 
the scene or object being viewed

Clip Frame 
Aspect Ratio

Sets the aspect of the perspective crop window; use in conjunction with the Clip Frame Size to 
obtain the desired window size

Clip Frame Size Sets the scale of the perspective crop window; use in conjunction with the Clip Frame Aspect 
Ratio to obtain the desired window size

Render Mode Selects a render mode for the 3D camera view

Fill/Pen Color Attribute Parameter

Fill foreground Sets the field of view angle color when the camera height is higher than the look-to height
Fill background Sets the text color for the camera name

Field of view angle
control point

Camera name text 
control point

Look-to point 
control point

Lens field of view

Apparent field of view

Camera 1
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The divergence between the apparent field of view angle and the lens field of view angle increases as the 
difference between the camera and look-to heights increases. When the camera and look-to heights are equal, the 
lens field of view angle line (dashed gray line by default) is not visible.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting a Camera View in Renderworks
Linking the Camera View to a Sheet Layer Viewport
Setting a 3D View
Applying Colors
Managing Lights and Cameras with the Visualization Palette

Linking the Camera View to a Sheet Layer Viewport
The view of a sheet layer viewport can be controlled by a Renderworks camera. Establish the view with the 
Renderworks camera on the design layer, and then create a sheet layer viewport linked to the camera. The camera view 
can be edited from the viewport.

Renderworks cameras cannot be linked to section viewports.
To link a Renderworks camera to a sheet layer viewport:

1. Create and adjust the Renderworks camera as described in “Setting a Camera View in Renderworks” on 
page 1157. A camera linked to a viewport can be in perspective or orthogonal projection.

2. Select the Renderworks camera, and then select View > Create Viewport.
3. An alert dialog box asks whether the camera should be used for the viewport’s view. Select Yes (click Always do 

the selected action to always use a selected Renderworks camera for the view when creating viewports).
4. The Create Viewport dialog box opens. Enter a viewport name and drawing title, and select the sheet layer to place 

it on. The view and projection parameters are set by the camera, and therefore appear dimmed; the camera’s render 
mode does not affect the viewport’s render mode. Change any other parameters as needed (see “Creating a Sheet 
Layer Viewport from a Design Layer” on page 1616).

5. Click OK.
The viewport is created on the specified sheet layer, with its view, projection, and perspective distance set to that 
of the Renderworks camera. In the Object Info palette, the RW Camera status changes to Yes.
The camera becomes part of the viewport and can be edited (or deleted), changing the viewport’s view parameters, 
by editing the camera through the viewport. An existing sheet layer viewport can also be linked to a Renderworks 
camera. See “Editing a Linked Renderworks Camera” on page 1654.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting a Camera View in Renderworks
Adjusting the Camera View
Editing a Linked Renderworks Camera
Creating a Sheet Layer Viewport from a Design Layer
Editing a Design Layer Displayed in a Viewport

Pen foreground Sets the color of the view line connecting the camera to the look-to point, as well as the 
color of the 3D camera representation

Pen background Sets the color of the angle of view lines

Fill/Pen Color Attribute Parameter

http://www.youtube.com/watch?v=3uBLH8gPQUQ
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Fit to Objects 
The Fit to Objects command provides an easy way to zoom in and out of a drawing. There are two options: fit the 
window around all the objects in the drawing, or fit the window around a particular object or set of objects.
When in an uncropped perspective projection, the view direction is preserved, and the viewpoint is adjusted to fit the 
model or object within the drawing window.

To fit the drawing window around all visible objects in the drawing:

1. Ensure that the current layer contains the object(s) to view, and that no objects are selected.
2. Select View > Zoom > Fit to Objects. Alternatively, click the Fit to Objects button on the View bar.

The program zooms in or out so that all the objects in the drawing display in the drawing area.

To fit the view to a particular object or set of objects:

1. Ensure that the current layer contains the object(s) to view.
2. Select the object or objects to view.
3. Select View > Zoom > Fit to Objects. Alternatively, click the Fit to Objects button on the View bar.

The program zooms in to display only the selected object(s) in the drawing area.

Fit to Page Area
The Fit to Page Area command displays the entire print area in the drawing window. For a single page drawing, this 
command displays the entire page. For a drawing with two or more pages, all of the pages display at one time.

To fit the print area in the window:
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Select View > Zoom > Fit to Page Area. Alternatively, click the Fit to Page Area button on 
the View bar.
The program zooms in or out to display all pages in the print area.

Viewing History
The program automatically records a history of the last 50 changes in drawing view, including projection, perspective 
and zoom changes. Click the Previous View and Next View buttons on the View bar to move through the change 
history stack.

On a Windows system with a five-button mouse, buttons 4 and 5 on the mouse (which invoke the Back and Forward 
commands in web browsers) invoke Previous View and Next View, respectively.

Rotating the Plan
In a design layer, the view may need to be rotated to match a drawing angle. When the plan is rotated, the view 
switches to Rotated Top/Plan, and all existing layers are rotated together.

The View bar has a button for quick access to the Rotate Plan command.

To rotate the plan:
1. Select View > Rotate Plan, or click Rotate Plan from the View bar.
2. Click to indicate the center of plan rotation, and then click again to indicate the angle of plan rotation. The angle 

snaps to existing objects.
The temporary reference line indicates the line that will become horizontal after the operation. The temporary 
arrow within the arc indicates the direction of the rotation. The rotation is referenced to a horizontal line, unlike 
the Rotate tool.
The angle of plan rotation can also be specified from the floating data bar, or entered directly in the View bar. The 
drawing rotates around plan center (0, 0) when the angle is specified in the View bar.

3. All layers in the drawing rotate to match the specified angle. (If some layers were in a 3D view, they will lose this 
view since all layers in the drawing are set to Rotated Top/Plan; confirm that this is the desired action.) Symbols 
placed and objects drawn while in this view match the current rotation angle.
At the bottom left of the drawing window, the position of the X - Y axis indicator shows the drawing rotation 
angle and direction.

Next ViewPrevious View

Rotate Plan button
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To disable the rotation animation, see “Interactive Preferences” on page 56.
The View bar indicates that the drawing has been rotated; the icon next to the layers in the Layers list changes, and 
the Current View list displays Rotated Top/Plan. If you switch to another view and want to return to the rotated 
top/plan view, select Rotated Top/Plan from the Current View list on the View bar.

In addition, in a Rotated Top/Plan view, the rulers display in a blue color, and the Object Info palette for objects in 
rotated plan display both global world coordinates and rotated plan coordinates (depending on the Object Info 
palette preference). 

The display of the Object Info palette coordinates in rotated plan view is controlled by a preference, accessed from the 
Coordinate/IFC menu at the top right corner of the Object Info palette:

Click to show/hide the parameters.

Once the drawing has been rotated, a different rotation angle can be specified with Rotate Plan in the View bar.

Parameter Description

Show screen coordinates with 
full labels

Displays screen coordinates (rotated plan coordinates) with Screen X, Screen Y, 
and Screen Z labels in the Object Info palette

Show screen coordinates with 
abbreviated labels

Displays screen coordinates with abbreviated X’, Y’, and Z’ labels

Show world coordinates when in 
rotated plan

Displays world coordinates in addition to screen coordinates when in rotated 
plan view

Do not show world coordinates 
when in rotated plan

Hides world coordinates when in rotated plan view

IFC options (Vectorworks 
Architect or Landmark required)

For information on IFC data, see “Assigning IFC Data to Objects” on page 1746

Global world coordinates

Rotated plan coordinates
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The green reference line indicates the unrotated, horizontal direction. If the Rotate Plan command is selected again, 
match this reference line to un-rotate the view, returning to the world coordinate system. Alternatively, to un-rotate the 
view, select View > Standard Views > Top/Plan, select Top/Plan from the View bar, or enter an angle of 0 for Rotate 
Plan in the View bar.
In rotated plan view, a working plane is automatically present, with its origin at the rotated plan pivot point and its X’ 
axis horizontal to the screen. Click on the X’ or Y’ axis to drag the working plane to a new location. The X’ and Y’ 
coordinates adjust from this point and the local coordinates are reflected on the rulers.

An elevation view can be easily set based on the working plane position. Click Working Plane Views  from 
the View bar, and then select a standard view such as Front. To return to the rotated 2D view, select Rotated Top/
Plan from the Current View list on the View bar. 

The plan rotation can be saved as a view and restored later by selecting the view for display. Select Save View 
Orientation in the Save View dialog box to save the plan rotation (see “Creating Saved Views” on page 189).
Saved views with rotation information display with a rotated icon in the View column of the Organization dialog box. 
Sorting by the View column separates non-rotated views from the rotated views.
~~~~~~~~~~~~~~~~~~~~~~~~~
The View Bar
Creating Saved Views

Using Working Planes
The working plane is an important concept for working in 3D. This section covers all aspects of the working plane, 
including setting, manipulating, and saving the working plane position.
~~~~~~~~~~~~~~~~~~~~~~~~~
Understanding the Working Plane
The Active Planes List

Click and drag to
move the working

plane handle
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Understanding the Working Plane
Every Vectorworks layer has a 3D plane associated with it. When a layer is active, this 3D plane is called the active 
layer plane. The active layer plane provides a constant visual and logical reference and is fixed in relation to the objects 
in the layer. In an architectural sense, the active layer plane is like the floor of a building; it is sometimes referred to as 
the ground plane.
Every Vectorworks drawing also has a working plane. The location of the working plane defaults to that of the active 
layer plane, and it is not seen. However, when working and modeling in 3D, the orientation of the working plane can be 
changed, and its positions saved. The working plane can be moved, aligned to different objects or surfaces, and rotated, 
unlike the active layer plane, which remains constant at the internal drawing center.
Working in 3D requires the cursor to snap to a 3D location. When no other 3D snap is active (the cursor is not snapping 
to 3D geometry), the cursor still needs to snap to a 3D location; this location is the 3D plane called the working plane.

Every object created in the drawing is placed in relation to the active layer plane for that layer, whether it is placed 
directly on that plane or placed above or below it. The working plane helps to easily create and position objects in 3D 
space. It allows you to draw while in an isometric view and position objects exactly where they are needed. When 
changing the location of the working plane, the active layer plane remains displayed, providing a constant frame of 
reference while adjusting the working plane.

 

For example, for a drawing of a complex machine, with numerous gears, cams, rollers, and other parts that intersect on 
multiple planes, the working plane can be changed to different locations and angles in relation to the active layer plane. 

Working plane

Active layer 
plane

Below the working plane
Above the active layer plane

Above the working plane

On the working plane
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Creating or locating objects according to the working plane allows highly accurate positioning of 
the objects in 3D space.

Hybrid symbols can only be inserted on a working plane that is parallel to the active layer plane. When inserting a 
hybrid symbol, if the working plane is not parallel to the active layer plane, the working plane is moved to, and 
aligned with, the active layer plane.

In addition, some tools require a vector or plane. The 3D viewing tools can use the working plane to define their center 
and/or axis of rotation, while the Mirror tool can mirror the selected 3D objects across the working plane. The location 
of 3D tools in 3D space is taken from the point on the working plane directly behind the cursor, or from a snap point if 
they are snapped to an object.
To assist with drawing in 3D with certain drawing tools, an automatic working plane appears on suitable object 
surfaces as the cursor moves over drawing objects with the tool selected. The automatic working plane is a temporary 
working plane that does not need to be explicitly set. Objects created on the automatic working plane are drawn planar 
to the automatic working plane, rather than on the layer plane. This facilitates drawing planar objects without the need 
to create or save a working plane. The color and opacity of the automatic working plane can also be customized; see 
“Configuring Interactive Display” on page 116.

If there is no suitable surface under the cursor, the automatic working plane aligns to the layer plane.

When the automatic working plane is in effect, Automatic displays in the Active Planes list located on the View bar.

Cylinder created on working plane Rectangle created on working plane

Automatic working
plane
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When drawing on a specific working plane that was established by the Set Working Plane tool, the automatic working 
plane should be turned off. Select a different plane from the list, such as a saved working plane, or press the \ key 
(backslash) to toggle the automatic working plane on and off. (This key can be customized in the Workspace Editor; 
see “Modifying Snapping and Mode Shortcuts” on page 1842.) When using a working plane tool such as the Set 
Working Plane tool, the automatic working plane defaults to off.
~~~~~~~~~~~~~~~~~~~~~~~~~
Appearance of the Planes
The Active Planes List
Setting the Working Plane Location
Manipulating the Working Plane
The Working Planes Palette
Aligning Objects to the Working Plane
The Automatic Working Plane

The Active Planes List
On the View bar, the Active Planes list displays the currently active plane, and also allows other active planes to be 
selected. The available planes depend on the drawing view, current tool, presence of named working planes, and plane 
mode options. 

~~~~~~~~~~~~~~~~~~~~~~~~~
Understanding the Working Plane

Plane Description

Automatic The active working plane changes as the cursor moves over the drawing area in a 3D view. The 
automatic plane is a temporary working plane that does not need to be set; over suitable 
surfaces and with certain drawing tools, the automatic plane is planar to the surface. Otherwise, 
the automatic plane aligns to the layer plane. 

Layer Plane The active working plane is planar to the current plane of the active layer
Custom Plane The active working plane is planar to a saved working plane position; selecting a working plane 

cancels the automatic working plane.
Screen Plane The active working plane is aligned to the screen plane (planar to the computer screen)
Options Opens the Document Preferences dialog box, for setting the plane mode options; see “Plane 

Mode Preferences” on page 63
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Plane Mode Preferences

Appearance of the Planes
In any view other than Top/Plan, the layer plane is represented in blue; when active, it has red X and green Y axes (an 
option in the display preferences of the Vectorworks preference can also show the axes in Top/Plan). When the working 
plane and the active layer plane are located in the same position, only the active layer plane is shown. However, once 
the position of the working plane has been changed or directly set, it is represented on the screen as a colored frame. 
The color of the active layer plane and appearance of the working plane can be customized in the Vectorworks 
preferences; see “Interactive Preferences” on page 56 for details.
The axis lines of both the working plane and the automatic working plane are colored red for X’, green for Y’, and blue 
for Z’; dashed axes represent the negative axes. In a 3D view, the axes are always visible, although they appear more 
transparent when they are behind rendered solid objects. The Z’ axis and all axis labels are optionally displayed by 
settings in the SmartCursor Settings dialog box; see “Grid Snapping” on page 133.

Simply click on an axis with the Set Working Plane tool to select and display the working plane and its grip handles. 
When the working plane is selected, it displays with colored grips around each axis, as well as a move grip, for 
manipulating the plane. 

The working plane can be moved, but not rotated, when in rotated top/plan view (Vectorworks Design Series required). 
See “Rotating the Plan” on page 1163.
When grid snapping is enabled, the working plane displays with dots; when grid snapping is off, the dots do not 
display. The working plane displays slightly darker, and with a double line frame, when it is viewed from below.
When the working plane and the active layer plane are coincident, the active layer plane displays with grid lines. 
Otherwise, when the planes are not coincident, the grid lines do not display on the active layer plane.
Dashed gray lines represent the intersection of the active layer plane and working planes. The active layer plane does 
not display in a rendered view.
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If the active layer plane grid lines are not visible, select Show Grid in the SmartCursor Settings dialog box (see 
“Grid Snapping” on page 133).

~~~~~~~~~~~~~~~~~~~~~~~~~
Understanding the Working Plane
The Active Planes List
Setting the Working Plane Location
Manipulating the Working Plane
The Working Planes Palette
Aligning Objects to the Working Plane

Setting the Working Plane Location
The Set Working Plane tool can set the location and angle of the working plane. Set the working plane to any location 
in 3D space.

Double-click on the Set Working Plane tool to set the working plane to the layer plane. Double-click on a planar 
object to re-activate the working plane on which it was created.

The Set Working Plane tool has two modes:

Once the working plane location has been set, Custom Plane displays in the Active Planes list on the View bar. The 
location can be saved; see “Working Plane Commands” on page 1174.

The working plane can be quickly set based on the automatic working plane location. Right-click (Windows) or 
Ctrl-click (Mac) on the automatic working plane, and select Set Working Plane from the context menu (or select 
Modify > Working Plane > Set Working Plane). The working plane is set to match the automatic working plane, 
and the working plane is active.

Mode Description

Three Point Defines the working plane by three, 3D points, or according to the surface of a rendered object
Planar Face Aligns the working plane to a planar face; or, for a NURBS curve, aligns the working plane 

perpendicular to that point's tangent on the curve

Working plane with grid snapping 
enabled

Working plane seen from below Active layer plane and working plane 
coincident, and working plane selected; Z axis 

display enabled

Planar FaceThree Point
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Click here for a video tip on this topic (Internet connection required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Working Plane with Three Points
Setting the Working Plane to a Planar Face
Manipulating the Working Plane

Setting the Working Plane with Three Points
Two methods are available for defining the working plane location in Three Point mode. The first method allows the 
position and angle of the working plane to be set by defining the origin and axes of the new working plane location. 
The second method sets the position and angle of the working plane according to a rendered object’s surface.

Setting the Working Plane

To set the working plane with three points:

1. In a 3D view, click the Set Working Plane tool from the 3D Modeling tool set, and then select Three Point from 
the Tool bar.

2. Click to set the first point.
This becomes the origin of the working plane.

3. Click to set the second point.
This sets the working plane X’ axis.

4. Select the third point.
This sets the Y’ axis for the working plane. Once the third point is defined, the working plane location is set.

With the automatic working plane in the 
desired location, select Set Working Plane

The working plane is active, set to match 
the automatic plane

Click 1

Click 2

Click 3

http://www.youtube.com/watch?v=km5feSXdfnY
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Setting the Working Plane to a Rendered Object’s Surface

The working plane can be defined according to the surface of a rendered object.

To set the working plane to a rendered object’s surface:

1. In a 3D view, select a rendering mode of Unshaded Polygon, Shaded Polygon, Shaded Polygon No Lines, or Final 
Shaded Polygon.

2. Click the Set Working Plane tool from the 3D Modeling tool set, and then select Three Point from the Tool bar.
The cursor changes to a pointing hand when over the surface of a rendered object.

3. Click on the surface that defines the working plane location.
The working plane location is set to the selected surface.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Working Plane Location
Understanding the Working Plane
Manipulating the Working Plane
The Working Planes Palette
Aligning Objects to the Working Plane

Setting the Working Plane to a Planar Face
Planar Face mode is particularly useful when aligning the working plane to the top of an object without sharp corners 
(like a cylinder); instead of clicking in three places, only the planar face of the object needs to be selected. 
In addition, the working plane can be positioned on a NURBS curve, aligning the working plane’s Z axis to the curve’s 
tangent direction. The ability to set the working plane to a NURBS curve requires one of the following conditions: a 
smart point must be set on the NURBS curve, Snap to Object must be enabled, or the Nearest Point on Edge object 
snapping must be enabled. 

To set the working plane to a planar face:

1. In a 3D view, click the Set Working Plane tool from the 3D Modeling tool set, and then select Planar Face from 
the Tool bar.

2. As the cursor moves over the underlying geometry, a preview of the working plane displays. Click to set the 
working plane location. The click location becomes the origin of the working plane.
The working plane is aligned to the selected face and remains selected for manipulation. The working plane is 
deselected when the Set Working Plane tool is no longer active.

Click the rendered surface to use for 
aligning the working plane
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Setting the Working Plane Location
Understanding the Working Plane
Manipulating the Working Plane
The Working Planes Palette
Aligning Objects to the Working Plane
Object Snapping

Manipulating the Working Plane
Working plane operations can be performed either by using the grips on the selected plane or by menu commands.
~~~~~~~~~~~~~~~~~~~~~~~~~
Working Plane Grips
Working Plane Commands

Working Plane Grips
Manipulate the working plane by rotating about any of the three axes (X’, Y’, and Z’) or moving the working plane 
origin. 

To manipulate the working plane directly:

1. Click the Selection tool from the Basic palette.
2. In a 3D view, select the working plane by clicking on its edge or any of its axes. Alternatively, double-click on a 

planar object to re-activate the working plane on which it was created.
The working plane must be selected for the grips to be visible. Any other object reshape handles are temporarily 
hidden, to avoid confusion.

3. The working plane displays with grips.
Each axis has two grips for rotation about the other two axes. Red grips rotate about the X’ axis, green grips rotate 
about the Y’ axis, and blue grips rotate about the Z’ axis. Moving the cursor over an axis displays a preview 
showing the rotation direction. The blue diamond grip at the working plane origin moves the working plane.
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4. Once the working plane has been positioned, press the Esc key, or click off of the working plane. The position can 
be saved with working plane commands or in the Working Planes palette.
Use the grips in combination with SmartCursor cues for accurate manipulation in relation to other objects.

The working plane can be moved, but not rotated, when in rotated plan view (Vectorworks Design Series required). See 
“Rotating the Plan” on page 1163.
~~~~~~~~~~~~~~~~~~~~~~~~~
Working Plane Commands
The Working Planes Palette

Working Plane Commands
The working plane commands can select and manipulate the working plane. Some commands have equivalents in the 
Working Planes palette or when editing the working plane directly.
To access the working plane commands:

Select Modify > Working Plane.
The same commands are available from the context menu of the working plane.

Action Description

Rotate the working plane Click on one of the axis grips. The rotate cursor displays. Move the cursor to rotate 
the plane about the selected axis, and click to set.

Move the working plane Click on the center grip. The move cursor displays. Move the cursor to move the 
plane, and click to set.

Smart point with extension line
Y’ axis is perpendicular to the active layer

plane, and the working plane is located
above the active layer plane, as indicated

by the dashed gray lines

Alignment indicators show that the
direction of working plane movement is

planar, in this case in the Z’ and X’
directions, as indicated by the blue and

red planar shading
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When using the rotate commands, left indicates counterclockwise when viewing the working plane origin from the 
positive X axis.
~~~~~~~~~~~~~~~~~~~~~~~~~
Working Plane Grips
The Working Planes Palette

Command Description

Select Working Plane Selects the working plane (alternatively, click on the plane with the Selection tool, 
select Edit > Select Working Plane, or select the working plane from the Working 
Planes palette’s Utility menu or context menu)

Look at Working Plane Changes the view to be perpendicular to the working plane; similar to the Top view 
under the View menu, in that you are looking straight at the working plane. This 
command is also available from the View menu and the View bar.

Save Working Plane Opens the New Working Plane dialog box. Enter a name to save the working plane 
position; if desired, change the origin and rotation values. Once a working plane 
position has been saved, it can be accessed through the Working Planes palette and 
the Active Planes list on the View bar. 

Working planes can also be saved by selecting New from the Working Planes 
palette’s Utility menu or context menu. 

Next Working Plane Cycles through the next ten unsaved palette positions
Previous Working Plane Cycles through the last ten unsaved palette positions
Set Working Plane If selected while the automatic working plane is highlighted, sets the working plane 

to match the automatic working plane. Otherwise, sets the working plane to the next 
clicked planar face, similar to the Planar Face mode of the Set Working Plane tool 
(see “Setting the Working Plane to a Planar Face” on page 1172)

Align Working Plane X 
Axis with Layer Plane

Rotates the working plane coordinates about the Z axis until the X axis is parallel to 
the active layer plane and the Y axis is pointing up. The working plane origin is 
unchanged.

Align Working Plane with 
Layer Plane

Aligns all working plane axes to the corresponding active layer plane axes. The 
working plane origin is unchanged.

Align Working Plane with 
Current View

Aligns the working plane Z axis toward the viewer; the X axis is aligned horizontally 
and the Y axis vertically, on the screen. The working plane origin is unchanged.

Rotate About X’ Left 90° Rotates the working plane to the left about its X axis by 90 degrees
Rotate About X’ Right 90° Rotates the working plane to the right about its X axis by 90 degrees
Rotate About Y’ Left 90° Rotates the working plane to the left about its Y axis by 90 degrees
Rotate About Y’ Right 90° Rotates the working plane to the right about its Y axis by 90 degrees
Rotate About Z’ Left 90° Rotates the working plane to the left about its Z axis by 90 degrees
Rotate About Z’ Right 90° Rotates the working plane to the right about its Z axis by 90 degrees
Flip X’ Flips the working plane about its X axis
Flip Y’ Flips the working plane about its Y axis
Flip Z’ Flips the working plane about its Z axis
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The Working Planes Palette
The Working Planes palette displays working planes that have been set or saved while working on a drawing. The 
palette allows you to save new working plane positions, and to edit, duplicate, delete, activate, and select existing 
working planes. Combine these features with the working plane controls on the View bar, the working plane commands 
on the Modify menu, the Set Working Plane tool, and the Align Plane tool to accurately control the placement and 
alignment of objects in 3D space.

To manage working planes in the Working Planes palette:

1. Select Window > Palettes > Working Planes.
2. The Working Planes palette opens. Click the Utility Menu button at the bottom of the palette to open the Utility 

menu. 
Alternatively, right-click (Windows) or Ctrl-click (Mac) on the palette to access the context menu.

3. Select the desired command.
~~~~~~~~~~~~~~~~~~~~~~~~~
Saving Working Plane Positions
Editing and Renaming Working Planes
Accessing Existing Working Planes
Working Plane View and Modes
Working Plane Commands

Menu/Command Action

New Saves a new working plane; see “Saving Working Plane Positions” on page 1177
Edit Edits the currently selected working plane; see “Editing and Renaming Working 

Planes” on page 1177
Duplicate Duplicates all currently selected working planes
Delete Deletes all currently selected working planes
Activate Activates the currently selected working plane.

Alternatively, double-click on an existing working plane from the Working 
Planes palette to activate it.

Select Activates the currently selected working plane, if it is not already active, then 
performs the Select Working Plane command to display the grip handles for the 
plane

Working planes
saved in the

drawing

Utility menu
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The Active Planes List

Saving Working Plane Positions
The working plane position can be permanently saved with the drawing and accessed later from the Working Planes 
palette or Active Planes list on the View bar.
To permanently save a working plane position:

1. Select Window > Palettes > Working Planes.
The Working Planes palette opens.

2. Click the Utility Menu button at the bottom of the palette to open the Utility menu.
Alternatively, right-click (Windows) or Ctrl-click (Mac) on the palette to access the context menu. 

3. Select New.
Alternatively, select Modify > Working Plane > Save Working Plane or right-click (Windows) or Ctrl-click 
(Mac) on the drawing to access the context menu.
The New Working Plane dialog box opens. If there is a currently active working plane, the dialog box displays the 
origin and rotation values of the current plane. Otherwise, the dialog box displays the origin and rotation values of 
the global ground plane centered at the internal origin. 

4. Name the working plane position and reset the values, if desired.
5. Click OK. Saved working plane positions are displayed in alphabetical order in the palette. To access a saved 

working plane position, double-click its name in the Working Planes palette or select it from the Active Planes list 
on the View bar.

~~~~~~~~~~~~~~~~~~~~~~~~~
The Working Planes Palette
Editing and Renaming Working Planes

Editing and Renaming Working Planes
To edit or rename a working plane position:

1. Select Window > Palettes > Working Planes.
The Working Planes palette opens.

2. Select the working plan to edit.
3. Click the Utility Menu button at the bottom of the palette to open the Utility menu. 

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the palette to access the context menu.
4. Select Edit.

The Edit Working Plane dialog box opens. 
5. Enter the new name and/or origin and rotation values.
6. Click OK.

~~~~~~~~~~~~~~~~~~~~~~~~~
The Working Planes Palette

Accessing Existing Working Planes
Initially, when the working plane has not yet been changed, the only plane saved in the Working Planes palette is that of 
the active layer plane location, and only the active layer plane or the automatic working plane are available from the 
Active Planes list in the View bar. Once the position of the working plane has been changed, it can be accessed from 
different locations depending on whether the position has been saved. 
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Accessing Saved Working Planes

The Active Planes list on the View bar displays and switches among saved working planes. See “The View Bar” on 
page 37 and “The Active Planes List” on page 1168. Selecting a working plane cancels the automatic working plane.
To access working planes from the View bar:

While in a view other than Top/Plan, select a working plane from the Active Planes list.

The current working plane displays in bold; if it has not yet been saved, it displays as Working Plane. 
Alternatively, select Window > Palettes > Working Planes and double-click the name of the plane from the 
Working Planes palette.
The selected working plane displays.

Accessing Unsaved Working Plane Positions from the Current Drawing Session

To access unsaved working plane positions, select Modify > Working Plane > Next Working Plane and Modify > 
Working Plane > Previous Working Plane.
~~~~~~~~~~~~~~~~~~~~~~~~~
The Working Planes Palette
The Active Planes List
Working Plane Commands

Working Plane View and Modes
The three buttons on the View bar control how the working plane is viewed and how it interacts with certain tools and 
commands. 

~~~~~~~~~~~~~~~~~~~~~~~~~
The Working Planes Palette
Working Plane Commands

Aligning Objects to the Working Plane
When the working plane has been set to the desired location, it can be used to position 3D objects. One way to align 
objects precisely in 3D space is to align them to the working plane. 

Button Description

Look At Working Plane Changes the view to be perpendicular to the working plane; similar to the Top view 
under the View menu in that you are looking straight at the working plane

Active Layer Plane Views Sets the active layer plane as the reference for tools such as the Flyover tool, 
Walkthrough tool, and other viewing tools; used with the Flyover tool’s rotation 
center mode

Working Plane Views Sets the working plane as the reference for tools such as the Flyover tool, 
Walkthrough tool, and other viewing tools; used with the Flyover tool’s rotation 
center mode
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Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Objects to the Working Plane with Three Points
Setting an Object Surface to the Working Plane

Setting Objects to the Working Plane with Three Points

To align an object to the working plane with three points:

1. In a 3D view, set the working plane location as desired. 
2. Select the object to align to the working plane.
3. Click the Align Plane tool from the 3D Modeling tool set.
4. Click a location on the object to align with the origin of the working plane.
5. Click a second point on the object to define the X axis.

The line between the first and second points defines the X axis position.
6. Click a third point on the object to define the Y axis.

The line between the second and third points defines the Y axis position.
The object aligns itself to the working plane as defined by these points. If the surface was mistakenly aligned to 
the wrong side of the working plane, use the Mirror tool to flip the object to the opposite side of the working 
plane.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting an Object Surface to the Working Plane

Setting an Object Surface to the Working Plane
A rendered object can be aligned to the working plane.

To align a rendered object to the working plane:

1. Select a 3D view and a rendering mode for the drawing.
The drawing projection must be other than Top/Plan, with a rendering mode of Unshaded Polygon, Shaded 
Polygon, Shaded Polygon No Lines, or Final Shaded Polygon.

2. Select the 3D object to align to the working plane.
3. Click the Align Plane tool from the 3D Modeling tool set.

The cursor changes to a pointing hand when over the surface of a rendered object.
4. Click on the surface to align to the working plane.

Click 1

Click 2

Click 3

Object aligned to working plane

http://www.youtube.com/watch?v=ltg65piTjGQ
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The object’s selected surface is aligned to the working plane.
~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Objects to the Working Plane with Three Points

Animating Drawings

Two types of animations can be created from a Vectorworks 3D drawing—orbit point and move along path. The orbit 
point animator rotates by a specified number of degrees around a 3D object or selected point in the drawing. The move 
along path animator moves through the 3D drawing, following a specified path.
In Perspective view, only the portion of the model within the perspective frame (see “Cropped and Uncropped 
Perspective Views” on page 1144) is visible in the animation.
Windows-generated and Mac-generated movies can be viewed on either platform. Simply double-click the file to open 
it, or open it from your preferred viewer.

On Mac and Windows 7/8 platforms, an .mov (MPEG4) file with H.264 compression is created; on Windows XP 
and Vista an avi file with optional MJPEG compression is created. 

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Orbit Point Animations
Creating and Editing Move Along Path Animations
Adding Text or Title Screens to Animations

Creating Orbit Point Animations
The orbit point animator creates an animation that moves in a circular path around a specific 3D object or point.

Click the rendered surface to align to 
the working plane
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To create an orbit point animation:
1. Set up the drawing view.

Select the desired views from the View menu—Standard Views, Projection, and Rendering. In addition, use the 
Zoom tool to set the drawing magnification level. Ensure that only the layers and classes that should display in the 
animation are visible.

2. To specify an object or objects as the center of rotation, select the object or group of objects.
3. Select Model > Create Animation.

The Create Animation dialog box opens.
4. Set the Camera to Orbit Point.
5. Click Animation Options.

The Orbit Options dialog box opens.
Click to show/hide the parameters.

6. Click OK to return to the Create Animation dialog box.
7. Specify the remaining parameter settings in the Create Animation dialog box.

Click to show/hide the parameters.

Parameter Description

Rotation angle Specifies the amount of rotation (in degrees) for the animation; for example, to complete an 
orbit around the selected center of animation, enter 360

Rotate about 
center of

Active 
Layer Plane

Specifies the center of the active layer plane (0X, 0Y, 0Z) as the center of rotation for the 
animation

Working 
Plane

Specifies the center of the working plane (0I, 0J, 0K) as the center of rotation for the animation

Selection Specifies the center of the selected object(s) as the center of rotation for the animation

Parameter Description

Duration (in 
seconds)

Sets the total length of time of the animation
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8. Click Preview to check the animation before saving it. The preview defined by the Time Range settings is shown 
in the current interactive render mode (OpenGL or Wireframe).
At the end of the preview, the view is returned to the view displayed before the preview began.

9. When satisfied with the preview, click Save Movie to save the animation.
The saved movie observes the current Time Range settings. 
The Save As dialog box opens.

10. Enter the name for the movie file and specify its location. Click Save. The progress of movie creation is displayed.

Creating and Editing Move Along Path Animations
The move along path type of animation moves through a 3D drawing along a specified path. For example, create a 
walk-through presentation of a house. 

To create an animation moving along a specified path:
1. Set up the drawing view.

Select the desired views from the View menu: Standard Views, Rendering, and Projection.

Time Scale Specifies the animation rate; a value between 0.1 and 0.99 creates a slow motion effect, while 
a value between 1.01 and 10.00 speeds up the animation. Leave the default value of 1.00 for a 
normal time scale.

Frames per 
second

Sets the number of frames per second (fps) in the animation.
30 fps generally produces a smooth final animation.

Quality Sets the quality of the movie output; the higher the quality, the larger the resulting file.
The Very High setting is of appropriate quality for follow-on video editing.

Time Range Sets the duration of a preview or saved movie relative to the full movie duration. 
Full 
Duration

Previews/saves the complete movie

Limited 
Duration

Previews/saves only the specified section of the movie. Start Time and End Time can be set 
to any value between 0 and the Duration of the movie.

Parameter Description
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The drawing Projection must be set to a perspective view.
2. Save a view for each point along the path to use for creating the animation.

Use the Walkthrough and/or Flyover tools to change views. To save a view, select View > Save View. In the 
Save View dialog box that opens, enter the View Name, select the view parameters for saving, and then click OK 
(see “Creating Saved Views” on page 189).

3. Select Model > Create Animation.
The Create Animation dialog box opens.

4. Set the Camera to Move Along Path.
5. Click Animation Options.

The Select Animation dialog box opens.
6. Click New.

The New Animation Name dialog box opens.
Enter a name for this animation and then click Create to return to the Select Animation dialog box.

7. Select the name of the animation to edit and click Edit.
The Edit Path Animation dialog box opens.

8. From the list of views on the left, select the starting view name and click the right arrow to add it to the animation 
graph.
The first view is placed at the graph’s origin: 0 seconds, 0 drawing units/second.

9. Select the next view to use and click the right arrow to add it to the animation graph. Continue selecting views and 
adding them to the animation graph until the desired views have been included within the time allotment.

10. For each added view, a bar with a bead is added to the graph. Drag the bar and bead to change the animation 
settings (time elapsed between view changes and velocity of camera movement).

Saved views

Right/left arrows 
add/remove 

views in 
animation graph

Animation graph

Double-click the 
arrow to change 
the animation 
duration

Change the
magnification

level of the
animation graph

Timeline: Click and hold the mouse to preview 
the movie at a specific time value. Click and 

drag the mouse right or left along the timeline 
to update the preview interactively

Saved view bar: 
Click on a bar to 
select it (indicated 
by a highlight) and 
drag the bar right 
or left to change 
the time the view 
will appear. 
Double-click the 
bar to change the 
view direction

Bead: Drag a bead up 
and down the bar to 
change the camera 

speed

Preview the animation 
with the current settings 

at any time



  1184 | Animating Drawings
The distance between bars is the time in seconds that it takes to move from one view to the next.
Move the bead up and down to determine the slope of the line between bars. This slope indicates the velocity of 
the movement between views (the number of drawing units/second that the camera moves). In general, the slope 
should form a steady curve. An uneven curve will cause a choppy camera movement, speeding up and slowing 
down in a jolting manner. The slope may dip below the X axis; however, this may result in a negative velocity.
If a bar is currently selected, the saved view is inserted between that bar and the following bar. If no bars are 
selected, the saved view is inserted after all the bars that are currently in the animation graph. Bars can be dragged 
past each other to change the order of the views’ appearance. Each saved view can be added to the graph multiple 
times.
To add a pause to the animation, add the same view twice to the animation graph so that the views are next to each 
other in sequence. The line between the views should be flat (no upward or downward slope). This creates a 
velocity of zero and, therefore, a pause in the animation.

Setting the view to different specified X, Y, Z coordinates for each of these frames, makes the camera appear to 
stop its forward motion and pan from one direction to another. 

11. To set a specific camera target, double-click on a bar.
The Set View Direction dialog box opens.

Click to show/hide the parameters.

Parameter Description

Look towards Specifies the direction toward which the view should look
Current view Sets the view to the current bead’s saved view
Working plane 
origin

Sets the view to the working plane origin

Center of currently 
selected object

Sets the view to the X, Y, Z center of the currently selected object(s) bounding box

Center of following 
named object

Sets the view to look at the center of a named 3D object. Click Select a different named 
object to open the Look At Named Object dialog box. Select the object to look toward 
(named objects in walls or layer links cannot be selected).

Following point Sets the view to the specified X, Y, Z coordinates

To create a pause, place the same view twice in the animation 
graph, with no slope between the repeated views
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12. Click OK to exit the Set View Direction dialog box.
13. Click Done to return to the Create Animation dialog box.
14. Specify the remaining parameter settings in the Create Animation dialog box.
Click to show/hide the parameters.

15. Click Preview to check the animation before saving it. The preview defined by the Time Range settings is shown 
in the current interactive render mode (OpenGL or Wireframe).
At the end of the preview, the view is returned to the view displayed before the preview began.

16. When satisfied with the preview, click Save Movie to save the animation.
The saved movie observes the current Time Range settings. 
The Save As dialog box opens.

17. Enter the name for the movie file and specify its location. Click Save. The progress of movie creation is displayed.

Duplicating and Deleting Move Along Path Animations
Existing move along path animations can be duplicated or deleted from the Select Animation dialog box. 
To duplicate an animation:

1. Select the animation name from the animations list and click Duplicate. 
2. Enter a name for the duplicate animation, and click Create. 

The duplicate animation is created.
To delete an animation:

1. Select the animation name from the animations list and click Delete. 
2. Click OK. 

The animation is deleted.

Parameter Description

Duration (in 
seconds)

Sets the total length of time of the animation. 
This value is automatically set to five seconds for move along path animations, and this 
field is disabled to prevent accidental truncation of the specified path. The duration can 
be changed by double-clicking the arrow to the far right of the timeline on the Edit Path 
Animation dialog box. 

Time Scale Specifies the animation rate; a value between 0.1 and 0.99 creates a slow motion effect, 
while a value between 1.01 and 10.00 speeds up the animation. Leave the default value of 
1.00 for a normal time scale.

Frames per 
second

Sets the number of frames per second (fps) in the animation.
30 fps generally produces a smooth final animation.

Quality Sets the quality of the movie output; the higher the quality, the larger the resulting file.
The Very High setting is of appropriate quality for follow-on video editing.

Time Range Sets the duration of a preview or saved movie relative to the full movie duration. 
Full Duration Previews/saves the complete movie
Limited 
Duration

Previews/saves only the specified section of the movie. Start Time and End Time can be set 
to any value between 0 and the Duration of the movie.
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Adding Text or Title Screens to Animations
Unless text is specifically converted into a 3D object (using the Convert Text to Polylines command), the Vectorworks 
program views text as 2D. This means text in a drawing exported as a movie remains motionless, not moving with the 
other 3D objects. This principle is also true for any graphic images placed in the drawing.
The Vectorworks program can be used to create an animated title screen as a separate movie, using an orbit point 
animation to move the 2D text. (The move along path animator requires 3D perspective projection.) Then, using a 
third-party video editor, link the two files together to create one movie.

When creating a title screen animation, ensure that the title movie uses the same frame rate setting as the linked 
animation movie.



Dimensions
Use the various dimensioning tools to measure 2D and 3D objects, and to add dimensioning lines and measurements to 
the drawing. Dimensions can be created on a design layer, or in the annotation space of a sheet layer viewport (see 
“Creating Annotations for Sheet Layer Viewports” on page 1653).
There are also Tape Measure and Protractor tools to measure distances and angles, and a Center Mark tool to mark 
the center of circles, ovals, and rectangles.
When you add a new dimension, the dimension standard set in the document preferences is used by default (see 
“Dimension Preferences” on page 61). In addition, when a dimension tool is active, the default dimension standard can 
be set from the Tool bar. Select any of the built-in dimension standards, or create a custom standard specifically for the 
drawing. If the default dimension standard for the document is changed, any new dimension that is added will use the 
new standard; no existing dimensions are affected.
~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Document Preferences
Using Custom Dimension Standards
Associative Dimensioning
Unconstrained Linear Dimensioning
Constrained Linear Dimensioning
Dual Dimensioning
Radial Dimensioning
Marking Object Centers
Angular Dimensioning
Arc Length Dimensioning
Converting Objects to Dimensions
Dimensioning Exterior Walls
Modifying Dimensions
Measuring Distance
Geometric Dimensioning and Tolerancing

Using Custom Dimension Standards
Custom dimension standards can be created in the current file or imported from another drawing file. There are three 
ways to access the Custom Dimensions dialog box for managing custom dimensions.

• Select File > Document Settings > Document Preferences. From the Document Preferences dialog box, click 
the Dimensions tab, and then click Custom.
Alternatively, access the Document Preferences command from the document context menu (right-click on 
Windows, or Ctrl-click on Mac), or from the Quick Preferences menu on the Tool bar.

• With any one of the dimension tools in the Dims/Notes tool set selected, open the Dim Std list on the Tool bar and 
select Custom Standards.

• With an existing dimension selected, open the Dim Std list on the Object Info palette and select Custom 
Standards.

From the Custom Dimensions dialog box, several functions are available.

Function Description

New Opens the Assign Name dialog box, to create a new custom dimension standard; see “Creating a 
Custom Dimension Standard” on page 1188

Delete Deletes the selected custom dimension standard and replaces it with the standard you specify; see 
“Creating a Custom Dimension Standard” on page 1188
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Custom Dimension Standard
Editing a Custom Dimension Standard
Deleting a Custom Dimension Standard
Renaming a Custom Dimension Standard
Importing a Custom Dimension Standard
Replacing a Dimension Standard
Dimensions

Creating a Custom Dimension Standard
To create a custom dimension standard:

1. Select File > Document Settings > Document Preferences. From the Document Preferences dialog box, click 
the Dimensions tab, and then click Custom.
Alternatively, with any one of the dimension tools in the Dims/Notes tool set selected, open the Dim Std list on 
the Tool bar and select Custom Standards from the list. Alternatively, with an existing dimension selected, open 
the Dim Std list on the Object Info palette and select Custom Standards from the list.
The Custom Dimensions dialog box opens.

2. Click New.
The Assign Name dialog box opens.

3. Enter a name for this dimension standard and click OK.
4. Select the new dimension from the Standards list and click Edit.

The Edit Custom Dimension Standard dialog box opens.
Click to show/hide the parameters.

 

Edit Opens the Custom Dimension dialog box, to edit the selected custom dimension standard; see “Editing 
a Custom Dimension Standard” on page 1189

Rename Opens the Assign Name dialog box, to rename the selected custom dimension standard; see 
“Renaming a Custom Dimension Standard” on page 1190

Import Opens a file and imports the custom dimension standard you specify; see “Importing a Custom 
Dimension Standard” on page 1191

Replace Opens the Replace Dimension Standards dialog box, to specify which dimension standard to replace, 
and which standard to replace it with; see “Replacing a Dimension Standard” on page 1191

Parameter Description

Dimension line distances Specifies the dimension line distances for linear, radial, and ordinate dimensions
Note: Distances are in Displays the drawing units currently in use for the file
Witness Lines Applies witness lines to dimensions; when deselected, witness lines are hidden
Fixed Witness Line Length Select to use a fixed length for the witness lines rather than a fixed offset from the 

dimensioned object (the default). When selected, the field for setting the witness line 
length is enabled on the top part of the dialog box.

To change the length of a particular witness line, use the Override option in the 
Object Info palette

Function Description
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5. Enter the desired values for the display of dimensions, and then click OK. Click OK again to close the Custom 
Dimensions dialog box.

6. To set the new standard as the default for the document, select the new standard from the Dimension Standard 
list, and then click OK.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Using Custom Dimension Standards
Editing Dimension Properties

Editing a Custom Dimension Standard
To edit a custom dimension standard:

1. Select File > Document Settings > Document Preferences. From the Document Preferences dialog box, click 
the Dimensions tab, and then click Custom.

Dimensions Always Inside When selected, the dimension value is always centered between the witness lines. 
When deselected, the dimension value is automatically positioned outside the witness 
lines if it is too large to fit between them.

Linear Markers Select the marker attributes for use with linear dimension markers (see “Marker 
Attributes” on page 1102)

Other Markers Select the marker attributes for use with other dimension markers 
Leader Line Markers Select the marker attributes for use with dimension leader lines. 

The marker is only visible if you first use the Object Info palette to add a leader 
line to the dimension, and then use the Attributes palette to add an end marker to 
the leader line (see “Marker Attributes” on page 1102).

SIA Format Numbers Sets all numbers to use the SIA format; not available when a dual layout is selected
Tolerance Size Sets the size of the tolerance in relation to the dimension text
Text Rotation Sets how text is handled when a dimension is rotated; text can be horizontal, aligned, 

or horizontal/vertical
Text Position Sets the location of the dimension value relative to the dimension line:

• Above/Left places the text above the dimension line for non-vertical dimensions, or 
left of the dimension line for vertical dimensions

• Above/Right places the text above the dimension line for non-vertical dimensions, 
or right of the dimension line for vertical dimensions

• Outside places the text outside the area enclosed by the two witness lines and 
dimension line, regardless of the dimension orientation

Layout Sets whether dimensions display as single values, dual - side by side, or dual - stacked
Dual view If a dual layout is selected, specify whether both dimensions are shown, primary only, 

or secondary only
Text Style Select a text style from either the default content or the current file’s content. To 

format the text using options on the Text menu, select <Un-Styled>. See “Using Text 
Styles” on page 393 and “Formatting Text” on page 389.

Parameter Description

http://www.youtube.com/watch?v=g7uThgm19rM
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Alternatively, with any one of the dimension tools in the Dims/Notes tool set selected, open the Dim Std list on 
the Tool bar and select Custom Standards. Alternatively, with an existing dimension selected, open the Dim Std 
list on the Object Info palette and select Custom Standards.
The Custom Dimensions dialog box opens.

2. Select the custom standard to edit, and click Edit.
The Custom Dimension dialog box opens.

3. Edit the settings as needed, and click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
Using Custom Dimension Standards

Deleting a Custom Dimension Standard
To delete a custom dimension standard:

1. Select File > Document Settings > Document Preferences. From the Document Preferences dialog box, click 
the Dimensions tab, and then click Custom.
Alternatively, with any one of the dimension tools in the Dims/Notes tool set selected, open the Dim Std list on 
the Tool bar and select Custom Standards. Alternatively, with an existing dimension selected, open the Dim Std 
list on the Object Info palette and select Custom Standards. 
The Custom Dimensions dialog box opens.

2. Select the custom standard to delete, and click Delete.
The Replace Dimension dialog box opens.

3. Select a new dimension standard to replace the standard being deleted, and then click OK.
Any existing dimensions that used the deleted standard are changed to the replacement standard.

~~~~~~~~~~~~~~~~~~~~~~~~~
Using Custom Dimension Standards

Renaming a Custom Dimension Standard
To rename a custom dimension standard:

1. Select File > Document Settings > Document Preferences. From the Document Preferences dialog box, click 
the Dimensions tab, and then click Custom.
Alternatively, with any one of the dimension tools in the Dims/Notes tool set selected, open the Dim Std list on 
the Tool bar and select Custom Standards. Alternatively, with an existing dimension selected, open the Dim Std 
list on the Object Info palette and select Custom Standards. 
The Custom Dimensions dialog box opens.

2. Select the custom standard to rename, and click Rename.
The Assign Name dialog box opens.

3. Enter a new name for this dimension standard and click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
Using Custom Dimension Standards
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Importing a Custom Dimension Standard
To import a custom dimension standard:

1. Select File > Document Settings > Document Preferences. From the Document Preferences dialog box, click 
the Dimensions tab, and then click Custom.
Alternatively, with any one of the dimension tools in the Dims/Notes tool set selected, open the Dim Std list on 
the Tool bar and select Custom Standards. Alternatively, with an existing dimension selected, open the Dim Std 
list on the Object Info palette and select Custom Standards. 
The Custom Dimensions dialog box opens.

2. Click Import.
The standard Open dialog box displays.

3. Select the file from which the dimension standard will be imported and click Open.
The Select Item dialog box opens. 

4. Select the dimension standard to import and click OK.
The imported dimension displays in the Custom Dimensions dialog box for the current drawing file. 

~~~~~~~~~~~~~~~~~~~~~~~~~
Using Custom Dimension Standards

Replacing a Dimension Standard
Replace any default or custom dimension standard with another dimension standard.
To replace a dimension standard:

1. Select File > Document Settings > Document Preferences. From the Document Preferences dialog box, click 
the Dimensions tab, and then click Custom.
Alternatively, with any one of the dimension tools in the Dims/Notes tool set selected, open the Dim Std list on 
the Tool bar and select Custom Standards. Alternatively, with an existing dimension selected, open the Dim Std 
list on the Object Info palette and select Custom Standards.
The Custom Dimensions dialog box opens.

2. Click Replace.
The Replace Dimension Standards dialog box opens.

3. Select the dimension standard to be replaced in the Replace list and select the standard to replace it with in the 
with list. Click OK.
Any existing dimensions that used the previous standard are changed to the replacement standard.

~~~~~~~~~~~~~~~~~~~~~~~~~
Using Custom Dimension Standards

Associative Dimensioning
In document preferences, the Associate dimensions option is selected by default. This automatically links dimensions 
to 2D objects, as well as walls and wall components. For linear dimensions to be associated, the dimension must be 
applied between two vertex points.
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A dimension is linked to its associated object with coincident constraints. This means that, when a linear, radial, or 
diametrical dimension is associated with an object, if the dimension is resized or moved, the associated object is resized 
or moved also, and vice versa.

If an angular associative dimension is resized or moved, the association with the object is broken. To maintain the 
association, move the dimensioned object instead.

Associative dimensions can exist across layers of the same scale. To apply an associative dimension across layers, 
Layer Options must be set to Show/Snap/Modify Others. Associative dimensions can be created on viewports in 
annotation edit mode (see “Creating Annotations for Sheet Layer Viewports” on page 1653).

If an associative dimension is used across layers, the association is broken if the scale of one of the layers changes.
Associative dimensions can only be placed in the plane defined by the object or objects being dimensioned; when 
multiple objects are dimensioned, they must be co-planar to create the association. The associated dimension of an 
object changes planes with the object, if the object changes its plane.
If a drawing has overlapping objects, it may be unclear which object should be associated with a dimension. When you 
dimension objects that have a shared endpoint, the Auto associate document preference controls whether the 
association is made automatically or manually. (See “Dimension Preferences” on page 61.)

• To always automatically associate a dimension with the top-most object, enable the Auto associate option.
• To manually select the object with which to associate the dimension, disable the Auto associate option; when you 

dimension an object that shares an endpoint with another object, the Select Object to Associate dialog box opens.

Unconstrained Linear Dimensioning
Use the Unconstrained Linear Dimension tool to draw dimension lines at any angle. This is different from the 
Constrained Linear Dimension tool, which constrains dimension lines to the X or Y axis of the plane on which the 
dimension is created. In addition to measuring and dimensioning objects, you can use this tool to calculate the distance 
between two or more points in the drawing area.

The dimension is not 
associated with the 

object

Green constraint markers 
show that the dimension is 
associated with the object

The triangle is being 
dimensioned, but the triangle 

overlaps with the purple 
rectangle and they share an 

endpoint

Because Auto associate is 
disabled, the Select Object to 
Associate dialog box opens to 
allow selection of the appropriate 
object
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The dimension text can be moved as needed. See “Modifying Dimensions” on page 1210.
~~~~~~~~~~~~~~~~~~~~~~~~~
Unconstrained Linear Dimension
Unconstrained Chain Dimension
Unconstrained Baseline Dimension
Modifying Dimensions
Associative Dimensioning
Constrained Linear Dimensioning

Unconstrained Linear Dimension
The Unconstrained Linear mode creates a dimension line with a single measurement.

To create an unconstrained linear dimension line with a single measurement:

1. Click the Unconstrained Linear Dimension tool from the appropriate tool set/palette, and select Unconstrained 
Linear mode.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

2. Click to set the measurement start point.
3. Click to end the measurement.
4. Move the cursor away from the object to the desired offset location.

In a 3D view, the first two clicks determine the X axis of the plane where the dimension will be placed; move the 
cursor to rotate the dimension plane as desired. The dimension plane can be horizontal or vertical to the layer 
plane, or aligned to adjacent faces of a 3D object being dimensioned.

5. Click to place the dimension line.

Mode Description

Unconstrained Linear Creates a dimension line with a single measurement
Unconstrained Chain Creates a continuous chain of dimension lines
Unconstrained Baseline Creates a series of connected dimension lines, starting from an initial base point
Preferences For Unconstrained Chain mode, specifies whether dimensions are created as a single 

unconstrained chain object, or as individual dimension objects; also enables collision 
control, which automatically spaces text blocks so that they do not overlap

Dimension Standards To change the dimension standard for new dimensions created in the document, select a 
standard from the list; select Custom Standards to create or manage custom dimensions 
(see “Using Custom Dimension Standards” on page 1187)

Unconstrained Linear

Unconstrained Chain

Chain Dimension Preferences

Unconstrained Baseline

Preferences Dimension Standards
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~~~~~~~~~~~~~~~~~~~~~~~~~
Unconstrained Linear Dimensioning

Unconstrained Chain Dimension
Unconstrained Chain mode creates a series of connected dimension lines, with each line segment displaying its specific 
measurements.
When dimensions are part of a chain object, they can all be moved at once, and their attributes and properties can be 
changed as a group. The properties of dimensions in a chain object also can be edited individually. When dimensions in 
the chain are modified, the other dimensions adjust automatically. See “Modifying Dimensions” on page 1210 for more 
information about editing chain objects.

To create an unconstrained chain of connected dimension lines:

1. Click the Unconstrained Linear Dimension tool from the appropriate tool set/palette, and select Unconstrained 
Chain mode.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

2. Click Preferences from the Tool bar.
The Chain Dimension Preferences dialog box opens. Select whether to Create smart chain dimension objects or 
to Create individual dimension objects adjacent to each other. Also select whether to use collision control to 
automatically space text blocks so that they do not overlap. Click OK.

3. Click to set the measurement start point.
4. Click to end the measurement of the first segment.
5. Move the cursor away from the object to the desired offset location.

In a 3D view, the first two clicks determine the X axis of the plane where the dimension will be placed; move the 
cursor to rotate the dimension plane as desired. The dimension plane can be horizontal or vertical to the layer 
plane, or aligned to adjacent faces of a 3D object being dimensioned.

6. Click to place the first dimension line.

Click 1

Click 2
Click 3

The dimension can be horizontal or vertical 
to the layer plane, or aligned to a face 
adjacent to the dimension line
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7. Move the cursor to the end of the next segment and click to set its endpoint.
8. Continue setting segments.
9. Double-click to end the chain.

~~~~~~~~~~~~~~~~~~~~~~~~~
Unconstrained Linear Dimensioning

Unconstrained Baseline Dimension
Unconstrained Baseline mode creates a series of connected dimension lines, with each line segment measuring the 
distance from the initial starting point (the base point).

To create a series of unconstrained baseline dimension lines:

1. Click the Unconstrained Linear Dimension tool from the appropriate tool set/palette, and select Unconstrained 
Baseline mode.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

2. Click to set the measurement start point.
3. Click to end the measurement of the first segment.
4. Move the cursor away from the object to the desired offset location.

In a 3D view, the first two clicks determine the X axis of the plane where the dimension will be placed; move the 
cursor to rotate the dimension plane as desired. The dimension plane can be horizontal or vertical to the layer 
plane, or aligned to adjacent faces of a 3D object being dimensioned.

5. Click to place the dimension line.
6. Move the cursor to the end of the next segment and click to set its endpoint.
7. Continue setting segments.
8. Double-click to end the baseline.

~~~~~~~~~~~~~~~~~~~~~~~~~
Unconstrained Linear Dimensioning

Click 1

Click 2 Click 3
Double-click

Click 1

Click 2 Click 3
Double-click



  1196 | Constrained Linear Dimensioning
Constrained Linear Dimensioning
Use the Constrained Linear Dimension tool to draw dimension lines that are constrained to the X or Y axis of the 
plane on which the dimension is created. This is different from the Unconstrained Linear Dimension tool, which can 
draw dimension lines at any angle. In addition to measuring and dimensioning objects, you can use this tool to calculate 
the horizontal or vertical distance between two or more points in the drawing.
In a 2D view, the dimension line is constrained to be parallel to either the X or Y axis of the active plane. In a 3D view, 
the dimension line is constrained to the X axis of the plane that it is created on, but the plane can have any rotation 
(same as the Unconstrained Linear Dimension tool).

If the Snap to Working Plane option on the Snapping palette is enabled, the dimension line is projected to the 
current working plane, in both 2D and 3D views.

The dimension text can be moved as needed. See “Modifying Dimensions” on page 1210.
Click here for a video tip on this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Constrained Linear Dimension
Constrained Chain Dimension
Constrained Baseline Dimension
Ordinate Dimensions
Selected Object Dimensions
Modifying Dimensions
Associative Dimensioning
Unconstrained Linear Dimensioning

Constrained Linear Dimension
The Constrained Linear mode creates a dimension line with a single measurement.

Mode Description

Constrained Linear Creates a constrained dimension line with a single measurement
Constrained Chain Creates a continuous chain of constrained dimension lines
Constrained Baseline Creates a series of connected constrained dimension lines, starting from an initial base point
Ordinate Creates a series of constrained ordinate dimensions, starting from an initial base point
Selected Objects Creates a constrained dimension line for the greatest span of a selected object or group of 

objects
Preferences For Constrained Chain mode, specifies whether dimensions are created as a single chain 

object, or as individual dimension objects; also enables collision control, which 
automatically spaces text blocks so that they do not overlap

Dimension Standards To change the dimension standard for new dimensions created in the document, select a 
standard from the list; select Custom Standards to create or manage custom dimensions (see 
“Using Custom Dimension Standards” on page 1187)

Constrained Linear

PreferencesConstrained Chain

Constrained Baseline

 Ordinate

Selected Objects Dimension Standards

http://www.youtube.com/watch?v=pdWFKH8UalI
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To create a constrained linear dimension line with a single measurement:

1. Click the Constrained Linear Dimension tool from the appropriate tool set/palette, and select Constrained 
Linear mode.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

2. Click to set the measurement start point.
3. Click to set the end of the measurement.
4. Move the cursor away from the object to the desired offset location.

In a 2D view, the dimension line preview is constrained to be parallel to either the X or Y axis of the layer plane. 
In a 3D view, the first two clicks determine the X axis of the plane where the dimension will be placed; move the 
cursor to rotate the dimension plane as desired. The dimension plane can be horizontal or vertical to the layer 
plane, or aligned to adjacent faces of a 3D object being dimensioned.

5. Click to place the dimension line.

~~~~~~~~~~~~~~~~~~~~~~~~~
Constrained Linear Dimensioning

Constrained Chain Dimension
The Constrained Chain mode creates a series of constrained, connected dimension lines, with each line segment 
displaying its specific measurements.
When dimensions are part of a chain object, they can all be moved at once, and their attributes and properties can be 
changed as a group. The properties of dimensions in a chain object also can be edited individually. When dimensions in 
the chain are modified, the other dimensions adjust automatically. See “Modifying Dimensions” on page 1210 for more 
information about editing chain objects.

To create a chain of constrained connected dimension lines:

1. Click the Constrained Linear Dimension tool from the appropriate tool set/palette, and select Constrained 
Chain mode.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

2. Click Preferences from the Tool bar.
The Chain Dimension Preferences dialog box opens.
Select whether to Create smart chain dimension objects or to Create individual dimension objects adjacent 
to each other. Also select whether to use collision control to automatically space text blocks so that they do not 
overlap. Click OK.

3. Click to set the measurement start point.
4. Click to set the end of the first measurement.
5. Move the cursor away from the object to the desired offset location.

Click 1

Click 3Click 2
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In a 2D view, the dimension line preview is constrained to be parallel to either the X or Y axis of the layer plane. 
In a 3D view, the first two clicks determine the X axis of the plane where the dimension will be placed; move the 
cursor to rotate the dimension plane as desired. The dimension plane can be horizontal or vertical to the layer 
plane, or aligned to adjacent faces of a 3D object being dimensioned.

6. Click to place the first dimension line.
7. Move the cursor to the end of the next segment and click to set its endpoint.
8. Continue setting segments.
9. Double-click to end the chain.

~~~~~~~~~~~~~~~~~~~~~~~~~
Constrained Linear Dimensioning

Constrained Baseline Dimension
Constrained Baseline modes create a series of constrained, connected dimension lines, with each line segment 
measuring the distance from the initial starting point (the base point).

To create a series of constrained baseline dimension lines:

1. Click the Constrained Linear Dimension tool from the appropriate tool set/palette, and select Constrained 
Baseline mode.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

2. Click to set the measurement start point.
3. Click to set the end of the first measurement.
4. Move the cursor away from the object to the desired offset location.

In a 2D view, the dimension line preview is constrained to be parallel to either the X or Y axis of the layer plane. 
In a 3D view, the first two clicks determine the X axis of the plane where the dimension will be placed; move the 
cursor to rotate the dimension plane as desired. The dimension plane can be horizontal or vertical to the layer 
plane, or aligned to adjacent faces of a 3D object being dimensioned.

5. Click to place the first dimension line.
6. Move the cursor to the end of the next segment and click to set its endpoint.
7. Continue setting segments.

Click 1
Click 2

Click 3

Double-click

Click 4

Click 5

Constrained chain dimension with collision control preference enabled
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8. Double-click to end the baseline.
~~~~~~~~~~~~~~~~~~~~~~~~~
Constrained Linear Dimensioning

Ordinate Dimensions
The Ordinate mode measures and dimensions a series of either horizontal or vertical distances from one fixed point. 
This mode of the Constrained Linear Dimension tool always creates dimensions on the active plane.

To draw constrained ordinate dimensions:

1. Click the Constrained Linear Dimension tool from the appropriate tool set/palette, and select Ordinate mode.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

2. Click to set the measurement start point; the first segment is always considered the fixed point and is labeled 0. 
3. Click to set the length of the first segment.
4. Move the cursor horizontally or vertically to the first location to be measured from the initial segment; click to set 

the segment.
5. Continue creating segments.
6. Double-click to complete the dimension.

~~~~~~~~~~~~~~~~~~~~~~~~~
Constrained Linear Dimensioning

Selected Object Dimensions
The Selected Objects mode measures and dimensions the horizontal or vertical span of any 2D or 3D object, or the 
edge-to-edge span of several objects or a group of objects. In all cases, the tool measures the greatest span. Horizontal 
dimension lines can be drawn inside, above, or below an object or group of objects. Vertical dimension lines can be 
drawn inside, to the right, or to the left of an object or group of objects. This mode of the Constrained Linear 
Dimension tool always creates dimensions on the active plane.

1. Select the object or objects to dimension.
2. Click the Constrained Linear Dimension tool from the appropriate tool set/palette, and select Selected Objects 

mode.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

3. Click near the object or group of objects to be dimensioned.
4. Move the cursor in the desired direction where the dimension should be created. A preview dimension displays, 

constrained in either the horizontal or vertical direction.

Click 1

Click 2

Click 3

Double-click
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5. Click to set the position of the dimension line.

~~~~~~~~~~~~~~~~~~~~~~~~~
Constrained Linear Dimensioning

Dual Dimensioning
Dual dimensioning displays two sets of values, such as inches and millimeters, within a single dimension. These values 
have independent unit settings and attributes. Dual dimensions can be displayed side by side or stacked.

Control the units for each dimension through File > Document Settings > Units. The primary dimension uses the 
Units set on the General Display and Dimensions tab of the Units dialog box. The settings on the Dual Dimensions tab 
provide full control of the unit of measurement, unit marks, rounding, and formatting used for the secondary 
dimension.
Once a dual dimension is placed on the drawing, adjust the individual attributes for both the primary and secondary 
dimension from the Object Info palette. The Dual View and Prim/Sec attributes apply to dual dimensions.
~~~~~~~~~~~~~~~~~~~~~~~~~
Modifying Dimensions
Units

Radial Dimensioning
The Radial Dimension tool measures and marks either radius or diameter dimensions for arcs and circles. This tool 
does not work on ovals or objects with rounded corners.
The Radial Dimension tool can place the dimension lines and measurements either inside or outside of the circle/arc. 
This tool always creates the dimension on the same plane with the arc or circle that is being dimensioned.

 

Mode Description

Internal Diametrical Measures and dimensions the diameter of a circle or arc, placing the dimension inside the 
object

External Diametrical Measures and dimensions the diameter of a circle or arc, placing the dimension outside 
the object

Click 1

Click 2

Side-by-side dual dimension Stacked dual dimension

Internal Diametrical

Right-Hand ShoulderExternal Diametrical

Interior Radial

External Radial

Left-Hand Shoulder Dimension Standards
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~~~~~~~~~~~~~~~~~~~~~~~~~
Diametrical Dimensioning Inside Circle/Arc
Diametrical Dimensioning Outside Circle/Arc
Radial Dimensioning Inside Circle/Arc
Radial Dimensioning Outside Circle/Arc
Modifying Dimensions
Associative Dimensioning

Diametrical Dimensioning Inside Circle/Arc
The Internal Diametrical mode measures and dimensions the diameter of a circle or arc, and places the dimension 
inside the object.

To dimension the diameter of a circle or arc and place the dimension inside the object:

1. Click the Radial Dimension tool from the appropriate tool set/palette, and select Internal Diametrical mode.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

2. Click on or within the arc or circle to dimension.
3. Move the cursor to preview the dimension line location.
4. Click to place the dimension.

~~~~~~~~~~~~~~~~~~~~~~~~~
Radial Dimensioning

Interior Radial Measures and dimensions the radius of a circle or arc, placing the dimension inside the 
object

External Radial Measures and dimensions the radius of a circle or arc, placing the dimension outside the 
object

Left-Hand Shoulder Places an exterior measurement with the dimension text to the left of the dimension 
leader shoulder

Right-Hand Shoulder Places an exterior measurement with the dimension text to the right of the dimension 
leader shoulder

Dimension Standards To change the dimension standard for new dimensions created in the document, select a 
standard from the list; select Custom Standards to create or manage custom dimensions 
(see “Using Custom Dimension Standards” on page 1187)

Mode Description
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Modifying Dimensions

Diametrical Dimensioning Outside Circle/Arc
The External Diametrical mode measures and dimensions the diameter of a circle or arc, and places the dimension 
outside the object.

To dimension the diameter of a circle or arc and place the dimension outside the object:

1. Click the Radial Dimension tool from the appropriate tools set/palette, and select External Diametrical mode.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

2. Specify the side of the dimension line to place the measurement.
To place it to the right of the line, click Right-Hand Shoulder mode button. To place it to the left of the line, click 
the Left-Hand Shoulder mode button.

3. Click on or within the arc or circle to dimension.
4. Move the cursor to preview the dimension line location.
5. Click to place the dimension.

~~~~~~~~~~~~~~~~~~~~~~~~~
Radial Dimensioning
Modifying Dimensions

Radial Dimensioning Inside Circle/Arc
The Interior Radial mode measures and dimensions the radius of a circle or arc, and places the dimension inside the 
object.

To dimension the radius of a circle or arc and place the dimension inside the object:

1. Click the Radial Dimension tool from the appropriate tool set/palette, and select Interior Radial mode.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

2. Click on or within the arc or circle to dimension.
3. Move the cursor to preview the dimension line location.
4. Click to place the dimension.
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~~~~~~~~~~~~~~~~~~~~~~~~~
Radial Dimensioning
Modifying Dimensions

Radial Dimensioning Outside Circle/Arc
The External Radial mode measures and dimensions the radius of a circle or arc, and places the dimension outside the 
object.

To dimension the radius of a circle or arc and place the dimension outside the object:

1. Click the Radial Dimension tool from the appropriate tool set/palette, and select External Radial mode.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

2. Specify the side of the dimension line to place the measurement.
To place it to the right of the line, click the Right-Hand Shoulder mode button. To place it to the left of the line, 
click the Left-Hand Shoulder mode button.

3. Click on or within the arc or circle to dimension.
4. Move the cursor to preview the dimension line location.
5. Click to place the dimension.

~~~~~~~~~~~~~~~~~~~~~~~~~
Radial Dimensioning
Modifying Dimensions

Marking Object Centers
The Center Mark tool divides an object or object face into quarters, marking the exact center of the object. This tool 
works for circles, ovals, rectangles, rounded rectangles, and faces of 3D objects that were created by a circular edge. In 
addition, it can place center marks on the corners of a rounded rectangle.
When the Center Mark tool is active, you can change the dimension standard for new dimensions created in the 
document from the Tool bar. To do so, select a standard from the Dim Std list, or select Custom Standards to create or 
manage custom dimensions (see “Using Custom Dimension Standards” on page 1187).

Marking the Center of an Object

To mark the center of an object:

1. Click the Center Mark tool from the Dims/Notes tool set.
2. Click on the object to mark.

The center is marked by the intersection of two lines.
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Marking the Center of a Rounded Rectangle Corner

To place a center mark in the corners of a rounded rectangle:

1. Click the Center Mark tool from the Dims/Notes tool set.
2. While pressing Option (Mac) or Alt (Windows), move the cursor over the rounded rectangle corner to mark.
3. Click to place the center mark.

The center is marked by the intersection of two lines.

~~~~~~~~~~~~~~~~~~~~~~~~~
Modifying Dimensions

Angular Dimensioning
The Angular Dimension tool measures and dimensions angles. Dimension the angle between two object edges, 
between two sides of a single object, between a single object and a reference line, or between two reference lines.
This tool works with all objects with linear or planar sides, including rounded and rotated rectangles, lines, polylines, 
polygons, and solids. It does not, however, work with circles, ovals, or arcs. In addition, it cannot dimension between 
parallel lines or lines on different planes.

If the Snap to Working Plane option on the Snapping palette is enabled, the face of the object being dimensioned 
must be parallel to the working plane.

Mode Description

Edges Dimensions the angle between two object edges or faces
Reference Line and Edge Dimensions the angle between an object and a reference line
Reference Lines Dimensions the angle between two reference lines

Click anywhere
on the object

Edges

Dimension StandardsReference Line and Edge Reference Lines
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~~~~~~~~~~~~~~~~~~~~~~~~~
Angle Between Two Object Edges or Faces
Angle Between One Reference Line and an Object
Angle Between Two Reference Lines
Modifying Dimensions
Associative Dimensioning

Angle Between Two Object Edges or Faces

To dimension the angle between the edges or faces of two objects:

1. Click the Angular Dimension tool from the appropriate tool set/palette, and select the Edges mode.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

2. Click the edge or face of the first object.
A preview line displays.

3. Click the edge or face of the second object.
An angular dimension preview displays.
To select a different angle—for example, spanning the opposite direction—move the cursor until the preview 
displays the desired angle.

4. Click a third time to define the radius of the dimension.

~~~~~~~~~~~~~~~~~~~~~~~~~
Angular Dimensioning
Modifying Dimensions

Angle Between One Reference Line and an Object

To dimension an angle between one reference line and an object:

1. Click the Angular Dimension tool from the appropriate tool set/palette, and select the Reference Line and Edge 
mode.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

Dimension Standards To change the dimension standard for new dimensions created in the document, 
select a standard from the list; select Custom Standards to create or manage custom 
dimensions (see “Using Custom Dimension Standards” on page 1187)

Mode Description

Click 1 Click 2 Click 3
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2. Click to set the start of the reference line.
A reference line preview displays. 

3. Click again to set the end of the reference line.
The cursor changes to a pointing hand.

4. Click on the edge of the object (and, therefore, angle) to dimension.
An angular dimension preview displays.
To select a different angle—for example, spanning the opposite direction—move the cursor until the preview 
displays the desired angle. 

5. When the preview displays the desired angle, click again to draw the reference line and to define the angle of the 
dimension.

~~~~~~~~~~~~~~~~~~~~~~~~~
Angular Dimensioning
Modifying Dimensions

Angle Between Two Reference Lines

To dimension an angle between two references lines:

1. Click the Angular Dimension tool from the appropriate tool set/palette, and select the Reference Lines mode.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

2. Click to set the start of the first reference line.
A reference preview line displays.

3. Click again to set the end of the first reference line.
4. A second reference line preview displays.
5. Click a third time to set the end of the second reference line.

An angular dimension preview displays.
To select a different angle—for example, spanning the opposite direction—move the cursor until the preview 
displays the desired angle.

6. When the preview displays the desired angle, click again to define the angle of the dimension.

Click 1

Click 2

Click 3

Click 4

Click 1 Click 2

Click 3
Click 4



Arc Length Dimensioning |  1207
~~~~~~~~~~~~~~~~~~~~~~~~~
Angular Dimensioning
Modifying Dimensions

Arc Length Dimensioning
The Arc Length Dimension tool measures and dimensions the length of an arc anywhere along its circumference. The 
dimension can be shown with its witness lines perpendicular to a chord on the arc, or perpendicular to a line tangent to 
the arc. There are also modes to hide or show a graphic of an arc over the dimension measurement.
This tool works with arcs, polylines that include arc segments, arc-based 3D objects, and round walls. It always creates 
the dimension on the same plane with the arc that is being dimensioned.

To create an arc length dimension:

1. Click the Arc Length Dimension tool from the appropriate tool set/palette.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

2. Select the desired mode for the display of the witness lines and whether to use the arc indicator over the dimension 
measurement.

3. Click to set the measurement start point.
4. Click to set the end of the measurement.
5. Move the cursor away from the object.

This specifies how far the dimension line is offset from the measured object.
6. Click to place the dimension line.

Mode Description

Witness Lines Perpendicular to Chord Dimensions the arc with witness lines that would be perpendicular to a 
chord drawn across the arc

Witness Lines Perpendicular to Tangent Dimensions the arc with witness lines that would be perpendicular to a 
line drawn tangent to the arc

Arc Indicator Visible Displays an arc graphic over the dimension measurement
Arc Indicator Invisible Uses a dimension measurement with no arc graphic
Dimension Standards To change the dimension standard for new dimensions created in the 

document, select a standard from the list; select Custom Standards to 
create or manage custom dimensions (see “Using Custom Dimension 
Standards” on page 1187)

Witness Lines
Perpendicular to Chord

Dimension StandardsWitness Lines
Perpendicular to Tangent

Arc Indicator Visible

Arc Indicator Invisible
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~~~~~~~~~~~~~~~~~~~~~~~~~
Modifying Dimensions
Associative Dimensioning

Converting Objects to Dimensions
To convert a line, double line, or arc to a dimension:

1. Select the object to convert.
2. Select Modify > Convert > Convert Object to Dimension.
3. The object is converted to a dimension. Lines change to linear dimensions, and arcs change to angular dimensions.

~~~~~~~~~~~~~~~~~~~~~~~~~
Modifying Dimensions

Dimensioning Exterior Walls
The exterior walls of a building can be automatically dimensioned with the Dimension Exterior Walls command. The 
command can:

• dimension exterior walls by outside edge or center line;
• associate dimensions with walls;
• dimension only visible wall components; and

Click 3

Click 2Click 1

Click 3

Click 2Click 1
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• dimension all windows and doors in the exterior walls by the center line or the edge of the openings.
For window objects, the rough opening is calculated as the unit size plus two times the shim gap. For door objects, 
the rough opening is calculated as the leaf size plus two times the jamb width plus two times the shim gap.
The exterior wall dimensioner uses the dimension standard specified on the Dimensions tab of the document 
preferences (File > Document Settings > Document Preferences) and the unit selection and precision settings in 
File > Document Settings > Units.

To generate exterior wall dimensions:
1. In a file with exterior walls, determine whether you wish to dimension to the structural or non-structural 

components of the wall. To dimension to the structural components, such as framing components, make the 
classes of the non-structural components invisible.
The wall styles available in the Vectorworks Architect product contain pre-classed components, making it easy to 
show and hide the desired portions of the wall. 

2. Select the Dimension Exterior Walls command from the appropriate menu:
• Architect workspace: AEC > Dimension Exterior Walls 
• Landmark workspace: Landmark > Architectural > Dimension Exterior Walls 
• Spotlight workspace: Spotlight > Architectural > Dimension Exterior Walls 
The Dimension Exterior Walls dialog box opens. Specify how to dimension the walls.

Click to show/hide the parameters.

Parameter Description

Source Layer Specifies the location of the walls to be dimensioned
Options Specify the dimension methods

Dimension T-joins in 
exterior walls

Interior walls which intersect with the exterior walls are dimensioned

Make dimensions 
associative

Associates dimensions with the wall or wall component; dimensions move and update 
with the wall or wall component

Dimension to Wall Specifies whether to dimension to the wall extents or center lines
Dimension to Specifies whether to dimension to the edge of the openings or to the center of the 

openings
Rough openings are automatically defined in door and window objects. To add a 
rough opening to a symbol inserted in a wall, draw an invisible polygon (line weight 
0, no fill) with three vertices to the extents of the rough opening.

Text Options Specifies dimension text properties
Rotation Controls the orientation of the dimension text

• Horiz/Vert places text horizontally for horizontal dimensions and vertically for vertical 
dimensions

• Horizontal keeps text always horizontal
• Aligned places text according to the dimension angle

Location Specifies whether the text should be centered between the witness lines if space permits, 
or always placed outside the witness lines

If forced outside, 
distance

Indicates the offset for text forced outside the witness lines
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3. Click OK.
The exterior wall dimensions are drawn automatically.

~~~~~~~~~~~~~~~~~~~~~~~~~
Using Wall Styles
Dimensions

Modifying Dimensions
Modify dimensions by adjusting parameters in the Object Info palette or the Properties dialog box. Use commands on 
the object context menu to format dimension text, to delete and edit individual dimensions within a chain, to add a 
dimension to a single or chain linear dimension, and to disassociate dimensions from the objects to which they are 
linked. You can also make many common adjustments by manipulating dimensions directly with the Selection tool; see 
“Editing Dimensions with the Mouse” on page 1214.

To change adjoining dimensions into a single chain dimension object, select them, and then select Modify > 
Compose. Similarly, to change a chain object into multiple dimensions, select the chain, and then select Modify > 
Decompose.

The association of any dimension with an object can be removed; however, special considerations apply when an 
object also has parametric constraints.

Above Dim Line Select to always place text above the dimension line
Offsets from Building Specifies the distance of the dimensions from the building, walls, doors and windows
Small Dimensions Specifies the limit for drawing small dimensions, which can help detect inaccuracies in 

the drawing; dimensions less than the value specified will be considered “small.” Select 
Draw in red to detect problems such as minute misalignments in layout; to overlook any 
inaccuracies, select Do not draw.

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Dimension Properties
Editing Dimensions with the Context Menu
Editing Dimensions with the Mouse

Editing Dimension Properties
Edit the properties of one or more selected dimensions in the Object Info palette. Alternatively, right-click (Windows) 
or Ctrl-click (Mac) on the dimension, and select Properties from the context menu.
For chain dimension objects, the edits are applied to all dimensions within the chain. To edit the properties of 
individual dimensions within a chain, right-click (Windows) or Ctrl-click (Mac) on the dimension, and select Edit 
Dimension from the context menu instead.
Different parameters are available depending on what type of dimension is being edited.
Click to show/hide the parameters.

Modification Method Description

Disassociate a dimension from an 
object that has parametric constraints

Select the object, then right-click 
(Windows) or Ctrl-click (Mac) and 
select Disassociate from the context 
menu

“Associative Dimensioning” 
on page 1191

Disassociate specific dimensions from 
an object that has parametric 
constraints, without affecting the 
parametric constraints

Select the object, select Modify > Edit 
Constraints, and then select the 
associated dimensions to remove

“Editing Parametric 
Constraints” on page 1237

Disassociate all of the dimensions from 
an object that has parametric 
constraints, as well as remove all of the 
parametric constraints

Select the object, then right-click 
(Windows) or Ctrl-click (Mac) and 
select Remove Constraints from the 
context menu

“Deleting Parametric 
Constraints” on page 1237

Parameter Description

Length For linear and baseline dimensions, and for individual dimensions within a chain, this sets 
the length of the dimension. For associative dimensions, this also changes the length of the 
associated object.
Use the segment position selector to the left of the field label to specify which segment of 
the dimension (either endpoint, or the center point) will remain fixed when the dimension is 
resized. This fixed point is a global setting for all editing of linear and baseline dimension 
lengths.

Radius For radial and diametrical dimensions, this sets the length of the dimension (without moving 
the center point of the dimension). For associative dimensions, this also changes the radius 
of the associated object.

Dim Std Selects the dimension standard type; this selection determines which fields display in the 
Object Info palette or Properties dialog box.

Dim Off Sets the distance that the dimension line is offset from the dimensioned object
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Arrows Inside Sets whether arrows display inside witness lines or are flipped outside
Interior Arc Sets the angular dimension inside the witness lines; deselect to move the dimension outside 

of the witness lines at the opposite angle
Leader to Left Switches the radial dimension leader from the right to the left side of the object
Witness Lines

Visible For linear and arc dimensions, this sets whether the witness line displays on both ends of the 
dimension line, only the start, only the end, or not at all. For chain dimension objects, this 
sets whether all or none of the witness lines display.

Wit Ang For arc dimensions, sets whether the witness lines are perpendicular to a chord on the arc or 
to a tangent to the arc

Override For linear and arc dimensions, this displays additional fields for you to enter override values 
for the length of one or both witness lines, or for the distance that one or both witness lines 
are offset from the dimensioned object.
For chain dimension objects, by default there is only a single override value for the length or 
offset distance for all witness lines. To set an override for a particular dimension, right-click 
(Windows) or Ctrl-click (Mac) on the dimension, and select Edit Dimension from the 
context menu.

Text
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using options on 
the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 and “Formatting 
Text” on page 389.

Text Off Sets the distance that the dimension text is offset from the dimension line. For non-aligned 
text, the offset is measured from the closest (left or right) edge of the text box. A value of 
zero places the text within the line.
Depending on the type of dimension, and the Text Rot setting, the Text Off field may or 
may not be applicable.
• Linear dimensions: text can be offset for any Text Rot setting
• Arc and angle dimensions: only aligned text can be offset
• Radial dimensions: aligned text can be offset whether inside or outside the circle; 

non-aligned text can only be offset when it is outside the circle
Text Rot Sets the orientation of the dimension text to the dimension line, even when the dimension 

text is moved.
• Horizontal: keeps the text horizontal
• Aligned: keeps the text aligned parallel to the dimension line
• Horiz/Vert: keeps the text vertical for a vertical linear dimension, and horizontal in all 

other cases
Auto Position 
Text

Automatically aligns the dimension text to the center of the dimension line; becomes 
deselected automatically when you drag the text to a new location

Flip Text Mirrors the dimension text to the opposite side of the dimension line
Box Text Places a box around the dimension value

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Modifying Dimensions

Editing Dimensions with the Context Menu
The editing commands available from the context menu depend on the dimension type. For chain dimensions, the 
commands also depend on where you click the dimension.

Arc Indicator Displays an arc graphic over the dimension value
Leader Line For linear, chain, and arc dimensions, draws a leader line from the dimension value to the 

dimension line. If desired, use the Attributes palette to add an end marker to the leader line 
(see “Marker Attributes” on page 1102); the end marker defaults to the style specified for 
the current dimension standard, but it can be changed.

Dual View Selects which dimensions to display, when a dual-dimension standard is selected. This 
parameter is not available for chain dimension objects.

Prim/Sec Toggles between settings for primary and secondary dimensions, when a dual-dimension 
standard is selected. This parameter is not available for chain dimension objects.

Prec Sets the dimension precision with up to ten digits of accuracy
Show Dim Value Shows or hides the dimension value; Note text is not affected by this setting
Leader Enter text to display before the dimension value
Trailer Enter text to display after the dimension value
Note Enter note text to display on the opposite side of the dimension line from the dimension 

value. (If the dimension value displays in the middle of the line, the note displays on the 
next paragraph.) If the dimension value is moved, the note moves with it, and maintains the 
same offset distance from the line, in the opposite direction.
The note text has the same font, size, and style as the dimension value.

Tol When a single-dimension standard is selected, sets whether a dimension displays a single, 
double, limited, or no tolerance value

Top/Bottom/
Display as Typed

When a tolerance display is selected, sets the tolerance values and how they display

Command  Dimension Type Description

Add Dimension Linear and chain Right-click (Windows) or Ctrl-click (Mac) anywhere on the dimension 
object, and select the command. Click with the bull’s-eye cursor to set the 
endpoint of the new witness line. The other dimensions in the chain adjust 
automatically.
If Create smart chain dimension objects is enabled in the chain 
dimension preferences, a single linear dimension automatically becomes a 
chain when you add a dimension to it.

Parameter Description

Text offset 6” Text offset 1/2” 
and shifted left

Text offset 0”
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~~~~~~~~~~~~~~~~~~~~~~~~~
Modifying Dimensions

Editing Dimensions with the Mouse
All dimension parameters are available in the Object Info palette and the Properties dialog box. Dimensions also have 
several controls that allow you to make common adjustments quickly and directly with the mouse.

Delete Dimension Chain Right-click (Windows) or Ctrl-click (Mac) on the dimension line of the 
dimension to be deleted, and select the command. The remaining 
dimensions in the chain adjust automatically.

Delete Segment/
Witness Line

Chain Right-click (Windows) or Ctrl-click (Mac) on the segment/witness line to 
be deleted, and select the command. The remaining dimensions in the 
chain adjust automatically.

Edit Dimension Chain Right-click (Windows) or Ctrl-click (Mac) on the dimension to be edited, 
and select the command. Adjust the settings in the Object Properties dialog 
box and click OK (see “Editing Dimension Properties” on page 1211).
To apply properties edits to all dimensions in the chain, use the Properties 
command or the Object Info palette instead.

Format Text All Right-click (Windows) or Ctrl-click (Mac) on the dimension, and select the 
command. Adjust the settings in the Format Text dialog box, and click OK.

Disassociate Linear, radial, 
and diametrical

Right-click (Windows) or Ctrl-click (Mac) on the dimension, and select the 
command.

Properties All Right-click (Windows) or Ctrl-click (Mac) on the dimension, and select the 
command. Adjust the settings in the Object Properties dialog box and click 
OK (see “Editing Dimension Properties” on page 1211).
To apply properties a specific dimension in a chain, use the Edit 
Dimension command instead.

Command  Dimension Type Description
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Action Description

Change the length of a 
dimension graphically

• For linear dimensions, click on the endpoint of a witness line with the Selection tool 
and drag it parallel to the dimension line; in chain dimension objects, the size of any 
adjoining dimension is adjusted automatically.

• For angular, arc length, radial, or diametrical dimensions, click on the endpoint of a 
witness line with the Selection tool and drag it in the desired direction.

For associative dimensions, a change to the length of a radial or diametrical dimension 
also changes the size of the associated object.
To enter a specific value, use the Length field on the Object Info palette.

Enter the length of a 
dimension on the drawing 
(linear and chain 
dimensions)

Double-click anywhere on the dimension to enter a text editing mode. Enter the 
desired length, and then use the segment position selector to specify which segment 
will remain fixed when the dimension is resized.

Alternatively, select the Text tool, and then click the dimension text to enter the 
text editing mode.

For associative dimensions, a change to the length of a linear dimension also changes 
the size of the associated object.

Click the right endpoint of 
the dimension and drag it to 
the left

The circle’s diameter is 
reduced from the right; the 
left endpoint remains fixed

The dimension has a 
constraint marker, so it is 
associative

Double-click the dimension 
to edit it; enter the new 
length, and click the left 
segment selector

The dimension has 
constraint markers, 
so it is associative

The triangle’s top side is 
expanded from the right; 
the dimension’s left 
endpoint remains fixed

Segment selector
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Change the rotation of a 
radial or diametrical 
dimension

Click anywhere on the witness line with the Selection tool and drag it in the desired 
direction

Change the position of the 
dimension text

Click on the text with the Selection tool and drag it to the desired location. The text for 
an angular dimension can only be moved along the curve of the dimension itself; the 
text for other dimensions can be moved in any direction.
For linear and arc length dimensions, press and hold the Shift key while dragging the 
text to maintain the same offset distance from the dimension line.
To enter a specific value for the text offset from the dimension line, use the Text Off 
field on the Object Info palette. For linear, arc length, and chain dimensions, you can 
add a leader line from the text to the dimension line if necessary.

Move a dimension With the Selection tool, click on a witness line (but not on an endpoint) or on one of 
the two control points at each end of a dimension line, and drag the entire dimension to 
a new location. For associative dimensions, this also moves the associated object.

Action Description

The dimension obscures 
part of the drawing

Click the dimension text and drag it 
to the other side of the line
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Change the offset of the 
dimension line from the 
dimensioned object 
(linear, chain, and arc 
dimensions)

Click on the dimension line with the Selection tool and drag it to the desired location.
• If the dimension standard does not have a fixed witness line length, the witness line 

endpoints remain stationary, and the witness line length is adjusted accordingly.
• If the dimension standard has a fixed witness line length, the witness lines are not 

adjusted by default; to override the fixed length, press the Shift key while dragging 
the dimension line. To enter a specific value for the witness line length, use the 
Object Info palette.

To enter a specific value for the offset, use the Dim Off field on the Object Info 
palette.

Change the offset of the 
witness lines from the 
dimensioned object 
(linear, chain, and arc 
dimensions)

With the Selection tool, click on the gray dashed line at the endpoints of the witness 
lines and drag it to the desired location. The dimension line remains stationary, and the 
witness line length is adjusted accordingly.
• If the dimension standard does not have a fixed witness line length, the Object Info 

palette shows that the witness lines have an offset override.
• If the dimension standard has a fixed witness line length, the Object Info palette 

shows that the witness lines have a length override.
To enter specific values for the offset or length of the witness lines, use the Override 
setting on the Object Info palette.

If the dimension has multiple override values for offset or length, each witness line has 
its own dashed line for editing.

Action Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Modifying Dimensions

Measuring Distance
Distance can be measured without actually being recorded. This can be useful for placing objects or for reference.
~~~~~~~~~~~~~~~~~~~~~~~~~
Measuring in Units
Measuring in Degrees

Measuring in Units
The Tape Measure tool measures the distance between two or more points in the drawing area or in a sheet layer 
viewport, and temporarily displays the length in the Data bar. The tool shows the measurement between one click and 
the next, and it also keeps track of the cumulative length from the very first click.
Measurements display in the Data bar until the mouse is double-clicked. Note the measurements before the display 
clears.

To measure a distance:

1. Click the Tape Measure tool from the appropriate tool set/palette.
• All workspaces: Dims/Notes tool set
• Spotlight workspace: Basic tool palette

2. Click where the first measurement is to start.
3. Move the cursor along the distance to measure.

The Data bar displays the following information:

Modify the offsets of 
several dimension lines or 
witness lines at once 
(linear and chain 
dimensions)

With the Selection tool, select the dimensions to modify. Drag one of the dimension 
lines to the desired location; all selected dimension lines move the same distance. Drag 
one of the dashed gray lines that indicate the witness line offset to the desired location; 
the endpoints of all selected witness lines move the same distance.

Data Bar Value Description

L Length (distance) from the previous point

Action Description
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4. To continue measuring in a different direction or area, click to set the next starting point.
The L measurement changes to zero.

5. Move the cursor to measure the next distance.
The Data bar reflects the length from the previous point and the total cumulative length.

6. When the measurements are complete, note the total length.
7. Double-click to end the measurements.

~~~~~~~~~~~~~~~~~~~~~~~~~
Measuring Distance

Measuring in Degrees
The Protractor tool measures angles in the drawing, and temporarily displays the degrees measurement in the Data 
bar. There are two modes for the tool.

Angles Between Objects or Object Sides

To measure the angles between objects or object sides:

1. Click the Protractor tool from the appropriate tool set/palette, and select Angle from Two Segments mode.
• All workspaces: Dims/notes tool set
• Spotlight workspace: Basic tool palette

TL Total length (cumulative measurement) from the starting point
Scale The scale set for the layer or sheet layer viewport where you clicked

Mode Description 

Angle from Two 
Segments

Calculates the angle between two objects or object sides that are linear—rectangles 
(including rounded and rotated), lines, polylines, and polygons. This mode cannot, 
however, measure circles, ovals, or arcs. In addition, it cannot measure between parallel 
lines.

Angle from Three Points Measures an angle between three points in the drawing area

Data Bar Value Description

First click to start 
the measurement

Second click to start 
the measurement of 
the next edge

The measurement from 
the second click to this 
corner is 6’ 3 3/8”

Click 3

Click 2

Click 1

Angle from Two Segments Angle from Three Points
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2. Move the selection arrow over the first side of the angle to measure.
3. Click to select the side, and then move the cursor to the other angle side.

The angle displays in the Data bar.

4. Note the angle, and then click to end the measurement.

Angles Between Three Points

To measure angles between three points:

1. Click the Protractor tool from the appropriate tool set/palette, and select Angle from Three Points mode.
• All workspaces: Dims/notes tool set
• Spotlight workspace: Basic tool palette

2. Click to set the first point.
3. Click to set the second point.
4. Move the cursor to the third angle point.

The angle displays in the Data bar.
5. Note the angle, and then click to end the measurement.

~~~~~~~~~~~~~~~~~~~~~~~~~
Measuring Distance

Geometric Dimensioning and Tolerancing
The Vectorworks Design Series products provide the tools required for dimensioning a drawing according to ISO and 
ANSI/ASME geometric dimensioning and tolerancing standards.

Click 2

Click 1
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The Feature Control Frame, Datum Feature Symbol, and Datum Target Symbol are inserted into the Dimension class 
by default; control the appearance of these markers globally by editing the parameters of this class. To control the text 
characteristics (font size and style) globally, assign a text style to the class. You can also apply text styles or Text menu 
options to format individual markers.
For more information about editing class attributes and formatting text, see “Setting Class Properties” on page 179, 
“Formatting Text” on page 389, and “Using Text Styles” on page 393.
~~~~~~~~~~~~~~~~~~~~~~~~~
Feature Control Frame
Datum Feature Symbol
Datum Target Symbol
Geometric Dimensioning and Tolerancing Note

Feature Control Frame
A feature control frame consists of a geometric characteristic symbol, up to two tolerance areas, and up to three datum 
reference areas.

To insert a feature control frame:

1. Click the Feature Control Frame tool from the Dims/Notes tool set.
2. Click on the drawing to insert the feature control frame. Click again to set the rotation of the object. 

If this is the first time the object has been inserted in this session, the Object Properties dialog box opens. If the 
Attributes palette has not been set to use end markers, select the marker style, size, and angle from the Object 
Properties dialog box.

Geometric Characteristic 
(w/Composite box)

Tolerance

Diameter 
symbol

Statistical 
Tolerance

Projected Tolerance Zone

Max. Projected 
Height

Primary Datum 
Reference

Secondary and Tertiary 
Datum Reference

Material Condition

Marker

Control points

Tolerance Area #2
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3. Set the feature control frame parameters in the Object Info palette.
If the leader is not immediately visible, drag it from the frame using the leader control points.

Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using 
options on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 
and “Formatting Text” on page 389.

Geometric Characteristic Select the geometric characteristic symbol, if any

Composite Box Select to increase the size of the geometric characteristic box; this is used when placing 
a second feature control frame

Tolerance Area #1/#2 Select to include Tolerance Area #1 and/or Tolerance Area #2
Tolerance Enter the tolerance value

Show Diameter Symbol Select to display a diameter symbol along with the tolerance value 

Material Condition Choose the material condition, if any

Statistical Tolerance Select to display a statistical tolerance symbol

Projected Tolerance 
Zone

Select to display a projected tolerance zone symbol

Zone Height Enter the maximum projected tolerance zone height when a projected tolerance zone 
symbol is displayed

Angularity Circularity

Position

Concentricity Cylindricity Flatness

Parallelism Perpendicularity Profile–Line Profile–Surface

Simple Runout Total Runout Straightness Symmetry

Free 
State

LMC (Least Material 
Condition)

MMC (Maximum Material 
Condition)

Tangent 
Plane



Geometric Dimensioning and Tolerancing |  1223
Once the feature control frame has been placed, its marker can be selected from the Attributes palette (see “Marker 
Attributes” on page 1102).
~~~~~~~~~~~~~~~~~~~~~~~~~
Geometric Dimensioning and Tolerancing
Marker Attributes

Datum Feature Symbol
A datum feature symbol consists of a marker, leader, and datum reference letter. 

To insert a datum feature symbol:

1. Click the Datum Feature Symbol tool from the Dims/Notes tool set.
2. Click on the drawing to insert the datum feature symbol. Click again to set the rotation of the object.

If this is the first time the object has been inserted in this session, the Object Properties dialog box opens. If the 
Attributes palette has not been set to use end markers, select the marker style, size, and angle from the Object 
Properties dialog box.

3. Enter the datum reference letter (which corresponds to the Feature Control Frame reference letter).
Once the datum feature symbol has been placed, its marker can be selected from the Attributes palette (see “Marker 
Attributes” on page 1102). To control the text characteristics (font size and style) globally, assign a text style to the 
class. You can also apply text styles or Text menu options to format individual markers. See “Using Text Styles” on 
page 393 and “Formatting Text” on page 389.

Place the PTZ symbol 
outside the FCF

Select to place the projected tolerance zone symbol outside and to the bottom of the 
feature control frame

Primary/Secondary/
Tertiary Datum 
Reference

Select to include the primary, secondary, and/or tertiary datum reference

Reference Enter the desired reference letter
Material Condition Select a material condition, if any

Leader Position Select left or right

Parameter Description

LMC (Least Material 
Condition)

MMC (Maximum 
Material Condition)

Marker

Datum Reference
letter

Leader

Control Points
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~~~~~~~~~~~~~~~~~~~~~~~~~
Geometric Dimensioning and Tolerancing
Marker Attributes

Datum Target Symbol
A datum target symbol consists of a marker, leader, and target with datum target letter and target area size.

To insert a datum target symbol:

1. Click the Datum Target Symbol tool from the Dims/Notes tool set.
2. Click on the drawing to insert the datum target symbol. Click again to set the rotation of the object.

If this is the first time the object has been inserted in this session, the Object Properties dialog box opens. If the 
Attributes palette has not been set to use end markers, select the marker style, size, and angle from the Object 
Properties dialog box.

3. Set the leader and marker position by dragging the symbol control points with the mouse. Specify the remaining 
datum target parameters in the Object Info palette.

Click to show/hide the parameters.

Once the datum target symbol has been placed, its marker can be selected from the Attributes palette (see “Marker 
Attributes” on page 1102).

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using 
options on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 
and “Formatting Text” on page 389.

Datum Target Specify the datum target letter/number combination
Target Area Size Enter the size of the target area
Show Diameter Symbol Select to display the diameter symbol with the target area size 

Place target size outside 
of symbol

When necessary, the target size can be displayed outside the symbol; specify right or 
left Placement

MarkerLeader

Control Points

Target Area
Size

Datum Target
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~~~~~~~~~~~~~~~~~~~~~~~~~
Geometric Dimensioning and Tolerancing
Marker Attributes

Geometric Dimensioning and Tolerancing Note
The Geom Dim and Tol Note tool is used to insert a notation symbol and text specifying the dimension of round, 
square, counterbore, and/or countersink holes, and unit ratio for conical and/or flat tapers. Alternatively, a depth 
symbol and associated text can be inserted.

To insert a geometric dimensioning and tolerancing note:

1. Click the Geom Dim and Tol Note tool from the Dims/Notes tool set.
2. Click in the drawing to insert the note. Click again to set the rotation of the object.

If this is the first time the object has been inserted in this session, the Object Properties dialog box opens. If the 
Attributes palette has not been set to use end markers, select the marker style, size, and angle from the Object 
Properties dialog box.

3. Specify the geometric dimensioning and tolerancing note parameters in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the style 

associated with the class, select <Class Text Style>. To format the text using options on the Text 
menu, select <Un-Styled>. See “Using Text Styles” on page 393 and “Formatting Text” on 
page 389.

Precision Select the decimal place rounding value for the hole size and depth
Note Type Select the style of the note marker

Hole Size/
Taper

Enter the diameter for round, square, counterbore, and countersink holes; enter the unit ratio for 
conical and flat tapers

Round Hole (and Depth) Square Hole (and Depth) Counterbore (and Depth)

Countersink Conical Taper Flat Taper Depth
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Once the geometric dimensioning and tolerancing note has been placed, its marker can be selected from the 
Attributes palette (see “Marker Attributes” on page 1102).

4. If desired, create and set a leader line using the Selection tool. Click the symbol control point. Crosshairs display 
to indicate the leader endpoint position. Click at the desired endpoint location; the leader line is drawn with the 
marker style, size, angle, and the shoulder length specified in the object preferences.

~~~~~~~~~~~~~~~~~~~~~~~~~
Geometric Dimensioning and Tolerancing

Tolerance Sets whether the hole size/taper has a single, double, limited, or no tolerance

Top/Bottom Enter the value that is added to or subtracted from the base dimension to determine the upper/
lower limit of the dimension

Depth/Angle Enter the depth for round, square, and counterbore holes (if the depth is zero or less, it is not 
displayed); enter the angle for countersink holes

Tolerance Sets whether the depth/angle has a single, double, limited, or no tolerance

Top/Bottom Enter the value that is added to or subtracted from the base dimension to determine the upper/
lower limit of the dimension

Leader Enter text to display before the dimension
Trailer Enter text to display after the dimension
Leader Line 
Position

Select to place the dimension leader line to the right or left side of the object

Shoulder 
Length

Specifies the length of the leader line’s shoulder

Parameter Description

None Single Double

Limit (1) Limit (2)

None Single Double

Limit (1) Limit (2)

Click 1
Click 2
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Marker Attributes
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Parametric Constraints
Parametric constraints ensure that a drawing maintains its original precision. Parametric constraints maintain 
relationships between an object and world space, between two objects, or within the object itself. There are two types 
of parametric constraints: dimensional and geometric. Dimensional constraints maintain a measurable relationship by 
limiting the object’s geometry to a particular value. Geometric constraints maintain a physical relationship by limiting 
the allowed orientation of objects.

 

Parametric constraints can be placed on all 2D objects. They cannot be placed on 3D objects except for walls, symbols, 
and plug-in objects that have 2D components. Multiple constraints can be applied to an object. Parametric constraints 
can be placed across layers as long as both layers are of the same scale, and Layer Options are set to Show/Snap/
Modify Others.
Constraints must always be placed in the plane defined by the object or objects being constrained; when multiple 
objects are constrained, they must be co-planar to create the constraint. The constraint on an object or objects changes 
planes with the object, if the object changes its plane.
Constraints attached to a single object move along with the object even if the object is copied or cut and pasted. When 
only one of a pair of constrained objects is duplicated or copied or cut and pasted, the constraint is removed.
When a parametric constraint is placed, green constraint indicators are drawn for the object(s) involved. To hide 
indicators, deselect Show parametric constraints in the Display tab of the Vectorworks preferences. Alternatively, 
select View > Show > Show or Hide Constraints; the command toggles between displaying or hiding constraints, as 
appropriate.
~~~~~~~~~~~~~~~~~~~~~~~~~
Dimensional Constraints
Geometric Constraints
Editing Parametric Constraints

Dimensional Constraints
Dimensional constraints maintain a measurable relationship. They resemble standard dimensions when placed.
~~~~~~~~~~~~~~~~~~~~~~~~~
Constrain Angle
Constrain Radius
Constrain Horizontal Distance
Constrain Vertical Distance
Constrain Distance

Constrain Angle
Constrain the angular relationship between separate objects or line segments of a single object. If one object or segment 
is rotated, the object or segment it is constrained to adjusts to maintain the angle.

Dimensional constraint maintaining the 
horizontal distance between two objects

Geometric constraint maintaining 
tangency between a line and a circle
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To constrain the angle between objects or line segments of a single object:

1. Click the Constrain Angle tool from the Dims/Notes tool set.
2. Click on one of the two objects or line segments to be constrained.

The cursor switches to the bull’s-eye cursor.
3. Click on the second object or line segment to be constrained.

A green angle constraint is drawn between the two objects or line segments.

Constrain Radius
Constrain the radius of a single arc or circle. If the arc or circle is accidentally resized, the constraint prevents the 
operation, preserving the radius.

To constrain the radius of an arc or circle:

1. Click the Constrain Radius tool from the Dims/Notes tool set.
2. Click on the arc or circle to be constrained.

A green radius constraint is drawn on the object.

The Constrain Radius tool does not work on quarter arcs.

Constrain Horizontal Distance
Constrain the horizontal distance of an edge of an object, a line segment, or between two points. If an object resize is 
attempted, the constraint prevents the operation, preserving the original horizontal distance. When the constraint is on 
two different objects, if one object is modified, the object it is constrained to moves to remain at the same constrained 
horizontal distance.

To constrain the horizontal distance of an edge of an object or a line segment:

1. Click the Constrain Horiz Distance tool from the Dims/Notes tool set.
2. Click on the object to be constrained.

Click 1

Click 2
Object

Click on the 
object
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A green horizontal distance constraint is drawn on the object.

To constrain the horizontal distance between two points:
1. Click the Constrain Horiz Distance tool from the Dims/Notes tool set.
2. Click on the first point to be constrained.

The cursor switches to the bull’s-eye cursor.
3. Click on the second point to be constrained.

A green horizontal distance constraint is drawn between the two points.

Constrain Vertical Distance
Constrain the vertical distance of an edge of an object, line segment, or between two points. If an object resize is 
attempted, the constraint prevents the operation, preserving the original vertical distance. When the constraint is on two 
different objects, if one object is modified, the object to which it is constrained moves to remain at the same 
constrained vertical distance.

To constrain the vertical distance of an edge of an object or line segment:

1. Click the Constrain Vertical Distance tool from the Dims/Notes tool set.
2. Click on the object to be constrained.

A green vertical distance constraint is drawn on the object.

Click on the object

Click 1 Click 2

Click on the object
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To constrain the vertical distance between two points:

1. Click the Constrain Vertical Distance tool from the Dims/Notes tool set.
2. Click on the first point to be constrained.

The cursor switches to the bull’s-eye cursor.
3. Click on the second point to be constrained.

A green vertical distance constraint is drawn between the two points.

Constrain Distance
Constrain the distance of an edge of an object, line segment, or between two points regardless of the angle. If an object 
is accidentally resized, the constraint prevents the operation, preserving the original distance. When the constraint is on 
two different objects, if one object is modified, the object to which it is constrained moves to remain at the same 
constrained distance.

To constrain the distance of an edge of an object or line segment:

1. Click the Constrain Distance tool from the Dims/Notes tool set.
2. Click on the object to be constrained.

A green horizontal distance constraint is drawn on the object.

To constrain the distance between two points:

1. Click the Constrain Distance tool from the Dims/Notes tool set.
2. Click on the first point to be constrained.

The cursor switches to the bull’s-eye cursor.
3. Click on the second point to be constrained.

A green distance constraint is drawn between the two points.

Click 1

Click 2

Click on the object

Object
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Geometric Constraints
Geometric constraints preserve the geometric properties of objects.
~~~~~~~~~~~~~~~~~~~~~~~~~
Constrain Horizontal-Vertical
Constrain Parallel
Constrain Perpendicular
Constrain Collinear
Constrain Coincident
Constrain Concentric
Constrain Tangent

Constrain Horizontal-Vertical
Constrain a linear object to remain horizontal or vertical. Once constrained, the object cannot be rotated to any other 
position. The object can be resized in length, but it always remains horizontal or vertical. 

To constrain an object to remain horizontal-vertical:

1. Click the Constrain Horiz-Vertical tool from the Dims/Notes tool set.
2. Click on the linear object to be constrained.

A green horizontal-vertical constraint is drawn on the object.

If the object is diagonal when the constraint is placed, it rotates to become vertical or horizontal, depending on 
which angle it is closest to.

Click 1

Click 2

Point

Click on the object
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Constrain Parallel
Constrain linear objects or line segments to be parallel to one another. If one object is rotated, the object constrained to 
it rotates to remain parallel to the first object. Lines do not need to be parallel when placing the constraints; the first line 
rotates to match the angle of the second line.

To constrain linear objects or line segments to be parallel:

1. Click the Constrain Parallel tool from the Dims/Notes tool set.
2. Click on the line to constrain.

The cursor switches to the bull’s-eye cursor.
3. Click on the line to be constrained.

Green parallel constraint indicators are drawn around the two lines.

Constrain Perpendicular
Constrain linear objects or line segments to be perpendicular to one another. If one line is rotated, the line it is 
constrained to adjusts to remain perpendicular to the first line. Lines do not need to be perpendicular when placing the 
constraints; the first line rotates to become perpendicular to the second line.

To constrain lines to be perpendicular:

1. Click the Constrain Perpendicular tool from the Dims/Notes tool set.
2. Click on the line to constrain.

The cursor switches to the bull’s-eye cursor.
3. Click on the line to be constrained.

A green perpendicular constraint is drawn, connecting the two lines.

Click 1

Click 2

Object

Click 1

Click 2
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Constrain Collinear
Constrain the collinearity between two linear objects. If one line is moved, the line it is constrained to adjusts to remain 
aligned. Lines do not need to be aligned when placing the constraints; the first line moves to become collinear to the 
second line. 

To constrain the collinearity between two lines:

1. Click the Constrain Collinear tool from the Dims/Notes tool set.
2. Click on the line to constrain.

The cursor switches to the bull’s-eye cursor.
3. Click on the line to be constrained.

Green collinear constraint indicators are drawn on the two lines.

Constrain Coincident
Constrain two selected points to remain attached. If one object is moved, the object it is constrained to adjusts to 
maintain the connection. The first point stretches to connect to the second point, if necessary.

To constrain the connection between two points:

1. Click the Constrain Coincident tool from the Dims/Notes tool set.
2. Click on the point to constrain.

The cursor switches to the bull’s-eye cursor.
3. Click on the point to be constrained.

A green coincident constraint is drawn where the two points touch.

Click 1

Click 2
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Constrain Concentric
Constrain circles and arcs concentrically. If a circle or arc is moved, the circle or arc it is constrained to moves so that 
their centers remain aligned. Circles and arcs do not need to be concentric when placing the constraints; the first object 
moves so that its center aligns to the second object’s center.

To constrain two circles or arcs concentrically:

1. Click the Constrain Concentric tool from the Dims/Notes tool set.
2. Click on the object to constrain.

The cursor switches to the bull’s-eye cursor.
3. Click on the object to be constrained.

A green concentric constraint is drawn at the center of the two objects.

Constrain Tangent
Constrain a circle, arc or line to be tangent to another circle or arc. If one object is moved, the other object it is 
constrained to adjusts to maintain the tangency. Objects do not need to be tangent to one another when placing the 
constraints; the first object moves to become tangent to the second.

To constrain a circle, arc or line to be tangent to a circle or arc:

1. Click the Constrain Tangent tool from the Dims/Notes tool set.
2. Click on the circle or arc to constrain.

The cursor switches to the bull’s-eye cursor.
3. Click on the circle, arc or line to be constrained.

Click 1
Click 2

Click 1

Click 2
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A green tangent constraint is drawn at the tangent point of the two objects.

Editing Parametric Constraints
When a constrained object is deleted, the parametric constraint attached to it is also removed. To remove the constraint 
without removing the attached object, use the Edit Constraints command.
A situation may arise where the value of a dimensional constraint needs to be changed. A wall with a horizontal 
distance constraint value of 2’ 6” may at a later point in the project need to be changed to 5’ 6”. This type of edit is also 
accomplished using the Edit Constraints command.
Individual constraints can be selected from a list of all constraints currently applied to a selected object. The selected 
constraint changes color to indicate which one is about to be edited. Geometric constraints, where appropriate, along 
with changing the constraint color, also show the connection between the two constrained objects for clarity.
Constraint errors related to editing operations that conflict with current constraints are solved by either removing the 
constraint, or canceling the editing operation.
~~~~~~~~~~~~~~~~~~~~~~~~~
Deleting Parametric Constraints
Changing a Dimensional Constraint Value
Parametric Constraint Errors

Deleting Parametric Constraints
You can select which constraints to delete or delete all constraints at once. Constraints can be removed or edited for 
multiple selected objects.
To select which parametric constraint to delete:

1. Select the object with the constraint.
2. Select Modify > Edit Constraints.

The Edit Constraints dialog box opens.
3. Select the constraint to be removed from the Constraints list.

The selected constraint changes color.
4. Click Delete to remove the constraint.
5. Click OK.

To delete all parametric constraints:
1. Select the object(s) with the constraints.
2. From the context menu, select Remove Constraints. Alternatively, select Delete All from the Edit Constraints 

dialog box.
Using the Remove Constraints context menu command will also disassociate any associated dimensions.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Parametric Constraints
Changing a Dimensional Constraint Value

Click 1

Click 2
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Parametric Constraint Errors

Changing a Dimensional Constraint Value
To change a dimensional constraint value:

1. Select the object with the constraint.
2. Select Modify > Edit Constraints.

The Edit Constraints dialog box opens.

3. In the Dimensional Constraint Value field, enter the new dimension, and click OK.
The dimensional value is updated and the object or objects are adjusted.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Parametric Constraints
Deleting Parametric Constraints
Parametric Constraint Errors

Parametric Constraint Errors
Occasionally, an editing operation cannot be performed due to conflicting or unsolvable constraints placed on the 
objects involved. When this occurs, an alert dialog box opens which allows the unsolvable constraints to be previewed 
and, if needed, removed.
To solve conflicting constraint errors:

1. When an unsolvable constraint occurs, an alert dialog box opens. Decide how to resolve the conflicting situation.
Click to show/hide the parameters.

2. Select Preview constraints that will be selected, and then click Yes to preview the unsolvable constraints.
The Unsolvable Constraints dialog box opens.

Parameter Description

No Continues with the editing operation, removing the conflicting constraints
Yes Cancels the editing operation, preserving constraints
Preview Opens the Unsolvable Constraints dialog box, listing the problem constraints and allowing a 

preview of each constraint
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3. Double-click on an unsolvable constraint to preview it in the drawing. The unsolvable constraint displays with a 
different color.

4. Click OK to remove the constraints and perform the editing operation. Click Cancel to retain the constraints and 
cancel the editing operation.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Parametric Constraints
Deleting Parametric Constraints
Changing a Dimensional Constraint Value
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Annotation
Inserting Leader Lines
The Vectorworks Fundamentals product provides a basic leader line object. In a Vectorworks Design Series workspace, 
the leader line includes additional parameters.

Inserting a Simple Leader Line
The Leader Line Simple tool inserts a basic leader line. Two modes are available.

To insert a leader line symbol:

1. Click the Leader Line Simple object from the Basic tool set and select the Constrained or Unconstrained mode 
from the Tool bar.

2. Click and move the mouse to define the leader line shoulder length. Click and move the mouse to define the leader 
line, and click to set the end point. 

Once the leader line has been placed, its marker can be selected from the Attributes palette (see “Marker Attributes” on 
page 1102).

Inserting a Design Series Leader Line 

To insert a leader line symbol:

Click the Leader Line object from the Basic tool set. 
If this is the first time the object has been inserted in this session, the Object Properties dialog box opens. Set the 
default properties for the object and click OK. The properties can be edited after placement from the Object Info 
palette.

Click to show/hide the parameters.

Mode Description

Constrained Constrains the line to be vertical, horizontal, and 30° or 45° from vertical or horizontal in 
any direction

Unconstrained Draws the line at any angle
Press and hold the Shift key to snap the line to predetermined angles

UnconstrainedConstrained
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If there are several leader line objects, use the Align/Distribute Leader Lines command to improve readability.
~~~~~~~~~~~~~~~~~~~~~~~~~
Marker Attributes
Aligning and Distributing Leader Lines
Using Notation Objects

Using Notation Objects
Several tools in the Vectorworks Fundamentals product add set information to a drawing with preformatted objects. 
Vectorworks Design Series products offer tools for additional notation objects.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Revision Clouds
Creating Drawing Labels
Creating Reference Markers
Creating Data Stamps
North Arrow
Revision Marker
Elevation Benchmark
Indicating the Slope of Surfaces
Inserting a Scale Bar
Creating Grid Bubbles
Section Lines and Section-Elevation Markers
Inserting a Symmetry Label

Creating Revision Clouds
Use the Revision Cloud tool to identify a section of a drawing that has changed. Insert a revision cloud in an area of 
the drawing, or around an entire portion of the drawing, if appropriate.
For the Vectorworks Design Series products, revision clouds can also be created by first drawing a polyline and then 
selecting the Create Objects from Shapes command (see “Creating Objects from Shapes” on page 277). 

Parameter Description

Shoulder Length Sets the length of the leader line’s shoulder

Arrows Sets whether to have an arrow on the leader line and if so, the side from which it 
extends

Marker Style Select a marker style from the list
Marker Size/Marker Angle Sets the size of the marker and the angle of the leader line

Shoulder 
Length
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Mode Description

Oval Inserts the revision cloud around the perimeter of a preview oval. Click to set the start point, 
move the cursor in the desired direction, and click to set the end point. Constrain the oval to 45 
degrees to draw a circle.

Rectangular Inserts the revision cloud around the perimeter of the preview rectangle. Click to set the start 
point, move the cursor in the desired direction, and click to set the end point. Constrain the 
rectangle to 45 degrees to draw a square.

Regular Polygon Inserts the revision cloud around the perimeter of the specified vertices. Click to set the start 
point (first vertex), click at the desired location for each subsequent vertex, and either click at 
the starting vertex to close the polygon or double-click at the final vertex to create an open 
polygon. If the polygon is open, the cloud is completed based on the outline.

Freehand 
Polygon

Inserts the revision cloud around the perimeter of the specified vertices. Click to set the start 
point and click-drag to draw the freehand polygon. If the polygon is open, the cloud is 
completed based on the outline.

PreferencesOval

Convex 
Shape

Rectangular

Regular 
Polygon

Concave 
Shape

Freehand 
Polygon

Click 1

Click 2
Convex Shape Concave Shape

Click 2

Click 1

Convex Shape Concave Shape

Start and 
end click

Click 2

Click 3
Convex Shape Concave Shape

Convex Shape Concave Shape

Start and 
end click
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To create a revision cloud:

1. Click the Revision Cloud tool from the Dims/Notes tool set.
2. Click the Preferences button on the Tool bar to define the revision cloud properties. The properties can also be set 

after placement, from the Object Info palette. Click OK.
3. Select the revision cloud mode and select to draw the cloud with either a convex or concave shape. The convex 

shape draws billows outward from the preview image or from the specified vertices. The concave shape draws 
billows inward from the preview image or from the specified vertices.

4. Click to draw the revision cloud according to the specified mode.
Click to show/hide the parameters.

The following illustration demonstrates the effects of varying the billow size and billow variability parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Using Notation Objects

Creating Drawing Labels
The Drawing Label tool is a point object that provides descriptive information for the drawing.

Parameter Description

Billow Size Select the relative billow size from extra small to extra large, or select Custom to specify a 
billow size

Billow Radius For a custom billow size, sets the billow size
Billow Variability Select the variability (the variation between the smallest and largest billows)
Billow Height Select the relative billow height (small, medium, or large)
Billow Type Select a convex or concave billow type
Vertex Parameters Edits the revision cloud vertices; see “Editing Vertex-Based Objects” on page 1002

Extra Small

None
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By default, a label object includes a title, the scale of the drawing, and an automatically assigned drawing number. The 
number of the sheet that contains the drawing can also be included in the label.
Many of these values default, depending on where the label was created: on a design layer, or in a viewport annotation, 
for example.

To create a drawing label:

1. Ensure that the appropriate layer is active.
2. Click the Drawing Label tool from the Dims/Notes tool set.
3. Click on the drawing at the desired location to place a drawing label object.
4. Click again to set the rotation.

If this is the first time the object is inserted in this session, the Object Properties dialog box opens. These 
parameters apply to subsequent placements of the object and can be changed in the Object Info palette. Click OK.
Drawing label objects maintain a constant size regardless of the drawing scale.

Click to show/hide the parameters.
 

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using 
options on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 and 
“Formatting Text” on page 389.

Drawing Title Specifies the title text that displays above the label’s horizontal ruling line; defaults to 
the file name (on a design layer), to nothing (on a sheet layer), or to the Drawing Title 
(in a viewport), but it can be edited.
If Use Automatic Drawing Coordination is enabled in document preferences 
(Vectorworks Design Series required), and the label is in a viewport, changing this field 
will update the viewport’s drawing title, and vice versa.

Title Alignment Specify the alignment of the Drawing Title in reference to the line. Select between left, 
center, and right alignment.

For center and right alignment, if the drawing label has a bubble style and the line 
length mode is not Auto-Fit, text may overlap the bubble if text is longer than the 
line.

Drawing Number Identifies this drawing on the current sheet. This value displays in the top half of the 
label bubble, unless Number Style is set to None. If the label is in a viewport or sheet 
layer, the program automatically numbers items and updates this field; this number must 
be unique on this layer. If the label is on a design layer, enter an identifier manually.

Sheet Number Identifies the sheet that contains the drawing. This value displays in the bottom half of 
the label bubble, if Number Style is set to Drawing and Sheet. If the label is on a sheet 
layer, this field defaults to the Sheet Number.
If Use Automatic Drawing Coordination is enabled in document preferences 
(Vectorworks Design Series required), and the label is on a sheet layer, this field cannot 
be edited and always contains the Sheet Number.
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Number Style Specifies which drawing identifier numbers (from the Drawing Number and Sheet 
Number fields) display in the label

Scale Display Style Specifies which scale information displays beneath the label’s horizontal ruling line

Custom Scale If Scale Display Style is set to Custom, enter information to display in the scale area
Scale Alignment Aligns the scale display in reference to the line. Select between left, center, or right 

alignment.
For center and right alignment, if the drawing label has a bubble style and the line 
length mode is not Auto-Fit, text may overlap the bubble if text is longer than the 
line.

Use Architectural Scale Select this option to use the US Architect scale style (as in 1/4” = 1’- 0”); deselect the 
option to use the Engineering style (as in 1:48)

Bubble Style Select the style of the label bubble graphic, which can contain the Drawing Number and 
Sheet Number that identify the drawing

Draw Full-width Bubble Select this option to extend the bubble graphic to the full length of the ruling line; not 
available if Bubble Style is set to None

Title / Scale / Drawing# 
/ Sheet# Text Size

Select the font sizes for the various elements of the drawing label

Bubble Scale Factor Specifies the label’s bubble size; enter a larger value to increase the size (the number 
must be greater than zero)

Parameter Description

 None
(Bubble Style=None)

Drawing only Drawing and sheet

Numbers only

Custom

None

Scale label

SCALE label

Round 
rectangle

Circle Rectangle

None



Using Notation Objects |  1247
5. Set the line attributes as needed using the Attributes palette.
~~~~~~~~~~~~~~~~~~~~~~~~~
Using Notation Objects
The Attributes Palette
Formatting Text
Using Text Styles

Line Length Mode Sets the length of the drawing label’s horizontal ruling line. A fixed length ruling line is 
set by the Printed Length value. An auto-fit ruling line is set to the length of the longest 
text bounding box, either above or below the ruling line. A control point ruling line is set 
by the location of its control point; click the control point to select it and click in the 
desired location in the drawing to adjust the ruling line length or to flip the ruling line to 
the opposite side.

Printed Length For a drawing label using a fixed length ruling line, sets the length of the drawing label 
on the printed page

Flip Select this option to move the bubble (including the Drawing Number and Sheet 
Number) to the right side of the label:

Rule Offset Specifies the vertical offset between the label’s bubble and horizontal ruling line on the 
printed page (0 is centered); enter a negative number to move the line, title, and scale 
below the center line of the bubble

Title Margin Specifies the vertical distance between the label’s horizontal ruling line and the text 
above it. Enter a positive value to move the text further above the ruling line, or a 
negative value to move the text closer to the ruling line.

Scale Margin Specifies the vertical distance between the label line and the text below it. Enter a 
positive value to move the text further above the ruling line, or a negative value to move 
the text closer to the ruling line.

Show Drawing Title Select to display the drawing title; if deselected, both the drawing title and the ruling line 
are not displayed

Show Scale with 
Drawing Title

Select to display the scale and drawing title on the same line; this option is only available 
when Show Drawing Title is selected

Position Scale on Center 
Line

Select to position the scale in place of the drawing title; this option is only available 
when Show Drawing Title is deselected

Parameter Description

Auto-Fit

Control Point

Fixed

control point

Default label Flipped label
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Creating Reference Markers
The Reference Marker tool displays the drawing number and sheet number of the referenced drawing. Select from a 
variety of configurations.

To create a reference marker:

1. Ensure that the appropriate layer is active.
2. Click the Reference Marker tool from the Dims/Notes tool set.
3. Click on the drawing at the desired location to place a reference marker object.
4. Click again to set the rotation.

If this is the first time the object is inserted in this session, the Object Properties dialog box opens. These 
parameters apply to subsequent placements of the object and can be changed in the Object Info palette. Click OK.
Reference marker objects maintain a constant size regardless of the drawing scale.

Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the style 

associated with the class, select <Class Text Style>. To format the text using options on the 
Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 and “Formatting Text” 
on page 389.

2D Scale Factor Specifies the marker size; increase the scale value to obtain a larger marker
Type/Config Select one of the types and configurations from the list

Drawing Number Specifies the drawing number of the item the marker references
Sheet Number Specifies the sheet number of the item the marker references
Separator For Config 1 configurations, specifies the separator between the Drawing Number and 

Sheet Number information
Arrow Angle For some configurations, specifies the angle of the marker arrow
Arrow Fill Select a filled or unfilled arrow style from the list

Config 1 Config 2 Config 3

Config 1 Config 2 Config 3

Config 1 Config 2 Config 3

Elevation 

Detail 

Section 
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5. Set the line attributes as needed using the Attributes palette.
~~~~~~~~~~~~~~~~~~~~~~~~~
Using Notation Objects
The Attributes Palette
Formatting Text
Using Text Styles

Creating Data Stamps
The Data Stamp tool displays the date, time and file name of the current drawing. Select from a variety of 
configurations.

To create a data stamp:

1. Click the Data Stamp tool from the Dims/Notes tool set.
2. Click on the drawing at the desired location to place a data stamp.

If this is the first time the object is inserted in this session, the Object Properties dialog box opens. Specify the 
preferences to use for this tool during this session, and then click OK.

3. Click again to set the rotation.
The data stamp parameters can be edited from the Object Info palette.

Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using options 
on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 and 
“Formatting Text” on page 389.

Show Date Select to display the current date
Show Time Select to display the current time in hours, minutes, and seconds
Show File Name Select to display the drawing’s file name
Draw Box Select to display a border around the data stamp
Use Labels Select to display date, time, and file name labels placed before the data
Date Display Style Select the format for the date display. Options include:

Short - 1/1/15
Medium - Jan 1, 2015
Long - January 1, 2015
Medium w/ Weekday - Mon, Jan 1, 2015
Long w/ Weekday - Monday, January 1, 2015

Text Size Select a font size for the data; the font itself can be changed from the Text menu
Data Style Select a font style for the data: plain, bold, italic, or bold italic
Label Style Select a font style for the data labels: plain, bold, italic, or bold italic



  1250 | Using Notation Objects
The date and time formats are determined by each Vectorworks application user’s local computer settings.
~~~~~~~~~~~~~~~~~~~~~~~~~
Using Notation Objects
The Attributes Palette
Formatting Text
Using Text Styles

North Arrow 
The North Arrow tool indicates the drawing orientation; several different styles can be selected. The deviation from 
true magnetic north can be displayed on some of the configurations. If the design layer is georeferenced, the object is 
rotated to point in the proper direction.

To place a north arrow object:

1. Click the North Arrow tool from the Dims/Notes tool set.
2. Click on the drawing at the desired location to place a north arrow object. 
3. Click again to set the rotation.

If this is the first time the object is inserted in this session, the Object Properties dialog box opens. These 
parameters apply to subsequent placements of the object and can be changed in the Object Info palette. Click OK.
North arrow objects maintain a constant size regardless of the drawing scale.

Click to show/hide the parameters.

Margin Spacing Specify the space between the text and the surrounding border
Label Size Factor Specify the label size relative to the data size
Update Click Update to manually update the data stamp date, time, or file name prior to printing 

it or exporting it, so that it reflects the most current data

Parameter Description

2D Scale Factor Specifies the marker size; increase the scale value to obtain a larger marker
Config Select the arrow style from the list

Arrow Graphics Select an arrow style from the list; arrow styles include filled and unfilled versions
Show MN Declination Select to add the deviation from true magnetic north for some styles

Declin Deg Offset Specifies the degree of offset from true north

Parameter Description

Config 2 Config 3 Config 4 Config 5

Config 6

Config 1

Config 7 Config 8 Config 9
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~~~~~~~~~~~~~~~~~~~~~~~~~
Using Notation Objects

Revision Marker 
The Revision Marker tool displays the drawing revision number.

To place a revision marker object:

1. Click the Revision Marker tool from the Dims/Notes tool set.
2. Click on the drawing at the desired location to place a revision marker object.
3. Click again to set the rotation.

If this is the first time the object is inserted in this session, the Object Properties dialog box opens. These 
parameters apply to subsequent placements of the object and can be changed in the Object Info palette. Click OK.
Revision marker objects maintain a constant size regardless of the drawing scale.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Using Notation Objects

Elevation Benchmark 
The Elevation Benchmark tool represents different levels in elevation drawings; two different elevation benchmark 
styles are available: ISO and US.

To place an elevation benchmark object:

1. Click the Elevation Benchmark tool from the Dims/Notes tool set.
2. Click on the drawing at the desired location to place an elevation benchmark linear object. 
3. Click to set the length and rotation of the elevation benchmark.

If this is the first time the object is inserted in this session, the Object Properties dialog box opens. These 
parameters apply to subsequent placements of the object and can be changed in the Object Info palette. Click OK.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using options 
on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393.

2D Scale Factor Specifies the marker size; increase the scale value to obtain a larger marker
Revision Number Specifies the revision number
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Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from the list of those available. To use the style associated with the class, 

select <Class Text Style>. To format the text using options on the Text menu, select 
<Un-Styled>. See “Using Text Styles” on page 393 and “Formatting Text” on page 389.

Title Specifies the benchmark title value
Title Text Max 
Width

Enter the maximum width of the title text. The title text wraps and adds as many lines as 
necessary to fit the complete text within the specified width. 

A control point on the text box allows the width of existing text to be changed manually.
Elevation Display Select the method for calculating the benchmark’s elevation value.

• Custom: Allows you to manually input a Custom Elevation value
• Z value relative to ground plane: Uses the Z value of the elevation benchmark marker, plus 

the elevation of the object’s layer, to determine the elevation value
• Z value relative to reference elevation: Uses the Z value of the elevation benchmark marker, 

plus the elevation of the object’s layer, minus the Reference Elevation value, to determine 
the elevation value

• Y value relative to reference elevation: Uses the Y value of the elevation benchmark marker, 
minus the Reference Elevation value, to determine the elevation value

• Distance from control point: Allows the elevation value to be referenced from a control point 
displayed on the drawing, rather than from the drawing’s active layer plane. If the control 
point is moved, the elevation value remains set by the distance from the control point to the 
elevation benchmark object. This allows you to set a control point at the ground floor of a 
house, for example, so that the elevation benchmark value is set according to the height from 
the ground floor.

Custom Elevation If Elevation Display is set to Custom, specifies the benchmark elevation value
Reference 
Elevation

If Elevation Display is set to Z Value Relative to Reference Elevation or Y Value Relative to 
Reference Elevation, specifies the reference elevation value

Style Select the marker style

Line Position For ISO style, specifies the position of the line relative to the marker

Click 1
Click 2

ISO style US style

Floor level
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After creation, multiple elevation benchmark objects can be aligned and distributed with the Align/Distribute 
Leader Lines command; see “Aligning and Distributing Leader Lines” on page 1035.

Title Position Specifies the position of the title text relative to the line and marker
Elevation 
Position

Specifies the position of the elevation value relative to the line and marker

Marker 
Orientation

Select the marker orientation (left or right)

Marker Graphics Select a marker style from the list; styles include filled, unfilled, and for ISO style half-filled 
versions. For the half-filled style, the left half is filled and the right half is unfilled.

2D Scale Factor Specifies the elevation benchmark size; increase the scale value to obtain a larger object
Crosshair Scale 
Factor 

For US style, increases the size of the elevation benchmark crosshairs, extending them beyond 
the marker circle;. For ISO style, when the Line Position is Top of Marker, draws a horizontal 
line at the bottom of the marker; a scale factor of 0 draws no line, and a scale factor of 1 makes 
the line the same width as the marker.

Marker Size For ISO style, specifies the marker size; increase the size value to obtain a larger marker
Use Offset Add an offset to the elevation benchmark’s leader line (available only on the Object Info palette 

after the elevation benchmark object is placed)

For ISO style when the Line position is set to Top of Marker, a different type of offset can 
be created by increasing the 2D Scale Factor and decreasing the Marker Size.

Offset Specify the size of the offset. A control point on the offset start point allows the offset to be 
moved horizontally to change the angle of the offset line. It cannot be moved horizontally past 
the shoulder point.

Shoulder 
Length

Specify the shoulder length. A control point on the shoulder point allows the shoulder length to 
be changed manually. The control point can be moved horizontally to adjust the shoulder length; 
the offset start point moves with it to maintain the angle of the offset line. The control point can 
also be moved vertically to adjust the offset; the marker moves with it.

Extension Length Specifies the length of the object line leading to the offset start point (available only on the 
Object Info palette after the elevation benchmark object is placed)

Only the extension length is drawn with the benchmark object’s line style set in the 
Attributes palette. The line portions extending from the offset start point to the marker 
remain solid.

Parameter Description

ISO styleUS style

Offset 
Start Point

Shoulder Point

Shoulder 
Length

Offset 

Extension 
Length
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~~~~~~~~~~~~~~~~~~~~~~~~~
Using Notation Objects

Indicating the Slope of Surfaces 
The Slope Dimension tool creates a rise over run indicator that displays the slope (rise/run) of any angle on any surface 
in the drawing. 

To create a slope indicator:

1. Click the Slope Dimension tool from the Dims/Notes tool set.
2. Click to mark the beginning of the slope. Click again to mark the end of the slope.

If this is the first time the tool is used in this session, the Slope Dimension Properties dialog box opens. Specify 
the preferences to use for this tool during this session, and then click OK. The preferences can be changed later in 
the Object Info palette.

3. The rise/run indicator is drawn.

Use the control point at the “elbow” of the slope indicator to move it; change the appearance of the rise/run 
indicator by editing its parameters in the Object Info palette.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Using Notation Objects

Inserting a Scale Bar
A scale bar can be placed on the drawing to define the scale of the drawing objects. To include a scale bar for a 
viewport, select Modify > Edit Viewport, and place the scale bar as a viewport annotation.

Parameter Description

Draw Roof Surface Draws the defining line as a dashed line
Scale Factor Determines the size of the indicator
Base Specifies a numerical denominator to indicate the “run” portion of the rise/run ratio

Click 1

Click 2
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To add a scale bar to the drawing:

1. Click the Scale Bar tool from the Dims/Notes tool set.
2. Click on the drawing to insert the scale bar. 
3. Click again to determine the rotation of the scale bar and to place it on the drawing.
4. Position the scale bar as desired. The scale bar properties can be edited later by selecting the scale bar and 

changing the properties in the Object Info palette.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Using Notation Objects

Creating Grid Bubbles
Grid bubble objects are dimensioned grid lines with bubble markers. This type of drawing notation can help locate 
columns and other primary building features on construction documents.

To draw a grid bubble object:

1. Click the Grid Bubble tool from the Dims/Notes tool set.
Place a line of grid bubbles by drawing an open polygon with the tool. The first click starts the grid line; the 
second click determines the angle of the grid line and sets a marker at that location. Each remaining click sets a 
grid marker. Grid marker objects maintain a constant size regardless of the drawing scale.

Parameter Description

Printed Height Specify the printed height of the scale bar
Minor Length Specify the minor length
# of Min Divs Specify the number of minor divisions (the first division is split into minor divisions; the 

remainder of the scale bar is in major divisions)
Major Length Specify the major length
# of Major Divs Specify the number of major divisions
Style Select the scale bar style: Zigzag, Box, Line, Checker, or Flip
Adjust Units Select to switch between units specified for the drawing file (File > Document Settings > 

Units); for example, switch between feet and inches
Decimal Points Select to display units with up to four decimal places
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2. Double-click to end the grid line. The first time the object is inserted in this session, the Preferences dialog box 
opens. These parameters apply to subsequent placements of the object and can be changed in the Object Info 
palette. 

The grid bubble parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

By combining several bubble grids and adjusting labeling properties, hierarchical (nested) grids can be created.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the 

style associated with the class, select <Class Text Style>. To format the text using options 
on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 and 
“Formatting Text” on page 389.

Starting Mark Indicates the starting number or letter for grid labeling; labels are automatically 
incremented

Prefix Specifies a prefix, if any, to apply to the grid labels
Dim Text Size Specifies the point size of the dimension text
Item Text Size Specifies the point size of the bubble label text
Show Dimensions Select to display the dimensions on the grid
Flip Select to flip the bubble labels to the other side of the dimension string
Rotate Text Select to rotate the bubble label text with the grid
Draw First Grid Select to display the first bubble grid; deselect to hide it (useful when creating nested grids)
Bubbles Both Ends Select to draw bubble labels at both ends of the grid line

Line Style Select the grid line style
Size Factor Scales the size of the bubbles
Bubble Offset Specifies the offset distance of the bubbles from the dimension string
Grid Length Indicates the grid length
Vertex parameters Edits the bubble grid line; while editing the bubble grid line in this way is possible, it may 

be preferable to use the Reshape tool instead. See “Reshaping Objects” on page 1043.



Error/Revision Management Using Redlines |  1257
~~~~~~~~~~~~~~~~~~~~~~~~~
Using Notation Objects

Inserting a Symmetry Label
In some drawing standards, when drawing a building or object that is in complete symmetry, the designer may draw 
only half of the model and insert a symmetry label to indicate the symmetry line. 

To insert a symmetry label:

1. Click the Symmetry Label tool from the Dims/Notes tool set. 
2. In a 2D view, click on the drawing at the desired location to place the symmetry label. 
3. Click to set the length and rotation of the label.

Symmetry label objects are specified and drawn in page scale; they draw to the same apparent size, regardless of 
the layer scale. If the layer the symmetry label object is on is re-scaled, or the symmetry label object is cut and 
pasted between layers of different scales, the symmetry label object automatically re-scales.
The symmetry label’s pen color, line weight, and line style can be changed in the Attributes palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Using Notation Objects

Error/Revision Management Using Redlines
The Redline tool and redline commands help control errors and revisions by providing the ability to annotate drawings 
with redlines and sketches, and to keep track of redline objects and any changes, corrections, and revisions that occur in 
a drawing.
The Redline tool and redline commands are compatible with redlines drawn in previous versions and will correctly 
handle both types of redlines.
~~~~~~~~~~~~~~~~~~~~~~~~~
Placing Redlines
Attaching a Sketch to a Redline
Show or Hide Redlines
Pick up Redline
Restore Redline
Redline Status Worksheet

Placing Redlines 
Use the Redline tool to create redline objects, which are graphical time-stamped change requests on the drawing. 
Several modes are available.
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To redline an object or area:

1. Click the Redline tool from the Dims/Notes tool set, and select the desired drawing mode from the Tool bar.
2. Click Preferences from the Tool bar to specify the Redline tool parameters for this session.

For information on drawing freehand, ovals, polygons, and rectangles, see “Creating Shapes” on page 277.
3. Click OK. Draw the redline around the area to be revised or corrected.

Click to show/hide the parameters.

Parameter Description

Redline Mode Creates a redline object using an oval, rectangle, polygon, or freehand drawing

Redline Style Select the style to apply to the redline object
• Cloud - applies a cloud style
• Radius - applies corner smoothing with a solid line style
• Radius Dashed - applies corner smoothing with a dashed line style
• Simple - applies a simple solid line with no smoothing 
• Simple Dashed - applies a simple dashed line with no smoothing 

Authorized by Specifies the default name or initials of the person who authorized the change; this name 
is used for the redlines created in this file

Assigned to Specifies the default name or initials of the person who has been assigned the task; this 
name is used for the redlines created in this file

Oval

Rectangular

Regular Polygon

Freehand Polygon

Preferences

Example of oval redline mode

Example of simple dashed redline style
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Based on the selected creation method, the appropriate tool creates the redline. This allows the use of SmartCursor 
cues, object snapping, and boomerang mode when drawing redlines.
Draw redlines on the design layer where the error occurred or where the desired revision is to be performed. 

4. The Place Redline dialog box opens. Enter the redline information and authorization.
Click to show/hide the parameters.

5. Click OK.
The redline object is drawn as specified, surrounding the drawing condition to be corrected. The date of the redline 
is automatically provided. Position redline text by clicking on the tag control point and dragging the tag to the 
desired location. If there are several redline objects, use the Align/Distribute Leader Lines command to improve 
readability (see “Aligning and Distributing Leader Lines” on page 1035).

The parameters of one or more selected redline objects can be edited in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Redline Notation Enter text describing the redline condition (and/or specifying the recommended action)
Authorized By Specifies the name or initials of the person who authorized the change; this originates from 

the redline preferences and is retained with the file
Assigned To Specifies the name or initials of the person who has been assigned the task; this originates 

from the redline preferences and is retained with the file
Attach the current 
selection as a sketch

Attaches any current selected item(s) to the redline as a symbol to provide more information 
about the redline (see “Attaching a Sketch to a Redline” on page 1260 for more information)

Click 1

Click 2

Rectangular mode depicted

Tag control point
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~~~~~~~~~~~~~~~~~~~~~~~~~
Error/Revision Management Using Redlines
Aligning and Distributing Leader Lines

Attaching a Sketch to a Redline
In screen plane mode, one or more selected objects can be attached to a redline object to illustrate the redline 
comments. The object to be attached as a sketch must be selected before drawing the redline; this process converts the 
selected object to a sketch symbol and places it in a Redline Sketches symbol folder saved with the file.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use the style 

associated with the class, select <Class Text Style>. To format the text using options on the 
Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 and “Formatting Text” 
on page 389.

Redline Style Select a redline style from the list
Tag Alignment Specifies the alignment of the redline tag:

• Auto: Justifies the text away from the center of the redline object
• Left: Places the text to the left of the tag control point and right-justifies the text
• Right: Places the text to the right of the tag control point and left-justifies the text

Picked Up Selecting Picked Up indicates that the redline has been resolved or “picked up.” The redline 
color changes to yellow and the pick-up date is automatically assigned. Deselect to indicate 
that a previously resolved redline has been restored.

Show Authorizer Select to display the Authorized By information on the redline
Authorized By Displays the initials or name of the person authorizing the change; can be edited 
Show Assignee Select to display the Assigned To information on the redline
Assigned To Displays the initials or name of the person assigned to correct the condition; can be edited
Show Sketch Select to display the sketch attached to the redline (if any)
Creation Date Displays the redline creation date
Pick Up Date Displays the redline pick-up date
Notation Redline comment information is displayed and can be changed
Tag Length Controls the length of the line separating the redline comments from the redline information, 

and changes the redline comment text wrapping 

Tag control point

Left alignment Right alignment
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To attach a selected object as a redline sketch:

1. Switch to the screen plane (see “Planar Modes of 2D Objects: Screen Plane and Layer Plane” on page 152).
2. Select the object to be converted to a sketch.
3. Click the Redline tool from the Dims/Notes tool set, and draw the redline as described in “Placing Redlines” on 

page 1257.
The Place Redline dialog box opens.

4. Select Attach the current selection as a sketch and click OK.
5. The selection is converted to a symbol that is attached to and moves with the redline object.

The sketch can be hidden by deselecting Show Sketch in the Object Info palette.
~~~~~~~~~~~~~~~~~~~~~~~~~
Error/Revision Management Using Redlines
Placing Redlines

Show or Hide Redlines 
Over the course of a project, most drawings receive a large number of redlines, which, if left visible, would clutter the 
drawing. Select Text > Redlines > Show or Hide Redlines to toggle redline visibility. 
All Redline objects are drawn in the Redlines class. If redlines are hidden when a new redline is drawn, the Redlines 
class visibility is automatically turned on and all the redlines become visible. Use the Show or Hide Redlines 
command to hide them again.
~~~~~~~~~~~~~~~~~~~~~~~~~
Error/Revision Management Using Redlines

Pick up Redline 
Once the change or correction indicated by the redline has been resolved, the redline needs to be “picked up” or 
changed to a closed state.
To pick up a redline: 

1. Select the redline object or objects.
2. Select Text > Redlines > Pick Up Redline.

Right-click on the redline and select Pick Up Redline from the context menu.
This sets the status of all selected redline objects to closed. The redline color changes from red to yellow, and the 
pick-up date is set.

Not picked up Picked up
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Redlines can be picked up by selecting one or more redline objects and selecting Picked Up in the Object Info 
palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Error/Revision Management Using Redlines

Restore Redline 
A selected closed redline object can be restored to an open status. A redline object may need to be restored when a 
revision has not been performed satisfactorily. 
To change the state of a closed redline back to open: 

1. Select the redline object or objects.
2. Select Text > Redlines > Restore Redline.

Right-click on the redline and select Restore Redline from the context menu.
The selected redlines are returned to an open status and the redline color changes back to red. The original redline 
creation date is displayed. Redlines can also be restored by selecting one or more redline objects and deselecting 
Picked Up in the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Error/Revision Management Using Redlines

Redline Status Worksheet 
The redline worksheet lists the status of all redlines in the current file. The Open Redlines section lists all redlines that 
require resolution; the Closed Redlines section shows all resolved redlines. For each redline item, the design layer 
location, date, and redline comment displays.
To create or open the redline status worksheet:

1. Select Text > Redlines > Create Redline Status WS.
2. The Redlines Status Report worksheet is created and opens automatically. It is added to the Window > 

Worksheets menu and it is listed in the Resource Browser.
Redlines, both open and closed, are listed in the report even if they are hidden in the current view of the file.

~~~~~~~~~~~~~~~~~~~~~~~~~
Error/Revision Management Using Redlines

Using the ID Label Tool 
The ID Label tool labels drawing objects with an identifier so they can be properly referenced on an associated 
schedule. These labels can be applied to specific objects with attached data records, such as doors, windows, 
equipment, plumbing fixtures, electrical items, and irrigation objects. This tool also provides a convenient way to 
specify or edit attached record data. The ID labels can be customized using special symbols (see “Creating Custom ID 
Label Symbols” on page 1266 for more information).

For doors and windows, the ID label bubble size is independent of text size. The ID bubble is drawn at the size 
specified in the ID Label Size field of the Object Info palette, unless the text exceeds the ID bubble size; in this 
case, the bubble automatically expands to fit the text. To restore the ID bubble to a fixed size, reduce the text size 
to fit within the ID bubble.
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To place an ID label:

1. Click the ID Label tool from the Dims/Notes tool set.
2. Click to set the location of the ID label.
3. Click on the object to associate with the ID label.

The ID/Specification Tool dialog box opens. Set the ID parameters.
4. Click Options to set specific preferences for this ID.

Click to show/hide the parameters.

If the object being labeled is a window or door, complete the fields in the ID Settings dialog box as described in 
the ID Tag tab section of “Window Settings: ID Tag Pane” on page 597 and “Door Settings: ID Tag Pane” on 
page 620. Select Auto-Increment ID Label in the ID Settings dialog box to automatically increment the 
numerical ID value each time the label is placed. Continue with step 6. For all other objects, go to step 5.

5. If the object being labeled is something other than a window or door, complete the fields in the Set ID Preferences 
dialog box.

Click to show/hide the parameters.

Parameter Description

ID Type Select the record associated with the ID; this is automatically selected if the object is 
associated with one of the available records

ID Style Select the graphical ID style to display
If a styled wall is being labeled, this is the only field available; data fields must be 
added and edited via the Resource Browser, as described in “Editing ID Labels and 
Records for Wall Styles” on page 1266.

Duplicate Existing ID Click to associate an existing ID to this label; select the ID from the list
Create New ID Click to create a new ID label

Prefix Assigns alphanumeric information before the numerical label value; adding prefix 
information is optional

Label Assigns a numerical value to the ID; this number increments automatically if the 
auto-increment option is chosen in the Set ID Preferences dialog box

Suffix Assigns alphanumeric information after the label value if the auto-increment option is 
chosen; adding suffix information is optional

Select a field to 
specify

Select a record field associated with the object to edit its value

Selected field value Enter or edit a field value and then click Set to confirm the change
Options For windows or doors, opens the ID Settings dialog box; for other objects, opens the Set 

ID Preferences dialog box

Parameter Description

Auto-Increment ID Label Automatically increments the numerical ID value each time the label is placed; 
not available for styled walls



  1264 | Using the ID Label Tool
6. Click OK.
The ID label is drawn.

To bypass the ID Label dialog boxes and automatically place an existing ID label repeatedly, hold down the Alt 
(Windows) or Option (Mac) key while applying additional labels.
To easily convert any object into a door or window, place an ID label on the object and select the Window Object 
or Door Object ID Type in the ID/Specification Tool dialog box. A symbol is automatically created for the object 
and displays in the Resource Browser, and is available to use as symbol geometry for subsequently placed 
windows or doors. Select the window or door object and click Settings in the Object Info palette to open the 
Window or Door Settings dialog box to attach record information to include in the window or door Schedule (see 
“Inserting Windows in Vectorworks Design Series” on page 594 and “Inserting Doors in Vectorworks 
Fundamentals” on page 609).

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Existing ID Labels and Record Information
Vectorworks Architect and Landmark ID Symbols

Editing Existing ID Labels and Record Information
After placement, objects with record information and ID labels can be edited to change the record or ID data. 
Worksheets, including schedules, and the ID Label tool can change the record information of multiple objects at once.

Editing Record Information with Worksheets
Global changes to symbol and plug-in object record information can be made using database rows in worksheets 
created with the Vectorworks program. During a schedule review, it is often necessary to make changes to objects and 
update them automatically on the drawing.
Only database rows are directly associated with drawing elements, and can update the drawing in this way. Fields 
which result from a calculation, or from locked objects, workgroup-referenced items, or control points, cannot edit 
drawing elements. For more information on worksheets, see “Using Worksheets” on page 1319.

Fix current record when 
matching IDs

Automatically overwrites the current record information when applying an 
existing ID label; not available for styled walls

Write ID fields of records with 
matchfield

Finds records with matching value in match field and writes ID value to match; 
not available for styled walls

Draw Leader from ID to object Draws a leader from the ID label to the object
Rotate ID with Leader Rotates the ID symbol to the angle of the leader line 
Length of leader shoulder Sets the length of the horizontal segment of the leader line
Arrow style Sets the style of arrow to use with the leader line
Marker scale factor Sets the size of the leader’s arrow; a factor of less than one decreases the size of 

the arrow while a factor of more than one increases its size

Parameter Description

H-79-R
Click 1

Click 2
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To edit record information from a worksheet:
1. Open the worksheet that contains the record information to be edited, by selecting the worksheet in the Resource 

Browser and selecting Edit from the Resources menu or the context menu. Alternatively, select the worksheet 
from the Window > Worksheets menu.
For example, a Window Schedule worksheet contains record information for the windows in the drawing.

2. Select the database row cell to be edited.
Text and number fields can be edited directly, while popup fields allow a selection to be made, either from the edit 
list at the top of the worksheet, or from the Pick Value from List context menu item.
To repeat the same value in several text or number fields of the same record, copy the desired value from one field, 
select multiple rows, and paste. (Pasting cannot be performed for popup fields.)

3. The drawing records automatically update with the new information, and the drawing objects reflect the changes.
If record field from a summarized database row has been edited, all objects referenced by the row are edited.

Editing ID or Record Information with the ID Label Tool
The ID Label tool can be used to change ID or record information after placing an ID. Labels and records for styled 
walls are edited differently; see “Editing ID Labels and Records for Wall Styles” on page 1266 for details.

To edit an existing ID label or record information:

1. Click the ID Label tool from the Dims/Notes tool set.
2. Double-click on the ID label to edit.

If the labeled object is a window or door, complete the fields as described in the Data tab section of “Window 
Settings: Data Pane” on page 605 and “Door Settings: Data Pane” on page 629. If editing the object through the 
Object Info palette, an additional parameter, ID Label Size, is available for controlling the size of the ID label 
bubble. Continue with step 4. For all other objects, go to step 3.
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3. If the labeled object is something other than a window or door, edit the fields in the ID/Specification Tool dialog 
box, as described in “Using the ID Label Tool” on page 1262.

4. Click OK.
The edits are applied to the ID label and record attached to the object.

Editing ID Labels and Records for Wall Styles
Data fields (including an ID label) are specified for each wall style, which means that each wall with a particular style 
has the same label and record attached to it. Therefore, ID labels and records cannot be edited for individual styled 
walls with the ID Label tool. (See “Using Wall Styles” on page 507 for more information about creating, editing, and 
using wall styles.)
To edit ID label or record information for a wall style:

1. Select the wall style from the Resource Browser and click Resources > Edit.
2. In the Edit Wall Style dialog box, click the Data Fields tab.
3. Enter a label ID in the Mark field, and enter other data fields as necessary.
4. Click OK to close the Edit Wall Style dialog box, and click OK again to close the Wall Replacement dialog box.

From this point forward, walls that are created with this style have the specified data record attached; when an ID 
label is added to a wall that has this style, the Mark entry displays in the label.

Vectorworks Architect and Landmark ID Symbols 
The following ID symbols are provided with the Vectorworks Architect and Landmark products, and require the 
presence of the indicated record format in the drawing file. The ID Label tool creates the record format if it does not 
already exist.

~~~~~~~~~~~~~~~~~~~~~~~~~
Sheet Border Properties

Creating Custom ID Label Symbols

Understanding ID Labels
The Vectorworks Architect and Landmark ID labels are created as plug-in objects that draw an ID symbol and an 
optional leader line. The symbols can automatically be kept horizontal, or can be rotated to the leader line angle.
It is possible to create ID symbols based on custom markers. ID symbols have certain requirements that must be met.

Architect and Landmark Equipment IDs
(require Equipment record)

Equipt ID 1
(ID)

Equipt ID 2
(ID) - [no leader]

Equipt ID 3
(ID)

Equipt ID 4
(ID)

Architect Partition IDs
(require Styled Wall record)

Wall ID 1
(ID)

Wall ID 2
(ID) - [fixed length line]

Wall ID 3
(ID) - [note: NCS style]

Wall ID 4
(ID)

The leader on these two 
symbols is part of the 
symbol and fixed in length
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ID Symbol Requirements
The ID Label tool (see “Using the ID Label Tool” on page 1262) detects the presence of any existing record 
information for the object being labeled in the drawing; if the tool cannot detect record information, you are prompted 
to select the appropriate record from a list. The ID symbols defined to work with that record type display for selection. 
The ID Label tool determines whether the ID symbol requested in the dialog box is present in the drawing. If not, it 
copies it in from the ID_Symbols.vwx file, and scales it to the current drawing layer scale. Once an appropriate scaled 
symbol is created, it is used without further reference to external documents.
ID symbols must meet the following requirements:

• They are stored in the library file [Vectorworks]\Plug-Ins\Common\Data\ID_Symbols.vwx;
• They are created at a 1:1 scale, using certain graphic primitives;
• They use linked text to display ID and attribute information; and,
• They have a TagSchema record attached.

The TagSchema Record
The TagSchema record determines the behavior of the ID symbol text. This record is present in the ID_Symbols.vwx 
file.

The AutoIncrement, FixCurrRecord, WriteMatchIDs, DrawLeader, and KeepHoriz fields are Boolean (true/false) 
values; ShoulderLength and MkrScaleFactor are numerical values. All other fields are text values.

ID Symbol Leader Options
Four TagSchema record fields determine whether the ID symbol is drawn with a leader, and, if so, determine the 
leader’s appearance. 
Click to show/hide the parameters.

Data record format ID symbol is linked to; must match
record name exactly

Current settings for these fields in the file, as set by the ID
Label tool

Up to seven definitions of linked text fields (can be
combinations of data record fields); see “Defining ID

Symbol Custom Fields” for more details

Advanced feature option settings for this symbol type; fields hold
current defaults for these ID settings and may be modified by the ID

Label tool in the ID/Specification Tool dialog box

Graphics options for drawing ID symbol

Up to seven fields linked to text within ID symbol
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ID Symbol Record Writing Options
There are three ID record writing options controlled by four fields in the TagSchema record:
Click to show/hide the parameters.

Parameter Description

DrawLeader If DrawLeader is false, no leader is drawn with the ID Leader object; otherwise, a leader is 
drawn between the ID symbol and the object to which the ID is referring. This field sets the 
default for the draw leader parameter in the ID Leader object, which can be changed later.

KeepHoriz If KeepHoriz is false, the ID symbol is drawn rotated to the leader angle; otherwise, the 
symbol is rotated horizontally, with a small “shoulder” line segment which is controlled 
using the value in the ShoulderLength field. These fields set the defaults for the KeepHoriz 
value and the ShoulderLength value of the ID Leader object, respectively. IDs with no 
leader should normally set KeepHoriz to true.

ArrowStyle This field, along with MkrScaleFactor, controls the appearance of the marker at the end of 
the leader (if any)

MkrScaleFactor This field, along with ArrowStyle, controls the appearance of the marker at the end of the 
leader (if any); this setting is a multiplier on a marker size of approximately 1/4”. For 
example, a MkrScaleFactor setting of 0.5 results in a marker of 1/8” standard size.

DrawLeader True DrawLeader False

KeepHoriz True KeepHoriz False

0 - None

1 - Thin Solid Arrow

2 - Wide Solid Arrow
3 - Thin Hollow Arrow

4 - Wide Hollow Arrow
5 - Dot
6 - Circle

7 - Cross

8 - Slash
9 - Lasso
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Defining ID Symbol Custom Fields
The ID symbol can have up to seven fields containing virtually any text, combined with the contents of the data record 
the ID uses.
For example, the ID Label tool reads the contents of the Fld1Spec field and writes the results to the Fld1Text field. 
The “Spec” field follows the format FieldName& “string constant” where the field names are fields in the data record 
named in the TagType field; the & indicates a concatenation, and the string constants are surrounded by double quotes.
For example, a field in the data record is called “Count.” This is a number field representing the total number of 
something. You want the first field in the ID to read: TOTAL: 12 when “Count” is 12. Enter the following formula in 
the Tag1Spec field: “TOTAL: ”&Count. There are no spaces between the ampersand and the field name, or between 
the string constant (in quotes) and the ampersand.
You can concatenate any number of fields and constants. For example, you could add the word “Item(s)” to the tag field 
definition by using the following formula: “TOTAL: ”&Count& “ Item(s)”.
There are a variety of pre-defined fields in the ID symbols that come with the Vectorworks Architect and Landmark 
products. Use these as a guideline in understanding this special formula language. This same formula convention is 
also used to define HVAC object tags.

Error Messages in ID Fields
If the ID Label tool cannot find the data record specified in the TagType field of the TagSchema record, the error 
message #RECORDNAME?# displays when the ID is placed. If any of the fields in the formula are misnamed, the 
message #FIELDNAME?# displays in the affected ID field. Verify the spelling of record and field names and ensure 
the data record is defined as described in “The Data Record” on page 1269.

The Data Record
The data record named in the TagType field of the ID symbol should be part of the standard records created using the 
VA Records and Schedules command and should be present in the current preference set. This enables the ID Label 
tool to create the record automatically if it is not defined at the time the ID Label tool is used.

The TagType “Styled Wall” is reserved for use when an ID is placed on a styled wall.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Custom ID Symbols

Creating Custom ID Symbols
Keeping in mind the information described in “Understanding ID Labels” on page 1266, it is possible to create a 
custom ID symbol to be used by the ID Label tool. 
An ID symbol can consist of any 2D object supported in the Vectorworks program except circles, arcs, grouped objects, 
or other symbols. These guidelines are necessary for the scaling algorithm currently used by the ID Label tool, to scale 

Parameter Description

AutoIncrement The value in this field controls the default setting for whether the ID number is automatically 
incremented between placements

FixCurrRecord The value in this field controls whether the contents of the current record are rewritten to match 
earlier IDs with the same ID entry

WriteMatchIDs The value in this field controls the writing of matching ID fields to records with identical 
contents in the MatchField text field

MatchField Provides a record field for writing the ID for matching
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the symbol to the correct scale for the file. To achieve the look of an arc in the symbol, use an arc-smoothed vertex of a 
polyline; use an oval instead of a circle.
To create a custom ID symbol:

1. Open the ID Symbols.vwx file, located in the [Vectorworks]\Plug-Ins\Common\Data folder.
The TagSchema record, as well as the ID symbols currently used by the ID Label tool, are present in this file.

2. At a 1:1 scale, draw the object representing the ID symbol.
3. Select Modify > Create Symbol to create a symbol from the object (see “Creating New Symbols” on page 239 

for more information on creating symbols).
4. Select the new symbol in the Resource Browser and select Resources > Edit.

The Edit Symbol dialog box opens.
5. Select the 2D Component and click Edit to open the Edit Symbol window.
6. Deselect all items by clicking in an empty area.

On the Data tab of the Object Info palette, *SYMBOL DEFAULTS* is displayed.
7. Attach the Tag Schema record by selecting it from the Data tab.
8. An “X “displays in the check box.
9. Select the TagType field and replace the field name with the exact name of your custom record.

10. Create and format text to be used to display the ID symbol text.
For more information, see “Linking Text to Record Formats” on page 269.

11. With the text selected, select Tools > Records > Link Text to Record.
The Choose Field dialog box opens.

12. In the Tag Schema record format, select the Label field and click OK.
13. The symbol text is linked to display the contents of the Label record field.

To check the text link, enter text in the Label field on the Data tab of the Object Info palette. Data entered now 
would be overwritten later, in any case, by the ID Label tool.
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14. Click Exit Symbol at the top right corner of the window to return to the drawing.
15. In the Pally script palette, double-click the Output ID Prefs script to run it.
16. Save the ID_Symbols.vwx file.
17. In the drawing file where the custom ID symbol is to be used by the ID Label tool, ensure that a record format 

exists which exactly matches the record name entered previously in the TagType field.
18. Select the ID Label tool from the Dims/Notes tool set.

The ID/Specification Tool dialog box opens.
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19. The custom record is one of the selections for ID Type. Select it to use the associated custom ID symbol and click 
OK.

Section Note 
The Section Note object annotates the drawing or detail with section letters, and, if desired, a scale. The text attributes 
are editable by the Format Text command.

To insert a section note:

1. Click the Section Note tool from the Dims/Notes tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.
Click to show/hide the parameters.

Parameter Description

Section Specifies the section note
% of Title Specifies the size of the section letters or numbers in relation to the section name. Enter a 

percentage between 50 to 200.
Scale (opt) Displays the scale information below the section information, if desired
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Material Note 
The Material Note object annotates the drawing or detail with material composition, and, if desired, scale. The text 
attributes are editable by the Format Text command.

To insert a material note:

1. Click the Material Note tool from the Dims/Notes tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.
Click to show/hide the parameters.

Center Line Marker 
The Center Line Marker object denotes the center line on drawings.

% of Title Specifies the size of the scale name and number in relation to the section name. Enter a 
percentage between 50 to 200.

All Caps Select to display the section and scale names in capital letters
Underline Select the underline style, if desired

Parameter Description

Material Specifies the material note
% of Title Specifies the size of the material letters or numbers in relation to the material name. Enter 

a percentage between 50-200.
Scale (opt) Displays the scale information below the material information, if desired

% of Title Specifies the size of the scale name and number in relation to the material name. Enter a 
percentage between 50 to 200.

All Caps Select to display the material name in capital letters
Underline Select the underline style

Parameter Description

None 1 line 2 lines

None 1 line 2 lines
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To insert a center line marker object:

1. Click the Center Line Marker tool from the Dims/Notes tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.
Click to show/hide the parameters.

Creating Detail Bubbles
A detail bubble assigns a detail number to the parts of an assembly drawing. 

The information associated with the detail bubble can be used to create both parts lists and bill of materials lists.
~~~~~~~~~~~~~~~~~~~~~~~~~
Adding Detail Bubbles
Detail Bubble Record Format
Editing Detail Bubbles
Aligning and Distributing Leader Lines

Adding Detail Bubbles 

To add a detail bubble:

1. Click the Detail Bubble tool from the Dims/Notes tool set.

Parameter Description

Size (on paper) Specifies the size of the object
Style Select the center line marker style

1 2 3 4
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2. Click on the drawing to place the bubble portion of the object. Click again to place the marker. 
If this is the first time the object has been inserted in this session, the Object Properties dialog box opens. If the 
Attributes palette has not been set to use end markers, select the marker style, size, and angle from the Object 
Properties dialog box.
If no Part Info record exists, one is created automatically the first time a detail bubble is placed in the drawing.

The detail bubble number automatically increments as the bubbles are placed. Change the auto-incrementing 
number by editing the Item Number field in the Object Info palette. When detail bubble placement resumes, the 
last number entered becomes the starting number.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Detail Bubbles

Detail Bubble Record Format
The Part Info record format stores the information for the detail bubble. This record format can be edited to add new 
fields or to delete existing fields. To edit the record format, right-click on the record format in the Resource Browser 
and select Edit. For more information on record formats, see “Record Formats” on page 262.
If new fields are created, the existing Bill of Materials and Parts List worksheets need to be modified to reflect the 
changes. Alternatively, create new worksheets to accommodate the new fields. For more information on using 
worksheets, see “Using Worksheets” on page 1319.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Detail Bubbles

Editing Detail Bubbles

Detail Bubble Properties
Edit the detail bubble properties in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use 

the style associated with the class, select <Class Text Style>. To format the text using 
options on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 
and “Formatting Text” on page 389.

Min. Bubble Size Enter the minimum bubble size

Click 1

Click 2
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Once the detail bubble has been placed, its marker can be selected from the Attributes palette (see “Marker Attributes” 
on page 1102).

Editing Detail Bubble Record Information
To edit the record information associated with a detail bubble: 

1. Select the bubble, and then click Change Bubble Info on the Object Info palette.
The Edit Detail Bubble dialog box opens.

2. Enter the information associated with the detail bubble. The information can be used to complete the parts list and 
bill of materials worksheets.

3. Click OK to return to the Object Info palette. If the Item # was changed, the change is automatically made to the 
Object Info palette and the object.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Detail Bubbles
Marker Attributes

Creating a Bill of Materials 
The information associated with the detail bubbles can be included in a worksheet which automatically generates a bill 
of materials list.
To create a bill of materials:

1. Once the detail bubble record information has been completed, select the Create Bill of Materials command from 
the appropriate menu:
• Architect workspace: AEC > Machine Design > Create Bill of Materials 
• Landmark workspace: Landmark > Machine Design > Create Bill of Materials 
• Spotlight workspace: Spotlight > Machine Design > Create Bill of Materials 

2. With the bull’s-eye cursor, click in the drawing to place the worksheet.
Alternatively, access the Bill of Materials worksheet object with the Resource Browser from the title blocks file in 
the [Vectorworks]\Libraries folder (see “Resource Libraries” on page 219). Double-click the Bill of Materials 
worksheet object in the Resource Browser to place the worksheet graphic object. 

3. Double-click on the worksheet, or select Window > Worksheets > Bill of Materials, to open the worksheet. 
From the Worksheet menu, select Recalculate. The record information from the detail bubbles automatically fills 
the worksheet, and all calculations are performed. For more information on worksheets, see “Using Worksheets” 
on page 1319.

4. Close the worksheet. The worksheet graphic object on the drawing reflects the changes.

Shape Select one of the bubble shapes

Item Number Specify the number to display in the detail bubble; the item number is used for bill of 
materials and parts list worksheets

Change Bubble Info Click to edit the bubble detail

Parameter Description

Round         Triangle         Square       Diamond      Hexagon
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5. Reopen the worksheet and select Recalculate from the Worksheet menu to update the worksheet when any 
changes are made to the record information.
A parts list can be added to an ASME title block; see “Sheet Border Properties” on page 78.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Parts List
Creating Detail Bubbles
Creating Reports

Creating a Parts List 
The information associated with the detail bubbles can be included in a worksheet that automatically generates a parts 
list.
To create a parts list:

1. Once the detail bubble record information has been completed, select the Create Parts List command from the 
appropriate menu:
• Architect workspace: AEC > Machine Design > Create Parts List 
• Landmark workspace: Landmark > Machine Design > Create Parts List 
• Spotlight workspace: Spotlight > Machine Design > Create Parts List 

2. With the bull’s-eye cursor, click in the drawing to place a Parts List worksheet.
Alternatively, select the appropriate parts list worksheet object with the Resource Browser from the title blocks 
file in the [Vectorworks]\Libraries folder (see “Resource Libraries” on page 219). Double-click the appropriate 
parts list worksheet object in the Resource Browser to place the worksheet graphic object. 
The Parts List-1 worksheet object is formatted to fit the ASME title blocks for ASME A, B, and C and ISO A2, 
A3, A4, and A5 drawing sizes. The Parts List-2 worksheet object is formatted to fit the ASME title blocks for 
ASME D, E, and F, and ISO A0 and A1 drawing sizes.

3. Double-click on the worksheet, or select Window > Worksheets > Parts List to open the worksheet. From the 
Worksheet menu, select Recalculate. The record information from the detail bubbles automatically fills the 
worksheet, and all calculations are performed. For more information on worksheets, see “Using Worksheets” on 
page 1319.

4. Close the worksheet. The worksheet graphic object on the drawing reflects the changes.
5. Reopen the worksheet and select Recalculate from the Worksheet menu to update the worksheet when any 

changes are made to the record information.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Bill of Materials
Creating Detail Bubbles
Creating Reports

Welding and Surface Texture Symbols
Vectorworks Design Series products contain a comprehensive collection of welding symbols and also include a surface 
texture symbol. All symbols are placed as point objects.
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~~~~~~~~~~~~~~~~~~~~~~~~~
Fillet Welding Symbol
Groove Welding Symbol
Flange Welding Symbol
Miscellaneous Welding Symbols
Slot-Plug Welding Symbol
Surface Texture Symbol
Editing the Arrow Segment

Fillet Welding Symbol

To insert a fillet welding symbol:

1. Click the Welding Sym-Fillet tool from the Dims/Notes tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.
4. Once the object has been placed, its marker can be selected from the Attributes palette (see “Marker Attributes” on 

page 1102).
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1-3
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Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use 

the style associated with the class, select <Class Text Style>. To format the text using 
options on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 
and “Formatting Text” on page 389.

Symmetrical (both sides 
the same as Arrow Side) 
(AWS Only)

Select to reflect the same information on both the arrow side and the other side

Configuration (ISO 
Only)

Select the data display configuration; if symmetrical is selected, the data on the other 
side is identical to the arrow side

Arrow Side/Other Side Select to display data on the arrow side, other side or both; if symmetrical is selected, 
the displayed data applies to both sides

Weld Size Displays the size of the weld
Number of Welds 
(ISO Only)

Displays the number of welds

Length of Weld Displays the length of the weld
Pitch/Spacing Displays the pitch or spacing of the weld
Finish Contour Select the finish contour type

Symmetrical (both 
sides the same as 
Arrow Side)

Arrow Side Bottom/ Other 
Side Top

Arrow Side Top/ Other 
Side Bottom

a25
a25

10 x 30 (25)
10 x 30 (25)

a25
a25

5 x 30 (50)
10 x 30 (25)

a25
a25

10 x 30 (25)
5 x 30 (50)

None Flush or Flat

ConcaveConvex

1/4 1 - 3

1/4 1 - 3

1/4 1 - 3

1/4 1 - 3
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Welding and Surface Texture Symbols
Editing the Arrow Segment

Finish Method Select the finish method type. A finish contour must be selected in order to display a 
finish method.

Stagger Select to indicate staggered welds

Arrow Sets whether to have an arrow on the leader line
Position Select the side from which the arrow on the leader line extends (left or right)

Reference Specify whether to include a reference note
Position Select the position of the reference note; by default, Left is selected if the arrow is on 

the right, or Right is selected if the arrow is on the left
Ref. Line 1 If desired, enter the data to display in 

the first reference line
Ref. Line 2 If desired, enter the data to display in 

the second reference line
Ref. Line 3 If desired, enter the data to display in 

the third reference line
Weld All Around Select to place a weld all around the marker
Field Weld Select to place a field weld flag

Position Sets the position of the field weld flag. Select Top |> to have the flag on top facing 
right, Top <| to have the flag on top facing left, Bottom |> to have the flag on bottom 
facing right, Bottom <| to have the flag on bottom facing left.

Parameter Description

Unspecified Chipping

Grinding Hammering

Machining Rolling

Finish methods are shown with the flat or flush contour

1/4 1 - 3 1/4 1 - 3

1/4 1 - 3 1/4 1 - 3

1/4 1 - 3 1/4 1 - 3

C

G H

M R

Staggered (AWS) Staggered (ISO)

a25
a25

10 x 30
10 x 30

(25)
(25)

1/4 1 - 3
1/4 1 - 3

Typ 2 Sides

See Section A-A

Top |> Top <| Bottom |>Bottom <|
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Marker Attributes

Groove Welding Symbol 

To insert a groove welding symbol:

1. Click the Welding Sym-Groove tool from the Dims/Notes tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.
4. Once the object has been placed, its marker can be selected from the Attributes palette (see “Marker Attributes” on 

page 1102).

Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use 

the style associated with the class, select <Class Text Style>. To format the text using 
options on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 
and “Formatting Text” on page 389.

Symmetrical (both sides the 
same as Arrow Side) (AWS 
Only)

Select to reflect the same information on both the arrow side and the other side

Configuration (ISO Only) Select the data display configuration; if symmetrical is selected, the information on 
the other side is identical to the arrow side

Arrow Side/Other Side Select to display data on the arrow side, other side or both; if symmetrical is selected, 
the displayed data applies to both sides

Welding Symbol - Groove (AWS) Welding Symbol - Groove (ISO)

Depth of Bevel
Weld Size

Depth of Bevel

Weld Size

Groove Angle

Root Opening

Groove Angle

Root Opening
1/4 (3/8)

60°

1/4 (3/8)

1/8

1/8
60°

60°

60°

6 (10)
6 (10)

3

3

Symmetrical (both 
sides the same as 
Arrow Side)

Arrow Side Bottom/ 
Other Side Top

Arrow Side Top/ 
Other Side Bottom

6 (10)

6 (10) 6 (10)

6 (10)5 (20)

5 (20)
333

3 3 3
60° 60°45°

45°60°60°
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Weld Symbol Select the type of groove weld symbol to be displayed

Weld Size Displays the size of the weld
Depth of Bevel Displays the depth of the bevel
Root Opening Displays the root opening
Groove Angle Displays the groove angle
Finish Contour Select the finish contour type

Finish Method Select the finish method type

Parameter Description

<None> Bevel Flare - Bevel Flare - V

Scarf Square J U

V Back or Backing Weld Melt Through Backing

Backing (Remove) Consumable Insert

None Flush or Flat

ConcaveConvex

1/4 (3/8) 1/4 (3/8)

1/4 (3/8) 1/4 (3/8)

60°
1/8

60°
1/8

60°
1/8

60°
1/8

Finish methods are shown with the flat or flush contour

<Unspecified> Chipping Grinding

Hammering Machining Rolling

1/4 (3/8) 1/4 (3/8) 1/4 (3/8)

1/4 (3/8) 1/4 (3/8) 1/4 (3/8)

C G

H M R

60°
1/8

60°
1/8

60°
1/8

60°
1/8

60°
1/8

60°
1/8
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Welding and Surface Texture Symbols
Editing the Arrow Segment
Marker Attributes

Flange Welding Symbol 

To insert a flange welding symbol:

1. Click the Welding Sym-Flange tool from the Dims/Notes tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.
4. Once the object has been placed, its marker can be selected from the Attributes palette (see “Marker Attributes” on 

page 1102).

Arrow Sets whether to have an arrow on the leader line
Position Select the side from which the arrow on the leader line extends (left or right)

Reference Specify whether to include a reference note
Position Select the position of the reference note; by default, Left is selected if the arrow is on 

the right, or Right is selected if the arrow is on the left
Ref. Line 1 If needed, enter the data to display in 

the first reference line
Ref. Line 2 If needed, enter the data to display in 

the second reference line
Ref. Line 3 If needed, enter the data to display in 

the third reference line
Weld All Around Select to place a weld all around the marker
Field Weld Select to place a field weld flag

Position Sets the position of the field weld flag. Select Top |> to have the flag on top facing 
right, Top <| to have the flag on top facing left, Bottom |> to have the flag on bottom 
facing right, Bottom <| to have the flag on bottom facing left.

Parameter Description

Typ 2 Sides

See Section A-A

Top |> Top <| Bottom |>Bottom <|
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Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. To use 

the style associated with the class, select <Class Text Style>. To format the text 
using options on the Text menu, select <Un-Styled>. See “Using Text Styles” on 
page 393 and “Formatting Text” on page 389.

Type of Weld Sets the weld type

Configuration (ISO Only) Select the data display configuration

Significance Select to display data on the arrow side or the other side
Weld Size Displays the size of the weld
Flange Size Displays the size of the flange
Radius of Flange Displays the radius of the flange
Root Opening Displays the size of the root opening
Complete Joint Penetration Select to display a complete joint penetration marker

Arrow Sets whether to have an arrow on the leader line
Position Select the side from which the arrow on the leader line extends (left or right)

Flange Size

Radius of
Flange

Weld Size

Root Opening

Radius of
Flange

Weld Size

Root Opening

Flange Size

Welding Symbol - Flange (AWS) Welding Symbol - Flange (ISO)

Arrow SideArrow Side

Other SideOther Side

3/32 + 1/16
1/8

1/64
2.5 + 2

4
1

Edge-Flange Weld Corner-Flange Weld

Arrow Side Bottom/ 
Other Side Top

Arrow Side Top/ 
Other Side Bottom

2.5 + 2

2.5 + 2

4

4

1

1

Complete Joint Penetration Marker

3/32 + 1/16
1/8 1/64
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Miscellaneous Welding Symbols 

To insert a miscellaneous welding symbol:

1. Click the Welding Sym-Misc tool from the Dims/Notes tool set to insert a spot, seam, stud, or surfacing welding 
symbol.

2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 
object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.
4. Once the object has been placed, its marker can be selected from the Attributes palette (see “Marker Attributes” on 

page 1102).

Click to show/hide the parameters.

Reference Specify whether to include a reference note
Position Select the position of the reference note; by default, Left is selected if the arrow is 

on the right, or Right is selected if the arrow is on the left
Ref. Line 1 If needed, enter the data to display in the 

first reference line
Ref. Line 2 If needed, enter the data to display in the 

second reference line
Ref. Line 3 If needed, enter the data to display in the 

third reference line

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)

Parameter Description

Typ 2 Sides

See Section A-A

Welding Symbol - Miscellaneous (AWS) Spot Weld Welding Symbol - Miscellaneous (ISO) Spot Weld

Weld Size
Weld Size

Spacing or Pitch

Number of WeldsSpacing or Pitch

Number of Welds

3/8 2
(6) 8 6 (50)



  1286 | Welding and Surface Texture Symbols
Text Style Select a text style from either the default content or the current file’s content. To use 
the style associated with the class, select <Class Text Style>. To format the text using 
options on the Text menu, select <Un-Styled>. See “Using Text Styles” on page 393 
and “Formatting Text” on page 389.

Type of Weld Select the weld symbol type

Configuration (ISO Only) Select the data display configuration

Significance Sets where data displays about the leader line

Weld Size Displays the size of the weld. Applies to all weld types.
Length Displays the length of the weld. Applies to the seam weld only.
Spacing or Pitch Displays the desired spacing or pitch. Applies to spot, seam, and stud welds only.
Number of Welds Displays the number of welds. Applies to spot, seam, and stud welds only.
Finish Contour Select the finish contour type

Finish Method Select the finish method type

Parameter Description

Spot Seam

Stud Surfacing

3/8 2
(6)

3/8 2
(6)

3/8

3/8

1/2 - 2
(6)

Arrow Side Bottom/ 
Other Side Top

Arrow Side Top/ 
Other Side Bottom

8 6 (50)
8 6 (50)

Arrow Side Other Side None

8 6 (50)

8 6 (50) 8 6 (50)

None Flush or Flat

ConcaveConvex

8 6 (50) 8 6 (50)

8 6 (50) 8 6 (50)

Unspecified Chipping

Grinding Hammering

Machining Rolling

8 6 (50) 8 6 (50)

8 6 (50) 8 6 (50)

8 6 (50) 8 6 (50)

C

G H

M R
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Slot-Plug Welding Symbol 

To insert a slot-plug welding symbol:

1. Click the Welding Sym-Slot-Plug tool from the Dims/Notes tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.
4. Once the object has been placed, its marker can be selected from the Attributes palette (see “Marker Attributes” on 

page 1102).

Arrow Sets whether to have an arrow on the leader line
Position Select the side from which the arrow on the leader line extends (left or right)

Reference Specify whether to include a reference note
Position Select the position of the reference note; by default, Left is selected if the arrow is on 

the right, or Right is selected if the arrow is on the left
Ref. Line 1 If needed, enter the data to display in the 

first reference line
Ref. Line 2 If needed, enter the data to display in the 

second reference line
Ref. Line 3 If needed, enter the data to display in the 

third reference line
Weld All Around Select to place a weld all around the marker
Field Weld Select to place a field weld flag

Position Sets the position of the field weld flag. Select Top |> to have the flag on top facing 
right, Top <| to have the flag on top facing left, Bottom |> to have the flag on bottom 
facing right, Bottom <| to have the flag on bottom facing left.

Parameter Description

Typ 2 Sides

See Section A-A

Top |> Top <| Bottom |>Bottom <|
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Click to show/hide the parameters.

Parameter Description

Rotation Specifies the number of degrees to rotate the object (0.00 is horizontal)
Text Style Select a text style from either the default content or the current file’s content. 

To use the style associated with the class, select <Class Text Style>. To 
format the text using options on the Text menu, select <Un-Styled>. See 
“Using Text Styles” on page 393 and “Formatting Text” on page 389.

Type of Weld Select the weld type

Symmetrical (both sides the same 
as Arrow Side) (AWS Only)

Select to reflect the same information on both the arrow side and the other 
side

Configuration (ISO Only) Select the data display configuration; if symmetrical is selected, the 
information on the other side is identical to the arrow side

Arrow Side/Other Side Select to display data on the arrow side, other side or both; if symmetrical is 
selected, the displayed data applies to both sides

Weld Size (Plug Weld Only) Displays the weld size
Slot Width (Slot Weld Only) Displays the width of the slot
Slot Length (Slot Weld Only) Displays the length of the slot
Angle of Countersink Displays the angle of the countersink
Depth of Filling Displays the depth of the filling
Spacing Displays the spacing
Number of Welds Displays the number of welds

Welding Symbol Slot-Plug (AWS) Slot Weld Welding Symbol Slot-Plug (ISO) Plug Weld
Arrow Side

Angle of Countersink

Slot 
Length

Number of
Welds Arrow Side

Other Side Other Side

Spacing

Slot Width

Depth of
Filling

Depth of
Filling

Weld Size
Number of

Welds

Spacing

(6)
60°

3/8
3/8

(6)
60°

1/4
1/4

1 1/2 - 2 1/2
1 1/2 - 2 1/2

60°

60°

6 (65)
6 (65)

Ø 8
Ø 8

10
10

Angle of Countersink

Plug Weld Slot Weld

Ø 3/8 1/4 2 1/2
60°
(6)

3/8 1/4 1 1/2 - 2 1/2
60°
(6)

Symmetrical (both 
sides the same as 
Arrow Side)

Arrow Side Bottom/ 
Other Side Top

Arrow Side Top/ Other 
Side Bottom

Ø 8
Ø 8

Ø 8
Ø 8

Ø 8
Ø 8

60°

60°

60°

60°

45°

45°
6 (65)
6 (65)

6 (65)
6 (65)

6 (65)
6 (65)

10
10

10
10

10
10
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Finish Contour Select the finish contour type

Finish Method Select the finish method type

Arrow Sets whether to have an arrow on the leader line
Position Select the side from which the arrow on the leader line extends (left or right)

Reference Specify whether to include a reference note
Position Select the position of the reference note; by default, Left is selected if the 

arrow is on the right, or Right is selected if the arrow is on the left
Ref. Line 1 If needed, enter the data to 

display in the first reference line
Ref. Line 2 If needed, enter the data to 

display in the second reference 
line

Ref. Line 3 If needed, enter the data to 
display in the third reference line

Weld All Around Select to place a weld all around the marker
Field Weld Select to place a field weld flag

Parameter Description

None Flush or Flat

ConcaveConvex

Ø 3/8 1/4 2 1/2
60°
(6)

Ø 3/8 1/4 2 1/2
60°
(6)

Ø 3/8 1/4 2 1/2
60°
(6)

Ø 3/8 1/4 2 1/2
60°
(6)

Unspecified Chipping

Grinding Hammering

Machining Rolling

Ø 3/8 1/4 2 1/2
60°
(6)

Ø 3/8 1/4 2 1/2
60°
(6)

Ø 3/8 1/4 2 1/2
60°
(6)

Ø 3/8 1/4 2 1/2
60°
(6)

Ø 3/8 1/4 2 1/2
60°
(6)

Ø 3/8 1/4 2 1/2
60°
(6)

C

G H

M R

Typ 2 Sides

See Section A-A



  1290 | Welding and Surface Texture Symbols
~~~~~~~~~~~~~~~~~~~~~~~~~
Welding and Surface Texture Symbols
Editing the Arrow Segment
Marker Attributes

Surface Texture Symbol

To insert a surface texture symbol:

1. Click the Surface Texture Symbol tool from the Dims/Notes tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Position Set the position of the field weld flag. Select Top |> to have the flag on top 
facing right, Top <| to have the flag on top facing left, Bottom |> to have the 
flag on bottom facing right, Bottom <| to have the flag on bottom facing left.

Parameter Description

Roughness Value 1 (Max) Displays the primary maximum roughness value
Roughness Value 1 (Min) Displays the primary minimum roughness value
Waviness Height Displays the waviness height
Roughness Value 2 (Max) Displays the secondary maximum roughness value
Roughness Value 2 (Min) Displays the secondary minimum roughness value

Parameter Description

Top |> Top <| Bottom |>Bottom <|

Production Method

Roughness Value 2 (Max)

Roughness Value 2 (Min)

Roughness Value 1 (Max)

Roughness Value 1 (Min)

Surface Pattern
Machining Allowance

b

(e)

a1

f2
a2 c / f1

=
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Editing the Arrow Segment 
The arrow segment of each welding symbol has two control points for adjusting the segment position.

To move the control points of an arrow segment:
1. Select the welding symbol to edit.
2. Click and hold the leader end control point.

Surface Pattern Select the surface pattern type

Machining Allowance Displays the machining allowance
Production Method Displays the production method
Special Conditions Select the special condition

Same Condition on All 
Surfaces

Select to add a Same Condition on All Surfaces marker

Rotate Text with Symbol Select to rotate the text with the symbol
Clear All Fields Select to delete the current information from all fields

Parameter Description

None Parallel Perpendicular

Crossed Multi-
Directional

Approximately 
Radial

Particulate or 
Non-Directional

Approximately 
Circular

X C

R P

=

None Removal of 
material 
required

Removal of 
material is not 

permitted

Leader shoulder

Leader end

1/4 1 - 3
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3. Drag the leader end control point to the new location and click to set.

4. Click and hold the leader shoulder control point.
5. Drag the leader shoulder control point to the new location and click to set.

1/4 1 - 3

1/4 1 - 3

1/4 1 - 3
1/4 1 - 3



Notes Management
The Vectorworks Design Series products provide a full set of features for managing and creating complete and 
fully-referenced annotation of project files. These features can streamline the annotation process by providing a central 
location for storing, selecting, and placing frequently-repeated notes. Notes can be reused across files, either within a 
project, or across separate projects.
A callout is text with a leader line, displaying information about an item in the drawing; a callout object is included 
with the Vectorworks Fundamentals product. Its capabilities are extended in the Vectorworks Design Series products, 
allowing it to be used for keynotes in addition to ordinary notes. A keynote is a callout that references a note contained 
in a keynote legend. Placing callouts as keynotes also creates a keynote legend object. The keynote legend 
automatically numbers the notes, and ensures that multiple instances of the same note are assigned the same keynote 
number. General notes, also available in the Vectorworks Design Series products, contain text not associated with a 
particular item in the drawing.
The callout, keynote legend, and general notes objects can be used with manually-entered text, or in conjunction with 
external databases which store and retrieve text. When a database is used, text is entered only once into the database, 
and then pulled from the database for notes in the drawing. After notes have been placed, if changes are made to the 
database or to the notes, the differences can be reconciled with the Reconcile Notes command.
~~~~~~~~~~~~~~~~~~~~~~~~~
Notes Management without Databases
Notes Management with Databases
Converting Notes from Previous Versions

Notes Management without Databases

Inserting Callouts or Keynotes
The Callout tool places callout objects on a drawing. A callout object is a block of text attached to a leader line with an 
optional bubble surrounding the text. Use callout objects to annotate items in a file.
In the Vectorworks Design Series products, the Callout tool includes extended capabilities which allow it to be used 
for keynotes. A keynote legend is automatically created.
A keynote can be used without a database as described in this section, or in conjunction with an external notes database 
(see “Placing Database Callouts” on page 1304).

Mode Description

Towards Target Click first where the callout text is to be placed, and then near the object to be annotated
Towards Text Click first near the object to be annotated, and then where the callout text is to be placed
Two Point Two clicks are required to place the callout object; in Two Point mode, the length of the 

shoulder is determined in the callout preferences or Object Info palette
Three Point Three clicks are required to place the callout object; in Three Point mode, the third click 

determines the length of the shoulder
Preferences Opens the Callout Preferences dialog box

Towards Target

Towards Text

Two Point

Three Point

Preferences
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To create a callout or (for Vectorworks Design Series products) a keynote:

1. Click the Callout tool from the Basic palette.
2. Click the Preferences button on the Tool bar. Specify the callout or keynote object preferences, which apply to 

new callouts created either in this file or all files. These parameters can be changed later for a selected callout 
object in the Object Info palette. If a marker type is selected in the Preferences, the marker can be changed later 
from the Attributes palette.

Click to show/hide the parameters.

Parameter Description

Text Options
Get Text from Database
(Vectorworks Design 
Series required)

Database controls are not available in the Vectorworks Fundamentals product. In the 
Vectorworks Design Series products, the Callout tool can be used in conjunction with 
an external notes database; see “Placing Database Callouts” on page 1304 for 
information on using a notes database.

Place As Keynote
(Vectorworks Design 
Series required)

Creates a keynote with keynote legend. Specify the keynote prefix and suffix text, if 
desired. Keynote legends are layer-specific; one legend is created per layer. However, 
a callout placed as a keynote can be associated with a keynote legend on any layer. 
Select the legend for the callout from the Keynote Legend list in the Callout 
Preferences dialog box or the Object Info palette of a selected keynote. The Default 
Legend is the keynote legend located on the current layer.

Rotate Text When selected, rotates the callout text or keynote number to the specified Text Angle
Text Angle Specifies the angle of text rotation; certain angles may not be available, depending on 

the text’s Horizontal Position settings
Max. Text Width Indicates the maximum text width before text wraps; if the text string is shorter than 

maximum width, the bubble sizes to fit the text. Rotated text cannot restrict the 
maximum text width.

Vertical Position Sets the vertical position of the text relative to the shoulder; select Auto to align the 
top text line to the shoulder if the leader is on the left, or to align the bottom text line 
to the shoulder if the leader is on the right

Horizontal Position Sets the horizontal position of the text relative to the shoulder; select Auto to position 
the text to the right if the leader is on the left, or to the left if the leader is on the right

Horizontal Text 
Alignment

Specify how to align callout text.
Horizontal text alignment for existing callouts can also be set by selecting 
Text > Alignment or Text > Format Text and selecting the desired alignment 
option.

Format Text Opens the Format Text dialog box, to set text attributes or select a text style
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3. Click OK to set the callout or keynote preferences.
4. Click the desired insertion modes from the Tool bar, and then click in the drawing to select the insertion point of 

the callout or keynote object.
Depending on the mode, the first click defines the leader shoulder or the leader endpoint.

5. Click again to determine either the leader endpoint or leader shoulder, depending on the mode.

Bubble Options
Bubble Style Select the type of bubble to draw around the callout text or keynote number

RR Corner Radius For Round Rect bubble styles, sets the corner radius
Text Margin Sets the distance between the bubble and the text
Bubble Shadow Select to draw the bubble with a drop shadow (does not apply to None, Bracket, ISO, 

or Vertical Accent Bar styles)
(Bubble) Shadow 
Settings

If Bubble Shadow is selected, opens the Bubble Shadow Settings dialog box, for 
specifying bubble shadow edge and fill attributes; see “Specifying Callout or 
Keynote Legend Bubble Shadow Settings” on page 1297

Leader Options
Shoulder Length Sets the length of the line between the text and the start of the leader; can be changed 

by moving a control point or in the Object Info palette. In Three Point mode, this 
length is set by the third mouse click.

Leader Type Select Line, Arc, Bézier, or None; curved leader lines contain additional control 
points for controlling the curve shape

Leader Radius For arc leader types, specifies the arc radius
Marker Select a marker style from the marker style list, or select Custom to create a custom 

marker. Select Edit Marker List to open the Edit Marker List dialog box; see 
“Editing the Marker List” on page 1103.

Other Options
Apply Settings to New 
Callouts in

Select whether these callout preferences should apply to new callouts or keynotes in 
this file only or globally, to all future files

Parameter Description

None Box Round 
Rect

Cloud Bracket ISO

Vertical Accent Bar Hexagonal Circle
Circle
Split

Leader shoulder

Leader
endpoint

example
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6. If in Three Point mode, click a third time to define the shoulder length.
The Notes Manager: Callout dialog box opens. Enter the callout or keynote legend text; text wraps if longer than 
the specified maximum text width. Press Enter to add a carriage return.
To place callout text both above and below the line in the Split Circle Bubble Style, press Enter between the lines 
of text. 

7. Click OK. 
The callout or keynote is placed in the drawing; if a keynote is placed, a keynote legend object is also created.

Click here for a video tip on this topic (Internet connection required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing a Callout Object
Editing Keynotes and the Keynote Legend
Formatting Text

Editing a Callout Object

Editing Callout Text
To edit the text of an existing callout object:

1. Select the callout object to edit.
2. Either double-click on the callout object with the Selection tool, or click Edit Note from the Object Info palette.

The Notes Manager: Callout dialog box opens.
3. Enter the desired text changes.

To place callout text both above and below the line in the Split Circle Bubble Style, press Enter between the lines 
of text. 

Click 1 defines the 
leader shoulder

Click 2 defines the 
leader endpoint Click 2 defines the 

leader shoulder

Click 1 defines the
leader endpoint

Towards Target mode Towards Text mode

New dishwasher

Callout Keynote and keynote legend 
(Design Series required)

http://www.youtube.com/watch?v=ChNo9iiMXoM
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4. Click OK.
5. Set the text attributes as needed using the Text > Format Text command. You can also assign a text style to the 

callout.

Editing Callout Parameters
To edit the callout properties:

1. Select the callout object.
2. In the Object Info palette, change the parameters as desired. The parameters are described in “Inserting Callouts or 

Keynotes” on page 1293. An additional parameter that is available in the Object Info palette is Leader Length, 
which allows the length of the leader line to be specified precisely with numeric values rather than with the mouse. 
Finally, the marker type can be changed from the Attributes palette.

3. On the drawing, a callout object contains control points which can be moved with the mouse to change the callout 
text width, shoulder length, and endpoint position. A curved callout leader includes additional control points for 
adjusting the leader curvature.

Re-scaling Callout Objects
Callout objects are specified and drawn in page scale; they draw to the same apparent size, regardless of the layer scale. 
If the layer the callout object is on is re-scaled, or the callout object is cut and pasted between layers of different scales, 
the callout object automatically re-scales.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Callouts or Keynotes
The Attributes Palette
Formatting Text
Using Text Styles

Specifying Callout or Keynote Legend Bubble Shadow Settings
To specify bubble shadow edge and fill attributes:

1. In the Callout Preferences dialog box click Shadow Settings, or in the Object Info palette for a selected callout or 
keynote legend, click Bubble Shadow Settings.
To activate this option, Bubble Style must be set to a style other than None, Bracket, ISO, or Vertical Accent Bar, 
and Bubble Shadow must be selected.
The Bubble Shadow Settings dialog box opens. 

Click to show/hide the parameters.

Parameter Description

Draw Bubble shadow 
edge/Draw Bubble 
shadow fill

Draws an edge/fill for the shadow

Use object’s pen color Uses the callout object’s or keynote legend object’s pen color

Adjusts text width

Adjusts endpoint location

Adjusts shoulder length

Adjusts leader length

Adjusts leader curvature

R-19 faced batt insulation 
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2. Specify the desired parameters and click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Callouts or Keynotes

Editing Keynotes and the Keynote Legend
Both the keynotes and keynote legend can be edited after placement. If only one keynote is to be edited, select it and 
make the changes in the Object Info palette. If the text of several keynotes is to be edited, select the keynote legend and 
make the edits from the Object Info palette.

Double-click a callout or keynote legend to edit it.
The keynotes bubble style can also display in the keynote legend; control the style with either the keynotes or the 
legend.

Editing Keynotes
To edit individual keynotes:

1. To change the text of a selected keynote, select the callout and click Edit Note in the Object Info palette.
2. Other callout parameters can be edited in the Object Info palette, like an ordinary callout object. For more 

information on the Callout tool, see “Inserting Callouts or Keynotes” on page 1293.
3. If there are several keynote objects, use the Align/Distribute Leader Lines command to improve readability (see 

“Aligning and Distributing Leader Lines” on page 1035).
4. After placement, a keynote can be converted into an ordinary callout object by deselecting Place As Keynote in 

the Object Info palette. The keynote is removed from the keynote legend.

Deleting Keynotes
If you delete a keynote, the remaining keynotes are not renumbered. The keynote legend maintains a “gap” or 
placeholder displaying the custom text specified in Unused Position Text. However, if Re-use Unused Positions is 
selected and another keynote is placed in the drawing, the new keynote replaces the first “gap” keynote. Clicking 
Remove Gaps in the Object Info palette of a selected keynote legend also removes gaps; another way to remove gaps 
is to sort the keynotes in the Notes Manager: Keynote List dialog box.

Editing the Keynote Legend
To edit the keynote legend:

1. Edit the keynote legend parameters from the Object Info palette.
Click to show/hide the parameters.

Use custom pen color Uses a custom pen color; select the color
Parameter Description
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Parameter Description

Update Refreshes the keynote legend display
Keynote Display Select the display format for keynotes: numbers, letters, numbers or letters with the 

prefix and/or suffix that was entered in the callout preferences, or the description text 
from the notes database (click Sort in the Notes Manager:Keynote List to sort the 
notes as they will appear in the keynote legend) 

Because the note description can display in both the callouts and the keynote 
legend, it is possible to create an alphanumerical designation within the note 
description for each database entry, and display that number on the drawing. A 
database of notes with numeric descriptions can be used directly in the drawing, 
automatically sorted into the proper order.

Overall Width Sets the text width for the entire keynote legend
Note Text Indent Adjusts the hanging indent value for the legend body text
Note Spacing Sets the width of the body of the keynote legend text
Line Spacing Sets the number of lines as space between the notes
# of Columns Select the number of columns for the keynote legend text
Gutter Width When more than one column is selected for keynote legend text, sets the distance 

between the columns
Break Note Text Across 
Columns

When more than one column is selected for keynote legend text, allows text to break 
across columns; when deselected, text for each note does not break to the next column 

Body Text Alignment Specify how to align keynote legend body text.
Horizontal text alignment for existing keynote legends can also be set by selecting 
Text > Alignment or Text > Format Text and selecting the desired alignment 
option.

Bubble Display Sets the bubble display for keynote numbers/letters
• None: No bubble displays for the keynote legend
• per Callout: The bubble style used for the callout also displays in the legend
• per Keynote Legend: The keynote legend controls the bubble style for callouts; 

select the Bubble Style
Bubble Style When the Bubble Display is set to be controlled per Keynote Legend, specifies the 

bubble style to apply to the keynote legend and the keynotes

RR Corner Radius For Round Rect bubble styles, sets the corner radius
Text Margin Sets the distance between the bubble and the text

None Box Round 
Rect

Cloud Bracket ISO

Vertical Accent Bar Hexagonal Circle Split
Circle
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For information on formatting text, see “Formatting Text” on page 389. Text styles cannot be applied to keynote 
legends.

2. The keynote legend contains control points for adjusting the hanging indent and text width directly from the 
drawing.

3. To change keynote numbering or edit the text of all keynotes at the same time, select the keynote legend object 
and click Edit Notes in the Object Info palette.
The Notes Manager:Keynote List dialog box opens. 
If the database controls are showing, click Hide Database Controls.

Click to show/hide the parameters.

Bubble Shadow Select to draw the bubble with a drop shadow (does not apply to None, Bracket, ISO, 
or Vertical Accent Bar styles)

Bubble Shadow Settings If Bubble Shadow is selected, opens the Bubble Shadow Settings dialog box, for 
specifying bubble shadow edge and fill attributes; see “Specifying Callout or Keynote 
Legend Bubble Shadow Settings” on page 1297

Re-use Unused Positions When deselected, maintains a placeholder gap for deleted keynotes; new keynotes are 
appended to the end of the legend.When selected, replaces unused keynote positions, 
in order starting with the first one, as new keynotes are placed in the drawing. 

Unused Position Text Specifies the text to display in unused keynote positions
Remove Gaps Removes unused keynote positions, renumbering the remaining positions
Edit Notes Opens the Notes Manager:Keynote Legend dialog box, for editing the keynote text, 

description, or order
A keynote object can be linked to a database by clicking Show Database Controls in 
the Notes Manager:Keynotes List dialog box.

Format Title Text Opens the Format Text dialog box, for changing the text format of the legend title
Format Body Text Opens the Format Text dialog box, for changing the text format of the legend body text

Parameter Description

Description Lists the keynotes (by description) in the keynote legend in numbering order
Edit Select a keynote description and click Edit to edit the note text or change the keynote 

description

Parameter Description

Keynote legend 
text width control 
point

Body text hanging indent
control point

Overall Width

Line Spacing

Note Spacing

Gutter Width
Text Indent
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4. The keynotes are listed by a description. The description normally consists of the first 42 characters of the 
keynote, but this can be changed by selecting the description and clicking Edit.
The Edit Note dialog box opens. To enter a different note description, deselect Use the first 42 characters, and 
change the Description. The note text can also be edited, if desired.

5. Click OK to close the Edit Note dialog box.
6. Click OK to close the Notes Manager:Keynote Legend dialog box and edit the keynote legend.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Callouts or Keynotes
Notes Management
Notes Management without Databases
Notes Management with Databases

Placing General Notes
Notes management includes a General Notes tool, for placing and numbering general notes.

To place a general notes object:

1. Click the General Notes tool from the Dims/Notes tool set.
2. Click the Preferences button on the Tool bar.

The General Notes Tool Settings dialog box opens. Specify the default settings for placing General Notes during 
this session.

Click to show/hide the parameters.

Move Up/Move Down Changes the order of the keynotes in the keynote legend; move the selected keynote up 
or down in the list

Sort Sorts the notes in the legend alphanumerically; this is useful when the keynote legend 
Keynote Display is set to Note Description from Database, and the Description is set to 
an alphanumeric code (such as C101 or 032000). If there are any unused keynote 
positions, they are removed by this operation.

Note Text Select a keynote description and edit the text of the note
<< Show Database 
Controls

Displays the database-related portion of the dialog box; when working without a 
database, these controls are not necessary (see “Placing Database Callouts” on 
page 1304)

A keynote object can be linked to a database by clicking Show Database Controls 
in the Notes Manager:Keynotes List dialog box. 

Parameter Description

Title Specifies the name for the general notes block, or use the default General Notes title
Indent/Width/Spacing Indicates the default formatting for the notes
General Notes Display Select the display format for general notes: numbers, letters, or the description text from 

the general notes database
Body Text Alignment Specify how to align general notes body text

Parameter Description
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3. Click to place the general notes object in the drawing.
The Notes Manager:General Notes dialog box opens.

Click to show/hide the parameters.

4. To add a new general note, click Add.
The Add Note dialog box opens.

5. Enter the new general note text. The general notes are listed by a description. The description normally consists of 
the first 42 characters of the general note. To enter a different note description, deselect Use the first 42 
characters, and change the Description. 

6. Click OK to add the new general note. 
7. The note text can be edited, if desired. Select the note description and edit the text in the Note Text area. The note 

text and its description can be edited by clicking Edit. Delete selected notes by clicking Remove.
8. Order the general notes by clicking Move Up or Move Down.
9. Click OK to place the general notes object.

Show Databases Deselect to place general notes without a database
Select Title Text/Body 
Text Format

Specifies the default text formatting for the title and note text

Parameter Description

Description Lists the general notes (by description) in numbering order
Add Opens the Add Note dialog box, for adding a general note and specifying its description
Remove Deletes the selected general note(s)
Remove All Deletes all general notes
Edit Select a general note and click Edit to edit the note text or change the general note 

description
Move Up/Move Down Changes the order of the general notes; move the selected general note up or down in the 

list
Note Text Select a general note description and edit the text of the note
<< Show Database 
Controls

Displays the database-related portion of the dialog box; when working without a database, 
these controls are not necessary

A general note object can be linked to a database by clicking Show Database 
Controls in the Notes Manager:General Notes dialog box. See “Notes Management 
with Databases” on page 1304.

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Editing General Notes
Notes Management

Editing General Notes
To edit a general notes object:

1. The general note parameters can be edited from the Object Info palette.
Click to show/hide the parameters.

For information on formatting text, see “Formatting Text” on page 389 and “Using Text Styles” on page 393.
2. The general notes object contains control points for adjusting the hanging indent and text width directly from the 

drawing.

~~~~~~~~~~~~~~~~~~~~~~~~~
Placing General Notes
Notes Management
Aligning and Distributing Leader Lines

Parameter Description

Title Specifies the general notes title
Indent Adjusts the hanging indent value for the general notes body text
Width Sets the width of the general notes text
Spacing Sets the spacing between each note
General Notes Display Select the display format for general notes: numbers, letters, or the description text from 

the general notes database
Body Text Alignment Specify how to align general notes body text.

Horizontal text alignment for existing general notes can also be set by selecting 
Text > Alignment or Text > Format Text and selecting the desired alignment 
option.

Edit Notes Opens the Notes Manager:General Notes dialog box, for editing the general notes text, 
description or order

A general note object can be linked to a database by clicking Show Database 
Controls in the Notes Manager:General Notes dialog box. See “Notes Management 
with Databases” on page 1304.

Format Title Text Opens the Format Text dialog box, for changing the text format of the general notes title
Format Body Text Opens the Format Text dialog box, for changing the text format of the general notes body 

text

General notes 
text width control 
point

Body text hanging indent 
control point
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Notes Management with Databases
Instead of manually typing the text for every callout or keynote and general notes object, text that is used repeatedly—
by one or many users—across projects and files can be stored in a tab-delimited text file (referred to as a “database”). 
The use of a database for storing notes saves time and prevents errors, and standardizes compliant notes usage across 
files.
There is no limit to the number of databases that can be used for annotating a drawing. The databases can have an 
unlimited number of notes of any length. After placement, notes can be easily updated if changes are made to a 
database. 
~~~~~~~~~~~~~~~~~~~~~~~~~
Placing Database Callouts
Editing a Database Callout
Placing Database Keynote Legends
Placing Database General Notes
Adding Text to a Database
Reconciling Database and Drawing Notes
Locating Databases on a Network
Notes Management

Placing Database Callouts
Callouts with database notes are placed with the extended capabilities of the Callout tool.

To place a database callout:

1. Click the Callout tool from the Basic palette.
2. Click the Preferences button on the Tool bar.

The Callout Preferences dialog box opens. For more information on the Callout tool, see “Inserting Callouts or 
Keynotes” on page 1293.

3. Select Get Text from Database; the current database file is displayed as a button.
4. To select a different database, click the database button.

The standard Open dialog box allows a different database file to be selected. Select the database file, and click 
Open.
A sample database is located in [Vectorworks]\Libraries\Defaults\Notes\Callouts.txt 

5. Click OK.
6. Click in the drawing to place the callout object. 

Once the callout leader is drawn, the Notes Manager:Callout dialog box opens automatically, displaying the 
information from the selected database.
The notes in a selected section are listed by a description. The description normally consists of the first 42 
characters of the note.

Click to show/hide the parameters.

Parameter Description

Active Database Displays the currently selected database file
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7. To add a note to a selected section, click Add under Notes in Database.
The Add Note dialog box opens. Specify the section, description, and note text.

Click to show/hide the parameters.

New Creates a new, blank database
Choose Selects a different, existing database. A database from a previous version of the 

Vectorworks program can be specified, but it must be converted to the current version 
format as prompted.

Save As Saves the current database with a new name
Sections in Database Lists the note sections; the associated notes in a selected section are displayed in Notes in 

Database
Add Adds a new note section; enter the section name in the Enter String dialog box
Remove Deletes the currently selected section and its associated notes
Edit Renames the currently selected section; enter the new name in the Enter String dialog box

Notes in Database Lists the notes associated with the current database section
Add Opens the Add Note dialog box, for adding a note to the database section
Remove Deletes the currently selected note
Edit Opens the Edit Note dialog box, for editing the selected note or its description

Note Text Displays the note text of the currently selected note; the note text can be edited
Database Filter Filters the database sections, descriptions, or notes with a search term, to more easily 

locate a note
Edit Opens the Edit Filter List dialog box, to add or edit database filters
Prefs Sets the automatic save options for the database
Update > Moves the selected note to the Callout Text list for placement on the drawing
< Update Replaces the database with the text in the Callout Text list
< Add Adds the text in the Callout Text list to the database, placing it in the current database 

section
< Locate If the selected text in the Callout Text list originated from a database, locates the note’s 

database, section, and description 
Connect to Database 
with:

Sets how to connect to the selected database; if an absolute path is selected, the database is 
expected to be present at the specific location. If a relative path is selected, the database is 
expected to be present at the indicated location relative to the current file.

Hide Database 
Controls >>

Hides the database portion of the callout dialog box; edits made with the database hidden 
are not reflected in the database

Parameter Description

Section Select the associated section for the note
Description By default, consists of the first 42 characters of the note text; deselect Use the first 42 

characters, and enter a different note description, if desired

Parameter Description
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8. Click OK to add the note to the specified section and return to the Notes Manager:Callout dialog box.
9. Change the note description by selecting the description and clicking Edit.

The Edit Note dialog box opens. To enter a different note description, deselect Use the first 42 characters, and 
change the Description. The note text can also be edited, if desired, and the note can be associated with a different 
section.

10. Click OK to edit the note description and return to the Notes Manager:Callout dialog box.
11. The text of a selected note can be edited in Note Text.
12. To search easily for a note, section, or description, use a filter. Only notes, sections, or descriptions with the 

specified text are displayed. Select the desired filter from the Database Filter list in the Notes Manager:Callout 
dialog box. To display all notes, sections, and descriptions, select All Notes. In addition, if no items match a 
selected filter, all notes are displayed.

13. To edit the database search filters, click Edit under Database Filter.
The Edit Filter List dialog box opens. The filters are listed in order.

Click to show/hide the parameters.

14. Click OK to change the search filters and return to the Notes Manager:Callout dialog box.
15. Changes and additions to the notes database are saved automatically according to the preferences specified. Click 

Prefs to set these preferences.
The Database Preferences dialog box opens. Set the desired actions that automatically save database changes by 
selecting the associated check box(es). If no automatic saving is specified, you will be prompted frequently about 
saving the database.
The Locate and Hide Database options are available when editing a General Notes or Keynote Legend with 
database.

16. Click OK to return to the Notes Manager:Callout dialog box.
17. Once the desired note has been entered or located, select it and click Update to move it to the Callout Text list.
18. Click OK. The selected note is used for the callout text.

Note Text Type the new note text
Use the first 42 characters If the default description is not desired, deselect and enter a new Description

Parameter Description

Filter list Lists the search filters in the order they display in the database filter list
Add Adds a search filter to the list; enter the new term in the Enter String dialog box
Remove Deletes the currently selected search filter(s)
Edit Renames the current search filter; enter the new name in the Enter String dialog box
Move Up/Move Down Changes the filter list order; select the search filter and move it up or down in the list

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Editing a Database Callout
Notes Management with Databases
Notes Management

Editing a Database Callout
The database callout can be edited after placement.
To edit a database callout:

1. To change the note text, select the callout and click Edit Note in the Object Info palette.
2. The Notes Manager:Callout dialog box opens. Select a different note as described in “Placing Database Callouts” 

on page 1304, and click OK.
3. Other callout parameters can be edited in the Object Info palette as for an ordinary callout object. For more 

information on the Callout tool, see “Inserting Callouts or Keynotes” on page 1293.
4. If there are several callout objects, use the Align/Distribute Leader Lines command to improve readability (see 

“Aligning and Distributing Leader Lines” on page 1035).
5. After placement, a database callout can be converted into an ordinary callout object by clicking Edit Note in the 

Object Info palette, and then clicking Hide Database Controls. The callout text can then be edited, and the 
database text is not affected.

~~~~~~~~~~~~~~~~~~~~~~~~~
Placing Database Callouts
Notes Management with Databases
Notes Management

Placing Database Keynote Legends
Keynote legends can take advantage of a notes database.

To place a database keynote legend:

1. Click the Callout tool from the Basic palette.
2. Click the Preferences button on the Tool bar.

The Callout Preferences dialog box opens. As described in “Inserting Callouts or Keynotes” on page 1293, select 
Place As Keynote and click OK.

3. Place the callouts in the drawing area.
4. Select the keynote legend. In the Object Info palette, click Edit Notes.
5. The Notes Manager:Keynote List dialog box opens.
6. If necessary, click Show Database Controls to access the keynote legend database parameters.

The dialog box is divided into two sections, with the database information on the left and the keynote legend 
information on the right. The buttons in the center of the dialog box move information from the database to the 
legend and vice-versa.

Click to show/hide the parameters.
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7. Click OK to change the keynote legend, replacing the notes with database notes.
~~~~~~~~~~~~~~~~~~~~~~~~~
Notes Management with Databases
Editing Keynotes and the Keynote Legend
Notes Management

Placing Database General Notes
General notes can take advantage of a notes database.

To place a database general notes object: 

1. Click the General Notes tool from the Dims/Notes tool set.
2. Click to place the general notes object in the drawing.

The Notes Manager:General Notes dialog box opens.
3. Click Show Database Controls to access the general notes database parameters.

The dialog box is divided into two sections, with the database information on the left and the general notes 
information on the right. The buttons in the center of the dialog box move information from the database to the 
general notes and vice-versa.
A sample database is located in [Vectorworks]\Libraries\Defaults\Notes\GeneralNotes.txt 

Click to show/hide the parameters.

Parameter Description

Active Database, Sections in 
Database, Notes in Database, 
Note Text, Database Filter, and 
Prefs

Edits the database sections, notes, note text, search filters, and saving preferences 
as described in “Placing Database Callouts” on page 1304

Notes in the Selected Keynote 
List Object

Edits the keynote legend notes and description as described in “Inserting Callouts 
or Keynotes” on page 1293; the Relative Path column indicates whether the 
associated database is referenced by a relative path (check mark) or absolute path 
(no check mark)

Update > Overwrites the selected keynote legend note(s) with the selected database note
< Update Overwrites the selected database note with the selected keynote legend note
< Add Adds the selected keynote legend note(s) to the database, placing the note(s) in 

the current database section
Auto-Locate Automatically locates the database, section, and description of a selected keynote 

legend note, if the note originated from a database
< Locate If the selected keynote legend note originated from a database, locates the note’s 

database, section, and description 
Hide Database Controls >> Hides the database portion of the keynote legend dialog box; edits made with the 

database hidden are not reflected in the database
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4. The note in the Notes in the Selected General Notes Object list will be placed as a general note. Click OK to 
place the general note.

~~~~~~~~~~~~~~~~~~~~~~~~~
Adding Text to a Database
Notes Management with Databases
Placing General Notes
Editing General Notes
Notes Management

Adding Text to a Database
Text objects can be added from the drawing to a selected database. This is convenient for retrieving text from older, 
converted files for use with the Notes Manager or when adding frequently-used text to a database for easy future 
insertion as an annotation.
To add drawing text to a database:

1. Select Text > Add Text to Database.
The Add Text to Database dialog box opens. Specify which text objects to select and indicate in which databases 
to search for duplicated text.

Click to show/hide the parameters.

Parameter Description

Active Database, Sections in 
Database, Notes in Database, Note 
Text, Database Filter, and Prefs

Edits the database sections, notes, note text, search filters, and saving 
preferences as described in “Placing Database Callouts” on page 1304

Notes in the Selected General 
Notes Object

Edits the general notes and description as described in “Placing General 
Notes” on page 1301; the Relative Path column indicates whether the 
associated database is referenced by a relative path (check mark) or absolute 
path (no check mark)

Add > Adds one or more selected database notes to the general notes
Update > Overwrites the selected general note(s) with the selected database note
< Update Overwrites the selected database note with the selected general note
< Add Adds the selected general note(s) to the database, placing the note(s) in the 

current database section
Auto-Locate Automatically locates the database, section, and description of a selected 

general note, if the note originated from a database
< Locate If the selected general note originated from a database, locates the note’s 

database, section, and description 
Hide Database Controls >> Hides the database portion of the general notes dialog box; edits made with 

the database hidden are not reflected in the database

Parameter Description

Add Text Meeting These 
Criteria

Specifies the criteria for selecting text objects to be added to a database
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2. Click OK. If any of the text was not found in the text search database(s), the Notes Manager:Add Text to Database 
dialog box opens.

3. The text to be added is listed on the right. As described in “Placing Database Keynote Legends” on page 1307, the 
text can be added to the active database in the desired section. Click OK.

~~~~~~~~~~~~~~~~~~~~~~~~~
Placing Database General Notes
Reconciling Database and Drawing Notes
Notes Management with Databases
Notes Management

Selected Text Only Adds only selected text to the database; when deselected, adds text from all text 
objects in the file

Layers/Classes Adds only text from the specified layers and/or classes to the database; when 
deselected, adds text from text objects in all layers or classes in the file

Exclude Text Already in One 
of These Databases

Lists the databases in which to search for duplicated text; the text search is case 
sensitive and the match must be exact. If duplicated text is found, it is not 
added to the database.

Add Adds a database to the text search database list
Change Allows changes to a selected database’s location
Remove Removes a database from the text search database list

Parameter Description
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Reconciling Database and Drawing Notes
The Reconcile Notes command handles differences between the database and the notes in the drawing. For example, if 
database callouts have been placed and the database is edited afterwards, differences must be reconciled.
To reconcile notes:

1. Select Text > Reconcile Notes.
The Reconcile Notes dialog box opens. Select the note objects to reconcile.

Click to show/hide the parameters.

2. Click OK to reconcile the notes. If any of the notes reference databases, the Notes Manager attempts to locate 
those databases. It searches first in the same folder as the current file; if not found, it searches in the same place 
relative to the Vectorworks program executable. If the databases still cannot be found, the Notes Manager tries to 
locate them with fully-qualified paths.
Place database files from another user in the same folder as the drawing file so that the Notes Manager can easily 
locate the databases.

3. If a database referenced by notes cannot be located, the Cannot Locate Database(s) dialog box opens. For each 
database that cannot be located, click Browse to specify the database location.

4. Click OK. Next, the Notes Manager searches the database(s) for the notes.
5. If one or more notes cannot be located in the database, an alert dialog box opens asking if you want Notes 

Manager to search for these notes in a database search list.
If there are no additional database files to be specified, click No and proceed to step 8. If the notes could be 
located in another database, click Yes to specify the database location.

6. The Specify Database Search List dialog box opens. Click Add to specify additional databases where the notes are 
located. Click Remove to delete a selected database from the list. The number of notes which have been located is 
displayed.

7. Click OK.
8. If some notes have still not been located, the Notes Manager:Reconcile Notes dialog box opens.

The dialog box is divided into two sections, with the database information on the left and the notes to be 
reconciled on the right. The buttons in the center of the dialog box move information from the database to the 
general notes and vice-versa.
By using the center buttons, reconcile each note manually. As a note is reconciled, it is removed from the list.

Parameter Description

Callouts obtained from database Selects database callouts
Callouts not obtained from database Selects ordinary callouts and keynote callouts that are not 

linked to a database
Callouts that used to get their text from a 
database

Selects callouts that were once database callouts and obtained 
note text from a database

Callouts that never got their text from a 
database

Selects callouts that did not obtain note text from a database

General Notes objects Selects general notes
Layers / Classes Select the layers and classes with notes to include for 

reconciliation
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Click to show/hide the parameters.

9. Click OK. 
An alert message explains how the notes were reconciled.

~~~~~~~~~~~~~~~~~~~~~~~~~
Notes Management with Databases
Notes Management

Parameter Description

Active Database, Sections in 
Database, Notes in Database, Note 
Text, Database Filter, and Prefs

Edits the database sections, notes, note text, search filters, and saving 
preferences as described in “Placing Database Callouts” on page 1304

Notes That Need To Be 
Reconciled

Displays the note text, type of note, database name and location, layer and class 
name, and database reference type (relative or absolute) for the notes that have 
not been reconciled

Update > Overwrites the selected note(s) to be reconciled with the selected database note
< Update Overwrites the selected database note with the selected note to be reconciled
< Add Adds the selected note(s) to be reconciled to the database, placing the note(s) in 

the current database section
Auto-Locate Automatically tries to locate the database, section, and description of a selected 

note to be reconciled, if the note originated from a database
< Locate If the selected note to be reconciled originated from a database, tries to locate 

the note’s database, section, and description 
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Locating Databases on a Network
To use databases efficiently in a multiple-user environment, the database files should be placed on a network. There, 
they can be accessed concurrently by several users who will then conform to office standards and will not need to 
retype notes.

Windows users should choose databases by browsing from Network Neighborhood (My Network Places) rather 
than from mapped drive letters. If databases are selected from mapped drives, the database references are then 
dependent on drive mapping.

Database changes made by different users are merged automatically.
A conflict could arise if two different users edit the same note in the same database at the same time. If this occurs, the 
Resolve Note Conflict dialog box opens when closing the Notes Manager dialog box.

On the left, your version of the note displays, and on the right, the other user’s version displays. Select which version of 
the note to save by selecting Mine is better or The other note is better. Click OK to resolve the conflict.
~~~~~~~~~~~~~~~~~~~~~~~~~
Notes Management with Databases
Notes Management

Converting Notes from Previous Versions
Databases and notes created in Vectorworks software versions prior to version 11 can be converted for use in the 
current version.
Databases created in previous versions of the Notes Manager are automatically converted to the current version when 
they are selected by clicking Choose to select a database.
Callouts created in version 9 and above are automatically converted to the current format. They can be used as ordinary 
callouts, keynotes, or database callouts.
Other notes objects, such as Text Notes, Keynotes, and General Notes created by previous Notes Manager versions, as 
well as Vectorworks text objects, must be converted by command. Vectorworks text objects are converted to general 
notes.
To convert old objects to the current format:

1. Select Text > Convert Old Notes to New.
2. The Convert Old Notes to New dialog box opens. Select the type of old notes to convert.

Click to show/hide the parameters.
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3. Click OK to convert the objects to the current version Notes Manager format.
4. The Conversion Results dialog box displays a summary of the objects converted.

~~~~~~~~~~~~~~~~~~~~~~~~~
Notes Management with Databases
Notes Management

Parameter Description

All updatable objects Converts any note-related items in the drawing
All selected objects Converts any note-related items in the current selection 
Just the following 
objects

Select the type of objects to be converted (Text Notes, Keynotes, General Notes 
from version 8.52 to 10, and text objects)

Layers/Classes Specifies the layers and classes to be searched for objects to convert



Worksheets
The worksheet functionality in the Vectorworks program complements its drawing functionality, making it a complete 
package for your work process. From the information present in the file, you can create worksheets to track data, create 
cost and material lists, perform calculations, and more. Worksheets are integrated within the Vectorworks file, which 
eliminates the need for a separate program and reduces the number of files per project.
Worksheets include both database and spreadsheet functionality. Data can be obtained from the drawing, and then 
calculations can be performed on that data.
Worksheets can be imported and exported, which allows data to be shared between worksheets, files, and other 
spreadsheet programs. A worksheet can also be added to a drawing and printed.
To get a quick overview of worksheet features, see “Worksheet Tutorial: Creating a Wall Schedule” on page 1361.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Worksheets
Creating Schedules Automatically
Using Worksheets
Selecting and Editing Worksheet Cells
Worksheet Commands
Database Row Sort and Summary Functions
Formatting Worksheet Cells
Entering Data in Spreadsheet Cells
Entering Data in Database Rows
Inserting Images in Worksheets
Worksheet Functions
Importing Worksheets
Exporting Worksheets
Worksheets as Graphic Objects
Worksheet Tutorial: Creating a Wall Schedule

Creating Worksheets
For complex drawings, it is best to create separate worksheets for each task rather than one large worksheet. 
Worksheets can be linked to share data, formulas, and calculations.
Worksheets can be created in several ways:

• Use the Create Report command to select worksheet data from the information associated with the objects in the 
drawing. See “Creating Reports” on page 1316.

• Use the Resource Browser to create a blank worksheet, and then add the desired information to it. See “Creating a 
Blank Worksheet” on page 1317.

• Import worksheets from other Vectorworks files or from other spreadsheet programs. See “Importing Worksheets” 
on page 1358.

• If Vectorworks Design Series is installed, preformatted records and schedules such as room finishes, plant lists, 
and lighting instruments can be added to the drawing. See “Creating Schedules” on page 1864 and “Creating 
Schedules Automatically” on page 1318.

Once created, a worksheet is saved with the file and is listed in the Resource Browser. It can also be accessed by 
selecting Window > Worksheets.
If the same objects are typically used in your drawings, you can create a template file with a worksheet that serves as a 
“master price list” listing all the objects and their costs. Then, to create materials lists and cost estimates for a new 
design, simply import the worksheet into the new drawing file.
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Creating Reports
The Create Report command allows you to select data that is attached to objects in a drawing (such as manufacturer, 
size, and price) and create a worksheet from it. The command can either create a new worksheet or append database 
rows to an existing worksheet. For more information about how to attach data to objects, see “Record Formats” on 
page 262.
To create a report from objects in a drawing:

1. Select the Create Report command from the appropriate menu:
• Fundamentals, Architect, Landmark workspaces: Tools > Reports > Create Report
• Spotlight workspace: Spotlight > Reports > Create Report
The Create Report dialog box opens. Specify the report criteria. Items in the Worksheet Columns list are listed in 
the order in which they will appear in the worksheet; to change the order, click in the # column and drag the item 
to the desired position in the list.

Click to show/hide the parameters.

2. Click Options to specify additional report criteria.
The Create Report Options dialog box opens.

Click to show/hide the parameters.

Parameter Description

Title Enter a worksheet title; if the report data is appended to an existing worksheet, this title is 
added to a spreadsheet cell above the database rows that are appended

List all Select whether to list all symbols in the drawing, or to list all drawing objects that have a 
specific record attached to them

Listing objects with 
record

If you selected the option to list all objects with a specific record, select the record format to 
use

Possible Columns Lists the columns that can be selected for inclusion in the worksheet
Worksheet Columns Lists the columns that are currently selected for inclusion in the worksheet
Add >> / Add All >> To add a column to the worksheet, select it in the Possible Columns list and click Add; click 

Add All to move all the columns to the Worksheet Columns list
<< Remove /
<< Remove All

To remove an item from the worksheet, select it in the Worksheet Columns list and click 
Remove; click Remove All to move all the columns to the Possible Columns list

Summarize items 
with the same

Select the checkbox to summarize symbols or objects that contain the same value for a 
specified field, rather than creating a new database sub-row for each; then select the field to 
summarize from the drop-down list

Options Opens the Create Report Options dialog box

Parameter Description

New worksheet Select to create a new worksheet
Append to existing 
worksheet

Select to append the information to a worksheet, and then select the target worksheet

Search in symbols Select to search inside symbol instances for embedded objects or symbols and include 
this information in the worksheet
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3. Specify the options for creating the report, and click OK to return to the Create Report dialog box.
4. Click OK to create the worksheet.

The worksheet opens automatically. The top row of the worksheet contains a title for each column selected. Next 
is a database header row (indicated by a diamond next to the row number) that contains sub-row totals for each 
column. Beneath the header row are sub-rows for each object or symbol in the drawing that matches the report 
criteria.

 

5. To add more data to the worksheet, repeat steps 1 through 4 and select the Append to existing worksheet option.
6. Once all the data is added, edit the worksheet as needed. For example, add rows or columns, change the text 

format, or add color. To hide the database header rows, toggle the Database Headers setting on the Worksheet 
menu.
Click here for a video tip on this topic (Internet connection required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Blank Worksheet
Using Worksheets
Importing Worksheets

Creating a Blank Worksheet
Instead of using the Create Report command, you can create a blank worksheet and add data to it manually. This gives 
you more control over the contents and format of the worksheet.
To create a blank worksheet:

1. Select Window > Palettes > Resource Browser.
2. Select Resources > New Resource to display the list of new resource types.
3. Select Worksheet.

The Create Worksheet dialog box opens.
Click to show/hide the parameters.

Search in plug-in objects Select to search inside plug-in object instances for embedded objects or symbols and 
include this information in the worksheet

Parameter Description

http://www.youtube.com/watch?v=SdavZ2UW8FU
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4. Specify the basic worksheet parameters and click OK.
A new worksheet window opens.

5. At this point, all rows contain spreadsheet cells, and they are all undefined. Define the contents of each row and 
cell as needed:
• To add simple text, numbers, or formulas to the worksheet, see “Entering Data in Spreadsheet Cells” on 

page 1333.
• To list data that is associated with objects in the drawing, change a spreadsheet row into a database row, and 

specify which objects to include in the list. A sub-row displays for each object that matches the criteria defined 
in the database header row. Then specify which information to display in the columns for each row; these can 
be fields from the object’s data record, as well as text, numbers, or formulas. See “Entering Data in Database 
Rows” on page 1339.

• To add images to either spreadsheet or database rows, see “Inserting Images in Worksheets” on page 1343 
(Vectorworks Design Series required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Reports
Using Worksheets

Creating Schedules Automatically
The Vectorworks Landmark and Spotlight products include a Choose Schedule command with preformatted schedules 
that are generated automatically. The Vectorworks Architect product includes preformatted, customizable records and 
schedules as described in “Records and Schedules” on page 1859. The schedules can be created any time; as objects are 
added to the drawing, recalculate the worksheet to update the results.
The preformatted schedules are from the default content included with the Vectorworks Design Series products in the 
[Vectorworks]\ Libraries\Defaults\Reports~Schedules folder (see “Resource Libraries” on page 219).
The default schedules for Vectorworks Landmark include plant lists, irrigation plans, and existing tree reports, with or 
without images. Plants to be included in the Plant List worksheets must have On Plant List selected in the Plant 
Settings dialog box or the Object Info palette.
A formatted worksheet can be saved as a custom schedule to be used again; export the worksheet resource (renamed 
with a custom name) to a file in the Reports~Schedules folder in your user folder. Your customized worksheet becomes 
available for selection in the Choose Schedule dialog box. For information about exporting resources, see “Exporting 
Custom Resources” on page 234.

Another way to create a schedule is to select the Create Report command. List the objects with the relevant 
record, such as the Existing Tree record, and then select the desired columns to include in the report. See “Creating 
Reports” on page 1316 for more information.

To add a schedule:
1. Select a command from the appropriate menu:

• Landmark workspace: Tools > Reports > Choose Schedule

Parameter Description

Name Enter a worksheet name. To rename the worksheet later on, select the worksheet in the 
Resource Browser, and click Resources > Rename.

Rows / Columns Enter the number of rows and columns for the worksheet; the number of rows and columns can 
be modified later
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• Spotlight workspace: Spotlight > Reports > Choose Schedule
• Architect workspace: Tools > Reports > VA Create Schedule
The Choose Schedule dialog box (for Landmark and Spotlight) or Create Schedule dialog box (for Architect) 
opens. Select one of the worksheets to create; select Place worksheet on drawing to add the worksheet to the 
drawing area.

2. Click OK to create the selected worksheet.
If the selected schedule already exists in the file, a warning dialog box opens. Select whether to replace or rename 
the new schedule (some schedules also have a recalculate option), and click OK.

3. If the worksheet is to be placed on the drawing, click to indicate the position of the top left corner of the 
worksheet.
The worksheet, populated with specific information from the current drawing, is automatically created.

~~~~~~~~~~~~~~~~~~~~~~~~~
Worksheets
Resource Libraries
Adding Plants to the Design
Placing Existing Trees
Irrigation
Records and Schedules

Using Worksheets
Worksheets can obtain data from the drawing based on specified criteria, and then list the data and allow calculations to 
be performed on the data.

Worksheets can have two types of rows: spreadsheet and database. The cells in a spreadsheet row contain constants 
(text or numbers), or formulas. Database rows consist of a header row and sub-rows, and they show data that are 
associated with specific drawing objects. The database header row is marked with a diamond shape next to the row 
number. Set selection criteria for this row, and a sub-row is created for each object that meets the criteria. In this 
example, the database header row 2 is set to list each object in the drawing that has an “appliance record” attached to it. 
The sub-rows 2.1 through 2.5 represent the five objects in the drawing that meet this criteria.
Rows are numbered sequentially starting with 1, and columns are labeled alphabetically starting with A. Database 
sub-rows are numbered with the database header row’s number, followed by a decimal and sequential numbers (header 
row 2 has sub-rows 2.1, 2.2, 2.3, and so on). The cell’s column letter and row number indicate the spreadsheet cell 
address, as in A4 or D2 (database sub-rows display a blank address).

Current cell address

Spreadsheet row

Database header row

Formula bar

Worksheet name

Database sub-rows

Increase the 
column width to 
view this number

Current zoom level

Worksheet menu
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When worksheets exist in an open file, the Window > Worksheets command becomes available. All the worksheets 
present in the indicated file are listed. Worksheets with a check mark are currently open. To open a worksheet, select it 
from this menu, or select the worksheet from the Resource Browser and then select Resources > Open.

A worksheet opens in a separate window, which can be resized, moved, and closed. The worksheet window contains its 
own menu and context menus.
Because an open worksheet is in a separate window, it is not printed with the drawing. To include a worksheet as part of 
a drawing, select the worksheet in the Resource Browser and click Resources > Worksheet on Drawing. When the 
worksheet is open, the worksheet on the drawing displays as an “X.” When the worksheet is closed, the updated 
worksheet displays on the drawing. Double-click the worksheet from the drawing to open it. See “Worksheets as 
Graphic Objects” on page 1360.
Use the Format Cells command to format individual rows, columns, and even cells of the worksheet as needed. The 
format is retained when the worksheet is included on the drawing. Alternatively, with the worksheet window closed, 
select the worksheet object on the drawing, and use the Attributes palette to modify the fill, pen, and line thickness 
attributes for the entire object.

~~~~~~~~~~~~~~~~~~~~~~~~~
Selecting and Editing Worksheet Cells
Worksheet Commands
Formatting Worksheet Cells

Selecting a worksheet from the Window menu Selecting a worksheet from the Resources menu
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Selecting and Editing Worksheet Cells
The contents of cells can be edited, and the rows and columns can be resized, moved, cut, copied, and pasted.

Moving Around in Worksheets
The following table describes the keys used to move around in the worksheet.

If more than one cell is selected, movement is restricted to the selected cells only.

Selecting Cells
Selected cells are surrounded with a black outline. When multiple cells are selected, the active cell is white, and the 
remaining selected cells are highlighted in blue.

Editing Cell Contents
When a cell is selected, the display of the Formula bar indicates whether the contents of the cell can be edited.

Keys Description

Arrow (Up, Down, Right, Left) Moves by one cell in the direction indicated
Tab Moves right by one cell
Enter Moves down by one cell
Shift+Tab Moves left by one cell
Shift+Enter Moves up by one cell

Selection Action

A single cell Click on the cell
A range of cells Click-drag across a range of cells to select them, or click in one corner and 

Shift-click in the opposite corner
An entire column or row Click the column letter or row number; to select multiple rows or columns, 

click-drag across the column letters or row numbers, or click the first column letter 
or row number, and then Shift-click the last column letter or row number in the 
desired range

Non-contiguous cells, rows, 
or columns

Press and hold the Ctrl (Windows) or Command (Mac) key and then click on each 
cell, row, or column to select

The entire worksheet Click the empty box directly above the row number boxes

Formula Bar Display Explanation

The cell address displays, and the red 
X and green check mark are active

The cell is in a spreadsheet row or database header row. Type directly in the 
Formula bar to enter text, numbers, or a formula. To accept the edits and 
change the cell contents, click the green check mark. To cancel the edits, 
click the red X.

No cell address displays; the current 
cell value is not editable

In database sub-rows, the results of calculations cannot be edited. In 
addition, object attribute information, such as the class the object belongs 
to, cannot be edited in the worksheet.
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Resizing Rows and Columns
To adjust column width or row height, drag the divider bar between the column letters or row numbers. If you select 
multiple rows or columns before you drag the bar, all rows or columns are adjusted to the same size.

Alternatively, select the Column Width command from either the Format menu or the column context menu (see 
“Column Width” on page 1326). Adjust the row height with the Row Height command from either the Format 
menu or the row context menu (see “Row Height” on page 1326).

Text that is longer than the width of a cell “floats” over empty adjacent cells. Numbers that exceed the cell width are 
displayed with # characters. Alternatively, text can be set to wrap (see “Formatting Worksheet Cells” on page 1330).

To hide a row or column, set the Column Width or Row Height to 0. To display the column or row again, position the 
cursor over the column letter or row number adjacent to the hidden column or row. When the cursor changes to a 
double bar resize cursor, click-drag the bar to resize the column or row.

No cell address displays; the current 
cell value is editable
(Vectorworks Design Series required)

In database sub-rows, if Vectorworks Design Series products are installed, 
information that comes from the object’s data record can be edited in the 
Formula bar, and the object’s record is updated automatically. For example, 
the price data for a sub-row object could be updated.
To accept the edits and change both the worksheet and record, click the 
green check mark.

No cell address displays; a list of the 
values that are available for the 
current cell displays
(Vectorworks Design Series required)

In database sub-rows, if Vectorworks Design Series products are installed, 
some fields that come from the object’s data record can be edited, but they 
only allow certain pre-defined values. For example, the sill style for a 
window sub-row object could be changed in the Formula bar.
Select the new value from the list to change both the worksheet and record.

Neither a cell address nor a cell value 
displays

In database sub-rows, if the Vectorworks Architect or Vectorworks 
Landmark product is not installed, information that comes from the object’s 
data record cannot be edited in the worksheet. To edit a value that displays 
in a sub-row, right-click (Windows) or Ctrl-click (Mac) the number of the 
row that is associated with the item in the drawing, and select the Select 
Item command from the context menu. Then use the Data tab of the Object 
Info palette to edit the object data as needed.

Formula Bar Display Explanation
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Cutting, Copying, and Pasting Cell Contents
The standard shortcut keys for Cut and Paste can be used for worksheet editing. The same value or formula can be 
copied and pasted to a range of cells.
To copy cell contents to a cell or range of cells:

1. Select the cell with the information to repeat, and then press Ctrl+C (Windows) or Command+C (Mac) to copy the 
cell.
Alternatively, select the Copy command from either the Edit menu or the appropriate context menu (see “Copy” 
on page 1325).

2. Select the destination cell(s) for the information, and then press Ctrl+V (Windows) or Command+V (Mac) to 
paste. The formula or value is repeated in each of the selected cells.
Alternatively, select the Paste command from either the Edit menu or the appropriate context menu (see “Paste” 
on page 1325).

Adding Rows and Columns
From the Insert menu, you can insert rows and columns (see “Worksheet Commands” on page 1324). An empty row is 
added above the current row, or an empty column is added to the left of the current column. Another option is to 
position the cursor at the bottom right corner of the worksheet to activate a special resize cursor; drag as needed to add 
rows and columns to the bottom and right side of the worksheet.

Moving Rows and Columns
Use the drag and drop method to move contiguous rows and columns or to move a copy of contiguous rows and 
columns.
To move a copy of rows or columns:

1. Click the column letter or row number to select a column or row (click-drag across the letters or numbers to select 
multiple columns or rows).

2. Press and hold Ctrl (Windows) or Option (Mac) and move the cursor to the edge of the selected rows or columns. 
When the cursor changes to a copy cursor to indicate that moving a copy is permitted, drag the selection to the 
desired location in the worksheet.

To move rows or columns:
1. Click the column letter or row number to select a column or row (click-drag across the letters or numbers to select 

multiple columns or rows).

Position the cursor over the bottom right corner of the worksheet to 
obtain the resize cursor; drag to add columns and/or rows
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2. Move the cursor to the edge of the selected rows or columns. When the cursor changes to a move cursor to 
indicate that moving the rows or columns is permitted, drag the selection to the desired location in the worksheet.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Record Information with Worksheets

Worksheet Commands
Various command menus are available in the worksheet window, as well as sorting functions. The main worksheet 
menu is at the top of the window. Right-click (Windows) or Ctrl-click (Mac) on a specific worksheet row or cell to 
open a context menu. To sort the sub-rows associated with a database header row, click and drag a sort icon to the 
column header cell.

~~~~~~~~~~~~~~~~~~~~~~~~~
Worksheet Menu
Worksheet Cell Context Menu
Worksheet Row Context Menu
Worksheet Column Context Menu

Worksheet Menu
The main Worksheet menu commands are described in the following table.

Worksheet Command Description

File menu
Recalculate Recalculates all formulas in all worksheets, whether open or closed. This function can also 

be accessed from the context menu of the worksheet image (on the drawing): right-click 
(Windows) or Ctrl-click (Mac) on the worksheet, and select Recalculate.

Ascending sort icon

Descending sort icon

Summarize iconAccept entryCancelCurrent cell

Worksheet menu

Row context menu Cell context menu

Formula bar

Current zoom level

Column context menu
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Preferences Opens the Worksheet Preferences dialog box. Header and Footer text fields and the 
Margin settings apply to printed worksheets only. Select Show Grid to display the 
worksheet gridlines. Select Show Tabs to print worksheet column and row headers. Select 
Auto-recalc to recalculate all worksheet arithmetic functions when cells are edited. Click 
Font to specify the worksheet default font and size.

Printer Setup Opens the Printer Setup dialog box. This is the same as the standard Printer Setup dialog 
box; however, it only affects the printer information for the worksheet.

Print Opens the Print dialog box, to print the current worksheet; this is the only way to print a 
worksheet unless the worksheet is included as a part of the drawing

Edit menu
Undo Undoes the last worksheet change; execute the command multiple times to undo multiple 

actions
Redo Reverses the last Undo command; execute the command multiple times to redo multiple 

undo actions
Cut Removes the contents of selected cells, temporarily storing the contents in the clipboard
Copy Copies the contents of selected cells to the clipboard, where they are temporarily stored; 

the original contents remain in the worksheet
Paste Places cell contents stored in the clipboard into the current cell or range of cells
Clear Contents Deletes the contents of the selected cells
Delete Rows Deletes the selected row(s) from the worksheet.

Use caution when deleting a row. Deleting cells that are part of a formula may change the 
values returned by the formula.

Delete Columns Deletes the selected column(s) from the worksheet.
Use caution when deleting a column. Deleting cells that are part of a formula may change 
the values returned by the formula.

View menu
Database Headers Toggles between displaying and hiding all worksheet database header rows
Grid Lines Toggles between displaying and hiding grid lines between the rows and columns of the 

worksheet, in both the worksheet window and the worksheet image (on the drawing)
Zoom Increases or decreases the zoom percentage by preset levels from 50% to 300%; the 

current zoom level displays in the worksheet title bar. Select a zoom level from the 
Worksheet menu, or roll the mouse wheel while holding Ctrl (Windows) or Option (Mac) 
to increase or decrease the zoom level by increments of 10% (regardless of the number of 
lines you assigned the mouse to scroll in the mouse setup).

This feature will not work properly if standard scrolling is disabled in the mouse 
setup. For example, if the mouse’s scrolling size is set to “none,” mouse zooming in 
the Vectorworks program is disabled. (The specific settings required for this feature 
depend on the type of mouse being used.)

Insert menu

Worksheet Command Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Worksheet Cell Context Menu
Worksheet Row Context Menu
Worksheet Column Context Menu

Worksheet Cell Context Menu
To access the commands available for a specific worksheet cell, right-click (Windows) or Ctrl-click (Mac) on the cell.

Rows Adds rows to the worksheet, above the selected row(s). The number inserted depends on 
how many rows in the worksheet are highlighted at the time the command is selected.
Use caution when inserting rows. Depending on the type of cell references used in 
formulas, inserting rows could change the values returned by a formula.

Columns Adds columns to the worksheet, to the left of the selected column(s). The number inserted 
depends on how many columns in the worksheet are highlighted at the time the command 
is selected.
Use caution when inserting columns. Depending on the type of cell references used in 
formulas, inserting columns could change the values returned by a formula.

Function Opens the Select Function dialog box; select a function to be inserted in the formula (see 
“Entering Formulas in Worksheet Cells” on page 1335)

Criteria Opens the Criteria dialog box; select search criteria to insert in a formula
Image Function
(Vectorworks 
Design Series 
required)

Inserts the image function in the formula for the current cell

Format menu
Cells Opens the Format Cells dialog box, for setting the format and appearance of selected cells
Column Width Opens the Column Width dialog box. Set the width value of selected cells in the specified 

units. Click Standard Width to use the default width. The width of multiple selected 
columns can be adjusted at one time.

Row Height Opens the Row Height dialog box; set the row height to automatically fit the selected cell 
contents, or set a specific row height in the specified units. The height of multiple selected 
rows can be adjusted at one time.

Menu Item Description

Cut Removes the contents of selected cells, temporarily storing the contents in the clipboard
Copy Copies the contents of selected cells to the clipboard, where they are temporarily stored; 

the original contents remain in the worksheet
Paste Places cell contents stored in the clipboard into the current cell or range of cells
Format Cells Opens the Format Cells dialog box, for setting the format and appearance of selected cells
Insert Image Function
(Vectorworks Design 
Series required)

Inserts the image function in the formula for the current cell

Worksheet Command Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Worksheet Menu
Worksheet Row Context Menu
Worksheet Column Context Menu

Worksheet Row Context Menu
To access the commands available for a specific worksheet spreadsheet or database header row, right-click (Windows) 
or Ctrl-click (Mac) while on the row number. These commands do not apply to database sub-rows.

Insert Adds rows or columns to the worksheet. The number inserted depends on how many rows 
or columns in the worksheet are highlighted at the time the command is selected. Select 
Insert > Rows to insert above the selected row(s). Select Insert > Columns to insert to the 
left of the selected column(s).
Use caution when inserting rows or columns. Depending on the type of cell references 
used in formulas, inserting rows or columns could change the values returned by a 
formula.

Delete Deletes rows or columns from the worksheet. Select one or more rows or columns and 
select Delete > Rows or Delete > Columns.
Use caution when deleting a row or column. Deleting cells that are part of a formula may 
change the values returned by the formula. Select Edit > Undo to undo the action.

Clear Contents Deletes the contents of the selected cells
Pick Value from List
(Vectorworks Design 
Series required)

If the cell is in a database sub-row, and the column lists a field that only allows certain 
pre-defined values, use this option to edit the object’s data.
For example, you might want to change the sill style for several window objects from the 
window schedule. Select the Sill cells for the objects to be changed, and right-click 
(Windows) or Ctrl-click (Mac). Select a different sill type from the list of options to 
change both the worksheet and the objects’ data records.

Menu Item Description

Spreadsheet Converts a database header row into a row of spreadsheet cells. This deletes all sub-rows 
and the information contained within them. Any formulas that were defined in the columns 
of the header row remain intact. This command has no effect on spreadsheet cells.

Database Converts a row of spreadsheet cells into a database header row and opens the Criteria dialog 
box. This command has no effect on database rows.

Set Criteria Opens the Criteria dialog box for setting the criteria that is used to generate the database 
sub-rows. Available only when a database header row is clicked.

Edit Criteria Opens the Criteria dialog box for editing the criteria that is used to generate the database 
sub-rows. Available only when a database header row is clicked.

Select Data Items Selects all objects on the drawing that meet the criteria for the database row. Available only 
when a database header row is clicked.

Format Cells Opens the Format Cells dialog box, for setting the format and appearance of selected cells
Row Height Opens the Row Height dialog box; set the row height to automatically fit the selected cell 

contents, or set a specific row height in the specified units. The height of multiple selected 
rows can be adjusted at one time.

Menu Item Description
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Database Sub-Row Context Menu
While on a database sub-row, right-click (Windows) or Ctrl-click (Mac) and select the Select Item command from the 
context menu. Use this command to select an individual database object in the drawing; the view changes to display the 
selected object (see “Importing Worksheets” on page 1358). The command is unavailable if the sub-row is summarized 
(see “Database Row Sort and Summary Functions” on page 1329).
~~~~~~~~~~~~~~~~~~~~~~~~~
Worksheet Menu
Worksheet Cell Context Menu
Worksheet Column Context Menu

Worksheet Column Context Menu
To access the commands available for a specific worksheet column, right-click (Windows) or Ctrl-click (Mac) while on 
the column letter.

Insert Rows Adds rows to the worksheet, above the selected row(s). The number inserted depends on 
how many rows in the worksheet are highlighted at the time the command is selected.
Use caution when inserting rows. Depending on the type of cell references used in formulas, 
inserting rows could change the values returned by a formula.

Delete Rows Deletes the selected row(s) from the worksheet.
Use caution when deleting a row. Deleting cells that are part of a formula may change the 
values returned by the formula.

Clear Row Contents Deletes the contents of the selected cells
Cut Removes the contents of selected cells, temporarily storing the contents in the clipboard
Copy Copies the contents of selected cells to the clipboard, where they are temporarily stored; the 

original contents remain in the worksheet
Paste Places cell contents stored in the clipboard into the current cell or range of cells

Menu Item Description

Format Cells Opens the Format Cells dialog box, for setting the format and appearance of selected cells
Column Width Opens the Column Width dialog box. Set the width value of selected cells in the specified 

units. Click Standard Width to use the default width. The width of multiple selected 
columns can be adjusted at one time.

Insert Columns Adds columns to the worksheet, left of the selected column. The number inserted depends 
on how many columns in the worksheet are highlighted at the time the command is 
selected.
Use caution when inserting columns. Depending on the type of cell references used in 
formulas, inserting columns could change the values returned by a formula.

Delete Columns Deletes the selected columns from the worksheet.
Use caution when deleting a column. Deleting cells that are part of a formula may change 
the values returned by the formula.

Clear Column Contents Deletes the contents of the selected cells
Cut Removes the contents of selected cells, temporarily storing the contents in the clipboard

Menu Item Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Worksheet Menu
Worksheet Cell Context Menu
Worksheet Row Context Menu

Database Row Sort and Summary Functions
The group of sub-rows associated with a header row can be sorted and summarized in different ways. These functions 
can be set independently for each database header row in a worksheet.

The sort and summary functions cannot be used on a header cell for an image column (Vectorworks Design Series 
required).

To sort or summarize a group of database sub-rows:
1. If the database header rows are not displayed, select View > Database Headers from the Worksheet menu.
2. Select the header row of the group of sub-rows to sort or summarize; the header row has a diamond next to its 

number.
The three icons above the left end of the column header cells become available.

3. Click and drag an icon to the column header cell to be used for the sort or summary. A new icon displays next to 
the column heading letter. For an ascending or descending sort, a number in the icon indicates the sort precedence 
for that column.

4. Apply additional sort or summary icons as needed. In each group of sub-rows, up to 20 columns can have either an 
Ascending or Descending Sort icon, and any number of columns can have a Summarize icon. The Summarize icon 
can be used on a column by itself, or in conjunction with one of the sort icons.

5. To remove a sort or summary, click and drag the icon away from the column header cell.

Copy Copies the contents of selected cells to the clipboard, where they are temporarily stored; 
the original contents remain in the worksheet

Paste Places cell contents stored in the clipboard into the current cell or range of cells

Icon Item Description

Descending Sort Sorts the database sub-rows in descending order, according to the contents of this column

Ascending Sort Sorts the database sub-rows in ascending order, according to the contents of this column

Summarize Summarizes the database sub-rows according to the contents of this column. Sub-rows that 
have identical items in this column are grouped together in a single row.
If a column contains data from a numeric field, the summarized column contains a sum of the 
values for all objects that are grouped on the row. This may be appropriate for some columns, 
but not others. For example, you might have a window schedule that sorts and summarizes the 
data by the Window ID column. You would want the Quantity column to show the sum of all 
windows with a particular ID, but you would want the Window Height column to show the 
height of a single window with that ID (not the height of all windows combined). Add an 
additional summary operator to the Window Height column to show the correct numeric data.

Menu Item Description
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Formatting Worksheet Cells
The appearance of worksheet cells can be set by a variety of formatting options.

Formatting applied to a database header row applies to all of the associated database sub-rows.
To format worksheet cells:

1. Select the cell(s) to format.
2. From the Worksheet menu, select Format > Cells.

The Format Cells dialog box opens.
On the Number tab, set the number format for the selected cells.

Click to show/hide the parameters.

3. Click the Alignment tab to specify text alignment options.
Click to show/hide the parameters.

Parameter Description

General Specifies the default general format
Decimal Uses decimal numbers; enter a value for the number of decimal places, and if desired, select to 

use commas as separators
Scientific Uses scientific numbers; enter a value for the number of decimal places
Fractional Uses fractional numbers; enter the rounding value for fractions
Percentage Uses percentages; enter a value for the number of decimal places
Dimension Uses dimension numbers
Dimension Area Uses the dimension area format (precision and units) as specified for this document; also 

displays the area units after the number
Dimension Volume Uses the dimension volume format (precision and units) as specified for this document; also 

displays the volume units after the number
Angle Determines the accuracy of angles and the measurement system used; the measurement 

system can be degrees/minutes/seconds, or decimal numbers up to eight decimal places
Date Uses date formats; select the desired format from the list
Boolean Select to evaluate the cell data to either True or False
Text Select to enter a string of characters; the cell contents are treated as text, even if a number is in 

the string
Leader Displays the specified leader text before the cell value (except for Boolean and Text formats)
Trailer Displays the specified trailer text after the cell value (except for Boolean and Text formats)

Parameter Description

Alignment Sets the alignment of text in relation to the cell border
Horizontal Specifies horizontal text alignment; select General to align text strings on the left and numbers 

on the right
Vertical Specifies vertical text alignment

Text Orientation Sets the text orientation
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4. Click the Font tab to specify the font, font size, style, and color of text in selected cells. See “Formatting Text” on 
page 389.

5. Click the Border tab to set cell border formatting options.
Select the Line Attributes, and then use the Presets or Preview buttons to add or remove border elements.

Click to show/hide the parameters.

6. Click the Patterns tab to specify fill options for the selected cell(s).
Click to show/hide the parameters.

Vertical Text Orients text vertically
Horizontal Text Orients text horizontally

Wrap Text Select to wrap text that exceeds the cell width (automatically adjusting row height); deselect to 
allow text that is longer than the cell width to “float” over empty adjacent cells. If adjacent 
cells contain content, unwrapped text may appear truncated. Numbers that exceed the cell 
width are displayed with # characters.

Merge Cells Merges a range of selected spreadsheet cells into one cell; cell and border formatting and text 
wrapping are applied to the cell group rather than to the individual cells. The cell contents and 
format of only the upper left cell in the group apply to the merged cells. Data and formatting in 
the other cells will be lost during the merge.
To split merged cells, select the merged cell group and then deselect Merge Cells.

Parameter Description

Line Attributes
Style Sets the line style and thickness for the border element
Color Sets the line color for the border element

Presets
None Removes all border formatting
Outline Adds or removes a border only on the outside edges (top, bottom, left, and right) of the cell 

selection
Inside Adds or removes a border only on the inside (horizontal and vertical) edges of the cell selection

Preview
Top Adds or removes a border at the top of the cell selection
Horizontal When more than one cell is selected, adds or removes a horizontal border between cells
Bottom Adds or removes a border at the bottom of the cell selection
Left Adds or removes a border on the left edge of the cell selection
Vertical When more than one cell is selected, adds or removes a vertical border between cells
Right Adds or removes a border on the right edge of the cell selection

Parameter Description
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7. If Vectorworks Design Series is installed, click the Images tab to specify the type, size, view, and margin for 
images in the selected cells. For more information, see “Inserting Images in Worksheets” on page 1343.

Click to show/hide the parameters.

8. Click OK to set the formatting for the selected cell(s). The worksheet formatting also applies to worksheets placed 
on a drawing.

Parameter Description

Style Select None to remove current cell fill options or to specify no fill; select Solid or Pattern to apply 
a solid fill color or pattern to the selected cell(s)

Color/Pattern If Style is set to Solid, select the fill Color; if Style is set to Pattern, select the Pattern and the 
foreground and background colors

Parameter Description

Image Type Select Thumbnail to display a thumbnail image of the referenced object in the cell; this is useful 
for 2D/3D symbols or plug-in objects. Use other settings to control the scale, view, rotation, and 
render mode shown in the thumbnail.
Select 2D Attributes to display a rectangle with the same 2D attributes as the referenced object. 
For a styled wall, slab, or space, the rectangle fill is a top/plan cross-section view of the object.

Size
AutoSize Sizes the image automatically so that the entire image is always visible, even when the cell size 

changes
Fixed Sizes the image according to the specified Height and Width; also specify the Units for the 

dimensions (points, millimeters, or inches)
Layer Scale Sizes the image according to the scale of the layer on which the object appears (thumbnails only)
Custom 
Scale

Select this option and then click Scale to select or enter a scale for the image (thumbnails only)

View
Standard 
Views

Select from any of the standard Vectorworks views for the image (thumbnails only)

Rotation If Top/Plan view is selected, enter the number of degrees to rotate the image (thumbnails only)
Render 
Mode

For any view except Top/Plan, select the render mode for the image (Wireframe, OpenGL, or 
Hidden Line); Top/Plan view is always rendered in Wireframe mode. Applies to thumbnails only.

Margin
Units Enter the units to use for the Size of the margin around the image (points, millimeters, or inches)
Size Enter the size of the margin around the image, in the specified Units
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Click here for a video tip on this topic (Internet connection required).
~~~~~~~~~~~~~~~~~~~~~~~~~
The Attributes Palette

Entering Data in Spreadsheet Cells
Three types of information can be entered into the spreadsheet cells of a worksheet: constant values (including text or 
numbers), formulas, and images (Vectorworks Design Series required). In addition, a cell can reference another cell in 
the same worksheet or in another worksheet.

• Text helps to identify the purpose of a worksheet and labels the columns in a worksheet.
• Images add visual information about items on a worksheet, and can also be used to create a drawing legend 

(Vectorworks Design Series required).
• Use formulas to perform calculations based on drawing data. A formula can be a simple mathematical equation, or 

it can include one or more built-in functions. The Vectorworks program provides mathematical functions (for 
example, a square root function), as well as functions that pull information from drawing objects (for example, a 
function that returns the volume of selected objects). See “Worksheet Functions” on page 1344 for a list of the 
functions available.
Database record fields that are attached to objects in the drawing (such as Model Number or Price) cannot be used 
in a spreadsheet cell. To include this type of data in the worksheet, see “Entering Data in Database Rows” on 
page 1339.

To define a spreadsheet row:
1. Right-click (Windows) or Ctrl-click (Mac) on the number of the row to change.
2. From the Row context menu, select Spreadsheet.

Formatted worksheet in 
the worksheet window

Formatted worksheet 
placed on the drawing

http://www.youtube.com/watch?v=CJSdy4IMytU
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3. The cells in the row are empty until you define the contents. Select a cell, and then enter the desired information in 
the worksheet Formula bar located at the top of the worksheet.
• To enter text or numbers, see “Entering Constant Values in Worksheet Cells” on page 1334.
• To enter a formula, see “Entering Formulas in Worksheet Cells” on page 1335.
• To reference other cells in this cell, see “Referencing Other Worksheet Cells” on page 1338.
• To insert an image, see “Inserting Images in Worksheets” on page 1343.

Entering Constant Values in Worksheet Cells
Constant values consist of numbers, spaces, non-numeric characters, or any combination of these. Constant values are 
not part of a formula or the result of a formula.

The formula phrase “=1”, or any number following an equal sign, is also considered a constant value.
Select the cell, and then enter the text or numbers needed; your entries automatically display in the worksheet Formula 
bar. When you click the green check mark on the Formula bar, the value displays in the cell.
Keep in mind the following:

• Most constant values are treated as text and default to the General format. However, some combinations of 
numeric and non-numeric characters are interpreted as a particular number format. For example, an entry of 07/19/
2013 automatically changes the format to the month/day/year date format. (See “Formatting Worksheet Cells” on 
page 1330.)

• Text is left-aligned unless the cell is formatted differently on the Alignment tab in the Format Cells dialog box 
(select Format > Cells from the Worksheet menu).

• Numbers entered in cells default to the General format. To change them to another format (for example, dimension 
or fractional), select Format > Cells from the Worksheet menu, and select the new format on the Number tab in 
the Format Cells dialog box.

~~~~~~~~~~~~~~~~~~~~~~~~~
Entering Data in Spreadsheet Cells
Entering Data in Database Rows
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Entering Formulas in Worksheet Cells
Use formulas to evaluate and perform operations on drawing data. Formulas always begin with an equal sign (=) and 
consist of a combination of functions, cell references, or operators that combine values to produce a new value.
Formulas must be entered with a specific syntax. If the formula is not entered correctly, the formula entry itself displays 
in the cell, instead of the result of the formula. Two common mistakes in syntax include forgetting to use pairs of 
parentheses, and omitting required commas when no argument is present. Formula syntax is described in the following 
table. 

Symbol Explanation Example

General 
Syntax

Equal sign = Begins each formula; also 
indicates a value for a variable

=CriteriaVolume(t=wall)

Parentheses ( ) Encloses a function argument; 
also used in arithmetic equations

=acos(0.6)

=A6+(A6*.07)

Square brackets [ ] Encloses a record destination =R IN ['myformat']

Period . Separates a record identifier and a 
field identifier

=Furniture.Type

Colon : Separates path name levels in cell 
references

=MyWorksheet:A1

Comma or semicolon
, or ;

Separates multiple values in a 
function argument; use a 
semicolon when commas are used 
as decimal separators by the 
operating system

=sum(A2,E3)

=sum(A2;E3)

Single quote ' Encloses a string constant =Appliances.'Model #'

Dollar sign $ Designates an absolute reference =A4*$B$1

Double period .. Designates a range of cells =sum(A10..A12)

Arithmetic 
Operators

Plus sign + Addition =A6+A8

Hyphen - Subtraction =A6-A8

Asterisk * Multiplication =A6*.06

Forward slash / Division =B3/12

Caret ^ Exponentiation =13^2

DIV Integer division (returns the 
integer quotient of the division 
operation)

j:= 36 DIV 5;

MOD Remainder division (returns the 
remainder of the division 
operation as an integer)

k:= 36 MOD 5;
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To force the program to treat a number as text, enclose the number in single quotation marks, as in '40'; or format 
the cell as Text on the Number tab of the Format Cells dialog box.

Formulas follow standard algebraic rules of hierarchy. In the following example, the value in cell C28 is first multiplied 
by 12, and then 4.5 is subtracted from that value. The result is then divided by 12.

=((C28*12)-4.5)/12

There are several built-in functions that can be used in formulas, including mathematical functions and functions that 
pull information from objects in the drawing. To use one or more worksheet functions in a formula, either enter the 
function manually, or use the Insert > Function and Insert > Criteria commands to select a function and selection 
criteria (if required) from dialog boxes. See “Worksheet Functions” on page 1344 for more information about how to 
use functions.
If there is a logic problem or calculation error with a formula, an error code displays in the cell.

To manually enter a formula:
1. Select the cell.

Comparison 
Operators
(used with IF 
function)

Equal sign = Equal =if((L='L2'),Area,0)

Less than and greater than signs 
(or Option+ = on Mac)
<> or 

Not equal =if((S<>'Dryer'),B9,0)

Less than sign < Less than =if((C7<100),100,C7)

Less than and equal signs (or 
Option+ < on Mac)
<= or   

Less than or equal to =if((E2<=G2),0.05,G2)

Greater than sign > Greater than =if((C7>100),100,C7)

Greater than and equal signs (or 
Option+ > on Mac)
>= or  

Greater than or equal to =if((E2>=G2),0.05,G2)

Error Code Explanation

#NAME? The field name in a database header row definition does not exist in the file; see “Retrieving 
Record Information in a Worksheet” on page 1342

#VALUE! The argument is the wrong type of data for the formula; for example, a cell referenced in a 
mathematical formula contains text 

#CVAL? A cyclical reference cannot be resolved
?Result? The result value type is unrecognized
#OPCODE? Internal error
#DIV 0! Division by zero error encountered
#FAC? Unrecognized entry
#OBJ! The worksheet name in an external reference does not exist, or the record name does not exist
#CSTATUS? Functions are nested too deeply (more than ten levels deep)

Symbol Explanation Example
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2. Enter an equal sign (=), and then enter the formula. The entries automatically display in the worksheet Formula 
bar. A formula can consist of functions, operators, cell references, and constant values.

3. When the formula is complete, click the green check mark or press Enter to validate the entry. To cancel an entry, 
click the red X or press Esc.

4. The formula executes as soon as the cell entry has been validated (Auto-recalc must be selected in the worksheet 
preferences; see “Preferences” on page 1325).

To enter a formula with the Function and Criteria commands:
1. Select the cell.
2. Enter an equal sign (=). The entry automatically displays in the worksheet Formula bar.
3. Select Insert > Function from the Worksheet menu.

The Select Function dialog box opens.
4. Select a function from the list and click OK.

The formula is placed in the worksheet Formula bar and the cursor is placed between the parentheses, awaiting an 
argument, if necessary.

5. Do one of the following:
• If the function requires numbers or text, enter the argument between the parentheses and proceed to step 8.
• If the function requires selection criteria, select Insert > Criteria from the Worksheet menu.

6. If an object is selected when the Criteria command is selected, the Paste Attributes dialog box opens. Otherwise, 
proceed to step 7.
Do one of the following:
• To use attributes of the selected object as the only selection criteria, select the attributes and click OK. Proceed 

to step 8.
• To specify other criteria, or to use attributes of other objects in the drawing, click the Custom button.

7. The Criteria dialog box opens. Set each of the three fields to the desired selection criteria. Click More Choices to 
specify additional criteria. Click Fewer Choices to remove added criteria. Click OK to add the criteria to the 
function argument.

8. When the formula is complete, click the green check mark or press Enter to validate the entry. To cancel the entry, 
click the red X or press Esc.

9. The formula executes as soon as the cell entry has been validated (Auto-recalc must be selected in the worksheet 
preferences; see “Preferences” on page 1325).

For each list, click to browse 
for criteria options

Design layer viewport 
functionality (Vectorworks 
Design Series required)
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~~~~~~~~~~~~~~~~~~~~~~~~~
Entering Data in Spreadsheet Cells
Entering Data in Database Rows
Entering Constant Values in Worksheet Cells
Referencing Other Worksheet Cells
Worksheet Functions

Referencing Other Worksheet Cells
A formula can reference the contents of one or more other cells. The cells can be referenced within the current 
worksheet (internal references), or from another worksheet (external references) within the same file.
External references must include the full path name to the other worksheet. The following table shows the syntax for 
entering an external reference into a formula.

If the name of the worksheet contains spaces, the name must be enclosed with single quotes as in the following 
example: ='Appliance Schedule':A1
To update an external reference, select File > Recalculate from the Worksheet menu.

Relative and Absolute Cell References
Cell references in a worksheet can be either relative and absolute. When the formula that contains the reference is 
moved, an absolute reference always refers to the original cell address, while a relative reference changes depending on 
the location of the cell that contains the reference. 
Use the dollar sign ($) character to indicate an absolute reference. The $ character locks the part of the cell reference it 
precedes, as described in the following table.

In the following example worksheet, the formula =AVERAGE(B1..B3) is in cell B4. If the formula were copied to cell 
E9, the formula would automatically be changed to =AVERAGE(E6..E8). Because the references are relative, both the 
column and row would change relative to the cell where the formula is placed—always indicating the three cells 
directly above the formula.

Syntax Example

worksheet name:cell address =MyWorksheet:A1

worksheet name:range of addresses =SUM(MyWorksheet:A1..A12)

Combination Description

$A1 Locks the specified column reference but leaves the row reference relative; the same column is 
always referred to, but the row changes if the formula is placed in a different row

$A$1 Locks both the specified column and row references; regardless of where the formula is copied, it 
always refers to the original cell

A$1 Locks the specified row reference but leaves the column reference relative; the same row is always 
referred to, but the column changes if the formula is placed in a different column
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Entering Data in Database Rows
Entering Formulas in Worksheet Cells
Entering Constant Values in Worksheet Cells

Entering Data in Database Rows
Database rows display data fields, calculations, or images associated with the objects in a drawing. The database header 
row is identified by a diamond shape next to the row number. When you create the database row, set the criteria to 
determine which objects will be listed in the related sub-rows. For example, you might set a header row to list all 
symbols in the drawing. A sub-row would then be generated for each symbol in the drawing. (If no object meets the 
header row criteria, no sub-rows are created.) 
Many criteria combinations can be specified, such as class, object type, record information, or line weight. For 
example, create a list of all the rooms in a resort, or list only the green wing-backed chairs from all the two-room suites 
that are scattered throughout the resort.
In each column in the database header row, specify which information about the objects to display. A column can list a 
specific attribute of each sub-row object, such as its class or layer. A column can also list a data field contained in a 
record attached to each object. Alternatively, a column can contain a constant, an image, or a formula, just as a 
spreadsheet cell can.
In the following example, database header row 2 has its criteria set to list all the objects in the drawing that have the 
appliance record attached to them. Columns A through D list the contents of the data fields in the appliance record: the 
appliance type, manufacturer, model number, and price. Column E contains a formula, which uses the value in column 
D to calculate the price of the appliance with sales tax. Column F lists which layer of the drawing contains the object.

Spreadsheet cells

Database header row

Database sub-rows
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To create a database row:
1. Right-click (Windows) or Ctrl-click (Mac) on the number of the row to change.

2. From the Worksheet row menu, select Database.
The Criteria dialog box opens.

3. Specify the selection criteria for which objects to display in the sub-rows. The number of objects that meet the 
criteria displays, to help you verify that the criteria is correct. To specify additional criteria, click More Choices.

4. Click OK to enable database functionality for the row. Beneath the header row, sub-rows are created for each 
drawing object that meets the criteria specified. The columns are empty until you define which data from the 
objects to display in each column.

5. Select each database header cell, and specify the information to be shown in each column of the row:
• To list attributes of each object (such as layer or class), see “Retrieving Object Attributes in a Worksheet” on 

page 1341.
• To list record data associated with each object (such as color or price), see “Retrieving Record Information in a 

Worksheet” on page 1342.
• To show the results of a formula for each object, see “Entering Formulas in Worksheet Cells” on page 1335.
• To show an image for each object, select Insert > Image Function from the Worksheet menu. Alternatively, 

select Insert Image Function from the context menu. See “Inserting Images in Worksheets” on page 1343.
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6. Each sub-row cell displays the information requested. Each cell in the header row displays the total number of 
objects found, or, if the column returns numerical data, the header cell displays the sum for all sub-rows. 
Information found in each column can be sorted using the ascending, descending, and summarize buttons; see 
“Database Row Sort and Summary Functions” on page 1329.

Undefining a Database Row
To undefine a database row:

1. Right-click (Windows) or Ctrl-click (Mac) on the number of the database header row to change.
2. Select Spreadsheet.

Undefining a database row removes the database row criteria and all sub-rows. Any formulas that were defined in 
the columns of the header row remain intact.

Retrieving Object Attributes in a Worksheet
A drawing object can have several attributes, such as the layer it is on, the type of object it is, the symbol name (if it is 
a symbol), and whether it is currently selected. You can display this information in the database rows of a worksheet.
To retrieve object information in the database rows:

1. Click the cell in the database header row where the formula will be entered.
2. Enter an equal sign (=), and then enter the criteria to display. For example, enter =C to display the name of the 

class to which each object belongs. The entries display in the worksheet Formula bar.

Code Criteria Name Code Criteria Name

ALL Every object PB Pen background
AR Arrowhead PF Pen Foreground 
ASZ Marker size PLA Plane
C Class name PON Plug-in object name
FB Fill background PP Pen pattern (same as LS)
FF Fill foreground R Object record
FOT Font S Symbol name
FP Fill pattern SEL* Selection status
FSZ Font size SLST Slab style
GFI Gradient fill SST Sketch style
HFI Hatch fill ST Object subtype
IFC_ENTITY IFC entity STO Story
IFI Image fill T Object type
L Layer name TFI Tile fill
LS Line style (same as PP) TSTY Text style
LT Line type TX Texture
LW Line weight V Visibility
N Object name VSEL* Visible selection status
OPA Opacity WST Wall style
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3. Click the green check mark to validate the entry.

Retrieving Record Information in a Worksheet
Database records are created in the Record Formats dialog box. These records are then assigned to objects through the 
Data tab of the Object Info palette. See “Viewing and Editing Object Records” on page 266 for more information. This 
information can be displayed in the database rows of a worksheet.
To retrieve record information in a database row:

1. Click the cell in the database header row where the formula will be entered.
2. Enter an equal sign (=), and then enter the record information to display. The entries display in the worksheet 

Formula bar. The syntax for retrieving record information is:

A period (.) must separate the two names, or the formula will not be executed.
If the name of the record format or field name contains spaces, the name must be enclosed with single quotes as in 
the following example: =‘Appliance Record’.‘Model Number’

3. Click the green check mark to validate the entry.
The database information attached to each object displays in the sub-rows.

Selecting and Editing Database Objects
You can use the database rows in a worksheet to select the object(s) in the drawing that are related to that row. If 
Vectorworks Design Series is installed, you can also edit the information associated with many database objects from 
the worksheet.
To select database objects:

1. Either all database objects or a single database object can be selected.
• To select all database objects that meet the database row criteria, right-click (Windows) or Ctrl-click (Mac) the 

row number of the database header row to open the context menu.
• To select an individual database object, right-click (Windows) or Ctrl-click (Mac) the row number of the 

sub-row that contains the object to open the context menu.
2. From the context menu, select either Select Data Items or Select Item.

All database objects that are represented by the header row, or the individual row object, are selected. If an 
individual object was selected with Select Item, the drawing view changes to display the selected object. The 
Select Item command is unavailable if the sub-row is summarized (see “Database Row Sort and Summary 
Functions” on page 1329).
To edit database objects:

* When used with the COUNT function, the SEL criterion counts objects that are actually 
non-selectable, such as the individual items within a group. The VSEL criterion counts only the 
visibly selected items, which is the same counting method used for the Object Info palette. For 
example, if you select and count a group that has 11 items in it, the SEL criterion returns a value 
of 12 (the group, plus the 11 items). The VSEL criterion returns a value of 1 (the group only).

Syntax Example

=record name.field name =Furniture.Type

Code Criteria Name Code Criteria Name
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In database sub-rows, some information can be edited, but some cannot. For example, the results of a calculation 
cannot be edited. However, if Vectorworks Design Series is installed, the data associated with a database object can be 
edited in the worksheet, and the object’s data record will be updated as well. For details, see “Editing Cell Contents” on 
page 1321.
~~~~~~~~~~~~~~~~~~~~~~~~~
Entering Constant Values in Worksheet Cells
Entering Formulas in Worksheet Cells
Worksheet Functions
Inserting Images in Worksheets

Inserting Images in Worksheets
If Vectorworks Design Series is installed, images can be added to worksheets to provide graphic views of the objects in 
a drawing. The images can be either thumbnail versions of objects, or samples of the 2D attributes of objects. For 
example, you might create a window schedule that shows top and front thumbnail views of each type of window in 
your drawing, in addition to data about each window.
Worksheets can have two types of rows: spreadsheet and database. The cells in a spreadsheet row contain constants 
(text or numbers), or formulas. Database rows consist of a header row and sub-rows, and they show data that are 
associated with specific drawing objects. Images can be inserted in either type of row.
To insert an image in a cell, use the image function, which works the same as other standard worksheet functions; see 
“Entering Formulas in Worksheet Cells” on page 1335.
Like other functions, you can enter an image function manually on the Formula bar, or use commands and dialog boxes 
to build a formula that uses the image function.

A cell that uses the image function in a formula can include either a text expression or an image, but not both.
To manually enter an image formula:

1. Select the cell.
2. Enter the image function (=IMAGE). The entry automatically displays in the worksheet Formula bar. If the cell is 

in a database header row, no further entry is required.
3. If the cell is in a spreadsheet row, enter the rest of the formula to specify which object to display. For example, to 

display an image of the symbol called K-02221, enter this:
=IMAGE(S='K-02221')

4. When the formula is complete, click the green check mark to validate the entry. To cancel an entry, click the red X.
5. The formula executes, and the image(s) display (Auto-recalc must be selected in the worksheet preferences).
6. Customize the image display as described in “Entering Data in Spreadsheet Cells” on page 1333.

To enter a formula with the Image Function and Criteria commands:
1. Select the cell.
2. Select Insert > Image Function from the Worksheet menu.

The image function is placed in the worksheet Formula bar and the cursor is placed between the parentheses, 
awaiting an argument. If the cell is in a database header row, no further entry is required.

3. If the cell is in a spreadsheet row, enter criteria to specify which drawing object to display. Select Insert > 
Criteria from the Worksheet menu.

4. If an object is selected when the Criteria command is selected, the Paste Attributes dialog box opens. Otherwise, 
proceed to step 5.
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Do one of the following:
• To use attributes of the selected object as the only selection criteria, select the attributes and click OK. Proceed 

to step 5.
• To specify other criteria, or to use attributes of other objects in the drawing, click Custom.

5. The Criteria dialog box opens. For each set of criteria, select the choices that apply. Click More Choices to 
specify additional criteria sets. Click Fewer Choices to remove added criteria sets. Click OK to add the criteria to 
the function argument.

6. When the formula is complete, click the green check mark to validate the entry. To cancel the entry, click the red 
X.

7. The formula executes, and the image(s) display (Auto-recalc must be selected in the worksheet preferences).
8. Customize the image display as described in “Entering Data in Spreadsheet Cells” on page 1333.

Click here for a video tip about this topic (Internet access required).

Worksheet Functions
Worksheet functions take an argument, perform an action, and return a value or values. There are two basic types of 
functions: those that use the value(s) you enter, and those that use information from objects in the drawing. The 
arguments required by the two function types are different.

• Number or text arguments: Functions that begin with a lower case letter typically require a number value or a 
cell address as the argument. For example, the acos function returns the arccosine of the value that is specified in 
the function argument. The argument you enter can be a mathematical expression (such as 3/5), an address of a 
cell that contains a number (such as A12), or an actual number. The argument for all trigonometry functions must 
be in radians.

• Criteria arguments: Functions that begin with a capital letter must be applied to one or more specific objects in 
the drawing. In a cell in a database header row, a function is automatically applied to the object listed in each 
sub-row, so no criteria argument is required.

Worksheet that includes 2D attribute images of wall styles Worksheet that includes thumbnail images of plant symbols

http://www.youtube.com/watch?v=_P1rfhKwD-Q 
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However, in a spreadsheet cell, you must enter criteria to select the objects the function applies to. For example, 
the Area function returns the combined area of all 2D objects that meet the criteria. To specify which objects to 
obtain the area of, either use the Insert > Criteria command on the Worksheet menu, or enter the criteria 
manually. For details about how to specify criteria such as the object type, class, or visibility, see the developer 
oriented documentation here:
http://developer.vectorworks.net/index.php/VS:Search_Criteria#Search_Criteria_Tables
http://developer.vectorworks.net/index.php/VS:Function_Reference_Appendix#attrCrit

The following table lists all of the worksheet functions available, as well as what kind of argument the function takes.
You may want to display an attribute associated with a drawing object in the worksheet (such as the object’s class, or 
which layer it is on); see “Retrieving Object Attributes in a Worksheet” on page 1341.

Function (argument) Description Example Related Functions

acos(number) The arccosine of a number. 
The arccosine is the angle 
whose cosine is number. 
The returned angle is 
given in radians in the 
range 0 to pi.
Number is the cosine of 
the angle, and must be 
from -1 to 1.

=acos(3/5)

(returns the angle for which the 
cosine value is 3/5)

cos

Angle(criteria) The angle (measured from 
horizontal) of the objects 
that meet the specified 
criteria, in degrees.
Use this function to return 
the angles of lines and 
walls (measured from 
horizontal), the span 
angles of arcs, and the 
slope angles of slabs.

Database header cell:
=Angle

(returns the angle of each object in 
the database)
Spreadsheet cell:
=Angle((t=arc)&(n='arc-1'))

(returns the sweep angle of the arc 
object named “arc-1” in the 
drawing)

Area(criteria) The total area of 2D 
objects that meet the 
specified criteria, based on 
the Area units in the Units 
dialog box

Database header cell:
=Area

(returns the area of each object in 
the database)
Spreadsheet cell:
=Area(t=rect)

(returns the combined area of all 
rectangle objects in the drawing)

Perim

http://developer.vectorworks.net/index.php/VS:Function_Reference_Appendix#attrCrit
http://developer.vectorworks.net/index.php/VS:Search_Criteria#Search_Criteria_Tables
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asin(number) The arcsine of a number. 
The arcsine is the angle 
whose sine is number. The 
returned angle is given in 
radians in the range -pi/2 
to pi/2. To express the 
arcsine in degrees, use the 
rad2deg function (or 
multiply the result by 180/
pi).
Number is the sine of the 
angle and must be from -1 
to 1.

=asin(A3)

(returns the angle for which the 
sine value is given in cell A3)

sin 

atan(number) The arctangent of a 
number. The arctangent is 
the angle whose tangent is 
number. The returned 
angle is given in radians in 
the range -pi/2 to pi/2. To 
express the arctangent in 
degrees, use the rad2deg 
function (or multiply the 
result by 180/pi).
Number is the tangent of 
the angle in question.

=atan(4/3)

(returns the angle for which the 
tangent value is 4/3)

tan 

average(number1, 
number2...)

The average (mean) of the 
arguments

=average(85,70,95)

(returns the average of the three 
numbers)

max, min, sum 

BotBound(criteria) The bottom 2D boundary 
(minimum y coordinate) of 
the objects that meet the 
specified criteria

Database header cell:
=BotBound

(returns the bottom 2D boundary of 
each object in the database)
Spreadsheet cell:
=BotBound(t=locus)

(returns the bottom 2D boundary of 
the locus that has the lowest bottom 
2D boundary value in the drawing)

LeftBound, 
RightBound, 
TopBound

Function (argument) Description Example Related Functions
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ComponentArea
(criteria, index)

The area of one side of the 
specified wall or slab 
component, minus any 
holes.
Index is the 1-based index 
identifying the component.

Database header cell:
=ComponentArea(2)

(returns the area of the second 
component for each wall or slab 
object in the database)
Spreadsheet cell:
=ComponentArea(t=wall,1)

(returns the combined area of the 
first components for all walls in the 
drawing)

ComponentVolume, 
ComponentName

ComponentName 
(criteria, index)

The name of the specified 
wall or slab component.
Index is the 1-based index 
identifying the component.

Database header cell:
=ComponentName(2)

(returns the name of the second 
component for each wall or slab 
object in the database)
Spreadsheet cell:
=ComponentName(t=wall,1)

(returns the name of the first 
component for all walls in the 
drawing)

ComponentVolume, 
ComponentArea

ComponentVolume
(criteria, index)

The volume of the 
specified component, 
minus any holes.
Index is the 1-based index 
identifying the component.

Database header cell:
=ComponentVolume(2)

(returns the volume of the second 
component for each wall or slab 
object in the database)
Spreadsheet cell:
=ComponentVolume(t=wall,1)

(returns the combined volume of 
the first components for all walls in 
the drawing)

ComponentArea, 
ComponentName

concat(text1, text2, 
text3)

Joins several text strings 
into one text string

=concat(B3,', ',B4)

(returns the contents of cells B3 
and B4 as a single string, separated 
by a comma and a space)

cos(number) The cosine of a given 
angle.
Number is the angle in 
radians for which the 
cosine is calculated.

=cos(deg2rad(23))

(converts a 23-degree angle to its 
radian equivalent, and returns the 
cosine of the angle)

acos 

Function (argument) Description Example Related Functions
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Count(criteria) The number of objects that 
meet the specified criteria

Database header cell:
=Count

(returns the total number of objects 
for each row in the database)
Spreadsheet cell:
=Count(s='simple sofa')

(returns the total number of symbol 
objects named “simple sofa” in the 
drawing)

CurtWallFrameLength
(criteria, class)

The combined length of 
the curtain wall frames 
that meet the specified 
criteria and are in the 
specified class. To find all 
frames in a curtain wall, 
use an empty class name.

Database header cell:
=CurtWallFrameLength('')

(returns the combined length of the 
curtain wall frames for each curtain 
wall in the database)
Spreadsheet cell:
=CurtWallFrameLength(t=wall, 
'')

(returns the combined length of the 
curtain wall frames for all curtain 
walls in the drawing)

CurtWallPnlAreaNet, 
CurtWallPnlAreaGross

CurtWallPnlAreaGross
(criteria, class)

The combined gross area 
of the curtain wall panels 
in the walls that meet the 
specified criteria and are in 
the specified class. The 
gross area includes 
portions of the panel 
covered by frames. To find 
all panels in a curtain wall, 
use an empty class name.

Database header cell:
=CurtWallPnlAreaGross('')

(returns the combined gross area of 
the curtain wall panels for each 
curtain wall in the database)
Spreadsheet cell:
=CurtWallPnlAreaGross(t=wall, 
'')

(returns the combined gross area of 
the curtain wall panels for all 
curtain walls in the drawing)

CurtWallFrameLength, 
CurtWallPnlAreaNet

Function (argument) Description Example Related Functions
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CurtWallPnlAreaNet 
(criteria, class)

The net area of the curtain 
wall panels in the walls 
that meet the specified 
criteria and are in the 
specified class. The net 
area includes only the 
visible area bounded by 
frames. To find all panels 
in a curtain wall, use an 
empty class name.

Database header cell:
=CurtWallPnlAreaNet 
('Class-1')

(returns the combined net area of 
the curtain wall panels assigned to 
the class “Class-1” for each curtain 
wall in the database)
Spreadsheet cell:
=CurtWallPnlAreaNet(t=wall, 
'Class-1')

(returns the combined net area of 
the curtain wall panels assigned to 
the class “Class-1” for all curtain 
walls in the drawing)

CurtWallFrameLength, 
CurtWallPnlAreaGross

deg2rad(number) Converts a number from 
degrees to radians. 
Number is the value in 
degrees to be converted to 
radians.

=deg2rad(47)

(converts the 47-degree angle 
measurement to its radian 
equivalent)

exp(number) e raised to the power of 
number. The constant e 
equals 2.71828182845904, 
the base of the natural 
logarithm. 
Number is the exponent 
applied to the base e.

=exp(2)

(returns the numeric value of e 
raised to the power of 2)

ln 

GetIfcProperty
(criteria)
(Vectorworks 
Architect or Landmark 
required)

The value of a specific IFC 
property associated with 
an IFC object. The criteria 
is a string with two 
elements separated by a 
period. The first element is 
either an IFC entity or 
PSet name, and the second 
element is the name of the 
IFC property.

=GETIFCPROPERTY 
('ifcfurnishingelement.name')

(returns the Name value for IFC 
objects whose IFC entity is 
IfcFurnishingElement)

Function (argument) Description Example Related Functions
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Height(criteria) The combined delta y 
(height) of objects that 
meet the specified criteria

Database header cell:
=Height

(returns the height (delta y) for 
each object in the database)
Spreadsheet cell:
=Height(sel=true)

(returns the combined height (delta 
y) value of the selected objects in 
the drawing)

Width

if ((logical_test), 
value_if_true, 
value_if_false)

Use value_if_true if 
logical_test is true, 
value_is_false if 
logical_test is false.
Use this function to 
conduct conditional tests 
on values and formulas 
and to branch based on the 
results of that test. The 
outcome of the test 
determines the value 
returned by the If function. 
The logical_test can be 
any value or expression 
that can be evaluated to 
true or false. Up to seven 
If statements can be nested 
as value_if_true, 
value_if_false arguments. 
Boolean statements within 
an if statement must be in 
parentheses. Text within 
an if statement should be 
enclosed within quotation 
marks. 

=if((C7>100),100,C7)

when commas are used as decimal 
separators by the operating system, 
use semicolons instead:

=if((C7>100);100;C7)

(if the value in cell C7 is greater 
than 100, the value in this cell is 
100; otherwise, the value in this 
cell is the same as the value in cell 
C7)

Image(criteria)
(Vectorworks Design 
Series required)

The image associated with 
the object that meets the 
specified criteria. In the 
cell format, specify 
whether to show a 
thumbnail of the object, or 
the 2D attributes applied to 
the object.

Database header cell:
=Image

(returns the image for each object 
in the database)
Spreadsheet cell:
=Image(s='cabinet')

(returns the image of the symbol 
named “Cabinet”)

Function (argument) Description Example Related Functions
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int(number) Removes any fractional 
part of a number.
Number is the real number 
to be changed to an 
integer.

=int(B9)

(returns the value in cell B9 
without its fractional component)

round

IsFlipped(criteria) The flipped state of the 
objects that meet the 
specified criteria

Database header cell:
=IsFlipped

(returns the flip state for each 
object in the database)
Spreadsheet cell:
=IsFlipped(PON=window)

(returns the total number of 
window objects in the drawing that 
are flipped)

LeftBound(criteria) The left side 2D boundary 
(minimum x coordinate) of 
the objects that meet the 
specified criteria

Database header cell:
=LeftBound

(returns the left 2D boundary for 
each object in the database)
Spreadsheet cell:
=LeftBound(t=locus)

(returns the left 2D boundary of the 
leftmost locus in the drawing)

BotBound, TopBound, 
RightBound

Length(criteria) The length of lines, walls, 
or path-based objects that 
meet the specified criteria

Database header cell:
=Length

(returns the length for each object 
in the database)
Spreadsheet cell:
=Length(t=line)

(returns the total length of all line 
objects in the drawing)

ln(number) The natural logarithm 
(base e).
Number is the positive real 
number for which the 
logarithm is calculated.

=ln(12)

(returns the natural logarithm of 
12)

exp

log(number) The base 10 logarithm.
Number is the positive real 
number for which the 
logarithm is calculated.

=log(2)

(returns the base 10 logarithm of 2)
ln

Function (argument) Description Example Related Functions
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max(number1, 
number2,...)

The largest number in the 
list of arguments.
Number is 1 – 14 numbers 
for which the maximum 
value is to be found.

=max(C5,C7,C9)

(returns the largest of the numbers 
that are in cells C5, C7, and C9)

min

min(number1, 
number2,...)

The smallest number in the 
list of arguments.
Number is 1 – 14 numbers 
for which the minimum 
value is to be found.

=min(C5,C7,C9)

(returns the smallest of the numbers 
that are in cells C5, C7, and C9)

max

ObjectType(criteria) The numeric object type 
ID of objects that meet the 
specified criteria
For a list of object type 
IDs, see the developer 
oriented documentation 
here:
http://
developer.vectorworks.n
et/index.php/
VS:Function_Reference
_Appendix#objects

Database header cell:
=ObjectType

(returns the object type value for 
each object in the database)
Spreadsheet cell:
=ObjectType(sel=true)

(returns the object type value of the 
selected object; for example, the 
object type value for a light is 81)

Perim(criteria) The combined perimeter 
of objects that meet the 
specified criteria

Database header cell:
=Perim

(returns the perimeter for each 
object in the database)
Spreadsheet cell:
=Perim(sel=true)

(returns the total perimeter of all 
selected objects)

rad2deg(number) Converts a number from 
radians to degrees.
Number is the value in 
radians to be converted to 
degrees.

=rad2deg(0.5235987)

(converts the radian angle 
measurement to its degree 
equivalent)

Function (argument) Description Example Related Functions
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RightBound(criteria) The right side 2D 
boundary (maximum x 
coordinate) of the objects 
that meet the specified 
criteria

Database header cell:
=RightBound

(returns the right 2D boundary for 
each object in the database)
Spreadsheet cell:
=RightBound(t=rect)

(returns the right 2D boundary of 
the rightmost rectangle in the 
drawing)

BotBound, TopBound, 
LeftBound

RoofArea_Heated
(criteria)

The heated area of the roof 
(minus the eve overhang) 
along the slope, combined 
for all objects that meet 
the specified criteria

Database header cell:
=RoofArea_Heated

(returns the heated area for each 
roof and roof face object in the 
database)
Spreadsheet cell:
=RoofArea_Heated 
(st=roofface)

(returns the combined heated area 
of all roof face objects in the 
drawing)

RoofArea_HeatedProj

RoofArea_HeatedProj
(criteria)

The heated area of the roof 
(minus the eve overhang) 
projected to the layer 
plane, combined for all 
objects that meet the 
specified criteria

Database header cell:
=RoofArea_HeatedProj

(returns the heated area for each 
roof and roof face object in the 
database, as projected to the layer 
plane)
Spreadsheet cell:
=RoofArea_Heatedproj(t=roof)

(returns the combined heated area 
of all roof objects in the drawing, 
as projected to the layer plane)

RoofArea_Heated

RoofArea_Total
(criteria)

The total area of the roof 
along the slope

Database header cell:
=RoofArea_Total

(returns the total area for each roof 
and roof face object in the 
database)
Spreadsheet cell:
=RoofArea_Total(st=roofface)

(returns the combined total area of 
all roof face objects in the drawing)

RoofArea_TotalProj

Function (argument) Description Example Related Functions
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RoofArea_TotalProj
(criteria)

The total area of the roof, 
projected to the layer plane

Database header cell:
=RoofArea_TotalProj

(returns the total area for each roof 
and roof face object in the 
database, as projected to the layer 
plane)
Spreadsheet cell:
=RoofArea_Totalproj(t=roof)

(returns the combined total area of 
all roof objects in the drawing, as 
projected to the layer plane)

RoofArea_Total

round(number) Rounds the specified 
number to the nearest 
whole number

=round(D11)

(returns the value in cell D11 
rounded to the nearest whole 
number)

int

sin(number) The sine of a given angle.
Number is the angle in 
radians for which the sine 
is calculated.

=sin(deg2rad(32))

(converts a 32-degree angle to its 
radian equivalent, and returns the 
sine of the angle)

asin

SlabStyleName
(Vectorworks 
Architect required)

The name of a slab style Database header cell:
=SlabStyleName

(returns the name of the slab style 
for each slab object in the database)

SlabThickness
(criteria)
(Vectorworks 
Architect required)

The combined thickness of 
slab objects (floors and 
roof faces) that meet the 
specified criteria

Database header cell:
=SlabThickness

(returns the thickness for each 
object in the database)
Spreadsheet cell:
=SlabThickness(PON=slab)

(returns the combined thickness of 
all slab objects in the drawing)

sqrt(number) A positive square root.
Number is the number for 
which the square root is 
calculated.

=sqrt(D27)

(returns the square root of the 
number in cell D27)

Substring(text/
function, delimiter, 
index)

Splits a single string into 
an array of strings using a 
delimiter, and outputs each 
string at the specified 
index

=SUBSTRING(('kitchen;bedroom;
bathroom;basement', ';', 2)

(returns “bedroom,” which is the 
second substring in the specified 
string)

Function (argument) Description Example Related Functions
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sum(number1, 
number2,...)

The sum of all numbers in 
the list of arguments.
Number is 1 – 14 numbers 
for which the sum is 
calculated.

=sum(A2,A10..A12)

(returns the sum of the numbers 
contained in cells A2, A10, A11, 
and A12)

Average

SurfaceArea(criteria) The total surface area of 
all objects that meet the 
criteria, based on the Area 
units in the Units dialog 
box

Database header cell:
=SurfaceArea

(returns the surface area for each 
object in the database)
Spreadsheet cell:
=SurfaceArea(st=sphere)

(returns the total surface area of all 
sphere objects in the drawing)

tan(number) The tangent of the given 
angle.
Number is the angle in 
radians for which the 
tangent is calculated.

=tan(deg2rad(32))

(converts a 32-degree angle to its 
radian equivalent, and returns the 
tangent of the angle)

atan

TopBound(criteria) The top 2D boundary 
(maximum y coordinate) 
of the objects that meet the 
specified criteria

Database header cell:
=TopBound

(returns the top 2D boundary for 
each object in the database)
Spreadsheet cell:
=TopBound(sel=true)

(returns the top 2D boundary of the 
topmost selected object)

BotBound, LeftBound, 
RightBound

value(text) Converts a text string that 
represents a number to a 
number

=value('2e3')

(returns the numeric value of 2 
times 10 raised to the power of 3)

Volume(criteria) The total volume of all 
objects that meet the 
criteria, based on the 
Volume units in the Units 
dialog box.

Database header cell:
=Volume

(returns the volume for each object 
in the database)
Spreadsheet cell:
=Volume(t=xtrd)

(returns the total volume of all 
extrude objects in the drawing)

Function (argument) Description Example Related Functions
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WallArea_Gross
(criteria)

The combined 2D gross 
surface area of one wall 
face for walls that meet the 
specified criteria

Database header cell:
=WallArea_Gross

(returns the gross surface area of 
one wall face for each wall object 
in the database)
Spreadsheet cell:
=WallArea_Gross(t=wall)

(returns the combined gross surface 
area of one wall face for all walls in 
the drawing)

WallArea_Net

WallArea_Net
(criteria)

The combined 2D net 
surface area of one wall 
face, without door, 
window, and inserted 
symbol areas, for walls 
that meet the specified 
criteria

Database header cell:
=WallArea_Net

(returns the net surface area of one 
wall face, minus inserted object 
areas, for each object in the 
database)
Spreadsheet cell:
=WallArea_Net(t=wall)

(returns the combined net surface 
area of one wall face, minus 
inserted object areas, for all walls 
in the drawing)

WallArea_Gross

WallAverageHeight
(criteria)

The average height of a 
wall, including wall peaks 
and different starting and 
ending heights

Database header cell:
=WallAverageHeight

(returns the average height for each 
wall object in the database)
Spreadsheet cell:
=WallAverageHeight((t=wall)&
(sel=true))

(returns the average height of all 
walls that are selected in the 
drawing)

WallStyleName
(criteria)
(Vectorworks 
Architect or Landmark 
required)

The name of a wall style Database header cell:
=WallStyleName

(returns the name of the wall style 
for each wall object in the 
database)

Function (argument) Description Example Related Functions
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WallThickness
(criteria)

The combined thickness of 
wall objects that meet the 
specified criteria

Database header cell:
=WallThickness

(returns the thickness for each wall 
object in the database)
Spreadsheet cell:
=WallThickness(t=wall)

(returns the combined thickness of 
all walls in the drawing)

Width(criteria) The combined delta x 
(width) of objects that 
meet the specified criteria

Database header cell:
=Width

(returns the width (delta x) for each 
object in the database)
Spreadsheet cell:
=Width(sel=true)

(returns the combined width (delta 
x value) of the selected object)

Height

XCenter(criteria) The x coordinate of the 
center point of an object 
that meets the specified 
criteria

Database header cell:
=XCenter

(returns the x coordinate value of 
the center of the 2D boundary for 
each object in the database)
Spreadsheet cell:
=XCenter(sel=true)

(returns the x coordinate value of 
the center of the 2D boundary of 
the selected object)

YCenter, ZCenter, 
XCoordinate

XCoordinate(critiera) The x coordinate of the 
insertion point for 
symbols, point plug-in 
objects, and loci.
The returned value is 
relative to the user origin.

Database header cell:
=XCoordinate

(returns the x coordinate value for 
each object in the database)

YCoordinate, 
ZCoordinate, XCenter

Function (argument) Description Example Related Functions
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~~~~~~~~~~~~~~~~~~~~~~~~~
Entering Data in Spreadsheet Cells
Entering Data in Database Rows

Importing Worksheets
Data from a wide variety of worksheet formats can be imported into a file, including worksheet data from other 
programs and worksheets from other Vectorworks files.

YCenter(criteria) The y coordinate of the 
center point of an object 
that meets the specified 
criteria

Database header cell:
=YCenter

(returns the y coordinate value of 
the center of the 2D boundary for 
each object in the database)
Spreadsheet cell:
=YCenter(sel=true)

(returns the y coordinate value of 
the center of the 2D boundary of 
the selected object)

XCenter, ZCenter, 
YCoordinate

YCoordinate(criteria) The y coordinate of the 
insertion point for 
symbols, point plug-in 
objects, and loci.
The returned value is 
relative to the user origin.

Database header cell:
=YCoordinate

(returns the y coordinate value for 
each object in the database)

XCoordinate, 
ZCoordinate, YCenter

ZCenter(criteria) The z coordinate of the 
center point of an object 
that meets the specified 
criteria

Database header cell:
=ZCenter

(returns the z coordinate value of 
the center of the 3D boundary for 
each object in the database)
Spreadsheet cell:
=ZCenter(sel=true)

(returns the z coordinate value of 
the center of the 3D boundary of 
the selected object)

XCenter, YCenter, 
ZCoordinate

ZCoordinate(criteria) The z coordinate of the 
insertion point for 
symbols, point plug-in 
objects, and loci.
The returned value is 
relative to the user origin.

Database header cell:
=ZCoordinate

(returns the z coordinate value for 
each object in the database)

XCoordinate, 
YCoordinate, ZCenter

Function (argument) Description Example Related Functions
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Importing Worksheet Data from Another Program
To import a worksheet into the current file, a blank worksheet must exist in the active drawing as a destination for the 
imported worksheet. During import, the spreadsheet data is imported, but the formulas (logic) are not.
To import worksheet data into a Vectorworks file:

1. From the Resource Browser, select Resources > New Resource > Worksheet.
The Create Worksheet dialog box opens.

2. Specify the same number of rows and columns that are present in the worksheet to be imported.
3. Select File > Import > Import Worksheet.
4. Select the worksheet file to be imported. The worksheet must be in one of the following formats:

• Tab delimited text (.txt)
• Comma delimited text (.csv)
• DIF (.dif)
• SYLK (.slk)

5. Click Open. The worksheet is imported into the open worksheet in the Vectorworks file.

Importing Worksheets from Another Vectorworks File
To import a Vectorworks worksheet from another Vectorworks file:

1. From the Resource Browser, locate the file containing the worksheet using the Resources > Find command, or 
from a Favorites file. See “Accessing Existing Resources” on page 229 for more information.

2. Select the worksheet to import, and click Import. (Alternatively, drag the worksheet resource into the desired 
Vectorworks file to insert it as a drawing object; see “Worksheets as Graphic Objects” on page 1360.)
The selected worksheet is imported into the current file.

Importing a Table from Microsoft Word
The following procedure is an example of how to import a table from Microsoft Word into a Vectorworks worksheet.
To import a Word table into a worksheet:

1. In Word, select the entire table to be imported.
2. In versions of Word prior to 2007, select Table > Convert > Table to Text. In Word 2007 and later, select the 

Table Tools > Layout > Convert to Text.
The Convert Table to Text dialog box opens.

3. In the dialog box, click Tabs for the separation identifier.
4. Click OK.
5. Save the table.

If the file consists of only the table, select File > Save As. In the Save As dialog box that opens, select Text Only 
from the Save as type list, and click OK.
If the table is part of a larger file, copy the table to the Clipboard. Select File > New, and paste the table text into 
the new document. Save the file as a text file.

6. Return to the Vectorworks file and import the table as described in “Importing Worksheet Data from Another 
Program” on page 1359.
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Exporting Worksheets
Vectorworks worksheet files can be exported and read by spreadsheet programs, such as Excel, as well as by some 
word processing programs. Because many of these programs have different format requirements, several export 
formats are available. These include comma delimited, tab delimited, merge, DIF, and SYLK. Using the tab delimited 
format, for example, creates a file that can be opened as a table in Microsoft Word.
To export a worksheet from a Vectorworks file:

1. Open the worksheet to export.
2. Select File > Export > Export Worksheet.
3. The Export Worksheet dialog box opens.

Select the format for the export, and whether to export all rows or only the selected rows. Click OK and specify 
the name and location of the exported worksheet.

4. Click Save. The specified worksheet rows are exported to the desired location in the set format.

Worksheets as Graphic Objects
A worksheet can be included in a drawing as a graphic object. The worksheet object can be moved to any location on 
the drawing, but it cannot be resized. Use the Attributes palette to modify the fill, pen, and line thickness attributes of 
the entire worksheet object. To edit the contents of the worksheet, open it from the Resource Browser, or from the 
drawing itself.
To include a worksheet as an object on a drawing:

1. From the Resource Browser, select the desired worksheet.
The worksheet must be a part of the current drawing. If the worksheet is part of another drawing, first import it 
into the current drawing. Select the worksheet from the Resource Browser and then select Resources > Import. 
(See “Importing Worksheet Data from Another Program” on page 1359.)

2. Select Resources > Worksheet On Drawing.
The worksheet is now included in the drawing as a graphic object. It can be moved like any other graphic object 
and placed where desired. If the worksheet is currently open, the contents of the worksheet in the drawing are 
replaced with an X.
Alternatively, double-click the worksheet in the Resource Browser to place it in the drawing file, or select the 
worksheet in the Resource Browser and drag it to the desired location in the drawing file. Both methods 
automatically select Worksheet on Drawing and place the worksheet as a graphic object. If you use the drag and 
drop method, the top left corner of the worksheet is placed at the point where the mouse is released in the drawing 
file.

To edit a worksheet included as a drawing object:
1. From the Resource Browser, select the desired worksheet.
2. Select Resources > Open.

Alternatively, double-click the worksheet object in the drawing.
3. The worksheet is opened and available for editing. The contents of the worksheet in the drawing are replaced with 

an X. Close the worksheet to display the worksheet contents in the drawing.
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Worksheet Tutorial: Creating a Wall Schedule
This simple tutorial explains how to create a customized schedule that links wall objects in a drawing to a database 
worksheet. The schedule will display data for wall areas, wall thicknesses, labor cost, material cost, taxes, and total cost 
per wall style.
The WorksheetTutorial.vwx file contains the data required to perform the tutorial steps. Though wall styles are a 
Vectorworks Design Series feature, any Vectorworks license can use the wall styles that already exist in the tutorial file. 
Download the file here (Internet connection required) and open it in Vectorworks to begin.

Step 1: Create a Blank Worksheet
There are three ways to create a schedule using worksheets. This tutorial uses the first option below.

• Start with a blank worksheet, and create the schedule from scratch. See “Creating a Blank Worksheet” on 
page 1317.

• Create a schedule based on a common record format of a set of objects (wall data, in this example). This option 
allows you to select the criteria you wish to display from all the available object criteria. See “Creating Reports” 
on page 1316.

• Start with a preformatted schedule and customize it to achieve your goals. See “Creating Schedules” on 
page 1864.

To create a blank worksheet:
1. From the Resources menu in the Resource Browser, select New Resource > Worksheet. The Create Worksheet 

dialog box opens.
2. Enter “Wall Area and Costs” as the name for the new worksheet, and click OK. You will add more rows and 

columns later.
A blank worksheet window opens.

Step 2: Set the Database Criteria
Next, create a database of the objects in the drawing from which to extract the wall area data. You can combine 
multiple criteria to collect the desired subset of objects.
For this tutorial, a single database of wall objects will be created and limited to a specified set of wall styles.

An alternative would be to create one database per wall style and include multiple databases in the same 
worksheet. However, for very large databases, it is recommended to create separate worksheets rather than include 
multiple databases into a single worksheet.

http://app-help.nemetschek.net/2015/NNA/eng/tutorial/WorksheetTutorial.vwx
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To set the database criteria:
1. Right-click (Windows) or Ctrl-click (Mac) on the header box for row 3.
2. From the Row context menu, select Database. The Criteria dialog box opens.
3. Set the three criteria options as follows:

• Type
• is
• Wall

4. Click More Choices, and set the next three criteria as follows:
• Wall Style
• is
• Aspen Interior Walls

5. Click More Choices, and set the next three criteria as follows:
• Wall Style
• is
• Ext-CIP Conc 36”-Footing
To include all wall styles in the schedule, do not enter criteria for walls and wall styles; instead, use the following 
criteria: Record, Wall Data, is present.

6. Click OK to set the criteria. The database of walls for the specified set of wall styles is created. The database 
header (row 3) now has a diamond next to the row number. Beneath row 3 are sub-rows for each object in the 
database (3.1 through 3.45).
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Step 3: Expand the Worksheet
For this tutorial, you need to expand the worksheet. Since no data has been assigned to the columns yet, it does not 
matter where the columns are added.
Use one of the following methods to add three columns to the worksheet, for a total of eight.

• Select Insert > Columns. An empty column is added to the left of the current column.
• Right-click (Windows) or Ctrl-click (Mac) the column header where you want to add a column, and select Insert 

Columns from the context menu.
• Position the cursor at the bottom right corner of the worksheet to activate a special resize cursor; drag as needed to 

add columns to the right side of the worksheet.

Step 4: Use Worksheet Functions to Extract Data
Next, add database functions to the worksheet to extract the desired data from the database. Enter formulas for each 
column in the database header row cells. The database header row can be hidden before the worksheet is placed on the 
drawing.
For this tutorial, the following data will be extracted:

• Wall Style Name
• Gross Wall Area
• Net Wall Area
• Wall Thickness

To extract the data associated with the walls in the database:
1. Click the following cells and enter the formula shown to extract data for each item in the database. Be sure to 

include the equal sign (=) before each item.
• In A3 enter =WALLSTYLENAME
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• In B3 enter =WALLAREA_GROSS
• In C3 enter =WALLAREA_NET
• In D3 enter =WALLTHICKNESS
Alternatively, use the worksheet menu command Insert > Function to insert functions.

2. By default, numerical data is unformatted and must be formatted to display appropriate units. Formatting applied 
to database header row cells is automatically applied to all sub-rows for that column.
Right-click (Windows) or Ctrl-click (Mac) each of the following cells, and select Format Cells from the context 
menu. The Format Cells dialog box opens. On the Number tab, select the format option shown and click OK.
• For B3 select Dimension Area
• For C3 select Dimension Area
• For D3 select Dimension
Alternatively, use the worksheet menu command Format > Cells to format cells.

3. Add labels for columns A through D by typing names in the cells in row 2.
• In A2 enter Wall Style Name
• In B2 enter Wall Area (Gross)
• In C2 enter Wall Area (Net)
• In D2 enter Wall Thickness

Various types of data can be extracted from Vectorworks objects into a worksheet database, as described in the 
following topics.

• “Worksheet Functions” on page 1344
• “Retrieving Object Attributes in a Worksheet” on page 1341
• “Retrieving Record Information in a Worksheet” on page 1342
• “Entering Formulas in Worksheet Cells” on page 1335

Step 5: Summarize Wall Styles
Instead of listing each wall individually in the database, you can summarize all walls with the same wall style, 
automatically calculating the total quantities for each, and shortening the list.
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To summarize the wall styles:
1. Click on the header box for row 3 to select it. Three icons display just below the Formula bar.
2. Click and drag the Summarize icon to the header box for column A, which contains wall styles.
3. The number of sub-rows is reduced to only two (one row per wall style). The numerical values in columns B, C, 

and D are now sums. While this is desired for the wall area gross and net columns, you probably want to show the 
thickness value as the thickness of an individual wall, rather than all walls combined. To do so, apply another 
Summarize icon to column D.

Step 6: Use Formulas to Calculate Costs
Next, calculate costs using worksheet operations and formulas.
For this tutorial, the following data will be calculated:

• Labor cost per wall style
• Material cost per wall style
• Taxes
• Total cost

To calculate costs with formulas:
1. Add labels for columns E through H by typing names in the cells in row 2.

• In E2 enter Labor Cost
• In F2 enter Material Cost
• In G2 enter Taxes
• In H2 enter Total Cost

2. Click the following cells and enter the formula shown to determine the cost sums. Be sure to include the equal sign 
(=) before each item.
• In E3 enter =C3*15.5 (multiply the value in C3 by 15.5, the estimated rate of labor cost per area unit)
• In F3 enter =C3*9.2 (multiply the value in C3 by 9.2, the estimated material cost per area unit)
• In G3 enter =F3*.08 (multiply the value in F3 by 0.08, the estimated tax rate)
• In H3 enter =E3+F3+G3 (calculate the total cost of labor, material, and taxes)
Instead of entering the tax rate directly into the calculation, an alternative and more flexible approach is to set the 
tax rate in a separate spreadsheet cell and simply reference it in the calculation.
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3. Format all of the cost data the same way. Select the four cost header cells (E3 through H3), and then right-click 
(Windows) or Ctrl-click (Mac) and select Format Cells from the context menu. The Format Cells dialog box 
opens. On the Number tab, select the options shown and click OK.
• Select Decimal
• In Dec. Places, enter 2
• Select Use Commas
• In Leader, enter $ (dollar sign)

Step 7: Set up Column Totals, and Add and Delete Rows
Next, set up totals at the bottom of the columns as appropriate. The cells in the database header row (in this case, row 3) 
display sums for all of the database columns. Reference these database header row cells in spreadsheet cells to set up 
the totals.
To set up the totals:

1. Click the following cells and enter the formula shown to show sums from the database header row. Be sure to 
include the equal sign (=) before each item.
• In B4 enter =B3
• In C4 enter =C3
• In E4 enter =E3
• In F4 enter =F3
• In G4 enter =G3
• In H4 enter =H3

2. Select cells B4 and C4, right-click (Windows) or Ctrl-click (Mac), and select Format Cells from the context 
menu. On the Number tab, select Dimension Area and click OK.

3. Select cells E4 through H4, right-click (Windows) or Ctrl-click (Mac), and select Format Cells from the context 
menu. On the Number tab, select the options shown and click OK.
• Select Decimal
• In Dec. Places, enter 2
• Select Use Commas
• In Leader, enter $ (dollar sign)

4. Click cell A1 and enter Wall Areas and Costs as the schedule title.
5. Select row 2, right-click (Windows) or Ctrl-click (Mac), and select Insert Rows from the context menu to add an 

empty row between the schedule title and the column labels.
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6. Select the empty rows at the bottom of the worksheet (6 through 11), right-click (Windows) or Ctrl-click (Mac), 
and select Delete Rows from the context menu.

7. Select View > Database Headers and then View > Grid Lines to hide the database header row and grid lines in 
the table.

Step 8: Format the Worksheet
Finally, select cells and use the Format Cells command to format the worksheet as needed. You can change the font, 
font style, size, and color to format the text. Add cell borders, and change cell background color, as desired. Change the 
text alignment in cells, and resize rows and columns, if necessary.
See “Formatting Worksheet Cells” on page 1330 for details.

Formatted worksheet placed in drawing
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Detail Drawings
To create detail drawings for architectural projects, first use the Create Standard Viewports command (Vectorworks 
Architect required) to automatically create the necessary detail sheet layers. For a complete description of viewports, 
see “Creating Sheet Layer Viewports” on page 1616.
When using viewports:

• The Create Standard Viewports command can automatically create the necessary detail sheet layers.
• Because sheet layer viewports can be easily copied and pasted, duplicate the floorplan viewports, and then copy 

them to the detail sheet layer. They can be rescaled and cropped to create plan detail drawings.
• When annotating a sheet layer viewport, keep in mind that “annotations” refer to any 2D element, including 2D 

detail objects.
Once the sheet layers and viewports have been defined, use the tools from the Detailing tool set to refine the detail 
drawing with either 2D or 3D detail objects. These tools can significantly reduce the amount of time necessary to make 
an accurate representation of an object. Detailing tool objects can be used in conjunction with other objects, such as 
groups, symbols, rectangles, and polylines. The following illustration shows several examples of each, used in 
conjunction to create a fully-developed detail form.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating an Interior Elevation
Creating Stipple Objects
Creating Linear Material Details
Creating Repetitive Unit Details
Creating Chain Extrude Objects
Creating Holes
Keyways
Screw Threads
Inserting Fastener Objects Using the Fastener Tool
Bolts
Nuts
Screws
Pins
Retaining Rings and Washers
Rivets
Gears
Pulleys
Sprockets
Roller Chains
Shafts
Keys

Created with the 
Break Line tool

Polyline for emphasis
of cut plane

Detail cut 
wood objects

Detail cut 
wood object

Batt insulation 
object

Symbol made from
imported DWG file

Rectangle with 
pattern fill
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Bearings
Springs
Structural Shapes and Details

Creating an Interior Elevation
To create an interior elevation using the Convert Copy to Lines command:

1. From the floor plan, select the wall for creating the elevation. If it has millwork or fixtures attached to or adjacent 
to it, ensure that they are selected.
Fixtures inserted in (attached to) the wall are automatically selected.

2. Select the view from which to create the elevation. For example, to view the wall from the right side of the plan, 
select View > Standard Views > Right.

3. Select Modify > Convert > Convert Copy to Lines and choose Hidden Line Rendering.
4. Select View > Rendering > Hidden Line. A hidden line group of the selection is created and selected. Select 

Edit > Cut.
5. Select the detail sheet layer from the Layers menu and select Edit > Paste. Move the newly created interior 

elevation to the desired location on the detail sheet layer and add graphics, notes, and dimensions as required.
Alternatively, interior elevations can also be created by creating a section viewport of the interior with a finite 
depth range (Vectorworks Design Series required; see “Creating Section Viewports” on page 1624) or by creating 
a viewport with hidden line rendering and annotate the elements with the inner or outer boundary mode of the 2D 
Polygon tool (see “Creating Boundary Polygons in a Hidden Line Rendered Viewport” on page 306).

~~~~~~~~~~~~~~~~~~~~~~~~~
Convert Copy to Lines

Creating Stipple Objects
The Stipple tool creates a random pattern (different shapes, sizes, and, optionally, colors) within a defined boundary, 
which resembles a hand-drawn shaded effect. To create a stipple object, either use the Stipple tool, or draw a polyline 
and then run the Create Objects from Shapes command (see “Creating Objects from Shapes” on page 277).

To create a stipple object:

1. Click the Stipple tool from the Dims/Notes tool set.
2. Click Preferences from the Tool bar to specify or change any default Stipple tool parameters.

The Define Stipple Pattern dialog box opens. Up to two different shapes can be specified to define the stipple 
pattern.

Click to show/hide the parameters.

Parameter Description

Shape 1/Shape 2 Click on the appropriate tab to define two different shapes, sizes, aspect ratios, and 
shape percentages
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Shape type Select the stipple fill shape. For the polygon shape, specify the number of sides.

Minimum/Maximum 
Size

Enter the minimum/maximum size of the stipple pattern

Max Aspect Ratio Enter the maximum aspect ratio of the stipple shapes (enter 1 to display square aspects)
Mix Percent Enter the fill shape mixture percentage. The percentage defines the contribution of each 

shape to the stipple pattern, up to 100% (e.g. enter 60% for shape one and shape two 
automatically displays 40%). If shape one is assigned 100%, then shape two cannot be 
defined.

Stipple Density
Low/High Adjust the density of the stipple fill shapes by dragging the slider along the Stipple 

Density slider or by entering a numeric value between 1and 200 in the box below the 
Stipple Density slider

Color Stipple Shapes Randomly fills the stipple shapes with colors in the specified color range
Color Range/to Click the color boxes to select the desired color ranges

Fade Stipple from Edge Creates a stipple that fades in from the edge of the stippled shape

Width of Stipple Enter the width of the faded area in page dimensions
Void Stipple Center Leaves the center of the stipple unshaded

Parameter Description

Line Oval

Triangle Polygon (with five sides)

Rectangle

Fade from edge No fade
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Both the Color Stipple Shapes and Fade Stipple from Edge options are processor-intensive actions and can 
significantly increase stipple regeneration time.

3. Click OK.
4. Click on the appropriate mode in the Tool bar to select the boundary creation method of the stipple object.

For more information on the Polyline tool modes, see “Creating Polylines” on page 298.
5. Click to set the stipple object’s start point.
6. Click to set the end of the segment and the beginning of the next. Continue drawing segments in this manner until 

the stipple object is complete.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing the Stipple Object Settings

Editing the Stipple Object Settings
The parameters can be edited for selected stipple objects through the Stipple Settings button on the Shape tab of the 
Object Info palette (the parameters are described in “Creating Stipple Objects” on page 1370). To modify default 
stipple settings, click the Preferences button on the Tool bar.

Reshaping the Stipple Object
Double-click a stipple object to activate the Reshape tool. Select the object handles to reshape the stipple object 
boundary. For more information, see “Reshaping Objects” on page 1043.

Edge Treatment Determines how the stipple shapes are drawn at the edge of the stippled area

Randomly Rotate Shapes Select to randomly rotate the stipple shapes. De-select to speed drawing when using fill 
shapes that do not require rotation, such as ovals with an aspect ratio of 1.

Use World Dimension 
Units

Select to use real-world dimensions; otherwise, the entries are made in page dimensions 
(the size the elements display when printed)

Parameter Description

Overlap Omit Clip
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Saving the Stipple Object Settings
Once the stipple object is set to the desired appearance, the settings can be saved for future use or importing into other 
files, by saving the stipple object. When inserted from the Resource Browser, all the stipple object settings are preset.
To save the selected stipple object:

1. Select a stipple object.
2. In the Object Info palette, click Save Stipple.

The Enter String dialog box opens.
3. Enter a unique name.
4. Click OK.

The stipple object is saved in the Stipples symbol folder in the Resource Browser. 
5. To use a saved stipple pattern, double-click it in the Resource Browser and begin drawing in Polyline mode. For 

more information, see “Inserting Symbols” on page 242.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Stipple Objects

Creating Linear Material Details
The Linear Material tool draws a standard representation of sheet building materials (such as plywood, gypsum 
board, and stucco) along a path. To create linear material details, either use the Linear Material tool, or draw a 
polyline and then select the Create Objects from Shapes command (see “Creating Objects from Shapes” on 
page 277).

To draw linear material details:

1. Click the Linear Material tool from the Detailing tool set.
2. If desired, set the linear material attributes in the Attributes palette (fill style, pen style, and line thickness). The 

linear material attributes can also be specified after creation.
3. Click to begin drawing the linear material detail polyline. Click the mouse at the start point to complete a closed 

polyline, or double-click the mouse to create an open polyline. For more information on polylines, see “Polyline 
Tool” on page 298.

4. The linear material parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Offset Sets the distance of the object baseline from the drawn path
Type Select the kind of linear material to draw; available parameters depend on the type of linear 

material selected
Board (generic) Creates two polyline edges; the space between the edges can be specified with a fill color 

from the Attributes palette
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Gyp. Bd. (detail) Creates a board object with an additional offset line and fills the space with a stipple pattern

Plaster/Stucco Draws an irregular top line for the object 

Plaster/Stucco 
(detail)

Draws an irregular top line for the object, and fills the space with a stipple pattern

Plywood/OSB Creates a board object with evenly spaced parallel lines

Plywood/OSB 
(detail)

Creates a plywood object with additional diagonal slashes

Built-up Roof Draws a filled band over a coarse, oval-shaped stipple pattern

Corrugated Deck Draws a zig-zag deck pattern

Corrugated Deck 
w/fill

Creates a corrugated deck and fills the depth of the deck

Corrugated Deck 
w/fill (detail)

Creates a corrugated deck, fills the depth of the deck, and adds a stipple pattern 

Thickness Specifies the thickness of the linear material
Pitch For corrugated deck details, determines the corrugation spacing
Corrugation Depth For corrugated deck details, determines the corrugation height
Closure Specifies which sections of the linear material object should have a closed end (does not apply 

to Built-up Roof details)

Parameter Description
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Linear material details with stipple patterns may require a significant amount of time to draw.
Create a plug-in symbol from a linear material object (see “Creating New Symbols” on page 239) with Convert to 
Plug-in selected. Activate the symbol in the Resource Browser to draw the linear material detail with the saved 
symbol parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Repetitive Unit Details

Creating Repetitive Unit Details
The Repetitive Unit tool draws world-scale symbols along a path, creating repetitive elements such as masonry units, 
shingles, and siding. To create repetitive unit details, either use the Repetitive Unit tool, or draw a polyline and then 
select the Create Objects from Shapes command (see “Creating Objects from Shapes” on page 277).

To draw repetitive unit details:

1. Click the Repetitive Unit tool from the Detailing tool set.
2. Click Preferences from the Tool bar to select the detail symbol. The detail symbol can also be specified after 

creation.
3. Click to begin drawing the detail polyline. Click the mouse at the start point to complete a closed polyline, or 

double-click the mouse to create an open polyline. For more information on polylines, see “Polyline Tool” on 
page 298.

4. Click Choose Symbol from the Object Info palette to select the unit to repeat.

Each unit is always drawn in its entirety; the last unit is not clipped, even if it exceeds the path drawn. The 
repetitive unit offset path is drawn in the object’s assigned pen style (the path always has a fill style of None).
The Repetitive Unit tool can create lines with custom symbols made from text and/or shapes. The Pitch 
determines the spacing; set the pen attributes from the Attributes palette.

Density For details with stipple patterns, sets the stipple density
Vertex parameters Edits the linear detail path vertices; see “Editing Vertex-Based Objects” on page 1002

Parameter Description

Pitch

Pitch point (the point that determines the symbol insertion point and rotation) 
is always placed on the baseline at the Offset distance
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The repetitive unit parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Create a plug-in symbol from a repetitive unit object (see “Creating New Symbols” on page 239) with Convert to 
Plug-in selected. Activate the symbol in the Resource Browser to draw the repetitive unit with the saved symbol 
parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Linear Material Details

Creating Chain Extrude Objects
The Chain Extrude tool automatically creates extruded objects with both continuous and repetitive elements. 
Architectural features such as an awning contain a continuous element (the awning) and intermittently repetitive 
elements (the supports). By specifying the polygon or polylines to be extruded, and then indicating the path of the 
extrusion, the object(s) are automatically extruded along the path.

Parameter Description

Offset Sets the distance of the object baseline from the drawn path; the symbol is rotated so that its 
first point (its “pitch point”) is always placed on the baseline at the offset distance

Pitch Sets the distance from the start of one unit to the start of the next unit
Use Symbol Pitch Sets the pitch according to the symbol definition; deselect to scale the pitch manually
Use Vertical Pitch Rotates the symbol 90 degrees counter-clockwise and sets the pitch vertically; this is useful 

for symbols that are to be stacked vertically rather than arrayed vertically, as they can be 
drawn in a more natural way

First Pitch Differs Allows a different pitch to be specified for the first unit
First Pitch Specifies the pitch for the first unit

Flip Vertically Flips the unit symbol vertically
Flip Horizontally Flips the unit symbol horizontally
Choose Symbol Opens the Choose Symbol dialog box. Select the unit Category, and then select the unit 

symbol from either the default content or the current file’s content (see “Resource Libraries” 
on page 219); the selected symbol is imported into the file and appears in the Resource 
Browser.

Vertex Parameters Edits the repetitive unit detail path vertices; see “Editing Vertex-Based Objects” on 
page 1002
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating the Profile Objects
Creating the Chain Extrude Object
Chain Extrude Properties

Creating the Profile Objects
The profile objects determine the shape of the chain extrude object. The profile objects can consist of up to three 
polygons/polylines or up to two polygons/polylines and one locus. For users of the Vectorworks Architect and 
Landmark products, profile objects are contained in the wall fixtures and accessories file of the [Vectorworks]\Libraries 
folder (see “Resource Libraries” on page 219).
To create the profile objects:

1. Create the continuous shape first. The Chain Extrude tool considers the first, or back, polygon/polyline to be the 
continuous shape, and extrudes it along the path polygon.

2. Create the second shape; the front object is considered to be the repeating or intermittent object.
A second shape is not required.

The reference location of the chain extrude relative to the path is the upper right or lower right corner of the 
shape’s bounding box. This location can be changed by including a locus in the profile group. The locus becomes 
the reference point for the path polygon in the profile group. This is useful if the bounding box of the repeating 
shape extends beyond the bounding box of the continuous shape.

3. Apply fill colors to the profile objects through the Attributes palette. The colors are applied to the continuous and 
repeating shapes in 3D.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating the Chain Extrude Object

Creating the Chain Extrude Object
Once the continuous and, if any, repeating shapes have been defined, specify the path for the chain extrude with the 
Chain Extrude tool.

Cornice created with chain 
extrude

Awning created with chain 
extrude

Repeating 
shape

Continuous
shape

First shape Second shape
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To create the chain extrude object:

1. Select the continuous and, if any, repeating shapes.
2. Click the Chain Extrude tool from the Building Shell tool set. 
3. Draw the chain extrude path polyline.

4. The chain extrude object is created based on the path drawn.

~~~~~~~~~~~~~~~~~~~~~~~~~
Chain Extrude Properties

Chain Extrude Properties
The chain extrude object parameters can be edited in the Object Info palette.
Click to show/hide the parameters.

Parameter Description

Draw 3D Select to display the chain extrude object in 3D view; deselect to display the object only in 2D 
view 

Flip Select to flip the orientation of the chain extrude object (for example, toward the inside of a 
room for a crown molding, instead of the outside of a building for a cornice)

Center Ribs Select to draw the repeating element centered along the edges of the path
Corner Ribs Select to draw the repeating element at the corners of the path

Click 3

Click 4

Click 1

Click 2

Double-click 
to end

In 2D, the chain extrude object is displayed with dashed single lines



Creating Holes |  1379
The placement of the repeating elements of the chain extrude object depends on the path created by the Chain Extrude 
tool. In particular, special considerations apply to the “miter zones” at the corners of the path:

• No repeating elements perpendicular to the building face will be drawn in miter zones
• The miter zones are excluded from the length calculations of the sides (for spacing calculations, for example)
• Repeating elements at corners, if drawn, bisect the angle of the corner and are elongated accordingly

The chain extrude path can be reshaped with the Reshape tool to add, subtract, and change vertices. The continuous 
and repetitive elements are automatically adjusted to fit the new shape. The path polyline can be edited by selecting 
Modify > Edit Chain Extrude, and selecting Path, or by selecting Edit or Edit Path from the context menu (see 
“Object Editing Mode” on page 1004).
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Chain Extrude Objects

Creating Holes

Drilled Holes
Both 2D and 3D drilled holes are available. The 3D drilled hole is a solid object that can be subtracted from any other 
solid object to create accurate 3D models of molds, dies, and many other machine parts (see “Converting to Generic 
Solids” on page 373).

To insert a drilled hole:

1. Click the Hole - Drilled tool or Hole - Drilled - 3D tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object’s properties and click OK.

Vertical Datum Specifies the reference point for the chain extrude object
Thickness Specifies the thickness of the repeating elements of the object
Spacing Indicates the spacing distance between the repeating elements of the object
Vertex 
parameters

Edits the chain extrude path vertices; see “Editing Vertex-Based Objects” on page 1002

Parameter Description

Miter zone

Repeating element at corner is 
elongated as necessary
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Click to show/hide the parameters.

Parameter Description

Hole Diameter Enter the hole diameter
Total Depth Enter the depth of the hole
Hole Type Select one of the hole types

Drill Point Angle For Blind Hole types, indicate the angle of the drill point at the bottom of the hole
Hole Style Select the hole style

Diameter For counterbored or countersunk hole styles, enter the diameter of the counterbore or 
countersink

Depth For counterbored hole styles, specify the depth of the counterbore
Angle (deg.) For countersunk hole styles, specify the angle of the countersink

2D 3D

C’Bore Diameter

C’Bore Depth

Hole Diameter

Total Depth Total Depth

Hole Diameter

C’Sink Diameter

C’Sink Angle

Through 
Hole

Blind 
Hole

Plain 
Hole

Counterbored 
Hole

Countersunk 
Hole
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~~~~~~~~~~~~~~~~~~~~~~~~~
Tapped Holes

Tapped Holes
Both 2D and 3D tapped holes are available. The 3D tapped hole is a solid object that can be subtracted from any other 
solid object to create accurate 3D models of molds, dies, and many other machine parts (see “Converting to Generic 
Solids” on page 373). 

To insert a tapped hole:

1. Click the desired Hole - Tapped inch or metric tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object’s properties and click OK.

Click to show/hide the parameters.

View Select the 2D view

Show Center Line Select to draw the 2D drilled hole with center line(s)

Parameter Description

Screw Thread Select the screw thread size in diameter/threads per inch (imperial) or diameter/thread pitch 
(metric)

Parameter Description

Front View Plain Hole 
Top View

Counterbore/
Countersunk Hole 
Top View

Plain Hole 
Bottom View

Counterbore/
Countersunk Hole 
Bottom View

Diameter

Tap Drill DepthThread Depth

2D 3D
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Tap Drill Size 
(Ref.)

Displays the tap drill size that corresponds to the selected screw thread

Hole Type Select one of the hole types

Thread Depth Specify the thread depth
Tap Drill Depth Enter the tap drill depth value
Drill Point Angle For Blind Hole types, enter the drill point angle
Use Custom Size Select to use custom diameter, thread pitch, and tap drill diameter values

Diameter When Use Custom Size is selected, specify the diameter value
Pitch When Use Custom Size is selected, specify the thread pitch value
Tap Drill Dia. When Use Custom Size is selected, specify the tap drill diameter value

Thread Style Select the 2D object thread style

View Select the 2D object view

Parameter Description

Through 
Hole

Blind 
Hole

Inch only

Simplified
(ISO)

DetailedSimplified
(ASME)

Front Top Bottom
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Drilled Holes

Hole Pattern

To insert a hole pattern:

1. Click the Hole Pattern tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object’s properties and click OK.
Click to show/hide the parameters.

Show Profile Only Select to show just the outline of the 2D object thread. Available when using Detailed thread 
style only.

Show Center Line Select to draw the 2D tapped hole object with center line(s)
Show Threads Select to draw the 3D tapped hole object with threads

Parameter Description

Pattern Select a hole pattern

Number of Rows For rectangular hole patterns, enter the number of rows
Vertical Spacing For rectangular hole patterns, enter the vertical spacing between the rows
Number of Columns For rectangular hole patterns, enter the number of columns
Horizontal Spacing For rectangular hole patterns, enter the horizontal spacing between the columns
Number of Holes For bolt circle patterns, enter the number of holes

Parameter Description

Detailed
thread style

Show Profile 
Only

Rectangular Bolt Circle
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Bolt Circle Dia. For bolt circle patterns, enter the diameter
Hole Type Select the type of holes

Hole Size For round and tapped hole types, enter the hole size 
Slot Width For slotted hole types, enter the slot width 
Slot Length For slotted hole types, enter the slot length 
Counterbore/
Countersunk

Select to draw counterbore or countersunk holes

Diameter Indicates the diameter of the counterbore or countersunk holes
Show Centerlines Select to display the centerlines on the pattern

View Select the hole pattern view

Parameter Description

Slotted - HorizRound Tapped Hole - ASME 
Style

Slotted - Vert

Tapped Hole - ISO Style

centerlines
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Keyways

To insert a keyway:

1. Click the Keyway tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Keys
Woodruff Keys

Parameter Description

Shaft/Bore Diameter Enter the diameter of the shaft or bore
Type of Keyway Select one of the keyway types

Key Size Standard Select inch or metric for the key size standard
Type of Key Select a square, rectangular, or woodruff key shape
Use Recommended Key Size Select to use the recommended ASME/ISO size based on the diameter and 

key type; deselect to specify custom width and height values
Key Width/Height For custom keyway sizes, enter the width and height values

Show Center Line Select to draw the keyway with center lines

Key Width

Diameter

Key Width

Diameter

Key Height / 2
Key Height / 2

Bore Keyway Shaft Keyway
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Screw Threads

To insert a screw thread:

1. Click the Screw Threads tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

Diameter Enter the thread diameter
Overall Length Specify the overall length of the screw thread
Thread Length Specify the length of the threads only
Thread Pitch Indicate the thread pitch
Fillet Radius Specify the fillet radius
Thread Style Select one of the thread display styles. For Style 1, the shoulder diameter is equal to the thread 

diameter; for Style 2, the shoulder diameter is equal to the pitch diameter.

Thread Bottom Select flat or chamfered

Thread 
Length

Overall
Length

Diameter

Simple - 1 
with Thread 

Runout

Simple - 2 Schematic - 1 
with Thread 

Runout

Schematic - 2 Detailed - 1 Detailed - 2
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Inserting Fastener Objects Using the Fastener Tool
Several types of fastener objects can be inserted by clicking the Fastener tool from the Fasteners tool set and 
specifying object parameters from the Tool bar.
The following modes are available.

Show Threads As For Simple thread styles, select dashed lines or solid lines

Show Thread 
Runout

For Simple-1 and Schematic-1 styles, select to display the thread runout

Show Center Line Select to draw the screw threads with center line(s)

Mode Description

Screw or Screw/
Washer/Nut 
Combination

Inserts a screw and nut object which can be composed of a variety of screw, washer, and/or 
nut components; hex bolts, square bolts, hex screws, cap screws, and machine screws can 
all be inserted using this tool mode

Nut Inserts a nut object, including hex, hex jam, slotted hex, and square nuts
Plain Washer Inserts a plain washer object
Lock Washer Inserts a lock washer object
Shoulder Screw Inserts a shoulder screw object
Set Screw Inserts a set screw object
2D Front View Inserts the selected item as a 2D object in front view
2D Side View Inserts the selected item as a 2D object in side view
2D Top View Inserts the selected item as a 2D object in top view
2D Bottom View Inserts the selected item as a 2D object in bottom view
3D Object Inserts the selected item as a 3D object
ASME Inch Inserts the selected object using ASME inch standards
ASME Metric Inserts the selected object using ASME metric standards
ISO Inserts the selected object using ISO standards
DIN Inserts the selected object using DIN standards
Preferences Opens the Preferences dialog box for specification of additional object parameters

Parameter Description

Dashed 
Lines

Solid 
Lines
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To insert a fastener object using the Tool bar:

1. Click the Fastener tool from the Fasteners tool set and click the desired fastener object button in the Tool bar.
2. Click the Tool bar button to insert either a 2D object in a specific view or a 3D object.

For objects that do not have bottom view (because it is the same as the top view), the top view is drawn when 
either the 2D Top View or 2D Bottom View mode is selected. The same applies to the front and side view.

3. Click the Tool bar button to insert the object using ASME (inch or metric), ISO, or DIN standards.
4. Click Preferences on the Tool bar to specify additional object parameters before placing the object in the drawing. 

Parameters vary based on the object selected for insertion, and show the available variations for a specified object 
size. Additional parameters display in the Object Info palette. Refer to the following table for detailed object 
parameter information.

5. If inserting a linear object (such as a bolt, screw, or screw and nut object), click in the drawing area to set the start 
point, drag to set the object’s length, and click again to set the object’s end point. For all other objects (such as 
washers and nuts), click in the drawing area to place the selected point object.

After placement, fastener objects can be edited in the Object Info palette.

Screw or Screw/Washer/Nut Combination Parameters

Click to show/hide the parameters.

Parameter Description

Screw or 
Screw/
Washer/Nut 
Combination

View Select the 2D view

 

Size Select the screw size (ASME inch), or the diameter/thread pitch (ASME metric, DIN, and ISO)
Configuration Opens the Configuration dialog box to select size, screw/bolt, washer, and nut type. See the 

following pages for illustrations of the available lock washers, washers, and nuts. The list of 
screw/bolt, washer, and nut types varies depending on the selected size. Not all types are available 
for all sizes.

2D 3D

Screw
Length

Bearing
Length

Size Size

Bearing 
Length (Flat 
Head)

Screw
Length

(Flat Head)

Front Side Top Bottom
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Screw / Bolt 
Type

Specify the screw/bolt type

Cap screw 
ASME inch 
and metric

Cap screw 
DIN and 
ISO

Hex bolt/
screw 
ASME inch 
and metric

Hex bolt/
screw DIN 
and ISO

Parameter Description

ASME inch only

Socket Head Flat Head 
Socket

Button 
Head 

Socket

Slotted Flat 
Head

Slotted Round 
Head

Slotted Fillister 
Head

Socket 
Head

Flat Head 
Socket

Button Head 
Socket

ISO only

ASME inch only

Hex Bolt Heavy
Hex Bolt

Finished
Hex Bolt 
(Hex Cap 

Screw)

Heavy Hex
Structural 

Bolt

Heavy Hex 
Screw

Square 
Bolt

Hex Bolt Hex ScrewHeavy 
Hex Bolt

DIN only

Flange 
Head 
Bolt

Flange 
Head Bolt 
(reduced 
shank)

ISO only

Hex Flange 
Head Screw 
(Reduced 

Shank)

Hex Flange 
Head Screw
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Machine 
screw 
ASME inch

Machine 
screw 
ASME 
metric

Machine 
screw DIN 
and ISO

Head Style
(ASME 
metric, ISO, 
and DIN only)

For cap screws (ASME metric, ISO, and DIN), specify the head style

Top/Bottom 
Lock Washer

Select to draw a top and/or bottom lock washer; several lock washer types are available

Top/Bottom 
Washer

Select to draw a top and/or bottom washer; several washer types are available

Nut Select to draw a nut. For Hex, Style 1 and Hex, Style 2 nut ISO types, specify either a regular or 
washer-face Nut Form; several nut types are available

Bearing 
Length

Specify the bearing length or click and drag the bottom bearing length control point to define the 
bearing length graphically

Parameter Description

Flat Countersunk 
Head (82 deg)

Oval 
Countersunk 

Head

Truss Head Pan Head Fillister 
Head

Round Head

Hex Head Hex Flange 
Head

Flat Countersunk 
Head

DIN only

Chamfered Rounded

Top control point

Bottom control point
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Nut Parameters

Click to show/hide the parameters.

Screw Length For a custom length value, deselect Use Standard Length Increments and enter the length under 
the screw head; alternatively, click and drag the screw length control point to define the length 
graphically

.

Thread Pitch
(ASME inch 
only)

For ASME inch sizes, specify Unified National Coarse or Unified National Fine threads

Thread Style Select the 2D thread style; see “Fastener Object Thread Styles” on page 1397
Use Standard 
Length 
Increments

Select to automatically adjust the length to the nearest increment based on size, per ASME, ISO, or 
DIN standards; deselect to enter a custom length

Adjust Screw 
Length 
Automatically

Select to automatically adjust the screw length to keep the screw threads within a nut or to prevent 
the bearing length from exceeding the screw length

Show Threads Select to create the 3D screw/bolt with threads

Draw 
Underhead 
Fillet 

Select to draw a fillet under the head of the 2D hex bolt/hex screw

Show Center 
Line

Select to draw the 2D screw and nut with center line(s)

Parameter Description

Nut

Size Select the nut size
Type Specify the nut type

Parameter Description

Screw length control point

2D 3D
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ASME inch Hex nuts

Hex jam nuts

Slotted hex nuts

Square nuts

ASME metric

ISO

 Form For Hex, Style 1 and Hex, Style 2 nut (ISO) objects, specify either a regular or washer-face 
form

DIN

View Select the 2D view

Show Center Line Select to draw the 2D nut with center line(s)

Parameter Description

Regular Heavy Thick Flat Heavy Flat Machine 
Screw

Regular Heavy Flat Heavy Flat

Regular Heavy Thick

Regular Heavy Flat Machine 
Screw

Heavy Flat

Hex, 
Type 1

Hex, 
Type 2

Hex Jam Heavy Hex Slotted Flanged

Hex, 
Style 1

Hex, 
Style 2

Thin, 
chamfered

Slotted FlangedThin, 
unchamfered

Regular Washer 
Face

Hex Hex Jam Square Square Thin Slotted Thin Slotted

Front Side Top Bottom
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Washer Parameters

Click to show/hide the parameters.

Show Hole Select to create the 3D nut with a center hole

Show Threads Select to create the 3D nut with threads

Parameter Description

Plain Washer

Type/Series Specify the plain washer type
ASME inch

ASME metric

ISO

Parameter Description

2D 3D

Type A 
Narrow

Type A 
Regular

Type A 
Wide

Type B 
Narrow

Type B 
Regular

Type B 
Wide

Narrow Regular Wide

Small Normal Large
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Screw Parameters

Click to show/hide the parameters.

DIN Type is not applicable for DIN objects

Size Select the plain washer size
View Select the 2D view

 

Show Center Line Select to draw the 2D plain washer with center line(s) 
Lock Washer

Series
(ASME inch and 
metric and ISO only)

Specify the lock washer series (not applicable for DIN objects)

Size Select the lock washer size
View Select the 2D view

Show Center Line Select to draw the 2D lock washer with center line(s) 

Parameter Description

Front Top

2D 3D

ASME inch only

Regular Heavy Extra Duty Hi-Collar

Front Side Top
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Parameter Description

Shoulder 
Screw

Size Select the shoulder screw size
Length For a custom length value, deselect Use Standard Length Increments and enter the length under 

the screw head 
Head Style 
(ISO only)

Select the head style

Thread Style Select the 2D thread style; see “Fastener Object Thread Styles” on page 1397

View Select the 2D view

 

Draw 
Underhead 
Fillet (ASME 
inch, ASME 
metric, and 
DIN only)

Select to draw a fillet under the head of the shoulder screw

Use Standard 
Length 
Increments

Select to automatically adjust the length to the nearest increment based on size, per ASME, ISO, 
or DIN standards; deselect to enter a custom length

Show Center 
Line

Select to draw the 2D shoulder screw with center line(s)

2D 3D

Length

Size

RoundedChamferedPlain

Front Top
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Show Threads Select to create the 3D shoulder screw with threads

Set Screw

Head Type Specify the set screw head type
ASME inch 
and metric

DIN and 
ISO

Point Type Specify the set screw point type
ASME inch 
and metric

DIN and 
ISO

Size Select the set screw size
Length For a custom length value, deselect Use Standard Length Increments and enter the length under 

the screw head

Parameter Description

2D 3D

Length

Size

Hex 
Socket

Spline 
Socket

Slotted Square

ASME inch only

Hex 
Socket

Slotted

Cup/Flat Full Dog Half Dog Oval Cone

ASME inch only

Dog Flat Cup Cone

ISO only

Half Dog

DIN only
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Fastener Object Thread Styles

Fastener Object Thread Styles
There are several thread types common to multiple fastener tools. The available thread types vary by the drawing 
standard being used.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Fastener Objects Using the Fastener Tool

Bolts
The following objects allow the creation and application of user-defined sizes:

Thread Pitch
(ASME inch 
only)

For ASME inch sizes, specify Unified National Coarse or Unified National Fine threads

Thread Style Select the 2D thread style; see “Fastener Object Thread Styles” on page 1397
View Select the 2D view

 

Use Standard 
Length 
Increments

Select to automatically adjust the length to the nearest increment based on size, per ASME, ISO, 
or DIN standards; deselect to enter a custom length

Show Center 
Line

Select to draw the 2D set screw with center line(s)

Show Threads Select to create the 3D set screw with threads

Parameter Description

Front Side Top Bottom

Simplified 
(ASME)

Simplified 
(ISO)

Detailed Simplified

ASME inch and ASME metric

Schematic

DIN and ISO
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See “Customizing Size Settings for Plug-in Objects” on page 1792 for instructions on establishing custom object sizes.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Fastener Objects Using the Fastener Tool
Bolts and Nuts
Carriage Bolts
Eye Bolts
J-bolts
Swing Bolts
Swing Eye Bolts
T-bolts
U-bolts

Bolts and Nuts

To insert a bolt and nut (mm or inch):

1. Click the Bolt and Nut tool from the Detailing tool set.
2. Click in the drawing area to set the start point, drag to set the object’s length, and click again to set the object’s end 

point. If this is the first time the object is placed in the drawing, an object properties dialog box opens. These 
parameters apply to subsequently created objects; they can be changed later by accessing them from the Object 
Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

• bolts and nuts • carriage bolts

• eye bolts • J-bolts

• swing bolts • swing eye bolts

• T-bolts • U-bolts

2D (inch)

Bearing Length 

2D (mm)

Bolt Length

Bearing Length 
(Square Bolt)

Bolt Length
(Square Bolt)

Bolt Size Bolt Size
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Parameter Description

Bolt Type (inch only) Select the bolt type

Nut Type (inch only) Select the nut type

Washer Type Select a washer type

Bolt Size Select the bolt size
Bearing Length Specify the bearing length or click and drag the bottom bearing length control point to 

define the bearing length graphically

Hex Bolt Square Bolt

 Hex Nut Square Nut

WideNarrow Regular

Bottom control point

Top control point
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Bolts
Inserting Fastener Objects Using the Fastener Tool

Bolt Length For a custom length value, deselect Use Standard Lengths and enter the length under 
the bearing length; alternatively, click and drag the bolt length control point to define 
the length graphically

Thread Style Select the bolt thread style

Top Washer/Top Lock 
Washer/Bottom Washer/
Bottom Lock Washer

Select to draw the bolt with top and/or bottom washers and top and/or bottom lock 
washers

Nut Select to draw the bolt with a nut
View Select the 2D view

Use Standard Lengths Select to automatically adjust the bolt length to the nearest increment based on size; 
deselect to enter a custom length

Adjust Bolt Length Select to automatically adjust the bolt length based on the bearing length
Show Center Line Select to draw the 2D bolt and nut with center line(s)

Parameter Description

Bolt length 
control point

Simplified Schematic Detailed

Front Side Top Bottom
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Carriage Bolts

To insert a carriage bolt (round head/round head square neck bolt):

1. Click the Carriage Bolt tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

View (2D only) Select the 2D view

Series Select inch or metric to display the appropriate nominal sizes
Bolt Type Select the carriage bolt type

Size Select the carriage bolt size

2D 3D

Length

Front Side Top Bottom

Round Head Round Head Short 
Square Neck

Round Head Square 
Neck

Round Head Square 
Neck with Large Head

Inch
Metric
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Inserting Fastener Objects Using the Fastener Tool
Bolts

Eye Bolts

To place an eye bolt:

1. Click the Eye Bolt tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

 

Click to show/hide the parameters.

Length For a custom length value, deselect Use Standard Length Increments and enter the 
length under the bolt head

Thread Style (2D only) Select the thread style

Use Standard Length 
Increments

Select to automatically adjust the length to the nearest increment based on size, per 
ASME standards; deselect to enter a custom length

Show Center Line (2D 
only)

Select to draw the carriage bolt with center line(s)

Parameter Description

Size Specify the eye bolt size in diameter/threads per inch (imperial) or diameter/thread pitch 
(metric)

Parameter Description

Simplified ASME Simplified ISO Schematic Detailed

2D 3D

Eye Inside 
Diameter

Length
Thread Length
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Inserting Fastener Objects Using the Fastener Tool
Bolts

Type Specify the eye bolt type

Eye Inside Dia Specify the eye bolt’s inside diameter
Length Specify the length under the bolt head
Thread Length Specify the thread length
Thread Style (2D 
only)

Select the thread style; see “Fastener Object Thread Styles” on page 1397

View (2D only) Select the 2D view

 

Show Center Line 
(2D only)

Select to draw the eye bolt with center line(s)

Show Threads (3D 
only)

Select to create the eye bolt with threads

Place Locus at 
Center

Select to draw the eye bolt with a center locus

Parameter Description

Plain Shoulder Bent

Front Side Top Bottom

Center locus
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J-bolts 

To insert a J-bolt:

1. Click the J-Bolt tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

View (2D only) Select the 2D view

 

Size Specify the J-bolt size in diameter/threads per inch (imperial) or diameter/thread pitch 
(metric)

Length Specify the bolt length
Thread Length Specify the thread length
Bend Radius Specify the radius of the bend
Anchor Length Specify the anchor length
Thread Style (2D 
only)

Select the thread style; see “Fastener Object Thread Styles” on page 1397

Bend Radius

Bearing 
Length

Anchor 
Length

2D 3D

Length

Thread
Length

Front Side Top Bottom
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Inserting Fastener Objects Using the Fastener Tool
Bolts

Swing Bolts

To insert a swing bolt:

1. Click the Swing Bolt tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Add Nut Select to draw the J-bolt with a hex or square nut; click the control point to adjust the nut 
placement graphically and click again to place the nut

Add Lock Washer / 
Washer

Select to draw the J-bolt with a lock washer and/or with a narrow, regular or wide washer

Bearing Length Specify the bearing length; if a nut or washer is added or removed, the bearing length 
remains constant and the position of the existing objects is adjusted accordingly (if the nut or 
washer is moved, the bearing length is not automatically adjusted) 

Show Threads (3D 
only)

Select to create the J-bolt with threads

Anchor to the right 
(2D only)

Select to draw the J-bolt with an anchor to the right or deselect to draw the anchor to the left

Show Center Line 
(2D only)

Select to draw the J-bolt with center line(s)

Parameter Description

Nut and washer 
control point

Right anchor Left anchor
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Click to show/hide the parameters.

Parameter Description

Size Specify the swing bolt size in diameter/threads per inch (imperial) or diameter/thread pitch 
(metric)

Head Width Specify the swing bolt head width
Shoulder Length Specify the swing bolt shoulder length
Head Thickness Specify the swing bolt head thickness
Length Specify the length under the bolt head
Thread Length Specify the thread length
Thread Style (2D 
only)

Select the thread style; see “Fastener Object Thread Styles” on page 1397

View (2D only) Select the 2D view

 

Show Center Line 
(2D only)

Select to draw the swing bolt with center line(s)

Show Threads (3D 
only)

Select to create the swing bolt with threads

2D 3D

Head 
Width

Thread Length

Shoulder Length

Length

Head 
Thickness

Front Side Top Bottom
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Inserting Fastener Objects Using the Fastener Tool
Bolts

Swing Eye Bolts

To insert a swing eye bolt:

1. Click the Swing Eye Bolt tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Place Locus at 
Center

Select to draw the swing bolt with a center locus

Parameter Description

Size Specify the swing eye bolt size in diameter/threads per inch (imperial) or diameter/thread 
pitch (metric)

Eye Inside Dia Specify the inside diameter of the eye
Outside Diameter Specify the outside diameter
Length Specify the length under the bolt head
Thread Length Specify the thread length
Thread Style (2D 
only)

Select the thread style; see “Fastener Object Thread Styles” on page 1397

Parameter Description

Center locus

Length

Eye Inside 
DiameterOutside

Diameter

2D 3D

Thread Length
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Inserting Fastener Objects Using the Fastener Tool
Bolts

T-bolts

To insert a T-bolt:

1. Click the T-Bolt tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette.

3. Specify the object properties and click OK.

View (2D only) Select the 2D view

 

Show Center Line 
(2D only)

Select to draw the swing eye bolt with center line(s)

Show Threads (3D 
only)

Select to create the swing eye bolt with threads

Place Locus at 
Center

Select to draw the swing eye bolt with a center locus

Parameter Description

Front Side Top Bottom

Center locus
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Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Fastener Objects Using the Fastener Tool
Bolts

U-bolts

To insert a U-bolt:

1. Click the U-Bolt tool from the Fasteners tool set. 

Parameter Description

Size Specify the T-bolt size in diameter/threads per inch (imperial) or diameter/
thread pitch (metric)

Head Size Specify the T-bolt head size
Head Thickness Specify the T-bolt head thickness
Length Specify the length under the bolt head
Thread Length Specify the thread length
Thread Style (2D only) Select the thread style; see “Fastener Object Thread Styles” on page 1397
View (2D only) Select the 2D view

 

Show Center Line (2D only) Select to draw the T-bolt with center line(s)
Show Threads (3D only) Select to create the T-bolt with threads

2D 3D

Length

Head Size

Thread Length

Head Thickness

Front Top Bottom
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2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 
object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

Size Specify the U-bolt size in diameter/threads per inch (imperial) or diameter/thread pitch 
(metric)

Inside Distance Specify the inside distance between the ends of the U-bolt
Length Specify the length from the inner portion of the “U” to the end of the legs
Thread Length Specify the thread length
Thread Style (2D 
only)

Select the thread style; see “Fastener Object Thread Styles” on page 1397

View (2D only) Select the 2D view

 

Show Center Line 
(2D only)

Select to draw the U-bolt with center line(s)

Place Locus at 
Center

Select to draw the U-bolt with a center locus

Show Threads (3D 
only)

Select to create the U-bolt with threads

2D 3D

Length

Inside 
Distance

Thread Length

Front Side Top Bottom

Center locus
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~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Fastener Objects Using the Fastener Tool
Bolts

Nuts

Acorn Nuts

To insert an acorn nut:

1. Click the Acorn Nut tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

Size Select the acorn nut size
Style Specify the acorn nut style

View (2D only) Select the 2D view

 

Show Center Line (2D only) Select to draw the acorn nut with center line(s)
Show Hole (3D only) Select to create the acorn nut with a center hole

2D 3D

Low Crown High Crown

Front Side Top
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~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Fastener Objects Using the Fastener Tool
Hex Cap Nuts
Knurled Thumb Nuts
Wing Nuts

Hex Cap Nuts

To insert a hex cap nut:

1. Click the Hex Cap Nut tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Fastener Objects Using the Fastener Tool
Acorn Nuts
Knurled Thumb Nuts
Wing Nuts

Parameter Description

Size Select the hex cap nut size
View (2D only) Select the 2D view

 

Show Center Line (2D only) Select to draw the hex cap nut with center line(s)
Show Center Hole (3D only) Select to create the hex cap nut with a center hole

2D 3D

Front Side Top
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Knurled Thumb Nuts

To insert a knurled thumb nut:

1. Click the Knurled Thumb Nut tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Fastener Objects Using the Fastener Tool
Acorn Nuts
Hex Cap Nuts
Wing Nuts

Wing Nuts

To insert a wing nut:

1. Click the Wing Nut (DIN) tool from the Fasteners tool set.

Parameter Description

Size For knurled thumb nut (ASME inch), specify the size/threads per inch and style. For knurled 
thumb nut (DIN) specify the size/thread pitch.

View (2D only) Select the 2D view

 

Show Detail (2D 
only)

Indicate whether to display a detailed view of the knurled thumb nut

Show Center Line 
(2D only)

Select to draw the knurled thumb nut with center line(s)

2D 3D

Front Top

Detailed view Plain view
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2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 
object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.
 

~~~~~~~~~~~~~~~~~~~~~~~~~
Wing Nuts - Type A
Wing Nuts - Type B
Wing Nuts - Type C
Wing Nuts - Type D

Wing Nuts - Type A

To insert a type A wing nut:

1. Click the Wing Nut - Type A tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

Size Select the wing nut size
View (2D only) Select the 2D view

 

Show Center Line (2D only) Select to draw the wing nut with center line(s)
Show Hole (3D only) Select to create the wing nut with a center hole

2D 3D

Front Side Top

2D 3D
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~~~~~~~~~~~~~~~~~~~~~~~~~
Wing Nuts
Wing Nuts - Type B
Wing Nuts - Type C
Wing Nuts - Type D

Wing Nuts - Type B

To insert a type B wing nut:

1. Click the Wing Nut - Type B tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.
 

Parameter Description

Size Select the wing nut size
View (2D only) Select the 2D view

 

Show Center Line (2D only) Select to draw the wing nut with center line(s)
Show Hole (3D only) Select to create the wing nut with a center hole

Parameter Description

Style Select the wing nut style

Size Select the wing nut size

Front Side Top

2D 3D

Style 1 Style 2
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~~~~~~~~~~~~~~~~~~~~~~~~~
Wing Nuts
Wing Nuts - Type A
Wing Nuts - Type C
Wing Nuts - Type D

Wing Nuts - Type C

To insert a type C wing nut:

1. Click the Wing Nut - Type C tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.
 

View (2D only) Select the 2D view

Show Center Line (2D only) Select to draw the wing nut with center line(s)
Show Hole (3D only) Select to create the wing nut with a center hole

Parameter Description

Style Select the wing nut style

Size Select the wing nut size
View (2D only) Select the 2D view

Show Center Line (2D only) Select to draw the wing nut with center line(s)

Parameter Description

Front Side Top

2D 3D

Style 1 Style 2 Style 3

Front Side Top
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~~~~~~~~~~~~~~~~~~~~~~~~~
Wing Nuts
Wing Nuts - Type A
Wing Nuts - Type B
Wing Nuts - Type D

Wing Nuts - Type D

To insert a type D wing nut:

1. Click the Wing Nut - Type D tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Wing Nuts
Wing Nuts - Type A

Show Hole (3D only) Select to create the wing nut with a center hole

Parameter Description

Style Select the wing nut style

Size Select the wing nut size
View (2D only) Select the 2D view

Show Center Line (2D only) Select to draw the wing nut with center line(s)
Show Hole (3D only) Select to create the wing nut with a center hole

Parameter Description

2D 3D

Style 1 Style 2 Style 3

Front Side Top
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Wing Nuts - Type B
Wing Nuts - Type C

Screws

Lag Screws

To insert a lag screw:

1. Click the Lag Screw tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

View (2D only) Select the 2D view

 

Series Select inch or metric to display the appropriate nominal sizes
Head Type Select the lag screw head type

Nominal Size Select an inch or metric nominal size
Length Enter the length under the screw head

2D 3D

Length

Front Side Top Bottom

Hex Square

Inch only
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~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting Fastener Objects Using the Fastener Tool
Sheet Metal Screws
Thumb Screws
Wood Screws

Sheet Metal Screws

To insert a sheet metal screw (self-tapping screw):

1. Click the Sheet Metal Screw tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Show Threads Select to create the lag screw with threads

Show Center Line 
(2D only)

Select to draw the 2D lag screw with center line(s)

Parameter Description

View (2D only) Select the 2D view

 

Parameter Description

2D 3D

LengthLength (Flat 
head)

Front Side Top Bottom
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Inserting Fastener Objects Using the Fastener Tool
Lag Screws
Thumb Screws
Wood Screws

Thumb Screws

To insert a thumb screw:

1. Click the Thumb Screw tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

Series Select inch or metric to display the appropriate nominal sizes
Head Type Select the sheet metal screw head type

Slot Type Specify the slot type

Point Type Select the sheet metal screw point type

Nominal Size Select an inch or metric nominal size
Length Enter the length under the screw head (or overall length for flat head screws)
Show Threads Select to create the sheet metal screw with threads

Show Center Line (2D 
only)

Select to draw the sheet metal screw with center line(s)

Parameter Description

Flat Oval Truss Pan Hex Hex
Washer

Regular Cross Square

A AB B

Inch only
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3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

Screw Type Specify the thumb screw type

Point Type Select the thumb screw point type

Size Select the thumb screw size
Length For a custom length value, deselect Use Standard Length Increments and enter the length 

under the screw head
Thread Style (2D 
only)

Select the thread style; see “Fastener Object Thread Styles” on page 1397

View (2D only) Select the 2D view

Use Standard 
Length Increments

Select to automatically adjust the length to the nearest increment based on size, per ASME 
standards; deselect to enter a custom length

Size

Length

2D 3D

Type A, 
Regular

Type A, 
Heavy

Type B, 
Regular

Type B, 
Heavy

Plain Cup/Flat Dog Oval Cone

Front Side Top
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Inserting Fastener Objects Using the Fastener Tool
Lag Screws
Sheet Metal Screws
Wood Screws

Wood Screws

To insert a wood screw:

1. Click the Wood Screw tool from the Detailing tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Show Center Line 
(2D only)

Select to draw the thumb screw with center line(s)

Show Threads (3D 
only)

Select to create the 3D thumb screw with threads

Parameter Description

2D 3D

LengthLength (Flat 
head)
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Inserting Fastener Objects Using the Fastener Tool
Lag Screws
Sheet Metal Screws
Thumb Screws

Parameter Description

View (2D only) Select the 2D view

Series Select inch or metric to display the appropriate nominal sizes
Head Type Select the wood screw head type

Nominal Size Select an inch or metric nominal size
Length For a custom length value, deselect Use Standard Length Increments and enter 

the length under the screw head (or overall length for flat head screws)
Slot Type Specify the slot type

Use Standard Length 
Increments

Select to automatically adjust the length to the nearest increment based on size; 
deselect to enter a custom length

Show Threads Select to create the wood screw with threads
Show Center Line (2D only) Select to draw the wood screw with center line(s)

Front Side Top Bottom

RoundFlat 
Countersunk

Oval 
Countersunk

Pan

Regular Cross Square
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Pins

Clevis Pins 

To insert a clevis pin:

1. Click the Clevis Pin tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

Size Select the clevis pin size
Use Standard Length (inch only) Select to automatically adjust the length to the recommended standard length 

per ASME standards; deselect to enter a custom length value
Pin Type (metric and DIN only) Specify the pin type for metric and DIN clevis pins

Length For a custom length value, deselect Use Standard Length (inch) or Use 
Standard Length Increments (metric and DIN) and enter the desired length

Head Style Select the head style

2D 3D

Length

Size

Metric DIN

Type B 
(with holes)

Type A 
(no holes)

Form A 
(no holes)

Form B 
(with holes)

Metric and DIN only

RoundedChamfered Headless



  1426 | Pins
Cotter Pins

To insert a cotter pin:

1. Click the Cotter Pin tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

View (2D only) Select the 2D view

Show Center Line (2D only) Select to draw the clevis pin with center line(s)
Use Standard Length Increments 
(metric and DIN only)

Select to automatically adjust the length to the nearest increment based on 
standard sizes; deselect to enter a custom length

Parameter Description

Cotter Pin Type Select square cut or hammer lock

Nominal Size Select the nominal size in inches
Grip Length Enter the grip length
Length Enter the pin length
Bend Angle (Top)/
(Bottom)

Enter a bend angle in degrees for the top and/or bottom section of the cotter pin

Parameter Description

Top Side Body EndHead End

2D 3D

Grip 
Length

Nominal Size

Length

Square Cut Bend Top Hammer Lock Bend 
Bottom
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Dowel Pins

To insert a dowel pin:

1. Click the Dowel Pin tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

View (2D only) Select the 2D view

Parameter Description

Dowel Pin Type Select the type of ANSI dowel pin

Nominal Size Select a nominal size in inches
Length Enter the pin length
View (2D only) Select the 2D view

Show Center Line (2D 
only)

Select to draw the dowel pin with center line(s)

Parameter Description

Front Left
Side

Right 
Side

Top Bottom

2D 3D

Length

Size

ANSI Hardened 
Ground Machine

ANSI Hardened Ground 
Production

ANSI Unhardened 
Ground

Side Left End Right End
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Parallel Pins

To insert a parallel pin:

1. Click the Parallel Pin tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Taper Pins

To insert a taper pin:

1. Click the Taper Pin tool from the Fasteners tool set.

Parameter Description

Size Select the parallel pin size
Pin Type Select the pin type

Length For a custom length, deselect Use Standard Length Increments and enter 
the length value

View (2D only) Select the 2D view

Show Center Line (2D only) Select to draw the parallel pin with center line(s)
Use Standard Length Increments Select to automatically adjust the length to the nearest increment based on 

DIN standard sizes; deselect to enter a custom length

2D 3D

Length

Size

Form A
(phase and head)

Form B
(phase only)

Top View End View
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2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 
object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Retaining Rings and Washers

Retaining Rings

To insert a retaining ring:

1. Click the Retaining Ring tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

Parameter Description

Size Select a taper pin size
Length For a custom length value, deselect Use Standard Length Range (inch) or Use 

Standard Length Increments (DIN) and enter the desired length
View (2D only) Select the 2D view

Show Center Line (2D 
only)

Select to draw the taper pin with center line(s)

Use Standard Length 
Range (inch only)

Select to automatically constrain the length to the standard range per ASME 
specifications; deselect to enter a length value outside of the range

Use Standard Length 
Range and Increments 
(DIN only)

Select to automatically constrain the length to the standard range per DIN specifications; 
deselect to enter a length value outside of the range

2D 3D

Length

Inch

DIN

Side View End View

Side Left End Right End
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3. Specify the object properties and click OK.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Retaining Washers

Retaining Washers

To insert a retaining washer:

1. Click the Retaining Washer tool from the Fasteners tool set.

Parameter Description

Type Select the retaining ring type
ASME

DIN

Size (mm) Select the retaining ring size in millimeters
View (2D only) Select the 2D view

Place Locus at Center Select to add a locus at the center of the retaining ring

2D 3D

Basic Internal 
Ring

Basic External 
Ring

Heavy Duty 
External

Basic 
E-Ring

Reinforced 
E-Ring

C-Ring

Bores, Regular Bores, Heavy Shafts, Regular Shafts, Heavy

Front Side-Section Side-Solid

Locus
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2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 
object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Retaining Rings

Rivets

Large Rivets

To insert a large rivet:

1. Click the Large Rivet tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Parameter Description

Groove Size (mm) Select the retaining washer groove size in millimeters
View (2D only) Select the 2D view

Place Locus at Center Select to add a locus at the center of the retaining washer

2D 3D

Front Side
Section

Side
Solid

Locus



  1432 | Rivets
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Small Rivets
Rivets (DIN)
Tubular Rivets

Small Rivets

To insert a small rivet:

1. Click the Small Rivet tool from the Fasteners tool set.

Parameter Description

Diameter Select a diameter in inches
Length Enter the length under the rivet head (or overall length for countersunk rivets)
Head Type #1 Select a head type for one end of the rivet

Head Type #2 Select a head type, if any, for the other end of the rivet
View (2D only) Select the 2D view

Show Center Line 
(2D only)

Select to draw the rivet with center line(s)

2D 3D

Length
Length 

(Countersunk 
Head)

Diameter

Button Head High Button 
Head

Cone Head Pan Head
Flat 

Countersunk 
Head

Oval 
Countersunk 

Head

Front Top
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2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 
object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Large Rivets
Rivets (DIN)
Tubular Rivets

Parameter Description

Diameter Select a diameter in inches
Length Enter the length under the rivet head (or overall length for the countersunk rivet)
Head Type #1 Select a head type for one end of the rivet

Head Type #2 Select a head type, if any, for the other end of the rivet
View (2D only) Select the 2D view

Show Center Line (2D 
only)

Select to draw the rivet with center line(s)

2D 3D

Length
Length 

(Countersunk 
Head)

Diameter

Button 
Head

Flat Head Pan Head Truss 
Head

Flat 
Countersunk 

Head

Front Top
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Rivets (DIN)

To insert a rivet (DIN):

1. Click the Rivet tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Large Rivets

Parameter Description

Diameter Select a diameter in millimeters
Length Enter the length under the rivet head (or overall length for the countersunk rivet)
Head Type #1 Select a head type for one end of the rivet

Head Type #2 Select a head type, if any, for the other end of the rivet
View (2D only) Select the 2D view

Show Center Line 
(2D only)

Select to draw the rivet with center line(s)

3D2D

Length
Length 

(Countersunk 
Head)

Diameter

Round Head Flat Round 
Head

Mushroom 
Head

Flat 
Countersunk 

Head

Front Top
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Small Rivets
Tubular Rivets

Tubular Rivets

To insert a tubular rivet:

1. Click the Tubular Rivet tool from the Fasteners tool set.
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Large Rivets
Small Rivets

Parameter Description

Size Select a size in millimeters
Length For a custom length value, deselect Use Standard Length Increments and enter the 

length
Form Select one of the rivet types

View (2D only) Select the 2D view

Show Uncompressed 
Length (2D only)

Select to display the uncompressed rivet length

Use Standard Length 
Increments

Select to automatically adjust the length to the nearest increment based on DIN standard 
sizes; deselect to enter a custom length value

Show Center Line (2D 
only)

Select to draw the rivet with center line(s)

2D 3D

Length

Uncompressed 
Length

Size

Form A Form B

Side Top
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Rivets (DIN)

Gears

Spur Gears

To insert a spur gear:

1. Click the Spur Gear tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

Pitch Diameter Specify the pitch diameter
Number of Teeth Enter the number of teeth

Hub 
Dia.

Hub - 3D
Spur Gear - 3D

Spur Gear - 2D

Center
Distance

Number of 
Holes = 6

Hole Dia.

Keyway
Width

Number of Teeth 
= 48

Keyway Height

Recess Dia.
Face Width

Pitch
Dia.

Hub Projection

Hub Corner
Radius

Recess Corner
Radius

Bore Dia.

Hub Fillet
Radius

Recess Fillet
Radius

Root
Dia.

Outside
Dia.
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Pressure Angle Enter the pressure angle

Diametrical Pitch 
(Ref.)

Displays the diametrical pitch (for reference only)

Module (mm) (Ref.) Displays the module (for reference only)
Outside Dia. (Ref.) Displays the outside diameter (for reference only)
Root Dia. (Ref.) Displays the root diameter (for reference only)
Tooth Profile Select the type of tooth profile

Face Width Enter the width of the gear face
Draw Recess (2D 
only)

To draw a recessed web, select Draw Recess and specify the 2D parameters

Web Thickness Enter the web thickness
Recess Diameter Enter the recess diameter
Recess Corner 
Radius

Specify the recess corner radius

Recess Fillet 
Radius

Indicate the recess fillet radius

Draw Hub (2D only) Select to include a hub and then specify the 2D parameters
Hub Diameter Enter the hub diameter
Hub Projection 
(Left / Right)

Specify the amount of projection for the hub on both the left and the right; a negative 
value indicates that the hub face is recessed

Hub Corner 
Radius

Enter the hub corner radius

Hub Fillet Radius Enter the hub fillet radius
Draw Bore (2D only) Select to draw a bore and then specify the 2D parameters

Bore Diameter Enter the bore diameter
Keyway If a keyway is present, select the square, rectangular, or custom size; otherwise, select 

None; the square and rectangular selections apply the ASME-recommended size based on 
the bore diameter

Parameter Description

Pitch Circle

Pressure 
Angle

Detailed - Straight Detailed - Involute Simplified - ASME Simplified - ISO
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Spur Gear Racks
Bevel Gears
Worm Gear Sets

Spur Gear Racks

To insert a spur gear rack:

1. Click the Spur Gear Rack tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

Width/Height For custom keyway sizes, enter the width and height values of the keyway
Web Configuration 
(2D only)

Select the web configuration and then specify the 2D parameters, if any. When Holes are 
selected, their size can be specified as a percentage or diameter value.

Number Indicate the number of holes or spokes for the gear (does not apply to Plain web 
configurations)

Size (10 - 100%) For Holes (Percent) and Spokes web configurations, enter the percentage of the recess 
opening occupied by the holes or spokes

Center Distance When Holes is selected for the web configuration, specify the distance between the hole 
centers

Hole Diameter When Holes is selected for the web configuration, indicate the size of the holes
View (2D only) Select the 2D view

Show Center Lines 
(2D only)

Select to draw the 2D gear with center lines 

Helix Angle (3D 
only)

Indicate the 3D spur gear helix angle

Hole Diameter (3D 
only)

Indicate the hole diameter for the 3D spur gear; when including a hub 3D object in the 
drawing, adjust the spur gear hole diameter and hub outside diameter to fit together

Parameter Description

Plain Holes Spokes

Front Side - 
Section

Side - 
Solid

Side - Solid 
with Hidden 

Lines

Back
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3. Specify the object properties and click OK.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Spur Gears
Bevel Gears
Worm Gear Sets
Worm Gears

Bevel Gears
A bevel gear set consists of a gear and pinion.

To insert a bevel gear:

1. Click the Bevel Gears tool from the Machine Components tool set. 

Parameter Description

Method Select whether to insert the spur gear rack using either a diametral pitch (for imperial 
sizes) or module (for metric sizes)

Diametral Pitch or 
Module (mm)

Specify either the diametral pitch or module, for the selected insertion method

Pressure Angle Select the pressure angle
Number of Teeth Enter the number of teeth
Thickness Enter the base thickness
Face Width Enter the width of the spur gear rack face
View (2D only) Select the 2D view

Show All Teeth Select to draw the all teeth or just the end teeth
Draw Fillet Select to draw filleted spur gear rack teeth
Show Pitch Line (2D 
only)

Select to draw the spur gear rack with a pitch line

3D2D

Pressure Angle

Circular Pitch =  / Diametral Pitch
Circular Pitch =  x Module

Face 
Width

Thickness

Front Top Side
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2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 
object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

View (2D only) Select the 2D view

Value to Use Select either Diametral Pitch or Module, and then enter the relevant parameter
Diametral Pitch Enter the diametral pitch
Module (mm) Enter the module

Shaft Angle (deg.) Enter the shaft angle in degrees
Face Width Enter the face width
Configuration Select to use the gear parameter values for only the gear, only the pinion, or for both the 

gear and the pinion; this can also be used to create miter gears

3D2D

Key Width

Key Height

Bore Size

2D

Pitch apex

Face width

Mounting distance

Recess

Fillet radii
Hub diameter

Mounting distance

Hub diameter

Pinion

Shaft angle

Top Side Front-Section Front-Solid
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Spur Gears

Gear Properties Specify the parameters to draw the gear
No. of Teeth Enter the number of teeth
Pitch Dia. (Ref.) Displays the pitch diameter based on the diametral pitch and number of teeth
Mounting Distance Enter the distance from the back of the gear to the pitch apex
Hub Diameter Enter the hub diameter
Hub Projection Enter the hub projection, for styles with a projected hub
Bore Diameter Enter the bore diameter
Key Type If the gear includes a keyway, select keyway shape (with ASME-recommended sizes), or 

select Custom size
Kwy Width/Height For custom keyway sizes, enter the keyway width and height
Recess If the gear has a recess, enter the recess value
Fillet Radius Enter the fillet radius of the hub

Pinion Properties For pinion only or gear and pinion configurations, specify the pinion parameters
No. of Teeth Enter the number of teeth
Pitch Dia. (Ref.) Displays the pitch diameter based on the diametral pitch and number of teeth
Mounting Distance Enter the distance from the back of the pinion to the pitch apex
Hub Diameter Enter the hub diameter
Hub Projection Enter the hub projection, for styles with a projected hub
Bore Diameter Enter the bore diameter
Key Type If the pinion includes a keyway, select keyway shape (with ASME-recommended sizes), 

or select Custom size
Kwy Width/Height For custom keyway sizes, enter the keyway width and height
Recess If the pinion has a recess, enter the recess value
Fillet Radius Enter the fillet radius of the hub

Show Pinion at Left 
(2D only)

Select to display the pinion on the left side of the bevel gear

Draw Center Lines 
(2D only)

Select to draw the bevel gear with center lines 

Show Teeth (3D only) Select to draw the bevel gear with teeth

Spiral Angle (Deg.) 
(3D only)

To draw a 3D spiral bevel gear, specify the spiral angle degrees for the teeth

Parameter Description
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Spur Gear Racks
Worm Gear Sets

Worm Gear Sets
Worm gear sets consist of a worm and worm gear. Create a worm gear set by following the instructions for creating 
both a worm and worm gear.

~~~~~~~~~~~~~~~~~~~~~~~~~
Worm Gears
Worms
Spur Gears
Spur Gear Racks
Bevel Gears

Worm Gears

To insert a worm gear:

1. Click the Worm Gear tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

2D 3D
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Click to show/hide the parameters.

Parameter Description

Circular Pitch Enter the circular pitch
Number of Teeth Enter the number of teeth
Pitch Diameter (Ref.) Displays the pitch diameter of the gear, based on the pitch and number of teeth
Pressure Angle (deg.) Select the pressure angle in degrees
Number of Starts (Worm) Select the number of starts of the worm
Pitch Dia (Worm) Specify the worm pitch diameter
Tooth Profile Select the type of tooth profile

Face Width Enter the width of the gear face
Draw Recess (2D only) Select Draw Recess to draw a recessed web, and specify the 2D parameters

3D

2D

Number of
Holes = 6

Keyway Width

Hole Dia.

Keyway Height
Center Dist.

Pitch Dia.

Bore Dia.

Hub Fillet Radius

Hub Corner Radius

Hub Dia.

Recess Fillet Radius

Recess Corner Radius

Hub Proj. (Left)

Face Width

Recess 
Dia.

Detailed Schematic
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Web Thickness Enter the web thickness
Recess Diameter Enter the recess diameter
Recess Corner Radius Specify the recess corner radius
Recess Fillet Radius Indicate the recess fillet radius

Draw Hub (2D only) Select to include a hub and then specify the 2D parameters
Hub Diameter Enter the hub diameter
Hub Projection 
(Left / Right)

Specify the amount of projection for the hub on both the left and the right; a negative 
value indicates that the hub face is recessed

Hub Corner Radius Enter the hub corner radius
Hub Fillet Radius Enter the hub fillet radius

Draw Bore (2D only) Select to draw a bore and then specify the 2D parameters
Bore Diameter (2D 
and 3D)

Enter the bore diameter 

Keyway If a keyway is present, select the square, rectangular, or custom size; otherwise, select 
None. The square and rectangular selections apply the ASME-recommended size 
based on the bore diameter. 

Width/Height For custom keyway sizes, enter the width and height values of the keyway
Web Configuration (2D 
only)

Select the gear configuration and then specify the 2D parameters, if any. When Holes 
are selected, their size can be specified as a percentage or diameter value.

Number Indicate the number of holes or spokes for the gear (does not apply to Plain web 
configurations)

Size (10 - 100%) For Holes (Percent) and Spokes web configurations, enter the percentage of the recess 
opening occupied by the holes or spokes

Center Distance When Holes is selected for the web configuration, specify the distance between the 
hole centers

Hole Diameter When Holes is selected for the web configuration, indicate the size of the holes

Parameter Description

Plain Holes Spokes
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Worms

Worms

To insert a worm:

1. Click the Worm tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

View (2D only) Select the 2D view

Show Center Lines (2D 
only)

Select to draw the gear with center lines 

Parameter Description

Pitch Diameter Enter the pitch diameter
Axial Pitch Enter the axial pitch
Pressure Angle 
(deg.)

Select the pressure angle in degrees

Parameter Description

Front Side - 
Section

Side - 
Solid

Side - Solid 
with Hidden 

Lines

Back

2D 3D

Face Width

Hub Proj. (Left)
Keyway Width

Keyway Height

Bore Dia.
Hub Dia.Pitch Dia.

Axial Pitch
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Worm Gears

Pulleys
The pulley object accommodates both round belts and V-belts, and up to ten grooves.

To insert a pulley:

1. Click the Pulley tool from the Machine Components tool set. 

Number of Starts Select the number of starts

Tooth Profile Select the type of tooth profile

Face Width Enter the width of the worm face
Draw Hub(s) Select to include a hub and then specify the parameters

Hub Diameter Enter the hub diameter
Hub 
Projection 
(Left/Right)

Specify the amount of projection for the hub on both the left and the right; a negative value 
indicates that the hub face is recessed

Draw Bore Select to draw a bore and then specify the parameters
Bore Diameter Enter the bore diameter
Keyway If a keyway is present, select the square, rectangular, or custom size; otherwise, select None. 

The square and rectangular selections apply the ASME-recommended size based on the 
bore diameter. 

Keyway 
Width/Height

For custom keyway sizes, enter the width and height values of the keyway

View (2D only) Select the 2D view

Show Center 
Lines (2D only)

Select to draw the worm with center lines

Parameter Description

QuadTripleDoubleSingle

Detailed Schematic

Front Right Side Left Side Side - Section Front - Section
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2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 
object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

Outside Diameter Enter the outside diameter
Groove Depth Enter the groove depth
Groove Width Enter the groove width
Groove Angle (deg.) Enter the groove angle
Groove Radius Enter the groove radius
Number of Grooves Select the number of grooves (up to ten)
Dist. to First Groove For multiple-groove pulleys, enter the distance from the left edge of the 

pulley to the center of the first groove
Distance Between Grooves For multiple-groove pulleys, enter the distance between grooves
Face Width For multiple-groove pulleys, this value is automatically calculated; for 

single-groove pulleys, enter the face width
Draw Recess (2D only) Select Draw Recess to draw a recessed web, and specify the 2D parameters

Web Thickness Enter the web thickness
Recess Diameter Enter the recess diameter
Recess Corner Radius Specify the recess corner radius
Recess Fillet Radius Specify the recess fillet radius

Draw Hub (2D only) Select to include a hub and then specify the 2D parameters
Hub Diameter Enter the hub diameter

2D 3D

Face Width

Distance Between Grooves
Groove Width

Groove Depth

Hub 
Dia.

Groove 
Radius

Outside 
Dia.

Hub Projection
Web Thickness

Bore 
Dia.

Recess 
Dia.

Groove Angle

Dist. To First Groove
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Hub Projection 
(Left / Right)

Specify the amount of projection for the hub on both the left and the right; a 
negative value indicates that the hub face is recessed

Hub Corner Radius Enter the hub corner radius
Hub Fillet Radius Enter the hub fillet radius

Draw Bore (2D only) Select to draw a bore and then specify the 2D parameters
Bore Diameter Enter the bore diameter
Keyway If a keyway is present, select the square, rectangular, or custom size; 

otherwise, select None. The square and rectangular selections apply the 
ASME-recommended size based on the bore diameter. 

Width/Height For custom keyway sizes, enter the width and height values of the keyway
Web Configuration (2D only) Select the web configuration and then specify the 2D parameters, if any. 

When Holes are selected, their size can be specified as a percentage or 
diameter value.

Number Indicate the number of holes or spokes for the sprocket (does not apply to 
Plain web configurations)

Size (10 - 100%) For Holes (Percent) and Spokes web configurations, enter the percentage of 
the recess opening occupied by the holes or spokes

Center Distance For Holes web configuration, specify the distance between the hole centers
Hole Diameter (2D and 3D) For Holes web configuration, indicate the size of the holes

View (2D only) Select the 2D view

Show Center Lines (2D only) Select to draw the pulley with center lines 
Show Root Diameter (2D only) Select to draw the pulley with a root diameter

Parameter Description

Plain Holes Spokes

Front BackSide - 
Section

Side - 
Solid

Side - Solid 
with Hidden 

Lines
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Sprockets

To insert a sprocket:

1. Click the Sprocket tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

Std. Chain No. (Pitch) Select the standard ANSI or ISO roller chain number; the pitch is given as 
reference

Number of Teeth Enter the number of teeth
Pitch Diameter (Ref.) Displays the pitch diameter based on the pitch and number of teeth
Number of Rows Enter the number of rows of teeth

2D

3D

Keyway Width

Keyway Height

Hole Diameter

Center Distance
Bore Diameter

Pitch 
Dia.

Number of 
Holes = 6 Spacing

Face Width

Recess 
Dia.

Number of Rows = 3

Hub Fillet Radius

Hub Corner Radius

Recess Fillet Radius

Recess Corner Radius

Hub Proj. (Left)

Hub Dia.
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Tooth Profile Select the type of tooth profile

Use Standard Width and 
Spacing

Select to use standard Face Width and Spacing values based on the selected 
Pitch; deselect to specify custom values and enter the values

Face Width Enter the face width value
Spacing Enter the spacing between rows of teeth

Draw Recess (2D only) Select Draw Recess to draw a recessed web, and specify the 2D parameters
Web Thickness Enter the web thickness
Recess Diameter Enter the recess diameter
Recess Corner Radius Specify the recess corner radius
Recess Fillet Radius Specify the recess fillet radius

Draw Hub (2D only) Select to include a hub and then specify the 2D parameters
Hub Diameter Enter the hub diameter
Hub Projection 
(Left / Right)

Specify the amount of projection for the hub on both the left and the right; a 
negative value indicates that the hub face is recessed

Hub Corner Radius Enter the hub corner radius
Hub Fillet Radius Enter the hub fillet radius

Draw Bore (2D only) Select to draw a bore and then specify the 2D parameters
Bore Diameter Enter the bore diameter
Keyway If a keyway is present, select the square, rectangular, or custom size; 

otherwise, select None. The square and rectangular selections apply the 
ASME-recommended size based on the bore diameter. 

Width/Height For custom keyway sizes, enter the width and height values of the keyway
Web Configuration (2D only) Select the web configuration and then specify the 2D parameters, if any. When 

Holes are selected, their size can be specified as a percentage or diameter 
value.

Number Indicate the number of holes or spokes for the sprocket (does not apply to 
Plain web configurations)

Parameter Description

Simplified Teeth Curved Teeth Schematic Representation

Plain Holes Spokes
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Roller Chains
To create a complete roller chain, it is usually necessary to combine linear and circular sections. Offset links may be 
required to connect chain sections.

~~~~~~~~~~~~~~~~~~~~~~~~~
Linear Roller Chains
Circular Roller Chains
Offset Links

Linear Roller Chains
The 2D linear roller chain is a linear object, while the 3D linear roller chain is a point object.

To insert a linear roller chain:

1. Click the Roller Chain - Linear tool from the Machine Components tool set. 

Size (10 - 100%) For Holes (Percent) and Spokes web configurations, enter the percentage of 
the recess opening occupied by the holes or spokes

Center Distance When Holes is selected for the web configuration, specify the distance 
between the hole centers

Hole Diameter (2D and 3D) When Holes is selected for the web configuration, indicate the size of the 
holes

View (2D only) Select the 2D view

Draw Center Lines (2D only) Select to draw the sprocket with center lines 

Parameter Description

Front BackSide - 
Section

Side - 
Solid

Side - Solid 
with Hidden 

Lines

Linear Roller Chain

Offset Link

Circular Roller Chain

2D 3D

Linear Roller Chain

Circular Roller Chain
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2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 
object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Circular Roller Chains
Offset Links

Circular Roller Chains

To insert a circular roller chain:

1. Click the Roller Chain - Circular tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Parameter Description

Std. Chain No. (Pitch) Select the standard ANSI or ISO roller chain number; the pitch is given as a reference
Length (2D only) Specify the length of the 2D roller chain by entering a value here or by clicking and 

dragging one of the chain control points; as the length increases, the number of links 
increases (depending on the selected pitch)

No. of Links Enter the number of links; the length automatically adjusts
Start with Pin Link Select to begin the chain section with a pin link; otherwise, the section begins with a 

roller link
Show Pins (3D only) Select to show the pins

Pin links shown

3D2D

Length

Pitch

Control 
Point
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Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Linear Roller Chains
Offset Links

Offset Links
The offset link connects a roller link and a pin link.

Parameter Description

Standard Chain No. (Pitch) Select the standard ANSI or ISO roller chain number; the pitch is given as a 
reference

No. of Teeth (Sprocket) Enter the number of teeth on the associated sprocket
Pitch Diameter (Ref.) Displays the pitch diameter, based on the pitch value and the number of teeth
Start Angle Specify the angle where the chain starts
Number of Links Enter the number of links in the chain; these will be added or subtracted from the 

end of the chain
Direction Select Clockwise or Counterclockwise

Start with Pin Link Select to begin the chain section with a pin link; otherwise, the section begins 
with a roller link

Show Pins (3D only) Select to show the pins
Place Locus at Center Select to draw the roller chain with a center locus

Pin links shown

3D2D

Start Angle

Number of 
Links = 5

Pitch

ClockwiseCounter-Clockwise 
Start with Pin Link

Center locus



  1454 | Shafts
To insert an offset link:

1. Click the Roller Chain - Offset Link tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Linear Roller Chains
Circular Roller Chains

Shafts
The Shaft tool allows the creation of a shaft consisting of multiple straight, tapered, and threaded shaft segments.

To insert a shaft segment:

1. Click the Shaft tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.
4. Click the Configuration button in the Object Info palette to add, delete, or modify shaft component segments (see 

“Shaft Segment Properties” on page 1455). 

Parameter Description

Standard Chain No. (Pitch) Select the standard ANSI or ISO roller chain number; the pitch is given as a 
reference

Show Pins (3D only) Select to show the pins

Pitch
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~~~~~~~~~~~~~~~~~~~~~~~~~
Shaft Segment Properties

Shaft Segment Properties

To add, delete, or modify component segments to construct the desired shaft object:

1. Select a shaft in the drawing file and click the Configuration button in the Object Info palette.
2. While the currently selected segment is highlighted, specify the shaft segment parameters on each tab to define the 

shaft. Click the Update button to dynamically change the preview when changes are made.
3. Click the Dimensions tab to specify the configuration of the shaft segment. 

2D shaft with five segments

Threaded Shaft
Segment with Right

Hand Acme Threads
Straight Shaft Segment

with Standard
Rectangular Keyway

Straight Shaft Segment with
Double Wrench Flats

Tapered Shaft 
Segment Right End: Radius

Dia. of Left End

Dia. of Right End

Center Drill on 
Right End

Outside Dia.

Included Angle

Thread
Pitch

Length

Width

Width 
Across 
Flats

Depth

Straight Shaft Segment
with Round Groove

Dist. From
Left End

Segment 
Length

Dist. From
Left End

Dist. From Left
End

Right End: Fillet

Left End: Plain

Length

Diameter

Center Drill on
Left End

Left End: Chamfer

3D shaft with five segments
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Center Drill on
Left End

 Diameter

Left End: Chamfer Right End: Fillet

Straight Shaft Segment with Standard 
Rectangular Keyway

Segment Length

Included 
Angle

Outside 
Diameter

Both Ends: Plain

Thread Pitch

Segment 
Length

Threaded Shaft Segment with 
Right Hand Acme Threads
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Click to show/hide the parameters.

Parameter Description

< Add / Add > Click < Add to add a shaft segment to the left of the current segment or click Add > to 
add a shaft segment to the right of the current segment

Delete Deletes the current shaft segment
< Previous / Next > Click Previous to select the shaft segment to the left of the current segment or click 

Next to select the shaft segment to the right of the current segment
Update Updates the preview image for the current segment
Segment Type Select a straight, tapered, or threaded shaft segment type

Segment Length Specify the shaft segment length
Diameter For straight or tapered segments, enter the diameter of the ends

Style For straight or tapered segments, select the end style
Chamfer Length For straight or tapered segments, specify the length for chamfer/flare ends styles
Chamfer Angle For straight or tapered segments, specify the angle value for chamfer/flare ends styles
Fillet Radius For straight or tapered segments, specify the radius value for fillet/radius end styles

Segment Length

Diameter of Right End

Center Drill on 
Right End

Right End: Radius

Tapered Shaft Segment

Left End: 
Plain

Diameter of 
Left End

Straight ThreadedTapered
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4. Click the Keyway tab to specify the configuration of the shaft segment keyway (straight Segment Type only).

Thread Type For threaded segments, select the standard inch or metric thread series, or select 
special threads to specify custom, Acme, or bearing locknut thread parameters; the 
selection in this field enables the associated thread size parameter or Special Threads 
button

Inch Sizes For standard inch series, select the thread size and threads per inch
Metric Sizes For standard metric series, select the thread size and pitch
Thread Spiral For threaded segments, select whether to draw left hand or right hand threads
Thread Taper For tapered pipe threads, select whether the taper points to the left or right

Special Threads For threaded segments, click Special Threads to specify custom, acme, or bearing 
locknut thread parameters.
• For custom threads, enter the outside diameter of threads, the thread pitch, the 

included angle of the threads, the flatness at both the top (at the outside diameter) 
and bottom (at the root diameter) of the threads, and the number of starts.

• For Acme threads, enter the outside diameter of threads, the thread pitch, and select 
the included angle of the threads.

• For bearing locknut threads, select the bearing locknut number, the thread relief 
position (if any), and select to add a keyway, if desired.

Click OK to return to the Shaft Configuration dialog box.
Left End / Right End For threaded segments, select plain or chamfered for the left and right ends
Chamfer Length For threaded segments, specify the length for chamfer end styles
Chamfer Angle For threaded segments, specify the angle value for chamfer end styles

Parameter Description

LengthDist. From Left
End

Straight Shaft Segment with 
Rectangular Keyway
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Click to show/hide the parameters.

5. Click the Groove tab to specify the configuration of the shaft segment groove (straight Segment Type only).

Click to show/hide the parameters.

Parameter Description

Add Keyway For straight segments, select Add Keyway to add a keyway to the current segment
Measure From Select to measure the position of the keyway from the left or right end
Distance Enter the distance from the end of the segment to the keyway
Key Standard Select to insert either an imperial or metric keyway 
Position Select to position the keyway in the front, top, bottom, or back of the segment
Parallel Keyway/ 
Rectangular Keyway

Select to add a rectangular or parallel keyway; specify either a standard square or 
rectangular keyway, and enter the keyway length

Woodruff Keyway Select to add a woodruff keyway and select the nominal size

Parameter Description

Add Groove For straight segments, select Add Groove to add a groove to the current segment
Measure From Select to measure the position of the groove from the left or right end
Distance Enter the distance from the end of the segment to the groove
Type Select to add a round, rectangular, or V-groove
Width Enter the groove width
Depth Enter the groove depth

WidthDist. From
Left End

Straight Shaft Segment with 
Round Groove

Depth
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6. Click the Wrench Flats tab to specify the configuration of the shaft segment wrench flats (straight Segment Type 
only).

Click to show/hide the parameters.

7. Click OK to set the shaft parameters and close the Shaft dialog box. 
8. To edit parameters, click Configuration in the Object Info palette, double-click the shaft, or select Edit from the 

context menu to open the Shaft dialog box. The following additional parameters can be modified directly in the 
Object info palette. 

Click to show/hide the parameters.

Parameter Description

Add Wrench Flats For straight segments, select Add Wrench Flats to add wrench flats to the current 
segment

Measure From Select to measure the position of the wrench flats from the left or right end
Distance Enter the distance from the end of the segment to the groove
Type Select to add single or double wrench flats
Length Enter the wrench flats length
Width Across Flats Enter the width across flats of the wrench flats

Parameter Description

Configuration Click Configuration to open the Shaft Configuration dialog box
Add Center Drill Select to draw the shaft with a center drill. Select either a plain or bell configuration 

for the center drill, select the size, and whether a center drill is drawn on the left, right, 
or both ends of the shaft.

Width 
Across Flats

Dist. From Left
End

Straight Shaft Segment with Double 
Wrench Flats

Length
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Shafts
Shaft Break 2
Shaft Break

Keys

To insert a key:

1. Click the Key tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Show Threads As Select how to draw the 2D threaded shaft threads

Show Center Line Select to draw the 2D shaft with center line(s) 
Show Threads Select to draw the 3D shaft with threads
Create Solid Select to create a generic solid from the individual 3D segments. For large, complex 

shafts, this will greatly reduce file size. Deselect this option when editing the shaft to 
speed the editing process.

Parameter Description

Standard Select Imperial or Metric
Nom. Size (in) or (mm) Select one of the standard key sizes
Length Enter the key length

Parameter Description

Simplified (ASME) Simplified (ISO) DetailedSchematic

2D 3D

Length

Height

Width
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Woodruff Keys
Keyways

Woodruff Keys

To insert a woodruff key:

1. Click the Woodruff Key tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette.

3. Specify the object properties and click OK.

Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Keys

View (2D only) Select the 2D view

Parameter Description

Standard Select Imperial or Metric
Nom. Size (in) or (mm) Select one of the standard key sizes
Key Type Select the key type

Depth of Keyseat (shaft)/Depth of 
Keyseat (hub)

Displays the depth of the keyseat shaft and hub, determined by the 
standard size selected

View (2D only) Select the 2D view

Parameter Description

Top Front Side

2D 3D

Full Radius Flat Bottom

Front Top Side
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Keyways

Bearings

Ball Bearings

To insert a ball bearing:

1. Click the Ball Bearing tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

Bearing Type Select from a variety of single ball or double ball radial and angular bearings
Single Row, Radial

Single Row, Angular

2D 3D 
(Section with rollers 
highlighted in black)

Width

Outside DiameterInside Diameter

Non-Filling 
Slot (BC)

Non-Separable 
(BH)

Separable 
(BM)

Four Point

Non-Separable 
(BN)

Separable 
Outer Ring 

(BNS)

Separable 
Inner Ring 

(BAS)
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Roller Bearings

To insert a roller bearing:

1. Click the Roller Bearing tool from the Machine Components tool set. 

Double Row, Radial

Double Row, 
Angular

Inside Diameter Specify the inside diameter of the bearing
Outside Diameter Specify the outside diameter of the bearing
Width Enter the width of the bearing
View (2D only) Select the 2D view

Show Detail (2D only) Indicate whether to display a detailed 2D view of the bearing

Show Center Line (2D 
only)

Select to draw the bearing with center lines

Section (3D only) Select to display a section of the bearing
Highlight Rollers (3D 
only)

Select to highlight the rollers within the bearing in black

Parameter Description

Non-Filling 
(BK)

Non-Separable 
(BHA)

Non-Filling, 
Slot 

Vert Out (BG)

Non-Filling, 
Slot 

Vert In (BJ)

Non-Separable 
(BAA)

Separable 
(BVV)

Front Section Assembly Rear

Detailed
view Plain view
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2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 
object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

Bearing Type Select from a variety of bearing types
Single Row, Separable

Single Row

2D 3D
(Section with rollers 
highlighted in black)

Outside 
Diameter

Inside 
Diameter

Width

Double Ribs - Inner
Double Ribs - Outer, 

Outer Ring Separable

Double Ribs - Inner
Double Ribs - Outer, 
Inner Ring Separable

Double Ribs - Inner/ 
No Ribs - Outer

No Ribs - Inner/Double 
Ribs - Outer

Double Ribs - Inner/ 
One Rib - Outer

One Rib - Inner/ 
Double Rib - Outer
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Single Row, Self 
Aligning

Double Row

Double Row, 
Self-Aligning

Inside Diameter Specify the inside diameter of the bearing
Outside Diameter Specify the outside diameter of the bearing
Width Enter the width of the bearing
View (2D only) Select the 2D view

Show Detail (2D only) Indicate whether to display a detailed 2D view of the bearing

Show Center Line (2D only) Select to draw the bearing with center lines 
Section (3D only) Select to display a section of the bearing

Parameter Description

Self-Aligning, 
Outer Ring

Self-Aligning, 
Inner Ring

Double Ribs - Inner/ 
Double Ribs - Outer

Double Ribs - Inner/ 
No Ribs - Outer

No Ribs - Inner/ 
Double Ribs - Outer

Self-Aligning, 
Outer Ring

Self-Aligning, 
Inner Ring

Front Section Assembly Rear

Detailed
view Plain view
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Tapered Roller Bearings

To insert a tapered roller bearing:

1. Click the Tapered Roller Bearing tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Highlight Rollers (3D only) Select to highlight the rollers within the bearing in black
Parameter Description

Two row, double cup, single cone (2D) Section with rollers highlighted in black, 
and a retainer (3D)

Single Row (2D) Two row, double cone, single cups (2D)

Inside 
Diameter

Inner Ring 
Projection

Inner Ring
Width

Outside
Diameter

Outside
Diameter

Inside 
Diameter

Outer Ring 
Width

Inner Ring
Width

Space Between Rows

Outer Ring 
Width

Inner Ring 
Width Inner Ring 

Projection

Outer Ring 
Width

Inner Ring 
Projection

Space Between Rows

Outside
Diameter Inside 

Diameter
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Parameter Description

Bearing Type Select from a variety of bearing types

Inside Diameter Specify the inside diameter of the bearing
Outside Diameter Specify the outside diameter of the bearing
Width of Inner Ring Enter the width of the inner ring
Width of Outer Ring Enter the width of the outer ring
Space Between 
Rows

Enter the space between rows

Inner Ring 
Projection

Specify the projection distance of the inner ring

View (2D only) Select the 2D view

Show Retainers Select to display the bearing with retainers; Show Detail must also be selected in order to 
view the retainers in 2D bearings

Show Detail (2D 
only)

Indicate whether to display a detailed 2D view of the bearing (including balls and/or 
retainers)

Show Center Line 
(2D only)

Select to draw the bearing with center lines 

Section (3D only) Select to display a section of the bearing
Highlight Rollers 
(3D only)

Select to highlight the rollers within the bearing in black

Single Row Two Row, Double Cone 
Single Cup

Two Row, Double Cup Single 
Cone, Adjustable

Two Row, Double Cup 
Single Cone, 

Non-Adjustable

Front Section Assembly Rear

Detailed view with
retainers

Plain view
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Needle Bearings

To insert a needle bearing:

1. Click the Needle Bearing tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

Bearing Type Select one of the bearing types

Inside Diameter Specify the inside diameter of the bearing
Outside Diameter Specify the outside diameter of the bearing
Width Enter the width of the outer ring
Number of Rows Enter the number of bearing rows
View (2D Only) Select the 2D view

2D 3D
(Section with rollers highlighted in black)

Outside 
Diameter

Inside 
Diameter

Number of
Rows = 1

Width

No Ribs-
Inner/Double
Ribs - Outer

Double Ribs-
Inner/No

Ribs - Outer

Front Section Assembly Rear
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Thrust Bearings

To insert a thrust bearing:

1. Click the Thrust Bearing tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Show Inner Ring Select to display the bearing inner ring
Show Detail (2D Only) Indicate whether to display a detailed 2D view of the bearing
Show Center Line (2D Only) Select to draw the bearing with center lines 
Section (3D Only) Select to display a section of the bearing
Highlight Rollers (3D Only) Select to highlight the rollers within the bearing in black

Parameter Description

Bearing Type Select one of the bearing 
types

Raceway Style
(Single Ball, Double Ball, and 
Cylindrical Roller types only)

Choose either grooved or 
flat

Inside Diameter Specify the inside diameter of the bearing
Outside Diameter Specify the outside diameter of the bearing
Thickness Enter the width of the outer ring

Parameter Description

2D 3D
(Section with rollers highlighted in black)

Outside Diameter

Inside Diameter

Thickness

Single Ball 
Grooved

Double Ball Flat Cylindrical Roller 
Flat

Tapered Roller 
Grooved

Spherical Roller 
Grooved
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Flanged Bearings: 2 Hole

To insert a flanged bearing - 2 hole:

1. Click the Flanged Bearing - 2 Hole tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

View (2D Only) Select the 2D view

Show Retainer(s) Select to display the bearing retainer(s); Show Detail must also be selected to 
view the retainer(s) in 2D bearings

Show Detail (2D Only) Indicate whether to display a detailed view of the 2D bearing (including balls)
Show Center Line (2D Only) Select to draw the bearing with center lines
Section (3D Only) Select to display a section of the bearing
Highlight Rollers (3D Only) Select to highlight the rollers within the bearing in black

Parameter Description

Nominal Size Select one of the common flanged bearing sizes; the associated parameters are displayed 
in the Object Info palette

Parameter Description

Top Section Assembly

Collar Diameter

Base Width

Bore Size

Hole 
Centers

Base 
Length

Hole Size

Housing 
Diameter

Overall Thickness
Housing Thickness
Base Thickness

2D 3D
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Use Custom 
Dimensions

Select to apply custom parameter modifications

Bore Size Indicate the bore diameter
Collar Diameter Specify the diameter of the bearing collar
Housing Diameter Indicate the diameter of the housing
Base Width Specify the width of the base
Base Length Specify the length of the base
Hole Centers Indicate the distance between the hole centers
Hole Size Indicate the diameter of the mounting holes
Base Thickness Specify the width of the bearing base
Housing Thickness Enter the housing thickness
Overall Thickness Specify the width of the bearing from the top of the collar to the bottom of the base
Set Screw Size Indicate the size of the locking set screws

View (2D Only) Select the 2D view

Show Set Screws Select to display the set screws

Show Grease Fitting Select to display the grease fitting

Parameter Description

Top Side Front

Set screws

Grease fitting
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Flanged Bearings: 4 Hole

Flanged Bearings: 4 Hole

To insert a flanged bearing - 4 hole:

1. Click the Flanged Bearing - 4 Hole tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Show Center Lines and 
Hidden Lines (2D 
Only)

Select to draw the bearing with center lines and hidden lines 

Parameter Description

Nominal Size Select one of the common flanged bearing sizes; the associated parameters are 
displayed in the Object Info palette 

Use Custom Dimensions Select to apply custom parameter modifications
Bore Size Indicate the bore diameter
Collar Diameter Specify the diameter of the bearing collar
Housing Diameter Indicate the diameter of the housing

Parameter Description

Center lines Hidden lines

Base
Size
(Sq)

Hole
Center

(Sq)

Collar Diameter

Housing 
Diameter

Bore Size
Housing Thickness
Base Thickness

Hole Size

2D 3D
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Flanged Bearings: 2 Hole

Base Size (Sq.) Specify the dimensions of the bearing base
Hole Centers (Sq.) Indicate the distance between the mounting hole centers
Hole Size Indicate the diameter of the mounting holes
Base Thickness Specify the width of the bearing base
Housing Thickness Enter the housing thickness
Overall Thickness Specify the width of the bearing from the top of the collar to the bottom of the base
Set Screw Size Indicate the size of the locking set screws

View (2D Only) Select the 2D view

Show Set Screws Select to display the set screws

Show Grease Fitting Select to display the grease fitting

Show Center Lines and 
Hidden Lines (2D Only)

Select to draw the bearing with center lines and hidden lines

Parameter Description

Top Side

Set screws

Grease fitting

Center lines Hidden lines
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Pillow Block Bearings

To insert a pillow block bearing:

1. Click the Pillow Block tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

Size Select one of the common pillow block bearing sizes; the associated parameter 
values are displayed in the Object Info palette

Use Custom Dimensions Select to change any parameter values
Bore Size Indicate the bore diameter
Center Distance Indicate the length from the center of the bore to the bottom of the base
Housing Width Enter the width of the housing
Base Length Specify the length of the base
Base Thickness Specify the thickness of the base
Hole Centers Specify the distance between the hole centers
Slot Width Indicate the width of the slots
Slot Length Indicate the length of the slots
Base Width Specify the width of the block base

Hole Center

Collar 
Diameter

Collar 
Width

Base 
WidthSlot Width

Slot Length

Housing Width
Bore 
Size

Center Distance

Base ThicknessBase 
Length

2D 3D
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Bearing Lock Nut

To insert a bearing lock nut:

1. Click the Bearing Lock Nut tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Collar Width Enter the width of the collar
Collar Diameter Enter the diameter of the collar
Set Screw Size Indicate the size of the locking set screws

View (2D Only) Select the 2D view

Show Set Screws Select to display the set screws

Show Grease Fitting Select to display the grease fitting

Show Center Lines and 
Hidden Lines (2D Only)

Select to draw the 2D bearing with center lines and hidden lines

 

Parameter Description

Top Side Front

Set screws

Grease fitting

Center lines

Hidden lines
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Click to show/hide the parameters.

Springs

Belleville Springs

To insert a belleville spring:

1. Click the Belleville Spring tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Parameter Description

Size Select the bearing lock nut size
View (2D Only) Select the 2D view

Show Washer Select to display a washer with the bearing lock nut. By default, the washer is displayed. 
The side view does not display a washer.

Show Center Line 
(2D Only)

Select to draw the 2D bearing lock nut with center lines

2D 3D

Section Side Front RearAssembly

Center lines
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Click to show/hide the parameters.

Parameter Description

Inside Diameter Specify the inside diameter of the Belleville spring
Outside Diameter Specify the outside diameter of the Belleville spring
Thickness Enter the wire thickness
Height Enter the height of each spring section
Height is Indicate whether the Height value applies to the Inside or Outside of the spring
Number of Springs Specify the number of springs
Configuration Select the spring configuration

Number Down / 
Number Up (Alternate 
only)

For Alternate Down and Up spring configurations, enter the number of springs which 
are oriented up and the number of springs which are oriented down

Draw First Spring Up
(Alternate only)

For Alternate Down and Up spring configurations, select to draw the first spring section 
oriented up

2D 3D

Outside Dia.

Inside Dia.

Outside Height

Inside Height

Thickness

Same Direction Alternate Down and Up
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Compression Springs 1 and 2

To insert a compression spring 1:

To insert a compression spring 2:

1. Click the Compression Spring 1 or Compression Spring 2 tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

View (2D Only) Select the 2D view

Draw Center Line (2D 
Only)

Select to draw the 2D spring with center line(s)

Parameter Description

Top - Spring Down Top - Spring Up Top - Simple

Side Section Side Solid Side Simple

Compression Spring 1 parameters (2D) 3D Compression Spring 2 parameters (2D) 3D

Outside Dia.
Wire Dia.

Working 
Length

Solid 
Height

Number of
Active Coils

= 7

Wire Dia. Mean Dia.

Working 
Length
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A utility calculates spring rates for compression springs (see “Spring Calculator” on page 1824).
To simulate the appearance of a spring wound around an object (such as a shaft or screw), use two springs. Set the front 
spring’s display parameter to Solid - Front Coils Only. The spring behind the object is set to Solid - Rear Coils Only. 
Adjust the objects’ relative position with the Modify > Send > Send to Front and Modify > Send > Send to Rear 
commands until the object displays correctly.

Parameter Description

Type of Ends Specify the spring end style

Outside Diameter For Compression Spring 1, enter the outside diameter
Mean Diameter For Compression Spring 2, enter the mean diameter
Wire Diameter Enter the wire diameter
Solid Height For Compression Spring 1, enter the solid height (compressed height)
Number of Active Coils For Compression Spring 2, specify the number of active coils
Working Length Either specify the spring working length value, or click and drag a spring control point 

to define the length graphically

Spiral Select either a Left Hand or Right Hand spiral direction
Display (2D Only) Select a display mode for 2D springs

Draw Center Line (2D 
Only)

Select to draw the spring with center line(s)

Closed and 
Ground

Open and 
Ground

Closed Open

Control point

Solid Section Solid - Front 
Coils Only

Solid - Rear 
Coils Only

Simple
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Conical Compression Springs

Conical Compression Springs

To insert a conical compression spring:

1. Click the Conical Compression Spring tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. Conical compression springs 

have ends of unequal diameter. When drawing a conical compression spring, the first click defines the large end of 
the spring, and the second click defines the small end.
If this is the first time the object is placed in the drawing, an object properties dialog box opens. These parameters 
apply to subsequently created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Parameter Description

Display (2D Only) Select a display mode for 2D springs

 

Wire Diameter Enter the wire diameter (thickness)
OD - Small End Specify the outer diameter of the small end of the spring
OD - Large End Specify the outer diameter of the large end of the spring
No of Active Coils Specify the number of active coils in the spring

2D 3D

Wire 
Dia.

Working 
Length

O D - Small End

O D - Large 
End

Solid Section Front Coils 
Only

Rear Coils 
Only

Simple
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Compression Springs 1 and 2

Die Springs
Die springs are made of rectangular wire.

To insert a die spring:

1. Click the Die Spring tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Working Length Either specify the spring working length value, or click and drag a spring control point 
to define the length graphically

Spiral Select either a Left Hand or Right Hand spiral direction
Draw Center Line (2D 
Only)

Select to draw the spring with center line(s)

Parameter Description

Fits into Hole The spring will be able to fit into a hole of this diameter

Parameter Description

Control point

2D 3D

Wire Width
Wire Height

Working 
Length

Fits over Shaft
Fits into Hole
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Extension Springs: Front View and 3D
In front view and 3D, two modes are available.

To insert an extension spring - front view:

1. Click the Extension Spring - Front View tool or the Extension Spring - 3D tool from the Machine Components 
tool set. 

2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 
object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Fits over Shaft The spring will be able to fit over a shaft of this diameter
Wire Width Specify the width of the wire
Wire Height Enter the height of the wire 
Solid Height Enter the height of the spring at maximum compression 
Working 
Length

Either specify the spring working length value, or click and drag a spring control point to define 
the length graphically

Spiral Select either a Left Hand or Right Hand spiral direction
Display (2D 
Only)

Select a display mode for 2D springs

Draw Center 
Line (2D Only)

Select to draw the spring with center line(s)

Mode Description

Constrained Line Lines are drawn at 30°, 45°, and 90° angles, and their complements are drawn in 
increments of 30° and 45°

Unconstrained Line Lines can be drawn at any angle; press the Shift key to temporarily constrain a line 
during drawing

Parameter Description

Control point

Solid Section Front Coils 
Only

Rear Coils Only Simple

Constrained Line Unconstrained Line
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Click to show/hide the parameters.

Parameter Description

Outside Diameter Specify the outside diameter of the coiled section of the spring
Wire Diameter Enter the wire diameter
Free Length Length of spring when not extended (no force is applied)
Working Length Either specify the spring working length value, or click and drag a spring control point to 

define the length graphically

End Style Select a style for the ends of the 
spring

Hook Length Enter the length of the hook from the 
spring end to the top of the hook

Hooks at Right 
Angles (3D only)

Select the create the 3D hooks at a 
right angle to each other

Spiral Select either a Left Hand or Right 
Hand spiral direction

View (Front Only) Select the 2D hook’s view

Free Length = 4

Free Length = 4
Working Length = 5

Free Length = 5
Working Length = 5

Working Length

Hook Length

Outside
Diameter

Wire Diameter

2D 3D

Control point

Full Loop
Hooks at Right Angles

Full Round Hook
Front View of Hooks

Machine Loop
Edge View of Hooks

Machine Hook
Front View of Hooks

Raised Hook
Front View of Hooks

Rectangular Hook
Front View of Hooks

V Hook
Front View of Hooks

3D Long Round
Hooks at Right Angles
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Extension Springs: End View

To insert an extension spring - end view:

1. Click the Extension Spring - End View tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

Click to show/hide the parameters.

Display (Front 
Only)

Select a display mode for the 2D spring

Set Free Length to 
Working Length 
(Front only)

Select to force the spring’s Free Length value to equal the Working Length value; this 
shows the coils tightly wound at any working length

Show All Coils 
(Front only)

Select to draw all of the spring’s coils

Draw Center Line 
(Front only)

Select to draw the spring with center line(s)

Parameter Description

Wire Diameter Enter the wire diameter
Outside Diameter Specify the outside diameter of the coiled section of the spring

Parameter Description

Solid Section Back Coils 
Only

SimpleFront Coils 
Only

Outside 
Diameter

Wire 
Diameter



  1486 | Springs
Torsion Springs: Front View

To insert a torsion spring - front view:

1. Click the Torsion Spring - Front View tool from the Machine Components tool set. 
2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 

object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

In the Object Info palette, set the torsion spring properties (Outside Diameter, Wire Diameter, Number of Active 
Coils, and Spiral), and then set the properties for each end of the spring.
Click to show/hide the parameters.

Ends at Right Angles Indicate whether the spring ends are displayed at right angles to each other

Spiral Select either a Left Hand or Right Hand spiral direction
Draw Center Lines Select to draw the spring with center lines

Parameter Description

Outside Diameter Specify the outside diameter of the coiled section of the torsion spring
Wire Diameter Enter the wire diameter
Number of Active Coils Specify the number of active coils in the spring
Left/Right End Select to enter the dimensions for left and/or right end
Length For each end, specify the length between the coil center and the end

Parameter Description

Ends not at right 
angles

Ends at right 
angles

Length of Left 
End

Number of Active 
Coils = 8

Wire Dia.

Length of 
Right End

Outside Dia.
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Torsion Springs: End View and 3D

To insert a torsion spring - end view:

1. Click the Torsion Spring - End View tool or the Torsion Spring - 3D tool from the Machine Components tool 
set. 

2. Click to place the object in the drawing, and click again to set the object’s rotation. If this is the first time the 
object is placed in the drawing, an object properties dialog box opens. These parameters apply to subsequently 
created objects; they can be changed later by accessing them from the Object Info palette. 

3. Specify the object properties and click OK.

In the Object Info palette, set the torsion spring properties (Wire Diameter, Outside Diameter, and Spiral), and then 
set the properties for each end of the spring.
Click to show/hide the parameters.

Direction Indicate whether each end 
is facing up or down

Orientation Select forward, rearward, 
or normal for each end

Spiral Select either a Left Hand or Right Hand spiral direction

Parameter Description

Wire 
Diameter

Enter the wire diameter 

Outside 
Diameter

Specify the outside diameter of the coiled section of the torsion spring

Parameter Description

Up-Normal Up-Facing 
Forward

Up-Facing 
Rearward

Down-Normal Down-Facing 
Forward

Down-Facing 
Rearward

2D 3D

Bend Length
Length End #1 Deflection 

= 30°

End #2
Deflection = 270°

Bend LengthOutside Dia.

Length

Wire Dia.
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Number of 
Active Coils 
(3D only)

Specify the number of active coils in the coiled section of the 3D torsion spring

End # 1/2 Select to enter the dimensions for End #1 and/or End #2
Length For each end, specify the length between the coil center and the bend
Deflection Enter the deflection angle for each end
End Style Select a style for each end (specify a clockwise (CW) or counterclockwise (CCW) direction)

Bend Radius For each end, specify the radius value of the bend (does not apply to Plain End Styles)
Bend Length For each end, specify the length between the bend and the wire end (does not apply to Plain or 

Full Loop End Styles)
Spiral Select either a Left Hand or Right Hand spiral direction

Parameter Description

Plain 1/4 Bend 1/2 Bend 3/4 Bend Full Loop



Solar Studies
The Heliodon tool, available in the Vectorworks Design Series, places one or more special directional lights in a 
drawing for conducting sun studies, calculating shadow angles, and creating solar animations. The tool demonstrates 
the location of sunlight and shadows cast on the model as the sun’s position changes, for any day of the year and any 
location on earth. Accurate region/city information is used for the calculations. Vertical and horizontal shadow angles 
can be automatically calculated for determining the correct placement of shading devices, such as awnings. When 
combined with a physical sky background, the heliodon can create natural lighting that responds to the sun position and 
time of day. Additionally, an area of a drawing, such as a window or a portion of a large model, can be studied to 
determine when (or if) sunshine will affect it. Solar animations can be generated on screen or by exporting to a movie 
file.

To show shadows, the Renderworks product is required; to show soft shadows, a Renderworks render mode is 
required.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting a Heliodon Object
Creating Solar Animations
Calculating Shadow Angles

Inserting a Heliodon Object

To insert a heliodon:

1. Click the Heliodon tool from the Visualization tool set.
If this is the first time a heliodon has been placed on the drawing, the Settings dialog box opens when placing the 
object. Specify the preferences to use for this tool during this session. (Otherwise, click Preferences from the Tool 
bar to specify or change the tool parameters.)

Click to show/hide the parameters.

Parameter Description

Time Display Select the method of time display; Samples shows the time as it is currently formatted
12/24 Hour Select whether to display the time in 12-hour or 24-hour time format; in 12-hour format, 

the date automatically displays as Month/Day, and in 24-hour format, the date 
automatically displays as Day/Month

Colon/Dot Sets the time to display with a colon or dot between the hour and minute
2D Graphic Select a heliodon symbol from the default content; default content is automatically 

imported into the current file at the point of use and displays in the Resource Browser; see 
“Resource Libraries” on page 219

Location Locations are derived from text files that can be found in the heliodon cities file in the 
[Vectorworks]\Libraries folder (see “Resource Libraries” on page 219).
Region text files with city, longitude, and latitude information can be added to the current 
set of files, or the information can be edited from this dialog box. Once a region has been 
selected, the corresponding text file is saved to the user folder; see “User Folders 
Preferences” on page 57.

Region Select the region from among the major regions of the world, or click Add New Region 
from the bottom of the Region list, to create a new region

City Select a major city from within the specified region

http://www.youtube.com/watch?v=-i9HjriDhHI
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2. Click OK. 
3. Click once in the drawing to set the object’s position. Click again to set the object’s rotation.

The heliodon graphic displays true North at the top of the heliodon. Normally, the drawing is oriented to page 
North (true North, not magnetic North), and true North matches the top of the page, with no compensation 
required for proper sun position. If the drawing was not created with this orientation, use the Object Info palette to 
specify a Rotation in degrees from page North. North set here should match true North in the drawing.
The white arrows represent the sunlight direction at the current time of day and the designated location. The 
gradient highlight shows the approximate position of the sun in the sky dome.

4. Edit the properties of the heliodon in the Object Info palette, as needed.
Click to show/hide the parameters.

Edit City If you have different information for the currently selected city, its information can be 
edited; new cities can also be added to the current region. Any edits are saved to the user 
folder.

City If updating the currently selected city, do not edit the city name; if adding a city, enter the 
new city name 

Latitude/Longitude Specifies the city’s global coordinates
North/South/East/
West

Sets the latitude (North/South) and longitude (East/West) hemispheres

Time Zone Select the city’s time zone based on Greenwich Mean Time (GMT)
Add Adds the new city to the selected region; the new city must have a unique name
Update Updates the information of the selected city
Delete Deletes the city from the selected region

Parameter Description

Settings Opens the Settings dialog box, to specify the heliodon parameters
Heliodon data Displays the location, position, and time zone set for the heliodon
Show Solar Data Displays solar information for the heliodon in the Object Info palette; select a Text 

Display option which includes “Data” to include the solar data in the heliodon text label
Daylight Savings Select if Daylight Saving Time is in effect
Use Solar Time Overrides the local time zone and daylight savings settings, using apparent solar time 

instead of mean solar time. When solar time is used, Daylight Saving Time cannot also be 
in effect.

Parameter Description

Label control point

Direction of sun’s rays

Approximate location of
sun in sky dome

True North
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Time/Day/Month Specify the time of day, the day of the month, and the month, or select a winter or summer 
solstice or spring or autumn equinox from the Month list.
The Time can also be specified as sunrise, dawn, midday, noon, dusk, sunset, or midnight.

Sun Brightness Sets the brightness of the directional light representing the sun
Renderworks Only Renderworks is required for the four next parameters

Soft Shadows Creates soft shadows when rendering shadows with a Renderworks mode 
Physical Sun Creates a physical sun with color and brightness that is controlled by the heliodon settings 

(when rendering with a Renderworks mode); deselect the option to use a white directional 
light, set to 100% brightness

Physical Sky Allows the heliodon settings, such as date, time, and use of warm colors, to control a 
physical sky Renderworks background, when one is applied (see “Creating Physical Sky 
Backgrounds” on page 1526). This creates more realistic solar animations, because the sky 
reflects the time of day and month of the year as the animation proceeds.

Deselect this option to view the physical sky with bright, midday settings.
Warm Colors Adds a rosier, richer appearance to physical sun and sky colors

Show Shadow Angle 
Calculator

Displays additional options for calculating shadow angles for selected walls

Object Display Select how to display the heliodon object in 2D and 3D views; the heliodon symbol is a 2D 
graphic.

• 2D Graphic + 3D Light: Displays as a 2D graphic in Top/Plan view and as a light in 
3D views

• 2D Graphic Only: Displays as a planar graphic in all views
• 3D Light Only: Displays as a light object; does not use a 2D graphic.

Parameter Description

July 13, 6:00 am July 13, 3:00 pm July 13, 8:30 pm

Warm Colors selected Warm Colors deselected
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Once placed, a heliodon symbol is added to the drawing file and is listed in the Resource Browser in the Heliodon 
Symbols folder. Edit the 2D component of the symbol as described in “Editing Symbol Definitions” on page 247 to 
change the appearance or the font style or size.
Heliodon objects display in, and can be controlled from, the Visualization palette. They can be identified by their 
location and time data.

Place several heliodon objects in the drawing, set to different times of day, to conduct a solar study. Turn the 
heliodon objects on and off in the Visualization palette to study the effects of the sun’s light and shadows cast at 
different times of day.

~~~~~~~~~~~~~~~~~~~~~~~~~
Solar Studies
Creating Solar Animations
Managing Lights and Cameras with the Visualization Palette
Calculating Shadow Angles
Creating Physical Sky Backgrounds

Creating Solar Animations
A solar animation illustrates the way the sun moves over, or shadows are cast upon, a project as the sun’s position 
changes. It studies how the sun affects a model or site at a particular time of day or year. The animation can be set to 
rotate the sun about the model, or the model can rotate about the layer plane center or heliodon object.
Solar animations can be interactive, observing the effects in the drawing as changes are made. To interactively view 
changes as you move the sliders, render in Wireframe or OpenGL render mode. The solar animation can also be 
exported to a .mov file.
Depending on the view, render mode, presence of shadows, and heliodon view, various solar assessments can be 
conducted. Generally, OpenGL rendering (with or without shadows; Renderworks required) will provide good results.

Text Display Select the information to include in the heliodon’s text label; move the label control point 
to adjust the label position.

• None: Does not display a text label
• Time + Location + Date: Displays the time, city, and date
• Time + Location + Date + Data: Displays the time, city, date, and solar data 

including solar time
• Time + Date Only: Displays the time and date
• Time + Date + Data: Displays the time, date, and solar data
• Data Only: Displays the solar data

Solar Animation Opens the Solar Animation dialog box; see “Creating Solar Animations” on page 1492

Settings Solar Animation Effect

Wireframe, Top/Plan view Observe the heliodon symbol while changing the time of year or time of day. 
Animating shows the position of the sun’s rays and approximate position of the 
sun in the sky dome. The date display on the heliodon label changes to indicate 
the animation’s day of the month.

Parameter Description
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Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Interactive Solar Animations
Exporting Solar Animations
Solar Studies
Inserting a Heliodon Object
Calculating Shadow Angles

Creating Interactive Solar Animations
Interactive solar animations display the sun’s effects within the drawing; specify the view, day, month, and time for 
interactive previews. Wireframe mode views as well as rendered views (with or without shadows) are useful to study 
the sun’s movements.
Large or complex rendered models, high-quality render settings, and smooth shadows may affect the animation. To 
interactively view changes as you move the sliders, render in Wireframe or OpenGL render mode. Low to medium 
(Detail and Quality) OpenGL options are recommended.

To animate the sun interactively:

1. Insert at least one heliodon object as described in “Inserting a Heliodon Object” on page 1489.
2. Select the desired view and render mode.
3. Select the heliodon, and click Solar Animation from the Object Info palette. Alternatively, double-click on a 

heliodon object.
The Solar Animation dialog box opens. Click on the Interactive tab. Set the Animate view, and the day, month, 
and time, or move the month and day sliders while observing the effects.

Click to show/hide the parameters.

OpenGL rendering (Use 
Shadows not selected), Top/Plan 
or 3D view

Observe the model as the sun’s rays move over it during the course of the year 
or day. Different portions of the model are illuminated by sunlight.

OpenGL rendering with shadows 
(Use Shadows selected), Top/
Plan view or 3D view

Observe the shadows cast by the model over the course of the day or year, and 
observe the portions of the model that are illuminated by sunlight.

Solar animation view set to View 
(sun to layer plane center) or 
View (sun to Heliodon center)

Observe as the model rotates, as if the viewer was positioned on the sun. Any 
visible surface has sunlight falling on it, while anything that can’t be seen is in 
shadow (therefore, Use Shadows is not necessary). The model rotates about 
the layer plane center or about the heliodon center. Rotating about the heliodon 
center can be useful when the model is not centrally located, or when a 
particular part of the model needs to be studied. For example, place the 
heliodon adjacent to a shading device, zoom in, and then animate using the 
heliodon center.

Parameter Description

Animate Sets whether to animate the sun about the model, or rotate the model about the 
sun

Settings Solar Animation Effect

http://www.youtube.com/watch?v=mLOiu9FXzJ8
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4. When finished with the solar animation, click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
Exporting Solar Animations
Creating Solar Animations
Inserting a Heliodon Object
Solar Studies

Exporting Solar Animations
The same type of solar animation effects that can be seen in the drawing in interactive mode can be exported to a 
movie.

To export a solar animation:

1. Insert at least one heliodon object as described in “Inserting a Heliodon Object” on page 1489. 
2. Select the desired view and render mode.
3. Select the heliodon, and click Solar Animation from the Object Info palette. Alternatively, double-click on a 

heliodon object.

Heliodon (Top/Plan view) or 
Sun (using current view)

Moves the sun over the model

View (sun to layer plane 
center)

Navigates around the model as viewed from the sun, showing the part of the 
model illuminated by the sun at that time; the model is assumed to be at the layer 
plane center and rotates about this center

View (sun to Heliodon center) Navigates around the heliodon as viewed from the sun; parts of the model that 
are visible are the areas receiving sunlight. This mode is helpful when studying a 
portion of a larger model or when the model is offset from the layer plane center. 
Place the heliodon in the area of interest.

Interactive/Export Movie Select whether to view the animation interactively, within the drawing, or export 
it to an animation file

Day/Month Enter the day of the month and the month, either by typing digits or using the up 
and down arrows

Month slider Move the interactive slider to progress through the months of the year
Hour/Min Enter the time as hour and minute, either by typing digits or using the up and 

down arrows. The increment for the minute arrows is set by the Minute 
Interval.

AM/PM 
(12 Hour time display only)

Toggles between AM and PM for a quick shortcut to setting morning or 
afternoon

Day slider Move the interactive slider to progress through the daylight hours
Minute Interval Sets the increment to advance or decrease the minutes with the up/down arrows, 

making it easier to quickly step through the day if needed.
Local Time/Solar Time Displays the sunrise and sunset times for the location and time of year, as well as 

the current local or solar time. The display of local or solar time depends on 
whether Use Solar Time is selected in the Object Info palette.

Parameter Description
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The Solar Animation dialog box opens.
4. Click on the Interactive tab, and set the date and time.
5. Click on the Export Movie tab. Set the Animate view and the export options. The solar animation occurs based 

either on time or date settings.
Click to show/hide the parameters.

6. Click OK to create the animation.
If showing the time of day or month and day, click in the drawing, when prompted, to set the text location.
The Set Movie Name and Destination dialog box opens.

7. Specify the location to save the movie file. By default, the file is named with the location and the date. Click Save.
The Compression Settings dialog box opens.

8. Set the Frames per second and Quality for the movie file.
9. Click OK. A message displays the progress of the export, and the movie is created.

Click to end the export early. The solar animation movie is created up to that point.

Parameter Description

Animate Sets whether to animate the sun about the model, or rotate the model about the sun
Heliodon (Top/Plan view) 
or 
Sun (using current view)

Moves the sun over the model

View (sun to layer plane 
center)

Navigates around the model as viewed from the sun, showing the part of the model 
illuminated by the sun at that time; the model is assumed to be at the layer plane 
center and rotates about this center

View (sun to Heliodon 
center)

Navigates around the heliodon as viewed from the sun; parts of the model that are 
visible are the areas receiving sunlight. This mode is helpful when studying a portion 
of a larger model or when the model is offset from the layer plane center. Place the 
heliodon in the area of interest.

Interactive/Export Movie Select whether to view the animation interactively, or export it to an animation file
Animate Time Creates the solar animation over the course of a day; set the start/end time and time 

interval
Animate Date Creates the solar animation over the course of a year; set the date start and end and 

date interval
Start Time/Date Select the starting time or month 
End Time/Date Select the ending time or month
Time/Date Interval Select the increment for the movie; a smaller increment creates a smoother movie, 

but creates a longer movie
Show time of day Displays the time of day in the movie, at a location specified before export; set the 

font size
Show month and day Displays the day and month in the movie, at a location specified before export; set 

the font size
Export summary Displays the length of the movie at 15 frames per second (fps) and the number of 

frames to be created
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10. View the movie in the application of your choice to watch the solar animation.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Interactive Solar Animations
Creating Solar Animations
Inserting a Heliodon Object
Solar Studies

Calculating Shadow Angles
Shadow angles can be calculated and displayed for up to four walls of a model. These calculations are useful for 
designing or positioning shading devices, such as awnings and overhangs.

Shadow angles are always calculated relative to a wall and not to true North.

To calculate shadow angles:

1. Name the wall or walls that will participate in the calculations by selecting each wall, and then clicking on the 
Data tab of the Object Info palette. Enter a Name for the wall to identify it.

2. Insert at least one heliodon object as described in “Inserting a Heliodon Object” on page 1489.
3. Select the heliodon. In the Object Info palette, select Show Shadow Angle Calculator.
4. Specify the No. of Walls to display shadow angle calculation values. Up to four walls can be specified.
5. In Wall Face, specify which side of the walls, left or right, is the external side.

By default, the wall direction as it was drawn determines which side of the wall is considered the outside and 
which is the inside. See “Wall Direction” on page 506.

6. Enter the exact Name of each wall.
When the wall name is recognized, its Horizontal Shadow Angle (HSA) and Vertical Shadow Angle (VSA) 
calculated values are displayed in the Object Info palette. If a wall is always in shadow, the text No sun on wall 
displays in the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Solar Studies



Sketch Rendering
The Vectorworks Design Series products include a sketch rendering mode that applies a hand-drawn or sketch effect to 
2D and 3D objects in any projection. The Renderworks product is not required. The vector-based sketch effects are 
saved as editable resources, and are applied directly to the objects in a drawing. The sketch effects can also be applied 
to hatches and sheet layer viewports, and can be used in hidden line rendering.
Unlike Artistic Renderworks, sketch rendering can be applied to 2D objects, and individual objects can have specific 
sketch styles. Sketch effects cannot be applied to worksheets, text, loci, or lights.
~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Default Sketch Style
Applying the Default Sketch Style
Editing Sketch Styles
Creating Custom Sketch Styles
Applying Sketch Styles to an Object
Applying Sketch Styles to Hatches
Applying Sketch Styles to Viewports
Sketching with Hidden Line Rendering

Setting the Default Sketch Style
To quickly apply a sketch style to all objects in the current design or sheet layer, specify a default sketch style. 
Specifying the sketch style in a design layer applies the default to all layers in the file (design and sheet). For sheet 
layers, applying a default sketch style applies only to objects placed on the sheet layer, overriding the document default 
sketch style; viewports also have individual sketch style settings (see “Applying Sketch Styles to Viewports” on 
page 1502).
Sketch styles are provided as default content (default content is automatically imported into the current file at the point 
of use and displays in the Resource Browser; see “Resource Libraries” on page 219). The following sketch styles are 
pre-defined, and can be selected as a default sketch style. Custom sketch styles that have been added to the file also 
display in the Resource Browser and can be selected as a sketch style (see “Creating Custom Sketch Styles” on 
page 1500).
Unused sketch styles can be purged; see “Purging Items from a File” on page 1011.

Sketch resources do not display in the Resource Browser until a sketch-related option is selected for the first time.

Default Sketch Style Description

No Sketch Does not apply a sketch style; useful for overriding an applied sketch style (see “Applying 
Sketch Styles to an Object” on page 1501)
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To specify the default sketch style:
1. Select View > Rendering > Sketch Options.

The Sketch Options dialog box opens. 
2. Select the default sketch style from the list.

Click to show/hide the parameters.

Careful Uses many small wobble points and minor variations from the actual endpoints

Certain Uses many small wobble points and specifies more overstrike

Quick Uses few wobble points, with more distance between them

Rough Uses many wobble points

Tentative Uses many small wobble points and a high amount of understrike

Default Sketch Style Description
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3. Click OK to set the default sketch style.
~~~~~~~~~~~~~~~~~~~~~~~~~
Applying the Default Sketch Style
Editing Sketch Styles

Applying the Default Sketch Style
To apply the default sketch style to the current design or sheet layer:

Select View > Rendering > Sketch.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Default Sketch Style
Editing Sketch Styles
Creating Custom Sketch Styles
Applying Sketch Styles to an Object

Editing Sketch Styles
Sketch styles can be edited and renamed. The changes are saved as resources in the file.

Sketch resources do not display in the Resource Browser until a sketch-related option is selected the first time.
To edit a sketch style:

1. Select View > Rendering > Sketch Options.
The Sketch Options dialog box opens.

2. Select the sketch style to edit from the sketch style list.
3. Click Edit.
4. The Sketch Style Editor dialog box opens. You can edit the sketch edge and end point settings, and rename the 

style. The preview graphic provides help with editing.

Parameter Description

Document Default Sketch Style or 
Sheet Layer Default Sketch Style

Specifies the sketch style to apply when the Sketch command is selected

Edit Opens the Sketch Style Editor dialog box, for changing the selected sketch 
style parameters

Preview Temporarily applies the current sketch style to objects in the current layer

Rough sketch style depicted



  1500 | Creating Custom Sketch Styles
Click to show/hide the parameters.

5. Click Save.
Alternatively, sketch styles can be edited by selecting the style in the Resource Browser and selecting Edit from 
the context menu. Sketch styles can also be deleted with the Resource Browser. For more information on the 
Resource Browser, see “Using the Resource Browser” on page 221. 

~~~~~~~~~~~~~~~~~~~~~~~~~
Applying the Default Sketch Style
Creating Custom Sketch Styles

Creating Custom Sketch Styles
The Vectorworks program includes several default sketch styles, but custom sketch styles can also be created
To create a custom sketch style:

1. In the Resource Browser, select Resources > New Resource to display the list of new resource types.
For more information on the Resource Browser, see “Using the Resource Browser” on page 221.

2. Select Sketch Style.
The Sketch Style Editor dialog box opens. Specify the sketch style settings as described in “Editing Sketch Styles” 
on page 1499.

3. Click Save to create the sketch style. The new style is listed in the Resource Browser and is available in sketch 
style lists.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Sketch Styles
Setting the Default Sketch Style
Applying the Default Sketch Style

Parameter Description

Name Changes the default sketch style name, if desired
Edge Settings

Wobble Controls how much the sketched lines are offset from the true lines of an object; drag the 
slider to the right to increase the wobble

Stroke Controls the length of the sketch drawing strokes; a longer stroke distance increases the 
number of wobble points. Drag the slider to the right to increase the number of wobble points.

Randomness Controls the amount of wobble and stroke variation
End Point Settings

Overstrike Extends sketched lines past their endpoints; drag the slider to the right to increase the 
overstrike

Understrike Shortens sketched lines before their endpoints; drag the slider to the right to increase the 
understrike

Randomness Controls the amount of overstrike and understrike variation
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Applying Sketch Styles to an Object
Each object can have its own sketch style, overriding the sketch style applied to the current layer. Apply the “No 
Sketch” style to objects that should never be sketched.
To apply a sketch style to an object:

1. Select the object or objects.
 Groups and symbols cannot have a sketch style applied directly; edit the group or symbol first.

2. On the Render tab of the Object Info palette, the Sketch list displays the current document default sketch style. 
Select the desired sketch style for the object(s).
Alternatively, select the desired sketch style resource from the Resource Browser and select Apply from the 
resource context menu, or drag the sketch style from the Resource Browser to the object.

3. The selected object’s sketch style overrides the default sketch style.

Objects that override the default design layer sketch style also override the default sketch style on a sheet layer.
~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Default Sketch Style
Applying the Default Sketch Style

Applying Sketch Styles to Hatches
There are several ways to create a unique look for drawing objects. In addition to the current layer’s default sketch style 
and the object sketch style, each hatch can have a unique sketch style.
To specify a hatch sketch style:

1. Select Modify > Hatch.
The Hatches dialog box opens. For more information on hatches, see “Defining Hatches” on page 1105.

2. Select the desired hatch to edit or click New to create a new hatch.
The Edit hatch dialog box opens.

3. The document default sketch style is displayed in the Sketch Style list. Select the desired sketch style instead, or 
select No Sketch to never apply a sketch style to the hatch.
When the document default sketch style is applied, the hatch sketch style changes when the document default 
sketch style changes.

4. Click OK to exit the hatch editor.
~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Default Sketch Style

The No Sketch style is applied 
only to the muntins

Window muntins are selected



  1502 | Applying Sketch Styles to Viewports
Applying Sketch Styles to Viewports
Sheet layers can have a document default sketch style applied, which changes the appearance of objects on the sheet 
layer, but does not sketch the viewports on the sheet layer. Each viewport can have its own sketch style, making it easy 
to present designs with different sketched looks.
To apply a sketch style to a sheet layer viewport:

1. Select the viewport.
2. On the Shape tab of the Object Info palette, select Sketch from the Rendering list. Click Render Settings to 

select the viewport default sketch style.
If you are creating a viewport, select Sketch from the Rendering list in the Create Viewport dialog box, and then 
click Render Settings to select the viewport default sketch style.
The Sketch Render Settings dialog box opens. Select a sketch style for the viewport.

Click to show/hide the parameters.

3. Click OK. 
The selected viewport sketch style overrides the document default sketch style for any objects within the viewport, 
including the crop object, referenced design layers, and any annotations.
A sketch style cannot be directly applied to a viewport from the Render tab of the Object Info palette or by 
dragging the sketch style from the Resource Browser.
A sketch style cannot be directly applied to a design layer viewport, but it can be applied to the layer of the design 
layer viewport.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Sketch Styles
Creating Sheet Layer Viewports

Sketching with Hidden Line Rendering
The default document sketch style can be applied to hidden line, dashed hidden line, and final shaded polygon 
rendering modes.
To apply a sketch style to hidden line rendering:

1. Select the default document sketch style as described in “Setting the Default Sketch Style” on page 1497.
2. Select View > Rendering > Line Render Options.

The Line Render Options dialog box opens. 
Select Sketch Hidden Line Results, and select the sketch style from the list. Click Edit to edit the sketch style 
parameters. Then click OK to apply the sketch style to hidden line rendering.

Parameter Description

Viewport Default Sketch Style Specifies the sketch style to apply to the viewport
Edit Opens the Sketch Style Editor dialog box, for changing the selected sketch style 

parameters
Preview Temporarily applies the current sketch style to the viewport (disabled when 

accessed through the Create Viewport dialog box)
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3. To sketch a viewport’s hidden line rendering, select the viewport, and then choose a hidden line rendering mode 
from the Rendering list in the Object Info palette. Click Render Settings to access the associated hidden line 
render settings dialog box.
The Hidden Line Render Settings dialog box opens.

4. Select Sketch Hidden Line Results, and select the sketch style from the list. Preview or edit the sketch style if 
desired.

5. The hidden line, dashed hidden line, or final shaded polygon rendering displays with the selected sketch style.

~~~~~~~~~~~~~~~~~~~~~~~~~
Setting the Default Sketch Style
Rendering with Vectorworks
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Creating and Mapping Textures
Textures and Shaders 
In the Renderworks product, textures are applied to 3D objects to make them appear more realistic. Textures are 
composed of components called shaders. There are four shader types: color, reflectivity, transparency, and bump; each 
shader makes an independent contribution to the overall texture appearance. When you create or edit textures, the 
shader components are combined or excluded to achieve the desired texture effect.
In addition to using textures, realistic models can be enhanced with the use of backgrounds, weather effects, and the use 
of image files as props.
Four shaders contribute to a texture definition. Combining and adjusting these components causes a texture to appear as 
an image, colored, bumpy, shiny, and/or transparent. The following table defines the shader types:

Textures can be associated with surface hatches to give the appearance of a texture in a monochromatic, hidden 
line rendering. See “Hidden Line Rendering with Surface Hatches” on page 1606.

~~~~~~~~~~~~~~~~~~~~~~~~~
Renderworks Shader Types

Creating Textures
Textures are created and displayed in the Resource Browser and are saved with the file (default content is automatically 
imported into the file at the point of use, and displays in the Resource Browser); see “Resource Libraries” on page 219 
and “Using the Resource Browser” on page 221. Textures are created by defining the shaders that make up the texture.
Apply textures to an object from the Resource Browser or from the Render tab of the Object Info palette. See 
“Applying and Mapping Textures” on page 1527 for more information. 
Textures can be associated with surface hatches to give the appearance of a texture in a monochromatic, hidden line 
rendering. See “Hidden Line Rendering with Surface Hatches” on page 1606.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a New Texture
Creating Image-based Shaders
Editing Textures and Shaders

Creating a New Texture
To create a texture resource:

1. Select Window > Palettes > Resource Browser to open the Resource Browser.
2. Select Resources > New Resource to display the list of new resource types.
3. Select Renderworks Texture.

Shader Function

Color Defines surface color; this can be a plain, uniform color, or a complex pattern like wood or 
marble

Reflectivity Defines amount of light reflected by surface; it is dependent on surface texture properties and any 
light sources

Transparency Defines surface transparency or opacity 
Bump Defines surface irregularities which give the texture a bumpy appearance
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The Edit Texture dialog box opens. Specify the shader parameters. Shader types and properties are described in 
“Renderworks Shader Types” on page 1546.

Click to show/hide the parameters.

Parameter Description

Name Specifies the name of the texture resource
Shaders Sets the type of shader or combination of shaders to use, and specifies the shader parameters. 

Color Color shaders apply a color or pattern to the surface of an object. Select a color shader from 
the list, or choose Object Attribute to apply the object’s fill color attribute. Image-based 
shaders require the selection of an image file. After selecting the shader, click Edit to edit the 
shader properties. 

Reflectivity Reflectivity shaders control how much light is reflected from a surface. Select a reflectivity 
shader from the list (or select None to exclude this type of shader from the texture). 
Image-based shaders require the selection of an image file. After selecting the shader, click 
Edit to edit the shader properties. 

Transparency Transparency shaders control surface transparency or opacity. Select a transparency shader 
from the list (or select None to exclude this type of shader from the texture). Image-based 
shaders require the selection of an image file. Mask-based transparency shaders create a 
transparent mask from an image based on specified settings. After selecting the shader, click 
Edit to edit the shader properties. 

Bump Bump shaders apply a texture with bumps or dimples to an object surface. Select a bump 
shader from the list (or select None to exclude this type of shader from the texture). 
Image-based shaders require the selection of an image file. After selecting the shader, click 
Edit to edit the shader properties. 

Size Sets the real-world size for each repetition of the texture
If applying a brick shader, specify whether to adjust the brick dimensions proportionally to 
match the change to the texture size.

Set By Image For image-based textures, opens the Set Image Size dialog box, to set the texture size using 
the image (see “Setting the Texture Size by Image” on page 1507)

Shadows
Cast Allows objects with this texture to cast shadows 
Receive Allows objects with this texture to receive shadows 

Surface Hatch Displays the name of the current surface hatch resource, for use in hidden line rendering with 
surface hatches. Surface hatches are an aspect of textures

Edit Surface Hatch Opens the Edit Surface Hatch dialog box, to select the surface hatch to associate with the 
texture, and to align and register the surface hatch and texture (see “Editing Surface Hatches” 
on page 1606)

Preview Options The Preview window displays the effects of shader and size selections on a preview object
Preview Controls Adjusts the preview position and magnification. Click Pan and drag the preview to the 

desired location. Click Zoom In or Zoom Out and then click and drag to create a marquee; 
this zooms in or out on a particular section of the preview. Click Fit to fit the preview to the 
window (according to Obj Size).
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4. Click OK to create a texture with the name and properties specified in the Edit Texture dialog box. The texture 
displays in the Resource Browser and is saved with the file (the texture preview in the Resource Browser uses the 
Flat preview object at twice the texture size for ease of identification).
If you are modeling a glass object (glass reflectivity shader) with a 3D polygon or other sheet-like 3D object, 
duplicate and offset the 3D polygon by a small amount so that rays are traced through the glass with both an 
entering and exiting surface.

Setting the Texture Size by Image
For image-based shaders, the real-world size of each texture repetition can be set based on a segment of the image.
To set the size of an image texture based on the image:

1. Select the image to use for the texture, as described in “Creating Image-based Shaders” on page 1508.
2. In the Edit Texture dialog box, click Set By Image. If several image-based shaders are used, select the shader with 

the desired image in the Choose Image dialog box. 
The Set Image Size dialog box opens. Red handles flash briefly to indicate the location of the line segment.

3. Specify the image length to use for sizing the texture by dragging the line segment into position, and then dragging 
the ends of the line segment. If necessary, use the mouse scroll wheel to zoom into and out of the image, or click 
and hold the mouse wheel button to pan. 
When the line is indicating the desired real-world length, specify the real-world size for the line segment in 
Feature Size.

4. Click OK to exit the Set Image Size dialog box and update the Size value.

Setting Indirect Lighting Options
To save rendering time, it is possible to override the indirect lighting settings for individual textures (see “Setting 
Lighting Options” on page 1571). 
To set indirect lighting overrides for a texture:

1. From the Edit Texture dialog box, click Indirect Lighting Options.
The Indirect Lighting Texture Options dialog box opens. Specify whether, and to what degree, the texture should 
override the indirect lighting options.

Click to show/hide the parameters.

Obj Type Select the type of preview object from the list; for procedural (non image-based) shaders, the 
Flat object type is automatically used to create a preview for OpenGL rendering to 
approximate the look of the solid shader

Obj Size Specifies the preview object size
Shader check 
boxes

Select to preview the associated shader; deselect to exclude the shader component from the 
texture preview

Indirect Lighting 
Options

Opens the Indirect Lighting Texture Options dialog box, to set any overrides for the texture 
when rendering with indirect lighting (see “Setting Indirect Lighting Options” on page 1507) 

Revert Returns the texture parameters to the original settings, undoing any changes

Parameter Description

Override Indirect Lighting Sets whether the texture should participate in indirect lighting calculations.

Parameter Description



  1508 | Creating Textures
2. Click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Image-based Shaders
Renderworks Shader Types
Editing Textures and Shaders

Creating Image-based Shaders
Image-based shaders are created from image files imported into the Vectorworks file. Like wrapped shaders, an 
image-based shader is applied to the surface of an object. See “Applying and Mapping Textures” on page 1527 for 
more information. Different settings are then required depending on the type of shader to be used with the image.
Multiple image shaders can be combined to create a realistic texture. For example, import an asphalt image, and then 
add an image bump to the asphalt. In addition, image-based shaders can be combined with non image-based shader 
types for a variety of effects.
Most image-based textures are automatically compressed when imported. Imported JPG files retain the original JPG 
data; all other image files are compressed using lossless PNG format.

The Bricks shader includes its own image-selection functionality; see “Color Shaders” on page 1546.

Selecting the Image for Import
To import an image for use as an image-based shader:

1. Create a graphics file to be imported as a shader. In a graphics program, save the image in a format that the 
Vectorworks program can import:
• BMP
• JPG
• PCT
• PNG
• PNT
• PSD
• QTI
• SGI
• TIF
• TGA

2. Create a new texture as described in “Creating a New Texture” on page 1505. From any of the four shader 
component lists, select one of the image shader types.

3. If a resource with an image is already present in the file, the Choose Image dialog box opens.
Click to show/hide the parameters.

Emit Light Select this option if the texture should both receive and emit light
Receive Light Select this option if the texture should receive light but not emit it

Parameter Description

Import an Image File Imports a new image; click OK and proceed to Step 4.
Reuse an Image from 
Another Resource

Reuses a previously imported image; select the resource or other shader type that 
contains the image. Click OK and proceed to Step 5.

Parameter Description
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4. Select the desired image file in the Import Image Document dialog box. Click Open.
5. The next dialog box that opens depends on the type of shader. Refer to the section that applies to the shader.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a New Texture
Editing Textures and Shaders

Importing Images for Color Shaders 
Color shaders can use images for image color and as a filtered image. The image color shader can display the image 
as-is, or can tint the image with a specified color.
The process of selecting a color image shader is illustrated by the following flow chart.

To import a color image shader:
1. Select and import the image as described in “Selecting the Image for Import” on page 1508.

The Edit Image Color dialog box opens. Specify the image-based shader properties. 
Click to show/hide the parameters.

Shader Section

Color “Importing Images for Color Shaders” on page 1509
Reflectivity “Importing Images for Reflectivity Shaders” on page 1510
Transparency “Importing Images for Transparency Shaders” on page 1511
Bump “Importing Images for Bump Shaders” on page 1514

Parameter Description

Image preview Edits to the image are displayed in the image preview

Image already
imported in file

No image previously 
imported

Import new image

Edit Texture 
dialog box

Open File dialog 
box

Choose Image 
dialog box

Color shader - 
image color 

Edit Image Color 
dialog box

Image appears in 
Preview window

Reuse image
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2. Click OK to import the image and preview the texture.
~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Colors
Creating Image-based Shaders
Renderworks Shader Types
Editing Textures and Shaders

Importing Images for Reflectivity Shaders
The process of selecting a reflectivity shader is illustrated by the following flow chart.

To import a reflectivity image-based shader:
1. Select and import the image as described in “Selecting the Image for Import” on page 1508.

Tile Image Repeats the image in the horizontal, vertical, or horizontal and vertical directions; 
deselect for no tiling 

Filter Color
No filter Does not change the image with a filter color
Use Object Fill Filters the color of the image by the fill color selected for the object (can be different for 

each object that is textured by this texture)
Use Chosen Color Tints the image with the selected color; click the color box to choose a filter color for the 

image
Change Image Selects a different image for import
Flip H/V Flips the image horizontally or vertically
Rotate Rotates the image 90° counter-clockwise
Invert Produces a negative of the image

Parameter Description

Image already
imported in file

No image previously 
imported

Import new image

Edit Texture 
dialog box

Open File dialog 
box

Choose Image 
dialog box

Reflectivity 
image-based shader

Edit Image Reflectivity 
dialog box

Image appears in 
Preview window

Reuse image
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The Edit Image Reflectivity dialog box opens. Specify the image-based shader properties.
Click to show/hide the parameters.

2. Click OK to import the image and preview the texture.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Image-based Shaders
Renderworks Shader Types
Editing Textures and Shaders

Importing Images for Transparency Shaders 
Transparency shaders can be created from images or image masks.

Image Transparency

The process of selecting an image transparency shader is illustrated by the following flow chart.

To import an image transparency shader:
1. Select and import the image as described in “Selecting the Image for Import” on page 1508.

Parameter Description

Image preview Edits to the image are displayed in the image preview
Change Image Selects a different image for import
Flip H/V Flips the image horizontally or vertically
Rotate Rotates the image 90° counter-clockwise
Invert Produces a negative of the image
Reflection (%) Sets the amount of reflection. Generally, white pixels are the most reflective, while colored pixels 

reflect in their color.
Blurriness (%) Sets how blurry the reflection appears. A range of 0 – 40% is typical.

Image already
imported in file

No image previously 
imported

Import new image

Reuse image

Edit Texture 
dialog box

Open File dialog 
box

Choose Image 
dialog box 

Image Transparency 
shader

Edit Image Transparency 
dialog box

Image appears in 
Preview window
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The Edit Image Transparency dialog box opens. Specify the image-based shader properties. 
Click to show/hide the parameters.

2. Click OK to import the image and preview the texture.See “Transparency Shaders” on page 1564 for more details 
about transparency parameters.

Mask Transparency

The process of selecting a mask transparency shader is illustrated by the following flow chart.

To create a mask transparency image-based shader:
1. Select and import the image as described in “Selecting the Image for Import” on page 1508.

Parameter Description

Image preview Edits to the image are displayed in the image preview
Index of Refraction As light moves through a medium, the index measures the change in the direction of the 

light’s rays. An index of 1.0 indicates none; a typical value for water and ice is 1.3, and for 
glass use 1.5 – 1.6.

Blurriness (%) Sets image blurring when rendered in Final Quality or Custom Renderworks (with 
Blurriness selected)

Absorption Color Click the color box to select a color that the object may absorb differently, making it appear 
tinted by that color

Absorption Distance Defines the distance rays of light have to travel before Absorption Color replaces the 
image color. The lower the value, the more intense the Absorption Color is. 

Change Image Selects a different image for import
Flip H/V Flips the image horizontally or vertically
Rotate Rotates the image 90° counter-clockwise
Invert Produces a negative of the image

Image already
imported in file

No image previously 
imported

Import new image

Reuse image

Edit Texture 
dialog box

Open File dialog 
box

Choose Image 
dialog box

Image Mask 
Transparency shader

Create Transparent Color 
Mask dialog box

Image appears in 
Preview window

Create transparent color mask
Edit Image Mask 

dialog box
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2. The Edit Image Mask dialog box opens.
Click to show/hide the parameters.

3. To use the image as a mask, click Transparent Color Mask; the Create Transparent Color Mask dialog box 
opens. Select the mask properties.
The source image must be more than eight-bit color to create a transparent color mask. Images with a 
monochrome background are easiest to use when creating a mask transparency.

Click to show/hide the parameters.

Parameter Description

Horizontal/
Vertical 
Repetitions

Specifies the number of repetitions of the mask shader in the horizontal and vertical direction

Single The mask shader does not repeat; it is only shown once (this is the typical setting, especially 
for decals)

Infinite The mask shader repeats infinitely in the horizontal and/or vertical direction
Custom The mask shader repeats the specified number of times

Anti-Aliased Select to smooth the edges of the image mask
Change Image Selects a different image for import
Transparent 
Color Mask

Edits the transparent color mask settings

Flip H/V Flips the image horizontally or vertically
Rotate Rotates the image 90° counter-clockwise
Invert Produces a negative of the image; useful for swapping the opaque and transparent areas of a 

grayscale mask

Black pixels are 
transparent

White pixels are 
opaque
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4. Click OK. The mask is previewed in the Edit Image Mask dialog box.
5. Click OK again. The imported mask transparency is previewed in the Edit Texture dialog box.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Image-based Shaders
Renderworks Shader Types
Editing Textures and Shaders

Importing Images for Bump Shaders 
The process of selecting a bump shader is illustrated by the following flow chart.

To import a bump image-based shader:
1. Select and import the image as described in “Selecting the Image for Import” on page 1508.

Parameter Description

Source Image Displays the imported image. Select the transparent color by clicking a color in the image; the 
resulting mask is displayed in the Transparent Color Mask preview. If necessary, use the 
mouse scroll wheel to zoom into and out of the image, or click and hold the mouse wheel 
button to pan. 

Transparent 
Color

Displays the current transparent color. Either click on the source image to designate the 
transparent color, or select the color by clicking the color box.

Transparent 
Color Mask

Displays a preview of the mask based on the current transparent color selection and settings

Color Matching 
Tolerance

Adjusts the transparency tolerance; drag the slider to the right to increase the tolerance level. 
This allows a wider range of pixels similar to the transparent color to be considered 
transparent.

Mask Contrast Adjusts the mask edge contrast; increase the edge contrast sharpness by dragging the slider to 
the right. Soften the contrast by dragging the slider to the left.

Image already
imported in file

No image previously 
imported

Reuse image

Edit Texture 
dialog box

Open File dialog 
box

Choose Image 
dialog box

Bump image-based 
shader

Edit Image Bump 
dialog box

Image appears in 
Preview window

Import new image
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The Edit Image Bump dialog box opens. Specify the image-based shader properties.
Click to show/hide the parameters.

2. Click OK to import the image and preview the texture.
When you use the monochromatic textures provided with the Vectorworks program, the Bump Strength 
parameter may require careful adjustment depending on the viewing distance from the model.

Parameter Description

Image preview Edits to the image are displayed in the image preview
Change Image Selects a different image for import
Flip H/V Flips the image horizontally or vertically
Rotate Rotates the image 90° counter-clockwise
Invert Produces a negative of the image; useful for reversing the high and low pixels for a 

bump image
Bump Strength (%) Sets the amplitude of the bump shader. Positive and negative values can be entered. A 

value of 10% would result in a mild bumpy appearance.
Displacement Mapping For realistic bump textures, displacement mapping creates texture and bumpy details 

with a rendering technique that appears embossed, projecting the geometry outward 
from the surface.

This mapping applies only to Final Quality and Custom Renderworks, when 
Displacement Mapping is enabled in the render options. Rendering can be 
significantly slower with displacement mapping.
If the image bump does not provide the desired results, try a noise bump shader.

Height Specify a non-zero height to enable displacement mapping; large height values may 
result in longer render times

Detail Sets the level of detail for displacement mapping; requirements and results vary 
depending on the texture and the surface’s face size. Textures without too much bump 
detail and a large face size, such as boards or stones, render with less detail and can be 
set with a lower level of detail; fine, faceted textures like grass or leaves may require a 
high level of detail, which also requires more rendering time. Conversely, very large 
surfaces, like a ground plane, may need higher levels of detail to see the displacement.

Self-Shadowing Adds shadows to the displaced geometry, increasing realism as well as rendering time

Bump shader without 
displacement mapping

Bump shader with 
displacement mapping
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Due to compression artifacts, JPG images generally do not work well as bump images. PNG and TIF compression 
works well for bump images; when importing images, select PNG rather than JPG as the compression method.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Image-based Shaders
Renderworks Shader Types
Editing Textures and Shaders

Creating a Texture from a Hatch
Textures can be created from existing hatches to create an associated texture and, optionally, surface hatch resource for 
use in rendering. The resulting image-based texture is created automatically from the hatch. The texture’s size is based 
on the calculated repeat interval of the hatch.
To create a texture from a hatch:

1. Right-click (Windows) or Ctrl-click (Mac) on the hatch in the Resource Browser and select Create Texture from 
Hatch from the context menu.

2. Name the texture and click OK.

Editing Textures and Shaders 
All textures, whether created by you, selected from default content, or imported from the resources included with the 
Vectorworks program, can be edited by changing the parameters of the shaders that make up the texture. This editing 
can be done from the Object Info palette, with the changes to the texture reflected immediately in the selected object. 
Alternatively, the texture can be edited from the Resource Browser.
~~~~~~~~~~~~~~~~~~~~~~~~~
Importing Arroway Textures
Editing Textures and Shaders of Selected Objects
Editing Textures and Shaders Through the Resource Browser

Importing Arroway Textures 
Arroway textures™ are high-quality, high-resolution, image-based textures available from 
www.arroway-textures.com. In the Renderworks product, low-resolution image-based textures from Arroway are 
available as default content. Default content is automatically imported into the current file at the point of use and 
displays in the Resource Browser; see “Resource Libraries” on page 219. Arroway textures are easily identified 
because they contain “Arroway” in the texture name.
If your file contains low-resolution Arroway textures and you want to update them to their high-resolution equivalents, 
or if you have purchased high-resolution Arroway textures and would like to use them in a Vectorworks file, the 
Import Arroway Textures command accomplishes this automatically. This command is not available by default, but 
must be added to the workspace.
To update low-resolution Arroway textures or import new Arroway textures:

1. Purchase the required high-resolution textures from Arroway and place them in a folder. Organize the purchased 
textures so that the ones to be imported or updated are contained in a folder, and optionally in subfolders.

2. Add the Import Arroway Textures command to a new or existing workspace (see “Modifying Menus and 
Commands” on page 1837). The command can be found among the Import/Export items on the Menus tab of the 
Workspace Editor.

3. Select Import Arroway Textures from the custom location in the workspace.

http://www.arroway-textures.com
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The Import Arroway Textures dialog box opens.
Click to show/hide the parameters.

4. Set the parameters and click Import.
The Import Arroway Textures Folder dialog box opens.

5. Select the folder containing the high-resolution Arroway textures you have purchased.
Using several very large images may affect performance.

6. Click Select Folder to import or upgrade the Arroway textures from the selected folder and any subfolders. 
Renderworks textures are automatically created or updated in the current file.

Editing Textures and Shaders of Selected Objects
The textures and shaders of a selected object can be edited directly through the Texture menu on the Render tab of the 
Object Info palette. The Texture menu allows the textures and shaders that make up the textures to be edited, with 
changes displayed immediately in the drawing. The texture mapping can also be edited from the Object Info palette; 
see “Applying a Texture to an Object” on page 1530.

To avoid making unwanted permanent changes to a texture resource that is used by several objects, select 
Duplicate (Texture Name) Resource and Edit and work on a copy of the texture resource instead of the original. 
Changes made to a copy of the texture only apply to the current selection.

Editing the Texture Resource
To edit the texture resource of a selection:

1. Select the desired textured object(s).
2. On the Render tab of the Object Info palette, click the arrow next to the texture name to open the Texture menu.
3. Select Edit (Texture Name) Resource to edit the current texture, or select Duplicate (Texture Name) Resource 

and Edit to make a copy of the resource for editing.
The Edit (Texture Name) dialog box opens, and a preview window is created around the selected object.
The parameters are the same as those used to create the texture; any changes are reflected directly in the drawing.
Some parameters are not available when editing a resource from the Object Info palette; to edit those parameters 
you must access the texture directly from the Resource Browser.

Click to show/hide the parameters.

Parameter Description

Create New Textures Creates new image-based textures from the Arroway high-resolution textures in the 
specified folder(s)

Update Existing 
Textures

Updates any low-resolution Arroway textures in the current file with their 
high-resolution equivalent

Max Pixel Dimension Specifies the maximum dimension for the imported textures; choose the lowest practical 
pixel dimension to avoid memory issues, particularly when several textures are used
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Editing the Shader
If only the shader parameters require editing, they can be accessed quickly from the Texture menu rather than editing 
the texture first.
To edit one of the shaders that makes up the texture of a selection:

1. Select the desired textured object(s).
2. On the Render tab of the Object Info palette, click the arrow next to the texture name to open the Texture menu.
3. Select Edit (Shader Name) Shader to directly edit one of the shaders that makes up the applied texture.

The Edit (Shader Name) Shader dialog box opens, and a preview window is created around the selected object.
The parameters are the same as those used to create the shader; any changes are reflected directly in the drawing.

~~~~~~~~~~~~~~~~~~~~~~~~~
Renderworks Shader Types
Editing Textures and Shaders Through the Resource Browser

Parameter Description

Shaders Select a different or additional shader, or edit the shader parameters, as described in 
“Creating Textures” on page 1505

Size Sets the real-world size for each repetition of the texture
Set By Image For image-based shaders, click to set the real-world size in relation to a segment of the 

image (if several image-based shaders are used, select the shader in the Choose Image 
dialog box first). In the Set Image Size dialog box, specify the texture length to use for 
sizing by dragging the ends of the line segment. Then, specify the real-world size for 
the line segment in Feature Size. Click OK to exit the Set Image Size dialog box and 
update the Size value.
The size should reflect the file setup. For example, if the layer scale is 1/4” and feet 
and inches are being used, the size should be in feet, not inches.

Shadows
Cast Allows objects with this texture to cast shadows (for rendering modes that display 

shadows)
Receive Allows objects with this texture to receive shadows (for rendering modes that display 

shadows)
Indirect Lighting Options Opens the Indirect Lighting Texture Options dialog box, to set any overrides for the 

texture when rendering with indirect lighting (see “Setting Indirect Lighting Options” 
on page 1507). 

Preview Options
Render Mode Select a rendering mode for the preview window; this does not change the drawing 

rendering mode
Update When Values 
Change

Select to render the preview with the selected Render Mode as parameters change; if 
deselected, the drawing is not updated until the dialog box is closed

Render Selected Object 
Only

Select to render only the selected object as parameters change; deselect to render 
objects within the preview window as parameters change

(Texture Name) is Used by Indicates the number of objects in the file with the current texture applied
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Editing Textures and Shaders Through the Resource Browser
A texture and its shader properties can be edited from the Resource Browser. The texture does not have to be applied to 
any objects to be edited in this way; changes are displayed in a preview window rather than directly in the drawing.
To edit a texture resource, including its shaders, from the Resource Browser:

1. From the Resource Browser, select the texture to be changed, and then select Resources > Edit.
The Edit Texture dialog box opens.

2. Click Edit to edit one of the shaders that make up the texture. The dialog box that opens depends on the shader. 
Descriptions of all the possible parameters are presented in alphabetical order in “Renderworks Shader Types” on 
page 1546.

3. Click OK to exit the shader properties.
4. Edit the texture properties as described in “Creating Textures” on page 1505. The texture can also be renamed.

The changes are displayed in the preview window.
5. Click OK to exit the Edit Texture dialog box. Textures applied to any objects are updated to reflect the changes.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Textures and Shaders of Selected Objects
Creating Textures
Renderworks Shader Types
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Creating Image Prop Objects 
The Renderworks product allows the insertion of “prop” objects made from imported images, such as trees, people, 
signs, and cars, to make a model look more realistic. An image prop must be in one of the formats listed in “Selecting 
the Image for Import” on page 1508. Most image-based textures are automatically compressed when imported into a 
Vectorworks file. Imported JPG files retain the original JPG data; all other image files are compressed using lossless 
PNG format.

For proper display when rendered, an image prop should have a fill style other than None in the Attributes palette.
An image imported for use as a prop is saved as a texture resource. A library of image prop resources is provided in the 
image props folder of [Vectorworks]\Libraries\ (see “Resource Libraries” on page 219).
To add an image prop:

1. Select Model > Create Image Prop.
2. If a resource with an image is already present in the file, the Choose Prop Image dialog box opens.

Click to show/hide the parameters.

3. Select the desired image file in the Import Image Document dialog box. Click Open.
4. The Image Prop Options dialog box opens. Specify the parameters for the image prop.

Click to show/hide the parameters.

Parameter Description

Import an Image File Imports a new image; click OK and proceed to Step 3
Reuse an Image from Another 
Resource

Reuses a previously imported image; select the resource that contains the 
image. Click OK and proceed to Step 4.

Parameter Description

Name Specify a name for the image prop (used for the texture and symbol name)
Dimensions Specifies the image prop’s height and width values

Lock Aspect Ratio Maintains the image’s aspect ratio when selected; editing one dimension 
automatically changes the other

Mask Options
No Mask Specifies that no image masking is to be used for the imported image
Use Mask Specifies that image masking is to be used; click Create Mask to specify the mask 

image and properties as described in “Mask Transparency” on page 1512
Crossed Planes Creates the illusion of object fullness by creating two image planes at a 90 degree 

angle to each other

Crossed planes
deselected

Crossed planes 
selected
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Select Auto Rotate to Viewer for crossed plane images, so that the crossed planes cannot be detected.
5. Click OK to create the image prop.

The image prop symbol parameters can be edited in the Object Info palette. In the Resource Browser, the image 
prop is listed as a symbol/plug-in object, if selected at creation. In addition, a texture is created for use by the 
image prop. Both the texture and, if created, the symbol/plug-in object, are assigned the name provided in the 
Image Prop Options dialog box.

~~~~~~~~~~~~~~~~~~~~~~~~~
Adding 3D Plants

Adding 3D Plants 
Many designs have a need for plants that render quickly and appear more realistic than image prop objects. The 
Renderworks product includes several high-quality 3D plants from VBvisual, makers of 3D content for rendering 
packages. These plants look authentic in all views and cast realistic shadows, without adding excessively to rendering 
times or file size. The Renderworks product includes three free plants; more plants can be purchased to add to the 
library of 3D plants.

To place a 3D plant:

1. Click the VBvisual Plant tool from the Visualization tool set.
2. Select the plant to insert from the VBvisual Plant list on the Tool bar.
3. Click to insert the selected plant into the drawing.

When applicable, the low resolution, summer version of the plant is inserted by default. The plant includes a 3D 
locus so it can be easily moved; in addition, the plant can be sent to the surface of a site model (see “Sending 
Objects to the Site Model Surface” on page 705). In plan view, a 2D version of the plant displays.

Constant Reflectivity Excludes the prop from the effects of light objects placed in the drawing; this is 
useful for images that already contain shadowed areas

Create Plug-In Object Creates a plug-in object out of the prop; this allows the prop to be resized and 
automatically rotated

Auto Rotate to Viewer Adjusts the plug-in object so that it is always rendered facing the viewer
Create Symbol Creates a symbol from the image prop; the image prop name is automatically 

assigned as the symbol name. Generating the image prop as a symbol allows the 
image prop to be easily re-inserted in the drawing.

Parameter Description
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The object properties can be edited from the Object Info palette. The options available depend on the selected plant 
type.
Click to show/hide the parameters.

More plants are available for purchase in Vectorworks file format from VBvisual. Purchased plants must be placed in 
the default content library folder named VBvisual Plant (see “Resource Libraries” on page 219).
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Image Prop Objects

Creating Layer Backgrounds
With the Renderworks product, backgrounds can be added to create a more realistic drawing. Backgrounds, such as 
clouds, a color or color gradient, or an imported image or panorama, are applied on a per-layer basis. A physical sky 
background can be combined with a heliodon (Vectorworks Design Series required) to create a realistic sky, correct in 
appearance for the time of day. In addition, a special lit fog effect can add the illusion of shafts of light in fog (point or 
spot light required).
Renderworks backgrounds are resources that are created and displayed in the Resource Browser and are saved with the 
file (default content is automatically imported into the file at the point of use, and displays in the Resource Browser); 
see “Resource Libraries” on page 219. Several Renderworks styles make use of backgrounds.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Background
Applying Renderworks Backgrounds

Creating a Background 
To create a background:

1. Select Window > Palettes > Resource Browser to open the Resource Browser.
2. Select Resources > New Resource to display the list of new resource types.
3. Select Renderworks Background.

The Edit Renderworks Background dialog box opens.
4. Enter the name of the new background and select the type of background to create. Click Options to set specific 

background parameters.
Click to show/hide the parameters.

Parameter Description

Name Select the plant species from the list of included or purchased plants, or click More Plants 
to purchase additional plants

Height Select the plant height from the list of available heights for the selected plant
Resolution Certain plants include both a low- and high-resolution version. Selecting a high resolution 

provides the best appearance, but takes longer to render.
Season Select the season for the plant to display

Parameter Description

None Select this option when creating a lit fog effect without an additional background
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OpenGL render mode only displays One Color, Two Color, and Image backgrounds.
Click here for a video tip about this topic (Internet access required).

5. Click OK from the Create Renderworks Background dialog box to create the background resource.
The new background resource is listed in the Resource Browser. It is available in the Edit Design Layers dialog 
box (see “Applying Renderworks Backgrounds” on page 1545 for information).
A Renderworks background can be quickly edited by pressing Ctrl (Windows) or Option (Mac) and 
double-clicking on the resource in the Resource Browser.
Backgrounds and lit fog effects can be used together.
Textures and backgrounds that are not used in the drawing file should be purged to reduce file size. See “Purging 
Items from a File” on page 1011.

~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Renderworks Backgrounds
Setting Lighting Options

Clouds Specifies a sky background with a background color and clouds
Scale Specifies the cloud scale (1 – 10); enter a larger value for larger cloud sizes 
Background Color Select a background color for the sky
Cloud Color Select a cloud color
Detail Specifies the level of cloud resolution; drag the slider to the right to specify a greater level 

of detail (requires longer rendering times)
One Color Specifies a background with one color; click Options to select the color
Two Color Specifies a background with two colors which blend to form a gradient; click Options to 

select the colors
Top Color Select the color for the start of the color gradient at the top of the page
Bottom Color Select the color for the end of the color gradient at the bottom of the page

Image Uses a specified image for the background (see “Creating Image Backgrounds” on 
page 1524)

Image Environment 
(HDRI)

Uses a panoramic High Dynamic Range Image (HDRI) file for the background (see 
“Creating HDRI Backgrounds” on page 1524)

Physical Sky Uses environment lighting to realistically simulate various sky conditions (see “Creating 
Physical Sky Backgrounds” on page 1526)

Lit Fog Creates volumetric lighting effects, such as a shaft or cone of scattered light in fog, haze, 
or smoke. A point or spot light object must be inserted in the drawing, and Lit Fog must 
be selected in the Object Info palette for the light source object.

Lit fog cannot be applied to directional, area, or line lights.
Fog Density (%) Specifies the fog density; enter a larger value to increase the density of the effect
Fog Consistency Creates either a smooth or uneven fog effect
Receive Shadows Allows the effect to be blocked by solid objects, creating shadows; for example, when 

blocking a shaft of light by a table, so that light does not display under the table
Use Shadows must also be selected in the rendering options.

Parameter Description

http://www.youtube.com/watch?v=D8UbRsfbS24&list=UUN7uzhu-ljLJOe6a0J-fBcQ
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Applying Colors

Creating Image Backgrounds
To be used for a background, an image must be in one of the formats listed in “Selecting the Image for Import” on 
page 1508.
To create an image background:

1. Create the background resource as described in “Creating Layer Backgrounds” on page 1522. 
2. Select Image from the Background list.
3. Select a new image or an image from either the default content or the current file’s content (see “Resource 

Libraries” on page 219). 
The Edit Image Background dialog box opens; specify the image height and width (centered on the page). An 
image used as a background of this type, as opposed to the HDRI background, remains fixed to the page and does 
not change according to the 3D view.
An image can also be reused from another image-based resource if one exists in the file. In the Choose Image 
dialog box, select Reuse an Image from Another Resource and specify the resource. The Edit Image 
Background dialog box opens to allow editing of image parameters (see “Selecting the Image for Import” on 
page 1508 for more information). 

Click to show/hide the parameters.

4. Click OK to use the image in the background.
~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Renderworks Backgrounds
Creating a Background
Setting Lighting Options
Applying Colors

Creating HDRI Backgrounds 
When an HDRI background is imported, it behaves as if an infinitely large, textured, sphere or cube was centered on 
the model. The virtual sphere or cube is so large that view position changes do not affect its display. However, view 
orientation changes do affect which part of the image is shown in the background; this provides a true 3D sense to the 
model. One bounce of indirect lighting is generated with HDRI lighting.

Parameter Description

Width Sets the width of the image in page units (inches or millimeters); width edits also automatically 
change the height, to maintain the image aspect ratio

Height Sets the height of the image in page units (inches or millimeters); height edits also 
automatically change the width, to maintain the image aspect ratio

Change Image Selects a different image for import
Flip H/V Flips the image horizontally or vertically
Rotate Rotates the image 90° counter-clockwise
Invert Produces a negative of the image
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By default, an image environment background renders as both a background and a light source. However, it is possible 
to use one HDRI background resource as an environment background, and another for environment lighting; see 
“Setting Lighting Options” on page 1571. Several Renderworks styles incorporate the use of an HDRI background.

HDRI backgrounds render best in Perspective projection. In Orthogonal projection, HDRI backgrounds are 
suitable for lighting and reflections, but appear as a single background color because of the narrow field of view.
If the HDRI background includes a sun in its image, and the drawing also contains directional lights, the light 
directions may not match, creating multiple shadows.

To create an HDRI background:
1. Create the background resource as described in “Creating Layer Backgrounds” on page 1522. 
2. Select Image Environment (HDRI) from the Background list.
3. Select the .hdr image file to use. The image is automatically converted to Lat/Long format. An OpenEXR file can 

also be used; it must be in Lat/Long format.
The Edit Image Environment (HDRI) Background dialog box opens.

Click to show/hide the parameters.

Purpose of HDRI Background Resource Creation Method

Use an HDRI background resource as 
both environment background and 
environment lighting

Create an HDRI background resource and apply it to the layer. By 
default, the Layer Lighting Options is set to use the lighting from the 
current background.

Use an HDRI background as 
environment background only

Create an HDRI background resource and apply it to the layer. In the 
Layer Lighting Options dialog box, specify None for Environment 
Lighting.

Use an HDRI background resource as 
environment lighting only

Create an HDRI background resource, but do not apply it to the layer. 
In the Layer Lighting Options dialog box, select From Selected 
Background and specify the resource.

Use one HDRI background resource as 
an environment background and a 
different background resource for 
environment lighting

Create the first HDRI background resource and apply it to the layer 
(environment background). Create the second background resource but 
do not apply it to the layer. Instead, in the Layer Lighting Options 
dialog box, select From Selected Background and specify the second 
resource (environment lighting).

Parameter Description

Preview Displays a preview of the selected image
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4. Set the parameters and click OK to use the image as an environment background resource.
~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Renderworks Backgrounds
Creating a Background
Creating Physical Sky Backgrounds
Setting Lighting Options
Applying Colors
Renderworks Styles

Creating Physical Sky Backgrounds 
A physical sky creates the realistic appearance of a sky background with various levels of cloudiness. When used in 
conjunction with the heliodon (Vectorworks Design Series required), the sky’s appearance is appropriate for the set 
time of day and can change its appearance automatically during a solar animation. Several Renderworks styles 
incorporate the use of a physical sky background; these are preset to give the design a specific look at a certain time of 
day. However, you can also create your own physical sky background for use in rendering.
Because the physical sky uses environment lighting (see “Creating HDRI Backgrounds” on page 1524), the sky 
provides a light source.
To create a physical sky background:

1. Create the background resource as described in “Creating Layer Backgrounds” on page 1522. 
2. Select Physical Sky from the Background list.

The Edit Physical Sky Background dialog box opens.
Click to show/hide the parameters.

Rotation Rotates the image clockwise about the Z axis, changing the light orientation and visible 
portion of the image (range: -180 to 180 degrees; positive angles are rotated clockwise)

Change Image Imports a different image to use as the HDRI background
Brightness (%) Specifies the brightness for environment lighting; enter a percentage or drag the slider to 

change the brightness. A value over 100% can be entered.
Saturation (%) Specifies the color saturation for environment lighting; enter a percentage or drag the 

slider to change the saturation. A value over 100% can be entered.
Quality Specifies the sampling value of the rendered image; higher-quality sampling results in 

better image resolution, but longer rendering times. Select From Render Mode to use the 
Soft Shadows quality specified in the render options (see “Custom Renderworks 
Options” on page 1600).

Parameter Description

Preview Displays a preview of the sky condition
Sky Condition Select the amount of cloud cover for the sky background
Brightness (%) Specifies the brightness of the sky background; enter a percentage or drag the slider to 

change the brightness. A value over 100% can be entered.
Saturation (%) Specifies the color saturation of the sky background; enter a percentage or drag the slider 

to change the saturation. A value over 100% can be entered.

Parameter Description
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3. Set the parameters and click OK to use the physical sky in the background.
~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Renderworks Backgrounds
Creating a Background
Creating HDRI Backgrounds
Setting Lighting Options
Solar Studies
Renderworks Styles

Applying and Mapping Textures
Once a texture resource has been created, it can be applied either to a selected object or to objects assigned to a class. 
Mapping specifies how a texture is applied to an object; different types of objects require different mapping types.

2D objects cannot have a texture applied; in this case, the Render tab of the Object Info palette displays the 
message “Cannot apply texture to object.”

When you select a textureable object, the Render tab of the Object Info palette displays controls to assign a texture and 
adjust the texture mapping to achieve various visual effects. The result of these parameter changes is visible 
immediately in the drawing, as the selected object is re-rendered. Some objects have specific parts, which can have 
different textures and mapping types; for example, the texture and mapping type applied to the Top part might be 
different from those applied to the Sides. For some mapping types, you can then use the Attribute Mapping tool to 
adjust the texture mapping directly.
Decals are special textures that are applied over other textures. They are created from imported images or existing 
texture resources.
Finally, a Renderworks background can be applied to add impact and realism to the design.
~~~~~~~~~~~~~~~~~~~~~~~~~
Texture Projection and Orientation
Applying a Texture to an Object
Direct Texture Mapping
Creating Decal Textures
Applying Textures to Symbols, Walls, and Roofs
Applying Renderworks Backgrounds

Texture Projection and Orientation

Map Types
A map type is used to control how a texture is projected onto different types of objects in a general way. Plane, 
auto-align plane, sphere, cylinder, perimeter, roof, and imported mapping types are available. To further adjust the 
mapping, the projected texture can be rotated, moved, and scaled using the Render tab of the Object Info palette. For 
plane, sphere, and cylinder mapping types, you can use the Attribute Mapping tool to adjust the mapping directly on 
the object.

Surface hatches observe the scaling, rotation, and offset applied to the defining texture.
Surface hatches associated with a texture support Plane, Auto-Align Plane, and Cylinder texture map types. 
Sphere, Perimeter, and Roof texture map types are rendered as Auto-Align plane for surface hatches. Surface 
hatches on some curved surfaces do not stretch in the way that textures do, so the results vary slightly. 

Select the map type from the Object Info palette; see “Applying a Texture to an Object” on page 1530.
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Map Type Description

Plane Projects the texture onto a plane

Auto-Align 
Plane

Projects the texture perpendicularly to each face of a polygonal object; mapping is handled 
automatically. This type of mapping is useful for wall sculpting, and for imported 3ds (Vectorworks 
Design Series required) or DXF/DWG content. Do not use this map type for decals. (Attribute 
Mapping tool not supported)

Sphere Projects the texture to the surface of a sphere

Editing a plane map with the 
Attribute Mapping tool

Texture frame
(showing the first 
repetition of the 
texture)

Mapping surface 
(a plane parallel 
to a face of the 
object)

Texture frame
(showing the first 
repetition of the 
texture)

Mapping surface representation (a cross-section of the sphere)

Editing a sphere map with the
Attribute Mapping tool

Texture projection line

Radius control
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Cylinder Projects the texture to the surface of a cylinder

Sphere and Cylinder maps have seams that are more apparent with wrapped and image-based shaders

Perimeter Wraps the texture around the perimeter of the object (Attribute Mapping tool not supported)

 

Roof Wraps the texture across the perimeter of the roof object (Attribute Mapping tool not supported)

Imported Preserves the texture mapping from the original SketchUp or 3ds model; all other mapping 
controls, including the Attribute Mapping tool, are disabled.

The map type for individual parts of an imported mesh object can be changed to other 
supported Vectorworks map types; it is possible to combine imported mapping and custom 
mapping on the same imported mesh object. The Attribute Mapping tool can be used for 
mesh parts that are set to Plane, Sphere, or Cylinder map types.

Map Type Description

Editing a cylinder map with the 
Attribute Mapping tool

Texture frame
(showing the first 
repetition of the 
texture)

Mapping surface 
representation (a 
cross-section of 
the cylinder)

Texture projection line Radius control
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The available map types vary based on the object type being mapped.

Textures and Drawing Direction
Textures are applied to 3D polygons and walls based on the direction the object was drawn. For 3D polygons, the 
texture is applied parallel to the first segment.

Wall Texture Orientation
The starting point and direction the wall is drawn affects how a texture is applied. Textures are applied to a wall’s left 
side, right side, and center (and, optionally, to its top, bottom, holes, and start and end cap). The center of a wall is 
always the same; the left and right sides are based on the drawing direction. When you draw a wall in a clockwise 
direction, which is the recommended method, the left side is the exterior side. See “Wall Direction” on page 506.
A texture applied to the center of the wall is visible at the ends of the wall.

If the texture(s) is incorrectly applied to a wall, with the wall selected, click Reverse Sides on the Shape tab of the 
Object Info palette. This flips the direction of the wall, switching the texture(s) to the opposite side(s).

~~~~~~~~~~~~~~~~~~~~~~~~~
Applying a Texture to an Object
Direct Texture Mapping

Applying a Texture to an Object 
To apply a texture to one or more objects:

1. Create or import a texture resource as described in “Creating Textures” on page 1505.

Object Type Map Types Available

Extrudes Plane, Auto-Align Plane, Sphere, Cylinder, Perimeter
Meshes Plane, Auto-Align Plane, Sphere, Cylinder, Imported
Roofs Roof
Slabs (Floors) Plane, Auto-Align Plane, Sphere, Cylinder
Solid Primitives (Sphere, Hemisphere, Cone) Plane, Auto-Align Plane, Sphere, Cylinder
CSG Solids, Extrude Along Path, and Tapered 
Extrude

Plane, Auto-Align Plane, Sphere, Cylinder, Perimeter

Sweeps Plane, Auto-Align Plane, Sphere, Cylinder, Perimeter
Walls Plane, Auto-Align Plane, Sphere, Cylinder

Original 3D Polygon First segment drawn 
horizontally

First segment drawn 
at an angle
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2. Select the object(s) to texture. If more than one object is selected, the texture resource applies to all objects in the 
selection. Additional mapping parameters are available for multiple selected objects so the texture renders 
seamlessly.

3. On the Attributes palette, select any Fill Style other than None (otherwise the texture will not render).
4. Click the Render tab on the Object Info palette.
5. If the object has parts, specify the Overall texture to apply to the parts, or select an individual part and apply a 

texture. The selected texture applies to the entire object if it does not contain parts.
Select the desired Texture from either the default content or the current file’s content (see “Resource Libraries” on 
page 219), and then set the texture parameters, which apply only to the selected object(s).
The texture parameters and mapping can be edited in the Render tab of the Object Info palette. 

Click to show/hide the parameters.
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Parameter Description

Part Some objects can have different textures (including decals) applied to different parts. 
• For extrudes, sweeps, slabs, floors, and roof faces, apply textures to the top, bottom, and 

sides. 
• For slabs (Vectorworks Architect required), the Mode selection determines whether to 

apply textures from the slab components or from the slab. If you select By Component 
mode, the textures set for the slab components also determine the slab textures (see 
“Creating Slab Components” on page 491). If you select By Object mode, apply textures to 
the top, bottom, and sides.

• For walls and round walls, the Mode selection determines whether to apply textures from 
the wall components or from the wall. If you select By Component mode, the textures set 
for the wall components also determine the wall textures (see “Creating Wall Components” 
on page 513). If you select By Object mode, apply textures to the left, right, top, bottom, 
start cap, end cap, and holes. Left and right wall texture parts can only be applied to wall 
holes when editing the wall hole component; see “Adding a 3D Wall Hole Component to a 
Symbol Definition” on page 260. 

• For roof objects, apply textures to the top, bottom, sides, and dormer walls, and if 
Vectorworks Design Series products are installed, fascia, attic, and soffit. The Part option is 
not available for objects without distinct parts.

• For mesh objects imported from SketchUp or 3ds (Design Series required), the imported 
model determines the number of texture parts for the mesh object. A numerical list indicates 
how many unique textures are assigned to the imported mesh faces; the individual parts are 
not named. 

The texture or decal applied to each part displays in parentheses next to the part. To apply a 
texture to Overall or to a part, select it and then select a texture to apply from the texture list.
Overall indicates that the same texture applies to all parts of the object. Parts that have been 
assigned a texture different from Overall display above the divider, and parts with the same 
texture as Overall display below the divider.

Overall no longer displays when all parts use distinct textures.
The additional parts do not display when setting class textures (see “Applying Textures to 
Symbols, Walls, and Roofs” on page 1542). A wall’s start cap, if set to obtain its texture 
by class, uses the class texture assigned to the wall center.

Revert to Overall If a part was assigned a texture but it should inherit its texture from Overall instead, select the 
part and click Revert to Overall. The part moves back below the divider, and (from Overall) 
displays as its texture name. Any decals applied to the part are removed.

Add Decal Adds a decal texture to the selected part; see “Creating Decal Textures” on page 1537
Texture list Select the texture to apply from either the default content or the current file’s content

The Overall texture is Glass Clear, and the sides of the object are 
inheriting the Overall texture. The top and bottom of the object have 
unique textures different from the Overall texture.
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Texture menu Click the arrow next to the texture list to open the Texture menu. The texture resource or 
shader used to create the resource can be edited from here as described in “Editing Textures 
and Shaders of Selected Objects” on page 1517. Before editing, the resource can be copied to 
preserve the original resource parameters.

Thumbnail view Displays a thumbnail view of the selected texture
Map Type Select how the texture is applied to the 3D object; see “Map Types” on page 1527
Reset to Default 
Mapping

Removes any changes made by the Attribute Mapping tool or in the Object Info palette, 
restoring the texture to its original location, scale, and rotation.

Scale Determines the texture size when projected onto the object. For example, a value of 2 doubles 
the size of the texture projection. Either enter a scale value or use the slider to change the 
scale.

Offset H Sets the start location of the texture horizontally

Offset V Sets the start location of the texture vertically

Rotation Sets the angle of texture rotation. Either enter a rotation value from 0 to 360 degrees or use the 
slider to change the rotation angle.

Repeat 
Horizontally

Repeats the texture in a horizontal direction

Parameter Description
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The texture can also be applied to objects from the Resource Browser. Click the texture and drag it to the desired 
object, or select the desired object(s), and double-click on the texture to apply. Alternatively, select the object(s), 
right-click (Windows) or Ctrl-click (Mac) on the texture, and select Apply from the context menu. However, when 
a texture is applied in this way, mapping options cannot be accessed directly. Click on the Render tab of the Object 
Info palette to edit the texture mapping.

6. The texture is applied to the selected object(s).
~~~~~~~~~~~~~~~~~~~~~~~~~
Direct Texture Mapping
Applying and Mapping Textures

Repeat Vertically Repeats the texture in a vertical direction
Flip Horizontally Flips the texture horizontally, along the vertical axis
Flip Vertically Flips the texture vertically, along the horizontal axis
Radius For sphere and cylinder map types, sets the texture radius; the default radius is the same as the 

3D object radius. Increasing this value reduces the size of the texture on the object.
Follow Longest 
Edge

Aligns the texture’s U axis with the long edge of a face, for simpler mapping when the 
auto-align plane map type is selected. When deselected, the texture aligns horizontally in 
object space.

Use World Z For 
Origin

Sets the texture’s Z origin to be relative to the world Z origin, rather than to object space. This 
allows seamless texture application across multiple layers for all mapping types. Multiple 
objects with this parameter enabled render seamlessly along the Z axis.

Align Selected 
Mappings

For plane, cylinder, and sphere map types, aligns the texture mapping of multiple selected 
objects, giving them the appearance of a shared texture. Multiple objects with this parameter 
enabled use the mapping parameters of the first selected object, and the texture appears 
seamless across all selected objects. The shared mapping depends on the objects currently 
selected and can change with a different selection of objects.
This parameter is not available for auto-align plane, perimeter, or roof map types.

Mesh Smoothing Set the mesh smoothing preference for the selected object(s) to None, Use Document 
Preference, Custom Crease Angle, or Imported. If Custom Crease Angle is selected, specify 
the desired Crease Angle. 
Mesh objects imported from SketchUp or 3ds are automatically set to Imported to preserve the 
surface normal data from the original imported file. Imported smooth normals can be disabled 
and edited by selecting a different mesh smoothing option, but imported smooth normal data is 
deleted if the mesh is edited.

This setting overrides the document preference mesh smoothing setting for the selected 
object(s) only. To set the document preference for mesh smoothing, see “Document 
Display Preferences” on page 60.
This parameter is available for editing Open GL renderings in Vectorworks Design Series 
products even if Renderworks is not installed.

Update Updates the drawing display

Parameter Description
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Direct Texture Mapping
The Attribute Mapping tool edits texture mapping parameters directly in the drawing window. This tool applies to 
textures created with wrapped color shaders or mask transparency shaders. The texture mapping type must be sphere, 
cylinder, or plane for this tool (edit textures with other types of mapping through the Object Info palette).
This tool also modifies decal textures; see “Editing Decal Textures” on page 1540.

Click here for a video tip about this topic (Internet access required).
The Attribute Mapping tool also edits hatch, tile, gradient, and image fills. See “Mapping Fills with the Attribute 
Mapping Tool” on page 1123.

To edit texture mapping directly in the drawing window:

1. Select a textured, 3D object.
2. Click the Attribute Mapping tool from the Basic palette or Visualization tool set. Alternatively, select the 

Attribute Mapping tool first, and then click on the object.
If the selected object has an unsupported texture (with an auto-align plane, perimeter, or roof mapping type), an 
alert displays. Select another map type and click Yes to continue.

3. For objects with parts, which may have different textures and mapping types applied to different portions of the 
object, select the part to edit from the Part list on the Tool bar. To edit decals, see “Editing Decal Textures” on 
page 1540.
If the selected part has an unsupported texture (with an auto-align plane, perimeter, or roof mapping type), an alert 
displays. Select another map type and click Yes to continue.

4. For easier direct mapping of a repeating texture, click Non-Repeating mode on the Tool bar to see a single 
repetition of the texture. (After you edit the texture mapping, click Original Repeat mode to return to the original 
pattern and see the effect.)

Mode Description

Non-Repeating For repeating textures, displays a single repetition of the texture for easier texture editing
Original Repeat For repeating textures, restores the repeating pattern of the texture
Scale/Rotate by 
Corner

For resizing or rotating textures with the handles on the texture frame; the texture frame scales 
from or rotates about the handle opposite to the handle that was clicked on

Scale/Rotate by 
Center

For resizing or rotating textures with the handles on the texture frame; the texture frame scales 
from or rotates about its center

Part For textured objects with more than one textureable part, such as walls and roofs, allows a 
different part of the object to be selected for texture editing; allows decals to be selected for 
mapping adjustments

Original Repeat

Part listNon-Repeating

Scale/Rotate by Center

Scale/Rotate by Corner

http://www.youtube.com/watch?v=jKtLplWeeyQ&list=UUN7uzhu-ljLJOe6a0J-fBcQ
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5. If applicable, select how to scale or rotate the texture from the Tool bar. To adjust the texture about a corner of the 
editing frame, click Scale/Rotate by Corner mode; to adjust the texture about the center of the editing frame, 
click Scale/Rotate by Center mode.

6. A colored texture plane with an editing frame is placed over the first repetition of the texture in 2D mapping mode. 
The texture origin is positioned at the origin of the axes. The Object Info palette only displays the parameters that 
can be edited while the Attribute Mapping tool is active.
• To switch to 3D mapping mode, click one of the three texture space axes (the red, blue, and green lines).
• To switch back to 2D mapping mode, click within the texture frame or anywhere off the textured object.
The editing frame provides object snaps for precise texture placement. Either use the editing frame handles to 
adjust the mapping, or use the Data bar to enter precise values (see “Using the Data Bar” on page 125).

7. To edit the mapping of another part of a textured object, select the next part to edit from the Part list and repeat the 
process.

Action Description

To move the texture • 2D mapping mode: Click inside the editing frame and drag the texture to the 
desired location on the object surface

• 3D mapping mode: Click the center diamond-shaped handle at the origin, and 
drag the texture to the desired location on the object surface. The texture plane 
moves with the image, allowing you to snap the image to a snap point on the 
object.

To resize the texture (2D 
mapping only)

Click on a corner handle of the editing frame (the resize cursor displays), and 
drag to set the editing object to a new scale. Click to set.

To rotate the texture • 2D mapping mode: Click on a side handle of the editing frame (the rotate 
cursor displays) and drag the handle to the new rotation angle. Click to set.

• 3D mapping mode: Click on one of the handles along the axis to rotate about. 
The rotate cursor displays, and a dashed preview indicates the rotation space. 
Move the cursor to rotate the texture, and click to set it.

To set the texture to a face 
(plane map type only)

Click the hand cursor to set the texture mapping to the surface of the indicated 
face. The texture plane is positioned tangent to the surface at the click point, with 
the origin of the texture plane at the click point.

To change the radius of the 
texture projection (sphere and 
cylinder map types, 2D 
mapping only)

Click on one of the four radius control handles around the edge of the circle that 
represents the mapping surface, and drag the handle to the new radius length. 
Click to set.
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~~~~~~~~~~~~~~~~~~~~~~~~~
Applying a Texture to an Object

Creating Decal Textures
Decals allow multiple textures to be applied to a single object or part of an object, over a base texture that is already 
applied to the object. The decal can originate from an imported image file or a texture resource present in the file. 
Decals can be used to simulate signs on a textured wall, or layered textures for portraying wainscoting on a wall or 
patterns on fabric.

Decals must be rendered in a Renderworks mode. The Cartoon Artistic Renderworks mode cannot display decals.

Click a corner handle 
to resize the texture

Click a red, blue, or green 
axis to activate 3D mode

2D mapping mode

Click a side 
handle to rotate 
the texture

3D mapping mode

Click a red, green, or 
blue axis handle to rotate 
the texture on a 3D axis

Click within the texture frame 
or anywhere off the textured 
object to activate 2D mode

Click-drag the center 
handle to snap the 
texture to other objects 

Click a radius handle
to change the radius

of the texture
projection (sphere or

cylinder map only)
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To create a decal texture:
1. Select a textured, 3D object. A decal can only be applied to an object with an underlying texture; the map type of 

the texture determines the decal map type.
The underlying texture must have planar, spherical, or cylindrical mapping for the decal to be edited with the 
Attribute Mapping tool. Textures with any type of mapping can be edited with the Object Info palette.

2. If the object has textureable parts, select the part where the decal will be placed from the Part list on the Render 
tab of the Object Info palette.

3. Click Add Decal.
The Add Decal dialog box opens.

Click to show/hide the parameters.

4. If the decal consists of an imported or reused image, the Decal Options dialog box opens.
Click to show/hide the parameters.

5. If creating a rectangular mask decal, proceed to step 9. Otherwise, if creating an image mask, click Choose 
Image.
The Choose Decal Mask Image dialog box opens; select the image mask to use. A new image can be imported for 
masking, or an existing image resource from the current file can be selected (including the current image).

6. Click OK.
The Create Mask dialog box opens.

Click to show/hide the parameters.

Parameter Description

Import an Image File Imports a new image; select the desired image file in the Import Image Document 
dialog box. Click Open.

Reuse an Existing Image Reuses a previously imported image; select the resource that contains the image
Select a Texture Applies the texture over the object’s base texture; no further settings are required

Parameter Description

Name Provide a name for the decal texture
Size Sets the real-world size for each repetition of the texture; by default, decal textures show 

only one repetition horizontally and vertically
Mask Options Indicates the type of masking for the image decal
Rectangular Mask Creates a rectangular mask around the decal; no further settings are required
Image Mask Masks the decal image per pixel using an image mask to determine which areas of the 

image are transparent or opaque
Choose Image Opens the Choose Decal Mask Image dialog box, for selecting the image mask

Parameter Description

Grayscale Pixels Creates a mask from the image’s pixel brightness values; brighter pixels are more opaque
Transparent Color Creates a mask with a selected transparent color and mask parameters
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For Grayscale Pixel and Alpha Channel masks, click OK. Proceed to Step 9.
7. If Transparent Color was selected, the Create Transparent Color Mask dialog box opens. Select the mask 

properties and click OK.
The source image must be more than eight-bit color to create a transparent color mask. Images with a 
monochrome background are easiest to use when creating a mask transparency.

Click to show/hide the parameters.

8. Click OK to return to the Decal Options dialog box.
9. Click OK to create the decal texture and apply it to the selected object.

The decal is placed on the object; adjust its position, scale, and rotation with the Attribute Mapping tool or 
Object Info palette as described in “Editing Decal Textures” on page 1540. By default, decal textures only repeat 
once horizontally and vertically, with matte reflectivity and no bump or other material options. This can be 
modified by editing the texture from the Resource Browser.
Click here for a video tip about this topic (Internet access required).

Alpha Channel Uses the alpha channel of a source image as the mask (image must contain valid alpha 
channel information)

Parameter Description

Source Image Displays the imported image. Select the transparent color by clicking a color in the image; the 
resulting mask is displayed in the Transparent Color Mask preview. If necessary, use the mouse 
scroll wheel to zoom into and out of the image, or click and hold the mouse wheel button to pan. 

Transparent 
Color

Displays the current transparent color. Instead of clicking on the source image to designate the 
transparent color, the color can be selected by clicking the color box.

Transparent 
Color Mask

Displays a preview of the mask based on the current transparent color selection and settings

Color Matching 
Tolerance

Adjusts the transparency tolerance; drag the slider to the right to increase the tolerance level. 
This allows a wider range of pixels similar to the transparent color to be considered transparent.

Mask Contrast Adjusts the mask edge contrast; increase the contrast sharpness by dragging the slider to the 
right. Soften the contrast by dragging the slider to the left.

Parameter Description

Black pixels are 
opaque

White pixels are 
transparent

http://www.youtube.com/watch?v=C4QHZQLmHRI
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~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Decal Textures

Editing Decal Textures
Similar to other textures, decal textures can be edited from the Object Info palette. Depending on map type, decal 
textures can also be positioned and adjusted with the Attribute Mapping tool. Because decals are texture resources, 
the texture definition can be edited from the Resource Browser.
Multiple decals can be applied to one object; the decals are applied in a stacking order, which can be changed to adjust 
the overall effect of the textures.
Multilayered textures and mapping parameters can be transferred between objects with the Eyedropper tool fill 
attributes (Texture). See “Transferring Attributes” on page 1095.

Decals must be rendered in a Renderworks mode.

Direct Decal Texture Mapping
Decals can be moved, scaled, and rotated with the Attribute Mapping tool. Decal mapping is performed on one decal 
at a time, separately from the base texture mapping described in “Direct Texture Mapping” on page 1535.

The map type of the underlying texture determines the decal map type. The underlying texture must have planar, 
spherical, or cylindrical mapping for the decal to be edited with the Attribute Mapping tool. 

To adjust the mapping of the decal texture with the Attribute Mapping tool:

1. Select a textured, 3D object with one or more decals.
2. Click the Attribute Mapping tool from the Basic palette or Visualization tool set.

Alternatively, select the Attribute Mapping tool and then click on the object with applied decal(s).
3. Select the decal to adjust from the Part list on the Tool bar. The Part list shows the textures mapped to the object, 

including the base texture.

If the selected part has an unsupported texture underlying the decal (with an auto-align plane, perimeter, or roof 
mapping type), an alert displays. Select another map type and click Yes to continue.

4. If applicable, select how to scale or rotate the texture from the Tool bar. To adjust the texture about a corner of the 
editing frame, click Scale/Rotate by Corner mode; to adjust the texture about the center of the editing frame, 
click Scale/Rotate by Center mode.

5. An editing frame in 2D mapping mode is placed over the decal texture. Set the decal position and rotate or resize 
the decal as needed.

Click a corner 
handle to resize 
the texture

Click a side 
handle to rotate 
the texture
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Editing the Decal Texture Parameters
When decal has been applied to an object’s overall part or to its parts, its parameters can be adjusted once the decal part 
has been selected from the Part list on the Object Info palette Render tab. Fewer parameters are available for decal 
textures than for the base texture, because the base texture determines the mapping type for the object.
Multiple decals applied to an object add to the Part list and also add buttons that allow the decal stacking order to 
change.
Click to show/hide the parameters.

Editing the Decal Texture Definition
Decals, like other textures, are saved as resources and can be edited from the Object Info palette or the Resource 
Browser. Decals are masked image-based textures with transparency, but shaders can be added and shader parameters 

Action Description

To move the decal Click inside of the editing frame and drag the texture to the desired location on the base 
texture

To resize the decal Click on a corner handle of the editing frame; the resize cursor displays. Drag to set the 
editing object to a new scale. Click to set.

To rotate the decal Click on a side handle of the editing frame (the rotate cursor displays) and drag the handle to 
the new rotation angle. Click to set.

Parameter Description

Part Some objects can have different textures (including decals) applied to different parts; Overall 
indicates that the same texture applies to all different parts of the object.
The texture or decal applied to each part displays in parentheses next to the part. To apply a 
decal to Overall or to a part, select it and then select Add Decal.
For more information, see “Applying a Texture to an Object” on page 1530.

Remove Decal Removes the decal from the currently selected Part; clicking Revert to Overall also removes 
all decals along with the base texture

Add Decal Adds a decal to the currently selected Part
Move Up/Down Decals are stacked in order as they are applied. When more than one decal has been applied to 

a selected Part, click to move the selected decal up or down in the stacking order.
Texture Select the texture to apply from either the default content or the current file’s content
Thumbnail view Displays a thumbnail view of the selected decal
Reset Mapping Removes any changes made by the Attribute Mapping tool or in the Object Info palette, 

restoring the decal to its original location, scale, and rotation
Scale Determines the texture size when projected onto the object. For example, entering a scale 

factor of two doubles the size of the texture projection.
Either enter a scale value or use the slider to change the scale.

Offset H/V Sets the start location of the texture horizontally and vertically
Rotation Sets the angle of texture rotation. Either enter a rotation value from 0 to 360 degrees or use the 

slider to change the rotation angle.
Update Updates the drawing display
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can be changed. For example, you may wish to apply a bump shader (based on the color image shader) to letters in a 
sign to give them a 3D appearance. By default, the reflectivity of a decal is matte, but this can also be changed. Adjust 
masking parameters and add vertical and/or horizontal repetitions of the texture if the default single repetition needs to 
be changed.
See “Editing Textures and Shaders of Selected Objects” on page 1517 and “Editing Textures and Shaders Through the 
Resource Browser” on page 1519 for information on editing the decal texture and its shaders.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Decal Textures

Applying Textures to Symbols, Walls, and Roofs 
While textures, and their associated surface hatches, can be applied to individual parts of many objects, as described in 
“Applying a Texture to an Object” on page 1530, applying textures to an object’s class or classes may be more 
efficient. Texture resources can be assigned to a class, which in turn can be applied to objects during creation.
Walls and roof objects have their own class texture assignment tabs for the main textureable parts of these objects. 
(Additional parts can be textured individually from the Object Info palette.)

Roof faces, extrudes, sweeps, and floors contain additional textureable parts, but the Edit Class(es) dialog box 
does not make this distinction. Textures/surface hatches are applied by class like any other 3D object; see 
“Applying Object Textures by Class” on page 1542. Apply textures to the individual parts of these objects with the 
Object Info palette and not by class.

Textures cannot be assigned to individual symbols directly through the Object Info palette. Textures must be applied to 
the separate components of the symbol. This can be done using the Edit Symbol command or by assigning textures to 
the classes that make up the symbol; complex objects can contain more than one class. Texture changes affect all 
instances of that symbol.
~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Object Textures by Class
Applying Textures to Symbols
Applying Wall Textures
Applying Roof Textures
Applying a Texture to an Object

Applying Object Textures by Class
Object textures, and their associated surface hatches, can be set by class.
To apply a texture by class:

1. Select Tools > Organization to open the Organization dialog box.
2. Select the Details view option, and then select the Classes tab.
3. Select an existing class or create a new class (see “Creating Classes” on page 177).
4. With the class selected, click Edit to open the Edit Class(es) dialog box.
5. Select any fill Style other than None (otherwise the texture will not render).
6. The texture properties of the class are set in the bottom section of the dialog box. Click the Other tab.
7. Select the desired Texture from either the default content or the current file’s content (see “Resource Libraries” on 

page 219). Select Use Textures/Surface Hatches At Creation to apply the texture/surface hatch to objects as 
they are created.
To suppress use of applied textures for the class, deselect Texture/Surface Hatch.
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8. Click OK to exit the Edit Class(es) dialog box.
The class displays on the Classes tab of the Organization dialog box.

9. If the object has not yet been drawn, click the blank area to the left of the Class Name to make the class active.
If the object already exists, apply the class to it. For some object types, the class name is specified in its settings or 
in the Object Info palette.

10. Click OK to exit the Organization dialog box.
11. Create the desired object(s). Objects are created with the specified texture for that class.
~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Textures to Symbols, Walls, and Roofs
Applying Textures to Symbols

Applying Textures to Symbols
Textures, and their associated surface hatches, can be applied to the components that make up the symbol, or to the 
classes used by the symbol components.

Applying Textures to Symbol Components
To apply texture(s) to the symbol components:

1. Select the symbol to edit.
2. Select Modify > Edit Symbol.

The Edit Symbol window opens; see “Editing Symbol Definitions” on page 247 for more information on the Edit 
Symbol window.

3. Select the first component that requires a texture.
4. On the Attributes palette, select any Fill Style other than None (otherwise the texture will not render).
5. Click the Render tab on the Object Info palette.
6. Select the desired Texture from either the default content or the current file’s content (see “Resource Libraries” on 

page 219), and then edit the mapping parameters as described in “Applying and Mapping Textures” on page 1527.
7. Repeat steps 3 – 6 for each component of the symbol.
8. Select Modify > Exit Symbol once all changes have been applied.

The new settings are applied to all instances of the symbol.

Applying Textures to Symbol Component Classes
To apply textures to the symbol component classes:

1. Select Tools > Organization to open the Organization dialog box.
2. From the Classes tab, select one of the symbol classes to edit.
3. Click Edit to open the Edit Class(es) dialog box.
4. Select any fill Style other than None (otherwise the texture will not render).
5. From the Other tab, select the desired Texture from either the default content or the current file’s content (see 

“Resource Libraries” on page 219). Select Use Textures/Surface Hatches At Creation to apply the texture/
surface hatch at creation.

6. Click OK to return to the Organization dialog box.
7. Repeat steps 2 – 6 until all classes have an assigned texture.
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8. Click OK to exit the Organization dialog box. The new settings are applied.
~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Wall Textures
Applying Roof Textures
Applying Textures to Symbols, Walls, and Roofs

Applying Wall Textures
Walls can be assigned a texture, and an associated surface hatch, individually with the Render tab of the Object Info 
palette, or, more efficiently, through an assigned class.
To apply a texture to a wall(s) by class:

1. Select Tools > Organization to open the Organization dialog box.
2. Select the Details view option, and then select the Classes tab.
3. Create a class for wall objects (see “Creating Classes” on page 177).
4. With the new class selected, click Edit to open the Edit Class(es) dialog box.
5. Select any fill Style other than None (otherwise the texture will not render).
6. The texture properties of the class are set in the bottom section of the dialog box. Click the Walls tab.
7. Select the desired Right, Center, and Left wall surface texture from either the default content or the current file’s 

content (see “Resource Libraries” on page 219). Select Use Textures/Surface Hatches At Creation to apply the 
texture/surface hatch at wall creation. See “Texture Projection and Orientation” on page 1527 to understand how 
textures are applied to wall faces.

8. Click OK to exit the Edit Class(es) dialog box.
The new walls class displays on the Classes tab of the Organization dialog box.

9. Click the blank area to the left of the Class Name to make the new class active.
10. Click OK to exit the Organization dialog box.
11. Create the wall(s); see “Creating Walls” on page 497.

The walls are created with the specified texture for that class. Existing wall(s) can be assigned the texture through 
the Object Info palette. Select the part of the wall to texture from the Part list and then Class Texture from the 
texture list on the Render tab.

~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Textures to Symbols, Walls, and Roofs

Applying Roof Textures
Textures, and their associated surface hatches, can be added to roof objects, dormers, and gable ends, either with the 
Render tab of the Object Info palette, or through an assigned class.
Use the Roof map type to map textures to roofs. The texture is automatically rotated for each individual roof face in the 
roof object.
To apply a texture to a roof object by class:

1. Select Tools > Organization to open the Organization dialog box.
2. Select the Details view option, and then select the Classes tab.
3. Create a new class for roof objects (see “Creating Classes” on page 177).
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4. With the new class selected, click Edit to open the Edit Class(es) dialog box.
5. Select any fill Style other than None (otherwise the texture will not render).
6. The texture properties of the class are set in the bottom section of the dialog box. Click the Roofs tab.
7. Assign a Top Texture, and if being used, a Dormer Texture from either the default content or the current file’s 

content (see “Resource Libraries” on page 219). Select Use Textures/Surface Hatches At Creation to apply the 
texture/surface hatch at creation.

8. Click OK to exit the Edit Class(es) dialog box. The class displays on the Classes tab of the Organization dialog 
box.

9. Click the blank area to the left of the Class Name to make the new class active.
10. Click OK to exit the Organization dialog box.
11. Create a roof with the Create Roof command (see “Creating Roof Objects” on page 571).

The roof is created with the specified texture for that class. Existing roofs can be assigned the texture through the 
Object Info palette. Select the part of the roof to texture from the Part list and then Class Texture from the texture 
list on the Render tab.

~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Textures to Symbols, Walls, and Roofs

Applying Renderworks Backgrounds 
Renderworks backgrounds, which include clouds, colors, images, and HDRI files, as well as a lit fog special effect, are 
resources saved with the file. They are applied to design layers on a per-layer basis. Backgrounds can also be applied to 
viewports by selecting the RW Background from the Object Info palette of a selected viewport. Backgrounds are also 
used in a variety of Renderworks styles; see “Renderworks Styles” on page 1596.

A Renderworks background can be quickly applied to the current design layer by double-clicking on the resource 
in the Resource Browser or by dragging it from the Resource Browser and dropping it into the current design 
layer.
The Lit Fog weather effect requires a light source (point or spot light) in the drawing with Lit Fog selected in the 
Object Info palette.

To apply a Renderworks background to the layer properties:
1. Create the background with the desired parameters (see “Creating Layer Backgrounds” on page 1522 for 

information on creating Renderworks backgrounds).
2. Select Tools > Organization to open the Organization dialog box.
3. From the Design Layers tab, select the design layer to receive the background.
4. Click Edit to open the Edit Design Layers dialog box.
5. Select the Renderworks Background for the layer from either the default content or the current file’s content (see 

“Resource Libraries” on page 219).
If the Renderworks Background choices are not available, the background selection is controlled by the 
Renderworks style in effect. Set the background in the Renderworks style instead.

6. Click OK to exit the Edit Design Layers dialog box.
7. Click OK to exit the Organization dialog box. 

When the drawing is rendered in a Renderworks mode, the background displays. OpenGL can display One Color, 
Two Color, and Image backgrounds.
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Applying a Renderworks Background in Vectorworks Design Series
To apply a Renderworks background to the current layer:

1. Create the background with the desired parameters (see “Creating Layer Backgrounds” on page 1522 for 
information on creating Renderworks backgrounds).

2. Select View > Set Renderworks Background (Vectorworks Design Series required).
The Set Renderworks background dialog box opens.

3. Select the Renderworks background for the current layer from either the default content or the current file’s 
content (see “Resource Libraries” on page 219).

4. Click OK.
When the drawing is rendered in a Renderworks mode, the background displays. OpenGL can display One Color, 
Two Color, and Image backgrounds.
When in unified view mode, the background selected here displays for all layers, overriding any background 
selected for individual layers in the layer properties. To retain the layer background upon exiting unified view, 
select Restore Original Views when exiting Unified View mode in the Unified View Options dialog box. See 
“Setting Unified View Options” on page 1152.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Layer Backgrounds

Renderworks Shader Types
Renderworks textures are composed of four shaders: color, reflectivity, transparency, and bump. Sections on the four 
shader types describe each and provide a description of the parameters obtained when editing shaders.
~~~~~~~~~~~~~~~~~~~~~~~~~
Color Shaders
Reflectivity Shaders
Transparency Shaders
Bump Shaders

Color Shaders 

Shader Description

Object Attribute Selects the object’s fill color attribute to apply as a color texture
Image Selects an imported image to apply as a color texture; the image can also be tinted with color 

(see “Creating Image-based Shaders” on page 1508)

Lit fog effect
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Color Specifies a color to be applied as a texture
Color Click the color box to select the shader color
Brightness (%) Lightens or darkens the selected color
Fresnel Can be used to create a texture with a somewhat fuzzy appearance, like that of a pillow that 

appears slightly darker or lighter on its edges
Edge Color Select the edge color by clicking the color box
Center Color Select the main color by clicking the color box
Bricks Creates a variegated brick pattern

Scale (%) Specifies the size of the bricks relative to the texture Size
Colors On the Bricks, Gaps, and Alt Bricks panes, click the color boxes to select color variations 

within a brick/gap, or choose the same color for no variation
Choose Image On the Bricks, Gaps, and Alt Bricks panes, click to use an image for the brick or gap texture. 

The chosen image is randomized to show no repetition on the textured object, so each brick/
mortar joint will look realistically unique.

For the completed brick surface to display correctly, the brick image should show only 
the flat face of a single brick or a portion of a brick, without any mortar joints. The gap 
image should show only mortar without any brick. Images of clay tiles and other similar 
materials can also be used in place of a brick.

Delete Image Removes the selected image from the shader and uses only colors to create the variegated 
pattern

Image Blend (%) When an image is used, specifies the blending between the image and the colors selected, to 
enhance the randomization of the resulting pattern. A low percentage value uses more color 
in the pattern, while a high value uses more of the image. The selected colors tint the image 
unless a blend value of 100% is set.

Bricks
Contrast (%) Sets the color contrast between the two brick colors, establishing the dot-like variation within 

a brick
Brick Width/
Height 

Sets the brick width and height in real-world dimensions

Shift (%) Sets the horizontal offset between rows of bricks
Half Brick Row Adds a row of half bricks at the specified row interval
Half Brick Shift 
(%)

For half-brick rows, sets the amount of horizontal shift

Gaps

Shader Description
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Size Sets the size of the mortar joint gap in real-world dimensions
Noise (%) Specifies the wobbliness of the mortar joints

Alt Bricks
Row Adds a row of alternate brick colors at the specified row interval
Column Adds a column of alternate brick colors at the specified column interval. Row must be greater 

than 0 to show columns.
Noise
Pattern Select the type of noise pattern to use. The preview helps distinguish the differences among 

the patterns. A generic noise pattern to select is Turbulence. Cell Voronoi is useful for 
creating speckled noise (set Low and High Clip around 70% each).
An example of each pattern is shown using default values for a color shader on a sphere with 
warm lighting on the top and cool lighting on the bottom. For comparison, this sphere has no 
texture applied:

The pattern might look different on a plane as opposed to the sphere used for the example. In 
addition, the appearance of each pattern can be dramatically affected by changes to its 
parameters. This example shows three variations of the blistered turbulence pattern.

Shader Description
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Pattern 
(continued)

Varying only the Low Clip and High Clip percentages can completely change the 
appearance of the pattern.

The selected shader type also obviously affects the appearance of the pattern. This example 
shows the blistered turbulence pattern as a color shader and as a bump shader.

Box Smoothed, random cube pattern

Blistered 
Turbulence

Varied distribution of light and dark areas

Buya Generally dark background with occasional random light areas

Shader Description

Low Clip%: 0
High Clip%: 100

Low Clip%: 60
High Clip%: 100

Low Clip%: 0
High Clip%: 25

Low Clip%: 50
High Clip%: 50



  1550 | Renderworks Shader Types
Cell Noise Tiled pattern with high contrast

Cranal Looping, curving pattern of lines

Dents Organic, twisted pattern of light and dark areas

Displaced 
Turbulence

Smooth version of turbulence, with random light and dark areas

FBM Finer, detailed pattern of random light and dark areas

Shader Description
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Hama Similar to the looping pattern of cranal, but more abrupt and with high contrast

Luka Mineral-like pattern of rough and more detailed areas

Mod Noise Similar to the tiled pattern of cell noise, but with less contrast

Naki Rough, concrete pattern

Noise Soft, random, and unfocused pattern of wider light areas and some dark areas

Shader Description
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Nutous Generally dark background with smooth, flaked light areas

Ober A variety of rough and detailed areas, interspersed with looping, flowing lines

Pezo Generally dark background with smaller, patchy, lighter areas

Poxo Fine-grained, detailed pattern

Random Very fine and even detailed pattern

Shader Description
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Sema Generally dark background with random, dripping/melted lines

Stupl Flowing, smeared pattern of light and dark areas

Turbulence Soft and smooth, yet detailed noise pattern

VL Noise Smoothed, varied, less-focused noise pattern

Wavy Turbulence Smooth, soft noise pattern with occasional random peaks

Shader Description
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Cell Voronoi Similar to mod noise, but with irregular mosaic shapes rather than square tiles

Displaced 
Voronoi

Organic voronoi pattern with smaller, inner pattern offset

Sparse 
Convolution

Soft, unfocused, wide pattern of light and dark areas

Voronoi 1 Organic, detailed voronoi pattern of small cell shapes

Voronoi 2 Blurred voronoi pattern with offset secondary pattern

Shader Description
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Voronoi 3 Sharp organic voronoi pattern of irregular cell shapes, high contrast with dark outlines

Zada Twisting, organic pattern with sharp looping areas and flat areas

Wood Detailed wood-grain pattern

Marble Marbled, veined pattern with high detail

Colors Click the color boxes to select color variations within the noise pattern
Scale

Global (%) Sets the size of the pattern as a percentage of the texture Size
Relative (%) U, 
V, W

Allows the pattern to be stretched in the U, V, and/or W direction; can be used to simulate the 
appearance of scratches

Options

Shader Description
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Dimensionality Select 2D Wrapped or 3D Solid. Wrapped shaders are 2D patterns projected onto a 3D object 
surface. Solid shaders are 3D patterns applied to a 3D object surface; when the shape 
changes, the object and pattern are still displayed correctly.

Detail Sets the level of detail or resolution for many of the patterns
Cycles Creates a repeating pattern of banded noise texture; set the number of repetition cycles to use 
Low/High Clip 
(%)

The low and high clip determine the abruptness of the transition between noise colors and are 
often set as a combination to achieve a desired effect. Set the Low clip higher or the high clip 
lower for a sharp transition to the other color; set the clips evenly to make the transition 
between noise colors more even.

Pavement Creates the appearance of cracked pavement; with no gaps, simulates variegated pavement, 
and with the same two colors, simulates solid pavement

Scale (%) Sets the size of the pavement as a percentage of the texture Size
Stones

Colors Click the color boxes to select color variations within the pavement, or choose the same color 
for no variation

Coarse Marbling 
(%)

Increases or decreases the coarse marbling appearance of the stones

Fine Marbling 
(%)

Increases or decreases the fine marbling appearance of the stones

Gaps
Colors Click the color boxes to select color variations within the pavement joints
Width (%) Sets the width of the pavement joint gap as a percentage of the texture Size
Softness (%) Sets the bevel amount between pavement stones and pavement joints
Grain (%) Sets the amount of color variation within the pavement gaps

Smudges

Shader Description

Wrapped shaderSolid shader



Renderworks Shader Types |  1557
Colors Click the color boxes to select color smudging variation within the pavement gaps
Amount (%) Sets the amount of smudging for the pavement gap smudges
Size (%) Increases or decreases the amount that the smudging extends from the gap centers

Tiles
Pattern Select the type of tile pattern. The preview helps distinguish the differences among the 

patterns. Some of the patterns use two of the tile colors, while others make use of all three.
Brick 1 Alternating brick pattern with two colors

Brick 2 Alternating brick pattern with three colors

Circles 1 Alternating polka dot pattern with two colors

Circles 2 Offset polka dot pattern with two colors

Shader Description
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Circles 3 Offset polka dot pattern with three colors

Hexagons Alternating hexagon pattern with three colors

Lines 1 Alternating pattern of lines with two colors

Lines 2 Line pattern with three colors 

Parquet Parquet pattern with three colors

Shader Description
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Planks Alternating rectangular pattern, similar to wood planks, with two colors

Radial Lines 1 Starburst pattern with two colors

Radial Lines 2 Starburst pattern with three colors

Random Irregular cellular pattern with blends of three colors for a stained glass effect

Rings 1 Alternating circular pattern with two colors

Shader Description



  1560 | Renderworks Shader Types
Rings 2 Alternating circular pattern with three colors

Sawtooth 1 Alternating zig-zag pattern with two colors

Sawtooth 2 Zig-zag pattern with three colors

Scales 1 Alternating scale pattern with two colors

Scales 2 Alternating scale pattern with three colors

Shader Description
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Spiral 1 Alternating spiral pattern with two colors

Spiral 2 Alternating spiral pattern with three colors

Squares Alternating checkerboard pattern with two colors

Triangles 1 Alternating triangle pattern with two colors

Triangles 2 Offset triangle pattern with two colors

Shader Description
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Triangles 3 Offset triangle pattern with three colors

Waves 1 Alternating wavy pattern with two colors

Waves 2 Wavy pattern with three colors

Weave Basketweave pattern with two colors

Colors Click on each color box to select the color for the grout, and up to three colors for the tiles
Randomize 
Colors

Uses randomly-selected colors for the pattern, mixing the selected colors in no particular 
order

Dimensions
Grout Width (%) Sets the width of the grout joint as a percentage of the texture
Bevel Width (%) Sets the bevel amount between tiles and grout
Horizontal 
Orientation

When selected, tiles are oriented horizontally; deselect for vertical tiles

Scale
Global (%) Sets the size of the tile pattern as a percentage of the texture Size

Shader Description
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Reflectivity Shaders
Transparency Shaders
Bump Shaders
Creating and Mapping Textures

Reflectivity Shaders 

Relative (%) U, 
V

Sets the relative scale of the tile pattern in the U (width) or V (height), allowing the tiles to be 
stretched

Shader Description

Image Specifies an imported image to be used as the reflectivity shader (white is 
more reflective; black is less reflective); see “Creating Image-based Shaders” 
on page 1508

Backlit This shader is useful for lamp shades, light bulbs, and curtains that are lit from 
behind. Deselect Cast Shadows in the Edit Texture dialog box when using the 
backlit shader.

Color Specifies a color to be applied as a backlit color; click the color box to select 
the color

Brightness (%) Controls the backlit brightness
Reflection (%) Sets the amount of reflection to use, or set to 0 for no reflection
Blurriness (%) Sets the amount of blurriness for the reflection, or set to 0 for no blur
Glass
Edge Color Click the color box to set the color applied to the glass at an angle, which is 

seen at the edge of the glass
Center Color Click the color box to set the color at the center (main) part of the glass
Blurriness (%) Sets the amount of blurriness for the reflection, or set to 0 for no blur
Glow The glow shader offers an alternative to creating line or area lights, and can 

create “neon” signs
Brightness (%) Sets the amount of glow
Emit Light Allows the texture to become a light source, when Indirect Lighting is enabled 

(View > Lighting > Set Lighting Options)
Add Matte Reflectivity Creates a partially glowing light that is also lit by other light sources
Reflection (%) Sets the amount of reflection to use, or set to 0 for no reflection
Blurriness (%) Sets the amount of blurriness for the reflection, or set to 0 for no blur
Metallic Creates metallic effects (also try colored mirror shaders for polished metal 

effects).
Metallic effects require the presence of light objects in the drawing. 
HDRI background lighting will not produce metallic effects.

Color Click the color box to select the metallic color

Shader Description
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Color Shaders
Transparency Shaders
Bump Shaders
Creating and Mapping Textures

Transparency Shaders 

Pattern Select the type of metallic pattern
• Metallic: provides a metallic paint effect (such as for car bodies)
• Brushed: provides a brushed metal appearance
• Turned: creates a machine-turned round pattern

Reflection (%) Sets the amount of reflection to use, or set to 0 for no reflection
Blurriness (%) Sets the amount of blurriness for the reflection, or set to 0 for no blur
Mirror
Color Click the color box to select the mirror color; use grayscale for a regular 

mirror effect, and select colors for mirrored metallic effects
Reflection (%) Sets the amount of reflection to use, or set to 0 for no reflection
Blurriness (%) Sets the amount of blurriness for the reflection; using a non-grayscale color 

and some blurriness creates an effective metallic look
Plastic
Color Click the color box to select the plastic color
Brightness (%) Sets how bright the shader appears
Roughness (%) Sets the width of shiny areas on the plastic; increase the percentage for wider 

shiny areas
Reflection (%) Sets the amount of reflection to use, or set to 0 for no reflection
Blurriness (%) Sets the amount of blurriness for the reflection, or set to 0 for no blur
Bricks These parameters are the same for all shaders; for a description, see “Color 

Shaders” on page 1546
Noise These parameters are the same for all shaders; for a description, see “Color 

Shaders” on page 1546
Pavement These parameters are the same for all shaders; for a description, see “Color 

Shaders” on page 1546
Tiles These parameters are the same for all shaders; for a description, see “Color 

Shaders” on page 1546

Shader Description

Image Mask Selects an imported image to apply as a transparency mask (see “Creating 
Image-based Shaders” on page 1508)

Shader Description
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Image Selects an imported image to apply as a transparency texture (see “Creating 
Image-based Shaders” on page 1508), for colored transparency and projected 
colored lights like gobo projections in the Vectorworks Spotlight software 

Color Specifies a color to be applied as a transparency
Color Click the color box to select the transparency color
Brightness (%) Lightens or darkens the selected color

Glass When using glass transparency, set the accompanying color shader to a dark 
color (or even black) for best results

Transmission (%) Sets how much light passes through the glass; set to a high value when the 
glass is very clear

Index of Refraction As light moves through a medium, the index measures the change in the 
direction of the light’s rays. An index of 1.0 indicates no change; a typical 
value for water and ice is 1.3, and for glass use 1.5 – 1.6.

To save time, use a value of 1.0x (just above 1) when the glass is thin.
Color Click the color box to select the color that appears in a very thin object; for 

glass, this is usually set to white
Blurriness (%) Blurs the transparency by the specified amount, or set to 0 for no blur. Blurred 

glass appears frosted (and takes longer to render).
Absorption Color Click the color box to select the color that a large, thick object assumes, when 

a ray of light has traveled the Absorption Distance

Absorption Distance Defines the distance rays of light have to travel before Absorption Color 
replaces Color. The lower the value, the more intense the Absorption Color 
is. This applies to thick or thin glass.

Plain Provides plain, uniform transparency of a specified amount

Shader Description

Different absorption colors (green, blue, and black, with the 
Color set to white)

Different absorption distances set, from low to high
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Color Shaders
Reflectivity Shaders
Bump Shaders
Creating and Mapping Textures

Bump Shaders 

Opacity (%) Sets how opaque the shader is; set to a lower value for more transparency and 
to a higher value for more opacity

Rectangular Mask Uses the texture as a rectangular mask to apply as a transparent texture 
(usually combined with another shader to create a specific masking effect). 
Useful for decals.

Horizontal/Vertical Repetitions Indicates how to display the mask: a single instance, infinite repetitions, or a 
set number of repetitions in each direction

Bricks These parameters are the same for all shaders; for a description, see “Color 
Shaders” on page 1546

Noise These parameters are the same for all shaders; for a description, see “Color 
Shaders” on page 1546

Pavement These parameters are the same for all shaders; for a description, see “Color 
Shaders” on page 1546

Tiles These parameters are the same for all shaders; for a description, see “Color 
Shaders” on page 1546

Shader Description

Image Specifies an imported image to be used as the source of the bump map 
displacement (see “Creating Image-based Shaders” on page 1508)

Bricks These parameters are the same for all shaders; for a description, see “Color 
Shaders” on page 1546

Noise These parameters are the same for all shaders; for a description, see “Color 
Shaders” on page 1546

Pavement These parameters are the same for all shaders; for a description, see “Color 
Shaders” on page 1546

Tiles These parameters are the same for all shaders; for a description, see “Color 
Shaders” on page 1546

Shader Description
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Color Shaders
Reflectivity Shaders
Transparency Shaders
Creating and Mapping Textures

Displacement Mapping For realistic bump textures, displacement mapping creates texture and bumpy 
details with a rendering technique that appears embossed, projecting the 
geometry outward from the surface.

This mapping applies only to Final Quality and Custom Renderworks, 
when Displacement Mapping is enabled in the render options. 
Rendering can be significantly slower with displacement mapping.
If an image bump does not provide the desired results, try a noise bump 
shader.

Height Specify a non-zero height to enable displacement mapping; large height 
values may result in longer render times

Detail Sets the level of detail for displacement mapping; requirements and results 
vary depending on the texture and the surface’s face size. Textures without 
too much bump detail and a large face size, such as boards or stones, render 
with less detail and can be set with a lower level of detail; fine, faceted 
textures like grass or leaves may require a high level of detail, which also 
requires more rendering time. Conversely, very large surfaces, like a ground 
plane, may need higher levels of detail to see the displacement.

Self-Shadowing Adds shadows to the displaced geometry, increasing realism as well as 
rendering time

Shader Description

Bump shader without 
displacement mapping

Bump shader with 
displacement mapping
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Rendering the Drawing
Rendering Overview
Rendering gives a solid appearance to 3D objects. Solid objects can cast shadows and occlude (hide) objects that are 
behind them.
The Vectorworks Fundamentals product provides a quick rendering solution using OpenGL (see “Rendering with 
Vectorworks” on page 1587). OpenGL performs lighting calculations for fast, interactive rendering and 
medium-quality render previews, but it cannot create reflections. For final-quality output, use the Renderworks 
product; it provides additional light sources, and it can cast shadows, create reflections, add indirect lighting effects, 
and produce much better rendering results through intensive lighting calculations. Render settings can be saved as a 
Renderworks style for re-use, and styles can be shared among files. The Renderworks product includes the 
Visualization palette for easily accessing all lights and cameras in the file. Another benefit of using the Renderworks 
product is that an image can be rendered in any mode from a specified portion of the drawing.

Optimizing Rendering Performance
Rendering is often a memory-intensive and time-consuming process. Modify your model and change rendering options 
in these ways to increase rendering performance and speed:

• Use the highest-level geometry possible to model your objects. It is much better to model an object as an extrude, 
sweep, Boolean solid, or a NURBS surface than as a mesh or a set of 3D polygons. For extrude and sweep 
profiles, use polylines, and do not use a sweep segment angle smaller than five degrees. Examine imported 
geometry for excessive vertices and polygons. The slowest way to model for rendering is to create a detailed 
object as a set of small, individual 3D polygons. 

• Eliminate 3D details that are not significant to the rendered image or the indirect lighting. For example, if you 
model a staircase's individual bolts and threaded screws, each of these will be contributing unnecessarily to the 
rendering time. Use classes to hide geometry that is not going to be visible in the rendered view.

• Test rendering settings on sheet layer viewports with lower sheet layer resolution values. Sheet layers can render 
in the background while you continue working. Sheet layers are set to 72 dpi by default, but for testing, set the dpi 
value even lower (such as 40). Zoom out of a drawing to reduce the rendered area, or use the Render Bitmap tool 
(Renderworks required) with a low dpi setting. 

• Use sheet layer viewports and render bitmaps for final renders, since they can render in the background 
(Renderworks render modes only).

• Consider turning off ambient lighting (Ambient Info off in the Lighting Options or set Ambient Light dialog box) 
to evaluate the contribution of individual light sources more clearly.

• Change rendering options temporarily to test a rendered look. For OpenGL options, disable Use Anti-Aliasing 
(Mac only). In the Custom Renderworks options (Renderworks required), set the Quality levels to low and turn 
Anti-Aliasing, and even Shadows, off. Render with Fast Renderworks to evaluate before switching to Final 
Quality or Custom Renderworks.
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• Shadows add to rendering time. Shadows can also be turned off for light objects that do not cast obvious shadows. 
In Renderworks, individual textures can be set not to cast or receive shadows (Shadows options in the Edit 
Texture dialog box). A clear glass texture, for example, has very slight shadows and does not cast shadows on 
other objects. In addition, enable soft shadows only for light sources that create prominent shadows in an image 
(for example, a directional light that represents the sun).

• When using indirect lighting (Renderworks required), use the fewest number of bounces needed (as specified in 
the Lighting Options dialog box) and adjust the quality in the Final Quality or Custom Renderworks settings. 
Individual textures can have their own indirect lighting setting overrides to reduce the rendering time required; 
disable indirect lighting for these textures.

• Area and line lights (Renderworks required) contribute significantly to rendering time. Use these light sources 
sparingly, and adjust the Quality of each in the Object Info palette. Only enable Soft Shadows for these lights if 
their shadows are prominent in the image.

• Reflective, blurry reflective, blurry transparent, and glow shaders add to rendering time (Renderworks required). 
Use these effects sparingly. Blurriness is faster at less than 15% and should not be set to more than 40% (for wide, 
shiny highlights, consider using a plastic or metallic reflectivity shader rather than a blurry reflection). Glowing 
objects need to be sampled more accurately and therefore, they take more time. Use the glow shader for a few, 
large objects; use the backlit shader for several small fixtures with simple light sources. 

• In Renderworks, glass adds to render times because it has reflective, refractive, and transparent shadow 
components. 
• Very clear glass can be set to not cast shadows in the Edit Texture dialog box to save render time. Indirect 

lighting can be disabled for glass textures in the Edit Texture dialog box, as well, to save time when calculating 
indirect lighting.

• For thin panes, like windows, the refractive qualities of glass are not significant, so the index of refraction 
parameter for the glass can be set to a low value (just above 1). 

• Often, buildings use glass with a metallic/mirrored energy efficient coating; in that case, a combination of 
mirror reflectivity and plain transparency can produce a glass effect that renders faster.

• Glass absorption color can be used for very accurate close-ups of items like glassware, but this effect takes 
longer to render.

• Blurry (frosted) glass, in particular, can be slow; use blurry glass in a strictly controlled way. Lower blur values 
render faster.

~~~~~~~~~~~~~~~~~~~~~~~~~
Adding Light
Advanced Renderworks Lighting
Renderworks Features for OpenGL
Preparing to Render
Background Rendering
Rendering with Vectorworks
Rendering with Renderworks
Rendering a Selected Area
Batch Rendering
Managing Lights and Cameras with the Visualization Palette
Exporting a Rendered Drawing

Adding Light
Once one or more light sources have been added to the drawing, it can be rendered to mimic the effect of light on the 
drawing surfaces.
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Default lighting is automatically added to a drawing for basic visibility of rendered objects. The default lighting is 
fixed to the “camera” so that it always lights an object appropriately. However, rendering a complex scene usually 
requires the addition of light sources; the addition of a visible light automatically hides the default lighting.
Light added to a Vectorworks drawing can be ambient or diffused. Ambient light affects all surfaces equally. Diffused 
lighting affects surfaces differently depending on the angle of the light source and position of the surfaces.
~~~~~~~~~~~~~~~~~~~~~~~~~
Ambient Light and Sunlight
Adding Light Sources

Ambient Light and Sunlight

Setting Lighting Options
The Set Lighting Options command specifies the ambient light brightness and default color for the current layer, or, 
when Unified View is selected, the view. By default, the ambient light parameters are set to On, with a Color of white, 
and a Brightness of 35%. When the Renderworks product is installed, this command also sets the white balance for 
any light sources with a color temperature, and specifies environment background lighting parameters when a 
Renderworks HDRI background resource has been added to the drawing.
The ambient light of a selected viewport can be edited by clicking Lighting Options from the Object Info palette (see 
“Creating Sheet Layer Viewports” on page 1616).
To set ambient light:

1. Switch to the layer where the desired ambient light settings are to be set.
2. Select View > Lighting > Set Lighting Options.

The Lighting Options (Renderworks required) or Set Ambient Light dialog box opens. Set the ambient light for 
the layer. The white balance setting can be adjusted for light sources in the layer with a color temperature specified 
(Renderworks required). For a chart of common color temperature ranges, see “Correlated Color Temperature” on 
page 1852.
If the lighting options are controlled by a Renderworks style that is currently in effect, the Edit Renderworks Style 
dialog box opens instead; see “Renderworks Styles” on page 1596.

Click to show/hide the parameters.
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3. Click OK.

Parameter Description

Indirect Lighting 
(Renderworks required)

Indirect lighting models the transfer of light energy among drawing objects and 
materials, as the light bounces around and affects the surroundings. The more 
bounces specified, the more realistic the rendering, but also the more time required 
to render.
Select the level of indirect lighting to use for rendering:

• None: Direct lighting only, for quick rendering
• Exterior, 1 Bounce: One bounce of lighting is often enough to enhance 

exterior views
• Normal, 2 Bounces: Two bounces of indirect lighting is appropriate for 

exterior scenes and well-lit interiors
• Interior, 4 Bounces: Using four bounces of indirect lighting is suited for 

darkened or partially-lit interior scenes, or very detailed and complete indirect 
lighting

Individual textures can have their own indirect lighting setting overrides to enhance 
a scene while reducing the rendering time required.
When rendering with Fast Renderworks, indirect lighting is rendered at a “Low” 
quality; Final Quality Renderworks uses a “High” quality setting for indirect 
lighting, and Custom Renderworks allows the quality setting to be selected.

Ambient Info
On/Off Activates or deactivates the ambient light settings for the layer
Brightness Specifies the ambient light brightness; enter a percentage or drag the slider bar
Color Specifies a default color associated with the ambient light; click the color box to 

select the color
Emitter Options
(Renderworks required)

Emitter Brightness (%) Adjusts the brightness of all light objects with Use Emitter selected
White Color 
Temperature

Select a color temperature that will be balanced to appear white. Lower 
temperatures, which might otherwise have an orange cast, or higher temperatures, 
which might otherwise appear with a blue tint, are adjusted to appear white. Select 
Custom to specify a temperature to be white balanced.

Custom (K) If a Custom Color Temperature is specified, enter the temperature in Kelvin
Environment Lighting 
(HDRI) (Renderworks 
required)

When an HDRI layer background has been selected for the layer or viewport, 
specifies how to control its lighting contribution to the rendering (see “Creating 
HDRI Backgrounds” on page 1524)

From Current 
Background

Uses the image environment background set for the layer as both a background and 
a light source

From Selected 
Background

Lights the model with the colors from the HDRI background selected here

None Uses the image environment background set for the layer or viewport as a 
background only. The background does not contribute to lighting.
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Adding Light
Adding Sunlight
Shadow Analysis

Adding Sunlight
Sunlight in Vectorworks Fundamentals is created by projecting parallel rays from a directional light.

The Vectorworks Design Series products have expanded capabilities with the Heliodon tool; see “Solar Studies” 
on page 1489.

To set the sun position:
1. Select View > Lighting > Set Sun Position.

The Set Sun Position dialog box opens. Enter the sun position information.
Click to show/hide the parameters.

2. Click OK and verify the results. If a directional light was selected before choosing the Set Sun Position 
command, the command modifies the angles of light to the new azimuth and elevation. If no light was selected, 
the tool inserts a new directional light at the specified sun position.
A shadow analysis can be performed for a site by inserting several light sources with identical parameters except 
for time of day. The Renderworks product must be installed to conduct a shadow analysis.

~~~~~~~~~~~~~~~~~~~~~~~~~
Adding Light
Shadow Analysis
Applying Colors

Shadow Analysis
With the Renderworks product, a shadow analysis can help determine the areas of the drawing that will receive less 
sunlight or remain in a shadow during a particular time of the year. By inserting several directional light sources, each 
representing a different time of day, an overlapping range of shadows is created which indicates the amount of time a 
particular area is in the shade over the course of the day.

Parameter Description

Site Specifies the site’s latitude and longitude
Time Zone 
Meridian

Specifies the site’s time zone; one hour of difference is equal to 15º of longitude

Page North Normally, the drawing is oriented to page north (true north, not magnetic north), and true 
north matches the top of the page, with no compensation required for proper sun position. 
If the drawing was not created with this orientation, specify an angular offset in degrees 
from page north. The North indicator should match true north in the drawing.

Date Specifies the time of year
Time Specifies the time of day

Daylight Savings Select if Daylight Saving time is in effect
Results Based on the settings made, displays the Azimuth (South at zero degrees, without Page 

North rotation), Azimuth N. Relative (North at zero degrees, without Page North 
rotation), Elevation (degrees above the horizon), and True Solar Time (takes into 
account daylight savings time, site longitude and time zone, and the earth’s orbit and tilt) 
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To perform a shadow analysis:
1. Add the objects to the drawing that will cast a shadow on the site (a house, for example).
2. Orient the drawing to page north. If the drawing was not created with this orientation, this can be compensated 

through the Set Sun Position dialog box described in the next step.
3. Insert each directional light source by selecting View > Lighting > Set Sun Position. Inserting one light source 

provides shadow information for that time of day only; several light sources set to different times of day yield an 
actual shadow analysis with overlapping shadows.
The Set Sun Position dialog box opens. See “Adding Sunlight” on page 1573
For each light source inserted with this command, specify the same parameters except for time of day. At a 
minimum, a light source for morning, noon, afternoon, and evening should be inserted.

4. Verify the parameters of each directional light source in the Object Info palette. Ensure that Cast Shadows is 
selected, and decrease the Brightness so that the combination of lights is not too harsh.

5. Render the drawing with the Fast Renderworks, Custom Renderworks, or Final Quality Renderworks option. 
Use the Render Bitmap tool to render a portion of the image for presentations.
See “Rendering a Selected Area” on page 1608 for more information on the Render Bitmap tool.

~~~~~~~~~~~~~~~~~~~~~~~~~
Adding Light
Adding Sunlight
Solar Studies

Adding Light Sources
The Light tool places light sources in the drawing. Select the type of light and specify the light preferences from the 
Tool bar.

Top view – Shadow analysis

The darkest areas
are in shade for the

longest portion of
the day

June 21st

5 PM 3 PM 12 PM

9 AM
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When the Renderworks product is installed, additional parameters and light source types are available. These 
additions are described in this section and in “Advanced Renderworks Lighting” on page 1582.

 

~~~~~~~~~~~~~~~~~~~~~~~~~
Adding a Light Source
Light Source Properties

Adding a Light Source
Adding a visible light source to a drawing hides the default lighting scheme that is automatically present for basic 
rendering purposes.

To add a light source:

1. Click the Light tool from the Visualization tool set.
From the Tool bar, select the type of light source to insert (directional light, point light, or spot light). If inserting a 
directional light, select the light placement method (Default Direction or Set Direction).

2. Click the Preferences Tool bar button to specify the light source preferences for this session. Depending on the 
light source selected, different parameters are available. In addition, certain parameters are only available when 
the Renderworks product is installed.
The Light Preferences dialog box opens. Set the parameters.

Click to show/hide the parameters.

Mode Description

Directional 
Light

 

Projects light with parallel rays, like the sun

Point Light Radiates light in all directions, like a bare light bulb 

Spot Light Projects light in a specific direction, aimed at a specific object, like a flashlight or 
conventional spotlight

Default 
Direction

For directional lights, click to specify the light position

Set Direction For directional lights, click to set the light direction, and then click to specify the light 
position

Preferences Sets the preferred light parameters

Directional Light Preferences

Point Light Default Direction

Spot Light Set Direction
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3. Click Directional Light Specs, Spot Light Specs, or Point Light Specs, for the selected light source type, to 
specify additional parameters.

Click to show/hide the parameters.

Parameter Description

On/Off Shows or hides the light produced by the light source
Color Specifies a color associated with the light source; click the color box to select the 

color. This parameter is not available if Use Emitter is selected and a Color 
Temperature is specified (Renderworks required).

Cast Shadows
(Renderworks required)

Select to create shadows 

Soft Shadows 
(Renderworks 
required)

Creates more realistic shadows by decreasing hard edges; shadows appear softer the 
farther they travel, as in reality. Rendering is slower when this option is enabled.

Brightness Specifies the light source brightness; enter a percentage or drag the slider bar. A value 
over 100% can be entered. This parameter is not available if Use Emitter is selected 
(Renderworks required).

Use Emitter
(Renderworks 
required)

For accuracy, specifies the light’s actual brightness and color temperature; leave 
deselected to use the light as a simple light source

Get Brightness From
(Renderworks required)

Specifies the luminous quantity of a light

User Input
(Renderworks 
required)

Specifies the brightness as an accurate number in Lux, Lumens, Footcandles, or 
Candelas; the units vary depending on the light source

Distribution File
(Renderworks 
required)

Does not apply to directional, point, or spot lights (see “Advanced Renderworks 
Lighting” on page 1582)

Color Temperature
(Renderworks required)

Specifies the light color temperature in Kelvin. This refers to an ideal black body 
emitter, glowing “red hot” or “white hot.” A lower temperature generates an orange 
color; the hotter the temperature, the closer to white the color of the light is.
Specifying this parameter is optional. If not specified, the default temperature is 0, 
meaning that the final emission color for the light is entirely controlled by the 
selection in Color. 
When the temperature is specified, Color cannot be changed. The final emission color 
is set by the Color Temperature.
Color temperature settings can be white-balanced on a per-layer basis; see “Setting 
Lighting Options” on page 1571.

Directional, Spot, or 
Point Light Specs

Click to set additional specifications for the light source

Parameter Description

Directional Light
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4. Click OK to return to the Light Preferences dialog box. Click OK to return to the drawing.
5. Click to place a light object with the parameters specified in the Light Preferences dialog box.

If placing a directional light, click to specify the light position in Default Direction mode. In Set Direction mode, 
click once to specify the light target or direction, and then click a second time to specify the light position.

Direction Specifies the light’s direction by either specifying the light angle or vector
Angle Sets the light’s angle by azimuth and elevation. The azimuth angle is set based on an 

angle of 0 degrees at the negative Y axis, and is positive in a counter-clockwise 
direction; the elevation angle is the angle above (positive) or below (negative) the 
horizon.

Vector Indicates the direction of the light by specifying the coordinates of its X, Y, and Z 
vectors

Point Light
Dist Falloff Select the distance falloff function (rate of intensity change while moving along the 

beam away from the light source):
• None: Brightness does not change
• Smooth: Brightness decreases according to a linear falloff
• Realistic: Light is brightest near the light source, and falls away according to the 

square of the distance, as in reality. This falloff selection is the most natural in 
appearance.

Spot Lights
Spread/Beam 
diagram

Drag the handles on the diagram to set the spot light Spread and Beam angles, or enter 
the values in the fields below the diagram

Spread Specifies the spread angle of the spot light (light cone’s maximum angle)
Beam Specifies the beam angle of the spot light (cone of light that does not change intensity up 

to the spread angle)
Dist Falloff Select the distance falloff function (rate of intensity change while moving along the 

beam away from the light source):
• None: Brightness does not change
• Smooth: Brightness decreases according to a linear falloff
• Realistic: Light is brightest near the light source, and falls away according to the 

square of the distance, as in reality. This falloff selection is the most natural in 
appearance.

Parameter Description

Spread Beam
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If placing a spot light, click to place the light, and then drag to specify the light direction and target. The spot light 
can be aimed at any object. Click again to set the spot light. The target Z height can be adjusted precisely with the 
Look To Height parameter of the Object Info palette.
The spot light target handle and projection line only display when the spot light is selected. Use the Selection tool 
to move the light. The target handle aims the spot light and can be adjusted with the Selection tool once the spot 
light has been created. Use the Reshape tool to move the target handle constrained about an axis selected in the 
Tool bar.

 

~~~~~~~~~~~~~~~~~~~~~~~~~
Adding Light Sources
Light Source Properties
Managing Lights and Cameras with the Visualization Palette

Light Source Properties
Light source parameters are displayed and can be modified in the Object Info palette. The parameters available depend 
on the type of light source.
Some of the parameters are only available when the Renderworks product is installed; see “Advanced Renderworks 
Lighting” on page 1582 for information on the Renderworks light types.
Click to show/hide the parameters.

Click 1

Click 2

Set Direction mode of directional light placement depicted

Click 1

Click 2
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Parameter Description

Kind Indicates the type of light source; change to a different type by selecting a different kind 
from the displayed list
A custom, area, or line light requires that the Renderworks product be installed.

On/Off Shows or hides the light produced by the light source. This setting can also be accessed 
from the light context menu: right-click (Windows) or Ctrl-click (Mac) on the light, and 
select Turn On or Turn Off.

Auto Update Automatically renders the drawing when rendering-related parameters change
Update When Auto Update is deselected, click to render the drawing when rendering-related 

parameters change
Cast Shadows 
(Renderworks 
required)

Select to create shadows

Soft Shadows 
(Renderworks 
required)

Creates more realistic shadows by decreasing hard edges; rendering is slower when this 
option is enabled

Lit Fog 
(Renderworks 
required)

Creates a special volumetric lighting effect for point lights and spot lights when used in 
combination with the Lit Fog Renderworks background weather effect (see “Creating a 
Background” on page 1522)

Use Emitter 
(Renderworks 
required)

For accuracy, specifies the light’s actual brightness and color temperature; leave deselected 
to use the light as a simple light source. Required for a custom, area, or line light. The 
emitter brightness of all light objects in a scene with Use Emitter selected can be 
controlled in Lighting Options; see “Setting Lighting Options” on page 1571.

Brightness Specifies the light source brightness; enter a percentage or drag the slider bar. A value over 
100% can be entered. This parameter is not available for custom, area, and line lights, or if 
Use Emitter is selected (Renderworks required).

Brightness From 
(Renderworks 
required)

Specifies the location of the light intensity data for a custom light (either user input or 
distribution file); the distribution file can be specified by clicking Load Distribution

Brightness Value 
(Renderworks 
required)

Specifies the brightness as an accurate number

Brightness Unit 
(Renderworks 
required)

Select Lux, Lumens, Footcandles, or Candelas for the unit of Brightness; the available 
units depend on the light type

Dimmer 
(Renderworks 
required)

Dims the light source brightness (intensity); enter a percentage or drag the slider bar. Only 
the brightness of the light source is affected; the color temperature is not changed.

Light Rotation Angle 
(Renderworks 
required)

Specifies the rotation angle of a custom light source around an axis connecting the light 
location to the light target; this angle defines the plane for the intensity distribution curve, 
and is displayed in red on the custom light object
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Use Distribution File 
(Renderworks 
required)

Specifies whether to use the attached emission profile data file for the custom light

Distribution File 
(Renderworks 
required)

For a custom light, displays the distribution file name when a valid distribution file has 
been selected, or “None” if a valid distribution file has not been designated (click Load 
Distribution to specify a file)

Load Distribution 
(Renderworks 
required)

For a custom light, loads light emission profile data from a standard file. The brightness 
value is obtained using the integral of the raw emission data provided with the file. The file 
must be a text file with industry standard intensity distribution data in .ies format.

Color Temperature 
(Renderworks 
required)

Specifies the light color temperature in Kelvin. This refers to an ideal black body emitter, 
glowing “red hot” or “white hot.” A lower temperature generates an orange color; the 
hotter the temperature, the closer to white the color of the light is (see “Correlated Color 
Temperature” on page 1852 for typical light source color temperature ranges).
Specifying this parameter is optional. If not specified, the default temperature is 0, 
meaning that the final emission color for the light is entirely controlled by the selection in 
Color. 
When the temperature is specified, Color cannot be changed. The final emission color is 
set by the Color Temperature.
Color temperature settings can be white-balanced on a per-layer basis; see “Setting 
Lighting Options” on page 1571.

Color Specifies a color associated with the light source; click the color box to select the color. 
This parameter is not available if Use Emitter is selected and a Color Temperature is 
specified (Renderworks required).

Dist Fall Indicates the distance falloff function for a point, spot, custom, area, or line light (specifies 
the rate of intensity change while moving along the beam away from the light source)

Quality 
(Renderworks 
required)

For area and line lights, specifies the sampling quality of the light; select From Render 
Mode to use the settings specified for Soft Shadows quality in the rendering options

Render Geometry 
(Renderworks 
required)

For area and line lights, renders the light object geometry

Spread/Beam 
diagram

Drag the handles on the diagram to set the spot light Spread and Beam angles, or enter the 
values in the fields below the diagram

Spread Specifies the spread angle of the spot light (light cone’s maximum angle)
Beam Specifies the beam angle of the spot light (cone of light that does not change intensity up to 

the spread angle)
X/Y/Z or X’/Y’/Z’ Specifies the location of the light source in relation to the active layer plane or working 

plane
Look To Height For spot lights, sets the Z height above the active layer plane of the spot light target handle

Parameter Description

Spread Beam
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A symbol that contains a light object can be copied to reproduce identical lights. Change the light intensity for 
each symbol in the Object Info palette.

Once a light has been placed on the drawing, the Selection tool can be used to change its location, and, depending on 
the light type, beam parameters.

Azimuth Indicates the azimuth for a directional light (South at zero degrees); enter new values or 
drag the slider bar to set

Elevation Indicates the elevation (degrees above the horizon) for a directional light; enter new values 
or drag the slider bar to set

Pan/Tilt

 

Click the top button to display the spot light or custom light beam pan and tilt angles; enter 
new values or drag the slider bar to set

±X/±Y/±Z

 

Click the bottom button to display the light beam direction in terms of its X, Y, and Z 
components

Set Light to View Sets the orientation of the directional, spot, or custom light to that of the current view. This 
setting can also be accessed from the light context menu: right-click (Windows) or 
Ctrl-click (Mac) on the light, and select Set Light to View.

Set View to Light Sets the orientation of the current view to that of the directional, spot, or custom light. This 
setting can also be accessed from the light context menu: right-click (Windows) or 
Ctrl-click (Mac) on the light, and select Set View to Light.

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Managing Lights and Cameras with the Visualization Palette

Advanced Renderworks Lighting
Default lighting is added by the Vectorworks program for the basic visibility of rendered objects. For a more realistic 
rendering, one or more light sources can be added to the drawing. The addition of a light source automatically hides the 
default lighting scheme, so that the scene is not overly bright.

The brightness and color of objects in shadow are affected by the layer’s ambient light setting.

Light Type Beam Parameter Description

Point, Spot, 
Directional

Light location Click on the light with the move cursor and drag it to its 
new location

The spot light target handle is not locked to its target. 
The target handle location may need re-adjusting after 
moving the spot light.

Spot, Directional Orientation and 
view

Select the light; in the Object Info palette, click Set 
Light to View to set the light orientation to the current 
view orientation, or click Set View to Light to set the 
orientation of the view to that of the light

Directional Azimuth and 
elevation direction

Click on the azimuth or elevation control points to 
change the directional light parameters. Move the 
handles with the mouse, or enter the azimuth and 
elevation values in the Data bar.

Spot Target direction Click on the handle with the Selection tool to change the 
spot light target direction; drag to the new target and 
click to set

Directional Beam direction Click and drag with the hand cursor to change the beam 
direction

Azimuth control point

Elevation
control point

Light location 
control point

Click

Click
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The Vectorworks Fundamentals product provides three light types: directional, point, and spot. With the Renderworks 
product, additional parameters are provided for these light types, and additional light source types are included.

Renderworks product rendering modes must be used for the Renderworks lighting options.
For information on the lighting types and parameters in the Vectorworks Fundamentals product, see “Adding Light” on 
page 1570.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting an Area or Linear Light
Inserting a Custom Light
Light Source Properties
Rendering with Renderworks

Inserting an Area or Linear Light 
An area or linear light can be created from an existing object or line. Unlike the other light source types, which are 
emitted from a specific, concentrated source, area and linear lights emanate from an extended object. This is useful for 
creating diffused light sources with softer lighting, such as fluorescent lights, neon lights, windows, and skylights.
An area light cannot be textured. Use a glow reflectivity shader to create textured objects that emit light only when 
indirect lighting is enabled in the Lighting Options dialog box.

The addition of multiple diffused light sources can add significantly to rendering time. For efficiency, replace a 
small area or line light with a point, spot, or directional light. In addition, since area lights can be slow to render, it 
may be better to use an Image Environment (HDRI) or physical sky background to supply the background (sky) 
lighting.

To create an area or linear light from an existing object or objects:
1. If creating an area light, select the object to convert to a light source; area light geometry should enclose a surface 

(a line or open polyline cannot be used, for example). Select a 2D line, closed 2D surface, or NURBS curve if 
creating a linear light.
Select more than one object to create several line or area lights at the same time.
Curved surfaces used for an area light require more rendering time than planar surfaces.

2. Select Modify > Convert > Convert to Area Light or Modify > Convert > Convert to Line Light.
The Light Preferences dialog box opens; indicate the area or line light parameters. Specify light intensity by 
entering a Get Brightness From value.

Click to show/hide the parameters.

Light Type Description Product

Directional Projects light with parallel rays Vectorworks and 
Renderworks

Point Radiates light in all directions Vectorworks and 
Renderworks

Spot Projects light in a specific direction Vectorworks and 
Renderworks

Line Emits light from a line Renderworks only
Area Emits light from the surfaces of objects Renderworks only
Custom Emits light based on a defined complex spatial distribution Renderworks only
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3. Click Area Light Specs or Line Light Specs to set additional parameters.
The Area Light Data or Line Light Data dialog box opens.

Click to show/hide the parameters.

4. Click OK to return to the Light Preferences dialog box.

Parameter Description

On/Off Shows or hides the light produced by the light source
Color Specifies a color associated with the light source; click the color box to select the color. 

This parameter is not available if a Color Temperature is specified.
Cast Shadows Creates shadows

Soft Shadows Creates more realistic shadows by decreasing hard edges; rendering is slower when this 
option is enabled

Dimmer (%) Dims the light source brightness (intensity); enter a percentage or drag the slider bar. 
Only the brightness of the light source is affected; the color temperature is not changed.

Use Emitter An area or line light’s actual brightness and color temperature must be specified, so this 
setting is not optional

Get Brightness From Specifies the luminous quantity of the area or line light
User Input Manually specifies the luminous quantity of an area light as an accurate number; the units 

of a line light are always Lumens
Distribution File For custom lights only; does not apply to area or line lights

Color Temperature Specifies the light color temperature in Kelvin. This refers to an ideal black body emitter, 
glowing “red hot” or “white hot.” A lower temperature generates an orange color; the 
hotter the temperature, the closer to white the color of the light is (see “Correlated Color 
Temperature” on page 1852 for typical light source color temperature ranges).
Specifying this parameter is optional. If not specified, the default temperature is 0, 
meaning that the final emission color for the light is entirely controlled by the selection in 
Color. 
When the temperature is specified, Color cannot be changed. The final emission color is 
set by the Color Temperature.
Color temperature settings can be white-balanced on a per-layer basis; see “Setting 
Lighting Options” on page 1571.

Area or Line Light 
Specs

Sets specific area or line light options

Parameter Description

Dist Falloff Select the distance falloff function (rate of intensity change while moving along the beam 
away from the light source)

Quality For area and line lights, specifies the sampling quality of the light; select From Render 
Mode to use the settings specified for Soft Shadows quality in the rendering options

Render Geometry Renders the light object geometry; deselect to hide the original geometry when rendering



Advanced Renderworks Lighting |  1585
5. Click OK. The object or line is converted into a light. If more than one object was selected for conversion, the 
converted objects are grouped. The area light emits light in both surface directions.
The light must be rendered with a Renderworks product rendering mode. When an area light is on and rendered, it 
has constant reflectivity and does not receive shadows; when it is off, it displays as a normal object.
If a line light with Cast Shadows enabled is not casting light as expected, the center of the line light’s bounds may 
be inside another object, which prevents shadow calculations. If this occurs, either deselect Cast Shadows, use 
several line lights, or split the line light geometry into segments with their bounding centers located outside of 
another object.

Editing an Area or Linear Light
The light parameters can be edited in the Object Info palette.
The area or linear light original geometry can be edited.
To edit the original light geometry:

1. Select the area or line light and then select Modify > Edit Light.
The Edit Light window opens, and the original 3D object or a NURBS representation of a 2D object is displayed.

2. The object geometry can be edited with the Reshape tool.
3. Click Exit Light at the top right of the drawing window to return to the drawing.

Inserting a Custom Light
A custom light source’s emission distribution can be defined by a standard intensity distribution profile for accurate 
physical lighting.

To create a custom light:

1. Select the Light tool from the Visualization tool set, and then select Custom Light from the Tool bar.
2. Specify the custom light parameters by selecting Preferences from the Tool bar.

The Custom Light Data dialog box opens. Click Load Distribution and specify the location of the custom light 
distribution file, and then specify any additional custom light parameters.

Click to show/hide the parameters.

Parameter Description

Light Rotation 
Angle

Specifies the rotation angle of the light source around an axis connecting the light location to 
the light target; this angle defines the reference plane for the intensity distribution curve

Distribution File Displays the distribution file name when a valid distribution file has been selected, or 
“None” if a valid distribution file has not been designated (click Load Distribution to 
specify a file)

Load Distribution Loads light emission profile data from a standard file. The brightness value is obtained using 
the integral of the raw emission data provided with the file. The file must be a text file with 
industry standard intensity distribution data in .ies format.

Dist Falloff Select the distance falloff function (rate of intensity change while moving along the beam 
away from the light source)

Direction Specifies the light’s direction by either specifying the light angle or vector
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3. Click OK.
The Light Preferences - Custom Light dialog box opens. Specify additional custom light parameters. Emitter 
parameters are specified by the distribution file, and cannot be changed.

Click to show/hide the parameters.

4. Click OK to return to the drawing.
5. Click in the drawing to insert the custom light.

Angle Sets the light’s angle by pan and tilt. The pan angle is based on an angle of 0 degrees at the 
positive Y axis, and is positive in a counter-clockwise direction; the tilt angle is equal to 0 at 
the horizontal plane, positive when pointing below the plane, and negative when pointing 
above the plane.

Vector Indicates the direction of the light by specifying the coordinates of its X, Y, and Z vectors

Parameter Description

On/Off Shows or hides the light produced by the light source
Color Specifies a color associated with the light source; click the color box to select the color. This 

parameter is not available if a Color Temperature is specified.
Cast Shadows Creates shadows
Dimmer Dims the light source brightness (intensity); enter a percentage or drag the slider bar. Only 

the brightness of the light source is affected; the color temperature is not changed.
Use Emitter A custom light’s actual brightness and color temperature must be specified, so this setting is 

not optional
Get Brightness 
From

Specifies the luminous quantity of the area or line light as a manually entered value or from 
a loaded distribution file

User Input Manually specifies the brightness in Lux or Lumens
Distribution 
File

Sets intensity distribution data with a standard file specified in Custom Light Specs. The 
brightness value is obtained using the integral of the raw emission data provided with the 
file. 

Color 
Temperature

Specifies the light color temperature in Kelvin. This refers to an ideal black body emitter, 
glowing “red hot” or “white hot.” A lower temperature generates an orange color; the hotter 
the temperature, the closer to white the color of the light is (see “Correlated Color 
Temperature” on page 1852 for typical light source color temperature ranges).
Specifying this parameter is optional. If not specified, the default temperature is 0, meaning 
that the final emission color for the light is entirely controlled by the selection in Color. 
When the temperature is specified, Color cannot be changed. The final emission color is set 
by the Color Temperature.

Color temperature settings can be white-balanced on a per-layer basis; see “Setting 
Lighting Options” on page 1571.

Custom Light 
Specs

Specifies additional custom light options and loads a distribution file

Parameter Description



Preparing to Render |  1587
The custom light object is represented by a pair of perpendicular arrow-head vectors and two perpendicular 
circles. The black vector points to the target location; its axis line (the light axis) connects the light source location 
to the target. The red vector starts at the light source location, pointing to a reference point on the “equator” of the 
polar intensity distribution. Also known as the “zero angle line,” it represents the origin for measuring the 
intensity on the light curve.
The two vectors form the black circle, and the red circle is perpendicular to it. The black circle represents the 
original plane where the light curves are located. The red circle constrains the movement of the zero angle line.

After a custom light has been placed, the light parameters can be edited in the Object Info palette.
~~~~~~~~~~~~~~~~~~~~~~~~~
Light Source Properties

Preparing to Render
Once the drawing is complete or near completion, any textures have been applied, and the desired lighting has been 
added, select one of the standard views (see “Using Standard Views” on page 1141), and use the Flyover, 
Walkthrough, Translate View, or Rotate View tools to orient the drawing. For presentation purposes, it is often easier 
to create sheet layer viewports and render the sheet layers, or create render bitmaps; both sheet layer viewports and 
render bitmaps can render in the background (Renderworks required) while drawing processes can continue.
~~~~~~~~~~~~~~~~~~~~~~~~~
Rendering with Vectorworks
Rendering with Renderworks
Background Rendering
Optimizing Rendering Performance
Rendering a Selected Area
Batch Rendering

Rendering with Vectorworks
The render modes in the Vectorworks program translate the drawing in various ways to create an image with additional 
realistic details. For example, a Hidden Line rendering is similar to the non-rendered (Wireframe) image, but it hides 
the portion of the objects that would not normally be visible. An OpenGL rendering also has hidden lines, and colors 
and shading; it also shows how the light sources interact with the object surfaces, and it can show any textures that 
were applied.

The View bar displays the Render Modes for quick access to the rendering commands. The View bar options 
display the Render Mode - Short (displaying a shortened version) or the Render Mode - Long (displaying the 
current render mode options and the current render mode). The Current Render Mode Options button opens the 
settings dialog box for the current render mode, if applicable.

To select a render mode:
Select View > Rendering, and then select the desired render mode.

Render Modes listCurrent Render Mode Options



  1588 | Rendering with Vectorworks
To cancel a render process before it is complete, press Esc.

Rendering Command Description

Wireframe A visual representation of the model is created using lines to represent object 
edges; see “Wireframe Options” on page 1589 to adjust settings for planar objects

OpenGL Creates a good-quality, detailed rendering, with colors, shading, and textures 
(optional); see “OpenGL” on page 1590 for details

Hidden Line Hides the edge lines of objects that are behind other objects, which gives a solid 
appearance; with the Renderworks product installed, optionally displays surface 
hatches that give the appearance of textures (see “Hidden Line Rendering with 
Surface Hatches” on page 1606)

Dashed Hidden Line Edge lines of objects that are behind other objects display as dashed lines

Unshaded Polygon Displays objects as solids, and displays attributes such as colors
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A Vectorworks preference sets the preferred 3D render mode, applied whenever the drawing is switched from Top/
Plan into a 3D view; see “3D Preferences” on page 54.

If you have a Vectorworks Service Select subscription, you can use the Vectorworks Nomad app to view and present 
your 3D drawings rendered in OpenGL on your iOS mobile device. Click here for more information.
~~~~~~~~~~~~~~~~~~~~~~~~~

Vectorworks Cloud Services
Line Render Options
Rendering with Renderworks

Wireframe Options
Planar objects with solid fills are drawn in stacking order. In a 3D wireframe view, objects may overlap, obscuring 
objects lower in the stacking order. The wireframe options control whether fills should be visible for planar objects in 
3D views, and if they are visible, sets the fill opacity of filled planar objects.
To set wireframe options:

1. Select View > Rendering > Wireframe Options.
The Wireframe Options dialog box opens.

Click to show/hide the parameters.

Shaded Polygon An Unshaded Polygon rendering with shading added

Shaded Polygon - No Lines A Shaded Polygon rendering with no edge lines

Final Shaded Polygon A Hidden Line rendering on top of a Shaded Polygon - No Lines rendering; edges 
and curved surfaces are cleaner than those in a Shaded Polygon rendering

Parameter Description

Show fills in planar 
objects in 3D views

Displays fills for 2D planar objects in 3D views

Rendering Command Description

http://www.vectorworks.net/service-select/cloud-services/
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2. Click OK to set the wireframe options.

OpenGL
Use the OpenGL render mode to create good-quality rendering previews that are fast and interactive. (For final-quality 
output, use the Renderworks product; see “Renderworks Rendering Modes” on page 1593.)

2D planar objects and graphics render with full fill attributes.
The Vectorworks program has a default lighting scheme, so that a basic rendering does not require an added light 
source. However, the addition of a light source is usually necessary for a more realistic rendering (see “Adding Light 
Sources” on page 1574). The addition of a light source automatically hides the default lighting scheme, so that the 
scene is not too bright. 

OpenGL renders up to eight lights in a drawing; additional ambient light, directional, point, or spot lights have no 
effect. Custom, area, and linear lights can be added (Renderworks required).

To get the best performance from OpenGL, use a video card that supports hardware-accelerated OpenGL. There are 
significant compatibility issues with some cards; see www.vectorworks.net for a list of video cards that are 
compatible with the Vectorworks program. If a model is too complex to render the design layer successfully, an alert 
message displays, informing you that the render mode has been switched to wireframe.

The power-saving video settings of some laptops may cause out-of-memory issues or other display issues that can 
easily be solved by turning off the power-saving video features.
Click here for a video tip about this topic (Internet access required).

OpenGL Options
Use the OpenGL options to control the level of detail in rendered images, which in turn affects the render speed (less 
detail renders faster). These settings apply only to the current drawing; they remain in effect in the current drawing 
until the settings are changed. The current OpenGL settings are saved when you create a template (see “Creating 
Templates” on page 75).

For smoother rendering of mesh objects, enable mesh smoothing for the entire document in the document 
preferences (see “Document Display Preferences” on page 60) or for selected meshes on the Render pane of the 
Object Info palette (see “Applying a Texture to an Object” on page 1530.)

To set the OpenGL options:
1. Select View > Rendering > OpenGL Options.

The OpenGL Options dialog box opens.
Click to show/hide the parameters.

Fill opacity Sets the opacity of filled 2D planar objects for situations where objects overlap
Ignore perspective When selected, draws quick orthographic representations of PDFs, images, and image 

fills (including tile definitions which contain images or image fills); deselect to draw 
more accurate perspective-projected representations of PDFs, images, and image fills, 
which may take more time

Ignore perspective in 
text

When selected, draws quick orthographic representations of text in 3D views; deselect 
to draw accurate perspective-projected text, which may take more time to represent

Parameter Description

Detail Specifies the level of detail for renderings; a low setting renders faster

Parameter Description

http://www.vectorworks.net
http://www.youtube.com/watch?v=9J8D3P27kk4
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2. Select the OpenGL render options, and click OK to change the settings for the file.

Renderworks Features for OpenGL

If the Renderworks product is installed, the OpenGL render mode has additional features that help you to preview and 
adjust a scene before it is rendered with Renderworks product render modes.

• Turn on the Draw Edges feature to outline objects more clearly in the rendered drawing; these edges are similar to 
those in the Hidden Line render mode. 

• Turn on the interactive Use Shadows feature to see how the shadows fall with different types of lighting and 
adjust the lights. When the system hardware and video card are sufficiently powerful, enhanced, highly accurate 
shadows are used for the OpenGL rendering. This option can be turned off if quality or instability problems are 
encountered; see “3D Preferences” on page 54. 

• OpenGL can display three types of Renderworks backgrounds: One Color, Two Color, and Image. It cannot 
display Cloud, HDRI, or physical sky backgrounds. (See “Creating Layer Backgrounds” on page 1522 for 
details.)

• OpenGL is used during viewing operations such as flyovers and walkthroughs when a Renderworks mode is in 
effect. OpenGL also previews a rendered scene before a Renderworks render has completed.

~~~~~~~~~~~~~~~~~~~~~~~~~
Rendering with Vectorworks
Rendering with Renderworks

Use Textures
(Renderworks 
required)

Renders object textures; this provides better detail and is usually enabled, but it takes 
longer to render

Use Colors When selected renders colors, and textures with colors; deselect to render colors as white.
Use Anti-Aliasing Filters the rendering and reduces pixellated edges; this option is only available if the 

graphics card supports the feature
Draw Edges
(Renderworks 
required)

Select to render objects with lines drawn around the edges, similar to the lines in the 
Hidden Line render mode. Edges are drawn where objects meet; break up an object into 
multiple objects if more edges are needed.

Crease Angle
(Renderworks 
required)

If Draw Edges is selected, surfaces that diverge by more than this angle will show crease 
edges. Set the value to zero to disable crease edges. By default the crease angle is set to 70 
degrees.

Use Shadows
(Renderworks 
required)

Objects in the drawing cast shadows on other objects (but not on the active layer plane)

On Ground Only
(Renderworks 
required)

If Use Shadows is selected, select this option for drawing objects to cast shadows on a 
plane at the lowest point in the drawing — which is usually the active layer plane — but 
not on other objects

Quality
(Renderworks 
required)

If Use Shadows is selected, select the level of quality for the shadow edges (a low setting 
uses less memory and renders faster)

Parameter Description
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Line Render Options
Use the line render options to control the appearance of lines in Hidden Line, Dashed Hidden Line, and Final Shaded 
Polygon modes. These settings apply only to the current drawing; they remain in effect in the current drawing until the 
settings are changed. The current line render settings are saved when you create a template (see “Creating Templates” 
on page 75).
To set line rendering options:

1. Select View > Rendering > Line Render Options.
The Line Render Options dialog box opens.

Click to show/hide the parameters.

Parameter Description

Dash Style Select the dash style for hidden lines when the Dashed Hidden Line mode is selected.
Dash Shade Adjust the slider to select how hidden lines are shaded when the Dashed Hidden Line 

mode is selected
Preview Displays a preview of the selected parameters
Smoothing Angle Sets the angle to reduce facet lines when the Hidden Line, Dashed Hidden Line, or 

Final Shaded Polygon mode is selected; if the value is greater than zero, facet lines will 
be removed between any two faces of an object that are within that angle of each other

Generate Intersecting 
Lines

Generates lines where surfaces in the drawing intersect each other when the Hidden 
Line, Dashed Hidden Line, or Final Shaded Polygon mode is selected; for large files 
with a lot of curved surfaces, this option can make rendering slower

A Dashed Hidden Line rendering with 
the Smoothing Angle set to 0

A Dashed Hidden Line rendering with 
the Smoothing Angle set to 15

A Hidden Line rendering with Generate 
Intersecting Lines disabled

A Hidden Line rendering with Generate 
Intersecting Lines enabled
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2. Select the line render options, and click OK to change the settings for the file.
~~~~~~~~~~~~~~~~~~~~~~~~~
Rendering with Vectorworks

Rendering with Renderworks

Renderworks Rendering Modes
The Renderworks product offers several rendering modes, including custom rendering options and an artistic rendering 
option. 
To render a drawing, select View > Rendering and the desired rendering mode. The rendering speed depends on the 
rendering option selected and the number and complexity of objects in the file.
To cancel a rendering before it is complete, press the Esc key.

The View bar displays the Render Modes for quick access to the rendering commands. The View bar options 
display the Render Mode - Short (displaying a shortened version) or the Render Mode - Long (displaying the 
current render mode options and the current render mode). The Current Render Mode Options button opens the 
settings dialog box for the current render mode, if applicable.

Save files in wireframe mode rather than in a rendered mode, so that files draw more quickly when opened. 
Rendered viewports are saved in a rendered state when Save viewport cache is selected in the Display tab of 
document preferences.

Display Surface 
Hatches 
(Renderworks 
required)

Select to display surface hatches in a hidden line rendered view

Display Text and 
Markers

Select to display text and markers in the rendered view. 
Hiding text and markers can significantly decrease rendering times.

Sketch Hidden Line 
Results
(Vectorworks Design 
Series required)

Specifies whether to apply sketch effects to lines when the Hidden Line, Dashed 
Hidden Line, or Final Shaded Polygon mode is selected; see “Sketch Rendering” on 
page 1497

Document Default 
Sketch Style
(Vectorworks Design 
Series required)

Sets the default sketch style for lines when the Hidden Line, Dashed Hidden Line, or 
Final Shaded Polygon mode is selected; see “Setting the Default Sketch Style” on 
page 1497. Click Edit to open the Sketch Style Editor dialog box for additional sketch 
style modification.

Parameter Description

A Hidden Line rendering with Display 
Surface Hatches disabled

A Hidden Line rendering with Display 
Surface Hatches enabled (and brick 

texture applied)

Render Modes listCurrent Render Mode Options
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For smoother rendering of mesh objects, enable mesh smoothing for the entire document in the document 
preferences (see “Document Display Preferences” on page 60) or for selected meshes on the Render pane of the 
Object Info palette (see “Applying a Texture to an Object” on page 1530.)

~~~~~~~~~~~~~~~~~~~~~~~~~
Background Rendering
Renderworks Styles
Custom Renderworks Options
Artistic Renderworks Options
Rendering a Selected Area
Batch Rendering
Optimizing Rendering Performance
Rendering with Vectorworks

Background Rendering
Sheet layer viewports and bitmaps created with the Render Bitmap tool can render in the background for 
Renderworks render modes, while you continue working. A sheet layer that requires updating because it is out of date 
displays with a striped border (see “Creating Sheet Layer Viewports” on page 1616 and “Viewport Status” on 

Rendering Mode Description

Fast Renderworks Renders without anti-aliasing or ray tracing; low detail level

Final Quality Renderworks Renders with reflections, shadows, anti-aliasing, transparency, and a 
high level of detail

Renderworks Style Renders with parameters that have been saved as a Renderworks Style
Custom Renderworks Renders with parameters set by the user
Artistic Renderworks Renders with multiple sketch styles for a hand-drawn look
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page 1664). The viewport renders with the render mode and settings specified for the foreground and background 
render in the Object Info palette. A render bitmap renders with the tool preference settings in effect when it is created 
(see “Rendering a Selected Area” on page 1608).

Starting a Background Render
A render bitmap begins rendering in the background as soon as it is created. There are several different ways to update 
the rendering of sheet layer viewports:

• Select View > Update Selected Viewports, or View > Update All Viewports.
• Select Update from the Object Info palette of selected viewports.
• Right-click (Windows) or Ctrl-click (Mac) on the viewport, and select Update from the context menu.
• With one or more sheet layer viewports selected from the Viewports tab of the Navigation palette (Vectorworks 

Design Series required), select Update from the Navigation menu. See “The Navigation Palette” on page 199.
When rendering begins, the Vectorworks program processes the drawing geometry first, as indicated in the message 
bar. If multiple viewports are selected, the geometry of each one is processed first before background rendering starts. 
During this time, actions other than canceling the render are blocked. Once the geometry has been processed, 
background rendering begins and the Vectorworks program is available once again.

If edits occur to a design layer that affect a current or queued background render of a sheet layer viewport, the 
render continues, but the viewport will be out of date when the render is complete.

An animated icon at the bottom right of the drawing window indicates that background rendering is queued or is in 
progress. This icon displays even when you switch to another layer, as a reminder that background rendering is 
occurring. Another icon, in the bottom right corner of the viewport or render bitmap, indicates the individual status of 
each viewport or bitmap. The Viewports tab of the Navigation palette (Vectorworks Design Series required) and 
message bar also display information about the rendering status. During background rendering, the rendering viewports 
and bitmaps are locked, and only the Cancel Update option is available from the Object Info palette; however, all other 
drawing processes are available, including switching to another layer, editing objects, and even moving render bitmaps 
to another layer. Printing, saving, exporting images, or closing the Vectorworks program when background rendering is 
in process will generate an alert message with the option to proceed with, or cancel, the rendering.

Background rendering is queued Background rendering is in progress

Sheet layer viewport is 
in rendering queue

Sheet layer viewport 
rendering is in progress

Render bitmap rendering 
is in progress

Render bitmap is in 
rendering queue
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The message bar indicates the name of each sheet layer viewport as it is rendered. When the individual and overall 
background render is complete, the icon no longer displays. 

Canceling a Background Render
There are several different ways to cancel sheet layer viewports and render bitmaps currently being rendered in the 
background or waiting in a render queue.

• Select View > Cancel All Viewport Updates.
• Select Cancel Update from the Object Info palette of selected viewports, or Cancel Rendering to cancel the 

rendering of selected render bitmaps.
• With one or more sheet layer viewports selected from the Viewports tab of the Navigation palette (Vectorworks 

Design Series required), select Cancel Update from the Navigation menu. See “The Navigation Palette” on 
page 199.

~~~~~~~~~~~~~~~~~~~~~~~~~
Rendering a Selected Area
Updating Viewports
Viewport Status
The Navigation Palette
Rendering with Renderworks
Optimizing Rendering Performance

Renderworks Styles
Several elements combine to create a satisfactory rendering: the selected render mode, the render mode options, the 
lighting options, and the selected Renderworks background. A Renderworks style saves the settings for these 
parameters as a resource that can be re-applied later and shared between files.
The Renderworks product includes several default styles to quickly obtain a variety of looks, with no parameter 
adjustment or rendering knowledge required.

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Renderworks Styles
Applying Renderworks Styles
Rendering with Renderworks

Creating Renderworks Styles
Renderworks styles that incorporate either realistic or artistic Renderworks parameters can be saved as resources. For 
more information on creating resources, see “Creating New Resources” on page 228.

Realistic Exterior Night Final Realistic Colors White Artistic Taper Thick Black

http://www.youtube.com/watch?v=mPjyP0PNPTE
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If you create a Renderworks style while the layer or viewport is rendered in any Renderworks mode or a 
Renderworks style, the current settings are used as the basis for the new style. This is a convenient way of saving 
render settings.

To create a Renderworks Style resource:
1. Select Window > Palettes > Resource Browser to open the Resource Browser.
2. Select Resources > New Resource to display the list of new resource types.
3. Select Renderworks Style.

The Edit Renderworks Style dialog box opens. Provide a name for the style resource and select a realistic or 
artistic type of style, and then specify the render parameters.

Click to show/hide the parameters.

Parameter Description

Name Specify the name of the Renderworks Style resource
Type Select either Realistic or Artistic; different options are available depending on the desired 

look
Realistic Creates a Renderworks style based on Custom Renderworks options
Options 

Anti-Aliasing Select for smoother edges on objects and textures; deselect for faster rendering with 
rougher edges

Shadows Render shadows for a higher degree of realism
Blurriness Select to render textures with blurred reflectivity and/or blurred transparency (this can add 

significant rendering time)
Textures Renders the textures assigned to objects; deselect for faster rendering
Displacement 
Mapping

Renders with displacement mapping when a texture’s bump shader setting has a 
displacement height set; select the displacement mapping quality on the Quality tab. 
Deselect for faster rendering.

Colors When selected, renders colors, and textures with colors; deselect to render colors as white
Image Exposure 
(%)

Adjusts the exposure brightness of the rendered image; enter a value to increase the 
brightness (above 100%) or to decrease the brightness (below 100%)

Quality For each parameter, select the quality level. Higher quality results in better resolution of 
rendered images, with better texture detail and softer shadows, but takes more time.

Quality Levels Conveniently sets the quality level of all the options at one time. Custom indicates that 
some options have different quality levels set.

Curved Geometry Select the quality level for faceting of curved geometry (such as NURBS surfaces)
Anti-Aliasing Select the quality level for anti-aliasing (smoothing) of edges on objects and textures
Indirect Lighting Select the quality level for indirect lighting effects
Soft Shadows Sets the quality level of shadows for light objects that have Soft Shadows enabled. For 

area and line lights, specifies the sampling quality of the light.
Blurriness Select the quality level of textures with blurry reflectivity and/or transparency
Environment 
Lighting

Select the sampling quality level for environment (HDRI) background lighting. This 
option has no effect when indirect lighting is enabled for the lighting options.
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4. Click OK to create a Renderworks Style resource with the name and properties specified in the Edit Renderworks 
Style dialog box. The Renderworks style displays in the Resource Browser and is saved with the file. It is added to 
the list of available Renderworks styles in View > Renderworks Style.

Displacement 
Mapping

When enabled on the Options tab and set for a bump shader, select the quality of the 
displacement mapping. Higher quality is more realistic for fine displacement bumps, but 
will require longer rendering times.

Rendering can be significantly slower with displacement mapping.
Max Reflections Enter the number of levels of reflection among shiny surfaces; a higher value slows 

rendering, but can yield a more realistic image for scenes with many inter-reflecting 
objects

Lighting 
Apply Lighting 
Options

Controls whether the Renderworks style changes the current lighting options when it is 
applied. Select the option to apply the style’s lighting options to the layer or viewport 
when the Renderworks style is applied. Deselect the option to leave the current lighting 
options unchanged when the Renderworks style is applied.

Lighting Options Sets the lighting options; see “Setting Lighting Options” on page 1571
Edit Resource Opens the Edit Renderworks Background dialog box, to conveniently change background 

and environment lighting options that affect the rendering
Edges

Apply Artistic 
Edges

Select to apply artistic edges on top of the realistic shaded rendering

Style Select an edge style
Thickness (pixels) Specifies the edge thickness
Color Specifies the edge color

Background 
Apply 
Renderworks 
Background

Controls whether the Renderworks Background changes the current background options 
when it is applied. Select the option to apply the style’s background to the layer or 
viewport when the Renderworks style is applied. Deselect the option to leave the current 
background unchanged when the Renderworks style is applied.

Renderworks 
Background

Sets the Renderworks Background options; see “Creating a Background” on page 1522

Artistic Creates a Renderworks style based on Artistic Renderworks options
Artistic Style Select an Artistic Renderworks style and set any options
Background

Apply 
Renderworks 
Background

Controls whether the Renderworks Background changes the current background options 
when it is applied. Select the option to apply the style’s background to the layer or 
viewport when the Renderworks style is applied. Deselect the option to leave the current 
background unchanged when the Renderworks style is applied.

Renderworks 
Background

Sets the Renderworks Background options; see “Creating a Background” on page 1522

Parameter Description
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To edit a Renderworks Style resource after it has been created, select the Renderworks style from the Resource 
Browser and select Resources > Edit. See “Working with Resources” on page 225.

~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Renderworks Styles
Custom Renderworks Options
Artistic Renderworks Options
Renderworks Styles
Using the Resource Browser

Applying Renderworks Styles
Renderworks styles are resources that are saved with the file and can be found in the Resource Browser. The 
Vectorworks program comes with several Renderworks styles that are provided as default content (default content is 
automatically imported into the current file at the point of use and displays in the Resource Browser; see “Resource 
Libraries” on page 219).
To render a drawing with a Renderworks style: 

Select View > Renderworks Style, and then the desired style from either the default content or the current file’s 
content. The current Renderworks style in effect displays with a check mark on the Renderworks Style menu. 
The rendering speed depends on the rendering option selected and the number and complexity of objects in the 
file. To cancel a rendering before it is complete, press the Esc key.
A Renderworks Style resource can also be applied by dragging it from the Resource Browser into a design layer of 
the drawing.
Renderworks styles are also available from the Render Mode menu on the View bar, as described in “Rendering 
with Renderworks” on page 1593. When creating a viewport, Renderworks styles are available from the Render 
list in the Create Viewport dialog box, or from the Object Info palette of an existing viewport. The Render 
Bitmap tool and batch rendering functionality can also take advantage of Renderworks styles.

When a Renderworks background is set from the Renderworks style, the option to select a background may not be 
available when the style is in effect, such as for viewports. The Renderworks style’s background settings override the 
Renderworks background settings when Apply Renderworks Background was selected for the style. Similarly, when 
lighting options have been set from the Renderworks style, any attempt to edit lighting options automatically opens the 
Edit Renderworks Style dialog box, since these are the settings in effect when Apply Lighting Options is selected for 
the style.

Use Renderworks styles and the Heliodon tool (Vectorworks Design Series required) to obtain good results from 
existing files. Open an existing model, and either delete or turn off existing lights in the drawing (through the 
Visualization palette). In the OpenGL Options, select Use Shadows. Render with the OpenGL render mode and 
select a 3D view. (A Renderworks Camera object can help to set and adjust the 3D view.)
Place a heliodon object in the drawing with the Heliodon tool. Click Solar Animation to interactively adjust the 
date and time (see “Solar Studies” on page 1489). This is particularly effective with physical sky Renderworks 
backgrounds.
For exteriors, select the Realistic Exterior Fast or Realistic Exterior Final Renderworks style; for interiors, 
select either Realistic Interior Fast or Realistic Interior Final. The heliodon creates a strong sun light with 
soft-edged shadows, while the Renderworks style provides soft sky lighting from the included HDRI 
backgrounds. 

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Renderworks Styles
Setting Lighting Options
Custom Renderworks Options
Artistic Renderworks Options
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Renderworks Styles
Using the Resource Browser
Solar Studies

Custom Renderworks Options
Custom render settings provide greater control over fine-quality rendering. These settings are used exclusively by the 
Custom Renderworks rendering mode. Custom geometry settings override the 3D conversion resolution setting on 
the 3D tab in Vectorworks preferences. These settings apply only to the current drawing and remain in effect in the 
current drawing until the settings are changed. In addition, the settings are saved when creating templates (see 
“Creating Templates” on page 75).
To set Custom Renderworks rendering options:

1. Select View > Rendering > Custom Renderworks Options.
The Custom Renderworks Options dialog box opens. The default options match Fast Renderworks rendering 
mode.

Click to show/hide the parameters.

Parameter Description

Options Enabling the options allows for better quality, higher detailed rendering, but takes 
longer to render

Anti-Aliasing Select for smoother edges on objects and textures; deselect for faster rendering with 
rougher edges

Shadows Render shadows for a higher degree of realism
Blurriness Select to render textures with blurred reflectivity and/or blurred transparency (this can 

add significant rendering time)
Textures Renders the textures assigned to objects; deselect for faster rendering

Displacement 
Mapping

Renders with displacement mapping when a texture’s bump shader setting has a 
displacement height set; select the displacement mapping quality below. Deselect for 
faster rendering.

Colors When selected, renders colors, and textures with colors; deselect to render colors as 
white

Lighting Options Click Layer Lighting Options (from a design layer) or Viewport Lighting Options 
(from a viewport) to quickly access the associated lighting options dialog box.

Image Exposure (%) Adjusts the exposure brightness of the rendered image; enter a value to increase the 
brightness (above 100%) or to decrease the brightness (below 100%)

Quality For each parameter, select the quality level. Higher quality results in better resolution of 
rendered images, with better texture detail and softer shadows, but takes more time.

Quality Levels Conveniently sets the quality level of all the options at one time. Custom indicates that 
some options have different quality levels set.

Curved Geometry Select the quality level for faceting of curved geometry (such as NURBS surfaces)
Anti-Aliasing Select the quality level for anti-aliasing (smoothing) of edges on objects and textures
Indirect Lighting Select the quality level for indirect lighting effects
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When testing a rendering, set the Quality levels to low and turn Anti-Aliasing and even Shadows off. Lower 
rendering quality is offset by faster rendering times.
To create a “white card” or white model rendering, turn off textures and colors.

2. Click OK to set the Custom Render options.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Renderworks Rendering Modes
Setting Lighting Options

 Artistic Renderworks Options
When you select the Artistic Renderworks mode, a variety of styles and options are available to create a hand-drawn or 
artistic look for a 3D drawing. These settings apply only to the current drawing and remain in effect in the current 
drawing until the settings are changed. In addition, the settings are saved when creating templates (see “Creating 
Templates” on page 75).
Artistic Renderworks options are available as part of a Renderworks style; see “Renderworks Styles” on page 1596. A 
Renderworks style allows artistic parameters to be saved as a resource to be re-applied later and shared between files.

Artistic Renderworks does not produce sketch rendering of 2D objects.
To set Artistic Renderworks options:

1. Select View > Rendering > Artistic Renderworks Options.
2. The Artistic Renderworks Options dialog box opens. A preview scene is shown in order to evaluate the effects of 

the different options.
3. Select the Style from the list, and then click Options to set specific style parameters. The preview image displays 

the resulting effect.
Most Artistic Renderworks styles use hidden line rendering (except for Art and Hatch). These styles may require 
longer rendering times for drawings with many facets (polygons). A style that does not use hidden line rendering 
is recommended for extremely complex drawings.
The Artistic Renderworks styles allow the layer’s Renderworks background to show through, if one has been 
defined and applied (see “Applying Renderworks Backgrounds” on page 1545). 

Soft Shadows Sets the quality level of shadows for light objects that have Soft Shadows enabled. For 
area and line lights, specifies the sampling quality of the light.

Blurriness Select the quality level of textures with blurry reflectivity and/or transparency
Environment Lighting Select the sampling quality level for environment (HDRI) background lighting. This 

option has no effect when indirect lighting is enabled for the lighting options.
Displacement Mapping When enabled in the Options and set for a bump shader, select the quality of the 

displacement mapping. Higher quality is more realistic for fine displacement bumps, 
but will require longer rendering times.

Rendering can be significantly slower with displacement mapping.
Max Reflections Enter the number of levels of reflection among shiny surfaces; a higher value slows 

rendering, but can yield a more realistic image for scenes with many inter-reflecting 
objects

Parameter Description

http://www.youtube.com/watch?v=rELyGmvaRWw
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Many of the artistic styles share the parameters of edge color and edge thickness. Some parameters are uniquely 
available to certain styles.

Click to show/hide the parameters.

Click to show/hide the options.

Parameter Description Style Where Applied

Edge Thickness Specifies the thickness of lines used in the style; for lines that vary in 
thickness, this sets the thickest portion of the line

All styles except Art 
and Hatch

Edge Color Click the color box to select the color of the lines All styles except Art 
and Hatch

Shadow Color Click the color box to select the color of shadows Lines and Shadow
Change Image Selects a different image to apply to Art mode; the image selected 

must be square, and contain a color-mapped sphere. The color of the 
sphere is used to color the image.

Art

Artistic Renderworks Option Description

None For comparison, the image below is rendered with Final Quality Renderworks

Art Transforms the image into a single color with shadows 

Cartoon Traces a border around edges of objects and combines simplified shading with 
drawn edges
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Hatch Shades the image with stroked hatch lines 

Lines and Shadow Traces a border around the edges of objects and displays shadows

Pencil (soft) Simulates a hand-drawn pencil drawing with soft, smudged pencil line(s) at the 
edges of objects

Pencil (Sketch Concept) Simulates a hand-drawn pencil drawing with thin lines that extend slightly past 
their intended point

Pencil (Rough Sketch) Simulates a hand-drawn pencil drawing with many overlapping lines

Artistic Renderworks Option Description
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Pencil (Loose) Simulates a hand-drawn pencil drawing with curvy, careless straight lines

Pen (Thick and Thin) Simulates a hand-drawn pen drawing with uneven pressure on the pen nib

Pen (Thin Distance) Simulates a hand-drawn pen drawing with lines that get thinner as the line retreats

Crayon Draws edges with a thick, monochrome crayon

Chunky Lines Draws lines with a hesitant stroke that simulates the ink sinking into the paper at 
those points

Artistic Renderworks Option Description



Rendering with Renderworks |  1605
4. Click OK to set the Artistic Renderworks options.

Cloned Lines Draws overlapping, tapering lines

Brush (Watercolor) Draws as with a thin watercolor brush, with ink that soaks into the paper

Brush (Watercolor Light) Similar to Brush (Watercolor), but with less pressure applied

Brush (Chinese) Draws as with ink and a watercolor brush, with thicker lines at the corners

Brush (Chinese Fade) Draws as with ink and a watercolor brush, with lines that start thick and become 
thinner along the stroke

Artistic Renderworks Option Description
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5. Select View > Rendering > Artistic Renderworks to render with the specified option.
~~~~~~~~~~~~~~~~~~~~~~~~~
Applying Colors

Hidden Line Rendering with Surface Hatches
In hidden line render mode, it is possible to produce monochromatic conceptual or production drawings by displaying 
planar hatches wherever a textured surface would exist in a raster-rending mode (Renderworks required). 

Surface hatches are an aspect or feature of a texture; they can be used when associated with the texture that is applied to 
an object. Some of the most commonly used Renderworks standard textures are pre-associated with an appropriate 
hatch, but the surface hatches can be associated with other textures, changed, and settings can be edited as desired. 

Most of the textures with pre-associated surface hatches are material textures that would be applied to building 
external surfaces, such as brickwork, CMU, concrete, corrugated metal, etc. They are easily identifiable in texture 
libraries by the text <surf hatch> in the resource name.
If a hatch that is associated with one or more textures is deleted, all textures associated with that hatch have their 
hatch association set to None.

To display surface hatches on a design layer using an existing hatch and texture association:
1. Select View > Rendering > Line Render Options.

The Line Render Options dialog box opens.
2. Select Display Surface Hatches and click OK. 

To display surface hatches in a viewport using an existing hatch and texture association:
1. On the viewport’s Object Info palette Shape tab, set Background Render and/or Foreground Render to Hidden 

Line.
2. Click Background/Foreground Render Settings to open the Hidden Line Render Settings dialog box.
3. Select Display Surface Hatches and click OK.

Click here for a video tip about this topic (Internet access required).

Editing Surface Hatches
To associate a hatch with a texture or to edit an existing hatch and texture association:

1. From the Resource Browser, select the texture, and then select Resources > Edit.
The Edit Texture dialog box opens.

2. Surface Hatch displays the name of the surface hatch resource associated with the texture, if any. To associate a 
new hatch or align and register the existing hatch with the texture, select Edit Surface Hatch.

Drawing with texture Drawing with hidden line rendering surface hatches

http://www.youtube.com/watch?v=p24jd_Bu1Ls&list=UUN7uzhu-ljLJOe6a0J-fBcQ
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The Edit Surface Hatch dialog box opens. 
To navigate directly to the Edit Surface Hatch dialog box without opening the Edit Texture dialog box, select Edit 
Surface Hatch from the pull-down menu to the right of the Texture list on the Object Info palette Render tab.
Hatches defined with page units cannot be aligned to a texture; therefore the alignment fields are grayed out in the 
Edit Surface Hatch dialog box.

Click to show/hide the parameters.

3. Set the desired parameters to align and register the hatch with the texture, and click OK to return to the Edit 
Texture dialog box.

4. Click OK.
Like textures, surface hatches can be applied to an object by class; see “Applying Object Textures by Class” on 
page 1542.

Parameter Description

Surface Hatch From the list of hatches present in the drawing, select a surface hatch to associate with 
the texture, or select None

Set Hatch 
Alignment

X/Y Offset Sets the horizontal/vertical surface hatch offset relative to the texture
I/J Length Sets the horizontal/vertical repeat distance relative to the hatch definition (I in the red 

direction and J in the green direction)
Lock button Select to maintain the aspect ratio between the I and J lengths
Rotation Sets the degree of rotation from horizontal relative to the texture
Flip 
Horizontally/
Vertically

Flips surface hatch horizontally/vertically relative to the texture

Reset Reset surface hatch alignment settings
Preview Displays an outline of the hatch over an image of the texture; control points can be 

moved for manual adjustment of alignment and registration

Preview Controls Adjusts the preview position and magnification. Click Pan and drag the preview to the 
desired location. Click Zoom In or Zoom Out and then click and drag to create a 
marquee; this zooms in or out on a particular section of the preview. Click Fit to fit the 
preview to the window (according to Obj Size).

Texture Size Sets the texture size. This field corresponds to the Size parameter in the Edit Texture 
dialog box; changes in one location affects the other.
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~~~~~~~~~~~~~~~~~~~~~~~~~
Line Render Options
Creating a New Texture
Applying a Texture to an Object

Rendering a Selected Area
The Render Bitmap tool creates a rendered bitmap image of a selected area and places it on top of the drawing. 
Manipulate this image similar to imported images.
Use this tool to preview a section of a drawing, or create a layout of several rendered views. It is also possible to render 
the entire drawing, creating an image that can be sent to a printer for preview or final quality output, or exported into a 
different image file format and saved.
Like sheet layer viewports, render bitmap images can render in the background for Renderworks render modes, while 
you continue working in the drawing. See “Background Rendering” on page 1594.
The Render Bitmap tool renders the image with the specified resolution and rendering mode. The bitmap created by 
the tool draws using the options selected on the Resolution tab in the document preferences (see “Resolution 
Preferences” on page 62). Choose Full Resolution, Reduced Resolution or Bounding Box. The bounding box option 
displays as a gray rectangle bitmap image. Using this option saves re-drawing time when using the Pan tool or scroll 
bars.
The image created by the Render Bitmap tool is compressed by either the JPEG or PNG compression method, to 
reduce file size. The compression used depends on the Default compression selected on the Edit tab of Vectorworks 
preferences (see “Edit Preferences” on page 49).

To render a specified area:

1. Select the Render Bitmap tool from the Visualization tool set.
2. Click the Preferences Tool bar button.

The Render Bitmap Settings dialog box opens. Specify the rendering mode and any options.
Click to show/hide the parameters.

3. Click OK.
4. Click and drag to create a marquee box around the desired area.

The area is rendered (using background rendering for any Renderworks modes). Cancel the rendering by clicking 
Cancel Rendering from the Shape tab of the Object Info palette. When complete, a bitmap image of the rendered 
area is placed on top of the original area.

5. Move the new image to the desired location.

Parameter Description

Render Mode Select the rendering mode for the image; if the mode has additional settings, click Options to 
make any changes (any changes also apply to the design layer settings)

Resolution 
(DPI)

Specify the resolution for the bitmap in dots per inch, relative to the page; lower resolution values 
reduce file size
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After rendering, the rendered bitmap image can be cut from the Vectorworks drawing and pasted into any image 
editing program for further manipulation.

~~~~~~~~~~~~~~~~~~~~~~~~~
Background Rendering
Rendering with Vectorworks
Rendering with Renderworks

Batch Rendering
Batch rendering allows several images to be rendered while the computer is unattended. Each batch job retains its own 
view, rendering mode, resolution, and export settings.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Batch Rendering Jobs
Starting the Rendering Job Batch

Creating Batch Rendering Jobs
The batch rendering job specifies the job name, rendering mode and options, and image dimensions and format, for the 
current drawing file.

Batch rendering does not retain geometry or lighting information; it saves the view, render, and export settings. To 
export different lighting situations for a scene, create sheet layer viewports and change the lighting with the 
Visualization palette (see “Managing Lights and Cameras with the Visualization Palette” on page 1611). 
Viewports allow lighting overrides without affecting the lighting on the design layer. This method allows batch 
rendering of viewports of the same scene with different lighting conditions.

To create a batch rendering job:
1. Establish the desired file view and level of magnification.

The Export Image File settings determine the specific dimensions of the exported area and the visibility of objects 
(see “Exporting an Image File” on page 1683).

2. Select View > Rendering > Create Batch Render Job.
The Create Batch Render Job dialog box opens. Specify the rendering job parameters and click OK.

Click to show/hide the parameters.

Parameter Description

Name Specifies the rendering job name for creating the batch
Render Mode Select the rendering mode from the list



  1610 | Batch Rendering
The Marquee export area option in the Export Image File dialog box is not available for batch rendering jobs.
3. Create additional batch rendering jobs as required.

Batch jobs can be renamed, edited, or deleted from the Start Batch Render dialog box.

Starting the Rendering Job Batch
Once rendering jobs have been created, specify their order and the rendered file location.
To specify the rendering job batch:

1. When it is time to begin the batch rendering process, select View > Rendering > Start Batch Render.
The Start Batch Render dialog box opens. Select the jobs to be rendered and specify the file location for the 
resulting rendered images.

Click to show/hide the parameters.

2. Click Start to begin the batch rendering.
The Batch Render Progress dialog box displays the status of the batch rendering. Press the Esc key to cancel the 
current job and proceed with the remaining batch jobs. Press Cancel to cancel all batch rendering jobs.

3. As each job is rendered, the resulting file is placed in the Results Folder.

Options For OpenGL and Custom Renderworks rendering modes, the default file settings are in 
effect; to change the settings, click Options. These changes apply to the current job only.
For more information on OpenGL settings, see “Rendering with Vectorworks” on page 1587. 
For Custom Renderworks settings, see “Custom Renderworks Options” on page 1600.

Set Export 
Image File 
Options

Opens the Export Image File dialog box for specifying the rendered image file settings, 
including export area and format

Parameter Description

Available Jobs Lists the current batch render jobs in order of job creation; the jobs are displayed with the 
image file extension to be generated according to the job settings

Chosen Jobs Lists the currently selected render jobs in order of execution; the most recently added job is 
placed at the end of the list

Choose All Moves all Available Jobs to the Chosen Jobs list
>> button Moves the selected job from the Available Jobs list to the end of the Chosen Jobs list
<< button Moves the selected job from the Chosen Jobs list to the end of the Available Jobs list
Duplicate Copies the selected available job and adds it to the end of the Available Jobs list; specify a 

new name for the job in the Assign Name dialog box
Edit Opens the Edit Batch Render Job dialog box, for changing the parameters of the selected job
Delete Removes the selected job from the list of available render jobs (no undo)
Browse 
(Windows)/
Choose (Mac)

Specifies the Parent Folder location, where all batch rendering resulting files will be 
located. By default, this is the application folder. The result subfolder name is also displayed 
(this subfolder is named according to the current date and time). 

Parameter Description
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Managing Lights and Cameras with the Visualization Palette
The Visualization palette provides fast and easy access to all lights and cameras in a Vectorworks file. Lights and 
cameras can be selected, edited, duplicated, created, and deleted. The palette also controls lighting overrides for 
selected sheet layer viewport(s), without modifying the lighting on the design layer or in another viewport.
Tasks that can be performed from the Visualization palette include:

• Quickly locating any light in the file;
• Turning lights on and off;
• Editing of any light or lights in the file, even lights that are inside a container object or on a different layer; 
• Creating lighting overrides for sheet layer viewports;
• Managing light and camera objects, including creating, editing, deleting, duplicating, and sorting;
• Quickly switching to a camera’s established view;
• Turning heliodon objects on or off to conduct sun studies (Vectorworks Design Series required).

To use the Visualization palette:
1. Select Windows > Palettes > Visualization.

The Visualization palette opens. The Visualization palette can remain open while you work in the drawing.
2. The Visualization palette contains two tabs: the Lights tab accesses lights, and the Cameras tab accesses cameras. 

The lights and cameras can be sorted by clicking in the header of any column. 
The Lights tab functions in two different modes depending on whether you are on a design layer or sheet layer. On 
a design layer, the palette lists either all the lights in the file, or just the lights that affect the current view. On a 
sheet layer, the palette lists either all the lights in the file, or just the lights of selected viewports; edits to the 
selected viewport(s) affect the viewport lighting, creating an override, but this does not affect the associated 
design layer lighting.
Depending on what action is being performed, different options are available in both the Visualization palette and 
the Visualization palette menu. To open the Visualization palette menu, click on the small triangle at the top 
right of the palette, or right-click (Windows) or Ctrl-click (Mac) in the palette to open a context menu.

Click to show/hide the parameters.

Design layer Visualization palette options Sheet layer Visualization palette options

Visualization palette camera options
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Parameter Description

Lights tab The Lights tab accesses the parameters of sheet layer viewports or all lights in the file
Current Scene Displays only the lights which affect the current view (lights from the current layer and 

in visible classes)
Selected Viewport(s) Displays only the lights which affect the currently selected sheet layer viewport(s); in this 

mode, lights can be edited to override the lighting of the selected viewports only. (Other 
Visualization palette light management commands are not available.) Select Revert 
Override to return the viewport to its original lighting.

All Lists all the lights in the file
On Click to toggle the light on or off; a check mark indicates that the light is on
(Cast Shadows) Click to toggle the ability of the lights to cast shadows on or off; a red “x” indicates that 

shadows are off

(Override State) For lights in selected viewport(s), indicates whether the light has an override.
•  Uses design layer definition: the light parameters are the same in both the design 

layer and the viewport(s).
• Uses viewport override definition: the light parameters have been edited for the 

selected viewport(s), creating a viewport lighting override.
Name Displays the name of the light (as shown on the Data tab of the Object Info palette)
Type Indicates the type of light: 

•  Directional
•  Point
•  Spot
•  Custom
•  Area
•  Line

(Light Parent) Indicates whether the light is within a container object; if blank, the light is not part of 
another object.
•  Group: indicates that the light is contained within a group.
•  Symbol: indicates that the light is contained within a symbol; each instance is 

listed in the palette. Edits made directly from the Visualization palette, such as turning 
lights on and off, affect all symbol instances. (Selecting Visualization > Edit, 
however, edits the symbol instance properties.)

•  Plug-in Object: indicates that the light is contained in a plug-in object, such as a 
lighting device (Vectorworks Spotlight required)

•  Layer Link: indicates that the light is contained within a layer link
Class/Layer Displays the light’s class and layer
Menu commands The Visualization palette menu commands manage and select light objects 
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Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Light Source Properties
Setting a Camera View in Renderworks
List Box Functionality

New Opens the Create Light dialog box, to create a directional, point, spot, or custom light on 
the current design layer; see “Adding Light Sources” on page 1574 

Edit Opens the Properties dialog box, to edit the parameters of the currently selected light(s); 
when more than one light is selected, only common properties can be edited

Revert Override Restores the original light parameters for the viewport(s), when the lights in selected 
sheet layer viewport(s) have been edited

Duplicate Copies the currently selected light(s), placing the copy or copies on the same layer and in 
the same class as the original(s). Lights in symbols or plug-in objects cannot be 
duplicated.

Delete Deletes the currently selected light(s). Lights in symbols or plug-in objects cannot be 
deleted.

Select On 
Document

Selects the current light(s), and automatically centers the view on the light, or its 
container (alternatively, double-click on a light in the Visualization palette, if the light is 
in the active class or layer.) The light properties can then be edited in the Object Info 
palette or by clicking Visualization > Edit. The selection and editing of multiple lights at 
once is supported.

If the light is not in the active class or layer, use the Force Select command instead.
The Vectorworks Display preference must be set to show lights.

Force Select If the light is in a different class or layer, activates the layer or class, and automatically 
centers the view on the light, or its container group or symbol. The light properties can 
then be edited in the Object Info palette or by clicking Visualization > Edit. Multiple 
lights cannot be selected by this method.

Cameras tab The Cameras tab accesses the parameters of the camera objects in the drawing
Name Displays the name of the camera (as shown on the Data tab of the Object Info palette)
Class/Layer Displays the camera’s class and layer
Menu commands The Visualization palette menu commands manage and select camera objects

New Activates the Renderworks Camera tool; click to place a camera object
Edit Opens the Properties dialog box, to edit the parameters of the currently selected 

camera(s)
Duplicate Copies the currently selected camera(s), placing the copy or copies on the same layer and 

in the same class as the original(s)
Delete Deletes the currently selected camera(s)
Activate Selects the current camera, and automatically changes the view to that of the camera 

(alternatively, double-click on a camera in the Visualization palette)

Parameter Description

http://www.youtube.com/watch?v=5al77SMdP_M 
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Viewports
Viewport objects allow you to create views from several directions, complete with details, annotations, dimensions, 
and title blocks. Viewports can show other parts of the active document, or even portions of other documents.
Viewports can display entire, as well as cropped, views of a drawing, with specified layer and class visibility settings, 
projection, render mode, and orientation parameters. If the drawing changes, you can easily update the viewports to 
reflect the changes.
There are several different types of viewports, depending on whether you have the Vectorworks Fundamentals product 
or one or more Vectorworks Design Series products.

• Sheet layer viewports
In both the Vectorworks Fundamentals and Vectorworks Design Series products, you can create one or more 
viewports on a sheet layer, and each viewport can show one or more design layers from this document. Sheet layer 
viewports, often created for presentation purposes, are created on special layers called sheet layers. Sheet layers 
retain their own print settings, including print area, resolution, and printer setup parameters. For more information 
on sheet layers, see “Layers” on page 161.
When Renderworks is installed, a sheet layer viewport can be linked to a Renderworks camera.

• Design layer viewports (Vectorworks Design Series required)
Vectorworks Design Series products allow you to create one or more viewports on a design layer, and the design 
layers shown in the viewports can be either from this document, or referenced from another document. Like a 
sheet layer viewport, a design layer viewport can display design layers from the current file in a full or cropped 
view; unlike a sheet layer viewport, it can include one or more design layers that are referenced from another file. 

• Section viewports (Vectorworks Design Series required)
A section viewport creates a cross section view of a model, but leaves the model intact. A section viewport can be 
created from a design layer or another non-sectioned viewport; it can be placed on a design layer or sheet layer.

• Detail viewports (Vectorworks Design Series required)
A detail viewport is a cropped sheet layer viewport that shows a detail view of any part of a drawing. A detail 
viewport can be created from a design layer, another sheet layer viewport, or a section viewport. The crop object 
used to create the detail viewport becomes a callout object that is linked to the detail viewport for easy navigation 
between layers.

The Viewports tab of the Organization dialog box differentiates among the various types of viewports.

 

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Sheet Layer Viewports
Creating Design Layer Viewports
Creating Section Viewports
Creating Detail Viewports
Viewport Properties
Modifying Viewports

Design layer viewport

The viewport contents are from the current document

Section viewport

Sheet layer viewport

The viewport references an external document

http://www.youtube.com/watch?v=ZulXWtpDhzU
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Viewport Status
Updating Viewports

Creating Sheet Layer Viewports

Creating a Sheet Layer Viewport from a Design Layer
To create a viewport from a design layer:

1. Select View > Create Viewport.
2. The Create Viewport dialog box opens. The viewport parameters are initially set to be the same as those of the 

design layer that is currently active, but they can be changed here. After the viewport has been created, additional 
parameters become available; see “Viewport Properties” on page 1636.
For Vectorworks Design Series products, the Create Viewport dialog box has additional functionality for creating 
design layer viewports; see “Creating a Design Layer Viewport from an Internal Design Layer” on page 1621.

Click to show/hide the parameters.

Parameter Description

Viewport Name Specifies the viewport name; this name must be unique in the document
Drawing Title Specifies a descriptive title for the sheet layer viewport. This name displays as the 

drawing title for any annotation objects (drawing labels, section markers, and sheet 
borders) that are added to the viewport. The drawing title name is limited to 63 
characters.

Create on Layer Select the sheet layer where the viewport will be created, or select New Sheet Layer to 
create a sheet layer. If there are no sheet layers present and a new one is not created now, 
you will be prompted to create a sheet layer after clicking OK.

Layers Specifies which design layers will be visible in the viewport
Display Planar Objects Select to display 2D planar objects, when the viewport’s view is other than Top/Plan
Project Screen Objects Select to display 2D objects associated with the screen plane, when the viewport’s view is 

other than Top/Plan 
Classes Specifies which classes will be visible in the viewport
Scale Specifies the viewport scale relative to the page; select a scale or choose Custom and 

enter the scale value in Custom Scale
Custom Scale When a custom scale is selected, enter the scale value

View Specifies the orientation of the design layers displayed in the viewport; select a cardinal 
view or choose Custom and then click Set View to specify the view

Set View When a custom view is selected, click Set View to open the 3D Rotation dialog box for 
the entry of custom view parameters (see “Rotating Precisely” on page 1151 for more 
information)

Rendering Specifies the render mode for the viewport; some modes enable the Render Settings 
button, to specify rendering parameters
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3. Enter the desired parameters and click OK.
4. If a sheet layer does not already exist in the file, the New Sheet Layer dialog box opens automatically to create 

one. Click OK.
The viewport is created on the designated sheet layer, and the sheet layer becomes active.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Sheet Layer Viewport by Cropping
Linking the Camera View to a Sheet Layer Viewport
Viewport Properties
Modifying Viewports
Viewport Status
Updating Viewports

Creating a Sheet Layer Viewport by Cropping
To create a cropped viewport either from a design layer or from an existing uncropped viewport on a sheet layer:

1. Make active the existing design layer or sheet layer that will display in the viewport.
2. Create a 2D object such as a rectangle, circle, or polyline. The 2D object must define an area; for example, a 2D 

line cannot be used. Crop objects are automatically placed in the screen plane (see “Planar Modes of 2D Objects: 
Screen Plane and Layer Plane” on page 152). Position the 2D object on the design layer or existing uncropped 
viewport to delimit the area to be included in the new viewport. The fill of a viewport cropping object is always 
None; however, the pen style can be set from the Attributes palette.

Render Settings Available when the selected Rendering mode requires parameters to be set. See the 
following:
• Sketch settings: “Applying Sketch Styles to Viewports” on page 1502
• OpenGL settings: “OpenGL” on page 1590
• Custom Renderworks settings: “Custom Renderworks Options” on page 1600
• Artistic Renderworks settings: “Artistic Renderworks Options” on page 1601
• Hidden Line, Dashed Hidden Line, and Final Shaded Polygon settings: “Line Render 

Options” on page 1592
RW Background
(Renderworks required)

Select a Renderworks background from either the default content or the current file’s 
content to use as a background for the viewport; see “Resource Libraries” on page 219

Projection Select the projection type for the viewport (see “Projection” on page 1142)
Perspective Type For Perspective projection, select the type of perspective, or choose Custom and specify 

the perspective distance
Perspective Dist For custom perspectives, enter the perspective distance

Parameter Description
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3. If the cropped viewport is being created from a design layer, select the 2D object. If the cropped viewport is being 
created from a sheet layer, select both the 2D object and the uncropped viewport.

4. Select View > Create Viewport.
5. An alert dialog box asks whether the object should be used as the viewport’s crop. Select Yes (click Always do the 

selected action to always use a selected 2D object as a crop object when creating viewports).
6. The Create Viewport dialog box opens. Enter a viewport name and drawing title, and select the sheet layer to place 

it on. The remaining viewport parameters are initially set to be the same as the design layer properties (for design 
layers) or selected viewport (for sheet layers). Change the parameters as needed.

7. Click OK.
The viewport, cropped by the selected 2D object, is created on the specified sheet layer.

8. By default, the crop object is not visible. To change the visibility of the crop object, select the viewport and select 
the Crop Visible setting in the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Sheet Layer Viewport from a Design Layer
Linking the Camera View to a Sheet Layer Viewport
Viewport Properties
Modifying Viewports
Viewport Status
Updating Viewports

Cropped viewport
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Creating Multiple Viewports Simultaneously
The Create Multiple Viewports command generates 2D drawings from a 3D model and creates up to seven sheet 
layer viewports configured with several orthographic views and one isometric view of the model.
If you run the command from a sheet layer, the viewports are added to that sheet layer. If you run the command from a 
design layer, the viewports are added to a new sheet layer that is created automatically.
To create multiple viewports simultaneously:

1. Select View > Create Multiple Viewports.
The Create Multiple Viewports dialog box opens.

2. Specify the desired viewport scale, views, and angle projection method, and then click OK.
Click to show/hide the parameters.

Parameter Description

Viewport Scale Select the viewport scale relative to the page
Method

First Angle Projection Create views using the first angle projection method; by default, the front, top, and 
left views are selected when the drawing units are metric

Third Angle Projection Create views using the third angle projection method; by default, the front, top, and 
right views are selected when the drawing units are imperial

Bottom

Right Front Left Back

Top
Isometric

Top

Isometric

Left Front Right Back

Bottom
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Viewports are created at the designated layer scale, using the current layer and class visibility and print area 
settings, with the rendered style set to hidden line rendering. Viewports are aligned horizontally and vertically, 
separated by a fixed distance, and centered on the sheet layer.

3. Optionally, configure the viewports’ layer and class settings (Active, Show, or Gray Others only), annotate the 
viewport, or modify the rendering style or other viewport parameters.
For more information, see “Setting Class and Design Layer Visibility for Viewports and Saved Views” on 
page 195, “Creating Annotations for Sheet Layer Viewports” on page 1653, and “Viewport Properties” on 
page 1636.

~~~~~~~~~~~~~~~~~~~~~~~~~
Viewports

Creating Design Layer Viewports
A sheet layer viewport displays a full or cropped view of one or more design layers, which you can change as needed 
and not affect the original drawing. For example, change the viewport’s layer and class visibilities, use a different 
render mode, or add annotations and dimensions. (See “Creating Sheet Layer Viewports” on page 1616.)
Design layer viewports provide different functionality, for more flexibility. Like a sheet layer viewport, a design layer 
viewport can display design layers from the current file in a full or cropped view; unlike a sheet layer viewport, it can 
include one or more design layers that are referenced from another file.
Like a sheet layer viewport, in a design layer viewport you can control layer and class visibility, and create layer and 
class overrides. However, because it is an object on a design layer, a design layer viewport has the same view, scale, 
and render mode as everything else on the layer. You can use 2D and 3D drawing tools to add objects to the design 
layer, but you cannot add annotations to a design layer viewport.
Design layer viewports replace the layer link functionality present in the Vectorworks Fundamentals product. Current 
layer links can be easily converted to a design layer viewport with the Modify > Convert > Convert to Viewport 
command (Vectorworks Design Series required). (See “Converting Layer Links” on page 1859.) 

The search criteria used in worksheets and in the Script Editor allow you to filter out items from design layer 
viewports, to prevent unwanted duplicates in schedules.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Design Layer Viewport from an Internal Design Layer
Creating a Design Layer Viewport by Cropping
Creating a Referenced Design Layer Viewport
Viewport Properties
Modifying Viewports
Viewport Status
Updating Viewports

Views
Front, Top, Right, Left, 
Bottom, Back, Isometric

Select the view(s) to create in the drawing

Parameter Description
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Creating a Design Layer Viewport from an Internal Design Layer
To create a design layer viewport that displays a design layer in the same file:

1. Select View > Create Viewport. Alternatively, from either the Organization dialog box or the Navigation palette, 
select the Viewports tab, and click New.

2. The Create Viewport dialog box opens. The scale, view, and render mode of the viewport are determined by the 
design layer on which it is placed; they cannot be changed here. Set the other viewport parameters as desired. 
After the viewport has been created, additional parameters become available; see “Editing a Design Layer 
Displayed in a Viewport” on page 1649.

Click to show/hide the parameters.

3. Click OK.
The viewport is created on the designated design layer, and the design layer becomes active. The viewport can be 
cropped, as described in “Cropping Sheet Layer or Design Layer Viewports” on page 1652.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Design Layer Viewports
Creating a Design Layer Viewport by Cropping
Creating a Referenced Design Layer Viewport
Viewport Properties
Modifying Viewports
Viewport Status
Updating Viewports

Parameter Description

Viewport Name Specifies the viewport name; this name must be unique in the document
Drawing Title Specifies a descriptive name for the viewport. The drawing title name is limited to 63 

characters.
Create on Layer Select the design layer in the current file where the viewport will be created, or select 

New Design Layer to create a layer
Source Displays the name of the file that contains the design layers to display in the viewport. If 

Current Document is not displayed here, click Select Source to open the Select Viewport 
Source dialog box; select Current Document as the source, and click OK to return to 
this dialog box.
See “Creating a Referenced Design Layer Viewport” on page 1622 for information about 
referencing an external file. 

Layers Specifies which design layers will be visible in the viewport; see “Changing the Layer 
Properties of Sheet Layer or Design Layer Viewports” on page 1659

Display Planar Objects Select to display 2D planar objects, when the viewport’s view is other than Top/Plan
Project Screen Objects Select to display 2D objects associated with the screen plane, when the viewport’s view is 

other than Top/Plan 
Classes Specifies which classes from the source file will be visible in the viewport; see 

“Changing the Layer Properties of Sheet Layer or Design Layer Viewports” on 
page 1659

Remaining fields The remaining fields are not available for design layer viewports
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Creating a Design Layer Viewport by Cropping
The viewport and the design layer that displays in it must both be in the same file.
To create a design layer viewport by cropping:

1. Access the design layer that will display in the viewport.
2. Create a 2D object such as a rectangle, circle, or polyline. The 2D object must define an area; for example, a 2D 

line cannot be used. Crop objects are automatically placed in the screen plane (see “Planar Modes of 2D Objects: 
Screen Plane and Layer Plane” on page 152). Position the 2D object on the design layer to delimit the area to be 
included in the new viewport. The fill of a viewport crop object is always None; however, the pen style can be set 
from the Attributes palette.

3. Select the 2D crop object, and then select View > Create Viewport.
4. An alert dialog box asks whether the object should be used as the viewport’s crop. Select Yes (also select Always 

do the selected action to always use a selected 2D object as a crop object when creating viewports).
5. The Create Viewport dialog box opens. Select the design layer on which to create the viewport. The Source must 

be the current document. Specify the design layers and classes to display in the viewport. (See “Changing the 
Layer Properties of Sheet Layer or Design Layer Viewports” on page 1659 and “Changing the Class Properties of 
Sheet Layer or Design Layer Viewports” on page 1661.)

6. Click OK.
The viewport, cropped by the selected 2D object, is created on the specified design layer.

7. By default, the crop object is not visible. To change the visibility of the crop object, select the viewport and select 
the Crop Visible setting in the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Design Layer Viewports
Creating a Design Layer Viewport from an Internal Design Layer
Creating a Referenced Design Layer Viewport
Viewport Properties
Modifying Viewports
Viewport Status
Updating Viewports

Creating a Referenced Design Layer Viewport
Referencing allows you to use information from other Vectorworks files in your file, including design layers, classes, 
and resources (such as hatches, worksheets, or symbols). There are two ways to reference design layers that are in other 
Vectorworks files:

1st Floor Powder Room 2nd Floor Master Bath 2nd Floor Hall Bath 
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• The default method in the Vectorworks Design Series products is to create a design layer viewport and then 
reference the desired design layers from the master file into the viewport, as described here. One advantage to this 
method is that all of the layers, classes, and resources from the master file are not automatically imported into the 
target file.

• In the Vectorworks Fundamentals product, design layers are imported into the target file when they are referenced. 
For backward compatibility, the Vectorworks Design Series products support this method. See “Adding and 
Editing Layer Import References” on page 210.

A reference for a design layer viewport can be created when the viewport is created, or it can be created ahead of time 
from the References tab of the Organization dialog box.
To create a design layer viewport that references a design layer in another file:

1. If the current file uses layer import referencing, switch to design layer viewport referencing. (From the References 
tab of the Organization dialog box, click Settings, and click the Design layer viewports option on the Reference 
Settings dialog box. Any existing referenced layers are automatically converted into referenced design layer 
viewports.)

2. Select View > Create Viewport. Alternatively, from either the Organization dialog box or the Navigation palette, 
select the Viewports tab, and click New.

3. The Create Viewport dialog box opens. Enter a Viewport Name and Drawing Title, and then select the design 
layer on which to create the viewport.

4. Click Select Source to open the Select Viewport Source dialog box, and enter information about the referenced 
document.

Click to show/hide the parameters.

Parameter Description

Current Document / 
External Document

Select External Document to indicate that the design layers that will display in this 
viewport are in a different file

Existing Reference If the master file is already a reference in this file, select this option, and then select the 
reference from the list

New Reference Select this option if this is a new reference, and click Choose to open the Open 
Current-Version Drawing dialog box; locate the master file and click Open to return to 
this dialog box. The path to the selected file displays below the New Reference field.

Referenced files must be the same Vectorworks software version as the target file.
Circular references are not allowed; for example, if file A references file B, and file 
B references file C, then file C cannot reference file A. The exception is if one of 
the references uses the referencing in the Vectorworks Fundamentals product (layer 
import).

Save reference 
location as

Maintains either an absolute or relative file path reference from the current file to the 
referenced file. Use the absolute path when the location of the referenced file with 
respect to the current file is not going to change. Use the relative path when the files 
might be moved to another computer or platform; as long as the relative path between 
the files remains the same, the reference can be found. Both files must be saved on the 
save volume to select this option.
The Source File path displays either an absolute or relative path, depending on the 
selection.
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5. Click OK in the Select Viewport Source dialog box to return to the Create Viewport dialog box.
6. Specify the design layers and classes to display in the viewport (see “Changing the Layer Properties of Sheet 

Layer or Design Layer Viewports” on page 1659 and “Changing the Class Properties of Sheet Layer or Design 
Layer Viewports” on page 1661).

7. Click OK.
The viewport is created on the designated design layer, and the design layer becomes active. The viewport can be 
cropped, as described in “Cropping Sheet Layer or Design Layer Viewports” on page 1652.
The master file displays on the References tab of the Organization dialog box; for details about how to edit, 
update, or delete references, see “Workgroups and Referencing” on page 207.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Modifying Viewports
Viewport Status
Updating Viewports

Creating Section Viewports
A section viewport creates a cross section view of a model, but leaves the model intact. The section viewport can 
display a 2D cross section view of only the objects that intersect the section line, or, additionally, the 3D geometry that 
remains on the indicated side of an infinite plane passing through the section line.
Create a live section view from one or more design layers, from a clip cube on a design layer, or from a viewport on a 
sheet layer or design layer. By creating several section viewports, models can be analyzed and presented effectively. 
The section views can be updated as the model changes, and their attributes and appearance can be easily changed.
A section viewport can be created on either a sheet layer or a design layer; the functionality and purpose of the two 
types of section viewports are different.
Section viewports on sheet layers can include annotations and automatic drawing coordination of the sheet and drawing 
numbers; also, if there are multiple viewports on a sheet layer, each can a have different view and scale. These types of 
sections are always Top/Plan since they are on sheet layers, and are created for construction drawings. To get a 3D 
“look,” switch to Perspective Projection.
Section viewports on design layers are useful when, for example, a detail section is needed in a Front rendered view. A 
design layer section viewport allows comparison between a section and an elevation view. In a team environment, the 
design layer section viewport can be referenced in other files.

For sheet layer section viewports, to automatically coordinate the sheet numbers and drawing numbers among the 
sheet borders, drawing labels, and section markers in a file, select Use Automatic Drawing Coordination in the 
Display tab of the Document Preferences. This feature keeps references up to date, even when drawings are edited 
or moved to a different layer.

Automatically update 
out of date reference 
during file open

Updates the reference each time the target file is opened; when deselected, the reference 
is updated only when Update is clicked from the References tab of the Organization 
dialog box

Save referenced 
cache to disk

Saves a copy of the referenced data with the target file. When this option is deselected, a 
copy of the referenced data is not saved, which means that the target file size is smaller; 
the referenced data is refreshed when the target file is opened.

Parameter Description
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Creating a Section Viewport on a Sheet Layer
When you create a section viewport, you can place it on either a sheet layer or design layer. Section viewports on sheet 
layers can have annotations and automatic drawing coordination of the sheet and drawing numbers; also, if there are 
multiple viewports on a sheet layer, each can a have different view and scale.

If you need to draw a detailed section, or to reference the section viewport into other files, create the viewport on 
a design layer instead. (See “Creating a Section Viewport on a Design Layer” on page 1628.)

Create a section view from a design layer, from a clip cube, or from a viewport on a sheet layer. A section viewport that 
was created from a design layer or clip cube can be updated when changes are made to the design layer. However, a 
section viewport that was created from a viewport does not maintain a connection to the viewport that created it. It 
updates when the design layers that are visible in the source viewport change.
To create a section viewport on a sheet layer:

1. Prepare to create the viewport as follows:
• To create a section view from an active design layer, set the layer to Top/Plan view by selecting View > 

Standard Views > Top/Plan.
• To create a section view from an existing viewport, select a non-sectioned viewport object. The viewport 

object must be in Top, Bottom, Left, Right, Front, or Back view orientation.
• To create a section view from an existing clip cube object, use the Selection tool to highlight the vertical face 

of the clip cube where the section will begin. (See “Viewing a Model with the Clip Cube” on page 1155.) 
Right-click (Windows) or Ctrl-click (Mac) to open the context menu.

2. Select View > Create Section Viewport (for a design layer or viewport), or select Create Section Viewport from 
the context menu (for a clip cube).

3. Draw the section line to create the cutting plane on the design layer or viewport. For a clip cube, skip to step 4; the 
section line is created automatically from the clip cube face that was used to create the section viewport.
Click in the drawing and drag the mouse to begin drawing the marker line. Click to mark the end of the line, and 
then click to indicate the side of the line to look toward (keep), which is indicated by a black arrow. Double-click 
to end the line.
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To create a broken section line, click in the drawing and draw the first segment. Indicate which side of the drawing 
to show in the viewport. Click and drag to draw additional segments; broken section line segments are always 
parallel or perpendicular to each other. Double-click to end the broken line.

4. The Create Section Viewport dialog box opens, set to the parameters of the active design layer or non-section 
viewport. Change the parameters as needed.

Click to show/hide the parameters.

Parameter Description

Name Viewport as Dwg 
No./Sheet No.

Select this option to automatically set the Viewport Name to be a combination of the 
Drawing Number and the Sheet Number assigned to this viewport.
Deselect this option to enter a custom Viewport Name.

Viewport Name If Name Viewport as Dwg No./Sheet No. is not selected, enter a descriptive name for 
the viewport; this name must be unique in the document

Create on Layer Select the sheet layer where the viewport will be created, or select New Sheet Layer to 
create a sheet layer. If there are no sheet layers present and a new one is not created now, 
you will be prompted to create a sheet layer after clicking OK.

Create Drawing Label Select this option to create a drawing label in the annotation space of the section 
viewport

Drawing Number The next sequential drawing number available on the selected Sheet Layer defaults 
automatically. This number displays on the section marker associated with this viewport, 
as well as on any drawing label in the viewport’s annotations. This number must be 
unique on this sheet layer.
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Drawing Title Specifies a descriptive title for the section viewport. This name displays as the drawing 
title for any annotation objects (drawing labels, section markers, and sheet borders) that 
are added to the viewport. The drawing title name is limited to 63 characters.
If Use Automatic Drawing Coordination is selected in document preferences, a change 
to this field for the viewport automatically changes the field for the viewport’s drawing 
label, and vice versa.

Layers Specifies which design layers are visible in the viewport
Display Objects beyond 
Section Plane

When selected, shows objects beyond the section plane; visible planar objects are 
sectioned if positioned at the section line

Display Planar Objects Select to display 2D planar objects; visible planar objects are sectioned if positioned at 
the section line

Display Flattened This option is available for viewports on design layers only
Classes Specifies which classes are visible in the viewport
Scale Specifies the viewport scale relative to the page; select a scale, or choose Custom and 

enter a Custom Scale value
Custom Scale When a custom scale is selected, enter the scale value

Rendering Specifies the render mode for the viewport; some modes enable the Render Settings 
button, to specify rendering parameters

After the viewport is created, foreground rendering can be added for a composite 
rendering effect; see “Viewport Properties” on page 1636.

Render Settings Available when the selected Rendering mode requires parameters to be set. See the 
following:
• Sketch settings: “Applying Sketch Styles to Viewports” on page 1502
• OpenGL settings: “OpenGL” on page 1590
• Custom Renderworks settings: “Custom Renderworks Options” on page 1600
• Artistic Renderworks settings: “Artistic Renderworks Options” on page 1601
• Hidden Line, Dashed Hidden Line, and Final Shaded Polygon settings: “Line Render 

Options” on page 1592
RW Background
(Renderworks required)

Select a Renderworks background from either the default content or the current file’s 
content to use as a background for the viewport; see “Applying Renderworks 
Backgrounds” on page 1545

Projection Select the projection type for the viewport (see “Projection” on page 1142)
Perspective Type For Perspective projection, select the type of perspective, or choose Custom and specify 

the perspective distance
Perspective Dist For custom perspectives, enter the perspective distance

Advanced Section 
Properties

Specifies advanced section viewport parameters defining the extent and attributes of the 
section view; see “Advanced Section Viewport Properties” on page 1645

Section Line Settings Specifies the graphic attributes of the section line object; see “Section Lines and 
Section-Elevation Markers” on page 1630

Parameter Description
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5. Click OK. A section line object is created in the design layer, or is added to the annotations of the existing 
non-sectioned viewport. A section viewport is created on the selected sheet layer, and the drawing switches to that 
sheet layer, displaying the new section viewport.

By default, the cross section areas (along the plane where the section was cut) are displayed in red. These areas are 
in the Section Style class, if you want to change the fill color.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Section Viewports
Viewport Properties
Modifying Viewports
Viewport Status
Updating Viewports

Creating a Section Viewport on a Design Layer
When you create a section viewport, you can place it on either a sheet layer or design layer. Section viewports on 
design layers are useful when a detailed section is needed, or when the section viewport needs to be referenced into 
other files.

If you want to use annotations and automatic drawing coordination of the sheet and drawing numbers, or if you 
need multiple viewports on a sheet layer with different views and scales, create the viewport on a sheet layer 
instead. (See “Creating a Section Viewport on a Sheet Layer” on page 1625.)

Create a section view from a design layer, from a clip cube, or from a viewport on a sheet layer. A section viewport that 
was created from a design layer or clip cube can be updated when changes are made to the design layer. However, a 
section viewport that was created from a viewport does not maintain a connection to the viewport that created it. It 
updates when the design layers that are visible in the source viewport change.
To create a section viewport on a design layer:

1. Prepare to create the viewport as follows:
• To create a section view from an active design layer, set the layer to Top/Plan view by selecting View > 

Standard Views > Top/Plan.
• To create a section view from an existing viewport, select a non-sectioned viewport object. The viewport 

object must be in Top, Bottom, Left, Right, Front, or Back view orientation.
• To create a section view from an existing clip cube object, use the Selection tool to highlight the vertical face 

of the clip cube where the section will begin. (See “Viewing a Model with the Clip Cube” on page 1155.) 
Right-click (Windows) or Ctrl-click (Mac) to open the context menu.

2. Select View > Create Section Viewport (for a design layer or viewport), or select Create Section Viewport from 
the context menu (for a clip cube).
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3. Draw the section line to create the cutting plane on the design layer or viewport. For a clip cube, skip to step 4; the 
section line is created automatically from the clip cube face that was used to create the section viewport.
Click in the drawing and drag the mouse to begin drawing the marker line. Click to mark the end of the line, and 
then click to indicate the side of the line to look toward (keep), which is indicated by a black arrow. Double-click 
to end the line.
To create a broken section line, click in the drawing and draw the first segment. Indicate which side of the drawing 
to show in the viewport. Click and drag to draw additional segments; broken section line segments are always 
parallel or perpendicular to each other. Double-click to end the broken line.

4. The Create Section Viewport dialog box opens. After you select the design layer on which to create the viewport, 
several parameters that apply only to section viewports on sheet layers become unavailable; they are not included 
in the parameters table. Enter the desired parameters.
The scale of a design layer section viewport is the same as the layer where it is placed. The rendering mode of the 
current layer is also used to render the design layer section viewport.

Click to show/hide the parameters.

5. Click OK. A section line object is created in the design layer, or is added to the annotations of the existing 
non-sectioned viewport. A section viewport is created on the selected design layer, and the drawing switches to 
that design layer, displaying the new section viewport.
Initially, the view is set to Top/Plan, but this can be changed, and the section can be displayed in any view (the 
Flyover tool can also be used to view the section). Additionally, there is an option to display a flattened version of 
the section, which can be used to create section drawings or details.
A design layer section viewport can be cropped, but it does not contain an annotation space.

Parameter Description

Viewport Name If Name Viewport as Dwg No./Sheet No. is not selected, enter a descriptive name 
for the viewport; this name must be unique in the document

Create on Layer Select the design layer where the viewport will be created, or select New Design 
Layer to create a design layer. If there are no design layers present and a new one is 
not created now, you will be prompted to create a design layer after clicking OK.

Layers Specifies which design layers are visible in the viewport
Display Objects beyond 
Section Plane

When selected, shows objects beyond the section plane, on the indicated side of the 
section; deselect to show only the objects that intersect the section line

Display Planar Objects Select to display 2D planar objects; visible planar objects are sectioned if positioned 
at the section line

Display Flattened This option becomes available after you select a design layer in the Create on Layer 
field. When selected, the viewport always displays a “flattened” section view, similar 
to a section viewport on a sheet layer; deselect this option to have the viewport 
display the current view selected for the design layer.

Classes Specifies which classes are visible in the viewport
Advanced Section Properties Specifies advanced section viewport parameters defining the extent and attributes of 

the section view; see “Advanced Section Viewport Properties” on page 1645
Section Line Settings Specifies the graphic attributes of the section line object; also sets the default 

attributes for the section lines for future section viewports you create (see “Section 
Lines and Section-Elevation Markers” on page 1630)
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Section Lines and Section-Elevation Markers
Section lines and section-elevation markers look very similar on a drawing, but they are created differently.
A section line is automatically created when a section viewport is created. The section line graphically indicates the 
cutting plane of the section viewport and shows the orientation of the section view. Specify the graphic properties of the 
section line (such as the marker style), when you create the section viewport. To access a section line from its section 
viewport, click Section Line Instances from the Object Info palette (see “Section Line Instances” on page 1631).

A section line that has been pasted from a copy, duplicated, or mirrored from a section line that was associated 
with a section viewport becomes an “unlinked” section line. It displays with black and yellow stripes and the 
Section Viewport field in the Object Info palette displays “Not Linked.”

A section-elevation marker is graphically similar to a section line, but it is not linked to any viewport. Use the 
Section-Elevation Marker tool from the Dims/Notes tool set to insert a marker, as a reference line graphic for sections 
and elevations, or as a cutting plane graphic. Select the Preferences option from the Tool bar to specify the graphic 
properties of the object before you create it.
After creation, edit both section lines and section-elevation markers as follows:

• Use the Object Info palette to edit the graphic properties (such as the marker style).
• Use the Attributes palette to apply attributes (such as the fill or pen color).
• Use options on the Text menu to control the text appearance (such as the font or size), or assign a text style.
• Use the Selection or Reshape tool to edit the objects (see “Modifying Section Lines Graphically” on page 1656).

Creating Section-Elevation Markers

To insert a section-elevation marker:

1. Select the Section-Elevation Marker tool from the Dims/Notes tool set.
2. Select the Preferences option from the Tool bar, and set the default parameters for section-elevation markers.
3. Click to place one end of the section-elevation marker.
4. To insert a single-segment marker, drag to determine the marker length.

To insert a multi-segment marker, click to define each segment. Because a multi-segment marker is a polyline, the 
methods of drawing and editing polylines apply (see “Creating Polylines” on page 298).

5. Double-click to finish placing the section-elevation marker.
~~~~~~~~~~~~~~~~~~~~~~~~~
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Section Line Instances
Section line instances associated with a section view can be added to or deleted from design layers or viewport 
annotations. In addition, the Section Line Instances dialog box provides an easy way to navigate from a section 
viewport to its associated section lines.
To edit section line instances or navigate to a section line:

1. Select the section viewport whose section line you want to navigate to or edit.
2. Click Section Line Instances from the Object Info palette.

The Section Line Instances dialog box opens.
Click to show/hide the parameters.

3. To add another instance of the section line to a different design layer or to the annotation for a different viewport, 
click in the column next to that design layer or viewport, and then click OK. Alternatively, to remove a section 
line instance from a layer or viewport, click the checked column (which removes the check mark), and then click 
OK.
Deleting all section line instances does not delete the section viewport, and new instances can be created at any 
time. However, deleting a section viewport deletes all section line instances.

4. The section line instances can also be used as a navigation tool to access a particular section line. Select the 
section line and click Activate to switch to the design layer or viewport; the section line is selected for any 
modifications.
To return from a section line instance to the associated section viewport, click Navigate to Section Viewport 
from the Object Info palette of a selected section line.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Creating Section Viewports from Unlinked Section Lines
An unlinked (orphan) section line is disconnected from its associated section viewport, possibly because the section 
line was pasted from a copy, duplicated, or mirrored. It displays as a black and yellow line, and “Not Linked” is 
displayed in Section Viewport on the Shape tab of the Object Info palette.
Section viewports can be created from unlinked section lines located on a design layer, sheet layer, or while in edit 
annotation mode.

Parameter Description

Viewport Displays the name of the selected section viewport
Design Layers tab/
Viewports tab

Displays the names of all design layers in the file (on the Design Layers tab) and all sheet 
layer viewports in the file (on the Viewports tab). Each design layer or viewport that contains 
a section line associated with the selected section viewport has a check mark to the left of its 
name.

Activate When a design layer or viewport with a check mark is selected, navigates to the section line 
instance
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To create a section viewport from an unlinked section line:
1. Select the unlinked section lines. If on a sheet layer, include the viewport to be sectioned in the selection set.

Each selected section line creates a new section viewport.
2. Select View > Create Section Viewport.

The Create Section Viewport dialog box opens (see “Creating Section Viewports” on page 1624). If multiple 
unlinked section lines were selected, the parameters specified apply to all section viewports created.

3. Click OK to create a section viewport for each selected section line.
~~~~~~~~~~~~~~~~~~~~~~~~~
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Creating and Sectioning Elevation Views
Section viewports are useful for creating images that show multiple design layers from a certain point of view.
For example, to show an exterior elevation of a building model, draw a section line outside of the model on one of the 
design layers and make all of the necessary layers visible in the section viewport. To show an interior view of the same 
model, do the same thing, but draw the section line through the model at the appropriate location. 
Alternatively, if you already have a (non-sectioned) sheet layer viewport that shows multiple design layers in an 
elevation view, you can draw the section line through the viewport at the appropriate location.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Section Viewports

Make all of the design layers visible in the section 
viewport to create an exterior elevation view

In Top/Plan view on one of the design layers, draw a 
section line looking toward the model

On a viewport that shows an elevation view, draw a section line to create an interior elevation view
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Creating Detail Viewports
The Create Detail Viewport command creates a cropped sheet layer viewport that shows a detail view of any part of a 
drawing. A detail viewport can be created from a design layer, another sheet layer viewport, or a section viewport.
The crop object used to create the detail viewport becomes a callout object that is linked to the detail viewport for easy 
navigation between layers. If the detail callout object is moved or reshaped, the detail viewport is updated accordingly. 
Additionally, the detail callout is automatically labeled with the drawing number and sheet number of the detail 
viewport. If the detail viewport is renumbered or moved to another layer, the callout marker is updated automatically.
To create a detail viewport:

1. Create a crop object on a design layer (in Top/Plan view), on a sheet layer viewport (sectioned or not), or inside a 
viewport annotation group.

2. Select the crop object and then select View > Create Detail Viewport.
The Create Detail Viewport dialog box opens. Different options are available, depending on where the crop object 
is located (design layer, viewport, or section viewport). Specify the desired parameters.

Click to show/hide the parameters.

Parameter Description

Name Viewport as 
Dwg No./Sheet No.

Select this option to automatically set the Viewport Name to be a combination of the 
Drawing Number and the sheet layer name.
Deselect this option to enter a custom Viewport Name.

Viewport Name If Name Viewport as Dwg No./Sheet No. is not selected, enter a descriptive name for the 
viewport. This name displays for the viewport on the Navigation palette and Organization 
dialog box. The name must be unique in the document.

Create on Layer Select the sheet layer where the viewport will be created, or select New Sheet Layer to 
create a sheet layer. If there are no sheet layers present and a new one is not created now, 
you will be prompted to create a sheet layer after clicking OK.

Create Drawing Label Select this option to create a drawing label in the annotation space of the detail viewport
Drawing Number The next sequential drawing number available on the selected sheet layer defaults 

automatically. This number displays on the drawing label associated with this viewport, 
as well as on the detail callout. The number must be unique on this sheet layer.

Drawing Title Specifies a descriptive title for the viewport; this name displays on the drawing label 
associated with this viewport. The drawing title name is limited to 63 characters.

Layers Specifies which design layers are visible in the viewport
Display Planar Objects Select to display 2D planar objects
Project Screen Objects Available if the detail viewport is being created from a design layer or a non-section 

viewport; when selected, displays 2D objects associated with the screen plane
Display Objects 
Beyond Section Plane

Available if the detail viewport is being created from a section viewport; when selected, 
shows objects beyond the section plane
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3. Click OK to close the Create Detail Viewport dialog box. The specified sheet layer is activated, and the detail 
viewport is placed in the center of the sheet.
Additionally, the original crop object is converted into a detail callout object. If the detail viewport was created 
from a design layer, the detail callout is created on the design layer. If the detail viewport was created from a 
viewport, the detail callout is created in the annotation space of that viewport. The callout includes the drawing 
number and sheet number of the detail viewport associated with it.

Classes Specifies which classes are visible in the viewport
Scale Specifies the viewport scale relative to the page; select a scale, or choose Custom and 

enter a Custom Scale value
Custom Scale 1: When a custom scale is selected, enter the scale value
Rendering Available if the detail viewport is being created from a viewport; some modes enable the 

Render Settings button, to specify rendering parameters
Render Settings Available if the detail viewport is being created from a viewport, and the selected 

Rendering mode requires parameters to be set. See the following:
• Sketch settings: “Applying Sketch Styles to Viewports” on page 1502
• OpenGL settings: “OpenGL” on page 1590
• Custom Renderworks settings: “Custom Renderworks Options” on page 1600
• Artistic Renderworks settings: “Artistic Renderworks Options” on page 1601
• Hidden Line, Dashed Hidden Line, and Final Shaded Polygon settings: “Line Render 

Options” on page 1592
RW Background
(Renderworks 
required)

Available if the detail viewport is being created from a viewport and one of the 
Renderworks Rendering modes is selected. Select a Renderworks background from 
either the default content or the current file’s content to use as a background for the 
viewport; see “Resource Libraries” on page 219.

Detail Callout Settings Opens a dialog box to set options for the detail callout object; see “Properties of Detail 
Callouts” on page 1642

Parameter Description

Draw a crop object over a portion of 
the viewport and select View > 
Create Detail Viewport
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4. You can create additional instances of the callout on other design layers or in the annotations of other viewports, if 
needed. See “Detail Callout Instances” on page 1635.

5. To delete a detail viewport and its associated callout, delete the viewport.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
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Detail Callout Instances
Detail callout instances associated with a detail viewport can be added to or deleted from design layers or viewport 
annotations. In addition, the Detail Callout Instances dialog box provides an easy way to navigate from a detail 
viewport to its associated detail callout.
To edit detail callout instances or navigate to a detail callout:

1. Select the detail viewport whose callout you want to navigate to or edit.
2. Click Detail Callout Instances from the Object Info palette.

The Detail Callout Instances dialog box opens.
Click to show/hide the parameters.

Parameter Description

Viewport Displays the name of the selected detail viewport

A detail callout object is created in the 
original viewport’s annotations

A detail viewport is created on the specified 
sheet layer; the detail viewport and detail callout 
are linked

http://www.youtube.com/watch?v=uzrT9mRPGQ0
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3. To add another instance of the detail callout to a different design layer or to the annotations for a different 
viewport, click in the column next to that design layer or viewport, and then click OK. Alternatively, to remove a 
detail callout instance from a layer or viewport, click the checked column (which removes the check mark), and 
then click OK.
Deleting all detail callout instances does not delete the detail viewport, and new instances can be created at any 
time. However, deleting a detail viewport deletes all detail callout instances.

4. The detail callout instances can also be used as a navigation tool to access a particular callout. Select the detail 
callout and click Activate to switch to the design layer or viewport; the detail callout is selected for any 
modifications.
To return from a detail callout instance to the associated detail viewport, click Navigate to Viewport from the 
Object Info palette of a selected detail callout.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Viewport Properties
Once it has been created, edit the viewport in the Object Info palette, or select Properties from the viewport’s context 
menu to open the Properties dialog box. Edit the parameters as needed.

A viewport is assigned to the None class when it is created, and its visibility is controlled by the class settings 
when that class is not active.

Click to show/hide the parameters.

Design Layers tab/
Viewports tab

Displays the names of all design layers in the file (on the Design Layers tab) and all other 
sheet layer and section viewports in the file (on the Viewports tab). Each design layer or 
viewport that contains a detail callout associated with the selected detail viewport has a check 
mark to the left of its name.

Activate When a design layer or viewport with a check mark is selected, navigates to the detail callout 
instance:
• If the detail callout instance is on a design layer, activates that design layer and centers the 

detail callout object in the screen
• If the detail callout instance is in a viewport, activates the sheet layer of the viewport and 

enters annotation editing mode for the viewport

Parameter Description

Rotation Sets the viewport rotation; if the viewport was created from a rotated plan view 
(Vectorworks Design Series required), this parameter can be used to reset the viewport 
to the world coordinate system

Lock Position (design 
layer viewport)
(Vectorworks Design 
Series required)

Select to prevent the viewport from being moved accidentally

Parameter Description
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Crop Indicates whether the selected viewport has been cropped (see “Cropping Sheet Layer or 
Design Layer Viewports” on page 1652)

Crop Visible If the viewport has been cropped, select to display the crop object
Update Click to update the viewport to reflect any changes that have occurred since the viewport 

was created or last updated
Description (design 
layer viewport)
(Vectorworks Design 
Series required)

Specifies a descriptive name for the viewport

Drawing Title Specifies a descriptive title for the viewport. This name displays as the drawing title for 
any annotation objects (drawing labels, sheet borders, and section markers) that are 
added to the viewport. The drawing title name is limited to 63 characters.
If Use Automatic Drawing Coordination is selected in document preferences, a 
change to this field for the viewport automatically changes the field for the viewport’s 
drawing label, and vice versa. (Vectorworks Design Series required)

Drawing Number (sheet 
layer section viewport, 
detail viewport)
(Vectorworks Design 
Series required)

The next sequential drawing number available on the selected Sheet Layer defaults 
automatically. This number displays on the section marker associated with this viewport, 
as well as on any drawing label in the viewport’s annotations. This number must be 
unique on this sheet layer. Additionally, if Text Auto-Fill is selected for the detail 
callout, a change to this field for the viewport automatically changes the field for the 
detail callout.

Layers Specifies which design layers are visible in the viewport and allows changes to some of 
the layer properties in the viewport; see “Changing the Layer Properties of Sheet Layer 
or Design Layer Viewports” on page 1659

Display Objects Beyond 
View Plane (section 
viewport, detail 
viewport)
(Vectorworks Design 
Series required)

Shows or hides objects beyond the view plane

Display Planar Objects Select to display 2D planar objects, when the viewport’s view is other than Top/Plan. For 
section viewports, visible planar objects are sectioned if positioned at the section line 
(Vectorworks Design Series required).

Project Screen Objects Select to display 2D objects associated with the screen plane, when the viewport’s view 
is other than Top/Plan. Detail viewports must be created from a design layer or 
non-section viewport to enable this option.

Display Flattened 
(design layer section 
viewport)
(Vectorworks Design 
Series required)

When selected, the viewport always displays a “flattened” section view, similar to a 
section viewport on a sheet layer; deselect this option to have the viewport display the 
current view selected for the design layer

Parameter Description
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Classes Specifies which classes are visible in the viewport and allows changes to some of the 
class properties in the viewport, including changes to the properties for annotation or 
crop objects. Class visibilities can be overridden for a selected viewport; see “Changing 
the Class Properties of Sheet Layer or Design Layer Viewports” on page 1661.

Scale Specifies the viewport scale relative to the page; select a scale, or choose Custom and 
enter a Custom Scale value

Custom Scale When a custom scale is selected, enter the scale value
RW Camera 
(Renderworks required)

Indicates whether the viewport is linked to a Renderworks camera

View Specifies the orientation of the design layers displayed in the viewport; select a cardinal 
view or choose Custom and then click Set View to specify the view

The standard view of a selected viewport can be changed with the numeric keypad 
shortcut keys (see “Using Standard Views” on page 1141).

Set View When a custom view is selected, click Set View to open the 3D Rotation dialog box for 
the entry of custom view parameters (see “Rotating Precisely” on page 1151 for more 
information)

Background/Foreground 
Render

Specifies the render mode(s) for the viewport. Select a background mode and specify the 
render settings, if any. For a composite effect, also select an optional foreground mode 
and specify any settings (Wireframe, Sketch, Hidden Line, or Dashed Hidden Line are 
the only render modes available for foreground rendering).

Background / 
Foreground Render 
Settings

Some render modes require parameters to be set; click the appropriate Render Settings 
button to specify them. See the following:
• Wireframe settings: “Wireframe Options” on page 1589
• Sketch settings: “Applying Sketch Styles to Viewports” on page 1502
• OpenGL settings: “OpenGL” on page 1590
• Custom Renderworks settings: “Custom Renderworks Options” on page 1600
• Artistic Renderworks settings: “Artistic Renderworks Options” on page 1601
• Hidden Line, Dashed Hidden Line, and Final Shaded Polygon settings: “Line Render 

Options” on page 1592
RW Background
(Renderworks required)

Select a Renderworks background from either the default content or the current file’s 
content to use as a background for the viewport; see “Applying Renderworks 
Backgrounds” on page 1545

If the Renderworks Background choices are not available, the background selection 
is controlled by the Renderworks style in effect. Set the background in the 
Renderworks style instead; see “Renderworks Styles” on page 1596.

Projection Select the projection type for the viewport (see “Projection” on page 1142)
Perspective Type For Perspective projection, select the type of perspective, or choose Custom and specify 

the perspective distance
Perspective Dist For custom perspectives, enter the perspective distance

Parameter Description
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Once a section viewport is created (Vectorworks Design Series required), you may need to add or remove items 
that display in the section view. To do so, first use the Convert to Lines, Convert to Polygons, or Convert to 
Group command to convert the viewport to another form. (This conversion results in a group of lines and other 
primitives; it is no longer a viewport and can’t be updated to reflect drawing changes.) The conversion will 
produce different results, depending on which command is used and on how the viewport is rendered at the time of 
the conversion.

~~~~~~~~~~~~~~~~~~~~~~~~~
Properties of Section Lines and Section-Elevation Markers
Properties of Detail Callouts
Advanced Sheet Layer Viewport Properties
Advanced Design Layer Viewport Properties
Advanced Section Viewport Properties
Creating Sheet Layer Viewports
Creating Design Layer Viewports
Creating Section Viewports
Creating Detail Viewports

Lighting Options Click to change the ambient light parameters described in “Setting Lighting Options” on 
page 1571.
By default, a viewport’s ambient light is set according to the ambient light settings of the 
first visible design layer in the viewport. If there are no visible layers, the ambient light 
is set to on, with a color of white and a brightness of 35% (similar to the default ambient 
lighting for a design layer). 

If the lighting options are controlled by a Renderworks style that is currently in 
effect (Renderworks required), the Edit Renderworks Style dialog box opens 
instead; see “Renderworks Styles” on page 1596.

Advanced Properties Opens the Advanced Viewport Properties dialog box; see “Advanced Sheet Layer 
Viewport Properties” on page 1642, “Advanced Design Layer Viewport Properties” on 
page 1644, or “Advanced Section Viewport Properties” on page 1645 

Source (design layer 
viewport)
(Vectorworks Design 
Series required)

Indicates the source file that contains the original design layer(s) that display in the 
viewport

Reverse Direction 
(section viewport)
(Vectorworks Design 
Series required)

Switches to view the other side of the section line

Section Line Instances 
(section viewport)
(Vectorworks Design 
Series required)

Lists the section line instances present in the file (see “Section Line Instances” on 
page 1631)

Detail Callout Instances 
(detail viewport)
(Vectorworks Design 
Series required)

Lists the detail callout instances present in the file (see “Detail Callout Instances” on 
page 1635)

Parameter Description
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Modifying Viewports
Viewport Status
Updating Viewports

Properties of Section Lines and Section-Elevation Markers
Parameters display on the Object Info palette for selected section lines and section-elevation markers. Many of these 
parameters also display on the Section Line Settings dialog box, which you can access when you create a section 
viewport. Edit the parameters as needed.
Click to show/hide the parameters.

Parameter Description

Section Viewport
(Section Lines only)

Displays the name of the viewport associated with the section line; a section 
line that is not associated with a viewport is labeled “Not Linked”

Reverse Direction
(Section Lines only)

Reverses the side to display when objects beyond the section plane are visible

Navigate to Section Viewport
(Section Lines only)

Navigates to the section viewport associated with the section line

Rotation
(Section-Elevation Markers only)

Sets the marker rotation; if the marker was created from a rotated plan view, 
this parameter can be used to reset the marker to the world coordinate system

Text Style Select a text style from either the default content or the current file’s content. 
To use the style associated with the class, select <Class Text Style>. To format 
the text using options on the Text menu, select <Un-Styled>.

Configuration Select the section line configuration
• Section: draws a section marker at both ends of a straight or broken section 

line
• Partial Section: draws a section marker at the beginning of a straight or 

broken section line
• Elevation: draws a section marker along a straight section line at a control 

point, which can be dragged to a new location

Flip
(Section-Elevation Markers only)

Reverses the direction of the marker

Section

Elevation

Partial Section

Text control point

Marker control point
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~~~~~~~~~~~~~~~~~~~~~~~~~
Viewport Properties
Creating Section Viewports

Set Marker Style(s) 
(for Section-Elevation Markers)
or
Section Marker Style(s) 
(for Section Lines)

Opens the Set Marker Style dialog box, to select the section marker type at 
each end of the section line; markers can be the same (Match Beginning) or 
different (Differentiate) at each end of the section line. Select from either the 
default content or the current file’s content; see “Resource Libraries” on 
page 219.

Marker Size Specifies the size of the section marker(s), measured from the marker’s 
insertion point to the top of its longest point. Changes to the marker size do not 
affect the text size.

Use Gapped Line
(Section and Partial Section 
configurations only)

Displays the section line with a gapped line

Gap Line Length If Use Gapped Line is selected, specifies the length of the solid section line at 
each end of the section line

Text Auto-Rotate When selected, the marker text always displays in the same orientation; when 
deselected, the text is rotated according to the Text Rotation value

Text Both Ends
(Section configuration only)

Displays text at the end of the marker, as well as the beginning

Text Style Specifies the display style for the Drawing Number and Sheet Number text; 
if Dwg. No.-Sheet No. or Sheet No.-Dwg. No. is selected, specify a Text 
Separator to place between the text items

Text Rotation When Text Auto-Rotate is not selected, specifies the rotation of the marker 
text

Text Sheet % Specifies the scale value for the Sheet Number portion of the marker text. 
Enter a number larger than 100 to make the text larger. Enter a number below 
100 to make it smaller. The scale value must be larger than 1.

Text Separator For the Dwg. No.-Sheet No. and Sheet No.-Dwg. No. text styles, specifies the 
separator to place between the Drawing Number and Sheet Number text

Text Auto-Fill
(Section Lines only)

For section line objects associated with a section viewport, automatically 
displays the Drawing Number of the referenced section viewport, and the 
viewport’s Sheet Number. Deselect this option to enter the Drawing Number 
and Sheet Number manually.

Drawing Number Enter the Drawing Number of the referenced section viewport; this value 
defaults for section lines when Text Auto-Fill is selected

Sheet Number Enter the Sheet Number of the referenced section viewport; this value defaults 
for section lines when Text Auto-Fill is selected

Parameter Description
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Properties of Detail Callouts
Parameters display for selected detail callouts on the Object Info palette. Many of these parameters also display on the 
Detail Callout Settings dialog box, which you can access when you create a detail viewport. Edit the parameters as 
needed. If there are multiple instances of the detail callout, all instances are updated.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
Viewport Properties
Creating Detail Viewports

Advanced Sheet Layer Viewport Properties
To access additional sheet layer viewport parameters, click Advanced Properties from the Object Info palette or 
Properties dialog box of a selected viewport. The Advanced Viewport Properties dialog box opens. These settings 
affect the viewport display only; they do not change the original design layer(s). Edit the parameters as needed.
Click to show/hide the parameters.

Parameter Description

Detail Viewport Displays the name of the viewport
Navigate to Viewport Accesses the detail viewport associated with this detail callout
Detail Callout 
Graphic Options

Opens a dialog box to set options for the marker attached to the callout object. Select a 
Marker Symbol from the list of those available. The Shoulder Length is the distance from 
the shoulder point of the leader line to the center of the marker. Leader Line sets the style 
and thickness of the leader line. Tag Position sets the position of the marker relative to the 
callout bubble.

Marker Size Specifies the size of the callout marker, measured from the marker’s insertion point to the 
top of its longest point. Changes to the marker size do not affect the text size.

Text Style Specifies the display style for the Drawing Number and Sheet Number text; if Dwg. 
No.-Sheet No. or Sheet No.-Dwg. No. is selected, specify a Text Separator to place 
between the text items

Text Rotation Specifies the rotation of the marker text
Text Sheet Specifies the scale value for the Sheet Number portion of the marker text. Enter a number 

larger than 100 to make the text larger. Enter a number below 100 to make it smaller. The 
scale value must be larger than 1.

Text Separator For the Dwg. No.-Sheet No. and Sheet No.-Dwg. No. text styles, specifies the separator to 
place between the Drawing Number and Sheet Number text

Text Auto-Fill Automatically displays the Drawing Number of the referenced detail viewport, and the 
detail viewport’s Sheet Number. Deselect this option to enter the Drawing Number and 
Sheet Number manually.

Drawing Number Enter the Drawing Number of the referenced detail viewport; this value defaults when Text 
Auto-Fill is selected

Sheet Number Enter the Sheet Number of the referenced detail viewport; this value defaults when Text 
Auto-Fill is selected
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Parameter Description

Line Weight Scale Enter a value larger than 1.0 to increase the viewport line weights, or a value below 1.0 
(but larger than 0) to decrease the line weights

Marker Scale Enter a value larger than 1.0 to increase the viewport marker size, or a value below 1.0 (but 
larger than 0) to decrease the marker size

Line Type Scale Enter a value larger than 1.0 to increase the length and spacing of viewport line type 
segments, or a value below 1.0 (but larger than 0) to decrease the length and spacing of line 
type segments

Hatch Line Scale Enter a value larger than 1.0 to increase the spacing between viewport hatch lines, or a 
value below 1.0 (but larger than 0) to decrease the spacing between hatch lines

Text Scale Enter a value larger than 1.0 to increase the text size in viewports, or a value below 1.0 (but 
larger than 0) to decrease the text size; only associated viewport text is affected. Graphic 
objects that are part of the text item, such as a reference marker container or callout bubble, 
are scaled with the text.

Dimensional objects inside plug-in objects, such as dimensions within a bubble grid 
object, are not scaled. Plug-in objects, such as a North arrow object, are not scaled if 
they have been placed while editing the viewport in Edit Annotation mode.

Page Symbol Scaling These settings affect page-based symbols in the viewport (see “Symbol Types” on 
page 237)

Symbol Scale Sets a scale factor for page-based symbols; a scale factor of less than one decreases the size 
of the symbol relative to its definition at a 1:1 scale, while a factor of more than one 
increases its size

Attribute Scaling These settings affect the attributes (such as line weight) of page-based symbols in the 
viewport

Use Symbol Factor Uses the Symbol Scale factor to scale the attributes 
Use Individual 
Factors

Uses the other, individual scale factors in the Advanced Properties dialog box, such as the 
Line Weight Scale, to scale the page-based symbol attributes

Show Wall 
Components

Displays or hides wall and slab components in Top/Plan view, regardless of the document 
preferences detail display setting (see “Document Display Preferences” on page 60)

Render Gray Layers 
Transparent

Design layers with a visibility set to “Gray” are rendered as transparent, similar to the 
transparent effect achieved with the Unified View command (see “Unified Layer View” on 
page 1152)

Black and white only Changes all colors in the viewport to black or white; this is useful for displaying two 
viewport copies on the same sheet layer, with one in color and the other in black and white. 
However, if the document preferences display setting is black and white, viewports will 
also display as black and white.

Adjust Flipped Text Re-orients rotated and flipped text in the viewport so that it is always readable. The text 
box stays in the rotated and flipped position relative to the dimension line, but the text itself 
is re-oriented. (This setting overrides the flipped text preference for the document; see 
“Document Display Preferences” on page 60.)
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Viewport Properties
Creating Sheet Layer Viewports

Advanced Design Layer Viewport Properties
To access additional design layer viewport parameters, click Advanced Properties from the Object Info palette of a 
selected viewport. The Advanced Viewport Properties dialog box opens. These settings affect the viewport display 
only; they do not affect the original design layer(s). Edit the parameters as needed.
Click to show/hide the parameters.

Re-Position 
Dimension Text

Re-positions rotated and flipped dimension text in the viewport according to the text 
position in the dimension standard. The text itself stays in the rotated and flipped 
orientation, but the text box position relative to the dimension line is changed. (This setting 
overrides the flipped text preference for the document; see “Document Display 
Preferences” on page 60.)

Preview Displays the viewport with a preview of the advanced settings

Parameter Description

Show Wall 
Components

Displays or hides wall components in Top/Plan view, regardless of the document 
preferences detail display setting (see “Document Display Preferences” on page 60)

Black and white only Changes all colors in the viewport to black or white; this is useful for displaying two 
viewport copies on the same design layer, with one in color and the other in black and 
white. However, if the document preferences display setting is black and white, viewports 
will also display as black and white.

Adjust Flipped Text Re-orients rotated and flipped text in the viewport so that it is always readable. The text box 
stays in the rotated and flipped position relative to the dimension line, but the text itself is 
re-oriented. (This setting overrides the flipped text preference for the document; see 
“Document Display Preferences” on page 60.)

Parameter Description

Dimension in an 
unrotated viewport

Dimensions after the viewport is rotated 180 degrees

Adjust Flipped Text 
enabled

Adjust Flipped Text 
and Re-Position 
Dimension Text 
both enabled

Re-Position
Dimension Text

enabled

Adjust Flipped Text
and Re-Position
Dimension Text

both disabled
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Viewport Properties
Creating Design Layer Viewports

Advanced Section Viewport Properties
Advanced properties define the extent and attributes of the sheet layer or design layer section viewport. Specify them 
when the viewport is created, or after the viewport has been created; edit the properties from either the Object Info 
palette or the Properties dialog box.
To specify the advanced properties of a section viewport:

1. From the Create Section Viewport dialog box, click Advanced Section Properties.
Alternatively, select the viewport, and then from the Object Info palette or the Properties dialog box, click 
Advanced Properties.
The Advanced Section Properties dialog box opens.

2. Click the Extent tab to specify either an infinite section view, or the length, depth, and height of a finite section 
viewport.
Finite sections are useful when you want to create interior elevations. For example, draw a section line across a 
particular room of a building, and set the layer visibility only for the room’s floor to create an interior elevation of 
only that room. For an even more precise interior elevation, use a clip cube to create the section viewport; the 
extents are automatically set according to the clip cube’s shape.

Click to show/hide the parameters.

Re-Position 
Dimension Text

Re-positions rotated and flipped dimension text in the viewport according to the text 
position in the dimension standard. The text itself stays in the rotated and flipped 
orientation, but the text box position relative to the dimension line is changed. (This setting 
overrides the flipped text preference for the document; see “Document Display 
Preferences” on page 60.)

Preview Displays the viewport with a preview of the advanced settings

Parameter Description

Dimension in an 
unrotated viewport

Dimensions after the viewport is rotated 180 degrees

Adjust Flipped Text 
enabled

Adjust Flipped Text 
and Re-Position 
Dimension Text 
both enabled

Re-Position
Dimension Text

enabled

Adjust Flipped Text
and Re-Position
Dimension Text

both disabled
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3. Click the Attributes tab to specify the appearance of objects on and beyond the section plane. Objects on the 
section plane can maintain an individual profile, or can be divided into structural and non-structural groups to 
display them differently according to class settings.

Click to show/hide the parameters.

Parameter Description

Length Range Specifies the length range of the section viewport
Infinite Cuts the section by an infinite plane
Limited by Section 
Line Length

Limits the section only to the length defined by the section line

Depth Range Specifies the depth range of the section viewport
Infinite All objects on the indicated side of the section line are displayed
Finite Displays objects on the indicated side of the section line up to a specified depth (the 

depth can be indicated graphically by dragging a dotted line on the design layer; see 
“Modifying Section Lines Graphically” on page 1656)

Height Range Specifies the height range of the section viewport
Infinite Does not limit the section to a Z range
Finite Limits the display of the section viewport to a range defined by the Start and End 

Height Z values

Parameter Description

Section Plane Objects on the section plane can be merged into a single profile, maintain individual 
profiles, or be divided into groups of structural and non-structural elements (useful for 
displaying cabinets and walls differently, for example)

Merged Cross Sections Merges the sectioned objects’ cross section profiles into one profile
Create Structural and 
Nonstructural Groups

Merges the structural objects’ cross section profiles into one group, and the 
non-structural objects’ cross section profile into another, allowing them to have a 
different class setting

Separate Cross Sections Generates a separate cross section for each sectioned object
Use Attributes of 
Original Objects

Each sectioned object is displayed with the attributes of its original object

Attribute Class / 
Structural Class

Specifies the line and fill class for the section profiles; by default, the Section Style class 
is applied to the cross sections, or you can select New to create a new class. If Create 
Structural and Nonstructural Groups is selected, the class selected here applies only 
to structural elements.

Nonstructural Class When Create Structural and Nonstructural Groups is selected, specifies the line and 
fill class for non-structural elements, or you can select New to create a new class

Objects Beyond 
Section Plane

Specifies the fill and line style for objects beyond the section plane (for section 
viewports that display objects beyond the section plane)

Fill
Use Original Uses the fill style of the original objects for objects beyond the section plane
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4. Click the Display tab to specify the section viewport display properties.
Click to show/hide the parameters.

5. Click OK to close the dialog box and save the changes.

Use Class Sets the fill style of the objects beyond the section plane by class. Select a class or select 
New to create a new class.

Line Style Changes section viewport settings for line thickness and line type
Use Original Uses the line thickness and line type of the original objects for the objects beyond the 

section plane
Use Class Sets the line thickness and line type of the objects beyond the section plane by class. 

Select a class or select New to create a new class.
Scale Factors Changes section viewport display scale settings for lines and line styles
Line Weight Scale Enter a number larger than 1.0 to make the section line weight thicker. Enter a number 

below 1.0 to make the line weight thinner. The scale value must be above zero.
Line Type Scale A line type could be used for a section viewport if the section is in a class with a line 

type (in the Attribute Class/Structural Class parameter) or the objects beyond the 
section plane have been set to a class with a line type (in the Use Class parameter). Enter 
a number larger than 1.0 to make the line weight of the line type sections thicker. Enter a 
number below 1.0 to make them thinner. The scale value must be above zero.

Parameter Description

Cast Shadows of Objects 
Removed by Section

When rendering, includes shadows cast by objects that are not included in the 
section viewport, for a more realistic effect (especially for interior elevations) 

This parameter is not available for design layer section viewports.
Show Wall and Slab 
Components

Displays the wall and slab components in 3D, regardless of the document 
preferences detail display setting (see “Vectorworks Display Preferences” on 
page 50), or component class visibility settings. The top and bottom wall lines of 
components do not display in section viewports, so that stacked walls display 
without a line break.

Merge Adjacent 
Components with Same Fill

If adjacent wall and/or slab components have the same fill, merges the fills so that 
they display as a single unit

Black and White Only Changes all colors in the section viewport to black or white; this is useful for 
displaying two section viewport copies on the same sheet layer, with one in color 
and the other in black and white. However, if the document preferences display 
setting is black and white, viewports will also display as black and white.

Adjust Flipped Text Re-orients rotated and flipped text in the viewport so that it is always readable 
(regardless of the flipped text Vectorworks preference; see “Document Display 
Preferences” on page 60)

3D Conversion Resolution Sets the segmentation resolution for curved surfaces in a live section, regardless of 
the Vectorworks preferences resolution setting (see “3D Preferences” on page 54). 
Changing the resolution of an existing section viewport causes the viewport to 
become out of date; the higher resolution settings require longer update times.

Parameter Description
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Viewport Properties
Creating Section Viewports

Modifying Viewports
There are several ways to modify viewports; their appearance can be completely different from the original design 
layers, for presentation purposes.

• Modify the settings for the viewport in the Object Info palette.
• Modify the viewport with various 2D and 3D tools and commands.
• Crop the viewport.
• Edit the design layer(s) that display in the viewport.
• Add annotations and dimensions to the viewport.
• Edit or delete a linked Renderworks camera (Renderworks required).
• Change the properties of the viewport’s layers and classes.

~~~~~~~~~~~~~~~~~~~~~~~~~
Moving and Editing Viewports
Editing a Design Layer Displayed in a Viewport
Cropping Sheet Layer or Design Layer Viewports
Creating Annotations for Sheet Layer Viewports
Editing a Linked Renderworks Camera
Modifying Section Viewports and Section Lines
Editing Detail Viewport Drawing Labels
Editing Detail Callout Objects
Changing the Layer Properties of Sheet Layer or Design Layer Viewports
Changing the Class Properties of Sheet Layer or Design Layer Viewports
Viewport Properties
Viewport Status
Updating Viewports

Moving and Editing Viewports
A sheet layer viewport can be edited like most 2D objects. For information on editing tools and commands, see 
“Editing Objects” on page 997. 3D tools cannot be used on sheet layers. However, a 3D object can be copied from a 
design layer and pasted on a sheet layer. A design layer viewport (Vectorworks Design Series required) cannot be 
pasted on a sheet layer.

• Use the Cut, Copy, and Paste commands to copy or paste a viewport on its original sheet layer or another sheet or 
design layer. Use the Selection tool to drag a viewport to a new position (or edit the X- and Y-axis positions in the 
Object Info palette). Press the Delete key to delete a selected viewport.

• Use the Move and Rotate commands and the Rotate and Mirror tools to move, rotate, or mirror a viewport. The 
viewport can be split by the Split tool (in Line Split mode), and clipped with the Clip tool. 
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• Use the Scale Objects command to scale a viewport. Any crop objects in the viewport are also scaled, as are 
annotations and dimensions. Viewport text, however, is not scaled unless Scale Text is selected in the Scale 
Objects dialog box.

• To scale a viewport with the mouse, select the viewport and use the Modify > Group command to turn it into a 
group object. Click and drag a handle to resize the viewport as needed. Then use the Modify > Ungroup 
command to change it back into a viewport object.

• Use the Modify > Lock and Modify > Unlock commands to lock and unlock viewports.
• Use the Eyedropper tool to transfer attributes from one viewport to another; see “Transferring Attributes” on 

page 1095.
• Use 2D drawing tools on sheet layers to create borders, title blocks, and so on.
• A sheet layer viewport can be copied and pasted into an image-editing application. The dpi setting of the sheet 

layer affects the resolution of the pasted image. Depending on the platform and the image-editing application, the 
resolution of the pasted image may still not be optimal; in this case, the File > Export Image File command offers 
control over the exported area, dimensions, resolution, and file type.

~~~~~~~~~~~~~~~~~~~~~~~~~
Modifying Viewports
Viewport Properties
Viewport Status
Updating Viewports

Editing a Design Layer Displayed in a Viewport
To edit a design layer that is displayed in a viewport:

1. Select the viewport.
2. Select Modify > Edit Viewport.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on a viewport, and select Edit from the context menu.
The Edit Viewport dialog box opens. The options available depend on whether the viewport is on a sheet layer or 
design layer (Vectorworks Design Series required).

Click to show/hide the parameters.

Parameter Description

Annotations (sheet layer 
viewport)

Creates or edits viewport annotations and dimensions

Crop Creates or edits a cropped viewport, and optionally displays the viewport outside of 
the crop area when in Edit Crop mode
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Display Viewport 
Outside Crop

Displays the viewport outside of the crop with wireframe rendering; objects outside of 
the crop can be snapped to when creating or editing a crop shape.
This option is only available when the Crop edit mode is selected.

Gray Outside Crop If Display Viewport Outside Crop is selected, displays the area outside of the crop in 
gray.
This option is only available when the Crop edit mode is selected.

Design Layer Navigates to the selected design layer to edit objects contained in the viewport 
Display using Viewport 
Attributes

Changes the file’s view parameters and layer and class visibilities to match those of 
the viewport.
If the Navigate Back to Viewport option is also selected, the file’s layer and class 
visibilities return to their original status when you return to the viewport; otherwise, 
the file’s attributes remain the same as the viewport’s.
This option is only available when the Design Layer edit mode is selected.

Add Reference Crop 
Object

When a viewport has been cropped, this option displays the crop on the design layer so 
that edits can be made to the design layer while knowing the position of the crop 
object.
This option is only available when the Design Layer edit mode is selected.

Navigate Back to 
Viewport

Temporarily adds a Return to Viewport button to the design layer that returns you to 
the viewport when the edit to the design layer is complete (similar to an Edit Group 
operation).
This option is only available when the Design Layer edit mode is selected.
To exit to the design layer instead of exiting to the viewport from design layer editing 
mode, press Shift + Esc. Alternatively, right-click (Windows) or Ctrl-click (Mac) in 
the drawing area, and select Exit Viewport from the context menu.

Display with Clip Cube 
(Vectorworks Design 
Series required)

If you are editing a section viewport, and Navigate Back to Viewport is selected, this 
option displays the design layer with a clip cube whose dimensions match the length, 
depth, and height ranges set for the viewport. Portions of the design layer outside the 
clip cube are not visible during editing.
You can adjust the faces and orientation of the clip cube as needed, and then either 
create a new section viewport, or update the current viewport. See “Viewing a Model 
with the Clip Cube” on page 1155 for details.
This option is only available when the Design Layer edit mode is selected.

Camera (Renderworks 
required)

Edits a Renderworks camera that is linked to the viewport view. The camera view can 
be changed or the camera can be deleted. See “Editing a Linked Renderworks 
Camera” on page 1654.
If no Renderworks camera is linked to the viewport, select a camera to be linked. 
Alternatively, the view can be manipulated with the standard view tools (such as the 
Flyover tool, zoom level, and View menu commands), changing the viewport view 
upon exit.

Parameter Description
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3. Click Design Layer and select the design layer to edit from the list.
Alternatively, right-click (Windows) or Ctrl-click (Mac) on a viewport and select Edit Design Layer from the 
context menu to activate the design layer of the right-clicked object (if the right-clicked object does not belong to 
a design layer, the Edit Viewport dialog box opens).

4. Select the editing options:
• Select Display using Viewport Attributes to view the design layer with the viewport attributes (orientation, 

projection, render mode, and layer and class visibilities). A rendered viewport displays the original design 
layer with the viewport’s render mode; however, the design layer’s render mode options for that mode are used.

• Select Add Reference Crop Object to view the crop object on the design layer during editing. However, 
because the crop object is added to the design layer, it could become visible in other viewports that reference 
that area of the design layer.

• Select Navigate Back to Viewport to easily return to the viewport when you are finished with the design layer 
edits. A colored border around the drawing window indicates that you are in an editing mode. The Return to 
Viewport button is visible in the top right corner of the drawing window.

• If this is a section viewport, select Display with Clip Cube to use a clip cube while editing the design layer.
5. Click OK to activate the selected design layer.
6. If you selected Navigate Back to Viewport, a colored border displays around the drawing window. Do one of the 

following when your edits are complete:
• Click Return to Viewport to return to the viewport. This saves changes to drawing objects, but it does not 

save clip cube edits.
• Press Shift + Esc to exit to the design layer instead of exiting to the viewport. Alternatively, right-click 

(Windows) or Ctrl-click (Mac) in the drawing area, and select Exit Viewport from the context menu.
• If the viewport has a clip cube, right-click (Windows) or Ctrl-click (Mac) the vertical cube face where the 

section line is located; select Update Section Viewport to save the clip cube edits. Then either click Return to 
Viewport, or select Exit Viewport from the context menu to exit editing mode.

Display Viewport Cache If the viewport is currently in a render mode other than Wireframe, select Display 
Viewport Cache to display a cache image of the rendered viewport during editing; 
deselect to display a Wireframe view of the viewport.
This option is only available when the Annotations or Crop edit mode is selected.

Keep the Edit View on Exit When you return to the viewport after an edit, this setting maintains any view changes 
(zoom and view location) made during edits to the viewport annotation or the crop 
object. Deselect this option to return to the original viewport view settings after 
editing.
This option is only available when the Annotations or Crop edit mode is selected.

Double Click Sets the future behavior when a viewport is double-clicked, eliminating the display of 
this dialog box if desired. If the Edits the Design Layer option is selected, a 
double-click activates the design layer of the double-clicked object. If the object does 
not belong to a design layer, the Edit Viewport dialog box opens to select a design 
layer to edit.

If Displays this Dialog is not selected, you can still open the dialog box: select 
Modify > Edit Viewport, or right-click (Windows) or Ctrl-click (Mac) the 
viewport and select Edit from the context menu.

Parameter Description



  1652 | Modifying Viewports
• If the viewport has a clip cube, right-click (Windows) or Ctrl-click (Mac) any vertical cube face other than 
where the section line is located; select Create Section Viewport to create a new section viewport with its 
section line located at that cube face.

~~~~~~~~~~~~~~~~~~~~~~~~~
Modifying Viewports
Viewport Properties
Viewport Status
Updating Viewports

Cropping Sheet Layer or Design Layer Viewports
To crop a viewport:

1. Select the viewport.
2. Select Modify > Edit Viewport. The Edit Viewport dialog box opens (see “Editing a Design Layer Displayed in a 

Viewport” on page 1649 for a description of the dialog box parameters).
3. Click Crop. 

Choose whether to display the viewport outside of the crop area. Select Display Viewport Outside Crop to view 
the rest of the viewport; select Gray Outside Crop to view the area outside of the crop in gray. These options 
make drawing and editing easier, since objects outside the crop can be snapped to.
To view other layer objects while in Edit Crop mode, select Show other objects while in editing modes on the 
Display tab of the Vectorworks preferences (see “Vectorworks Display Preferences” on page 50).

4. Click OK to enter Edit Crop mode.
Alternatively, right-click (Windows) or Ctrl-click (Mac) on a viewport and select Edit Crop from the context 
menu.
A colored border around the drawing window indicates that you are in an editing mode. The Exit Viewport Crop 
command becomes available from the Modify menu, and the Exit Viewport Crop button is visible in the top right 
corner of the drawing window.

5. Create a 2D object such as a rectangle, circle, or polyline. The 2D object must define an area; for example, a 2D 
line cannot be used. Position the 2D object to delimit the new viewport display area. The fill of a viewport 
cropping object is always None; however, the pen style can be set from the Attributes palette while in Edit Crop 
mode. Move and resize the 2D object as needed.
Use the Flyover tool to adjust the view as necessary (see “Flyover” on page 1144).
The bounding box of the crop object is also the perspective clip rectangle, if the viewport is in Perspective 
projection. Reshaping the crop object changes the perspective clip rectangle as well.
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6. Click Exit Viewport Crop to return to the sheet layer or design layer.

7. The cropped viewport displays; in the Object Info palette, the Crop status changes to Yes.
8. To change, replace, or delete the crop object, select the viewport and then select Modify > Edit Viewport to 

re-enter Edit Crop mode. Alternatively, right-click (Windows) or Ctrl-click (Mac) and select Edit from the context 
menu.
To change the visibility of the crop object, change the Crop Visible setting in the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Modifying Viewports
Viewport Properties
Viewport Status
Updating Viewports

Creating Annotations for Sheet Layer Viewports 
Use the Edit Annotation mode to add annotations and dimensions in viewports, and to edit those annotations and 
dimensions later on.
To add annotations, including dimensions, to a viewport:

1. With the viewport’s sheet layer active, select the viewport by clicking on it with the Selection tool.
2. Select Modify > Edit Viewport. The Edit Viewport dialog box opens (see “Cropping Sheet Layer or Design 

Layer Viewports” on page 1652 for a description of the dialog box parameters).
3. Click Annotations and then click OK to enter Edit Annotation mode.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on a viewport and select Edit Annotations from the 
context menu.
A colored border around the drawing window indicates that you are in an editing mode. The Exit Viewport 
command becomes available from the Modify menu, and the Exit Viewport Annotation button is visible in the 
top right corner of the drawing window.
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4. Use the various dimension tools from the Dims/Notes tool set to add dimensions to the viewport (see 
“Dimensions” on page 1187). The dimension tools snap to the objects in the viewport as if you were dimensioning 
the design layer. The dimensions are automatically updated if the design layer object changes.
Annotations are 2D objects that are placed on the screen plane. Therefore, a 2D object in the viewport must be 
dimensioned in Top/Plan view. A 3D object can be dimensioned in any view, but you must align the face that is to 
be dimensioned with the screen plane to get an accurate measurement.
To view other objects on the sheet layer while in Edit Annotation mode, select Show other objects while in 
editing modes on the Display tab of the Vectorworks preferences (see “Vectorworks Display Preferences” on 
page 50).
Text, callouts, and other annotations, as well as 2D objects, can be added to the viewport. The Vectorworks Design 
Series products contain additional annotation objects.
The stacking order of selected annotations can be changed with the Modify > Send commands. To add graphical 
annotations to a viewport rendered with Hidden Line, use the inner or outer boundary mode of the 2D Polygon 
tool (see “2D Polygon Tool” on page 303).
Annotations are in viewport scale, not sheet layer scale.

5. Click Exit Viewport Annotation to exit Edit Annotation mode and return to the sheet layer.
6. To change, replace, or delete the viewport annotations, select the viewport and then select Modify > Edit 

Viewport to re-enter Edit Annotation mode.
To change the visibility of the crop object, change the Crop Visible setting in the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Editing a Linked Renderworks Camera
You can edit a linked Renderworks camera, to change the associated sheet layer viewport’s view.
To edit a linked Renderworks camera:

1. Select the viewport.
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2. Select Modify > Edit Viewport. The Edit Viewport dialog box opens (see “Editing a Design Layer Displayed in a 
Viewport” on page 1649 for a description of the dialog box parameters).

3. Click Camera. 
4. An alert dialog box opens. Click OK to enter Edit Renderworks Camera mode.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on a viewport and select Edit Camera from the context 
menu.
A colored border around the drawing window indicates that you are in an editing mode. The Exit Renderworks 
Camera command becomes available from the Modify menu, and the Return to Viewport button is visible in the 
top right corner of the drawing window.

5. The design layer that was active when the viewport was created is active, and the linked Renderworks camera 
object is selected. Edit the camera view as described in “Adjusting the Camera View” on page 1159. 
The camera can be deleted. The view and projection parameters are controlled by the viewport if the camera is 
deleted.
If no Renderworks camera is linked to the viewport, select a camera to be linked. Alternatively, the view can be 
manipulated with the standard view tools (such as the Flyover tool, zoom level, and View menu commands), 
changing the viewport view upon exit.

6. Click Return to Viewport to return to the viewport once the Renderworks camera has been edited or deleted. The 
viewport’s view, projection, and perspective distance are updated.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Modifying Section Viewports and Section Lines
Section viewports can be modified, cropped, annotated, and updated, the same as regular sheet layer viewports. See 
“Modifying Viewports” on page 1648 and “Updating Viewports” on page 1665.
The appearance of a section viewport can be completely customized, from the items it displays to the attributes of those 
items. Copies of a section viewport on a sheet layer can look completely different. Changes to a section viewport’s 
appearance can be made by several methods; after changes are made, update the section viewport by clicking Update 
in the Object Info palette.

Modification Method Description

Change the section view Click Advanced Properties from the Object 
Info palette of a selected section viewport, and 
modify the section view from the Extent tab

“Advanced Section Viewport 
Properties” on page 1645

Change the view attributes Click Advanced Properties from the Object 
Info palette of a selected section viewport, and 
modify the attributes of the view from the 
Attributes tab

“Advanced Section Viewport 
Properties” on page 1645

Change the view direction 
of the section line

Click Reverse Direction from the Object Info 
palette of a selected section viewport

“Viewport Properties” on 
page 1636
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Modifying Section Lines Graphically
In addition to modifying section line parameters as described in “Section Lines and Section-Elevation Markers” on 
page 1630, the section line can be modified by changing its location, length, or shape.
To modify a section line:

1. Navigate to the section line by clicking Section Line Instances from the Object Info palette of a selected section 
viewport.

Change the cross section 
appearance for sectioned 
items

The cross section appearance is set by the 
Section Style class. Edit the class to change the 
appearance of sectioned items. If the Section 
Style class is made invisible, the cross sections 
are not displayed.

“Setting Class Properties” on 
page 179

Override the layer settings 
from the design layer

Click Layers from the Object Info palette of a 
selected section viewport, and override the layer 
properties.

Unlike a regular sheet layer viewport, the 
design layer stacking order in the section 
viewport cannot be changed.

“Changing the Layer Properties 
of Sheet Layer or Design Layer 
Viewports” on page 1659

Override the class settings 
from the design layer

Click Classes from the Object Info palette of a 
selected section viewport, and override the class 
properties of “by class” objects

“Changing the Class Properties of 
Sheet Layer or Design Layer 
Viewports” on page 1661

Change the location of the 
section line

Change the location of the section line with the 
Selection tool, and update the section viewport

“Modifying Section Lines 
Graphically” on page 1656

Create section viewports 
from unlinked section lines

Select the unlinked section lines and then select 
the Create Section Viewport command to 
create section viewports from the section lines

“Creating Section Viewports from 
Unlinked Section Lines” on 
page 1631

Add additional section line 
instances to design layers or 
viewports

Click Section Line Instances from the Object 
Info palette of a selected section viewport, and 
specify the design layers or viewports where 
section line instances should display

“Section Line Instances” on 
page 1631

Change the section line 
length, position, or type

Change the section line with the Selection tool 
or the Reshape tool, and update the section 
viewport

“Modifying Section Lines 
Graphically” on page 1656

Change the depth of a finite 
section

The depth can be changed graphically or by 
modifying the Depth Range in the Advanced 
Properties of the section viewport

“Modifying Section Lines 
Graphically” on page 1656, or 
“Advanced Section Viewport 
Properties” on page 1645

Modification Method Description
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2. The section line is automatically selected for modification.
• Move the section line to a new location with the Selection tool
• Shorten, lengthen, or rotate the line by dragging an end point with the Selection tool
• Add vertices and change a straight section line to a broken section line with the Reshape tool
• Reshape the section line with the Reshape tool

3. A section view with a finite depth has a special control point on a dashed line. To adjust the depth, drag the control 
point with the Selection tool.

4. Return to the section viewport by clicking Activate Section Viewport from the Object Info palette. Click Update 
from the Object Info palette to reflect the section line changes in the section view.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Editing Detail Viewport Drawing Labels
After creation, the detail viewport drawing label may be edited, either to change its appearance, or to change the 
information that it displays. Edit the drawing label from within the detail viewport’s annotation space.

Changing the length Adding vertices Adjusting the position of vertices 
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If Use Automatic Drawing Coordination is selected in document preferences, a change to the Drawing 
Number field for the detail viewport automatically changes the field for the viewport’s drawing label, and vice 
versa. Additionally, if Text Auto-Fill is selected for the detail callout, a change to the Drawing Number field for 
the viewport automatically changes the field for the detail callout.

There are several ways to change the appearance of a detail viewport drawing label.
• Use the Attributes palette to change the label’s line color or thickness
• Use the Object Info palette to change the object properties
• Use the Text menu to change the attributes of the label text (or apply a text style to it)
• Use the Selection tool to adjust the label position

To edit a detail viewport drawing label:
1. Select the detail viewport and then select Modify > Edit Viewport. The Edit Viewport dialog box opens.
2. Click Annotations and then click OK to enter Edit Annotation mode.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on a viewport and select Edit Annotations from the 
context menu.
A colored border around the drawing window indicates that you are in an editing mode. The Exit Viewport 
command becomes available from the Modify menu, and the Exit Viewport Annotation button is visible in the 
top right corner of the drawing window.

3. Select the drawing label and edit it as needed. The parameters in the Object Info palette are described in “Creating 
Drawing Labels” on page 1244.

4. Click Exit Viewport Annotation to exit Edit Annotation mode and return to the sheet layer.
~~~~~~~~~~~~~~~~~~~~~~~~~
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Editing Detail Callout Objects
After creation, the detail callout may be edited, either to change the appearance of the callout itself, or to change the 
view in the detail viewport that is linked to the detail callout. The edit method depends on where the detail callout was 
created. If the callout object was created on a design layer, select the callout and edit it directly. If the callout object was 
created within a viewport’s annotation space, select the viewport and edit its annotations (see “Editing a Detail Callout 
in a Viewport” on page 1659).

If Use Automatic Drawing Coordination is selected in document preferences, a change to the Drawing 
Number field for the detail viewport automatically changes the field for the viewport’s drawing label, and vice 
versa. Additionally, if Text Auto-Fill is selected for the detail callout, a change to the Drawing Number field for 
the viewport automatically changes the field for the detail callout.

There are several ways to change the appearance of a detail callout object.
• Use the Attributes palette to change the crop object’s line color, thickness, or type
• Use the Object Info palette to change the object properties (see “Properties of Detail Callouts” on page 1642)
• Use the Text menu to change the attributes of the marker text (or apply a text style to it)
• Use the Selection tool to adjust the marker position

You can also adjust the shape or location of the callout object, which will change the contents of the detail viewport 
associated with the callout. If there are multiple instances of the detail callout, all instances are updated.
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• Use the Selection tool to move the entire callout
• Use the Reshape tool to reshape the callout object

Editing a Detail Callout in a Viewport
If the callout was created from a viewport, the callout object cannot be edited directly because it is in the viewport’s 
annotation space.
To edit a detail callout object in a viewport:

1. Select the original viewport and then select Modify > Edit Viewport. The Edit Viewport dialog box opens.
2. Click Annotations and then click OK to enter Edit Annotation mode.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on a viewport and select Edit Annotations from the 
context menu.
A colored border around the drawing window indicates that you are in an editing mode. The Exit Viewport 
command becomes available from the Modify menu, and the Exit Viewport Annotation button is visible in the 
top right corner of the drawing window.

3. Select the detail callout and edit it as needed. The parameters in the Object Info palette are described in 
“Properties of Detail Callouts” on page 1642.

4. Click Exit Viewport Annotation to exit Edit Annotation mode and return to the sheet layer.
~~~~~~~~~~~~~~~~~~~~~~~~~
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Changing the Layer Properties of Sheet Layer or Design Layer Viewports
The viewport’s layer visibility, opacity, stacking order, and colors can be changed from the sheet layer or the design 
layer (Vectorworks Design Series required). Other viewports, as well as the design layer properties, are not affected. 
The viewport attributes can be tailored as desired for presentation; several copies of the same viewport can appear 
completely different.
To change the viewport layer properties:

1. Select the viewport.
2. From the Object Info palette, click Layers.

The Viewport Layer Properties dialog box opens.Change layer visibilities and/or make layer attribute overrides 
for the selected viewport.
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Click to show/hide the parameters.

Parameter Description

Layer list Lists the viewport layers and their visibility, edited status, layer color use status, and 
stacking order. Click the triangle in the heading of an active column to toggle between 
ascending and descending sort order based on that column parameter. 

Visibility  Click in a layer visibility column to change the layer visibility for this viewport. 
• Column 1: Visible (displays objects in this layer)
• Column 2: Invisible (hides objects in this layer)
• Column 3: Gray (displays objects in this layer as dimmed)

 (Source) • Column 4 indicates whether the layer definition is the same as the source layer, or the 
layer definition has overrides in this viewport. When a layer is edited with the Edit 
button, the override icon displays automatically. Click the Revert button to revert to the 
original settings.

          

 (Layer Colors) Click to apply the viewport layer colors set in the Edit Viewport Design Layers dialog box 
(click Edit to set the colors, as described in the next step), overriding the design layer 
colors. This setting is independent of the Use layer colors document preference.

# (Stacking Order) Displays the layer stacking order; drag a layer within the # column to change its stacking 
order. This column displays only when the viewport is in Top/Plan view. 

Edit Opens the Edit Viewport Design Layers dialog box, to override the properties of the 
selected layer

Revert Returns the settings in the Edit Viewport Design Layers dialog box to their default values 
and removes the override icon in the Source column

After editing the colors in 
the layer properties, click 
here to apply the override 
to the viewport

Click the visible, invisible, or
gray column to set the layer

visibility in the viewport

Indicates whether the layer
definition has overrides in

this viewport

Click here and drag up or 
down to change the layer 
stacking order in the 
viewport

The layer definition is from the
viewport’s source layer

Layer overrides exist in this viewport
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3. To override the layer properties (for viewport display), select one or more viewport layers and click Edit.
Alternatively, double-click on a viewport layer to edit it.
The Edit Viewport Design Layers dialog box opens.

4. The same parameters apply when you create a design layer (see “Setting Design Layer Properties” on page 165); 
for viewport layers, only the stacking order, transfer mode or opacity, and colors can be edited. These edits apply 
to the current viewport only, though they can be transferred to other viewports with the Eyedropper tool.
The viewport layer colors can be controlled separately from the design layer colors, for flexible presentation 
output. Click Colors to override the fill and pen colors for the selected viewport layer. To see the effects of the 
color override, Use Layer Colors must be selected in the Viewport Layer Properties dialog box for the selected 
viewport. This is similar to the way that Use Layer Colors must be selected in document preferences to see the 
layer color settings for a design layer, as described in “Setting the Design Layer Color” on page 170.

5. Click OK to return to the Viewport Layer Properties dialog box.
Click Preview to evaluate the results of the property changes.

6. Click OK to return to the sheet layer or design layer.
~~~~~~~~~~~~~~~~~~~~~~~~~
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Changing the Class Properties of Sheet Layer or Design Layer Viewports
The class visibilities and attributes of a selected viewport can be changed from the sheet layer or the design layer. This 
does not change the class properties or the class visibility for the original design layers or for other viewports. The 
viewport attributes can be tailored as desired for presentation; several copies of the same viewport can appear 
completely different.

Stacking Override Indicates whether the layer stacking order in the viewport is different from the design layer 
stacking order. Click Revert Stacking Order to return to the original design layer stacking 
order.

Use embedded design 
layer viewport settings 
for
(Vectorworks Design 
Series required)

• Layer overrides: If the sheet layer viewport contains a non-referenced design layer 
viewport for which layer overrides have been set, this option uses the design layer 
viewport overrides, ignoring any layer overrides that may be set here for the sheet layer 
viewport.

• Layer visibilities: If the sheet layer viewport contains a non-referenced design layer 
viewport for which layer visibilities have been set, this option uses the design layer 
viewport visibilities, ignoring any layer visibilities that may be set here for the sheet 
layer viewport.

Referenced design layer viewports are not affected by either of these settings.
Preview Click to preview the layer property settings in the selected viewport

Parameter Description
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To override viewport class properties:
1. Select the viewport.
2. From the Object Info palette, click Classes.

The Viewport Class Properties dialog box opens. The dialog box functionality is slightly different for referenced 
(Vectorworks Design Series required) and non-referenced (internal) viewports. Change class visibilities and/or make 
class attribute overrides for the selected viewport.

Click to show/hide the parameters.

Parameter Description

Class list Lists the viewport classes and their visibility and edited status; click in a class visibility 
column to change the class visibility for this viewport. Click the triangle in an active column 
to toggle between ascending and descending sort order based on that column parameter.

Non-referenced Viewport Referenced Viewport

Click the visible, invisible, 
or gray column to set the 

class visibility in the 
viewport

Indicates whether the class 
definition is specific to this 

viewport

Indicates whether the class 
definition will be updated 

from the source file
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Visibility Click in a class visibility column to change the class visibility for this viewport. 
• Column 1: Visible (displays objects in this class)
• Column 2: Invisible (hides objects in this class)
• Column 3: Gray (displays objects in this class as dimmed)

(Source) Column 4 indicates whether the class definition is the same as the source class, or the class 
definition has overrides specific to this viewport. When a class is edited with the Edit 
button, the viewport-specific icon displays automatically. Click the Revert button to revert 
to the original settings.

• Non-referenced viewports: All classes use the document class definition by default. To 
change the appearance of a class in this viewport, click Edit and change the settings as 
needed; the viewport-specific icon displays automatically. Click the Revert button to 
revert to the original settings.

• Referenced viewport: (Vectorworks Design Series required) Because they come from an 
external file, all classes show as viewport-specific by default. If the same class exists in 
both the viewport and in the current file, they remain completely separate. By default, the 
class definition in the viewport will be updated from the source file when the reference is 
updated.

 To change the appearance of a class for this viewport, leave the Source set as 
viewport-specific; then click Edit and change the class settings as needed. Also set the 
class to not update from the source file; otherwise, the edits will be removed the next time 
the reference is updated.

 To use the same class definition both in the current file and in the viewport, click the 
Source icon to toggle the setting. If the viewport class does not exist in the current file, it 
will be imported. If the class is also set to update from the source file ( ), an alert 
message prompts you to verify that you want to reference the class definition. If you 
answer Yes, the class in the current file and in the viewport will be changed whenever the 
reference to the viewport source file is updated. If you answer No, the Source reverts to 
the default setting.

(Update)

(Referenced 
viewports only)

Column 5 indicates whether the class definition will be updated from the source file when 
the reference is updated. Click the icon to toggle the setting.

Use current 
document’s class 
visibilities
(Vectorworks Design 
Series required)

When enabled, the viewport uses the current document’s class visibilities. The option is 
automatically enabled when layer links or referenced layers are converted into viewports; it 
is disabled by default for new design layer viewports.

Edit Opens the Edit Class(es) dialog box, to make overrides to the selected class that only apply 
to the current viewport (see “Setting Class Properties” on page 179); drawing objects’ class 
setting should be “By class” to take advantage of class overrides

Parameter Description

The class definition is
from the source class

The class definition is 
specific to this viewport

Update Do not update
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3. Click OK to apply the class visibility and attribute changes to the selected viewport.
~~~~~~~~~~~~~~~~~~~~~~~~~
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Viewport Status
The status of a viewport or section line is indicated visually.

Import Opens the Import Attributes dialog box, to import the class attribute settings from the file. 
The attributes can be imported for the classes selected in the Viewport Class Properties 
dialog box, from corresponding classes, or from a specified class in the file or a specified 
viewport.
Click OK to import the class attributes into the selected viewport. (The Eyedropper tool 
can also transfer class override attributes between viewports.)

Revert Sets the selected class back to its original document attributes, undoing any class overrides; 
also removes the override icon in the Source column

Use embedded 
design layer 
viewport settings for
(Vectorworks Design 
Series required)

• Class overrides: If the sheet layer viewport contains a design layer viewport for which 
class overrides have been set, this option uses the design layer viewport overrides, 
ignoring any class overrides that may be set here for the sheet layer viewport.

• Class visibilities: If the sheet layer viewport contains a design layer viewport for which 
class visibilities have been set, this option uses the design layer viewport visibilities, 
ignoring any class visibilities that may be set here for the sheet layer viewport

Preview Click to preview the class visibility and attribute settings in the selected viewport

Viewport Status Description

Normal A normal, up-to-date viewport displays with orange highlighting when selected 

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Updating Viewports
Modifying Viewports
Viewport Properties

Updating Viewports
Changes that affect the appearance of a viewport are automatically updated for a wireframe viewport. However, if 
changes require the viewport to be rendered again, the viewport will be displayed as an out-of-date viewport.

If a sheet layer with an out-of-date viewport is printed, a message prompts you to either print the viewport as an 
out-of-date viewport or update the viewport(s) on the sheet layer before printing.

Rendered viewport updates occur in the background for Renderworks render modes; you can continue working in the 
file while the viewports are updating. See “Background Rendering” on page 1594.

Out of date When the objects in a viewport have changed since the viewport was created or last updated, 
the viewport becomes out of date. An out-of-date viewport is indicated by red text on the 
Update button on the viewport’s Object Info palette. Optionally, an out-of-date viewport also 
displays with a red and white striped border around the viewport (see “Document Display 
Preferences” on page 60).

Empty A viewport displays as a red “X” when the associated design layer contains no objects or the 
objects are hidden, or when the associated design layer is set to “invisible”

Unlinked (section 
line)
(Vectorworks 
Design Series 
required)

An unlinked section line (disconnected from its associated section viewport, possibly because 
the section line was pasted from a copy, duplicated, or mirrored) displays as a black and 
yellow line, and “Not Linked” is displayed in the Object Info palette

Viewport Status Description
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Updating Selected Viewports
To update selected viewports:

1. Select the viewport(s).
2. On the Object Info palette, click Update. Alternatively, select View > Update Selected Viewports.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on the viewport and select Update from the context 
menu.

3. The selected viewports are updated.

Updating All Viewports
To update all the viewports in the file:

1. Select View > Update All Viewports.
2. All viewports on all sheet layers are updated.

Canceling Viewport Updates
To cancel viewport updates:
To cancel the updates of all viewports, including those queued to update for background rendering:

1. Select View > Cancel All Viewport Updates.
2. The updates are canceled.

~~~~~~~~~~~~~~~~~~~~~~~~~
Viewport Status
Modifying Viewports
Viewport Properties



Importing and Exporting Files
The Vectorworks program has the ability to import and export to a variety of file formats. Your work may require you 
to import drawings from colleagues that use previous versions of Vectorworks or other programs. You may also have to 
export your drawings for those colleagues. The import and export functionality provides the means to incorporate 
Vectorworks files with other program’s files, including other CAD programs, worksheet, and word processing 
programs.
~~~~~~~~~~~~~~~~~~~~~~~~~
Drag and Drop Importing
Importing in PartSpec Format
Importing in SketchUp Format
Importing in PICT Format
Exporting as a Database
Exporting a Rendered Drawing
Exporting in CINEMA 4D Format (3D only)
Exporting in COLLADA Format (3D only)
Exporting in FBX Format (3D only)
Exporting in KML Format
Exporting in STL Format
Exporting to an Earlier Version of the Vectorworks Program
Exporting in gbXML Format
Importing and Exporting in EPSF Format
Importing and Exporting Image Files
Importing and Exporting in Metafile Format
Importing and Exporting PDF
Importing and Exporting in Shapefile Format
Importing and Exporting Scripts
Importing and Exporting in 3ds Format
Importing and Exporting in IGES Format
Importing and Exporting in SAT Format
Importing and Exporting in STEP Format
Importing and Exporting in Rhino 3DM Format
Importing and Exporting in Parasolid X_T Format
Importing and Exporting Georeferenced Raster Images
Importing and Exporting Vectorworks Spotlight Data
DXF/DWG and DWF File Import
DXF/DWG and DWF File Export
Batch Publishing
IFC Format Interoperability
Importing Worksheets
Exporting Worksheets

Drag and Drop Importing
In addition to the import commands on the File menu, a drag and drop import shortcut is available for most file 
formats. Click the file to import and drag it into a window where a Vectorworks document is open.
Drag and drop importing is supported for the following file types:

• 3DS (.3ds) • DXF/DWG (.dxf, .dwg) • EPSF (.eps)

• IFC (.ifc, .ifcxml, .ifczip) • IGES (.igs) • Image files (various file extensions)

• Metafile (.emf, Windows only) • Parasolid (.x_t) • PDF (.pdf)
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The imported objects will be centered on the drop point, except for the following file types: DXF/DWG, IFC, 
Shapefile, and SketchUp.

Importing in PartSpec Format
The Import PartSpec command imports Thomas Register PartSpec files saved in either DWG/DXF (2D objects) or 
IGES or ACIS (3D objects) format. It places all parts in a single class on the active design layer and deletes any 
extraneous layers. The Import PartSpec command does not differentiate between a file created in the Thomas 
Register and other programs.
To import PartSpec files:

1. Select the Import PartSpec command from the appropriate menu:
• Architect workspace: AEC > Machine Design > Import PartSpec 
• Landmark workspace: Landmark > Machine Design > Import PartSpec 
• Spotlight workspace: Spotlight > Machine Design > Import PartSpec 

2. A message indicates that the undo cache will be cleared, and that this action cannot be undone; click OK to 
proceed.
The Import Thomas Register PartSpec dialog box opens.

Click to show/hide the parameters.

3. Select the desired import options and click OK.

• PICT (.pct, .pict) • SAT (.sat) • Shapefile (.shp)

• SketchUp (.skp)

Parameter Description

Import 2D Part (DWG/DXF) Select to import a 2D part from a DWG or DXF file
Import as symbol named Select to import the part as a symbol; enter the name of the symbol in the symbol 

name field
Import as group Select to import the part as a group
Attach part information to 
the group or symbol

Select to attach the manufacturer’s part information to the symbol or group. The 
information is attached through the Part Information record format which is created 
if not already existing in the file.

Put objects into class Select the class to apply to all objects being imported
Import 3D Part Select to import a 3D part

ACIS Select to import the part from an ACIS file
IGES Select to import the part from an IGES file
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Importing in SketchUp Format
The Import SketchUp command allows architectural drawings created in SketchUp® (versions 4 and above) to be 
imported into a Vectorworks file. SketchUp component instances are imported as 3D symbols, and geometry can be 
designated as walls, roof faces, and floors. After importing, refine the design using Vectorworks editing tools, or 
replace imported 3D symbols with Vectorworks 3D symbols.
Flexible import options either allow automatic conversion of architectural elements based on their orientation, or allow 
geometry conversion to be mapped to specific SketchUp materials or layers.
Consider the following points when importing a SketchUp file into a Vectorworks file.

• SketchUp layers are imported as classes in Vectorworks. Geometry from invisible layers in SketchUp have their 
class attributes set to invisible in Vectorworks.

• SketchUp groups are imported as Vectorworks group objects. If the SketchUp group has a scale assigned, the 
imported objects inside the group will be transformed with that scale.

• SketchUp components are imported as Vectorworks 3D symbols except for the rare cases when they have 
non-linear scale, in which case they are imported as groups of transformed geometry.

• A component which creates an opening in a vertical face is imported as a symbol in wall, if attached to an object 
imported as a Vectorworks wall.

• When selected, architectural objects in Vectorworks are created from SketchUp faces that are not contained in 
SketchUp groups of components.

• The SketchUp format supports materials on the front and back of each face of an object. When importing as 3D 
polygons, only the front material is assigned to the imported objects, as Vectorworks only supports one material 
for 3D polygons.
• When importing as architectural objects, both materials are imported and assigned to the imported objects, as 

Vectorworks supports several materials in this case.
• When importing as architectural objects, faces which are not part of a group or a component instance in SketchUp 

will import as roofs, slabs, or floors.

Import Description

2D part from either a 
DWG or DXF file

In the Import DXF/DWG Files dialog box, select the file to import, and then click Open. 
The DXF DWG Import Options dialog box opens. (See “DXF/DWG and DWF File 
Import” on page 1716).

The only setting that may need to be edited in the DXF DWG Import Options dialog 
is Units Setting In File under the Primary Settings tab. This setting refers to the units 
in the PartSpec DXF or DWG file, not the units of the current Vectorworks file. Do 
not edit the Import DXF Layers As Classes field under the Graphics Attributes tab 
or the Group Record Fields under the Objects tab. Changing these options will 
prevent objects from importing correctly. Depending on the imported part, the Map 
Colors to Line Weights dialog box and/or the Font Mapping dialog box may open. 
Make any necessary changes and then click OK. The part is imported into the file 
based on the specified settings.

3D part from an ACIS 
or IGES file

If this is an IGES file, the Import IGES File dialog box opens. Select the file to import, and 
then click Open. If this is an ACIS file, the Import SAT File dialog box opens. Select the 
file to import, and then click Open. The part is imported into the current class and design 
layer, and is available for editing and/or converting into a symbol.
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• Walls are unjoined upon import, and may need to be rejoined.
To import a SketchUp file:

1. Select File > Import > Import SketchUp.
Alternatively, click the file to import and drag it into a window where a Vectorworks document is open.

2. The Import SketchUp Model dialog box opens. Select the file to import, and click Open.
3. The SketchUp Import Settings dialog box opens.
4. Select the method for importing geometry through the options on the Import Method tab.

Click to show/hide the parameters.

5. Click the Options tab to specify which material properties to import, whether to import geometry as mesh objects 
or 3D polygons, and set the parameters for architectural objects.

Click to show/hide the parameters.

Parameter Description

Import Method
Simple Select to automatically import all objects in the input file. 

• Meshes/3D Polygons will import all objects as meshes or 3D polygons.
• Architectural Objects will import objects as Vectorworks architectural objects. 

Vertical faces will become walls, horizontal faces will become slabs, and oblique 
faces will become roof faces. Vectorworks recognizes faces in the SketchUp file 
and determines if they should be converted to building elements by analyzing the 
angle of the face relative to the horizontal plane.

Custom Select to specify which materials/layers to import. All materials/layers are selected for 
import by default.

Import By Select Layer to display the list of layers in the SketchUp file or Materials to display the list 
of materials. A check mark to the left of each layer/material indicates that it is to be 
imported. To omit one or more layers/materials, select the item(s) to be omitted and click 
to remove the check mark.

Layer/Material 
Import Method

Select the material/layer from the list and specify whether it should be imported as either a 
mesh/3D polygon or as an architectural object.

Parameter Description

Options
Import Materials Select whether to assign fill colors from the imported objects according to the colors of 

the materials of objects when selected.
If Layer/Material Import Method is selected, any imported architectural objects 
will automatically be assigned the correct properties as defined in the SketchUp file.

Import Transparency 
and Image Data as 
Renderworks 
Textures

Select to import texture and transparency materials as Renderworks texture resources
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6. Click OK.
7. SketchUp geometry and components are imported as specified, and are automatically selected. The Resource 

Browser is populated with the converted 3D symbols.
Items are imported at a 1:1 scale. It may be helpful to click Fit to Objects on the View bar to zoom to fit the 
objects in the drawing. It may also be helpful to adjust the layer scale at this time.

Importing in PICT Format
This section only applies to Mac users.
PICT files were first produced by MacDraw and other object-oriented drawing programs. When you import a PICT file 
with the Import PICT command, multiple bitmap objects may be created, which can be edited individually later on. 
When you import a PICT file with the Import PICT as Bitmap command, the image is imported as a single bitmap 
object. The Trim, Clip, and Shear tools cannot be used on the imported bitmap. Bitmap objects imported with these 
commands automatically have PNG compression applied.
To import a PICT file:

1. Select File > Import > Import PICT or File > Import > Import PICT as Bitmap.

Create Renderworks 
Textures for All 
Materials

Select to create Renderworks textures for all imported materials from the input file.
Solid colors will also be imported as Renderworks textures.

Import the Geometry 
from the File as

Select whether to import geometry as a group of mesh objects or 3D polygons

Vectorworks Mesh 
Object

Select to import all geometry as a group of mesh objects. 
When importing as mesh objects with materials, the SketchUp faces will be triangulated, 
this affects the appearance of the imported file if pen color is used to display the face 
edges.

Vectorworks maintains the original mesh smoothing normal and texture mapping 
data from SketchUp. This information can be edited on the Render tab of the Object 
Info palette, though some of the imported rendering information may be lost during 
editing. 

Groups of 3D 
Polygons

Select to represent all imported geometry as a group of 3D polygons. 
When importing as 3D polygons, the SketchUp faces will not be triangulated except 
when importing complex faces with textures. SketchUp defines a complex face as a face 
containing either inner loops or openings cut by attached component instances or attached 
groups.

Preserve Texture 
Assignment and 
Mapping

If Import Materials is selected, and you are importing geometry as polygons, specify 
whether textures and texture mappings are applied to imported 3D polygons to preserve 
their overall appearance (Renderworks required).

Architectural Objects 
parameters when 
created from automatic 
or layer/material 
assigned import method

Specify the thickness at which to create various building elements:
• Wall Thickness: Set the thickness to assign to wall geometry during import; this value 

must be greater than zero
• Floor Thickness: Set the thickness to assign to floor geometry during import
• Roof Face Thickness: Set the thickness to assign to roof face geometry during import

Parameter Description
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The Import PICT File dialog box opens.
2. Select the file to import, and click Open.

Alternatively, click the file to import and drag it into a window where a Vectorworks document is open.

Exporting as a Database
The Export Database command exports all records of a particular format as a file that can be used in a database 
program, such as FileMaker Pro and Microsoft Access. The Vectorworks program provides a variety of formats to 
select from when exporting records as a database, including comma-delimited, tab-delimited, merge, DIF, and SYLK.
To export a file from a database:

1. Select File > Export > Export Database.
The Export Database dialog box opens.

2. Select the database and the file format to export, and click OK.
3. Specify the export file name and destination, and click Save.

~~~~~~~~~~~~~~~~~~~~~~~~~
Database Connectivity

Exporting a Rendered Drawing
All files rendered with the Renderworks product can be exported. It is possible to export all or part of a drawing 
depending on the selected export format.

The image is re-rendered automatically before export.
The Export Image File command exports a rendered drawing to a variety of image file formats. This command is 
described in detail in “Exporting an Image File” on page 1683.
The following additional export options are available only as part of the Renderworks product.

• “High Dynamic Range Image (HDRI) Export” on page 1672
• “QuickTime VR Object Export” on page 1674
• “QuickTime VR Panorama Export” on page 1675

High Dynamic Range Image (HDRI) Export
When the Renderworks product is installed, the HDRI option is added to the list of export file choices. This command 
creates an HDR file. This is a good choice for export when touching-up the image in an imaging program; the exported 
image is “lossless” and will not have quantization artifacts when color or exposure is further adjusted after export.
To export a file in HDR format:

1. Select the Renderworks rendering mode to use for the export, and render the image.
2. Select File > Export > Export High Dynamic Range Image (HDRI).

The Export Image File dialog box opens. Specify the dimensions and resolution for the exported image.
Click to show/hide the parameters.

Parameter Description

Export Area
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All Visible Objects Exports an image that includes all visible objects (objects do not have to be 
currently on screen to be considered visible)

Current View Exports an image that is exactly as it displays on the current screen
All Pages as Single Image Not applicable for HDRI export
Each Page as Separate Image Not applicable for HDRI export
Marquee Exports the portion of the image specified with a marquee box. Select this option 

and then click Draw Marquee to temporarily close the dialog box. Click, and 
then drag to specify the area for export; the marquee dimensions are displayed 
on the Data bar. Click to set the export area and return to the Export Image File 
dialog box. The Pixel Dimensions of the image are automatically set to the 
marquee dimensions.

Dimensions
Lock Aspect Ratio Select to maintain the image aspect ratio when specifying dimensions
Resolution Specifies the printed image resolution in pixels per inch
Pixel Dimensions

Width/Height Specifies the exported image dimensions; if Lock Aspect Ratio is selected, 
changes to one dimension will update the other to maintain the aspect ratio

Print Size
Width/Height Specifies the printed image dimensions in the selected Unit; if Lock Aspect 

Ratio is selected, changes to one dimension will update the other to maintain the 
aspect ratio

Units Select a unit to apply to the Print Size parameters
Preview Displays a rendered or wireframe preview according to the current settings

Render Updates the preview with a rendered view using the currently set rendering 
option

Wireframe Updates the preview with a wireframe view
Memory Required/Estimated 
File Size

Not applicable for HDRI export

Update Not applicable for HDRI export
Format

File Type Not applicable for HDRI export (always HDR format)
Compression Not applicable for HDRI export

Update visible out of date 
viewports prior to exporting

Automatically updates any visible, out-of-date viewports before exporting

Reset all plug-in objects that 
require a reset prior to exporting

Automatically resets plug-in objects that require an update (such as data stamps) 
before exporting

Parameter Description
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3. Click Save.
The Export OpenHDR File dialog box opens.

4. Specify the export file name and destination, and then click Save.
~~~~~~~~~~~~~~~~~~~~~~~~~
Exporting a Rendered Drawing

QuickTime VR Object Export
When the Renderworks product is installed, the QuickTime® Virtual Reality object option is added to the list of export 
file choices. This command creates a QuickTime VR object file of the selected object, which can then be opened in 
QuickTime. Movie resolution is fixed and does not depend on the size of the window in the Vectorworks file; the 
current selection determines the zoom and center for the movie, set so that the selected object is entirely visible and 
centered.

To obtain more control over the zoom and view center, create an “invisible” 3D object with no fill or pen style. 
Select the object before exporting the movie.
QuickTime must be installed to view or create QuickTime movies; it is a separate program. QuickTime includes a 
viewer for opening several different file types.

To export an object as a QuickTime VR object:
1. Render the drawing with a Renderworks rendering mode, which is also used for the movie.

Due to a limitation, Renderworks backgrounds cannot be exported.
2. Select the object to export.
3. Select File > Export > Export QuickTime VR Object.

The QTVR Object Options dialog box opens.
4. Select the number of frames and spin options for creating the VR object file, and then click OK.

Click to show/hide the parameters.

Export Georeferencing File
(Vectorworks Architect or 
Landmark required)

Available only if the current design layer is georeferenced. Along with the image 
file, exports a worldfile that describes the exported image’s location, scale, and 
rotation in the geographic coordinate system. If multiple georeferenced layers 
are visible, the worldfile will be written according to the topmost layer. See “GIS 
and Georeferencing” on page 775 for more information.

Parameter Description

Frames Specify how many frames to create in the file; more frames take longer, but increase the quality 
of the exported file. Total Frames displays how many frames will be created based on the 
horizontal and vertical frames specified.

Horizontal Specifies the number of horizontal frames to create
Vertical Specifies the number of vertical frames to create

Spin Specify the angular sweep desired, relative to the front view of the object
Left Indicates the left pan angle (0 to 180 degrees)
Right Indicates the right pan angle (0 to 180 degrees)

Parameter Description



Exporting in CINEMA 4D Format (3D only) |  1675
5. Specify the .mov file name and location, and click Save to generate the QuickTime movie. 
~~~~~~~~~~~~~~~~~~~~~~~~~
Exporting a Rendered Drawing

QuickTime VR Panorama Export
When the Renderworks product is installed, the QuickTime Virtual Reality Panorama option is added to the list of 
export file choices. This command creates a QuickTime VR panorama file of the drawing, which can then be opened in 
QuickTime. Movie resolution is fixed and does not depend on the size of the window in the Vectorworks file; the 
current Vectorworks view (XYZ coordinates of the view origin or, in other words, the center of projection) becomes the 
pivot point for the QTVR panorama view, as if the view was rotated to be flat, and then oriented towards the positive Y 
axis.

QuickTime must be installed to view or create QuickTime movies; it is a separate program. QuickTime includes a 
viewer for opening several different file types.

To export a drawing as a QuickTime panorama:
1. Render the drawing in Perspective projection with a Renderworks render mode, which is also used for the movie.

Due to a limitation, Renderworks backgrounds cannot be exported.
2. Select File > Export > Export QuickTime VR Panorama.
3. Specify the .mov file name and location, and click Save to generate the QuickTime movie. 

~~~~~~~~~~~~~~~~~~~~~~~~~
Exporting a Rendered Drawing

Exporting in CINEMA 4D Format (3D only) 
Exports 3D objects in the unified view or active layer to the .c4d format, for use in CINEMA 4D. A “Vectorworks 
Scene” is created within the CINEMA 4D project. Vectorworks layers are exported as container objects in the scene 
hierarchy. Vectorworks classes become CINEMA 4D layers, allowing visibility to be controlled across the scene. Layer 
names, object names, and object types are preserved.

Exporting a File to CINEMA 4D
To export a CINEMA 4D file:

1. Select File > Export > Export CINEMA 4D (3D only).
2. Specify the export file name and destination, and then click Save.

Sending a File Directly to CINEMA 4D
An additional command allows you to send a file to CINEMA 4D directly, when CINEMA 4D is installed.
To send a file to CINEMA 4D:

1. Select File > Send to CINEMA 4D (3D only).

Above Indicates the angle above the horizon (0 to 90 degrees) 
Below Indicates the angle below the horizon (0 to 90 degrees)

Parameter Description
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2. For CINEMA 4D version 12 or later, this exports the file to .c4d format (3D objects only), launches the CINEMA 
4D application, and opens the file. During export, the Update Merge Options dialog box opens. Specify whether to 
create a new project or merge into the current one. By default, the options are set so that the geometry from the 
Vectorworks program is merged, but material and sky objects in CINEMA 4D are unaffected.
Once the file has been sent to CINEMA 4D, select the Save Project with Assets command in CINEMA 4D. This 
keeps the texture assets with the .c4d file, and prevents them from becoming disconnected in CINEMA 4D.
For CINEMA 4D versions prior to R13.053, the Send to CINEMA 4D dialog box opens. Select whether to create 
a new scene or merge into the current scene.

Exporting in COLLADA Format (3D only)
This command exports 3D objects in the unified view or active layer to .dae format. When saved, textures are placed in 
a “tex” folder in the same location as the .dae file. This format may provide better results than the older 3DS file 
format.
To export a COLLADA file:

1. Select File > Export > Export COLLADA (3D only).
2. Specify the export file name and destination, and then click Save.

Exporting in FBX Format (3D only)
This commend exports 3D objects in the unified view or active layer to .fbx format. This format may provide better 
results than the older 3DS file format.
To export a FBX file:

1. Select File > Export > Export FBX (3D only).
2. Specify the export file name and destination, and then click Save.

Exporting in KML Format
The Export KML command exports 3D drawing components to KML, the markup language used by the Google Earth 
application. The resulting file can then be opened in Google Earth, in order to provide a visualization of how a building 
fits into its intended environment, for example. KML models can also be uploaded and shared through the Trimble ® 
3D Warehouse.
To export a KML file:

1. Select File > Export > Export KML (3D only).
2. The KML Export Options dialog box opens.

Click to show/hide the parameters.

Parameter Description

Mapping A 2D reference point on the object is mapped to specific Google Earth coordinates 
during export. If the file is georeferenced, the following mapping fields are filled in 
automatically and disabled.
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3. Select the export parameters, and then click OK.
4. Specify the export file name and destination, and then click Save.

Exporting in STL Format
The Export STL (3D Only) command exports 3D surfaces and solids to an STL (Stereo Lithography) file. Once 
exported, this file can be used for rapid prototyping purposes or imported into other CAD packages.
To export an STL file:

1. If 3D objects from only one layer should be exported, make that layer active. If only selected objects should be 
exported, select the objects.

2. Select File > Export > Export STL (3D only).
3. The Export STL Options dialog box opens.

Click to show/hide the parameters.

Set Reference Point to 
Next Mouse Click/Set 
Reference Point to

To specify the reference point manually, select Set Reference Point to Next Mouse 
Click. Alternatively, to specify X and Y coordinates for the reference point, select Set 
Reference Point to and enter the appropriate values.

Latitude Enter the latitude where the model will be positioned in Google Earth, using DMS 
notation (for example, 39d 12m 34s N)

Longitude Enter the longitude where the model will be positioned in Google Earth, using DMS 
notation (for example, 76d 51m 44s W)

Page North Enter the angle between the drawing’s Y axis and true north in DMS notation; positive 
angles proceed clockwise

Z Height Offset Enter the difference between the Vectorworks active layer plane and the Google Earth 
ground plane

Objects To Export Select the specific object types to be exported; leaving out unnecessary objects can 
reduce the KML file’s size

Layer(s) to export from Select the design layers to export 3D objects from—either the active layer only, or all 
visible layers.
To export all design layers, first set the layer options to show all layers. If multiple 
layers are exported, in Google Earth, the Vectorworks layers are listed in the Places 
panel on the left side of the application window, and their visibilities can be controlled 
individually.
To export some (but not all) layers, create a new design layer from which to export. On 
the new layer, create a design layer viewport (or create layer links) that shows only the 
layers to export. Then export that layer only. With this method, only one layer displays 
in Google Earth.

Parameter Description

Export
Selected Objects on 
Active Layer

Exports only selected 3D objects from the active layer

Parameter Description
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4. Select the export options, and then click OK.
5. Specify the export file name and destination, and then click Save.

Click here for a video tip about this topic (Internet access required).

Exporting to an Earlier Version of the Vectorworks Program
The Vectorworks software can save a copy of the file in a format that can be opened and manipulated in an older 
version of the Vectorworks program. Features and capabilities of the current version may not be available in previous 
versions of the program.

1. Select File > Export > Export as Vectorworks <<version>> File.
2. Specify the export file name and destination, and then click Save.

Exporting in gbXML Format
The gbXML file format transmits building information for energy analysis.
Valid Vectorworks Architect objects that are included in gbXML export are spaces, walls, slabs, windows, doors, 
columns, and roofs. Geo-referenced site location, if any, is included. The model must have a structure with stories, even 
if the model is very simple with only one design layer per story. Columns to be included in the export must be along the 
periphery of a space; columns totally within or outside of a space are not considered. All space objects must be fully 
enclosed by walls, slabs, and/or roof elements, and there should be a full-floor boundary for each story in the building. 
The Place Spaces command makes this simple; it places the required spaces automatically and ensures that they 
properly touch their bounding objects.
The model can include shading surfaces (overhangs, awnings, or other surfaces, including walls roofs, and slabs, that 
do not bound a space and lie outside the bounds of the model).
For best results, before exporting, simplify the model so that only objects that affect energy consumption are visible. 
Eliminate, or make invisible, items that do not contribute to the energy profile of the building, such as unnecessary 
geometric detail, furniture, and fixtures. (Note that spaces in invisible classes are ignored.)

Automatically Creating Spaces
For export, the model must contain space objects, which represent the essential organizational elements for gbXML 
exchange. Spaces must be contained by walls, slabs, and roofs. If the model does not contain space objects for each 
enclosed area and the full floor of each story, the Place Spaces command creates the necessary spaces for export, with 
full boundaries on all sides so that the exporter can properly determine the space volume. 

All Visible Objects on 
Active Layer

Exports all visible 3D objects from the active layer (including objects in design layer 
viewports)

All Visible Objects on 
All Layers

Exports all visible 3D objects from all layers in the Vectorworks file (including objects 
in design layer viewports)

File Type Select ASCII or Binary for the file type
Export Quality (Number 
of Polygons)

Controls the conversion quality of 3D objects that have rounded sides. Move the slider 
bar left to convert rounded objects using fewer large polygons (thus lower quality). 
Move the bar right to create rounded objects of higher quality.

Exporting more polygons slows down the export and increases the size of the 
output file.

Parameter Description

http://www.youtube.com/watch?v=fMMWMnMOPHE&list=UUN7uzhu-ljLJOe6a0J-fBcQ
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To create spaces optimized for gbXML export:
1. Select AEC > gbXML > Place Spaces.

The Place Spaces dialog box opens.
Click to show/hide the parameters.

2. Click OK to place the spaces automatically.

Exporting to gbXML Format
To export a gbXML-compliant model:

1. Select AEC > gbXML >Export gbXML.
The Export gbXML dialog box opens.

2. Enter the average ground level for the project, and then click OK.
3. The gbXML Save File dialog box opens. Type a file name, select a location to save the file, and then click Save.

If the file did not meet the requirements for successful gbXML export, you are notified by alert dialog boxes.

Importing and Exporting in EPSF Format

Importing an EPSF File
EPSF (encapsulated PostScript format) files are produced by many graphics and desktop-publishing programs. EPSFs 
are typically high-resolution files. On Windows, EPSF files will only display a preview image if a TIFF preview image 
was selected when the file was created.
To import an EPSF file:

1. Select File > Import > Import EPSF.
The Import EPSF File dialog box opens.

2. Select the file to import, and click Open.
Alternatively, click the file to import and drag it into a window where a Vectorworks document is open.

Exporting an EPSF File 
The Export EPSF command exports a drawing to an .EPS file format. EPSF (encapsulated PostScript format) files can 
be read by many graphics and desktop-publishing programs. The Vectorworks translator exports EPSF files in 

Parameter Description

Place Room Spaces in Class Creates spaces automatically for the enclosed room areas of the model; select a class 
for the spaces, or select New to create a new class

Place Full-floor Spaces in 
Class

Creates a full-floor space automatically within the boundary of the exterior walls on 
each story of the model; select a class for the spaces, or select New to create a new 
class

Place Spaces for Current 
Story Only

Places spaces only for the story of the current layer; only this story will be 
considered for gbXML export

Ignore Small Enclosed Areas When selected, spaces are not created for small enclosed areas, such as small gaps 
between walls. This results in more exact export results, but the additional analysis 
can take some time.
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Illustrator 88 format. EPSFs contain all drawing elements, and a TIFF preview using standard byte ordering. The 
Vectorworks program exports these files with high resolution and full accuracy.
To export an EPSF file:

1. Select File > Export > Export EPSF.
2. The EPS Preview Options dialog box opens. Specify the type of TIFF preview to export along with the PostScript 

data, and then click OK.
3. The Export as EPSF File dialog box opens. Specify the export file name and destination, and then click Save.
4. If any of the objects in the drawing are outside of the print area, a dialog box opens to ask if the print area should 

be used as the bounds of the EPSF export. If the print area is used as the bounds of the EPSF export, any objects 
outside of the print area are not included in the export.

Importing and Exporting Image Files

Importing an Image File
Image files, including GIF, JPG, TIF, BMP, and others, can be imported into a drawing directly; for example, you might 
import a sketch or a logo graphic into a drawing. The Vectorworks Design Series products have an option to create a 
reference to the original image file, if the original image may change, and you want to keep the imported image up to 
date.
The following table lists the standard image import formats that are supported.

Images are compressed when they are imported into a Vectorworks file, to reduce the file size.
You can also import an image as a resource, to be used as a fill or image-based shader, for example. See “Creating 
Image Resources” on page 1120 for details.

Export 
Formats

Mac Windows

BMP X X
GIF X X
JPEG X X
JPEG2000 X
PNG X X
Photoshop 
(.psd)

X

SGI X
TGA X
TIFF X X
ICNS X
ICO X X
MacPaint X
XBitmap X
WMPhoto X
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To import an image file:
1. Select File > Import > Import Image File, and then select the image file to import.

Alternatively, click the file to import and drag it into a window where a Vectorworks document is open.
2. The Image Import Options dialog box opens. Specify the options for the imported image.

Information about the image file is displayed at the top. The compression method that produces the smallest file 
size is selected by default. Select the method that will give the best balance between compression and detail 
display. The file size for each type of compression is displayed to help with the selection.
If the selected option results in a file size larger than the uncompressed size, the image is imported uncompressed.

3. If Vectorworks Design Series products are installed, referencing options display. See “Workgroups and 
Referencing” on page 207 for more information. Specify the reference options for the imported image as 
described in the following table.

Click to show/hide the parameters.

4. Click OK to import the image. The Object Info palette displays the image information.
If Vectorworks Landmark is installed, and the image was georeferenced, a message displays that the image has 
been translated according to the associated world file. See “Importing and Exporting Georeferenced Raster 
Images” on page 1702 for more information.

5. Imported images are planar objects and may be assigned to 3D planes. They can be scaled, rotated, and cropped. 
See “Cropping Imported Images” on page 1682 for more information about cropping.
The Trim, Clip, and Shear tools cannot be used on an imported image.
Images imported into the file that are not already in JPEG format can be compressed by JPEG with the Compress 
Images command. See “Compressing Images” on page 1822.

Compression Method Description

JPEG Provides a high amount of compression, resulting in the smallest Vectorworks file size. 
However, fine detail may be obscured. JPEG compression is most suitable for 
photographic images.

PNG Provides a moderate amount of compression, while preserving image details; select 
Import as Black and White to import as a 1-bit monochrome image in PNG format

Parameter Description

Reference References the original image file (master file), so that the imported image can be updated 
when the master file changes.

Absolute path Stores the absolute file path of the master file. Select this option when the location of the 
master file will not change in the future, or if the master file is on another volume.

Path relative to 
current document

Stores the file path of the master file relative to the target Vectorworks file; this option is 
available only if the master file is on the same volume as the target file. Select this option if 
the target file and the master file may be moved to another volume in the future.

Save referenced 
cache to disk

Saves a copy of the referenced image in the target Vectorworks file; if deselected, the target 
file is smaller, and the image is automatically updated when the target file is opened

Automatically 
update reference 
during file open

Updates the image from the master file each time this file is opened, if the image is out of 
date
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If you use the Delete Outside Crop button on the Object Info palette to modify the imported image, the reference 
will be broken.

A referenced image file can be opened with the default application associated with this file type. To open a referenced 
image file, use one of the following methods:

• Ctrl-click (Mac) or right-click (Windows) the referenced image in the drawing area, and then select Open
• Ctrl-click (Mac) or right-click (Windows) the referenced image file in the Navigation palette, and then select 

Open
Select the referenced image file in the Navigation palette, and then select Open from the Navigation menu
~~~~~~~~~~~~~~~~~~~~~~~~~
Cropping Imported Images
Importing Manual Sketches

Cropping Imported Images
1. Select an imported image, and select Modify > Edit Crop.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on an image and select Edit Crop from the context menu.
A colored border around the drawing window indicates that you are in an editing mode. The Exit Bitmap Crop 
command becomes available from the Modify menu, and the Exit Bitmap Crop button is visible in the top right 
corner of the drawing window.

2. Create a 2D object such as a rectangle, circle, or polyline. The 2D object must define an area; for example, a 2D 
line cannot be used. Position the 2D object to delimit the new image display area. The pen style can be set from 
the Attributes palette while in Edit Crop mode. Move and resize the 2D object as needed.

3. Click Exit Bitmap Crop to return to the design layer.
4. The cropped image displays; in the Object Info palette, the Crop status changes to Yes.

To change the visibility of the crop object, change the Crop Visible setting in the Object Info palette. The crop 
object can be a visible frame for the bitmap in the drawing, or it can be invisible.
To permanently delete the part of the image that lies outside the crop object, click Delete Outside Crop on the 
Object Info palette. When prompted, click Yes to confirm the deletion. The Object Info palette displays the new 
image file size.
If the image file is referenced, another alert message displays that the action will break the reference; click OK to 
confirm the deletion.
To change, replace, or delete the crop object, select the image and then select Modify > Edit Crop to re-enter Edit 
Crop mode. Alternatively, right-click (Windows) or Ctrl-click (Mac) and select Edit Crop from the context menu.

~~~~~~~~~~~~~~~~~~~~~~~~~
Importing and Exporting Image Files

Importing Manual Sketches
Scanning and importing sketches, and then tracing them, is a useful technique that can serve as a bridge between 
manual drawing and CAD. To be useful, sketches for tracing should be drawn to scale and scanned at a relatively high 
resolution (300 dpi or above).
To import sketches to be traced:

1. After scanning the sketch, save the file in one of the image import formats supported in the Vectorworks program.
2. Determine the scale of the original sketch.
3. In the Vectorworks program, open the file into which the sketch will be imported.
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4. Select or create a design layer for importing the sketch. Set the layer to the scale of the sketch. Make this layer the 
active layer.
See “Creating Layers” on page 162 and “Setting Design Layer Properties” on page 165.

5. Select File > Import > Import Image File to import the sketch.
6. Set the layer back to the desired drawing scale.
7. Move the image to locate it properly. The image can be rotated; however, the best results are obtained when the 

image is scanned as straight as possible. Consider locking the image once it is in the desired orientation.
Any manual reshaping or scaling of the image distorts its scale.

The following image shows a scanned sketch used as the basis for a guidelines layout. Draw guidelines in the Guides 
class. Prior to printing, turn this class off with the Modify > Guides > Hide Guides command. See “Guides” on 
page 71.

 

~~~~~~~~~~~~~~~~~~~~~~~~~
Cropping Imported Images

Exporting an Image File
The Export Image File command exports a rendered drawing to a variety of file formats, including GIF, JPG, TIF, 
BMP, WMPhoto, and others. Different portions of the image can be selected for export.

The list of image formats is populated depending upon the operating system and installed drivers.
The following table lists the standard image export formats that are supported.

Export 
Formats

Mac Windows

BMP X X
GIF X X
JPEG X X
JPEG2000 X
PNG X X
Photoshop 
(.psd)

X

TGA X
TIFF X X
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To export an image file:
1. Select File > Export > Export Image File.

The Export Image File dialog box opens.
2. Select the export options, and then click Render or Wireframe to display the exported image preview.

Click to show/hide the parameters.

OpenEXR X
WMPhoto X

Parameter Description

Export Area
All Visible Objects Exports an image that includes all visible objects (objects do not have to be currently 

on screen to be considered visible)
Current View Exports an image that is exactly as it displays on the current screen
All Pages as Single Image Saves all pages in the print area as one image. By default, the image dimensions are 

set to match the print area specifications in the Page Setup dialog box. The image 
dimensions can be changed, but must remain proportional to the print area aspect 
ratio.

Each Page as Separate Image Saves each page in the print area as separate images. By default, the image 
dimensions are set to match the page size specifications in the Page Setup dialog 
box. The image dimensions can be changed, but must remain proportional to the 
page size aspect ratio.

Marquee Exports an image within a user-created marquee. Select this option and then click 
Draw Marquee to temporarily close the dialog box. Click and drag to specify the 
area for export; the marquee dimensions are displayed on the Data bar. Click to set 
the export area and return to the Export Image File dialog box. The Pixel 
Dimensions of the image are automatically set to the marquee dimensions.

Dimensions
Lock Aspect Ratio Select to maintain the image aspect ratio when specifying dimensions
Resolution Specifies the printed image resolution in pixels over inches
Pixel Dimensions

Width/Height Specifies the exported image dimensions; if Lock Aspect Ratio is selected, changes 
to one dimension will update the other to maintain the aspect ratio

Print Size
Width/Height Specifies the printed image dimensions in the selected Unit; if Lock Aspect Ratio is 

selected, changes to one dimension will update the other to maintain the aspect ratio
Units Select a unit to apply to the Print Size parameters

Preview Displays a rendered or wireframe preview according to the current settings
Render Updates the preview with a rendered view using the currently set rendering option
Wireframe Updates the preview with a wireframe view

Export 
Formats

Mac Windows
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3. Click Save.
In the dialog box which opens, provide a name for the file; the program adds the file extension according to the 
file format selected. If the Each Page as a Separate Image was selected for export, the program automatically 
appends an incremental number to each file name.

4. Click Save.
A new file is created without changing the original drawing file. This new file can then be opened in other 
applications or imported into another software program.

Importing and Exporting in Metafile Format
There are two versions of Metafiles (Windows only): standard (pre-Windows 95) and enhanced. The Vectorworks 
program supports the enhanced version.

Importing Metafile Format
Graphics files in the Metafile format can be imported from virtually any program, including AutoCAD and word 
processing programs.
When you import a Metafile file with the Import Metafile command, multiple bitmap objects may be created, which 
can be edited individually later on. When you import a Metafile file with the Import Metafile as Bitmap command, 
the image is imported as a single bitmap object. The Trim, Clip, and Shear tools cannot be used on the imported 
bitmap. Bitmap objects imported with these commands automatically have PNG compression applied.
To import a Metafile:

1. Select File > Import > Import Metafile or File > Import > Import Metafile as Bitmap.
The Import EMF File dialog box opens.

2. Select the file to import, and click Open.

Memory Required/
Estimated File Size

Estimates the amount of memory required for the export and the approximate file 
size of the exported file, based on the current settings

Update Updates the estimated memory and file size requirements
Format

File Type Select the file format for the exported image
Color Specify whether to export the image in Full color, Grayscale, or Black and white
Quality For file formats that observe a quality setting, drag the Opacity slider to the left to 

decrease the image quality or to the right to increase quality
Update visible out of date 
viewports prior to exporting

Automatically updates any visible, out-of-date viewports before exporting

Reset all plug-in objects that 
require a reset prior to 
exporting

Automatically resets plug-in objects that require an update (such as data stamps) 
before exporting

Export Georeferencing File
(Vectorworks Architect or 
Landmark required)

Available only if the current design layer is georeferenced. Along with the image 
file, exports a worldfile that describes the exported image’s location, scale, and 
rotation in the geographic coordinate system. If multiple georeferenced layers are 
visible, the worldfile will be written according to the topmost layer. See “GIS and 
Georeferencing” on page 775 for more information.

Parameter Description
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Alternatively, click the file to import and drag it into a window where a Vectorworks document is open.

Exporting Metafile Format
Graphics files can be exported in Metafile format for inclusion in virtually any Windows program, including AutoCAD 
and word processing programs.
To export a Metafile:

1. Select File > Export > Export Metafile.
The Export Metafile dialog box opens.

2. Set the desired Resolution and click OK.
In addition to rendered design layers and Vectorworks geometry, the Resolution setting affects PDF objects, 
which are rasterized when exported to Metafile format.

3. Specify the export file name and destination, and then click Save.

Importing and Exporting PDF
The Vectorworks Design Series products can import and export Portable Document Format (PDF) files. An imported 
PDF is useful for displaying company logos, contractor drawings, and other graphics.
In Vectorworks Design Series, the Export PDF and Publish commands create high-quality PDF files for printing, and 
takes advantage of PDF layers for creating an interactive representation of a model.
~~~~~~~~~~~~~~~~~~~~~~~~~
Importing PDF Files
Exporting PDF Files

Importing PDF Files
The Import PDF command allows a PDF file to be imported into a Vectorworks file, where each PDF page becomes 
an independent PDF Page object. Create a reference to the original PDF file, if the original file may change, and you 
want to keep the imported pages up to date.
To import a PDF file:

1. Select File > Import > Import PDF.
Alternatively, click the file to import and drag it into a window where a Vectorworks document is open.

2. Select the PDF file to be imported, and click Open.
The Import PDF dialog box opens.

Click to show/hide the parameters.

Parameter Description

Import Range Specifies which portion of the PDF file to import
Pages Imports the specified range of pages from the PDF file
All Pages Imports all pages in the PDF file

Reference References the original PDF file (master file), so that the imported PDF pages can be 
updated when the master file changes. See “Workgroups and Referencing” on page 207 for 
more information.
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3. Click Import. Each PDF file page becomes a separate PDF page or referenced PDF page in the Vectorworks file.
The PDF page can be resized, moved, or rotated with the Modify > Rotate > Rotate command or the Rotate tool, 
scaled with the Modify > Scale Objects command, printed, and exported. You can snap to geometry in the PDF 
page by selecting Snap to Geometry in the Object Info palette.
A referenced PDF file can be opened with the default application associated with this file type. To open a 
referenced PDF file, use one of the following methods:
• Ctrl-click (Mac) or right-click (Windows) the referenced PDF page in the drawing area, and then select Open.
• Ctrl-click (Mac) or right-click (Windows) the referenced PDF file in the Navigation palette, and then select 

Open.
• Select the referenced PDF file in the Navigation palette, and then select Open from the Navigation menu.

~~~~~~~~~~~~~~~~~~~~~~~~~
Importing and Exporting PDF
Snapping to and Scaling Imported PDF Files
Cropping Imported PDF Files

Snapping to and Scaling Imported PDF Files
Content files from a variety of manufacturers can be imported into a Vectorworks file in PDF format and then, because 
the Vectorworks program can snap to the vector graphics within the PDF Page object, the PDF object can be moved 
and snapped into a desired position. Lines drawn in the Vectorworks file snap to the 2D items in the PDF object, so the 
PDF can be incorporated into your own designs.
The Scale Objects command scales an imported PDF object so it matches the current drawing scale. Cropped PDF 
objects can also be scaled.

Snapping to a PDF file is only possible when the PDF originated from an application that creates vector graphics. 
Snapping cannot occur if the PDF file is encrypted. To enable snapping, select Snap to Geometry in the Object 
Info palette after importing.

To use an imported PDF file effectively:
1. Import the PDF file as described in “Importing PDF Files” on page 1686.

A PDF Page object is created. In this example, the PDF object imported at an incorrect scale for the current 
drawing.

Absolute path Stores the absolute file path of the master file. Select this option when the location of the 
master file will not change in the future, or if the master file is on another volume.

Path relative to 
current document

Stores the file path of the master file relative to the target Vectorworks file; this option is 
available only if the master file is on the same volume as the Vectorworks file. Select this 
option if the target file and the master file may be moved to another volume in the future.

Save referenced 
cache to disk

Saves copies of the referenced PDF pages in the target Vectorworks file; if deselected, the 
target file is smaller, and the PDF pages are automatically updated when the target file is 
opened

Automatically 
update reference 
during file open

Updates the PDF pages from the master file each time this target file is opened, if the PDF 
pages are out of date

Parameter Description
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2. To change the scale of the imported PDF, select Modify > Scale Objects.
The Scale Objects dialog box opens. The Scale Objects command is described in “Scaling Objects” on 
page 1063. Select Symmetric by Distance, and click the button to specify the current distance on the drawing. 
Click to indicate a segment of known distance in the PDF, and click again to finish the segment (note that 
snapping is possible within the PDF).

3. In the Scale Objects dialog box, enter the New Distance for the segment.

4. Click OK.
The PDF object scale matches the drawing.

EndpointClick 1



Importing and Exporting PDF |  1689
The imported PDF could be made into a viewport and cropped for use in the drawing. In this example, walls could 
be drawn in the Vectorworks file using the PDF object as a basis for the walls.
Alternatively, you can ungroup the PDF to create Vectorworks objects from the snapping objects, giving you a 
close approximation of the original PDF that can be manipulated in Vectorworks.

~~~~~~~~~~~~~~~~~~~~~~~~~
Importing PDF Files

Cropping Imported PDF Files
Imported and referenced PDF pages can be cropped so only part of the PDF page is visible.
To crop an imported of referenced PDF:

1. Import the PDF as described in “Importing PDF Files” on page 1686.
2. Select the PDF page object.
3. Select Modify > Edit Crop.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on a PDF and select Edit Crop from the context menu, or 
simply double-click on the PDF page object.

4. A colored border around the PDF indicates you are in an editing mode. The Exit PDF Crop command becomes 
available from the Modify menu, and the Exit PDF Page Crop button is visible in the top right corner of the 
drawing window. If the PDF object is on a 3D plane, the view will rotate so that the view is parallel to the screen 
plane

5. Create a 2D object such as a rectangle, circle, or polyline. The 2D object must define an area; for example, a 2D 
line cannot be used. Position the 2D object to delimit the new PDF display area. The fill of a PDF cropping object 
is always None; however, the pen style can be set from the Attributes palette while in Edit Crop mode. Move and 
resize the 2D object as needed.

6. Click Exit PDF Page Crop to return to the drawing.
7. The cropped PDF displays; in the Object Info Palette, the Crop status changes to Yes.
8. To change, replace, or delete the crop object, select the PDF page object and then select Modify > Edit Crop to 

re-enter Edit Crop mode. 
To change the visibility of the crop object, change the Crop Visible setting in the Object Info palette.
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~~~~~~~~~~~~~~~~~~~~~~~~~
Importing PDF Files

Exporting PDF Files
Vectorworks drawing files can be exported to PDF for use as an interactive representation of a model, or for final 
quality printing purposes. Export settings are designed for maximum usability and the smallest possible file size. Pages 
in the Vectorworks file become PDF pages when exported. Fonts are always embedded in the PDF, for portability. 
Layer transfer modes other than Paint become transparent in the PDF. The Vectorworks program can export the 
currently visible design layer(s) or sheet layer, or create a batch export list of saved views and sheet layers.
You can choose between the standard PDF format and PDF/A-1b. The PDF/A-1b format is useful for archiving, and 
helps preserve the visual appearance of the document by embedding color and font information into the exported file. 
PDF/1-1b format flattens all layers, and elements of the drawing with transparency settings appear opaque.
The layers and classes in the Vectorworks file can be exported as PDF layers, to create an interactive model 
representation (PDF layers require PDF rev. 1.5 minimum).
You can export a single PDF file, or select the Publish command to export several files as a batch.

Batch PDF File Export
Use the Publish command to export a series of sheet layers and/or saved views from the current drawing and 
externally-referenced files to PDF. See “Batch Publishing” on page 1765.

Single PDF File Export
The Export PDF command creates a PDF file from the current sheet layer or visible design layer(s).
To export the current sheet layer or design layer(s) to PDF:

1. Set the view for the export. The current sheet layer or currently viewed design layer(s) are exported.
Set the visibility of layers and classes as desired. All visible and grayed layers are exported; invisible layers and 
classes are not exported. For viewports on sheet layers, set the layer and class visibility of each viewport.

2. Select File > Export > Export PDF.
The Export PDF dialog box opens.

3. Specify the settings for exporting to PDF.
Click to show/hide the parameters.
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Parameter Description

PDF Conversion
Export Design Layers as PDF 
Layers (PDF format only)

When exporting design layers, creates a PDF layer from each visible design 
layer

Export Classes as PDF Layers 
(PDF format only)

When exporting design layers, creates a PDF layer from each visible class

Make grayed PDF Layers initially 
invisible (PDF format only)

When creating PDF layers, grayed layers or classes appear invisible when first 
opening the resulting PDF

but appear with normal 
attributes when made visible

When creating PDF layers, grayed layers or classes do not display grayed, but 
with their assigned attributes once made visible in the PDF

Format Select the PDF export format
Resolution Sets the export resolution of pictures, rendered images, and patterns (unless 

Export patterns at on-screen resolution is selected). A larger value results in 
higher quality images, but also a larger PDF file. Range: 72—2500 dpi.

Export patterns at on-screen 
resolution

Exports the pattern size as viewed on-screen; when deselected, patterns are 
exported according to the specified Resolution

Downsample higher resolution 
raster images to

Reduces the resolution of raster images to the specified value, resulting in a 
smaller PDF file size

Rasterize text Exports text in bitmapped format to ensure that it matches the on-screen 
appearance; use this option when the font is not displaying correctly in a bold 
or italic style. This option may result in a larger PDF file and can cause the font 
to appear pixellated at high PDF zoom levels.

Use Opacity of Sets the transparency of layers in the PDF file (replaces Layer Transfer modes 
in the Vectorworks program). Not necessary on Mac systems or on Windows 
systems when the GDI+ imaging Vectorworks preference is enabled.

Gray level for grayed Layers and 
Classes

Adjusts the level of gray when exporting with grayed layers and/or classes

Open PDF in the default viewer After export, opens the PDF automatically in the system’s specified PDF 
viewer

Export Range
Export the whole printable area as 
one page

When the printable area consists of more than one page, exports the entire area 
as a single PDF page

All Pages Exports all pages, creating a PDF page for each Vectorworks page
Pages Exports the specified pages only
Current View Exports the current view to a PDF page
Update visible out of date 
viewports prior to exporting

Automatically updates any visible, out-of-date viewports before exporting

Reset all plug-in objects that 
require a reset prior to exporting

Automatically resets plug-in objects that require an update (such as data 
stamps) before exporting

Recalculate worksheets prior to 
exporting

Automatically recalculates worksheets before exporting
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4. Click OK to create the PDF file based on the settings. If Open PDF in the default viewer was selected, the PDF 
viewer opens automatically.
If layers or classes were exported as PDF layers and the viewer supports PDF layers, the layers are listed and their 
visibility can be controlled through the viewer.

Importing and Exporting in Shapefile Format

Importing in Shapefile Format
The Vectorworks Architect and Landmark products can import files in shapefile (.shp) format. Each geometric feature 
stored in the shapefile is converted to a Vectorworks object. In turn, each of these objects has a corresponding data 
record, which is converted from the shapefile’s database file.
To import a shapefile and select conversion options:

1. Select File > Import > Import Shapefile, and then select the shapefile to import.
Alternatively, click the file to import and drag it into a window where a Vectorworks document is open.

2. The Vectorworks program determines the appropriate units for the imported objects from the projection (.prj) file, 
if one is available. If no projection file is found, the current document’s units are used.

3. The Import Shapefile dialog box opens. Specify the file import options.
Click to show/hide the parameters.

Parameter Description

Import to layer Select the design layer to import themes from the shapefile into; by default, objects will be 
imported to a new layer named after the shapefile
If a projection file (.prj) is included with the shapefile, the layer is automatically set to be 
georeferenced based on the projection file (but it can be changed if necessary)

Edit Layer Opens the Edit Design Layers dialog box, to edit the selected design layer’s 
georeferencing settings as needed

Georeference message If the selected layer is georeferenced, a message displays the current projection setting; 
otherwise, a message indicates that the layer is not georeferenced

Assign to class Select an existing class to assign to the themes imported from the shapefile, or select New 
to create a new class
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4. Click OK to import the file with the selected options. The Object Info palette displays the imported shapefile 
information.

~~~~~~~~~~~~~~~~~~~~~~~~~
Exporting in Shapefile Format
GIS and Georeferencing

Exporting in Shapefile Format
The Export Shapefile command exports drawing components to the shapefile format. Each shapefile (.shp) exported is 
accompanied by an index file (.shx) and a database file (.dbf) with the same name.
Shapefile export options allow the export of drawing components using multiple criteria. For an object to be exported, 
it must satisfy all selected criteria. For example, if you select both Objects with classes and Objects in layers export 
options, only objects that belong to both one of the selected classes and one of the selected layers will be exported.
The following objects cannot be exported: text, dimensions, worksheets, bitmaps, lights, layer links, walls, round walls, 
and some 3D objects (including extrudes, sweeps, meshes, roofs, floors, columns, and NURBS curves). Other objects 
are exported as follows:

• Lines, rectangles, circles, ovals, arcs, polygons, rounded rectangles, polylines, and path plug-in objects are 
exported as shapefile polygons or polylines.

• Symbols, 2D and 3D loci, and point plug-in objects are exported as shapefile points or 3D points.
• 3D polygons are exported as shapefile 3D polyline or 3D polygon shape types.
• Shapefiles can contain only one shape type. If multiple shape types are being exported, they will go into separate 

files.
• Groups that contain exportable object types are exported as individual polygons, polylines, and loci, as 

appropriate.
• If the Vectorworks file contains projection data, the file can either be deprojected, or exported with projection and 

(optionally) a projection (.prj) file.
• Object data that are not part of the record can be included in the export.

To export a shapefile:
1. Select File > Export > Export Shapefile.
2. The Export Shapefile dialog box opens.

Click to show/hide the parameters.

Parameter Description

Objects with record Select which objects that share a specific data record will be exported
Objects with classes Select this option to export objects in specified classes
Objects in layers Select this option to export objects in specified design layers
Selected objects Select this option to export objects that are currently selected
Deproject / Keep projection Select Deproject to create a shapefile with latitude and longitude coordinates only; 

select Keep Projection to create a shapefile with the currently projected coordinates 
(in document units)

Write projection files If Keep projection is selected, select this option to create a projection file (.prj), in 
addition to the .shp file
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3. Select the export parameters.
If Objects with classes or Objects in layers is selected, click Select Classes/Select Layers to open the relevant 
dialog box. Place a check mark in the column beside all classes and layers from which to export objects, and click 
OK.
If Additional Object Data is selected, the Additional Object Data dialog box opens automatically. Place a check 
mark in the column beside additional data to be exported. If desired, rename data in the Export Name field; 
names can be no more than ten characters long. Click OK. The customizations in the list are remembered across 
Vectorworks sessions.
Click OK.

4. Specify the file name and destination, and then click Save. The default shapefile file name is the record format 
name.
The Vectorworks program creates a set of export files, leaving the original file intact.

~~~~~~~~~~~~~~~~~~~~~~~~~
Importing in Shapefile Format
GIS and Georeferencing

Importing and Exporting Scripts

Exporting a Simple VectorScript (3D only)
You can export 3D drawing objects as a Pascal-like script designed to be easy to import into programs like Strata 
Software products.
To export a simple VectorScript file:

1. Select File > Export > Export Simple VectorScript (3D only).
2. Select whether to export in front view or in the current view, and click OK.
3. Specify the export file name and destination, and then click Save.

Importing Scripts
The Import Script command executes a saved script (Python or VectorScript), automatically creating a new design 
layer for the scripted objects. See “Using Scripts” on page 1771.
To import a script:

1. Select File > Import > Import Script.
2. Select a file from the Open dialog box.
3. Click Open.

Exporting Scripts
The Export Script command writes out the contents of the current file as a script. The script can then be imported into 
another file, used as part of another script, or studied as a guide for learning. See “Using Scripts” on page 1771.

Additional Object Data Select this option to export additional object data that belong to the object(s) being 
exported, but are not part of the record

Parameter Description
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To export a script:
1. Select File > Export > Export Script.
2. Specify the export file name and destination, and then click Save.

~~~~~~~~~~~~~~~~~~~~~~~~~
Using Scripts

Importing and Exporting in 3ds Format
The Vectorworks Design Series products can both import from and export to the .3ds file format used by Autodesk® 
3ds Max® software, version 3.0 and higher.

Importing in 3ds Format (3D only)
When importing a 3ds file, specify how the drawing components will be represented in the Vectorworks file.
To import a 3ds file:

1. Select File > Import > Import 3DS (3D only), and then select the 3ds file to import.
Alternatively, click the file to import and drag it into a window where a Vectorworks document is open.

2. The Import 3DS Options dialog box opens; the options available depend on the contents of the file being 
imported. Specify the file import options.

Click to show/hide the parameters.

Parameter Description

Import Materials Select whether to assign fill colors from the imported objects according to the colors 
of the materials of objects when selected.

Import Transparency and 
Image Data as 
Renderworks Textures

Select to import texture and transparency materials as Renderworks texture 
resources

Create Renderworks 
Textures for All Materials

Select to create Renderworks textures for all imported materials from the input file

Import Mesh Objects Imports each mesh object defined in the 3ds file as either a group of mesh objects or 
3D polygons

Import as Vectorworks 
Mesh Object

Select to import all geometry as a group of mesh objects
The 3DS file format does not contain smoothing information. The 3DS import 
will set document smoothing to the created mesh objects.

Import as Groups of 3D 
Polygons

Select to represent all imported geometry as a group of 3D polygons

Preserve Texture 
Assignment and Mapping

If Import Materials is selected, and you are importing geometry as polygons, 
specify whether textures and texture mappings are applied to imported 3D polygons 
to preserve their overall appearance (Renderworks required).

Scale Opens the Import 3DS Scale dialog box, for specifying a scale to apply to all 
imported objects; see “Scaling 3ds Objects” on page 1697

Import Light Objects Imports light objects from the 3ds file
Import Spot Light Select this option to import spot lights from the 3ds file as Vectorworks spot lights
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3. Click OK to import the file. The Object Info palette displays the image information.
~~~~~~~~~~~~~~~~~~~~~~~~~
Exporting in 3ds Format (3D only)
Scaling 3ds Objects

Exporting in 3ds Format (3D only)
Different portions of the drawing can be selected for export to a 3ds file.
To export a 3ds file:

1. If 3D objects from only one layer should be exported, make that layer active. If only selected objects should be 
exported, select the objects.

2. Select File > Export > Export 3DS (3D only).
3. The Export 3DS Options dialog box opens; the options available on the lower part of the dialog box depend on 

which group of items were selected for export.
Click to show/hide the parameters.

Import Omni Light Select this option to import omni lights from the 3ds file as Vectorworks point lights
Import Camera Objects Imports camera objects from the 3ds file

Import Active Camera 
Only

Imports only the active camera from the 3ds file, and sets the current view to the 
camera view

Create Saved Views for 
Each Camera

Imports all camera objects from the 3ds file, and creates a saved view in the 
Vectorworks file for each

Parameter Description

Export
Selected Objects on 
Active Layer

Exports only selected 3D objects from the active layer; if no objects are selected, all 
3D objects from the active layer are exported

All Visible Objects on 
Active Layer

Exports all visible 3D objects from the active layer (including objects in design layer 
viewports). Exclude or include specific types of objects using the dialog check boxes; 
for example, export walls but not lights.

All Visible Objects on 
All Layers

Exports all visible 3D objects from all layers in the Vectorworks file (including objects 
in design layer viewports). Exclude or include specific types of objects using the 
dialog check boxes; for example, export walls but not lights.

Export Quality (Number 
of Polygons)

Controls the conversion quality of 3D objects that have rounded sides. Move the slider 
bar left to convert rounded objects using fewer large polygons (thus lower quality). 
Move the bar right to create rounded objects of higher quality.

Exporting more polygons slows down the export and increases the size of the 
output file.

Export Objects Exports all kinds of Vectorworks 3D objects except walls, 3D loci, symbols, lights, 
and plug-in objects

Export 3D Locuses Exports each 3D locus as a one-vertex 3ds mesh
Export Walls Exports walls

Parameter Description
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4. Select the types of objects to export, and then click OK.
5. Specify the export file name and destination, and then click Save.

~~~~~~~~~~~~~~~~~~~~~~~~~
Importing in 3ds Format (3D only)
Scaling 3ds Objects

Scaling 3ds Objects
The scale of 3ds objects can be changed during both import and export. The scaling is applied to all imported/exported 
objects.
To scale 3ds objects during import or export:

1. From the import or export dialog box, click Scale.
2. The Import/Export 3DS Scale dialog box opens. Choose whether to scale the object(s) by custom dimensions or 

by scale factor.
Click to show/hide the parameters.

Export 3D Symbols Exports each 3D symbol as a group of 3D meshes
Export Plug-in Objects Exports each plug-in object as a group of 3D meshes
Export Lights Exports Vectorworks light objects as 3ds light objects. Vectorworks point lights are 

exported as 3ds omni lights, and Vectorworks directional and spot lights are exported 
as 3ds spot lights.

Export Current View as 
Camera

If the current view was set with one of the perspective options (Narrow Perspective, 
Normal Perspective, Wide Perspective, or a custom perspective), this option exports 
the view as a 3ds camera object

Scale Opens the Export 3DS Scale dialog box, for specifying a scale to apply to all exported 
objects; see “Scaling 3ds Objects” on page 1697

Export Materials Exports colors that are attached to the exported objects as 3ds materials; this includes 
colors both from the Attributes palette and from Renderworks textures

Export Textures as If Export Materials is selected, this option exports each Renderworks texture to a 
texture image file (Renderworks required). Select the export file format from the list. 
Exported image files are automatically named with sequential numbers starting at 
zero. For example, a Vectorworks file with two textures would export two image files 
named Textr0.jpg and Textr1.jpg.

When exporting multiple drawings with textures, be sure to save them to different 
folders—otherwise, new textures will overwrite existing exported textures.

Parameter Description

(3DS) Model Width/Height/
Depth

Displays the original dimensions of the object(s) selected for import or export; if 
there are multiple objects, the scaling center is the center of the selection bounding 
box

Parameter Description
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3. Click OK to save the scaling information.
~~~~~~~~~~~~~~~~~~~~~~~~~
Importing in 3ds Format (3D only)
Exporting in 3ds Format (3D only)

Importing and Exporting in IGES Format

Importing IGES Format (3D only)
During IGES import, points are imported as a group of 3D loci, NURBS curves are imported as a group of NURBS 
curves, NURBS surfaces are imported as a group of NURBS surfaces, closed solids are imported as a group of 
imported solids, and open solids are imported as a group of NURBS surfaces. If there is only one element in the IGES 
file, it is imported as a single element rather than grouped. Imported solids cannot be ungrouped or edited through the 
Edit Group command; they can be used in solid operations.
To import an IGES file:

1. Select File > Import > Import IGES.
The Import IGES File dialog box opens.

2. Select the file to import, and click Open.
Alternatively, click the file to import and drag it into a window where a Vectorworks document is open.

Exporting in IGES Format (3D only)
The Export IGES (3D only) command exports 3D curves, surfaces, and solids from a Vectorworks file into IGES 
format (version 5.3). Closed solids are exported as solids, while open solids are exported as a collection of surfaces.
Objects that are exported to an .igs file include:

To export an IGES file:
1. Select File > Export > Export IGES (3D only).

The Export Options dialog box opens.

Custom Allows entry of custom dimensions for imported or exported objects in the Desired 
Width, Desired Height, and Desired Depth fields. Select Maintain Proportions to 
have the Vectorworks program automatically adjust the proportions when a custom 
width, height, or depth is entered.

Scale Allows entry of a scaling factor to be applied to imported or exported objects. Either 
select a Scale from the list, or select Custom from the top of the list and enter a 
Custom Scale value. When the scale factor changes, the dimension values also 
change to show the exact size of the selection bounding box for the given scale.

• 3D loci • 3D polygons • Architectural objects (wall/slab/column/stair)

• Chamfers • NURBS curves and surfaces • CSG solids (add/subtract/intersect/section)

• Fillets • Groups • Extrudes and multiple extrudes

• Parametric objects • Shells • Solids (sphere/cone/hemisphere)

• Sweeps • 3D Symbols

Parameter Description
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2. Select Export Solid as Trimmed Surfaces to export a solid as several different “bodies” (for example, a cube 
exports as six bodies); otherwise, a solid is exported as a single body.

3. Click OK.
4. Specify the export file name and destination, and then click Save.

Importing and Exporting in SAT Format

Importing SAT (3D only)
ACIS/SAT 3D solids are imported as NURBS-based Vectorworks solids.
To import an SAT file:

1. Select File > Import > Import SAT.
The Import SAT File dialog box opens.

2. Select the file to import, and click Open.
Alternatively, click the file to import and drag it into a window where a Vectorworks document is open.

Exporting SAT (3D only)
Vectorworks software creates an SAT file for exporting ACIS 3D solids.
To export an SAT file:

1. Select File > Export > Export SAT (3D only).
The Export Options dialog box opens.

2. Select Export Solids as Trimmed Surfaces to export a solid as several different ACIS “bodies” (for example, a 
cube exports as six ACIS bodies). If this option is deselected, a solid is exported as a single body.

3. Click OK.
4. Specify the file name and destination, and then click Save.

Importing and Exporting in STEP Format

Importing STEP Format (3D only)
During STEP import, points are imported as a group of 3D loci, NURBS curves are imported as a group of NURBS 
curves, NURBS surfaces are imported as a group of NURBS surfaces, closed solids are imported as a group of 
imported solids, and open solids are imported as a group of NURBS surfaces. If there is only one element in the 
STEP .stp file, it is imported as a single element rather than grouped. Imported solids cannot be ungrouped or edited 
through the Edit Group command; they can be used in solid operations. 
To import a STEP file:

1. Select Files > Import > Import STEP (3D only).

Export Item Export Result

NURBS curve IGES Entity Type 126
NURBS surface IGES Entity Type 128
Trimmed NURBS surface IGES Entity Type 144
Closed solid IGES Entity Type 186
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The Import STEP File dialog box opens.
2. Select the file to import, and click Open.

Alternatively, click the file to import and drag it into a window where a Vectorworks document is open.

Exporting STEP (3D only)
The Export STEP (3D only) command exports 3D curves, surfaces, and solids from a Vectorworks files into STEP 
format. Closed solids export as solids, while open solids export as a collection of surfaces.
Objects that are exported to an .stp file include:

To export a STEP file:
1. Select File > Export > Export STEP (3D only).

The Export Options dialog box opens.
2. Select Export Solid as Trimmed Surfaces to export a solid as several different “bodies” (for example, a cube 

exports as six bodies); otherwise, a solid is exported as a single body.
3. Click OK.
4. Specify the file name and destination, and then click Save.

Importing and Exporting in Rhino 3DM Format

Importing Rhino 3DM Format (3D only)
During Rhino 3DM import, points are imported as a group of 3D loci, NURBS curves are imported as a group of 
NURBS curves, NURBS surfaces are imported as a group of NURBS surfaces, closed solids are imported as a group of 
imported solids, and open solids are imported as a group of NURBS surfaces. If there is only one element in the Rhino 
3DM file, it is imported as a single element rather than grouped. Imported solids cannot be ungrouped or edited through 
the Edit Group command; they can be used in solid operations. 

Exporting in Rhino 3DM Format (3D only)
The Export Rhino 3DM (3D only) command exports 3D curves, surfaces, and solids from a Vectorworks file into 
Rhino 3DM format, used by Rhinoceros® model files. Closed solids are exported as solids, while open solids are 
exported as a collection of surfaces.
Objects that are exported to a .3dm file include:

• 3D loci • 3D polygons • Architectural objects (wall/slab/column/stair)

• Chamfers • NURBS curves and surfaces • CSG solids (add/subtract/intersect/section)

• Fillets • Groups • Extrudes and multiple extrudes

• Parametric objects • Shells • Solids (sphere/cone/hemisphere)

• Sweeps • 3D Symbols

• 3D loci • 3D polygons • Architectural objects (wall/slab/column/stair)

• Chamfers • NURBS curves and surfaces • CSG solids (add/subtract/intersect/section)

• Fillets • Groups • Extrudes and multiple extrudes
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To export a Rhino 3DM file:
1. Select File > Export > Export Rhino 3DM (3D only).

The Export Options dialog box opens.
2. Select Export Solid as Trimmed Surfaces to export a solid as several different “bodies” (for example, a cube 

exports as six bodies); otherwise, a solid is exported as a single body.
3. Click OK.
4. Specify the file name and destination, and then click Save.

Importing and Exporting in Parasolid X_T Format

Importing Parasolid X_T Format (3D only)
The Vectorworks program can import 3D Parasolid X_T objects, including NURBS curves, NURBS surfaces, and 
solids; solids are imported as generic solids.
To import a Parasolid X_T file:

1. Select File > Import > Import Parasolid X_T.
The Import Parasolid X_T File dialog box opens.

2. Select the file to import, and click Open.
Alternatively, click the file to import and drag it into a window where a Vectorworks document is open.

Exporting in Parasolid X_T Format (3D only)
The Export Parasolid X_T (3D only) command exports 3D objects to Parasolid .x_t format. Only 3D objects are 
exported. This is a convenient way of exchanging files with other applications that also use Parasolid as their modeling 
kernel, even when the other application’s Parasolid version is older.
To export a Parasolid X_T file:

1. If 3D objects from only one layer should be exported, make that layer active. If only selected objects should be 
exported, select the objects.

2. Select File > Export > Export Parasolid X_T (3D only).
The Export Parasolid X-T Options dialog box opens. Select whether to export only selected objects from the 
active layer, all visible objects from the active layer, or all visible objects from all layers in the file.

Click to show/hide the parameters.

• Parametric objects • Shells • Solids (sphere/cone/hemisphere)

• Sweeps • 3D Symbols

Parameter Description

Export
Selected Objects on Active Layer Exports only selected 3D objects from the active layer
All Visible Objects on Active Layer Exports all visible 3D objects from the active layer
All Visible Objects on All Layers Exports all visible 3D objects from all layers in the Vectorworks file
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3. Click OK.
4. Specify the export file name and destination, and then click Save.

Importing and Exporting Georeferenced Raster Images
A georeferenced raster image is a regular image file that comes with an additional companion file, known as a world 
file. A world file associated with the raster file must have the same name as the raster file and an extension 
of .bpw, .jgw, .pgw, .tfw, .gfw, or .wld. Georeferenced raster images are supported in the Vectorworks Landmark 
product, for both import and export.

Importing Georeferenced Raster Images
When you import a raster image file, the Vectorworks Landmark product automatically uses the companion world file 
to import the image as a georeferenced raster image.
To import a georeferenced raster image:

1. Select File > Document Settings > Units and set the document units to match the units of the image to be 
imported. For example, if the world file’s units are meters, set the Vectorworks document units to meters.

2. Select File > Import > Import Image File.
The Open dialog box opens. Select the raster file for import.

3. If a world file is associated with the raster file, the image is automatically imported, translated, and scaled. The 
current view changes to Fit to Objects, so the imported image is visible. 
To import an image without its associated world file scaling and translation, either rename the associated world 
file, or move it to a different folder.
GeoTiff image files can be imported, but no georeferencing information within the file is used.

Exporting Georeferenced Raster Images
If the current design layer is georeferenced, there is an option to export a worldfile along with an image file of the 
Vectorworks drawing.
To export a georeferenced raster image and world file:

1. Select File > Export > Export Image File.
2. The Export Image File dialog box opens. Select the export options, including Export Georeferencing File.
3. Click Save, and then name and save the image file. Along with the image file, the Vectorworks program exports a 

worldfile that describes the exported image’s location, scale, and rotation in the geographic coordinate system. If 
multiple georeferenced layers are visible, the worldfile will be written according to the topmost layer. See 
“Exporting an Image File” on page 1683.

~~~~~~~~~~~~~~~~~~~~~~~~~
GIS and Georeferencing

Parasolid Version Specify the Parasolid version for export; if the exported file cannot be 
opened, try exporting to a lower version of Parasolid

Parameter Description
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Importing and Exporting Vectorworks Spotlight Data
The Vectorworks Spotlight product provides the ability to import and export lighting design data. The Vectorworks 
program is compatible with Lightwright 5 and later, and includes extra functionality to automatically data transfer to 
and from Lightwright.
~~~~~~~~~~~~~~~~~~~~~~~~~
Exporting Instrument Data
Exporting Patch Information
Importing Instrument Data
Automated Import and Export to Lightwright

Exporting Instrument Data
Vectorworks Spotlight instrument data (including accessory, power, and position information) can be exported to an 
external file. The resulting file can then be opened by a spreadsheet or database program, and is compatible with 
Lightwright.

All instrument and accessory data from the current light plot are exported. Individual instruments cannot be 
selected for export.

To export instrument data:
1. Select File > Export > Export Instrument Data.

The Export Instrument Data dialog box opens.
Click to show/hide the parameters.

The Unique ID field (UID) is not in the list, but is automatically exported. This field is required to re-import data.
2. Select the desired parameters and click Export.
3. Specify the export file name and destination, and then click Save.

Parameter Description

Instrument Fields Selects the instrument data to be exported. Double-click (Macintosh) or click (Windows) 
an item to select it; a plus sign (+) next to the field indicates that it will be exported. To 
deselect a field, double-click it.

All Selects all instrument data fields for export
Lightwright Selects only the instrument data fields supported by Lightwright. All 

Lightwright-compatible fields will be exported; these fields are displayed with a plus 
sign. Verify the selections to ensure that these are the fields desired for export.

User Restores the last saved or loaded set of instrument data fields
None Deselects all instrument data fields
Save Saves the current set of selections; enter a name for the selection set file
Load Loads a selection set file 
Export field names as 
first record

Retains headers for the field information during export; this option is recommended, as it 
helps to organize the data in the database or spreadsheet program

Export in Lightwright 4 
format

Exports all static accessories attached to an instrument as a list separated by a “+” sign, to 
the Accessories field associated with the instrument
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4. The selected instrument data is exported to the file in tab-delimited format. Import the file as tab-delimited into the 
other program.

~~~~~~~~~~~~~~~~~~~~~~~~~
Importing and Exporting Vectorworks Spotlight Data
Automated Import and Export to Lightwright

Exporting Patch Information
The Export ASCII Patch command exports the dimmer and channel information from the drawing to a USITT 
standard ASCII text patch file (Version 3.0, Ident 3.0).
To export dimmer and channel information to a patch file:

1. Select File > Export > Export ASCII Patch. 
2. Select whether to clear existing console patch information when importing the patch data into the lighting console. 

Click Yes to delete all existing patch data in the console before importing the new patch. Click No to preserve the 
current console patch data; the new patch information may overwrite existing data.

3. The Export ASCII Patch File dialog box opens. Specify the location and file name of the patch text file.
Fixtures with multiple channels are patched sequentially. For example, setting the Channel to 6, the Dimmer to 
20, and the Num Channel to 4 generates the following patch information:

~~~~~~~~~~~~~~~~~~~~~~~~~
Importing and Exporting Vectorworks Spotlight Data

Importing Instrument Data
Instrument data from an external file can be imported into a Vectorworks Spotlight file. Import settings can be saved.
To import instrument data:

1. Select File > Import > Import Instrument Data.
The Instrument Data Import dialog box opens.

2. Click Browse to search for the file to be imported.
The imported file must consist of tab-delimited text, with the instrument information in the rows and the field 
information in the columns. 

3. Once the file has been selected, choose the Unique ID Field from the list of available fields. 
This field will be used as the key field to match imported data to the data in the plot. Normally, select UID (Unique 
ID) or EID (External ID). 

4. After the Unique ID Field has been selected, the list of incoming data fields is displayed in the Incoming Data 
list on the left, and all available instrument fields are shown in the Record Fields list on the right.

Channel Dimmer

6 20

7 21

8 22

9 23
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5. To map the incoming data to an instrument field, select a data item from the Incoming Data list, and then select 
the destination record field on the right. Click Link to link the fields. The linked field moves to the Record Fields 
list. (To unlink two linked fields, select the field from the Record Fields list and then click Unlink.) 

6. Continue mapping fields individually until the desired links have been made. To save time, click AutoLink; this 
automatically matches fields based on the similarity of their names. Verify that the links were made as intended.

7. To import the data without saving the links, click Import.
Saving the mapping information allows you to skip the process of mapping individual fields when importing 
similar external files. Once the fields have been mapped appropriately, save the mapping links by clicking Save. 
Specify the name of the links file, which can then be restored with the Load button. 

8. During import, the Vectorworks Spotlight product attempts to match all incoming data to an appropriate 
instrument. However, if items exist which cannot be matched, these display as orphan instruments at the bottom 
left of the drawing, outside the page boundary.
The first row of the imported file should contain the field labels. However, if the file to import contains instrument 
data in the first row, select Import First Record.

To load saved mapping files:
1. Click Browse and select the file to be imported.
2. Click on the Load button, and select either a pre-defined mapping file or a saved mapping file. Click Import to 

open the mapping file and automatically map the fields based on the saved links. 
~~~~~~~~~~~~~~~~~~~~~~~~~
Importing and Exporting Vectorworks Spotlight Data
Automated Import and Export to Lightwright

Automated Import and Export to Lightwright
The lighting instruments and parameters specified in the Vectorworks Spotlight product can be automatically sent to 
Lightwright versions 5 and later to perform paperwork processing. Any changes to the data in Lightwright 
automatically update the light plot. Once configured (and once the Vectorworks file has been saved), these updates 
occur seamlessly in both applications.

For versions of Lightwright earlier than 5, see “Exchanging Data with Older Versions of Lightwright” on 
page 1707.

To specify automatic data transfer between the Vectorworks Spotlight product and Lightwright:
1. Select File > Document Settings > Spotlight Preferences.

The Spotlight Preferences dialog box opens. Click the Lightwright tab.
Click to show/hide the parameters.

Parameter Description

Use automatic Lightwright 
Data Exchange

Enables the automatic exchange of data between the Vectorworks Spotlight product 
and Lightwright; deselect to suspend or stop the data exchange

Perform a complete export 
on exit

Exports the Spotlight data, replacing all the data in Lightwright the next time 
Lightwright is used. This should occur whenever field export changes have occurred; 
therefore, when changes have been made, the field appears dimmed and cannot be 
deselected.
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2. Click Use automatic Lightwright Data Exchange to enable automatic data transfer between the Vectorworks 
Spotlight product and Lightwright, and indicate the location for saving the transfer file.

3. Move fields to be exported from the Available Fields list to the Export Fields list. All parameters in the Export 
Fields list are exported to Lightwright.
Click Save as default to save the current status of the lists for new Vectorworks files. When enabling data 
exchange, click Reset Defaults to use the default lists.

4. Click OK to close the dialog box and export the instrument and accessory information from the Vectorworks file 
to the exchange file. 

As instruments are added, deleted, and changed in the Vectorworks Spotlight product, the edits appear in Lightwright. 
Similarly, edits made in Lightwright apply automatically to the Vectorworks file. Instrument data are updated when the 
file focus switches from the Vectorworks file to Lightwright, or Lightwright to the Vectorworks file.
Lights added in Lightwright are placed between existing lights on a lighting position upon import, based on the unit 
number of the new light. If no adjacent lights can be determined, the light is placed at the center of the lighting position.
In the Vectorworks file, an import worksheet is automatically created, listing instruments that have been added from 
Lightwright as well as instruments that did not have a Lightwright equivalent and should possibly be deleted from the 
Vectorworks file. 

Include Inventory Select to include inventory data in the data transfer. An updated instrument types 
inventory list, which is controlled by the Lighting Inventory Setup command, is 
sent to Lightwright when the Lightwright data exchange performs a complete export 
and when lighting inventory is updated (see “Lighting Inventory Setup” on page 960 
and “Inventory Reports” on page 969).

Only instruments types with a count of one or more are sent to Lightwright.
Inventory updates from Lightwright are processed with the other instrument data. 
Instrument summaries are updated automatically if Show Counts and Compare to 
Inventory are selected in the Instrument Summary Settings dialog box for the placed 
objects. 

File Path Specifies the location of the exchange file. The file is in .xml format, and it is named 
according to the Vectorworks file.

Same location as the file Saves the exchange file with the Vectorworks file
A custom location Saves the exchange file in a specific location; click Choose to set the location
Available Fields Lists field names from the Vectorworks file that are available to export to 

Lightwright, but have not been selected for export
Move > Moves the selected Vectorworks file field to the Export Fields list for export to 

Lightwright
< Move Removes field names from the Export Fields list, returning them to the Available 

Fields list, where they are not included for export
Export Fields Lists field names that will be exported to Lightwright
Reset Defaults Restores the fields to the lists specified as a default when Save as default was last 

clicked
Save as default Saves the current lists as the default mapping to be restored by Reset Defaults; the 

default settings saved include those on the Lighting Device and Universe tab

Parameter Description
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Right-click (Windows) or Ctrl-click (Macintosh) on a database row of the import worksheet, and choose Select 
Item to select and display the associated instrument.

~~~~~~~~~~~~~~~~~~~~~~~~~
Lighting Device Setup
Universe Assignment in Vectorworks Spotlight
Importing and Exporting Vectorworks Spotlight Data

Exchanging Data with Older Versions of Lightwright
The Vectorworks Spotlight product automatically exchanges data with Lightwright version 5 and later (see “Automated 
Import and Export to Lightwright” on page 1705). However, instrument data can also be transferred between the 
Vectorworks Spotlight product and versions of Lightwright earlier than 5. Once lighting instruments and parameters 
have been specified in the Vectorworks file, their information can be sent to Lightwright to perform paperwork 
processing. When the paperwork in Lightwright is complete, the data can be imported back into the Vectorworks file to 
update the light plot.
The Vectorworks Spotlight product includes Lightwright automated action files, which, when selected at installation, 
are located in the Extras folder. These files have the correct settings required for exchanging data with the Vectorworks 
Spotlight product, and need to be placed into Lightwright’s Automated Actions folder. Consult the Lightwright 
documentation for information on using these files.
~~~~~~~~~~~~~~~~~~~~~~~~~
Exporting the Vectorworks Data for Editing
Importing the Vectorworks Data into Lightwright
Exporting the Edited Data from Lightwright
Importing the Edited Lightwright Data into Vectorworks

Exporting the Vectorworks Data for Editing
To export instrument data from the Vectorworks Spotlight file to Lightwright:

1. When the Vectorworks file contains instrument data that is ready to export, select File > Export > Export 
Instrument Data.
The Export Instrument Data dialog box opens.

2. Select the appropriate Lightwright items for export by clicking the Lightwright button. (See “Exporting 
Instrument Data” on page 1703 for more information.) Select Export field names as first record. If exporting to 
version 4 of Lightwright, select Export in Lightwright 4 format.

3. Click Export to export the lighting instrument information as a tab-delimited file. Specify the location for the 
exported file, and click Save.

Importing the Vectorworks Data into Lightwright
The data exported from the Vectorworks Spotlight program now needs to be imported into Lightwright so that it can be 
edited.

1. Prior to import, select Setup > Vocabulary in Lightwright.
The Show Setup dialog box opens.
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2. Ensure that the Separate accessories from instrument types with field contains a “+” sign.
To import Vectorworks data into Lightwright:

1. In Lightwright, select File > Import Data. Specify the location of the file that was just created, and click Open.
2. The Importing dialog box opens. Click Suggest Matches.

Lightwright attempts to match the imported data fields to Lightwright fields. Verify that the information has been 
matched correctly. 

3. Select Do not import first record and Ignore fields with only. Enter a “-” (dash) so that Vectorworks Spotlight 
fields with a “-” are ignored. 

4. Click OK to begin the import. Lightwright reports the number of instruments that were imported; this may differ 
from the number of instruments exported from the Vectorworks program due to Static Accessories.

5. Select whether to save the import action in Lightwright.
Saving the action speeds up the import process, because the matching selections and other options will not need to 
be specified again.
Provide a name for the automated action, which can be selected later from File > Automated Actions.

Ensure that UID is
matched to
External ID
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6. The instrument information is now available for editing in Lightwright.

7. Save the Lightwright file.

Exporting the Edited Data from Lightwright
Once the lighting instrument data has been edited in Lightwright, export the data so that it can be used to update the 
light plot in the Vectorworks Spotlight file.

If lighting instruments have been deleted in Lightwright, they will not automatically be deleted in the Vectorworks 
file. A warning message opens if this is the case, and the affected instruments are automatically selected for 
further action.

To export the edited data from Lightwright:
1. In Lightwright, select File > Export > Data. The Export Options dialog box opens.
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2. Select the fields for export; selected fields display a check mark. Ensure that the External ID and Accessory 
fields are selected for export, and that Tab Separated is selected as the Export File Type. In addition, select 
Export field labels as first record, Strip Channel Parentheses, For lights with attributes and Fill blank fields 
with. For the blank fields, enter a “-” (dash), so that a “-” is inserted in any blank fields. Click OK.

3. Specify the export file name and location.
4. The option to save the export action for future automation is presented.
5. Click Yes to save the action.

Importing the Edited Lightwright Data into Vectorworks
Import the edited Lightwright data into the Vectorworks Spotlight file to update the lighting instrument information.
To import Lightwright data back into the Vectorworks file:

1. In the Vectorworks program, select File > Import > Import Instrument Data.
The Instrument Data Import dialog box opens.

2. With the Browse button, specify the file exported from Lightwright. If the file to import has External ID or UID as 
a field name, it will automatically be selected as the UID. Do not select Import First Record.
Click AutoLink to correctly match important fields. If not all fields are automatically mapped, map the incoming 
data to an instrument field as described in “Importing Instrument Data” on page 1704.
Accessories should be mapped to Accessories, and Instrument Type Symbol to Symbol Name.

3. Click Import. The Lightwright data is imported into the Vectorworks file, automatically updating the instrument 
data in the light plot.
If the instruments are not updated, verify that the External ID field was exported, and the Export Field Labels as 
First Record option was selected in Lightwright.
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If the data needs to be sent back to Lightwright after this initial export, select the Merge command in Lightwright 
rather than Import. Lightwright uses the Lightwright ID number to match the data to existing instruments rather 
than creating new instruments.
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DXF/DWG and DWF File Formats
DXF and DWG are two common file formats used to exchange information between different CAD and drawing 
programs. DXF is a semi-public standard promoted and controlled by Autodesk, Inc. DWG is a proprietary, closed 
format used by Autodesk for its products. DXF and DWG files contain almost identical information, and both store all 
of the same objects. Recent versions of AutoCAD have issues when reading some DXF files, such as losing links to 
images, so DWG is usually a safer choice in that case. As of this writing, the most recent DXF/DWG version is version 
2015. The Vectorworks program imports versions 2.5 through 2015, and exports versions 12 through 2015.
DWF is a format developed by Autodesk to allow efficient sharing of design drawings with colleagues who do not have 
access to AutoCAD or other design software. DWF files are highly compressed, device and software independent, and 
can include 3D models. The Vectorworks program imports and exports versions 4.2, 5.5, and 6.0 (DWF text and 
binary); 4.2 and 5.5 (DWF compressed binary); 6.01 (3D DWF); and 6.02 (DWFx).

Vectorworks 2015 Improvements
The following changes to the DXF/DWG and DWF translation procedure have been added:

• Standard leader and multileader lines now import as polylines or polygons with arrow markers; custom leader 
arrows import as symbols. Previously, all leader and multileader lines imported as a set of independent objects.

• New options allow you to import dashed lines as solid lines, and to set a minimum gap size. Previously, even lines 
with gaps too small to be seen were imported as dashed line types, which could affect the performance of the 
Vectorworks program.

• The precision settings for length and angle are now set according to the setting in the Units dialog box during 
export. Previously, only the length precision was set, to a fixed value.

• A new Location tab in the import options allows you to decide how to handle imported objects relative to the 
drawing’s internal origin. The default option centers the drawing about the internal origin, and shifts the user 
origin, if necessary, to preserve file coordinates. This prevents problems caused by objects located too far away 
from the internal origin. Subsequent imports match the user origin, keeping all files properly aligned with each 
other. Other options on the Location tab allow you to preserve the import behavior of previous versions of 
Vectorworks software.

• A new option allows you to import tables as worksheets, for easier modification. Previously, tables were always 
imported as sets of individual line and text objects.

• A new option allows you to export SIA dimensions as non-superscript AutoCAD dimensions that update 
automatically during reshape. Previously, SIA dimensions were always converted into non-dimension objects that 
looked exactly the same as they did in Vectorworks.

Information Lost in Translation
Importing from and exporting to DXF/DWG or DWF is not the same as saving or opening a Vectorworks file. It is a 
translation from one way of doing things to another; consequently, information can get lost in the translation. 
Following are some items that DXF/DWG and DWF handle differently. These can introduce unwanted effects in the 
translated file.
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Item Description

Units Version 2000 DXF/DWG and later supports the concept of units, so the file’s unit settings 
can be imported (if it includes units). Previous versions of DXF/DWG do not support units, 
and some version 2000 and later files may be unitless. There is no way for the Vectorworks 
program to tell whether these unitless drawings were made in meters, feet and inches, or 
microns. Communicate with the person providing the file to determine this information. 
Unitless DXF/DWG files do have five “units” settings (such as “Architectural” and 
“Engineering”) which are used to guess the original units, but the guess may need to be 
adjusted.

Line Weights The Vectorworks program allows line weights and colors to be specified independently. 
AutoCAD has recently gained the ability to do so, but most AutoCAD users still use colors 
to map to line weights. Version 14 and earlier DXF/DWG files do not support true line 
weights at all. If you choose to export with line weights mapped to colors, then original 
object colors will be lost.

Colors and Fills The Vectorworks program is more graphically rich than DXF/DWG can currently support. 
In all cases, the Vectorworks program chooses the closest possible translation given the 
limitations inherent in DXF/DWG. The default version in the export dialog box will always 
give the best results possible, assuming the recipient’s software can read all of the 
information.
DXF/DWG versions prior to 2004 have a fixed color palette (which changes slightly 
depending on whether the background is black or white) and all objects have just one solid 
color associated with them. Objects such as circles in DXF have no fill color (just a line 
color). A few objects can have a fill color, but they have no separate line color.
DXF/DWG version 14 and above supports a “solid hatch,” which is a separate object that 
can be associated with objects such as circles to make them look like they have a color fill. 
These hatches cannot be the same color as the background color (such as a white rectangle 
on a white background to mask objects underneath). Since these solid hatches can be 
associative, the Vectorworks program can import them and set the associated object’s fill 
color instead of having two separate objects for frame and fill.
DXF/DWG version 2000 supports “wipeout” entities, which are essentially polygonal 
images filled with the background color. Some AutoCAD users may not want to receive 
files with wipeouts. DXF/DWG export includes an option to exclude solid fills (which 
includes both wipeouts and solid hatches). Since wipeouts can only be polygons and are 
not associative, if a white circle on a white background is exported and then re-imported 
into a Vectorworks file, the result is an unfilled circle and a polygon with a white fill and 
no pen inside the circle. The smoothness of the polygon (number of facets) depends on the 
2D conversion resolution preference when it was exported.
Objects with pattern fills export as a plain solid color.
Surface hatches associated with a Renderworks texture must be exported as standard 
AutoCAD hatches.

Layers and Classes Each Vectorworks design layer is similar to a DXF/DWG model space. A Vectorworks 
drawing can have many design layers visible at the same time, with different scales and 
views for each design layer, but only one model space is allowed in a DXF/DWG file. 
Therefore, the Vectorworks program has to merge the multiple design layers, and some 
information can be lost. The drawing should generally look and print the same after the 
export, but independent layer scales, object coordinates, and invisible objects can be lost.
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~~~~~~~~~~~~~~~~~~~~~~~~~
DXF/DWG and DWF File Import
DXF/DWG and DWF Items Which Cannot Import to Vectorworks
DXF/DWG and DWF File Export
Items Which Cannot Export to DXF/DWG or DWF

Groups and Symbols The Vectorworks program uses symbols, which are objects that can be inserted multiple 
times without greatly increasing the file size, and which need only one edit to update all 
copies. It also has groups, which are objects that are grouped together and act as one 
object. The DXF/DWG equivalent of a Vectorworks symbol is called a “block.” The 
closest DXF/DWG equivalent to a Vectorworks group is an “anonymous block,” which is 
like a symbol without a name. Unlike anonymous blocks, named blocks can be edited 
easily in AutoCAD, and new instances of the blocks can be inserted into the drawing. 
However, named blocks re-import into Vectorworks files as symbols, which may not be 
desirable. Therefore, the Vectorworks program has an option to export groups as 
anonymous blocks, if named blocks cause a problem.

Attributes and Linked 
Text

DXF/DWG does not have database records that correspond to Vectorworks record formats. 
It does have objects called attribute definitions (“attdefs”) which, when placed in blocks/
symbols, behave somewhat like linked text in a Vectorworks file. The correspondence is 
very loose and as a result translation of these objects is not always smooth. DXF/DWG 
block attributes are created for things exporting as blocks (symbols, groups, plug-in 
objects, or layer links) that have record formats attached. Because only DXF/DWG blocks 
can have attributes attached, the record format information is not exported for other object 
types, such as lines or circles.

Names When exporting to DXF/DWG version 2000 and later, the characters in layer and block 
names will not change. Accurate translation of lower case text, spaces and other Unicode 
characters is supported (except for the following illegal characters, which are converted 
during export: < > " `, / \ : ? * | = ). Export to previous versions converts all name 
characters to uppercase; all spaces and special characters are converted to underscores. 
DXF/DWG attribute tag names cannot have spaces in any version; any spaces found in 
record field names are converted to an underscore.

Styled Multiline text Multiline formatted text includes various sized fonts that are bold, underlined, or italicized, 
and that wrap to the next line. This type of text is supported for DXF/DWG versions 13 
and up. For earlier versions, wrapped text is split into separate lines.

Layer Transfer Mode / 
Transparency

DXF/DWG does not support layer transfer modes or transparency, so use only paint 
transfer mode (100 percent opaque on Mac systems and on Windows systems that have 
GDI+ imaging enabled)

Dimensions The Vectorworks and AutoCAD programs handle dimensions, units, and dimension 
standards very differently. Dimensions exported to DXF/DWG look exactly the same when 
opened in AutoCAD, but they may change appearance slightly if edited. The Vectorworks 
program also creates appropriate dimension styles for all dimension standards that are used 
in the file, so even if the recipient modifies the dimensions or creates new ones, they 
should not look significantly different. During import, the dimension styles from the DXF/
DWG file will be created as custom dimension standards in the Vectorworks file, to 
preserve the original look.

Item Description
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DXF/DWG and DWF File Import
Consider the following points when importing from DXF/DWG or DWF file format to Vectorworks file format.

~~~~~~~~~~~~~~~~~~~~~~~~~
Preparing to Import
DXF/DWG and DWF Import Procedure
DXF/DWG and DWF Import Options
DXF/DWG and DWF File Formats

Item Import Notes

Line Weights If no .ctb file is present and true line weights are present, then the line weights import 
exactly. If no .ctb file is present and no true line weights are present, values will have to be 
entered manually. The values in the dialog can be initialized by first importing a file that 
does have an associated .ctb file. This creates a hidden record that stores the mapping 
information. A template file could be created after doing such an import, to save the values 
for future use.

Text • Text is sometimes unlinked from symbols when imported to preserve the original look. 
Options are provided for preserving the links instead.

• Some text styles are not supported; when the active plane is set to Layer, text in 3D 
symbols is imported; when the active plane is set to Screen Plane, text in 3D symbols is 
not imported.

Model Space Entities Model space entities are imported as design layer objects.
Paper Space and 
Viewports

Each paper space layout creates a Vectorworks sheet layer when imported. DXF viewports 
are imported as Vectorworks viewports, with the same scale, view, and projection.

Points Points are imported as symbols or as loci, depending on the file and the import options 
chosen.

Multilines Multilines are imported as grouped lines. An option is provided to import them as walls.
bhatches, Images, and 
Wipeouts

• bhatch definitions are imported as hatch definitions.
• A single object associative bhatch with no islands is imported as an equivalent object 

with a solid or hatch fill.
• A multi-object, non-associative bhatch or associative bhatch is imported as an object 

with zero line weight and solid or hatch fill.
• A bhatch with islands is imported as one or more polylines with holes, with solid or 

hatch fill.
• Images referenced by the DXF/DWG file are imported as Vectorworks images.
• A wipeout is imported as a polygon with a solid fill that is the same color as the 

background.
AEC objects created 
with AutoCAD 
Architecture

AEC (architectural, engineering, and construction) objects such as walls, doors, and 
windows are imported as grouped lines and polygons (2D conversion), or grouped meshes 
(3D conversion)
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Preparing to Import
The Vectorworks program imports versions 2.5 through 2015 of DWG and text and binary DXF. Additionally, DWF 
files of the format .dwf (3D DWF), .dwfx (DWFx), and .w2d (DWF 2D sheet) can be imported. Before import, the 
following steps are recommended to increase the likelihood of a satisfactory translation:

1. Read “DXF/DWG and DWF File Import” on page 1716 for more information about the differences between the 
DXF/DWG and DWF formats and Vectorworks file formats.

2. It is not necessary to explode the entire drawing in AutoCAD before importing. If a file is not importing correctly, 
try exploding individual problem objects before import.

3. If possible, communicate with the file originator. Determine the intended units, page size, and scale of the file, 
along with the intended color-to-line weight mapping, if any.

~~~~~~~~~~~~~~~~~~~~~~~~~
DXF/DWG and DWF Import Procedure
DXF/DWG and DWF Import Options
DXF/DWG and DWF File Formats

DXF/DWG and DWF Import Procedure
There are three commands to import DXF/DWG and DWF files into Vectorworks.

• Import Single DXF/DWG and Import Single DWF are very similar; they both import a single file into the 
current file, either directly, or by reference. When a master file is imported with one of these commands, the 
external reference files (“xrefs”) are automatically bound. The Vectorworks program displays an alert if any xrefs 
are missing, along with the names of the missing files.

• Import DXF/DWG or DWF imports one or more files that are in any of these three formats. There are three 
options for importing the files: import into the current file, which creates a new design layer for each imported 
file; import objects into the current file as symbol resources; or import each file into a separate Vectorworks file in 
a designated folder. The results of the import process are summarized in a log file. Referencing is not allowed 
when multiple files are imported. Also, no alert displays if xrefs are missing when multiple files are imported.

Verify that the best possible options were selected for import by checking the imported file(s). If the import was not 
successful, try again with different options. Import options can be saved as a set.

Sometimes files import with large numbers of small lines that are connected end to end. To create a single object, 
first use the Edit > Select Connected Objects command to select all connected lines. Then use the 
Modify > Compose command to compose them into one object. See “Selecting Connected Objects” on 
page 1021, and “Composing and Decomposing Objects and Surfaces” on page 1020.

~~~~~~~~~~~~~~~~~~~~~~~~~
Importing DXF/DWG and DWF Files
Importing a Single DXF/DWG or DWF File

Importing DXF/DWG and DWF Files
When you have several DXF/DWG or DWF files to import, use the Import DXF/DWG or DWF command for 
maximum flexibility.
To import DXF/DWG or DWF files:

1. Create a blank file and set the drawing size, or open an empty template that already has the correct drawing size.
Import into an existing Vectorworks drawing is not recommended, because it can produce unexpected results. For 
the same reason, if you import more than one file with the Import DXF/DWG or DWF command, ensure that the 
files are very similar.

2. Select File > Import > Import DXF/DWG or DWF.
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The Import dialog box opens.
Click to show/hide the parameters.

Parameter Description

Source
One or More Files Imports only one file or only certain files within a folder. Click Choose Files and choose 

one or more DXF/DWG or DWF files to import. The number of files selected and their 
location is displayed.

All ___ Files in 
Folder

Imports all files of the selected type (DXF only, DWG only, DXF and DWG, or DWF 
only) from a specified folder. Click Choose Folder and choose the source folder.

Include Subfolders If All Files in Folder is selected, includes all files of the selected type in all subfolders
Destination

Current File Imports the selected file(s) into the current file. If several files are selected, a new layer is 
created for each imported model space.

Symbols in Current 
File

Imports the selected file(s) into the current file. Each file creates a separate symbol. This 
is convenient when importing part catalogs, for example. Paper space is not imported.

New Files in Folder Converts the selected file(s) into new, separate Vectorworks files in the selected folder. 
Click Choose Folder to choose the location. This is the best option when converting 
many files.

Use Document 
Template

If New Files in Folder is selected, select a template to use for each new file, or select 
Blank Document. The template can be useful for specifying the page size to use for model 
space objects (which can also affect dash scales and conversion of polyline widths). It also 
allows specification of default color to line weight mappings, and in some cases, units.

References
Bind External 
References

Imports the selected master DXF/DWG file and all its external references into the current 
file

Ignore External 
References

Imports the selected master DXF/DWG file without its external references

Use Design Layer 
Viewports
(Vectorworks Design 
Series required)

If New Files in Folder is selected, imports the selected master DXF/DWG file and all its 
external references into separate Vectorworks documents; the external documents are 
referenced from the master Vectorworks document using design layer viewports

Use Layer Import If New Files in Folder is selected, imports the selected master DXF/DWG file and all its 
external references into separate Vectorworks documents; the external documents are 
referenced from the master Vectorworks document using layer importing

Architectural Objects
2D View Imports AEC objects created with AutoCAD Architecture (such as walls, doors, and 

windows) in 2D view; only 2D graphics are imported
3D View Imports AEC objects in 3D view; only 3D graphics are imported



DXF/DWG and DWF File Import |  1719
3. Click OK to import the file(s).
The progress of the import is displayed for each imported file during import. The final results of the import 
process are shown in the DXF/DWG or DWF Import Results dialog box.

4. Click Details to open the results log file. The log text file, named DXF_DWG_DWF Import Log, is placed in the 
specified destination folder if it exists, or in the Vectorworks user folder. New log information is appended to any 
existing log file. The report provides a summary of the import, including the import settings that were used, and a 
list of which files succeeded, and which failed.

~~~~~~~~~~~~~~~~~~~~~~~~~
Importing a Single DXF/DWG or DWF File
DXF/DWG and DWF Import Options

Importing a Single DXF/DWG or DWF File
To import a single DXF, DWG, or DWF file:

1. Create a blank file and set the drawing size, or open an empty template that already has the correct drawing size.
Import into an existing Vectorworks drawing is not recommended, because it can produce unexpected results. For 
example, the class attributes for existing objects in the drawing may be overwritten. Workgroup referencing may 
give better results in these cases.

2. Select File > Import > Import Single DXF/DWG (or Import Single DWF).
The Import DXF/DWG Files (or Import DWF Files) dialog box opens. Select the file to import; the progress of the 
initial import is displayed.
Alternatively, click the file to import and drag it into a window where a Vectorworks document is open.

3. During the import, the import options dialog box opens.
Select appropriate import options as described in “DXF/DWG and DWF Import Options” on page 1720.

4. Click OK to continue importing the file. A progress bar displays, along with the number of objects processed and 
free memory available.

5. If the file being imported has one or more complex hatches with multiple boundaries, the import may have 
performance problems. An alert displays to allow you to choose how to process the hatches. Select an option and 
click Continue. If you select the option to convert hatches to groups of lines, solid type hatches will be skipped 
rather than imported.
For batch imports, no alert displays; the last option you selected from this dialog box for single file import is used 
by default.

Import Options
Use Settings Select a set of import options to apply to the imported files. If several files will be 

imported, it is recommended that Units Setting In File be set to Determine 
Automatically.
• The Default options are those that ship with the Vectorworks software, and they cannot 

be changed.
• To select custom options and save them as a set, select <Active Settings> or a set name, 

and then click Set Custom Options to open the DXF DWG Import Options dialog box.
• To use custom import options that have been saved, select the set name from the list.

Parameter Description



  1720 | DXF/DWG and DWF File Import
6. The Location tab of the import options has a default setting, which provides the best chance of locating the 
imported data close to the internal origin, while keeping subsequent imports aligned: Center first import, align 
all subsequent imports. If the file being imported contains objects located far from the internal origin, and this 
option was deselected in the import options, an alert opens to warn you of potential issues.

Select Yes to switch to the option to Center first import, align all subsequent imports. Select No to continue the 
import with the option that was selected on the Location tab.

7. A results dialog box displays to notify you whether the import succeeded or failed.
8. Click Details to open the results log file. The log text file, named DXF_DWG_DWF Import Log, is placed in the 

specified destination folder if it exists, or in the Vectorworks application folder. New log information is appended 
to any existing log file. The report provides a summary of the import, including the import settings that were used, 
and a list of which files succeeded, and which failed.

9. Check the imported file.
~~~~~~~~~~~~~~~~~~~~~~~~~
Importing DXF/DWG and DWF Files

DXF/DWG and DWF Import Options
The DXF DWG Import Options dialog box and the DWF Import Options dialog box are very similar. This is because 
when you import from DWF, the drawing objects are first converted to DXF/DWG, and then converted into 
Vectorworks format. Change the import options as needed to import a DXF/DWG or DWF file with the maximum 
integrity. The same import options display for import of single files and batches of files.
The first tab, Primary Settings, contains important basic settings. The Graphic Attributes and Objects tabs contain 
settings for advanced users to customize the import process. The Location tab helps with importing a file and locating 
it appropriately relative to the internal origin of the Vectorworks drawing.
Options that do not apply to the current file import appear dimmed, and an explanation displays next to the option. For 
example, if no points are contained in the file to be imported, the Points options are dimmed, and the message “No 
points were found” displays.
If true line weights are not present in the file, you can map the DXF/DWG line colors to Vectorworks line weights for 
import (on the Map Colors to Line Weights dialog box).
To make custom imports faster and easier, save the sets of options that you use frequently.
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Import Options: Primary Settings Tab
The options on the Primary Settings tab establish the basic import options.
Click to show/hide the parameters.

Parameter Description

Saved Settings Options
Settings Select <Active Settings> to use the import options currently selected in the dialog box; to 

use a set of saved import options, select them from the list
Save Opens a dialog box to name and save the currently selected import options so that they 

can quickly be selected as a set
Manage Opens the Saved Settings dialog box to rename or delete sets of saved import options see 

“Managing Saved Import Options” on page 1729
Model Space Units Version 2000 and later DXF/DWG or DWF files support true units. When importing a 

file with true units, the Vectorworks program determines and sets the units automatically. 
If the imported file does not contain true units information, the program tries to guess the 
units setting; however, it may still require adjusting (see “Setting Units Manually” on 
page 1723).

Units Setting In File The Vectorworks program tries to determine the imported file’s unit settings, and displays 
the information to the right of Units Setting in File, along with the unit format (such as 
Architectural), and the scaling factor that will be assumed (such as 1 DXF/DWG Units = 
1”).
• To use the displayed unit settings in the Vectorworks file, select Determine 

Automatically from the list, and also select Set Vectorworks Units to Match.
• To use another unit type (such as Centimeters), select it from the list, and also select 

Set Vectorworks Units to Match.
• To use a custom unit type, or to change the defaulted scaling factor, select Custom 

from the list, and then specify the units in the text boxes. Enter the unitless DXF/DWG 
or DWF number in the first box, and a number with units in the second box. (For 
example, 15 DXF/DWG Units = 1” in the Vectorworks drawing.) The units displayed 
in the second box are the same as the current Vectorworks document settings, but other 
units can be entered as long as the appropriate units suffix is included, such as 3 cm. 
Also select Set Vectorworks Units to Match.

• To use the units currently set in the Vectorworks file, select Use Vectorworks 
Document Units. The Vectorworks program assumes that 1 DXF/DWG or DWF unit = 
1 current document unit when importing objects.

Set Vectorworks 
Units to Match

Changes the Vectorworks document units and units format to match the DXF/DWG or 
DWF file being imported; the physical sizes of imported objects will not be affected. This 
option is disabled when Use Vectorworks Document Units is selected from the Units 
Setting In File list.

2D/3D Conversion
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Convert Objects To Specify whether objects should be imported as 3D, 2D, or a mixture of 2D and 3D. 
Generally, select the 2D and 3D option, which converts objects that appear to be 2D 
(planar objects parallel to or in the active layer plane) to Vectorworks 2D objects. The 
remaining objects are imported as 3D.
To import 3D versions of AutoCAD Architecture objects such as walls and doors, select 
the 3D View setting for Architectural Objects on the DXF/DWG or DWF Import dialog 
box, and select a 3D conversion option. To import both 2D and 3D versions of the 
objects, import them twice from the DXF/DWG file: once with 3D View selected, and 
once with 2D View selected.
Because the Vectorworks program does not have 3D text, selecting 2D and 3D can cause 
text in 3D symbols to be deleted. When the active plane is set to Layer, text in 3D 
symbols is imported; when the active plane is set to Screen Plane, text in 3D symbols is 
not imported.
In addition, objects parallel to the active layer plane that have a thickness are imported as 
3D even though the originator of the file may not have intended for them to be 3D. If 
problems occur, import all objects as 2D by selecting All 2D. A warning displays if 
selecting this option will distort any objects, such as 3D symbols with 3D rotation.
If the file contains only a 3D model, select the All 3D option. Otherwise, parts of a large 
object composed of several entities could be converted to 2D.
Occasionally, none of the choices is appropriate for all the objects. In this case, select the 
option that best converts most of the objects.

2D/3D Conversion 
Res

Specify the resolution that will be used to import both 2D and 3D objects. By default, the 
2D and 3D resolutions set in the Vectorworks Preferences are used (see “Edit 
Preferences” on page 49 and “3D Preferences” on page 54). Higher resolutions can have 
an adverse effect on drawing performance.

This parameter is disabled for DWF import.
Model Space Once the units have been determined, specify the scale to display the imported file.

Choosing the model space scale is important. The scale affects the dash length scaling 
and the conversion of polylines with widths (world-space line weights) to Vectorworks 
line weights. If the scale or drawing size are set incorrectly, some polylines may seem to 
have the wrong line weight and some dashes may be too long or too short.

Fit to Page The Vectorworks program estimates a scale based on the bounds of all of the objects in 
model space; the scale fits those objects on the page. Select this option to use the 
estimated value.

This Scale To import at a different scale, set the scale manually. Click Scale to open the standard 
Layer Scale dialog box, and select the desired scale. (All Layers and Scale Text do not 
apply to DXF/DWG files.) Click OK to return to the Primary Settings tab, and the 
selected scale displays.

Reference References the original DXF/DWG or DWF file (master file), so that the imported 
objects can be updated when the master file changes. See “DXF/DWG and DWF 
References” on page 1728 for more information about referencing.
This option is unavailable if multiple files are being imported.

Absolute path Stores the absolute file path of the master file. Select this option when the location of the 
master file will not change in the future, or if the master file is on another volume.

Parameter Description
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Sometimes DXF/DWG or DWF drawings are split up into pieces and saved as separate files, such as different areas of 
a large city map. When multiple files like this are imported into one file, they need to have their coordinates aligned, 
and their layer scale set the same. The recommended workflow is to import the files with the Center first import, 
align all subsequent imports option on the Location tab.
The Primary Settings tab covers the basic requirements for importing a DXF/DWG or DWF file. If the results are not 
satisfactory, explore the options on the Graphic Attributes and Objects tabs.

Setting Units Manually

If objects seem to be the wrong physical size after import, ensure that the units chosen are correct. (Model Space Scale 
only affects the display, but Units Setting in File affects the actual measured size of the objects.) DXF/DWG or DWF 
files do not always have the true units set, and sometimes have incorrect units set.
The Vectorworks program guesses the units based on the information available, and indicates what it found in the 
dynamic text at the top of the pane. If the guess is wrong, set the units manually.

If you do not know the correct units, but you know the true length of one of the objects in the drawing, determine 
the true units as follows. 
Import the file and choose Custom units, setting the edit boxes to something like 1 DXF Units = 1". After import, 
measure the size of the object that you know the true length of. Close the document and redo the import, but this 
time set the units to Custom with these values in the edit boxes: (measured length) DXF Units = (true length). For 
example, if the true length is 1", but the measured length is 2.54", enter 2.54 DXF Units = 1". (Do not include 
units in the first box, and if in feet and inches mode, just use the total measured length in inches.) 
If the Vectorworks program finds an exact match for that ratio, it will change the Custom choice to the correct 
units. (In the example above, it changes it to Centimeters.) If the measurements and the ratio are not exact (for 
example, 2.539 instead of 2.54), manually adjust it to a standard ratio. Common ratios have values such as 1, 12, 
2.54, and powers of 10. Examples: 1/12, 12/10, 2.54/0.01, etc. 
If you do not know any true lengths, but the document contains dimension objects that show lengths, follow the 
steps just described with the following change: Select Convert Dimensions to Groups (see “Import Options: 
Objects Tab” on page 1725), import, and use the value in the imported dimension object as the true length. 

Normally the Vectorworks program leaves the document units setting unchanged after an import. If a DXF/DWG or 
DWF file is set to meters, but the Vectorworks document is set to feet and inches, then a dimension object that shows 1 
meter in the original file will show as 3'3.37" in the imported file. If you want the imported drawing to be the same as 
the original, select the Set Vectorworks Units to Match option. You can also import with the option to convert 
dimensions to groups (see “Import Options: Objects Tab” on page 1725) if you want the document to stay in the current 
units, but you want the dimensions to look the same as in the original. 
~~~~~~~~~~~~~~~~~~~~~~~~~
DXF/DWG and DWF References

Path relative to 
current document

Stores the file path of the master file relative to the target Vectorworks file; this option is 
available only if the master file is on the same volume as the target file. Select this option 
if the target file and the master file may be moved to another volume in the future.

Save referenced 
cache to disk

Saves a copy of the referenced data with the target Vectorworks file. When this option is 
deselected, a copy of the referenced data is not saved, which means that the target file 
size is smaller; the referenced data is updated when the target file is opened

Automatically 
update out of date 
reference during file 
open

Updates the reference each time the target Vectorworks file is opened; when deselected, 
the reference is updated only when Update is clicked from the References tab of the 
Organization dialog box.

Parameter Description
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Import Options: Graphic Attributes Tab
Import Options: Objects Tab
Import Options: Location Tab

Import Options: Graphic Attributes Tab
The Graphic Attributes tab contains settings for advanced users to customize the import process.
Click to show/hide the parameters.

Parameter Description

Color and Line 
Weights

Most DXF/DWG or DWF files do not use true line weights, although that is starting to change. 
Color is traditionally used to indicate line weights. There are some standards that specify 
mappings between colors and line weights, but those standards are often ignored. The 
Vectorworks program automatically chooses the standard mappings when exporting, if the 
document does not already have a hidden record left over from a previous export or import that 
specifies the mappings. When importing, the Vectorworks program does not choose the standard 
mappings, but rather defaults to a reasonable line weight for all colors, implicitly alerting the user 
that they should determine the true mappings that are desired.
If desired, specify mappings by selecting Map Colors to Line Weights. Select the desired color 
mapping during the import process; if necessary, communicate with the file originator to 
determine the correct line weights.
The colored lines can be changed to black (or white if the background is black). Select Set Colors 
to Black and White. Note that most DXF/DWG or DWF files are created with a black 
background, and the colors may not show up well on a white background.
Version 2000 and later uses .ctb files to store color mapping information, but it also supports line 
weights, so these options may or may not be needed.
• If no .ctb file is detected during import, and true line weights are present, Map Colors to Line 

Weights is deselected automatically, and the line weights import exactly.
• If no .ctb file is detected, and true line weights are not present, Map Colors to Line Weights is 

selected automatically. The Map Colors to Line Weights dialog box displays to allow manual 
mapping (by default, all colors are mapped to the same line weight, or to the last mapping used 
during the current session).

If a .ctb file is detected, Map Colors to Line Weights is selected automatically, and the 
Vectorworks program reads the file to determine how colors should map to line weights. A dialog 
box displays to allow manual mapping (values are pre-set by the mapping file; duplicate 
mappings are indicated by italics).

If you used a set of saved import options, the .ctb file overrides any color mappings in your 
saved settings. Remove the .ctb file from the DXF/DWG or DWF file folder to use the saved 
settings instead.

Dash Patterns In some files, dash lengths may import at an inappropriate scale. Change the dash length scale by 
selecting Manually Scale All Dash Lengths by and entering a scale value. A suggested scale 
value is displayed. The scaling does not affect line thickness. The Vectorworks program converts 
any dash patterns that are extremely small to solid lines to avoid unacceptable slowdowns during 
file display and printing. To adjust which dash patterns convert to solid lines, select Import as 
Solid Line when Gap is Smaller than and enter the smallest line gap size you wish to maintain 
(in document units).
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Import Options: Primary Settings Tab
Import Options: Objects Tab
Import Options: Location Tab
DXF/DWG and DWF Import Options
Managing Saved Import Options

Import Options: Objects Tab
The Objects tab contains settings for advanced users to customize the import process. In particular, decisions about 
preserving object visibility and record field links are available.
Click to show/hide the parameters.

Classes/Layers DXF/DWG and DWF layers correspond more closely to Vectorworks classes than they do to 
Vectorworks layers. Normally, import DXF/DWG and DWF layers as Vectorworks classes.
There is no equivalent to Vectorworks layers in a DXF/DWG or DWF file. When DXF/DWG or 
DWF layers are mapped to Vectorworks layers, a warning displays if some of the objects in 
symbols or groups would leave their original layers and take on the layer of the symbol or group. 
For simple files without blocks, or files with objects inside the block that are set to “by block” 
attributes, importing layers as Vectorworks layers should pose no problems.
To group imported DXF layers in Vectorworks class and layer lists for easy identification, select 
the option to add a prefix to the imported layers. Enter the custom prefix to use in the field to the 
right of the check box. Depending on whether you are importing layers as classes or as layers the 
prefix and hyphen are added as appropriate to either the beginning of the layer or class name. 
Rays and Xlines (or construction lines) are DXF/DWG or DWF objects that are similar to 
Vectorworks guides. A ray starts at a point and goes off to infinity, while a construction line is 
anchored at a point and goes off to infinity in both directions. Select Rays and XLines Use 
Guides Class to convert Rays and Construction Lines into lines in the Guides class, which are of 
finite length.

Parameter Description

Points DXF/DWG or DWF Points act either like a locus in a Vectorworks file (a drawing aid that is 
not printed), or like a symbol that is visible and can be printed. Select whether to import 
points as Loci or as Symbols. The default behavior is to import as symbols if the point style 
has specified a real world size (that is, it is zoom invariant and always prints the same), or as 
loci if the point style is specified as a percentage of the pixel size of the drawing window 
(that is, it varies with the zoom level). Select Use Guides Class to import points as Symbols 
in the Vectorworks Guides Class; this allows them to be hidden. In the Vectorworks program, 
use the Show/Hide Guides commands to toggle their display.

MultiLines Multilines (or “mlines”) are similar in some ways to walls in a Vectorworks file, in that they 
can have breaks that are “healed” and can be connected to other multilines. There are several 
significant differences between multilines and walls, but an option is provided to import 
multilines as walls. Do not select this option unless all multilines in the DXF/DWG or DWF 
file are intended to be walls.

When you import multilines as walls, the wall heights may need to be adjusted. To do 
so, select Tools > Custom Selection, select all walls, and change their height in the 
Object Info palette.

Parameter Description
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Tables Select Grouped Text and Lines to import each table as a group of independent objects and 
text that will precisely reflect the format and structure of the original table; select this option 
if you only need the graphical representation of the table and do not intend to alter the table 
or its content. 
Select Worksheets to create a worksheet resource and place a worksheet object in the 
drawing. The worksheet has the attributes of the original table and can be more easily 
modified.

Block Attributes “Attributes” in a DXF/DWG or DWF file are similar to linked text in a Vectorworks file. 
Select how to handle attribute conversion into Vectorworks symbol linked text. Regardless 
of the selection, record formats will be created based on the attributes found during import, 
and imported blocks with attributes will have record formats attached.
Choose a Linked Text Handling method from the list. Depending on the file to be imported, 
not all options are available.

Preserve Look 
and Links

This option should be selected when available. The attributes will display as they did in the 
DXF/DWG or DWF file, and they will be converted to symbol linked text.
If the file contains invisible attributes or attributes that override the attribute definitions, this 
option is not available.

Preserve Look This is the next best option. The attributes will look and print as they did in the DXF/DWG 
or DWF file, but some symbol text may become unlinked, if necessary, to preserve the look. 
Symbol record field updates are not reflected in unlinked text. With this option, an individual 
symbol could have a mixture of linked and unlinked text.

Preserve Visible 
Links

This option is available when the DXF/DWG or DWF file contains attributes marked as 
“invisible.” This type of attribute is converted in to a record format attached to a symbol, but 
is not converted to linked text. The look of the drawing should be preserved, but minor 
changes to visibility are possible. The advantage of this method is that linked text is 
preserved for all visible attributes.

Preserve All 
Links

The link between record fields and symbol text is preserved with this option. Any invisible 
attributes will become visible. The look of the DXF/DWG or DWF file may not be 
preserved, but the symbol text will not be unlinked.

Hide All All attribute text is hidden upon import. The information is still attached to the object in 
record format, but it is not visible.

Group Record 
Fields

Each block attribute imports as a record format field. Select Group Record Fields to group 
those fields into a single record format. The Vectorworks program groups sets of attributes 
into record formats if they have the same set of field names. For example, if two blocks 
(symbols) have attributes with field names of “color” and “part number,” both blocks are 
converted with the same record format. If one of the blocks has “color,” “part number,” and 
“price,” while the other only has two of those, then the blocks are converted with different 
record formats. When grouped, the record format name is created from the names of the first 
few fields in the record format.
Deselect Group Record Fields to create one record format per field, with no grouping. 
Without grouping, the record format uses the same name as the record field.

Blocks

Parameter Description
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Import Options: Primary Settings Tab
Import Options: Graphic Attributes Tab
Import Options: Location Tab
DXF/DWG and DWF Import Options
Managing Saved Import Options

Import Options: Location Tab
Depending on the coordinates of the imported file, objects in the file might be located far from the drawing’s internal 
origin, which can cause issues with OpenGL rendering and with calculation precision due to rounding errors. It is best 
to center the first import about the internal origin at import, and align subsequent imports with the user origin. This is 
the recommended option. Normally, the internal origin and the center of the page are coincident, so this option also 
centers the objects to the page center. 
Click to show/hide the parameters.

Ignore Block 
Clipping

Select Ignore Block Clipping to import a clipped block as a cropped design layer viewport 
(if Vectorworks Design Series is installed) or as a cropped layer link. This can create many 
layers in the Vectorworks file, and the created objects cannot be manipulated easily.
Deselect Ignore Block Clipping to import a clipped block as a normal scaled or unscaled 
Vectorworks symbol, which may look very different from the original image.

Dimensions
Convert 
Dimensions to 
Groups

By default, the import process automatically creates custom dimension standards to match 
the dimension styles in the DXF/DWG or DWF file. If a dimension was customized in the 
DXF/DWG or DWF file after the style was applied, the converted dimensions may not 
match the originals; select Convert Dimensions to Groups to convert the dimensions into 
groups instead. 

Parameter Description

Center first import, 
align all subsequent 
imports

Centers the first imported file about the Vectorworks drawing’s internal origin, preventing 
problems with the imported drawing’s coordinates. The file’s user origin is shifted if 
necessary, so that all coordinates and measurements appear unchanged. Any subsequently 
imported files are then aligned to the file’s user origin, so that the imported files are aligned 
correctly relative to each other.

Center on Internal 
Origin

Centers the imported file about the Vectorworks drawing’s internal origin. The file’s user 
origin is shifted if necessary, so that all coordinates and measurements appear unchanged. 
Only objects from this import may have their user origin shifted by a specific distance, and 
potentially, previously imported objects and subsequently imported objects may have their 
user origin shifted by a different distance. Objects from these other imports may not be at 
the same relative user origin location.

Align with User 
Origin

Imports objects relative to the user origin currently set in the Vectorworks file. Note that 
some imported objects may display off of the page. If objects are located far from the 
Vectorworks drawing’s internal origin, calculation issues may result.

Align with Internal 
Origin

Positions imported objects according to the Vectorworks drawing’s internal origin, but does 
not shift the user origin; coordinates of the imported file may change. 

Parameter Description
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Internal Origin and User Origin
Import Options: Primary Settings Tab
Import Options: Graphic Attributes Tab
Import Options: Objects Tab
DXF/DWG and DWF Import Options
Managing Saved Import Options

DXF/DWG and DWF References
When you import a single DXF, DWG, or DWF file, you can create a reference to the original file, if the original file 
may change, and you want to keep the imported objects up to date.
You can create the reference during the import process, or create it from the Organization dialog box. The Organization 
dialog box is also used to edit, update, and delete references. See “Workgroups and Referencing” on page 207 for more 
information.
This type of reference is similar to the type of reference that you can create to a design layer in another Vectorworks 
file. You can import from the referenced file into a design layer, or into a design layer viewport (if Vectorworks Design 
Series is installed). The import method is set in the Organization dialog box.
After the reference is created, you may need to edit it. To edit references from the Organization dialog box, select the 
reference and click Edit. The Edit Reference dialog box opens.
Click to show/hide the parameters.

If the reference is a design layer viewport, you can also edit the viewport as follows (also see “Modifying Viewports” 
on page 1648):

• From the Object Info palette, edit the classes and layers shown in the viewport.
• Right-click (Windows) or Ctrl+click (Mac) the viewport and select the Edit Crop command to edit the viewport 

crop.

Parameter Description

Source File Displays the path and file name of the referenced master file; click Browse to edit 
the file location

Save reference location as Maintains either an absolute or relative file path reference from the current file to 
the referenced file. Use the absolute path when the location of the referenced file 
with respect to the current file is not going to change. Use the relative path when the 
files might be moved to another computer or platform; as long as the relative path 
between the files remains the same, the reference can be found. Both files must be 
saved on the same volume to select this option.
The Source File path displays either an absolute or relative path, depending on the 
selection.

Save referenced cache to 
disk

Saves a copy of the referenced data with the target file. When this option is 
deselected, a copy of the referenced data is not saved, which means that the target 
file size is smaller; the referenced data is updated when the target file is opened.

Automatically update out of 
date reference during file 
open

Updates the reference each time the target file is opened; when deselected, the 
reference is updated only when Update is clicked from the References tab of the 
Organization dialog box

Import Settings Opens the Import Options dialog box, to adjust the settings as needed. The next time 
the reference is updated, the new import settings will be used.
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DXF/DWG and DWF Import Options

Managing Saved Import Options
If you have saved a set of import options, use the Manage button on the import options dialog box to rename or delete 
these saved settings when needed.
To manage saved DXF/DWG or DWF import settings:

1. Select File > Import > Import Single DXF/DWG (or Import Single DWF), and select a file to import. The 
appropriate import options dialog box opens.

2. Click Manage.
The Saved Settings dialog box opens. Select the set of saved import options to change.

Click to show/hide the parameters.

3. Click OK to close the Saved Settings dialog box. Click OK again to close the import options dialog box.
~~~~~~~~~~~~~~~~~~~~~~~~~
DXF/DWG and DWF Import Options

DXF/DWG and DWF Items Which Cannot Import to Vectorworks
Certain DXF/DWG and DWF items have no equivalent in a Vectorworks file and cannot be imported. A few other 
objects theoretically could be imported, but the Vectorworks program does not currently support them.

• Named views
• Textures
• Lights
• rtext
• SHX fonts
• User coordinate systems (UCS)
• Custom line styles and shape files
• DXF groups (named selection sets, not the same as Vectorworks groups)
• Certain objects from industry-specific variations of AutoCAD, if those objects do not have proxy graphics saved 

in the file. AEC objects that were created with AutoCAD Architecture can be imported as groups of 2D or 3D 
objects, depending on how you import; for example, a door imported from a DWG file with a 3D view is 
converted to a group of 3D mesh objects in a Vectorworks file.

~~~~~~~~~~~~~~~~~~~~~~~~~
DXF/DWG and DWF Import Options

Parameter Description

Rename Select and enter a new name for the set of options. If the entered name is already assigned to 
another set of options, you are prompted to confirm that you want to replace the existing set with 
the set being saved.

Delete Select to delete the set of options. You are prompted to confirm that you want to delete the saved 
settings.
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DXF/DWG and DWF File Export
Consider the following points when exporting from a Vectorworks file to DXF/DWG or DWF.

Item Export Notes

Linked Text Linked text in symbols export as block attributes.
Symbols, Plug-ins, Layer 
Links, and Groups

Symbols, plug-ins, layer links, and groups export as blocks. Blocks for symbols, 
plug-ins, and layer links are given a generic name such as “Group-2” unless they were 
named in the Data tab of the Object Info palette. By default, groups also are exported as 
named blocks, but there is an option to export them as anonymous blocks.

Line Weights By default, line weights are converted to the closest DXF line weight. If the color 
mapping option is used, mapping information is entered during export and written to 
a .ctb file.

Fills, Patterns, Gradients, 
and Hatches

Solid fills and patterns export as DXF objects with associated solid hatch or 
unassociative wipeout. Wipeouts are only available in version 2000 and later. Hatches 
export as associative hatches to AutoCAD version 14 and higher, or as anonymous 
blocks to AutoCAD version 13 and lower. There is an option to export all of the fills, 
patterns, gradients, and hatches within a class or layer to a separate DXF layer.

Raster Images Raster images export to the same folder that the drawing and any hatch pattern files are 
exported to. They export as JPEG files, with an image object in the DXF/DWG file that 
stores the name of the JPEG file and the insertion point. Images are only supported in 
AutoCAD versions 14 and higher.

Solids and NURBS 
Surfaces

Solids and NURBS surfaces typically export as ACIS objects. The following objects 
cannot be exported as ACIS objects: meshes (which export as DXF meshes), 3D 
polygons (which export as 3D polygons, or as triangles if filled), NURBS curves 
(which export as DXF splines), and walls (which export as triangulated 3D polys in 3D 
views, and as lines and arcs in 2D views).

Page-based symbols, 
world-based symbols

Page-based symbols are typically used for annotation, and export as annotative blocks 
with the annotative property set to “true.” World-based symbols export as blocks with 
the annotative property set to “false.”
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Preparing to Export
DXF/DWG and DWF Export Procedure
DXF/DWG and DWF Export Options
DXF/DWG and DWF File Formats

Design Layers, Sheet 
Layers, and Viewports

• Vectorworks design layers export as DXF model space entities. If only design layers 
(no sheet layers) are exported, individual design layers’ scales and views are 
exported to model space as one scale and view. There is an option to export all of the 
design layers in a file as separate DXF/DWG or DWF files.

• By default, each design layer viewport (Vectorworks Design Series required) is 
exported to a referenced DWG file; cropped viewports become clipped referenced 
files, and nested viewports become nested referenced files. This preserves the 
visibility overrides from the original viewport, because the visibility of the layers in 
the referenced file can be controlled separately from the layers in the master file. 
There is an option to export design layer viewports as part of the master document 
instead.

• By default, Vectorworks sheet layers export as DXF paper space layouts, with 
normal viewports exported directly, and section viewports exported as blocks. 
Annotations become paper space objects on top of the viewports. AutoCAD requires 
all paper space objects to be either above or below the viewports, but not both, so any 
objects or annotations that appear below the viewports in the Vectorworks file will 
appear above the viewports in the AutoCAD file. Therefore, avoid putting anything 
underneath viewports in your Vectorworks files.

• If sheet layers are exported, all design layers referenced from viewports on the sheet 
layers are exported to model space in top view without scaling, and viewports are 
created in paper space layouts to show the various views and scales. Sheets should 
generally look and print as expected (though without rendering modes set due to 
some AutoCAD bugs), but the single model space may have many overlapping 
objects and may not be as usable. There is an option to export the selected sheet 
layers as separate DXF/DWG files. In addition, there is an option to export sheet 
layer viewports as 2D graphics to model space (each layer as a separate file).

• Since AutoCAD has only one model space, and it does not have hybrid 2D/3D 
objects, it is sometimes necessary for the Vectorworks program to export the design 
layers as one or more blocks with special DXF layer names to control the block 
visibility. For example, a design layer called “Foundation” might export as blocks 
named “Foundation (2D)” and “Foundation (3D),” with associated DXF layers 
named “_Foundation (2D)” and “_Foundation (3D).” The blocks will be inserted in 
model space and assigned to those DXF layers. Viewports that should hide either the 
2D or 3D objects will freeze or thaw the appropriate DXF layer.

• When you export sheet layers, the Vectorworks program optimizes the translation to 
preserve the look of the sheets, at the cost of possibly adding some complexity and 
decreasing the ease of editing items in model space. To minimize the complexity, 
export sheets with unrelated design layers as separate files, or limit the drawing to 
one Vectorworks design layer.

Item Export Notes



  1732 | DXF/DWG and DWF File Export
Preparing to Export
The following procedures are recommended to help ensure a satisfactory translation.

1. Export behaves differently based on whether design layers or sheet layers are selected for export.
• If one or more sheets are selected for export, a paper space layout is exported for each sheet with the sheet 

objects; any design layers visible in sheet layer viewports are exported to model space. (Sheets that do not 
share design layers should usually be exported to separate files.) Other sheet layers and unreferenced design 
layers are omitted from export.

• If only design layers are selected for export, the design layers are exported to model space and all sheet layers 
are omitted. If the design layers are exported to a single file, only the visible layers are exported; if the layers 
are exported to separate files, all layers are exported.

2. AutoCAD does not have multiple model spaces. If the sheet layer being exported has multiple viewports at 
different scales, the model space may have overlapping objects from the design layers, and the scale will be set to 
1:1 instead of the expected design layer scale(s). To avoid this problem, set the scale the same for all design layers, 
and make sure that no objects overlap. Then, adjust the viewport scales as desired.

3. Do not export design layers in perspective, as they will not be in perspective in the DXF/DWG file. Instead, create 
a sheet layer with a viewport set to perspective view.

4. For DXF/DWG versions earlier than 14, object fills will not export. To better approximate the appearance of the 
exported file for these versions, remove all fills in a copy of the file before export. This will help identify lines 
under solid fills that need to be deleted or trimmed when the solid fill is removed.
DXF/DWG versions 14 and later support associative boundary hatches, or “bhatches.” Therefore, fills, solid fills, 
and hatches can be exported as follows.

5. Set the class and layer visibility appropriately. If invisible Vectorworks layers are exported as DXF/DWG layers, 
objects in invisible classes will not be exported, and vice versa. To preview what will be exported, set classes to 
“show/snap/modify others” and layers to “show others.”

Vectorworks Entity DXF/DWG Entity

Associative hatch definition Select Export Hatches to create a bhatch definition; also select 
Export Hatch Pattern Files to export a hatch pattern file (.pat) 
along with the DXF/DWG file

Hatch with multiple colors or with background 
fill

Select Export Hatches to create multiple bhatch definitions; 
also select Export Hatch Pattern Files to export multiple 
hatch pattern files (.pat) along with the DXF/DWG file

Filled polygon with three or four sides, with the 
fill color different from the background color

Select Export 2D Fills to create a “solid” entity

Object with a solid fill (color different from 
background color) or hatch 

Select Export 2D Fills to create an object with associated 
bhatch

Object with a solid fill (color same as 
background color)

Select Export 2D Fills to create one of the following:
• Wipeout entity (AC2000 and later)
• No fill (AC14 and earlier)
• Light gray bhatch (AC14)

Filled polyline with one or more holes Select Export 2D Fills or Export Hatches (depending on the 
Vectorworks fill) to create multiple objects and an associated 
bhatch definition with island detection
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6. DXF/DWG does not support hybrid objects. If only design layers are being exported, set the view for each design 
layer so the appropriate 2D or 3D components are exported. From Plan view, the 2D component of a hybrid 
symbol is exported; from Top view or any 3D view, the 3D component is exported. To preserve the 3D object 
coordinates, use Top view to export all 3D design layers (or use viewports to show other views, and export the 
sheets containing those viewports). Ensure that the option Export as Flattened 2D Graphics is not selected if 
you want to export 3D coordinates.

7. Symbols, plug-in objects, and layer links export as named blocks in DXF/DWG. Groups can be exported as either 
named blocks or anonymous blocks.
The name that these items receive depends on the view that is in effect upon export. As an example, the symbol 
“Widget” would receive the following names, depending on the view:

The assigned layer link depends on whether Project 2D was selected for the layer link.
 

To check the item names, re-import an exported file into a Vectorworks file.
8. Check the drawing with both black and white backgrounds. If the Vectorworks file has a white background and 

uses a dark (but not black) color to draw objects, then others who look at the exported file with a black background 
may not be able to see the objects.

9. Set the 2D and 3D conversion resolutions (in the Vectorworks preferences) to a low value if file size is a concern. 
Higher resolutions result in larger exported file sizes. Lower resolutions decrease file sizes, but can result in 
blockiness, especially when exporting to earlier versions of DXF/DWG.

~~~~~~~~~~~~~~~~~~~~~~~~~
DXF/DWG and DWF Export Procedure
DXF/DWG and DWF Export Options
DXF/DWG and DWF File Formats

DXF/DWG and DWF Export Procedure
You can export a single DXF/DWG or DWF file, or export several files as a batch.
It is frequently helpful to view the translated file in a third-party software program to ensure that the translation process 
did not introduce unwanted effects. After export, leave the file open and import the exported file back into a 
Vectorworks file or into another software package. Compare the two versions, noting any problems. For example, the 
loss of object fills in earlier versions of DXF/DWG can cause unwanted lines to display. Correct these problems in a 
copy of the Vectorworks file and export the file again. Export options can be saved as a set.

Do not change the file extension of the exported file, or other software packages will not be able to read the file. 
Do not export as binary DXF unless you are certain that the recipient will be able to read this format.

Symbol Type and View Exported Block Name

Hybrid symbol in Plan view Widget (2D)
Hybrid symbol in 3D view Widget (3D)
Non-hybrid symbol Widget

Layer Link Option Exported Block Name

Layer link in plan view with Project 2D option selected Layer-1 (2D)
All other layer links Layer-1 (3D)
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AutoCAD users may report that circles and other objects look like blocky polygons. They can improve the 
appearance of the drawing by zooming in and using either the “regenall” or “regen” command, or by increasing 
the VIEWRES value.

Exporting a Single DXF/DWG or DWF File
1. Select File > Export > Export DXF/DWG or File > Export > Export DWF.

Either the DXF DWG Export Options or the DWF Export Options dialog box opens, depending on your selection. 
The dialog boxes are very similar, except for the file format settings. 

2. Select the appropriate export options, and click OK to export the file.
The export dialog box options are described in “DXF/DWG and DWF Export Options” on page 1734. During the 
export, a progress bar displays, along with the number of objects processed.

Exporting DXF/DWG or DWF Files as a Batch
Use the Publish command to export a series of sheet layers and/or saved views from the current drawing and 
externally-referenced files to DXF/DWG or DWF format. See “Batch Publishing” on page 1765.
~~~~~~~~~~~~~~~~~~~~~~~~~
DXF/DWG and DWF Export Options
Batch Publishing

DXF/DWG and DWF Export Options
The DXF/DWG Export Options dialog box and the DWF Export Options dialog box are very similar, except for the file 
format settings. This is because when you export to DWF, the drawing objects are first converted to DXF/DWG, and 
then output in DWF format. Change the export options as needed to retain the integrity of the Vectorworks drawings in 
the DXF/DWG format. The same export options display for export of single files and batches of files.
To make custom exports faster and easier, save the sets of options that you use frequently.
Click to show/hide the parameters.

Parameter Description

Saved Settings Options
Settings Select <Active Settings> to use the export options currently selected in the dialog box; 

to use a set of saved export options, select them from the list
Save Opens a dialog box to name and save the currently selected export options so that they 

can quickly be selected as a set
Manage Opens the Saved Settings dialog box to rename or delete sets of saved export options 

(see “Managing Saved Export Options” on page 1741)
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File Format
Format DXF/DWG export:

• Choose from three exported file formats: DXF as plain text, DXF as a binary 
encoding, and DWG.

• One of the main differences between these formats is file size. Although individual 
files can vary, an uncompressed text DXF file is generally larger than an 
uncompressed DWG file. However, the file size can be significantly reduced by 
using a compression utility. A compressed text DXF file is normally smaller than a 
compressed DWG file. Binary DXF file sizes generally fall between the two for both 
compressed and uncompressed files.

• In addition to file size, consider the formats that other applications can support. 
Before exporting to binary DXF or to DWG, ensure that the receiving party’s 
software can read those formats. Since binary and text DXF both use the same .dxf 
extension, if the DXF file cannot be opened, it may be may be mistakenly considered 
corrupted. When in doubt, export as text DXF, which is universally supported.

• Recent versions of AutoCAD have bugs when reading some DXF files, such as 
losing links to images, so DWG is usually a safer choice in that situation.

• DXB is a simpler file format used by some third-party applications that do not 
support the full DXF or DWG file format. It is not the same as binary DXF; do not 
use .dxb as the extension for binary DXF files. The Vectorworks program does not 
support DXB.

DWF export:
• Choose from five file formats: DWF as plain text, DWF as a regular or compressed 

binary encoding, 3D DWF, or DWFx.
Version For best results, export to the highest version supported by the recipient’s software, or 

the default export version, whichever is lower. The latest versions of DXF/DWG and 
DWF have features more similar to the Vectorworks program and may provide a better 
translation, but not all software packages can read the latest versions. When in doubt, 
export as DXF and version 12, which has widespread industry support.
Other options on the dialog box can change or become unavailable depending on the 
version selected.

Class/Layer Conversions
Export as DXF/DWG 
Layers

This option is available if the Export option is set to Design Layers Only.
Since Vectorworks classes correspond most closely to DXF/DWG layers, normally, the 
Classes option is recommended. There is no direct equivalent for Vectorworks layers in 
DXF/DWG. A single Vectorworks design layer is similar to DXF “model space.”
This is most important for the import of groups and symbols. In a Vectorworks file, the 
objects in groups and symbols can belong to different classes, but they must be on the 
same layer. In a DXF/DWG file, the entities equivalent to Vectorworks symbols and 
groups (known as “blocks”) can be on different DXF/DWG layers.
Layers normally do not export relative to the Elevation value shown in the Design 
Layers tab of the Organization dialog box.

Parameter Description
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Invisible Classes/
Layers Are

DXF/DWG export:
While a Vectorworks file organizes drawings by class and by layer, the DXF/DWG file 
format only has layers. The following description assumes that, as recommended, 
classes are selected for export as layers. (If instead Vectorworks layers are selected for 
export as DXF layers, equivalent options are presented for the layers.)
Select whether to export invisible classes or layers. If Exported As Invisible DXF/
DWG Layers is selected, objects that are in invisible classes in the Vectorworks file 
are exported, and can be seen by making the DXF/DWG layer visible. This is the 
recommended option. However, if invisible classes contain private information or if the 
size of the exported file needs to be reduced, select Not Exported to delete these.

If invisible classes are exported as DXF layers, objects on invisible Vectorworks 
layers are not exported. To export these items, first make the layers visible, and 
then select the Export command.

DWF export:
This option is unavailable; only visible graphics can be exported to DWF.

Export Layers as 
Separate Files

• For single file export, select this option to export the selected sheet layers or design 
layers to separate DXF/DWG or DWF files (named after the original layer); 
otherwise, the selected layers are exported to one file.
This option is unavailable if the Export option is set to Design Layers Only, and 
Export As DXF/DWG Layers is set to Layers. Additionally, DWF versions 4.2 and 
5.5 do not support multiple sheets, so this option is unavailable if multiple sheet 
layers are selected for export to one of these versions.

All design layers are exported, including those that are set to be invisible. 
• For batch file export, this setting is ignored; each sheet layer is always exported as a 

separate file.
Layer Scale

Rescale Layers To When the Export option is set to Design Layers Only, paper space is not used; all items 
are placed in model space. Model space must be at one scale; DXF/DWG files do not 
have different layer scales. If the layers to be exported are at various scales, the option 
to rescale them to a common scale before export becomes available. By default, the 
most frequently used layer scale will be used.
Choosing the best scale for export is important. Select Rescale Layers To and click the 
common scale to use from the displayed list.
Symbols on rescaled layers are exported as scaled blocks in the DXF/DWG file.
When sheets are selected for export, all design layers export to model space at 
effectively a 1:1 scale, and viewports take care of showing the objects at other scales.

Parameter Description
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Sheets to Include
Export The options on this list change depending on the contents of the file being exported and 

on which export Version is selected.
Select the items to export from the list. By default, the selected layers are exported to a 
single file (to export multiple files instead, select Export Layers As Separate Files).
• If Design Layers Only is selected, you can select either classes or layers to Export 

as DXF/DWG Layers. If you export the design layers as DXF layers, you cannot 
select Export Layers As Separate Files. Additionally, you have the option to 
Export as Flattened 2D Graphics when you export design layers only.

• If one of the sheet options is selected, the selected sheet layers are exported as paper 
space layouts; also, design layers used in viewports are exported to model space. 
While multiple sheets can be exported to the same file, note that unrelated sheets 
usually should be exported to different files. Select the sheets from the list below.

• If one of the saved view options is selected, saved views are each exported as 
separate files. Select the views from the list below.

Export Viewports as 
2D Graphics in Model 
Space

If one of the sheet options is selected, select this option to export all 2D and 3D objects 
that display inside a viewport as 2D projected (flattened) graphics in model space. Each 
selected sheet is exported to a separate file. On re-import, all exported graphics are 
imported into a design layer.
• Rendered viewports in any view other than Top/Plan view are exported as groups.
• Non-rendered viewports in an orthogonal view (Top, Bottom, Front, Back, Left, and 

Right) are set to hidden line rendering and then exported as groups.
• Non-rendered viewports in an isometric view (including custom views) are 

converted to lines before export.
• Section viewports are exported as groups.
• Viewport annotations are extracted from the viewport groups and exported as single 

entities.
• All other sheet layer graphics (such as title blocks) are exported as single entities.

Sheets or View Name If Selected Sheets or Selected Saved Views is selected as the Export option, select the 
sheets or saved views to export from the displayed list.

References
Export Design Layer 
Viewports as Separate 
Files
(Vectorworks Design 
Series required)

Select this option to export each design layer viewport as a separate DXF/DWG file, 
named with the viewport name. If deselected, design layer viewports are bound into the 
master DXF/DWG file; this may cause the viewport objects to look different, because 
class and layer visibility overrides are not retained. This option is available only for 
DXF/DWG export.

Objects
Export Only Selected 
Objects

Select this option to export only the objects that are currently selected in the drawing; 
this option is unavailable if no objects are selected

Export as Flattened 
2D Graphics

If you are exporting design layers only, select this option to export all of the objects 
from the current design layer as flattened 2D graphics

Parameter Description
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Text
Preserve Mapped Font 
on Export

If the file contains text that has been mapped to a different font, select this option to 
export the text with the replacement font; if the option is disabled, the text is exported 
with the original font

2D Fills and Files
Export 2D Fills Select this option to export solid fills as wipeouts (DXF/DWG versions 2000 and later) 

or solid hatches (DXF/DWG version 14 and later). If Export Images and Image Files 
is enabled, image fills export as clipped images; if the option is disabled, image fills 
export as solid fills.

Export Images and 
Image Files

Select this option to export image objects and image files. If this option is disabled, 
objects with image fills export as objects with solid fills. This option is only enabled for 
DXF/DWG versions 2000 or higher.

Export Hatches Select this option to export Vectorworks hatches as bhatches; no hatch pattern files are 
created unless Export Hatch Pattern Files is also selected

Export Hatch Pattern 
Files

If Export Hatches is enabled, select this option to create additional hatch pattern (.pat) 
files in a specified folder. A Vectorworks hatch with multiple levels and colors 
generates multiple hatch pattern definitions. See “Preparing to Export” on page 1732 
for more information on the conversion.
The hatch pattern files, and the DXF/DWG exported file and any support files, such 
as .jpg images, are placed in this folder. AutoCAD requires the hatch pattern files to 
retain the hatch associativity and to add hatches to additional objects with the same 
hatch pattern. When Export Hatch Pattern Files is disabled, AutoCAD displays the 
hatch but cannot edit it.
This option is unavailable during DWF export.

Export Hatches and 
2D Fills into Separate 
DXF/DWG Layers

Select this option to export all of the fills, patterns, gradients, and hatches within a class 
(or design layer, if layers are exported to DXF/DWG layers) to a separate DXF/DWG 
layer. The DXF/DWG layers are named after the original class or layer that contains 
the object to which the fill, pattern, gradient, or hatch is applied. For example, if the 
Vectorworks file has an object on the “Hardscape” layer with a hatch applied to it, the 
export file will have a layer called “Hardscape_Hatch.”

3D
Export Solids as ACIS 
Solids

Select this option to export most Vectorworks solids and NURBS surfaces as ACIS 
objects. Deselect this option to export solids as polygonal faces (if the target software 
package cannot read ACIS solids, for example).
Walls, round walls, roof and floor slabs, filled 3D polygons, meshes, and NURBS 
curves cannot be exported as ACIS solids.
This option is unavailable during DWF export.

Parameter Description
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Triangulate to 
Preserve Fills

Some software packages, such as AutoCAD, are not capable of rendering exported 3D 
surfaces that have more than three or four vertices per face. Select this option to break 
up such faces into a set of triangles that can be properly rendered. The algorithm used 
works best on planar or nearly planar surfaces, such as the top of an extruded circle.
Even if Export Solids as ACIS Solids is selected, this option may be used to handle 
3D objects that cannot be exported as ACIS solids.
When in doubt, select this option (this increases the exported file size and the time 
necessary to export it, and may result in unwanted lines in some cases).

Symbols and Groups
Decompose 3D 
Symbols and Groups

Some software packages cannot handle exported groups and symbols. If a problem 
occurs, select Decompose 3D Symbols and Groups to convert symbols and groups to 
ungrouped objects. Do not select this option unless it is absolutely necessary.
This option is unavailable during DWF export.

Export Groups as 
Anonymous Blocks

Normally, Vectorworks groups are exported as named blocks, which can be opened and 
edited in other software packages. However, the named blocks are imported back into 
Vectorworks files as symbols. If this creates a problem, select Export Groups as 
Anonymous Blocks, which are imported back into Vectorworks files as groups.
This option is unavailable during DWF export.

Dimensions
Preserve SIA 
Dimension Text 
Appearance

Select this option to maintain the SIA dimension superscript formatting upon export. 
Dimensions are converted to non-interactive objects.
Deselect this option to change the SIA dimensions to a non-superscript dimension 
format.

Line Types
Export Complex Line 
Types as Blocks

Select this option to export complex Vectorworks line types as anonymous blocks, 
which preserves the exact appearance of the drawing. If the option is disabled, complex 
line types export as true line types, and additional graphic information is compiled into 
a shape file (.shx).

Line Weights and Colors
Use True Colors Exports line colors with the Vectorworks RGB values, and converts line weights to the 

closest possible DXF/DWG weight value. Named Vectorworks colors export as named 
DXF/DWG true colors.
• For DXF/DWG versions prior to version 2000, line weights are not supported, and 

this option should not be selected; select Use DXF/DWG Indexed Colors and Map 
Line Weights to Colors instead.

• For DXF/DWG version 2000 and later, select this option only if the exported file 
will not be used with a .ctb file for plotting or printing in AutoCAD. If the exported 
file is intended to be used with a .ctb file later on, select Use DXF/DWG Indexed 
Colors instead.

Parameter Description
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Line Weight Conversions

Use DXF/DWG 
Indexed Colors

Exports line colors with DXF/DWG indexed color values, and converts line weights to 
the closest possible DXF/DWG weight value.
Unlike Use True Colors, this option allows you to use the exported file with a .ctb file 
for plotting or printing in AutoCAD. You can either use a predefined .ctb file, or select 
Map Line Weights to Colors to create a .ctb file specific to this drawing upon export.

Map Line Weights to 
Colors

If Use DXF/DWG Indexed Colors is selected, this additional option creates a .ctb file 
for each exported DXF/DWG file (named after the original .vwx file) to be used during 
plotting or printing in AutoCAD. The AutoCAD user must put this file in the support 
path, as AutoCAD does not read the .ctb file when it is simply included in the same 
folder as the DXF/DWG file.
During the export process, a list of line weights in the file displays. Specify the color to 
map to each of these line weights. To select a different color for a selected line weight, 
click the color box and select a color from the displayed options.

If Export Layers As Separate Files is also selected, the mapping dialog box does 
not display; instead, the Vectorworks program automatically maps line weights to 
colors according to a predefined standard.
To avoid having a color table file for each exported file, use a single .ctb file for 
each unique set of mappings, and delete the others. When an exported file is 
opened in AutoCAD, edit the page setup and choose an appropriate color table 
file.

When you import the file back into the Vectorworks program, use the reverse process 
to convert the colors back to line weights.

VW Line 
Weight (mm)

DXF Line 
Weight (mm)

VW Line 
Weight (mm)

DXF Line 
Weight (mm)

0 Deleted 0.52 - 0.56 0.53
0.01 - 0.07 0.05 0.57 - 0.65 0.60
0.08 - 0.11 0.09 0.66 - 0.75 0.70
0.12 - 0.14 0.13 0.76 - 0.85 0.80
0.15 - 0.16 0.15 0.86 - 0.95 0.90
0.17 - 0.19 0.18 0.96 - 1.03 1.00
0.20 - 0.22 0.20 1.04 - 1.13 1.06
0.23 - 0.27 0.25 1.14 - 1.30 1.20
0.28 - 0.32 0.30 1.31 - 1.49 1.40
0.33 - 0.37 0.35 1.50 - 1.75 1.58
0.38 - 0.45 0.40 1.76 - 2.05 2.00
0.46 - 0.51 0.50 2.06 - 6.48 2.11

Parameter Description
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Managing Saved Export Options
If you have saved a set of export options, use the Manage button on the DXF DWG Export Options (or DWF Export 
Options) dialog box to rename or delete these saved settings when needed.
To manage saved DXF/DWG or DWF export settings:

1. Select File > Export > Export DXF/DWG (or Export DWF). The appropriate export options dialog box opens.
2. Click Manage.

The Saved Settings dialog box opens. Select the set of saved export options to change.
Click to show/hide the parameters.

3. Click OK to close the Saved Settings dialog box. Click OK again to close the export options dialog box.
~~~~~~~~~~~~~~~~~~~~~~~~~
DXF/DWG and DWF Export Options

Items Which Cannot Export to DXF/DWG or DWF
Certain Vectorworks items have no equivalent in DXF/DWG or DWF and therefore cannot be exported. Other items 
could be exported, but inadequate support in AutoCAD makes it inadvisable to do so. A few objects (such as 
worksheets) could in theory be exported to something useful, but the Vectorworks program currently lacks support for 
doing so.
The following list includes items that do not export to DXF/DWG or DWF, for various reasons.

Parameter Description

Rename Select and enter a new name for the set of options. If the entered name is already assigned to 
another set of options, you are prompted to confirm that you want to replace the existing set with 
the set being saved.

Delete Select to delete the set of options. You are prompted to confirm that you want to delete the saved 
settings.

• Textures • Record format information attached to arbitrary objects

• Lights • Design layers with perspective views

• Image props • Oblique cavalier and oblique cabinet projections

• Individual layer scales • Object names attached to arbitrary objects

• EPS or vector PICTs in some cases • Layer transfer modes other than Paint

• “Graying” of layers and classes • Depending on the export options, either layers or classes

• Renderworks background images
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IFC Format Interoperability
IFC Overview
The Vectorworks Architect and Landmark products support Building Information Model (BIM) interoperability using 
the Industry Foundation Classes (IFC) data specification and file formats. Vectorworks currently supports versions 2x2 
and 2x3 and is certified by buildingSMART International for the export of models based on the IFC2x3 Coordination 
View 2.0 – Architecture model view definition, as well as import of any IFC2x3 Coordination View 2.0 model.
IFC is an open standard, developed and maintained by buildingSMART International, for building data that permits 
information to be shared and maintained throughout the life cycle of the construction project: design, analysis, 
specification, fabrication, construction, and occupancy.
The capabilities and usage for IFC data standards are still evolving. However, objects and models containing IFC data 
have been proven to be a useful part of the design process. Some examples of the use of IFC data include:

• Collaborative design, where an architect exports an architectural model to a structural engineer for analysis and 
design, and then imports the structural model, in an IFC format, for coordination purposes

• Energy performance simulation and analysis of a building envelope and systems
• Automated analysis of code compliance
• Space planning and space inventory analysis

Central to the concept of IFC is the idea of “semantic objects.” Like Vectorworks plug-in objects, IFC objects are more 
than just collections of geometry; they have a meaning within the building fabric itself, be it as a door, a wall, a 
window, or a handrail. The following Vectorworks plug-in objects have default IFC2x3 object types and properties 
assigned, but they may be edited by the user as necessary. These Vectorworks plug-in objects are automatically 
converted upon export to the corresponding IFC object types shown. Additionally, most content in the Vectorworks 
Architect, Landmark, and Designer symbol libraries has default IFC2x3 object types and properties assigned, but 
symbols may be edited by the user, as necessary, and are automatically converted upon export.

Base Cabinet [IfcFurnishingElement] Bath-Shower [IfcFlowTerminal]

Ceiling Grid [IfcCovering] Clothes Rod [IfcFurnishingElement]

Column [IfcColumn] Comm Device [IfcDistributionFlowElement]

Compartment Sink [IfcFlowTerminal] Counter Top [IfcFurnishingElement]

Curtain Wall (Straight & Curved) [IfcCurtainWall] Curtain Wall Frames [ifcMember]

Curtain Wall Panels [IfcPlate] Desk [IfcFurnishingElement]

Door [IfcDoor] Drilled Footing [IfcFooting]

Simple Elevator [IfcTransportElement] Escalator [IfcTransportElement]

Fireplace [IfcDistributionFlowElement] Floor [IfcSlab]

Framing Member [IfcMember or IfcBeam] Grab Bars [IfcRailing]

Guardrail (Curved & Straight) [IfcRailing] Handrail (Curved & Straight) [IfcRailing]

HVAC Damper [IfcDistributionFlowElement] HVAC Diffuser [IfcDistributionFlowElement]

HVAC Elbow Duct [IfcDistributionFlowElement] HVAC Flex Duct [IfcDistributionFlowElement]

HVAC Outlet [IfcDistributionFlowElement] HVAC Splitter [IfcDistributionFlowElement]

HVAC Straight Duct [IfcDistributionFlowElement] HVAC Transition [IfcDistributionFlowElement]

HVAC Vertical Duct [IfcDistributionFlowElement] HVAC Vertical Elbow [IfcDistributionFlowElement]
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With the IFC Data command, users can assign object types and properties to arbitrary collections of geometry so that 
other applications that use these IFC files can identify these objects.
When an IFC file is imported into a Vectorworks file, IfcSpace objects are translated into the corresponding 
Vectorworks Space object. Since the properties of other objects cannot easily be matched to all the corresponding 
Vectorworks object properties and controlling parameters, the objects are imported into the Vectorworks file as a 
particular and flexible kind of plug-in object: an “IFC Entity.” The semantic definition of the IFC Entity—IfcColumn, 
IfcWall, IfcWindow, for example—is maintained and displayed. Like a group or symbol, an IFC Entity can contain an 
arbitrary collection of geometry, usually generic or constructive solid (CSG), but like a plug-in object, it can be inserted 
into walls and has sets of data and properties attached. With this generalized import capability, the Vectorworks 
program can import any kind of object supported by the IFC data standard, regardless of whether it has a corresponding 
parametric plug-in object.

Click here for a video tip about this topic (Internet access required).
~~~~~~~~~~~~~~~~~~~~~~~~~
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Incandescent Fixture [IfcDistributionFlowElement] Landscape Wall (including Arc and Bezier) [IfcWall]

Massing Model (on layer mapped to site) [IfcBuilding] Mullion [IfcMember]

Parking Spaces [IfcSpace] Pilaster [IfcColumn]

Pillar [IfcColumn] Piping Run [IfcDistributionFlowElement]

Plant [IfcBuildingElementProxy] Ramp [IfcRamp]

Receptacle [IfcDistributionFlowElement] Roadway (all types) [IfcTransportElement]

Roof [IfcRoof containing instances of IfcSlab] Roof Face [IfcSlab]

Seating Layout [IfcFurnishingElement] Round Wall [IfcWall or IfcWallStandardCase]

Wall [IfcWall or IfcWallStandardCase] Site Model [IfcSite]

Shelving Unit [IfcFurnishingElement] Slab [IfcSlab]

Space [IfcSpace] Stair (including Simple and Custom) [IfcStair]

Switch [IfcDistributionFlowElement] Table [IfcFurnishingElement]

Tables and Chairs [IfcFurnishingElement] Toilet Fixture [IfcFlowTerminal]

Utility Cabinet [IfcFurnishing Element] Wall Cabinet [IfcFurnishingElement]

Window [IfcWindow] Workstation Counter [IfcFurnishingElement]

Workstation Overhead [IfcFurnishingElement] Workstation Panel [IfcFurnishingElement]

Workstation Pedestal [IfcFurnishingElement]

http://www.youtube.com/watch?v=aL34US0OOeo
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IFC Workflows
Generally, IFC-compatible applications are set up to work with an entire project (sites with buildings consisting of 
stories) in a single file. When you use the Export IFC Project command, you assign design layers to building stories 
for meaningful export (Vectorworks Architect required). For a project initially set up with stories, mapping is done 
automatically so that the layers assigned to the building stories are automatically included in the Mapped Layers list 
and are mapped to an appropriately named IFC Story. Mapping can also be controlled manually, allowing you to 
override or edit the automated process or make any subsequent changes. The Import IFC command automatically 
assigns IFC building stories to their own design layers.
To make Vectorworks building models easy to export to IFC, the following guidelines may be useful:

• Set up the project initially with stories as described in “Setting Up the Building Structure with Stories” on 
page 172 (Vectorworks Architect required).

• Design layers for the building model should correspond to building stories (Vectorworks Architect required), not 
categories of information. (Use classes for categorization.)

• Take care to set up the elevation values of layers correctly, and verify that all the objects in the drawing are aligned 
correctly vertically. Examining the project in Unified View mode makes this much easier.

• Use standard Vectorworks plug-in objects listed in “IFC Format Interoperability” on page 1743 wherever possible.
• Use the IFC Data command to attach IFC data to custom user-defined hybrid or 3D symbols, custom 3D 

elements, or auto-hybrid objects, so that they will be recognized at IFC export.
• Use the VA Create Schedule command (Vectorworks Architect required) to generate default IFC schedules, or 

create your own schedules to verify and correct the IFC data attached to objects. See “Records and Schedules” on 
page 1859.

• Test the quality of the IFC export file by verifying it in an IFC model viewer. Almost all IFC viewers can traverse 
the IFC hierarchical “tree” structure to view and validate the model. Some examples of IFC viewers available at 
this time include:
• Solibri Model Viewer (Macintosh or Windows)
• FZKViewer (Windows)
• DDS-CAD Viewer (Windows)
• Tekla BIMsight (Windows) 
• Constructivity Model Viewer (Windows)
• RDF IFC Viewer (Windows; Macintosh and Linux versions planned)
• Field 3D (iOS)
• IFC WebServer (web browser)
• xBIM Xplorer (Windows)
• IfcPlusPlus (Windows)
For more information about additional available IFC viewers and other IFC-compatible applications, visit the 
buildingSMART IFC-Compatible Implementations Database website or IfcWiki.org.

• If you receive comments or corrections for the project in BIM Collaboration Format (BCF), use the Open BCF 
Viewer command to view the notes, and then correct the project file as needed.

~~~~~~~~~~~~~~~~~~~~~~~~~
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http://www.buildingsmart-tech.org/implementation/implementations/allplominoform.application
http://www.solibri.com/solibri-model-viewer.html
http://www.ifcwiki.org
http://www.iai.fzk.de/www-extern/index.php?id=1931&L=1
http://www.dds-cad.net/132x2x0.xhtml
http://www.teklabimsight.com
http://www.constructivity.com/cmviewer.htm
http://rdf.bg/ifc-viewer.php
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Assigning IFC Data to Objects
When a building project is exported to an IFC file, Vectorworks plug-in objects and pre-assigned symbols are 
automatically assigned to IFC entities. Simple hybrid or 3D geometric objects, unless they receive IFC assignments, 
are not exported. To be exported, these object associations must be made prior to export with the IFC Data command. 
Assigning IFC data to an object does not alter it in any visible way. The object can still be edited with standard 
Vectorworks tools and commands. An example of this would be to use a floor or slab object to model a flat ceiling. 
Select the floor or slab in the model, and then select the IFC Data command. From the list in the Select IFC Entity 
dialog box, select IfcCovering, the correct assignment for a ceiling. Then, in the IFC Data dialog box, select CEILING 
from the PredefinedType list in the Properties for the selected Data Set lists.

The IFC Zones command attaches IFC data to space zones. See “Assigning IFC Data to Space Zones” on 
page 1748.

An object can also be “wrapped” in a container so that it is identified in the Vectorworks file as an IFC Entity object. 
Editing an IFC Entity is less direct than editing simple Vectorworks objects with IFC data attached. For this reason, an 
IFC Entity can be useful for model elements that need to be secured from casual changes.
To assign IFC data:

1. Select the object, group, symbol instance, or symbol definition for assignment of IFC data. More than one item 
can be selected at one time.
IFC data applied to symbol instances affect only the selected instances, not all instances. To attach IFC data to 
symbol definitions, select the symbol definition in the Resource Browser. Right-click (Windows) or Ctrl-click 
(Macintosh) on the symbol and select IFC Data from the context menu. This attaches the IFC data to future 
symbol placements, and to any current instances that do not have IFC data already attached to them.

2. Select the IFC Data command from the appropriate menu:
• Architect workspace: AEC > IFC Data 
• Landmark workspace: Landmark > Architectural > IFC Data
Alternatively, select Show IFC Data from the Coordinate/IFC menu on the Object Info palette to enable 
IFC-related information display on the palette, and then click IFC Data from the Object Info palette.

The Select IFC Entity dialog box opens, listing available IFC object types.
Click to show/hide the parameters.

Object Info palette 
Coordinate/IFC menu

IFC Data button
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3. Select the object type and click OK.
The IFC Data dialog box opens.

Click to show/hide the parameters.

4. Click OK to assign the IFC data to the object, or create the IFC entity. The Object Info palette displays the 
selected IFC object or entity information (IFC value type and the object name, if any) when Show IFC Data is 
enabled on the palette. Objects like walls and slabs, with default IFC data assigned, display with <Default> to 
indicate that the default IFC data have not been modified.

The geometry of IFC entities can be edited with the Modify > Edit IFC Entity command; alternatively, right-click 
(Windows) or Ctrl-click (Macintosh) on the IFC entity and select Edit from the context menu.
~~~~~~~~~~~~~~~~~~~~~~~~~
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Parameter Description

Simple List/Full List 
view

Choose the list view. The simple list is an adjusted view of primary IFC objects, while the 
full list displays all available IFC concepts

Filter List Enter text or keywords to filter the objects list; only entries which contain the text are listed
IFC object types Lists available IFC object types; click the object type to select it

Parameter Description

Entity Displays the selected type of IFC entity
Select Opens the Select IFC Entity dialog box, to select a different entity type
GUID Displays the Global Unique Identifier assigned to the entity; this ID follows the entity 

throughout the IFC workflow to distinguish it from other IFC objects
Create IFC Entity Leave deselected to retain the Vectorworks object properties in the Object Info 

palette (the IFC Data remains attached); select to display the object as an IFC Entity 
in the Object Info palette. 
IFC Entities are container objects. They display the type IFC Entity on the Object 
Info palette.

Data Sets for this object Displays the property sets associated with the IFC object; select whether to use each 
IFC pSet by clicking in the Use column

Manage Custom Property 
Sets

Opens the Manage Custom Property Sets dialog box. This allows you to include data 
from your model even if the data are not defined as part of the IFC specifications. 

Properties for the selected 
Data Set

Displays the available properties and values for the selected pSet

Value for selected property Specifies a string or number value for the selected pSet property
Select IFC Instance For some pSet properties with complex values, an IFC Instance is specified. Select 

from the list of instances, or click New to open the IFC Instance Edit dialog box. 
Specify the values of the complex properties and click OK to return to the IFC Data 
dialog box. (To delete an IFC instance, select it from the list and click Delete.)
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Assigning IFC Data to Space Zones
The IFC Zones command attaches IFC data to the specified IFC zones from the current file. 

Zones are assigned to space objects from the Occupancy pane of the Space Settings dialog box (see “Space 
Settings: Occupancy Pane” on page 408). 

To attach IFC data to zones in use in the file:
1. Select the IFC Zones command from the appropriate menu: 

• Architect workspace: AEC > IFC Zones 
• Landmark workspace: Landmark > Architectural > IFC Zones
The IFC Zones dialog box opens. Zones in use in the file are listed above the divider line; available IFC zones are 
listed below the divider.

2. Select a zone and click OK. Only one zone can be selected at a time.
3. The IFC Data dialog box opens. The object type is automatically set to ifcZone, and the property Name value set 

to the zone name. See “Assigning IFC Data to Objects” on page 1746.
4. Click OK to attach the IFC data to the zone. 

At IFC export, the IFC zone data is automatically applied to all space objects with a matching zone definition.
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Viewing and Editing IFC Data
The data attached to custom Vectorworks objects or IFC entities, whether created in the Vectorworks program or 
imported from an IFC file, can be viewed and edited with the IFC Data command or from the Object Info palette. In 
addition, the IFC object that corresponds to a Vectorworks plug-in object, such as a Space object, window, or wall, can 
be viewed.
To access IFC data:

1. Select the IFC entity or Vectorworks plug-in object. Multiple items can be selected.
2. Select the IFC Data command from the appropriate menu:

• Architect workspace: AEC > IFC Data
• Landmark workspace: Landmark > Architectural > IFC Data
Alternatively, click IFC Data from the Object Info palette (Show IFC Data must be enabled from the 
Coordinate/IFC menu on the Object Info palette to enable IFC-related information display on the palette).
When multiple items have been selected, edits apply to all eligible objects in the selection.
If you have selected a group that contains objects with multiple IfcObjectTypes, the Choose IFC Type dialog box 
opens. Select the IFC Type to apply to the group. Optionally remove the IFC data from the contained objects.
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3. When the items to be edited have been specified if necessary, the IFC Data dialog box opens. View or edit the IFC 
data as described in “Assigning IFC Data to Objects” on page 1746 and click OK.
If an IFC entity was selected, the IFC Data dialog box displays the data attached to the entity as described in 
“Assigning IFC Data to Objects” on page 1746; the data can be edited. If a Vectorworks plug-in object was 
selected, the IFC Data dialog box displays the corresponding IFC Object type. At export, the object will be 
converted to that type of entity.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Using Custom IFC Property Sets
Property sets (Pset_XxxxXxxx) are used to assign groups of individual data fields, or properties, to IFC entities. 
Property sets can be very specific to an IFC entity, such as Pset_WallCommon to IfcWall, or more generally applied to 
any IFC entity, such as Pset_ManufacturerTypeInformation. Some property sets and their values are explicitly 
predefined and listed in the IFC specification; the naming convention Pset_Xxx applies to these officially specified 
property sets.
Due to the extensible nature of IFC, any user-defined data, even when not explicitly identified in the IFC specification, 
can still be captured and exchanged using custom property sets. Custom property sets must follow technical encoding 
conventions. They must have unique and allowable names; the names cannot duplicate specified property set names or 
begin with “Pset_.” 
Record formats allow custom property sets to be saved and exchanged. See “Record Formats” on page 262 for more 
information on record formats.

Creating IFC-Compatible Record Formats
To use a custom property set, first create the record format to define the data to be captured and exchanged in IFC 
format. The record format name defines the name of the custom property set. Record formats designated for IFC export 
should be named with a VwPset_ or ePset_ prefix, or use a name that is defined by a specific Model View Definition 
(MVD) or documented model Exchange Requirement (ER). Record format names are case sensitive, and should not 
contain blank spaces (use an underscore if needed). In the following example, the record format is named 
“ePset_MyDataExchange.”
The record format can consist of any number of fields, designated by a Field Name and a Field Type; see “Creating 
Record Formats” on page 262. To be compatible with IFC standards, each field name must be paired with a second 
field name that identifies an IFC value (IfcValue) type. Each pair must have the same field type. 
For example, the Field Name “Reference,” with a Text Type, is followed by the Field Name “IfcIdentifier,” also with 
a Text Type. The “IfcIdentifier” field indicates the kind of value type being used; in this case, it is a simple text ID 
string (IfcSimpleValue:IfcIdentifier). 
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When creating record format fields, a default value can be specified. The default values are optional, except for number 
fields, which require at least a zero value to be entered. However, the default values for the IFC field names are ignored 
when converted to custom property sets.
Deciding which IFC value type and record format field type to use depends on the kind of information being captured 
by the field, such as a simple number, a TRUE/FALSE choice, a text string or simple label, or a measurement. In the 
Vectorworks program, allowable types include Integer, Boolean, Text, or Number. The Field Name identifying an IFC 
value type should be based on the IFC specification for the different defined types of values (IfcValue), as shown in the 
following list.

IFC Value Types Vectorworks Record Format Field Type and Description

IfcSimpleValue These are the most common and cover most user cases
IfcInteger Integer: a simple whole number ranging from -32,7568 to 32,767
IfcReal Number: General or Decimal
IfcBoolean Boolean: also known as TRUE or FALSE
IfcLogical Boolean: similar to Boolean, but can include a value of 

“UNKNOWN”
IfcIdentifier Text: a simple text ID string, usually a mix of alphanumeric 

characters and symbols
IfcLabel Text: a simple text name string, usually a mix of alphanumeric 

characters
IfcText Text: a descriptive text field string of up to 255 characters

IfcMeasureValue A complete list can be found in the IFC2x3 TC1 specification
IfcAreaMeasure Number: Dimension Area
IfcLengthMeasure Number: Dimension
IfcMassMeasure Number: General or Decimal
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When all field data pairs have been completed, click OK to create the record format.

The record format appears in the Resource Browser, under the Record Format category. Like any resource, it can be 
shared between files using the export or import functionality of the Resource Browser.

Converting a Record Format to an IFC Custom Property Set
Once the custom record format has been created, it is converted to an IFC Property Set and attached to an object, group, 
symbol definition, or symbol instance.
To assign the custom IFC data:

1. Select the object, group, or symbol for assignment of IFC data. 
2. Select the IFC object type as described in “Assigning IFC Data to Objects” on page 1746.
3. Click OK.

The IFC Data dialog box opens.
4. Click Manage Custom Property Sets. 

The Manage Custom Property Sets dialog box opens.

IfcThermodynamicTemperatureMeasure Number: General or Decimal
IfcTimeMeasure Integer or Number: General
IfcVolumeMeasure Number: Dimension Volume

IfcDerivedMeasureValue A complete list can be found in the IFC2x3 TC1 specification
IfcEnergyMeasure Number: General or Decimal
IfcIlluminanceMeasure Number: General or Decimal
IfcPowerMeasure Number: General or Decimal
IfcThermalTransmittanceMeasure Number: General or Decimal
IfcTimeStamp Integer or Number: General
IfcLuminousIntensityDistributionMeasure Number: General or Decimal

IFC Value Types Vectorworks Record Format Field Type and Description
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5. Click in the Use column to include a record format. Selected record formats display with a check mark.
6. Click OK to return to the IFC Data dialog box.

The selected custom record formats are listed as data sets in the IFC Entities/Psets list.
If there are any errors in the naming or formatting of any fields in the record format, the custom property set does 
not appear in the IFC Entities/Pset list. Internal checks ensure the integrity of the data and automatically reject 
any errors. Correct the errors by editing the record format from the Resource Browser, and try again.
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7. Select the custom Pset and click in the Use column. A check mark indicates that the Pset is enabled and attached to 
the object. 

8. Select the custom Pset properties and assign values to the selected properties.
9. Click OK to assign the IFC data to the object.

The IFC data can be reviewed or edited by clicking IFC Data from the Object Info palette of a selected IFC object 
or entity, or by selecting the object or entity and selecting AEC > IFC Data (Vectorworks Architect workspace) or 
Landmark >Architectural > IFC Data (Landmark workspace); see “Viewing and Editing IFC Data” on 
page 1748.

The custom property set is saved in the current file. To use a custom property set in another file or project, export the 
record format to another file and repeat the manage custom property sets process.
~~~~~~~~~~~~~~~~~~~~~~~~~
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Creating IFC Schedules
Before you export an IFC project, check that objects have appropriate IFC data associated with them. In the 
Vectorworks Architect product, the following schedules with IFC data can be added to the drawing with the VA Create 
Schedule command, or you can create your own schedules (see “Records and Schedules” on page 1859).

• Objects with IFC Entity gives a count of IFC objects for each entity type on each layer. The object class, name, 
and type also display, if available.

• Objects with IFC Entity - Specific lists each IFC object, broken down by entity type (walls, slabs, roofs, doors, 
windows, stairs, and columns). The object layer, class, name, and description also display, if available.

• Objects without IFC Entity lists each non-IFC object. The object layer, class, type, and type name also display, if 
available.

Alternatively, from the Resource Browser, open the default architectural reports file from the [Vectorworks]\Libraries 
folder that is included with the Vectorworks Architect product (see “Resource Libraries” on page 219). Drag the 
appropriate IFC worksheet to the drawing.
To edit the worksheets after they have been created, see “Using Worksheets” on page 1319.
~~~~~~~~~~~~~~~~~~~~~~~~~
IFC Format Interoperability

Importing IFC Files
An IFC project, including one which contains multiple buildings or large information sets, can be imported into a 
Vectorworks file. The units of the imported file are determined by the Vectorworks file. The presentation layers or 
CAD layers from an imported IFC file are assigned to corresponding Vectorworks classes.
Stories and elements in the IFC file can be filtered during the import, to remove irrelevant objects. Filtering an import 
can significantly lower the file size, making both the import process and subsequent collaboration more efficient.
To import an IFC file:

1. Select File > Import > Import IFC.
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Alternatively, click the file to import and drag it into a window where a Vectorworks document is open.
2. Select the .ifc, .ifczip, or .ifcxml file to open, and click Open.

The Select IFC Stories and Elements dialog box opens.
3. All stories and elements are imported by default. If you want to apply a filter to the import, choose whether to 

filter by Stories or Elements.
4. If Stories is selected, a list of all stories in the document displays; a check mark to the left of each story indicates 

that it is to be imported. To omit one or more whole stories and any associated elements from the import, select the 
story and click to remove the check mark.
Alternatively, to omit only specific elements on specific stories from the import, click the disclosure arrow to the 
left of a story name to display the list of IFC elements associated with that story. Select the element(s) to be 
omitted and click to remove the check mark. The deselected elements are omitted only from that story.
On stories with a combination of selected and deselected elements for import, the check mark is replaced by a 
dash.

If Elements is selected, a list of all IFC object types in the file displays; the number of elements of each type 
displays in parentheses to the right of the object type. A check mark to the left of each item in the list indicates that 
all are to be imported by default. Select the element(s) to be omitted from the import, and click to remove the 
check mark. The deselected elements are not imported on any story.
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If you deselect some items from the elements list, and return to the stories list, stories that contain deselected 
elements display a dash rather than a check mark, indicating that some elements are not to be imported.

5. Click OK.
The IFC file is imported.

~~~~~~~~~~~~~~~~~~~~~~~~~
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Exporting IFC Projects 
Vectorworks project files can be exported to .ifc, .ifczip, and .ifcxml formats.
Export to IFC Versions 2x2 or 2x3 is supported. The export of a project to an IFC file is based on specifying the 
geometry and associated data needed for the use of the exported file. This specification is called a Model View 
Definition (MVD), which is a subset of all the geometry and data in a building model. MVDs have been created by 
international, national, or local groups to standardize information exchange for various purposes, such as design 
coordination, collision/clash detection, structural analysis, and element quantity analysis. You can use MVDs to 
automate the export, or manually define a custom set of geometry and data to be exported.
To export a Vectorworks file to IFC:

1. Select File > Export > Export IFC Project.
The Export IFC Project dialog box opens.

2. Specify the overall project export options, site information, and author data for each pane of the Data tab. Many of 
the fields are required by the IFC specification; they are automatically mapped to their IFC equivalent for 
inclusion in the IFC file header information.

Click to show/hide the parameters.
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Parameter Description

Export Options Sets export parameters for the file
File Format Select whether to export an .ifc, .ifczip, or .ifcxml file
IFC Version Select the IFC version
Model View Select the MVD that specifies the geometry and data required for export.

• CV 2.0 - Architecture is an official buildingSMART International MVD for 
exporting architectural models for coordination with structural and building 
services models.

• Extended Vectorworks Model View allows you to customize the geometry and 
data to be exported in conjunction with the Export Options for data exchange 
workflows without a standard or official MVD.

• IES VE is a custom MVD to exchange model information with the IES-Virtual 
Environment platform to conduct building energy performance simulation and 
analysis.

• COBie/Facilities Management MVD enables the handover of graphic and 
non-graphic facility management information to the building manager. It 
includes the international version of COBie/COBie2 exchange requirements.

• Simplified Geometry exports walls as IfcWallStandardCase, merging all 
components into one extrude. Slabs are exported as multiple slab instances 
(one slab for each component).

The model view and any add-on views are included as information in the IFC file 
header.

Add-on Views Select optional information to be added to the model view at export.
• Quantity Take Off writes element quantity data to specific IFC data fields for 

use by costing/estimating applications.
• 1st Level Space Boundaries exports planes that represent the contact surface 

between a Space object and an adjacent surface, like a wall, floor, or ceiling. 
These boundary planes will also indicate the placement and extents of 
openings, such as doors and windows.

Export Visible Objects Only Exports objects within visible classes only (the selection of layers for export is 
handled by the Layer Mapping options). When deselected, exports any objects 
required by the Model View selection.

Export Site Model For drawings with a site model, this option exports the site model geometry and 
enables site model layers to be mapped on the Layer Mapping tab

Export Custom Property Sets Exports custom Psets that were specified in the Manage Custom Property Sets 
dialog box for objects’ IFC data, for models not explicitly defined in the Model 
View definition, or when using the extended Vectorworks model view

Export Solids Operations as 
BREPs

Depending on the receiving application and data exchange requirements, solids 
operations may need to be simplified to a surface model, also known as a 
boundary representation (BREP) to display correctly and be properly identified
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Export Text in Unicode 
Format

The Unicode format is more reliable for double-byte characters (text 
representing characters from such alphabets as Japanese, Chinese, and Cyrillic, 
for example) but it must also be supported by the receiving application

Export Walls/Slabs by 
components

Exports the components of walls and slabs as sub-elements, for building material 
estimation purposes

Project Data
Name Type the project name
Phase Enter the construction phase information
Project Type Specify the type of project
Building Permit ID Enter the building permit information
Gross Area (Planned) Enter the total planned area for the entire project

Author Data Enter the information for the primary author of the file and select the author’s 
professional role. A custom role can be specified; select USERDEFINED and 
enter the role title.

Author Addresses Enter pertinent information related to the physical location of the author’s place 
of business

Organization Data Enter pertinent information related to the professional organization in charge of 
the project

Organization Addresses Enter pertinent information related to the physical location of the organization’s 
place of business. If the author address data and the organization address data are 
identical, click Copy Author Addresses to complete the telecom and postal 
information automatically. Subsequent edits made to either pane remain unique 
to the pane.

Site Data Specify site information for the project location, regardless of whether site model 
data is selected for export

Site Address Enter address information for the project site
Building Data Specifies the IFC properties associated with the building 

ID/Name/Description Enter the building’s ID, name, and description
Gross Planned Area Specifies the total planned area for the building, used for programming purposes
Reference Elevation/Site 
Reference Elevation

Enter the elevation above sea level for the building and the building site

Occupancy Type Specifies the occupancy classification, defined according to the presiding 
national building code

Primary Construction Type Specifies the main fire use for the building, assigned from the fire use 
classification table as given by the relevant national building code

Secondary Construction Type Enter any ancillary fire use for the building, assigned from the fire use 
classification table as given by the relevant national building code

Sprinkler Protection Indicates whether the building has sprinkler protection, and if so, whether it is 
automatic (the selection is reflected on the Layer Mapping tab, where it can be 
overridden for an individual story)

Year of Construction Enter the year when the building was built

Parameter Description
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3. Click the Layer Mapping tab to specify which layers to export, and the Story Name to assign to them at export. If 
specified, this includes the site model. For a project initially set up with stories, mapping is done automatically so 
that the layers assigned to the building stories are automatically included in the Mapped Layers list and are 
mapped to an appropriately named story (Vectorworks Architect required). Mapping can also be controlled 
manually.
Specify the associated building or site data for each of the mapped layers.

Click to show/hide the parameters.

4. Click OK to export the project.
Indicate the file name and location in the Save As dialog box.

~~~~~~~~~~~~~~~~~~~~~~~~~
IFC Format Interoperability
Assigning IFC Data to Objects

Landmark Status Indicates a building with special historical landmark designation
Building Address Enter address information for the building; if the site address and building 

address are identical, click Copy Site Address to complete the postal 
information automatically. Subsequent edits made to either pane remain unique 
to the pane.

Parameter Description

Vectorworks Story 
Name 

Specify the mapping options for each story, and for the site model, if it was selected for export 
on the Data tab. As each story is selected, its associated layers display for mapping. Files set up 
with a story structure automatically map the story layers for export.

IFC Story Name Displays the name assigned to the currently mapped layers for export; change the story name if 
necessary

Available Layers Lists Vectorworks layers available for mapping; lists the layers associated with the number of 
stories and the story selected in the Story/Site Selection list

Number of Stories Displays the number of stories in the file, which determines the number of stories available in 
the Story/Site Selection list. If the number of stories entered here is different from the number 
of stories set up for the file, additional layers display for possible mapping for the current story. 
This allows greater export flexibility, to override the story structure in the file and assign 
certain layers to different stories at export.

Mapped Layers Lists layers that have been selected for export; they are associated with the Story Name entry
Add > Adds available Vectorworks layers to the Mapped Layers list for export
< Remove Removes mapped layers from the export list, returning them to the Available Layers list
Mapped layer data Specifies IFC properties for selected mapped story layers 

Above Grade Indicates whether the story is fully above ground
Entrance Level Indicates whether the story includes an entrance for the building
Sprinkler 
Protection

Specifies whether the story includes sprinkler fire protection, and if so, whether the sprinklers 
are automatic; initial settings match the sprinkler protection setting on the Data tab

Planned Areas, 
Gross/Net

Indicates optional gross and net planned areas, used for design and programming purposes

Parameter Description
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Importing IFC Files
Setting Up the Building Structure with Stories

Viewing BCF Files
BIM Collaboration Format (BCF) allows collaborators to exchange comments between software applications without 
exchanging the entire BIM model. Issues, proposals, and change requests about a project are “topics” in the BCF file, 
linked to specific objects in the BIM model. The BCF file only contains comments; it does not modify the model.
To view a BCF file:

1. Open the Vectorworks file that is associated with the BCF file. For best results, the BIM model in the Vectorworks 
file should exactly match the version of the model that was used when the BCF file was created.

2. Select the Open BCF Viewer command from the appropriate menu:
• Architect workspace: AEC > Open BCF Viewer
• Landmark workspace: Landmark > Architectural > Open BCF Viewer

3. If no BCF file is currently imported into this Vectorworks file, the Import BCF dialog box opens. Select the 
desired .bcfzip file and click Open. If the BIM model in the current Vectorworks file is different from the model 
the BCF file was created with, an alert displays.

4. The BCF Viewer dialog box opens and displays data from the imported file.
Click to show/hide the parameters.

5. Click OK to switch the view in the Vectorworks application to display the objects described in the selected topic. 
The related objects are selected, and the view is similar to the snapshot.

6. To open another BCF file related to this project, click Import BCF, and select the BCF file from the Import BCF 
dialog box. The previous BCF file closes, and the new one opens.

7. When you open a BCF file, saved views, a symbol folder, and worksheets are added to the Vectorworks file. When 
you are done reviewing the BCF file, click Close BCF to remove the BCF data.

Parameter Description

List of Topics All topics in the file display, along with the date each was added; click a topic to view the data 
associated with it in the bottom of the dialog box

Topic Snapshot Displays an image of the IFC objects described in the selected topic; since the snapshot was 
created in a different software application, it will not match the view in the Vectorworks file 
exactly

Comments on 
Selected Topic

All comments associated with the selected topic display; for each comment the following 
information displays:
• Date of comment
• Abbreviated Comment text
• Status
• Author
• Additional Status Text

Comment Displays the full text of the comment
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Printing and Publishing
Printing

The Print Area
Within the drawing area is a colored border which defines the print area. Anything within the print area is printed and 
anything outside of the print area is not printed.

The settings from both the Page Setup and Printer Setup dialog boxes determine the number of sheets of paper (pages) 
required to print the entire drawing on the selected printer.
This allows the same drawing to be printed or plotted to numerous sources without readjusting the drawing. For 
example, if you enter the dimensions of a “D” size sheet of technical paper in the Printable Area of the Page Setup 
dialog box, and select “Letter” paper size in the Printer Setup dialog box, the program determines that the drawing 
needs to be “tiled” across 12 sheets of 8-1/2” x 11” paper to a standard laser printer. The number of 8-1/2” x 11” pages 
required for printing horizontally and vertically are automatically updated in the Page Setup dialog box. To send this 
same drawing to a plotter, change the settings in the Page Setup dialog box for a plotter, and the program converts the 
pages required accordingly.
The color of the print area border can be changed; see “Configuring Interactive Display” on page 116.

The page setup (including the printable area) is specified individually for each sheet layer (see “Setting Sheet 
Layer Properties” on page 170).

~~~~~~~~~~~~~~~~~~~~~~~~~
Page Setup
Printer Setup
Printing a File
Setting Quick Preferences

Page Setup
The Page Setup dialog box settings determine the number of sheets of paper (pages) required to print the entire drawing 
on the selected printer. It is also used to specify whether to display the gray drawing boundary box representing the 
print area for design layers, and whether to display page breaks in the drawing file.
To change the page setup settings:

1. Select File > Page Setup.
The Page Setup dialog box opens.

Click to show/hide the parameters.

Drawing area

Print area
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2. Specify the page setup options, and click OK.

Printer Setup
The Printer Setup dialog box settings determine the printer, paper size, scale, and orientation of the drawing.
To change the printer setup settings:

1. Select File > Page Setup.
The Page Setup dialog box opens.

2. Click Printer Setup.
In the dialog box that opens, configure the selected printer options.

Parameter Description

Pages
Horizontal Specify the number of pages in the horizontal direction
Vertical Specify the number of pages in the vertical direction

Show page boundary Select to display a gray border around the perimeter of the print area for design layers 
(this setting is selected by default); alternatively, press Alt+B (Windows) or 
Command+B (Mac) to toggle selection in this field. This setting also affects the 
visibility of the page boundary in a unified view.
Sheet layers always display the page boundary.

Show page breaks Indicates how the drawing is divided over each printable page; for design layers, the 
page boundary must be displayed in order to see the page breaks (this setting is 
selected by default)

Show watermarks If the file is created in an educational version of Vectorworks software, it includes a 
watermark. This option is selected by default and indicates whether to display 
watermarks on screen, at the top and bottom of every page boundary; the page 
boundary must be displayed in order to see the watermarks. 

The title bar clearly indicates watermarked files. A watermarked file always 
prints the watermark, regardless of the display option set here.

Printable Area
Choose size unavailable 
in printer setup

If the desired paper size is not available in the Printer Setup dialog box (see “Printer 
Setup” on page 1762), select this option, and then select the desired paper Size from 
the list; this is useful when sending files to a print bureau that has different paper sizes 
available than your printer

Size/Width/Height To manually specify the paper size, select the appropriate drawing units (inch or 
millimeter) and enter the paper Width and Height

Printer Setup Accesses the Printer Setup dialog box for specifying the printer, paper size, drawing 
scale, and orientation; see “Printer Setup” on page 1762
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3. Scaling resizes the entire drawing by a specified percentage. To access the Scaling parameter in the Mac Page 
Setup dialog box, select Vectorworks from the Settings list.

Selecting a printer in Printer Setup (Mac) only changes the drawing’s settings; to change the printer used for the 
drawing, access the Mac System Preferences.

Printing a File
The program can print or plot to any device that is selected in the Printers and Scanners System Preferences (Mac) or 
Devices and Printers Control Panel item (Windows). The actual parameters of the printed or plotted file are determined 
by the printer setup settings.
All visible objects, classes, and layers within the print area of the Vectorworks file are printed.
If Vectorworks Design Series is installed, you can also use the Publish command to print a batch of files. See “Batch 
Publishing” on page 1765.
To print a file:

1. Select File > Print. 
The Print dialog box opens; the options that display depend on which printer or plotter is selected.
To display additional print options on the Mac, click Show Details.

2. Specify the print options, such as which pages to print and how many copies to make. The following Vectorworks 
print settings are available:
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3. If the Rasterize print output option is selected, specify the edge of the image onscreen that is the first edge to 
come out of the printer.

Platform Setting Description

Mac Application resolution 
(DPI)

Sets a resolution for the application output; this affects only 
Vectorworks geometry and any PICT or PDF objects that 
must be rasterized. The resolution for bitmaps, rendered 
design layers, and viewports are controlled elsewhere; see 
“Setting the Print Resolution” on page 1765 for details.
Either select a recommended DPI value for this printer type 
(from the drop-down list), or manually enter a value. On 
Mac systems, this always defaults to a minimum of 300 
DPI, for optimum printing results.

Windows and Mac Gray level for grayed 
layers and classes

Adjusts the level of gray when printing with grayed layers 
and or/classes

Windows Enable special processing 
for transparent color 
bitmaps

When GDI+ imaging is disabled in the Vectorworks 
display preferences on Windows, some printers (including 
PostScript printers) cannot support transparent color for 
raster images, which can affect bitmaps and picture objects 
that have the fill style set to None. Select this option to use 
a more detailed (and slower) imaging process to print 
transparency properly. 

Windows and Mac Print current view only 
(Mac) or Current View 
(Windows)

Prints the view currently displayed in the file window; this 
view is scaled larger or smaller to fit the selected page size

Windows and Mac Print patterns at on-screen 
resolution

Prints fill patterns at approximately the same size as they 
appear on the screen at a 100% zoom.
Deselect this option to use the printer resolution, which is 
usually much higher, making the patterns print much 
smaller. This prints patterns much faster on Windows, if 
GDI+ imaging is disabled and you have a non-PostScript 
printer.

Windows Rasterize print output Prints the drawing as a raster bitmap. Select this option 
when the printer memory is insufficient, or when image 
problems occur (for example, to print design layer transfer 
modes on PostScript printers).

Windows and Mac Update visible out of date 
viewports prior to printing

Automatically updates any visible, out-of-date viewports 
before printing

Windows and Mac Reset all plug-in objects 
that require a reset prior to 
printing

Automatically resets plug-in objects that require an update 
(such as data stamps) before printing

Windows and Mac Recalculate worksheets 
prior to printing

Automatically recalculates worksheets before printing
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The first edge to come out of the printer depends on the printer driver, the page orientation, and the rotation 
options that are supported by the driver. It cannot be predicted by the program. If the wrong page edge is selected, 
some portions of the drawing may fail to print if the printer runs out of memory.
The Rasterize print output method can be significantly slower than other print methods.

4. Click Print (Mac) or OK (Windows) to print.

Setting the Print Resolution
The resolution at which Vectorworks objects are printed is controlled by different settings, depending on the type of 
object and on whether imaging preferences are enabled.
• A raster rendered viewport is controlled by the Raster Rendering DPI setting of its sheet layer (which does not 

affect vector geometry or bitmaps that are inside the viewport). See “Setting Sheet Layer Properties” on page 170.
• A raster rendered design layer is controlled by the Design Layer Raster Rendering DPI on the Resolution tab in 

the Document Preferences. See “Resolution Preferences” on page 62.
• Vectorworks geometry is controlled by the resolution selected from the Print dialog box.
• Rasterized PDF objects are controlled by the resolution selected from the Print dialog box. On Windows, if GDI+ 

imaging is not enabled, PDF objects are rasterized.
Click here for a video tip on this topic (Internet connection required).

~~~~~~~~~~~~~~~~~~~~~~~~~
The Print Area

Batch Publishing
The Publish command exports a series of sheet layers and/or saved views from the current drawing and 
externally-referenced files to DXF/DWG or DWF format. Vectorworks Design Series users can also export to PDF or 
Image formats, or output to a printer with this command.
The publish list and options can be saved as a set. The list order can be changed, and each item can be published in 
either color or black and white. If the Issue Manager is in use (Vectorworks Architect or Vectorworks Landmark 
required), sheets and views can be sorted by issue date for quick publishing.
To batch publish sheet layers and/or saved views:

1. Set up the sheet layers and/or saved views as desired for publishing.
Set the visibility of layers and classes in the viewports/views. All visible and grayed layers are published. Invisible 
layers and classes are not printed, or published to PDF or DWF; they can be published as invisible DXF/DWG 
layers, if the option is selected in the DXF/DWG Export Options dialog box. Each sheet layer or saved view is 
published as a separate file.

2. Select File > Publish.
The Publish dialog box opens.

Click to show/hide the parameters.

http://www.youtube.com/watch?v=iDbp9KXNXzg
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Parameter Description

Sheets and Saved 
Views Available
(Available list)

Lists the sheet layers and saved views present in the current file (indicated with <Active 
File> in the File Name column) and, if specified, within the selected folder (indicated with a 
file name and path). Click in a column header to sort the sheets and views by the column 
parameter. For example, click in the Issue Date column to sort by the Issue Manager issue 
date (Vectorworks Architect or Vectorworks Landmark required).

Sheets and saved views from restored sets that cannot be found display in red and 
cannot be published.

Show All Items As items are added to the publish list, keeps them in the available list. If you need to publish 
an item to multiple formats (for example, to both print (Vectorworks Design Series required) 
and export to DWF), select this option to show all sheet layers and saved views in the file, 
whether or not they have been selected to be published. Deselecting this option will cause an 
item to disappear from the Available list when you add it to the Publish list.

Folder path Displays the most recently selected project folder and file path, for including sheet layers and 
saved views from other Vectorworks files within the folder

Select Folder Opens the Choose Project Folder (Mac) or Select Folder (Windows) dialog box; select a 
project folder, including any subfolders, that contains sheet layers and saved views to be 
published. Once a project folder has been selected, all saved views and sheet layers from 
Vectorworks files within the folder (and any subfolders) are automatically added to the 
available list. Files must be the same version as the active file.

Add New Items as Sets the default Publish To value for each item that is added to the Publish list (DWG/DXF 
or DWF). If Vectorworks Design Series is installed, Print, PDF, and Image options are also 
available.

Add Adds one or more selected item(s) from the Available list to the end of the Publish list

Add All Adds all sheet layers/saved views in the Available list to the end of the Publish list

Remove Removes one or more selected item(s) from the Publish list

Remove All Removes all sheet layers and saved views from the Publish list

Set to Publish Select a previously saved set to publish
Save a Set Saves the current publish set in the current file, to be restored later; see “Saving a Publish 

Set” on page 1768
Manage Sets Manages saved file sets, and restores a previously-saved set of sheets and views for 

publishing; see “Restoring a Saved Publish Set” on page 1768

sheet layer saved view
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3. Select available items from the available list on the left side of the dialog box, and use the buttons in the middle of 
the window to move them to the publish list on the right side of the dialog box. The Publish To column in the 
right pane indicates the current output setting for each item. To publish an item to multiple formats, Show All 
Items must be selected; add the item to the publish list multiple times, and specify a different format for each one.

4. Verify that the output options for each item are set appropriately, and then click Publish.
5. If the Publish set has not been saved, you are prompted to save it.
6. If PDF, DWG/DXF, DWF, or Image is a selected publish format, the Select Folders dialog box opens. Specify a 

location for the output folders.
7. Click OK. The output files are printed or created based on the selected settings. Within the specified output folder, 

a subfolder is created for each type of output file. A publish log file is created in the same location, which 
summarizes the results of the publish job.
Click here for a video tip about this topic (Internet access required).

Sheets and Saved 
Views to Publish
(Publish list)

Lists the sheet layers/saved views to be published; to change the list order, use the cursor to 
drag and drop the items in the # column.
Click Color for each item to toggle between color and black and white.

Publish To Select one or more items in the publish list and then select from this list to change the output 
format (DWG/DXF or DWF). If Vectorworks Design Series is installed, Print, PDF, and 
Image options are also available.

Options Opens the appropriate dialog box to set the options for the currently selected item:
• DWG/DXF and DWF: see “DXF/DWG and DWF Export Options” on page 1734
• Print (Vectorworks Design Series required): see “Printing a File” on page 1763
• PDF (Vectorworks Design Series required): see “Exporting PDF Files” on page 1690
• Image (Vectorworks Design Series required): see “Exporting an Image File” on 

page 1683; some image export options are not available when publishing
All items of a specific type that are added to the publish list will default to the user 
specified options if left unchanged.

Export PDFs as 
Separate Files
(Vectorworks 
Design Series 
required)

For items to be published to PDF, exports each selected sheet layer and saved view as a 
separate PDF file; deselect this option to create a single PDF file only

Open Destination 
Folder upon 
Completion

After publishing, opens the containing folder for published files

Create Folder for 
Each File Type

Creates a folder for each file type within the destination folder
Certain publish formats, such as DWG/DXF, require subfolders for output organization, 
even when this option is deselected.

Parameter Description

color black and 
white

http://www.youtube.com/watch?v=GYVMjKJx04s&list=UUN7uzhu-ljLJOe6a0J-fBcQ
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Saving a Publish Set
You can save the current publish settings to be reused later. The set of sheet layers and saved views, along with their 
color settings, list order, and publish method, are saved in the file. If the file set contains sheet layers and views from a 
selected folder, specify how to save the path relative to the current file.

The PDF, Image, and Print publish options are available in Vectorworks Design Series only. Items that were saved 
with PDF, Image, or Print options will not display if the saved set is opened with Vectorworks Fundamentals.

To save the export list as a set:
1. In the Publish dialog box, click Save a Set.

The New Saved Set dialog box opens.
Click to show/hide the parameters.

2. Click OK. The settings are saved with the file and are available for future publish jobs.

Restoring a Saved Publish Set
To restore a saved publish set:

1. In the Publish dialog box, click Manage Sets.
The Manage Saved Sets dialog box opens.

Click to show/hide the parameters.

Parameter Description

Name Enter a unique name for the set
Absolute path Sets an absolute path to files used by the saved set. Use the absolute path when the 

location of the referenced files with respect to the current file is not going to change.
Path relative to the 
active document

Sets a relative path to files used by the saved set. Use the relative path when the files 
might be moved to another computer or platform; as long as the relative path between the 
files remains the same, the referenced files can be found. All files must be saved on the 
same volume or server to select this option.

Open Destination 
Folder upon 
Completion

Select to open the containing folder for the saved set

Create Folder for Each 
File Type

Select to create a folder for each file type in destination folder

Export PDFs as 
Separate Files 
(Vectorworks Design 
Series required)

Select to publish each sheet layer or saved view as a separate PDF file

Parameter Description

List of saved sets Lists the currently saved sets by name; select a set to edit, recall, or delete it
Edit Opens the Edit Saved Set dialog box; rename the set and/or change the file path style (relative 

or absolute)
Delete Deletes the currently selected saved set(s)
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2. Select a saved set.
3. Click Recall. The settings for the selected saved set display in the Publish dialog box.

If the saved set references external files and a file, sheet layer, or saved view from the set cannot be located, you 
are prompted to manually locate a missing file, or warned that sheets or views are missing. Missing sheets and 
views display in red in the Publish dialog box, and are not included in the publish job.

Recall Restores the list of saved views and sheet layers, along with their settings, to the export list in 
the Publish dialog box

Parameter Description
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Using Scripts
Scripting is one method of customizing the Vectorworks program to suit a wide range of design needs. Scripts can 
create anything from simple tools that assist with the most tedious drafting tasks, to sophisticated solutions for 
demanding designs. Three scripting options in the Vectorworks program include:

• The Software Developer’s Kit (SDK) in the C++ language
• Python® programming language
• VectorScript™, a lightweight Pascal-like programming language

This section discusses scripting, but not the SDK. For detailed developer-oriented documentation related to the SDK, 
Python, and VectorScript, please navigate to http://developer.vectorworks.net 
The Vectorworks program provides several methods for creating, managing, and executing scripts. While scripting 
languages provide a rich set of development tools when creating scripts from scratch, there are also several commands 
that allow you to create scripts without direct knowledge of programming. The most basic of these methods is to select 
the File > Export > Export Script command. The command creates a script from the file’s contents and saves it as a 
Python or VectorScript file in the designated location. Select the File > Import > Import Script command to execute 
the script from a saved file in a new, automatically created design layer.
The Custom Selection, Custom Tool/Attribute, and Custom Modification commands provide the ability to create 
useful scripts directly. 
In addition to these automated methods of creating scripts, the traditional method for creating and saving scripts (and a 
feature of Vectorworks since its original release as MiniCad), is to write document scripts, which are saved as script 
resources and are stored in script palettes contained within a file. Both document scripts and script palettes can be 
created, accessed, exported, imported from another file, renamed, and deleted through the Resource Browser. 
Scripts can also be created and stored in plug-ins. Plug-ins are a component of a workspace, and can be accessed from 
any file. Scripts in plug-ins can be used as menu items, tools, or parametric objects. Plug-ins are created and maintained 
using the Plug-in Manager, which is accessed by selecting Tools > Plug-ins > Plug-in Manager.
Finally, scripts can be purchased from third-party vendors and installed.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Custom Selection Scripts
Creating Custom Tool/Attribute Scripts
Creating Custom Modification Scripts
Creating and Editing Script Palettes and Scripts
Running Scripts
Scripted Plug-ins
Creating Custom Path Objects
Customizing Size Settings for Plug-in Objects
The VectorScript Debugger

Creating Custom Selection Scripts
Custom selection scripts allow objects in the current file to be selected or deselected according to user-specified 
criteria. The wide array of options in the command allows for very specific filtering and selection according to the 
defined selection requirements. No scripting knowledge is necessary.

The layer options must be set to Show/Snap/Modify Others to select objects on another layer.
To create a custom selection script:

1. Select Tools > Custom Selection.
The Custom Selection dialog box opens. Choose the desired options for the selection operation.

Click to show/hide the parameters.

http://developer.vectorworks.net
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2. Click Criteria to specify the selection criteria for the operation.
The Criteria dialog box opens.

3. Choose the desired criteria options. The number of objects in the file that meet the criteria displays.
Specify additional options by clicking More Choices. To remove the most recently added option, click Fewer 
Choices.
Specify whether to also include objects that are part of symbols, plug-in objects, or viewport annotations.

4. Click OK.
If the Execute Immediately option was chosen, the selection operation is now performed. If one of the create 
script options was chosen, when prompted, name the script palette (if none exists) or select an existing script 
palette, and name the selection operation script. The script is saved in the script palette, and can be run as 
described in “Running Scripts” on page 1780.
Click here for a video tip about this topic (Internet access required).

~~~~~~~~~~~~~~~~~~~~~~~~~
Entering Formulas in Worksheet Cells
Using Scripts
Opening a Script Palette
Running Scripts

Parameter Description

Select Selects the objects matching the specified criteria without affecting the existing selection 
status of other objects

Select Only Deselects all objects prior to performing the selection operation
Deselect Deselects any objects matching the specified criteria without affecting the selection status 

of other objects in the file
Execute Immediately Performs the specified selection operation immediately upon exiting the Criteria dialog 

box; the operation criteria are not saved for future use
Create VectorScript Saves the criteria and command options as a VectorScript that can be executed later
Create Python Script Saves the criteria and command options as a Python script that can be executed later

Criteria selection parameterCriteria comparison optionCriteria type

Adds more selection criteria Reduces selection criteria

http://www.youtube.com/watch?v=483uIGjRhJM
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Creating Custom Tool/Attribute Scripts
Custom tool/attribute scripts record the current attribute and file settings in a script format for later use. These custom 
settings can be combined with the active tool to allow a specific set of attributes, such as fill style or pen color, to be 
reactivated for use with the tool. For example, a dashed line style and red pen foreground color can be saved with the 
line tool in a script for drawing red dashed lines. No scripting knowledge is necessary.
To create a custom tool/attribute script:

1. Select Tools > Custom Tool/Attribute.
The Custom Tools dialog box opens.

2. Select which attributes should be saved in the script.
The saved attributes are used when the script is executed and can be modified or reset.

Click to show/hide the parameters.

3. Click OK.
4. When prompted, name the script palette (if none exists) or select an existing script palette, and name the attribute 

settings script.
The script displays in a script palette, and can be run as described in “Running Scripts” on page 1780.

~~~~~~~~~~~~~~~~~~~~~~~~~
Using Scripts
Opening a Script Palette
Running Scripts

Creating Custom Modification Scripts
Custom modification scripts can select multiple objects and modify their common properties and attributes in a single 
operation. Objects can be selected regardless of layer, layer scale, class, or current selection or visibility status. Several 
levels of selection criteria make it easy to target specific object sets for modification. No scripting knowledge is 
necessary.

Parameter Description

All • Checked box: All attributes in the group are selected; click to deselect all attributes in the 
group to be saved to the script.

• Empty box: No attributes in the group are selected; click to select all attributes in the group 
to be saved to the script.

• Box displays  (Windows) or   (Mac): One or more attributes in the group are not 
selected; click to select all attributes in the group to be saved to the script.

Fill Attributes Saves fill foreground and background colors and fill style
Pen Attributes Saves pen foreground and background colors and pen style
Line Attributes Saves line weight (thickness) and the presence and size of markers
Text Attributes Saves text attributes including font, size, style, spacing, and justification (alignment)
Other Attributes Saves other attributes such as classes, layers, symbols, tools, and SmartCursor settings 

(snapping parameter settings, as well as which snapping tools are active on the Snapping 
palette)
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To create a custom modification script:
1. Select Tools > Custom Modification.

The Custom Modification dialog box opens.
Click to show/hide the parameters.

2. Select the desired criteria options. The number of objects that meet the criteria displays.
When symbols are selected as the criteria and symbol folders are present in the file, click the button available near 
the symbol type to open the Select Symbol dialog box. Select the specific symbol, and then click OK to return to 
the Custom Modification dialog box. 

3. Click OK.
If the Create Script option was chosen, when prompted, name the script containing the modification commands. 
The script then displays in a script palette, and can be double-clicked to perform the operation. See “Creating and 
Editing Script Palettes and Scripts” on page 1775.

4. If the Execute Immediately option was chosen, the Properties dialog box opens.
The common properties of the selected objects are displayed and can be modified. Similar to a multiple selection, 
if the parameter settings for the objects are different, they display as a blank list or as a check box of indeterminate 
state. Parameter edits apply to all selected objects when in multiple edit mode.

Parameter Description

Execute Immediately Performs the specified selection operation immediately upon exiting the Custom 
Modification dialog box; the operation criteria is not saved for future use

Create VectorScript Saves the criteria and command options as a VectorScript that can be reused as needed
Create Python Script Saves the criteria and command options as a Python script that can be reused as needed
Selection Criteria Determines the objects to select and modify based on the selected criteria
Including components 
of

Applies the selection to objects that are grouped and/or included in viewport annotations

Objects that meet the 
criteria

Displays the number of drawing objects that will be affected

More Choices/Fewer 
Choices

Specify additional criteria by clicking More Choices. To remove the most recently added 
level of criteria, click Fewer Choices.
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5. To edit the object attributes, click Attributes.
The Attributes dialog box opens. Edit the available attributes of the selected objects, and click OK. See “The 
Attributes Palette” on page 1093 for more information.

6. Click OK to return to the drawing.
~~~~~~~~~~~~~~~~~~~~~~~~~
Using Scripts
Opening a Script Palette
Running Scripts

Creating and Editing Script Palettes and Scripts
Document scripts can be created, saved, and executed within a Vectorworks file. Use the Resource Browser to manage 
script palettes as well as individual document scripts.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Script Palette
Opening a Script Palette
Creating Scripts
Editing Scripts
Using Scripts
Running Scripts

Creating a Script Palette 
Scripts are organized and accessed from script palettes located in the Resource Browser. If no script palettes exist when 
a script is created, a new script palette resource is automatically created. However, creating a script palette ahead of 
time allows you to select an existing script palette when creating new scripts.
To create a script palette:

1. Select Window > Palettes > Resource Browser.
The Resource Browser opens.

The blank Layer list indicates
that the selected objects are

located on different layers

The indeterminate check box
means that some of the objects

have different settings

Multiple selection mode

Edits the attributes of the 
selected objects
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2. Select Resources > New Resource to display the list of new resource types.
3. Select Script Palette.

The Assign Name dialog box opens. Enter the name of the script palette and click OK.

Opening a Script Palette
To open a script palette:

1. Select Window > Palettes > Resource Browser.
The Resource Browser opens.

2. Select the script palette to be opened, and then select Resources > Open.
Alternatively, open the palette from the Window > Script Palettes menu.
The script palette opens. While open, scripts can be easily executed from the palette.
Script palettes can be edited, renamed, deleted, exported, and imported from the Resource Browser.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Scripts
Editing Scripts
Using Scripts
Running Scripts
Using the Resource Browser

Creating Scripts
To create a script:

1. Select Window > Palettes > Resource Browser.
The Resource Browser opens.

2. Select Resources > New Resource to display the list of new resource types.
3. Select Script.

The Assign Name dialog box opens. Enter the name of the script and click OK.
Newly created scripts are located by default in the active script palette (the palette which is open and active, or 
which is open in the Resource Browser). If multiple script palettes exist, but are not currently open, the Select 
Script Palette dialog box opens to select a location for the script. Select the palette to add the script to and click 
Add. If no script palette exists in the file, a new script palette must be created to contain the script. 

4. The Script Editor opens to begin a script editing session. The editor provides a basic authoring environment for 
script development and maintenance. Its features allow you to create, edit, and compile scripts, browse available 
functions, view errors, and perform other tasks associated with creating scripts. Select the script language for the 
script: Python Script or VectorScript. Scripts are limited to 32,001 characters. For detailed developer-oriented 
documentation related to Python and VectorScript, please navigate to http://developer.vectorworks.net

http://developer.vectorworks.net
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Click to show/hide the parameters.

Parameter Description

Editor menu

Procedure Opens the Procedures dialog box, which lists all the available script functions/procedures 
by category and provides a prototype as well as a brief description of what operation is 
performed by the function/procedure. The list serves as both a reference and a means of 
building the code by pasting the relevant function/procedure into the editor.
Select the procedure or function and click OK to add it to the current line of the script 
editor.

Criteria Opens the Criteria dialog box, for automatically defining selection criteria in a script (see 
“Creating Custom Selection Scripts” on page 1771)

Tool/Attribute Opens the Custom Tools dialog box, for saving the current tool and attribute state 
information into a script (see “Creating Custom Tool/Attribute Scripts” on page 1773)

Parameter The Parameter command provides access to a plug-in objects’ parameter list for editing, 
when working on the script of a plug-in (see “Plug-in Definition” on page 1785)

Text File The Text File command allows script source code to be imported from external text files
Font Settings Opens the Format Text dialog box, where the font settings of the text in the Script Editor 

window can be changed. Changes to the text formatting apply to all of the text in the 
Editor (formatting a selection of text is not possible). See “Formatting Text” on page 389 
for more information on text formats.

Editor menu

Compile script Current line numberFont settings Palette name Script name

Script
language

Script options for
Python scripts



  1778 | Creating and Editing Script Palettes and Scripts
5. When the script is complete, click OK to save it.
Scripts can be edited, renamed, deleted, exported, imported, moved, and executed from the Resource Browser.

~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Scripts
Running Scripts
Using the Resource Browser
Creating a Script Palette
Using Scripts

Editing Scripts
To edit an existing script from the Resource Browser:

1. From the Resource Browser, select the script to be edited. Scripts are nested in script palette folders.

2. Select Resources > Edit. 
Alternatively, open the script palette from the Resource Browser. Press Option (Mac) or Alt (Windows) and 
double-click on the script to be edited. 

Compile Script The Compile Script button allows a script to be compiled directly from the Script Editor 
without the need to execute the script. If errors exist within the script that prevent 
successful compilation, they will be displayed and can be resolved without the need to exit 
the script editor.

While compiling VectorScripts reports all errors in the script code, compiling Python 
scripts reports only the syntax errors. For example, an undefined variable is not 
reported as an error for Python scripts, because this type of error is determined only 
during script execution. As a result, Python scripts report most errors when executed.

Language Select Python or VectorScript for the script language
Script Options 
(Python scripts only)

Opens the Script Options dialog box, which lists folders (environment paths) where 
imported modules are located, for Python scripts that require external libraries.

This dialog box can also be accessed from Tools > Plug-in > Script Options.
• Add: Select a folder location to add it to the list
• Remove: Deletes the currently selected folder location
• Open Folder in OS: Displays the contents of the selected folder in either Windows 

Explorer or Mac Finder

Parameter Description
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3. The Script Editor opens, displaying the script source code. See “Creating Scripts” on page 1776 for a description 
of the Script Editor.

Moving a Script to Another Palette
To move a script from one palette to another:

1. From the Resource Browser, select the script palette containing the desired script, and then select Resources > 
Open. Alternatively, open the palette from the Window > Script Palettes menu.
The source script palette opens.

2. Select the script palette where the script will be moved, and then select Resources > Open.
The destination script palette opens.

3. Click on the script to move, and then press Command+X (Mac) or Ctrl+X (Windows). The script is removed from 
the palette and placed into the clipboard.

4. Click on the destination script palette, and then press Command+V (Mac) or Ctrl+V (Windows). The script is 
placed into the selected script palette.

Alternatively, move the script by selecting it from the Resource Browser and selecting Resources > Move. Specify the 
new script palette location for the script. See “Using the Resource Browser” on page 221 for more information.

Encrypting Scripts
A script can be encrypted and locked to prevent editing. 
To encrypt a script file:

1. Select Tools > Plug-ins > Encrypt Script.
The Choose Script File dialog box opens.

2. Locate and select the script file to encrypt.
3. Click Open.

The Save Encrypted VectorScript Code Document dialog box opens.
4. Enter a new name for the script, and then select the location for saving the file.
5. Click Save.

The script is saved in an encrypted format.
~~~~~~~~~~~~~~~~~~~~~~~~~
Running Scripts
Creating Scripts
Using the Resource Browser
Creating a Script Palette
Using Scripts
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Running Scripts
Document scripts can be executed in a variety of ways.

Running Scripts from the Resource Browser
To run a script from the Resource Browser:

1. From the Resource Browser, select the script palette containing the script to run.
2. Double-click on the script palette to open it.

Alternatively, right-click (Windows) or Ctrl-click (Mac), and select Enter from the context menu to open the 
palette.

3. Select the script to run. Select Resources > Run, or right-click (Windows) or Ctrl-click (Mac), and select Run 
from the context menu.
Alternatively, double-click the script resource to run it or drag the script resource into the drawing area.

Running Scripts from the Script Palette
To run a script from a script palette:

1. Select Window > Script Palettes and select the script palette containing the desired script.
To open the script palette from the Resource Browser, select the script palette containing the desired script, and 
double-click to open it, or right-click (Windows) or Ctrl-click (Mac) on the palette, and select Open from the 
context menu.

2. From the script palette, double-click on the script to run it.

Running Scripts from Files
Some scripts may exist as text files only, if they were created in a separate text editor program or exported from the 
Vectorworks program. These scripts are not available from the Resource Browser.

1. Select Tools > Plug-ins > Run Script (or File > Import > Import Script).
The Choose Script File (or Import Script Drawing Document) dialog box opens.

2. Select the desired script file and click Open to run the script.

Script Errors
If an error occurs during script execution, an alert dialog box opens.
To handle script errors:

1. From the alert dialog box, click View Error Output.
2. The Script Errors dialog box opens, displaying the nature of the error and the line(s) where the error occurred.
3. To edit the script, click Edit Script, or double-click on a script line to edit that line. The Script Editor opens for 

making corrections to the script.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Scripts
Editing Scripts
Using the Resource Browser
Creating a Script Palette
Using Scripts
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Scripted Plug-ins
Document scripts, as described in “Creating and Editing Script Palettes and Scripts” on page 1775, allow scripts to be 
created, saved, and executed from the Resource Browser of a Vectorworks file. However, scripted plug-in objects allow 
scripts to be available in any Vectorworks file. The three types of plug-ins—menu commands (.vsm), tools (.vst), and 
objects (.vso)—allow scripts to be incorporated into a workspace as menu commands, tool palettes, and objects in 
Resource Browser libraries.
Plug-in objects created with scripts become custom items that can streamline and enhance the design/drafting process. 
They support the standard Vectorworks program core technologies such as snapping, classing, and advanced object 
editing, giving them essentially the same status as Vectorworks built-in object types.
Scripted plug-ins also provide enhanced portability and platform independence for scripts, allowing them to be easily 
moved to Vectorworks software installations on either Mac or Windows systems. Drawings containing plug-in objects 
can be exchanged between users in different countries. The plug-ins can be localized for use in other countries by 
translating the names and strings that display.

How Plug-ins Work
Scripted plug-ins are saved as files. They combine script code with a plug-in “wrapper,” an encoded header which 
defines the characteristics and behaviors of the plug-in. Information such as the category of the plug-in, properties 
which define how the plug-in is activated, or any other information needed by the plug-in to function within the 
Vectorworks application framework is included within the header.

Plug-in Types
A key feature of scripted plug-ins is their smooth integration into the Vectorworks product interface. These menu 
commands, tools, and objects work just like any built-in Vectorworks software tool, object, or menu item. Like built-in 
menu commands, scripted menu commands can be set to require certain file conditions such as 2D/3D view orientation 
or a selected set of items in order to activate. When a menu command or tool item is selected, the script and any 
information needed by the plug-in is loaded into memory, and the plug-in script executes. The Vectorworks program 
uses information provided by the plug-in to provide the user interactions (such as snapping) and file environment for 
the menu command or tool to perform its defined actions. Scripted tools, like their built-in counterparts, make use of 
the SmartCursor and other tool-centric Vectorworks program features.
Plug-in objects have characteristics of both tools and symbols. Plug-in objects can be added to a tool palette and 
resemble tool items, but in use, they place instances of the object in the file much like the symbol tool places symbols 
in a file. Object scripts can also be invoked through events that occur in the file. Placed object instances can be 
modified with the Object Info palette to edit the parametric values that are used to define the object, and these changes 
will cause the script defining the object to execute for the object to redraw. Global file changes which force a 
regeneration of the file can also cause the scripts of objects placed in the file to execute. These characteristics give 
plug-in objects enormous flexibility in how they can be displayed within a file.
Plug-in objects can also be used in conjunction with the Resource Browser to create preconfigured object instances that 
need minimal editing after placement. Libraries of different object configurations based on a single plug-in object can 
be easily created and retrieved through the Resource Browser.

Plug-in File Location
When the Vectorworks program launches, it searches for any scripted plug-in files and registers the information 
necessary to activate and manage the plug-ins. Include files are searched for in the same folder where the associated 
plug-in file is located.
Vectorworks software searches for plug-ins in the following order and locations:

• In the user’s Plug-Ins folder, or aliases or shortcuts in the user’s Plug-Ins folder
• In the Vectorworks Plug-Ins folder and its subfolders
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• Aliases or shortcuts in the Vectorworks Plug-Ins folder that point to locations outside the Vectorworks hierarchy
The user’s Plug-Ins folder exists in a platform-specific location.

When plug-in files are first created, they are always placed in the user’s Plug-Ins folder.
When the Vectorworks program launches, or a workspace is activated, a plug-in is available in the current session 
only if it is located in the Plug-Ins folder, its subfolders, user’s Plug-Ins folder and subfolders, or folders 
referenced by aliases (Mac) or shortcuts (Windows).
If duplicate plug-in files exist in more than one location, the instance that occurs first in the folder hierarchy is the 
one that is used.

The flexibility of the plug-in file location provides an advantage when upgrading from a previous version of 
Vectorworks software. Because third-party plug-ins can be stored in a folder separate from the application, they can 
easily be referenced when installing the upgrade. Copying the Plug-Ins folders to the current version’s folders, or 
referencing them with an alias or shortcut, is all that is required when upgrading.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Scripted Plug-Ins

Creating Scripted Plug-Ins
The Plug-in Manager displays three types of plug-ins:

• Custom, unencrypted plug-ins that you create
• Third-party plug-ins, purchased from developers (encrypted), and encrypted plug-ins you create
• Built-in, encrypted plug-ins that are included with the Vectorworks program

Third-party plug-ins and built-in plug-ins, which are encrypted, may allow limited editing of the plug-in parameters 
and definition. Options that are not available for editing appear dimmed.
Custom, unencrypted plug-ins are created and edited from the Custom Plug-ins tab of the Plug-in Manager, where you 
can specify the plug-in type, category, parameters, options, and code for a new custom plug-in. Plug-ins are saved as 
described in “Plug-in File Location” on page 1781.
To create a plug-in:

1. Select Tools > Plug-ins > Plug-in Manager.
The Plug-in Manager dialog box opens.

Click to show/hide the parameters.

• Windows XP: C:\Documents and Settings\<Username>\Application Data\Nemetschek\Vectorworks\
2015\Plug-Ins

• Windows Vista/7/8: C:\Users\<Username>\AppData\Roaming\Nemetschek\Vectorworks\2015\Plug-Ins

• Mac: /Users/<Username>/Library/Application Support/Vectorworks/2015/Plug-Ins

Parameter Description

Custom Plug-ins
Plug-ins list Lists available custom plug-ins; the icon to the left of the plug-in name indicates the type of 

plug-in (see “Plug-in Types” on page 1781)
New Creates a new custom plug-in as described in this section
Edit Definition Opens the Edit Plug-in Definition dialog box, to define or edit the properties of the currently 

selected custom plug-in (see “Plug-in Definition” on page 1785)
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2. From the Custom Plug-ins tab, click New.
The Assign Name dialog box opens. Enter the name of the new plug-in item and select the type of the plug-in to 
create. Plug-in names are limited to 27 characters in length. The appropriate plug-in extension will be appended to 
the plug-in name. Plug-ins can contain a Python script for execution. 

Click to show/hide the parameters.

Edit Script Opens the Script Editor window, to create, rename, or edit the code that executes with the 
selected custom plug-in. See “Specifying the Plug-in Script” on page 1788.

Duplicate Creates a copy of the currently selected plug-in; specify a name for the copy in the Assign 
Name dialog box

Delete Deletes the currently selected plug-in; this action cannot be undone
Third-party Plug-ins Lists any third-party plug-ins, and allows third-party plug-ins to be installed, uninstalled, 

and customized as permitted.
• Install: Select the installation files from the third-party script provider; they are 

automatically copied to your plug-ins folder.
• Delete: Removes the plug-in from the Vectorworks program and deletes the plug-in files. 

This action cannot be undone.
• Customize: When permitted by the third-party provider, a selected plug-in may allow 

limited customization. Options that are not available for editing appear dimmed.
Built-in Plug-ins Lists the plug-ins available with the Vectorworks installation; some of these allow limited 

customization as permitted. Options that are not available for editing appear dimmed. 
Examples of built-in plug-in customization are described in “Customizing Photometric 
Threshold Colors” on page 904 and “Customizing Size Settings for Plug-in Objects” on 
page 1792.

Parameter Description

Name of the Script 
Plug-in

Specifies the name of the new plug-in; this is also the name of the plug-in file, 
automatically appended with the appropriate extension (.px, .vsm, .vst, or .vso)

Parameter Description

Enter the name of the new plug-in

Select the type of plug-in
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3. Click OK to create the plug-in item.
4. Define the plug-in properties as described in “Specifying the Plug-in Definition” on page 1784.
5. Add the new plug-in to one or more workspaces with the Workspace Editor. See “Creating or Editing 

Workspaces” on page 1835. Once the item has been added to a workspace, it is available to any open file in 
Vectorworks without the need for importing the associated script into the active file. 

~~~~~~~~~~~~~~~~~~~~~~~~~
Specifying the Plug-in Definition
Scripted Plug-ins

Specifying the Plug-in Definition
Unencrypted, custom plug-ins are listed on the Custom Plug-ins tab of the Plug-in Manager dialog box. Depending on 
the plug-in type, other settings control execution conditions, appearance, stored and default parameters, insertion 
options, and associate a script with the plug-in. Third-party plug-ins, encrypted plug-ins, and built-in plug-ins may 
allow limited editing of the plug-in definition.
~~~~~~~~~~~~~~~~~~~~~~~~~
Plug-in Definition
Specifying the Plug-in Script

The plug-in will be 
created in

Describes the location of the plug-in file; plug-ins are saved in the location indicated so 
that they are not overwritten when installing a new version of Vectorworks software; see 
“Plug-in File Location” on page 1781

Plug-in type Select the type of plug-in to create
Command Menu command ( .vsm) plug-ins can be used like any standard menu command item, 

performing operations on the active Vectorworks file. Menu commands can detect the 
view state of the active Vectorworks file, or can determine if a selection set exists upon 
which the menu command can act.

Tool Tool item ( .vst) plug-ins allow scripts to be added to a Vectorworks workspace as a tool 
palette item. Tools make use of the SmartCursor, and can respond to file state conditions 
such as selection status or view orientation. 

Objects Plug-in objects ( .vso) allow the creation of complex objects such as standard 
architectural or mechanical elements, “smart” drawing components like callouts or 
drawing borders, or other flexible objects which streamline the design process. Plug-in 
objects support standard Vectorworks program core technologies such as snapping, 
classing, and advanced object editing; they can contain up to 32,767 parameters for 
defining and editing the object appearance. 

Point Object Point objects are defined by a single point click for placement
Linear Object Linear objects require a user-defined line to create the basic geometry of the object
Rectangle Object Rectangle objects utilize a user-defined rectangle to define and create the basic geometry 

of the object
2D/3D Path Object Path objects define a user-defined polygonal path or NURBS curve to create the basic 

geometry of the object
Include File Specifies an additional file ( .vss or .px) to be included with a script

Parameter Description
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Plug-in Definition
The parameters that define the appearance of a scripted command, tool, or object plug-in are stored in a parameter 
record, which is associated with each object instance placed in the file. These records store persistent data between uses 
and provide default parameter values. A menu command that displays a dialog box, for example, might need to store 
values entered by a user for later use. A tool might provide several mode options in a popup list. Should the user wish 
to select a different mode for the tool, the new setting can be saved and reused on a subsequent use of the tool item. 
These values can be stored in the parameter record of the menu command or tool and retrieved later when the command 
or tool is selected again. Switching files will display stored values associated with the new files or, if no parameter 
record exists, will display the default values of the parameter record as created by the plug-in item.
The parameters for each object instance can be modified by using the Object Info palette to access the values in the 
object parameter record. A default parameter record is also created when the first instance of an object (or tool) is 
created in the file. This default parameter record, which is distinct from the parameter records associated with object 
instances, stores the object default settings with the file. It is used when placing subsequent object instances to define 
the defaults for each new object instance.
To define the custom plug-in parameters:

1. From the Plug-in Manager Custom Plug-ins tab, select the plug-in to define or edit.
2. Click Edit Definition.

The Edit Plug-in Definition dialog box opens.
Click to show/hide the parameters.

Parameter Description

General
Type Displays the type of plug-in being created (menu command, tool, object, or include file)
Language Displays either Python or VectorScript, depending on the language used for the script 

portion of the plug-in (see “Specifying the Plug-in Script” on page 1788)
Name Specifies the name of the new plug-in; this is also the name of the plug-in file, 

automatically appended with the appropriate extension (.px, .vsm, .vst, or .vso). If 
renaming a plug-in, update the workspace afterwards to update the plug-in name.

Category Assigns a plug-in to a heading category, to easily find the plug-in in the Workspace Editor
Parameters Specifies the default parameters for the plug-in. Default parameters are applied to the 

plug-in at insertion. Parameters are listed in the specified order for the plug-in; change the 
parameter order by dragging within the # column.

Parameters list Lists the default object parameters, alternate (localized) name if applicable, format, and 
default value. For linear objects, the LineLength parameter displays, which contains the 
axis length of the linear object. For rectangular objects, both the LineLength (the initial 
length of the object instance) and BoxWidth (the initial width of the object instance) 
parameters display. New default values can be specified for these parameters, but they 
cannot be deleted.

New Creates a new parameter for the plug-in. The Edit Parameter dialog box opens.
Specify the parameter name, alternate (localized) name if applicable, type, and default 
value, and click OK to create the plug-in parameter.
To create a pop-up list of pre-defined parameter options, select the Pop-up Type. The Edit 
Choices dialog box opens. List the options; each line in the list represents a choice in the 
pop-up. Click OK. To edit the pop-up choices, click Choices.
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Edit Edits the selected plug-in parameter. Certain third-party and built-in plug-ins allow 
parameter editing.

Delete Deletes the selected plug-in parameter
Strings Specifies text strings used by a plug-in 
Strings list Lists the strings used by the plug-in (for example, color selector values that specify a 

certain color to be used by the plug-in)
Add Adds a text string to the plug-in definition. The Add Category dialog box opens.

The next available Resource ID number is assigned automatically; specify the category 
name and click OK.

Edit Edits the currently selected string. The Edit Strings dialog box opens. Select the 
individual string value and click Edit to open the Edit String dialog box.
Specify the string value and then click OK; the value depends on the category; for 
information, see http://developer.vectorworks.net. 

Delete Deletes the currently selected string
Properties Property settings allow plug-ins to behave like standard Vectorworks menu commands, 

tools, and objects. These settings control behavior of the plug-in with respect to the state 
of the file (selection status, view orientation) as well as define the help text to display.
The properties available depend on the plug-in type. Only custom plug-in properties can 
be specified.

 Command
Availability Options For each drawing state, specify whether the condition is required (the drawing state 

condition is necessary for the command to be active), prohibited (the command is 
deactivated if the drawing state condition exists), or can be ignored (the drawing state 
does not affect the command activation)

Tooltip Help Specifies the menu command help text; help text describing the menu command displays 
when the cursor pauses over the command (currently, this is only available on Mac)

Contextual Help 
Override

Enter a URL (starting with http:) to specify a web page containing help information. To 
specify a file relative to the Vectorworks program folder, indicate the path starting with . / 
(period and forward slash).

Version Created Specifies the version number of Vectorworks when the plug-in was created. For example, 
for Vectorworks 2013, 2014, and 2015, use 18, 19, and 20, respectively.

Version Modified Specifies the version number of Vectorworks when the plug-in was last modified. For 
example, for Vectorworks 2013, 2014, and 2015, use 18, 19, and 20, respectively.

Version Retired Specifies the version number of Vectorworks when the plug-in was retired. For example, 
for Vectorworks 2013, 2014, and 2015, use 18, 19, and 20, respectively.

Tool
Tool Bar String Specifies the descriptive text to display in the Tool bar; usually this includes the name of 

the object, and it can include text indicating an action for the user to perform

Parameter Description

http://developer.vectorworks.net
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Icon The default icon for the plug-in can be replaced by a custom icon, if desired. With a 
third-party icon editor, create two versions of the icon: one for a standard-resolution 
display and one for a high-resolution display:

• Standard-resolution: an image centered in an area 26 pixels wide by 20 pixels 
high. Save the icon in .png format.

• High-resolution: an image centered in an area 52 pixels wide by 40 pixels high. 
Save the icon in .png format with the same name as the standard-resolution image 
with “@2x” appended to the end of the file name. For instance, if the 
standard-resolution icon is named 3DModelingToolSet.png, the high-resolution 
icon must be named 3DModelingToolSet@2x.png; otherwise the Vectorworks 
software will be unable to locate the icon.

Click Import PNG Icon to import the standard-resolution icon; if a high-resolution icon 
is also present with the @2x designation, the software automatically imports it as well. 
The Vectorworks program automatically displays the appropriate image for the device’s 
resolution.

Projection Determines what view projection must be active. If 3D projection is required, the view is 
changed. If 2D projection is required, the Screen Plane is activated for the tool. Hybrid 
projection does not affect the view projection.

Execute Script Tools are set by default to execute immediately when selected. In some cases, however, it 
may be desirable to have the script execution wait for mouse movement (such as a tool 
which draws interactively based on user mouse movement).

Contextual Help 
Override

Enter a URL (starting with http:) to specify a web page containing help information. To 
specify a file relative to the Vectorworks program folder, indicate the path starting with . / 
(period and forward slash).

Version Created Specifies the version number of Vectorworks when the plug-in was created. For example, 
for Vectorworks 2013, 2014, and 2015, use 18, 19, and 20, respectively.

Version Modified Specifies the version number of Vectorworks when the plug-in was last modified. For 
example, for Vectorworks 2013, 2014, and 2015, use 18, 19, and 20, respectively.

Version Retired Specifies the version number of Vectorworks when the plug-in was retired. For example, 
for Vectorworks 2013, 2014, and 2015, use 18, 19, and 20, respectively.

Tooltip Help Specifies the help text to display when the cursor pauses over the object icon in a palette
Object

Icon The default icon can be replaced by a custom icon, if desired. With a third-party icon 
editor, create an 8-bit image, centered in an area 26 pixels wide by 20 pixels high. Save 
the icon in .png format, and click Import PNG Icon to import it.

Projection Determines what view projection must be active. If 3D projection is required, the view is 
changed. If 2D projection is required, the Screen Plane is activated for the tool. Hybrid 
projection does not affect the view projection.

Execute Script Objects are set by default to execute immediately when selected. In some cases, however, 
it may be desirable to have the script execution wait for mouse movement (such as an 
object which draws interactively based on user mouse movement).

Default Class Specifies the default class for the object upon insertion; if the class does not exist when 
the object is placed, the class is automatically created

Parameter Description
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3. When the plug-in parameters have been defined, click OK to return to the Plug-in Manager.
~~~~~~~~~~~~~~~~~~~~~~~~~
Specifying the Plug-in Script
Specifying the Plug-in Definition
Scripted Plug-ins

Specifying the Plug-in Script
The script source code for the command, tool, or object can be created using the Script Editor or a third-party text 
editor and imported into the plug-in. The source code is saved as part of the plug-in item. Either Python or VectorScript 
can be used for the code. For third-party or built-in plug-ins, only unencrypted plug-in scripts can be edited.

Contextual Help 
Override

Enter a URL (starting with http:) to specify a web page containing help information. To 
specify a file relative to the Vectorworks program folder, indicate the path starting with . / 
(period and forward slash).

Version Created Specifies the version number of Vectorworks when the plug-in was created. For example, 
for Vectorworks 2013, 2014, and 2015, use 18, 19, and 20, respectively.

Version Modified Specifies the version number of Vectorworks when the plug-in was last modified. For 
example, for Vectorworks 2013, 2014, and 2015, use 18, 19, and 20, respectively.

Version Retired Specifies the version number of Vectorworks when the plug-in was retired. For example, 
for Vectorworks 2013, 2014, and 2015, use 18, 19, and 20, respectively.

Tooltip Help Specifies the help text to display when the cursor pauses over the object icon in a palette
Options 
(custom parametric 
object types only)
Execution Options Objects, like symbols, can be assigned predefined insertion options for document 

placement. These options allow objects to properly interact with walls or other advanced 
Vectorworks object types. Command and tool plug-ins do not have insertion option 
settings.
By default, object geometry will only be recalculated if the object parameters or control 
points are edited. When object geometry is recalculated, file default settings for attributes 
such as font, text size, or line color will be reapplied to the object. If any of these settings 
have been modified since the object was placed or last edited, changes in the appearance 
of the object may occur.
The script is called whenever the object parameters have changed. Additionally, for 
instances where it is important for the object to recalculate (for example, windows placed 
in a wall), the script can cause geometry to be recalculated when the object is rotated 
(Reset on Rotate) or moved (Reset on Move).
Alternatively, the plug-in script can become an event handler (Event-Based); scripts must 
then respond to a small set of application events. For samples and documentation on event 
handling scripts, access the Support area at www.vectorworks.net 

Insert in Walls Select the wall insertion option settings for the object. See “Creating New Symbols” on 
page 239.
For objects that do not require insertion options, leave the options at the default settings.

Parameter Description

http://www.vectorworks.net/support/custom/vscript/example.php
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To create script code:
1. Click the Script button from the Plug-in Manager dialog box.

Enter the script source code in the Script Editor window. See “Creating Scripts” on page 1776 for more 
information. For detailed developer-oriented documentation, please navigate to http://
developer.vectorworks.net

2. Click OK to save the script as part of the plug-in.
During plug-in development, scripts can be easily compiled and tested when developer mode is enabled in the 
Session tab of Vectorworks preferences.

~~~~~~~~~~~~~~~~~~~~~~~~~
Specifying the Plug-in Definition
Scripted Plug-ins

Creating Custom Path Objects
The Create Objects from Shapes command supports custom path objects (custom path plug-in objects with a .vso 
extension). 

For information on creating custom path objects, see “Scripted Plug-ins” on page 1781.
To add a custom path object to the Create Objects from Shapes command:

1. Ensure that the custom path object file is located in the Vectorworks\Plug-Ins folder.
2. Select Tools > Plug-ins > Plug-in Manager.

The Plug-in Manager dialog box opens. Click on the Built-in Plug-ins tab.

http://developer.vectorworks.net
http://developer.vectorworks.net
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3. In the list of VectorScript plug-in objects, select Objects from Polyline.
Press the letter O key to quickly access Objects from Polyline in the list.

4. Click Customize.
The Customize Plug-in dialog box opens. Click on the Strings tab.
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5. Select Resource ID 6000, User Defined Path Objects, and click Edit.
The Edit Strings dialog box opens.

6. Select ID 6001, and click Edit.
The Edit String dialog box opens. Enter the number of custom path objects that will be added, and click OK. (If 
adding one path object, enter 1.)

7. Click OK.
8. In the Edit Strings dialog box, click Add.
9. Enter the name of the path object that should be used in the command list, and then the actual name of the plug-in 

object file (without the .vso extension), separated by a colon.

10. Click OK to return to the Edit Strings dialog box.
The custom path object ID and string are listed.
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11. Repeat steps 8-10 for each custom path plug-in object to add.
12. Click OK twice, and then Close, to exit the Plug-in Manager.
13. The custom path object is included in the list of path objects created by the Create Objects from Shapes 

command.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Objects from Shapes

Customizing Size Settings for Plug-in Objects
User-defined sizes can be created for eye bolts, J-bolts, swing bolts, swing eye bolts, T-bolts, U-bolts, and tapped holes. 
Use the following procedures to add or remove sizes for use with these plug-in objects. Sizes are then assigned through 
the Object Info dialog box for the applicable object.
To add or remove plug-in object sizes:

1. Select Tools > Plug-ins > Plug-in Manager.
The Plug-in Manager dialog box opens. Click on the Built-in Plug-ins tab.

2. Select the plug-in object to be edited, and then click Customize. 
The Customize Plug-in dialog box opens. Click on the Parameters tab.

3. Select the size parameter and click Edit. 
The Edit Parameter dialog box opens.

4. Click Choices.
The Edit Choices dialog box opens. 

5. To remove a size, highlight it and press the Backspace key. To add a new size, insert the cursor in the desired 
location in the list of sizes. Enter the new parameters. To edit a size, simply type over the existing parameters. Use 
the following guidelines to add or edit a size:
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Do not leave blank lines in the list of sizes. Also, if sizes are added to a 2D plug-in object that has a 3D 
counterpart, the same sizes must be added to the 3D plug-in object in order for the Create 3D Object from 2D 
command to work properly.

6. Click OK to accept the changes, and then continue to click OK until you can close the Plug-In Manager dialog 
box. 

The VectorScript Debugger
If you prefer using VectorScript over Python for your scripts, VectorScript provides a powerful tool to assist in solving 
problems that may occur while developing scripts. This tool, known as a source-level debugger, controls the execution 
so that the internal operations of the script can be observed while the script is running. Using the debugger, it becomes 
possible to locate and solve problems by moving through the script line by line to view the associated data, variables, 
and flow of script execution.
For a detailed description of the VectorScript debugger and VectorScript, please navigate to the detailed 
developer-oriented documentation at http://developer.vectorworks.net

Size Description

Inch Enter the size as a fraction or decimal. Enter a dash as a separator (with optional spaces before and 
after). Enter the threads per inch. Example: 1/2 - 20

Metric Enter either an upper or lowercase “m.” Enter the nominal size in millimeters. Enter either an upper or 
lowercase “x” as a separator (with optional spaces before and after). Enter the thread pitch. Example: 
M8 x 1.25

http://developer.vectorworks.net


  1794 | The VectorScript Debugger



Database Connectivity
ODBC Workflow
The Vectorworks Design Series products include the ability to communicate with external databases according to Open 
Database Connectivity (ODBC) standard. Using ODBC, a set of data can be used to automatically update the records 
attached to objects. Similarly, Vectorworks objects can send object data to a database, updating it. To successfully use 
ODBC in Vectorworks Design Series products, a database management system is required, and steps need to be 
followed to set up the connection and manage the data flow. 

1. Configure and set up data in the database program of your choice. Database connectivity in Vectorworks software 
is supported for the following database systems:
• Microsoft Excel
• FileMaker Pro
• Microsoft Access
• MySQL
• SQLite*
• Any database that supports ODBC and has either Mac or Windows drivers
Database and/or operating systems typically include a separate ODBC Administrator or Manager application, 
which defines drivers and data sources. Database drivers may need to be installed. See “ODBC Driver 
Information” on page 1818.
The installation, setup, and usage of database systems is beyond the scope of this help system and is not described 
here. Please consult the documentation related to your operating system or database software for information.
* SQLite database files do not require an ODBC manager or server. For information on SQLite, visit http://
www.sqlite.org 

2. Set up the connection between Vectorworks software and the database system. A “key” column with unique 
values is designated, to establish and maintain the communication between the database system and Vectorworks 
record formats.

3. Identify the object instances of each type of object to be connected, and define the link between the database and 
the record formats of the object types.

4. When connections have been established, determine the settings to update the Vectorworks record formats from 
the database, and to update the database from the Vectorworks object records. The two-way communication 
process can be automated.

~~~~~~~~~~~~~~~~~~~~~~~~~
Database-Vectorworks Communication
Database Setup
Database Connection
Record Format Database Connection
Object Database Connection
Automating Database Connection Workflows
Specifying Update Settings
ODBC Driver Information

Database-Vectorworks Communication
The values in a database link to the record fields of an object instance through a series of connections made between the 
database software and the Vectorworks software. 

http://www.sqlite.org
http://www.sqlite.org
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One or more columns of the database table must have unique values. These Key columns are used by the Vectorworks 
program to uniquely identify the database rows.
Database setup consists of identifying the key column(s) and setting up each type of connection, and then specifying 
update settings for the flow of data.
~~~~~~~~~~~~~~~~~~~~~~~~~
Database Setup
Database Connection
Record Format Database Connection
Object Database Connection
Specifying Update Settings
ODBC Workflow

Database Setup
In Vectorworks Design Series products, open the ODBC Data Source Administrator (Windows) or ODBC Manager 
(Mac). The standard drivers may already be installed for the major database providers; verify this on the Drivers tab. 
More information on drivers is available in “ODBC Driver Information” on page 1818. Add the database file, 
providing a name for it. This makes the database available through the ODBC administrator. 

SQLite database files do not require an ODBC manager, so setting up the database drivers is not necessary.

Database Column
Database Table 

Database Row

Key Column

Record Format Record Instance Record Field

Vectorworks

Database



Database Connection |  1797
~~~~~~~~~~~~~~~~~~~~~~~~~
Database Connection
Record Format Database Connection
Object Database Connection
Specifying Update Settings
ODBC Workflow
Database-Vectorworks Communication

Database Connection
In the Vectorworks file, connect the database to the file and then select a Key identifier for each data source.
To establish the connection between the database and the Vectorworks file:

1. Open the Vectorworks drawing. Database connection information is saved in the Vectorworks file.
2. Select Tools > Database > Manage Databases.

The Manage Databases dialog box opens. Through this dialog box, manage available databases and connect the 
desired database or databases to the current file.
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3. Since the connection has not yet been made, the Available Databases list is empty. Click Connect.
The Database Connection dialog box opens.

Click to show/hide the parameters.

Parameter Description

Use Data Source 
Name

Connect to a database source that was previously added to the ODBC manager or ODBC 
administrator; click Refresh to update the choices
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4. Either select the SQLite file, or the named database added to the ODBC manager/administrator earlier, enter a 
User Name and Password if required, and click OK.

5. The selected database is added to the list of available databases in the Manage Databases dialog box. The tables 
associated with the Layout database are listed on the left, with the database table columns listed on the right.

6. Select one of the available database tables; its rows display on the right. Select one of the rows to serve as the Key 
identifier by clicking in the Use as Key column for that row. The Key column uniquely identifies the data rows in 
the table. By default, this is one of the columns with unique data, used as a row identifier. 
The ability to select the Key depends on the database driver. If needed, click Show Table to display the table’s 
contents and help select an appropriate Key.

7. Select the Key identifier for any other database tables. Each table must have at least one column selected as Use as 
Key.

8. Click Connect if there are other databases to connect, and identify the Key for each additional table.
9. Once the database tables have been selected and connected, and the Key identifier(s) set for each table, click OK.

The data sources have now been properly connected and identified for the file.

Use Connection String On Windows, this option allows temporary creation of data sources from files, or can 
select the known data source name similarly to the Use Data Source Name option. Click 
Build and select the database from the Machine Data Source tab. The connection string 
cannot be built from a specified source on the Mac.

Use SQLite File Click Browse to select and connect to an SQLite database file; this type of database 
connection is indicated as [sqlite] in database-related dialog boxes.

If no SQLite file exists, browse to an appropriate location and enter a file name to 
automatically create an empty SQLite database file.

User Name/Password If a database connection requires a user name/password, enter the information

Parameter Description
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If the connection to the database becomes out of date, select the database and click Renew Connection to 
re-establish the database connection. Table and column information data is updated.
If there are problems connecting to the database, an error message provides troubleshooting information. Click 
Details to open a log file in the default text editor application. The log file provides further information to help 
diagnose connection errors.

~~~~~~~~~~~~~~~~~~~~~~~~~
Database Setup
Record Format Database Connection
Object Database Connection
Specifying Update Settings
Database-Vectorworks Communication

Record Format Database Connection
Each field of the record format needs to be mapped to the appropriate database table column. The record connections 
can be saved in an xml file and imported into another file.

Record formats can be automatically created and linked to the database table; see “Automatically Creating Record 
Formats from a Database Table” on page 1811.

To connect the desired record format to the database table:
1. Select Tools > Database > Record Format Connection. Alternatively, select a record format in the Data tab of 

the Object Info palette for a selected object with the desired record attached, and then click Record Format 
Database Connection.
The Record Format Database Connection dialog box opens, showing available record formats and parametric 
objects in the file. Each record format can be linked to a data source that has already been connected to the file.

Click to show/hide the parameters.
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2. Select the record format and click Edit.
The Edit Record Format dialog box opens, with additional database controls available due to the presence of the 
database connection.

3. Select Database Connection to link the record format fields to the selected database and table. This area only 
displays for record formats when a database is connected in the file.
If needed, verify or change the connected database by clicking Manage Databases, or check the table selected in 
Table Name to view the table contents.

4. Click Connection Options to specify database connection update options.

Parameter Description

Record Formats in the 
Document

Lists the record formats available in the Vectorworks file, as well as the databases and 
database tables to which they are connected

New Creates a new record format as described in “Creating Record Formats” on page 262
Edit Opens the Edit Record Format dialog box, to link the record format to the specified 

database and table
Delete Deletes the selected record format from the file
Export as Database 
Table

Automatically creates database table rows from the selected record format; see 
“Automatically Creating a Database Table from a Record Format” on page 1813

Manage Databases Opens the Manage Databases dialog box, to connect to available databases; see 
“Database Connection” on page 1797

Import Connections Imports the connection settings from an external .xml file, overriding any existing 
database connections. This allows the connections specified from another file to be used 
in this file.

Export Connections Exports the current connection settings to an .xml file
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The Connection Options dialog box opens. Select the actions to occur in the database table when the connected 
record format, or object with the record attached, is edited. (These changes occur at the time of database update set 
in “Specifying Update Settings” on page 1817; alerts inform you of any changes to the database.)

5. Click OK to return to the Edit Record Format dialog box.
Click to show/hide the parameters.

6. For each record field, assign a database table from the selected database. Select a record field and click Edit.
The Edit Field dialog box opens.

7. Select the associated table row from the database in DB Table Column, and select the method of database 
communication in DB Link Type:
• Read/Write: Allows data to move in both directions between the database and the Vectorworks file
• Read Only: Allows database information to be read into the Vectorworks file, but does not allow record data to 

modify the database
• Write Only: Allows the Vectorworks file data to modify the database, but does not allow the database 

information to modify the Vectorworks record field
8. Click OK to return to the Edit Record Format dialog box. The dialog box updates to display the associated table 

data and link type.
Click in a DB Read/Write column to easily change the link type for the selected row.

Parameter Description

Add new rows in Database Table 
when creating Records of this 
Format

When a new record format is created, automatically adds a database table row 
to the connected database

Delete the row in the Database 
Table when removing Records of 
this Format

When a record format is disconnected from an object, or an object with a 
connected record format is deleted, automatically deletes the row that was 
connected to the object in the database table
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9. Once the data has been linked for each record field, click OK. The fields in the record format have now been 
linked to the table data in the specified database, and the link type has been defined. On the Data tab of the Object 
Info palette, connected record formats display with the name of the connected database and its table.

~~~~~~~~~~~~~~~~~~~~~~~~~
Database Setup
Database Connection
Object Database Connection
Specifying Update Settings
Record Formats
Database-Vectorworks Communication

Object Database Connection
The final step in setting up a database connection is to connect object instances to the database. Once connected, the 
connection can be edited. The connection can also be removed.
~~~~~~~~~~~~~~~~~~~~~~~~~
Single Object Connection
Multiple Object Connection
Editing Object Connections
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Removing Object Connections
Database Setup
Database Connection

Single Object Connection
To connect a database to an object:

1. Select an object.
2. On the Data tab of the Object Info palette, click the box for the selected format to attach the record format to the 

object instance. (See “Attaching Record Formats to Symbols and Objects” on page 263.)
The Record Fields display with default values from the record format.

3. Select Tools > Database > Object Connection. Alternatively, click Object Database Connection from the Data 
tab of the Object Info palette.
The Object Database Connection dialog box opens. If a row was previously selected for the object, it appears 
highlighted and bolded.

Click to show/hide the parameters.

Parameter Description

Available Records Lists the record formats available for the selected object
Database Connection Opens the Record Formats Database Connection dialog box, to connect a record format 

to a database table
Add New Database 
Table Row

Inserts a new row in the database table, and associates it with the object
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4. Click Use Selected Database Table Row, and then select the appropriate row for the selected object.
5. Click OK.
6. The record fields are populated from the database table for the record instance attached to the object.

~~~~~~~~~~~~~~~~~~~~~~~~~
Multiple Object Connection
Editing Object Connections
Removing Object Connections
Database Setup
Database Connection
Record Format Database Connection
Specifying Update Settings
Record Formats
Database-Vectorworks Communication

Multiple Object Connection
When there are multiple similar objects that should be identically connected to database tables through attached record 
formats, it would be tedious to connect each one. The connection for multiple objects can be made at one time.
To connect a database to multiple objects:

1. Select several objects of the same type; for example, select several space objects.
2. Select Tools > Database > Object Connection. Alternatively, click Object Database Connection from the Data 

tab of the Object Info palette.
The Multiple Objects Database Connection dialog box opens. By selecting a format field and selecting search 
filter criteria, the table rows associated can be searched.

Use Selected Database 
Table Row

Allows the database table row from the linked database table list to be selected, 
associating an existing row with the object

Database Table Rows Selects a table row to associate with the object; this row provides data for the selected 
object or receives data from the selected object

Parameter Description
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Click to show/hide the parameters.

3. Select a Format Field, and then click in the Find by Value column to select the field as a search filter.

Parameter Description

Available Records Lists the record formats available for the selected objects (only record formats 
that are common to the selected objects display)

Database Connection Opens the Record Formats Database Connection dialog box, to connect a record 
format to a database table

Add New Database Table 
Rows

Inserts a new row in the database table for each selected object, and associates 
each row with each object

Find Row by Value (exclude 
objects with existing object 
connection)

Only the format fields connected to a database are listed. Selects a format field, 
and uses the value from the selected objects that are not already connected to a 
database, to search the database table for a particular row. (Once the row is found, 
the Key identifier is used to link the table row to the record fields.)

Find Row by Value (for all 
objects) 

Only the format fields connected to a database are listed. Selects a format field, 
and uses the value from the selected objects to search the database table for a 
particular row. (Once the row is found, the Key identifier is used to link the table 
row to the record fields.)

Show Database Table Opens the Database Table dialog box, to view the database table associated with 
the record format and help determine which column to use for the search criteria

When this dialog is dismissed Determines the selection status of resolved objects, or of unresolved objects that 
may require further attention to connect them. Select do not change selection to 
make no change to the number of selected objects.
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4. On the right, the status of resolved objects indicates how many of the selected objects had data found in the 
database tables based on this search. When objects are resolved, their record field data is properly connected to the 
database table.

5. Click OK. For each resolved object, the record fields are populated from the database table for the record instance 
attached to the objects.
Resolved objects are connected to the corresponding rows using the Key identifier, and then each row is 
associated with the corresponding object.

~~~~~~~~~~~~~~~~~~~~~~~~~
Single Object Connection
Editing Object Connections
Removing Object Connections
Database Setup
Database Connection
Record Format Database Connection
Specifying Update Settings
Record Formats
Database-Vectorworks Communication

Editing Object Connections
The read/write queries of an object connection can be viewed and edited for one or several selected objects.
To edit object connections:

1. Select one or more objects. The objects should already be connected to a database.
2. Select Tools > Database > Edit Object Connection. 

The Edit Object Connection dialog box opens. The reading and writing SQL queries for the selected object(s) 
display and can be edited, either individually for each selected object, or for all the objects at once.
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Click to show/hide the parameters.

Parameter Description

Available Records Lists the record formats available for the selected objects (when multiple objects are 
selected, only record formats that are common to the selected objects display)

Modify selected 
objects individually

Edits the reading and writing SQL queries of each selected object individually, by 
scrolling through each one

Modify selected 
objects in bulk

Edits the reading and writing SQL queries of all the selected objects at one time using 
record name identifiers; scrolling through the selected objects is not necessary

Reading Query Shows the reading SQL query for the selected object(s)
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Protocol Reading SQL queries consist of the following rows:
• SELECT: indicates the column names, in brackets separated by commas

Example: [id],[room name],[area]
• FROM: indicates the name of the database and table, in brackets separated by periods

Example: [SpaceInfo].[dbo].[Spaces]
• WHERE: indicates the name and value of the record format, with the record format 

name in brackets and the value (or identifier in angle brackets) separated by an equal 
sign
Example: [area]=30 or [area]=<area>

When editing a single query that applies to multiple selected objects (Modify selected 
objects in bulk is selected), use an identifier within angle brackets for the WHERE 
record field name, instead of the actual value. Using an identifier in angle brackets 
allows the query to proceed for all selected objects regardless of each object’s actual 
value.

Test Query Tests the current reading SQL query to see if it is valid; this is useful for verifying 
queries before committing to the changes. An alert indicates whether the test query was 
successful or invalid

Reset If the reading SQL query has been modified, returns the query to its original settings
Writing Query Shows the writing SQL query for the selected object(s)

Protocol Writing SQL queries consist of the following rows:
• UPDATE: indicates the name of the database and table, in brackets separated by 

periods
Example: [SpaceInfo].[dbo].[Spaces]

• SET: indicates the name and value of the table column, with the column name in 
brackets and the value (or record format field name in angle brackets) separated by an 
equal sign
Example: [Room Name]=Kitchen or [Room Name]=<name>

• WHERE: indicates the name and value of a search condition, such as column name 
and value, with the search item name in brackets and the value (or record format field 
name in angle brackets) separated by an equal sign
Example: [id]=1 or [id]=<identifier>

When editing a single query that applies to multiple selected objects (Modify selected 
objects in bulk is selected), use a record format field name within angle brackets for the 
SET and/or WHERE value, instead of the actual value. Using a record format field name 
in angle brackets allows the query to proceed for all selected objects regardless of each 
object’s actual value.

Test Query Tests the current writing SQL query to see if it is valid; this is useful for verifying queries 
before committing to the changes. An alert indicates whether the test query was 
successful or invalid.

Reset If the writing SQL query has been modified, returns the query to its original settings

Parameter Description
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3. View or edit the object connection information, and then click OK.
If there are validation problems, an error message provides information. The cursor is automatically placed in the 
field where the problem exists to help identify the problem.

~~~~~~~~~~~~~~~~~~~~~~~~~
Single Object Connection
Multiple Object Connection
Removing Object Connections
Database Setup
Database Connection
Record Format Database Connection
Specifying Update Settings
Record Formats
Database-Vectorworks Communication

Removing Object Connections
The connection between an object and a database can be removed.
To remove object connections:

1. Select one or more objects. The objects should already be connected to a database.
2. Select Tools > Database > Remove Object Connection. 

The database is disconnected from the object(s).
~~~~~~~~~~~~~~~~~~~~~~~~~
Single Object Connection
Multiple Object Connection
Editing Object Connections
Database Setup
Database Connection
Record Format Database Connection
Specifying Update Settings
Record Formats
Database-Vectorworks Communication

Automating Database Connection Workflows
In the Vectorworks Design Series, the functionality for connecting to a database and then establishing object/record 
format database linking contains built-in automation features to make the job easier. While it is still necessary to know 
how to accomplish the steps manually, dynamic updating between the Vectorworks file and the connected database 
allows record formats to be automatically created from a database table, and database tables to be automatically created 
from record formats. Connections are automatically established, and remain up to date.
~~~~~~~~~~~~~~~~~~~~~~~~~
Automatically Creating Record Formats from a Database Table
Automatically Creating a Database Table from a Record Format

< or > When multiple objects are selected with the Modify selected objects individually 
option enabled, scrolls among the objects to display each object’s queries for editing

Show Object Displays the current object in the drawing window for identification

Parameter Description
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Automatically Creating Record Formats from a Database Table
Record formats can be created from database tables. The imported tables are automatically linked to the new record 
formats.
To create record formats from a table in a connected database:

1. Select Tools > Database > Manage Databases.
The Manage Databases dialog box opens.

2.  Select the database on the left, and then click Import Table.
The Import Table dialog box opens. 
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Click to show/hide the parameters.

3. Select the columns from the database that will become record fields in the new record format by placing a check 
mark in the left column. For each selected column, specify the record field name, type, and connection type. For 
more information on connection types, see “Record Format Database Connection” on page 1800.

4. Click OK. 
Each selected table column in the database table becomes a record field in the new record format. The record 
fields are automatically connected to the database according to the connection type specified.

~~~~~~~~~~~~~~~~~~~~~~~~~
Automatically Creating a Database Table from a Record Format

Parameter Description

Database Table 
Name

Displays the name of the selected database

New Record Format 
Name

Specifies the name of the new record format to create; the suggested name is based on the 
database table name, but it can be changed

New Record Format 
Fields connection

Lists the database columns and the corresponding record field and type; database fields 
with a check mark in the left column become record fields in the Vectorworks file

Selection Specifies the parameters and link type for the selected record field to be created; the 
Record Field Name, Record Field Type, and Database Link Type are suggested based 
on the column information, but they can be changed
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Specifying Update Settings
Record Format Database Connection

Automatically Creating a Database Table from a Record Format
Database tables can be created from record formats. These steps quickly create a database table and link objects to it:

• Connect to a database as described in “Database Connection” on page 1797. Connecting to an empty sql database 
is the easiest method.

• Select the record format and create the database rows as described in the following steps.
• Connect the objects with that record format to the database table as described in the following steps. The new 

tables are automatically linked to the record formats.
To create a database table from a record format:

1. Select Tools > Database > Record Format Connection.
The Record Format Database Connection dialog box opens, listing the record formats available in the current file.

2. Select the record format, and then click Export as Database Table.
The Export as Database Table dialog box opens.
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Click to show/hide the parameters.

Parameter Description

Format Name Displays the name of the selected record format
Database Lists the databases connected to the current file; select the database to receive the new 

table
New Database Table 
Name

Specifies the name of the new data table to create; the suggested name is based on the 
record format name, but it can be changed

New Database Table 
Columns connection to 
Record Format Fields

Lists the columns and rows, based on the record format fields, that will become database 
table columns; the table column names are based on the record fields, but they can be 
changed in Selection.
Remove any record format rows for data that does not need to be connected to a database.

Key Selects which field from the record format is used to match the object records to the 
particular rows in the database. A key must be selected.

Add Adds table rows; select each added row and specify its properties in Selection.
This action does not affect the existing record format in the file.
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3. Specify the parameters of the database table columns to be created. The columns will be created in the order listed; 
to change the order of a database table column, click and drag within the # column.

4. Click Close to return to the Export as Database Table dialog box and make any further necessary table column 
adjustments.

5. Click OK. 
Each record field in the format becomes a column in the new database table.

6. The database rows are currently empty; the objects in the drawing need to be connected to the table to fill in the 
data. In this example, the plant record database table was created, so plants in the drawing need to be connected. 
Select all plants in the drawing.
Use the Select Similar tool to easily select all objects of a particular type that should be connected to the database.

7. Select Tools > Database > Object Connection. 
Since several objects were selected, the Multiple Objects Database Connection dialog box opens.

Remove Removes selected table row(s), when one or more record formats does not need to be 
used as the basis for a database table column.

This action does not affect the existing record format in the file.
Selection Specifies the parameters for the selected table column to be created; the Database Table 

Column Name, Database Table Column Type, Database Link Type, Format Field 
Name, and Format Field Type are suggested based on the record format information, 
but they can be changed. 

A column can be created in the database table, but not be connected to a record 
format field, by selecting <not connected> in the Format Field Name list.

Parameter Description



  1816 | Automating Database Connection Workflows
8. Select the applicable record from the Available Records list, and then select the Add New Database Table Rows 
option.

9. Click OK.
10. To verify that the database rows exist and have been populated with data, select Tools > Database > Manage 

Databases. The database rows have been created for the selected record format.

11. Click Show Table.
A dialog box opens, showing the database table for the associated record format.

12. The objects with the record are connected to the rows of the database table. The table is filled with data from the 
record formats of the objects in the drawing.

~~~~~~~~~~~~~~~~~~~~~~~~~
Automatically Creating Record Formats from a Database Table
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Specifying Update Settings
Record Format Database Connection

Specifying Update Settings

Setting Update Frequency
Database or Vectorworks file updates can be executed automatically or manually. The update settings control the 
frequency of automatic updates, or only permit manual updates.
If there are problems connecting to the database, an error message provides troubleshooting information. Click Details 
to open a log file in the default text editor application. The log file provides further information to help diagnose 
connection errors.
To specify update settings:

1. Select Tools > Database > Update Settings.
The Update Database Settings dialog box opens. Specify the update parameters.

Click to show/hide the parameters.

2. Click OK.

Manually Updating the Database
If the record fields have been changed for objects with linked fields to a database table, and the link type for the field is 
set to Read/Write or Write Only, the drawing data can update the database table data.
Select Tools > Database > Update External Database.

Manually Updating the Vectorworks File
If database information has changed, and the link type for connected record fields is Read/Write or Read Only, the 
information can be automatically sent to the Vectorworks file, updating the record fields of all object instances 
connected to the database.
Select Tools > Database > Update Vectorworks Document.
~~~~~~~~~~~~~~~~~~~~~~~~~
Database Setup
Database Connection

Parameter Description

Update database Sets the frequency of updates from the Vectorworks file to the database
Manually The database is only updated by selecting the Update External Database command
Every record 
change

Updates the database each time a record field value changes in Record Info

Every __ minutes Updates the database after a set number of minutes
Update Vectorworks 
document

Sets the frequency of updates of the Vectorworks file from the database

Manually The Vectorworks file is only updated by selecting the Update Vectorworks Document 
command

Every __ minutes Updates the file after a set number of minutes
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Record Format Database Connection
Object Database Connection
Database-Vectorworks Communication

ODBC Driver Information
When setting up a database program for ODBC functionality, related drivers may not be installed. This list describes 
drivers available for each platform, where to obtain them, and current problems that may exist.

SQLite database files do not require an ODBC manager. 

Windows
On Windows, the ODBC manager is integrated into the operating system (OS).

* On Windows 7 64-bit systems, you need to run the 32-bit ODBC manager (odbcad32.exe) to see the built-in drivers, 
which are currently 32-bit only. 
** FileMaker Pro includes the driver needed to share your database as a data source. To use your FileMaker database 
file locally, FileMaker Pro must be running, and the database file opened and shared. To share your FileMaker database 
file as a data source over a network, use FileMaker Server Advanced. 

Mac
On the Mac, there is no integrated ODBC manager. Suggestions include:

• ODBC Manager (http://www.odbcmanager.net)
• iODBC Manager (http://www.iodbc.org)
• ODBC Administrator Tool (http://suport.apple.com/kb/DL895)

Driver Name Driver Driver 
Connection

Update 
Vectorworks 
records by 
reading data 
from database

Update database 
with Vectorworks 
record data

Add new 
database table 
rows through 
object 
connection

Microsoft 
Access

Integrated* in the OS Supported, 
working

Supported, 
working

Supported, 
working

Supported, 
working

Microsoft 
Excel

Integrated* in the OS Supported, 
working

Supported, 
working

Supported, 
working

Supported, 
working

Microsoft 
SQL Server

If not integrated in 
the OS, ask vendor

Supported, 
working

Supported, 
working

Supported, 
working

Supported, 
working

Microsoft 
Text Driver

Integrated* in the OS Supported, 
working

Supported, 
working

Supported, 
working

Supported, 
working

MySQL Available at:
www.mysql.com 

Supported, 
working

Supported, 
working

Supported, 
working

Supported, 
working

FileMaker Pro 
**

Available at:
www.filemaker.com 

Supported, 
working

Supported, 
working

Supported, 
working

Supported, 
working

http://www.iodbc.org
http://www.odbcmanager.net
http://www.mysql.com
http://www.filemaker.com
http://support.apple.com/kb/DL895
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* FileMaker Pro includes the driver needed to share your database as a data source. To use your FileMaker database file 
locally, FileMaker Pro must be running, and the database file opened and shared. To share your FileMaker database file 
as a data source over a network, use FileMaker Server Advanced. 
~~~~~~~~~~~~~~~~~~~~~~~~~
Database Setup

Driver Name Driver Driver 
Connection

Update 
Vectorworks 
records by 
reading data 
from database

Update database 
with Vectorworks 
record data

Add new 
database table 
rows through 
object 
connection

Actual SQL Available at:
www.actualtech.com 

Supported, 
working

Supported, 
working

Supported, 
working
Problem 
reported: data 
length restriction 
when writing to 
database

Supported, 
working
Problem 
reported: data 
length restriction 
when writing to 
database

Actual 
Access

Available at:
www.actualtech.com

Supported, 
working

Not supported Not supported Not supported

MySQL Available at:
www.mysql.com 

Supported, 
working

Supported, 
working

Supported, 
working

Supported, 
working

FileMaker 
Pro *

Available at:
www.filemaker.com 

Supported, 
working

Supported, 
working

Supported, 
working

Supported, 
working

http://www.actualtech.com
http://www.actualtech.com
http://www.mysql.com
http://www.filemaker.com
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Utilities
Obtaining Engineering Properties
The Engineering Properties command automatically calculates the engineering properties of a 2D object.
To determine the engineering properties of an object:

1. Select a single object, or select a single object and a locus point.
2. Select Model > Engineering Properties.

The Engineering Properties dialog box opens. The data that displays is selection-dependent.
For a single closed surface, the following displays:
• Plane properties (area, perimeter, and absolute coordinates of the centroid of the object)
• Moments of inertia, section modulus’, and radii of gyration about the object’s centroidal axes
For a single closed surface and a locus point, the moments of inertia and radii of gyration about the axes that pass 
through the locus are also displayed, as well as the horizontal and vertical distances from the locus to the centroid 
of the object.

3. Select the desired options and units.
Click to show/hide the parameters.

4. Click OK.

Obtaining Volumetric Properties
The volumetric properties of a 3D object can be obtained with the Volumetric Properties command.
To obtain the volumetric properties of a 3D object:

1. Select the 3D object.
2. Select Model > Volumetric Properties.

The Volumetric Properties dialog box opens, displaying the surface area, volume, and center of mass of the object.
Click to show/hide the parameters.

3. Set the parameters and click OK. If Place locus at center of mass was selected, the 3D locus is placed 
automatically on the object. If Place properties on drawing was selected, click in the drawing file to specify the 
location of the text.

Parameter Description

Units Update the displayed information to reflect the selected unit of measurement
Place locus at centroid Select to add a locus at the centroid of the selected object after closing the 

Engineering Properties dialog box
Place properties on drawing Select to place a list of the properties at the next mouse click after closing the 

Engineering Properties dialog box
Write properties to a file Select to send the properties to a text file; specify the file name and location after 

closing the Engineering Properties dialog box

Parameter Description

Place locus at center of mass Places a 3D locus at the center of mass of the object
Place properties on drawing Places the volumetric properties as text on the drawing at a specified location
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Compressing Images
The bitmap images and image resources in a Vectorworks file can be compressed with the JPEG compression method, 
to save file space. JPEG compression can significantly reduce bitmap image file size, but can result in the loss of fine 
detail for some images.
The compression method and file size for a selected image display in the Object Info palette. Images that are already 
compressed by the JPEG compression method remain unchanged.
A selected bitmap file displays “Bitmap” as the object type at the top of the Object Info palette. A bitmap file may 
already have had PNG compression applied at import; the Compress Images command changes its compression 
format to JPEG.

Compressing Selected Bitmap Images
To compress selected bitmap images:

1. Select the bitmaps to be compressed.
2. Select Tools > Compress Images. 

The Compress Images dialog box opens.
3. Select Apply JPEG Compression to Selected Bitmap Objects. Click OK to compress the selected images.

Compressing All Bitmap Images and/or Image Resources
The JPEG compression method can be applied to all bitmap images in the file. For the best possible reduction in file 
size, images that have been imported as resources (shown as image resources in the Resource Browser) can also be 
compressed by the JPEG compression method.
To compress all bitmap images and/or image resources:

1. Select Tools > Compress Images.
The Compress Images dialog box opens.

2. Select Apply JPEG Compression to All. Choose whether to apply the JPEG compression to all bitmap images in 
the drawing, image resources, or both. Click OK to compress the images.

Tracing Bitmaps
The Trace Bitmap command traces bitmap objects and picture objects (images which have been imported with the 
Import PICT as Bitmap command). It creates a group of vector lines from the image.
To trace a bitmap or picture object:

1. Select the image to trace.
2. Select Modify > Trace Bitmap.

The Trace Bitmap dialog box opens.
Click to show/hide the parameters.

3. Set the parameters and click OK.

Parameter Description

Maximum width in pixels Specify the maximum number of pixels to be recognized as a single line; pixel 
counts above the selected value are traced

Collinearity Sensitivity Select a value to define the segment size and accuracy of the trace
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The time it takes to trace the image can vary from seconds to hours. The tracing time required is determined by the 
image size, as well as the line threshold and collinearity sensitivity settings selected.

Creating 3D Objects from 2D Objects
The Create 3D Object from 2D command places a 3D version of a 2D object in a drawing. The command applies to 
the following 2D objects with 3D counterparts.

Acorn nut (Inch) Lock washer (Inch, Metric, DIN, ISO) Spur gear *

Angle (AISC Inch and Metric,
BSI, JIS, ANZ, DIN)

Needle bearing Spur gear rack

Ball bearing Nut (Inch, Metric, DIN, ISO) Square tubing (AISC Inch and Metric, 
BSI, JIS, ANZ, DIN)

Bearing lock nut Parallel pin (DIN) Swing bolt

Bevel gears Pillow block bearing Swing eye bolt

Bulb flat (BSI, JIS, DIN) Plain washer (Inch, Metric, DIN, ISO) Taper pin (Inch, DIN)

Carriage bolt (Inch, Metric) Pulley * Tapered roller bearing

Channel (AISC Inch and Metric, 
JIS, ANZ, DIN)

Rectangular tubing (AISC Inch and 
Metric, BSI, JIS, ANZ, DIN)

T-bolt

Clevis pin (Inch, Metric, 
DIN, ISO

Retaining ring (Inch, DIN) Tee (AISC Inch and Metric, BSI, JIS, 
DIN)

Compression spring - 1 and 2 Retaining washer (DIN) Thrust bearing

Conical compression spring Rivet - large (Inch) Thumb screw (Inch)

Cotter pin (Inch) Rivet - small (Inch) Torsion spring - Front, End

Die spring Rivet (DIN) Tubular rivet (DIN)

Dowel pin (Inch) Roller bearing U-bolt

Extension spring - Front, End Roller chain - circular Wide flange (AISC Inch and Metric, 
BSI, JIS, ANZ, DIN)

Eye bolt Roller chain - linear Wing nut (DIN)

Flanged bearing - 2 and 4 hole Roller chain - offset link Wing nut type A, B, C, D (Inch)

Hole - drilled Round tubing (AISC Inch and Metric, 
BSI, JIS, ANZ, DIN)

Woodruff key

Hole - tapped (Inch, Metric) Screw and nut (Inch, Metric, DIN, ISO) Wood screw

I-Beam (AISC Inch and Metric, 
BSI, JIS, ANZ, DIN)

Set screw (Inch, Metric, DIN, ISO) Worm

J-Bolt (Inch, Metric) Shaft Worm gear *

Key Sheet metal screw (Inch, Metric) Z-Section

Knurled thumb nut (Inch, DIN) Shoulder screw (Inch, Metric, DIN, ISO)

Lag screw (Inch, Metric) Sprocket *
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* The spur gear, worm gear, sprocket, and pulley convert to a 3D object and 3D hub object.
This command creates the 3D equivalent of a selected 2D object. If a 2D object with no 3D equivalent is selected, 
a beep sounds, a notice indicates that the object cannot be converted, and the object is deselected. 

To create a 3D object from a 2D object:
1. Select the 2D object. Several 2D objects can be selected at one time. 
2. Select the Create 3D Object from 2D command from the appropriate menu:

• Architect workspace: AEC > Machine Design > Create 3D Object from 2D 
• Landmark workspace: Landmark > Machine Design > Create 3D Object from 2D 
• Spotlight workspace: Spotlight > Machine Design > Create 3D Object from 2D 
The 3D object is created with the same parameters as the 2D object.

Spring Calculator
The Spring Calculator command solves for spring rates and unit stresses based on compression spring parameters.
To calculate a spring rate:

1. Select the Spring Calculator command from the appropriate menu:
• Architect workspace: AEC > Machine Design > Spring Calculator 
• Landmark workspace: Landmark > Machine Design > Spring Calculator 
• Spotlight workspace: Spotlight > Machine Design > Spring Calculator 
The Spring Calculator dialog box opens.

2. Edit the compression spring parameters. To add to the list of available parameter values, see “Adding 
User-defined Information to Commands” on page 1883.

Click to show/hide the parameters.

Parameter Description

Units Sets the spring dimension units to Inches, cm, or mm
Method Select the method; as data is entered, the other dimensions are automatically calculated
Dimensions The fields available depend upon the Method and the Type of Ends selected

Outside Diameter Enter the outside diameter
Mean Diameter Enter the mean diameter
Wire Diameter Enter the wire diameter
Solid Height Enter the solid height
No. of Active Coils Enter the number of active coils

3D Conical 
Compression 
Spring

2D Conical
Compression

Spring
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3. Click Close to exit the calculator.

Belt Length Calculator
The Belt Length Calculator solves for either belt length or center distance between two pulleys.
To calculate belt length or center distance:

1. Select the Belt Length Calculator command from the appropriate menu:
• Architect workspace: AEC > Machine Design > Belt Length Calculator 
• Landmark workspace: Landmark > Machine Design > Belt Length Calculator 
• Spotlight workspace: Spotlight > Machine Design > Belt Length Calculator 
The Belt Length Calculator dialog box opens.

Click to show/hide the parameters.

2. Enter the known values, and then click Solve.
The belt length or center distance value displays.
If the center distance value is unknown, leave the field blank, and then click Solve. The minimum distance is 
displayed. Click Solve again to solve for the belt length based on the minimum center distance.

3. Click Close to exit the calculator.

Type of Ends Select Closed and Ground, Open and Ground, Closed, or Open to set the type of ends 
on the spring

Properties The properties of the spring can be selected from the list or manually entered
Material Select the material to be used for the spring or select <Other> to set the Modulus of 

Elasticity manually
Mod. of Elasticity Automatically entered based on the material selected; displayed in pounds per square 

inch, newtons per square centimeter, or newtons per square millimeter, depending on 
selected units. If <Other> was selected, enter the Modulus of Elasticity manually.

Spring Rate Automatically calculated based on the spring parameters; displayed in the selected units
Unit Stress Automatically calculated based on the spring parameters; displayed in the selected units

Place 2D spring on 
drawing

Select to draw a 2D spring according to the above parameters; if both check boxes are 
selected, the 2D and 3D springs are automatically aligned in the drawing

Place 3D spring on 
drawing

Select to draw a 3D spring according to the above parameters; if both check boxes are 
selected, the 2D and 3D springs are automatically aligned in the drawing

Parameter Description

Find Select whether to calculate the Belt Length or the Center Distance between pulleys
(1) Diameter Enter the first pitch diameter
(2) Diameter Enter the second pitch diameter
(3) Center Distance If calculating the belt length, enter the Center Distance
Belt Length If calculating the center distance, enter the Belt Length
Place data on drawing Select to insert the calculated data on the drawing

Parameter Description
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~~~~~~~~~~~~~~~~~~~~~~~~~
Chain Length Calculator

Chain Length Calculator
The Chain Length calculator solves for either the length of a chain or center distance between two sprockets. 
To calculate chain length or center distance:

1. Select the Chain Length Calculator command from the appropriate menu:
• Architect workspace: AEC > Machine Design > Chain Length Calculator 
• Landmark workspace: Landmark > Machine Design > Chain Length Calculator 
• Spotlight workspace: Spotlight > Machine Design > Chain Length Calculator 
The Chain Length Calculator dialog box opens.

Click to show/hide the parameters.

Parameter Description

Chain and Sprocket Data
Find Select whether to calculate the Chain Length or the Center Distance between 

sprockets
Std.Chain No. (Pitch) Select the pitch of the chain
(1) Number of Teeth, 
Sprocket #1

Enter the number of teeth of sprocket #1

(2) Number of Teeth, 
Sprocket #2

Enter the number of teeth of sprocket #2

(3) Center Distance or 
Chain Length

If calculating the chain length, enter the Center Distance; if calculating the center 
distance, enter the Chain Length

Chain Length or Center 
Distance

Depending on the Find selected, the chain length or center distance calculation is 
displayed

Placement Options
Place chain on drawing Inserts the continuous chain onto the drawing, based on the specified and calculated 

values

Place sprockets on drawing Inserts the two sprockets onto the drawing based on the specified and calculated value

Sprocket #1 (N1) Sprocket #2 (N2)
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The Chain Length value can be entered based on the number of pitches multiplied by the pitch value.
2. Enter the known values, and then click Solve.

The chain length or center distance value displays.
If the center distance value is unknown, leave the field blank, and then click Solve. The minimum distance is 
displayed. Click Solve again to solve for the chain length based on the minimum center distance.

3. Select the desired placement options.
4. Click OK.
5. If placement options were selected, the cursor changes to a bull’s eye. Click in the drawing to insert the chain and/

or sprockets. If Place data on the drawing was selected, click again to insert the calculated data.
6. Click OK to close the calculator.

~~~~~~~~~~~~~~~~~~~~~~~~~
Belt Length Calculator

Control Values for Keys
The Control Values for Keys calculator solves for the key depths of a given shaft and the key size.
To calculate the control values:

1. Select the Control Values for Keys command from the appropriate menu:
• Architect workspace: AEC > Machine Design > Control Values for Keys 
• Landmark workspace: Landmark > Machine Design > Control Values for Keys 
• Spotlight workspace: Spotlight > Machine Design > Control Values for Keys 
The Depth Control Values for Keys dialog box opens.

2. Enter the shaft diameter size. Select Recommended Key Size to use the recommended key size according to the 
ASME or ISO standard; otherwise, select Custom Key Size to enter custom key sizes.

Click to show/hide the parameters.

Group the objects Select to group the objects when inserted onto the drawing; if deselected, the objects 
are ungrouped when inserted onto the drawing and are editable in the Object Info 
palette

Place data on drawing When selected, inserts the calculated data onto the drawing

Parameter Description

Nom. Shaft Diameter (D) Enter the size of the shaft
Recommended Key Size Select to use the recommended key size according to the ASME or ISO standard

Square Select to use the recommended square key
Rectangular Select to use the recommended rectangular key
Key Width (W)/Height (H) Displays the dimensions of the recommended key

Custom Key Size Select to use custom key sizes
Key Width (W) Enter the width of the key
Key Height (H) Enter the height of the key

Parameter Description
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3. Click Solve.
The key depth values for the given shaft diameter and key size are displayed.

4. Click Close to exit the calculator.

Shaft Analysis
The Shaft Analysis utility analyzes the results of a twisting moment being applied to a round solid or hollow shaft.
To perform the analysis:

1. Select the Shaft Analysis command from the appropriate menu:
• Architect workspace: AEC > Machine Design > Shaft Analysis 
• Landmark workspace: Landmark > Machine Design > Shaft Analysis 
• Spotlight workspace: Spotlight > Machine Design > Shaft Analysis 
The Shaft Analysis dialog box opens.

2. Enter the shaft properties and the known value in the Solutions section. To add to the list of available units, see 
“Adding User-defined Information to Commands” on page 1883.

Click to show/hide the parameters.

3. Click Solve.
The unknown values in the Solutions section are solved based on the information given.

4. Click Close to exit the shaft analysis calculator.

Solution
Depth to Bottom of Key (S) Displays the dimension from the bottom of the shaft to the bottom of the key
Depth to Top of Key (T) Displays the dimension from the bottom of the shaft to the top of the key

Place data on drawing Select to insert the calculated data on the drawing

Parameter Description

Shaft Properties Enter the shaft properties; the analysis results are based on the properties provided
(1) Outside Diameter Enter the outside diameter of the shaft; select the desired units from the list
Inside Diameter Enter the inside diameter of the shaft; enter zero for a solid shaft
Polar Moment of 
Inertia

Automatically calculated from the outside and inside diameters

(2) Length Enter the length of the shaft
Shear Modulus Enter the value of the shear modulus; select the desired units from the list

Solutions Select and enter the known value
(3) Twisting Moment Enter the twisting moment; select the desired units from the list
Maximum Shear 
Stress

Enter the maximum shear stress; the units are set by the Shear Modulus value

(4) Angle of Twist Enter the angle of twist in degrees

Parameter Description
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Centroid 
The Centroid utility calculates the centroid, or center of gravity, of a 2D shape. The utility shows the location of the 
centroid and can place a locus at that point. For more information, see “Obtaining Engineering Properties” on 
page 1821.
To place a centroid locus point on an object:

1. Select the object.
2. Select the Centroid command from the appropriate menu:

• Architect workspace: AEC > Machine Design > Centroid 
• Landmark workspace: Landmark > Machine Design > Centroid 
• Spotlight workspace: Spotlight > Machine Design > Centroid 
The Centroid dialog box opens.

3. The location of the centroid is displayed. Select Place locus at centroid to place a locus marker at the centroid of 
the object.

4. Click OK.
If the object is moved, the locus point does not remain centroidal unless the object and locus point are grouped and 
then moved.

Conversion Factors
The Conversion Factors utility provides the conversion factor between units.
To perform a conversion factor calculation:

1. Select the Conversion Factors command from the appropriate menu:
• Architect workspace: AEC > Machine Design > Conversion Factors 
• Landmark workspace: Landmark > Machine Design > Conversion Factors 
• Spotlight workspace: Spotlight > Machine Design > Conversion Factors 
The Conversion Factors dialog box opens.

2. In the Multiply field, enter the number of units to convert. Select the original unit of measure from the Multiply 
list.

3. Select the target unit of measure from the To Obtain list. The conversion results display in the To Obtain field 
and the conversion factor displays in the By field.

4. Click OK to exit the utility.

Solution of Triangles
The Solution of Triangles utility solves for unknown values of a triangle.
To solve for the unknown values of a triangle:

1. Select the Solution of Triangles command from the appropriate menu:
• Architect workspace: AEC > Machine Design > Solution of Triangles 
• Landmark workspace: Landmark > Machine Design > Solution of Triangles 
• Spotlight workspace: Spotlight > Machine Design > Solution of Triangles 
The Solution of Triangles dialog box opens.
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2. Select the format of the known values, and then enter them in the fields below.
3. Click Solve. The calculated values display in the Solution fields.

4. Click Close to exit the utility.

3D Properties
The 3D Properties utility calculates a 3D object’s center of mass, radii of gyration, and mass properties based on 
density or specific gravity, surface area, and volume. This can be used for 3D objects such as a sweep, extrude, or solid.
To display the 3D properties of an applicable object:

1. Select the 3D object.
2. Select the 3D Properties command from the appropriate menu:

• Architect workspace: AEC > Machine Design > 3D Properties 
• Landmark workspace: Landmark > Machine Design > 3D Properties 
• Spotlight workspace: Spotlight > Machine Design > 3D Properties 
The 3D Properties dialog box displays the object surface area, volume, radii of gyration, and center of mass.

Click to show/hide the parameters.

3. Click Calculate Mass Properties.
The Mass Properties dialog box displays the weight, mass, and mass moments of inertia of the object.

Parameter Description

Units Select the unit for displaying values
Places locus at centroid Select to place a locus point at the 3D center of the object
Place properties on drawing Select to place a grouped text block containing the 3D property values on the 

drawing at the next mouse click
Write properties to a file Select to create a text file containing the 3D property values
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4. Specify the system of units to use when calculating the mass properties.
The mass properties calculations display.

Click to show/hide the parameters.

5. Click OK to return to the 3D properties dialog box.

Simple Beam Analysis
The Simple Beam Analysis command opens a message box displaying the calculated values that correspond to the 
cursor position.
To analyze a simple beam:

1. Create the beam and diagrams as described in “Simple Beam” on page 1888.
2. Select the Simple Beam Analysis command from the appropriate menu:

• Architect workspace: AEC > Machine Design > Simple Beam Analysis 
• Landmark workspace: Landmark > Machine Design > Simple Beam Analysis 
• Spotlight workspace: Spotlight > Machine Design > Simple Beam Analysis 
A message dialog box opens at the bottom of the screen, displaying x (location on the beam), vx (shear), mx 
(bending moment), sx (shearing stress), and y (deflection) values.

Parameter Description

Input
System of Units Select the units to use for the calculation
Property to Use Select whether to display properties based on the density or specific gravity
Value Enter the material density or gravity value
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The values displayed depend on the location of the cursor along the beam and the Calculation Interval specified 
in the Beam Properties dialog box.

3. Click on a blank area of the drawing to stop the analysis. Close the message dialog box.
To lock the values in the message dialog box, click on a point along the beam. The values at this point can then be 
studied or written down for future analysis. Select the Simple Beam Analysis command again to continue 
checking values along the beam.

~~~~~~~~~~~~~~~~~~~~~~~~~
Simple Beam
Simple Beam Calculator

Simple Beam Calculator
The Simple Beam Calculator command provides a quick way to analyze a simply-supported beam with a single load.
To use the Simple Beam Calculator:

1. Select the Simple Beam Calculator command from the appropriate menu:
• Architect workspace: AEC > Framing > Simple Beam Calculator 
• Landmark workspace: Landmark > Architectural > Simple Beam Calculator 
• Spotlight workspace: Spotlight > Architectural > Simple Beam Calculator 
The Simple Beam Calculator dialog box opens.

2. Select the desired configuration, and then enter the values to be calculated.
Click to show/hide the parameters.
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Certain input fields may appear dimmed depending on the configuration selected.
3. Click Solve.

The results are displayed in Solution.
4. Click Close to exit the Simple Beam Calculator dialog box.

~~~~~~~~~~~~~~~~~~~~~~~~~
Simple Beam
Simple Beam Analysis

Parameter Description

Configuration Select the simple beam configuration to analyze; the preview window updates 
to correspond to the selected configuration

Input
Units Select Imperial or Metric (SI) as the displayed unit value
Beam and Load Data Select Imperial or Metric (SI) as the displayed unit value

Beam Length (L) Enter the length of the beam
Concentrated Load (P) Enter the value of a concentrated load or loads
Dist. from end of beam (a) Enter the distance from the end of the beam to the load
Distributed Load (w) Enter the value per unit length of a distributed load

Beam Properties
Modulus of Elasticity Enter the modulus of elasticity of the beam
Moment of Inertia Enter the moment of inertia of the beam
Section Modulus Enter the section modulus of the beam
Select Structural Shape and 
Materials

Opens the Select Structural Shape and Material dialog box for selection of a 
structural shape, series, size, and material for the beam and axis about which 
the properties are needed (see “Structural Shapes and Details” on page 443). 
Click OK to return to the Simple Beam Calculator dialog box; the beam 
properties section is updated with these values for the selected structural 
shape, and the fields can be manually adjusted as needed. 

Solution
Reaction at Left End (rL) Displays the reaction at the left support
Reaction at Right End (rR) Displays the reaction at the right support
Moment at Left End (mL) Displays the bending moment at the left support
Moment at Right End (mR) Displays the bending moment at the right support
Max. Shear (vMax) Displays the maximum vertical shear
Max. Bending Moment (mMax) Displays the maximum bending moment
Max. Shear Stress Displays the maximum shear stress
Max. Deflection Displays the maximum deflection
at x (from left end) Displays the point from the left end of the beam at which the maximum 

deflection occurs
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Managing Workspaces
The Fundamentals workspace is installed with the Vectorworks Fundamentals product in the folder 
[Vectorworks]\Workspaces. If the Renderworks product is installed, all of the user interface elements are added to the 
Fundamentals workspace. Each Vectorworks Design Series product is installed with a unique, industry-specific 
workspace. Any changes you make to the default workspaces are saved in your User Data and Preferences folder, to 
maintain the integrity of both the default and custom workspaces. Custom workspaces can also be saved to a 
workgroup folder (see “User Folders Preferences” on page 57).
To create a custom workspace, you can edit the current workspace, edit a copy of the current workspace, or create a 
new workspace. Create multiple workspaces for different drawing needs, or customize a single workspace to your 
personal preferences.
Custom workspaces imported from other users may contain tools or commands that are not available with your current 
Vectorworks license; if this occurs the Workspace Editor dialog box notifies you which commands and tools in the 
custom workspace are unavailable for your use. Selecting or attempting to use a tool or command that is unavailable 
with your license results in a warning notifying you that you cannot use the selected tool or command.
Workspace customization options include:

• Add menus, tool palettes, tool sets, tools, and commands
• Remove unused menus, tool palettes, tool sets, tools, and commands
• Rearrange the order and the position of menus, tool sets, tools, and commands
• Add, modify, delete, and print the keyboard shortcuts for tools and commands
• Configure the context menus
• Establish palette positions and settings to be used in the workspace
• Specify tool set icons

You can also create customized plug-in tools, commands, and objects. See “Using Scripts” on page 1771.
Between Vectorworks versions, commands may have been added to or removed from a workspace menu; 
therefore, moving a prior custom workspace to a newer version may result in unintended commands being 
selected. 

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating or Editing Workspaces
Updating Custom Workspaces and Plug-in Objects

Creating or Editing Workspaces
Workspaces can be managed in several ways:

• Select Tools > Workspaces > Workspaces to manage all available workspaces
• Select Tools > Workspaces > Edit Current Workspace to edit the current workspace
• Select Customize from a tool palette’s/ set’s utility menu to edit the active tool palette/set portion of the 

workspace
To manage all workspaces:

1. Select Tools > Workspaces > Workspaces.
The Workspaces dialog box opens.
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2. Select a workspace to edit from the list and click Edit, or click New to create a new workspace.
The Workspace Editor dialog box opens.

Option Description

New Opens the Workspace Editor dialog box and creates a new workspace
Edit Opens the selected workspace in the Workspace Editor dialog box. Only one 

workspace can be edited at a time.
If you edit one of the standard Vectorworks workspaces, Vectorworks 
will save the customized copy in the user folder and hide the original in 
the application folder.

Duplicate Creates a duplicate of the currently selected workspace. Copies 
automatically have “copy” appended to the end of the original workspace 
name.

Delete Deletes the selected workspace permanently from the User folder. Default 
workspaces cannot be deleted from the application folder. If you delete the 
active workspace, Vectorworks will re-load with the first workspace in the 
list as the active workspace.

Revert Deletes the selected workspace from the user folder if a workspace with the 
same name exists in the Workgroup or application folder. You cannot revert 
a workspace in the Workgroup folder. If used on a customized workspace 
from the application folder, reverts the workspace to its default settings. If 
you revert the active workspace, Vectorworks will reload the workspace 
with the same name from the application folder.

Export Exports the selected workspace as a text file. To export a list of all menu 
items, tools, and keyboard shortcuts contained in the current workspace, 
click Export. When prompted, specify the file name and the location for the 
file and click OK. The text file also lists keys reserved by the Vectorworks 
program or the operating system, shortcuts that cannot be user modified, and 
shortcuts that can be modified from within the Workspace Editor.

Reveal in Finder (Mac)
Show in Explorer (Windows)

Opens the folder containing the selected workspace



Creating or Editing Workspaces |  1837
Workspaces in different folder locations with identical names will not be listed, Workgroup folder workspaces 
override Application folder workspaces, and User folder workspaces override both Workgroup and Application 
folder workspaces.

3. Modify the menus, context menus, tools, keyboard shortcuts, and palette positions and settings as described in the 
following sections:
• “Modifying Menus and Commands” on page 1837
• “Modifying Context Menus” on page 1839
• “Modifying Tool Palettes and Tool Sets” on page 1840
• “Modifying Snapping and Mode Shortcuts” on page 1842
• “Saving Initial Palette Positions and Settings” on page 1843
Some shortcuts are reserved by the Vectorworks program or by the Windows or Mac operating system. The 
Workspace Editor does not prevent such shortcuts from being assigned to a palette or a tool. If this occurs, the 
Windows or Mac shortcut typically overrides the shortcut assigned in the Vectorworks program.
If a duplicate item is added to a menu, a palette, or a tool set, the item displays in both locations. Highlight the 
undesired occurrence of the tool or command and press the Delete key to remove it.

4. When you are finished customizing or creating workspaces, click Done to close the Workspace dialog box.

Modifying Menus and Commands
Modify menus and assign keyboard shortcuts to commands, as needed.
To add, modify, or delete a menu or a command:

1. Access the Workspace Editor dialog box as described in “Creating or Editing Workspaces” on page 1835.
Click the Menus tab. The left side of the dialog box displays all available commands, grouped by category. The 
right side of the dialog box displays the menus and commands currently assigned to the workspace. To help you 
easily identify what changed in this release, the Recent Changes folder lists the new and revised menus and 
commands for the current and prior version of the Vectorworks software; it also lists those menus and commands 
that are now considered obsolete (legacy). Modify the menus and commands as described in the following table.

Menus and commands 
in the current workspace

All available commands,
listed by category

Click the triangle (Mac) or
plus (+) sign (Windows) to

display the available
commands in the category

All available commands,
listed alphabetically

Context menus and 
commands in the 
current workspace

Click the triangle (Mac) or 
plus (+) sign (Windows) to 
display current 
commands under the 
menu item

All new, revised, or
obsolete menus and

commands in the current
and prior version of

Vectorworks

Change the name of the
workspace

Separator line for dividing
menus
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0

The Document Windows, Font, Tool Palettes, and Workspaces menu items are populated at run time. Therefore, 
they can only be placed as the last item in a list of submenu items.

2. If desired, assign or change a combination of keys to use as a shortcut to access a menu command.

If a keyboard shortcut is already in use, the option to reassign the shortcut to the current menu command is 
presented. If the shortcut is reassigned, the original command no longer has a shortcut.

Option Description

Add a new menu or 
submenu

Click the New Menu command from the Commands list and drag it to the desired 
position in the Menus list. Click to highlight the new item, and then click again to edit 
it; enter the name of the new menu item.

Add a command to a menu Click the plus sign (Windows) or triangle (Mac) to expand the list of commands; 
click-drag the command from the Commands list to the desired position in the Menus 
list

Add a separator Click-drag the Separator command (Windows) or separator line (Mac) from the 
Commands list to the desired position in the Menus list; a separator line displays

Move an item Click-drag the item in the Menus list to the desired position
Delete an item Select the item from the Menus list and press the Delete key. If you delete an item that 

has other items stacked beneath it, all of the stacked items are deleted along with the 
main item; to prevent this, move the stacked items to another location first. A warning 
will display asking you to confirm deletion of an item if other items are stacked 
beneath it.

Change a menu name Select the menu from the Menus list and type the desired name; commands cannot be 
renamed

1. Select the command

3. Click in the field and 
press the desired key

2. Select a shortcut key combination
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Common computer keyboard shortcuts such as Ctrl + C (Windows) or Cmd + Z (Mac) and operating system 
shortcuts cannot be overridden.

3. If necessary, modify or delete a keyboard shortcut.
• Modify: Select the shortcut from the Menus list; select a new shortcut key combination and/or enter a different 

key for the shortcut (if that key is reserved by the Vectorworks program or is already in use, a message 
displays)

• Delete: Select the shortcut key from the Menus list and press Delete
4. Click OK to save the changes and close the Workspace Editor dialog box.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating or Editing Workspaces
Modifying Context Menus

Modifying Context Menus
Modify document context menus and object context menus in the same manner as described in “Modifying Menus and 
Commands” on page 1837. These menus display when you click on an object or on the drawing area with a right-click 
(Windows) or Ctrl-click (Mac). The object context menus contain context-sensitive commands that pertain to the item 
that is currently selected in the drawing area. 
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~~~~~~~~~~~~~~~~~~~~~~~~~
Creating or Editing Workspaces

Modifying Tool Palettes and Tool Sets
Modify tool palettes and tool sets, and assign keyboard shortcuts to tools, as needed. Tools can only be added to tool 
sets, not to tool palettes.

To provide more drawing space, stack the tools that have similar functionality.
To add, modify, or delete a tool palette or a tool set:

1. Access the Workspace Editor dialog box as described in “Creating or Editing Workspaces” on page 1835.
Alternatively, you can directly edit a tool set by clicking Customize from the tool palette Utility menu.

2. Click the Tools tab. The left side of the dialog box displays all available tools, grouped by category. The right side 
of the dialog box displays the tool palettes, the tool sets, and the tools that are currently assigned to the workspace. 
To help you easily identify what changed in this release, the Recent Changes folder lists the new and revised tools 
for the current and prior version of the Vectorworks software; it also lists those tools that are now considered 
obsolete (legacy). Modify the tool palettes and the tool sets as described in the following table.
For the Basic palette, the edit tools and the tools for 2D and 3D object creation are listed in the View/Draw tool 
set.

Option Description

Add a new tool palette Click-drag the New Tool Palette command from the Create list to the Palettes list; 
click the item’s text label and type the new palette’s name in place of New Tool 
Palette

The tool palettes, 
tool sets, and 
tools in the current 
workspace

All available tools,
listed by category

Click the plus (+) sign
(Windows) or the
triangle (Mac) to

display the available
tools in the category

All available tools,
listed alphabetically

Click the plus (+) sign 
(Windows) or the 
triangle (Mac) to 
display the current 
tools or tool sets 
under the item

All new, revised, or
obsolete tools in the

current and prior
version of the

Vectorworks program

Click to change 
the default icon for 
the selected tool 
set
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3. If desired, assign or change the combination of keys to use as a shortcut to access a tool.

Add a new tool set Click-drag the New Tool Set command from the Create list to the Palettes list; click 
the item’s text label and type the new tool set’s name in place of New Tool Set

Change a tool set icon The default icon for the tool set can be replaced by a custom icon, if desired. With a 
third-party icon editor, create two versions of the icon: one for a standard-resolution 
display and one for a high-resolution display:

• Standard-resolution: an image centered in an area 26 pixels wide by 20 pixels 
high. Save the icon in .png format.

• High-resolution: an image centered in an area 52 pixels wide by 40 pixels 
high. Save the icon in .png format with the same name as the 
standard-resolution image with “@2x” appended to the end of the file name. 
For instance, if the standard-resolution icon is named 
3DModelingToolSet.png, the high-resolution icon must be named 
3DModelingToolSet@2x.png; otherwise the Vectorworks software will be 
unable to locate the icon.

Select the tool set and click Image to import the standard resolution icon; if a 
high-resolution icon is also present with the @2x designation, the software 
automatically imports it as well. The Vectorworks program automatically displays the 
appropriate image for the device’s resolution.

Add a tool or a tool 
category to a tool set

Click the plus sign (Windows) or triangle (Mac) to expand the list of tools; click-drag 
the tool (or the entire group of tools) from the Tools list to the desired position in the 
Palettes list

Move an item Click-drag the item in the Palettes list to the desired position
Delete an item Select the item in the Palettes list and press the Delete key.

If you delete an item that has other items stacked beneath it, all of the stacked items 
are deleted along with the main item; to prevent this, move the stacked items to 
another location first.

Change the name of a tool 
palette or a tool set

Select the item from the Palettes list, click the item’s text label, and type the desired 
name; tools cannot be renamed

Option Description
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If a keyboard shortcut is already in use, the option to reassign the shortcut to the current tool is provided. If the 
shortcut is reassigned, the original tool no longer has a shortcut.
Common computer keyboard shortcuts such as Ctrl + C (Windows) or Cmd + Z (Mac) and operating system 
shortcuts cannot be overridden.

4. If necessary, modify or delete a keyboard shortcut.
• Modify: Select the shortcut from the Palettes list; select a new shortcut key combination and/or enter a 

different key for the shortcut (if that key is reserved by the Vectorworks program or is already in use, a message 
displays)

• Delete: Select the shortcut key from the Palettes list and press Delete
5. Click OK to save the changes and close the Workspace Editor dialog box.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating or Editing Workspaces

Modifying Snapping and Mode Shortcuts
You can modify the keyboard shortcuts for switching between modes on the Tool bar, and for activating snapping 
functionality.
To modify the shortcuts for modes and snapping:

1. Access the Workspace Editor dialog box as described in “Creating or Editing Workspaces” on page 1835.
2. Click the Keys tab to display the keyboard shortcuts for the workspace currently in use. Assign or modify the 

keyboard shortcuts, as needed.
Click to show/hide the parameters.

1. Select the tool

3. Click in the field and 
press the desired key

2. Select a shortcut key 
combination
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3. Click OK to save the changes and close the Workspace Editor dialog box.
~~~~~~~~~~~~~~~~~~~~~~~~~
The Vectorworks Workspace
SmartCursor Cues
Angle Snapping
Smart Points Snapping
Smart Edge Snapping
Creating Vector Locks
Using the Snap Loupe
Creating or Editing Workspaces

Saving Initial Palette Positions and Settings
You can save a set of initial palette positions and settings for a workspace. For example, a CAD manager might want to 
create a customized workspace—including palette settings—to be shared with all new users.

This command simply creates the initial settings for the first time a workspace is used. Each time a user exits the 
Vectorworks program, the current palette settings and positions are automatically saved for each workspace in a 
file in the user folder ([User]\Settings\SavedSettings.xml). The settings in this user file override the settings in the 
workspace file. To reset to the original workspace settings, click Reset Saved Settings from the Session tab of 
Vectorworks preferences (see “Session Preferences” on page 52).

Parameter Description

Mode Groups Sets the shortcut keys to switch modes for the active tool; the key in 1 controls the 
first mode group, the key in 2 controls the second mode group, and so on

Other Keys Sets the keyboard shortcuts for the functions below
Toggle SmartCursor Cues Press this key to toggle on and off the SmartCursor cue display
Toggle Angles Relative 
To Prior Segment

Press this key to toggle whether angle snaps are set relative to the axes or to the 
previously drawn segment

Set Datum Press this key to create a datum point for snapping at the current cursor location
Snap Loupe Press this key to open the Snap Loupe window
Set Smart Point, Edge, or 
Vector Snap Lock

Press this key to set a smart point, smart edge, or vector snap lock at the current 
location

Toggle Automatic 
Working Plane

Press this key to toggle on and off the automatic working plane functionality; see 
“The Automatic Working Plane” on page 153

Suspend Snapping Press and hold this key to disable snapping temporarily
X-ray Select Mode Press and hold this key to see and select objects that are normally obscured behind 

2D object fills or 3D rendered objects; see “X-ray Select Mode” on page 113
Coincident Selection If the cursor is over multiple objects at the current location, press and hold this key 

and click to open a dialog box from which you can select one or more of the objects; 
see “Coincident Object Selection” on page 112

Close Polygon, Polyline, 
Wall Network or Path 
Objects

After completing all but the final click, press the keyboard shortcut to automatically 
close polygon, polyline, polygonal wall network, or path-based objects

Snapping Keys Sets the keyboard shortcuts to toggle on and off each Snapping palette tool
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To save initial palette positions and settings for a workspace:
1. Customize the workspace as needed in the Workspace Editor.
2. Place palettes in the desired position, set palette size, and set whether palettes should be minimized, or docked 

(Windows only); see “Palette Layout Options” on page 40, “Minimizing Palettes” on page 41, and “Docking 
Windows Palettes” on page 41.

3. For tool palettes, set the tool and tool set display and sort style, and the tool set placement option; see “Tool Palette 
Features” on page 42.

4. For the Object Info palette, click the Shape, Data, or Render tab to set the active pane upon opening, and manually 
position the separator in the Data pane, as desired.

5. For the Resource Browser, set the resource display style and group visibilities; see “Viewing Resources” on 
page 223 and “Hiding and Showing Resources” on page 225.

6. For the Navigation palette (Vectorworks Design Series required), click the desired tab to set the active pane upon 
opening.

7. Once palettes are positioned and settings have been established, select Window > Palettes > Save Palette 
Positions. A message displays the location of the workspace file where the changes were saved. Click OK.

8. Place the custom workspace file in a user Workspaces folder to make it available in the Vectorworks program. 
When that workspace is selected, the initial palette settings display.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating or Editing Workspaces

Updating Custom Workspaces and Plug-in Objects
When a Vectorworks software upgrade is installed, the workspaces and plug-in objects in the Vectorworks root folder 
(where the application is installed) are replaced.
Your custom workspaces and plug-ins (in your user folder) remain in place; see “User Folders Preferences” on page 57 
for details about user folders. The first time the new version of the Vectorworks program is opened, it automatically 
converts the custom workspaces to the new format and saves a copy of the original workspaces in a Legacy 
Workspaces folder (in your user folder).
The Vectorworks installer and updater programs both make backup copies of all workspaces. The installer places 
backup copies of workspaces in a folder entitled Original, within the [Vectorworks]\Workspaces folder. The updater 
places backup copies of workspaces in a sequentially numbered folder entitled Backup, within the Workspaces folder. 
Each time the updater is run, another Backup folder is created. After the backup, both the installer and the updater 
overwrite the workspaces at the top level of the Workspaces folder.
For more information about where plug-in objects may be located, see “Plug-in File Location” on page 1781.



Standards
Vectorworks Cursors
The cursor in the Vectorworks program changes depending on which tool, mode, and modifier keys are currently in 
use, as well as what type of object the cursor is over in the drawing area. This helps you to know which actions are 
available at any given time, without shifting your attention from the drawing. 

Cursor Description

2D Polygon tool
Inner Boundary mode is active; click in an enclosed area to create a 2D polygon 
based on the area’s inner boundary

Reshape tool (2D modes)
Move Polygon Handles mode is active, and the cursor is over a handle; click-click 
to move the handle
Move Edges Parallel mode is active, and the cursor is over a handle; click-click to 
move the handle
Change Vertex mode is active, and the cursor is over a vertex handle; click to 
change the vertex to the type selected in the Tool bar
Add Vertex mode is active, and the cursor is over a handle; click-drag the handle to 
create a new vertex
Delete Vertex mode is active, and the cursor is over a vertex handle; click to delete 
the vertex
Rectangular Marquee mode is active, and the cursor is not over any handle

Lasso Marquee mode is active, and the cursor is not over any handle

Polygonal Marquee mode is active, and the cursor is not over any handle

Reshape tool (3D modes)
The cursor is over a handle on a selected 3D object that can be dragged vertically 
(for example, the top handle of an extrude)
The cursor is over a handle on a selected 3D object that can be dragged in any 
direction (for example, any handle on a NURBS curve)
The cursor is over a handle on a selected 3D object that can be scaled (for example, 
a radius handle on a sphere)
Change Vertex mode is active, and the cursor is over a vertex handle; click to 
change the vertex type
Add Vertex mode is active, and the cursor is over a handle; click-drag the handle to 
create a new vertex
Delete Vertex mode is active, and the cursor is over a vertex handle; click to delete 
the vertex
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Align Plane tool
Click to define the X and Y axes on the selected object

Angular Dimension tool
Edges mode is active; click two intersecting objects to create the dimension object

Attribute Mapping tool
Click-drag to scale the fill larger or smaller (the cursor is over a corner handle of the 
mapping object)
Click-drag to rotate the fill (the cursor is over a middle handle of the mapping 
object)
Click-drag to move the origin of the fill (the cursor is over other parts of the 
mapping object)

Center Mark tool
Click the highlighted object to create a center mark

Chamfer Edge tool
Select Faces preference off The cursor highlights edges that can be used in the chamfer operation

Select Faces preference on The cursor highlights faces that can be used in the chamfer operation

Constraint tools
Click the objects to be constrained

Edit Curtain Wall tool
Click to add a new frame to the curtain wall

Click to split the frames at the frame intersection

Click on the second collinear frame to combine the frames

Click to move the frame grid along the curtain wall

Cursor Description

Near a 
handle

Anywhere 
except a 
handle

Windows Mac

Windows Mac
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Extract tool
Extract Point or 
Extract Curve mode

The cursor highlights edges that can be used in the extract operation

Extract Iso-parametric 
Curve or Extract Surface 
mode

The cursor highlights faces that can be used in the extract operation

Eyedropper tool
Pick up Attributes mode is active

Apply Attributes mode is active

Fillet Edge tool
Select Faces preference off The cursor highlights edges that can be used in the fillet operation

Select Faces preference on The cursor highlights faces that can be used in the fillet operation

Fixed Point Resize tool
Click the point on the selected object that is to remain fixed, and then move the 
cursor to resize the object

Flyover tool
Click-drag to “fly over” the drawing

Help (What’s This? 
command)

Click a tool or command to open the online help topic that describes it

Cursor Description

Windows Mac

Windows Mac

Windows Mac

Windows Mac
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Loft Surface tool
The cursor highlights curves that can be used in the loft operation

Move Page tool
Click to move the page print boundary

Pan tool
The Pan tool is active, or the pan mode is activated when another tool is active 
(Space bar is pressed)

Polyline tool
Bézier Vertex mode

Cubic Vertex mode

Arc Vertex Fillet mode

Project tool
The cursor highlights curves that can be used in the project operation

Push/Pull tool
In Extrude Face or Move Face mode, the cursor highlights faces that can be used in 
the push/pull operation

Radial Dimension tool
Click the highlighted circle to create a radial dimension

Render Bitmap tool
Click-drag to select the area from which to create a rendered bitmap image

Rotate View tool
Click-drag to rotate the drawing view

Selection tool
Click to scale the selected object

The cursor is over an object; click to select or click-drag to move the object

Cursor Description

Windows Mac

Windows Mac

Windows Mac
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Click-drag to duplicate the object (the Ctrl key is pressed on Windows, or the 
Option key is pressed on Mac)
The cursor is over an object; click to select or click-drag to move the object

Click to add an object to the current selection (the Shift key is pressed)

Click-drag to duplicate an object (the Ctrl key is pressed on Windows, or the Option 
key is pressed on Mac)
The cursor is not over any selectable object

Lasso Marquee mode is active

Polygonal Marquee mode is active

The cursor is over edges or points of multiple objects; use either the Coincident 
Selection key or the Select Coincident Objects command to select the appropriate 
objects
The cursor is over edges or points of multiple objects, and the Shift key is pressed; 
use either the Coincident Selection key or the Select Coincident Objects command 
to select the appropriate objects to add to the selection
The cursor is over edges or points of multiple objects; use either the Coincident 
Selection key or the Select Coincident Objects command to select the appropriate 
objects to move
The cursor is over the resizing points of multiple objects; use either the Coincident 
Selection key or the Select Coincident Objects command to select the appropriate 
objects to resize

Set Working Plane tool
Click to place the working plane

Click the square center grip and move the cursor to move the working plane

Click a red, green, or blue axis grip and move the cursor to rotate the working plane

Shear tool
Click the point on the selected object that is to remain fixed, and then move the 
cursor to shear the object

Shell Solid tool
The cursor highlights faces that can be used in the shell solid operation

Cursor Description

Windows Mac

Windows Mac
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Symbol Insertion tool
Symbol Pick up mode is active; click a symbol to make it active

Text tool
Click to create a text object

Click to place the text editing cursor in a text object or in a field

Translate View tool
Translates the drawing view from side to side or up and down

In perspective projection, adjusts the distortion by moving the mouse up (more 
distorted) or down 

Trim tool
Click to trim the object under the cursor

Walkthrough tool
Walk mode; Click-drag to simulate a walkthrough by moving through the drawing

Look Around mode; Click-drag to change the viewing angle up, down, left, or right

Elevator mode; Click-drag to move the viewer higher or lower

The cross indicates the control point of the walkthrough

Worksheet object
The cursor is over a worksheet cell

The cursor is over a worksheet column header cell

The cursor is over a worksheet row header cell

Click-drag left or right to change the column width

Click-drag up or down to change the row height

Click-drag left/right to remove/add columns; click-drag up/down to remove/add 
rows
Click-drag to move the column or row to a new location

Cursor Description

Windows Mac
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Vectorworks Circle/Arc Conventions
Due East is 0º. Positive degrees run counter-clockwise and negative degrees run clockwise.

Survey Bearings
The acute angle between the Meridian and a line measured from North to South, toward East and West gives a reading 
of less than 90º. 

Zoom tool
Marquee mode is active; click and move the cursor to create a marquee around the 
area to zoom in on
Marquee mode is active, and the Alt key (Windows) or Option key (Mac) is 
pressed; click and move the cursor to create a marquee around the area to zoom out 
on
Interactive mode is active; click-drag up to zoom in, or click-drag down to zoom out

Context menus
(Mac only)

The control key is pressed while the cursor is over an object or an open area in the 
drawing; click to open the context menu

All remaining tools
Click to begin the tool operation (such as placing a new drawing object, or splitting 
an existing object)

Cursor Description

Coordinates N°’ " W
add to 90° to get

positive angle

Coordinates N°’ " E 
subtract from 90° to 
get positive angle

Coordinates W°’ " N
subtract from 180° to get

positive angle

Coordinates W°’ " S
subtract from -180° to

get negative angle

Coordinates
S°’ " W add to -90° to

get negative angle

Coordinates E°’ " S 
subtract from 0° to get 
positive angle

Coordinates E°’ " N 
add to 0° to get 
positive angle

Coordinates S°’ " E 
subtract from -90° to 
get negative angle

90°

+/- 180° 0°

-90°
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Correlated Color Temperature
Color temperature is a simplified way to indicate the hue of a light source in degrees Kelvin (K). Lower color 
temperatures suggest more of a yellow-reddish color, while higher color temperatures tend to be more blue.
The following chart can be used to approximate various light sources in a rendered scene.

Architectural Scale
The following table provides the architectural scale conversion.

Approximate Degrees K Light Source Example

1500 - 1800 Candlelight
2800 - 3200 Indoor household tungsten light bulb
5000 - 5500 Sunny day at noon
6500 - 7000 Overcast sky
9000 - 12000 Blue sky

1" = 1' Fraction of inch 
equaling 1 foot

12 x 1/1 = 12 Inches/ foot multiplied by 
inverted fraction

1 : 12 Number to be typed into 
Paper Scale

1/2" = 1' 12 x 2/1 = 24 1 : 24
1/4" = 1' 12 x 4/1 = 48 1 : 48
3/4"= 1' 12 x 4/3 = 16 1 : 16
1/8" = 1' 12 x 8/1 = 96 1 : 96
3/8" = 1' 12 x 8/3 = 32 1 : 32
5/8" = 1' 12 x 8/5 = 19.2 1 : 19.2
7/8" = 1' 12 x 8/7 =13.714... 1 : 13.7142857
1/16" = 1' 12 x 16/1 = 192 1 : 192
3/16" = 1' 12 x 16/3 = 64 1 : 64
5/16" = 1' 12 x 16/5 = 38.4 1 : 38.4
7/16" = 1' 12 x 16/7 = 27.428... 1 : 27.4285714
9/16" = 1' 12 x 16/9 = 21.333... 1 : 21.3333333
11/16" = 1' 12 x 16/11 = 17.454... 1 : 17.4545454
13/16" = 1' 12 x 16/13 = 14.769... 1 : 14.7692307
15/16" = 1' 12 x 16/15 = 12.8 1 : 12.8
1/32" = 1' 12 x 32/1 = 384 1 : 384
3/32" = 1' 12 x 32/3 = 128 1 : 128
5/32" = 1' 12 x 32/5 = 76.8 1 : 76.8
7/32" = 1' 12 x 32/7 = 54.857 1 :54.8571428
1/64" = 1' 12 x 64/1 = 768 1 : 768
3/64" = 1' 12 x 64/3 = 256 1 : 256
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Vectorworks Equivalent to AutoCAD Terms and Concepts
Many concepts are similar between Vectorworks and AutoCAD® software; however, different vocabulary can result in 
confusion for AutoCAD users new to Vectorworks. Additionally, some features of the Vectorworks program have no 
equivalent in AutoCAD, and vice versa.
Layers in the Vectorworks program are not the same as layers in AutoCAD (instead, Vectorworks classes are the 
equivalent). Vectorworks layers are like sheets of vellum, placed one on top of the other, with all layers visible and 
editable, or only the current layer showing/editable. Like hand drafting, each design layer of a Vectorworks drawing 
has a scale. Sheet layers, which contain viewports, are at a scale of 1:1 and are the “paper space” equivalent. 
In the Vectorworks program, some tool is always active; switch tools by selecting a different tool.
The help system includes a PDF listing all commands and tools in the Vectorworks program, along with their location 
in the workspace. Other useful help sections include “Drawing Structure” on page 155, “Creating Objects” on page 1, 
“Editing Objects” on page 1, “Viewing the Drawing” on page 2, and “Vectorworks 2015 Keyboard Shortcuts” on 
page 1.
This table provides the approximate Vectorworks equivalent to many common AutoCAD terms.

AutoCAD Vectorworks

AC Trim Trim tool
Annotation tools Dims/Notes tool set
Array (Polar, Rectangular) Duplicate Array command
Attributes Records, schedule worksheets
Block Symbol or group
Block command Create Symbol command (or Group command)
Break Trim tool, Connect/Combine tool
Build Panel Building Shell tool set
Chamfer 0 0 Join command
Circle Oval tool
Construction Line Guide
Design Center Resource Browser
Copy Duplicate 
Distance Tape Measure tool
DRAWORDER Send command
Dynamic Dialog, palette Palette
Entity Object
Erase Clear command or Delete key
Explode Symbols and groups can be edited with the Edit Symbol or Edit Group commands; 

exploding first (Decompose or Ungroup commands in Vectorworks) is unnecessary
Extend Connect/Combine tool
Grips Handles
Insert Symbol Insertion tool
Layer Class (Vectorworks layers have no equivalent in AutoCAD)
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Linetype Line type
MATCHPROP Eyedropper tool
Menu Workspaces
MLine Wall tool and Round Wall tool (Vectorworks walls have a 3D height and additional 

functionality)
Model space Design layers
Move Select and drag the object
MText Text block
Osnap SmartCursor cues, Snapping palette
Paper space Sheet layers
PEDIT Compose command
PLINE 2D Polygon tool, Polyline tool
Polygon Regular Polygon tool
Properties Attributes palette and/or the Object Info palette of a selected object
Property Palette Object Info palette
Scale Scale Objects command
Stretch Resize by selecting the object and dragging the handles
Toolbar Tool palette
User Coordinate System Snap to Grid tool and User Origin commands
VPORTS, Viewport 
Windows

Viewports, including sheet layer viewports, design layer viewports, section viewports 
and detail viewports (Vectorworks Design Series required for certain viewports)

Xref Workgroup referencing
Zoom All Fit to Objects command
Zoom Extents Fit to Page Area command

AutoCAD Vectorworks



Miscellaneous Topics
Cutting Sections
In the Vectorworks Fundamentals workspace, the cutting section commands define a section line through a 3D model, 
placing the cut section on a new layer and leaving the original model intact.

Creating section viewports (Vectorworks Design Series required) may be preferable to creating cutting sections. 
However, the Cut 2D Section command and Cut 3D Section command can be added to Design Series 
workspaces if desired.

The Cut 2D Section command creates a cross-section, or 2D contour, on the cutting plane. The contour is created by 
the intersection of the model with an infinite plane passing though the section line. Only the elements that actually 
intersect the section line are shown.
The Cut 3D Section command creates a section with all the 3D geometry that remains on the indicated side of the 
infinite plane passing through the section line. The elements that intersect the section line, as well as the 3D geometry 
that exists beyond the line, are shown.

Place a 2D section, along with a bold line, on top of a 3D section, to show the cutting plane with the section behind 
it. 

~~~~~~~~~~~~~~~~~~~~~~~~~
Cutting 3D Sections
Cutting 2D Sections
Creating Section Viewports

Cutting 3D Sections
The Cut 3D Section command (Vectorworks Fundamentals only) cuts a 3D section, or slice, through a 3D model while 
leaving the model intact. The slice is placed on a new design layer.
To cut a 3D section from a 3D model:

1. Select the 3D model to section.
2. Select Model > Cut 3D Section.

The cursor changes to cross-hairs.
3. Click to set the start of the section. Draw a line across the object to define the section, and then click to set the end 

of the section.
When cutting a section while the drawing is in a Plan projection, the cutting plane (and the cut edge of the object) 
is perpendicular to the active layer plane.
When cutting a section while in a 3D projection, the cutting plane is perpendicular to the working plane.

4. Click on one side of the line to indicate the portion of the model to keep.
The Vectorworks program automatically creates a new design layer and places the cut 3D section on it. The 
original layer remains intact. The new 3D section behaves like any other Vectorworks 3D object.
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Dimensions and text are 2D objects; therefore, they do not rotate with the cut 3D section.
~~~~~~~~~~~~~~~~~~~~~~~~~
Cutting Sections
Cutting 2D Sections

Cutting 2D Sections
The Cut 2D Section command (Vectorworks Fundamentals only) cuts a 2D section, or a slice, from a 3D model 
without affecting the model. The slice is then placed on a new design layer. For example, to show the profile or a 2D 
cutaway section of an object in a mechanical 3D drawing, use this command to create the cutaway section in 2D 
quickly and easily, without affecting the original object.
To cut a 2D section from a 3D model:

1. Select the 3D model to section. 
2. Select Model > Cut 2D Section.

The cursor changes to cross-hairs.
3. Click to set the start of the section. Draw a line across the object to define the section, and then click to set the end 

of the section.
When cutting a section while the drawing is in a Plan projection, the cutting plane (and the cut edge of the object) 
is perpendicular to the active layer plane.
When cutting a section while in a 3D projection, the cutting plane is perpendicular to the working plane.

4. Click on one side of the line to indicate the portion of the model to keep.
The Vectorworks program automatically creates a new design layer and places the cut 2D section on it. The 
original layer remains intact.

Layer Linking

Creating Layer Links
Layers are independent of each other. Each design layer has its own scale, view, and render status. In the Vectorworks 
Fundamentals product, however, a layer link can be created that combines the geometry of several design layers, 
including referenced layers, onto a single design layer. The linked objects on this design layer display in the same view 
and scale, and share the same render status. This can then be used to give an accurate depiction of how objects in each 
layer work together. For example, the various floors of a building can be drawn on separate layers and then linked 
together into a new layer to form an entire building.

Select the object(s) and select Model > Cut 3D 
Section; set the section line and click on either side 

of it to specify the section to keep

The 3D section (rotated and rendered) is 
created on a new design layer; the original 

object(s) are left intact
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In the Vectorworks Fundamentals product, consider using viewports instead of layer links, as they provide a better 
and easier way to present drawings.
In the Vectorworks Design Series products, layer links are being superseded by design layer viewports. For 
backward compatibility, the Create Layer Link command can still be added to any of the Vectorworks Design 
Series workspaces, and existing layer links can still be viewed and edited. For information on design layer 
viewports, see “Creating Design Layer Viewports” on page 1620.

The layer link is created on a new design layer that contains links to the existing design layers of the drawing. 3D 
objects on selected layers are automatically linked; 2D planar or screen objects can be displayed in the layer link. Once 
the layer link is created, updates to the design layers are automatically reflected on the linked layer when a screen 
redraw occurs. However, this updating occurs only in one direction; any new objects or details added to the linked layer 
will not appear in any other layers. Linked objects cannot be edited on the linked layer; they must be edited on their 
source layer.
To create a layer link:

1. Create a new layer, and then make it the active layer.
This layer shows objects on all linked layers and any changes made to them.

2. Select View > Create Layer Link.
The Create Layer Link dialog box opens; the layer being linked to (the currently active layer) is not listed.

Click to show/hide the parameters.

3. Select the design layers to be linked from the list of existing layers.
4. Click OK.

Linked layers are locked objects. To unlock a linked layer, select Modify > Unlock. Double-click on an item in the 
layer link to return to its source layer and edit it.

To project 2D planar or screen objects after a layer link has been created, select and then unlock the layer link 
object. Select the options in the Object Info palette.

~~~~~~~~~~~~~~~~~~~~~~~~~
Cropping Layer Links
Creating Sheet Layer Viewports
Creating Design Layer Viewports
Converting Layer Links

Cropping Layer Links
Layer link objects can be cropped in a similar manner to viewports (see “Cropping Sheet Layer or Design Layer 
Viewports” on page 1652), although the area outside of the crop cannot be displayed as it can for a sheet layer or design 
viewport. When cropped, only a portion of the layer link displays; increase the scale of the layer to create a detailed 
view. Layer links with workgroup-referenced layers can also be cropped.

Parameter Description

Layers list Lists the existing design layers; sheet layers and the active design layer are not displayed. 
Referenced layers display in italics.

Display Planar Objects Select to display 2D planar objects, when the layer link is in a view other than Top/Plan
Project Screen Objects Select to display 2D objects associated with the screen plane, when the layer link is in a 

view other than Top/Plan
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To crop a layer link:
1. Select an existing layer link.
2. Unlock the layer link by selecting Modify > Unlock.
3. Click Edit Crop from the Object Info palette to enter the Layer Link Crop mode.

Alternatively, right-click (Windows) or Ctrl-click (Mac) on a layer link and select Edit Crop from the context 
menu.
A colored border around the drawing window indicates that you are in an editing mode. The Exit Crop command 
becomes available from the Modify menu, and the Exit Layer Link Crop button displays in the top right corner 
of the drawing window.

4. Create a 2D object such as a rectangle, circle, or polyline. The 2D object must define an area; a 2D line, for 
example, cannot be used. Position the 2D object to delimit the new crop display area. The fill of a cropping object 
is always None; however, the pen style can be set from the Attributes palette while in Edit Crop mode. Set the pen 
style to None (or the crop object class to invisible) to make the crop object invisible. Move and resize the 2D 
object as needed.
To view other objects while in Edit Crop mode, select Show other objects while in editing modes on the Display 
tab of the Vectorworks preferences (see “Vectorworks Display Preferences” on page 50).
Use the Flyover tool to adjust the view as necessary (see “Flyover” on page 1144).

5. Click Exit Layer Link Crop, or select Modify > Exit Crop to return to the drawing.
The cropped layer link is displayed. In the Object Info palette, the crop status has changed to Yes.
By increasing the scale of the layer with the layer link, and making other layers visible, a floor plan can be 
displayed (original design layer) along with a detailed view of the floor plan (zoomed in, cropped layer link).
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To change, replace, or delete the layer link crop, select the cropped layer link and then select Edit Crop from the 
Object Info palette to re-enter crop mode. Click Exit Layer Link Crop, or select Modify > Exit Crop to return to 
the drawing.
The entire layer link is displayed if a viewport of a cropped layer link is created.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Layer Links

Converting Layer Links
In the Vectorworks Design Series products, layer links are being superseded by design layer viewports. Because users 
of the Vectorworks Fundamentals product cannot create design layer viewports, and users of the Vectorworks Design 
Series products cannot create layer links, it occasionally may be necessary to convert a layer link into a viewport, or to 
convert a design layer viewport into a layer link.

• To convert a layer link into a design layer viewport, first unlock the layer link. Then, right-click (Windows) or 
Ctrl-click (Mac) on the layer link, and select Convert to Viewport from the context menu.

• To convert a design layer viewport into a layer link, select the viewport and then select Modify > Decompose. The 
Object Info palette changes to indicate that the object is now a group. Select Modify > Ungroup to create a layer 
link.

Records and Schedules
Some architectural elements (doors and spaces, for example) have pre-defined data that is automatically attached to 
them as they are created. Pre-formatted schedules are available for reporting this data, as well as data from other 
elements of the Vectorworks Architect, Landmark, and Spotlight products. (For information on choosing a 
preformatted schedule in Vectorworks Landmark and Spotlight, see “Creating Schedules Automatically” on 
page 1318.)
Typically, custom data records and schedules are created and edited with the Resource Browser. The Record and 
Schedule Management suite provides an alternate method for managing data in architectural documents.
For information about using the Resource Browser to create and edit record formats and schedules (worksheets), see 
“Record Formats” on page 262 and “Creating Worksheets” on page 1315. Record formats and schedules created in this 
way cannot be used with Vectorworks Architect product’s Record and Schedule management suite, however.
The records and schedules suite includes the following commands:

• VA Records and Schedules: Establishes default formats for records that can be attached to objects, and for 
schedules that can be generated from those records

• VA Create Record: Adds selected record formats to the current file
• VA Create Schedule: Adds selected schedules to the current file

By default, records and schedules created with VA Records and Schedules are added to the VA Defaults project 
preference set, and new files use that VA Defaults set. If additional sets of records and schedules are needed, create a 
new set of preferences and select that set before setting up a new drawing file. See “Working with Project Preference 
Sets” on page 1866 for more information.
~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Records and Schedules
Creating Records
Creating Schedules
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Defining Records and Schedules
Use the VA Records and Schedules command to create and modify a set of record format and schedule definitions that 
can be used in any file.
After defining record formats and schedules, make them available in the current file using the VA Create Record and 
VA Create Schedule commands.
~~~~~~~~~~~~~~~~~~~~~~~~~
Editing Record Definitions
Adding Record Definitions
Removing Record Definitions
Editing Schedule Definitions
Adding Schedule Definitions
Removing Schedule Definitions

Editing Record Definitions
To edit a record definition:

1. Select Tools > Reports > VA Records and Schedules.
The Records and Schedules dialog box opens.

Click to show/hide the parameters.

2. Select the record to edit.
3. Click Edit in the Records section of the Records and Schedules dialog box.

The Record Formats dialog box opens.
Click to show/hide the parameters.

4. Click Add to add a new record field or click Edit to edit the selected field.

Parameter Description

Records Lists currently defined record formats
Add Adds a new record to the current preference set
Remove Deletes the selected record
Edit Opens the selected record for editing

Schedules Lists currently defined schedule formats
Add Adds a new schedule to the current preference set
Remove Deletes the selected schedule
Edit Opens the selected schedule for editing

Parameter Description

Record Fields Lists the current fields of the selected record
Add Creates a new record field
Remove Deletes the selected record field (cannot be undone)
Edit Opens the selected record field for editing
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The Edit Field dialog box opens. Add or edit the field information.
Click to show/hide the parameters.

5. Click OK to close the Edit Field dialog box.
6. In the Record Formats dialog box, continue to modify, add, or remove record items.
7. Click OK to close the Record Formats dialog box, and then click Done to close the Records and Schedules dialog 

box.
Once a record definition has been updated, instances of the new record format cannot co-exist in the same file with 
instances of the old record format. If an object is inserted into a drawing with a record format that differs from the 
current record of the same name, a dialog box opens requesting which format to retain. Records in the un-retained 
format will be purged, and their information will be lost. For this reason, it is recommended that any changes be 
made to record formats prior to beginning a project.

~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Records and Schedules

Adding Record Definitions
To add a record definition:

1. Select Tools > Reports > VA Records and Schedules.
The Records and Schedules dialog box opens.

2. Click Add in the Records section of the Records and Schedules dialog box.
The Enter Text dialog box opens. Enter the name of the new record.

3. Click OK.
The Record Formats dialog box opens, listing the default fields of the new record; only the Add button is enabled.

4. Click Add to add a new field to the current record definition. Enter a Name and Default value for the field. Select 
the field Type from the list.

5. Click OK to close the Edit Field dialog box.
The new field displays on the Record Formats dialog box. If more fields are needed, repeat steps 4 and 5.

6. Click OK.
The new record and its fields are added to the record definition list.

7. Click Done to close the Records and Schedules dialog box.
~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Records and Schedules

Removing Record Definitions
To remove a record definition:

1. Select Tools > Reports > VA Records and Schedules.

Parameter Description

Name Specifies the name of the selected record field
Default Enter a default value for the field, if desired
Type Specifies the type of field: Integer, Boolean, Number, or Text
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The Records and Schedules dialog box opens.
2. Select the record to remove.
3. Click Remove in the Records section of the Records and Schedules dialog box. This operation cannot be undone; 

click Yes to confirm that the record should be removed.
The record definition is removed from the record list.

4. Click Done to close the Records and Schedules dialog box.
~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Records and Schedules

Editing Schedule Definitions
The Schedule definitions detail the column heading text, width, and border attributes for each record field being 
reported.
To edit a schedule definition:

1. Select Tools > Reports > VA Records and Schedules.
The Records and Schedules dialog box opens.

2. Select the schedule to edit.
3. Click Edit in the Schedules section of the Records and Schedules dialog box.

The Edit Schedule Format dialog box opens. Specify the schedule appearance by selecting the column order and 
formatting.

Click to show/hide the parameters.
 

4. Click Options to edit the schedule font style and size.

Parameter Description

Schedule Information Select the record to format, defining the data to be reported in the schedule
Available Record Fields Select the record field(s) to include in the schedule
Schedule Columns Displays the fields that will be included in the schedule
Add > Moves the selected available record field into the Schedule Columns list
< Remove Deletes a selected field from the Schedule Columns list
Move Up Moves the selected field up in the Schedule Columns list order
Move Dn Moves the selected field down in the Schedule Columns list order
Heading Enter a title for the selected Schedule Column item, if desired. The title displays in row 2 

of the column corresponding to the field.
Sub-Heading 1 Enter a subheading for the selected Schedule Column item if desired. The title displays 

in row 3 of the column corresponding to the field.
Sub-Heading 2 Enter a subheading for the selected Schedule Column item, if desired. The title displays 

in row 4 of the column corresponding to the field.
Width (chars) Specifies the width, in characters, for the selected Schedule Column item
Borders Specifies the column border display for the selected Schedule Column
Options Opens the Schedule Format Options dialog box; proceed with step 4
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The Schedule Format Options dialog box opens; the current font type and size settings for the heading, 
subheadings, and body display. 

5. If different font settings are desired, click the appropriate Change button to open the Format Text dialog box and 
modify the font type and size for the heading, subheadings, and body of schedule items. (See “Formatting Text” 
on page 389.)

6. Click OK to close the Schedule Format Options dialog box, and then click OK to close the Edit Schedule Format 
dialog box.

7. Click Done to close the Records and Schedules dialog box.
~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Records and Schedules

Adding Schedule Definitions
To add a schedule definition:

1. Select Tools > Reports > VA Records and Schedules.
The Records and Schedules dialog box opens.

2. Click Add in the Schedules section of the Records and Schedules dialog box.
The Enter Text dialog box opens.

3. Enter the name for the new schedule.
4. Click OK.

The Edit Schedule Format dialog box opens. For details on the Edit Schedule Format dialog box parameters, see 
“Editing Schedule Definitions” on page 1862.

5. Select the record that defines the data to be reported in the new schedule, and then add the desired fields to use for 
the schedule.

6. Select a schedule column, and then enter the column formatting information. If desired, click Options and set the 
font formatting for the column, and then click OK.

7. Click OK to save the new schedule.
The new schedule definition is added.

8. Click Done to close the Records and Schedules dialog box.
~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Records and Schedules

Removing Schedule Definitions
To remove a schedule definition:

1. Select Tools > Reports > VA Records and Schedules.
The Records and Schedules dialog box opens.

2. Select the schedule definition to remove.
3. Click Remove in the Schedules section of the Records and Schedules dialog box. This operation cannot be 

undone; click Yes to confirm that the schedule should be removed.
The schedule definition is removed from the schedule list.

4. Click Done to close the Records and Schedules dialog box.
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~~~~~~~~~~~~~~~~~~~~~~~~~
Defining Records and Schedules

Creating Records
The VA Create Record command adds record formats created with the VA Records and Schedules command to the 
current file. Once the records are added, they can be attached to items in the drawing using the ID Label tool. They can 
also be attached by selecting an object and then selecting the check box next to the record format in the Data tab of the 
Object Info palette.
To create a record:

1. Select Tools > Reports > VA Create Record.
The Create Record dialog box opens, listing the available records that can be added to the file.

2. Select the record to add to the file.
3. Click OK to add the specified record to the file.

Creating Schedules
The VA Create Schedule command generates worksheets for the current file. Any schedule definitions that were 
created with the VA Records and Schedules command display in the list, as well as several pre-formatted schedules 
provided as default content with the Vectorworks Architect product. 

The Display default content option must be selected on the Session tab of Vectorworks preferences to see the 
pre-formatted schedules. (See “Session Preferences” on page 52.)

Pre-formatted schedules include:

To generate a schedule:
1. Select Tools > Reports > VA Create Schedule.

The Create Schedule dialog box opens, listing the schedules that can be added to the file.
2. Select the desired schedule to be created. Enter a new Schedule Title if desired. Select Place worksheet on 

drawing to place the worksheet on the drawing for printing.

• Diffuser Report • Hardscapes Budget US • Plant List - Simple w/Images

• Door Hardware Legend • Objects with IFC Entity • Plant List - Types

• Door Schedule • Objects with IFC Entity - Specific • Plumbing Schedule

• Door Schedule w/Images • Objects without IFC Entity • Roof Face Area

• Drawing List • Plant List - Basic • Room Finish Schedule

• Equipment Schedule • Plant List - Basic w/Images • Wall Area

• Existing Tree Schedule • Plant List - Colors • Wall Style Report

• Existing Tree Schedule w/Images • Plant List - Colors w/Images • Wall Style Report w/Images

• Irrigation Head Schedule • Plant List - Costing • Window Schedule

• Irrigation Line Schedule • Plant List - Costing w/Images • Window Schedule w/Image

• Hardscapes Budget UK • Plant List - Simple •
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3. Click OK.
Each schedule has a record format associated with it. If there is a difference between the record definition 
currently in the file and the record definition in the current preference set, a notice displays with the option to 
continue or fix the record.
If the selected schedule already exists in the file, a warning dialog box opens. Select whether to replace or rename 
the new schedule (some schedules also have a recalculate option), and click OK.

4. Click on the drawing area where the top left corner of the schedule is to be located.
The worksheet opens, displaying the schedule information. If the option to place the worksheet on drawing was 
selected, the worksheet is included on the drawing.
If the “on drawing” worksheet is accidentally deleted, select the worksheet name from the Resource Browser and 
select Resources >Worksheet On Drawing.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a Room Finish Legend

Creating a Room Finish Legend
There can be dozens of room finishes assigned within a project file. To obtain a detailed report of all room finish data, 
first generate a room finish schedule as described in “Creating Schedules” on page 1864. Then generate a detailed 
legend showing a full description of the finishes using the Create Rm Finish Legend command. This command can 
only be used after room finishes have been assigned to space objects.
To generate a room finish legend:

1. Select Tools > Reports > Create Rm Finish Legend.
The Create Room Finish Legend dialog box opens.

Click to show/hide the parameters.

2. Select whether the legend should be displayed as a text block or as a worksheet. See “Creating Text Blocks” on 
page 384 and “Creating Worksheets” on page 1315.

Parameter Description

Create legend as text block Adds the legend to the drawing as a text block
Label Indent Sets the offset from the location title to the item title
Note Indent Sets the offset from the location title to the item description
Section Spacing Sets the text spacing between each section
Note Spacing Sets the text spacing between each item description
Bold Section Titles Displays the location titles in bold face text 

Create legend as worksheet Adds the legend to the drawing as a worksheet
Worksheet Name Sets the name of the worksheet
Place worksheet in document Places the worksheet on the drawing at the next mouse click
Add row between sections Adds a worksheet row between each location section
Bold section titles Displays the location titles in bold face text
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3. Click OK.
~~~~~~~~~~~~~~~~~~~~~~~~~
Creating Schedules

Working with Project Preference Sets
In most cases, the default project preference set (VA Defaults) is the only set needed. If additional sets of records and 
schedules are needed, create a new set of preferences and select that set before setting up a new drawing file. 
A project preference set is a grouped configuration of record, schedule, and library information that is used by a 
drawing file. A project preference set can be customized for particular projects (residential or commercial, for 
example) or different types of clients (restaurant or retail store, for example). Different record and schedule formats can 
be assigned, as well as information in room finish libraries and door hardware libraries. These custom configurations 
are saved in external text files. The VA Set Project Prefs command assigns which set of external files to use within the 
current drawing. The settings files used by these commands, taken together, are called a “project preference set.” 
Dialog boxes in the Vectorworks Architect product’s Record and Schedule management suite display the name of the 
current preference set in the title bar.
Because the preference sets are stored as external files, they can be shared among many users to comply with office 
standards. The preference set folders can be copied to the same location for each user, or shared on a network location. 
Either select the VA Set Project Prefs command to designate the preference set location, or copy the following text file 
to each computer:
[Vectorworks]\Plug-Ins\VW_Arch\Data\VA2_Preference_Set_Paths.txt
See “Project Preference Sets” on page 1897 for information on the files contained in the preference set folders.
~~~~~~~~~~~~~~~~~~~~~~~~~
Selecting a Project Preference Set
Creating a New Project Preference Set

Selecting a Project Preference Set
The default preference set is named “VA Defaults,” and its files are located in 
[Vectorworks]\Plug-Ins\VW_Arch\Data\Prefs_Def.
To use a different project preference set, select it when setting up the file. The preference set selection is saved with the 
file. Changes to VA Records and Schedules, the Door Hardware Library, or the Room Finish Library are saved in the 
currently selected project preference set.

When using template files for different types of projects, make a preference set selection before saving the 
template.

To select a project preference set:
1. Select Tools > Options > VA Set Project Prefs.

The VA Preference Sets dialog box opens. The listed sets are available for use in the file.

Display Method Description

Text block Define the area for the legend to occupy. Click to set the top left corner of the text block, and 
then click to set the bottom right of the text block. The text legend is generated within the 
defined rectangle.

Worksheet The worksheet is created with the legend information. If the Place worksheet in document 
option is selected, click on the drawing to set the top left corner of the worksheet.
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Click to show/hide the parameters.

2. Select the project preference set to activate.
3. Click Done.

The selection “VA Defaults” cannot be deleted or edited; it contains the information that is used if no project 
preference set is designated or if there is an error finding the designated set.

~~~~~~~~~~~~~~~~~~~~~~~~~
Creating a New Project Preference Set

Creating a New Project Preference Set
While the Vectorworks Architect product installs with six project preference sets, it supports the use of an unlimited 
number. To add preference sets beyond the default options, manually create additional preference folders and then add 
the set to the list of defined sets using the VA Set Project Prefs command.
The project preference set folder must contain the following files for correct operation:

• Door Hardware Library.txt
• Equipment Record.txt
• Equipment Schedule.txt
• Plumbing Fixt Record.txt
• Plumbing Schedule.txt
• VA2 Records and Schedules.txt
• VA_Project_Set.txt

If additional records and schedules are defined using the VA Records and Schedules command, their data files are 
stored in the project preference set folder.

Adding a Project Preference Set
After creating a project preference set, add it to the list of project preference sets available:

1. Select Tools > Options > VA Set Project Prefs.
2. The VA Preference Sets dialog box opens. Click Add.

The Add Preference Set dialog box opens. Specify the name and location of the project preference set.
Click to show/hide the parameters.

3. Click OK to return to the VA Preference Sets dialog box. To use the new project preference set, select it from the 
list and click Done.

Parameter Description

Preference set list Lists project preference sets that are available for use in the file
Add Adds a project preference set to the list; specify the set location and name
Remove Deletes the selected project preference set association (the file is not deleted, but cannot be 

selected for this project)
Edit Changes the project preference set name or location

Parameter Description

Path Enter or browse for the path to the project preference set folder
Name Specifies a name for this project preference set
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~~~~~~~~~~~~~~~~~~~~~~~~~
Records and Schedules

Creating a Human Figure
A 3D human figure object can be inserted for a realistic addition to the drawing. Constructed of NURBS surfaces for a 
high-quality model, the object contains a wide variety of parameters for full control over the figure type, position, and 
appearance.

An entourage/figures object library also contains pre-configured human figure objects in a variety of poses and 
figure types (see “Resource Libraries” on page 219).

Several figures can increase the time required to render the model in 3D.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting the Figure and Setting Parameters
Setting Figure Attributes
Specifying a Custom Figure Position

Inserting the Figure and Setting Parameters

To insert and configure a human figure:

1. Click the Human Figure tool from the Visualization tool set. 
2. Click to place the human figure in the drawing.
3. The human figure parameters can be modified from the Object Info palette.

Click to show/hide the parameters.

Parameter Description

Height Specifies the figure height, in the current unit
Body Type Select the figure body type (Slight/Petite, Average, or Large)
Figure Type Select the type of human figure (Man, Woman, Boy, or Girl)
Posture Select the figure position; Custom is displayed when the figure posture has been adjusted in the 

Figure Custom Position dialog box (see “Specifying a Custom Figure Position” on page 1870)
Hand Height For the Standing (shaking hands) posture, specifies the height of the hands, in the current unit
Attire (Top) Select the clothing for the top of the figure
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~~~~~~~~~~~~~~~~~~~~~~~~~
Setting Figure Attributes
Specifying a Custom Figure Position

Setting Figure Attributes
Figure attributes can be set precisely to control the figure appearance.
To set figure attributes:

1. Select the desired figure.
2. In the Object Info palette, make the initial selections for the figure.
3. Click Set Attributes from the Object Info palette.

The Human Figure Attributes dialog box opens, with the figure set to the current Object Info palette parameters. 
Select each desired model part and then set its attributes.

Click to show/hide the parameters.

Attire (Bottom) Select the clothing for the bottom of the figure
A dress overrides the selected top attire

Footwear Select the figure’s footwear, or select None if the figure is barefoot
Hair Select the figure’s hairstyle
Jacket Places a jacket on the figure
Stockings Places stockings on the figure
Tie Places a tie on the figure
Set Attributes Click to set the figure attributes more specifically (see “Setting Figure Attributes” on 

page 1869)
Custom Position Click to set a custom figure position (see “Specifying a Custom Figure Position” on page 1870)

Parameter Description

Preview Displays a preview of the figure in the specified posture, with a sample of the selected 
texture and attributes

Rotate Left/Right Rotates the figure preview 90 degrees to the left or right
Render Select a rendering mode for the preview figure. If Automatically Render is not selected, 

click Render after each attribute change to view a rendered preview.
Automatically 
Render

Renders the preview figure automatically, according to the selected mode, after an 
attribute change (depending on the selected rendering mode and the inclusion of attributes 
such as textures, this can take some time)

Model parts Select each figure attribute to configure, and then set its parameters
Attributes

Class Select a class to apply to the attribute from the list of classes in the file, or select Container 
to apply the object’s class to the selected attribute

Parameter Description
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For more information on texture parameters and mapping, see “Applying and Mapping Textures” on page 1527.
4. Click OK to apply the attributes to the figure.

~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting the Figure and Setting Parameters
Specifying a Custom Figure Position

Specifying a Custom Figure Position
If the Posture selection is not sufficient to position the figure exactly as desired, a custom figure pose can individually 
position the figure’s head, body, arms, and legs.

Use the Rotate tool to set the overall position of the figure.
To specify a custom figure pose:

1. Select the desired figure.
2. In the Object Info palette, make the initial parameter selections for the figure.
3. Click Custom Position from the Object Info palette.

The Figure Custom Position dialog box opens, with the figure set to the current Object Info palette parameters. 
Select the body part tab to change, and then set the part parameters by dragging the slider for the desired settings.
Use slight slider adjustments for best results.

Click to show/hide the parameters.

Fill Style Select Class to use the class style for the selected attribute, choose None to apply no fill, 
or choose Solid to apply a solid color and then click on the color box to select the fill color

Texture 
(Renderworks 
required)

Sets the texture parameters for the selected attribute from either the default content or the 
current file’s content; see “Resource Libraries” on page 219

Texture Select the texture to apply from either the default content or the textures in the current file, 
or select Class to apply the class texture; select None to apply no texture 

Map Type Select the texture map type
Radius For sphere and cylinder maps, sets the texture radius; the default radius is the same as the 

3D object radius. Increasing this value reduces the size of the texture on the object.
Repeat 
Horizontally/ 
Vertically

Repeats the texture in a horizontal and/or vertical direction

Scale Factor Determines the texture size when projected onto the object; either enter a scale value or 
use the slider to change the scale

Horizontal/
Vertical Offset

Sets the start location of the texture horizontally and vertically

Rotation Sets the angle of texture rotation; either enter a rotation value from 0 to 360 degrees or use 
the slider to change the rotation angle

Parameter Description
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Parameter Description

Preview Displays a preview of the figure with the specified figure pose
Rotate Left/
Right

Rotates the figure preview 90 degrees to the left or right

Render Select a rendering mode for the preview figure. If Automatically Render is not selected, click 
Render after each position change to view a rendered preview.

Automatically 
Render

Renders the preview figure automatically, according to the selected mode, after a position 
change (depending on the selected rendering mode and the inclusion of attributes such as 
textures, this can take some time)

Revert Returns the figure to its original position
Head Specifies the head parameters

Angle Indicates where the head is positioned along a vertical axis (looking “up” or “down”). Move 
the slider left to move the head up, and move the slider right to look down.

Tilt Specifies how much the head tilts to the left or right; move the slider left to tilt over the right 
shoulder, and move the slider right to tilt over the left shoulder

Turn Sets the amount that the head turns to the left or right; move the slider right to look over the left 
shoulder, and move the slider left to look over the right shoulder

Body Specifies the body trunk parameters
Hip Bend Sets the bend of the lower torso and legs, by setting the angle between the hip and thigh. Move 

the slider right to set the angle towards the back of the body, and move the slider left to set the 
angle towards the front of the body

Waist Bend Indicates the bend of the upper torso; move the slider right to bend forwards, and left to bend 
backwards

Waist Tilt Indicates how much the upper torso tilts to the left or right; move the slider right to tilt towards 
the left, and move the slider left to tilt towards the right

Waist Twist Specifies how much the upper torso twists to the left or right; move the slider right to rotate 
towards the left, and move the slider left to rotate towards the right

Arms Specifies the arm parameters
Arm Selector For each parameter, select the arm for the position change, or select Both Arms to mirror the 

position change on both sides of the body
Arm Rotation Specifies the arm position at the front or back of the body; move the slider right to move the 

arm behind the body, and move the slider left to move the arm in front of the body
Arm Twist Specifies the arm position as it twists along the arm axis; move the slider right to rotate the arm 

counter-clockwise, and move the slider left to rotate the arm clockwise
Arm Angle Sets the up and down position of the arm; move the slider left to move the arm away from the 

body, and move the slider right to move the arm towards the body (depending on which arm 
moves, this may be reversed)

Elbow Bend Specifies the amount that the elbow is bent; normally, move the slider left to bend the elbow in 
a natural direction

Wrist Twist Sets the rotation of the wrist; move the slider left to twist the wrist clockwise and to the right to 
twist the wrist counter-clockwise
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4. Click OK to apply the custom position to the figure.
~~~~~~~~~~~~~~~~~~~~~~~~~
Inserting the Figure and Setting Parameters
Setting Figure Attributes

Exporting for DOE-2 Requirements
With rising energy costs and stricter regulations on energy usage in commercial buildings, it is becoming increasingly 
important to be able to estimate the energy cost implications of design strategies, especially during the schematic 
design phase. Energy usage programs develop these estimates. The Vectorworks Architect product can export the 
building geometry to a file in the format read by the DOE energy analysis engine.
To create a DOE-2 export file:

1. The initial building space planning should be complete, with layers for all the building levels and spaces on those 
layers. Exterior walls are also required; create these automatically with the Create Walls from Spaces command, 
or manually.
Windows and doors should also be inserted into the walls where appropriate.

2. Select AEC > Space Planning > Export DOE-2. 
The Export DOE-2 dialog box opens.

Click to show/hide the parameters.

Hand Twist Sets the flex of the hand; move the slider to the left to flex the hand towards the front of the 
body, and move the slider to the right to flex the hand towards the back of the body

Legs Specifies the leg and foot parameters
Leg Selector For each parameter, select the leg for the position change, or select Both Legs to mirror the 

position change on both sides of the body
Leg Rotation Specifies the leg position at the front or back of the body; move the slider right to move the leg 

behind the body, and move the slider left to move the leg in front of the body
Leg Twist Specifies the leg position as it twists along the leg axis; move the slider right to rotate the leg 

counter-clockwise, and move the slider left to rotate the leg clockwise
Leg Angle Sets the up and down position of the leg; move the slider left to move the leg away from the 

body, and move the slider right to move the leg towards the body (depending on which leg 
moves, this may be reversed)

Knee Bend Specifies the amount that the knee is bent; normally, move the slider left to bend the knee in a 
natural direction

Foot Rotation Sets the rotation of the foot; move the slider left to twist the foot clockwise and to the right to 
twist the foot counter-clockwise

Foot Flex Sets the flex of the foot; move the slider to the left to flex the foot towards the front of the body, 
and move the slider to the right to flex the foot towards the back of the body

Parameter Description

File Name Enter the path and file name for the DOE-2 file, or click Browse to specify the location and file 
name

Parameter Description
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3. Click OK to create the DOE-2 text file. Send the file to your DOE consultant for analysis.
The relationship between Vectorworks entities and their corresponding BDL language entities is shown in the 
following table.

~~~~~~~~~~~~~~~~~~~~~~~~~
Generating an INP File from a DXF File

Generating an INP File from a DXF File
If .INP files need to be generated from DXF files for analysis with the DOE-2 engine, several steps are required to 
properly import and format the file in the Vectorworks Architect product prior to exporting it.

X-REFs and Layers
AutoCAD building plans are often broken up into several files, which are then cross-referenced (x-ref) to a master file. 
Prior to importing into a Vectorworks file, all of these files must be pulled into the master file. Essentially, all of the 
information about a building must be present in one file for the export to recognize the relationships among adjacent 
building levels and spaces on each of those floors. See “DXF/DWG and DWF File Import” on page 1716.
Vectorworks classes are roughly equivalent to AutoCAD layers. When importing the DXF file, the layers should be 
imported as Vectorworks classes. The Vectorworks program allows the specification of the base elevation (Z value) of 
layers; therefore, Vectorworks layers are typically used to separate the different building levels in the drawing. Once 
these layers have been established with the appropriate Z values, it is much easier to draw on the layers without having 
to specify base heights of each object.
The Export DOE-2 command uses the layer Z values to determine the Z value of each floor in the INP file. After 
importing a DXF file, first create a layer for every building level, and then assign a Z value to that layer. In addition, 
assign a delta Z value. In a normal drawing created with the Vectorworks Architect product, the delta Z controls the 
default height (at object creation time) of all walls on that layer. The Export DOE-2 command uses the delta Z as the 
space-height.
To create a layer for a building level, select Tools > Organization. On the Design Layers tab, create and set properties 
for the building level layer. See “Creating Layers” on page 162 and “Setting Design Layer Properties” on page 165.

Defining Spaces
Once the layers have been defined, define the spaces. Polygons may already exist for all the spaces; if so, convert the 
polygons to spaces with the Create Spaces from Polys command (see “Space Settings” on page 406).

Confirm Layer 
Heights

Displays the floor elevation and ceiling heights as specified in the Layers Setup dialog box; these 
values can be edited

Up/Down Scroll up and down through the list of layers (available when there are more than five layers)

Vectorworks DOE

Distance from layer Z to next highest layer Z Floor height
Layer delta-Z Space height
Description field in wall record Construction type
Wall record R-value Construction type U-Factor
Window vs. door record Window vs. door

Parameter Description
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Walls
The Vectorworks program has a dedicated object type for walls. A Vectorworks wall is a complex object type which is 
a combination of lines, arcs (in the case of rounded walls), polygons/polylines, and fill patterns. The Vectorworks 
Architect product adds more functionality to wall objects by attaching a record with a description field.
The Export DOE-2 command checks for wall objects along the perimeter of the spaces in the drawing. If walls are 
found, it checks for a wall record. If this is found, the description field is exported as the construction type for that 
segment. If no wall record is present, the command exports the wall’s class name as the construction type. If it does not 
find a wall object on any particular space vertex, a default construction type for the wall on that vertex is assigned. The 
default construction types are “Default Exterior Wall” construction and “Default Interior Wall” construction.
If the walls in the original DWG file were drawn with multi-lines, importing the multi-lines as Vectorworks walls is 
recommended. If the original draftsperson did not use multi-lines, then the walls must be manually drawn. The walls 
must be on the same layer as their respective space objects. In other words, first floor walls must be on the same layer 
as the space objects for the first floor.

Windows and Doors
The Export DOE-2 command determines the difference between windows and doors on the basis of the attached 
record. If the symbol has a door record attached, the symbol is exported as a door. If it has a window record attached to 
it, or no record at all, it is exported as a window.
To export windows and doors, walls are required. Inserting windows and doors into Vectorworks walls is much easier 
than creating them mathematically within the DOE-2 interface. Vectorworks walls normally “contain” the windows 
and doors, essentially as nested objects. The associativity of windows and doors with their parent walls allows the 
Export DOE-2 command to recognize which windows/doors are associated with which walls, and export them to the 
appropriate place in the INP file. Ensure that when inserting the windows and doors into the walls, they create a wall 
break. Otherwise, they are not considered associated with the wall.
AutoCAD blocks can be used, which convert to Vectorworks symbols during the DXF import. The length of the 
window/door, parallel to the wall, is exported as the width. For windows, the elevation of the lowest part of the window 
is exported as the Y value.

Cam Design
The cam design tool can be animated and generates cam data worksheets and diagrams.
~~~~~~~~~~~~~~~~~~~~~~~~~
Cam Template
Cam Properties
Cam Data Worksheets
Cam Diagrams

Cam Template
To use the cam design tool, open a new file and select the Cam (Imperial).sta or Cam (Metric).sta template.
To open the cam template:

1. Select File > New. 
The Create Document dialog box opens.

2. Select Use document template, and choose the Cam (Imperial).sta or Cam (Metric).sta template.
3. Click OK. The new file opens, with a cam inserted by default. The file contains Cam and Diagrams layers.
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The recommended procedure to include a cam in a Vectorworks drawing is to copy and paste it into the drawing, 
and convert it to a group by selecting it and selecting Modify > Convert > Convert to Group.

~~~~~~~~~~~~~~~~~~~~~~~~~
Cam Properties
Cam Data Worksheets
Cam Diagrams

Cam Properties
The cam object is a point object located in the Cam (Imperial).sta and Cam (Metric).sta templates. Cam properties can 
be edited in the Object Info palette.

Click to show/hide the parameters.

Parameter Description

Prime Circle Radius Specify the prime circle radius
Cam Type Select plate or groove
Outside Dia. Enabled if Groove is selected in Cam Type. Enter the outside diameter for groove 

cam types.
Cam Drawing Incr. 
(Deg.)

Enter the cam drawing increment, in degrees; this parameter affects how the cam is 
drawn. The larger the value, the less smoothly the cam is drawn. 

Cam Speed (rpm) Specify the cam rotation in revolutions per minute (rpm); this value is used to 
calculate the velocity and acceleration of the cam follower

Prime Circle

Follower Offset

Offset Circle

Follower Diameter
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Follower Type Select one of the follower types

Follower Dia. Enter the follower diameter
Follower Offset Enabled if Offset Translating Roller or Offset Pivot Roller is selected in Follower 

Type. Indicate the distance between the center of the cam and the follower center 
for the offset follower types.

Pivot X/Y (from cam 
center)

Enabled if Pivot Roller is selected in Follower Type. Specify the x and y distance 
from the cam center to the pivot arm for pivot roller follower types.

Draw Followers Select to display the followers
Follower Incr. (Deg.) Determine at what angles to display followers by entering the follower increment in 

degrees (to show only the actual follower, enter 360). If a segment of the cam ends 
on an angle that does not correspond to the follower increment, the additional 
follower is also displayed.

Draw Prime and Offset 
Circles

Select to display both the prime and offset circles

Parameter Description

Radial Translating Offset PivotPivot Offset Translating

Pivot X

Pivot Y

Prime circle

Offset circle (offset 
follower types only)
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~~~~~~~~~~~~~~~~~~~~~~~~~
Defining the Cam Profile
Animating Cam Movement
Cam Template
Cam Data Worksheets
Cam Diagrams

Draw Follower Path Select to display the follower path

Draw Radii Select to draw a radius from each follower to the center mark

Draw Center Mark Select to draw a center mark

Data Incr. (Deg.) Specify the increment at which the displacement, velocity, and acceleration of the 
cam follower are calculated for the worksheet and text file

Define Cam Profile Click to specify the profile of each cam segment
Write Data to 
Worksheet

Click to write the results (displacement, velocity, and acceleration) to the worksheet 
named Cam Data, using the increment specified by Data Incr. 

Write Data to Text File Click to write the results (displacement, velocity, and acceleration) to a text file 
using the increment specified by Data Incr. 

Animate Click to animate the cam
Reset Cam to 0 Click to position the cam back to zero degrees; for more information, see “Resetting 

the Cam to Zero Degrees” on page 1878

Parameter Description

Follower path

Follower radius

Center mark
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Defining the Cam Profile
Specify the profile of each cam segment in the Define Cam Profile dialog box.
To define the cam profile:

1. Select the cam, and click Define Cam Profile on the Shape tab of the Object Info palette.
The Enter Value dialog box opens.

2. Enter the number of cam segments and click OK.
The Define Cam Profile dialog box opens for specifying the parameters for each segment. Click OK to update 
cam diagram.

Click to show/hide the parameters.

Animating Cam Movement
The effect of parameter changes to the cam design can be evaluated by animating the cam.
To animate the cam:

1. Select the cam, and in the Object Info palette, click Animate.
The Rotate Cam dialog box opens.

2. Adjust the relative speed by moving the slider along the Speed bar.
3. Click Rotate.

The cam rotates at the relative speed specified and the follower moves accordingly.
Since the animation is for illustrative purposes only, the Cam Speed parameter does not affect the animation. 
However, the animation is affected by the selected speed in the Rotate Cam dialog box; the larger the increment, 
the faster the cam appears to rotate. In addition, the computer processor speed also affects the apparent animation 
speed.

4. To stop the cam rotation, press any key or click anywhere on the screen.

Resetting the Cam to Zero Degrees
Once the cam rotation stops, the position of the cam remains where it was when it was stopped. To reset the cam to zero 
degrees (original position), click Reset Cam to 0 on the Shape tab of the Object Info palette.

Cam Data Worksheets
Two worksheets are defined in the Cam (Imperial).sta and Cam (Metric).sta templates: 

• Cam Data – lists cam data, such as rotation angle, follower displacement, velocity, and acceleration 
• Cam Properties – lists the cam parameters from the Object Info palette

The worksheets are accessed by selecting them from the Window > Worksheets menu or from the Resource Browser. 
The Cam Properties worksheet updates when the Define Cam Profile dialog box is exited (see “Defining the Cam 

Parameter Description

Type of Motion Select the type of motion for each segment
End Angle Specify the end angle for the segment
Displacement Specify the displacement at the end point of the segment
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Profile” on page 1878). The Cam Data worksheet updates when the cam properties are changed. The worksheets can be 
placed on the drawing as graphic objects, if desired (see “Worksheets as Graphic Objects” on page 1360).

To prevent slower performance, when changing cam properties, keep the Cam Data worksheet closed.
~~~~~~~~~~~~~~~~~~~~~~~~~
Cam Template
Cam Properties
Cam Diagrams

Cam Diagrams
Diagrams of the cam follower displacement, velocity and acceleration are created automatically from the current cam 
properties.

The diagrams exist on the Diagrams layer.
To display or update the diagrams:

1. Select the Draw Cam Diagrams command from the appropriate menu:
• Architect workspace: AEC > Machine Design > Draw Cam Diagrams 
• Landmark workspace: Landmark > Machine Design > Draw Cam Diagrams 
• Spotlight workspace: Spotlight > Machine Design > Draw Cam Diagrams 

2. The cam diagrams are displayed. To return to the cam, select Cam from the Layers list on the View bar.
~~~~~~~~~~~~~~~~~~~~~~~~~
Cam Template
Cam Properties
Cam Data Worksheets

Geneva Mechanism
The Geneva mechanism device produces intermittent rotational motion of the driven part (index plate) while the driver 
rotates at a constant speed.
~~~~~~~~~~~~~~~~~~~~~~~~~
Geneva Mechanism Template
Geneva Mechanism Properties
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Animating Geneva Mechanism Movement

Geneva Mechanism Template
The Geneva mechanism is available in the Geneva Mechanism (Imperial).sta and Geneva Mechanism (Metric).sta 
template files.
To open the Geneva mechanism template:

1. Select File > New. 
The Create Document dialog box opens.

2. Select Use document template, and choose the Geneva Mechanism (Imperial).sta or Geneva Mechanism 
(Metric).sta template.

3. Click OK. 
The new file opens with a Geneva mechanism inserted by default.
The recommended procedure to include a Geneva mechanism in a Vectorworks drawing is to copy and paste it 
into the drawing and convert it to a group by selecting it and selecting Modify > Convert > Convert to Group.

~~~~~~~~~~~~~~~~~~~~~~~~~
Geneva Mechanism Properties
Animating Geneva Mechanism Movement

Geneva Mechanism Properties
The Geneva mechanism’s properties can be edited in the Object Info palette.

Click to show/hide the parameters.

Parameter Description

Number of Points Enter the number of points on the index plate
Center Distance Enter the distance between the center of the index plate and the driver

Index Plate

Follower Dia. 

Cam Cutout 
R

Number of Points = 6

Driver

Center Distance

Cam Clearance

Lighting Hole Dia. 

Cam Dia.

Driver Dia.

Lighting Hole Center 
Distance 

Index Plate Dia.

Follower
 Dist.
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~~~~~~~~~~~~~~~~~~~~~~~~~
Geneva Mechanism Template
Animating Geneva Mechanism Movement

Animating Geneva Mechanism Movement
The effect of parameter changes to the Geneva mechanism design can be evaluated by animating the Geneva 
mechanism.
To animate the Geneva mechanism:

1. Select the Geneva mechanism, and in the Object Info palette, click Animate.
The Rotate Geneva Mechanism dialog box opens.

2. Adjust the relative speed by moving the slider along the Speed bar.
3. Click Rotate.

The Geneva mechanism rotates at the relative speed specified.
4. To stop the Geneva mechanism rotation, press any key or click anywhere on the screen.

Resetting the Geneva Mechanism to Zero Degrees
Once the mechanism rotation stops, the position of the mechanism remains where it was when it was stopped. To reset 
the mechanism to zero degrees (original position), click Reset Mechanism to 0 on the Shape tab of the Object Info 
palette.

Notes Manager Database Format
The Notes Manager, in version 11 and later, can use a database from an outside source, provided that it has been 
formatted appropriately. Data files must be in one of two formats: a version 11 or later format, or the format used by the 
Notes Manager in versions of Vectorworks software previous to version 11. The format used by previous versions may 
be somewhat simpler to use, and is automatically converted to the current format by the Notes Manager.

Follower Dia. Enter the follower diameter
Cam Clearance Enter the cam clearance
Cam Dia. Enter the cam diameter
Driver Dia. Enter the driver diameter
Index Plate Dia. (Ref.) Displays the diameter of the index plate 
Follower Dist. (Ref.) Displays the follower distance
Cam Cutout Radius 
(Ref.)

Displays the cam cutout radius

Lighting Holes Select to place lighting holes on the driver
Number Enter the number of lighting holes
Diameter Enter the diameter of the lighting holes
Center Distance Enter the distance between the center of the lighting holes about the driver

Show Center Marks Select to place center mark symbols on the index plate and cam/driver
Show Center Lines Select to draw the index plate and cam/driver with center lines

Parameter Description
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Formatting by Previous Version
The database format must adhere to the following requirements to be recognized as a database from versions of the 
Notes Manager prior to 11.

• The first line must contain only a numeric value
• The rest of the file must contain notes with the following data separated by tabs: 

• a numeric value
• a dash
• the section name
• the description
• the note text

• Additional tabs or carriage returns are not allowed within each field
• There can be no blank lines before the end of the file

This format is illustrated by the following example.

Formatting by Current Version
The database format must adhere to the following requirements to be recognized as a database from version 11 and 
later Notes Manager.

• The first line must contain the word “NotesManager11DataFile”
• The second line must contain the database ID (unique for all databases used)
• The rest of the file must contain notes with the following data separated by tabs:

• a note ID (unique for all notes in the file)
• the section name
• the description
• the note text

• After the notes, an optional section can identify which description was last selected in each section
• Additional tabs or carriage returns are not allowed within each field
• There can be no blank lines before the end of the file

The database and note IDs are in the format of “ID_#”, where “#” represents any numeric value with not more than 14 
digits and no decimal point. Notes Manager does not change these IDs after creation, but when new notes are added, it 
uses IDs similar to those shown in the following example.

3

00 - Section 1 Description 1 This is keynote 1.

00 - Section 1 Description 2 This is keynote 2.

00 - Section 1 Description 3 This is keynote 3.

Notes Manager11DataFile

ID_04030110200020 General Project Notes Scope of Work Project located at 
‘ADDRESS’,’CITY’,’STATE’, county of 
‘COUNTY’.

ID_04030110200021 General Project Notes Accessibility 
Compliance

Project complies with accessibility 
standards.



Adding User-defined Information to Commands |  1883
Adding User-defined Information to Commands
Certain commands permit adding to the list of available values for certain parameters (for example, the Material list 
for the Spring Calculator or the Units list for the Simple Beam command).

~~~~~~~~~~~~~~~~~~~~~~~~~
Adding User-defined Spring Calculator Materials
Adding User-defined Simple Beam Units

ID_04030110200022 General Project Notes Involved Parties “Owner” refers to ‘OWNER ID’ or its 
authorized representatives.

0 End of Notes

General Project Notes Scope of Work

Parameters Allowing Addition of User-defined Values in the GetUserData.vss File 

Group Plug-in Object Parameter Dialog Box

1 Spring 
Calculator

Units (inches, mm and cm only) Spring Calculator

Shaft Analysis Outside Diameter Shaft Analysis
Simple Beam Beam Length Simple Beam: Set Beam 

Properties
Simple Beam Deflection Units Simple Beam: Set Beam 

Properties
2 Simple Beam These items are the singular form of the names in 

Group 1 and are used when writing the values to 
a worksheet and a text block on the drawing

Not applicable

3 Simple Beam Load Units Simple Beam: Add/Remove/
Change Loads

4 Simple Beam These items are the singular form of the names in 
Group 3 and are used when writing the values to 
a worksheet and a text block on the drawing

Not applicable

5 Simple Beam Section Modulus Units Simple Beam: Set Beam 
Properties

6 Simple Beam Moment of Inertia Units Simple Beam: Set Beam 
Properties

7 Shaft Analysis Shear Modulus Units Shaft Analysis
Simple Beam Modulus of Elasticity Units Simple Beam: Set Beam 

Properties
8 Spring 

Calculator
Material Spring Calculator

9 Shaft Analysis Twisting Moment Units Shaft Analysis
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Adding User-defined Spring Calculator Materials
The following example shows how to add to the list of materials available to the Spring Calculator.
To add to the list of Spring Calculator materials:

1. Make a backup copy of the GetUserData.vss file, located in Plug-Ins\VW_Mech\Includes. Keep the backup copy 
in case there is a need to restore the GetUserData.vss file to its original state.

2. Open the GetUserData.vss file in any word processor and locate group 8 in the getUserString function. 
3. Using the next available sequential number, add the new Material to the end of the list (in this example, 

Beryllium Copper). Enclose the name in single quotes and put a semi-colon at the end of the line. The new line 
should read: 
16: getUserString := ‘Beryllium Copper’;

4. Locate group 8 in the getUserData function. 
5. Using the next available sequential number, add the new Mod. of Elasticity value (in this example, pounds per 

square inch). The sequential number added here must correspond to the number added in the getUserString 
function. Put a semi-colon at the end of the line; do not use single quotes or commas in the value. The new line 
should read: 
16: getUserData := 7000000;

6. Change the value of item 0 to the new group number, which indicates the number of available values (in this 
example, 16).

7. Save the file. The next time the Spring Calculator is run, the new item is available in the Material list, and when 
selected, the new value is available in the Mod. of Elasticity field. When executed, the Spring Calculator 
automatically recalculates the value to the user-specified units. (For beryllium copper, the value is 7,000,000 lb/
in2.)
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If the Spring Calculator was used during the current session, the Vectorworks program needs to be restarted for the 
changes to take place.

Adding User-defined Simple Beam Units
The following example shows how to add to the list of available units for the Simple Beam command.
To add to the list of units for the Simple Beam command:

1. Make a backup copy of the GetUserData.vss file located in Plug-Ins\VW_Mech\Includes. Keep the backup copy 
in case there is a need to restore the GetUserData.vss file to its original state.

2. Open the GetUserData.vss file in any word processor and locate group 1 in the getUserString function. 
3. Using the next available sequential number, add the new Units to the end of the list (in this example, Yards). 

Enclose the name in single quotes and put a semi-colon at the end of the line. The new line should read: 
6: getUserString := ‘Yards’;

4. Locate group 2 in the getUserString function. 
5. Using the next available sequential number, add the new Units to the end of the list. (In this example, type yard in 

the singular form; this value is used in certain output for the Simple Beam command and must have an entry 
corresponding to the same item in group 1). 
Enclose the name in single quotes and put a semi-colon at the end of the line. The new line should read: 
6: getUserString := ‘Yard’;

6. Locate group 1 in the getUserData function. 
7. Using the next available sequential number, add the new Units to the end of the list (in this example, units per inch 

of a yard: 1/36). The sequential number added here must correspond to the number added in the getUserString 
function. Put a semi-colon at the end of the line; do not enclose the name in single quotes. The new line should 
read: 
6: getUserData := 1/36;

8. Change the value of item 0 to the new group number, which indicates the number of available values (in this 
example, 6).
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9. Save the file. The next time the Simple Beam command is used, the new item is available in the Beam Properties 
dialog box.
This change also affects the Shaft properties of the Shaft Analysis command. These values are also used by the 
Spring Calculator Units, but only items 1, 3, and 4 are applicable, so the new units (Yards) will not show up in this 
field.

Simple Beam and Spring Calculator Examples
This section provides examples of using the Spring Calculator and Simple Beam commands to accomplish specific 
tasks.
~~~~~~~~~~~~~~~~~~~~~~~~~
Spring Calculator
Simple Beam

Spring Calculator
The spring calculator can determine spring rates and unit stresses of round wire helical coil compression springs with 
known parameters. It can also be used to design a spring knowing the working values. This example is based on the 
following compression spring with closed and ground ends of music wire.

To calculate spring rate and unit stress:
1. Determine the required spring rate based on the deflection at a load divided by the difference in the working length 

and the free length. For this example, the desired spring rate equals 28.8 lb/in (36 lb/1.25 in = 28.8 lb/in).
2. Select the Spring Calculator command from the appropriate menu:

1.063” Max. Solid Height

1.25” Deflection at a load = 36 pounds

Outside Diameter = .812”

Free Length = 2.5”
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• Architect workspace: AEC > Machine Design > Spring Calculator 
• Landmark workspace: Landmark > Machine Design > Spring Calculator 
• Spotlight workspace: Spotlight > Machine Design > Spring Calculator 
The Spring Calculator dialog box opens.

3. As shown in the above dialog box, select 1 - Outside Dia., Wire Dia., Solid Height from the Method list. After 
entering the known values, calculate a spring rate close to the desired value by trying several standard wire 
diameter values. Adjust the material in the Material list to fit the wire diameter used. Here, a wire diameter 
of .090” gives a spring rate of 8.94 lb/in.

4. In the Method list, select 2 - Mean Dia., Wire Dia., No. of Active Coils.
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5. As shown in this dialog box, vary the wire diameter and number of active coils to get a spring rate close to the 
required spring rate. A wire diameter of .095” and 11 active coils gives a spring rate of 16.3 lb/in, but the solid 
height is 1.24”, which is too high. A wire diameter of .090” and 9 active coils, however, gives a spring rate of 16.1 
lb/in, and a solid height of .990”, which is within acceptable limits.

6. Finally, check the stresses applied to the spring to verify that they are within acceptable limits. With a unit stress of 
3074 (lb/sq in)/lb, multiply by 36 to obtain 110,663 lb/sq in. With a solid height of .990”, the stress will be:
(2.500-0.900)in x 16.1 lb/in x 3074 (lb/sq in)/lb = 79,200 lb/sq in

7. This value is below the safe working stress of 111,000 lb/sq in for this material and wire size.

Simple Beam
This example shows how the Simple Beam commands can be used to find the stresses on the horizontal elements of a 
certain machine part.

To calculate the stresses:
1. Select File > New.

4” x 4” x .5” Steel Tubing

Data:
Length = 48”
Distance between supports = 36”
Distributed load = 600lb/in
Concentrated load = 2000lb
Tubing = 4” x 4” x 1/2” Steel
Section Modulus = 6.12in^3
Moment of Inertia = 12.26in^4
Modulus of Elasticity = 29E+6lbsq in
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The Create Document dialog box opens.
2. Select Use document template, and choose the Simple Beam (Imperial) or Simple Beam (Metric).sta template.
3. Click OK.
4. Select the Simple Beam command from the appropriate menu:

• Architect workspace: AEC > Machine Design > Simple Beam 
• Landmark workspace: Landmark > Machine Design > Simple Beam 
• Spotlight workspace: Spotlight > Machine Design > Simple Beam 
The Simple Beam dialog box opens.

5. Click Configure Beam.
The Configure Beam dialog box opens.

6. Specify the beam properties. In this example, enter the following values:

To obtain the section modulus and moment of inertia of the tubing, select a tubing shape from the Resource 
Browser and place an instance of it on the drawing. Convert the tubing to a group and then use the Engineering 
Properties command to obtain the properties. For more information on the Engineering Properties command, 
see “Obtaining Engineering Properties” on page 1821.

7. Click OK to close the Beam Properties dialog box.
8. Click Define Loads on the Simple Beam dialog box.

The Define Loads dialog box opens.
9. Specify the load properties. In this example, use the following values:

Configuration: Fixed - Pivot
Length: 48
Units: Inches
Distance Between Supports: 36
Section Modulus: 6.12 in^3
Moment of Inertia: 12.26 in^4
Modulus of Elasticity: 29E+6 lb/sq in
Calculation Interval: 0.5
Deflection Units: Inches
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10. Click OK close the Define Loads dialog box.
11. In the Simple Beam dialog box, click Calculate Reactions, and then click Calculate Stresses and Deflection, 

and then click OK.
A simple beam diagram is created based on the information provided. See “Simple Beam” on page 1888 for more 
information on what is depicted in the diagram.

Layer, Class, and Viewport Standards
The standards for the Vectorworks Architect and Landmark products are centered around the concept of viewports on 
sheet layers. A project file contains a number of viewports; each viewport consists of a particular combination of 
visible layers and classes.
This section provides information about the viewport, layer, and class standards in Vectorworks Architect and 
Landmark products. Modifying these standards is not recommended, as it requires a large effort to manage and 
coordinate standards information.

Load Units: Pounds
Load #1
Type: Uniformly Distributed
Distance from Left End: 0
Load Value 1: 600
Width: 36
Load #2
Type: Concentrated Load
Distance from the Left End: 48
Load Value 1: 2000
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~~~~~~~~~~~~~~~~~~~~~~~~~
Using the Layermap Worksheet
The Layermap Worksheet
Viewport/View Types
Standard Layer Visibility in Viewports/Views
Design Layer Types in the Standards
Class Visibility in the Standards

Using the Layermap Worksheet
The creation of layers, classes, and viewports or views by the setup commands (Create Standard Viewports in 
Vectorworks Architect and Standard Naming in Vectorworks Architect and Landmark) is controlled through the use 
of the worksheet LayerMap.G, in the VA Setup Data-Imperial.vwx or VA Setup Data-Metric.vwx file 
([Vectorworks]\Plug-Ins\Common\Data). This worksheet contains the predefined class, layer, attribute, and visibility 
information needed to generate a completely ready-to-use project file at any scale or level of complexity.
The LayerMap.G worksheet applies to viewports on sheet layers created with the Create Standard Viewports 
command, or views created with the Create Corresponding View for Each Viewport option in the Create Standard 
Viewports dialog box.
The settings in the LayerMap.G worksheet are automatically applied when a new file is opened and one of the Setup 
commands is selected. If the LayerMap.G worksheet contained in the VA Setup Data-Imperial.vwx or VA Setup 
Data-Metric.vwx file is edited, all sheets created on that machine will use the new standards. However, a copy of the 
LayerMap.G worksheet can be included in a file (by importing it) and edited there. These custom settings will 
supersede any automated settings for that file only. This is a convenient way of sharing standards between offices and 
users, without modifying the default standards on an individual machine.
If a Vectorworks file contains a LayerMap.G worksheet, when the Create Standard Viewports command is selected, 
the Import LayerMap.G dialog box opens. Specify which worksheet to use.
Click to show/hide the parameters.

~~~~~~~~~~~~~~~~~~~~~~~~~
The Layermap Worksheet

The Layermap Worksheet
The Layermap worksheet, located in the VA Setup Data-Imperial.vwx or VA Setup Data-Metric.vwx file, begins 
with a listing of project types in the first six rows (before the LayerMap.G row). These project types are used by the 
legacy command Create Standard Views, and are not used by the Create Standard Viewports command. As such, 
they are no longer supported.

Parameter Description

Use the existing LayerMap.G Uses the LayerMap.G worksheet present in the file rather than the standard 
worksheet

Import and use the standard 
LayerMap.G

Imports and applies the standard LayerMap.G worksheet (from the VA 
Setup Data.vwx file) rather than using the settings from the existing 
imported worksheet

Delete the LayerMap.G worksheet 
when finished

Deletes the LayerMap.G worksheet from the file; this is recommended when 
using the standard worksheet 



  1892 | Layer, Class, and Viewport Standards
Following the legacy project types are the names of the viewports or views used by the Create Standard Viewports 
command. Below the name is the viewport/view type, which controls under which drawing type the viewport/view 
appears in the Create Standard Viewports dialog box.
After the project types section is the layers section. This section of the Layermap worksheet controls the initialization 
and setup of layers in a specific viewport/view. Based on the information in this section, the Create Standard 
Viewports command generates a complete array of layers with the proper settings to correctly display a viewport or 
view.

The final section in the Layermap worksheet is the classes section. This section controls class setup and initialization 
for each viewport/view. As with the layer section, the Setup commands use the information to generate a full class 
setup configuration for each viewport/view in a project file.

~~~~~~~~~~~~~~~~~~~~~~~~~
Using the Layermap Worksheet
Viewport/View Types
Standard Layer Visibility in Viewports/Views
Design Layer Types in the Standards
Class Visibility in the Standards

Viewport/View Types
Viewport/view types are found directly under the viewport/view names in the Layermap worksheet. The identifier 
directly beneath the viewport/view name indicates its drawing type. Viewport/view types control how the viewport/
view is generated, and are used by the Create Standard Viewports command to properly configure the project 
document. The viewport/view type identifier may take on one of the following values:

Layers
section

Layer visibility 
settings

Viewport/view names (the full name 
can be viewed in the formula bar)

Class visibility settings Class attribute settings
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Standard Layer Visibility in Viewports/Views
In the layers section of Layermap worksheet, layer names are listed down the left side of the worksheet in the first 
column. This listing represents the available layers that can be included in a viewport/view. Layer names that are used 
when generating multiple layers (for example, for the floor viewports/views of a multi-floor building) are indicated by 
a pound sign (#) suffix.
The visibility status of a specific layer is indicated by an alphabetic identifier located in the worksheet cell which 
cross-references the layer and the viewport/view in which it will be a component. The identifier can take on one of the 
following values:

 

Identifier Drawing Type

1 Project plan view/viewport (one viewport/view only)
L Auxiliary viewport/view (create a user-specified number of viewports/views)
M Floor plan viewport/view (create one viewport/view for each floor in the project)
N Notation viewport/view (create a user-specified number of viewports/views)
S Site plan viewport/view (create one viewport/view)

Identifier Meaning

A Active layer
V Visible
G Grayed
I Invisible
<no value> Not created for viewport/view; set to invisible if existing

The cover sheet is a notation 
viewport/view

The Mod-Site-Arch layer is the active layer in 
the Site Plan (General) viewport/view
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Design Layer Types in the Standards
The Layermap worksheet contains a specialized set of identifiers which control how model design layers are 
configured for a project file. These identifiers, which are located on the extreme right of the Layermap worksheet 
opposite the model layers, are used by the Setup commands to correctly configure a set of model layers for the project 
file.
Model layer type identifiers can take on one of the following values:

 

Class Visibility in the Standards
In the class section of the Layermap worksheet, class names available for inclusion in the viewports/views are listed 
down the left side of the worksheet in the first column. The visibility of a specific class is indicated by an alphabetic 
identifier, which is located in the worksheet cell which cross-references the layer and the viewport/view. 
The identifier can take on one of the following values:

An explanation of the specific uses of and applications for classes, including AIA layer name equivalents, is provided 
in PDF format (VA Sheet-Layer-Class stds.pdf) included with the Vectorworks Architect product and available in 
[Vectorworks]\Extras.
Default class attributes, such as line style and pen color, are no longer controlled from the Layermap worksheet.

 Identifier  Meaning

C Layer w/ ceiling referenced information (one per floor)
F Foundation layer (one per project)
R Roof layer (one per project)
S Slab layer (one per floor)
W Layer w/ floor referenced information (one per floor)
<no value> Supplemental model layer

Identifier Meaning

V Visible
G Grayed
I Invisible
<no value> Not created for viewport/view; set to invisible if existing

The Mod-Floor-# layers will be 
referenced to finish floor level
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Auto-classing Objects
Certain plug-in objects and symbols have specific default classes, which coordinate with the Layermap worksheet class 
name standards. The plug-in objects listed here are automatically classed when they are inserted into a file that is set up 
to use auto-classing (when Enable Auto-classing is selected in the Standard Naming dialog box). If auto-classing is 
not enabled, these objects are set to a default class when they are inserted into a file.

Object Default Class Vectorworks Product

Base Cabinet Millwork-Main Architect
Bath-Shower Plumbing-Fixtures Architect
Collar Structural-Framing Architect
Column Structural-Columns Architect, Landmark
Comm Device DataComm-Devices Architect
Compartment Sink Plumbing-Fixtures Architect
Counter Top Millwork-Main Architect
Desk Furniture-Main Architect
Door Door-Main Architect, Landmark
Drilled Footing Structural-Footings Architect
Drip Emitter Irrigation-SprayPat Landmark
Escalator Vert Trans-Main Architect
Fireplace Fixtures-Main Architect
Grab Bars Fixtures-Main Architect
Grade Site_Util_Storm Landmark
Guardrail (Curved) Site-Improvements Architect, Landmark
Guardrail (Straight) Site-Improvements Architect, Landmark
Handrail (Curved) Fixtures-Main Architect, Landmark
Handrail (Straight) Fixtures-Main Architect, Landmark
Hardscape (tag) Site-Hardscape Comp-Spec Landmark
Hardscape (border) Site-Hardscape Comp-Border Joint Landmark
Hardscape (main area) Site-Hardscape Comp-Main Joint Landmark
Hip and valley rafters Structural-Framing Architect
HVAC Damper HVAC-Duct/Equipment Architect
HVAC Diffuser HVAC-Diffusers Architect
HVAC Elbow Duct HVAC-Duct/Equipment Architect
HVAC Flex Duct HVAC-Duct/Equipment Architect
HVAC Outlet HVAC-Duct/Equipment Architect
HVAC Splitter HVAC-Duct/Equipment Architect
HVAC Straight Duct HVAC-Duct/Equipment Architect
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HVAC Transition HVAC-Duct/Equipment Architect
HVAC Vertical Duct HVAC-Duct/Equipment Architect
HVAC Vertical Elbow HVAC-Duct/Equipment Architect
Irrigation Head Irrigation-SprayPat Landmark
Joist Structural-Framing Architect
Mullion Wall-Ext-Glazed Architect
North Arrow Notes-Sheet Architect, Landmark
Parking Spaces Site-Paving-Marking Architect, Landmark
Pilaster Structural-Columns Architect
Plate Structural-Framing Architect
Purlin Structural-Framing Architect
Rafter Structural-Framing Architect
Ramp Vert Trans-Main Architect, Landmark
Receptacle Electrical-Devices Architect
Reference Marker Notes-Sheet Architect, Landmark
Revision Marker Notes-Sheet Architect, Landmark
Ridge Structural-Framing Architect
Roadway (Poly) • Site-Paving-Surface

• Site-Paving-Curb
• Site-Paving-Stations

Architect, Landmark

Roadway (Curved), Roadway (Custom 
Curb), Roadway (NURBS), Roadway 
(Straight), Roadway (Tee)

• Site-Paving-Surface
• Site-Paving-Curb

Architect, Landmark

Shelving Unit Furniture-Main Architect
Simple Elevator Vert Trans-Main Architect
Site Modifiers with Grade Limits 
configuration

Site-DTM-Modifier Architect, Landmark

Site Modifiers with Pad configuration Site-DTM-Modifier Landmark
Site Modifiers with Texture Bed 
configuration

Site-DTM-Modifier Landmark

Space (2D) - boundary Space-Main Architect
Space (2D) - label Space-Spec Architect
Space (2D) - leader line Space-Spec Architect
Space (3D) - attributes Space-Patterns Architect
Stair Vert Trans-Main Architect, Landmark
Switch Electrical-Devices Architect
Table and Chairs Furniture-Main Architect, Landmark

Object Default Class Vectorworks Product
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Machine Design Class Standards
The Machine Design_Classes.sta file, located in the Standards folder, contains a number of pre-defined class standards. 
To use the pre-defined classes in a drawing:

1. Select Tools > Organization.
The Organization dialog box opens. Click the Classes tab.

2. Click New.
The New Class dialog box displays.

3. Click Import Classes and choose Machine Design_Classes.sta from the list.
4. Select the desired classes and click OK.
5. Click OK in the Organization dialog box to return to the drawing.

Click the classes list on the Data bar to list the classes that are available for use in the drawing.

Project Preference Sets
The following table lists the files contained in a preference set folder, and the menu commands/tools/objects which use 
those preference files. A description of the information stored in each preference file is also provided.

Toilet Stall Fixtures-Main Architect
Trimmer Structural-Framing Architect
Utility Cabinet Millwork-Main Architect
VBvisual Plant Landscape-Plants Renderworks
Wall Cabinet Millwork-Main Architect
Window Window-Main Architect, Landmark
Workstation Counter Furniture-Main Architect
Workstation Overhead Furniture-Main Architect
Workstation Panel Furniture-Main Architect
Workstation Pedestal Furniture-Main Architect

Preference File Used By Information Stored

Door Hardware Library.txt Door tool, Door Hardware Library Door hardware set name and 
record values

Equipment Record.txt VA Create Record Format and default values of 
record

Equipment Schedule.txt VA Create Schedule, VA Records and 
Schedules

Format of schedule

Plumbing Fixt Record.txt VA Create Schedule Format and default values of 
record

Object Default Class Vectorworks Product
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Taken together, these files constitute a preference set; they must all be present in the folder of the “current preference 
set.”
The Vectorworks Architect product ships with six predefined preference sets.

Making no changes to the preferences in the Defaults folder is strongly recommended. System administrators 
should make this folder “read-only” (Windows) or “locked” (Mac) to prevent users from making changes. The 
remaining preference set folders (01 – 05) can be customized.

Unused folders can be removed, leaving only the one that will be used; new folders can be created. To create a new 
folder, simply copy one of the existing folders to a new location. Select Tools > Options > VA Set Project Prefs to 
specify the location of the new folder. The folder location is not restricted. In a workgroup environment, locating the 
folder on the network makes the same project preference set available to everyone.
~~~~~~~~~~~~~~~~~~~~~~~~~
Working with Project Preference Sets

Reserved Names
There are a number of words that are reserved for specific use within the Vectorworks Landmark product. These words 
should not be used to name objects or symbols.

Plumbing Schedule.txt VA Create Schedule, VA Records and 
Schedules

Format of schedule

Room Finish Library.txt Space tool, Room Finish Library Room finish names and 
descriptions

VA2 Records and Schedules.txt VA Records and Schedules Format of records and schedules, 
and default values of records

VA_Project_Set.txt Utility file for VA to ensure that the 
folder has not been moved 

Name Location

VA Defaults [Vectorworks]\Plug-Ins\VW_Arch\Data\Prefs_Def
Prefs_01 [Vectorworks]\Plug-Ins\VW_Arch\Data\Prefs_01
Prefs_02 [Vectorworks]\Plug-Ins\VW_Arch\Data\Prefs_02
Prefs_03 [Vectorworks]\Plug-Ins\VW_Arch\Data\Prefs_03
Prefs_04 [Vectorworks]\Plug-Ins\VW_Arch\Data\Prefs_04
Prefs_05 [Vectorworks]\Plug-Ins\VW_Arch\Data\Prefs_05

• 2D Contours to 3D Polys • BADSHEET678 • Cut N Fill DTM

• DTM Mod Record • Data • Drawing Border

• Elev Analysis • Fit To Objects • Guides

• ID Label • Irrigation Head • Landscape-Plant

• LineLength • Mod-Guidelines • Mod-Site-Civil

• None • Plant • Plant Record

Preference File Used By Information Stored
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• Polyline ID • Project Plant List • Project Symlst

• Raise/Lower Record • Roadway (Curved) • Roadway (Straight)

• Saved Sheets • Setup Record • Sheet Border

• Sheet-Common • Site-DTM-Modifier • Site-Improvement-Spec

• Slope Analysis • Stake # • Stake Object

• Stake Record • Station Worksheet • Survey Data

• Symbol List • Symbol List Sym • Symbol to Group

• VW_Land-Invisible • Vegetation line • ZVI Analysis
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Vectorworks 2015 Keyboard Shortcuts

The Vectorworks program has keyboard and mouse shortcuts for many common tasks. Many (but not all) shortcuts can be 
customized; the headings below indicate whether the shortcuts can be modified, and where. Note that these tables list the default 
shortcuts for all workspaces; your workspace may not have all of the tool sets, tools, menus, and commands listed.

For your convenience, the shortcuts are available as a PDF file for printing from the help system Table of Contents.
~~~~~~~~~~~~~~~~~~~~~~~~~
Tool Shortcuts (Modify in Workspace Editor)
Command Shortcuts (Modify in Workspace Editor)
Other Shortcuts (Modify in Workspace Editor)
Arrow Key Shortcuts (Modify in Vectorworks 
Preferences, Edit Tab)

Worksheet Key Functions (Cannot be Modified)
Miscellaneous Key Shortcuts (Cannot be Modified)
Numeric Key Pad (Cannot be Modified)
Mouse Shortcuts (Cannot be Modified)
Shortcuts Reserved by Operating System

Tool Shortcuts (Modify in Workspace Editor)

Basic Palette
Tool Windows Mac

Selection X X

Pan H H

Move Page Alt+Z Option+Z

Flyover Shift+C Shift+C

Zoom C C

Text 1 1

Callout Alt+1 Option+1

2D Locus 0 (zero) 0 (zero)

Symbol Insertion Alt+0 (zero) Option+0 (zero)

Line 2 2

Double Line Alt+2 Option+2

Rectangle 4 4

Rounded Rectangle Alt+4 Option+4

Circle 6 6

Oval Alt+6 Option+6

Arc 3 3

Quarter Arc Alt+3 Option+3

Freehand Alt+5 Option+5

Polyline 5 5

2D Polygon 8 8

Triangle Shift+T Shift+T

Double-line Polygon Alt+8 Option+8

Regular Polygon Alt+Shift+R Option+Shift+R

Spiral Alt+Shift+S Option+Shift+S

Eyedropper Shift+E Shift+E

Visibility V V

Attribute Mapping Shift+A Option+A

Reshape - (hyphen) - (hyphen)

Rotate Alt+= Option+=

Mirror = =

Split L L

Connect/Combine ; (semi-colon) Option+L

Trim Alt+Shift+L Option+Shift+L

Fillet 7 7

Chamfer Alt+7 Option+7

Offset Shift+- (hyphen) Shift+- (hyphen)

Clip Shift+N Option+C

Move by Points Shift+M Shift+M

Building Shell Tool Set
Tool Windows Mac

Wall 9 9

Round Wall Alt+9 Option+9

Wall Join Alt+J Option+J

Component Wall Join Alt+Shift+J Option+Shift+J

Door Alt+Shift+D Option+Shift+D

Window Shift+D Option+Shift+W

3D Modeling Tool Set
Tool Windows Mac

Flyover Shift+C Shift+C

Set Working Plane Shift+1 Shift+1

Align Plane Alt+Shift+1 Option+Shift+1

Push/Pull Shift+R Shift+R

3D Locus Shift+0 (zero) Shift+0 (zero)

NURBS Curve Shift+7 Shift+7

Sphere Shift+3 Shift+3

Hemisphere Alt+Shift+3 Option+Shift+3

Fillet Edge Shift+F Shift+F

Chamfer Edge Shift+J Shift+J

Shell Solid Shift+G Shift+G

Loft Surface Shift+K Shift+K

Extract Shift+L Shift+L

Create Contours Shift+H Shift+H

Project Shift+; (semi-colon) Shift+; (semi-colon)

Analysis Shift+’ (apostrophe) Shift+A

Visualization Tool Set
Tool Windows Mac

Flyover Shift+C Shift+C

Walkthrough Shift+U Shift+U

Translate View Shift+V Shift+V

Rotate View Shift+W Shift+W

Light Shift+Z Shift+Z

Attribute Mapping Shift+A Option+A

Basic Palette



Command Shortcuts (Modify in Workspace Editor)

Dims/Notes Tool Set
Tool Windows Mac

Constrained Linear 
Dimension

N N

Unconstrained Linear 
Dimension

M M

Angular Dimension . (period) . (period)

Radial Dimension , (comma) , (comma)

Walls Tool Set
Tool Windows Mac

Wall 9 9

Round Wall Alt+9 Option+9

Wall Join Alt+J Option+J

File Menu
Command Windows Mac

New Ctrl+N Cmd+N

Open Ctrl+O Cmd+O

Close Ctrl+W Cmd+W

Save Ctrl+S Cmd+S

Page Setup Ctrl+Alt+P Cmd+Option+P

Print Ctrl+P Cmd+P

Exit Alt+F4 or Ctrl+Q Cmd+Q

Edit Menu
Command Windows Mac

Undo Ctrl+Z Cmd+Z

Redo Ctrl+Y Cmd+Y

Cut Ctrl+X Cmd+X

Copy Ctrl+C Cmd+C

Paste Ctrl+V Cmd+V

Paste in Place Ctrl+Alt+V Cmd+Option+V

Duplicate Ctrl+D Cmd+D

Duplicate Array Ctrl+Shift+Alt+D Cmd+Shift+Option+D

Select All Ctrl+A Cmd+A

View Menu
Command Windows Mac

Zoom–Normal Scale Ctrl+3 Cmd+3

Zoom–Fit to Page Area Ctrl+4 Cmd+4

Zoom–Fit to Objects Ctrl+6 Cmd+6

Class Options–
Active Only

Ctrl+Shift+Alt+3 Cmd+Shift+Option+3

Class Options–
Gray Others

Ctrl+Shift+Alt+4 Cmd+Shift+Option+4

Class Options–
Gray/Snap Others

Ctrl+Shift+Alt+5 Cmd+Shift+Option+5

Class Options–
Show Others

Ctrl+Shift+Alt+6 Cmd+Shift+Option+6

Class Options–
Show/Snap Others

Ctrl+Shift+Alt+7 Cmd+Shift+Option+7

Class Options–
Show/Snap/Modify Others

Ctrl+Shift+Alt+8 Cmd+Shift+Option+8

Layer Options–
Active Only

Ctrl+Alt+3 Cmd+Option+3

Layer Options–
Gray Others

Ctrl+Alt+4 Cmd+Option+4

Layer Options–
Gray/Snap Others

Ctrl+Alt+5 Cmd+Option+5

Layer Options–
Show Others

Ctrl+Alt+6 Cmd+Option+6

Layer Options–
Show/Snap Others

Ctrl+Alt+7 Cmd+Option+7

Layer Options–
Show/Snap/Modify Others

Ctrl+Alt+8 Cmd+Option+9

Standard views: Top/Plan Ctrl+5 Cmd+5

Rendering–Wireframe Ctrl+Shift+W Cmd+Shift+W

Rendering–Sketch Ctrl+Shift+S Cmd+Shift+S

Rendering–
Sketch Options

Ctrl+Shift+Alt+S Cmd+Shift+Option+S

Rendering–
OpenGL

Ctrl+Shift+G Cmd+Shift+G

Rendering–
Final Quality Renderworks

Ctrl+Shift+F Cmd+Shift+F

Rendering–
Hidden Line

Ctrl+Shift+E Cmd+Shift+E

Rendering–
Dashed Hidden Line

Ctrl+Shift+D Cmd+Shift+D

Rendering–
Final Shaded Polygon

Ctrl+Shift+P Cmd+Shift+P

Set 3D View Ctrl+0 (zero) Cmd+0 (zero)

Unified View Ctrl+Alt+L Cmd+Option+L

Create Multiple Viewports Ctrl+Shift+M Cmd+Shift+M

Next View Ctrl+Shift+. (period) Cmd+Shift+. (period)

Previous View Ctrl+Shift+, (comma) Cmd+Shift+, (comma)

Modify Menu
Command Windows Mac

Move Ctrl+M Cmd+M

Move 3D Ctrl+Alt+M Cmd+Option+M

Send to Front Ctrl+F Cmd+F

Send Forward Ctrl+Alt+F Cmd+Option+F

Send to Back Ctrl+B Cmd+B

Send Backward Ctrl+Alt+B Cmd+Option+B

Align to Grid Ctrl+- (hyphen) Cmd+- (hyphen)

Align/Distribute Ctrl+= Cmd+=

Align/Distribute 3D Ctrl+Shift+= Cmd+Shift+=

Rotate Left 90 Ctrl+L Cmd+L

Rotate Right 90 Ctrl+Shift+R Cmd+Shift+R

Flip Horizontal Ctrl+Shift+H Cmd+Shift+H

Flip Vertical Ctrl+Shift+V Cmd+Shift+V

Set Working Plane Ctrl+ \ Cmd+ \

Trim Ctrl+T Cmd+T

Join Ctrl+J Cmd+J

View Menu



Other Shortcuts (Modify in Workspace Editor)

Join and Fillet Ctrl+Alt+J Cmd+Option+J

Join (no Trim) Ctrl+Shift+J Cmd+Shift+J

Add Surface Ctrl+Shift+Alt+A Cmd+Shift+Option+A

Clip Surface Ctrl+Shift+Alt+C Cmd+Shift+Option+C

Intersect Surface Ctrl+Shift+Alt+I Cmd+Shift+Option+I

Compose Ctrl+Shift+Alt+P Cmd+Shift+Option+P

Convert to Group Ctrl+K Cmd+K

Convert to Mesh Ctrl+Alt+R Cmd+Option+R

Convert to 3D Polys Ctrl+Alt+O Cmd+Option+O

Convert to NURBS Ctrl+Alt+N Cmd+Option+N

Group Ctrl+G Cmd+G

Ungroup Ctrl+U Cmd+U

Edit <editing mode> Ctrl+[ Cmd+[

Exit <editing mode> Ctrl+] Cmd+]

Show Guides Ctrl+Alt+G Cmd+Option+G

Hide Guides Ctrl+Shift+Alt+G Cmd+Shift+Option+G

Unrotate 3D Objects Ctrl+Shift+0 (zero) Cmd+Shift+0 (zero)

Model Menu
Command Windows Mac

Add Solids Ctrl+Alt+A Cmd+Option+A

Subtract Solids Ctrl+Alt+S Cmd+Option+S

Intersect Solids Ctrl+Alt+I 
(uppercase i)

Cmd+Option+I 
(uppercase i)

Section Solids Ctrl+Alt+T Cmd+Option+T

Extrude Ctrl+E Cmd+E

Multiple Extrude Ctrl+Alt+E Cmd+Option+E

Extrude Along Path Ctrl+Alt+X Cmd+Option+X

Tapered Extrude Ctrl+Alt+U Cmd+Option+U

Sweep Ctrl+Alt+W Cmd+Option+W

Create Fillet Surface Ctrl+Alt+Y Cmd+Option+Y

Create Planar Caps Ctrl+Alt+Q Cmd+Option+Q

Create Surface from Curves Ctrl+Alt+K Cmd+Option+K

Spotlight Menu
Command Windows Mac

Number Instruments Ctrl+Shift+Alt+N Cmd+Shift+Option+N

Auto Number Positions Ctrl+Shift+Alt+O Cmd+Shift+Option+O

Focus Instruments Ctrl+Shift+Alt+F Cmd+Shift+Option+F

Replace Instrument Ctrl+Shift+Alt+R Cmd+Shift+Option+R

Find and Modify Ctrl+Shift+Alt+M Cmd+Shift+Option+M

Refresh Instruments Ctrl+/ Cmd+/

Label Legend Manager Ctrl+Shift+Alt+L Cmd+Shift+Option+L

Tools Menu
Command Windows Mac

Organization Ctrl+Shift+O Cmd+Shift+O

User Origin Ctrl+9 Cmd+9

SmartCursor Settings Ctrl+8 Cmd+8

Plug-in Manager Ctrl+Shift+Z Cmd+Shift+Z

Workspace Editor Ctrl+Shift+Alt+W Cmd+Shift+Option+W

Text Menu
Command Windows Mac

Format Text Ctrl+Shift+T Cmd+Shift+T

Modify Menu Window Menu
Command Windows Mac

Palettes–Snapping Ctrl+Shift+C Cmd+Shift+C

Palettes–Attributes Ctrl+Shift+A Cmd+Shift+A

Palettes–Object Info Ctrl+I (uppercase i) Cmd+I (uppercase i)

Palettes–Working Planes Ctrl+Shift+K Cmd+Shift+K

Palettes–Resource Browser Ctrl+R Cmd+R

Palettes–Navigation Ctrl+Shift+N Cmd+Shift+N

Palettes–Visualization Ctrl+Shift+Alt+V Cmd+Shift+Option+V

Palettes–
Activate Object Info Palette

Ctrl+‘ (backquote) Cmd+Option+C

Cycle Through Modes on Tool Bar
1st group U

2nd group I (uppercase i)

3rd group O

4th group P

5th group [

6th group ]

Miscellaneous Keys
Close 2D Polygon, Polyline, 
Polygonal Wall Network, or 
Path-based Objects

K

Toggle SmartCursor Cues Y

Toggle Angles Relative to Prior 
Segment

/

Set Datum G

Snap Loupe Z

Set Smart Point, Edge, or Vector 
Snap Lock

T

Toggle Automatic Working Plane \

Suspend Snapping ‘ (backquote)

X-ray Select mode B

Coincident Selection J

Toggle Snapping Palette Settings
Snap to Grid A   (AA = Set Grid dialog box)

Snap to Angle S   (SS = Angle Snaps dialog box)

Smart Points D   (DD = Smart Points dialog box)

Smart Edge (2D only) F   (FF = Edge Snaps dialog box)

Snap to Working Plane (3D only) F

Snap to Object Q   (QQ = 3D Snapping dialog box)

Snap to Intersection W

Snap to Distance E   (EE = Snap Distance dialog box)

Snap to Tangent (2D only) R



Arrow Key Shortcuts 
(Modify in Vectorworks Preferences, Edit Tab)

Worksheet Key Functions (Cannot be Modified)

Numeric Key Pad (Cannot be Modified)

Miscellaneous Key Shortcuts (Cannot be Modified)

Function Windows Mac
Switch active layer or class Ctrl+Arrow (up 

and down for 
layers, left and 
right for classes)

Cmd+Arrow (up 
and down for 
layers, left and 
right for classes)

Pan drawing Arrow Arrow

Nudge objects Shift+Arrow Shift+Arrow

Move objects Shift+Ctrl+Arrow Shift+Cmd+Arrow

Function Windows Mac
Move one cell up, down, 
left, or right

Arrow keys Arrow keys

Move right by one cell Tab Tab

Move left by one cell Shift+Tab Shift+Tab

Move down by one cell Enter Enter

Move up by one cell Shift+Enter Shift+Enter

Switch to a Standard View
Top/Plan or
Rotated Top/Plan

0 (zero)

Left Isometric 1

Front 2

Right Isometric 3

Left 4

Top 5

Right 6

Left Rear Isometric 7

Back 8

Right Rear Isometric 9

Function Windows Mac
Temporarily 
activate 
another tool

Press and hold 
Space bar, while you 
select and use 
another tool

Press and hold 
Space bar, while you 
select and use
another tool

Temporarily 
activate 
Selection tool

Press and hold Alt 
while you select 
objects (Rotate, 
Mirror, Offset, Clip, and 
Move by Points tools)

Press and hold Cmd 
while you select 
objects (Rotate, 
Mirror, Offset, Clip, 
and Move by Points 
tools)

Temporarily 
activate 
Flyover tool

Press and hold 
Ctrl+mouse wheel button

Press and hold 
Ctrl+mouse wheel 
button

Temporarily 
activate 
Zoom tool

Press and hold 
Space bar+Ctrl 
(zoom in) or 
Space bar+Ctrl+Alt (zoom 
out)

Press and hold 
Space bar+Cmd 
(zoom in) or 
Space bar+Cmd+
Option (zoom out)

Hide unselected 
objects during 
movement

Press and hold 
Ctrl (Flyover, 
Walkthrough, 
Translate View, and 
Rotate View tools)

Press and hold 
Cmd (Flyover, 
Walkthrough, 
Translate View, and 
Rotate View tools)

Increase zoom 
by a factor of 2

Ctrl+1 Cmd+1

Decrease zoom 
by a factor of 2

Ctrl+2 Cmd+2

Increase zoom 
by a factor of 4

Ctrl+Alt+1 Cmd+Option+1

Decrease zoom 
by a factor of 4

Ctrl+Alt+2 Cmd+Option+2

Increase zoom 
by a factor of 2

CC CC

Deselect all 
selected objects

XX XX

Cancel the 
current operation

Esc Esc

Exit text editing mode Esc Esc

Exit Group Esc Esc Esc Esc

While drawing 
walls, NURBS, 
etc., undo the last 
clicked point

Backspace Delete

Display additional tooltip 
information

With tooltip displayed, 
press and hold Shift

With tooltip 
displayed, press and 
hold Cmd



Mouse Shortcuts (Cannot be Modified)
*The mouse wheel zooms by default, and scrolls with a modifier key. You can 
swap these functions in the Vectorworks Preferences, Edit tab.

Shortcuts Reserved by Operating SystemFunction Windows Mac
Refresh the 
drawing view

Double-click Pan tool Double-click Pan tool

Set the print page origin 
to the user 
origin

Double-click Move 
Page tool

Double-click Move 
Page tool

Increase zoom 
by a factor of 2

Double-click Zoom 
tool

Double-click Zoom 
tool

Decrease zoom 
by a factor of 2

Alt-double-click 
Zoom tool

Option-double-click 
Zoom tool

Open or edit a 
Resource Browser 
object

Ctrl-double-click 
the resource name 
or thumbnail

Cmd-double-click the 
resource name or 
thumbnail

Activate a class, design 
layer, or 
sheet layer

Double-click the 
item name in the 
Navigation palette

Double-click the 
item name in the 
Navigation palette

Switch to a saved 
view

Double-click the 
view name in the 
Navigation palette

Double-click the 
view name in the 
Navigation palette

Change visibility 
for all classes or 
layers

Alt-click a Visibility column 
in the 
Navigation palette

Option-click a 
Visibility column in 
the Navigation 
palette

Edit a saved view Alt-double-click the 
view name in the 
Saved Views palette

Option-double-click 
the view name in the 
Saved Views palette

Activate Selection 
tool

Double-click anywhere in 
the drawing (works for 
many, but not all tools)

Double-click 
anywhere in the 
drawing (works for 
many, but not all 
tools)

Duplicate an object With Selection tool 
selected, Ctrl-click and 
drag an object

With Selection tool 
selected, 
Option-click and drag 
an object

Create a similar object 
(activate 
tool and attributes)

Ctrl+Alt-click an 
existing object

Cmd+Option-click an 
existing object

Switch to Next or 
Previous view in history

On Windows, with a 
5-button mouse, click 
button 4 or 5 (same 
as Back or Forward 
for web browsers)

not applicable

Pan the drawing 
view

With a wheel mouse, press 
and hold the 
wheel button

With a wheel mouse, 
press and hold the 
wheel button

Zoom in and out* With a wheel mouse, 
roll forward to zoom 
in and backward to 
zoom out

With a wheel mouse, 
roll forward to zoom 
in and backward to 
zoom out

Scroll* With a wheel mouse, 
Ctrl-roll (up and 
down); Shift-roll (left 
and right)

With a wheel mouse, 
Option-roll (up and 
down); Shift-roll (left 
and right)

Mac Windows
Cmd+H Shift+Alt+- (hyphen)

Cmd+Shift+Q Alt+- (hyphen)

Cmd+Shift+1 Shift+Alt+P

Cmd+Shift+2

Cmd+Shift+3

Cmd+Shift+4

Cmd+Shift+5

Cmd+Shift+6

Cmd+Shift+7

Cmd+Shift+8

Cmd+Shift+9

Cmd+Option+8

Cmd+Option+- (hyphen)

Cmd+Option+=

Cmd+Option+D

Cmd+Option+H

Cmd+Shift+Option+Q
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